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Introduction

n the ten-plus years that I've been writing about Web design, I've seen

many changes — from the early days (before Dreamweaver even existed)
when you could create only simple pages with HTML 1.0, to the elaborate
designs you can create with Dreamweaver today using XHTML, CSS,
JavaScript, multimedia, and more.

If you're not sure what those acronyms mean yet, don’t worry. [ remember
what it was like to learn all this stuff, too, so I designed this book to intro-
duce you to the basic concepts. But I also want to prepare you for the ever-
changing world of Web design, so I show you how to use Dreamweaver to
create Web sites that take advantage of the latest advances in Web technolo-
gies, such as CSS and XHMTL.

One of the challenges of Web design today is that Web pages are not only
displayed on different kinds of computers but are also being downloaded to
computers with monitors that are as big as wide-screen televisions and as
small as cell phones. As a result, creating Web sites that look good to all visi-
tors is a lot more complex than it used to be, and standards have become a
lot more important. That’s why you find out not only how to use all the great
features in Dreamweaver but also how to determine which of those features
will best serve your goals and your audience.

About This Book

[ designed Dreamweaver CS3 For Dummies to help you find the answers you
need when you need them. You don’t have to read this book cover to cover,
and you certainly don’t have to memorize it. Consider this a quick study
guide and a reference you can return to. Each section stands alone, giving
you easy answers to specific questions and step-by-step instructions for
common tasks.

Want to find out how to change the background color in Page Properties,
design styles to align images, or add an interactive photo gallery with the
Swap Image behavior? Jump right in and go directly to the section that most
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interests you. And don’t worry about getting sand on this book if you do
take it to the beach or coffee spilled on the pages if you bring it with you to
breakfast — I promise it won’t complain!

What's New in Dreamweaver CS3?

Dreamweaver’s high-end features make it the preferred choice for profes-
sional Web designers, and its easy-to-use graphical interface makes it popular
among novices and hobbyists as well. With each new version, Dreamweaver
has become more powerful and feature rich, but this upgrade is arguably the
most dramatic, with the following new features:

1~ Better integration with Photoshop, Flash, and other design programs.
Some of the coolest improvements to Dreamweaver CS3 are due to the
fact that Macromedia (the company that created all previous versions
of Dreamweaver) was acquired by Adobe (a company well-known for
creating other popular programs, including Photoshop, Illustrator, and
InDesign). As a result, programs that used to belong to Macromedia,
including Fireworks and Flash, are now fully integrated with programs cre-
ated by Adobe, such as Photoshop and Acrobat. And that means you can
now work much more efficiently with this popular collection of tools, cre-
ating graphics in Photoshop and moving them into Dreamweaver with cut-
and-paste ease. If you're an experienced Photoshop user, you may already
be familiar with Adobe’s Bridge program, which makes it easy to share
images and other files among programs. With CS3, the Bridge now sup-
ports files from a wide collection of programs, including Dreamweaver.

+ Enhanced CSS support. Other enhancements to Dreamweaver CS3
include better CSS support and new CSS features and templates. Creating
Web sites with Cascading Style Sheets is by far the best option today.
That’s why so many of the improvements to Dreamweaver are related to
CSS and why I've dedicated more of this book than ever to the best strate-
gies for creating styles and CSS layouts.

v A built-in device emulator. When it comes to testing your Web designs,
one of the most exciting additions to Dreamweaver CS3 is the new
device emulator (shown at the end of in Chapter 2). Adobe Device
Central comes with a collection of emulators that let you see how your
pages will look when displayed in a variety of cell phone brands and
models, and you can add more emulators as they become available.

1 Advances in dynamic site development. The most advanced features
in Dreamweaver CS3 are designed to help you create database-driven
Web sites using a broad range of technologies. Whether you prefer
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PHP, ColdFusion, ASP, or any of several other options, you can use
Dreamweaver to create these kinds of advanced site technologies. If
you're still not sure how dynamic sites work or their advantages, you’ll
find an introduction to database development in Chapter 13 and instruc-
tions for defining data sources, displaying data in Web pages, and build-
ing master pages in Chapters 13 and 15.

Using Dreamweaver on a Mac or PC

Figure 1:
The front
page of my
JCWarner.
com Web
site open
in Dream-
weaver
CS3ona
Macintosh.
|

Dreamweaver works almost identically on Macintosh or Windows computers.
In these two figures, you see the same Web page opened in design view on a
Mac and a PC. To keep screenshots consistent throughout this book, I've
used a computer running Windows XP. However, I've tested the program on
both platforms, and whenever there is a difference in how a feature works, I
indicate that difference in the instructions.
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Conventions Used in This Book

Keeping things consistent makes them easier to understand. In this book,
those consistent elements are conventions. Notice how the word conventions
is in italics? That’s a convention I use frequently. [ put new terms in italics
and then define them so that you know what they mean.

When I type URLs (Web addresses) or e-mail addresses within regular para-
graph text, they look like this: www. jcwarner . com. Sometimes, however, |
set URLs off on their own line, like this:

www . jcwarner .com

That’s so you can easily spot them on a page if you want to type them into
your browser to visit a site. I also assume that your Web browser doesn’t
require the introductory http: // for Web addresses. If you use an older
browser, remember to type this before the address (also make sure you
include that part of the address when you’re creating links in Dreamweaver).

Even though Dreamweaver makes knowing HTML code unnecessary, you may
want to wade into HTML waters occasionally. I include HTML code in this
book when I think it can help you better understand how things work in
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design view. Sometimes it’s easier to remove or edit a tag in code view than
design view. When I do provide examples, such as the following code which
links a URL to a Web page, I set off the HTML in the same monospaced type
as URLs:

<A HREF="http://www.Jjcwarner.com">Janine's Web Site</A>

When I introduce you to a new set of features, such as options in a dialog
box, | set these items apart with bullets so that you can see that they're all
related. When [ want you to follow instructions, I use numbered steps to walk
you through the process.

What You're Not to Read

If you're like most of the Web designers [ know, you don’t have time to wade
through a thick book before you start working on your Web site. That’s why I
wrote Dreamweaver CS3 For Dummies in a way that makes it easy for you to
find the answers you need quickly. You don’t have to read this book cover to
cover. If you're in a hurry, go right to the information you need most and then
get back to work. If you're new to Web design, or you want to know the intri-
cacies of Dreamweaver, skim through the chapters to get an overview and
then go back and read what’s most relevant to your project in greater detail.
Whether you are building a simple site for the first time or working to
redesign a complex site for the umpteenth time, you’ll find everything you
need in these pages.

Foolish Assumptions

Although Dreamweaver is designed for professional developers, I don’t assume
you’re a pro — at least not yet. In keeping with the philosophy behind the For
Dummies series, this book is an easy-to-use guide designed for readers with a
wide range of experience. Being interested in Web design and wanting to
create a Web site is key, but that desire is all that [ expect from you.

If you're an experienced Web designer, Dreamweaver CS3 For Dummies is an
ideal reference for you because it gets you working quickly with this pro-
gram, starting with basic Web page design features and progressing to more
advanced options. If you're new to Web design, this book walks you through
all you need to know to create a Web site, from creating a new page to pub-
lishing your finished project on the Web.
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How This Book Is Organized

To ease you through the learning curve associated with any new program, I
organized Dreamweaver CS3 For Dummies to be a complete reference. This sec-
tion provides a breakdown of the five parts of the book and what you can find
in each one. Each chapter walks you through the features of Dreamweaver step
by step, providing tips and helping you understand the vocabulary of Web
design as you go along.

Part I: Creating Great Web Sites

Part I introduces you to the basic concepts of Web design as well as the main
features of Dreamweaver. In Chapter 1, I give you an overview of the many
approaches to Web design, so you can best determine how you want to build
your Web site before you get into the details of which features in Dreamweaver
are best suited to any particular design approach. In Chapter 2, I start you on
the road to your first Web site, including creating a new site, importing an exist-
ing site, creating new Web pages, applying basic formatting, and setting links.
To make this chapter more interesting and help you see how all these features
come together, [ walk you through creating a real Web page as | show you how
the features work.

In Chapter 3, we move onto graphics, with an introduction to creating graph-
ics for the Web, an overview of the differences in formats (GIFs, JPEGs, and
PNG files), and detailed instructions for adding and positioning graphics in
your pages. In Chapter 4, you discover Dreamweaver’s testing and publishing
features, so you can start uploading pages to the Internet as soon as you're
ready. If you work with a team of designers, you may be especially interested
in the Check In/Out feature, which makes it easier to manage a site when sev-
eral people are working together. You'll also find instructions for using inte-
grated e-mail for communicating with other team members.

Part II: Appreciating Web Design Options

Chapter 5 provides an overview of how Cascading Style Sheets work and how
they can save you time. CSS has become the way to create page designs and
manage formatting on Web pages, and these features have been nicely
improved in Dreamweaver CS3. In this chapter, you find descriptions of the
style definition options available in Dreamweaver as well as instructions for
creating and applying styles. In Chapter 6, I take you further into CSS, intro-
ducing you to the power of <div> tags and how to create CSS layouts. Here
you’ll find instructions for working with Dreamweaver’s Layers features, as
well as how to create centered CSS designs and fluid layouts.
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In Chapter 7, you discover how to use HTML table features. In Chapter 8, you
find all you need to know about designing a site with frames and iframes.
(This chapter also includes tips about when frames are useful and why they
should sometimes be avoided.)

In Chapter 9, I introduce you to some of my favorite Dreamweaver features,
including sophisticated template capabilities, that enable you to create more
consistent designs and make global updates across many pages at once. |
also cover Dreamweaver’s Library items, which can be used to place and
update commonly used elements, such as navigation bars or copyright tags.

Part 11I: Making It Cool with
Multimedia and JavaScript

In Part IIl you discover how cool your site can look when you add interactive
image features, audio, video, and Flash. In Chapter 10, you find instructions
for creating an interactive photo gallery with the Swap Image behavior, as
well as how to use other features in Dreamweaver’s Behaviors panel, includ-
ing the Open New Browser behavior. In Chapter 11, you find out what it takes
to add multimedia to your Web pages, including how to insert as well as
create links to a variety of file types — from Flash to video and audio files. In
Chapter 12, I cover Dreamweaver’s HTML form options, which you can use to
add feedback forms, surveys, and much more.

Part IV: Working with Dynamic Content

Part IV features three chapters that cover the most advanced features in
Dreamweaver CS3. Chapter 13 is designed to help you understand how data-
base-driven Web sites work and why they have become so important on the
Web. In Chapter 14, you discover how to add dynamic content to your pages,
define data sources, display recordsets, and take advantage of Dreamweaver
CS3’s new Spry features. And in Chapter 15, you pull it all together and find
out how to build master pages, create pages to search databases, and test
your work with a live connection.

Part U: The Part of Tens

Part V features three quick references to help you develop the best Web sites
possible. Chapter 16 provides a collection of online resources where you can
register domain names and find hosting services, as well as a few services
that can help you take care of more advanced challenges, such as setting up

/
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an e-commerce system. In Chapter 17, you find ten design tips to help you get
the most out of Dreamweaver, and Chapter 18 showcases ten Web sites cre-
ated with Dreamweaver to give you an idea of what’s possible and inspire you
in your own Web projects.

Icons Used in This Book

When I want to point you toward something you can download for your use, I
use this icon.

This icon points you toward valuable resources on the Web.

This icon reminds you of an important concept or procedure that you’ll want
to store away in your memory banks for future use.

This icon signals technical stuff that you may find informative and interesting
but that isn’t essential for using Dreamweaver. Feel free to skip over this
information.

This icon indicates a tip or technique that can save you time and money —
and a headache — later.

This icon warns you of any potential pitfalls — and gives you the all-impor-
tant information on how to avoid them.

Where to Go from Here

If you want to get familiar with the latest in Web design strategies and options,
don’t skip Chapter 1, which is designed to help guide you through the many
ways to create Web sites today. If you're ready to dive in and build a basic Web
site right away, jump ahead to Chapter 2. If you want to find out about a spe-
cific trick or technique, consult the Table of Contents or the index; you won’t
miss a beat as you work to make those impossible Web design deadlines. Most
of all, I wish you great success in all your Web projects!
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Creating Great
Web Sites

The Sth Wave By Rich Tennant
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“I have to say I'm really impressed with th
interactivity on this car wash Web site.”




In this part . . .

n Part I, you find an introduction to Web design and

an overview of the many ways you can create a Web
site in Dreamweaver. Chapter 1 compares different layout
techniques and provides an introduction to the toolbars,
menus, and panels that make up Dreamweaver’s interface.

In Chapter 2, you dive right into setting up a Web site, cre-
ating a Web page and adding text, images, and links. In
Chapter 3, you find an introduction to Web graphics and
tips for using Photoshop to optimize images in GIF, PNG,
and JPEG formats. And Chapter 4 covers testing and pub-
lishing features, so you can make sure that everything
works before you put your site online.




Chapter 1

The Many Ways to
Design a Web Page

In This Chapter

Comparing Web design options
Understanding browser differences
Developing a Web site

Customizing your workspace

mb design is an art and a science. I think that’s what makes it so hard.
Most of us don’t have the artistic talent to create great Web designs,
the science and math skills to develop all the technical elements, and the
understanding of interface design and usability that make a Web site easy to
use and intuitive to navigate. But you need all those skills to create a great
Web site. That’s why most of the best Web sites were created by a team of
people with many different specialties.

In the early days, Web design was relatively easy — and vanilla boring. You
could combine images and text, but that was about it; no complex layouts,
no fancy fonts, and certainly no multimedia or animation.

Over the years, Web design has evolved into an increasingly complex field
and Dreamweaver has evolved with it, adding new features that go way
beyond the basics of combining a few words and images.

When I first started learning to creating Web sites in the mid 1990s, it was
easy to learn and easy to teach others how to do it. More than 10 years and a
dozen books later, it’s a lot more complex, and I've come to realize that one of
the first things you have to understand about Web design is that there isn’t
just one way to create a Web site anymore.

Today, you can find out how to design simple Web sites with HTML in a
matter of hours or you can spend years developing the advanced program-
ming skills it takes to create complex Web sites like the ones you see at
Amazon.com or MSNBC.
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For everything in between, Dreamweaver is the clear choice among profes-
sional Web designers as well as among a growing number of people who want
to build sites for their hobbies, clubs, families, and small businesses.

But before we dive into the details about how you create a Web page in
Dreamweaver, I think it’s helpful to start by introducing the many ways you
can create a Web site. The more you understand about the various approaches
to Web design, the better you can appreciate your options.

Comparing Web Designs

Throughout this book, you find chapters covering a variety of aspects of Web
design, from the basics of creating a page and adding images and links to more
complex concepts such as creating rollover effects and pop-up windows with
Dreamweaver’s behaviors, which use JavaScript to create advanced interac-
tive features.

You also find a few chapters that explore different page layout techniques.
You can create Web designs using HTML tables, frames, or Cascading Style
Sheets. You can even use these different technologies in combination. The
next few sections are designed to help you understand the differences in
these approaches before you decide which one is best for your Web site.

Appreciating the advantages of CSS

Today, the W3C, which sets standards for the Internet, recommends CSS for
nearly every aspect of Web design. That’s because the best CSS designs are
accessible, flexible, and adaptable. Also, the fact that they follow standards
has become increasingly important over the years.

If everyone who designed Web sites and everyone who created the browsers
that displayed them followed the same standards, we’d have a much better
Internet today. Unfortunately, over the years Web technology has evolved
but Web browsers haven’t always displayed the features of Web sites in the
same way. As a result, the same Web page can look quite different from one
browser to another, especially in older browsers. (You find more about
browser differences and testing your designs in Chapter 4.)

Today, there is a growing movement among some of the best designers in the
world to get everyone to follow the same standards, create Web sites with
CSS, and make sure they are accessible to everyone.
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|
Figure 1-1:
This site
was
designed
using one of
Dream-
weaver's
CSS layouts.
|

When Web designers talk about accessibility, they mean creating a site that
can be accessed by anyone who might ever visit your pages — and that
includes people with limited vision who use special browsers (often called
screen readers) that read Web pages aloud, as well as many others who use
specialized browsers for a variety of other reasons.

If you work for a university, a nonprofit, a government agency, or a similar
organization, you may be required to create accessible designs. But even if
you're not required to use CSS or to design for accessibility, it’s still good
practice. That’s why Dreamweaver CS3 includes so many CSS features and a
collection of predesigned CSS layouts like the one [ used to create the site
design shown in Figure 1-1. You find instructions for creating CSS layouts like
this one in Chapter 6.

One of the big advantages of CSS is that it lets you separate content from
design. For example, instead of formatting every headline in your site as 24-
point Arial bold, you can create a style for the <h1> tag and use it to format
all your headlines. Then if you decide later that you want all your headlines
to use the Garamond font instead of Arial, you need to change the style for
the <h1> tag only once in the style sheet and it automatically applies every-
where you've used that style.
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|
Figure 1-2:
Designing
Web pages
with CSS
can help
you create
designs that
display
better on
large and
small
screens.
|

Separating content from design also enables you to create different style
sheets for different audiences and devices. In the future this is likely to
become even more important as a growing number of people view Web pages
on everything from giant flat-screen monitors to tiny cell phone screens like
the one shown in Figure 1-2. One of the coolest additions to Dreamweaver
CS3 is Device Central, where you can preview your page designs in a variety
of handheld devices and cell phones to see just how different they can look
when displayed on these small screens.

As you get more advanced with CSS, you can create multiple style sheets for
the same Web page. For example, you can create one that’s ideally suited to

a small screen like the one shown in Figure 1-2, another that works best when
the page is printed, and yet another designed with a larger font size for anyone
who may have a trouble reading the small print that is so common on Web
pages.
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Figure 1-3:
In the old
days, the
only way
you could
create a
complex
Web page
design was
by using a
HTML table
like the one
shown
here to

control the |z

placement
of text and
images.
|

Reviewing old-school designs

Although CSS is by far the best option for creating Web designs today, many
sites on the Web were created using tables to control the layout, like the one
shown in Figure 1-3. Old-school sites like this one were created using the
HTML table tag. To help you appreciate how this page was created, I altered
the original design to display the table borders, although most designers turn
off table borders when using them to create layouts like this.

Because you can merge and split table cells, you can control the layout of a
page, positioning text and images more or less where you want them. And if
you set the table border to 0 (instead of 10 as I did here to show you the bor-
ders), you can hide the table so that it doesn’t interfere with the design.

In Chapter 7, you find an introduction to Dreamweaver’s Table features and
tips for creating accessible table designs by including the table header tag in
all your tables. You can even combine CSS with tables to create more stream-
lined designs.
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|
Figure 1-4:
Tables

are still
considered
the best
way to
display
tabular data
like the
information
on this

order page.
|

Although I recommend that you redesign sites like the one shown in Figure 1-3
with CSS and <div> tags, as you'll find out how to do in Chapter 6, [ do
understand that many designers still find it easier to create layouts with
tables, and not everyone has time to redesign their Web sites right away. |
have to admit, I've been guilty of leaving sites online designed with tables
long after I learned better myself. So in the chapter on tables, I show you how
to use Dreamweaver’s features to create a page layout like the one in Figure
1-3, as well as how best to create tables for displaying tabular data like the
content you'd find in a spreadsheet.

Although tables are no longer recommended for page layouts, they are still
considered the best way to format data like the order page from the artist
site shown in Figure 1-4.

Considering frame options

In Chapter 8 you find instructions for creating Web sites that use frames, like
the family site shown in Figure 1-5. Many designers make a face much like the
one my niece is displaying in the photo in Figure 1-5 because they think
Frames are a terrible way to design Web sites.
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Frames have a bad rep, and there are some compelling reasons why they’re
not used much anymore. But frames still have their place on the Web, so I've
included a chapter on the basics of using Dreamweaver’s frame features to
create pages like the one in Figure 1-5 that display multiple Web pages in one
browser window.

Creating dynamic Web sites

When you use Dreamweaver’s most advanced features, you can create Web
sites (like the one shown in Figures 1-6 and 1-7) which connect to a database

and display content dynamically on a Web page.

What’s happening behind the scenes of a site like the one at www. PowerYoga.
com gets complicated fast, but one of the advantages of using this kind of
technology is that you can create a Web page like the one in Figure 1-7 and
make it easy for anyone to enter data, like the details for a new event, even

if they don’t know how to use Dreamweaver. If you've used Dreamweaver’s
programming features, such as PHP or ASP, to set up a system that saves that
data into a database automatically, you can then serve the contents of the
form back to the live site on a page like the one shown in Figure 1-6, which

includes a long list of events and retreats.
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In Figure 1-7, you see an administrative tool that was designed to make it easy
for someone who works at Power Yoga to update this section of the site with-
out having to know HTML or even Dreamweaver, but you could also use this
technology to create an online discussion board or any other system that col-
lects data in one page and then uses that data to determine what is displayed
on another page.

That’s how the most advanced sites on the Web do things like remind you of
the last book you searched for or keep track of your order as you select prod-
ucts in an online shopping cart. Although I can’t cover all these advanced fea-
tures in this book, you find an introduction to creating database-driven Web
sites in Chapters 13, 14, and 15.

One other thing I feel compelled to mention at this point is that most of the
big, complicated Web sites in the world were created by a team of develop-
ers, not just one person. In the case of the Power Yoga site, the design was
created by Kathy McCarthy and the programming that makes all the dynamic
features work was created by my friend Anissa Thompson. And that’s part of
why Christine Fang, the Managing Director who runs Power Yoga, is able to
update the training section by herself using a Web browser, even though she
knows only a little HTML.

Understanding Browser Differences

Another thing that’s important to understand before you start creating Web
pages is that no matter how carefully you create your designs, your pages
will never look exactly the same to every possible visitor to your site. That’s
because one of the greatest advantages of the Web is also one of the biggest
challenges. HTML was created to share information in a way that could be
displayed on every computer on the planet. Unfortunately, not all those com-
puters use the same browsers, or the same fonts, or the same-sized monitors.
On top of that, a lot of older Web browsers are out there, and they can’t dis-
play the latest Web features. And even the newer browsers don’t all display
the same features the same way.

As a result, although you have more design control today than ever before, and
the capability to create more interesting Web sites, you also have more chal-
lenges if you want your pages to look good to everyone who might visit your
site. My best advice is to test, test, test, and then ask your friends to test your
pages some more. If you want to play it safe, the simpler your page design, the
more likely it will look the same, or at least similar, to all your visitors.

If you want to create more interesting designs, and you want to reach the
broadest possible audience, pay special attention to Dreamweaver’s browser
preview and compatibility features and be prepared to look for more advanced
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books and training programs when you finish with this one. Entire books and
Web sites are dedicated to creating layouts that work on a variety of comput-
ers and browsers.

Because you'’re reading this book, [ assume you are relatively new to Web
design or looking for a refresher course and a chance to update your skills
with CSS and the new features in Dreamweaver CS3, so [ begin with the
basics. In the next sections of this chapter, you find a few tips and sugges-
tions for planning a Web site. At the end of this chapter, you find an introduc-
tion to Dreamweaver’s interface.

Over the course of the nearly 400 pages that follow, you find a variety of
approaches to Web design, from old-school techniques like tables and frames
to the newest and most advanced features like CSS and multimedia.

Developing a New Site

A\

In a nutshell, building a Web site involves creating individual pages and link-
ing them to other pages. You need to have a home page (the first page visi-
tors will see when they arrive at your URL) and that page needs to bring
them into the rest of the pages of the site, usually with links to each of the
main sections of the site. Those pages, in turn, link to subsections that can
then lead to deeper subsections.

A big part of planning a Web site is determining how to divide the pages of
your site into sections and how those sections should link to one another.
Dreamweaver makes creating pages and setting links easy, but how you orga-
nize the pages is up to you.

If you're new to this, you may think you don’t need to worry much about how
your Web site will grow and develop. Think again. All good Web sites grow,
and the bigger they get, the harder they are to manage. Planning the path of
growth for your Web site before you begin can make a tremendous difference
later. Neglecting to think about growth is probably one of the most common
mistakes among new designers. This becomes even more serious when more
than one person is working on the same site. Without a clearly established
site organization and some common conventions for tasks such as naming
files, confusion reigns.

Managing your site’s structure

Managing the structure of a Web site has two sides: the side that users
see, which depends on how you set up links, and the behind-the-scenes
side, which depends on how you organize files and folders.
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What the user sees

The side that the user sees is all about navigation. When users arrive at your
home page, where do you direct them? How do they move from one page to
another in your site? A good Web site is designed so that users navigate
easily and intuitively and can make a beeline to the information most relevant
to them. As you plan, make sure that users can

v Access key information easily from more than one place in the site
v Move back and forth easily between pages and sections

v Return to main pages and subsections in one step

Setting links is easy in Dreamweaver; the challenge is to make sure that those
links are easy for visitors to follow.

What's behind the scenes

The second side to managing your Web site structure happens behind the
scenes (where your users can’t see the information, but you want some kind
of organizational system to remember what’s what). Before you get too far
into building your site with Dreamweaver, spend some time thinking about
the management issues involved in keeping track of all the files you create for
your site. Files are all the images, HTML pages, animations, sound files, and
anything else you put in your Web site.

Once your Web site grows past a handful of pages, organizing them in sepa-
rate folders or directories can help you keep track. Fortunately, Dreamweaver
makes this easy by providing a Files panel, shown in Figure 1-8, where you
can see all the files of your site and even move and rename files and folders.
(You find detailed instructions for organizing the files and folders in a Web
site in Chapters 2 and 4.)

Under construction? No hard hats here!

All good Web sites are under construction —
always. It's the nature of the Web. But build your
site in such a way that you can add pages when
they're ready instead of putting up placehold-
ers. Don't greet your viewers with a guy in a
yellow hat who seems to say, “You clicked this
link for no good reason. Come back another day,
and maybe we’ll have something for you to
see.” Instead of creating “Under Construction”

placeholders, create directory structures that
make adding new pages later easy. You can let
readers know that new things are coming
by putting notices on pages that already have
content — a message like “Come here next
Thursday for a link to something even cooler” is
a great idea. But never make users click a link
and wait for a page to load, only to find that noth-
ing but a guy with a hard hat is waiting for them.

21
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Preparing and planning a Web site

One of the most common mistakes new Web designers make is plunging into
developing a site without thinking through all their goals, priorities, budget,
and design options. The instinct is to simply start creating pages, throw
them all into one big directory, and then string stuff together with links.
Then, when designers finally test the site out on an audience, they're often
surprised when users say the site is hard to navigate and they can’t find
what they want.

Save yourself some grief by planning ahead, and you stand a much better
chance of creating an attractive Web site that’s easy to maintain and update.

Visualizing your site

Before you get too far into building Web pages, take some time to plan your
site and think about its structure and organization. A good place to begin is
by answering the following questions:

v What do you want to accomplish with your Web site? (What are your
goals and objectives?)
v Who is your target audience?

v Who will be working on your site? How many developers do you have
to manage?

v How will you create or collect the text and images you need for your site?
v How will you organize the files in your site?

v Will you include multimedia files such as Flash, audio, or video?

v Will you want interactive features such as a feedback form or chat room?

v What kind of navigation system will you have for your site (that is, how
can you make it easy for visitors to move from one page or section to
another in your site)?

v How will you accommodate growth and further development of the site?
(Good Web sites always grow over time.)

Taking the time to get clear on your goals and objectives is time well spent. It
can help you set the tone for a successful Web project from the beginning
and ensure you spend your precious time, money, and energy on the ele-
ments and features that matter most.

Preparing for development

One of the first things many professional Web designers do when they’re work-
ing on a new site with a group or a company is hold a brainstorming session
with a few key people who understand the mission for the Web site. The pur-
pose of this session is to come up with proposed sections and features for the



Chapter 1: The Many Ways to Design a Web Page 23

MBER
@&
&

site, what should be included, and how the site should be organized. A good
brainstorming session is a nonjudgmental free-for-all — a chance for everyone
involved to share all the ideas they can think of, whether realistic or not.

Not discrediting ideas at the brainstorming stage is important. Often an unre-
alistic idea leads to an innovation that no one may have thought of other-
wise, especially when you're working on the Internet, where the best ideas
are almost always new ones.

After a brainstorming session like this, you’ll probably have a long list of pos-
sible features to develop into your site. Your next challenge is to edit that list
to the most important ones and then plan your course of development to
ensure that everything will work well together when you're finished.

Customizing the Workspace
in Dreamweaver CS3

Dreamweaver can seem a bit overwhelming at first. It has so many features,
and they are spread out in so many panels, toolbars, and dialog boxes that
you can easily get lost. If you prefer to understand by poking around, have at
it (and feel free to skip ahead to the next chapter, where you start building
your first Web page right away). If you want a tour before you get started,

the last few sections of this chapter introduce you to the interface and are
designed to give you a quick overview of the features in this powerful program.

When you launch Dreamweaver, the Start screen appears in the main area of
the program (and reappears anytime you don’t have a file open unless you
close it permanently by selecting the Don’t Show Again option). From the
Start screen, you can choose to create a new page from one of the many
Dreamweaver predesigned sample files, or you can create a new blank page
by selecting HTML from the Create New options in the middle column. When
you select HTML, Dreamweaver creates a new blank HTML page in the main
workspace, as shown in Figure 1-8.

You build HTML pages, templates, style sheets, and other files in the work-
space, which consists of a main window that shows the page you’re working
on surrounded by a number of panels and menus that provide tools you can
use to design and develop your pages. The Dreamweaver workspace consists
of the following basic components: the menu bar (at the very top), the Insert
bar (just below it), the Document window (the main area of the screen, just
below the Insert bar), the Property inspector (at the bottom of the screen),
and the vertical docking panels (to the right of the Document window) that
expand and collapse as needed. More detailed descriptions of each of these
follows.
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Dreamweaver has two main program layout settings: the designer layout,
shown in Figure 1-8, and the coder layout, which places the panels on the left
side of the screen instead of the right side. You can change layouts by choos-
ing Window=>Workspace Layout and then choosing Coder or Designer.

The Document window

The big, open section in the main area of the workspace is the Document
window, which is where you work on new and existing pages. If you use the
Designer interface in design view, you see your page as it would appear in
a Web browser. If you want to see the HTML code behind your page, click
the Code button at the top of the work area. Choose the Split button to see
the HTML code and design view simultaneously (which you can see in
Figure 1-8).
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Customizing the interface

The docking panels, palettes, and bars in Dreamweaver provide easy access
to most of the program’s features, and you can drag these elements around
the screen. You can also close any panels on the right by clicking the tiny
Options icon in the top right of each panel and choosing Close Panel from the
drop-down list. (The Options icon looks like three bullet points with lines
next to them and a little arrow underneath, and it’s really, really small.) You
can also close all the panels at once by choosing Windowr>Hide Panels (or by
clicking the arrow in the middle of the row of panels). If you want to open a
panel, select it from the Window menu. For example, to open the CSS Styles
panel, choose Window=>CSS Styles.

The Insert bar

The Insert bar, located at the top of the screen, includes seven subcategories,
each with a different set of icons representing common features. Click the
small arrow to the right of the name to access the drop-down list and

switch from the buttons of one subcategory to the buttons for another.

The options are

v Common bar: Displays icons for many of the most common features,
including links, tables, and images.

v Layout bar: Displays div, table, and frame options essential for creating
page layouts.

1 Forms bar: Features the most common form elements, such as radio
buttons and boxes.

v Data bar: Displays options for building dynamic Web pages powered by
database material.

v Spry bar: Features a collection of widgets that combines HTML, CSS,
and JavaScript to create interactive page elements.

v Text bar: Displays common text-formatting features, including para-
graphs, breaks, and lists.

+ Favorites bar: Enables you to right-click (Windows) or Control+click
(Mac) to add any of the icons from any of the other Insert bar options to
create your own collection of favorite features.

At the end of the drop-down list is Show as Tabs option, which enables you to
display the names of the Insert bars as tabs across the top of the screen, as
shown in Figure 1-9.
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Figure 1-9:
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The Property inspector

The Property inspector is docked at the bottom of the workspace in
Dreamweaver. If you prefer it at the top of the screen, you can drag it to the
top and it will lock into place; but I rather like that it’s handy, yet out of the
way, at the bottom of the screen.

The Property inspector displays the properties, or options, for any selected
element on a page, and it changes based on what'’s selected. For example, if
you click an image, the Property inspector displays image properties. If you
click a Flash file, it displays Flash properties. Figure 1-10 shows the image
options displayed in the Property inspector, including height and width,
alignment, and link settings.
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Figure 1-11:
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At the bottom-right corner of the Property inspector, you see a small arrow.
Click this arrow (or double-click in any open inspector space) to reveal addi-
tional attributes that let you control more advanced features, such as the
image map options when a graphic is selected.

The docking

panels

The docking panels are located to the right of the work area when you
choose designer layout, as shown in Figure 1-11, or on the left if you choose
coder layout. You can move the panels anywhere on the screen by clicking

and dragging them.

The docking panels display a variety of important features in Dreamweaver,
including all the files and folders in a site in the Files panel and Cascading
Style Sheets in the CSS panel. You can open and close panels by clicking the
small arrow to the left of each panel’s name. To display more panels, select
the panel name from the Window menu. To hide all the visible panels at once,
click the tab with the small arrow in the middle of the row of panels.

(HL g =
éSS éty\es
Al iCurrEnt
all Rules
=h zstyles
body, td, th
body
Properties - -
= At = F S =
|17% Application
I # Tag Inspector
[ ¥ Files =|
7F|Iasr jssets  Snigass
(= Water Birds o | Local view s
RG (&9 us|F
Local Files Size
=y Site - Water Birds (Z:\Doc...
BB os
® ) images
= B pages
= beach.html KB
= e html 4KE
‘E saundetlinigs.hml ZKE
<\ ¥

.‘ 1 Iocal irems selected botaling 1| Lag,,,

27



28 Part I: Creating Great Web Sites

The menu bar

Like most programs you’ve used, the menu at the top of the screen provides
easy access to most program features, including the options you find in the
Insert bar, Property inspector, and panels, as well as a few others that are
available only from the menu.

The status bar

The status bar, at the bottom of the Document window, includes a number of
useful details about the page that’s open in the program, as well as access to
a number of useful features. On the right side of the status bar are tool icons
that control the on-screen display of your document. On the left end, you
find the Tag selector, which features a collection of HTML tags that change
depending on your cursor’s location on the page. The tags indicate how ele-
ments on your page are formatted. If you click a tag in the Tag selector, you
can select the tag and everything it contains in the main Document window, a
handy feature for making precise selections in Dreamweaver.

§‘\‘;,N\BEIf The more you use Dreamweaver, the more you are likely to appreciate the
& capability to customize its features. Remember that you can always change
the workspace to better suit the way you like to work, and you can easily
alter Dreamweaver’s preference settings using the Preferences dialog box
shown in Figure 1-12 by choosing Edit=>Preferences on a Windows computer,
or DreamweaverPreferences if you're using a Mac.
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Chapter 2

Opening and Creating
Sites in Dreamweaver

In This Chapter

Opening an existing Web site

Creating a new Web site

Making new pages

Inserting and formatting text

Creating links

\

If you're ready to dive in and start building a Web site, you’ve come to the
right place. If you're working on an existing site and need to make changes,
this is also the place to start because in this chapter you discover an important
preliminary step — the site definition process, which enables Dreamweaver to
keep track of the images and links in your site. After you’ve completed the site
setup process, you're ready to create Web pages, insert text and images, set
links, and more. But whatever you do, don’t skip this first step.

Although you can use Dreamweaver without doing this initial site definition,
you run the risk of breaking links when you upload your site, and many of
Dreamweaver’s features, such as automated link checking and the Library,
won’t work at all.

Setting Up a New or Existing Site

The first thing to understand about the site definition process is that you
need to store all your site’s resources in one local root folder on your hard
drive and identify the folder in Dreamweaver. That’s because all the elements
of your site must remain in the same relative location on your hard drive as
they are on your Web server in order for your links, images, and other ele-
ments to work properly.
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Building and publishing a Web site

As a general rule, you should first create a Web
site on your computer’s hard drive, where you
can test the site before it is visible on the
Internet. Then when you’re ready to publish the
completed site, you transfer it to a Web server.
A Web serveris a computer with a permanent

connection to the Internet and special software
that enables it to communicate with Web
browsers such as Internet Explorer and Firefox.
You find detailed instructions for publishing a
Web site in Chapter 4.

A\

As you go through the site definition process, you can create a new folder on
your hard drive and designate that as your local root folder or you can iden-
tify an existing folder.

The Site Definition dialog box, where you define a site, also contains Dream-
weaver’s file transfer features, including its FTP (File Transfer Protocol) capa-
bilities. For now, we’ll skip those (as well as Dreamweaver’s other publishing
and site management features) to keep things simple. In Chapter 4, however,
you find detailed instructions for using these features as well as instructions
for downloading an existing Web site hosted on a remote server.

FTP is a common method of copying files to and from computers connected
across a network, such as the Internet. FTP is the protocol you'll probably
use to send your Web pages to your Web server when you’re ready to publish
your site on the Web.

Defining a Web site in Dreamweaver

If the site definition process seems a little confusing at first, don’t worry; it’s
a quick, relatively painless process, and you have to do it only once for each
site. Just trust me; don’t skip this preliminary step.

Whether you are creating a new site or working on an existing site, the follow-
ing steps walk you through the process of defining a root site folder.
1. Choose Site->New Site.
The Site Definition dialog box appears, as shown in Figure 2-1.
2. Click the Advanced tab.

The Advanced window appears. If you prefer, you can use the Basic
wizard that steps you through the setup process, but I find it faster and
easier to view all the options at once using the Advanced tab.
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3. In the Category box on the left, make sure that the Local Info category
is selected.

4. In the Site Name text box, type a name for your site.

You can call your site whatever you like; this name is used only to help
you keep track of your sites. Many people work on more than one site in
Dreamweaver, and this feature enables you to keep track of them by
name. The name you enter here appears in the drop-down list in the
Files panel and in the Manage Sites dialog box. You use this list to select
the site you want to work on when you open Dreamweaver. In the exam-
ple shown in Figure 2-1,  named the new site “Birds of North America.”

= 5. Click the Browse icon next to the Local Root Folder text box to locate
the folder on your hard drive that you want to serve as the main
folder for all the files in your Web site.

If you're working on a new site, create a new folder and designate that as
the location of your site in Dreamweaver. If you're working on an existing
site, select the folder that contains the files for that site.

&

Specify the Default Images folder by entering the location or using the
Browse icon to locate it.

You do not have to identify an images folder, but it’s another way
Dreamweaver helps keep track of things for you. If you store images in
more than one folder, I still recommend that you identify a main image
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10.

11.

folder. If you're setting up a new site, you can create a new folder inside
your site folder and identify that as your images folder, even if it is
empty.

. For Links Relative To, leave the Document option selected unless you

know that you want your links to be set up relative to the root of
your site.

This setting controls how the path is set in links. If you're working on a
site with other developers and you’re not sure, check with your col-
leagues. If you're working alone on your own site, Links Relative to
Document is the simplest option to manage. (You can learn more about
relative versus root links in the sidebar, “Creating relative, root, and
absolute links,” later in this chapter.)

. In the HTTP Address text box, type the URL of your Web site.

The HTTP address is the URL, or Web address, that your site will have
when published on a Web server. If you do not yet know the Web
address for your site or you do not plan to publish it on a Web server,
you can leave this box blank. Include the http:// at the beginning, and
a / at the end.

. Select the Use Case-Sensitive Link Checking box.

Unless you know for sure that you don’t have to worry about the case of
your filenames, checking this box means Dreamweaver will ensure that
the case matches for all your site’s links (which many Web hosting ser-
vices require).

Select the Enable Cache option.

Dreamweaver creates a local cache of your site to quickly reference the
location of files in your site. The local cache speeds up many site man-
agement features of the program and takes only a few seconds to create.

Click OK to close the Site Definition dialog box and save your settings.

If the folder you selected as your local site folder already contains files
or subfolders, they are automatically cached and all the files and folders
in your site are displayed in the Files panel, as you see in Figure 2-2.

If you haven’t checked the Enable Cache option, a message box appears
asking whether you want to create a cache for the site.

Editing and managing multiple sites

You can define as many sites as you like in Dreamweaver and change from
one site to another by selecting the site name in the Files panel. To load a dif-
ferent site into the Files panel, use the drop-down arrow next to the site name
and choose the name of the site you want to display.
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Once you've completed the site definition process covered in the preceding
exercise, you can make changes and additions to a site definition by choosing
Sitec>Manage Sites, selecting the name of the site in the Manage Sites dialog
box, and then clicking the Edit button. The defined site is then opened in the
Site Definition dialog box, where you can make changes to any of the settings.

In Figure 2-4, I selected the Birds of North America site to edit. You can use
this dialog box to define a new site, remove an existing site, duplicate a site,
and import or export a site. Note that when you remove a site from the
Manage Sites dialog box, you do not delete the site’s files or folders from your

hard drive.
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Creating New Pages

\\J

Every Web site begins with a single page. Visitors are first greeted by the
front page — or home page — of your site, and that’s usually a good place to
start building. Dreamweaver makes creating new pages easy: When the pro-
gram opens, you are greeted by a Start Screen with shortcuts to many handy
features for creating new pages in a variety of formats.

If you want to create a simple, blank Web page, choose HTML from the Create
New list in the middle column (see Figure 2-5). If you are creating a dynamic
site, choose ColdFusion, PHP, or one of the ASP options. (If you don’t even
know what those options mean, you probably won’t need to use them yet,
but you can find some information about these advanced options in Chap-
ters 13, 14, and 15.)

Get in the habit of saving new Web pages in your main Web site folder as
soon as you create them, even though they are still blank. As you create links
or add images to your pages, Dreamweaver needs to be able to identify the
location of your page. Although Dreamweaver will set temporary links until
your page is saved, it’s always best to save a page first.

You can create a new page from the Start Screen or by using the New
Document window available from the File menu, as you see in the following
the steps. If you prefer not to use the Start Screen, you can turn it off by
selecting the Don’t Show Again box in the bottom-left corner.
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Follow these steps to create a new page using the New Document window:

1. Choose Filez>New.
The New Document window opens.
2. From the left side of the screen, select Blank Page.
3. From the Page Type list, select HTML, and then choose Create.
4. Choose Filew>Save to save your page.

You find many other options in the Dreamweaver New Document
window, including a wide range of predesigned templates. For now, let’s
start with a simple blank page. You find instructions for working with
templates in Chapter 9.

It’s also good practice to add a page title right away. It’s an easy detail to
forget, and pages on the Web look bad when they are titled “Untitled docu-
ment.” You can add a page title by changing the text in the Title box at the
top of the workspace. The page title won’t appear in the main part of your
Web page, but it does appear at the top of a browser window, usually just to
the right or left of the name of the browser. The page title is also the text that
appears in a user’s list of Favorites or Bookmarks. And perhaps even more
important, many search engines give special priority to the words that
appear in the title of a Web page.
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Naming Web Pages

Over the years, [ have received more e-mail messages from panicked Web
designers because of broken links caused by filename conflicts than about
almost any other issue. Because these problems usually don’t occur until
after a Web site is published on a server, they can be especially confusing
and difficult to understand. If you're publishing your Web site to a Web server
that runs on Mac or Windows, the following may not apply to you; but if
you’re using a Web server that runs Unix or Linux (which is what many com-
mercial Web hosting companies use), the following instructions are especially
important. If you are not sure, follow these rules to be safe.

When you save Web pages, images, and other files on your site, the first rule
is to include an extension at the end to identify the file type (such as .html
for HTML files or .gif for GIF images). Dreamweaver automatically adds the
.html file extension to the end of HTML files (which works for most Web
servers), but you can change the extensions in Dreamweaver’s preference
dialog box if necessary for your Web server.

Filenames are especially important in Web sites because they are included in
the HTML code when you set links. The rules are easy: Don’t use spaces or
special characters in the name. For example you shouldn’t name a Web page
with an apostrophe, such as cat's page.html. If you want to separate
words, you can use the underscore (_) or the hyphen (-). For example,
cat-page.html is a fine filename. Numbers are okay in most cases and
capital letters don’t generally matter, as long as the filename and the code in
the link match.

What can be misleading about these filename restrictions is that links with
spaces and special characters work just fine when you test pages on a Mac or
PC computer, but the software programs used on many of the Web servers on
the Internet don’t understand spaces or special characters in links. Thus,
links that don’t follow these rules may get broken when you publish the site
to a Web server.

Another confusing rule, and one of the most important, is that the main page
(or the front page) of your Web site must be called index.html or default.
html, depending on your Web server. That’s because most servers are set up
to serve the index.html page first. To be sure what to name the main page
of your site, you should check with your service provider or system adminis-
trator. (Some servers are set up to handle home . html, or default.asp for
dynamic sites, but most commercial service providers serve index.html
before any other page in any folder on a site.) The rest of the pages in your
site can be named anything you like, as long as the names don’t include any
spaces or special characters (except the dash or underscore).
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Designing your first page

Many people are pleasantly surprised by how easily they can create a basic
Web page in Dreamweaver.

If you're ready to plunge right in, create a page and click to insert your cursor
at the top of the blank page. (See the previous section, “Creating New Pages,”
if you need to start from the beginning.) Type some text on the page, any-
thing you like; you just need something to get started. In the example in Fig-
ure 2-6, I've typed the text “A Great Egret Hunts Prey in Northern California.”
I'll use this as a headline in the simple page I'm creating.

In this chapter, I stick with the most basic formatting options. In Chapter 5, you
find detailed instructions for going beyond these basic formatting options by
creating Cascading Style Sheets to control and manage formatting.

Creating a headline

One of the most common text formatting options is to use the collection of
heading tags. In HTML, there are many advantages to using heading tags
(<h1>, <h2>, and so forth) to format text that serves as a title or headline.
That’s because heading tags are designed to be displayed in relative sizes,
with <hl> the largest, <h2> smaller, <h3> smaller still, and so on through
<h6>. That’s valuable because no matter what the default text size is for a
Web page (and text sizes can vary because of things such as browser settings
and computer platform), any text formatted with an <h1> tag will always be
larger than text formatted with <h2>.

Many search engines also give priority to keywords in text formatted with an
<h1> tag because it is perceived to be the most important text on a page.

To format text with a heading style, follow these steps:

1. Highlight the text you want to format.

2. In the Property inspector, at the bottom of the page, use the drop-
down arrow in the Format field to select a style (see Figure 2-6).

When heading tags are applied, the text automatically changes to dis-
play the formatting in design view.

Although Dreamweaver’s design view provides a good preview of how text,
images, and other elements should look when viewed in a Web browser (such
as Firefox or Internet Explorer), the page display varies from browser to
browser depending on the browser settings and the operating system used to
display the page.
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In general, I find the Property inspector the easiest way to apply basic for-

matting, but some people prefer using the Text menu. Both achieve the same

results, except the Property inspector features font sizes (listed as sizes 9
through 36 and xx-small through xx-large) and the Text menu offers only the
capability to increase or decrease font size.

Changing fonts and text sizes

You can change the font and the size of the text for the entire page or for any
selected text on a page. You find instructions for changing font options for an

entire page in the following section, “Changing Page Properties.” To change
the font face or size for a selected section of text, follow these steps:

1. Highlight the text you want to change.

2. In the Font drop-down list, at the bottom of the work area, select a col-

lection of fonts, as shown in Figure 2-7.
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|
Figure 2-7:
You can
change the
font face
and size
using the
text settings
in the
Property
inspector.
|

The selected text changes to the first font in the collection of fonts you
selected (unless that font is not available on your hard drive). You can
also choose the Edit Font list option and use any font, but beware that

the font you apply is displayed on your visitors’ computers only if that
font is on their hard drives. (See the “Why so many fonts?” sidebar for

more about how this works.)

In the Size drop-down list, specify the size for your text.

Font sizes in HTML are different from the font sizes you may be used to
using in a word processing or image program. Your size options are
more limited, and you have the added choices of small, x-small, and so
on. The numbered font sizes work much like those you may be used to,
but they offer less flexibility to users of your site. When you set the size
using the settings, which include small, medium, or large, the text is dis-
played according to the settings of the user’s browser. You'll find more
about font sizes in Chapter 5, where I cover creating text styles with CSS.
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The Great Egret, also known as the Common Egret, or by the Latin Casmerodius albus, can
black legs and feet. Snowy Egrets are much smaller and have thicker plumage.

The Great Egret can be found throughout North America, except in the coldest regions and
desert areas. In the west, Great Egrets breed from southern Oregon and Idaho southward.
Each Egret nest can have as many as five pale blue eggs. Great Egrets are endangered
because of hunting for their beautiful feathers, but their greatest threat today is the loss of
suitable habitats.
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Why so many fonts?

Although you can specify any font you want for
text on your Web pages, you don't have com-
plete control over how that font appears on your
visitor's computer. That's because the font you
apply is displayed properly only if your visitors
have the same font on their hard drives. To help
ensure that your text appears as you intend,
Dreamweaver offers collections of common
fonts, grouped together in families, such as
Arial, Helvetica, sans-serif, Georgia, Times New
Roman, Times, and serif.

Here's how it works. When you apply a collec-
tion of fonts like these, the browser displays the
formatted text in the first font available in the
font list. For example, if you choose the font col-
lection that starts with Georgia and your visitors
don't have Georgia, the text is displayed in
Times New Roman; if they don't have that font,
either, the text is displayed in Times; and if they
don't even have Times, the browser looks for
another serif font. (In case you're not familiar
with font terms, serif describes fonts, such as

Times, that have those little curly things on the
edges of letters; sans serif means no curly
things, which is what you get with a font such
as Arial.)

You can create your own font collections by
selecting the Edit Font List option from the
bottom of the Font field in the Property inspec-
tor and using the Edit Font List dialog box. Use
the plus and minus buttons at the top of the Edit
Font List dialog box to add or remove a font col-
lection. To add fonts to a collection, select the
font name from the bottom right of the dialog
box and use the arrow to add it to a font list.

The only way to ensure that text appears in the
font you want is to create the text in a graphic in
a program such as Photoshop or Fireworks and
then insert the graphic with the text into your
page. That's not a bad option for special text,
such as banners or logos; but it's usually not a
good option for all your text because graphics
take longer to download than text and are
harder to update later.

You find many more text formatting options in the Property inspector, such
as bold and italic. Go ahead, experiment a little; you can always undo your
formatting choices or change them again if you don’t like the way they look.

Adding paragraphs and line breaks

When you create page designs for the Web, you must work within many limi-
tations that may be confusing at first, even if they serve a purpose. How you
create paragraph and line breaks is a good example.

If you are working in design view in Dreamweaver and press the Enter key
(Windows) or the Return key (Mac), Dreamweaver inserts a Paragraph, or
<p>, tag in the code, which creates a line break followed by a blank line. If
you want a line break without the extra blank line, hold down the Shift key
and press Return or Enter; Dreamweaver inserts the <br /> tag into the

code, creating a single line break.
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Inserting text from another program

Dreamweaver gives you many options for main-
taining formatting when you copy and paste text
from another program. You can change the
default for how Dreamweaver handles format-
ting when you choose Edit=>Paste and alter the
Preferences in the Copy/Paste category. And
you can choose Edit=>Paste Special to have all
the options available each time you paste new
content. Here are your four options:

v~ Text only: Dreamweaver strips any format-
ting and inserts plain text.

v Text with structure: Dreamweaver includes
paragraphs, lists, tables, and other struc-
tural formatting options.

v~ Text with structure plus basic formatting:
Dreamweaver includes structural formatting

as well as basic formatting, such as bold and
italic

Text with structure plus full formatting: In
addition to the previous options, Dream-

weaver includes formatting created by style
sheets in programs such as Microsoft Word.

Retain line breaks: Line breaks are pre-
served, even if you don’t keep other format-
ting options.

Clean up Word paragraph spacing: The
option addresses a common problem with
the way Microsoft Word's paragraph spac-
ing is converted when content is pasted into
an HTML file.

If you want to add a lot of space, you’ll need to use some other formatting
option because by default most Web browsers condense extra spacing cre-
ated by the paragraph or break tags and remove the extra space when the
page is displayed in the browser. You’ll have greater design control and more
consistent results if you use CSS to create your page layouts. (I cover CSS in
Chapters 5 and 6.)

If you are working in code view and add space using the Enter or Return key,
you add blank space within the code, but you will not affect the display of the
page in design view or how it will look in a browser.

Adding images

Now for the fun part. Adding an image to your Web page may seem almost
magical at first because it is so simple with Dreamweaver. The challenge with
Web graphics is not adding them to your pages but creating good-looking
images that load quickly in your viewer’s browser. You need another pro-
gram, such as Photoshop or Fireworks, to create, convert, and edit images.
Dreamweaver just lets you place the images on your page.
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For more information on finding and creating images, as well as keeping file
sizes small, see Chapter 3. For now, | assume that you have a GIF or JPEG
image file ready and that you want to insert your image into your page. The
two most common image formats you can use on your Web page are GIF and
JPEG (which is often shortened to JPG), but the PNG file is increasingly used
today because it is superior to the GIF format. But beware: PNG is not fully
supported in older versions of Internet Explorer. For the exercise that fol-
lows, you can use any image in GIF, JPEG, or PNG format.

If you don’t have an image handy, you can download free images from my
Web site at www.DigitalFamily.com/free. (You find instructions for
downloading the free images on the site).

Before inserting an image into a Web page, it’s good practice to save the
image inside your local root folder (the one you should have identified in the
site definition process described in the “Defining a Web site in Dreamweaver”
section, earlier in this chapter). Saving your image in your Web site’s local
root folder is important because you need to keep Web pages and images in
the same location relative to each other in your Web site or you risk broken
image links when you publish your site to a server. If you insert an image into
a page that is not saved in the local root folder, Dreamweaver will display a
warning and offer to copy the image into your local root folder as it inserts
the image into the page.

Many designers create a folder called images so they can keep all their image
files in one place. If you are working on a very large site, you may want to
create an images folder within each of the main subfolders of your site to
better organize your files. The thing to remember is that if you move a page
or image to another folder after you place the image on your page, you risk
breaking the link between the page and the image.

To avoid breaking links or image references, always use the Files panel to
move or rename files. When you do so, Dreamweaver automatically fixes your
links. If you move or rename a file or folder outside Dreamweaver, the links
will break. You find more detailed instructions on managing and fixing links in
Chapter 4.

Okay, assuming you've saved your page and the image you want to link is
saved within your main Web site folder (or you're ready to let Dreamweaver
copy it into your local root folder for you), you're ready to follow these steps
to add an image on your Web page:

1. Click to place your cursor on the page where you want to add the
image.

I inserted my cursor under the headline at the beginning of the first
paragraph.
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You can’t just place your cursor anywhere on a blank page and insert an
image where you want it. This is not a limitation of Dreamweaver; it’s a
restriction caused by how HTML is displayed on a Web page. By default,
all images, text, and other elements are inserted starting at the top-left
corner. To create more complex layouts, you'll need to position elements
with CSS (the most highly recommended option, which is covered in
Chapter 6), or with an HTML table (covered in Chapter 7) or a layer
(also covered in Chapter 6).

. Click the Image icon, located in the Common Insert bar at the top of

the work area and choose Image from the drop-down list.

The Select Image Source dialog box opens, displaying files and folders
on your hard drive.

. Navigate to the folder that has the image you want to insert and

double-click to select the image you want to insert into your page.

If you have Accessibility options turned on in Preferences (the default),
the Image Tag Accessibility Attributes dialog box appears. It is good prac-
tice to always add alternate text in this dialog box. To do so, simply enter
text in the Alternate Text field. You can type any text in this field, but it is
meant to provide a description of the image. Alternate text will not appear
on your Web page unless the image is not visible, but it will appear in
Internet Explorer when a user holds the cursor over the image. Alternate
text is also important for Web surfers who use browsers that “read” Web
pages to them, such as those with limited vision. For this reason, Alter-
nate text is required for accessibility compliance. A long description is
considered optional under most accessibility guidelines. You can also add
or edit alternate text in the Property inspector.

. Click OK.

The image automatically appears on the Web page.

. Click to select the image on your Web page.

Image options are automatically displayed in the Property inspector at
the bottom of the page.

. Use the Property inspector to specify image attributes, such as align-

ment, spacing, and Alternate text.

In the example shown in Figure 2-8, I've set the alignment to Left, using
the align option at the very bottom right of the Property inspector.
That’s how I got the text to wrap to the right of the image. I've also
added 10 pixels of space using the H Space field to create a margin
between the image and the text.

If you use CSS, you can create more precise formatting options. For example, H
Space inserts space on both the left and right sides of an image. Using CSS, you
can create a style that applies margin space on any or all sides of an image.

43
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|
Figure 2-8:
When an
image is
selected,
the Property
inspector
provides
easy access
to common
image
attributes,
such as
alignment
and
spacing.
|
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With an image selected, the Property inspector enables you to specify many
attributes for an image. Table 2-1 describes those attributes. If you don’t see
all the attributes listed in the table on your screen, click the triangle in the
bottom-right corner of the Property inspector to reveal all the image options.

Table 2-1 Image Attributes in the Property Inspector
Abbreviation  Attribute Function

Image N/A Specifies the file size.

Image Name  Name Identifies image uniquely on the page —

an important detail if you use behaviors or
other scripts that are triggered by the
image.

Map Map Name Assigns a name to an image map. All
image maps require a name.
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Abbreviation

Attribute

Function

Hotspot tools

Image Map
Coordinates

Use the Rectangle, Oval, and Polygon
icons to create image map hotspots for
links. (See Chapter 5 to find out how to
create an image map.)

w Width Dreamweaver automatically specifies the
width of the image based on the actual size
of the image dimensions.

H Height Dreamweaver automatically specifies the
height of the image based on the actual
size of the image dimensions.

Src Source Required. The source s the filename and
path from the current document to the
desired image. Dreamweaver automati-
cally sets this when you insert the image.

Link Hyperlink This field shows the address or path if the
image links to another page. (For more
about linking, see “Setting Links" later in
this chapter.)

Alt Alternate Text The words you enter are displayed if the
image doesn't appear on your viewer's
screen because images are turned off in
the user’s browser. Alt text is especially
important for search engines and
browsers used by the blind to read Web
pages.

Edit Icons for Fireworks,  Click the Fireworks icons to launch

Optimize, Crop, Fireworks. Use any of the other icons to
Resample, make other minor alterations to an image
Brightness and in Dreamweaver.

Contrast, and

Sharpen

V Space Vertical Space Measured in pixels, this setting inserts
blank space above and below the image.

H Space Horizontal Space Measured in pixels, this setting inserts

blank space to the left and right of the
image.

(continued)

b5
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Table 2-1 (continued)

Abbreviation  Attribute

Function

Use this option when the image appears in
a page where you want to control the
target, such as when a page is part of an
HTML frameset or when you want a link to
open a new window. The Target specifies
the frame into which the linked page
opens. | cover creating frames and how
to set links in frames in Chapter 7.

This option enables you to link two images
to the same place on a page. The Low
Source image loads first and, after the rest
of the page loads, it is replaced by the
primary image. You may find this option
especially useful when you have a large
image size because you can set a smaller
image (such as a stretched black-and-
white version) as the Low Source, which
appears while the main image downloads.
The combination of two images in this way
creates the illusion of a simple animation.

Measured in pixels, this attribute enables
you to put a border around an image. |
nearly always set the image border to 0
(zero) when using an image as a link to
prevent the image from being surrounded
by a border with link colors.

This option enables you to align the image.
Text automatically wraps around images
aligned to the right or left. The other
options, including Baseline, Top, and
Middle, control how text or other elements
align next to the image. The alignment
icons control the entire paragraph contain-
ing the image, and align the text left, right,
or center.

Target Link Target
Low Src Low Source
Border Image Border
Align Alignment
Class CSS Setting

The Class field enables you to apply any
class styles defined in Dreamweaver. To
use this option, select any element in the
workspace and then select any class style
you want to apply from the drop-down list.
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Creating multiple pages to set links

Creating a new page to start a Web site may
seem obvious, but consider this: You may want
to create a bunch of new pages before you get
too far in your development, and you may even
want to start organizing the new pages in sub-
directories before you have anything on them.
Doing so enables you to organize the structure
of your site before you start setting links. After
all, you can't link to a page that doesn't exist. If
you plan to have five links on your front page to
other pages in your site, go ahead and create
those other pages, even if you don’t put any-
thing on them yet.

For example, say you're creating a site for your
department at a big company. You're likely to

want a few main pages, such as a page about
your staff, another about what you do, and a
third with general information and resources. At
this initial stage, you could create four pages —
one for the front page of the site and three
others for each of the subsections. Name the
front page index.html and name the other
pages staff.html, about.html, and
general .html. With these initial pages in
place, you benefit from having an early plan for
organizing the site, and you can start setting
links more easily among the main pages of your
site. See Chapter 4 for more tips on Web site
planning and managing and testing links.

\NG/
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Although you can resize an image in Dreamweaver by clicking and dragging
the edge of the image or by changing the Height and Width values in the

Property inspector, | don’t recommend you change an image size this way:.
Changing the height and width in the Property inspector won’t actually
change the size of the image, just the way it appears on the page. That’s a

problem for two reasons. First, using this option to make an image look larger

or smaller can make the image look distorted. Second, using this option to
make an image look smaller requires your visitor to download a larger file

than necessary.

You can use Dreamweaver’s Cropping tool in the Property inspector to crop
an image, but doing so changes the image file permanently. For more precise
image-editing options, use an image editor such as Fireworks or Photoshop.
In Chapter 3 you find instructions for optimizing images for the Web in
Photoshop.

Setting Links

Dreamweaver is truly a dream when it comes to setting links. The most
important thing to keep in mind is that a link is essentially an address (a URL)
that tells a viewer’s browser what page to go to when the viewer clicks the
text or image containing the link.
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If the page you want to link to is within your Web site, you can create a rela-
tive link that includes a path describing how to get from the current page to
the linked page. A relative link doesn’t need to include the domain name of
the site, just instructions for a browser to get from one page within your site
to another. Here’s an example of what the code looks like for the relative link
from the home page on my Web site at www . JCWarner . com to the main page
in the books section, which is contained in a folder called books:

<A HREF="books/index.html">Janine's Books</A>

If you select the Root option instead of Relative in the Site Definition dialog
box, this address would begin with a forward slash (as you see here) instruct-
ing the browser to begin at the root level:

<A HREF="/books/index.html">Janine's Books</A>

Because my Web server is set up to deliver any page named index.html
first, no matter what folder it’s inside of, I gain an advantage when I name the
main page of a subdirectory index.html. Here’s the advantage. If I had
named this page books.html, then to get to this page on my Web site, you’d
have to enter www.JCWarner . com/books/books.html into a browser.
With the main page named index, you can simply type www.JCWarner . com/
books into a browser and get to the same page. (This works similarly on
servers that are set up to deliver default.html).

If you link to a page on a different Web site, you need to create an absolute, or
external, link. An absolute link includes the full Internet address of the other
site. Here’s an example of what the code would look like behind an absolute
link if you created a link from your site to the books page on my site:

<A HREF="http://www.jcwarner.com/books/index.html">Janine's Books</A>

Note that because | named the main page index.html, you could leave out
the filename and use the shortened address http://www.jcwarner.com/
books. And if all that HREF code stuff looks like Greek to you, don’t worry.
The following section shows you how Dreamweaver sets links like this for
you so you don’t even have to look at this code if you don’t want to. (But I do
think it’s helpful to have a little understanding of what’s happening behind
the scenes.)

Linking pages within your Web site

Linking from one page to another page in your Web site is easy. The most
important thing to remember is to save your pages in your site’s root folder
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(as described in the “Defining a Web site in Dreamweaver” section, previously
in the chapter) before you start setting links. Here’s how you create a link
from one page in a Web site to another:

1. In Dreamweaver, open the page where you want to create a link.

2. Select the text or image that you want to serve as the link (meaning
the text or image that a user will click to trigger the link).

Click and drag to highlight text or click once to select an image. In this
example, I've selected the text Great Egret and I'm linking it to a page
named egret .html located in the same folder.

%, 3. Click the Link icon in the Common Insert bar, at the top of the
workspace.

Alternatively, you can set a link using the Link field in the Property
inspector.

] 4. In the Hyperlink dialog box (see Figure 2-9), click the Browse icon to
the right of the Link drop-down list.

The Select File dialog box opens.

|
Figure 2-9:

The Hyperlink
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5. Click the filename to select the page that you want your image or text
to link to, and then click OK (Windows) or Choose (Mac).

The link is automatically set and the dialog box closes. If you haven’t
already saved your page, a message box opens explaining that you can
create a relative link only after you save the page. It’s always best to
save the page you’re working on before you set links. Note that, to test
your links, you have to view your page in a browser, a process covered
in the “Previewing Your Page in a Browser” section, later in this chapter.

49
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You can use the Target field in the Hyperlink dialog box shown in Figure 2-9 to
“target” where your linked page will open. For example, the _top option causes
the linked page to open in a new browser window. The other options are most
important when working with Frames, which are covered in Chapter 8.

\\J

Setting links to named anchors
within a page

If you like to create really long pages, using anchor links to break up naviga-
tion within the page is a good idea. A named anchor link, often called a jump
link, enables you to set a link to a specific part of a Web page. You can use a
named anchor to link from an image or text string on one page to another
place on the same page, or to link from one page to a specific part of a differ-
ent page. To create a named anchor link, you first insert a named anchor in
the place that you want to link to, and then use that anchor to direct the
browser to that specific part of the page when a viewer follows the link.

Suppose that you want to set a link from the word Convertible at the top of a
page to a section lower on the page that starts with the headline Convertible
Sports Cars. You first insert a named anchor at the Convertible Sports Cars
headline. Then you link the word Convertible from the top of the page to that
anchor.

To insert a named anchor and set a link to it, follow these steps:

1. Open the page on which you want to insert the named anchor.

2. Place your cursor next to the word or image that you want to link to
on the page.

You don’t need to select the word or image; you just need a reference
point that appears when the link is selected. For this example, I placed
the cursor to the left of the headline Convertible Sports Cars.

3. Choose Insert=>Named Anchor.
The Insert Named Anchor dialog box appears.
4. Enter a name for the anchor.

You can name anchors anything you want (as long as you don’t use
spaces or special characters). Just make sure that you use a different
name for each anchor on the same page. Then be sure that you remem-
ber what you called the anchor, because you have to either type the
anchor name to set the link or select it from the drop-down list in the
Hyperlink dialog box, as you see in Step 8. In this example, I chose con-
vertible as the anchor name because it’s easy for me to remember.
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5. Click OK.

The dialog box closes, and a small anchor icon appears on the page
where you inserted the anchor name. You can move an anchor name by
clicking the anchor icon and dragging it to another location on the page.

If you're curious about what this named anchor looks like in HTML,
here’s the code that appears before the headline in my example:

<A NAME="convertible"></A>

6. To set a link to the named anchor location, select the text or image
that you want to link from.

You can link to a named anchor from anywhere else on the same page or
from another page. In my example, I linked from the word Convertible
that appears at the top of the page to the anchor | made next to the
headline.

7. Click the Link icon in the Common Insert bar, at the top of the screen.

8. In the Hyperlink dialog box, use the small arrow to the right of the
Link box to select the anchor.

Alternatively, you can set a jump link using the Property inspector by
typing a pound sign (#) followed by the anchor name.

You can also select the text and drag a line from the Point to File icon
(next to the Link text box) to the anchor icon. The anchor name auto-
matically appears in the Link box, saving you from typing the name.

In my example, [ typed #convertible in the Link text box. The HTML
code for this line looks like this:

<A HREF="#convertible">Convertible</A>

If you want to link to an anchor named convertible on another page with
the filename coolcars.html, you type coolcars.html#convertible in
the Link text box.

Linking to another Web site

Linking to a page on another Web site — called an external link — is even
easier than linking to an internal link. All you need is the URL of the page to
which you want to link, and you’re most of the way there.

To create an external link, follow these steps:

1. In Dreamweaver, open the page from which you want to link.

2. Select the text or image that you want to act as a link.
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Figure 2-10:
To set a link
to another
Web site,
highlight the
text or
image you
want to link
and type the
URL in the
Link text
box.
|

3. In the Link text box in the Property inspector, type the URL of the
page you want your text or image to link to.

The link is set automatically. In the example in Figure 2-10, I created a
link using the photograph of the egret to the California Nature
Conservancy Web site at www.nature.org.

Although, you don’t have to type the http: // or even the www. at the begin-
ning of a Web site address to get to a site in most browsers, you must always
use the full URL, including the http://, when you create an external link in
HTML. Otherwise, the browser can’t find the correct external site address
and the visitor will probably end up on an error page.
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A Great Egret in Northern California

The Great Egret, alzo known as the Common Egret, or by the
Latin Casmerodius qlbus, can grow to more than 30" tall. Great
Egrets are a striking snowy white color with a yellow bill and
black legs and feet. Snowy Egrets are much smaller and have
thicker plumage.
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MThe Great Egret can be found throughout Morth Armerica,
except in the coldest regions and desert areas. In the west,
Great Egrets breed from southern Oregon and Idaho
acuthward, Each Egret nest can have az many as five pale blue
eggs. Great Egrets are endangered because of hunting for their
beautiful feathers, but their greatest threat today is the loss of
suitable habitats.
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Setting a link to an e-mail address

Another common link option goes to an e-mail address. Visitors can send you
messages easily with e-mail links. I always recommend that you invite visitors
to contact you because they can point out mistakes in your site and give you
valuable feedback about how you can further develop your site. Setting a link
to an e-mail address is just as easy as setting a link to another Web page. All
you need to know is the e-mail address you want to link to and what text or
image you want to use when you set the link.

To create an e-mail link, select the text you want to link and then click on the
E-mail link icon in the Common Insert bar. In the Email Link dialog box, enter
the e-mail address in the Link field and then click OK. If you want to use an
image as an e-mail link, you must select the image in the main work area and
then enter the e-mail link into the Link field of the Property inspector.

When you create an e-mail link using the Link field in the Property inspector,
the e-mail links must begin with the codemailto: (no //). For example, if
you were to type a link to my e-mail address into the Property inspector,
you’d need to type mailto:janine@jcwarner.com. Here’s what the full line of
code behind that e-mail link would look like:

<A HREF="mailto:janine@jcwarner.com">Send a message to Janine</A>

When visitors to your Web site click an e-mail link, their computer systems
automatically launches their e-mail program and create a blank e-mail mes-
sage to the specified e-mail address. This is a cool trick, but it can be discon-
certing to your users if they don’t expect it to happen, and it won’t work if
they don’t have e-mail programs on their computers. That’s why I always try
to let users know when I use an e-mail link. For example, instead of just link-
ing the words Contact Janine, 1 link the words E-mail Janine. Even better, |
often link the actual e-mail address.

When you create an e-mail link on a Web page that will be displayed on the
public Internet, you open yourself to spammers, some of whom use auto-
mated programs to “lift” e-mail addresses off Web pages. That’s why many
sites don’t include e-mail links, but instead use text such as Send e-mail to
Janine at jcwarner.com. You can also use a form to get around this potential
problem. By setting up a form with a script that delivers the form’s contents
to an e-mail address, you can shield your e-mail address from spammers
while still making it easy for visitors to your site to send comments. You find
instructions for creating forms in Chapter 12.
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Changing Page Properties

|
Figure 2-11:
The
Appearance
category in
the Page
Properties
dialog box
enables you
to change
text colors,
font face,
font size,
background,
and
margins.
|
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You can change many individual elements on a page in the Property inspec-
tor, but if you want to make changes that affect the entire page, such as
changing the background color of the entire page or changing the way links
and text are formatted, you need to use the Page Properties dialog box.

As you see in Figure 2-11, the Page Properties dialog box includes a list of
categories on the left. Each of these reveals different page options. Some of
these options are covered in other parts of the book, such as the Tracing
Image feature (Chapter 5), and the Background Image feature (Chapter 3).
For now, to keep things simple, this section focuses only on changing the
background and text colors available from the Appearance category, shown
in Figure 2-11, and the options in the Links category.

Page Properties

Cateqory Appearance

Appearance i - - o
Links Page Font: | Georgia, Times Mew Roman, Times, serif ~ B I

Headings g
TitlefEncoding Size: | mediurn ~

Tracing Image
Test color: W] | #330000

Background color: E #FFCCO9

Background image: Browse...
Repeat: |
Left margin: | 0 :p\XE|§ ~ Right margin: | 0 pixels [+ ]
Top margin: | 0 .p\xels .v Battom margin: | 0 pixels .V_
o) Com ) oy ]

Although you can apply global settings, such a text size and color, in the Page
Properties dialog box, you can override those settings with other formatting
options in specific instances. For example, you could set all your text to
Helvetica in Page Properties and then change the font for an individual head-
line to Arial using the Font field in the Property inspector.

To change the font settings, the background and text colors, and the page
margins for an entire page, follow these steps:
1. Choose Modify->Page Properties.

The Appearance category of the Page Properties dialog box appears
(refer to Figure 2-11).
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2. In the Page Font drop-down list, specify the fonts you want for the text
on your page.

In this example, I set the font face to the collection that begins with the
Georgia font. If you don’t specify a font, your text appears in the font
specified in your user’s browser, which is usually Times.

3. If you want all the text on your page to appear bold or italic, click the
B or I, respectively, to the right of the Page Font drop-down list.

If you select one of these options, all your text appears bold or italic in
the page.

4. In the Size drop-down list, specify the font size you want for the text
on your page.

Again, you can override these settings for any text on the page.

5. Click the Text Color swatch box to reveal the color palette. Choose
any color you like.

The color you select fills the color swatch box but will not change the
text color on your page until you click the Apply or OK button.

6. Click the Background Color swatch box to reveal the color palette.
Choose any color you like.

The color you selected fills the color swatch box. The color does not fill
the background until you click the Apply or OK button.

7. If you want to insert a graphic or photograph into the background of
your page, click the Browse button next to the Background Image box
and select the image in the Select Image Source dialog box.

When you insert a background image it automatically repeats or tiles
across and down the page unless you choose the no-repeat option from
the Repeat drop-down list or use CSS to further define the display.

8. Use the margin options at the bottom of the dialog box to change the
left, right, top, or bottom margins of your page.

Entering 0 in all four of these fields removes the default margin settings
that automatically add margin space at the top and left of a Web page,
enabling you to create designs that begin flush with the edge of a
browser.

9. Click the Apply button to see how the colors look on your page.
10. Click OK to finish and close the Page Properties dialog box.
When you change the background, text, or link colors, make sure the colors

look good together and that your text is still readable. As a general rule, a
light background color works best with dark text color and vice versa.
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To change the link color and underline options, follow these steps:

1. Choose Modify->Page Properties.
The Page Properties dialog box appears.
2. In the Category list, select the Links option.
The Links category is displayed, as shown in Figure 2-12.

Page Properties
Cateqgory Links
Eﬁﬁ;aran:e Link fant: | (:_Sama as page font) B I
Headings
I TitlefEncoding Size: w
Tracing Image
- Lrkcolor: B8] | #330066 | Rollover inks: [0 | #FFCCo0
Figure 2-12: B &
qrhe Links visited links: [ | #333333 active inks; [73] | #FFCcan
Underline style: | always underline ot
Category Always underling
fever underline I
ena bles yOU Show underling only on rollover by
to Change Hide undetling on rollover
link colors
and remove
the
underline. o [ coneel ) [ aemy
|

3. Specify the font face and size you want for the links on your page.

If you don’t specify a font, your links appear in the same font and size
specified for the text of your document.

4. To the right of the Link Font drop-down list, click the B or I if you
want all the links on your page to appear bold or italic, respectively.

If you select one of these options, all your links appear bold or italic
unless you specify other formatting in the page.

5. Specify a color for any or all link options.

The color you selected is applied to links on your page based on the link
state. There are four link states, and all can be displayed in the same or
different colors:

Link Color: This option controls the color in which a link appears
when it is first displayed on a page.

Visited Links: This option controls the color of links that a visitor
has already clicked (or visited).

Rollover Links: A link changes to this color when a user rolls a
cursor over the link (also known as hovering).

Active Links: A link changes to this color briefly while a user is
actively clicking it.
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Figure 2-13:
When you
specify
formatting
options in
the Page
Properties
dialog box
Dream-
weaver
auto-
matically
creates
styles that
appearin
the CSS
panel.

6. In the Underline drop-down list, specify whether you want your links
underlined.

By default, all links on a Web page appear underlined in a browser, but
many designers find the underline distracting and prefer to turn off
underlining by selecting Never Underline. You can also choose Show
Underline Only on Rollover to make the underline appear when a user
moves a cursor over a link. Hide Underline on Rollover causes the
underline to disappear when a user moves a cursor over a link.

7. Click the Apply button to see how the changes appear on your page.
8. Click OK to finish and close the Page Properties dialog box.
When you change formatting options in the Page Properties dialog box,
Dreamweaver automatically creates styles corresponding to these settings

and saves them in the CSS styles panel, as shown in Figure 2-13. I cover
Dreamweaver’s CSS panel in detail in Chapters 5 and 6.
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Adding Meta Tags for Search Engines

If you’'ve heard of Meta tags, you probably associate them with search
engines, and you’d be right. Meta tags are used for a variety of things, but the
most common use is to provide special text that doesn’t appear on your page
but is read by crawlers, bots, and other programs that scour the Web cata-
loging and ranking Web pages for Yahoo!, Google, and a long list of other
search-related sites.
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Some search engines read the Meta tags for keyword tags and descriptions.
The first enables site designers to include a list of keywords they would like
used to make their Web site a match when someone types the same key-
words into a search engine. Unfortunately, Meta keywords have been so
abused by Web designers attempting to mislead visitors about the true con-
tent of their Web pages that most search engines ignore the Meta keyword
tag. Some search engines continue to recognize Meta keywords, however,
and it shouldn’t hurt your ranking with any search engines if you use this
Meta tag.

The Meta description tag is more widely used and is definitely worth using.
This tag is designed to let you include a written description of your Web site
and is often used by search engines as the brief description that appears in
search results pages. If you don’t include your own text in a Meta description
tag, many search engines use the first several words that appear on your
front page or some other collection of text from your page, usually based

on formatting or placement on the page. Depending on your design, the first
few words may not be the best description of your site, and you’ll be better
served by including your own Meta description.

Follow these steps to fill in the Meta description tag:

1. Open the page where you want to add a Meta description.

You can use Meta descriptions on any or all pages on your Web site.
(Many people using search engines to find your site may end up directly
at internal pages if the content matches the search.)

2. Choose Insert=>"HTML="Head Tags->Description, as shown in Fig-
ure 2-14.

The Description dialog box appears.

3. In the Description text box, enter the text you want for your page
description.

Don’t add any HTML to the text in this box.
4. Click OK.

The description text you entered is inserted into the Head area at the
top of the page in the HTML code. Meta content does not appear in the
body of the page.

If you want to add keywords, repeat Steps 1 through 4, choosing Insert=>
HTML=>Head Tags=Keywords in Step 2.
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Previewing Vour Page in a Browser

Although Dreamweaver displays Web pages much like a Web browser, not all
interactive features work in Dreamweaver. To test links, for example, you
need to preview your work in a Web browser.

The simplest way to preview your work is to save the page you are working
on and then click the Preview/Debug in Browser icon located at the top-right
of the workspace (it looks like a small globe). You can also choose Filer>
Preview in a Browser.

A\

When you install Dreamweaver, it automatically finds all the browsers
installed on your computer and sets them up so that you can easily select
them to preview your pages. It’s always a good practice to test your pages in
more than one Web browser because page display can vary. How many
browsers you test your pages on depends on the audience you expect to visit
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your Web site, but most good Web designers test their pages on at least the
latest two or three versions of Internet Explorer and Firefox. It’s also good
practice to preview your pages on both Macintosh and Windows computers
because the page display might differ.

If you install more browsers on your computer, you can add them to the
Browser Preview list by choosing Edit2>Preferences (Dreamweaver
Preferences on a Mac) and then choosing Preview in Browser from the
Category list. Click the plus sign at the top of the screen to add a browser
and then navigate your hard drive to select the installed browser to add to
the list. Alternatively, you can click the globe icon at the top of the workspace
and choose Edit Browser List.

One of the newest and most exciting additions to Dreamweaver CS3 is the
device emulator, shown in Figure 2-15. Adobe Device Central features an
impressive list of cell phone brands and models, and you can add more emu-
lators as they become available. Essentially, the device emulator makes it
easy for you to see how your Web pages will look when displayed on a cell
phone or other device.

To use this feature, open the page you want to test and choose Filew>
Previewr>Device Central. When you double-click the name from the Device
List on the left, the Web page is automatically displayed in the corresponding
emulator in the main area of the dialog box. It’s never been easier to test how
your Web pages will look when displayed on a cell phone.
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Chapter 3
Adding Graphics

In This Chapter

Creating and optimizing images for the Web
Buying royalty-free images

Aligning images

Image editing

Including a background image

Using image maps

No matter how great the writing may be on your Web site, the graphics
always get people’s attention first. And the key to making a good first
impression is to use images that look great, download quickly, and are a good
fit with the design of your Web site.

If you're familiar with using a graphics-editing program, such as Adobe
Photoshop or Fireworks, to create graphics for the Web, you're a step ahead.
If not, you find pointers throughout this chapter on how to convert images
for the Web, what image formats to use, and how to optimize images for
faster download times.

If your images are already in GIF or JPEG format and ready for the Web, you
can jump ahead to the “Inserting Images on Your Pages” section, where you
find out how to place and align images, create image maps, and use an image
as a background. You also discover some of Dreamweaver’s built-in image-
editing features, which enable you to crop images and even adjust contrast
and brightness without ever launching an external image-editing program.
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Comparing Adobe Web graphics programs

Most professional designers strongly prefer
Adobe Photoshop, although | have to say I've
been impressed with Photoshop Elements,
which is a “light” version but offers many of the
same features for a fraction of the cost. (If
you're designing images for print, you need
Photoshop; but for the Web, Elements is a sur-
prisingly complete, low-cost alternative.) For
vector-based graphics (a good choice for illus-
trations), Adobe lllustrator is the favorite.

The following is a list of the most popularimage-
editing programs on the market today. Unless
otherwise indicated, all the following image pro-
grams are available for both Mac and Windows:

v+~ Adobe Fireworks (www.adobe.com/
fireworks): Fireworks was one of the
first image-editing programs designed to
create and edit Web graphics. Originally
created by Macromedia, the program is
now part of the Adobe Web Suite and is
fully integrated with Dreamweaver. Fire-
works gives you everything you need to
create, edit, and output Web graphics, all in
one well-designed product.

v Adobe Photoshop (www.adobe.com/
photoshop): Adobe calls Photoshop the
“camera of the mind.” This is unquestion-
ably the most popular image-editing pro-
gram on the market and a widely used
standard among graphics professionals.

With Photoshop, you can create original art-
work, correct color in photographs, retouch
photographs, scan images, and so much
more. Photoshop has a wealth of powerful
painting and selection tools in addition to
special effects and filters to create images
that go beyond what you can capture on film
or create with other illustration programs. In
previous versions, Photoshop came bundled
with a program called Image Ready, a com-
panion program designed for Web graphics.
In CS3, those Web features are included in
Photoshop. And thanks to the acquisition of
Macromedia, Photoshop is now fully inte-
grated with Dreamweaver as well.

Adobe Photoshop Elements (www . adobe .
com/elements): If you're not designing
images for print and don't need all the bells
and whistles offered in the full-blown ver-
sion of Photoshop, Photoshop Elements is a
remarkably powerful program — for about a
sixth of the cost of Photoshop. If you're
a professional designer, you will be best
served by Photoshop CS3. But if you're a
hobbyist or small business owner and want
to create good-looking images without the
high cost and learning curve of a profes-
sional graphics programs, Elements is a
great deal and well suited to creating Web
graphics.

Creating and Optimizing Web Graphics

The most important thing to keep in mind when creating images for the Web
is that you want to optimize your images to keep your file sizes as small as
possible. You can optimize images using compression techniques or color

reduction.

How you optimize an image depends on how the image was created and
whether you want to save it as a JPEG or a GIF. You find instructions for opti-
mizing GIFs and JPEGs with Photoshop in the next section, but first you
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should know that no matter what program, format, or optimization technique
you choose, the biggest challenge is finding the best balance between small
file size and good image quality. Essentially, the more you reduce colors or
compress an image, the worse it looks but the faster it downloads.

Choosing the best image format

One of the most common questions about images for the Web concerns when
to use GIF and when to use JPEG. Table 3-1 provides the simple answer.

Table 3-1 Image Formats for the Web

Format Best Use

GIF For line art (such as one- or two-color logos), simple drawings, anima-
tions, and basically any image that has no gradients or blends. GIF is
also the best format for images that you want displayed with a trans-
parent background.

PNG PNG generally produces better-looking images with smaller file sizes
than GIF for the same kinds of limited-color images. Just beware that
really old browsers such as IE 3 don't support the PNG format and that
even newer browsers such as IE 4, 5, and 6 have problems with full
PNG alpha channel support.

JPEG Colorful, complex images (such as photographs), images containing
gradients or color blends, and any other images with millions of colors.

Saving images for the Web

You can convert images from any format, including TIF, BMP, and PSD, into
the GIF, PNG, and JPEG formats. And you can optimize images that are
already in GIF, PNG, or JPEG format to further reduce their file sizes for faster
download over the Internet.

You can use many programs to create Web graphics, but one of the best

and easiest to use is Photoshop. Under the File menu in Photoshop (and
Photoshop Elements), you'll find the Save for Web option. (In Photoshop CS3,
the option is Save for Web & Devices.) Fireworks provides a similar feature,
but to help you appreciate how file conversion works, I include a few instruc-
tions for converting Web graphics right away. Although the dialog boxes are
different in different programs, the basic options for compressing and reduc-
ing colors are the same.
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It’s always best to use the highest quality image possible when you are edit-
ing, so take care of resizing and any other editing before you optimize your
images for the Web and always go back to the higher resolution image if you
want to do further editing.

In the Save for Web dialog box, you can preview your image and select your
optimization settings, choosing the format, amount of compression, and
color options. You can view the same image in multiple panes to make it easy
to compare the original image with optimized versions at different settings.

Below the original image preview, you see the filename and file size of the
original image. Below each of the optimized image previews, you see the
effects of the optimization settings specified when that preview was selected,
including the format, the settings, and the new file size and estimated down-
load time. Download time is calculated using an estimated Internet connec-
tion. You can change the setting by right-clicking (Option-clicking on a Mac)
the file size and optimization time text.

When you use the Save for Web feature, Photoshop creates a new copy of
your image using the settings you specified and leaves the original
unchanged in the main Photoshop workspace.

Optimizing JPEG images in Photoshop

The JPEG format is the best choice for optimizing continuous-tone images
such as photographs and images with many colors or gradients. When you
optimize a JPEG, you specify how much compression should be applied, a
process that makes the file size of the image smaller.

If you have a digital photograph or another image that you want to prepare
for the Web, follow these steps to optimize and save it in Photoshop. If you're
using another image program, the process is similar although the specific
steps may vary:

1. With the image open in Photoshop, choose Filez>Save for Web &
Devices (or File =>Save for Web).

The Save for Web & Devices dialog box appears.

2. Click the arrow to open the Optimized File Format drop-down list on
the right side of the dialog box and choose JPEG (see Figure 3-1).

3. Set the compression quality.

Use the preset options: Low, Medium, High, Very High, or Maximum from
the pull-down list. Or use the slider just under the Quality field to make
more precise adjustments. Lowering the quality reduces the file size and
makes the image download more quickly, but if you lower this number
too much, the image will look blurry and blotchy.
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File size and settings

Photoshop uses a compression scale of 0 to 100 for JPEGs in this dialog
window, with 0 the lowest possible quality (the highest amount of com-
pression and the smallest file size) and 100 the highest possible quality
(the least amount of compression and the biggest file size). Low, Medium,
and High represent compression values of 10, 30, and 60, respectively.

4. If you want to make the image focus softer, use the Blur settings.
5. Click Save.
The Save Optimized As dialog box opens.

6. Enter a name for the image and save it into the images folder in your
Web site folder.

Photoshop saves the optimized image as a copy of the original and
leaves the original open in the main Photoshop work area.

Repeat these steps for each image you want to optimize as a JPEG.
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Optimizing GIF images in Photoshop

If you're working with a graphic, such as a logo, cartoon character, or draw-
ing that can be displayed in 256 colors or less, you should use the GIF format
and reduce the total number of colors used in the image as much as possible
to reduce the file size. To help make up for the degradation in image quality
that can happen when colors are removed, GIF uses a trick called dithering.
Dithering involves alternating pixels in a checkerboard-like pattern to create
subtle color variations, even with a limited color palette. The effect can
smooth the edges in an image and make it appear that the image uses more
colors than it does.

To convert an image to a GIF in Photoshop, follow these steps:
1. With the image open in Photoshop, choose File=>Save for Web &
Devices (or File =>Save for Web).
The Save for Web & Devices dialog box appears.

2. In the Optimized File Format drop-down list on the right side of the
screen, choose GIF, as shown in Figure 3-2.

3. In the Colors box, select the number of colors.

The fewer colors you use, the smaller the file size and the faster the
image will download. For an even smaller file size, reduce the number to
4 or 8 colors, but be careful. The ideal number depends on your image; if
you go too far, you'll lose details and the image will look terrible.

4. If you want to maintain a transparent area in your image, select the
Transparency option.

Any area of the image that was transparent when you created the image
in the editor appears transparent in the preview window. If you don’t
have a transparent area in your image, this setting will have no effect.

Transparency is a good trick for making text or another part of an image
appear to float on a Web page because the transparent background
doesn’t appear on the Web page. You can select transparency as a back-
ground option in the New File dialog box when you create a new image.

5. Leave the other settings unchanged.

The remainder of the settings in this dialog box can be left at their
defaults in Photoshop.

6. Click Save.
The Save Optimized As dialog box opens.

7. Enter a name for the image and save it into your local root folder.

Repeat these steps for each image you want to prepare for your site.
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Illustration by Tom McCain

<P Trial and error is a great technique in the Save for Web & Devices dialog box.
In each of the three preview windows displaying optimized versions of the
Blue Heron cartoon image in Figure 3-2, [ used fewer and fewer colors, which
reduced the file size. The version in the top left is the original, which has a
file size of 164K. Reducing the image to 256 colors dramatically reduced the
file size to 11K, but made little noticeable change to the image, as you see in
the top right. In the bottom left, the image is reduced to 32 colors, which
brought the size down to 5.8K, but still made little change to the image. In the
bottom right, [ reduced it to 2 colors, and although it’s hard to tell in the
black-and-white reproduction in this book, the image quality suffered dramat-
ically. Because it is displayed in only two colors, it lost the original blue color
of the bird and the green in the grass at its feet. In this last case, the small
savings in file size is clearly not worth the loss of image quality.
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How small is small enough?

After you know how to optimize GIFs and JPEGs and appreciate the goal of

making them as small as possible, you may ask, “How small is small enough?”

The answer is mostly subjective — remember that the larger your graphics
files, the longer people have to wait for them to download before they can
see them. You may have the most beautiful picture of Mount Fuji on the front
page of your Web site, but if it takes forever to download, most people aren’t
going to be patient enough to wait to see it. Also remember that when you
build pages with multiple graphics, you have to consider the cumulative
download time of all the graphics on the page. Even if each individual image
is a small file size, they can add up. Unlike most things in life, smaller is defi-

nitely better on the Web.

Buying royalty-free clip art and photographs

If you don’t want the hassle of creating your
own images (or if you lack the artistic talent),
you may be happy to find that many sources of
clip art are available. Royalty-free images,
which include clip art and photographs, are
generally sold for a one-time fee that grants you
all or most of the rights to use the image. (Read
the agreement that comes with any art you pur-
chase to make sure that you don't miss any
exclusions or exceptions. For example, you may
have to pay extra to use an image for commer-
cial purposes.) You can find a wide range of
CD-ROMs and Web sites full of clip art, pho-
tographs, and even animations that you can use
on your Web site. (Speaking of animations,
nowadays you can even find Web sites that sell
Flash files, animations, buttons, and other artis-
tic elements that you can edit and integrate into
your Web site. For more info on how to add mul-
timedia to your Web site, see Chapter 11.) Many
professional designers buy clip art images and
then alter them in animage program — such as
Adobe Fireworks, Adobe Illustrator, or Adobe
Photoshop — to tailor them for a specific pro-
ject or to make the image more distinct.

Here are some clip art suppliers:

v Getty Images, Inc. (www.gettyimages.
com): Getty Images is the largest supplier
of royalty-free digital imagery on the Web,
specializing in photographs and illustrations
of a wide variety of subjects, including film
footage. Pay for images and footage as
you go.

+” Photos.com (www.photos . com): Photos.
com is a subscription-based service for
royalty-free stock photography and photo
objects. A 1- to 12-month subscription
gives you unlimited access and use of its
collection.

v~ iStockphoto.com (www. istockphoto.
com): An innovative variation of the fee-for-
use model, iStockphoto lets you trade your
own photographs for stock images.

+* Web Promotion (www.webpromotion.
com): A great source for animated GIFs and
other Web graphics. Artwork on this site is
free provided you create a link back to Web
Promotion on your Web site, or you can buy
the artwork for a small fee.
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Most Web pros consider anything from about 75K to 150K a good maximum
cumulative size for all the elements on a given page. With the increasing pop-
ularity of DSL and cable modems, many Web sites are starting to become a
bit more graphics heavy and go beyond that size limit. However, anything
over 150K is pushing the limits, especially if you expect people with dialup
modems (56K and under) to stick around long enough to view your pages.

To make determining the total file size of the images on your page easy,
Dreamweaver includes this information in the status bar of the current
Document window, as shown in Figure 3-3. This number indicates the total
file size of all the images and HTML on your page as well as the expected
download time at a given connection speed. (You can set your own connec-
tion speed by choosing Edit>Preferences=>Status Bar~>Connection Speed. On
a Mac, choose Dreamweaver—~Preferencesw>Status Barm>Connection Speed).
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Inserting Images in Dreamweaver

WING/
gg‘

Dreamweaver makes placing images on your Web pages easy and provides a
variety of ways to do so, including choosing Insert=>Image, clicking the Image
icon in the Common Insert bar and selecting an image using the Insert image
dialog box, or simply clicking an image name in the Files list panel and drag-
ging it onto the page.

To place an image on a Web page, follow these steps:

1. Open an existing page or choose File=>New to create a new page.

2. Make sure you save your page before inserting an image by choosing
File>Save and saving it to your main site folder.

3. Click to place your cursor where you want to insert the image on the
page.

4. Click the Image icon on the Common Insert bar at the top of the work
area (the icon looks like a small tree) or choose Insert-=>Image.

The Select Image Source dialog box appears.
5. Browse to locate the image you want to insert.

Choose Thumbnails from the View menu, as shown in Figure 3-4, to see a
preview of the images in the Select Image Source dialog box. You also
see a preview of any selected image on the right side of the dialog box if
you’re using the Windows operating system. (The Mac doesn’t have an
image preview option.)

6. To insert the image, double-click it or click once and then click OK.

The image automatically appears on the page.

When you insert an image file onto a page, you create a reference to the
image from the page. The underlying code looks much like it does when you
create a link from one page to another and then include the path from the
image to the page. As a result, if your images and the pages they are linked to
are not in the same relative location on your hard drive as they are on your
server, you break the reference to your images and they will not appear on
your pages. (Instead, you get that ugly broken image icon.) The best way to
make sure that your images and files stay where they’re supposed to in rela-
tion to one another is to save all your images in your local root folder (or

in a subfolder within that folder) and make sure they are located in the same
folder or subfolder on your Web server. You find more information about cre-
ating and identifying a local root folder at the beginning of Chapter 2.
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Aligning Images on a Page

After you place an image on your Web page, you may want to center or align
it so that text can wrap around it. In the following two sections — “Centering
an image” and “Aligning an image with text wrapping” — you find the steps to
accomplish both these goals using basic HTML. In Chapters 5 and 6, you find
instructions for aligning and positioning images using CSS, which provides

more precise design options.

Centering an image

To center an image on a page, follow these steps:

1. Click to select the image that you want to center.

The Property inspector changes to display the image properties.

2. From the icons for alignment options in the Property inspector, shown
in Figure 3-5, click the Align Center icon.

The image automatically moves to the center of the page.

/1
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You may have noticed the Align drop-down list in the Property inspector has
left and right alignment options but no center option. In HTML there is no
center option for the image tag, but when you use the Align center icon in the
Property inspector, you can add a center align option to any tag that sur-
rounds the image, usually the paragraph, or <p>, tag. You can also create a
CSS style that will serve to center an image by setting the left and right mar-
gins to default. You learn more about creating styles in Chapters 5 and 6.

Aligning an image with text wrapping

To align an image to the right of a page and wrap text around it on the left,
follow these steps:

1. Insert the image immediately to the left of the first line of the text (see
Figure 3-6).

@ The easiest way to do this is to place the cursor just before the first
letter of text; then choose Insertr®Image or click the Image icon in the
Common Insert bar.



Chapter 3: Adding Graphics 73

File Edit Yiew Insert Modify Text Commands Site Window Help:
emr DOosdEEEBERAE=Q

sé’underllngs 8 | Heach bt aier ss

sbch

Check Page

TR S R ]
i

|
Figure 3-6:
To wrap text
around an
image, first
place the
image
immediately
totheleftof fE3. = ——= — ]
the text with [izbods> <h> <ma- — i O [100% 763460 105K /1
no spaces |{"
between the ﬁ Imsge, 48K wizsn | mc |gesfshorebird-2500pg (65 3 Ak | Shore bird
text and = Jwm]| w[ ob xBINR
image. IE&nu:[ uspace | | Taget . Border | |
LY e " — = s

2 >
£
0
£
.
0

EAdline]

Class |-None V‘

i a ©
B

"
(T

k3

If you want the text to wrap, don’t put spaces or line breaks between the
image and the text.

2. Click to select the image.
The Property inspector changes to display the image attribute options.
3. In the Property inspector, choose Right from the Align drop-down list.
The image aligns to the right, and the text automatically wraps around it
as shown in Figure 3-7.

To align the image to the left of the page with text wrapping around on the
right, follow Steps 1 and 2, but choose Left from the Align drop-down list
instead of Right in Step 3.
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To prevent text from running up against an image, click the image, find V and
H spacing in the Property inspector, and enter the amount of space you want
(the space is measured in pixels). Five to ten pixels is usually enough to pre-
vent the text from bumping up against its edge. If you want to add space to
only one side of an image, it’s a bit more complicated, but you can more pre-
cisely control spacing with CSS (covered in Chapters 5 and 6).

Creating complex designs with images

The alignment options available in HTML enable you to align your images
vertically or horizontally, but you can’t do both at once. Also, the alignment
options don’t really enable you to position images in relation to one another
or in relation to text with much precision. For example, if you try to center an
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image positioned up against a text block, the text gets centered, too. One
way to get around this limitation is to create HTML tables and then combine
and merge cells in the table to control positioning. This old-school but still
common technique is covered in Chapter 7. A better options it to use
Cascading Style Sheets (see Chapters 5 and 6) to create layout and alignment
styles to control the positioning of all elements on a page following the latest
standards.

Image Editing in Dreamweaver

|
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The image-editing features in Dreamweaver enable you to make minor
changes to images inside Dreamweaver without opening Fireworks or
Photoshop or any other graphics-editing program. These tools are available
from the Property inspector when an image is selected (see Figure 3-8).
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You also find two buttons that enable you to easily move an image between
Dreamweaver and Fireworks to make editing images easy. The Edit button
launches Fireworks and opens the selected image in the main window of the
program. The integration between these programs means that when you save
changes to the image in Fireworks, they are automatically reflected in the
page in Dreamweaver. A new button, just to the right of the Edit button, is
designed to make optimizing an image in Fireworks fast and easy. Chapter 10
covers the Edit in Fireworks and Optimize in Fireworks features in greater
detail.

Before you get carried away editing your images, remember that
Dreamweaver is primarily a Web-page-creation application and not really
designed to edit graphics. Although these tools can be useful, they shouldn’t
take the place of doing serious work on your graphics in a graphics applica-
tion, such as Fireworks or Photoshop.
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When you do use the tools for cropping, adjusting brightness and contrast, and
sharpening an image, beware that you are changing the actual image (not just
a copy of it). Make sure you're happy with these changes before you save the
page you’re working on. You can use the undo feature in Dreamweaver to
revert back several steps, but after you save the page, you can’t undo changes
to an image. To protect your original image, save a copy before editing it.

Cropping an image

Essentially, cropping an image is trimming it. To crop a graphic or photo,
follow these steps:

1. In the Document window, select the image you’d like to crop by click-
ing it.
The Property inspector changes to display the image’s properties.

2. Click the Crop icon (labeled in Figure 3-8).

A dialog box appears warning you that cropping will change the original
image.

Don’t make the change if you’re concerned about keeping the entire
image available. If you're concerned, the best thing to do is to make a
copy of the image and apply your cropping to the copy.

3. Click OK.

A solid crop line with handles at the sides and corners appears over the
image, as shown in Figure 3-9.

4. Click and drag the handles to outline the area of the image you want
to keep.

Any part of the image outside the crop line (and shaded) will be deleted
when the crop is completed.

5. Double-click inside the box, or press Enter (Return on a Mac).
The image is cropped.

You can undo cropping by choosing Edit=>Undo. However, after you save the
page, changes permanently apply to the image and cannot be undone.

Adjusting brightness and contrast

Adjusting an image’s brightness allows you to change the overall amount of
light in an image. Contrast controls the difference between the light and dark
areas of an image.
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Using Dreamweaver’s editing tools will permanently alter the image when the
page is saved. If you're concerned, the best thing to do is to make a copy of
the image and make your adjustments to the copy.

To adjust brightness and contrast, follow these steps:

1. In the Document window, select the image you want to alter.
The Property inspector shows the image properties.
2. Click the Brightness and Contrast icon (labeled in Figure 3-8).

A dialog box appears, indicating that the changes you make are made to
the original file.

3. Click OK.
The Brightness/Contrast dialog box appears.

4. Use the sliders to adjust the brightness and contrast settings of the
image.
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Make sure to select the Preview check box if you want to see how the
changes affect the image as you move the sliders around.

5. Click OK.

The settings take effect permanently when you save the page.

Sharpening an image

When you apply sharpening to an image, you increase the distinction between
areas of color. The effect can be one of increased definition to the shapes and
lines in an image.

Using Dreamweaver’s editing tools will permanently alter the image when the
page is saved. If you're concerned, the best thing to do is to make a copy of
the image and make your adjustments to the copy.

To sharpen an image, follow these steps:

1. In the Document window, select the image you want to sharpen.
The Property inspector shows the image properties.
2. Click the Sharpen icon (labeled in Figure 3-8).

A dialog box appears, indicating that your change is made to the
original file.

3. Click OK.
The Sharpen dialog box appears.
4. Use the slider to adjust the sharpness of the image.

Make sure you select the Preview check box if you want to see how the
changes affect the image as you move the slider.

5. Click OK.

The image is sharpened and changes are made permanently when you
save changes to the page.

Optimizing images in Dreamweaver

Dreamweaver CS3 includes an Optimize icon that you can use to convert an
image to the GIF, PNG, or JPEG format and optimize it by reducing the colors or
increasing the compression, much as you can do in Photoshop or Fireworks.
To use this feature, simply select any image and then click the Optimize icon in
the Property inspector. (Hint: it looks like a C-clamp.)
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Dreamweaver’s editing tools permanently alter the image when the page is
saved. If you're concerned, copy the image and make changes to the copy.
To optimize an image in Dreamweaver, follow these steps:

1. In the Document window, select the image you want to optimize.
The Property inspector shows the image properties.
2. Click the Optimize icon (labeled in Figure 3-8).
A dialog box appears, indicating that your change is made to the
original file.
3. Click OK.
The Image Preview dialog box appears, as shown in Figure 3-10.
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4. In the Format drop-down list, select the image format you want.
You can select from Gif, JPEG, or PNG format.

5. If you choose JPEG, use the slider next to Quality to select the level of
compression. If you choose Gif or PNG, choose the number of colors
desired.

The image is altered based on the settings you specify.
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You can also change other settings in the Image Preview dialog window, such
as transparency settings for the GIF format, much as you would in Photoshop
or Fireworks.

Inserting a Background Image
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Background images can add depth and richness to a page design by adding
color and fullness. Used cleverly, a background image helps create the illu-
sion that the entire page is one large image while still downloading quickly
and efficiently. The trick is to use an image with a small file size that creates
the impression of a large image. One way this works on the Web is to use the
default settings for a background image, which cause the image to tile
(repeat) across and down the page (see Figure 3-11).

Beware that certain backgrounds (such as the one shown in Figure 3-11)
can make it difficult to read text placed on top. Choose your background
images carefully and make sure your background and your text have plenty
of contrast — reading on a computer screen is hard enough.
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Using CSS, you can have far greater control over the display of a background
image. When you create a CSS background style you can insert a background
image that does not repeat or that repeats only across the Y axis or down the
X axis of the page. When you insert an image using Dreamweaver’s Page
Properties feature, as shown in Figure 3-12, you can use the Repeat drop-
down menu to specify how the image repeats on the page, and Dreamweaver
automatically creates a background style for the page with these settings. If
you use the CSS Definition dialog box to further edit the background options
in the body style, you can also specify where the background image is dis-
played on a page. (You find more on CSS background options in Chapter 5).
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Creating Image Maps

Image maps are popular on the Web because they enable you to create hot
spots in an image and link them to different URLs. A common use of an image
map is with a geographic map, such as a map of the United States, that links
to different locations, depending on the section of the map selected. For
example, if you have a national bank and want customers to find a local
branch or ATM machine easily, you can create hot spots on an image map of
the United States and then link each hot spot to a page listing banks in that
geographic location.

Dreamweaver makes creating image maps easy by providing a set of simple
drawing tools that enable you to create hot spots and set their corresponding
links. To create an image map, follow these steps:

1. Place the image you want to use as an image map on your page.

2. Select the image.

The image properties are displayed in the Property inspector.
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Figure 3-13:
Select any
image to
display the
image map
tools in the
Property
inspector.
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3. To draw your hot spot, choose a shape tool from the image map tools
in the lower-left of the Property inspector (labeled in Figure 3-13).

The shape tools (a rectangle, a circle, and an irregular polygon) allow
you to draw regions on your images, called hot spots, each with a spe-

cific link.

4. With a shape tool selected, click and drag over an area of the image
that you want to make hot (link to another page).

Here’s how the different hot spot tools work:

¢ Rectangle: As you click and drag, a light blue highlight appears
around the region that you’re making hot; this highlighted area
indicates the active region. If you need to reposition the hot area,
select the Pointer hotspot tool (labeled in Figure 3-13) and then
select and move the region to the location you want. You can also
resize the hot spot by clicking and dragging any of the corners.
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e Circle: The Circle tool works much like the Rectangle tool — just
click and drag. To resize a circle hot spot, select the Pointer
hotspot tool, and click and drag one of the small square boxes on
its edges.

¢ Polygon: The Polygon tool functions a little bit differently than do
the other two tools. To make a polygon selection, you click the tool
once for each point of the polygon shape you want to draw. The
shape automatically connects the points as you click. When you're
finished, switch to another map tool or click outside the image.
You can change the size of the polygon or move any of its points
by using the Pointer hotspot tool.

5. To link a selected hot area:

] a. Click the Browse icon, next to the Link text box (at the top of the
Property inspector).
The Select File dialog box opens.

b. Browse to find the HTML file that you want to link to the hot spot
on your image.

c. Double-click the file to which you want to link.

The hot spot links to the selected page and the Select File dialog
box automatically closes.

You can also type the path directly in the Link text box.

6. To add more hot spots, choose an image and a shape tool, and repeat
Steps 4 and 5.

7. To give your image map a name, type a name in the Map text field,
just above the shape tools.

Giving your map (and all the hot spots it includes) a name helps to dis-
tinguish it in the event that you have multiple image maps on the same
page. You can call the map anything you want, as long as you don’t
include spaces or special punctuation.

When you finish, all your image map hot spots are indicated by a light
blue highlight.

At any time, you can go back and edit the image map. Simply click and high-
light the blue region on your image and drag the edges to resize the hot spot
or enter a new URL to change the link.
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Chapter 4

Managing, Testing, and
Publishing a Site

In This Chapter

Testing your site in different Web browsers

Testing your site with the Dreamweaver Site Reporting feature
Fixing broken links

Setting up FTP and other file transfer options

Publishing your site on the Web

Using Dreamweaver’s site management features

A fter you’ve built your Web site, you’ll probably want to publish it on the
Web. But before you go live with your site, [ recommend that you take a
little time to test your pages using Dreamweaver’s many testing features,
which I cover at the beginning of this chapter.

At the end of this chapter, you find instructions for using Dreamweaver’s site
management features, which are designed to help teams of designers work
better together. These include the Check In/Out feature, which prevents two
people from working on the same page on a site — an important feature if
you want to make sure that one designer doesn’t overwrite the work of
another. And believe me, you want to do everything you can to prevent this
situation.

If you're anxious to get your site online, jump ahead to midway through this
chapter, where you find instructions for using Dreamweaver’s publishing fea-
tures in the “Publishing a Site to a Web Server” section.

If you want to work more on the design of your site before you move onto
testing and publishing, feel free to skip ahead to the CSS chapters and other
more advanced chapters that follow. You can always come back to this chap-
ter when you’re ready to put your work online.
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) If you're looking for information about Web hosting services and domain reg-

istration sites, you find recommendations and tips for choosing the best host-
ing and domain services in Chapter 16.

Testing Vour Site in Different Browsers

One of the more confusing and frustrating aspects of Web design is that you
can create a page design that looks great in Dreamweaver and test it in a
browser to confirm that it looks fine, only to discover later that it looks terrible
in a different browser. Web pages can look different from one browser to
another for many reasons, but it all boils down to this: Browsers display Web
pages differently because HTML and other Web technologies have evolved dra-
matically over the years, and not all browser makers have designed their pro-
grams to display Web design features, such as HTML and CSS, in the same way.

Today, dozens of browsers are in use on the Web, not counting the different
versions of each browser. For example, at the time of this writing, Internet
Explorer 7 is the newest release from Microsoft, but a significant percentage
of Web users have not yet upgraded and are still using IE 6 or earlier ver-
sions. Similarly, browser companies such as Firefox and Safari have now cre-
ated a number of versions that are still in use on the Web.

Add to that the differences between Macintosh and Windows computers. For
example, the same font size can appear smaller on a Macintosh than on a PC,
and image colors can vary from one computer to another. In addition, the
same Web page may look very different on a 21-inch monitor than it does on
a 15-inch monitor.

As a result, the same Web page can look very different to the many people
who visit a Web site. For example, Figure 4-1 shows a Web page in Internet
Explorer and Figure 4-2 shows the same page in Firefox. The kinds of differ-
ences you see in these two browsers can become even more pronounced in
older browsers and on different size monitors.

This challenging aspect of Web design is at the root of many of the limitations
and complications of creating good Web sites. But with patience, testing, and
an understanding of the tags and styles that are most problematic, you can
create great Web sites that look good to most, if not all, of the people who
visit your Web site.
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In the example shown in Figures 4-1 and 4-2, the design is created using the
HTML <div> tag to separate each of the elements and create columns on the
page. CSS styles position the elements in the <div> tags on the page and add
margin spacing and padding. Because that spacing is not displayed the same
in Firefox as it is in Internet Explorer in the examples shown in these figures,
the display is different from one browser to another, and the right column is
forced down below the middle column in Figure 4-2. (You find out more about
using <div> tags and CSS to create page layouts and a few tips about how to
avoid this common problem in Chapter 6.)

Understanding browser differences

Entire books and Web sites are dedicated to the differences among browsers,
especially when it comes to CSS. Although I can’t possibly cover all these dif-
ferences here, [ do provide instructions for using Dreamweaver features that
can help you manage this type of design challenge, such as the Preview in
Browser feature covered in Chapter 2. The best way to test your work is to
view your pages in a selection of browsers.

Getting your pages to look exactly the same across every browser in use on
the Web is difficult to impossible, unless you're willing to use only the sim-
plest and most basic HTML formatting options or create multiple copies of
the same page, each designed for the unique display settings of the different
browsers that may be used to display your page. Most designers create a
page that looks as good as possible on as many browsers as they consider
important, even if the page doesn’t look exactly the same on all browsers.

Which browsers you should design for depends on your audience. If you
have the luxury of having good log files or visitor statistics, you may be able
to get a list of the browsers (and even the browser versions) used by visitors
to your site. For example, you may be able to determine that 50 percent of
your audience uses Firefox, 40 percent uses Internet Explorer, and 10 percent
uses Safari. With that in mind, you may decide that you want to optimize your
pages for display in Firefox, make sure they look almost if not equally good in
Internet Explorer, and make sure the content is at least readable and accessi-
ble in Safari.

If you want to create complex page designs using CSS and want your pages to
look as good as possible on as many browsers as possible, a number of hacks
and workarounds have been developed by Web designers to help ensure
pages look good to a broad audience. Some of these tricks are relatively
simple; others are extraordinarily complex.
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|
Figure 4-3:
Specify the
browsers
and
versions you
want to
target when
youruna
browser
compatibility
check.
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Because these kinds of problems are so common, especially when you use
CSS, Adobe has launched a special section of its Web site dedicated to help-
ing Web designers share ideas and strategies for designing with CSS. You'll
find these tips and tricks in the Adobe CSS Advisor section. Just visit
adobe.com/go/cssadvisor and search for CSS Advisor.

If you know that your visitors will be using only one browser — for example, if
you're designing a corporate intranet and can require that all employees use
the same browser — your design work will be much simpler. Some public

Web site designers resort to putting a note on the front page of a site advising
anyone who visits that the pages display best in a particular browser. Although
that may be warranted in some cases, | don’t recommend it because you risk
losing many potential visitors.

Using Dreamweaver’s Browser
Compatibility feature

To help you test your pages for possible problems in different Web browsers,
Dreamweaver includes a Browser Compatibility feature. To test a Web page,
open the page in Dreamweaver and choose File>Check Pager>Browser
Compatibility. You can also access this feature by clicking the drop-down
arrow next to Check Page at the top right of the workspace. Any recognized
conflicts are displayed in a report at the bottom of the workspace.

You can specify which browsers and browser versions you want to target
by clicking the small menu icon at the top-right corner of the Browser
Compatibility Check dialog box (the cursor is hovering over it in Figure 4-3).
You can also access the Browser Settings from the Check Page drop-down
list. When you select Browse Settings, the Target Browsers dialog box
appears, as you see in Figure 4-3.
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Testing Your Work with the
Site Reporting Features

|
Figure 4-4:
You can
select any
and all
options, and
you can run
reports on a
single page
or the entire
site.
|

Before you put your site online for the world to see, checking your work using
the Dreamweaver Site Reporting feature is a good idea. You can create a vari-
ety of reports and even customize them to identify problems with external
links, redundant and empty tags, untitled documents, and missing Alt text.
You can easily miss things — especially when you work on a tight deadline —
and what you miss can cause real problems for your viewers.

Before Dreamweaver added this great new feature, finding these kinds of mis-
takes was a tedious and time-consuming task. Now you can run a report that
identifies these errors for you and use Dreamweaver to correct mistakes
across your entire site automatically.

Follow these steps to produce a Site Report of your entire Web site:
1. In the drop-down list at the top of the Files panel, select the site name.

In the list that appears, select the site you want to work on.

Your site appears in the Files panel list only if you've completed the Site
setup process covered in Chapter 2.

2. Make sure all your open documents are saved by choosing File~>
Save All

3. Choose Site~>Reports.
The Reports dialog box appears (see Figure 4-4).

Reports

Repart on: | Entire Current Local Site hd Run

Current Document.

Entire Current Local Site % Cancel
Selected Files in Site:

Select reporl Eoider :

B3 Workflaw

[T Checked Out By

[T Design Notes

I Recently Modified
=] (e} HTML Reports

b Combinable Mested Fort Tags
Accessibility
Missing Al Text
Redundant Mested Tags
Removable Empty Tags

minlnllsls]

Untitled Documents
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Figure 4-5:
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4. In the Report On drop-down list, choose Entire Current Local Site.

You can also choose to check only a single page by opening the page in
Dreamweaver and then choosing Current Document in the Report On
drop-down list. You can also run a report on selected files or on a partic-
ular folder. If you choose Selected Files, you must have already selected
the pages you want to check in the Files panel.

5. In the Select Reports section, select the reports you want.

Table 4-1 describes the kind of report you get with each option. You can
select as many reports as you want.

The Workflow options in the Select Reports section are available only if
you already enabled Check In/Out in the Remote Info section of the Site
Definition dialog box and selected Maintain Design Notes in the Design
Notes section of the Site Definition dialog box’s Advanced tab. You can
read more about the Site Definition dialog box in Chapter 2 and more
about Design Notes and the Check In/Out in the “Making the Most of
Dreamweaver’s Site Management Features” section, later in this chapter.

6. Click the Run button to create the report(s).

If you haven’t already done so, you may be prompted to save your file,
define your site, or select a folder. (See Chapter 2 for more information
on defining a site in Dreamweaver.)

The Results panel appears, as shown in Figure 4-5, displaying a list of
problems found on the site. You can sort the list by different categories
(filename, line number, or description) by clicking the corresponding
column headings.

¥ Properties

¥ Results  Search | Reference | validation | Browser Compatibilty Check | Link Checker  Site Reparts  FTPLog | Server Debug
B File Line | Description ~
@ Ay tipstweb-design.html 789 Warning: Missing "alt” attribute
G| A tips\phatoshoplindex.hitml 288 Warning: Missing "alt” attribute
& A& tips\photoshoplindex.hml 288 Warning: Missing "alt” attribute
Ay tips\Farily-Fag, htrl 244 Warning: Redundant nested tag: <STRONG>
A tips)Family-Faa. ikl 243 Warning: Redundant nested tag: <STRONG>

< I >

Complete.

7. Double-click any item in the Results panel to open the corresponding
file in the Document window.

You can also right-click (Windows) or Control+click (Mac) on any line of
the report and choose More Info to find additional details about the spe-
cific error or condition.

8. Use the Property inspector or another Dreamweaver feature to cor-
rect the identified problem and then save the file.
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Table 4-1

Site Report Options

Report Name

What It Does

Checked Out By

Lists files checked out of the site and identi-
fies the person who checked them out.

Design Notes

Lists Design Notes used in the site.

Recently Modified

List files that have been edited within a
specified time period. You can set the time
period for the report by selecting the
Recently Modified check box and then click-
ing the Report Settings button at the bottom
of the dialog box.

Combinable Nested Font Tags

Lists all instances where you can combine
nested tags. For example, <font
color="#000000"><font
size="2">Great Web Sites You
Should Visit</font></font>

is listed because you can simplify the
code by combining the two font tags

into <font color="#000000"
size="2">Great Web Sites You
Should Visit</font>.

Accessibility

Lists possible accessibility issues in a wide
variety of categories. To specify what this
report checks, select the Accessibility
check box and then click the Report Settings
button at the bottom of the dialog box.

Missing Alt Text

Lists all the image tags that do not include
Alt text. Alt text is a text description for an
image tag included in the HTML code as an
alternative if the image is not displayed. Alt
text is important to anyone who uses a spe-
cial browser that reads Web pages.

Redundant Nested Tags

Lists all places where you have redundant
nested tags. For example, <h1>Good
headlines <hl>are harder to
write</hl> than you might
think</h1> is listed because you can
simplify the code by removing the second
<h1> tag to make the code look like this:
<h1>Good headlines are harder
to write than you might
think</hl>.
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Report Name What It Does

Removable Empty Tags Lists the empty tags on your site. Empty tags
can occur when you delete an image, text
section, or other element without deleting all
the tags applied to the element.

Untitled Documents Lists filenames that don't have a title. The
titletagis easy to forget because it does
not appear in the body of the page. The
title tag specifies the text that appears at
the very top of the browser window and also
the text that appears in the Favorites list when
someone bookmarks a page. You can enter a
title for any page by entering text in the title
field just above the work area or in the title
field in the Page Properties dialog box.

Finding and Fixing Broken Links

If you're trying to rein in a chaotic Web site, or if you just want to check a site
for broken links, you’ll be pleased to discover the Check Links feature. You
can use Check Links to verify the links in a single file or an entire Web site,
and you can use it to automatically fix all the referring links at once.

Here’s an example of what Check Links can do. Assume that someone on your
team (because you would never do such a thing yourself) changed the name
of a file from new.htm to o1d.htm without using the Files panel or any of
Dreamweaver’s automatic link update features. Maybe this person changed
the name using another program or simply renamed it in Explorer (Windows)
or the Finder (Mac). Changing the filename was easy, but what this person
may not have realized is that if he or she didn’t change the links to the file
when the file was renamed, the links are now broken.

If only one page links to the file that your clueless teammate changed, fixing
the broken link isn’t such a big deal. As long as you remember what file the
page links from, you can simply open that page and use the Property inspec-
tor to reset the link the same way you created the link in the first place. (You
can find out all the basics of link creation in Chapter 2.)

But many times, a single page in a Web site is linked to many other pages.
When that’s the case, fixing all the link references can be time-consuming,
and forgetting some of them is all too easy. That’s why the Check Links fea-
ture is so helpful. First, it serves as a diagnostic tool that identifies broken
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links throughout the site (so you don’t have to second-guess where someone
may have changed a filename or moved a file). Then it serves as a global fix-it
tool. You can use the Check Links dialog box to identify the page a broken
link should go to, and Dreamweaver automatically fixes all links referring to
that page. The following section walks you through this cool process.

If you are working on a dynamic, database-driven site or if your site was
altered with programming that was performed outside Dreamweaver, the
Check Links feature may not work properly. This feature works best for sites
with static HTML pages

Checking for broken links

To check a site for broken links, follow these steps:

1. In the drop-down list at the top of the Files panel, select the site name.
In the list that appears, select the site you want to work on.

Link checking works only for sites listed in the Dreamweaver Site dialog
box. For more information about the Site dialog box and how to set up a
new site or import an existing one, see Chapter 2.

2. Choose Sitec>Check Links Sitewide.

The Link Checker tab opens in the Results panel at the bottom of the
page, just under the Property inspector, as shown in Figure 4-6. The

tab displays a list of internal and external links. The tab also lists any
pages, images, or other items not linked from any other page in the site.
(Dreamweaver calls these orphans.) Unused images can waste space on
your server, so this list is handy if you want to clean up old images or
other elements you no longer use on the site.

Most service providers limit the amount of space on your server and
charge extra if you exceed that limit. You can save valuable server space
by deleting unused files, especially if they are image or multimedia files.
But remember, just because you delete them from your hard drive does-
n’t mean they are deleted from the server. Make sure you remove them
from the Remote Site window in the Files panel as well as the Local Site
panel. (For more on using FTP and synchronization to update or delete
files on your server, see the section, “Publishing Your Site to a Web
Server,” later in this chapter.)

Fixing broken links

Broken links are one of the worst problems you can have on a Web site. After
you identify a broken link in a site, you should fix it as soon as possible.
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Nothing turns off visitors faster than clicking a link and getting a File Not
Found error page. Fortunately, Dreamweaver makes fixing broken links
simple by providing quick access to files with broken links and automating
the process of fixing multiple links to the same file.
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After using the Link Checker tab described in the preceding section to iden-
tify broken links, follow these steps to use the Results panel to fix them:

1. With the Results panel open at the bottom of the page, double-click a
filename that Dreamweaver identified as a broken link.

The page and its corresponding Property inspector opens. The Results
panel remains visible.

2. Select the broken link or image on the open page.

In Figure 4-7, a broken image was selected and is being fixed by using the
Property inspector to find the correct image name.

3. In the Property inspector, click the folder icon to the right of the Src
text box to identify the correct image file.

(Alternatively, you can type the correct filename and path in the text box
instead of using the browse option to find the correct image.) The Select
Image Source dialog box appears. You fix links to pages just as you fix
links to images, except you type the name of the correct file into the Link
text box or click the folder icon next to it to find the file in your site folder.

4. Click to select the filename of the correct image or file and then
click OK.

The link automatically changes to reflect the new filename and location.
If you replace an image, the image file reappears on the page.
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If the link that you correct appears in multiple pages and you fix the link
using the broken link’s Results panel, Dreamweaver prompts you with a
dialog box asking whether you want to fix the remaining broken link refer-
ences to the file. Click the Yes button to automatically correct all other refer-
ences. Click the No button to leave the other files unchanged.

Finding files by their addresses

If you're not sure where you saved a file or what
you called it, but you can get to it with your
browser, you can determine the filename and
location by looking at the URL in the browser’s
address bar. Each folder in a Web site is
included in the address to a page within that
folder. Folder names are separated by the

forward slash, /, and each filename can be dis-
tinguished because itincludes an extension. For
example, the address to the page displayed in
the figure tells me that the file is named
dw8fd.html and is located in a folder called
dreamweaver, which is a subfolder of a
folder called books.
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Similarly, you can identify the name and location
of any image you are viewing on a Web page. If
you're using Internet Explorer, place your cursor
over the image and right-click (Windows)
and then choose Properties. The Properties

dialog box includes the specific URL of the
image, which has the name and folder (path). In
this example, the image is named DWSFD-
cover-sm.gif and is stored in a folder
named images inside a folder named




dreamweaver inside a folder named books.
If you're using the Safari browser on a Mac, it
works a little differently. Control+click an image

and choose Open Image in New Window. In the
new window, the image URL appears in the
location bar.

& Element Properties

ok

Image Properties

Size of File: 7.75 KB (7940 bytes)
Alternate text:  Dreamweaver 8 For Dummies

Location: http:fawesy. digitalfamily. com/books/drearmweaver/images/DWEF D-cover-sm. gif
Width: 112px
Height: 1ddpx
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Changing and moving linked files

Dreamweaver includes a variety of tools that help you manage the files and
folders within a site without breaking links. You can use the Files panel to
rename and rearrange files and folders, as well as create new folders, all with
drag-and-drop ease.
< You need to define your site for Dreamweaver’s Files panel features to work.
If you haven’t already defined your site, turn to the instructions at the begin-
ning of Chapter 2.

To rename or rearrange files, follow these steps:

1. If it’s not already active, select the site you want to work on in the
drop-down list at the top of the Files panel, as shown in Figure 4-8.

When you select a site by clicking the site name, the folders and files in
that site appear in the Files panel.

|
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You can
select any
defined site
in the Files
panel.
|

= = Files

(=D 1Warner

(it d===r | Snippeis

| %

:j Desktop
gl Local Disk (C:)
a D Drive (D1

|5 Coastal Traveler
150 Digital Farmily
15 HardMewsIne
£ IEWarnek

15 Sample EItE%
15 5CuBA Site

1= Water Birds

=
=
Local view ||

B e | 1

150 Birds of North Americy

Size ]:
P

o e B e B

- Soripks
F-E templates
[ - titles
-1 video
o] i

b T T T T |

w

[Log.. |

2. To open and close folders in the Files panel, use the plus (+) and
minus (-) signs, respectively.

3. In the Files panel, select the file or folder you want to move or rename
or both.

4. To move a selected file or folder:
a. Drag the selected file or group of files into a folder.

Dreamweaver automatically changes all the related links. The Files
panel works much like the Explorer window on a PC or the Finder
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|
Figure 4-9:
The Update
Files dialog
box lists all
files that will
be changed
during the
update
process.
|

on a Mac, except Dreamweaver tracks and fixes links when you
move files through the Files panel. By contrast, if you move or
rename site files or folders in the Finder or Explorer, you break any
links set to or from those files.

When you move a linked file into a new folder in Dreamweaver, the
Update Files dialog box appears with a list of links that need to be
updated, as shown in Figure 4-9.

b. To adjust the links, choose Update. If you choose Don’t Update,
any links to or from that file are left unchanged.

5. To rename a selected file:
a. Click twice on any filename or folder name.

b. When a box appears around the name, edit it just as you would
a name in the Finder or Explorer. Then press Enter (Return on
a Mac).

Again you're prompted with the Update Files dialog box to update
any links affected by the filename change.

c. Choose Update to adjust the links.

Update Files

Update links in the Following files? ‘ Update
fwriting/1-27-03-online-reputation, htm ~ k
fwriting/ 12-16-02-ebay hkm
fwriting/2- 10-03-digital-survey. htm
fwriting/2- 16-04-Online-Metworking, hkm
fwriting/2-9-04-spamblockers. htm
fwriting/3-10-03-sparn.hkm
fwriting/3-24-03-personals.htm

fwriting/4-07-03-cell-phones. htm
Awibinun IE_AE_ A bt hosilla kb

Making global changes to links

If you want to globally change a link to point at a new URL or to some other
page on your site, you can use the Change Link Sitewide option to enter the
new URL and change every reference automatically. You can use this option
to change any kind of link, including mailto, ftp, and script links. For example,
if an e-mail address that you use throughout your site changes, you can use
this feature to fix it automatically — a real timesaver. You can use this feature
also when you want a string of text to link to a different file than it currently
does. For example, you can change every instance of the words Enter this
month’s contest to link to /contest/january.htm instead of /contest/
december . htm throughout your Web site.
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To change a collection of links using the Change Link Sitewide feature, follow
these steps:

1. Make sure the site you want to work on is displayed in the Files panel.
See the preceding exercise for instructions on selecting a site.

2. Choose Site>Change Link Sitewide.
The Change Link Sitewide dialog box appears.

4. Enter the old address and then enter the new address, or click the
Browse button to identify files where you want to change the links.

You can use this feature to change any link, including e-mail links, links
from one page to another within a site, or links to a different Web site.

5. Click OK.

Dreamweaver updates any documents that include the specified links.

Any changes you make to links using Dreamweaver’s automated link features
occur only on the local version of your site on your hard drive. Make sure
you upload all affected files to your Web server to ensure that all changes are
included on your published site. To automatically reconcile changes on your
local and remote sites, use Dreamweaver’s Synchronize Files feature, which is
described later in this chapter.

Publishing Your Site to a Web Server

After you create your Web site, test it, and are ready to publish it on the Web,
it’s time to put Dreamweaver’s publishing tools to work. Which features you
use depends on the kind of Web server you use. If you're using a commercial
service provider, you’ll most likely need Dreamweaver’s FTP features, which
are covered in detail in the following section.

To access Dreamweaver’s publishing tools:

1. Choose Siter>Manage Sites.
The Manage Sites dialog box opens.

2. In the list of defined sites, select the site you want to publish and then
click the Edit button.

The Site Definition dialog box opens. If you have not already defined
your site, refer to the instructions for this important initial site setup
process at the beginning of Chapter 2.



Chapter 4: Managing, Testing, and Publishing a Site ’ 0 1

3. Select the Advanced tab from the top of the Site Definition dialog box.

The Advanced options appear instead of the Site Definition wizard avail-
able on the Basic tab.

4. In the Category list, select the Remote Info category.

5. Click the drop-down arrow to the right of the Access box (see Figure
4-10) and select the publishing option that is best suited to your Web
server and development environment.

As you can see in Figure 4-10, Dreamweaver provides five Access options:

¢ None: Select this option if you are not uploading your site to a
server or if are not yet ready to fill in these settings.

¢ FTP: Select this option to use Dreamweaver’s built-in File Transfer
Protocol features, which are covered in detail in the following sec-
tion. These are the settings you're most likely to need if you're
using a commercial Web hosting service.

¢ Local/Network: Select this option if you are using a Web server on
a local network, such as your company or university server. For
specific settings and requirements, check with your system

administrator.
Site Definition for Birds of North America
Basic | Advanced
Category Remate Infa
Local Info
Remote Infi T
T:ggﬁ'lgszr\ufer Aceess: | None 2,
Claaking {ule] = Tesh S S S SR
Design Motes FTR %
Site Map Layout Local{Metwork,
File Yigws Columns ehDAY
Contribute RDS
Templates Micrasoft® Yisual SourceSafe®
Spry
|
Figure 4-10:
The Remote
Info
category
has many
options for
publishing a
Web Site' [ [a]4 J [ Cancel 1 [ Help
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¢ WebDAV (Web-based Distributed Authoring and Versioning):
Select this option if you are using a server with the WebDAV
protocol, such as Microsoft IIS.

¢ RDS (Rapid Development Services): Select this option if you are
using ColdFusion on a remote server.

¢ Microsoft Visual SourceSafe: Select this option if you are using
Microsoft Visual SourceSafe. Note this option is available only in

Windows.

Setting up Web server access for FTP

To make your life simpler, Dreamweaver incorporates FTP capability so that
you can easily upload your pages to a remote Web server. The FTP options

include features that can help you keep track of changes you make to files on
your hard drive and ensure that they match the files on your Web server.

Protecting yourself with clever passwords

An extraordinary number of people use the
same word for their user IDs and passwords.
That may seem like a good idea because it's
easy to remember, butit's also the easiest pass-
word for someone to guess if they find (or
guess) your user ID and want to break into your
system.

If you want to make it harder for someone to
break into your computer system, use more than
just a name or a common word (using a pet's
name is also a popular password choice).
Adding punctuation and mixing the case in your
password makes it much harder to guess, but
not necessarily harder to remember if you're
clever. For example, if your dog is named Spot
and you live at 44 Maple, you could add the
number to your dog’s name to create a great
password such as spot44. The goal is to come
up with a password that is easy for you to
remember but hard for someone else to guess,

even if they use a software program designed
to try random names and common words from
the dictionary as passwords.

Add a random capital letter, and you make it
even harder to guess. For example, sPoT44
would be an even more challenging password
to crack. (Assuming the password system on
your Web server is case-sensitive, and most
are.) Oh, and don’t leave your password on a
sticky note next to your computer, unless you
want anyone who walks into your home or
office to have access to your system. Also be
careful about throwing notes with written pass-
words away (dumpster diving is a tried-and-true
method for stealing passwords). E-mail can also
be intercepted or discovered, so it's best not to
share passwords through e-mail if you're con-
cerned about security. Good old-fashioned tele-
phone service is still one of the best options for
sharing passwords.
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To upload your site using FTP, you need the following information from your
Web hosting service:

v FTP host name

v~ Path for the Web directory (this is optional but useful)

v FTP login

v FTP password

To access the FTP features in Dreamweaver:

1. Follow the steps in the preceding section, choosing FTP in Step 5.
The dialog box in Figure 4-11 appears.
2. In the FTP Host text box, type the hostname of your Web server.

It should look something like ftp.host.com or shell.host.com or
ftp.domain.com, depending on your server. (In my example, [ used
ftp.techytranslator.com.)

3. In the Host Directory text box, type the directory on the remote site
in which documents visible to the public are stored (also known as
the site root).

It should look something like public_html/ or www/htdocs/. Again,
this depends on your server.

4. In the Login and Password text boxes, type the login name and pass-
word, respectively, required to gain access to your Web server. If you
check the Save box, Dreamweaver stores the information and auto-
matically supplies it to the server when you connect to the remote
site.

This is your unique login and password information that provides you
access to your server.

Click the Test button to make sure you've entered everything correctly.
If there are no problems, Dreamweaver responds with a box saying
Dreamweaver connected to your Web server successfully.

5. Select the Use Passive FTP or Use Firewall option only if your service
provider or site administrator instructs you to do so.

If you aren’t on a network but you do use a commercial service provider,
you should not need to select either option.

6. Click OK to save your Web Server Info settings and close the Site
Definition dialog box.
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If you prefer to use a dedicated FTP program instead of Dreamweaver’s built-
in features, you can download FTP programs for the Mac and PC at the fol-
lowing Web addresses:

v A popular FTP program for the PC with the unusual name of WS_FTP,
can be downloaded from www . ipswitch.com.

v Another popular Windows program, Cute FTP, can be downloaded from
www.cuteftp.com.

v If you use a Macintosh computer, popular options are Fetch, available
for download at www. fetchsoftworks.com, and Transmit, available
for download at www.panic.com/transmit.

Putting your Web site online

Now that your site is set up, it’s time to upload pages on your server and
retrieve them by using the built-in FTP capabilities of Dreamweaver.
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Downloading an existing Web site

If you want to work on an existing Web site
and you don't already have a copy of it on your
local computer’s hard drive, you can use
Dreamweaver to download any or all the files in
the site so that you can edit the existing pages,
add new pages, or use any of Dreamweaver's
other features to check links and manage the
site’s further development. The first step is to
get a copy of the site onto your computer by
downloading it from the server.

To download an existing Web site, follow these
steps:

1. Create a new folder on your computer to
store the existing site.

2. Specify this folder as the local root folder
for the site with Dreamweaver's site setup
features.

Check out Chapter 2 for information on
defining a site, if you're not sure how to do
this.

3. Set up the Remote Info dialog box.

| explain how to do this in the “Setting up
Web server access for FTP” section.

4. Connect to the remote site by clicking the
Connects to Remote Host button, which
looks like the ends of two cables, in the
Files panel.

5. Click the Get Files button, which looks like
a down arrow, to download the entire site
to your local drive.

Sometimes your Web host has files on the
remote server that you don't need to down-
load. If you want to download only specific
files or folders from the site, select those
files or folders in the Remote Site pane of
the Files panel and click the Get Files
button. Dreamweaver automatically dupli-
cates some or all of the remote site’s struc-
ture, meaning the folders in the site but not
all the files within them, and places the
downloaded files in the correct part of the
site hierarchy. Re-creating the folder struc-
ture on your local computer is important
because Dreamweaver needs to know the
location of the files as they relate to other
parts of the site to set links properly. The
safest option is to download the entire site;
but if you are working on a large Web pro-
ject, downloading a part and duplicating the
structure enables you to work on a section
of the site without downloading all of it.

If you are working on only one page or sec-
tion of a site, you should generally choose
to include dependent files, meaning any
files linked from those pages, to ensure that
links are set properly when you make
changes.

. After you download the site or specific

files or folders, you can edit them as you do
any other file in Dreamweaver.

To transfer files between your hard drive and a remote server, follow these

steps:

1. Make sure you have defined your site (as described in the beginning
of Chapter 2), the site you want to upload is open and displayed in the

Files panel, and you have used all the FTP settings described in the

previous section.
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2. In the top left of the Files panel, click the Connects to Remote Host

Get files Putfiles

icon.

If you're not already connected to the Internet, the Connects to Remote
Host icon starts your dialup connection. If you have trouble connecting
this way, try establishing your Internet connection as you usually do to
check e-mail or surf the Web, and then return to Dreamweaver and click
the Connects to Remote Host icon after establishing your Internet connec-
tion. When your computer is online, Dreamweaver should have no trouble
establishing an FTP connection with your host server automatically.

If you still have trouble establishing a connection to your Web server,
refer to the preceding section, “Setting up Web server access for FTP,”
and make sure that you specified the server information correctly. If you
still have trouble, contact your service provider or site administrator

to ensure you have all the correct information for connecting to your
server. Getting all this information set up correctly the first time can be
tricky, and each service provider is different.

After you establish the connection, the directories on your server appear
in the Files panel. You can move between views in this panel by choosing
from the drop-down list at the top right, (visible in Figure 4-12). The main
options are Local View, which displays files on your local hard drive, and
Remote View, which displays files on the server.

Expand/Collapse

‘| w Files
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3. To upload a file (transfer a file from your hard drive to your Web

server), select the file from the Local View panel (which displays the
files on your hard drive) and click the Put Files icon (the up arrow) in
the Files panel.
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The files are automatically copied to your server when you transfer them.
You can select multiple files or folders to be transferred simultaneously.

After you upload files to you server, test your work by using a Web
browser to view them online. Sometimes things that look and work fine
on your computer (such as links) won’t work on the server.

4. To download files or folders (transfer files or folders from your Web
server to your hard drive), select the files or folders from the Remote
View panel (which displays the files on your server) and click the Get
Files button (the down arrow) in the Files panel.

The files are automatically copied to your hard drive when you transfer
them. Be aware that when you copy files to or from your server, the
files you're transferring overwrite the files already at the destination.
Dreamweaver notifies you about the overwriting if it notices you're
replacing a new file with an old one, but it isn’t always able to correctly
assess the proper time differences. When the transfer is complete, you
can open the files on your hard drive.

You can see both the remote and local views simultaneously by clicking

the Expand/Collapse icon on the far right side of the Files panel (labeled in
Figure 4-12). To collapse this Site dialog box and return the Files panel to the
side of the screen again, click the Expand/Collapse icon again.

The arrows with the check mark and the little lock at the top of the Files
panel are for the Check In/Out feature, which enables you to keep track of
who is working on a site and prevent more than one person making changes
to the same page. These features are covered in the “Using Check In and
Check Out” section, later in this chapter.

Synchronizing Local and Remote Sites

One of the most valuable features in Dreamweaver’s FTP options is the capa-
bility to automatically synchronize the files on your hard drive with the files
on your server. This is cool because it helps you keep track of which pages
you’ve edited and ensure that they have been updated on the server. This
may not matter much to you the first time you upload your site, or if you
have only a few pages in your site. But if you have a large site and make fre-
quent updates, this feature is a wonderful way to make sure all the changes
you make get to your server. Dreamweaver also confirms which files are
updated after you complete the synchronization.

Follow these steps to synchronize your Web site:

1. Make sure the site you want to work on is selected and displayed in
the Files panel.
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B 2. Click the Connects to Remote Host icon, in the top left of the Files
panel, to log on to your remote site.

3. Click the Expand/Collapse icon (labeled in Figure 4-12) to expand the
dialog box and view the remote and local sites simultaneously.

The Site dialog box displays both the remote and local views of the site.
(To collapse this dialog box, click the Expand/Collapse icon again.)

4. Choose Site=>Synchronize Sitewide.
The Synchronize Files dialog box appears.

5. In the Synchronize drop-down list, choose whether to synchronize the
Entire Site or Selected Files Only.

6. In the Direction drop-down list, choose which option you want to use
to copy the files:

e Put Newer Files to Remote: This option copies the most recently
modified files from your local site to the remote site. Click the
Delete Remote Files Not on Local Drive box if you want those files
removed from your Web site.

¢ Get Newer Files from Remote: This option copies the most
recently modified files from your remote site to the local site. Click
the Delete Local Files Not on Remote Server box if you want to
remove those files from your local copy.

¢ Get and Put Newer Files: This option updates both the local and
remote sites with the most recent versions of all the files.

7. Make sure the Delete Remote Files Not on Local Drive box is not
selected.

Be careful of this feature. As a general rule, | recommend you leave it
unchecked because you may have folders and files on the server, such
as log files, that do not exist on your hard drive, and you don’t want to
delete them inadvertently.

8. Click the Preview button.
The Site FTP dialog box displays the files that are about to be changed.

Now you have the option to verify the files you want to delete, put, and
get. If you don’t want Dreamweaver to alter a file, deselect it from the
Site FTP dialog box now, or forever live with the consequences.

9. Click OK.

All approved changes are automatically made, and Dreamweaver
updates the Site FTP dialog box with the status.
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10. When the synchronization finishes, you can choose to save or not
save the verification information to a local file.

[ recommend you choose to save the verification information because it
can be handy if you want to review your changes after synchronization
is complete.

Be careful of the Delete Remote Files Not on Local Drive option, especially if
you have special administrative pages, such as stats files, which are often
added to your server space by your service provider to track traffic on
your site.

Setting Cloaking Options

The Dreamweaver Cloaking option enables you to exclude folders or files from
all site operations, meaning they won’t be uploaded to the live site when you're
synchronizing or batching files back and forth. This feature is handy if you
have sections of a site that you want to save but don’t want visible to your
viewers. For example, if you have a special holiday folder that you don’t want
visible during the rest of the year, you can use the Cloaking feature to save it
locally, with the assurance that no one can accidentally publish the files with
Dreamweaver until you uncloak them and publish them in December.

To use the Cloaking feature, follow these steps:

1. Choose Sitec>Manage Sites.
2. Select the site you want to work on and then click Edit.
The Site Definition dialog box appears.
3. In the Category list on the left, select the Cloaking category.
4. Select the Enable Cloaking box.

5. If you want to cloak files of a certain type, select the Cloak Files
Ending With box and enter the extension(s) in the text field, as shown
in Figure 4-13.

For example, if you want to cloak any original Photoshop files that may
be saved in your local root folder so they don’t upload and take up
space on your server, enter the . psd extension. If you want to cloak
more than one file type, separate each file extension with a space. Do
not use a comma or other delimiter.

6. Click OK to close the Site Definition dialog box and then click the
Done button in the Define Sites dialog box to close it.

Files matching the extensions specified, if any, are now cloaked.
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7. If you want to manually cloak specific folders, select the folders in the
Files tab of the Files panel.

You can’t cloak individual files, for reasons known only to the

Dreamweaver programmers.

8. Right-click (Windows) or Control+click (Mac) and select

Cloaking~>Cloak.

To uncloak files or folders, repeat Steps 4 through 8 and select Uncloak from

the shortcut menu. You can also use these steps to uncloak all the files in your

current site, disable cloaking in the site, and change the cloaking settings.

If you're an experienced Web designer and just
want to make quick changes to a site or use the
FTP features to access files on a server without
doing the site setup steps, Dreamweaver does
enable you to use these features without com-
pleting site setup. To access FTP features and
setthem up quickly, choose Sitez>Manage Sites

Editing Web pages online

and then choose New=>FTP & RDS Server from
the Manage Sites dialog box. This shortcut
enables you to work directly on your server
using FTP & RDS Server, however,
Dreamweaver does not manage link checking,
and none of the other site management features
work.
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If you disable cloaking for all files, any manual cloaking choices you've made
are lost, even if you enable cloaking again later.

Making the Most of Dreamweaver’s
Site Management Features

In the following sections, you'll find descriptions and instructions for using
more of the options available from the Site Definition dialog box, including
Design Notes, Check In/Out, and integrated e-mail. If you're the only person
working on a Web site, you probably don’t need the features described in this
section because they are intended for use on sites developed by a team of
people who need to communicate with each other and make sure they don’t
overwrite each other’s work.

Using a testing server

The Testing Server option enables you to specify a development server, a
necessary step if you are creating a Web site using the Dreamweaver dynamic
page-creation features for developing sites using PHP, ASP, or ColdFusion. You
find more information about using these options in Chapters 13, 14, and 15.

Using Check In and Check Out

The Check In/Out feature is designed to keep people from overwriting each
other’s work when more than one person is working on the same Web site (a
valuable feature if you want to keep peace among all the members of your
Web design team). When a person working on the Web site checks out a file,
other developers working on the site are unable to make changes to that file.
When you check out a file, a green check mark appears next to the filename
in the Files panel. If someone else checks out a file, you see a red check mark
next to the filename.

To use the Check In/Out feature, select the Enable File Check In and Check Out
option at the bottom of the Remote Info dialog box. The dialog box expands to
expose other options. If you want files checked out whenever they are opened,
select the Check Out Files When Opening option (see Figure 4-14).
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Using this feature, you can track which files a particular person is working
on. But if you want to use this tracking mechanism, select the Check Out Files
When Opening option and then fill in the name you want associated with the
files (presumably your name or nickname) in the Check Out Name field and
then include your e-mail address in the Email Address field. (The Email
Address field is needed for Dreamweaver’s integration with e-mail, which
facilitates communication among developers on a site. See the next section
for more information about integrated e-mail.)

Keeping the peace with version control

Version control systems enable you to better
manage changes and prevent different team
members from overwriting each other’s work. If
you already use these programs, you'll be glad to
know that you can integrate both Visual
SourceSafe and systems that use the Web DAV
protocol with Dreamweaver. This way, you can

take advantage of the Dreamweaver site man-
agement features and still protect your code
development process. If you don‘t know about
these programs, visit the Microsoft site
(http://msdn.microsoft.com/ssafe
/) to find out more about Visual SourceSafe. For
more on Web DAV, visit www . webdav . org.
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Staying in touch with integrated e-mail

Dreamweaver features integrated e-mail as another handy tool for collabora-
tive Web design when you use the Dreamweaver Check In/Out tool (described
in the preceding section). With the e-mail program you already use, integrated
e-mail gives you easy access to the e-mail addresses of other members of your
team.

When you work on a site with a team of people, finding that someone else has
already checked out the page you want to work on is common. Until that
person checks the file back in, doing the work you need to do to the page is
impossible. In the Dreamweaver Site Definition dialog box, each developer
types his or her e-mail address with the Check In/Out feature. Then, when you
find that someone else has the page you need, you can easily fire off an e-mail
asking that person to check it back in so you can work on it, just by clicking
that person’s name in the Files window. (I find bribes can be more effective
than threats, especially when you bribe with chocolate or free movie passes.)

Developers on your team can use the following steps to associate their e-mail
addresses with their version of Dreamweaver as part of the Check In/Out
setup:
1. Choose Siter>Manage Sites.
The Manage Sites dialog box opens.
2. Select the site you want to work on and then click the Edit button.
The Site Definition dialog box opens.
3. Click the Advanced tab.
4. In the Category list on the left, choose Remote Info.
The Remote Info page appears (refer to Figure 4-14).
5. Select the Enable File Check In and Check Out check box.
6. Select the Check Out Files When Opening check box.
7. In the Check Out Name text box, enter your name.

Nicknames are okay as long as everyone on the team knows your silly
name.

8. In the Email Address text box, enter your e-mail address.

9. Click OK to save your changes. Click the Done button in the Manage
Sites dialog box.

The Manage Sites dialog box closes.
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Using Design Notes

If you sometimes forget the details of your work or neglect to tell your col-
leagues important things about the Web site you're all working on, the
Dreamweaver Design Notes feature may save you some grief.

Design Notes are ideal if you want to hide sensitive information from visitors,
such as pricing structures or creative strategies, but make it available to
members of your development team. Information saved as a Design Note in
Dreamweaver can travel with any HTML file or image, even if the file transfers
from one Web site to another or from Fireworks to Dreamweaver.

Essentially, Design Notes enable you to record information (such as a mes-
sage to another designer on your team) and associate it with a file or folder.
Design Notes work a lot like the comment tag (HTML code that enables you to
embed in a page text that won’t appear in a browser) but with a bit more pri-
vacy. Unlike the comment tag, which is embedded directly in the HTML code
of a page (and can be seen if someone views the source code behind a page
on the Web), Design Notes are never visible to your visitors. The only way for
a visitor to view Design Notes is to deliberately type the path to your notes
subdirectory and view the notes files directly. You can even explicitly block
this from being allowed, but only if you have administrative access to your
server. To be even more secure, you can keep the notes on your hard drive
and prevent them from ever being uploaded to your server — though, of
course, your team members won'’t see your witty remarks.

To access the Design Notes page, choose Design Notes in the Category list in
the Site Definition dialog box (see Figure 4-15). The settings on this page
enable you to control how Dreamweaver uses Design Notes:

v Maintain Design Notes: Select this option to ensure that the Design Note
remains attached to the file when you upload, copy, or move it.

+~ Upload Design Notes for Sharing: Choose this option to include Design
Notes when you send files to the server via FTP.

v Clean Up: Use the Clean Up button, also shown in Figure 4-15, to delete
any Design Notes that are not associated with any files in the site.

When you create graphics in Adobe Fireworks, you can save a Design Note
for each image file that is also available in Dreamweaver. To use this inte-
grated feature, create a Design Note in Fireworks and associate it with the
image. Then when you save the Fireworks image to your local Web site folder,
the Design Note goes with it. When you open the file in Dreamweaver, the
Design Note appears when you right-click the image (Control+click on the
Mac). This feature is a great way for graphic designers to communicate with
other members of the Web development team.
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To activate the Design Notes feature, follow these steps:

1. Choose Site>Manage Sites.
The Manage Sites dialog box opens.

2. Select the site you want to work on and then click the Edit button.
The Site Definition dialog box opens.

3. Select the Advanced tab.

4. In the Category list at the left, choose Design Notes.
The Design Notes page appears (refer to Figure 4-15).

5. Select the Maintain Design Notes option.

With this option selected, whenever you copy, move, rename, or delete a
file, the associated Design Notes file is also copied, moved, renamed, or
deleted with it.

6. If you want your Design Notes to be sent with your files when they are
uploaded to your server, select the Upload Design Notes for Sharing
option.

If you're making notes only to yourself and don’t want them to be associ-
ated with the page when you upload it to the server, deselect this option
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and the Design Notes will be maintained locally but not uploaded with
your file.

7. Click OK in the Site Definition dialog box and then click the Done
button in the Manage Sites dialog box.

The Manage Sites dialog box closes.

To add Design Notes to a document, follow these steps:

1. Open the file you want to add a Design Note to and then choose
Filew>Design Notes.

The Design Notes dialog box opens (see Figure 4-16). You need to have a
file checked out to add or modify a Design Note, but not to read a note.

Design Notes

Basic info Allinfa

File:
Location:

Status:

Mates:

indese.html

...5ettingsiJanine WarneriMy DocumentsiWeb sitesi\Unnamed Site 2

draft hd

Please edit this file for me before posting, Thanks!

0K

Cancel

Help

III e

2. In the Status drop-down list box, choose the status of the document.

Your options are Draft, Revision 1, Revision 2, Revision 3, Alpha, Beta,
Final, and Needs Attention. You can choose any status, and you should
set a policy with your design team about what each status means and
how you use these options to manage your development.

3. In the Notes text box, type your comments.

4. If you want to insert the current local date, click the Insert Date icon,

which is just above the Notes text box.
The current date is inserted automatically.

You can also select the Show When File Is Open check box. If this box is
selected, the Design Notes appear whenever the file is opened so that
they can’t be missed.



Chapter 4: Managing, Testing, and Publishing a Site ’ ’ 7

5. Click the All Info tab.

You can add other information that may be useful to developers of your
site. For example, you can name a key designer (in the Name field) and
define the value as the name of that person or the priority of the project
(in the Value field). You may also define a field for a client or the type of
file that you commonly use.

6. Click the plus (+) button to add a new information item; click the
minus (-) button to remove a selected item.

7. Click OK to save the notes.

The notes you entered are saved to a subfolder named notes in the same
location as the current file. The filename is the document’s filename plus
the extension .mno. For example, if the filename is art . htm, the associ-
ated Design Notes file is named art .htm.mno. Design Notes are indicated
in Site View by a small yellow icon that looks like a cartoon bubble.

Activating Site Map Layout

If you have trouble keeping track of all the files in your Web site and how they
link to one another, you're not alone. As Web sites get larger and larger, this
task becomes increasingly daunting. That’s why Dreamweaver includes a Site
Map Layout feature — to help you keep track of the structure and hierarchy
of your site. This is not a site map (like those you often see on Web sites) that
links to the main pages of a site. The Dreamweaver Site Map Layout is never
visible to your visitors; it’s a site management feature designed to help you
visually manage the files and folders in your site.

To create a site map from the Site Map Layout page, follow these steps:

1. Choose Sitec>Manage Sites.

The Manage Sites dialog box opens.
2. Select the name of the site you want to work on.
3. Click the Edit button.

The Site Definition dialog box opens.

4. Make sure the Advanced tab at the top of the Site Definition dialog
box is selected and the Advanced options are visible.

5. In the Category list on the left, select Site Map Layout.

The Site Map Layout options appear on the right side of the Site Definition
dialog box, as shown in Figure 4-17.
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. Click the Browse icon next to the Home Page text box and browse to

find the main folder of your Web site. Note: If you already filled out
the Local Info page for your site, this field is already filled in.

This text box specifies the location of the home page of the Web site and
the main site folder. This information is essential because it shows
Dreamweaver where the Web site begins and ends.

. Specify the number of columns you want to display per row in the

site map.

If you're not sure what you want for these settings, start with the default
value of 200. You can always come back and change these settings later
if you don’t like the spacing of the icons in your site map.

. In the Column Width text box, set the width of the site map’s columns

in pixels.

Again, start with the default value of 125 if you're not sure of the width.

. In the Icon Labels section, select the File Names or Page Titles option

if you want the filename or the page title, respectively, as the label for
each page in the site map.

You can manually edit the displayed filename or page title after you gen-
erate the site map.
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10. In the Options section, you can choose to hide certain files, meaning
they won’t be visible in the Site Map window.

If you select the Display Files Marked as Hidden option, files you have
marked as hidden appear in italic in the site map. If you select the
Display Dependent Files option, all dependent files in the site’s hierarchy
appear. A dependent file is an image or other non-HTML content that the
browser loads when loading the main page.

11. Click OK.

The site map is generated automatically.

12. To view the Site Map, open the Files panel on the right side of the
screen and select Map View from the drop-down list in the top-right
corner.

(In Figure 4-18 the drop-down list is displayed on the left because the
Files panel has been expanded.) The site map appears in the Files panel
using icons to represent each file and link in the site.
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Using the File Uiew Columns option

You can use the File View Columns category in the Site Definition dialog box

(see

Figure 4-19) to customize how file and folder options appear in the

expanded Files panel. This can be useful for sorting or grouping files in novel
ways — for example, by adding a section, department, season, or version
column.
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You can customize File View Columns in the following ways:

v You can add up to 10 new columns by clicking the small plus sign at the
top of the dialog box and entering the name, association, and alignment
of each new column.

v You can reorder or realign the order in which columns appear by select-
ing the name of the column and then clicking the up or down arrow in
the top right of the dialog box to move it up or down the list.

»* You can hide any columns except the filename column by selecting the
column name and clicking to remove the check mark in the Show box.

»* You can designate which (if any) columns are shared with other develop-
ers who have access to the site by selecting the column name and click-
ing to remove the check mark in the Enable Column Sharing check box.

» You can delete any of the custom columns (you can not delete default
columns) by selecting the column name and clicking the minus sign at
the top of the dialog box.

v You can rename custom columns as you would edit a filename.

v You can associate Design Notes with custom columns by selecting the
column name and using the drop-down list next to Associate with Design
Note.
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Enabling Contribute features

Adobe Contribute is a program that was created so that people who don’t
know much about Web design can easily contribute to a Web site. Think of
Contribute as sort of a Dreamweaver Light, except it doesn’t work very well
as a stand-alone program. Contribute was designed to work on sites designed
in Dreamweaver, and a number of features have been carefully integrated to
make that collaboration work smoothly. If you're working with other develop-
ers of a site who use Contribute, make sure you select the box next to Enable
Contribute Compatibility in the Contribute category of the Site Definition
dialog box.

Remembering Your History

Figure 4-20:
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undoing and
repeating
your steps
easy.
|

You can keep track of what you're doing and even replay your steps with the
History panel. The History panel also lets you undo one or more steps and
create commands to automate repetitive tasks.

To open the History panel, shown in Figure 4-20, choose Window=>History. As
soon as you open a file, the History panel starts automatically recording your
actions as you do work in Dreamweaver. You can’t rearrange the order of steps
in the History panel, but you can copy them, replay them, and undo them.
Don’t think of the History panel as an arbitrary collection of commands; think
of it as a way to view the steps you’ve performed, in the order in which you
performed them. This is a great way to let Dreamweaver do your work for you
if you have to repeat the same steps over and over. It’s also a lifesaver if you
make a major mistake and want to go back one or more steps in your develop-
ment work.

il ¥ History =
A Typing: Once upon a kime
?é ew Paragraph
B Apply Bold
1 apply Tralic
E Mew Paragraph
ATyplng: Histary mattered
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Repeating your steps with Recorded Commands

You can automate repeat tasks using
Dreamweaver's Recorded Commands feature,
available from the Commands menu. Simply
start the record option, execute any series of
actions in Dreamweaver, stop, and save them.
Then you just replay the recording to repeat the
actions automatically. To use the Recorded
Commands option, choose Commandsc>Start
Recording and then carefully execute a series

of steps that you want to be able to repeat.
When you complete the steps you want to
record, choose Commands=>Stop Recording
and name the command to save it. To play the
actions back, choose Commands=>Play
Recorded Command and select your new com-
mand. Then kick back and watch the action; or
better yet, take a break and get out of your
office for a change.

Here’s a rundown of how you can put the History panel to use:

v To copy steps you already executed: Use the Copy Steps option as a
quick way to automate steps you want to repeat. You can even select
steps individually, in case you want to replay some (but not all) actions
exactly as you did them.

1 To replay any or all steps displayed in the History panel: Highlight the
steps you want to replay and click the Replay button at the bottom of
the History panel.

v To undo the results of the replayed steps: Choose Edit>Undo Replay
Steps.

1 To apply steps to a specific element on a page: Highlight that element
in the Document window before selecting and replaying the steps. For
example, if you want to apply bold and italic formatting to just a few

words on a page, you can replay the steps that applied bold and italics
to selected text.

You can also set the number of steps displayed in the History panel by choos-
ing Edit=>Preferences (Windows) or Dreamweaver~Preferences (Mac) and
selecting General from the Category list on the left. The default is 50 steps,
more than enough for most users. The higher the number, the more memory
the History panel uses.

Using the Quick Tag Editor

If you're one of those developers who likes to work in the Dreamweaver
WYSIWYG editing environment but still wants to look at the HTML tags once
in a while, you’ll love the Quick Tag Editor.
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The Quick Tag Editor, as the name implies, lets you quickly access HTML tags
and enables you to modify, add, or remove an HTML tag without opening the
HTML Source window. That means that while you’re in the middle of working
on a page in design view, you can view the HTML tag you are working on
without switching over to code view. You can use the Quick Tag Editor to
insert HTML, edit an existing tag, or wrap new tags around a selected text
block or other element.

The Quick Tag Editor opens in one of three modes — Edit, Insert, or Wrap —
depending on what you selected on the page before you launched the editor.
Use the keyboard shortcut Ctrl+T (Windows) or 38+T (Mac) to change modes
while the Quick Tag Editor is open.

You can enter or edit tags in the Quick Tag Editor just as you would in code
view, without having to switch back and forth between code view and design
view. To enter or edit tags in the Quick Tag Editor, follow these steps:

1. With the document you want to edit open, select an element or text
block.

If you want to add new code, simply click anywhere in the file without
selecting text or an element.

2. Choose Modify=>Quick Tag Editor.
You can also press Ctrl+T (Windows) or $8+T (Mac).

The Quick Tag Editor opens in the mode that is most appropriate for
your selection, as shown in Figure 4-21. For example, if you click an
image or formatted text, it displays the current tag so that you can edit
it. If you don’t select anything or if you select unformatted text, the
Quick Tag Editor opens with nothing in it, and you can enter the code
you want to add. Press Ctrl+T (38+T) to switch to another mode.

If you want to edit an existing tag, go to Step 3. If you want to add a new
tag, skip to Step 4.

3. If you selected an element formatted with multiple HTML tags or a tag
with multiple attributes, press Tab to move from one tag, attribute
name, or attribute value to the next. Press Shift+Tab to move back to
the previous one.

If you aren’t sure about a tag or attribute, pause for a couple of seconds
and a drop-down list appears automatically, offering you a list of all the
tags or attributes available for the element you are editing. If this Hints
list doesn’t appear, choose Edit=>Preferences=>Code Hints (Windows) or
Dreamweaver~Preferences~>Code Hints (Mac) and make sure that the
Enable Code Hints option is selected.
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4. To add a new tag or attribute, simply type the code into the Quick Tag
Editor.

You can use the Tab and arrow keys to move the cursor where you want
to add code. You can keep the Quick Tag Editor open and continue to
edit and add attribute names and values as long as you like.

5. To close the Quick Tag Editor and apply all your changes, press Enter
(Windows) or Return (Mac).
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Part ]
Appreciating Web
Design Options

The Sth Wave By Rich Tennant
(ORGTENNNT

T ST .
“Just how accurately should my Web site
reflect my place of business?”




In this part . . .

Fe best way to create standards-based, accessible
Web designs is with Cascading Style Sheets (CSS).
This part introduces you to the power and advantages of
CSS, but you'll also find instructions for working with
tables and frames, which are still viable approaches to
Web design.

In Chapter 5, you find an introduction to CSS and a review
of the CSS features in Dreamweaver. In Chapter 6, you

move on to creating CSS layouts, using div tags and other
block-level elements to create accessible, flexible designs.

In Chapter 7, you find out how to create tables, split and
merge cells, and use table attributes. In Chapter 8, you get
an introduction to frames and discover how targeting makes
it possible to open a link in a specific part of the page. And
in Chapter 9, you discover how Dreamweaver’s templates
can make creating Web pages faster and save you even
more time if you ever have to redesign your pages.




Chapter 5
Cascading Style Sheets

In This Chapter
Introducing Cascading Style Sheets

Using Dreamweaver’s CSS features
Comparing internal and external style sheets

Working with tag, class, and advanced style selectors

Wmt to add a little style to your pages? Cascading Style Sheets (CSS) is
the way to create Web sites today if you want to follow the latest stan-

dards and develop Web sites that are accessible, flexible, and designed to
work on a wide range of devices.

The concept of creating styles has been around since long before the Web.
Desktop publishing programs, such as Adobe InDesign, and even word pro-
cessing programs, such as Microsoft Word, have long used styles to manage
the formatting and editing of text on printed pages. Using styles in a word
processor, you could create styles for common features such as headlines,
subheads, and captions. In print design, styles are great timesavers because
they enable you to combine a collection of formatting options, such as Arial,
bold, italic, and centered, into one style and then apply all those options at
once to any selected text in your document using a single style. When you
use styles this way in print, you also have the advantage that if you change a
style, you can apply the change everywhere you’ve used that style.

On the Web, you can do all that and more with CSS because you can use
styles sheets for a lot more than just text formatting. In addition to creating
styles for things such as headlines, you can use CSS to create styles that align
images to the left or right side of a page, add padding around text or images,
and change background and link colors. You also have the option of creating
style sheets that apply only to the page you are working on or to create style
sheets that are separate documents and can be applied to many pages in the
same site. Using this approach, you can make changes across any or all pages
in a Web site simply by altering the styles in an external style sheet. Because
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you can create multiple style sheets for the same page, CSS is rapidly becom-
ing the preferred method of designing Web pages among most professional
Web designers.

If you haven’t jumped on the CSS bandwagon yet, this chapter is designed to
help you appreciate the benefits of CSS, introduce you to Dreamweaver’s CSS,
and show you how to create and apply styles. In Chapter 6, you find instruc-
tions for using CSS to control the position of elements and create page lay-
outs by combining HTML <div> tags and styles.

Introducing Cascading Style Sheets

One of the most powerful aspects of CSS is the way you can use it to make
global style changes across an entire Web site. Suppose, for example, that you
create a style for your headlines by redefining the <h1> tag to create large,
blue, bold headlines. Then one fine day you decide that all your headlines
should be red instead of blue. If you aren’t using CSS, changing all your head-
lines could be a huge undertaking — a matter of opening every Web page in
your site and making changes to the font tags around your headlines. But if
you are using CSS, you can simply change the style sheet, and voila! Your
headlines all turn red automatically. If you ever have to redesign your site
(and believe me, every good site goes through periodic redesigns), you can
save hours or even days of work if you have created your design with CSS.

CSS has many other advantages and a remarkably broad scope. The following
partial list shows some of what you can do with CSS:

v Make global changes anywhere a style is applied simply by changing the
original style.

v Create multiple styles for the same page. For example, you can create
one style for print and another that uses a large text size for anyone who
has trouble reading small print on the Web.

v Create styles for commonly used elements, such as headlines, captions,
and sidebars to create a more consistent design and speed the develop-
ment process.

v Define styles that align and position elements, including images, tables,
and <div> tags.

v Define font sizes in fixed or relative sizes using percentages, pixels,
picas, points, inches, millimeters, ems, and exs (described in the side-
bar, “Understanding CSS size options,” later in this chapter).

v Add and remove borders around images, tables, <div> tags, and more.
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v~ Alter the display of existing HTML tags, such as the unordered list tag,
which you can redefine to appear in a browser as a horizontal or vertical
list with or without bullets. You can also replace standard HTML bullets
with a variety of other bullet styles or an image.

v Change link colors, remove link underlining, and create mouseover
effects using text links.

Understanding the basics of styles

When you create a CSS rule, you essentially define an element, either by
redefining an existing HTML tag or by creating and naming a new style. You
can name a style anything you like as long as you don’t use spaces or special
characters and you follow a few simple rules about how different kinds of
selectors are created.

Once you've created a CSS definition, such as .imagecaption, you can apply
that style to an element in your Web page, such the text under a photo, and a
browser will format the text or other element based on the definition you cre-
ated in the style sheet.

P Many people find CSS confusing at first. If you're starting to feel baffled at this
point, hang in there. Once you read about the basic concepts and start creat-
ing and applying styles yourself, it all starts to make a lot more sense.

Understanding style selectors

You can create a number of different kinds of styles or selectors. Each has dif-
ferent naming restrictions and purposes. These are the most common options:

v Class selectors, which must begin with a period and can be used as
many times as you like on any page.

v ID selectors, which begin with a # (pound sign) and can be used only once
per page. (Dreamweaver groups ID selectors in the Advanced category.)

v Tag selectors, which redefine existing HTML tags and must exactly
match the HTML tag. For example, if you redesign the <h3> tag, you
must name the style H3, not a variation like heading3.

» You can also create contextual styles that are combinations of these
style types and enable you to define rules for a style that appear only
when a style is contained within another style on the same page. (You
find more information about contextual styles in Chapter 6.)
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Understanding style sheet options

You also have the option of creating internal, external, or inline styles. If you
create internal styles, or styles that apply only to the document you are
working on, they are created and stored in the <HEAD> area at the top of the
HTML page.

If you save your styles in an external style sheet, they are stored in a separate
file with a . css extension. External style sheets can be attached to any Web
page in much the same way as you link one Web page to another. You can
attach the same style to many pages, and you can attach multiple style
sheets to the same page.

Inline styles are created within a document at the place that a style is used
and only apply to the element they are attached to in the document.

No matter how you create your styles, each style definition, or rule, contains
a selector and a declaration. The selector identifies the name and type of
style; for example, the selector would be something like H1, or #container, or
.caption. The declaration defines the style and describes its properties, such
as bold or blue.

Looking at the code behind the scenes

If you prefer not to look at HTML and CSS code, you’ll appreciate that if you
work in design view you never have to look at the code. That said, I find it
helpful to have a general understanding of the code behind the scenes to
better understand how and why CSS works the way it does.

The following examples show what the CSS code would look like in
Dreamweaver for a class style called .imagecaption — defined as small, bold,
and italic with the font face Times — and a redefined HTML tag H1 — defined
as large, bold, and formatted with the font face Arial.

.imagecaption {
font-family: "Times New Roman", Times, serif;
font-size: small;
font-style: italic;
font-weight: bold;

font-family: Arial, Helvetica, sans-serif;
font-size: large;



Chapter 5: Cascading Style Sheets ’3 1

Creating page layouts with CSS

CSS is a great alternative to plain old HTML placement and alignment of every element on
when it comes to formatting text. But the for-  the page. In Chapter 7 you find detailed instruc-
matting fun doesn't stop there! Besides helping  tions for creating CSS layouts and using style
you to style text, CSS can be used to create options such as floats and positioning to create
complex layouts with styles that control the flexible, adaptable page designs.

When you apply a style, like the preceding .imagecaption style, to an element
in your Web page, such as the text that appears under a photo, the HTML
code looks something like this:

<p class=".imagecaption">This text is formatted with the
caption style.</p>

In this example, the style .imagecaption was applied to the paragraph tag

(p>) that was already surrounding the text; but this same style could have
been applied to a <div> tag, a <span> tag, or to any other HTML tag that
was already associated with the text.

When you redefine a style, like the <h1> tag, you simply use that existing tag
to apply the style. In this case, formatting the text with the <h1> tag is all
that is needed to apply the defined style to a headline because when a
browser reads the new definition for H1 in the style sheet, it formats any text
surrounded by <h1> tags with those rules. Thus, the code for a headline for-
matted with the <h1> tag would look like this, whether or not you redefined
the <h1> tag with a CSS rule:

<hl1>This headline is formatted with the H1 tag.</hl>

If you happen to know some CSS already, and you're advanced enough to be
able to hand-code CSS or HTML, you’ll be interested in a cool feature named
code hints, which offer autocomplete options for filling in code. Code hints
work only in code view. To use them, simply start typing the code and
Dreamweaver’s code hints will help fill in the details, such as close tags, for
you. You can change code hint options in the preferences dialog box avail-
able from Edit ©Preferences (Dreamweaver=Preferences on a Mac). You can
also display the list of code hints by pressing Ctrl+spacebar (38+spacebar on
the Mac).
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Creating Styles in Dreamweaver
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Figure 5-1:
The New
CSS Rule
dialog box.
|

When you start creating and using Cascading Style Sheets, you use one of the
most complex and advanced Dreamweaver features. Consequently, creating
style sheets takes a little more time to grasp than does applying basic HTML
tags and modifying their attributes. Still, Dreamweaver makes defining style
sheets much easier than writing them by hand.

To help you get the hang of using Dreamweaver to create style sheets, you
find detailed descriptions of all the panels and dialog boxes that define CSS
rules later in this chapter in the “Working with the CSS Panel” section.

Defining a new style

Using styles to format text in Dreamweaver is a relatively simple process.
First you define a style, and then, as you see in the following exercise, you
apply it to an element on the page. This first exercise walks you through the
process of creating a class style that can be applied to text. In this example,
you’ll create a class style called .imagecaption and then, in the next exercise,
you’ll use it to format the text under a photo.

As you go through the steps to create a new style in Dreamweaver, you may
be surprised by the number of options in the many panels and dialog boxes
available for creating CSS. As you explore the possibilities, remember that
you can leave attributes unspecified if you don’t want to use them. For exam-
ple, if you're creating a style for a headline and you don’t specify a font, the
browser uses the default page font.

To define a new style, create a new document or open an existing HTML file,
and follow these steps:

1. Choose Text=>CSS Styles=>New.
The New CSS Rule dialog box appears, as shown in Figure 5-1.

New CSS Rule

Cancel

Selector Type: (*) Class {can apply ko any tag)
() Tag {redefines the lock of a specific tag)
() Advanced (IDs, pseudo-class selectors)

MName; | .caption L'

Define in: () | (Mew Style Sheet Fils) |

(%) This dacument anly

Help
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2. Choose a Selector Type.

For this example, choose Class.

When you create a new style, you must first specify which type of style
you are creating. Select the radio button that corresponds with the type
of style you want to create. You can choose:

¢ Class: Creates a class style that can be applied to any element on a
page and can be used multiple times on the same page. You can
name a class style anything you like, as long as you don’t use
spaces or punctuation. Class style names must begin with a period
(). If you select the class option and neglect to enter a period at
the beginning of the name, Dreamweaver adds one for you. Once
created, class styles are available from the Class drop-down list in
the Property inspector.

Tag: Redefines any existing HTML tag. In this case, you're creating
a new style that will override the existing rules for the selected tag
or add additional formatting to an existing tag rule. When you alter
an existing tag, you change the way all instances of that HTML tag
appear throughout your page, unless you use the Advanced option
to redefine a tag within another style.

Advanced: Creates an ID style, a contextual style, or any other
advanced style option. ID styles must begin with a pound sign (#)
and can be used only once per page. Contextual styles specify
that the display of one style requires the context of the other. (In
Chapter 6, you find instructions for creating contextual styles).

3. In the Name field, select an existing HTML tag from the drop-down list

or type a new name for the style.
For this example, type .imagecaption.

The name you enter depends on which option you select in Step 2. The
drop-down list provides a collection of HTML tags that you can select
and redefine if you want to create a tag style. If you want to redefine an
existing tag and selected the Tag option, you must select a tag from the
drop-down list. If you choose the Class option, you should enter a name
that begins with a period and includes no other spaces or special char-
acters. If you choose the Advanced option and want to create an ID
style, you should enter # at the beginning of the name.

. In the Define In area, select This Document Only to create an internal

style sheet.

An internal style sheet affects only the current page. When you select
this option, the style will be created and added to the top of the HTML
page in the <head> section. If you choose the first radio button, you can
select any existing external style sheet from the drop-down list or create
a new style sheet by selecting the radio button and leaving (New Style
Sheet File) displayed in the field.

133
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|
Figure 5-2:
The Type
category of
the CSS
Rule
Definition
dialog box.
|

5. Click OK.

The CSS Rule Definition dialog box opens,.
6. Choose a Category from the left of the CSS Rule Definition dialog box.

For this example, choose the Type category, as shown in Figure 5-2. (For
a detailed description of each of the categories, refer to the “Comparing
CSS Rule Options” section, later in this chapter.)

CSS Rule definition for .caption

Category Type

| Type
Background
Block

Box

Eorder

Lisk —
Pasitioning Style: | italic v
Extensions

Size: | medium ||

Line height: | |

Font: | Arial, Helvetica, sans-serif

Weight: t:uld.|
ariank;

Case!

Decoration: [ ] underline Color; Q
[Javerline
[ line-through
[ blink.
[Jnone

Help [ O J‘ Cancel Jl Apply I

7. In the Font field, choose a Font List collection from the drop-down list

or enter the name of a font.

For this example, I chose Arial, Helvetica, san serif. To use a font that
isn’t included, choose the Edit Font List option from the drop-down list
and create a new font list using your own fonts.

Dreamweaver includes predesigned font lists that are designed for opti-
mal display on Web pages. The biggest challenge when it comes to using
less common fonts is that a browser can display a font in the text of a
page only if the font is installed on the user’s computer. If a user doesn’t
have the font, the browser searches for the next font in the font list. If
the user doesn’t have any of the fonts specified, the browser’s default
font is used to display the text. By specifying multiple fonts, you have a
better chance that your text appears the way you intend. If you want to
use an unusual font for a logo or other special text, your best option is
to create a graphic or Flash file and insert that file into the page instead
of using formatted text.
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8. In the Size drop-down list, choose the size you want for your caption
style.

For this example, I chose Medium. You can specify text sizes in pixels,
picas, mm, and several other measurements. For an explanation of
options, see the sidebar “Understanding CSS size options,” later in this
chapter.

9. In the Style drop-down list, choose a font style.
In this example, I chose italic.
10. In the Weight drop-down list, chose a weight.
For this example, | chose bold.
11. Click the color well and choose a color for the style.

Sticking to the default color swatches in the color well (the square icon)
is certainly the quickest way to choose a color, but you can also create
custom colors by clicking the icon that looks like a rainbow-colored
globe in the upper-right corner of the color well and selecting a color
from the System Color Picker. For this example, I left the color set to the
default, which is black in most browsers.

12. Click OK.

As you see in Figure 5-3, the new style is added to the CSS panel. If the
style doesn’t appear, click the plus sign (+) (or triangle on the Mac) next
to the <style> tag to reveal the rules in the current style.

When you create a class style, like the .imagecaption style in this example, it
is also added to the class drop-down list in the Property inspector, as you will
see in the following exercise.

i wess s
€55 Styles
Al | current
All I‘%l‘l‘les =

[ <styles
L Jimagecaption

Properties for ".imagecaption"

Fant-Family Arial, Helvetica, sans-serif
Font-size medium

Fonk-style ikalic

Fonk-weight bold

Add Property

= Agd | @¥H Jm
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Applying styles in Dreamweaver

Defining custom styles in Dreamweaver is the time-consuming part. Applying
them after you define them is the timesaving part. How you apply a style
depends on the kind of style you've created. If you've redesigned an existing
tag, you simply format the text or other element with that tag and the new style
is automatically associated with that tag. If you create a class style, such as the
caption style created in the preceding lesson, you can apply it by simply select-
ing the text or other element you want to affect and choosing the style from the
Class field in the Property inspector (as you see in this exercise).

To apply a style in Dreamweaver, follow these steps:

1. Open an existing document or create a new one and add some text or
an image. Highlight the text or other element to which you want to
apply a style.

2. In the Property inspector, click the Style pop-up menu to reveal the list
of styles associated with the document and select the one you want.

Notice that Dreamweaver provides a preview of the style by formatting
the name in the drop-down list based on the specified options in the
style definition. When you choose a style, the selected text or other ele-
ment automatically changes in the Document window to reflect the
application of the style. If Figure 5-4 you see the caption style created in
the previous exercise applied to the text below the image in this page.

e
o @ | © L@ | % E checkpege

40 |Gl T o ‘Asso

L B

|
Figure 5-4:
To apply a
class style,
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text or other
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the main
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<® Another way to apply a style to a highlighted text selection is by choosing the
name of the style from the menu you see when you choose Text=>CSS Styles
or when you right-click (Control+click on the Mac) the selected text and
choose the style from the resulting pop-up menu. The method you choose
depends on your own preferences. I like to use the Property inspector
because it’s the only method that allows you to preview the way the style
appears before applying it.

Removing styles in Dreamweaver

To remove a style from a selected text block or other element, select the ele-
ment and choose the None option in the Style drop-down list in the Property
inspector. You can also remove a style or any HTML tag using the Tag selec-
tor, as shown in Figure 5-5.

E = — = e e e e
le: | Untitied Document M. @ | @ EL @ | % chekPage
|
Figure 5-5:
You can use
the Tag y %
Remove Tag r
SEIECtor at Quick Tag Editar... -', £
the bottom = el Class booNene
|eft Of the Set D » v imagecaption
Dream- ] CE;Haps:E F‘u\;Ta-g. J
Collapge Outside Full Tag =z = cune s ol
weaver [R 679 O [100% v| 783447+ 431K} 6z sec
workspace —— - ;
Link | B =] =
toremove a o
style or tag. [Page ropertes... ] L - ——
| a

Redefining HTML tags

When you create a class style, as you saw in the preceding section, you
create a completely new style with its own unique name and any rules that
you defined in the CSS Rule Definition dialog box.
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In contrast, when you redefine an existing HTML tag, you begin with all the
formatting options associated with that tag — such as the bold settings
already included in a header tag. Any options you specify in the CSS Rule
Definition dialog box are added to the style of the tag or replace the existing
formatting created by the tag if there is a conflict. For example, in the exer-
cise that follows, I redefine the <h1> tag by changing the headline font to
Garamond instead of the browser’s default font, but I don’t need to make bold
part of the style definition because it is already included in the style for an
<h1> tag.

When you redefine an existing HTML tag, you don’t need to apply the style
for the formatting to change. You simply apply the HTML tag, and the style
definition settings are applied at the same time.

You may ask “Why would I redefine the <h1> tag instead of just creating a
new headline style as a class style?” or “What’s the best scenario for using
each of these options?” In the preceding section, you find out how to create
a new style class that you can selectively apply to any block of text on your
page, but there are times when using an existing HTML tag is better. Heading
styles are especially important because they are well recognized on the Web
as an indicator of the most important text on a page.

Many search engines place a higher priority on keywords that appear in an
<h1> tag than on any other text on the page. As a result, you can improve
search engine ranking by placing important text in the <h1> tag. By redefin-
ing the style of an <h1> tag you can get the benefits of the <h1> tag and still
change the formatting of the text to look however you prefer.

To redefine an HTML tag such as the <h1> tag, follow these steps:

1. Choose Text=>CSS Styles=>New to create a new CSS rule.

Alternatively you can right-click (Option-click on a Mac) anywhere in the
CSS panel and choose New or you can click the New CSS Rule icon at the
bottom right of the CSS panel. The icon looks like a small plus (+) sign.

2. In the Selector Type area, select the Tag option.

Notice that when you select the Tag option, the name of the Name text
box at the top changes to Tag.

3. Click the Tag pop-up menu to reveal a comprehensive list of HTML
tags and choose the tag you want from this list (see Figure 5-6).

If you're unsure of the meaning of any of these HTML tags, consult the
Reference panel, available by choosing Windowr>Reference.
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4. In the Define In box, select the This Document Only option to create
an internal style sheet.

If you prefer, you can choose the New Style Sheet File option to create a
new external style sheet as you create the style, or you can use the drop-
down list to select any existing style sheet already attached to the page
and add the new style to it.

5. Click the OK button, and then use the CSS style definition categories
to define the new tag style.

For this example, | redefined the <h1> tag to use the Garamond font
instead of the default browser font and changed the size to Large.

Be aware that when you redefine an existing HTML tag, any text you have
already formatted with that tag changes to reflect the new definition. If you
want to be able to use the same tag with different style definitions, you can
create contextual styles, as described in Chapter 7.

Changing link styles

If you're like many designers, you probably don’t like the underline to appear
under all linked text. You’ll be happy to discover how easy it is to remove
that underline and change the color and other style options for the links in
your Web pages.
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Although you can change link styles by redefining the anchor tag using the
CSS Rule Definition dialog box covered in the previous two exercises, the eas-
iest way to alter link styles for an entire page is to change them in the Page
Properties dialog box. When you use this option, Dreamweaver automatically
creates all the corresponding styles and adds them to the CSS panel.

To change hyperlink styles using the Page Properties dialog box, follow
these steps:
1. Choose Modify->Page Properties.

Alternatively, you can click the Page Properties button in the Property
inspector. The Page Properties dialog box appears.

2. Select the Links category on the left of the Page Properties dialog box,
as shown in Figure 5-7.

Page Properties
Cateqgory Links
Appearance 5 — -
Links Link Font: | Georgia, Times Mew Roman, Times, serif v B I
Headings ) 7
Title/Encading Size: | medium v

Tracing Inage
Link color: )| #000066 | Rollover links: [o) | #FFCC00

visited links: | | #920000 active links: [71] | #FFCCO0
Underline style: |Never underling ¥
Alwvays underline
Mewer underling
Show underline only on rallover
Hicle underline on rollover
|

3. Specify a font face and size or leave these fields blank to use the
default text settings for the page.

If you don’t want to change the font size or face of your linked text, it’s
best to leave these options blank; then if you change the text settings
for the page, you won't risk having specified conflicting settings for
your links.

4. Specify colors for each of the hyperlink states by clicking in the corre-
sponding color well and selecting a color from the color dialog box.

You can change any link color settings. If you do not specify a link color,
the browser will use the default link color. Here’s an explanation of each
of the four link states:
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Link color: The color in which your links appear when the page is
first loaded and the linked page has not yet been visited by the
browser. The corresponding HTML tag is <a: 1ink>.

Visited Links: The color in which your links appear after a browser
has already viewed the linked page. The corresponding HTML tag
is<a:visited>.

Rollover Links: The color a link changes to as a user rolls a cursor
over a link. The corresponding HTML tag is <a :hover>.

Active Links: The color a link changes to as a user is actively click-
ing a link. The corresponding HTML tag is <a:active>.

5. In the Underline Style list, select a style.

Many designers prefer to remove the underline that automatically
appears under linked text by choosing Never Underline, as you see in
Figure 5-7.

6. Click OK.

The Page Properties dialog box closes, the style settings are automati-
cally applied to any links on the page, and the new styles are added to
the CSS panel.

To view link styles and test links, you have to preview your page in a Web
browser. It’s good practice to test link settings in a browser when you make
changes like the ones in the preceding exercise. Take a look at how your

links now appear and how they interact with the user when you trigger the
rollover color and other options. Remember that any styles you create in this
way affect all links on your page unless you specifically apply a different class
style to the individual link that overrides the redefined tag style or you create
a contextual style using the advanced options covered in Chapter 7.

Creating advanced styles

Dreamweaver lumps a number of style types into the advanced selector cate-
gory. If you want to create ID styles, for example, you’ll need to select the
Advanced option in the New CSS Rule dialog box. ID styles and contextual
styles, which often include ID styles, are covered in detail in Chapter 7.

Managing conflicting styles

Be careful when you apply more than one style to the same element (some-
thing that’s easier to do than you may realize). This advice holds true for CSS
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styles as well as style attributes applied via HTML, such as font-styling prop-
erties. The styles may conflict, and because browsers aren’t consistent in
the way in which they display styles, the results can be inconsistent and
undesirable.

For the most part, the latest versions of Firefox and Internet Explorer display
all attributes applied to any element, even if they're from different style rules,
as long as the styles don’t conflict. If they do conflict, browsers prioritize
styles depending on how the styles have been defined and the order in which
they appear. The method for determining this priority is what cascading is

all about.

The term cascading refers to the way in which multiple styles can apply to —
or cascade over — the same element on a page. Because multiple styles can
affect the same element, CSS has many rules to help prevent conflicts. These
rules determine the priority each style should receive as a browser interprets
styles. Style priorities are organized in a hierarchical order and work in a kind
of a top-down fashion, similar to the way water cascades over rocks as it
flows down a stream.

To help you better understand how styles cascade, consider this example.
You can create a style for an entire page by redefining the <body> tag, the
HTML tag that surrounds all the content displayed in the main window of a
browser. So, for example, you could redefine the <body> tag with a rule that
makes the default font for all text on your page Arial. Then you could redefine
the <h1> tag with a rule that makes your headlines Garamond. And then the
browser would have to determine how to display your headline based on this
conflicting information. Should the headline be Arial because the page font is
set to Arial in the body style or should it be Garamond because that’s the
font in the h1 style?

To resolve this kind of conflict, CSS follows a hierarchy that can get rather
complicated, but one of the simplest things to remember is that the closer a
style is to an element, or the more specifically a style defines an element, the
higher that style’s priority. So, as you might imagine, the headline style over-
rides the page style because it more specifically defines the style of the head-
line than the body style, which applies to the entire page.

CSS selectors also follow a hierarchy. Styles created with ID selectors are
given priority over styles created with class, and both are given higher prior-
ity than styles that use the Tag selector to redefine existing HTML tags. When
styles have the same priority, which is highest comes down to which style
most specifically applies to an element.

Another basic guideline is that CSS rules get the highest priority, followed by
HTML presentation attributes (for example, align, color, face, and bgcolor),
followed by the browser default settings (font type and font size, for exam-
ple). CSS rules always get the highest priority in any scenario. But within CSS,
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internal style sheets have priority over external style sheets, and inline styles,
which are styles defined within the line of HTML code where the tag appears,
get the highest priority.

Editing an existing style

You can change the attributes of any style after you have created it by
editing its style definitions. This is where some of the biggest advantages of
Cascading Style Sheets come into play. You can make global changes to a
page or even to an entire Web site by changing a style you applied to multiple
elements through the use of an external style sheet. Be aware, however, that
everything you defined with that style changes when you make your edit,
which also makes it possible to accidentally change the style of elements on
many pages at once.

MBER

You can also create new styles by duplicating an existing style and then alter-

ing it. Then, you can apply that new style without affecting elements that are

already formatted on your pages with the original version of the style.

To edit an existing style, follow these steps:

1. Open the CSS panel by selecting Window=>CSS Styles.
2. Click to select the name of an existing style in the CSS panel.

The corresponding definition settings are displayed in the CSS
Properties panel below it.

3. Click to select any of the settings in the CSS Properties panel and edit
them.

Alternatively, you can double-click the name of any style in the CSS panel
to launch the CSS Rule Definition dialog box and edit the style there.

4. Click OK to close the CSS Rule Definition dialog box and automatically
apply the style changes.

If you edit a style definition in the CSS Properties panel, the changes are
automatically applied as soon as you press the Return or Enter key or
click outside the formatting field in the panel.

Comparing CSS Rule Options

When you choose to make a new style and select one of the three style
options in the New CSS Rule dialog box, the CSS Rule Definition dialog box
opens. You can define a wide variety of attribute options, which in CSS are
referred to as rules. This dialog box includes eight categories, each with
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multiple options you can use to define various rules to apply as part of your
CSS declaration. In this section, you find a general overview of the options in
each of these eight categories.

You don’t have to specify any of the options in any category when you create
a new style. In fact, usually you select only a few properties for each style.
Any options you leave blank retain the browser’s default settings. For exam-
ple, if you don’t specify a text color, the text displays as black or whatever
the default color is in the browser.

Some options in the CSS Rule Definition dialog box aren’t supported by all
current browsers and are included for future compatibility. Some other CSS
properties aren’t displayed in these dialog boxes because they are not com-
monly supported.

The Type category

As you see in the exercises earlier in this chapter, the Type category features
a collection of options that control the display of text in your pages. With the
Type category selected (see Figure 5-8), you have the following formatting
options:

v Font: Specifies a font, font family, or series of families. You can add fonts
to the list by choosing Edit Font List in the drop-down list.

v~ Size: Defines the size of the text. You can choose a specific numeric size
or a relative size. Use the drop-down arrow to select from a list of options
including pixels, picas, and percentages. For more on size options, see the
sidebar “Understanding CSS size options.”

1 Style: Enables you to choose whether the text appears as normal, italic,
or oblique. (Italic and oblique are rarely different in a Web browser, so
stick with italic unless you have a specific reason not to.)

v~ Line Height: Enables you to specify the height of a line on which the text
is placed (graphic designers usually call it leading).

v Decoration: Enables you to specify whether text is underlined, overlined
(the line appears over the text rather than under it), or displayed with a
strikethrough. You can also choose Blink, which makes the text flash on
and off, or None, which removes all decorative effects.

Use the Decoration options sparingly, if at all. Links are automatically
underlined, so if you underline text that isn’t a link, you risk confusing
viewers. Overlined and strikethrough text can be hard to read. Use these
options only if they enhance your design. And by all means, resist the
blink option; it’s distracting and can make the screen difficult to read.
(Overline and blink don’t appear in the Document window; you must
preview your page in a Web browser to see these effects.)
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v Weight: Enables you to control how bold the text appears by using a
specific or relative boldness option.

v Variant: Enables you to select a variation of the font, such as small caps.
Unfortunately, this attribute isn’t supported by most browsers; for exam-
ple, if you specify small caps the text may simply display in all caps.

v Case: Enables you to globally change the case of selected words, making
them all uppercase or lowercase or with initial caps.

1 Color: Defines the color of the text. You can use the color well (the
square icon) to open a Web-safe color palette in which you can select
predefined colors or create custom colors.

CSS Rule definition for h2

Tvpe

Faont: | Georgia, "Times Hew Roman', Times, serif |

Size: | large | % | weight: | bold |

List - 2
Positioning Style: | italic w Mariant: |»
Extensions =

Line height: | s Casg! |

Decoration: [ underline Color: !‘ #O00066
[ overline
[Jline-through
[ blink
[Toone
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After you select the Type options for your style sheet, click OK to save the
settings.

The Background category

The Background category in the CSS Rule Definition dialog box (see Figure
5-9) enables you to specify a background color or image for a style and to
control how the background will be displayed on the page. You can use back-
ground style settings for any block-level element of your Web page. For exam-
ple, you can alter the <body> tag and include background settings that apply
to the entire page, or you can create a class style with background settings
and apply the style to a table cell or a <div> tag. As you see in Chapter 7,
you can also alter background settings for ID tags.

145



146 Part ll: Appreciating Web Design Options

CSS Rule definition for #container
Category EBackground
Type |
giaaccl;umund Backoround calor; | #0099
gsr)'(der Backaround image: "] ’Wl
I g;;itimjing Repeat: | o-repeat] [+
Figure 5-9;: | =" —
The Horizontal position: :ZE::::X
Background “Wertical position: | center :v
category in
the CSS
Rule
Definition
dialog box. Help [oc ][ concel J[ app
I

Understanding CSS size options

One of the more confusing aspects of CSS is
that there are so many ways to specify sizes for
fonts and other elements. A common option is
to use point sizes or pixel sizes. If you're famil-
iar with print, this may be the most familiar
option, but it's not necessarily the best, espe-
cially if you're designing with accessibility in
mind.

A better option is to use relative sizes, such as
the small, medium, and large sizes. The advan-
tage is that the font size adjusts based on your
visitor's settings while maintaining its relative
relationship so that text formatted as large will
display larger than text formatted as small, no
matter what the default font size. This enables
you to maintain the hierarchy of text elements
on a page, which gives your user control over
how large the text is displayed.

Once you've set a font size for the page, you can
use percentages to make text larger or smaller,

relative to the base size, by choosing a per-
centage option. For example, if you set the page
font to medium, you can define the textin a cap-
tion style as 90% and your caption text would
appear at 90% of the default text size for
medium.

Another size option is em, which is named after
the letter M. When you use em as a measure-
ment of size, the size is based on the font size of
the letter M in the font face and size of the dis-
played text. The ex option is similar, but it's
based on the size of a small x. These two sizes
are popular for line spacing because the spac-
ing is adjusted relative to the displayed text size.
This can get confusing, but em and ex work sim-
ilarly to percentages and are even better at
adapting to different user settings.
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You can choose from these options:

v Background Color: Specifies the background color of an element such
as a table. You can use the color well to open a Web-safe color palette in
which you can select predefined colors or create custom colors.

v Background Image: Enables you to select a background image as part of
the style definition. Click the Browse button to select the image.

v Repeat: Determines how and whether the background image tiles across
and down the page. In all cases, the image is cropped if it doesn’t fit
behind the element. The Repeat options are

¢ No Repeat: The background is displayed once at the beginning of
the element.

¢ Repeat: The background image repeats vertically and horizontally
behind the element.

¢ Repeat-x: The background repeats horizontally, but not vertically,
behind the element.

¢ Repeat-y: The background repeats vertically, but not horizontally,
behind the element.

v Attachment: This property determines how the background behaves
when the page is scrolled.

¢ Fixed: The background remains glued to one place in the viewing
area and does not scroll out of sight even when the Web page is
scrolled.

¢ Scroll: The background scrolls along with the Web page. This is the
default behavior for backgrounds.

v Horizontal Position: Allows you to align the image left, center, or right,
or to set a numeric value to determine the horizontal placement of the
background. You can use horizontal positioning only when the back-
ground doesn’t repeat.

v~ Vertical Position: Allows you to align the image top, center, or bottom,
or to set a numeric value to determine the vertical placement of the
background. You can use vertical positioning only when the background
doesn’t repeat.

The Block category

The Block category (see Figure 5-10) defines the spacing and alignment set-
tings for tags and attributes.
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You can choose from these options:

»* Word Spacing: Defines the amount of white space inserted between
words in points, millimeters (mm), centimeters (cm), picas, inches,
pixels, ems, and exs.

1 Letter Spacing: Defines the amount of white space inserted between let-
ters in points, millimeters (mm), centimeters (cm), picas, inches, pixels,
ems, and exs.

v Vertical Alignment: Aligns inline elements such as text and images in
relation to the elements that surround them. Note that you may have
to preview the page in a browser to see these effects. Your options are
baseline, sub, super, top, text-top, middle, bottom, and text-bottom, or
you can set a numeric value.

v~ Text Align: Enables you to left, right, center, or justify your text.

v Text Indent: Specifies how far the first line of text is indented. Negative
numbers are allowed if you want the first line to stick out.

1 Whitespace: Tells the browser how to handle line breaks and spaces
within a block of text. Your options are Normal, Pre (for preformatted),
and Nowrap.

v~ Display: Indicates how to render an element in the browser. You can
hide an element by choosing None.

The Box category

The Box category (see Figure 5-11) defines settings for tags and attributes
that control the placement and appearance of elements on the page. As you
see in Chapter 7, these settings are especially important for creating page lay-
outs using CSS.



|
Figure 5-11:
The Box
category in
the CSS
Rule
Definition
dialog box.
|

Chapter 5: Cascading Style Sheets , 4 9

CSS Rule definition for #sidebar
Category Box
Type
gia;cl;gmund width: | 350 | [pimets || Float: [left v
B E 2
Bgr)'(der Height: || Clear: |
IESt't' y Padding Margin
ositioning
Eetentioie [#] 2ame F_or all [ 5ame F_DI: all .
Top: | 10 | | pixels |w Top: | 10 | plels v
Right: pight: (20 | [pixels [+]
Bottom: Bottom: | 10 o | plxels [
Left: } Left; [l ~ | pixels | s
| e e

You can use the Box category properties to set positioning and spacing
issues for box-level tags such as the table, list, and <div> tags:

v Width, Height: Enables you to specify a width and height that you can
use in styles you apply to images, <div> tags, or any other element that
can have its dimensions specified. You can use pixels, points, inches,
centimeters, millimeters, picas, ems, exs, or percentages for your mea-
surements.

v Float: Enables you to align a boxed element to the left or right so that
other elements, such as text, wrap around it.

v Clear: Prevents floating content from overlapping an area to the left or
right, or to both sides.

v Padding: Sets the amount of space around an element to its edge. You
can set padding separately for the top, right, bottom, and left. Padding is
measured in pixels, points, inches, centimeters, millimeters, picas, ems,
exs, and percentages.

v Margin: Sets the amount of space between the edge of an element and
other elements on the page. You can set the margin separately for the
top, right, bottom, and left. Padding is measured in pixels, points,
inches, centimeters, millimeters, picas, ems, exs, and percentages.

The Border category

The Border category defines settings — such as width, color, and style — for
the borders of box elements on a page. As you see in Figure 5-12, you can
specify border settings on all four sides of an element or create borders only
on one, two, or three sides of an element. Using this technique, you can use
the border settings to create dividing lines and other kinds of borders.
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The List category

The List category defines settings, such as bullet size and type, for list tags.
You can specify whether bullets are disc, circle, square, decimal, lower-
roman, upper-roman, upper-alpha, lower-alpha, or none (see Figure 5-13). If
you want to use a custom bullet, you can use the Browse button to locate an
image to be used as the bullet. You can control the location of the list bullet
in relation to the list item. In Chapter 7, you find instructions for redefining
the unordered list tag to create rollover effects for links, a popular option for
creating navigation rows and other collections, or lists, of links.
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The Positioning category

The Positioning category (see Figure 5-14) enables you to alter the way ele-
ments are positioned on a page. As you see in Chapter 7, positioning can dra-
matically change the way block-level elements appear in a browser. Block-level
elements include table, list, header, paragraph, and <div> tags. For example,
AP Divs in Dreamweaver are simply <div> tags that use absolute positioning
to place elements in a specific part of a page.
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To understand how positioning works, it’s important to know that positioning
is always determined relative to something else, such as another element on
the page or the browser window. How you set up positioning depends on
where your element is on the page and whether the element is inside another
element, such as a <div> tag. Here are the Positioning options:

v Type: Enables you to specify the position of an element, such as a
<div> tag as absolute, relative, fixed, or static:

¢ Absolute: Uses the top and left coordinates to control the position
of an element relative to the upper-left corner of the browser
window or the upper-left corner of an element that contains the
element. (For example, the positioning of an AP Div contained
within another AP Div is based on the position of the first AP Div.)

¢ Fixed: Positions an element relative to the top-left corner of the
browser. The content of an element using fixed positioning will
remain constant even if the user scrolls down or across the page.
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¢ Relative: Uses a position relative to the point where you insert the
element into the page or relative to its container.

e Static: By default, all HTML elements that can be positioned are
static, which simply places the content at its location within the
flow of the document.

v~ Visibility: Enables you to control whether the browser displays the ele-
ment. You can use this feature, combined with a scripting language such
as JavaScript, to dynamically change the display of elements. Visibility is
used to create a number of effects on a page because you can control
when something is seen or not seen. For example, you can cause an ele-
ment to appear on a page only when a user clicks a button and then
make it disappear when the button is clicked again. The options are

e Inherit: The element has the visibility of the element in which it is
contained. This is the default.

e Visible: The element is displayed.
¢ Hidden: The element isn’t displayed.

v Width, Height: Enables you to specify a width and height that you can
use in styles you apply to images, AP Divs, or any other element that
can have its dimensions specified. You can use pixels, points, inches,
centimeters, millimeters, picas, ems, exs, or percentages for your
measurements.

v Z-Index: Controls the position of an element, such as an AP Div, on the
Z coordinate, which is how it stacks in relation to other elements on the
page. Higher-numbered elements overlap lower-numbered elements.

v Overflow: Tells the browser how to display the contents of an element if
the element doesn’t contain the entire contents. (This option does not
currently appear in the Dreamweaver Workspace.)

e Visible: Forces the element to increase in size to display all its con-
tents. The element expands downward and to the right.

¢ Hidden: Cuts off the contents of the element that don't fit. This
option doesn’t provide scroll bars.

¢ Scroll: Adds scroll bars to the element regardless of whether the
contents exceed the element’s size.

e Auto: Makes scroll bars appear only when the element’s contents
exceed its boundaries. (This feature does not currently appear in
the Dreamweaver workspace.)

v Placement: Defines the size and location of an element within its con-
taining element. For example, you can set the right edge of the element
to line up with the right edge of the element that contains it. You can use
pixels, points, inches, centimeters, millimeters, picas, ems, exs, or per-
centages for your measurements.
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v~ Clip: When the content of an element overflows the space allotted and
you set the Overflow property to scroll or auto, you can set the clip set-
tings to specify which part of the element is visible by controlling which
part of the element is cropped if it doesn’t fit in the display area.

The Extensions category

Extensions (see Figure 5-15) include filters and cursor options:

v~ Pagebreak: Inserts a point in a page where a printer sees a page break.
This option allows you to control the way the document is printed.

v Cursor: Defines the type of cursor that appears when a user moves the
cursor over an element.

v~ Filter: Enables you to apply to elements special effects such as drop
shadows and motion blurs. These are visible only in Microsoft Internet

Explorer.
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Using External Style Sheets

The first part of this chapter focuses on using CSS only in the context of inter-
nal style sheets. Internal style sheet information is stored in the HTML code of
the document you're working on and applies to only the current document. If
you want to create styles you can share among documents, you need to use
external style sheets. External style sheets enable you to create styles you can
apply to pages throughout a Web site by storing the style sheet information in
a separate text page that can be linked to from any HTML document.
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External style sheets (also called linked style sheets) are where you can real-
ize the greatest time savings with CSS. You can define styles for common for-
matting options used throughout an entire site, such as headlines, captions,
and even images, which makes applying multiple formatting options to ele-
ments fast and easy. Big news- and magazine-type Web sites often use exter-
nal style sheets because they need to follow a consistent look and feel
throughout the sites, even when many people are working on the same site.
Tying styles to HTML tags via an external style sheet is a foolproof way of
making sure that everyone creating content for your Web site ends up with
pages that look the same. Using external style sheets also makes global
changes easier because when you change the external style sheet, you glob-
ally change every element to which you applied the style throughout the site.

Creating an external style sheet

You create external style sheets almost exactly the same way you create
internal style sheets, except that external style sheets need to be saved as
separate files. When you use Dreamweaver to create an external style sheet,
Dreamweaver automatically links the style sheet to the page you're working
on. You can then link it to any other Web page in which you want to apply the
style definitions.

To create an external style sheet as you create a new style, follow these
steps:
1. Choose Text=>CSS Styles=>New.
The New CSS Rule dialog box appears.

2. Select from the Selector Type category the type of style you want to
create.

The three options — Class, Tag, and Advanced — are described in detail
in the “Understanding style selectors or types” section, earlier in this
chapter.

3. Fill out the Name field or select an option from the Tag or Selector
fields, depending on which selector type you chose in Step 2.

4. In the Define In area, select (New Style Sheet File).

This is how you create an external style sheet instead of an internal
style.

5. Click OK.
The Save Style Sheet File As dialog box opens.
6. Select a location in which to save the style sheet file.

Note that you should save the style sheet in the root folder of your Web
site and upload it to your Web server when you publish the site. (For
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more information on the root folder and how to define a site in
Dreamweaver, see Chapter 2.)

7. Name the file and be sure to use a .css extension to identify your file
as a style sheet.

Dreamweaver automatically adds the . css; just make sure you don’t
delete it.

8. Click Save.
The CSS Rule Definition dialog box opens.

9. Define the new style rule specifying all formatting options you want
applied with the new style.

10. Click OK to save the new style and close the dialog box.

Your new style is saved to your external style sheet and made available
to link to any of the files in your Web site.

Linking to an external style sheet

After you set up an external style sheet, you may want to link it to additional
Web pages. Begin by opening the page to which you want to attach the style
sheet, and then follow these steps:

1. Choose Window=>CSS Styles.
The CSS panel appears.

2. Click the Attach Style Sheet icon in the CSS panel (the first button in
the lower-right area).

The Attach External Style Sheet dialog box appears (shown in Figure 5-16),
prompting you to select the location of the external style sheet.

3. Use the Browse button to locate the CSS file in your site folder.

You can also enter a URL if you want to use a remote CSS file located on
another Web site, but it is most common to use a style sheet contained
within the Web site you are working on. Either way, Dreamweaver auto-
matically sets the link to the style sheet for you, includes the style sheet
link code at the top of the HTML file, and applies the styles to the page.

Attach External Style Sheet
FilefURL: | css/text-styles.css |
Add ast (&) Link :
) Impart
S Cancel
Media: | print| |
You may also enter a comma-separated list of media bypes,
Dreamweaver has sample style sheets to get you started. Help
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4.

Select the Link or Import option.

You can attach a style sheet to an HTML file by linking to it; importing is
intended to allow one style sheet to refer to another.

. In the Media drop-down list, choose an option.

Using the Media list, you can specify the intended use for the style
sheet. For example, if you've created a style sheet that formats your
page for printing, select the print option on this menu. You can leave
this option blank if you are attaching a style sheet to control the way the
page will appear in a browser.

. Click OK.

The dialog box closes, and the external CSS file is automatically linked to
the page. Any styles you have defined in the external style sheet appear

in the CSS panel under the name of the style sheet, and styles are auto-
matically applied to the page (see Figure 5-17).
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You can attach multiple style sheets to the same HTML page. For example,
you can save all your text styles in one style sheet and all your layout styles
in another and attach both to the same document to make all the defined
styles available to the page. Similarly, you create different style sheets for
different purposes, such as one for printing the file and another for browser

display.

Editing an external style sheet

You edit linked external style sheets the same way you edit internal style
sheets: by using the CSS Styles panel, which lists all the styles available to a
document, whether they’re internal or external. You can use the Properties
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Figure 5-18:
You can edit
external
style sheets
(files with

a .css
extension)
by opening
them as
you would
any other
document.
|

pane, which is located in the bottom portion of the CSS Styles panel, to edit
the rules for each style, or you can double-click the name of any style in the
CSS Styles panel to launch the CSS Rule Definition dialog box and edit the
style there.

Any changes you make to a style in an external style sheet are automatically
applied to all files to which the external style sheet is attached (as long as the
style sheet exists in the same relative location as the file on the computer or
Web server).

If you want to edit a remote CSS file, you should download the file to your
hard drive before you open it in Dreamweaver. In Dreamweaver, you open

. css files by double-clicking them or choosing Filec>Open, both of which
open the style sheet in code view. Code view is the only view available for
CSS files because they’re text files and have no layout components. When you
view an external style sheet this way, you can still use the CSS panel to edit
any defined styles, even if the style sheet isn’t linked to an HTML page. Be
sure to save it when you finish editing it!

If you prefer, you can also edit the code by hand directly in code view. Figure
5-18 shows an example of a style sheet opened directly in Dreamweaver.
Notice that the CSS Styles panel displays all relevant style information and
gives you access to the CSS editing tools.
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Figure 5-19:
You can
access and
preview
sample style
sheets by
creating a
new CSS
document.
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When you edit an external style sheet, you must upload it to your server
before the style changes can be applied to pages on your live Web site.

Applying ready-made external style sheets

Adobe includes a bunch of sample style sheets for you to use to create new
pages in your Web site. These come in the form of external styles sheets
that have been created with some popular styles to help you get better
acquainted with style sheets and give you a jump-start in designing with
them. You can use these styles as is or modify them to suit your needs.

To access the sample style sheets provided by Adobe, follow these steps:

1. Choose Filec>New.

The New Document dialog box opens, as shown in Figure 5-19.
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2. In the Sample Folder list, select CSS Style Sheet to display the list of

CSS files, and then click to select any of the sample styles listed under
Sample Page.

Notice that a preview of how the style appears is displayed on the right
when you click any of the sample styles.

. Select a style you like and click Create.
A new, untitled style sheet opens in code view.

. To save the style sheet, choose File~>Save (or Save As) and save it in
the site directory where you plan to use it.
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If you want to customize your style sheet, you can also modify the rules before
saving the file. When you do save a sample file, Dreamweaver saves a copy so
that it doesn’t overwrite the original sample file.

Appreciating the CSS Styles panel

The CSS Styles panel provides a great place to store, manage, organize, and
edit CSS rules. To open the CSS styles panel, choose Window =>CSS Styles or
click the small arrow next to CSS at the top of the panel.

You can also use the CSS Styles panel, shown in Figure 5-20, to organize styles
once style sheets are attached. For example, you can move styles from one
style sheet to another by clicking to select the name of a style and dragging it
over the name of the external style sheet you want to move it to in the CSS
Styles panel. You can also use click and drag to change the order of styles
within a style sheet and to move styles from an internal style sheet to an
external style sheet.

v?‘“\NG! You can also rename styles in the CSS Styles panel, but be aware that renam-
ing a style does not change its corresponding reference in the HTML code of
your Web pages. If you change a name in the CSS Styles panel, you must also
change the corresponding name in the HTML code of the page or reapply the
style with the new name. For example, if you create a style called .imagecap-
tion and apply it to text in your Web page, and then later rename the style to
.bigimagecaption in the CSS Styles panel, you need to reapply the style with
its new name.

On the left side of the panel, you see the Show Category View, Show List View,
and Show Only Set Properties icons (see Figure 5-20). These apply to the
Properties panel in both Current and All modes. Here’s how to use these:

+ Show Category View: In the category view of the Properties view,
Dreamweaver displays all the properties available to use for a rule orga-
nized by the category to which they belong. For example, all the font
properties are grouped into a Font category.

v~ Show List View: In the list view, Dreamweaver displays all the properties
available to use for a rule organized alphabetically.

v Show Only Set Properties: When you define a new rule, you set certain
properties; but, of course, you can set many more. In this view,
Dreamweaver displays only those properties you defined for this rule.

The second set of icons, on the bottom-right of the CSS Styles panel (see
Figure 5-20) are useful no matter what mode the panel is in. From left to right,
these icons represent Attach Style Sheet, New CSS Rule, Edit Style, and Delete
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Figure 5-20:
The CSS
Styles
panel,
showing all
the styles
associated
with the
open
document.
|
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CSS Property. The easiest way to start a new style sheet is to create a new
style and the style sheet at the same time. To do that, click the New CSS Rule
icon (labeled in Figure 5-20).
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The All mode of the CSS Styles panel

The CSS Styles panel has two modes, accessible by clicking the tabs at the
top of the panel. The first tab displays All mode, which opens a list of all
defined rules in a document or an attached style sheet or both, whether the
styles are internal or contained in an external style sheet. When you are in All
mode, you can select a style in the CSS Styles panel and its properties are dis-
played in the Properties pane in the bottom part of the CSS Styles panel.
When a style is selected in All mode, you can add, edit, and delete existing
style rules in the Properties pane. (see Figure 5-20).

If you don’t see your styles listed in the CSS Styles panel when the All tab is
selected, it’s probably because you haven’t opened the style sheet to see them.
To view any defined styles in a style sheet, you need to click the plus sign (the
triangle on the Mac) to open the style sheet. You'll find the arrow (or triangle)
next to the <style> tag if you are using an internal style sheet or next to the
style sheet name if you're using an external style sheet attached to the page. (If
the CSS Styles panel is blank when you select the All tab at the top, it means no
styles are associated with the page.)
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Using CSS with templates

Templates, covered in Chapter 9, are a perfect
complementto CSS because they enable you to
recreate page designs easily and update them
automatically when things change. You can use
internal or external styles with templates and
make automatic updates to any pages created
from the template by changing the template

design, the styles, or both. Although it may take
a little longer to create a page using CSS and
templates in the first place, the time you can
save by creating new pages from the template
and making updates across many pages at
once more than makes up for the initial
investment.

101

The Current mode of the CSS Styles panel

When you select the Current tab at the top of the CSS Styles panel, you can
view the styles currently applied to any selected element on a page as you see
in Figure 5-21. Current mode is useful for identifying how styles are applied to
a particular element and for troubleshooting when styles conflict.
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The Current mode has three sections: the Summary for Selection pane, the
About pane, and Properties pane. In the Summary for Selection pane, you see
the rules currently defined for the selected style. In the Rules pane, you see
all the rules that are applied the currently selected element; this pane is
exceptionally useful when you have created a complicated layout and are
trying to understand how different styles may be affecting the same element.
In the Properties pane, you can edit, add, or delete style rules just as you can
in All mode.
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Using Design Time Style Sheets
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After you become savvy about using style sheets, you’ll find that working with
external style sheets affords the most power because you can link to them
from multiple pages in your site rather than having to create a new internal
style sheet for each page in your site. You have the added advantage that you
can easily alter your styles in just one place if you need to make changes after
styles are applied. Even better, you can create multiple external style sheets
as part of the design process and use a Dreamweaver feature called design
time style sheets to switch between them as you work on your document.

One benefit of the design time style sheets feature is that you can view how
different external style sheets affect your page without having to link to them.
This feature is a great way to quickly switch between style sheets in a docu-
ment and explore various what-if scenarios with the style sheets you create
before you apply them. You may begin to like this feature because you can
play around with and explore the full power of CSS.

After you decide that you like a particular style sheet, you can apply it to
your page as you do any other style sheet. (See the section, “Applying Styles
in Dreamweaver,” earlier in this chapter, for information on applying a style.)

Design time style sheets affect only the appearance of styles in Dreamweaver.
Because they're not real links, they show up only at runtime when a
Dreamweaver document is open. Design time style sheet info is also stored in
a design note file. If you want to preserve your design time style sheet info,
be sure that you don’t delete the corresponding design note file.

To set up design time style sheets, follow these steps:

1. Choose Text=>CSS Styles=>Design-Time.
The Design Time Style Sheets dialog box appears.

2. To work with a specific style sheet, click the Add Item button (+)
above the Show Only at Design Time field.

The Select File dialog box appears, and you can select a CSS file.
Remember that CSS files usually end with a . css extension. You can
also add multiple CSS files by clicking the Add button again.

3. To hide a specific style sheet, click the Add Item button (+) above the
Hide at Design Time field and select from the Select File dialog box
the style you want to hide.

4. To delete a listed style sheet from either category, select the style
sheet and click the Remove Item button () to delete it.
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Creating CSS Layouts

In This Chapter
Creating page layouts with CSS

Understanding the box model
Comparing browser differences
Creating CSS layouts with <div> tags
Using Dreamweaver’s AP Divs

Learning more about CSS

If you want to create Web designs that can adapt to display well in a variety
of browsers, screen sizes, and devices, and you want to ensure that your
pages are accessible to everyone who may visit your site now and for years
to come, CSS is your best option. In Chapter 5, you find an introduction to
CSS and instructions for creating CSS styles for text formatting. In this chap-
ter, you move on to more advanced uses of CSS by creating styles to position
and align images, text, and other elements on a Web page.

Brace yourself. You're getting into some of the most complex Web design fea-
tures Dreamweaver has to offer, but I think you’ll find the power and preci-
sion of these options well worth the effort. Today, you can create Web page
designs in many ways, but using CSS for formatting and layouts is clearly
emerging as the best approach as browser support improves and accessibil-
ity becomes increasingly important.

Using CSS for Page Layout

The key to understanding the way CSS works when it comes to page layout is
to think in terms of designing with a series of infinitely adjustable containers,
referred to as the box model. Think of the box model this way: First you use
HTML tags, such as the <div> tag or <p> (paragraph) tag to contain your
content in a box. Then you use CSS to style each box, using attributes to con-
trol the position and alignment of each box, and specify such settings as mar-
gins, padding, and borders.
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Comparing block and inline elements

As a general rule, HTML tags can be divided
into block elements and inline elements. Block
elements, such as the <div> tag, interrupt the
flow of the page, creating a box or block around
which other page elements align. In HTML,
block elements include the paragraph (<pP>)
tag, which creates a line break before and after
it is used and doesn't allow anything to appear

alongside it. Heading tags, such as <hl>,
<h2>, and <h3>, and list tags, such as <ul>
and <o1>, are also block elements. In contrast,
inline elements flow with text. For example, the
<strong> and <em> tags are inline elements.
You can place these elements one after another,
and a new line break doesn’t appear between
each element. They simply flow with the text.

Although you can use any HTML element for page layout, the <div> tag is
used most often to create page layouts with CSS. <div> stands for division.
Think of the <div> tag as simply a container to hold other content or to
make a division on the page, separating one section of content from another.
Unlike other HTML tags, the <div> tag has no inherent formatting features.
Unless CSS is applied to a <div> tag, it can seem invisible on a page. And yet
it has a powerful purpose because any content surrounded by an opening
and closing <div> tag becomes an object (or a box) that can be formatted
with CSS. When you create a style that corresponds to a <div> tag ID, you
can specify properties such as alignment, border, margin, height, and width
to control how the <div> tag is displayed on the page. In the exercises that
follow, you find step-by-step instructions for using <div> tags to contain con-
tent and CSS to create a layout.

Creating designs using the box model

Although you can create CSS layouts using many approaches, one of the most
popular and effective is to create a series of block elements, such as <div>
tags, assign each element an ID, and then create an ID style to control how
the block element, or container, appears on the page.

In Figure 6-1, you see a diagram of a series of block elements with text
describing the ID of the <div> tag and its corresponding style, which must
use the same name. ID style names always begin with a # sign and must
match the corresponding ID assigned to an element in the HTML code.

In Figure 6-2, you see how those same containers are arranged using CSS to
control the width and positioning of the container <div> tag so that it’s cen-
tered on the page and to position the story and sidebar <div> tags side by
side. The CSS definitions are also used to specify the font and positioning of
text within each <div> tag.
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Figure 6-3:
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page as
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style sheet
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When you create a CSS layout like this, you begin by simply creating <div>
tags that span the full width of the page and stack one on top of another. With
the boxes in place, you can start adding content, such as text and images,
into each box. With the content and boxes in place, you can then create the
styles that position each of the boxes to create the design you want for the
page. (Alternatively, you can create the CSS styles to position the boxes and
then add content, but I find it easier to decide how to define the styles after |
see the content in place.)

In the exercise that follows, you create a series of <div> tags with IDs and
then insert text and images, as you see in Figure 6-3. In the second part of the
exercise, you create ID styles that correspond to the IDs assigned to each
<div> tag to create the page layout you see in Figure 6-4.

Viewing a page with no styles in Firefox

When you view an HTML page in the Web browser Firefox, you can use the
No Style option to remove a style sheet and see the underlying structure of
the Web page. This is a helpful way to understand how styles affect HTML
documents and to test your own designs to ensure they are well organized.
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In Figure 6-3 you see the same page shown in Figure 6-4 but with the style
sheet turned off. To turn off a style sheet using Firefox, choose Viewr>Page
Styler>No Style. To reapply a style sheet to the page, choose Viewr>Page
Stylec>Basic Page Style. (Note that some Web pages are designed with multi-
ple style sheets so you can choose among different styles using this feature.)

Creating semantic page designs

The page shown in Figures 6-3 and 6-4 was designed semantically, so that
even if the styles are not visible or turned off, the content of the page is dis-
played in order of importance and with formatting that makes logical sense.

For example, with or without the style sheet turned on, the banner is the first
thing at the top of the page. Below the banner is a list of links formatted using
the <ul>, or unordered list, tag. The unordered list tag is an increasingly
common convention for formatting lists of links because without CSS it is still
clear that the list of links should be grouped together on the page. Using CSS,
you can alter the display of the unordered list and link tags to cause links
with this kind of formatting to be displayed in a different style, such as the
horizontal display you see at the top in Figure 6-4. You find instructions for
changing the display of an unordered list in the section, “Styling an
Unordered List for Links,” later in this chapter.
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Figure 6-5:
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and margins
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the outside.
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Comparing margins and padding

One of the more confusing aspects of the box model when it comes to design

is the way margins and padding work. Essentially, padding adds space inside

an element, and margins add space outside an element. In Figure 6-5, you see

a <div> tag with a corresponding ID style that creates the border and places

25 pixels of padding inside the <div> tag border and 50 pixels of spacing out-
side the <div> tag border.

Think of padding as a way to add a cushion around the inside of a box so that
your content doesn’t bump into the sides of your box. Think of margins as a
way to add space between boxes so that they don’t bump into each other.

Here’s the confusing part. If you specify a width for a <div> tag (or any other
box element), as | have in the example in Figure 6-5, the width is affected by
the padding. The ID style controlling the display of the <div> tag shown in
Figure 6-5 is 350 pixels wide. But when you add padding to a container, the
browser adds the padding to the overall width of the container, so the <div>
tag is 400 pixels wide with the padding.
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The margins of the <div> tag style are set to 50 pixels, so the <div> tag is
positioned 50 pixels from the top and left of the page and with 50 pixels of
margin on the right and bottom. This prevents the display of any other ele-

ment in that space.

The ID style for the <div> tag also includes border settings, which cause the
dark border to surround the <div> tag. The thin border adds 2 pixels to the
outline of the <div> tag and means the final width of the <div> tag is 404
pixels the 350 pixel width, plus 50 pixels of padding, plus 4 pixels of border.
As you see in the exercise that follows, understanding how styles affect the
width of elements is especially important when you want to place two con-
tainers side by side, such as the story and sidebar <div> tags used in the

page design shown in Figure 6-4.

CSS options at a glance

As you create CSS page layouts, you'll be best
served by using a combination of CSS selectors
including class, tag, and ID selectors. Consider
this sidebar a quick reference and handy
reminder of how each of these selectors may be
used in a Web page. (You find more detailed
descriptions of these selectors in Chapter 5.)

Class selectors can be used to create com-
pletely new styles. Once you've created a class
style, it can be applied to any element and used
as many times as you like on the same Web
page. For example, you could create a class
style called .image-right and use itto align
images to the right of other content by applying
the style to the image tag like this:

<img src="deer.jpg" width="200"
height="250" alt="Fallow deer"
class="image-right" />

Tag selectors are used to redefine existing
HTML tags. Once you create a style for an
HTML tag, anytime that tag is used, the

attributes in the style are applied. For example,
you can redefine the <ul> and <11i> tags to
change the display of content formatted in an
unordered List. You find instructions for doing
just that in the section “Styling an Unordered
List for Links,” later in this chapter.

ID selectors are included in the category of
Advanced selector options in Dreamweaver.
You can use ID selectors to define elements that
are used only once in a Web page. For example,
if you create a copyright section at the bottom of
a page, you might use an HTML <div> tag as
the container for the copyright information and
give the <div> tag an ID that corresponds to an
ID style that controls the position and formatting
of the copyright information. You can use the ID
attribute with any tag, but it's commonly used
with the <div> tag for positioning and format-
ting. A <div> tag with an ID style would look
like this:

<div id="copyright">Copyright 2007</div>
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Figure 6-6:
Remove the
automatic
margins at
the top and
left of any
Web page
by setting
the margin
fields to 0.
|

Note that the margins of the page are set to 0 with a style that controls the
<body> tag. Setting page margins to 0 means that any content on the page is
aligned to the very top and left of the page instead of being offset by 10 pixels
of space, which is the default in most Web browsers and in the Dreamweaver
workspace area. You can set the page margins using the Page Properties
dialog box by choosing Modify~>Page Properties, and then entering 0 in each
of the Margin fields in the Appearance category, as shown in Figure 6-6.

Page Properties

Cateqgary

Appearance i
Links Page fort: | Default Font ~lm

Headings g
TitlefEncoding ize | ~

Tracing Image
Text color: Q

Background color: g

Appearance

Background image:

Browse, ..

Repeat: | e

Left margin: | 0 |pizels v Right: margin: | 0 pixels v_'

gixels i v

......... %

Apply ]

Top margin: | 0 pixels | % Battom margin: | 0

o (o

Displaying CSS in different browsers

Neither Dreamweaver nor I can show you exactly how your Web pages will
look to everyone who may ever view them on the Web because different
browsers display Web pages differently, especially older browser versions that
do not include standards-compliant support for CSS and many other features.

If you want a consistent appearance on every browser that might ever visit
your pages, you have to move on to more advanced CSS training when you're
finished with this book and explore the “hacks” that have been developed to
get around browser differences. You'll find many books, Web sites, and train-
ing videos dedicated to advanced CSS training.

For a list of more advanced CSS training resources online and off, visit
www.DigitalFamily.com/dreamweaver.

For the purposes of this book, [ have designed pages that are consistent in
their display on IE 6 and later, Firefox 1.5 and later, and Safari and Firefox on
the Mac. I can’t cover all the CSS hacks needed to design CSS layouts for
every browser in use on the Web today, but the browsers that [ targeted with
these designs represent the majority of Web browsers. I leave it to you to
decide whether to worry about visitors with older browsers and whether to
explore more advanced CSS training when you’re finished here.
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Splitting

If you're creating a series of <div> tags to
position content on a Web page, you may find it
easier to keep track of the <div> tags if you
use Dreamweaver’s split view, which enables
you to see the code view and design view simul-
taneously. To split the workspace area, choose
Viewr>Code and Design or click the Show Code
and Design Views button, located just under the
Insert bar at the top of the workspace.

As you see in the figure, if you select an image,
text, or another element on a page in design

the view

view, it is automatically highlighted in code
view, a great feature that makes it easier to find
your place in the code when you are trying to
troubleshoot what's happening behind the
scenes.

| like to use split view to keep an eye on the
code as | create page designs, especially when
I'm inserting <div> tags, because it can be
hard to keep track of how <div> tags are
arranged and nested when you're using only
design view.

| Fallow-desr, him — — e A e - ﬂsﬁl
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The following exercise walks you through the creation of a two-column CSS

layout that displays well in all th

e latest browsers in use on the Web today.

Creating a CSS Layout

There are many approaches to c

fluid layouts that expand and contract to fill the browser window no matter

reating layouts using CSS. You can create
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how wide or narrow, and you can create fixed layouts that remain a specified
width no matter how wide the browser window. When you create fixed-width
designs, such as the one in this exercise, it’s good practice to center the
design on the Web page so that it appears to float in the middle of the page
no matter what the size of the browser window.

The following exercise walks you through the creation of the design shown in
Figure 6-4 using a series of <div> tags created within a <div> tag called con-
tainer. The corresponding container style defines the container with a fixed
width of 780 pixels. As you see in Step 6, the trick to centering a <div> tag
with a style is to set the left and right margins to Auto, which makes the
browser display an equal margin on each side of the container and effectively
center the <div> tag. This is an important trick because <div> tags and
other block-level elements have no center option.

Follow these steps to create a fixed-width, two-column layout with a header
and footer area using CSS and <div> tags:

1. Choose File=>New and then choose Blank Page from the left column,
HTML from the Page Type options in the middle, and <none> from the
Layout section.

Alternatively, you can use one of the predesigned CSS layouts listed
under the Layout section.

2. Save the page in the root folder of the Web site.

It’s important to save all the pages of a Web site in the root folder. You
find more about defining a Web site and specifying a root folder in
Dreamweaver in Chapter 2.

3. Choose Modify=>Page Properties and specify the page-wide options.

For this example, I set the page margins to 0 and the Background color
to a green color.

Note that when you use the Page Properties dialog box, Dreamweaver
creates the corresponding CSS styles for the <body> tag and saves them
in an internal style sheet at the top of the HTML document.

4. Insert <div> tags for each section of content.

This step can get a bit tricky, but the goal is simple — to insert a <div>
tag for each collection of content that you want to appear on the page.
To do so, click the Div button in the Common Insert bar at the top of the
page and enter a name in the ID field for each <div> tag. When you click
OK, the <div> tag is inserted onto the page and spans across the top of
the workspace. The trick is to make sure that you create each <div> in
order and that all section <div>s are placed inside the container <div>.
[ find it easier to ensure this if | have the design area set to Split so that I
can see the code while I work, as you see in Figure 6-7.
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In this example, I created one <div> tag with the ID container and then
placed a series of other <div> tags inside that container. First [ inserted
a <div> tag and with ID top (for the banner graphic), and then I inserted
a <div> tag with the ID navbar for the navigation links. After that, I
inserted two more <div> tags, one with the ID story and the other with
the ID sidebar, and finally [ added a <div> tag with the ID footer.

Depending on the complexity of your design, you may want to further
divide a page like this one by creating two main sections of the design,
such as top and main. You then insert <div>s for the banner graphic
and navigation elements inside the top <div> and the <div>s for the
story and sidebar inside the main <div>. The more you divide a page’s
content, the better you can control the placement of elements as the
design gets more complex.

5. Add content to each <div> tag.

Although you can create the corresponding styles as you create the
<div>s, I find it easier to get all my <div>s and content in place before
I create the styles to position them. You can add content to <div>s as
you would add content anywhere else on a page. For this example, |
used copy and paste to insert text from a separate Word document and
the Insert Image icon in the Common insert bar to add the images.

T —
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|
Figure 6-8:
Use the Box
settings to
define the
width,
margins,
and other
settings.
|

6. Create a style for the container <div> tag.

To create a new style for the container <div>:

a. Choose Text=>CSS Styles=>New.

b. Select the Advanced option and enter a name (note, your style
names must exactly match your <div> names).

Remember that when you create an ID style, the name must begin
with a pound sign (#).

c. Specify whether the style should apply to This Document Only or
be added to an external style sheet.

For this exercise, | chose This Document Only.

d. Click OK.

e. In the CSS Rule Definition dialog box, specify the formatting

settings.

As you see in Figure 6-8, for the container <div> tag in this exam-

ple, I set the width to 780 pixels. And here’s the trick to centering a
<div> tag like this: Set the left and right margins to auto. That way
a browser will automatically add an equal amount of margin space
to each side of the <div> tag, effectively centering it on the page.

[ also set the background to white to create a white box for the
content.

When you create an ID style that matches the name of an ID
assigned to a <div><div> tag, the style is immediately applied
when you click the Apply button. (Make sure the ID and the style
name are an exact match. If you add an extra space or mistype a
character, this won’t work.)

. Click OK to close the CSS Rule Definition dialog box and save the

style.
CSS Rule definition for #container
Cateqgary Baox
Type
B d i — %
Eizikl?mun Width: | 780 | |pixels |%|  Float: »
Box :
Barder Height: w Clear: v
;'St.t. . Padding [Marain
osIEIoning
Extensions Same f_or all |:| Same f_or all
Top: » Top: w
Right: Right: | auto w
Battom: Bottom; | w
Left: | Left: | auto  |we
Help {04 Cancel Apply ‘
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7. Calculate the width and positioning of the two columns in the design.

To ensure that your layout will work with two columns, you need to cal-
culate how wide to define the styles for your story and sidebar <div>s.
As you see in Figure 6-9, if the style #container is set to 780 pixels wide,
and we want the #story style to make its corresponding <div> tag 410
pixels with 10 pixels of padding. That means a total width of 430 (10+10
=20 pixels in padding, plus 410). For the sidebar, which is further compli-
cated by the border and margins to separate it from the sides of the con-
tainer and the story, I set the width to 310 pixels, added 20 pixels of
margin (10 on each side), then 16 pixels of padding (8 on each side), and
finally 4 pixels of border (2 on each side) for a total width of 350 pixels.
Because 350 and 430 equal 780, both <div>s fit within the container
with room to appear side by side. (Yes, you can use a calculator).

If you don’t specify a width for a <div> in a multicolumn design, the
<div> automatically adjusts to fill the remaining space. Using this
approach can save you math calculations and help with browser differ-
ences. For example, I could have set the width in the #story style to 410
pixels and not specified a width in the #sidebar style, and the page
design would look the same in most browsers and be more adaptable to
browser differences. Because browsers can display margin and padding
settings differently, a column set with a fixed width within another
column with a fixed width can overflow the boundaries of the container,
causing one column to get bumped below the other. This is a simple
example of one way you can design CSS to work more consistently
across many browsers.

<divid="top"> (C55ID style: #top I
<divid="navbar"> (55 ID style: #navbar
—
Figure 6-9: <div id="story"> <div id="sidebar">
Ehalcu!::ﬁ _S CSS ID Style: #story S5 10: #sidebar %
e wi ; ) . !
= Width =410 pixels Width = 310 pixels B
youcanuse | B . - Y ; ; €
for each E Padding = 10 pixels left and right Padding = B pixels | ‘
<div> tag _ Total width = 420 pixels {on all sides) '
by adding g Margin = 10 pixels I 5
the total o [=— (onall sides)
width Surrounding outline represents Border = thin (2 pixels)
including <div id="container> Total Width = 350 pixels
mda(;_gln, CSS ID style: #container
padding, 4 ;
Width = 780 pixels
and border i
settings. <div id="footer"> CSS ID: #footer ,
—
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Figure 6-10:
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and the
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of the page.
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8. Create styles for the story and sidebar <div> tags.

With the calculations complete, you should be ready to define the styles
for the two columns by creating ID styles for the story and sidebar. In
addition to setting the width, padding, margins, and borders to the
values in Step 7, I also used the Float option to align the <div>s to the
left and right sides of the page as follows:

a. Choose Text=>CSS Styles=>New.

b. Select the Advanced option and enter a name.

In this case, I've named the first style #sidebar to match the name
of the ID in the sidebar <div>.

. Select the This Document Only option and then click OK.
d. Select the Box category and specify the formatting settings.

As you see in Figure 6-10, for the sidebar <div> in this example, I
set the width to 310 pixels, the margins to 10, the padding to 8, and
the Float to Right. In Figure 6-11 you can see that I also used the
Border category to set the border to solid, thin, and a dark red
color.

. Create a second style for the story <div> by repeating Steps 8a

through 8d.

Name the style #story and define the style with no border, a width
of 410, padding 10, and Float set to left.

CSS Rule definition for #sidebar
Cateqgary Baox
Type
gianikfmund width: | 310 || pixels [+ Float: | Fighk |
Box % left:
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Figure 6-11:
Using the
Border
category,
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border that
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surrounds
an element
or appears
only on the
left or right.
|
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9.

Create a style for the footer using the Clear option to keep the footer
positioned at the bottom of the page layout.

If you are creating a two-column design like the one in this example, and
you use the Float option to align the columns to the left and right, you
run the risk that the footer <div> at the bottom of the design will be dis-
played beside one of the columns instead of below them. The reasons
for this get complicated, but it has to do with how box elements change
when you use the Float setting and take them out of the flow of the page.
Because column heights can vary due to text size differences in different
browsers and computer platforms, it’s almost impossible to create two
columns of text on a Web page that will always be displayed with the
same height. As a result, it’s good practice to use the Clear option to
ensure that the footer remains at the bottom of the design no matter
what. Using the Clear option also ensures that the container will sur-
round all the content on the page when it is displayed in a browser.
Follow these steps to create a style for the footer <div>:

a. Choose Text=>CSS Styles=>New.
b. Select the Advanced option and enter a name.

I named the first style #footer to match the name of the ID in the
footer <div>.

c. Select the This Document Only option.
d. Click OK.

d. Select the Box category and specify the formatting settings you
see in Figure 6-12.

177
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|
Figure 6-12:
Use the
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|

Padding is set to 10 to create space around the text that will be
added to the footer, and the Clear field is set to Both to force the
footer to clear both columns above it to ensure that the footer
appears at the very bottom of the page. I also set a background
color for the footer to match the color of the navbar style.

CSS Rule definition for #footer
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10. Add a few more styles for the images and other elements in the
design.

To achieve the final design you see in Figure 6-4, I created styles to align
the images to the right and left so the text would wrap around them, and
I created a series of styles for the unordered list and link tags to create a
navigation bar with a simple rollover effect using CSS. (You find instruc-
tions for creating these kinds of styles in the “Styling an Unordered List
for Links” section later in this chapter.)

Creating Styles to Align Images

If you've ever been frustrated by the limitations of V space and H space
(that’s vertical and horizontal space for those unfamiliar with HTML), you're
going to love what CSS can do for your images. In the days when H space and
V space were the only options, you could add margins around images, but
you had to add the same amount of space to both sides, which almost never
looked good.

As you'll see in this exercise, using CSS to create styles for your images
enables you to add margin space only where you want it. I routinely create
two image styles for every site | work on, one that aligns an image to the right
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with a little margin space on the left and bottom, and another that aligns
images to the left with a little margin space on the right and bottom. This
enables me to position images with a margin that keeps them from bumping
into text and other elements on the page, while still keeping their alignment
flush with the side of the page or column.

To create images styles that use floats and margins, follow these steps:

1. Open an existing page or create one.

2. Insert images into your page using Dreamweaver’s standard insert
image features.

You can choose Insert=>Image and then select the image you want to
insert, or click the image icon in the Common Insert bar at the top of the
screen to choose the image you want to insert.

3. Create a new style to align images to the right by choosing Text~>CSS
Styles=>New.

The New CSS Rule dialog box opens.
4. Select the Class option.

Class styles are ideal for image styles like the one I'm creating in this
example because they can be used as many times as you want on each
page and can be applied to images as well as other elements.

5. In the Name field, enter a name for your style.

I called the style .image-right. Note that all class styles must begin with a
period. If you don’t type one yourself, Dreamweaver will add a period to
the beginning of the style name when you create a class style.

6. Specify whether the style should apply only to this document or
should be added to an external style sheet:

¢ To apply the style to only this document, select the This Document
Only option and then click OK.

¢ To add the style to an existing external style sheet, select Define In,
select the style sheet from the drop-down list, and then click OK.

¢ To add the style to a new external style sheet as you create a new
style, select Define In and then click OK. Then in the Save Style
Sheet File dialog box, enter a name for the external style sheet and
click Save.

The CSS Rule Definition dialog box opens.

\P
) One of the advantages of saving an image style like this in an external

style sheet is that you can attach the same external style sheet to any
page in your Web site and use the same style throughout your site.
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Figure 6-13:
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7.

10.
11.

Select the Box category.

The Box category options are displayed.

. Click the drop-down arrow next to Float and select Right, as shown in

Figure 6-13.

This is what will cause an image to float to the right when the new CSS
style is applied to an image.

. Deselect the Same for All option below Margin and set only the Left

and Bottom Margins.

When I align an image to the right, | generally like to include 8 to 10
pixels of margin on the left to create a space between the image and the
text that will wrap around the image when it is aligned right. [ also like to
include 8 to 10 pixels of margin on the bottom. You should enter a
margin value that works best for your design.

Click OK to save the new style.
Create a style to align images to the left.

Repeat Steps 3 through 10, naming the style .image-left. In the Box cate-
gory, set the Float to left and enter a value for only the right and bottom
margins.

To apply an image style to an image on a Web page, click to select the image
and then select the image style in the Class field in the Property inspector, as
shown in Figure 6-14.

When you apply a class style to an image, the effects of the style are dis-
played in the workspace. As you see in the example shown in Figure 6-14,
applying the image-right style to the selected image caused the image to align
to the right side of the page, made the text to wrap up beside it on the left,
and created an 8-pixel margin between the image and the text.

CSS Rule Definition for .image-right in multimedia.css
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<P If you want to add a border to your images, you can define the border as part

of the same styles you use to align images left and right. In the example
shown in Figure 6-14, the .image-right style includes a border set to solid,
thin, and black.

Styling an Unordered List for Links

Here’s a great CSS trick for turning a bulleted list into a navigation bar with a
simple rollover effect. Using a bulleted list for navigation bars is a well-
accepted convention for Web sites that meet current accessibility standards.
A bulleted list is a logical choice for navigation elements because even if the
style is removed, the links still stand out from the rest of the elements on the
page and are clearly grouped together.

Thanks to CSS, you can gain the benefits of styling a list of links with the
unordered list tag and still format your links with any style you choose so
that you don’t have to keep those boring bullets and can align your links hori-
zontally or vertically. Using CSS instead of images to create a rollover effect
helps your page load faster, too.
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Creating contextual styles

When you redefine tags, such as the unordered
list and link tags, the new style applies to all
uses of that tag within a page unless you rede-
fine the tags as contextual styles by including
the name of their container as part of the style
name.

For example, in the exercise in the “Styling an
Unordered List for Links” section, instead of
creating a new tag style with just the name of
the <ul> tag, | could have created a new tag

style called #navbar ulto redefine the <ul> tag
only when it is contained within a <div> tag
with an ID of navbar (see the figure).

When you create advanced styles like this, you
use the name of the container followed by the
tag name separated by a single space. In this
example, | could have also created styles for the
<1i> and <link> tags inthe same way, cre-
ating styles with names like #navbar li, #navbar
a:link, and #navbar a:hover.

New CSS Rule

Seleckar Type: () Class (can apply ko any kag)

Cancel

() Tag (redefines the lnok of & specific tag)
(%) advanced (IDs, pseudo-class selectars)

Selector: | #navhar ul PV

Define in: (3 |text.css |v

) This document only

Help

To create a navigation bar using CSS to redefine the unordered list and link
tags, follow these steps:

1. Place your cursor in the HTML page where you want your navigation
bar to appear and then click the Div button in the Common Insert bar
at the top of the page to insert a <div> tag.

2. In the Insert Div dialog box, enter a name in the ID field.

You can name the ID for the <div> tag anything you like as long as you
don’t use spaces or special characters. In this example, | named the
<div> tag navbar. (Note: ID styles are recommended for positioning
<div> tag like this one for a navigation bar).

3. Specify whether the style should apply only to this document or
should be added to an external style sheet:

¢ To apply the style to only this document, select the This Document
Only option and then click OK.

¢ To add the style to an existing external style sheet, select Define In,
select the style sheet from the drop-down list, and then click OK.
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10.

¢ To add the style to a new external style sheet as you create a new
style, select Define In and then click OK. Then in the Save Style
Sheet File dialog box, enter a name for the external style sheet and
click Save.

The CSS Rule Definition dialog box opens.

. Select the Box category and specify a height for the navigation bar

<div> tag.

I set the height to 20 pixels. You can also define a width. In this example,
the width is already controlled by the style for the container <div> tag,
so [ left the width blank for the navbar <div> tag.

. Select the Background category and choose a background color for

the navbar <div> tag.

If you don’t specify a color, the color of the navbar <div> tag will be
determined by the color of any <div> tag that contains it or by the
specified page color. In this example, I've selected a golden color to set
the navbar apart from the rest of the design.

. Select the Type category and specify the text options.

I set the font face to Geneva, the size to Small, and the text to a dark
brown color.

. Click OK.

The <div> tag with the ID set to navbar automatically changes to reflect
the settings in the corresponding #navbar ID style.

. Insert the text for each of the links into the navbar <div> area.

Make sure to separate each line of text with a Return (so that the text is
formatted with a <p> tag in the code).

. To format the text as an unordered list, click and drag to select all the

text in the navbar <div> and then click the Unordered List icon in the
Property inspector.

If you have not redefined the unordered list tag already, the text will
change to the default settings of an unordered list, removing the space
between each line and adding bullets.

Set links from each text section just as you would link any other text
block or image.

You find detailed instructions for setting links in Chapter 2, but the sim-
plest way is to first select the text and then click the Link icon in the
Common Insert bar at the top of the screen. In the Hyperlink dialog box,
enter the URL you want the text to link to or use the small folder icon to
the right of the link field to locate the file you want to link to.
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11. Create a new style to redefine the unordered list tag by following
these steps:

a.
b.

C.

Choose Text>CSS Styles>New.
Under Selector Type, choose Tag.

In the Tag field, enter ul or click the arrow and select ul from
the drop-down list of HTML tags, as shown in Figure 6-15. Then
click OK.

New CSS Rule

Selectar Type! () Class (can apply to any kag)

Tag: |ul »

Define in: (3) |text.css [

Cancel

(%) Tag (redefines the look of & specific kag)
(7 advanced (10s, pseudo-class selectors)

Help

() This document onily

d.

In the CSS Rule Definition dialog box, choose the Box category
and set Margins and Padding to 0 with the Same for All box
checked for both to remove the margins and padding included
in the UL HTML tag.

12. Create a new style to redefine the list item tag by following these
steps:

a.
b.

C.

Choose Text>CSS Styles=>New.
Under Selector Type, choose Tag.

In the Tag field, enter li or select li in the drop-down list of HTML
tags. Then click OK.

. In the CSS Rule Definition dialog box, select the Block category

and set Display to inline (see Figure 6-16).

This changes the style of the li tag from vertical to horizontal.

. Select the List category and set Type to none to remove the bullet.

. Select the Box category and set Margins left and right to 10 pixels.

This separates the list items from one another in the horizontal
list. You can change the setting to any measurement to create the
amount of space between links that best fits your design.
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Figure 6-16:
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13. Create a new style to redefine the link tag by following these steps:

a.
b.

C.

Choose Text>CSS Styles>New.
Under Selector Type, choose Tag.

In the Tag field, enter a:link or select a:link in the drop-down list
of HTML tags. Then click OK.

. In the CSS Rule Definition dialog box, select the Type category

and set Decoration to none by clicking the text box.

(This removes the underline from linked text.)

. Still in the Type category, change the text color to the color you

want your links to appear when they are first loaded on a page.

I set the text color to a dark brown.

14. Create a new style to redefine the hover link tag so that the link color
will change when a user rolls a cursor over the link:

a. Choose Text=>CSS Styles=>New.

b.

C.

Under Selector Type, choose Tag.

In the Tag field, enter a:hover or select a:link in the drop-down
list of HTML tags. Then click OK.

d. In the CSS Rule Definition dialog box, select the Type category

and set Decoration to none by clicking the text box.
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e. Still in the Type category, change the text color to the color you
want your links to appear when users roll their cursors over the
link.

I set the text color to a bright red color.

15. Create a new style to redefine the visited link tag so that the link color
will change after a user clicks a link:

a. Choose Text>CSS Styles>New.
b. Under Selector Type, choose Tag.

c. In the Tag field, enter a:visited or select a:link in the drop-down
list of HTML tags. Then click OK.

d. In the CSS Rule Definition dialog box, choose the Type category
and set Decoration to none by clicking the text box.

e. Still in the Type category, change the text color to the color you
want your links to appear when users roll their cursors over the
link.

I set the text color to a light gray color.

16. Preview the page in a browser to see the effect of the link styles.

Working with AP Divs

AP Divs, which were called layers in Dreamweaver 8, permit precise position-
ing of elements on an HTML page. Think of an AP Div as a container for other
elements, such as images, text, tables, and even other layers. You can put this
container anywhere on an HTML page and even stack these containers on top
of each other.

Using AP Divs, you can position text blocks and images exactly where you
want them on a page by specifying the distance of the AP Div from the top
and left sides of a page or from another <div> tag. Using AP Divs you can
also layer, or stack, elements on top of each other. With AP Divs, a positioning
option called the Z index adds this capability, which enables you to create
separate layers with text, images, and other elements.

Because an AP Div is a container, you can manipulate everything in it as a
unit. For example, you can move one AP Div so that it overlaps another. You
can even make AP Divs invisible and use JavaScript or another scripting lan-
guage to change visibility dynamically. Dreamweaver’s Show Hide behavior
can be used to create this level of interactivity. (Dreamweaver’s behaviors are
covered in Chapter 11.)
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Creating AP Divs

To create an AP Div, follow these steps:

1. Choose Insert=>Layout Objects=>AP Div.

A box representing an empty AP Div appears at the top of the page out-
lined in blue. Alternatively, you can click the Draw AP Div button in the
Layout Insert bar and then click and drag to create a new AP Div any-
where in the work area (see Figure 6-17).

2. Click anywhere along the outline of the AP Div to select it.

When you hold the mouse over the outline of the AP Div, the cursor
turns to a four-pointed arrow (or a hand on the Macintosh). You also see
eight tiny, square handles around the perimeter of the box.

3. Click and drag any of the handles to resize the AP Div.

Figure 6-17:
Create an
AP Div
anywhere
on the page
by clicking
the Draw
AP Div
button in the
Insert
Layout bar
and then
clicking and
dragging in
the main
work area.
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Adding elements, resizing,
and repositioning layers

To make an AP Div useful, you have to put something inside it. You can place
pretty much anything within an AP Div that you can place in a document. To
add images or text to an AP Div, follow these steps:

1.

Click to insert your cursor inside the AP Div.

A blinking cursor appears inside the AP Div box.

. Choose Insert=>Image.

The Select Image Source dialog box appears.

. Click the filename of the image you want to insert, and then click OK.

The Image Tag Accessibility Attributes dialog box opens.

. Fill in the Alternate text and Long description fields, and then click OK.

The image appears inside the AP Div.

. Select the image and use the Property inspector to make any format-

ting changes to it.

Formatting images inside AP Divs works the same as it does anywhere
else on an HTML page. For example, you can use the Align Center icon to
center the image within the AP Div.

. Click inside the AP Div again to insert your cursor and enter some

text (see Figure 6-18).

. Click the tab that appears in the upper-left area of the AP Div or any-

where along the border to select the AP Div.

You know that you have successfully selected an AP Div when you see
the selection handles, the little black squares that appear at the corners
and in the middle of each side.

. Click any handle and drag to resize the AP Div.

As a general rule, always size an AP Div so that its contents just fit within
its boundaries. Positioning the AP on the page is then easier.

Rather than dragging to resize, you can type exact measurements in the
width (W) and height (H) fields in the Property inspector (as shown in
Figure 16-19). The Property inspector displays these options only when
the AP Div is selected.
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AP Divs can be problematic when you’re working with text because text
size can change in Web pages when displayed on different computer
platforms, and users can change the text size in their browsers. If you've
created AP Divs that are sized to fit only around the text in the size it
appears on your computer, the layout can change dramatically when the
page is displayed on another computer. For example, if the text size is
larger, the text can get cut off or overlap other elements on the page.
The best way to avoid this problem is to leave the height unspecified so
that the AP Div can adjust to fit the content and to make sure nothing is
positioned under the AP Div in the layout that is likely to get hidden if
the text overlaps the AP Div.
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9. To move an AP Div, click and drag the little tab (which appears in the
upper-left area of the AP Div when it’s selected).

Because AP Divs use exact (or absolute) positioning, you can move them
to any precise location on a page, and they will always appear in that
exact position in relation to the left and top of a browser window.

The Property inspector displays the AP Div coordinates in relation to
the left and top of a browser window when the AP Div is selected: L (for
left), T (for top). As you see in Figure 6-19, the AP Div in this example is
exactly 200 pixels from the left side of the browser window and 75 pixels
from the top. In addition to using the click-and-drag method to move a
layer, you can change a layer’s position by entering a number in the
position boxes: L (number of pixels from the left edge of the page) and T
(number of pixels from the top of the page).

10. Name your AP Div by typing a name in the AP Div ID text box in the
upper-left corner of the Property inspector.

When you create a new AP Div, Dreamweaver automatically names your
AP Div for you, starting with apDiv1, apDiv2, and so on. I find it easier to
keep track of AP Divs when I change the name to something more
descriptive, especially if 'm working with lots of AP Divs on a page.

You must select the AP Div in the main work area first for its properties to
appear in the Property inspector, where you can rename the AP Div and
change the height, width, left, top, and other settings.

Stacking and changing visibility
of AP Divs

A powerful feature of AP Divs is their maneuverability: You can stack them on
top of each other and make them visible or invisible. To stack AP Divs, simply
drag one AP Div on top of another. Unlike other elements in a Web page, AP
Divs give you complete layout control by including the capability to overlap
one another. And you can use AP Divs to position and layer any element on a
page. For example, to overlap images, simply place each image in a separate
AP Div and then move one AP Divs so that it overlaps the other. To let you
control which AP Div is on top, Dreamweaver provides two ways of changing
the stacking order using the Z index. You can change the Z index from the
Property inspector or the AP Elements panel (see Figure 6-20). To open the
AP Elements panel shown in Figure 6-20, choose Window=>AP Elements.
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Figure 16-20:
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To change the stacking order and visibility of AP Divs, follow these steps:

1. Open a page that has two or more layers on it, such as the deer.html
page shown in Figure 16-21.
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2. Select an AP Div by clicking anywhere on the border outline of the
AP Div.

3. Choose Window=>AP Elements to open the AP Elements panel.

The AP Elements panel lists any AP Divs that have been inserted into a
Web page.

If you're familiar with layers in Adobe Photoshop or Macromedia
Fireworks, you may find some similarities here, such as the eye icon to
control visibility and the capability to drag AP Divs around in the panel
to change their order.

4. Reorder the stacking of the AP Divs by changing their corresponding
Z Index numbers in the Property inspector or in the AP Elements
panel.

The lowest number is the bottommost layer. The highest number is the
topmost layer. To change the stacking order, simply click to select the
number under the Z index field and enter a higher or lower number.

5. Click the eye icon to the left of any AP Div in the AP Elements panel
to turn the layer visibility on or off.

If no eye appears, the visibility is set to the default, which usually means
on, except in the case of nested AP Divs. (You find out about nested AP
Divs in the next section.) If the eye is open, the AP Div is visible on the
screen and in the browser. If the eye is closed, the layer is invisible.

If you want to prevent any of your AP Divs from overlapping, select the
Prevent Overlaps check box in the AP Elements panel.

Nesting AP Divs: One happy family

Another way to position AP Divs on a page is by nesting them. A nested AP Div
is essentially an AP Div contained within another AP Div in a kind of parent-
child relationship. The child AP Div uses the upper-left corner of the parent AP
Div, rather than the upper-left corner of the browser window, as its orientation
point for positioning. Even if the AP Divs are on different areas of the page, they
still retain this parent-child relationship. When you move the parent AP Div
around on the page, the nested AP Div moves along with it. You can also think
of this scenario as an owner walking his or her dog on a leash — where the
owner goes, the dog has to follow, even though the dog can still move indepen-
dently of its owner within the confines of the length of the leash.

If you were to nest an AP Div inside another that is already nested inside a
third AP Div, the newly nested AP Div would be both a parent and a child.
The new AP Div would then use the upper-left corner of its parent as its ori-
entation point. The first AP Div in the nested chain still retains control over
all the child AP Divs, so they all move when the parent moves.



Chapter 6: Creating CSS Layouts ’ 93

|
Figure 6-22:
You can
manage
nesting
options in
the AP
Elements
panel.
|

Nested AP Divs offer a great way to keep chunks of your layout working
together as you move them around the page. Rather than trying to keep track
of loads of different AP Divs and moving each one individually, you can group
them into more easily manageable family units. Furthermore, you can make
an entire family visible or invisible by clicking the eye icon of the parent AP
Div in the AP Elements panel. If the child AP Div’s visibility has been set to
the default (no eye icon in the AP Elements panel), it inherits the visibility of
its parent layer.

To create a nested AP Div, follow these steps:

1. Choose Insert->Layout Objects=>AP Div or click the AP Div icon in the
Layout Insert bar and click and drag to create the AP Div anywhere
on the page.

A box representing the AP Div appears at the top of the page, and
Dreamweaver automatically gives it a name such as apDivl.

2. Place the cursor inside the first AP Div, and choose Insert->Layout
Objects~>AP Div to create a second AP Div inside the first.

3. Position the second AP Div anywhere on the page by dragging the
small tab in the upper-left corner of the AP Div box or by clicking and
dragging anywhere on the AP Div’s border.

Visually, nested AP Divs don’t need to reside inside their parent AP Divs;
they can be placed anywhere on the page or stacked on top of each
other.

4. Choose Window=>AP Elements to open the AP Elements panel.

In the AP Elements panel, you can see how AP Divs are nested because
the name of the nested AP Div is shown underneath and slightly
indented from its parent, as you see in Figure 6-22.

You can nest an existing AP Div inside another by holding down the
Control key (Option key on the Mac), clicking to select an AP Div, and
dragging it over the name of another existing AP Div in the AP Elements

panel.
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Setting AP Div options

Like other HTML elements, AP Divs have many attributes you can set.
Dreamweaver makes these options available in the Property inspector when-
ever you select an AP Div.

This list describes the AP Div options and what they control:

v~ AP Div ID: You can type your own descriptive name in this drop-down
list in the upper-left corner of the Property inspector. If you don’t name
an AP Div, Dreamweaver names it for you. When you name AP Divs, don’t
use special characters, such as spaces, hyphens, slashes, or periods.

v L (Left): This value specifies the distance of the AP Div from the left side
of the page or parent AP Divs. Dreamweaver automatically enters a pixel
value when you create or move an AP Div using drag and drop. You can
also enter a numeric value in pixels or percents (positive or negative) to
control the positioning.

v T (Top): This value specifies the distance of an AP Div from the top of
the page or parent layer. Dreamweaver automatically enters a pixel value
when you create or move an AP Div using drag and drop. You can also
enter a numeric value in pixels or percentages (positive or negative) to
control the positioning.

v W (Width): Dreamweaver automatically specifies the width when you
create an AP Div on a page. You can also enter a numeric value to spec-
ify the width. You can change the px (pixels) default measurement to
any of the following: pc (picas), pt (points), in (inches), mm (millime-
ters), cm (centimeters), or % (percentage of the page or parent layer’s
width). Don’t put any spaces between the number and the measurement
abbreviation.

1 H (Height): Dreamweaver automatically specifies the height when you
create an AP Div on a page. You can also enter a numeric value to specify
the height. You can change the default measurement of px (pixels) to any
of the following: pc (picas), pt (points), in (inches), mm (millimeters), cm
(centimeters), or % (percentage of the page or parent’s height). Don’t put
any spaces between the number and the measurement abbreviation.

v Z-Index: This option determines the position of an AP Div in relation to
other AP Divs when they are stacked. Higher-numbered AP Divs appear on
top of lower-numbered AP Divs, and values can be positive or negative.

v Vis: This visibility setting controls whether an AP Div is visible or invisi-
ble. You can modify this setting with a scripting language, such as
JavaScript, to dynamically change the display of AP Divs.
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You can choose from these visibility options:

e Default: The default option in most browsers is the same visibility
property as the parent’s value. If there is no parent AP Div, the
default state is visible.

¢ Inherit: This option always uses the visibility property of the AP
Div’s parent.

e Visible: This option always displays the AP Div, regardless of the
parent’s value.

¢ Hidden: This option always makes the AP Div invisible, regardless
of the parent’s value. Even when it’s hidden, all the content in an
AP Div downloads when the page is viewed in the browser, but is
not displayed. You can dynamically control visibility by using the
JavaScript behaviors covered in Chapter 10.

v Bg Image: With this option, you can select a background image for the
AP Div in the same way you would select a background image for a Web
page. Click the folder icon to select an image or enter the name and path
in the text box.

v Bg Color: Use this option to set a background color for an AP Div.
Clicking the color square opens the color palette. If you want the back-
ground to be transparent, leave Bg Color blank.

v Overflow: These options determine how the contents of an AP Div dis-
play if they exceed the size of the AP Div.

You can choose from these Overflow options:

e Visible: If the AP Div has too much content, this option lets the
content spill out over the edges of the AP Div — though this effect
may not perform as expected in certain browsers. Making sure that
content won’t escape the confines of an AP Div is usually the best.
Be sure to preview the results in the browser to make sure you get
the effect you want.

¢ Hidden: Clips off the edges of content that doesn’t fit within the
specified size of an AP Div. Be careful with this option; it doesn’t
provide scroll bars.

¢ Scroll: Adds scroll bars to the sides of an AP Div regardless of
whether its content exceeds the AP Div’s size.

¢ Auto: Displays scroll bars only if the AP Div’s content doesn’t fit
within the AP Div’s boundaries.

v~ Clip: This option controls which sections of the content of an AP Div are
cropped if the AP Div isn’t large enough to display all its content. You
should specify the distance from the L (Left), T (Top), R (Right), and B
(Bottom). You have to specify clips in pixels or choose the Auto value.
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Using Dreamweaver’s CSS Layouts

|
Figure 6-23:
You can
create a
CSS layout
from any

of the
predesigned
options
included in
the New
Document
window.
|

In addition to all the tools, panels, and dialog boxes you can use to create
your own CSS layouts and styles in Dreamweaver, you'll find many pre-
designed CSS layouts and styles included in the program.

To create a new page using one of Dreamweaver’s CSS layouts, choose
File>New, choose Blank Page on the left, choose HTML from the Page Type
options, and then choose any of the CSS layouts listed under Layout on the
right. In Figure 6-23, I'm selecting a predesigned CSS layout that creates a two-
column page layout with a header and a footer using a fixed width.

HEpe Dot T H
Page Type: Layout:
U o = HML <nanes i~

w i o == HTHL template 1 column elastic, centered |
= Library itsm 1 column elastic, centered, header and |

_w Blank Template = ¥5LT (Entire page) 1 column fixed, centered
= welT (Fragment) 1 column fixed, centered, header and |

i = actionSeript 1 column liquid, centered

Ew Page fiom Template | 2 55 1 colurin liquid, centered, header and F &8
E— e 2 column elastic, left sidebar

— =y 2 column elastic, left sidebar, header a

,___ﬁ] Page from Sample To mML

2 column elastic, right sidebar

2 colurin elastic, right sidebar, header
ASP Javascripk

ASF YBScript

2 column fixed, |eft sidebar
2 colurn fixed, left sidebar, header an

,‘ Other

Two columns, all widths in pizels, with right
sidebar, headst and Footer,

-

=

= ASPNETC#

= ASPNET VB

= ColdFusion

. ColdFusion component 2 column hybrid, left sidebar, header a DocType; KHTML 1.0 Transitional :p

"_ J5p 2 column hybrid, right sidebar Lavitt €55; [add ta Head ;‘
- PHP 2 colurin hiybrid, right sidebar, header —

- 2 column liquid, left sidebar Btkach ©55 fils: -

2 colurmn liguid, left sidebar, header an
2 column liguid, right sidebar |int|
%] ?

| Help | | Ereferences... Get more conbent, Create Cancel

Once you've created a page with a CSS layout, you can change the layout by
changing the various styles included with the page. For example, to change
the width of the sidebar in the CSS layout shown in Figure 6-24, you would
first select the style for the sidebar in the CSS panel and then use the CSS
Properties below the CSS panel to edit the style. Alternatively, you could
double-click the style name in the CSS panel and open the CSS Definition
dialog box to make any changes there.
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Figure 6-24:
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To use any of the collections of CSS styles included in Dreamweaver, choose
File>New. In the New Document window, choose the Page from Sample option
on the left, choose CSS Style Sample from the Sample Folder, and then choose
from any of the Sample Pages listed on the right. When you click the name of a
Sample Page, a preview of the CSS styles is displayed on the far right.

Want to discover more about CSS? You'll find many advanced CSS resources
on the Web. Visit www.DigitalFamily.com/dreamweaver for a list of
great places online to find more tips, tricks, hacks, and other reassurances
as you work to master CSS.
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Chapter 7

Coming to the HTML Table

In This Chapter
Introducing HTML tables
Going beyond spreadsheets

Customizing table structure

Creating complex designs

In the early days of Web design, HTML tables offered one of the only
options for creating complex page layouts. By splitting and merging table
cells and using them as containers for text and images, Web developers were
able to create intricate page designs despite the limits of HTML. Most of us
were frustrated by this solution.

Using tables to create designs was far from ideal, and we often had to resort
to special tricks, such as using a clear GIF to control spacing (see the sidebar
on the clear Gif trick later in this chapter). But at least with tables you could
position text, images, and other elements, anywhere you wanted on a page.
For example, you could use a table to align two columns of text side by side
with a headline across the top like the format you might see in a newspaper
or magazine. And because you could make the borders of a table invisible,
you could use tables to create these kinds of designs without the table itself
being visible on the page.

Today CSS is quickly changing the way Web pages are created. Although
tables are still an ideal way to present tabular data on the Internet (for exam-
ple, just about any content you could display in a spreadsheet can be format-
ted easily and effectively with a table), they are no longer the recommended
solution for creating page layouts like those you’d find in a magazine or news-
paper. Instead, a growing number of designers are using CSS to create page
designs because these pages download faster, are easier to update, and are
more flexible and accessible than tables ever were. Chapters 5 and 6 are dedi-
cated to CSS and the latest developments in Web design.
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Choosing between tables and CSS

More and more pages on the Web are designed
with CSS, and you can expect to see that trend
continue. As Internet users upgrade their
browsers and newer browsers support CSS
better and better, the advantages of CSS are
quickly outweighing the limitations. CSS offers
much better design control than tables, especially

in Dreamweaver, where you can simply click
and drag to place them wherever you wanton a
page. You can put any elementin a layer, includ-
ing images, text, and multimedia files. You can
even stack layers on top of each other, and you
get down-to-the-pixel design control, which is
far better than what you get with tables.

This chapter is designed to help you appreciate how to create and edit tables
in Dreamweaver. Even though tables are no longer recommended for most Web
page layouts, you still find them used on many Web sites; so I've included
instructions for working with tables for page layouts, as well as formatting
and sorting tabular data with tables in Dreamweaver.

I also show you how to create HTML tables for everything from columnar
data to complex page designs. Tables are a bit complicated to create and not
as precise as you might like them to be, but Dreamweaver has a number of
tools that make creating tables easier.

Creating HTML Tables

Tables are made up of three basic elements: rows, columns, and cells. If you've
ever worked with a spreadsheet program, you're probably familiar with tables.
Tables in HTML differ from spreadsheet tables mainly in that they’re used for
more complex alignment of data, which requires lots of merging and splitting
of cells. Back in the days when you had to design Web pages in raw HTML
code by hand, even simple tables were difficult to create. The code behind an
HTML table is a complex series of <tr> and <td> tags that indicate table
rows and table data cells. Figuring out how to type those tags so that they
created a series of little boxes on a Web page was never an intuitive process.
If you wanted to merge or split cells to create rows or columns with varying
numbers of cells, you faced a truly complex challenge.

Thank the cybergods that you have Dreamweaver to make this process easy.
Using Dreamweaver, you can easily create tables and modify both the appear-
ance and the structure of a table by simply clicking and dragging its edges. You
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Figure 7-1:
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weaver
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content
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can add any type of content to a cell, such as images, text, and multimedia
files — even nested tables. Using the Property inspector, you can merge and
split cells, add color to the background or borders, and change the vertical
and horizontal alignment of elements within a cell.

You can create tables in Standard or Expanded mode in Dreamweaver.
Expanded mode, shown in Figure 7-1, makes it easier to select inside and
around tables by adding space around table borders. However, the display of
a table changes in Expanded mode — it literally expands table cells. The
added space makes it easier to edit content within tables, but it also changes
the display. Because Standard mode (shown in Figure 7-2) is more consistent
with how tables will appear in a browser, you should generally do most of
your table editing, especially resizing and moving tables, in Standard mode.
You can switch between these two modes by clicking the Standard and
Expanded mode buttons in the Layout menu bar at the top of the work area
shown in Figures 7-1 and 7-2.
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Although Expanded mode is useful for selecting and editing the contents of a
table, Standard mode is best for creating tables. You can insert a table by
choosing Insert=>Table or by clicking on the Table icon in the Common or
Layout Insert bar.

When you insert a new table, the Table dialog box, shown in Figure 7-3, makes
it easy to specify many table settings at once. Don’t worry about getting them
all perfect, you can always change these options later (a list of common Table
settings and their descriptions is included later in this section).

Don’t skip the Accessibility options at the bottom of the Table dialog box.
They are important for anyone who uses a browser that “reads” Web pages,
such as those used by people with limited vision. If you enter a table caption,
it will be displayed within the table. (You can specify with the Align Caption
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option where the caption will appear.) The Table Summary does not appear
on the page and is used only to describe the table for visitors who can not
see the table contents and layout.

Table

Table size

Rows: |3 Colurnnst | 3

Table width: |S00 | | pixels v
I
Border thickness: |0 | pixels

Figure 7-3:
When you
inserta
table into a
Web page,
you can
specify
many table
settings in
this dialog
box.
|

el padding: | O
Cell spacing; | 0

Accessibility

Caption: | Room Rates
align caption: |defadle ||

Summary: | This table provides a list of room rates and
charges

You can edit all the table options, except the Accessibility options, in the
Property inspector. When you select a table or cell, the attributes appear in
the Property inspector at the bottom of the work area. Click the border of
any table to select the entire table, and the Property inspector displays the
table options shown in Figure 7-4. To view all the options, click the expander
arrow in the lower-right corner of the Property inspector. (Cell properties are
described in the next section.)

How wide should you make a table?

Designers often wonder how wide to make a
table when they are using tables to control page
layout. My advice is that if you are designing
your pages for an 800 x 600 screen resolution
(still a popular resolution among Internet users),
a safe bet is to make your table no more than

780 pixels wide and center it in the middle of the
page. That leaves a little room on each side to
prevent the appearance of sideways scrollbars
and causes the table to “float” in the middle of
the page if users have a larger monitor.
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If you're having trouble selecting the table (sometimes selecting the entire
table and not just an individual cell is tricky), simply place your cursor any-
where inside the table and choose Modify=>Table=>Select Table.

The Property inspector gives you access to the following table options for
customizing the appearance of your table:

v~ Table Id: Provides a text area where you can enter a name or table.

v Rows: Displays the number of rows in the table. You can alter the size of
the table by changing the number. Be careful, though: If you enter a smaller
number, Dreamweaver deletes the bottom rows — contents and all.

v Cols: Displays the number of columns in the table. You can alter the size
of the table by changing the number. Again, if you enter a smaller number,
Dreamweaver deletes the columns on the right side of the table —
contents and all.

v W (Width): Displays the width of the table. You can alter the width by
changing the number. You can specify the width as a percentage or a
value in pixels. Values expressed as a percentage increase or decrease
the table’s size relative to the size of the user’s browser window or any
enclosing container, such as another table or a <div> tag.

v H (Height): Displays the height of the table. You can alter the height by
changing the number. You can specify the height as a percentage or a
value in pixels. Values expressed as percentages increase or decrease
the table’s size relative to the size of the user’s browser window. This
table attribute is no longer supported in XHTML 1.0. Although many
browsers still recognize this setting, it may not be supported in future
browser versions, and it is generally recommended that you leave the
height setting unspecified so that the table adjusts to automatically fit
the contents.

Table dimensions expressed as a percentage enable you to create a table
that changes in size as the browser window is resized. For example, if
you want a table to always take up 75 percent of the browser window, no
matter how big the user’s monitor or display area, set the size as a per-
centage. If you want a table to always be the same size — that is, to
remain the same size regardless of the browser window size — choose
pixels rather than percentages for your table dimensions.
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If a table is inserted inside another container, such as a <div> tag or a
table with a fixed width, it will not change size based on the browser
window but will be sized based on the container.

v CellPad: Specifies the space between the contents of a cell and its
border.

v~ CellSpace: Specifies the space between table cells.

1~ Align: Controls the alignment of the table. Options are Default, Left,
Right, and Center. As a general rule, the Default setting aligns the table
from the left side of the browser window or other container.

v Border: Controls the size of the border around the table. The larger the
number, the thicker the border. If you want the border to be invisible,
set it to 0.

v Class: Provides easy access to style sheet options. (See Chapters 5 and 6
for more on CSS.)

v Clear and Convert: The icons in the lower-left area of the Property
inspector (click the expander arrow in the lower-right corner to view
them) provide these formatting options:

¢ Clear Row Heights and Clear Column Widths enable you to
remove all height and width values at one time.

¢ Convert Table Heights to Pixels and Convert Table Heights to
Percents, and Convert Table Widths to Pixels and Convert Table
Widths to Percents enable you to automatically change Height and
Width settings from percentages to pixels. Pixels specify a fixed
width; a percent setting means the browser automatically adjusts
the specified percentage of the browser display area.

+ Bg Color: Controls the background color. Click the color square next to
this label to open the color palette. Click to select a color from the box
or click the color wheel at the top-right corner to choose any color. Also
note that when you click the color square, the cursor changes to an eye-
dropper, enabling you to pick up a color by clicking anywhere on the
page. You can apply this option to a single cell by placing your cursor in
a particular cell before specifying the color or to the entire table by
selecting the table.

v Bg Image: Enables you to select a background image. Specify the file-
name or click the folder icon to locate the image. You can apply this
option to a single cell or to the entire table.

v Brdr Color: Controls the border color of the entire table. Click the color
square next to this label and select a color from the box that appears,
or use the color wheel at the top-right corner to choose any color. Also
note that when you click the color square, the cursor changes to an
eyedropper, enabling you to pick up a color by clicking anywhere on
the page.



206 Part ll: Appreciating Web Design Options

Make sure the table fits the contents

Be aware that table cells automatically adjust
to accommodate whatever you insert into them.
For example, if you create a cell that is 100
pixels wide and then insert a 300-pixel-wide
image, the table cell adjusts to fit the image.
This can cause problems if the overall size of
the table is not set large enough to accom-
modate all the objects within the table cells. As

you build your tables, be aware of the size of the
images and multimedia files you are inserting
into cells or you may have unpredictable
results. For example, if you set a table to a total
width of 400 pixels and then insert 600 pixels
worth of images, the table may not appear the
same in all browsers.

You can also apply formatting options and change the attributes of any ele-

options in the Property inspector to make any desired changes, just as you

merge cells (combine two or more cells into one) or split cells (split one cell
into two or more rows or columns). Using this technique, you can vary the

space in table sections and customize their structures. For example, you may
want a long cell space across the top of your table for a banner and then mul-

tiple cells below it so that you can control the spacing between columns of
text or images. The following two sets of steps show you how to merge and

§,‘\\;,N\Bflf
& ment, such as text, an image, or a multimedia file, that you have placed
within a table cell. To do so, click to select the element and then use the
would if the element were not in a table cell.
Merging and splitting table cells
Sometimes, the easiest way to modify the number of cells in a table is to
@&“\BE’? split cells in a table.
<
<

You can merge and split cells only in Standard mode.

To merge cells, create a new HTML page or open an existing HTML file and
follow these steps (see Chapter 2 for more information on creating files):

1. Choose Insert->Table and create a table with four rows and four
columns, a 75 percent width, and a border of 1. Skip header and
accessibility. Click OK and the table appears on the page.

2. Highlight two or more adjacent cells by clicking and dragging the
mouse from the first cell to the last.

You can merge only cells that are adjacent to one another and in the

same row or column.
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3. Click the Merge Selected Cells icon, in the lower-left region of the
Property inspector, to merge the selected cells into a single cell.

The cells are merged into a single cell by using the Colspan or Rowspan
attributes. These HTML attributes make a single cell merge with adja-
cent cells by spanning extra rows or columns in the table.

To split a cell, follow these steps:

1. Click to place the cursor inside the cell you want to split.

N

. Click the Split Selected Cell icon, in the lower-left region of the
Property inspector.

The Split Cell dialog box appears.

3. Select Rows or Columns in the dialog box, depending on how you
want to divide the cell.

You can split a cell into however many new rows or columns you want.
4. Type the number of rows or columns you want to create.

The selected cell is split into the number of rows or columns you entered.

Controlling cell options

In addition to changing table options, you can control options for individual
cells within a table. When you select a cell, which you do by clicking the
cursor anywhere inside the cell area, the Property inspector changes to dis-
play the individual properties for that cell (see Figure 7-5). The Property
inspector is where you find the controls to merge and split cells, as well as to
change the alignment of the contents of a particular cell.

i  Properties =
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Format | Mone |%#| Style | None »|| C55 MR ==8== Link. |l =
Font | Default Fark || Size | Mone |+ l_' = 1= £2 42 Target
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0 3&  Vert|pefadk [v| H Header [7] Ba [ | Brer [ ) .

You can also change multiple cells at the same time. For example, suppose that
you want to have some (but not all) cells in your table take on a certain color
background and style of text. You can apply the same properties to multiple
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cells by selecting more than one cell at a time. To select adjacent cells, press
the Shift key while clicking to select cells. To select multiple cells that are not
adjacent, press the Ctrl key (the 8 key on the Mac) and click each cell you
want to select. Any properties you change in the Property inspector apply to
all selected cells.

If you're having trouble selecting an individual cell because it contains an
image, click the image and then use either the « or — key on your keyboard
to move the cursor and deselect the image, which activates the Property
inspector and displays the options for that cell.

When one or more cells are selected (they have to be adjacent for this to
work), the top half of the Property inspector controls the formatting of text
and URLs within the table cells. The lower half of the Property inspector pro-
vides these table cell attribute options (refer to Figure 7-5):

v Merge Cells icon: Merges two or more cells. To merge cells, you must
first select two or more cells by clicking and dragging or by pressing
either the Shift or Ctrl key while selecting multiple cells.

v~ Split Cell icon: Splits one cell into two. When you select this option, a
dialog box lets you specify whether you want to split the row (you split
the cell horizontally) or the column (you split the cell vertically). You
can then specify the number of columns or rows, which controls how
many times the cell divides. Note that you can apply the Split Cell option
to only one cell at a time.

v Horz: Controls the horizontal alignment of the cell contents.
v Vert: Controls the vertical alignment of the cell contents.

v W: Controls the width of the cell.

v H: Controls the height of the cell.

v No Wrap: Prevents word wrapping within the cell. The cell widens to
accommodate all text as you type or paste it into a cell. (Normally, the
excess text just moves down to the next line and increases the height of
the cell.)

v Header: Formats a cell’s contents by using a header tag, which displays
the text in bold and centered by default in most Web browsers.

1 Bg (Image): The Bg field followed by a text field with a browse icon
enables you to browse to select a background image or to enter the
name and path of a background image by typing it.

 Bg (Color): The Bg field below it features a color well you can click in to
select a background color from the color palette and a text field where
you can enter a hexadecimal color code. If you use the color palette, the
hexadecimal code is automatically entered into the Bg color field.

+ Brdr (Color): Allows you to change the border color of the cell.
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Formatting multiple columns in a table

When you’re working with lots of cells in a table, you may want to format
multiple cells in the same way. Dreamweaver makes that task easy, whether
you want to align numbers, make the headings bold, or change the color
scheme. But before you start planning how to line up all your numbers per-
fectly, be aware that you don’t have as much control in HTML as you have in
a program such as Excel, where you can align numbers to the decimal point.
You can, however, align the content of columns to the left, right, or center.
Thus, if you use the same number of digits after the decimal point in all your
numbers, you can get them to line up. For example, if one price is $12.99 and
another is $14, express the latter as $14.00; then, when you right align, the
numbers line up properly. (If your columns are still not lining up the way you
want them to, consider using a monospace font such as Courier, which lines
up better.)

The steps in this section explain how to create a table in Standard mode and
align all the data cells to the right so that the numbers or other content align
consistently. You can use these exercises also to align the contents of table
cells to the left or center and to apply other formatting options, such as bold
or italic. In these steps, I insert the data into the table after I create the table
in Dreamweaver.

If you want to import data from a table you have created in a program such
as Word or Excel, see the section, “Importing Table Data from Other
Programs,” later in this chapter. If you're working with a table that already
has data in it and just want to format or align the cells, go directly to Step 7.

If you're starting from scratch, create a new, blank HTML page and follow
these steps from the beginning:

1. Make sure that you’re in Standard mode. (Choose View~>Table Mode->
Standard Mode.)
2. Click to place the cursor where you want to create a table.

In both Standard and Expanded modes, tables are automatically created
in the top-left area of the page, unless you insert them after other content.

3. Click the Table icon on the Common or Layout Insert bar.

Alternatively, you can choose Insert=>Table. The Insert Table dialog box
appears.

4. In the appropriate boxes, type the number of columns and rows you
want to include in your table.

Remember you can always add or remove cells later using the Property
inspector.

209
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5.

6.

7.

8.

Specify the width, border, cell padding, and cell spacing. Then
click OK.

The table automatically appears on the page.

Click to place the cursor in a cell and then type the data you want in
that cell. Repeat for each cell.

Alternatively, you can use Edit>Paste Special to insert columnar data
from another program such as Excel.

Select the column or row for which you want to change the alignment.

Place the cursor in the first cell in the column or row you want to align;
then click and drag your mouse to highlight the other columns or rows
that you want to change.

Right-click (Windows) or Ctrl+click (Mac) in any cell in the highlighted
column or row.

A pop-up menu appears, as shown in Figure 7-6. Alternatively, you can
use the Property inspector to change selected items.
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9. From the pop-up menu, choose Align and then choose Left, Center,
Right, or Justify from the submenu.

This option enables you to change the alignment of all highlighted cells
in the column or row at one time. If you’re working with financial data,
choose Align=>Right, which produces the best alignment for numbers.
You can also apply other formatting options, such as bold or italic, to
selected cells and their contents by choosing the option from the pop-
up menu or from the Property inspector.

P If you want to format one cell in a column or row differently from the others,
click to place the cursor in just that cell and then click one of the formatting
options in the Property inspector. You can also choose to align multiple cells
that aren’t contiguous (they don’t touch each other) by pressing and holding
the Ctrl key (88 on the Mac) in Windows while you click the cells you want to
select. Any options you change on the pop-up menu or in the Table Property
inspector apply to all selected cells.

Sorting Table Data

When you’re working with lots of columnar data, you want to be able to sort
that data just as you do in a spreadsheet program such as Excel. In
Dreamweaver, you can sort data even after it’s formatted in HTML (some-
thing you couldn’t easily do before). You still don’t have as many options as
you do in Excel. For example, you can’t sort different rows individually, but
you can sort an entire table based on a specified row.

To use the Sort Table Data feature, create a new, blank HTML page, add a
table with several rows and columns, and add some content. (I explain how
in the preceding section.) You may also open an existing page with a table of
columnar data. Then, follow these steps:
1. Select the table you want to sort.
Place the cursor in any cell of the table you want to sort.

2. Make sure that you’re in Standard mode. (Choose Viewr>Table
Mode~>Standard Mode.)

3. Choose Commands->Sort Table.

The Sort Table dialog box appears, as shown in Figure 7-7.
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|
Figure 7-7:
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4. Specify which column you want to sort by. Then choose
Alphabetically or Numerically, and Ascending or Descending.

You can set up one or two sorts to happen simultaneously and opt
whether to include the first row and whether to keep the TR (Table Row)
attributes with a sorted row by selecting Keep All Row Colors the Same.

5. Click OK.

The selected cells are sorted, just as they are in a program such as
Microsoft Excel. (Pretty cool, huh?)

Importing Table Data
from Other Programs

Manually converting financial data or other spreadsheet information can be
tedious. Fortunately, Dreamweaver includes a special feature that enables you
to insert table data created in other applications such as Microsoft Word or
Excel. To use this feature, the table data must be saved from the other program
in a delimited format, which means that the columns of data are separated by
tabs, commas, colons, semicolons, or another type of delimiter. Most spread-
sheet and database applications, as well as Microsoft Word, enable you to save
data in a delimited format, such as CSV (which stands for Comma Separated
Values) because that’s the file extension they’re given. Consult the documen-
tation for the application you’re using to find out how. After the data is saved
in a delimited format, you can import it into Dreamweaver.

To import table data into Dreamweaver after it has been saved in a delimited
format (such as CSV) or in its native application (such as Access or Excel),
create a new, blank HTML page or open an existing file and follow these steps
to import the data:
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|
Figure 7-8:
You can
import
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into Dream-
weaver
from other
programs
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|

1. Choose Filec’Import=>Tabular Data or choose Insert=>Table Objects=>
Import Tabular Data.

The Import Tabular Data dialog box appears (see Figure 7-8).

Import Tabhular Data
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=
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Help

Cell padding:

Cell spacing;
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5 Format bop row: |[Mo Formatting] v

Border: | 1

2. In the Data File text box, type the name of the file you want to import
or use the Browse button to locate the file.

3. In the Delimiter drop-down list, select the delimiter format you used
when you saved your file in the native application.

The delimiter options are Tab, Comma, Semicolon, Colon, and Other.
You should have made this choice when you exported the data from the
original program in which you created it, such as Excel or Access. If you
don’t remember what you chose, you can always go back to the original
program and export the data again. You must select the correct option
for your data to import correctly.

4. Select the table width.

If you choose Fit to Data, Dreamweaver automatically creates the table
to fit the data being imported. If you choose Set, you must specify a per-
cent or pixel size.

5. Specify the cell padding and cell spacing only if you want extra space
around the data in the table to be created.

6. Choose an option from the Format Top Row option only if you want to
format the data in the top row of the table.

Your options are Bold, Italic, or Bold Italic.

7. Specify the border size.

The default is 1, which puts a small border around the table. Choose 0 if
you don’t want the border to be visible. Choose a larger number if you
want a thicker border.

8. Click OK to automatically create a table with the imported data.
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Dreamweaver also enables you to export data from a table into a delimited
format. This capability is useful if you want to export data from a Web page
so that you can import it into another program, such as Word or Excel, or
into a database program, such as FileMaker or Access. To export data from
Dreamweaver, place the cursor anywhere in the table and choose FileExportw>
Table. In the Export Table dialog box, choose from the options on the Delimiter
drop-down list (you can choose Tab, Space, Comma, Semicolon, or Colon).
From the Line Breaks drop-down list, specify the operating system (you can
choose Windows, Mac, or Unix).

Using Tables for Spacing and Alignment

Tables have long been used on the Web to create page layouts that require
more than basic alignment of elements on a page. Using tables, you could get
around many of the limitations of basic HTML and accomplish some otherwise
impossible design feats, such as evenly spacing bullets, creating columns
side-by-side on a page, and spanning headlines or images across multiple
columns. Today, CSS offers a much better option for these kinds of designs,
but many people are still using tables and you may inherit a design that uses
them, so I've included this exercise to help you appreciate how to use tables
to format complex content, such as the elements of the form that are dis-
played in a table in the bottom of the upcoming Figure 7-10.

Using tables to design forms

Creating text boxes and drop-down lists for HTML forms is easy in
Dreamweaver, but if you want all the fields to line up, you may want to use
tables or CSS to help with the formatting. You find instructions for formatting
forms, text, and other elements with CSS in Chapters 5 and 6. In Chapter 12,
you find step-by-step instructions for creating a variety of forms; for now, |
assume that you have already created a form and want to align the text boxes
evenly using a table. I've use a simple form with just a few questions as an
example, but you can use this technique to align any form elements.

I've left this exercise in this revision of the book for two reasons: Tables offer
a simple way to control the alignment and positioning of form elements, and
what you discover in this exercise will help you with the formatting of any
table design. That said, CSS provides a much better option for formatting
forms like the one featured in this example and is the recommended option if
you want your Web site to comply with contemporary Web standards.




The transparent, or clear, GIF trick

One of the ways Web designers have created
complex layouts within the limitations of HTML
tables is to use a technique commonly known
as the transparent, or clear, GIF trick. Essen-
tially, you create an invisible image (a GIF with a
transparent background and nothing else), and
then you insert that invisible GIF into your page
and use the image height and width settings in
Dreamweaver to control the image’s size. The
effectis the creation of empty space on a page
that can be precisely controlled by the height
and width attributes.

In the old days, this was one of the only ways
you could precisely control margins and other
spacing within a table and between elements
on a Web page. Today, CSS offers far superior
ways to control spacing and add margins and
padding.

Among the challenges with the clear GIF trick is
how hard it can be to manage them within the
design area because they are invisible. When
you select a transparent GIF, you can see the
outline of the image while it's selected, but as

soon as you deselect the image, it becomes
invisible in Dreamweaver (unless you add a
border in the image properties). You can always
reselect an image by clicking the area until the
cursor highlights it. Just be aware that select-
ing it, especially if it's very small, can be tricky
because it's not visible.

Because CSS offers better ways to control
spacing (using margin and padding settings, for
example), | no longer recommend that you use
the clear GIF trick. However, if you are editing a
Web page layout that someone else created
using HTML tables, you may discover lots of
little invisible GIFs. | offer this brief explanation
only because | wanted to make sure you know
about this trick so you're not baffled by why
anyone would place invisible graphics all over
a Web page.

If you inherit a Web site that used this design
method, | strongly recommend that you
redesign the pages using <div> tags and CSS
(covered in Chapter 6) instead of tables with
clear GIFs.

To use a table to align form elements, such as text boxes, on your page,

follow these steps:

1. Open a page containing an HTML form (or create an HTML form).

See Chapter 12 to find out how to create HTML forms.

2. Click to place the cursor where you want to start formatting your form.

3. Choose Insert=>Table.

The Insert Table dialog box appears.

4. Type the number of columns and rows you want in your table.

I set the table to three rows and two columns.
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. Set the width to whatever is most appropriate for your design and
then click OK.

Remember, up to 760 pixels is a good width if you are designing for an
800-by-600 screen resolution, which many designers consider the best
size to reach the most users.

. Enter 0 for the border.

When you set the border to 0, the edges of your table change from solid
lines to dotted lines so that you can still see where the borders are while
you’re working in Dreamweaver. When you view the page in a browser,
as shown in Figure 7-9, the border of the table is invisible.

. Click OK.
The table automatically appears on the page.

. You need to copy the data from your form into the table. Using the Cut
and Paste commands from the Edit menu, cut the text preceding the
form’s first text field and paste it into the cell in the upper-left corner
of the table.

Alternatively, you can select the text and then click and drag it into each
table cell.

In my example in Figure 7-10, I cut the words What’s your favorite song?
and pasted them into the first table cell.

. Select the first text field (the empty box where users type their
responses) and cut and paste (or click and drag) the field into the
desired cell of the table.

10. Repeat Steps 8 and 9 until you have moved all form elements into

table cells.

11. Click the vertical column divider line between the first and second
columns and drag it to the left or right to create the alignment you

want for your form.

Vertical alignment solves common problem

If you're having trouble getting the contents of
adjacent cells to line up with each other, setting
Vertical alignment to Top may solve your prob-
lem. A common frustration when you're building
tables is that you have two or more rows side by
side with text in one and images in the other and
you want the top of the image and the top of the
textto line up. Often they don't because they are
different lengths, and the table is trying to adjust

the contents to best use the space within their
respective cells. The solution is simple: Select
all the cells you want to align, and in the
Property inspector, change Vertical alignment
to Top. Seemingly like magic, all the content
jumps right to the top of the cells and lines
up perfectly. This is such a common problem, |
routinely set the Vertical alignment of table cells
to Top.
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Using nested tables: Tables within tables

Placing tables within tables, called nested tables, can help you create extremely
complex designs. You create nested tables by inserting a table within a cell of
another table. In the days when you had to write your own code, this task
was daunting. Dreamweaver now makes nesting tables easy, enabling you to
create complex designs without ever looking at the HTML code.

The best Web designs communicate the information to your audience in the
most elegant and understandable way and are easy to download. To make
sure that your designs don’t get too messy, remember these guidelines:

v~ A table within a table within a table is nested three levels deep. Anything
more than that gets hairy.

v Pages that use nested tables take longer to download because browsers
have to interpret each table individually before rendering the page. For
some designs, the slightly longer download time is worth it, but in most
cases you're better off adding or merging cells in one table, as [ explain
in the section “Merging and splitting table cells,” earlier in this chapter.
One situation that makes a nested table worth the added download time
is when you want to place a table of financial or other data in the midst
of a complex page design.

To place a table inside another table, follow these steps:

1. Click to place the cursor where you want to create the first table.
2. Choose Insert=>Table.

The Insert Table dialog box appears.
3. Type the number of columns and rows you need for your design.

4. Set the Width option to whatever is appropriate for your design, and
then click OK.

The table is automatically sized to the width you set.

5. Click to place the cursor in the cell in which you want to place the
second table.

6. Repeat Steps 2 through 4, specifying the number of columns and rows
you want and the width of the table.

The new table appears inside the cell of the first table.

7. Type the information that you want in the nested table cells as you
would enter content in any other table.



Chapter 8
Framing Your Pages

In This Chapter

Introducing HTML frames
Creating frame pages

Knowing when not to use frames
Setting targets and links

Changing the properties of frames

No one wants to be “framed,” whether that means being falsely accused
of something you didn’t do or trapped in the HTML frameset of a Web
site with no escape. Appreciating not only the best way to create frames but
also the best way to use them to enhance site navigation is important if you
don’t want to leave your visitors feeling stuck in your pages.

Many experienced Web designers say you should never use frames. I take

a more open approach — I don’t recommend frames, but I think you should
decide for yourself. Besides, I can think of a few instances when frames come
in quite handy, such as when you want to bring in content from another Web
site and still maintain your own navigation and logo. Of course, you should
do this only with permission from the other site (see the sidebar later in this
chapter, “Resist using frames when you link to other people’s Web sites”).

To help you make the most of this HTML design feature, this chapter covers
how to build HTML framesets in Dreamweaver and also discusses when
frames are most useful and when you should avoid them. Frames add a wide
range of design possibilities, but they can also create confusing navigation
systems and can be frustrating to viewers. As you go through this chapter,
consider not only how to create frames but also whether they are really the
best solution for your Web site project.

Appreciating HTML Frames

Frames add innovative navigation control because they enable you to display
multiple HTML pages in one browser window and control the content of each
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