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Welcome to the world of Microsoft Excel, the most popular and powerful
spreadsheet program in the world. You may ask...what is a spreadsheet
program? A spreadsheet is a computer program with a huge grid designed to
display data in rows and columns where you can create calculations to per-
form mathematical, logical, and other types of operations on the data you
enter. You can sort the data, enhance it, and manipulate it a plethora of ways
including creating powerful charts and graphs from it. Whether you need a list
of names and addresses, or a document to calculate next year’s sales revenue
based on prior years’ performance, Excel is the application you want to use.

About This Book

This book provides the tools you need to successfully tackle the potentially
overwhelming challenge of using Microsoft Excel. Through this book you
find out how to create spreadsheets; however, what you create is totally up
to you. Your imagination is the only limit!

Why You Need This Book

Time is of the essence and most of us don't have the time to do a lot of
reading. We just need to get a task done, effectively and efficiently. This book
is full of concise, easy to understand steps designed to get you quickly up
and running with Excel by taking you directly to the steps for a desired task,
without all the jibber-jabber that often accompanies other books.

How This Book Is Organized

This book is divided into eighteen different chapters broken into five con-
venient parts:

Part I: Putting Excel to Work

In Chapter 1, you uncover the basics of working with Excel files, such as open-
ing, closing, and saving files, while in Chapter 2, you work with entering the

| “*’froducﬁon

Conventions used
in this book

= When you have to type something, | put it in
bold type.

w= For menu commands, | use the <> symbol to
separate menu items. For example, choose
Filec>Open. The => symbol is just my way of
saying "Choose Open from the File menu."

This icon points out insights or helpful
suggestions related to the tasks in the

step list.
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different types of data into Excel worksheets, and in Chapter 3,
you create various types of formulas and functions to perform
worksheet calculations.

Part 11: Sprucing Up Your Spreadsheet

Chapter 4 shows you how to dress up the data you enter into a
worksheet, including data alignment, formatting values, chang-
ing fonts, colors, and cell borders. In Chapter 5, you also work
with graphics such as arrows and clip art. Then in Chapter 6,
you work with multiple worksheets, hyperlinks and worksheet
protection, and passwords.

Part 11I: Viewing Data in Different Ways

This part shows how you modify how Excel displays certain
workbook options on your screen. Chapter 7 illustrates chang-
ing the worksheet views. In Chapter 8, you sort your data
making it easier to locate particular pieces of information. In
Chapter 9, you create charts to display your data in a superb
graphic manner and in Chapter 10 you work with the different
output methods, including printing, for your worksheets.

Part 1V: Analyzing Data with Excel

Use these chapters to effectively analyze all the data you
input into a worksheet. In Chapters 11, 12, and 13, you
work with Excel Outlines, Filters, and Pivot Tables.
Chapters 14 and 15 show some of the timesaving
data entry tools included with Excel.

Part U: Practical Applications for Excel

Go to these chapters to save yourself time with a commis-
sion calculation worksheet (Chapter 16), a medical expense
tracking worksheet (Chapter 17), and Chapter 18 which
helps you plan for your future by planning to purchase a
house, pay off a credit card balance, and save for college
or retirement. Chapters 19 through 21 show how you

can use Excel with the other Office programs — Word,
Powerpoint, and Access.
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Putting Excel to Work

The 5th Wave

By Rich Tennant
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Working with
Excel Files

your PC probably has many different computer programs loaded on

it, but you'll not likely find one that is as versatile as Microsoft Excel.
Throughout the course of this book, you discover methods to use Excel as a
spreadsheet of course, but also as a database, a calculator, a planner, and even
a graphic illustrator. But as with most things in life, you need to figure out
the basics before you can carry out the more advanced actions.

In this chapter, you

m= Discover the fundamental measures needed when working with Excel
files; basic operations to file management such as opening, closing,
and saving files.

== Meet Clippit, the animated Office Assistant, who stands by your virtual
screen waiting for a question from you. Clippit takes your question to
the Excel Help system, both local and over the Internet, searching to
provide the best answer to your inquiry.

== Customize what you see on the Excel screen, thereby making it easier
and faster for you to use.

w= Use workbook properties to better manage your files and provide a
means to search for those files that sometimes mysteriously get lost
in a computer hierarchy.

| “%ap’fer

Get ready to. . .

w= Open and Close Excel 6
w= (reate a New Excel File 7
= Save a Workbook 7
w= Open an Existing Excel File ............cccoooeen... 8
= Delete an Existing Excel File ........................ 8
e Use the Office Assistant..............oooocccecceveeees 9
= Separate the Excel Toolbars........................ 10
w= Display Different Toolbars........................... 10
= Specify Workhook Properties...................... 1
w= Search for a File by Properties .................. 12

w= Save or Open Files in Different Formats......12



Chapter 1: Working with Excel Files

Open and Close Excel

1.

To open Excel, choose Start=>All Programs=>Microsoft
Officer>Microsoft Excel. The Microsoft Excel program
begins with a new blank workbook, as shown in
Figure 1-1, ready for you to enter data. Take note of
the following elements on-screen:

e Getting Started task pane: Appears on the right side
on the workbook.

e Office Assistant: An animated icon that can answer
questions, offer tips, and provide help. See the “Use
the Office Assistant” section later in this chapter.

¢ Toolbars: A series of tools that provide fast access
to commonly used Excel features. By default, Excel
includes nineteen toolbars but only three display
when you start Excel: Standard, Formatting, and
Drawing. See “Separate the Toolbars” and “Display
Different Toolbars” later in this chapter.

If you have an Excel icon on your Windows desktop, double-click
the icon for a quick way to start Excel.

To close the current workbook, choose Filew>Close. If any
changes are not saved, Excel prompts you to save your
changes. See “Save a Workbook” later in this chapter.

Optionally, click the Close box to close the current Excel file. If no
other workbook is open, the Excel program also closes.

To exit Excel, choose Filer>Exit as shown in Figure 1-2.
The Excel file and program closes. If any changes are not
saved, Excel prompts you to save your changes.
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Save a Workbook

Create a New Excel File

1. Choose Filec>New. The New Workbook options appear
on the task pane.

Optionally, press Cirl+N or click the New button on the toolbar to
create a new blank workbook.

2. From the task pane, click Blank Workbook. A new work-
book (see Figure 1-3) appears on top of the existing
workbook.

Save a Workbook

1. Choose Filer>Save or click the Save button on the toolbar.
The Save As dialog box appears, as shown in Figure 1-4.

Optionally, press Ctrl+S to save the Excel file.

2. By default, Excel saves your files in the My Documents
folder. If you want to save your file in a different folder,
select the folder where you want to save the file from
the Save In drop-down list.

3. In the File Name text box, type a descriptive name for
the file.

Filenames cannot contain an asterisk, slash, backslash, or the
question mark character.

4. Click the Save button. Excel saves the workbook in the
location and with the name you specified.
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Chapter 1: Working with Excel Files

Open an Existing Excel File

1.

With Excel already open, choose File=>Open or click the
Open button on the toolbar. The Open dialog box opens,
as shown in Figure 1-5.

Optionally, press Ctrl+0 to display the Open dialog box.

At the bottom of the File menu, Excel stores the names of the last
four Excel files you opened. Click any listed filename to quickly
open the selected file.

By default, Excel looks for your files in the My Documents
folder. If your file is not in My Documents, select the
appropriate folder from the Look In drop-down list.

Select the file you want to open.

Click the Open button. Excel opens the file.

Delete an Existing Excel File

1.

With Excel open, choose File=>Open or click the Open
button on the toolbar. The Open dialog box displays.

Right-click the file you want to delete. Do not open
the file.

Choose Delete from the shortcut menu (see Figure 1-6).
A confirmation message appears.

Click Yes. Excel deletes the file.
Click the Cancel button to close the Open dialog box.
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Use the Office Assistant

Use the Office Assistant

1.

Click anywhere on the Office Assistant icon. The Office

Assistant displays a What Would You Like to Do text box.

Want to see your Office Assistant do tricks? Right-click the assistant
and select Animate. Each different Office Assistant performs a dif-
ferent series of tricks.

Type a request in the text box, as shown in Figure 1-7.
Then, press Enter.

The results of your request appear in a Search Results task
pane on the right side of your screen (see Figure 1-8).
Click any link in the Search Results task pane to discover
the answer to your request.

Optionally, drag the Office Assistant to a different part
of your screen if it's in your way. In many cases, the
Office Assistant moves out of the way automatically.

Right-click the Office Assistant and select Choose Assistant, which
displays the Office Assistant dialog box. From the Gallery tab, you
can select a different assistant than the default paper clip. Options
include a robot, a magician, a cat, a dog, and others.

Click the Close box in the upper-right corner of the
Search Results task pane to put it away.

Right-click the Office Assistant and choose Hide to tem-
porarily hide the Office Assistant.

To permanently hide the Office Assistant, right-click the Office
Assistant, choose Options, and remove the check mark from the Use
the Office Assistant option.
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Chapter 1: Working with Excel Files

Separate the Excel Toolbars

1.

Choose View=>Toolbarst> Customize. The Customize
dialog box appears.

Click the Options tab (see Figure 1-9).

Select the Show Standard and Formatting Toolbars on Two
Rows option. Excel displays the toolbars separately, which
makes the most commonly used tools easily accessible.

Click the Close button.

In the Customize dialog box, select the Always Show Full Menus to
immediately display all the menu choices when you dlick a menu
such as File or View. With this option unchecked, you must dlick the
down arrow on a menu to display the remainder of the options.

Display Different Toolbars

10

1.

Choose View>Toolbars. Toolbars currently displayed
have a check mark next to them. (See Figure 1-10.)

Select a toolbar you want to display. A few of the tool-
bars are

e Standard: See Chapters 1, 7, 9, 10, and 12.

e Formatting: See Chapters 4, 5, and 8.

e Drawing: See Chapters 5 and 9

e Chart: See Chapter 9

e Picture: See Chapter 5

Repeat Steps 1 and 2 to hide a toolbar from display.
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Close

Figure 1-9: Display the Standard and Formatting
toolbars in their entirety
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Specify Workbook Properties

Specify Workbook Properties

1.

Choose FilevProperties. The Properties dialog box
appears with several tabs:

e General: Illustrates filename, location, size, and dates
including the creation, modification, and last accessed
date. Excel automatically updates the information on
the General tab.

e Summary: Includes fields for author, title, subject,
and other similar information. (See Figure 1-11.)

e Custom: Allows you to create custom fields that you
can assign text, date, number, or even yes or no values
(see Figure 1-12).

e Statistics: Displays facts about the workbook usage
including creation, modification and last print date,
editing time, and revision numbers.

e Contents: Displays a list of all worksheets included
in the workbook.

To have Excel automatically prompt you to set file properties for
every workbook you create, choose Tools=>Options and on the
General tab, select the Prompt for Workbook Properties check box.
When you save a workbook the first time, Excel displays the
Properties dialog box.

Select the tab on which you want to enter information
and enter any desired data.
Click OK.

Save the workbook. The workbook properties are saved
with the workbook data.
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Chapter 1: Working with Excel Files

Search for a File by Properties

1.
2.
3.
4.

5.

Choose File>Open. The Open dialog box appears.
Click the Tools button and choose Search from the menu.
In the File Search window, click the Advanced tab.

Select the field you want to search from the Property
drop-down list.

In the Value box, enter the data by which you want to
search.

Click the Add button.
Select where to search from the Search In drop-down list.

Select the file types you want to look for from the Results
Should Be drop-down list as shown in Figure 1-13.

Click the Go button. A list of the files matching your
criteria appears at the bottom of the File Search window.

Save or Open Files in Different

Formats

1. Choose Filem>Save As or Files>Open.

2. Select a location in which to save the file or the location
in which your file is currently located.

3. Select the file type you want to use from the Save as Type
(shown in Figure 1-14) or Files of Type drop-down list.

4. Enter a name for the file in the File Name text box or
select the file you want to open.

5. Click Save or Open.
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Entering Spreadsheet
Data

you can enter three primary types of data in a spreadsheet: labels, values,
or formulas. Labels are traditionally descriptive pieces of information
such as names, months, or other identifying statistics and usually include
alphabetic characters. Values are generally raw numbers or dates and formu-
las are results of calculations.

The first part of this chapter shows how you can easily enter labels and val-
ues into your worksheet. But, alas, none of us are perfect and you may need
to correct your mistakes. So I also show you how to delete incorrect entries,
duplicate data, or move it to another area of the worksheet. You even dis-
cover an Excel feature that prevents worksheet cells from accepting the
incorrect data.
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w= Change the Active Cell

w= Enter Data

w= Undo Data Entry

w= Edit or Delete Cell Data..............
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w= Extend a Series with AutoFill......
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Chapter 2: Entering Spreadsheet Data

Change the Active Cell

1.

14

Open a spreadsheet in Excel. The formula bar displays the
active cell location. A single worksheet has 256 columns
across and 65536 rows down. Columns display the letters
from A to IV and rows display numbers from 1 to 65536.
A cell address is the intersection of a column and a row

such as D23 or AB205.

Move the cursor to an adjacent cell with one of the fol-
lowing techniques:

e Down: Press the Enter key or the down arrow key.
In Figure 2-1, I've moved the cursor from E9 to E10.

e Up: Press the up arrow key.
e Right: Press the right arrow key
o Left: Press the left arrow key.

To move to a cell farther away, use one of these
techniques:

e Click the mouse pointer on any cell to move the
active cell location to that cell.

e Choose Edit=>Go To (or press F5). The Go To dialog
box displays, as shown in Figure 2-2. In the Reference
box, enter the cell address you want to make active,
and then click OK.

e Press Ctrl+Home. Excel jumps to cell Al.

e Press Ctrl+End. Excel jumps to the lower-right cell of
the worksheet.

e Press Ctrl+PageDown or Ctrl+PageUp. Excel moves to
the next or previous worksheet in the workbook.

“Miciawsh Frcal Hookl -
4l Ble Edn View (et Fgrmal fooks Qata Windew  ffelp
; LA PaynSetme d S|P Ak bia

ALEE oAl

T BSESED

R e e e )

12 (i s | 1a

AODHAR N LA ERERSE

s
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Enter Data

Enter Data

Type the label or value in the desired cell.

Press Enter. The data is entered into the current cell
and Excel makes the next cell down the active cell.
(See Figure 2-3.) How Excel aligns the data depends
on what it is:

e Label: Excel aligns the data to the left side of the cell.

If the descriptive information is too wide to fit in a
cell, Excel extends that data past the cell width as

long as the next cell is blank. If the next cell is not
blank, Excel displays only text meeting the display

width. Widening the column displays additional text.

To enter a value as a label, type an apostrophe before the value.

e Whole value: Excel aligns the data to the right side of
the cell.

e Value with a decimal: Excel aligns the data to the
right side of the cell, including the decimal point,
with the exception of a trailing 0. For example, enter-
ing 246.70 displays 246.7. The trailing zero is not
lost; it simply doesn’t display. (See Chapter 4 to
change the display appearance, column width, and
alignment of your data.)

If a value displays as scientific notation or number signs such as in
Figure 2-4, it means the value is too long to fit into the cell. You
need fo widen the column widih.

e Date: If you enter a date, such 12/3, Dec 3, or 3 Dec,
Excel automatically returns 03 -Dec in the cell,
but the formula bar displays 12/03/2005.
See Chapter 4 to change the date appearance.
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Chapter 2: Entering Spreadsheet Data

Undo Data Entry

1. Enter text into a spreadsheet.

2. To undo any actions or correct any mistakes you make
when entering data, do one of the following:

e Choose Edit>Undo.
e Press Ctrl+Z.

e (Click the Undo icon on the toolbar.

3. Keep repeating your favorite undo method until you're
back where you want to be.

4. To undo several steps at once, click the arrow on the
Undo icon and select the step you want to undo from.
(See Figure 2-5.)

You can’t undo some actions and Excel indicates this by changing
the Undo command (on the Edit menu) o Can't Undo.

To repeat the last action, choose Editc>Repeat, or press Cirl+Y.
You can't repeat some actions, however.

Edit or Delete Cell Data

Action

Edit

Choose Edite>Clear=>Contents.

Delete the confents and retype new cell
information.

Press the Delete key.

Double-click the cell contents and press the
Backspace key to delete unwanted characters;
then, type new characters. (See Figure 2-6.)
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Select Multiple Cells

- [T =
Select Multiple Cells e e B
2 IS TN E TR T Y e ey |
What to Select Do This T s i i i 5
Sequential cells Hold the Shift key and select the last cell you want to select. g
All cells in the selected area are highlighted, with the excep- s
tion of the first cell. It looks like it's not included in the i
selected area, but it is. Figure 2-7 shows a sequential area |5
selected from cell B4 to cell F15. Notice the black border £
surrounding the selected area. 5
Non-sequential cells Hold the Ctrl key and click each additional cell you want to
select. Figure 2-8 shows the nonsequential cells A4, (7, and :
D13 through D20 selected. z
Assingle entire column Click a column heading. 5 !
CHCRTRE LT P T ([ wl
Multiple columns Drag across mulfiple column headings. s i
Figure 2-7: A sequential cell selection
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Figure 2-8: Nonsequential cells selected



Chapter 2: Entering Spreadsheet Data

Copy and Paste Data

1.

Select the area of data you want to copy. The selected
area is highlighted.

Choose Edit=>Copy (or press Ctrl+C). The selected cells
have a marquee (which looks like marching ants) around
them (see Figure 2-9).

Click the cell where you want to copy the selected area.

Choose EditeoPaste (or press Ctrl+V). The selected cells
are pasted into the new location.

Paste the cells into another location or press Escape to
cancel the marquee.

Choose Edit=>Cut (or press Cirl+X) and then Edit>Paste to move,
instead of duplicate, the selected cells to a different location.

Name a Range of Cells

18

Select the cells you want to name.

Choose InserttoNamer>Define. The Define Name dialog
box shown in Figure 2-10 appears.

In the Names in Workbook text box, enter a name (up
to 256 characters) for the range you selected. Range
names are not case sensitive and must begin with a let-
ter or the underscore character and cannot include a
space or a hyphen.

Click the Add button and then the Close button.

Jump quickly to a range by selecting the range name in the Go To
dialog box.
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Locate Cells with Data Validation

Extend a Series with AutoFill

1. Type the first cell of data with data such as a day
(Tuesday) or a month (August) and press Enter.
AutoFill works with days of the week, months of the
year, or yearly quarters such as 2nd Qtr.

2. Position the mouse pointer on the small black box at
the lower-right corner of the cell. Your mouse pointer
turns into a small black cross. Drag the small black box
across the cells you want to fill. You can drag the cells
up, down, left, or right.

3. Release the mouse. Excel fills the selected cells with a
continuation of your data. Figure 2-11 shows how Excel
filled in the cells with the rest of the days of the week.

If you use AutoFill on a single value or a text word, Excel duplicates
it. For example, if you use AutoFill on a cell with the word Apple,
all filled cells contain Apple.

To AutoFill a series of numbers, enter two values in two cells, such as
1 and 2. Select both cells, and then use the AutoFill box fo highlight
cells and Excel continues the series as 3, 4, 5, and so forth.

Locate Cells with Data Validation

1. Choose Edit=>Go To. The Go To dialog box appears.
Click the Special button.

In the Go To Special dialog box, shown in Figure 2-12,
select the Data Validation option.

4. Select All; then click OK. Excel highlights all cells that
have data validation.

To remove data validation, from the Data Validation dialog box,
click the Clear All button. The following section shows how to vali-
date data entry.
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Chapter 2: Entering Spreadsheet Data

Validate Data Entry

1.

20

Select the cell or cells you want Excel to validate upon
data entry. Then choose Data=>Validation. The Data
Validation dialog box displays.

From the Settings tab, choose the type of validation you
want Excel to check from the Allow drop-down list:

e Whole Number or Decimal: Specify the upper and
lower limits of allowable data values.

e Lists: Define a list, a range of cells in the existing
worksheet, or a named range. (See Figure 2-13.)

e Dates or Times: Specify a valid date or time ranges
or limitations.

e Text Length: Specify that the number of characters in
the data is within the limits you want.

When creating a list, select the In-Cell Dropdown check box if you
want the choices to appear when the cell is dicked.

Select a criterion such as Between, Greater Than, Equal To,
or Less Than or Equal To from the Data drop-down list.

Select other criteria such as a max and min value or
specify a location for a list of data you want to allow.
You can type values or refer to cell addresses. If you
want to refer to a range name, precede the range name
with an equal sign (=).

On the Error Alert tab, select an option from the Style
drop-down list (see Figure 2-14) to determine whether
Excel warns you about an invalid entry or stops you
from entering an invalid entry.

Click OK.

Data Validation
| settings | Input Message | Error Alert
walidation criteria
Allowa:
s e i Ignore blank
Data: - Irecell dropdown
Source:
0

Figure 2-13: Create a list of acceptable options
or select one from the worksheet
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Show error alert after invalid data is entered
when User enters invalid data, show this error alert:
Style: Title:

|stop

Stop Errar message:
Warning

Information

Figure 2-14: Determine the action to take upon
invalid data entry



Building Formulas

Fis chapter is all about the math. With Excel, you can create formulas to
perform calculations. The calculations can be simple such as adding 2
plus 2 or they can be extremely complex such as those used to calculate
depreciation. But don’t despair; you don't have to do most of the work.
Excel includes over 230 built-in calculations in nine different categories,
which are called functions.

Functions contain arguments, which appear in parentheses following the func-
tion’s name. The arguments are the details you provide to Excel indicating
which numbers to calculate in the function. Some functions require several
arguments to function correctly but again, don’t worry; Excel contains a
Function Wizard to walk you through the entire process.

The primary tasks in this chapter include
w= Creating simple and complex formulas by typing them into a cell.
m=  Analyzing data with Excel’s timesaving functions.

m= Creating cell ranges separated with a colon for a sequential cell
selection or by a comma to list specific cell locations.

»= FEvaluating formula errors and locate a cell’s precedents and
dependents.

| “*\apter

Get ready to. . .
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w= (reate Compound Formuls........................ 23
= Add Numbers with AutoSum ..................... 24
= Find an Average Value .........cccccceeeeeeremrne. 24
= Copy Formulas with AutoFill ..................... 25
w= Edit a Formula 25
w= Define an Absolute Formula ...................... 26
= Copy Values Using Paste Specidl ................ 26
w= Build a Formula with the Function Wizard ....27
w= Generate an IF Statement Formula ........... 28
w= Troubleshoot Formula Errors ...................... 29

w= Audit Formulas 30




Chapter 3: Building Formulas

Create Simple Formulas
with Operators

1.

22

Enter values in two different cells; however, formulas do
not need to reference a cell address. They can contain an
actual number.

In the cell that you want the calculation of the two val-
ues, type an equal sign (=). All formulas begin with an
equal sign.

Type the first cell address or type the first value you want
to include in the formula. In the example in Figure 3-1,
I'm adding two cell references (B5 and B6) together.

Using the keys on the main part of your keyboard or
from the numeric keypad, type an operator. Operators
include the following:

e The plus sign (+) to add

e The minus sign (-) to subtract
e The asterisk (*) to multiply

e The slash (/) to divide

Type the second cell address or the second value you
want to include in the formula.

Press Enter and Excel displays the results of the calcula-
tion in the selected cell. (See Figure 3-2.)

The formula bar af the top displays the actual formula.

Formulas can have mulfiple references. For example, you could
have a formula =B5+B6+B6+B8. Formulas with multiple operators
are called compound formuls.
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Create Compound Formulas

Create Compound Formulas

s, W N~

Type values in three or more different cells.
Select the cell where you want the formula.

Type the equal sign and then the first cell reference.

Type the first operator and then the second cell reference.

Type the second operator and then the third cell reference.

Compound formulas are not limited to three references. They can
contain many different cell references and you can use cell refer-
ences multiple fimes in a compound formula.

Press Enter. Excel displays the results of the calculation
in the selected cell. The actual formula appears in the
formula bar as shown in Figure 3-3.

If you were paying atfention in your high school algebra class, you
may remember the Rule of Priorities. In a compound formula, Excel
calculates mulfiplication and division before it calculates addifion
and subtraction. This means that you must include parentheses for
any portion of a formula you want calculated first. As an example,
in Figure 3-4, you see where the formula 3 +5* 2 gives a result
of 13, but (3+5) *2 gives a result of 1.6.

You can indude range names in formulos such s =D23 *
CommissionRate where a specfic cell was named
CommissionRate. See Chapter 2 about using range
names.

Compound formulas can have multiple combinations in parentheses
and can contain any combination of operators and references. A for-
mula might read ( (B5+C5) /2) *SalesTax, which
would add B5 and C5, divide that result by 2 and then multiply
that result times the value in the cell named SalesTax.
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Chapter 3: Building Formulas

Add Numbers with AutoSum

Click the cell beneath a sequential list of values.

Click the AutoSum (Z) button on the toolbar. Excel
places a marquee (marching ants) around the cells
directly above the current cell. (See Figure 3-5.)

If the cells directly above the current cell have no values, Excel
selects the cells directly to the left of the current cell. If you want to
add a group of different cells, highlight the desired cells.

Press the Enter key to display the sum.
The formula bar displays the actual formula that begins with the equal

sign and the word SUM. The selected cells are shown in parenthe-
ses and the beginning and ending cells are separated by a colon.

Find an Average Value

1.

24

After selecting the cell beneath a sequential list of values,
click the arrow next to the AutoSum button. Besides the
Sum operation, Excel displays a list of other calculation
options as shown in Figure 3-6:

e Average: Calculated by adding a group of numbers
and then dividing by the count of those numbers.

e Count: Counts the number of cells in a specified
range that contains numbers.

¢ Max: Determines the highest value in a specified range.

¢ Min: Determines the lowest value in a specified range.

Choose Average and then press Enter to select the mar-
quee. The selected cell displays the average value.
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Edit a Formula

a e [ e Bk ==
Copy Formulas with AutoFill B e
1. On a cell with a formula, position the mouse on the - : E E=g e
AutoFill box in the lower-right corner. Make sure the 2
mouse pointer turns into a black cross. i Gawry . Fabuary [Whardy
5 Bob 75 84 a7
2. Drag the AutoFill box to include the cells you want to g jSusan i
copy the formula to and then release the mouse button. Sem ST
(See Figure 3-7.) The AutoFill method of copying formu- L P
las is helpful if you're copying a formula to surrounding e e oo
cells. 13
14 AVERAGE SALES [ 110.124] |
15
When you copy a formula, the formula actually changes because a i
copied formula is relative to the position of the original formula. &
For example, if the formula in cell D23 is B23+C2 3 and you 2
copy the formula fo the next cell down, to cell D24, Excel automat- e A—— ? N
ically changes the formula to B24 +C24. If you do not want L TS P e |
the formula to change when copied, you must make the originating Figure 3-7: Using AutoFill to duplicate a formula

formula an absolute formula (see the “Define an Absolute
Formula” section coming up).

[ e
0 Bie Edll Miww et Faemar Tasls  [atn Window  fielp LT |
. _d. i = 2 _ﬂ - = X -
- A e— e ome—.|
Edit a Formula , e T
2
. .. 3
1. Double-click the cell containing the formula you want 4 Salesperson January _ February March
. 5 [Bob 75 o 97 =(B5+BE2
to edit (or press F2). The cell expands to show the for- & Susan 0 w13 12
mula instead of the result. (See Figure 3-8.) " o
. 9 Andrew 147 126 172
2. Use the arrow keys to navigate to the character you want lohescer o w18
ex
to change. 12 Danel 210 84 37
13
3. Delete any unwanted characters by pressing the Backspace 14 AVERAGE SALES UEAZ5! 101128, 1385
key and type any additional characters you want to add. )
18
Press the Delete key to delete the entire formula and start over. 1
21
i Tt 1, i it [ “l
LA e TR et L AIEEEAAL

4. Press the Enter key. Figure 3-8: Edit a formula
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Define an Absolute Formula

1.

To prevent a formula from changing a cell reference as
you copy it to a different location, you need to lock in
an absolute cell reference by following one of these
methods:

e Lock in a cell location: Type a dollar sign in front
of both the column reference and the row reference
(for example $B$2). If the original formula in cell F5
is =E5*$B$2, and you copy the formula to cell F6,
the copied formula would read =E6*$B$2 instead
of =E6*B3, which is what it would read without the
absolute reference. (See Figure 3-9.)

e Lock in a row or column location only: Type a dol-
lar sign in front of the column reference ($B2) or in
front of the row reference (B$2).

Copy the formula as needed to other locations. Notice
that the absolute cell reference in the original formula
remains unchanged in the copied formulas.

Copy Values Using Paste Special

26

1.

Select a cell (or group of cells) containing a formula and
then choose Edit>Copy. A marquee appears around the
selected cell.

Select the cell where you want the answer; then choose
Edit=>Paste Special. The Paste Special dialog box, shown
in Figure 3-10, appears.

Select the Values option.

Click OK. Excel pastes the result of the formula, not the
actual formula. If the original formula changes, this
value doesn't change.
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1
2 Commission Rate : _g.:_rsj
3
4 Salesperson January February March TOTAL COMMISSION
5 Bob 75 a4 a7[ " 266)=E5°sES2
G Susan 134 103 128 366
T Sam 32 T4 62 168
8 Erin 86 88 &1 265
8 Andrew 147 126 172 445
10 Spencer a2 107 106 305
11 Alex 105 81 100 296
12 Daniel 210 164 an 695
13 TOTALS &8 857 1088 2806
14
15
16
7
18
18
20
21
o] - -
CRRC e Py E e Jal |
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Figure 3-9: A formula containing an absolute reference
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2 Commission Rate Lo N
3 Fasin Spaciid o |
4  Salesperson January " .
5 Bob i
& Susan Y=
7 Sam i
8  Enin —
8 Andrew i
10 Spencer et
11 Alex
12 Daniel Vel
13 TOTALS

14
15 1st Quarter Expenses

16 Rent 1400

17 Advertising 652

18 Telephone 129

20 Salaries 950

21
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Figure 3-10: Paste only the value, not the formula with the Paste Special feature



Build a Formula with the Function Wizard

Build a Formula with the Function
Search for a function:
s Type a brief description of what you want to do and then E
l z ar click Go
Qr seleck a cakegary: | Financial
. I d
1. Select the cell where you want to enter a function; then st afunciion [y
choose Insert>Function. The Insert Function dialog box iz Date 5 Tine
| Math & T
appears. 1ipeR ccatistcal
IPMT Lookup & Reference
2. Select a function category from the Or Select a Category frev perese
drop-down list. (See Figure 3-11.) PMT(ratenper v tion
Calculates the payment For aloan based on constant payments a
constant interest rate.

To make the functions easier to locate, Excel separates them into

categories including Financial, Date, Math & Trig, Stafistical, Lookup Figure 3-11: Selec from over 230 huftin

and Ref, Database, Text, Logical, and Information. For example, fundtions
the Sum function is in the Math category, while Average, Count,
Max, and Min are Statistical functions. Functions that calculate a TR T e 99663 "0 b
payment value are considered Financial functions. = WY vy
= J P s S
A E F G H =
3. Select a function name from the Select a Function list. e me . B
A brief description of the function and its arguments ooty Wit iols | 0%
appear under the list of function names. 5 st woou
4. Click OK. The Function Arguments dialog box displays. I
The Function Arguments dialog box you see depends on 2
the function you select. Figure 3-12 shows the PMT func- i
tion that calculates a loan payment based upon constant % S T ——
payments and interest. 1 —
16
5. Type the first argument amount or cell reference or click 7
the cell in the worksheet. If you click the cell, Excel places 19
a marquee around the selected cell. o
22 e al A L
Press Tab to move to the next argument. [T — sgiscmnseal X :
Type or select the second argument. Figure 3-12: Specifying arguments for the PMT function

Repeat Steps 6 and 7 for each necessary argument.

e NS

Click OK. Excel calculates the result based on the
arguments you specified.
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Generate an [F Statement Formula

1.
2.

10.

28

Select a cell where you want the formula result.

Type the equal sign and then the word IF.

You could also use the Function Wizard to help create an T F state-
ment. Excel considers T F° statements a logical function that contains
three arguments. The first argument determines whether o speci-
fied condition is met. If the condition is met (or TRUE), then the
function returns the value specified in the second argument; if the
condition is not met (or FAL SE), then it returns the values spec-
ified in the third argument.

Type an open parenthesis (.

Begin the first argument by referencing the cell you want
to check. For example, if you want to check that cell B10
is greater than 100, type B10.

Type an operator such as equal to (=), greater than ( >),
or less than (<) and then the value you want to compare.

Type a comma to begin the second argument.

Type what you want Excel to do if the first argument

is true. If you want Excel to display a value or cell

value, type the value or cell reference, but if you want
Excel to display text, enclose the text in quotation marks.
(See Figure 3-13.)

Type a comma to begin the third and final argument.

Type what you want Excel to do if the first argument is
not true.

Press Enter. Excel displays the results of the analysis in
the selected cell. In Figure 3-14, you see the result of No
in cell B8 because the payment amount was not less
than the limit.
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3 monthly interest rate 0.42%
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5 payment amount | 394356
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Figure 3-13: Entering I F stafement arguments
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Figure 3-14: The results of a statement that was not true



Troubleshoot Formula Errors

Troubleshoot Formula Errors

1.

Select the cell with an error message. A Smart Tag, like
the one in Figure 3-15, appears.

Click the Smart Tag. A list of options appears. See
Chapter 15 for more information on Smart Tags.

Depending on the error type, edit the formula as needed:

DIV/0!: Divide by zero error. This error means the

formula is trying to divide by either an empty cell or
one with a value of zero. Make sure all cells referenced
in the division have a value other than zero in them.

#VALUE!: This error means the formula is referencing
an invalid cell address. An example might be if text is
in a cell and the formula is expecting a value. You
may also see this error if you delete a value in a cell
that was used in a formula. Locate and correct the
invalid cell reference.

NAME#: This error occurs when Excel doesn’t recog-
nize text in a formula, perhaps from a misspelling of
a range name. Make sure the text name actually exists
and is spelled correctly. Also verify the spelling of the
function name to make sure it is accurate.

Circular: This means that the formula in a cell is
referring to itself. Locate the circular reference and edit
the formula so it does not include itself. Figure 3-16
shows a circular reference.

To help determine the nature of the problem or where the problem
originates, click the drop-down arrow on the Smart button and dlick
Show Calculation. Steps display the logic behind the formula.
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(%) Eite L8 View nesvi Format Toals [uta Windoew  Haip L AL
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T
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Figure 3-16: A formula referring to its own cell address 29
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Audit Formulas

1.

30

Choose Tools=>Formula Auditing=>Show Formula
Auditing Toolbar. Excel displays the Formula Auditing
toolbar. (See Figure 3-17.)

Pause the mouse over each tool to see ifs function.

Select a cell.

To trace where formulas refer to the selected cell, click the
Trace Dependents icon. Blue tracer arrows like the ones
you see in Figure 3-18 appear on the screen. The arrows
indicate that both cells B6 and B9 use the value in cell B2.

Red arrows indicate cells that cause errors and a black arrow points
from the selected cell to a worksheet icon if the selected cell is ref-
erenced by a cell on another worksheet or workbook.

Dependent cells are those that contain formulas that refer to other
cells. Precedent cells are those that are referred to by a formula in
another cell.

Click the Remove Dependent Arrows icon to remove the
dependent tracer arrows.

Select the cell that contains the formula for which you
want to find precedent cells.

Click the Trace Precedent icon. Arrows appear indicating
which cells are used in the selected formula cell.

Click the Remove Precedent Arrows icon to remove the
precedent tracer arrows.

To close the Formula Auditing toolbar, choose Tools=>
Formula Auditing=>Show Formula Auditing Toolbar.

Bidr AR N )= ey Re g |

Figure 3-17: The Formula Auditing
toolbar
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Figure 3-18: Tracer arrows
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Formatting Cells
and Data

Whoever said “Looks aren’t everything” didn't stare at an unformatted
Excel spreadsheet. Columns often aren’t wide enough, fonts are too
small to read, dates display in an unusual manner, and when you have
columns of data stacked next to each other, sometimes the information
begins to overlap.

Fortunately, Excel includes a plethora of features to make your data look
more presentable and easier to read. Here are some of the Excel formatting
features you'll discover in this chapter:

== The ability to change the font type, size and style of text, values,
or dates.

w= Change the alignment of data in a cell from the standard left aligned
for text and right aligned for values or dates.

w= Create titles using the Excel Merge and Center button.
m= Change column width and row heights.
w= The ability to use Excel’s predefined AutoFormats.

== The use of styles for report consistency.

| “*\apter

Get ready to. . .

w= Format Values

w= |ndent Data in Cells

w= (reate a Title by Merging Cells
w= Select Font Atiributes
e Wrap Text in a Cell

w= Rotate Text

w=Work with Date Formats
= Adjust Column Width
= Change Row Height

w= Copy Formatting

w= |Jse AutoFormats

= Manage Formatting Styles

34
34
35
35
36
36
3
3
38
39
40
40



Chapter 4: Formatting Cells and Data

Align Data

Select the cells you want to align.
Click an alignment button on the Formatting toolbar:
o Left: Lines the data along the left edge of the cell.

e Center: Centers the data in the middle of the cell. If
you modify the column width, the data remains cen-
tered to the new column width. Cells B4 through F4
are center aligned in Figure 4-1.

¢ Right: Lines the data along the right edge of the cell.

Values formatted as currency or commas can only display as right
aligned.

Format Values

1.
2.

34

Select the cells containing values you want to format.

On the Formatting toolbar, click the Currency Style,

Percent Style, or Comma Style button. Figure 4-2 shows
values in column B, C, and D in Comma Style; column
E is in Currency Style; and column F is in Percent Style.

Cells displaying ###### indicate the cellis not wide enough fo display
the complete number. Widening the column displays the number.

To remove digits to the right of the decimal point, click

the Decrease Decimal button on the Formatting toolbar.

Each click removes the number to the far right of the
decimal point. Click enough times and the decimal
point disappears.
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Figure 4-1: Text and values center aligned
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Figure 4-2: Cells formatted af currency, comma, and percentage



Create a Title by Merging Cells

Indent Data in Cells

Select the cells you want to indent.

Click the Increase Indent button on the Formatting tool-
bar. Notice in cells A6 through A9 and A13 through A18
of Figure 4-3 that each Increase Indent click adds a
small amount of space between the cell border and the
data itself. How Excel indents depends on how you for-
mat the cell:

o If the data is left aligned: Excel indents to the left.
o If the data is right aligned: Excel indents to the right.

o If the data is centered: With the first click, Excel
indents to the right, but subsequent clicks cause
Excel to move the data to the left.

(lick the Decrease Indentation button to remove indentation.

Create a Title by Merging Cells

1.

Select the cell containing the data you want to merge
and the cells you want to include in the merge. The data
cell must be in the left cell of the selection and the
other cells cannot contain data as shown in Figure 4-4.

Click the Merge and Center button. All the selected cells
merge into one larger cell and the data is centered.

After clicking Merge and Center, you can left or right align the cell
if you don’t want it centered.

Click the Merge and Center button again to unmerge the cells from
each other.
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Figure 4-3: Indenting helps set data apart from other cell
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Chapter 4: Formatting Cells and Data

Select Font Attributes

Select the cells you want to format.

Click the Font drop-down list. A list of available fonts
appears, as shown in Figure 4-5. By default, an Excel
worksheet uses an Arial 10 point font.

Select the font you want to use. Excel displays the
selected cells in the chosen font.

Select the font size you want to use from the Font Size
drop-down list.

Click any combination of the Bold, Italic, or Underline
buttons on the Formatting toolbar.

Click the Bold, ltalic, or Underline button a second fime to remove
the atiribute.

Wrap Text in a Cell

36

Select the cells you want to format.

Choose Format=>Cells. The Format Cells dialog box
appears.

Click the Alignment tab.

Select the Wrap Text check box from the Text Control area.

Click OK. In Figure 4-6, you see cells (A10 and A19)
with the text wrapped.

Selecting the Shrink to Fit opfion instead of the Wrap Text option
allows Excel to automatically change the font size of the selected cell,
which forces the data fo fit in the cell's current width. Use caution with
this option; the fext may become unreadable.
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Figure 4-5: Dress up your worksheet with different fonts, sizes, and attributes
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Work with Date Formats

m’m Faak 1 =~
Rotate Text =
1. Select the cells you want to format. _ . G H E
1 ABC Corporation
2. Choose Format=>Cells to display the Format Cells 2 Income Statement
dialog box. | f@
3. On the Alignment tab, in the Orientation section, drag ‘df £ L owe o
the small red arrow to indicate the rotation you want bl R o S S S
for your selected cells. S |§ 1073
4. Click OK. Figure 4-7 shows cells (B4 through D4) with e (e b i
text rotation. 5
is
17 i3 hme § 2w ;
a 18 3 n 5 3% i
Work with Date Formats g e . oo,
B - Ia il
1. Select the cells you want to format. PR ) CORARMME RIS o

2. Choose Format>Cells to display the Format Cells Figure 4-7: Rotating text adds a special effect to your worksheet

dialog box.
Format Cells Ea
3. Click the Number tab. As you see in Figure 4-8, you can e ey e v s —
select many different value formats. Category: sarsle
EE;?]V:: September 16, 2005
4. Click Date. Eg{éﬁ"nii.g
Select a date format from the Type list. Notice how the ‘E!Iftmge !
sample box displays how your data will look with the St fisiiie =
selected formatting. ] e -
;_Enghsh (United States) |zl
If none of the date styles are what you want, you can create a cus- i ——
tom date by dlicking Custom from the Category list. Then in the Type e S et LT iRt
box, type how you want the date displayed. Use m for month, d for :
day, and y for year. If you type m, Excel displays the month number.

If you type mm, Excel displays the month number with a leading
zero. If you type mmm, Excel displays the month in abbreviated
form such as Feb. If you type mmmm, Excel displays the month
spelled out in its entirety (February). Keep an eye on the Sample
box to view how Excel displays the customized date formats.

Figure 4-8: Applying date formatting

6. Click OK to apply the format.
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Adjust Column Width

38

Highlight the columns you want to change.
Choose a method to adjust column width:

¢ To manually change the width of one column, posi-

tion the mouse on the right boundary of the column
heading until the mouse turns into a black bar with
arrowheads pointing right and left. Drag the boundary
bar left or right until the column is the width that
you want. In Figure 4-9, I've expanded column A.

To set column width to a specific setting, click any-
where in the column you want to modify, and then
choose Format=>Column=>Width. The Column
Width dialog box, shown in Figure 4-10, appears.
Type the exact width you want; then click OK.

Excel displays cell width in characters and pixels instead of in
inches.

To automatically change the width of the column so
it fits the widest entry in the column, double-click
the boundary on the right side of the column head-
ing or select the columns; then choose Format>
Columnr>AutoFit Selection.

The default column width is 8.43. To change the default column width
on the current worksheet, choose Formatc>ColumncoStandard
Width. Enter the new width; then click OK. All columns, not already
manually changed, change to the standard width you specified.
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Figure 4-9: Manually changing column width
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Figure 4-10: Set a
specific column width



Change Row Height
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1. Highlight the rows you want to change. i ' B o B A
1 ABGC Carparation
2 Income Statement
Optionally, select the rows and choose Formatc>Row=>AutoFit. 2 r
4 & e?j* @'ﬁ & &
5 Revenues
B East . 4287520 49,421.25 56,834 43 514923028 30%
oA West 37 48535 43,107.75 48,573,917 $130,167.01 26
1 1 . 8 Marth P 28,994,714 3334310 38344 50 $100,681.74 20%
2' Choose a methOd to adJUSt row helght 9 _ South 49.722.00 4298400 26,08102 511878702 24%
¢ To manually change the height of a single row, position 10 15217669 16885610 17083386 $496.860.65
. 11
the mouse on the boundary under the row heading 12 Expensss
until the mouse turns into a black bar with arrowheads Wy AABLELA SLCAE SATIE AL SN
] ] 1 15 Office Expense 980,98 1127 40 129600 3 340438 1%
p01nt1ng. up and Flown. Drag the bounda:ry bar untll 16 Litilties 112377 1,281.a5 148516 § 380038 1%
the row is the height that you want. In Figure 4-11, 17 Auto Expense 179454 206310 237256 S 623020 1%
18 Other 1,420.00 1,783.00 155500 5 475800 1%
I expanded row 10. T Eumancns  usi97aR mxdnann  engn s <snsnn e of
Oprw=, o AotuShopes o s D1o o AL 8 -l A ST M8
Row height is measured in points and depends on the font you are Figure 4-11: Changing row height

using. The default font of Arial 10 point, uses a default row height
of 12.75, but Excel automatically adjusts the row height when you
select a font larger than the cell height.

"Row Height | %]

R height: 25
e To set row height to a specific setting, click anywhere i
in the row you want to modify or highlight the desired Figure 4-12: Enter
rows; then choose Format>Rowr>Height. The Row a desired row height

Height dialog box opens, as shown in Figure 4-12.
Type the exact height you want; click OK. The row
changes to the height you specified.

e To automatically change the height of the row so it
fits the tallest entry in the row, double-click the
boundary on the bottom of the row heading.

The square to the left of column A and above row 1is called the Select
All square. To change the row height for all rows in the worksheet,
click the Select All square and follow the steps fo change all rows.
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Copy Formatting

1.

2.

Select a cell that has formatting you want to copy.

Click the Format Painter tool on the Formatting toolbar.
A marquee surrounds the selected cell and the mouse
pointer turns into a paintbrush (see Figure 4-13).

Click the cells you want to format. Excel immediately
applies formats such as font, size, color, borders, and
alignment.

Double-click the Format Painter fool to lock it in so you can paint
additional cells without having to reselect the tool. Click the tool
again to unlock it.

To quickly copy the width of one column to another column, select
the heading of the first column, click the Format Painer tool, and
then click the heading of the column that you want to apply the col-
umn width to.

Use AutoFormats

40

Select the spreadsheet data.

Choose Format=>AutoFormat. The AutoFormat dialog
box appears.

Select an AutoFormat style.

Click the Options button. The AutoFormat dialog box
expands as shown in Figure 4-14.

Uncheck any AutoFormat formatting options you don't
want to use.

Click OK. Excel applies the formatting you choose to
your selected data.
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Figure 4-13: Copying formatting with the Format Painter tool
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Figure 4-14: Save fime with AutoFormat




Manage Formatting Styles

E]

Manage Formatting Styles i e e e e

1. Select a cell with formatting and choose Format=Style.
Excel displays the Style dialog box shown in Figure 4-15.

ABC Corporation
Income Statement

L]

2. In the Style Name text box, type a descriptive name for
the style such as category, salesperson, or heading.

|East
West 3748535
orth 2R584.14

o~ AW -

3. Remove any check marks from the formatting categories e iy

you do not want to save with the style. You can retain 10{Total Revenues 12817633 § 283 SRR =
any combination of formatting for a style including - St o —=
. penses
number style, alignment style, font style, border style, 15 Supplies 3256781 45205 4308085 11308051
. 14 Wages B440.25 H708 111618 25930815
pattern style, and whether the cell is protected when the 15 OMceExpense  S0088 11274 1205 340436
. 16 Utflities 112377 1281 45 1485496 300038
worksheet is protected. 17 AuloExpense 179454 20831 237256 62303
18 Other 420,91 483 55545 14655
4_ Clle the Add button and then C]iCk ClOSQ. 19 Total Expenses  45328.05 52123 59940.52 157391.90
20 I -
4% 0 W, S e (3 S TS St Te i
To apply the styles to worksheet cells, select the cells G O KA it d e

you want to have the format style. Figure 4-15: Creafing a syle

6. Choose Format=>Style to display the Style dialog box.

Select the style you want to use from the Style Name
drop-down list (see Figure 4-16).

To remove a style, select the style name and dlick Delete. Cells for-
matted with a style revert to the Normal style.

Click the Modify button to change any of the existing format
options.

8. Click OK. Excel applies the style you selected.

W3 o S ) et S o ([ |
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Figure 4-16: Select a style name from the list
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Adding Color and
Graphics

Sometimes, even after adding font and style attributes to cell data, you still
need to call extra attention to specific areas. How about adding a little
color to the cell data? Or instead of modifying just the data in the cell, how
about making alterations such as adding a background color or a border?

And if that's still not enough, you can draw an arrow to point to a specific
area. What? You can't draw a straight line? That's not a problem because
with Excel, you don't have to be a gifted artist to draw. Whether you want
to draw circles, squares, lines, or arrows, Excel provides tools to assist you,
making the drawing process fun and easy.

In this chapter, you discover how to

m=  Add color or lines to text or cells, bringing contrast to particular por-
tions of your worksheet.

w= Use Excel’s conditional formatting feature. With this function, you can
have Excel do the legwork for you when searching for specific criteria
and flag you by applying special formatting to the cells containing the
criteria you're looking for.

»= Draw arrows, shapes, and annotation boxes, all of which you can add
depth to with shading and dimension.

»= Insert clip art, which is a collection of ready-made computerized graphic
illustrations, or your company logo and your viewers will sit up and
take notice of your worksheet.

| “*\apter

Get ready to. . .

w= Use Font Color

w= Apply Shading to Cells

w= Place Borders Around Cells ..

w= Specify Conditional Formatting ..................

web [[lustrate with Arrows ..........

w= Annotate with Text Boxes ....

= Draw AutoShapes

= Shade Your Drawings ..........

w= Make Objects 3-Dimensional

w= [nsert Saved Images
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e Add Clip Art
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w= Manipulate Graphics
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Chapter 5: Adding Color and Graphics

Use Font Color

1. After selecting the cells you want to change the text
color, choose Formate>Cells.

Click the Font tab.

Select a color from the Color drop-down list, as shown
in Figure 5-1.

4. Click OK.
Optionally, click the Font Color icon from the Formatting toolbar

(to add data color) or the Fill Color icon (to add color fo the cell
background).

Apply Shading to Cells

1. After selecting the cells you want to add background cell
color to, choose Format=Cells.

Optionally, click the arrow next to the Fill Color button on the
Formatting toolbar and select from a broad variety of different shad-
ing colors. Select No Fill from the options to remove any cell coloring.

2. Click the Patterns tab (see Figure 5-2), select a shading

color.
You can add a background pattern to the selected cells by selecting
a fill pattern from the Pattern drop-down list. The color box under
the pattern choices represent the second color used in the pattern.
3. Click OK.
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Format Cells (8[%]
Number | Alignment: | Fent | Border | Patterns | Protection
| Eort: Farlt style: Size:
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Figure 5-1: Choosing a font color
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Figure 5-2: Select a color for the cell
background



Place Borders Avound Cells

Place Borders Around Cells e
1. After selecting the cells you want to add a border to, I —
choose Format>Cells. deg.@ ik i o

2. Click the Border tab. The Border tab appears (as shown
in Figure 5-3).

Text Text

. . Automatic |+
3. Select a line style from the Style area. Choose from solid B B 8 —
lines to dOtted, dashed, or double lines' The default The selected border style can be applied by clicking the presets, preview

diagram or the buttons sbove.,

option is a thin solid line.

4. Select a color for the cell border from the Color drop- Fiaure 5-3: Creafing border fines for cel
down list. The default color is black. gure 5=3: Liedling horder fines for (¢1s

5. Select a Preset option:

e Qutline: Place the border around the outside of the 1
selected cell range. o F L@ i i
. . ABC € i —E0n
Inside: Place the border along the inside cells of the ; Imm:;f:::;::* P
cell range. 3 : :
4 Tamiiiary Fabmany Harily Tetala Fatin
5
You can optionally select both Outline and Inside to place a border 2 o
around each individual selected cell. 2| s
6. Instead of, or in addition to the Preset options, select ?ﬁ-
any of the options in the Border section to apply a ;
border of a specific type, such as a diagonal, center, '
or bottom underline. -1 - U Vil ipihasal Whghiors
7. Click OK. T ot e i 1a i
Dorwe s fanshones: o ACICE A Al A S EER
Optionally, click the drop-down arrow next to the Border butfon on Figure 5-4: The Border button on the Formatting toolbar

the Formatting toolbar. As you see in Figure 5-4, you can select
from a number of predefined border styles.

Excel also includes a Tables and Borders toolbar from which you can
select border options. Choose View=>Toolbars=>Tables and Borders.
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Specify Conditional Formatting

1.

46

Select the cells you want to apply conditional format-
ting to.

Ideas for using conditional formatting include locating dates that
meet a certain condition, such as falling on a Saturday or Sunday,
specifying highest or lowest values in a range, or indicating values
that fall under or over a specified amount.

Choose Format=>Conditional Formatting. The
Conditional Formatting dialog box, shown in
Figure 5-5, appears.

Select the criteria you want to use from the second drop-
down list in the Condition 1 area. Criteria options include
Equal To, Greater Than, Less Than, and Between.

Enter the values you want to reference in the text box.
The number of boxes depends on the condition you
selected in Step 3. You can type a value here, such as
500, or you can reference a cell address, such as F13.

Click the Format button, which displays a modified ver-
sion of the Format Cells dialog box.

Specify the format options you want to apply if the con-
dition you specified is true. You can select from font
styles, size, borders, patterns, or background color.

Click OK. A sample of your format appears in the Sample
area.

Click OK to apply the conditional formatting or click
Add to save the condition. Figure 5-6 shows formatting
options applied to two cells with the specified criteria of
being less than 30,000.

To clear conditional formats as well as all other cell formats for
selected cells, choose Editc>Clear=Formats.

Conditional Formatti

Condition 1

Cellvalue Is |w| [less than [+ |30000

|

==

Preview of Farmat to use |

when condtion s krue: blosEcfmat set

[ add>> | [ pelete.. ] [ ok

Figure 5-5: Specifying conditions for formatting options
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Figure 5-6: In this example, conditional formatting options included applying a font
color change and a background color



Iltustrate with Arrows

Illustrate with Arrows

Click the Arrow button on the Drawing toolbar. The
mouse pointer turns into a small black cross.

Click and drag the mouse pointer to draw an arrow, as
shown in Figure 5-7.

Release the mouse button, and the arrow appears on the
worksheet with a white circle at each end indicating the
arrow is selected. (See Figure 5-8.)

By default, Excel draws a black arrow with a thin line and small
arrowhead. The arrowhead appears af the end of the drawn line.

Click anywhere in the worksheet fo deselect the arrow. Click the
arrow again to reselect if.

Modify your arrow as needed by clicking these buttons
on the Drawing toolbar:

e Arrow Style: Change the arrowhead style or direction

e Dash Style: Change the line style from a solid line to
a dashed or dotted line

e Line Style: Change the arrow thickness

e Line Color: Change the arrow color

To delete the arrow, click it and press the Delete key on the
keyhoard.

See the “Manipulate Graphics” section later in this chapter fo mod-
ify the arrow size, posifion, or direction.
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Figure 5-7: Drawing an arrow
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Figure 5-8: A selected arrow
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Annotate with Text Boxes

1.

48

Click the Text Box tool on the Drawing toolbar. The
mouse pointer appears as an upside down cross.

Click and drag diagonally to draw the box the approxi-
mate size you want it. You can resize or move it later if
necessary. When you release the mouse button you see a
text box like the one in Figure 5-9.

Type the desired text.

Click outside of the text box to deselect it.
Depending on the text box size and location, the fext box may
cover up worksheet cells. See the “Manipulate Graphics” section to
see how to move it out of the way.

Right-click the text box and choose Format Text Box.
You see the Format Text box, as shown in Figure 5-10.

Optionally, if you want to format only a portion of the fext, select
the text before displaying the Format Text dialog box.

Select and modify any desired options in the Format
Text box. Chapter 4 shows you how to use the Format
Text dialog box.

To make the text hox size fit automafically around the text, select
the Alignment tab in the Format Text dialog box and check the
Automatic Size options.

Click OK.

To delete the fext box, click it and press the Delete key on the
keyboard.
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Figure 5-9: Annotate worksheet issues with fext boxes
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Shade Your Drawings

W T T . :
Draw AutoShapes ] Ele L8N Vew el Foman Todls Dua Wiadew elp rr
1. Click the AutoShapes button on the Drawing toolbar. Z. i B
1 ABC Corporation
2. Select an AutoShape category and then select an 2 Income Statement
AutoShape (see Figure 5-11). ;3 R e
3. Click and drag diagonally to draw the object the size 3 ey ik s
you want it; then release the mouse button. Bl truir H
10 'Total Revenuss £
Select the AutoShape and begin typing to add text to the shape. 12 Exponaes i -
: =
To delete the AutoShape, click it and press the Delete key on the ; *
keyhoard. =
(=2~}
4 M ER More AuiShapes.. ;lo | o 1é |
See the “Manipulate Graphics” section later in this chapter fo resize, e eI
rotate, move, or crop the AutoShape. Figure 5-11: Select from over 130 different shapes
- ﬁ‘:;-‘l:_m-:“:ﬁlun Foman Tl Duta Windes Nalp 3 _o x
Shade Your Drawings T
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1. Select the drawn AutoShape, text box, or arrow. Click 1 ABC Corporation
the Shadow Style button on the Drawing toolbar. 2 Income Statement
3
2. Select an option. As shown in Figure 5-12, the object e — [y Bl v
takes on a shadowed appearance. :
7]
3. With the shadowed object selected, click the Shadow -
Style button again and click the Shadow Settings button. A
This displays the Shadow Settings toolbar. 13| sianlos
15
4. From the Shadow Settings toolbar, click any button to L
further modify the shadowed object, such as, turn the 1, M T : Gl lemsR
shadow on or off; increase the shadow direction left, 2 P S iy v ::::.
right, up, and down; change the shadow color. = - L SRES ]

Draw: s AwioShupes: 0 2 OO A NS M AS TS
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Figure 5-12: Adding shadow effects to objects

5. Click the Close box on the Shadow Settings toolbar to
put it away.
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1. Select the drawn AutoShape or text box. ] A ] c G] S B S
ABC Corporation -
Click the 3-D Style button on the Drawing toolbar. Income Statement '
[ Tmary Fabniary Marih Tetsla Fatin |

Select an option. The object takes on depth giving the
impression of a 3-dimensional object.

1

2
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5 |Revenues
B 5
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4. With the object still selected, click the 3-D Style button
again and click the 3-D Settings button. The 3-D Settings
toolbar displays.

5. From the 3-D Settings toolbar, click any button to fur-
ther modify the object (see Figure 5-13):

19 Total Expenses

20
e Tilt: Controls the object rotation up, down, left, 2w prom
or right ot LSS,

""L.LEQE!"E LAOCH AN g A ST A

e Depth: Increases or decreases the depth of the Figure 5-13: Adding depth fo objedts

3-D object
e Direction: Changes the object perspective TP - S |
. Lighting: .Displays the 3-D object as though a light SF JW‘ Ji' ‘&1}‘: — |
were shining on it R e
e Surface: Gives the object surface the appearance of E:;‘:.,

solid matte to wire frame, plastic, or metal v ? ﬂ d

e Color: Select the object color iy
.

i Cnepeter

o TUme s mmE .

Tl e -l

Insert Saved Images L T 1 =

Figure 5-14: Use this feature to insert your company logo onto
1. Choose InsertcoPicturecoFrom File. a worksheet

CCHANGELR.

2. From the Insert Picture dialog box shown in Figure 5-14,
select the picture you want to place in the worksheet.

3. Click the Insert button. Excel places the picture on the
worksheet.
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Add Clip Art

Add Clip Art

1.

Choose InsertroPicturer>ClipArt. The Clip Art task pane
appears on the right, as shown in Figure 5-15.

In the Search For box, type a brief description of the
type of image you want, such as food, buildings, or
people.

Choose where you want Excel to search for the clip art
from the Search In drop-down list:

e My Collections: Includes searching in your private
folders such as Favorites and My Documents.

e Office Collections: Includes clip art installed with
the Microsoft Office application. These choices are
organized by category.

e Web Collections: Includes clip art from the Microsoft
Office Web site.

Choose the type of image you want from the Results
Should Be drop-down list. Excel can locate clip art,
photographs, movies, or sound files.

Click the plus sign next to any image type to further define the
search opfions.

Click the Go button. Excel displays a number of images
representing the art you specified, such as the images in
Figure 5-16.

Select the desired image. Excel places the image onto
your worksheet.

See “Manipulating Graphics” later in this chapter to resize, rotate,
move, or crop clip art or other images.
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Figure 5-15: Searching for clip art
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Figure 5-16: Placing dip art onto your worksheet
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Manipulate Graphics

1.

3

52

Select the object you want to modify. Small white cir-
cles, called handles, appear around the perimeter of a
selected object. Arrows typically have two selection han-
dles while other objects, including images, have eight
handles. Objects other than arrows also have one small
green circle called a rotation handle. Figure 5-17 shows
a selected object.

Perform any of the following actions:
e Delete: Press the Delete key on the keyboard.

* Move: Position the mouse pointer over the object,
but not on the handles. Click and drag the object
to the desired location.

e Resize: To resize an object, position the mouse
pointer over one of the white selection circles and
drag the circle until the object is the desired size.

¢ Rotate Shape: Drag the green rotation handle until
the object rotates to the desired angle. This does not
apply to arrows.

¢ Rotate Arrow: Drag either of the white circles in the
direction you want to rotate.

e Crop: From the Picture toolbar (see Figure 5-18),
select the Crop tool and drag a corner, top, bottom,
or side until the unwanted picture portion is
removed.

Click the Reset Picture button on the Picture toolbar fo restore a
picture to ifs original seffing.

Click anywhere outside of the graphic to deselect it.
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Working with
Workbooks

A llow me to begin by clearing up a couple of terms. There are worksheets
(sometimes called spreadsheets), which are a single collection of cells
with up to 65,536 rows down and 256 columns across. Therefore, each
worksheet can contain up to 16,777,216 cells of data.

Secondly, there are workbooks, which are a collection of worksheets. By default,
each time you create a new Excel workbook, it contains three worksheets.
Each workbook however, can have up to 256 worksheets. The resulting possi-
ble number of cells in a single workbook is too huge (over 4 billion!) to even
think about, but the fact remains you could create a single huge workbook.
Realistically though, you'll probably have a number of different workbooks,
each with a number of worksheets.

This chapter is primarily about working with multiple sheets. You discover
how to insert, delete, move, and copy worksheets, move among the sheets,
rename the tabs that reference them, and create formulas that reference
other worksheets or workbooks.

It's also about protection. Throughout this chapter, you find out about secu-
rity protection in the form of hiding rows, columns, single worksheets, or
even entire workbooks. Discover how to lock a sheet so you or others don't
accidentally overwrite critical formulas or other data. I even show you how
to protect a workbook with a password so others cannot see it or modify it.

Finally, I show you how to create hyperlinks to Web sites, other cells or
workbooks, or create an instant e-mail.

| “%ap’fer

Get ready to. . .
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Chapter 6: Working with Workbooks

Insert Additional Worksheets

1. Right-click a worksheet tab and choose Insert. The Insert
dialog box appears.

Optionally, choose Insert=>Worksheet.

2. Click Worksheet; then click OK. Excel inserts a new
worksheet. Excel names by default the first three work-
sheets Sheet1, Sheet2, and Sheet3, so new worksheets
pick up the next number such as Sheet4. You can give
your worksheet a more appropriate name. See the
“Rename Worksheets” section.

3. Click a tab at the bottom of the worksheet. That work-
sheet becomes the current sheet (see Figure 6-1 where
Sheet4 is the current worksheet).

Optionally, press Ctrl+PageUp or Cirl+PageDown to move between
worksheets.

Delete Worksheets

1. Choose Edit=>Delete Sheet. A warning message appears
as shown in Figure 6-2.

Aworksheet with no data on it doesn't display the warning message.

2. Click the Delete button.

You may want fo save your workhook before you delete a worksheet.
The Undo feature does not work with the Delete Sheet function.
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Rename Worksheets

Copy Worksheets

1. Right-click the tab on the worksheet you want to
duplicate. Choose Move or Copy from the menu. The
Move or Copy dialog box appears.

Check the Create a Copy box. (See Figure 6-3.)

Select where, in the order of the worksheets, you want
the duplicate sheet placed.

4. Click OK. Excel adds another worksheet exactly like the
current one and names it with a (2) next to it.

Select a different open workbook from the To Book drop-down list
in which to place the selected worksheet.

To quickly move sheets within the current workhook, you can drag
the selected sheet fabs along the row of sheet fabs. To copy the
sheets, hold Cirl, and then drag the sheet tabs, releasing the mouse
button before you release Ctrl.

Rename Worksheets

1. Click anywhere in the worksheet you want to rename.

2. Choose FormatoSheettoRename. The worksheet tab
becomes highlighted.

3. Type a unique name for the worksheet, as shown in
Figure 6-4. Two worksheets in a single workbook cannot
have the same name.

Worksheet names can contain spaces and many special characters
such as a dash or number sign, but they cannot contain the slash
(/), backslash (\) or the asterisk (*).

4. Press Enter to accept the change.
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Create a copy

Figure 6-3: Duplicating
a worksheet
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Chapter 6: Working with Workbooks

Change Worksheet Tab Colors

1.

To assist in organizing multiple worksheets, click any-
where in the worksheet you want to recolor the tab.

Choose Format=>Sheet>Tab Color. The Format Tab
Color dialog box, shown in Figure 6-5, appears.

Select a color.
Click OK.

When a worksheet with a colored tah is the current worksheet, Excel
does not display the tab color in full. It displays only a colored line
under the fab name. The fab becomes full color when it is not the
active worksheet.

Hide and Unhide Worksheets

1.

56

Click anywhere in the worksheet you want to hide (hold
Ctrl for multiple worksheets).

Optionally, to hide all but one worksheet in a workbook, right-dick
a sheet tab and choose Select All Sheets. Then press Cirl and click to
deselect the sheet you do not want fo hide. A workbook must con-
tain at least one visible worksheet.

Choose Format>SheetvHide. Excel hides the worksheet
from view. All formula references to a hidden worksheet
are still valid even when a worksheet is hidden.

To unhide the worksheet, choose Formatr>Sheetr>
Unhide. The Unhide dialog box, shown in Figure 6-6,
appears, listing all the currently hidden worksheets in
the active workbook.

Select the worksheet you want to unhide.
Click OK.

Format Tab Color
Tab Color

No Color

Figure 6-5: The Format
Tab Color dialog box

Usiliile B

Unhide sheeti
(G

o]

Figure 6-6: Select a worksheet to unhide



Redisplay Rows or Columns

Hide Rows or Columns

1. Select the column or row headings you want to hide.

Press Cirl to select multiple contiguous or noncontiguous rows or
columns.

2. Choose Format>Column>Hide to hide columns or
Format>Rowr>Hide to hide rows. Notice in Figure 6-7
how column D seems to have disappeared.

All formula references in or referring to hidden columns or rows are
still valid even when hidden.

Excel gives hidden rows a row height of 0 and hidden columns a col-
umn width of 0.

You cannot hide selected cells. It must be an entire row or column.

Redisplay Rows or Columns

1. Select the columns before and after the hidden column, or
the rows above and below the hidden row. In Figure 6-8,
because column D is hidden, I selected columns C and E.

To unhide Row 1 or Column A, choose Edit=>Go To. In the Reference
box, type Al, and then lick OK. Then proceed fo Step 2.

To redisplay all hidden rows at the same time, click the small gray
square above row 1 and fo the left of column A, and then follow

Step 2.

2. Choose Formate>Column=Unhide to unhide a column
or Format>Row=>Unhide to redisplay hidden rows.
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Unlock Cells

1. Select the cells you want to allow users to modify after
you apply worksheet protection.

When you apply worksheet protection, Excel assumes cells are
locked unless you specify which cells you want unlocked. You need
to unlock these cells before you apply worksheet profection.

2. Choose Format=>Cells, which displays the Format Cells
dialog box.
Click the Protection tab, as shown in Figure 6-9.

4. Deselect the Locked option.

5. Click OK.

Relock Cells

1. Unprotect the worksheet if protected. (See the next sec-
tion, “Protect Worksheets.”)

You may be prompted for a password to unprotect the worksheet.

Select the cells you want to relock.
Choose Format>Cells.

4. Click the Protection tab and select the Locked option
(see Figure 6-10).

Click OK.
6. If needed, apply worksheet protection again.
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Protect Worksheets

Protect Worksheets

1.

Click anywhere on the sheet you want to protect.
Choose Tools=>Protection=>Protect Sheet. The Protect
Sheet dialog box appears, as shown in Figure 6-11.

A good reason to protect a worksheet is fo protect formulas from
accidental changes.

Verify the Protect Worksheet and Contents of Locked
Cells box is checked.

Optionally, type a password to allow a user to unprotect
the worksheet in the Password to Unprotect Sheet box.

Passwords are case sensitive.

From the Allow All Users of the Worksheet To box,
select any options a user is allowed to change without
unprotecting the worksheet.

Deselecting the Select Locked Cells option doesn't allow an unau-
thorized user fo even click a locked cell.

Click OK.

If you generated a password, a Confirm Password dialog
box appears. Retype the password and then click OK
again.

Try to change a locked cell in a protected worksheet.
Excel displays the error message in Figure 6-12.

To unprotect the worksheet, choose Toolsw> Protection>
Unprotect Sheet. Excel prompts you to enter the pass-
word if you originally supplied one.

Protect worksheet and contents of Iocked calls
Password ko unpratect sheet:

Allow all users of this worksheet to:

[ select locked cells |~]
[¥] Select unlocked cells il
[ Farmat cells

|[JFormat columns

CIFarmat rows

|[insert columns

[ 1nsert rows

| 1nsert hyperlinks

[ oelete columns 1
\Cpslete rows sl

Protect Sheet

Figure 6-11: Profect a single
worksheet
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Create File Passwords

1.
2.

3.

10.

11.
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Choose Filer>Save As. The Save As dialog box appears.

Click the Tools button and then select General Options.
The Save Options dialog box appears (see Figure 6-13).

Type a password in the Password to Open text box if you
want users to enter a password before they can even open
and view the workbook.

Type a password in the Password to Modify text box if
you want users to enter a password before they can mod-
ify the workbook. Users must have the workbook open
before they're prompted for the password to modify.

Click OK.

Retype the password to open; then click OK.
Retype the password to modify; then click OK.
Click the Save button.

Click the Yes button if you're prompted to overwrite the file.

Open the password-protected file and the Password dia-
log box opens, as shown in Figure 6-14.

Type the password and click OK. If you opted for a
password to modify, Excel prompts you for the modify
password.

Type the modify password and click OK. The protected
file opens.

To remove passwords, repeat Steps 1 through 5, but make the pass-
word hoxes blank.
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Figure 6-13: Protecting a workhook from unwanted viewing
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“Book 1.xls' is protected.

Password: | ewees

Figure 6-14: Enter the
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Include a Reference in a Formula

Generate a Reference to
Another Worksheet

L.
2.

Click the cell in which you want to create a reference.

To display a value located in a cell on a different work-
sheet, but in the same workbook, type the equal sign (=).

Click the worksheet tab containing the cell you want
to reference and then click the actual cell you want to
reference.

Press the Enter key. In the current cell, Excel displays the
equal sign, the worksheet name, an exclamation point,
and the cell reference. (See Figure 6-15.)

To display a value located in another cell on the same worksheet,
type the equal sign and then the cell address; for example: =B45.
If the value in B45 changes, the cell with the reference to B45
changes also.

Include a Reference in a Formula

1.

To include in a formula a cell located on a different
worksheet but in the same workbook, begin the formula.

Click the worksheet containing the cell where you
want to position the distant cell reference; then click
the actual cell.

Finish the remainder of the formula. Figure 6-16 illus-
trates an example of a formula using a reference to a
different worksheet.

Formulas referencing other worksheets or other workbooks can
also be compound formulas or used in a function.
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Cross-Reference Other Workbooks e e e o e e Z 5
1. Open the workbook to which you want to refer (for _ == ey
example, Workb00k2). ; | January - March _—:E;rﬂl:"lio?:];‘f
2. Click the desired cell in the workbook you want to cre- : ?ff;l > ;::fember
ate a reference (for example, Workbook1). 2 October - December
3. In Workbook1, begin the formula or reference with an !
equal sign (=). g
10
4. If using a function or formula, enter any portion that 2
you want to precede the cross reference. 13
14
5. Click the cell that you want to reference from Workbook2. 18
6. Finish any remainder to the formula or press the Enter E
key. Excel displays the following: the equal sign, an e T T ety i wlf]
apostrophe, the Workbook? filename in brackets, the B et o AR N, AR SRR A) v
ggiﬁ(:h:ril rtlﬁglfél? rcelgasrlenr?czpl(:)cj?:)g};relb ?: e[XSC;alHelfglon Figure 6-17: Create a reference to another workbook
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Figure 6-17 for an example of a cross reference. P S W Y W N T Y R
J=A 0 E i G H=|
Excel uses absolute references (with dollar signs) when referring ! S
o other workbooks. =i Wk = Soacin Gl

Widgets - Standard
Purple Thangies
Yellow Thing GEieaim cace

=)

Other Stuf

Th skt combama Wiy 14 b 03 caree

4

5

L]

4

7. Open the workbook that contains the cross-reference. 5

Excel display the dialog box shown in Figure 6-18, " el
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prompting you to update the cross-referenced cell. SomasTo R

8. Click Update if you want Excel to check the originating

workbook for changes to the referenced cell, or click the 1
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Insert a Hyperlink

Insert a Hyperlink

1.

Select a cell or graphic object; then choose Insert~>
Hyperlink. The Insert Hyperlink dialog box, shown in
Figure 6-19, appears.

Select an option depending on what you want to link to:

e Another file: Locate and select the filename. When
the user clicks the link, the referenced file opens.

e A Web site: Enter the Web address in the Address text
box. When the user clicks the link, the browser opens
to the referenced Web page.

¢ A different cell in the current workbook: Click the
Place in This Document button, and then specify
which worksheet and cell location you want to refer-
ence. When users click this link, they're redirected to
the specified cell address.

e An e-mail: Click the E-mail Address button, and
then enter the recipient’s e-mail address and a sub-
ject. When the user clicks the link, the user’s e-mail
program starts (see Figure 6-20).

Click OK.

To remove a hyperlink, right-click the link and choose Remove
Hyperlink. The text that was entered for the hyperlink remains in
the cell.

Another method fo add a hyperlink is with the Excel Hyperlink func-
tion. In the cell where you want the link, type =HYPERLINK
(“FullPathName”, “TextToDisplay”). For example, if you type
in cell B3 =HYPERLINK(“C\practice.xls”,” Click here to open
the practice file”), cell B3 disploys C1ick here to
open the practice file,andwhenyou click
the link, it opens a worksheet named PRACTICE . XLS. Be
sure fo indude the quotation marks.
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Figure 6-19: Creating a hyperlink
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Changing Worksheet
Views 11 apter

omeone once wrote about the importance of seeing and being seen.

While I'm sure that quote referred to people, it also can apply to
your Excel worksheets. You need to see them in many different contexts.
That's what this chapter is about — seeing your workbook from different

perspectives: Get ready to. . .

m= Viewing alternatives such as zooming in or out, or seeing the work-

sheet without toolbars and other screen elements. = Zoom In or Qut

w=  Splitting your screen to see multiple sections of a worksheet at the = Split the Excel Screen ......ooooeevrrcee
same time or viewing multiple worksheets together. = Freeze Worksheet Titles
m= Freezing portions of a worksheet so you can see category or row .
. 3
headings. Hide an Open Workbook...............ccoooc.....
= Adding non-printing comments, which are similar to sticky notes for == Arrange Windows

individual cells. w= Compare Spreadsheets ..............cccccocoooo.

w=  Quickly and temporarily hiding open workbooks — perhaps to pro-

tect them from prying eyes. w= \iew Excel in Full Screen View....................

m= Creating templates that can bring consistency, such as the company »= Add Cell Comments
standards or personal preferences, to your workbooks. e Work with Cell Comments

1y 1 1
Options that change the way you view the Excel workbook. For example, w= Save as  Template

see the actual formulas instead of viewing only the formula results.
Go ahead, take a look! = Open a Template

= Customize Excel Viewing Opfions................



Chapter 7: Changing Worksheet Views

Zoom In or Out

1.

3

Choose View>Zoom. The Zoom dialog box appears,
shown in Figure 7-1.

Optionally, click the Zoom drop-down list on the Standard toolbar.

Select a magnification percentage. A higher zoom setting
makes the text appear larger so you see less on-screen; a
lower zoom setting shows more on-screen, but the data
appears smaller. Zooming does not affect the printed
data size.

You can select the Custom opfion and enter your own magnifica-
tion percentage. Zoom values are from 10 to 400.

Click OK.

Split the Excel Screen

1.

68

Click anywhere in a row and column where you want to
split your screen.

Choose WindowwSplit. Excel splits the window hori-
zontally into two or four panes each separated from
other panes, by bars. Each pane has its own set of scroll
bars (see Figure 7-2).

Drag the horizontal split bar up or down or the vertical
split bar left or right to resize the window sections.

Choose WindoweoUnsplit to remove the split or double-click any
part of the bars that divide the panes.
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Figure 7-2: Splitiing a window to view different areas of the worksheet simultaneously




Freeze Worksheet Titles

Freeze Worksheet Titles B e
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1. Choose what you want to freeze:

e Columns: Select the column to the right of the
columns you want to freeze. For example, click
cell B1 to freeze only column A.

1 03
125 HE 152 140

Febrswy  March April Moy e Ry August  Sepbember
[~ o7 07 134 126
03 5 2

1
168
116
1
1

® Rows: Select the row below the rows you want to
freeze. For example, click cell A4 to freeze rows

1,2, and 3. b == g &
e x " 5 @
e Columns and rows: Click the cell below the rows = i
and to the right of the columns you want to freeze. & b e
For example, click cell B5 to freeze both column A - i T
and rows 1 through 4 (as shown in Figure 7-3). \ 20 m. =
X . . ‘;" iob-hi.ﬂdiuxm' 29 2326 2,658 2901 F208
2. Choose Windowr>Freeze Panes. A thin black line appears Do ot . T Y A (L s A
to separate the sections. As you see in Figure 7-4, as — X - -
you scroll down and to the left, rows 1, 2, 3, and 4 and Figure 7-3: Cells above and left of the current cell will be frozen
column A remain visible even though you see rows 7 ] _
through 27 in the bottom section and columns H Tt 0w e Do D Won o S
through P on the right. - “'.”.‘L.;'. oy v T T e
I, e e B T e I L = l‘_i- =W = 5T = E ;1

LTION COMPANY

Normally, when you press the Home key, Excel takes you fo cell Al. |
 BY SALCSPLRSON

However, when Freeze Panes is active, pressing the Home key takes
you to the cell just below and to the left of the column headings.
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3. Choose Windowr>Unfreeze panes to remove the freeze
from row and column headings.
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Figure 7-4: Keep fitles visible by freezing the panes



Chapter 7: Changing Worksheet Views

=

Hide an Open Workbook

1. From an open workbook, choose Window=>Hide. The
open workbook hides from view. The Excel program
remains open as you see in Figure 7-5, but the work-
book itself doesn't display.

5 You can't find the hidden workbook name on the Window menu.

2. Choose Windowr>Unhide. The Unhide dialog box
appears, displaying a list of hidden open workbooks.

| Elis [t View jmari Formel Took [wia Wesdvw Help

3. Select the workbook you want to unhide and click OK.
The workbook redisplays.Q2

X desdir-g- A= g a8l
Figure 7-5: Hidden workbooks are open but don't display

Arrange Windows

1. Open two or more workbooks. Choose Window=>

Arrange. The Arrange Windows dialog box, shown in Biciiny
i - O Verical
Figure 7-6, appears. Dg:@
2. Make a selection: Dﬂ&““‘:‘ﬁm

¢ Tiled: The open workbooks don't overlap. Figure 7-6: Arranging

e Horizontal: The open workbooks are stacked on top fo see mulfiple worksheets

of each other.
e Vertical: Lays the open workbooks side by side.

e (Cascade: Arranges the windows to overlap each
other, keeping the title bar visible.

3. Click OK.

Maximize the workbook to return it back fo a larger size.
70



View Excel in Full Screen View

Compare Spreadsheets e e lact s = 1

1. Open two workbooks.

2. Choose Windowr>Compare Side by Side with other file-
name. The two workbooks are split horizontally on the
screen and a Compare Side by Side toolbar appears, as
shown in Figure 7-7.

3. Click the Synchronous Scrolling button to scroll the two
windows simultaneously. Click the button again to scroll
them independently.

4. Click the Reset Window Position button if you want to
reset the workbook windows to the positions they were
in when you first started comparing workbooks.

5. Click the Close Side by Side button to return the win-
dows to normal size.

Figure 7-7: Comparing duta between two different workbooks

Uiew Excel in Full Screen View X
i ABL PRODULTION COMPARY
| UNIT SALES BY SALESPERSON

1. Choose Viewr>Full Screen. Figure 7-8 shows a worksheet i
in full view. Notice the title bar and toolbars are hidden. e o, © g T ] g o e o
Besides the worksheet itself, only the row and column ' e = n
headings, the menu bar, and the Full Screen toolbar

remain.

151 a1 )

& i 104 a8

100 L] 144
0]

15

L
1

1
e Full Scnen | |

343 12 187

1

1

1

1

If you want to see a particular toolbar while in Full Screen view, TR—
choose View=>Toolbars and select the toolbar you want to use.

105 1
2. Click the Close Full Screen button to return to = e = %
Normal view. & ToTALs 239 2ms & s
m|
If you closed the Full Screen toolbar, restore the screen to normal 3

by choosing View=>Full Screen.

o0 shentd { St St |4

Figure 7-8: See more of your worksheet in Full Screen mode
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Chapter 7: Changing Worksheet Views

Add Cell Comments

1. Select the cell you want to add a comment to. Choose
Insert=>Comment. A small red arrow appears in the
upper-right corner of the cell with a yellow note.

2. Enter your comment text in the comment box. Format
the text by choosing Format>Comment.

3. Click the mouse anywhere outside of the comment box.

4. Pause the mouse over the red triangle to read the com-
ment. Figure 7-9 shows a comment.

When printing the worksheet, comments do not print.

Work with Cell Comments

1. Right-click a cell with a comment. A shortcut menu
appears.

2. Select an option from the menu (see Figure 7-10):

e Show/Hide Comments: Keep the comment visible
on-screen.

Optionally, choose View=>Comments to keep comments visible
on-screen.

e Delete Comment: Get rid of the comment.

¢ Edit Comment: Make any typing or formatting
changes to the comment.

Optionally, control how Excel manages comments by choosing

Tools=>Options and making a selection in the Comments section of
72 the View tab.
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Figure 7-9: View cell comments
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Open a Template

Save as a Template

1.

Create an Excel workbook. Templates can store cell,
worksheet and page formats, print settings, styles, the
number and type of sheets in a workbook, protected
and hidden areas of the workbook, page headers, row
and column labels, data, graphics, formulas, charts, data
validation settings, custom toolbars, macros, hyperlinks,
and workbook calculation and window view options.

Choose File>Save As. The Save As dialog box appears.
Type a name for the template in the File Name text box.

Choose Template from the Save As Type drop-down list.
Excel automatically saves the template in the default
template location (see Figure 7-11).

Click the Save button.
Close the workbook.

Open a Template

1.

Choose Filer>New. The New Workbook task pane opens.

Clicking the New button on the Standard toolbar automatically cre-
ates a new blank worksheet, not from a specially saved template.

Click On My Computer. The Templates dialog box,
shown in Figure 7-12, opens.

Click Templates on Office Online in the New Workbook task pane
to view a great collection of mostly free femplates.

Select the template you want to use.

Click OK.
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Figure 7-11: Saving a template
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Figure 7-12: Create a new file based on a template
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Chapter 7: Changing Worksheet Views

Customize Excel Uiewing Options

1. Choose Tools=>Options. The Options dialog box appears.

2. Click the View tab (see Figure 7-13) and then select any
desired options:

Show: Select the items you see on the screen such as
the formula bar or status bar. If you remove the check
mark from the Startup Task Pane, Excel only displays
the task pane if you select an option that requires it —
such as when inserting clip art.

Comments: Determine how you want to see cell
comments (see the “Work with Cell Comments”
section, earlier in this chapter).

Objects: Establish whether or not to display objects
such as arrows, clip art, or text boxes, or to show only
a placeholder for them.

Window Options: Select the Formulas option to turn
on formulas; Excel displays the formula in a cell, not
the result (see Figure 7-14). This is extremely helpful
when troubleshooting formula problems. Additionally,
select the Zero Values option to leave the cell blank
or with a dash if the cell value is zero.

Control the gridline display in the Window Options category.

Click the General tab and choose R1C1 reference style if you want
Excel to display the columns in numbers instead of alphabetic
characters.

3. Click OK.

74

Comments

O bone @ Corment indicator only
Objects

@ show all © Shaw glaceholders
Windaw cptions

[rage bresks Row & column headers

[ Formulas Qutline symbols

Gridines

—
Gridlines color: | Automatic |

Options &
Inkernational Save Error Checking Speling Security
| Caleulation Edt General | Transtion | Customlists | Chart
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[] startup Task Pare Formula bar Status bar “indows in Taskbar
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© Hide 2l

Horizontal scral bar
Vertical scroll bar
Sheet tabs

Figure 7-13: Customize Excel viewing options
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Figure 7-14: Analyze Excel formulas with formulas displayed



Sorting Data

Sometimes worksheets become quite large, which makes it time-consuming
and difficult to locate particular pieces of information. If your data is in
an array, you may find the data easier to view if it is sorted in a particular
manner.

Perhaps you have multiple worksheets and you want to locate every occurrence
of a specific value. Or, maybe you're just a neat freak and want everything to
be in a particular order. Excel contains features to help keep your worksheets
in an easy-to-manage sequence.

Here’s what you can expect in this chapter:

== Sort your data in ascending or descending order using either the tool-
bar or the Excel Sort dialog box.

m= Perform a secondary sort if the primary sort has multiple matches.
w= Sort data containing days of the week or month names.
m= Create a customized list of frequently used names or terms.

m= Tocate cells containing data you specify, whether the data is part of a
formula or a resulting cell value.

m= Quickly replace data containing certain information with another
specified set of data.

w= Locate all cells with a particular style of formatting and easily replace
them with a different format.

| “*\apter

Get ready to. . .

w= Use the Toolbar fo Sort .............................. 76
= Work with the Sort Command .................... 77
w= Sort by Multiple Criteria .........ccoooerrrren.es 78
= (reate a Customized List ...........cccceeeernnn. 79
w=Sort by Day, Month, or Custom List ............ 80
w= Search for Data 81
w= Find All Data Occurrences ........................ 82
w= Locate Cells Based on Format .................... 82
= Use the Replace Command ........................ 83



Chapter 8: Sorting Data

Use the Toolbar to Sort

76

Create a list in contiguous order with headings specify-

ing the contents of each column. Figure 8-1 illustrates
an ideal data array.

Click any cell containing data in the column by which
you want to sort.

©)

If the data is in a connected list, you do not have fo select it first. If
the data is not in an adjoining list, you must first select the entire
list. If unselected data is in columns next to the selected data, Excel
may prompt you for more information.

Click the Sort Ascending button. Excel sorts the entire

list in ascending order. Text is sorted A-Z; numbers are

sorted 1-10; and dates are sorted earliest to last.

©)

Click the Sort Descending button. Excel sorts the entire list

Excel sorts in the following pattern: numbers, spaces, special char-
acters (whichare 1 “#S% & ()*,./:; 7@ [\1"_"{|}~
+ < =>) and finally, alphabetic letters.

by descending order, as shown in Figure 8-2. Text is
sorted Z-A; numbers are sorted 10-1; and dates are
sorted last to earliest.

©)
©)

If you do not see two sorting buttons (Ascending and Descending),
choose View=>Toolbars=>Customize and select the Show Standard
and Formatting Toolbars on Two Rows option. Click the Close button
and you can see both the Ascending and Descending Sort buttons.

If Excel incorrectly sorts a cell that contains a value, make sure the
cell is formatted as a number and not as text.
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Figure 8-1: Data for sorfing
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Work with the Sort Command

Work with the Sort Command

1.

Select or click in the list of data you want to sort. Select
only a single column of data if you want to sort that
column independently of the rest of the data.

Choose Data=Sort. The Sort dialog box opens
(see Figure 8-3).

If your data includes column headings, select the
Header Row option in the My Data Range Has section.
If it doesn't include column headings, select the No
Header Row option. Excel does not include header rows
in the sort process.

From the Sort By drop-down list, select the column by
which you want to sort (see Figure 8-4).

If you do not have header rows, Excel displays Column A, Column B,
and so forth.

Select whether you want to sort the data in ascending or
descending order.

Click the Options button if you want to make the sorfing case sen-
sitive (noncapitalized words before capitals). This opfion is not
available in PivotTable reports (see Chapter 13).

Click OK. Excel sorts data in the following order: num-

bers, special characters, and finally alphabetic characters.

Blanks are always placed last.

When sorfing an outline, Excel sorts only the highest-level groups.
This keeps the detail rows or columns fogether, even if hidden. (See
Chapter 11.)
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Figure 8-3: The Sort dialog box
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Chapter 8: Sorting Data

Sort by Multiple Criteria

1.

78

Select or click in the list of data you want to sort.
Choose Datar>Sort.

If your data includes column description headings,
select the Header Row option in the My Data Range
Has section.

Although the most common sort is to sort by rows, you can also sort
by columns. In the Sort dialog box, dick the Options button, choose
Sort Left to Right in the Orientation section, and then click OK.

From the Sort By drop-down list, select the first column
by which you want to sort. Choose whether to sort the
first criteria in ascending or descending order.

Excel sorts dates formatted with slashes such as 11/22/68 as
numeric data. Dates with the day or month spelled out must be
sorted differently. See the later section, “Sort by Day, Month, or
Custom List.”

Click the Then By down arrow and select the column
you want to sort by if two or more items are identical in
the first Sort By option. See Figure 8-5.

Choose whether to sort the second criteria in ascending
or descending order.

(Optional) Repeat Steps 4 and 5 for a third criterion.

Click OK. Excel performs the sort process. Figure 8-6
illustrates data rows sorted first by Artist, and then by
Song Title.

During an Excel sort, apostrophes (') and hyphens (-) are ignored,
unless two text strings are the same except for a hyphen. In that
situation, the text with the hyphen is sorted as the latter.

Sort (8[%]
Sort by
[artist [w] @ ascending
) Dbescending
Then by
[Name Tv] ©sgendng

) Descepding
Then by
r o] @ hscening
- ~ O Descending
WMy data range has

(%) Header row ) Ho header rop

[ options... ] [ ok ][ cancel ]

Figure 8-5: Select a second
sort criteria
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Figure 8-6: A duta array sorted by multiple criteria




Create a Customized List

Create a Customized List

1. Choose Tools=>Options. The Options dialog box appears.

2. Click the Custom Lists tab. Excel provides two ways to
create a custom list:

A custom list can contain text or text mixed with numbers. Use cus-
tom lists to speed up data entry for commonly used terms such as
salespeople, regions, or producis.

e To create a list from items you already have entered
into the worksheet, click the worksheet icon next to
the Import button. The Options dialog box collapses.
Highlight the worksheet cells containing your list;
then press Enter. The Options dialog box reappears.
Click the Import button. The data you selected appears
in both the List Entries box and the Custom Lists box
(see Figure 8-7).

e To type your own list, without entering it into the
worksheet first, select New List from the Custom Lists
section. Type your list in the List Entries text box
(see Figure 8-8) separating each list item with a
comma, and then click the Add button.

3. Click OK.

You can now use the AutoFill feature with the custom list by typing
one list entry and using AutoFill to enter the other list entries. See
Chapter 2.

To edit a custom list, choose Tools=>Options. From the Custom Lists
tab, select the list that you want to edit. Make any desired changes
in the List Entries box, and then click Add. To delete a customized
list, select the list and dick Delete. You cannot edit or delete the
Excel provided fill series such as months and days.
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Figure 8-7: Create your own custom lists from dqu in your worksheet
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Chapter 8: Sorting Data

Sort by Day, Month, or Custom List

80

1.

Select or click in the list of data you want to sort. Choose
Data=>Sort. The Sort dialog box appears.

Excel sorts numbers first, and then text. If your duta includes values des-
ignated os text, Excel prompts you before the Sort dialog hox appears
how you want these cells handled. You can choose to keep the numbers
as text values, or sort them as numbers. If you sort them as numbers,
both numbers stored as text and actual numbers are sorted together.

If your data includes column description headings, click
the Header Row option in the My Data Range Has section.

Specify the order in which you want the data sorted and
whether to sort in ascending or descending order (see
Figure 8-9).

If you're sorting on days of the week or months of the year, the data
must be spelled out completely (for example, September or
Tuesday), or abbreviated to the first three characters only (for
example, Sep or Tue).

By default, Excel sorts days and months alphabetically instead of by
date. To sort days or months by date, or to sort a custom list, the day,
month, or list column must be the first sort criteria.

Click the Options button. The Sort Options dialog box
opens.

Unless you specify otherwise, Excel sorts customized lists alphabeti-
cally instead of list order.

Select a sort order from the available list. (See Figure 8-10.)
Click OK twice to perform the sort.
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Figure 8-9: To sort days or months
click the Options button
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Search for Data

Se arc h fo r D ata Find and Ruploce — —

I o s
|

Feshwhal:  Men -

1. Choose Edit>Find (or press Ctrl+F). The Find and
Replace dialog box, shown in Figure 8-11, appears.

(o] (Ee=] [o=_]

2. In the Find What box, enter the value or word you want

Figure 8-11: The Find and Replace dialog box
to locate.

3. Click the Options button and specify any desired options: ek

A Eite L8 View |nesvi Fpomar Tools Duta Windew Help .8
= : BiAsi e Sr CRE TR T T Y |
T ER N T IRt

e Within: Search just the current worksheet or the
entire workbook.

or down the columns first.

o Search: Select whether to search across the rows first,
¢ Look In: Select whether you want to search through i
the values or formula results, through the actual for-

mulas, or look in the comments.

HHEE -T-li &

Select Formulas when you are looking for a formula that refer-
ences a specific cell address.

1 LA

b

¢ Match Case: Decide if you want your search to be
case specific.

il T E T SO TG T s — [T ¢ TR s
Figure 8-12: Excel finds data based on search specifications

e Match Entire Cell Contents: Decide if you want your
search results to list only the items that exactly match
your search criteria.

4. Click the Find Next button. Excel jumps to the first
occurrence of the match (see Figure 8-12). If this is not
the entry you are looking for, click the Find Next button
again. Excel advises you if it does not locate the data
you are searching for.

5. Click the Close button when you have located the entry
you want.



Chapter 8: Sorting Data

Find All Data Occurrences

Choose Edit=>Find. In the Find What box, enter the
value or word to locate.

Click the Options button and specify any desired options.

Click the Find All button. The Find and Replace dialog
box expands showing a list of each cell entry that con-
tains your data (see Figure 8-13).

Click any entry. The specified cell is selected.
Click the Close button when you finish.

Locate Cells Based on Format

82

Choose Edit=>Find. Click the Options button. Verify the
options you want to use.

Click the Format button. The Find Format dialog box,
shown in Figure 8-14, appears.

Select any formatting options on which you want to
search. A preview appears in the Preview box. Click OK.

Optionally, click the Choose Format from Cell button and select a
cell already containing the formatting you want to search.

In the Find What box, enter the value or word you want
to locate. Leave this blank if you want to locate only
cells with the specified formatting, regardless of the cell
contents.

Click the Find or the Find All button.
Click the Close button when finished.
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Use the Replace Command

Use the Replace Command

1.

Choose Edit>Replace (or press Ctrl+H). The Find and
Replace dialog box opens with the Replace tab on top.
(See Figure 8-15.)

If you want to replace only data in certain cells, rows, or columns,
select the desired area before you open the Find and Replace dio-
log box.

In the Find What box, enter the data you want to locate.

Click the Options button fo select additional search preferences. click
the Format button and match the formatting you are searching for.

In the Replace With box, enter the data with which you
want to replace the found data.

Like the Find data, you can specify the replacement data have
specific formatting.

Choose the Find Next button to locate the first found
occasion or choose the Find All button to display a list
of all occurrences.

If you want to use the replacement data, click the
Replace button. Excel performs the replacement and
locates the next occurrence.

If you want to replace all occurrences at the same time,
choose the Replace All button. Excel displays an infor-
mation box, shown in Figure 8-16, indicating the num-
ber of replacements made.

Click OK.
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Figure 8-15: Exchange data with the Find and
Replace feature
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Creating Charts
with Excel

w hoever said a picture is worth a thousand words is most certainly
referring to a chart. Let’s face it . . . we like looking at pictures more
than we like looking at sheets of data. Charts, sometimes referred to as
graphs, provide an effective way to illustrate your worksheet data by making
the relationship between numbers easier to see because it turns numbers
into shapes, and then the shapes can be compared to each other.

If you've ever spent hours drawing a chart on graph paper, you'll really
appreciate the ease with which you can create dozens of different chart styles
using your Excel data and you don't really have to draw a thing! With just a
few decisions on your part, and a few clicks of the mouse, you have a two-
or three-dimensional illustration of your data.

Charts let you get across your thoughts with simplicity and strength and
because different charts draw you to different conclusions, they prod you

to ask different questions about what you are seeing. Whatever the idea you
are trying to convey, charts make it easier.

In this chapter, discover how to
w= Quickly and easily create a chart
»= Modify a chart whether in appearance or content
w= Work with a 3-dimensional chart

m= Design and create an organization chart

| “%ap’fer

Get ready to. . .

w= (reate a Basic Chart
w= Work with the Chart Wizard .....................
= Change the Chart Type .......oeeeeeeeeeccssesnn.

= [nclude Titles and Labels .............ccoceeen.....
w= Cystomize the Chart Legend .....................
= Modify Chart Attributes...........occcoccorrrvre
= Add Graphic Images to a Series..................
= Change a Chart Location ............cceeeeeeen...
w= Add a Data Table
w= Enhance a 3-D Chart
w= Add or Delete Data

= Format the Value AXiS..........oveoemeeeeerreennnn.

w= (reate an Organization Chart ....................



Chapter 9: Creating Charts with Excel

Create a Basic Chart

1.
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Select the data (sequential or nonsequential) you want
to plot in the chart. See Figure 9-1 for an example of
sequential data selected for a chart.

Press the F11 key. Excel immediately adds a new sheet
called Chartl1 to your workbook with the data plotted
into a column chart. Each subsequent chart page is num-
bered sequentially such as Chart2, Chart3, and so forth.
Looking at Figure 9-2, you can see the various elements
that make up a chart:

Some newer keyboards use a different function for the F11 key. If
your F11 key does not produce a chart, use the Excel Chart Wizard
as explained in the next section.

Throughout this chapter you find out how to edit the look and style
of a chart, induding creating a chart using the Excel Chart Wizard.

e Title: A descriptive name for the overall chart. By
default, titles are not added in a basic chart, but you
can add them later manually or by using the Chart
Wizard.

¢ X or Category axis: Column or row headings from
your selected data, which Excel uses for Category axis
names. In a column chart, the categories display along
the bottom. In other charts (such as a bar chart), the
category axis displays along the left side.

e Category label: A descriptive name for the Category
axis. By default, a category label is not added in a
basic chart, but you can add one later manually or
with the Chart Wizard.
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Create a Basic Chart

e Y or Value axis: A scale representing the zero or the
lowest and highest numbers in the plotted data.
The Value axis is usually located on the left side on
a column chart or on the bottom on a bar chart.

e Value label: A descriptive name for the values. By
default, a value label is not added in a basic chart,
but you can add one later manually or by using the
Chart Wizard.

¢ Legend: The box, usually located on the right, identi-
fies the patterns or colors that are assigned to the chart
data series. Notice in Figure 9-3 how the legend
explains that the striped series represents January,
the checked series is for February, and the solid color
series is for March.

e Tick marks: The small extension of lines that appear
outside of the gray area and represent divisions of the
value or category axis.

o Gridlines: These lines extend from the tick marks
across the chart area, which allows you to easily view
and evaluate data.

e Series: Excel uses the worksheet cell values to generate
the series. Each element, called data markers, represents
a single worksheet cell value and related data markers
make up a data series and have the same pattern or
color. In Figure 9-4, you can see the comparison of
the data values to the y-axis and the series values.

¢ Plot area: The gray background that represents the
entire plotted chart area.

To delete this chart, right-click the Chart tab and choose Delete. When
Excel asks for a confirmation, dick Delete again.

Use any of the drawing tools on the Drawing toolbar fo annotate
your chart such as adding arrows, cirdles, or fext boxes. See Chapter 5
for more info.
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Figure 9-3: A chart legend
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Work with the Chart Wizard

1.

88

Select the data you want to plot in the chart. If you are
selecting values such as monthly figures, you don’t want
to include totals in your chart.

Choose Inserte>Chart or click the Chart Wizard button
on the Standard toolbar. The first screen of the Chart
Wizard appears. (See Figure 9-5.)

Select the chart type you want to use (click a chart type
to see a sample and an explanation of the chart):

e Column: Column charts compare values to categories
using a series of vertical columns to illustrate the series.

e Bar: Bar charts, like column charts, compare values to
categories, but use a series of horizontal bars to illus-
trate the series.

e Line: Line charts are similar to bar charts but use dots
to represent the data points and lines to connect the
data points.

e Pie: This chart compares parts to a whole. Usually
a pie chart has only one data series (see Figure 9-6).

e Area: Area charts display the trend of each value, usu-
ally over a specified period of time.

e X.Y Scatter: These charts include two value axes,
showing one set of numerical data along the x-axis
and another along the y-axis.

o Surface: Shows trends in values in a continuous curve.

e Doughnut: Displays data similarly to a pie chart; it
compares parts to a whole, but contains multiple series.

e Radar: Displays changes in values relative to a center
point by comparing the cumulative values of multi-
ple data series.
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Work with the Chart Wizard

e Stock: Stock charts (see Figure 9-7) illustrate the
fluctuation of stock prices. In a stock chart, the data
order is very important and usually the row headings
are High, Low, and Close; or Open, High, Low, and
Close.

e Bubble: These charts are similar to scatter charts, but
compare three sets of values by displaying a series of
circles.

e (Cylinder, Cone, and Pyramid: These three charts cre-

ate a column or bar chart using 3-dimensional shapes.

Choose a chart subtype. Depending on the chart type,
some chart subtypes show the data series next to each
other, others show the data stacked on top of each other.
Additionally, some charts are 2-dimensional and others
are 3-dimensional.

If you are not sure which chart subtype is best for your data, dick
the Press and Hold to View Sample button to see your selected data
in any chart style and subtype.

Click Next. Step 2 of Chart Wizard (shown in Figure 9-8)
appears.

Select whether you want Excel to plot the data series
from your columns of selected data or from the rows of
selected data.

To select different data for your chart, either type the correct cell
address range in the Data Range text box, or click the spreadsheet
icon af the end of the Data Range text box, highlight the desired
data, and press Enter fo refurn to the Chart Wizard.

Click Next. Step 3 of the Chart Wizard appears. The
options you see depend on the chart type you selected.
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Figure 9-7: A stock chart and its data
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Chapter 9: Creating Charts with Excel

10.

11.

Choose which options you want to include with your
chart (Figure 9-9 shows column chart options). The
options you see depend on the chart type you selected:

e Titles: Adds descriptive information to the chart and
optionally to the category and value axes.

e Axes: Displays or hides the primary axes of your chart.
e Gridlines: Displays or hides chart gridlines.

e Legend: Displays the chart legend and determines
legend placement.

e Data Labels: Adds category and value labels.

e Data Table: Displays data values. See the “Add a Data
Table” section.

Click Next. The final screen of the Chart Wizard appears.

Select whether you want Excel to place the chart on its
own worksheet or whether you want it placed on the
worksheet where your data resides.

Click the Finish button to create your chart.
If you opt to place the chart on the existing worksheet, Excel treats

it as a graphic image. Chapter 5 covers how fo resize, move, or
delete the chart.

Change the Chart Type

1.
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If the chart is on a regular worksheet, click the chart to
select it. If it is on its own sheet, display the sheet. The
menu changes to reflect the chart options.

Choose Chart=>Chart Type. Select the chart type and
subtype you want. (See Figure 9-10.)

Click OK. Excel modifies the existing chart.
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Customize the Chart Legend

Include Titles and Labels

1.

If you want to add a title to your chart, choose Chart=
Chart Options. The Chart Options dialog box opens,
with the Titles tab showing (see Figure 9-11).

Enter a title in the Chart Title box.

Enter a name for the Category axis and the Value axis.
Note that 3-dimensional charts may consider a z-axis
for the value axis.

Click OK.

Customize the Chart Legend

1.

To modify the Legend box (but not the series), select the
Legend box.

Choose Format>Selected Legend. The Format Legend
dialog box appears.

Click the Patterns tab and select the following options:
e Color or fill effects for the background of the legend.
¢ A border style that goes around the legend.

Click the Font tab and select a font, size, style, and color
for the legend text. See Figure 9-12.

Click the Placement tab and select the legend location.

Optionally, in the chart itself, you can drag the legend to any
desired location.

Click OK. Excel makes the legend changes.
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Modify Chart Attributes B ks e e

1. Double-click the chart element you want to modify.
For example, if you want to change the style of the
gridlines, double-click a gridline. If you want to apply
different colors or patterns to a series, double-click
any part that represents the series you want to change.
The appropriate Format dialog box appears (Figure 9-13
shows the Format Data Series dialog box).

2. Make any desired changes in the Format dialog box.

Click the Fill Effects button in the Format Data Series dialog box to
add texture, gradients, or patterns to the series.

3. Click OK. it Lo L e ey
Figure 9-13: Double-click a chart element fo modify it
Add Graphic Images to a Series S _ —

1. Double-click the series you want to add an image to.
The Format Data Series dialog box appears.

2. Click the Fill Effects button on the Patterns tab. The Fill
Effects dialog box opens.

3. Click the Select Picture button on the Picture tab. The
Select Picture dialog box opens.

™

4. Locate and select the picture you want to use. ——— —— - il _-—- — ;Ei‘
Click the Insert button. : _ o i _‘ﬁ,_ s i

Wrter

6. In the From the Format section of the Fill Effects dialog
box, choose Stack.

7. Click OK twice. Figure 9-14 illustrates a bar chart where
I changed one bar series to a graphic image.
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Add a Data Table

e “Chart Location 12]=]
Change a Chart Location
O asnewshest:  Chartl
1. Choose Chartz>Chart Location. The Chart Location dia-
log box, shown in Figure 9-15, appears. HoE owomen (e By]
Select a location.
Click OK. Your chart is moved to the location you've Flgﬁre ‘|)1-15: Switch o dhartfrom one locafion
specified. to the other
I E———
anTak Gnn 'muilullllp .t
[ r i T e
Add a Data Table M—*ﬂm———-—*ﬂg - e
1. To display a chart data table, click the sheet containing | sty ssapen
the chart.
You can add data tables fo charts included with a regular worksheet,
but it isn't a common practice because the worksheet itself already - -
displays the data. B ==
| |oass
g
Data tables display the chart values in a grid beneath the chart. _I‘ !
You'll find them very helpful if a reader needs fo see exact values i8]
along with a graphical display, such as when using a 3-D chart. 2 i
Choose Chart=>Chart Options. 5 |
Select the Data Table tab. Mﬁhu‘_‘j anzesl o
Data tables are not available for pie, scatter, bubble, radar, or Figure 9-16: Display the dota tabl
surface chart types.
4. Select the Show Data Table option.
Be sure to check the Show Legend Keys box if you want the data
table to display each legend next to the series label in the
data table.
5. Click OK. A data table, as shown in Figure 9-16, displays 93

at the bottom of the chart showing the actual values.
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Enhance a 3-D Chart

1.

94

Using the Chart Wizard, create a 3-dimensional chart.
(See the “Work with the Chart Wizard” section.)

If the chart is on a regular worksheet, click the chart to
select it. If it is on its own sheet, display the sheet.

Just in case you don't like your changes, make sure to save your
worksheet, which also saves your chart, before modifying chart
atfributes.

Choose Chart>3-D View. The 3-D View dialog box,
shown in Figure 9-17, appears. The options you see
depend on the chart type.

Click the up or down arrows to modify the up/down
elevation angle of the chart. You can optionally type
the elevation angle (between 10 and 80) in the
Elevation text box.

Click the Apply button to see the changes before you close the 3-D
View box.

Click the left or right rotation arrows or enter the degree
of left/right rotation (between 0 and 360) you want for
the chart in the Rotation box.

Change the thickness of the bars or height of pie slices by
entering a value (between 5 and 500) in the Height box.

Click OK. The chart appears on-screen, rotated to the
angles you selected. Figure 9-18 shows a 3-D pie chart
before and after changing the elevation, rotation, and
depth. The pie also has a piece pulled out for emphasis.
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Figure 9-17: Rotate a 3-dimensional chart
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Format the

Value Axis

Add or Delete Data

1.

To add or delete a series to a chart, choose Chart=>
Source Data. The Source Data dialog box opens.

Alter the table data as you need:

Add a series: Click the Data Range tab, which dis-
plays the current chart data selected in the worksheet
(see Figure 9-19). Use the mouse to select the new
complete data range, including both the current data
and the new data.

Remove a series: Click the Series tab. In the Series
section, select the series name you want to remove
and click the Remove button.

3. Click OK. The Source Data dialog box closes.

Format the Value Axis

1.

Double-click the value axis, which displays the Format
Axis dialog box.

Choose the options you want to change:

Patterns: Change the line styles used by the value axis.

Scale: Change a range by entering the maximum and
minimum values, as shown in Figure 9-20.

Font: Change the value font name, size, and
appearance.

Number: Format the range as currency, including
decimal points and dollar signs.

Alignment: Change the value orientation. This
option is rarely used.

Click OK when you're done.
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Create an Organization Chart

1.

96

Choose Insert=>Picture>Organizational Chart. A sample
organization chart like the one in Figure 9-21 appears
on the current worksheet along with an Organization
Chart toolbar.

Click a box and type a name or position. Press Enter to
add a second line if desired and apply any formatting.

Double-click any box to change the individual box background
color.

Using the Organization Chart toolbar, make other chart
layout changes as follows (Figure 9-22 shows a modified
org chart):

¢ Add additional subordinates, coworkers, or
assistant: Click the box to which you want to add
a subordinate, coworker, or assistant. Select the
appropriate choice from the Insert Shape drop-down
list. A new box appears under or next to the previously
selected box.

e Change the overall layout: Select a different layout
from the Layout drop-down list.

e Change the connecting line styles: Choose All
Connecting Lines from the Select drop-down list.
Double-click any line and change the style in the
Format AutoShape box. Click OK.

Other charts not hased on Excel values (called diagrams) include
Cycle, Radial, Pyramid, Venn, and Target. Choose Insert=>Diagram,
select the type of diagram you want, and then lick OK. Use the
Diagram foolbar to annotate or edit the diagram.
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Printing Workbooks

w hen you finish compiling your worksheet, you'll probably want to
print a hard copy or e-mail a copy to someone else. This chapter

shows you a number of Excel tools you can use to improve your document
layout, including headers, footers, page orientation, and margins.

Also, before you print or give your Excel file to someone else, you should
check it for spelling errors because typos can stand out screaming “I can't
spell.” Excel includes a built-in dictionary you can use to check your work-
books for misspellings; however, it can’t read your mind, so if you type

too instead of two, Excel probably won't indicate that as an error. But, com-
bine the spell check with proofreading on your part, and you'll find a very
helpful tool.

When printing, Excel assumes you want to print the entire worksheet area
unless you specify otherwise. You discover how to specify exactly what you
want to print. This chapter also includes these topics:

e Working with page breaks
e Adjusting the paper size

¢ Making your worksheet fit better on a page for those times when
you want to get that last few rows or columns on a single page

e Printing gridlines or row and column headings on the page as well
as other print options that you might want to select when printing
your worksheet or chart

| “*\apter
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Get ready to. . .

= Spell Check 98
= Preview Before Printing ............................ 99
w= Add a Manual Page Bredk ..................... 100
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Chapter 10: Printing Workbooks

Spell Check

1.

98

Choose Tools=>Spelling or click the Spelling icon on the
Standard toolbar. The Spelling dialog box opens and
Excel highlights the cell with the first potential mis-
spelling along with suggested changes (as shown in
Figure 10-1).

Optionally, press F7 to start the spell check.

Spell check reviews all cell values, comments, embedded charts,
text boxes, buttons, and headers and footers, but it does not check
profected worksheets, formulas, or text that results from a formula.

Select one of the following options:

e Change or Change All: Choose one of the sugges-
tions; then click Change to change just this incident
of the spelling mistake or Change All if you think
you could have made the mistake more than once.

o AutoCorrect: Have Excel, in future workbooks,
automatically correct the mistake with the selected
replacement.

e Ignore Once: Click this button if you don’t want to
change the highlighted instance of the spelling.

¢ Ignore All: Click this button if you don’t want to
change any instances of the spelling.

e Add to Dictionary: Add a word to Excel’s built-in
dictionary so that Excel won't flag it as a potential
error in the future.

After you select an option, Excel proceeds to the next
error, and when all potential mistakes are identified,
click OK (as shown in Figure 10-2).
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Preview Before Printing

Preview Before Printing

1.

Choose File=>Print Preview or click the Print Preview
icon on the Standard toolbar.

From the Print Preview screen (shown in Figure 10-3),
select from the following options:

I cover many of the Print Preview options in greater detail later in
this chapter.

e If there are multiple pages, click the Next or Previous
buttons to view additional pages.

e Click the Zoom button to enlarge the view. Click a
second time to reduce the view.

e Click the Print button to display the Print dialog box.

e Click the Setup button to display the Page Setup dia-
log box.

e Click the Margins button to display the page margins;
then drag any margin line to manually set margin
sizes. Click the Margins button again to turn off the
margin lines.

e Click the Page Break Preview button; then click OK to
display the worksheet in Page Break Preview mode.
You can manually adjust where the page breaks occur
by dragging any blue page break line (see Figure 10-4).
You can also resize the print area and edit the work-
sheet. Return to Normal view from Page Break Preview
by choosing Viewr>Normal.

Click the Close button to return to Normal view.
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Add a Manual Page Break

1. Click a cell in the row where you want the new page to
begin.

2. Choose Insert=>Page Break. Dotted page break lines sim-
ilar to the ones in Figure 10-5 appear.

To remove the manual page break, lick a cell in the row just below
the page break and choose Insert=>Remove Page Break.

Optionally, adjust page breaks through Page Break Preview mode.
Choose View=>Page Break Preview.

Set a Specific Area to Print

1. Highlight the area you want to print. See Figure 10-6.

Unless you specify a print areq, Excel prints the entire worksheet.

2. Choose Filem>Print Arear>Set Print Area. Dotted lines
appear around the print area. When you print the work-
sheet, only the area within the boundaries print. See the
“Print Worksheets or Charts” section, later in this chap-
ter to print.

To reset Excel to print the entire worksheet, choose Filec>Print
Areac>Clear Print Area.

dialog box, choose Selection in the Print What section.

s Optionally, highlight the area you want to print and from the Print
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Make Worksheets Fit Better on a Page

Adjust the Paper Size and Orientation

1.

4.

Choose Filer>Page Setup. The Page Setup dialog box
opens.

From the Page tab (see Figure 10-7), select whether
you want a Portrait or Landscape orientation from the
Orientation section. Portrait orientation prints the
top along the short edge of the paper and Landscape
prints along the long edge of the paper.

Select a paper size from the Paper Size drop-down list.
The paper size choices you see depend on the printer
you use. The two most common choices are Letter
(which is 8.5 inches by 11 inches) and Legal (which is
8.5 inches by 14 inches).

Click OK.

Make Worksheets Fit Better on a Page

1.

Choose Filer>Page Setup. The Page Setup dialog box
opens.

Click the Page tab.

From the Scaling area, make a selection from the
options shown in Figure 10-8:

¢ Adjust To: Enlarge or shrink the printed font size by
setting a percentage option between 10 and 400.

e Fit To: Force Excel to a specified number of pages
wide and tall.

Don't try to shrink the document oo much. Because Excel shrinks
the font, trying to fit too much on a page can make the document
too small to read.

Click OK.
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Figure 10-7: Choose paper options from the
Page tab
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Figure 10-8: Squeeze your worksheet onto a
specified number of pages
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Set Page Margins

1.

Choose Filer>Page Setup. The Page Setup dialog box
opens.

Click the Margins tab (shown in Figure 10-9) and set
the margins for the top, bottom, left, and right side
of the page.

The default worksheet margins are 1 inch on both the top and bot-
tom and .75 inch on the left and right sides.

Page section fo center the worksheet on the page, regardless of the
margins.

s Click the Horizontally and/or the Vertically options in the Center on

Click OK.

Add a Standard Header or Footer

1.
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Choose Filer>Page Setup. The Page Setup dialog box
opens.

Click the Header/Footer tab. See Figure 10-10.
Headers appear af the top of each printed page and footers
appear at the hottom of each printed page.

Select a header from the Header drop-down list.
Select a footer from the Footer drop-down list.
Click OK.
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Create a Custom Header or Footer

Create a Custom Header or Footer

1.

Choose Filer>Page Setup. The Page Setup dialog box
opens.

From the Header/Footer tab, click the Custom Header
(or Custom Footer) button. The Header (or Footer)
dialog box appears (see Figure 10-11).

In any desired section, type the text you want for the
header (or footer).

Select any text and click the Font button to select font
options.

Optionally, click one of the other buttons to insert date
or file codes:

e Page: Insert a code that indicates the page number.
e Pages: Insert a code that indicates the total number
of pages.

You can add text to the Page text. For example: Page
&[Page] of &[Pages] printsPage 3 of
5o Page 1 of 2.

¢ Date or Time: Insert the print date or time of day
(see Figure 10-12).

e Path, File Name, or Sheet Tab Name: Include file
information.

e Insert Picture: Insert a graphic image such as a com-
pany logo.

e Format Picture: Resize, rotate, or crop a header or
footer graphic image.

Click OK.
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1. Choose Filer>Page Setup. The Page Setup dialog box
opens.

2. Click the Sheet tab. Type a dollar sign ($) followed by
the row numbers or column letters you want to print as
titles in the Print Titles section. Entering $1:$2, as you
see in Figure 10-13, repeats rows 1 and 2 at the begin-
ning of each page.

Click the worksheet icon on the right to collapse the Page Setup dia-
log hox so you can select the rows or columns you want to incude.
Click the button again to return fo the Page Setup dialog box.
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3. Click OK. Figure 10-13: Select rows or columns to repeat at the top of each page
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3. Click OK. Figure 10-14 illustrates a worksheet printed
with gridlines and row and column headings. Figure 10-14: A printed worksheet with column and row

headings and gridlines

By default, gridlines are a lighter shade of gray. You can change the
gridline color by choosing Tools=>Options and selecting a gridline
color from the View tab.
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E-Mail a Workbook

Print Worksheets and Charts

1. Choose Filer>Print. The Print dialog box, shown in
Figure 10-15 appears.

Optionally, print the worksheet immediately by clicking the Print
button on the Standard toolbar.

2. Choose from the following options:
e Name: Select a printer different than the default printer.

e Print Range: Specify whether to print the entire work-
sheet as determined by the print area, or whether to
print only specific pages.

e Copies: Select the number of copies you want to print.

¢ Print What: Choose whether to print the current
worksheet, a preselected area, or the entire workbook.

3. Click OK.

E-Mail a Workbook

1. Choose File>Send Tom>Mail Recipient (as Attachment).
As you see in Figure 10-16, your e-mail program
launches with the worksheet as an attachment.

Recipients must have Excel installed on their systems fo open the
workbook file. If they don't have Excel, send the worksheet as the
body of the e-mail instead of an attachment by choosing Filec>
Send Tor>Mail Recipient.

2. Enter the recipient e-mail information and enter any
additional text in the body of the message.

3. Click the Send button.
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Part IV
Analyzing Data with Excel

The 5th Wave By Rich Tennant

“ Somebody got through our dead end Web links,
past the firewalls, and around the phone prompt
loops. Betore you Know it, the Kid here picKs up
the phone and he’s talking oneonone to a customer.”
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Working with
Outlines

you can use Excel to automatically calculate subtotal and grand total
values from rows containing related data (sometimes called a database).
When you create subtotals, Excel outlines the list so that you can display and
hide the detail rows for each subtotal.

Before you use the subtotal function, you must first sort your list so that
the rows you want to subtotal are grouped together. You can then calculate
subtotals and other mathematical calculations for any column that contains
numbers, or you can count the number of items in a selected field.

If your data is not in a database format, you can still group sections together,
allowing you a quick way to display or hide the sections as needed. Similar
to using subtotals, Excel displays groups in an outline format. In this chapter,
I take a look at the extensive subtotaling, grouping, and outlining features
contained in Excel.

| “*\apter

Getready to. ..

w= Generate a Subtotal .......ooooeeeece...........
= Collapse Subtotal Headings ......................
w= Control Individual Subtotds......................
= (reate Multiple Subtotdls.............c...........
w= Copy Subtotals

w= Remove Subtotals

w= Use AutoQuiline

= Form an Qutling Group ........ceeeeereeereeene.

= Remove ltems from a Group....................
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Generate a Subtotal

1.

110

Sort the field by which you want to generate subtotals.

The subtotal data must have no blank rows or columns, and each
column in the database must have a label in the first row.

Choose Datar>Subtotals. The Subtotal dialog box
appears.

Select the field you want to subtotal from the At Each
Change In drop-down list.

Select a function from the Use Function drop-down list.
Choices include suu (totals the values in a field), couNT
(returns the quantity of items in a field), AVERAGE
(determines the average value of a field), Max and MIN
(display the highest and lowest value in a field), and
PRODUCT (returns the value of all the numbers in a field
multiplied together).

Select the fields you want to subtotal from the Add
Subtotal To drop-down list. (See Figure 11-1.) You
can select more than one field to subtotal.

Check the Replace Current Subtotals box if you already
have a previous subtotal calculation. Excel replaces the
previous subtotals with the new one.

Check the Page Break Between Groups box if you want
Excel to begin each subtotaled group on a new page.

Remove the check from the Summary Below Data box if
you want Excel to place the subtotals at the top of each
group instead of under each group.

Click OK. Excel performs the subtotal. Figure 11-2
shows sales subtotaled by Sales Rep.
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to calculate
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Figure 11-2: A subtotaled worksheet



Control Individual Subtotals

Collapse Subtotal Headings

1.

Create subtotals of your data. (See the preceding
“Generate a Subtotal” section.)

With subtotals, Excel defines groups in the form of an outline and
bases the groups on the rows used fo calculate the subtotals.

Hide and show data as you need with the following
methods (see Figure 11-3):

e See only the grand total. Click the 1 on the subtotal
headings.

e See the subtotal categories and amounts (the detail
is hidden). Click the 2 on the subtotal headings
(the column on the left side of the worksheet).

e Show all the detail and subtotals: Click the 3 on the
subtotal headings. Excel displays the individual work-
sheet rows.

Control Individual Subtotals

1.

Create subtotals for your data (see the “Generate a
Subtotal” section, earlier in this chapter).

Click the Hide Detail button (minus sign) next to any
subtotal row. As seen in Figure 11-4, the selected subto-
tal detail collapses. It's not lost, only hidden.

Click the Show Detail button (plus sign) next to any
subtotal row. The detail data for the selected row appears.

Optionally, choose Datac>Group and Outline=>Hide Detail or Show
Detail.
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Figure 11-3: Collapse and expand entire subtotal sections
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Create Multiple Subtotals

1.

10.

112

From the Sort dialog box, select the column by which
you want to generate primary subtotals and the column
by which you want to generate secondary subtotals.

For example, if you want to first subtotal sales by state
and then by city, you would also sort first by state and
then by city.

Choose Datam>Subtotals to display the Subtotals
dialog box.

Select the primary field you want to subtotal from the
At Each Change drop-down list. Figure 11-5 shows the
primary field as the State field.

Select a function from the Use Function drop-down list.

Select the fields you want to subtotal from the Add
Subtotal To drop-down list.

Click OK. Excel summarizes the data by the selected field.

Choose Data=Sort. Excel again displays the Sort
dialog box.

Select the secondary field you want to subtotal, the
type of function, and the fields you want to subtotal.
In my example, I use the City field.

Deselect the Replace Current Subtotals box.

Click OK. Figure 11-6 illustrates both the sales amount
and the sales tax subtotaled by state and then by city.

As you perform additional subtotaling, Excel adds additional levels.
In Figure 11-6, four heading levels are displayed. Level 1 displays
only the grand tofals, level 2 displays the totals by state, level 3
shows the totals by city and state, and level 4 displays the detail.
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Remove Subtotals

Copy Subtotals

1.

Hide any unwanted Detail button by clicking the
Expand or Collapse buttons.

Select the data you want to copy.

Choose Edit>>Go To, which displays the Go To
dialog box.

Click the Special button. The Go To Special dialog box
opens (see Figure 11-7).

Select the Visible Cells Only option. White lines appear
around the selected cells.

Another use for the Go To Special dialog box is if you want fo select
only cells with constant values or to select only cells containing
formulos.

Click OK.

Choose Edit=>Copy (or press Ctrl+C). A marquee
appears around the selected cells.

Select the beginning cell where you want to place the
copied data.

Choose Edit=>Paste (or press Ctrl+V). Excel duplicates
only the subtotaled values, not the formulas or hidden
cells.

Remove Subtotals

1.

Choose Datar>Subtotals. The Subtotal dialog box opens
(see Figure 11-8).

Click the Remove All button. Excel removes all subtotal
information from the database.
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Use AutoOutline

1.

Choose Data=>Group and Outlinem>AutoOutline.
Figure 11-9 illustrates a worksheet with outline head-
ings for both rows and columns. Row outline symbols
are on the left, and column outline symbols are at the
top of the worksheet.

AutoOutline works best if the worksheet has summary formulas
that reference cells in the detail cells. The summary formulas must
be adjacent to the detail.

AutoOutline assumes your summary rows are helow the detail rows
or 1o the right of the detail columns. If your worksheet summary
rows are above or to the left of the detail, choose Datac>Group and
Outlinec>Settings and uncheck the Summary Rows Below Detail
check box and/or the Summary Columns to Right of Detail option.

You can create and apply styles to an outline, or you can apply
AutoFormats to an outline. You can apply the formatting either
before or after you create the outline. See Chapter 4. To apply an
automatic style, choose Data=>Group and Outling=>Settings and
select the Automatic Styles check box.

2. To expand the outline, click the Show Detail buttons to

114

the left of the rows or above the column headings. (See
Figure 11-10.)

To collapse the outline, click the Hide buttons to the left
of the rows or above the column headings.

To remove the AutoOutline, choose Data=>Group and
Outliner>Clear Outline.

To hide an outline without removing it, display all the data by dlicking
the highest number in the outline symbols and then choosing Tools=>
Options. Click the View tab and clear the Outline Symbols check box.
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Remove Items from a Group

Form an Outline Group

1.

Highlight the rows or columns that you want to group
together.

Choose Data=Group and Outline=>Group. In Fig-
ure 11-11, you see where all the vehicles in the asset
list are grouped together.

Click the Hide or Show Detail buttons to hide or display the group
detail.

Repeat Steps 1 and 2 until you have created all the levels
you want in the outline.

Remove Items from a Group

1.

Select the rows or columns you want to remove from
the group. If you want to remove an entire group, select
all the rows or columns in the group.

Choose Data= Group and Outline=>Ungroup. Excel
removes the rows or columns from the group and if
the rows or columns you delete are in the middle of a
group, Excel breaks the group into two smaller groups.
See Figure 11-12, where the vehicles are broken from
one group into two smaller groups.

Optionally, ungroup sections by holding the Shift key, clicking the Hide
or Display buttons, and then choosing Data=>Group and Outline=>
Ungroup. Excel does not delete any data when you remove items
from a group.
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Filtering Data

A fter you create an Excel database and assemble a large amount of data,
you'll probably want to analyze it. You may want to ask yourself questions
about your data such as “Who are my best customers?”, “Which inventory
items are provided by a specific supplier and cost less than a certain amount?”,
or “Which employees work the least amount of hours?” Excel includes sev-
eral tools you can use to study your data so you can make better decisions.

This chapter is about filtering, where Excel pulls out specific records for
review, providing you an easy way to break your data into smaller more
manageable chunks. Filtering does not rearrange your data; it simply tem-
porarily hides records you don't want to review, so you can clearly examine
those you do.

You can create your database by just typing in the Excel screen, or you can
use an Excel data entry screen. In the first section, you see how to create a
data entry screen for assistance in creating your database. But, remember,
you don't have to use the data entry screen to use the filtering.

The remainder of the chapter is devoted to the different ways you can filter
your data including

w= Using AutoFilter, which allows you to select key pieces of data.
w= Selecting records by more than one condition.
w= Displaying only the top x number of records.

== Multiple filtering where you locate records that either match all crite-
ria, or belong to one or the other criteria.

w= Advanced filtering where you designate a specific area of your work-
sheet to manage your criteria selections.

| “*lapter

Get ready to. . .

w= (reate a Data Entry Screen ...................... 118
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Chapter 12: Filtering Data

Create a Data Entry Screen

1.

118

Enter the column headings for your database. When you
create the data entry screen, the column headings appear
as field names.

For faster data entry, format any numerical columns with the desired
number format. Then, when you use the data entry screen, you need
to enter only the raw numbers without commas or dollar signs.

Click in any heading cell; then choose Data=>Form.

Click OK at the message box that appears. Excel displays
a data form with the headings shown as field names
(see Figure 12-1). Each label has a blank field to enter
the data.

If you already have data entered into your database, Excel does not
display the message box.

Using a data form makes data entry easier than typing across the
columns when you have a wide range with more columns than can
fit on the screen at one time.

Enter the first record information, pressing the Tab key
to move from field to field (see Figure 12-2).

Press Shift+Tab key to move back to the previous field.

Click the New button. Excel adds the record to the data-
base and displays another blank screen ready for the
next record.

Click Close when you finish entering data. Reopen the
database form at any time by choosing Datar>Form.
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Filter Data with AutoFilter

Filter Data with AutoFilter

1.

After clicking anywhere in your database, choose
Data>Filterm>AutoFilter. Excel displays an arrow in
each database column.

Click the arrow in the column heading. Excel displays
a drop-down list, which includes one of each unique
entry (up to 1000 entries) in the selected column. See
Figure 12-3. Besides the option of finding an exact
match, the choices include

e Top 10: Displays the 10 most (or least) repeated
items. See the “Select Only the Top 10” section.

e Custom: Prompts you to customize the filter. See the
“Customize an AutoFilter” section.

e Blanks: Displays all records with a blank in the
selected field.

e NonBlanks: Displays all records with data in the
selected field. This hides the blank records.

e All: Redisplays the entire list.

Press Alt+Down Arrow while in any column to display the
AutoFilter list for the current column.

Click the entry you want to filter. Excel displays only
the records that match your choice. In Figure 12-4, for
example, you see only the customers from Cincinnati.

Choose DatawFilterr>Show All to redisplay all entries.

Optionally, click the AutoFilter arrow from the filtered column and
choose (All).

When you finish filtering your data, choose Data=>
Filter=>AutoFilter to turn off the AutoFilter.
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Perform a Secondary Filter Selection

1.

120

Turn on the AutoFilter by choosing Datar>Filtere>
AutoFilter.

Click the column arrow by which you want to first
filter data.

Choose the data you want to filter. In Figure 12-5, you see
selections only containing the city of Atlanta. However,
notice that there is an Atlanta in GA, IN, and SC.

To further isolate specific items, click the AutoFilter
arrow at the top of another column.

Select the field by which you want to perform the second
filter. In Figure 12-6, the primary option was by the city
of Atlanta, but I apply the state of GA to the secondary
filter.

Repeat Steps 4 and 5 to further filter by additional fields
as many times as you need.

When you're done looking at your filtered data, choose
one of these options:

e Return to the first filter: Click the second filter col-
umn arrow and choose a different second filter.

e Return to the first filter only: Click the second filter
column arrow and choose Show All.

e Return to viewing all records: Choose Data->Filter=
Show All.

Optionally, dick the AutoFilter arrow from the filtered column and
choose (All).
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Select Only the Top 10

Select Only the Top 10

1.

8.

Turn on the AutoFilter by choosing Data>Filtere>
AutoFilter.

Click the column arrow by which you want to filter
data. This column must contain numeric data.

Choose Top 10. The Top 10 AutoFilter dialog box
appears, as shown in Figure 12-7.

Use the Top 10 AutoFilter o filter for the smallest or largest numbers.

From the first option, select whether you want the top
(highest) or bottom (lowest) values.

In the second option, select the number of items you
want to see (from 1 to 500).

In the third option, select whether you want to filter the
items by their name or by their percentile. For example,
choose to list the top 10 customers per their sales dol-
lars, or list the top 10 percent of your customer base.

Click OK. In Figure 12-8, you see the top 10 customers
by their sales values, sorted by record number.

To return to the filter options, click the current filter column arrow
and choose a different filter.

Click  Sort button on the Standard foolbar to sort the records by
their value.

When you're ready to view all records, choose
Datar>Filter>Show All.

Top 10 AutoFilter

Show

Top | 10 F |tems B2

Figure 12-7: The Top 10 AutoFilter dialog box
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Customize an AutoFilter
1. Turn on the AutoFilter by choosing Datar>Filter>
AutoFilter.

2. Click the column arrow by which you want to first
filter data.

3. Choose Custom. The Custom AutoFilter dialog box,
shown in Figure 12-9, appears.

Use a Custom filter when you need to select a range of data instead
of a single piece of data. For example, use the Custom filter when
you want to find any value greater than a specified amount or
where the data contain specific characters.

4. Select a qualifier from the first drop-down list (see
Figure 12-10):

e Equal To and Does Not Equal

e Greater Than and Less Than

e Greater Than Or Equal To and Less Than Or Equal To
e Begins With and Does Not Begin With

e Ends With and Does Not End With

e Contains and Does Not Contain

The qualifiers can apply to label or value cells.

5. Select a value to go with the qualifier from the second
drop-down list or type a value in the text box.

6. Click OK. The filtered data now matches the data criteria.
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Find Multiple Criteria

Find Multiple Criteria

1.

Turn on the AutoFilter by choosing Data>Filtere>
AutoFilter.

Click the column arrow by which you want to first
filter data.

Choose Custom. The Customize AutoFilter dialog box
appears.

Select the first qualifier from the first drop-down list.

Select the second qualifier from the second drop-
down list.

When using the AutoFilter, both qualifiers filter on the same field.
For example, if the first qualifier filters on the Sales field, the sec-
ond qualifier filters on the Sales field also. If you want to filter on
two separate fields, such as Sales and State, then you must use the
Advanced Filter. See the next section “Use Advanced Filtering.”

Select a matching option:

e And: Your data must match both qualifications. In
Figure 12-11, the Sales values must be greater than
$50,000 and be less than $100,000. This allows the
sale of $61,833.51 (D32), but the sale of $2,988.12

(D4) and $175,086.38 (D34) would not be included.

e Or: Your data must match only one of the two quali-
fications. For example, if the first qualifier specifies the
sales value must be less than 50,000 or be greater than
100,000, then the sale of $2,988.12 in cell D4, and
the one of $175,086.38 in D34 would be included
in the filter, but the sale of $61,833.51 in D32 would
not be included.

Click OK. In Figure 12-12, you see only records whose
sales fall between the two values.
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Use Advanced Filtering

1.

NS &

124

Make sure the AutoFilter is turned off.
Select the first four rows of the worksheet.

Choose InsertevRows, which inserts the blank rows at the
top of your worksheet. Excel uses these as your criteria
range.

At least one blank row needs to separate your writeria range from
your actual database. By inserfing four rows, you are creating the
opportunity fo create three criteria opfions.

Select the header row of your database.
Choose Edit>Copy. A marquee appears.
Click the first cell of the first blank row.

Choose Edite>Paste to copy the header row of your data-
base to the first blank row (Row 1). You now have a crite-
ria range ready to enter filter selections (see Figure 12-13).

While you could just retype the header row, using the copy and
paste feature protects you against typing errors. The criteria area
header row must exactly match the database header row.

In the first blank row of the criteria range, enter the data
you want to match. For example, if you want to locate
any entries for the state of California, type California
under the State heading.

Enter any additional filter criteria:

e Create an And filter: If you want Excel to find data that
meets more than one restriction, enter the desired addi-
tional criteria in another field on the first criteria row.

e Create an Or filter: Enter the filter data on the sec-
ond row of the criteria range. See Figure 12-14 where
I've added data to both the State and Sales columns.
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Use Advanced Filtering

10.
11.

12.

13.
14.

15.

16.

You can use Greater Than, Greater Than Or Equal To, Less Than, or
Less Than Or Equal To as operators in your criteria range. For exam-
ple, to find sales greater than or equal to 100, enter >=100 in the
Sales criteria row.

Click any cell in the main part of the database.

Choose DatarvFiltert>Advanced Filter. Excel displays the
Advanced Filter dialog box.

Select the Filter the List, In Place option in the Action
section.

Verify the database range in the List Range box.
Enter the criteria range. Excel provides two different ways:

e Type the criteria range including the header row, but
not any blank rows. For example, in Figure 12-15, the
criteria range is Al: F2.

Be sure to specify only the rows that contain filtering information.
If you include blank rows in your criteria range, Excel includes it in
the filtering with the effect of not filtering out any data, therehy
returning all records.

e Click the Collapse button to the right of the Criteria
Range box and highlight the entire criteria range,
including the header row, but not any blank rows.
Press Enter to return to the Advanced Filter dialog box.

Click OK. Excel places the results of your search in place
of your original database (as shown in Figure 12-16).

You cannot place filtered data on a different sheet than the origi-
nal data, but you can copy and paste it to a different sheet.

When you're ready to view all data records, choose
Data=>Filter=>Show All
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Creating Pivot Tables

M any people don't use PivotTables because they find them overwhelm-
ing. Yet, this powerful Excel tool helps you, within an instant, see your
spreadsheet data in a variety of different ways. PivotTable reports allow you
to group information, along with varying levels of detail, by different criteria,
such as date or category. They automatically create subtotals of your data on
a separate worksheet, which leaves your raw data untouched.

However, PivotTable calculations aren’t limited to adding the numbers
together. You can use Count, Average, Maximum, Minimum, and a num-
ber of other statistical functions to help you view the overall picture of
your data.

You can fill any of the four main PivotTable areas with your data by a drag
of the mouse and you can display the data in a table format or in one of
Excel’s many chart formats.

In this chapter, you find out how you can, within a matter of seconds, gener-
ate and extract meaningful information from a large amount of data, thereby
saving you potentially dozens of hours of manual calculations.

| “*\apter

Get ready to. . .

= (reate a PivofTable

= Select and Manage Pivot Dafa..................

= Change the Calculation Type ....................

w= AutoFormat PivotTables......

w= Apply Page Fields

= Generate Separate PivotTables ...............

w= Rename a Field

w= Format PivoiTable Values ..
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w= Group Data Together..........

w= Calculate a Percent of Totdls ....................

= Add Your Own Calculations

w= (reate a PivotChart
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Chapter 13: Creating PivotTables

Create a PivotTable

1.

128

Organize your data in a list, while keeping these points
in mind:

e Each column should contain only one type of data,
such as dates in one column and values in another
column.

e Make sure each column in the list has a heading label
directly above the data. (See Figure 13-1 for an exam-
ple.) PivotTables use the column headings as PivotTable
fields.

¢ Do not leave any blank rows between the data and the
row headings and no blank columns within the data.

¢ Avoid blank cells within the data. If you have dupli-
cate data, use the Copy command to replicate it in
the blank cells.

e If you have more than one list on the same worksheet,
make sure at least one blank column and one blank
row separate them. Figure 13-2 illustrates a worksheet
with multiple data tables. Although you can create
multiple PivotTables in a workbook, you can use
only one table at a time when creating a PivotTable.

e Remove any Excel generated subtotals or grand totals
in the data by choosing Data=>Subtotals=>Remove All.

e Plan your questions about how you want your data
analyzed. For example, if your data is sales informa-
tion, perhaps you want to know your sales totals by
region or a specific salesperson, or even deeper such
as by salesperson and by quarter. If your data is infor-
mation about your video collection, perhaps your
questions are how many DVDs you have with a cer-
tain actor as the star, or, how much you paid for all
the PG-13 rated movies?
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Create a PivotTable

2.
3

Click in any cell containing data.

Choose Datar>PivotTable and PivotChart Report. Step 1 of
the PivotTable and PivotChart Wizard appears. Excel needs
to know where your data will come from:

¢ Microsoft Excel List or Database: Creates the
PivotTable from organized data in a Microsoft Excel
worksheet.

e External Data Source: Creates a PivotTable from data
stored in a non-Excel database.

e Multiple Consolidation Ranges: Creates a PivotTable
from multiple Microsoft Excel worksheet ranges.

¢ Another PivotTable Report or PivotChart Report:
Creates a PivotTable from another PivotTable
report in the same workbook.

Click the Next button. Step 2 appears.

Verify that Excel correctly identified your data range,
including the headings. If not, specify the correct
area in the Range box as you see in Figure 13-3.

Click the Next button. Step 3 appears.
Select the New Worksheet option.

You can use the existing worksheet opfion if you're creating a
PivotChart. You must create PivotTables as a new sheet in the exist-
ing workbook.

Click the Finish button. The PivotTable and PivotChart
Wizard closes and Excel creates a new worksheet with a
blank PivotTable, along with the PivotTable toolbar and
the PivotTable Field List, which contains each field from
your data range (see Figure 13-4). PivotTables contain
four primary elements:
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Figure 13-3: Specify the data you want to analyze
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e Rows: Displays your data vertically, with one item
perrow.
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e Column: Displays the data horizontally, with one
item per column.

e Data: Summarizes the numerical data.

e Page: Displays each section of data on its own page,
which allows you to display data for a single item.

9. From the PivotTable Field List, select the field you want

17}
(]

categorized. 7
10. Select Row Area from the drop-down list at the bottom :
of the PivotTable Field List. Excel displays each unique 5
item from the field you selected. In Figure 13-5, Excel z
displays each Sales Rep. £

5l il 1a

If you want the categorized field displayed horizontally instead of o

vertically, choose Column Area instead of Row Area from the drop- Figure 13-5: Placing a row field

down list.
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11. Click the Add To button.

I A IRELL S |
Optionally, drag a field to its marked area, such as Add Rows Here. 2
As you drag the field, your mouse pointer drags a small gray box.
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12. From the PivotTable Field List, select the field you want
summarized, such as sales totals.

13. Select Data Area from the drop-down list at the bottom
of the PivotTable Field List. Excel takes the data and
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adds the totals to the PivotTable (see Figure 13-6). “

The PivotTable Field List indicates fields used in the PivotTable with bold letter- e

ing. You don't have to use all the fields in the PivotTable and you don't have to &

place fields in every area of the PivotTable. 5
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130 Figure 13-6: A completed PivoiTable



Select and Manage Pivot Data

Select and Manage Pivot Data

1.

On the PivotTable, click the down arrow in the gray
heading over the Row Fields section. A list of individual
items appears.

To remove any unwanted or misplaced field, select the gray heading
and drag it off the PivotTable onfo another area of the worksheet.

Remove the check mark next to any item you don’t want
included in the PivotTable.

Optionally, fo hide data in a PivotTable, right-click the field and
choose Hide. Hiding an item removes it from the report, but the item
sill appears in the drop-down list for the field.

Click OK. In Figure 13-7, only data for two specifically
selected sales reps appears in the PivotTable.

Click the Show All option to quickly select or deselect all options.

Select any of the following methods to update the
PivotTable with any changes made in the original data:

¢ Click the Refresh Data button (as shown in
Figure 13-8) or the PivotTable button on the
PivotTable toolbar; then choose Refresh Data.

e Right-click anywhere on the PivotTable and choose
Refresh Data from the shortcut menu.

To have the PivotTable refresh itself whenever you reopen the file, click
the PivoiTable button on the PivotTable toolbar and then choose Table
Options. In the PivotTable Options dialog hox, select Refresh on Open.

Double-click any data value to display, on a new worksheet, the
specific detail from which the data comprised.
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Figure 13-7: Filter data from a PivotTable

O L L =2
S File LS0 View (nesvi Fpemer Twils Qo Windew  Help T

G H -
1 0 Fage Fieks H
2
3 Sum o{TOTALSf
4 SalesRep . 'Total
5 Barker 128583 96|
G Bowiing 30438.21
7 Feltsman 50086164
8 King 14776.91
9 Kingston 433162 61
10 Koors 117205 88|
11 Martineze 19058.22]
12 | Matthews 322326.35|
13 Perkins 108090.38
14 Rogers 15464, 23|
15 Thomasson 7082 68/
16 | Grand Total 168517137

17
18
19
20
21

R R ey SO

Do g ettt s ROl A Mo A ST S AN

Ll — NN

IEigl-lr_e- 13-_8:Eeep your PivotTable accurate with the Refresh Dota feature

131



Chapter 13: Creating PivotTables

Change the Calculation Type

1. Click anywhere in the totaled data field.

2. Click the Field Settings button on the PivotTable tool-
bar or right-click the field and choose Field Settings.
The PivotTable Field dialog box, shown in Figure 13-9,
appears.

3. From the Summarize By list, select the function you want
to use. Choices include Sum, Count, Average, Max, Min,
Product, CountNums, StdDev, StdDevp, Var, and Varp.

Optionally, click the Number button and select a format for your
summary field.

4. Click OK. Excel re-summarizes the field based on the
function you selected. The field title also changes to
reflect the selected function.

If you don’t want to display grand totals at the hottom, dick the
PivotTable button on the PivotTable toolbar and choose Table
Options. From the PivotTable Options dialog box, remove the check
mark from Grand Totals for Columns. Click OK.

AutoFormat PivotTables

1. From the PivotTable toolbar, click the Format Report
button. The AutoFormat dialog box opens (see Fig-
ure 13-10).

2. Select a format and click OK.

If you don't like any of the AutoFormat options, you can manually
format any PivotTable section through the Field Settings feature.
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Generate Separate PivotTables

Apply Page Fields

1.

From the PivotTable Field List, select the field you want
to use to subdivide your PivotTable. For example, if you
want to see the total sales of each sales rep by country,
you select the Country field.

Page fields allow you to filter the entire PivotTable report to dis-
play data for a single item or all the items.

Drag the field onto the Drop Page Fields Here section.

From the Page Field Selection drop-down list, select the
field by which you want to filter. Figure 13-11 shows the
sales total for the Canadian sales reps, instead of view-
ing all sales reps sales totals.

Generate Separate PivotTables

1.

Save your file. The Undo function isn’t available for this
step, so if you don't get the results you expected, you have
to manually delete each and every added worksheet.

From the Page Field Selection drop-down list, select the
field by which you want to filter.

Click the PivotTable button on the PivotTable toolbar
and choose Show Pages.

Click OK at the resulting Show Pages dialog box. As
Figure 13-12 shows, Excel generates a PivotTable for
each field (in this example, Country), each on its own
worksheet in the workbook.

To delete an unwanted separate PivotTable worksheet, right-click
the unwanted worksheet tab and choose Delete. Click Delete again
at the resulting confirmation message.
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The PivotTable Field dialog box opens (see Figure 13-13). f R T Sk v
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Format PivotTable Ualues

1. Select the heading for the field you want to modify.

Figure 13-13: Rename a PivotTable field
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Click the Field Settings button on the PivotTable toolbar.

From the Field Settings dialog box, click the Number

o E F G
button.

4 Representative . Total

4. From the Format Cells dialog box (see Figure 13-14),
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Generate Multilevel Totals

Generate Multilevel Totals

1.

Create a PivotTable (see the “Create a PivotTable” sec-
tion, earlier in this chapter).

To create a second summary level, drag the next field
you want to subtotal from the PivotTable Field List onto
another PivotTable area, keeping these pointers in mind:

e If you want to create a second category, such as by
Country, and then by Salesman, drag the field onto
the Row area. Figure 13-15 shows a PivotTable with
two categories. The field closest to the data is called
the inner row (in this example, Sales Rep). The other
field is called an outer row (in this example, Country).
Excel displays data in the inner row under each of the
outer row fields.

¢ If you want to total additional fields, drag the field
into the Data area.

e If you want to sum different fields, or if you want to
create two different total types (such as count and
sum, or max and min), select a field you have already
used. Currently used fields are listed in bold type. As
you see in Figure 13-16, the fields appear vertically in
the Data area.

You can add even more data fields to your PivotTable. PivotTable data
fields are only limited by the amount of memory in your computer.

If you want the data fields displayed horizontally,
drag the gray Data button onto the cell that has the
Total heading. Excel rearranges the data fields.

To redisplay the data in a verfical format, drag the Data button to
the left, onto the Row area.
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Figure 13-15: Multiple category fields

Figure 13-16: Multiple data fields
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Group Data Together

1.

Create a PivotTable (see the “Create a PivotTable” section,
earlier in this chapter).

Click in any cell of the field you want to group. A popu-
lar field to group is a date field.

Click the PivotTable button on the PivotTable toolbar,
and choose Group and Show Detail=>Group.

From the Grouping dialog box, select the grouping option
you want to use. The options that appear depend on the
type of data you are grouping.

Click OK. Figure 13-17 illustrates two pivot table exam-
ples; one with the dates in detail and the other with the
dates grouped together by month.

To ungroup categories and redisplay the entire list, dlick the PivotTable
button and choose Group and Show Detail->Ungroup.

Calculate a Percent of Totals

1.
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Add a second totals field and display the two fields hori-
zontally (see the earlier section, “Generate Multilevel
Totals”).

Select the second totals field and click the Field Settings
button on the PivotTable toolbar.

From the PivotTable Field dialog box (see Figure 13-18),
choose % of Column from the Show Data As drop-
down list.

Click OK. Excel displays the second totals field as a per-
cent of total.
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Add Your Own Calculations

Add Vour Own Calculations

1.

From the PivotTable toolbar, choose PivotTabler>
Formulas=>Calculated Field. The Insert Calculated Field
dialog box appears.

In the Name text box, type a name for the formula, such
as CommAmt.

Calculated Field names can indude spaces and special characters.

In the Formula box, delete the =0 and create your own
formula, following these tips:

e Like other Excel formulas, begin with an equal sign,
but use field names instead of cell references.

While you can't use cell references in  formula, you can use static
values.

e Double-click any field name in the Fields box to add
it to the formula.

e Use the standard formula operators such as plus,
minus, multiply, and divide (+, -, *, and /).
Figure 13-19 shows a formula that calculates a
12% commission on the sales rep totals.

Click OK. Excel creates a new data column with the
calculated value. Figure 13-20 shows a PivotTable
with a calculated field next to the data field.

If you no longer want the calculated field on your PivotTable, drag
the calculated field heading off the PivotTable, and onto another
area of the worksheet.

Insert Calculated Field
Mame: | Commissian Amount fv’j Modiy
Formula: | =TOTALS* 12%]
Fields:
[Inveice Date [a]
| Current =
130 Days
|60 Days
190 Days |
1120 Days
|ToTALS E
| Commission Amount 12
Insert Field

Figure 13-19: Create a customized calculation
formula
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Figure 13-20: A customized formula calculation added to a PivoiTable
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Create a PivotChart

1.
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Create the PivotTable (see the earlier section, “Create a
PivotTable”).

Click anywhere in the PivotTable.
Click the PivotTable button on the PivotTable toolbar.

Choose PivotChart. Excel automatically inserts a new
worksheet with a chart based on the PivotTable (see
Figure 13-21). All PivotTable data, except for the totals
and subtotals, appear in the PivotChart.

Optionally, dick the PivotChart button on the PivotTable toolbar.

Changes to the PivofTable affect the PivotChart and field changes
to the PivotChart affect the PivotTable.

Format the chart (see Chapter 9) with the following
exceptions:

* You cannot move or resize the plot area.
® You cannot move or resize the legend.

e Refreshing the PivotTable removes any manually
applied chart formatting.

e PivotCharts cannot be scatter, bubble, or stock charts.

e You cannot add data to the PivotChart from outside
the PivotTable.

® You can use the PivotField buttons with the same func-
tionality as those in the PivotTable. See Figure 13-22.

To delete the PivotChart, right-click the chart sheet tab and choose
Delete.
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Figure 13-21: Create a PivotChart
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Building Simple
Macrosq g ' "%apter

ou can often save yourself time by automating tasks you perform fre-

quently. The automation takes the form of an Excel macro, which is a
series of commands and functions grouped together as a single command.
Macros are created in a special programming language called Visual Basic

and can be run whenever you need to perform the task. Get ready to. ..
While you can write your own very complex macros in the Visual Basic pro-
gramming language, the easiest method for many macros is to use the Excel »= Record o Macro 140
Macro Recorder. When you record a macro, Excel stores information about = Check Macro Security Level ................. 141
each step you take as you perform a series of commands. You then run the
macro to repeat, or play back, the commands. w= Run a Macro 142
The macro recorder is very literal and records every action you complete. = Assign a Macro KeyStroke................cceennee. 142
Therefore, planning your macro before you begin the recording process is
very imponant SO you don’t record unnecessary steps. w= (reate a Macro TOOIbﬂr Button ................ 143
Security is an important issue when working with macros, because if you w= Stop a Macro 143
open worksheets from other sources, the worksheets may contain macros

w= Delete a Macro 144

that are harmful to your computer. By default, Excel protects you from run-
ning macros, but if you're creating your own macros, you'll probably need w= Delete a Personal MACro oo 144
to change the security settings.

In this chapter, you find out how to change your security settings, as well as
how to record, run, and delete Excel macros.



Chapter 14: Building Simple Macros

Record Macro
Record a Macro
1. Choose ToolstoMacrooRecord New Macro. The Record e
Macro dialog box, shown in Figure 14-1, appears. pesarption:

Macro recorded 11714)2005 by Diane Koers

2. In the Macro Name text box, type a name for the macro:

Figure 14-1: The Record Macro

o The first character of the macro name must be a letter.

® Macro names cannot contain spaces. You can use let- dialog box
ters, numbers, or the underscore character.
® You cannot use a cell reference as a macro name. B T =]
e SEEY PP - Y AL N T | Lt ¥
e Macro names are not case sensitive. CERT SN Y T
- R
3. Select where you want to store the macro from the Store 1
. 2 arih Totals Fato |
Macro In drop-down list: 3 {Rovermn
4 | Esat §
¢ This Workbook: Save the macro in the current work- B o ;
book. If the file is a template, Excel stores the macro I M L
with the template. Any workbook using the template o —
has access to the macro. N ' 3
13 §
¢ New Workbook: Create macros that run in any new il :
workbooks created during the current Excel session. e s s
18
e Personal Macro Workbook: Choose this option if you e I
want the macro to be available whenever you use Excel.

4. Type a description of the macro in the Description box. L ey .
Click OK. A Stop Recording toolbar, as shown in T
Figure 14-2, appears on-screen. - '

5. Perform the actions you want to record. Toolbar

Figure 14-2: The Stop Recording toolbar
If you want to record the steps relative fo the current cell, such as

(Go up one row and insert a blank line), click the Relative Reference
button on the Stop Recording toolbar.

6. Click the Stop Recording button or choose Tools=>
Macro=>Stop Recording.
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Check Macro Security Level

Check Macro Security Level

1. Choose Tools=>Macro=>Security. The Security dialog box
shown in Figure 14-3 appears.

2. Set a security level:

¢ Very High: Allows you to only run macros that are
stored in a trusted location. The Trusted Publishers
tab lists all trusted locations.

e High: You can run only those macros that are digi-
tally signed. This is the default setting in Excel.

A digital signature is an electronic, encrypted, secure stamp of
authentication obtained from a commercial certification authority.
Excel’s Visual Basic programming language contains a self-certifying
digital signature tool, but because it doesn't come from a third party,
Excel sfill considers it unauthenticated and displays a warning box.

® Medium: Excel displays a dialog box asking if you
want to enable macros. If you are creating your own
macros, you should probably choose this setting.

e Low: Allows macros to run without you being noti-
fied first. This can be helpful if you run a lot of
macros, but be aware of the risk of using macros
from unknown sources.

Select the Low setting only if you have virus scanning software that
checks your Microsoft Office files or you open only workbooks that
you know do not contain viruses.

3. Click OK.

4. Close any currently open Excel workbooks. Depending
on the setting you selected, when you reopen a file con-
taining a macro, you may see the Security Warning dia-
log box, shown in Figure 14-4.

5. Click the Enable Macros button if you know where the
macro originated.

Security &%)

| security Level | | Trusted Publishers

O Yery High, Only macros installed in trusted locations will be allowed
tarun. Al other signed and unsigned macras are disabled

) High. Only signed macros from trusted sources wil be allowed to
run, Unsigned macros are automatically dissbled,

(&) Medium. You can choose whether or not to run potentially unsafe
macros.

© Law {not recommended). You are not protected from patentialy
unsafe macros. Uss this setting only IF you have virus scanning
software installed, or you have checked the safety of al documents
you open.

Figure 14-3: The Security dialog box

Security Warning
*CAMYFILES|EXCEL\Employee timecard1 k" contains macros.
IMacros may contain viruses, It is usually safe ko disable macros, but if the
macros are legitimate, you might lase some functionaity.

Disable Macros T Crable Mamas ] More Info

Figure 14-4: Macro warning box
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Run a Macro

1.

Choose Toolse>MacrowMacros. The Macro dialog box,
shown in Figure 14-5, appears.

Select the macro you want to run.

Click the Run button. Excel executes the selected macro.

Save your file before running a newly created macro. You cannot
undo the macro.

Assign a Macro KeyStroke

1.

142

Click Tools=>Macro=>Record New Macro.
In the Macro Name text box, type a name for the macro.

Select where you want to store the macro from the Store
Macro In drop-down list.

Type a description of the macro in the Description box.

Assign a keystroke combination (see Figure 14-6). If you
select a shortcut key already used in Excel, the macro
shortcut overrides the Excel shortcut while the work-
book that contains the macro is open.

If you enter a lowercase letter, Excel assigns it a Ctrl-+lowercase let-
ter combination. If you type an uppercase letter, you must press
Ctrl+Shift+the letter to run the macro. The shortcut key cannot be
a number or special characer.

Click OK.

Perform the actions you want to record and then click
the Stop Recording button.

To execute the macro, press the shortcut key you assigned.

0]
Step Inko
Macros in: All Open Workbooks v

Description
Inserts company name at the top of a worksheet

Figure 14-5: Select a prerecorded macro

[

Record Macro

Macra name:
CompanyHeadings

Shortcut key:
Ctrl+shift+ A

Store macra in:
This Warkbook ||

Description:
Macro to sntsr company nams at top of worksheet

Figure 14-6: Assign a shortcut key
fo a macro




Stop a Macro

My et Vil Basle | Foaks - Mbedulet | Codel] =5

Create a Macro Toolbar Button T e e i i _

= =] et

1. Choose Toolsc>Customize.

2. Click the Commands tab. Then select Macros from the
Categories list.

3. Drag the Custom button from the Commands box to
the toolbar on which you want to place it.

4. Release the mouse button when the mouse pointer
resembles a capital letter I like the one in Figure 14-7.

5. With the new button selected, click the Modify Selection
button in the Customize dialog box. i

6. Choose Assign Macro. The Assign Macro dialog box
appears. S .

Figure 14-7: Quickly access a macro by adding it to the toolbar

7. Select the macro you want to assign to the toolbar

button.
CliCk OK' F My vl Wil Basle | Foah . [Hedulet (Codit] =50
% Flle B Wiew bwen Faomar Debug B Tesk Addins Windsw Help - xi

9. Click the Close button. Bad ans o ooxbii oo —

= =] et

10. To run the macro, simply click the toolbar button.

Check out Chapter 15 for more information on customizing toolbars.

Stop a Macro

1. Press the Escape key. The Microsoft Visual Basic window
opens (see Figure 14-8). . |

2. Click the End button. .

Hold the Shift key while starting Excel to prevent Excel from auto- P .

matically running a macro. i = w e piow w
Figure 14-8: Stopping a macro 143
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Delete a Macro

1.

Open the workbook containing the macro you want to
delete.

Choose Tools=>Macro>Macros. The Macro dialog box
appears (see Figure 14-9).

From the Macro dialog box, select the macro name you
want to delete.

Click the Delete button. A confirmation box appears.

Click Yes.

Delefing a macro does not remove any button you placed on the tool-
bar. To delete a button from the toolbar, choose Toolsc>Customize
and drag the button off the foolbar.

Delete a Personal Macro

1.
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Choose Window=>Unhide. The Unhide dialog box,
shown in Figure 14-10, appears (unless the Personal
Workbook already is displayed or you don’t have any
personal Macros).

Choose Personal, then click OK. The Personal
Workbook appears.

Choose Toolse>MacroMacros. From the Macro dialog
box, select the macro you want to delete.

Click the Delete button. A confirmation box appears.
Click Yes.

Choose Filew>Close. (You are closing the Personal
Workbook.) A Save Confirmation dialog box appears.

Click Yes.

Macro

WMatra niame:

CompanyHeadings

CompanyHeadings

Descr)
Macro

Bun

Cancel

Step Inta

fal

Delete

&

Al Open Workbooks || [ options...

rker company name at top of worksheet

Unhide

[%]

Uit workbiook:

(PEHEOREL

oK Cancel - \

Figure 14-10: Unhide the Personal

Workbook

Figure 14-9: Select a macro to delete




Saving Time with
Excel Tools

Fis chapter is about stuff . . . Excel stuff. In the earlier chapters, I show
how Excel has lots of power to make your computing life a little easier.
This chapter contains a diverse group of Excel tools designed to speed up
data entry and help improve spreadsheet quality.

In this chapter you discover how to

w=  Add special characters such as the copyright symbol, the registered
trademark, foreign characters, or smiley faces.

m= Create a custom toolbar where you can specify the tools you use most
often.

w=  Split data into multiple columns where you can break up data contain-
ing multiple words such as a first name and last name; or city, state,
and zip code into separate columns.

w= Merge columns, which uses the Excel CONCATENATE function to com-
bine data.

m=  Manage Excel’s AutoCorrect feature, where you see how Excel automati-
cally corrects many common misspelling or formatting issues.

w= Work with SmartTags, those funny little indicators that often appear
when you perform certain Excel functions or enter a particular type
of Excel data.

w= ] et Excel flag potential formula errors and offer to correct them for you.

| “*lapter

Get ready to. . .

= Add Special Characters ..........ccccoocoeeeeenne. 146
= (reate a Custom Toolbar .......................... 146
w= Split Data info Multiple Columns .............. 147
= Merge Columns 148
w= Manage AutoCorrect .........vvvverreveenenenens 149
= Check for Formula Errors ........................ 149
we> Work with SmartTags ..........ooooeeeeeseerceees 150



Chapter 15: Saving Time with Excel Tools

Add Special Characters

1.

Click where you want the symbol. Special characters can
be in their own cell or amid other text or values.

Choose Insert>Symbol. The Symbol dialog box appears
(see Figure 15-1).

From the Symbols tab, click the symbol you want to use.

Different fonts display different symbols. If you don't see the
symbol you want, select a different font from the Font drop-down
list. Additional special characters are available on the Special
Characters tab.

Click the Insert button. Excel inserts the symbol into the
current cell. Click the Close button.

Create a Custom Toolbar

1.

AT N SR
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Choose Tools=>Customize. The Customize dialog box
appears.

From the Toolbars tab, click the New button.
Enter the name you want to describe the new toolbar.
Click OK. A new blank toolbar appears on-screen.

From the Commands tab of the Customize dialog box,
select a category for the first tool you want to add. A list
of available Excel commands appears on the right side
of the dialog box (see Figure 15-2).

Drag the command you want until it is on top of the new
toolbar. When you release the mouse button, a button
representing the command appears on the new toolbar.

Click the Close button.
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Figure 15-1: Insert symbols, such as the copyright character,

info a cell
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Figure 15-2: Create a customized toolbar



Split Data into Multiple Columns

Split Data into Multiple Columns

1.

Insert blank columns to the left of the cells you want to
convert into multiple columns. If you want your data in
three columns, then you must have two blank columns.

Select the cells you want to convert.

You can't split empty cells, and you can't split merged cells. You
must first unmerge the cells. See Chapter 4 for information about
merged cells.

Choose Data>Text to Columns. The Convert Text to
Columns Wizard appears (see Figure 15-3).

Select the Original data type that suits your date. The
Delimited type works if your data has a similar format.
If the cells all contain a specific number of characters,
select the Fixed Width radio button.

If your data type is delimited, be sure that each section is separated
by a common character such as a comma, period, apostrophe, or tab.

Click Next. The option you see next depends on which
data type you selected in Step 4. For Fixed Width, click
the ruler bar where you want the data to split. For
Delimited, enter the character you used to separate your
text. In Figure 15-4, the text is separated by a space.

Click the Finish button. Excel separates the selected cells
into multiple columns.

Click OK.

To split data info two lines in the same cell, press Alt+Enter where
you want to break the line.
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Chapter 15: Saving Time with Excel Tools

, O T
Merge Columns R PSP S L el
= — — ¥ ]
1. Click in the cell where you want the merged data. e iR e,
2. Choose Insert=>Function. r_:.:m.... G co—]
3. From the Category drop-down list, choose Text. ';',"“"‘:’; _ ___-"‘5
4. Select CONCATENATE. (See Figure 15-5.) - e ——
5. Click OK. The Function Arguments dialog box appears. 2 = = c
6. Type the first cell address or click the cell you want to .'P :.‘:_:m.,.,.,:u
add to the combination. Excel enters the cell address in .’ ______
the Text1 box. st |
Optionally, on any line, if you want specific text that's not in a cell
address, type the fext or punctuation, including any spaces. Excel s 1
places any spaces, punctuation, or fext in quotation marks. Dup: _fwiwn . aASTEA A

Figure 15-5: Using a function to combine multiple columns into a single column
7. In the Text2 box, click the cell or type the text you want

next. Each element must go in its own Text box line. —

Figure 15_6 ShOWS an eXample %) Eite 8 M .Inun Format Toals Data Windew Help :
8. Click OK.

Mail to Ciy

To convert the merged cells into plain text, instead of formulas,
select the merged cells, choose Edit>Copy, choose Editc>Paste
Special, and then select Values from the Paste Special dialog box.

Optionally, use the ampersand (&) between cell addresses fo join

text items. For example, =a1sB1 returns the same value as i
=CONCATENATE (A1, B1) . However, the cells you connect 3
with the ampersand cannot be blank. ie

Ia
A

148 Figure 15-6: Concatenating fext columns



Check for Formula Errors

Manage AutoCorrect

1.

Choose Tools=>AutoCorrect Options. The AutoCorrect
Options dialog box opens.

Remove the check marks from any option you do not
want Excel to automatically correct.

In the Replace box, type a common typing mistake. For
example, if you frequently type profitt instead of profit,
type profitt in the Replace box.

In the With text box, type the correct word (see
Figure 15-7).

Click the Add button.

To remove any unwanted entry, select the entry and dlick the
Delete button.

Click the AutoFormat As You Type tab.

Remove the check mark from any feature you don't
want Excel to automatically perform.

Click OK.

Check for Formula Errors

1.

3.

Choose Toolst>Error Checking. Excel checks the current
worksheet for formula errors and stops at the first error.
As Figure 15-8 shows, the Error Checking dialog box offers
several pieces of information including the cell reference
containing the possible problem, a description of the
possible problem, and a button to remedy the problem.

Click the button that offers to remedy the problem or
Next to leave the formula as is.

When the error checking is complete, click OK.

AutoCorrect: English (11.5.) (%]

| AuroCormect | autaFarmat As You Type | Smart Tags |
Show AukaCarrect Options buttons
[#] Correct Two Initial Capitals |
: Exceptions...
[¥] Capitalize first letter of sentences
Capitalize names of davs

Correct accidental use of cAPS LOCK key
Replace text as you type

Replacs: with: |
ABS All Business Service| ‘

= — =
|abouts about & [

| aboutit about it - ‘

aboutthe about the

shscence absence v

| e

oK | concel |

Figure 15-7: AutoCorrect Options
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Figure 15-8: Check for potential errors
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Chapter 15: Saving Time with Excel Tools

Work with SmartTags

1.
2.
3.
4.

150

Choose Tools>AutoCorrect Options.

Click the SmartTags tab (see Figure 15-9).

Enable the Label Data with SmartTags option.
Click OK.

To have Excel notify you with a sound whenever a SmartTag appears,
you must have Microsoft Office Sounds installed on your computer.
Then choose Tools=>Options and from the General fab, select the
Provide Feedback with Sound opfion.

From the worksheet, click a SmartTag icon. Each SmartTag
type appears with a different icon appearance including

Paste: These appear over pasted data (such as the one
in Figure 15-10), offering options about pasting.

AutoFill: These appear after you fill data in a work-
sheet, offering how to fill the text or data.

Insert: These appear next to inserted cells, rows, or
columns, offering a list of formatting options.

AutoCorrect: These appear as a small, blue box near
text that was automatically corrected, offering to
undo an AutoCorrect action.

Financial: These appear over a cell with a U.S. stock
symbol and offers options to check stock prices.
Financial SmartTags are indicated by a purple triangle
in the lower-right corner of a worksheet cell.

Error Checking: These appear over potential for-
mula errors in the same way as the Error Checking
feature. Error Checking SmartTags are indicated by
a small green triangle in the upper-left corner of a
worksheet cell.

| AutoCorrect | AutoFormat As You Type | Smart Tags

Excel can recagnize certain bypes of data in your workbooks. For each
| recoanized type, there are actions you can perform with that data,

Label data with smart tags

| Recogrizers:

Crystal Reparts {Crystal Reports Smart Tag Recogr|
ate (Smark tag lists)

inancial Symbol (Sraart taq lists)

Persan Mame (OUtlook e-mail recipients)

Geographic Heading (MapPoint location headings)

|

|

| £ I ] [
L J |

|

[ check warkbaok.., | [ More smart Tags...

Show smart tags as | Indicator and Button |

| [CJEmbed smart tags in this workbook.

AutoCorrect 8% ]

Figure 15-9: Enable addifional SmartTags
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Creating a Commission
Calculator

Slppose you're a business owner and you pay your salespeople a sliding
commission rate based on their total sales for a specified period, such
as a month. First, you need a sheet of paper to list each salesperson’s sales.
Then, at the end of the period, you have to subtotal each person’s sales.
Finally, you have to figure out which percent commission to give based

on that subtotal.

With a Commission Calculator worksheet, designed with the use of basic
Excel features, as well as using several Excel functions (SUMIF, COUNTIF, and
nested IF statements), all you have to do is enter the individual sales. Excel
does the rest for you, saving you precious time and reducing the chance for
human error. To set a worksheet up, you do the following tasks:

w= Enter basic headings
w= Create a sliding commission rate table
m= Define the data input area where you track the individual sales

== Design the calculation area where Excel calculates the totals and
commission

w= Enhance the worksheet appearance so it’s easier to read

m= Protect and save the worksheet as a template

| “*\apter

Get ready to. . .

w= Enter Headings

w= (reate the Commission Table....................

w= Define the Sales Data Input Area ...........
w= Total Sales with the SUMIF Function..........
w= Jse the COUNTIF Function

to Count Sales

w= Calculate Commission with a

Nested IF Statement

w= (reate Totals

w= Make It Look Nicer

w= Protect Your Work

154
154
155
155

156

156
157
158
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Chapter 16: Creating a Commission Calculator

Enter Headings

In cell A1, type Commission Calculator.
In cell A2, type For the month of:.

In cells A3, B3, C3, and D3, type the following column
headings: Sales Person, # of Sales, Total Sales Amount,
and Commission Amount.

Move down enough rows to accommodate all your
salespeople’s names, plus a couple of extra rows, and
in column A of the row, type Totals.

Beginning with cell A4, moving down the column, list
the names of your salespeople.

Move down three more rows and type the following col-
umn headings: Sale Date, Transaction Number, Sales
Person, Sale Amount. Your worksheet should look like
Figure 16-1.

Create the Commission Table

154

1.

In an unused area of the worksheet, enter your sales
dollar breakdown.

In the cells next to the sales dollar breakdown, such as
in cells L4, L5, L6, and so forth, enter the commission
percentage.

Format the sales dollar values as currency (see Chapter 4).
Format the commissions as percentages (see Figure 16-2).

Select the commission table and choose Insert=>"Name=
Define. The Define Name dialog box appears.

Type CommissionTable or another name for the table.
Click OK.
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Figure 16-1: Enter headings for a commission worksheet
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Total Sales with the SUMIF Function

Define the Sales Data Input Area

1.

At the bottom of the worksheet where you will enter the
individual sales, select the cells in the Salesperson col-
umn. In Figure 16-3, I selected cells C15 through C114,
which gives room for 100 sales entries.

Choose Insertr>Namer>Define. The Define Name dialog
box appears.

Type SalesRep for the range name; then click OK.

In the same worksheet section, select the cells you will
use in the Sales Amount column. Be sure to include the
same number of cells you included in Step 1.

Choose Insert>Namer>Define. The Define Name dialog
box appears.

Type SalesAmt for the range name; then click OK.

To verify the formulas you create in the next several sections, enter
some sample data in the sales data input area.

Total Sales with the SUMIF Function

1.

In cell C4, enter the following formula and then press
Enter: =SUMIF(SalesRep,A4,SalesAmt). If you entered
sample data in the sales data input area, you see the
total sales for the salesperson.

The Excel sumMIF fundtion calculates the fotals of numbers that
meet specified criteria. The function first asks for the area you want
to look at, then the cell it should look o match, and finally the
amount you want the function to tofal.

Copy the formula in C4 to the end of your salesperson list

(see Figure 16-4). Chapter 2 shows how to copy formulas.
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Figure 16-4: Copy the formula down the rows
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Chapter 16: Creating a Commission Calculator

Use the COUNTIF Function T i e
to Count Sales

1. In cell B4, enter the following formula, then press
Enter: =COUNTIF(SalesRep,A4). If you entered sample
data in the sales data input area, you see the total num-
ber of sales for the salesperson.

The Excel counTIF function counts the number of entries that
meet specified criteria. The function first asks for the area you want to
look at, then the cell it should look to maich.

Select cell B4 and choose Edit=>Copy.
Highlight cells B5 through the end of your salesperson list.

i 4 W ety e et Jat

4. Choose Edit>Paste. Excel duplicates the formulas to L e

include all the salespeople. (See Figure 16-5.) Figure 16-5: Copy the formula throughout the rows

Calculate Commission with Nenlis e T
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< e rp—
e ST B A Y vl —
a Nested IF Statement e
A B C Des E F G H
1 Commission Caleulator
1. In cell D4, enter the beginning function and the first i D T T
T 5 *%| 55 C4* (C4<5K5E]
parameter to check the total sales for the sales person oo TG e e .
against the commission table. Type =IF(C4<$K$5 and gsue z 7
a comma. & Dome 0 0
8 Juka 0 1]
o o . o . 10
If you created your commission table in a different location, change 1 Totals
the cell references to match your commission fable. 12
14 Sale Date Transactio Sales PersSale Amount
15 15-Dec 1234 Bob Tad
. . & D 585 Ti 362
Be sure fo place the dollar signs in front of the cell references fo {7 ioDec 3211 Sue 4120
make them an absolute reference to a specific cell. a0 921 que o
20
Ci e W " at
e funshags: NNTE ST S T
2. Enter the first True result. Type C4*$L$4 and a comma. = i i

156 Figure 16-6: Beginning a nested IF statement



Create Totals

3. Enter the first False result that begins another IF state-

ment. Type IF(C4<$K$6 and a comma (see Figure 16-6).

4. Enter the next True result. Type C4*$L$5 and a comma.

Enter the next False result that again begins another ¥
statement. Type IF(C4<$K$7 and a comma.

6. Enter the third True result, if applicable. Type C4*$L$6
and a comma.

7. Enter the third False result, which in my example is the
last level to check. Type C4*$L$7.

8. Type three closing parentheses, enough to match
the number of opening parentheses and press Enter.
Figure 16-7 illustrates the final formula and its results.

9. Copy the formula to the other rows.

The Excel T function evaluates a condifion you specify, and refurns
one value if the statement is TRUE and another value if it evalu-
ates fo FALSE. In this example, if the sales are less than the first
commission level, making the first condifion TRUE, it calculates
the sales multiplied by the first level commission percentage. If the
stafement is not TRUE, then Excel checks if the sales are less than
a second commission level, and if so, it multiplies the sales fimes
that commission level percentage. The nesfing continues until Excel
checks all commission levels, resulting in a commission amount.

Create Totals

1. In cell B11, or the cell below your last sales rep, create a
suM function to total the cells above it. In Figure 16-8,
the formula =suM (B4:B10) totals the sales orders.

Select the formula in cell B11 and choose Edit=>Copy.

3. Select the cells C11 and D11 and choose Edit>Paste.
Excel duplicates the formulas, which total the sales
and commissions, respectively.
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14 Sale Date Transactio Sales Pers Sale Amount
15 Di-Noy 1458 Smith 1352 B4
168 02-hov 1458 Smith 7418
17 02-Nov 1460 Jones 13352
18 D2-Nov 1461 Michaels  G400.03
18 03-Nov 1462 Brown 1500
20 D3-Nov 1463 Jones 316.84
21 03-Mov 1484 Smith 325011
22 03-Noy 1465 Brown 410013
23 D4-Nev 1456 Brown 180472
4 iy 14R7 Fehuarde 754 60 -
LR iR e = Jat Ml
LN L R ST TR IS =t P V]
— oo
Figure 16-7: A completed nested IF statement
ool e =g
-0 X

S ble L8 View ol bgrer Teds Uae Windew Halp

Sales Per# of Sale: Tatal SaleCommission

3

4 Smith J 534485 374126

5 Edwards 2 158763 79.3815

& Jones 2 45046 135138

7 Abemathy o o 0

8 Michaels 1 640003 4485002

9 Brown 4 108651 108651

10 0 o 0

11 Totals

12

13

14 Sale Date Transacti Sales Per Sale Amount
15 01-Noy 1458 Smith 135264

16 02-Maov 1458 Smith 741.8

17! 02-Nov 1460 Jones 13352

18 02-Noy 1461 Michaels EB400.03

19 03-Nov 1462 Brown 1500

20 03-Nav 1463 Janes 316.94

2 03-Nov 1464 Smith 325011
CROTRTLE-P T R - i Ja
L L L R VST YU TP R =t P}
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Chapter 16: Creating a Commission Calculator

Make It Look Nicer

~—
S

11.

& R NSNS NN

Apply currency number formatting to cells with currency.

Widen columns to allow all cell data to appear.
Bold the headings.

Make the headings a larger font.

Apply borders as desired.

Merge and center cells A2 and B2.

Click the Right Align button to right align the data.
Merge and center cells C2 and D2.

Click the Left Align button to left align the data.

Add a light color shading to every other row as shown
in Figure 16-9.

Choose Tools>Options. From the View tab, remove the
check mark from the Zero Values option.

Protect Your Work

1.

158

Select the cells in which you will enter the entry month
and the sales data.

Choose Format=>Cells.

On the Protection tab, deselect the Locked option
(as shown in Figure 16-10) and click OK.

Choose Tools=>Protection=>Protect Sheet.
Click OK.

Save the worksheet as a template to profect it from changes. (See
Chapter 7.)
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Tracking Medical
Expenses

Wth today’s high cost of medical care, very few of us can be without
medical insurance. In fact, many of us have two insurance compa-
nies, perhaps Medicare and a supplemental insurance, or insurance through
your employer and your spouse’s employer.

Tracking medical costs is very important, especially when filing your annual
tax return. In this project, you create an Excel spreadsheet that efficiently tracks
your expenses, generating totals, even sorting out prescriptions from the rest of
the medical expense totals. See at a glance how much your medical expenses
total, how much is paid by your insurance companies, and — most important
of all — how much you have to pay out of your pocket.

To accomplish this task, you use a number of Excel features including data
validation, duplication of worksheets, creating totals from other worksheets,
and a few Excel mathematical functions, too.

Hopefully your health is well and you won't need to use this worksheet a lot!
But if you do . . . you'll be glad it's here.

| “*\apter
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Chapter 17: Tracking Medical Expenses

Enter Text Headings

In cell A1, enter a heading for the worksheet.

In cells B4 and B5, type Total Billed and Total Paid by
Insurance, respectively.

In cells D4 and D5, type Total Paid Out of Pocket and
Total Due, respectively.

In cell D7, type Totals.

In cells A8 through K8, type the following: Bill Date,
Provider, Rx?, Description of Services, Total Amount
Billed, Insurance #1 Paid, Insurance #2 Paid, Write
Off, Paid Out of Pocket, Check Number, and Amount

Due. Your worksheet should look similar to Figure 17-1.

Create Totaling Formulas

1.

160

In cell E7, enter a formula to calculate the entire Total
Amount Billed column =SUM(E9:E50). Make the formula

longer or shorter depending on such as the items you have.

Select cell E7 again, and grab the AutoFill handle and
drag across to cell K7. This duplicates the formula from
F7 through K7. (See Figure 17-2.)

Select cell J7 and press Delete to delete the formula.

In cell C4, which references the total amount billed
shown in cell E7, type =E7.

In cell C5, type =F7+G7, which adds the insurance pay-
ments together.

In cell E4, type =17 to reference the total out of pocket
expenses.

In cell E5, type =K7 to reference the total still due.
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Figure 17-1: Enter headings for a medical expense fracking worksheet
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Specify Data Validation

Calculate the Amount Due

1.

Create a formula in cell K9 that subtracts the total of the
payments made from the total amount billed by typing
=E9-SUM(F9:19).

©)

Select cell K9.

Notice in Step 1, the compound formula created with a standard
reference and an Excel function.

Choose Edit>Copy a marquee appears.

Click and drag from cell K10 through the end of your
calculation area. Use the same amount of rows as in
Step 1 of the section “Create Totaling Formulas”.

Choose Edit=>Paste. Excel copies the formula. Figure 17-3
shows a value of 0 in each pasted cell.

Specify Data Validation

1.

In two adjacent cells, preferably in an unseen area, type
Yes and No.

Select cells C9 through C50, or whichever row you use
as your last worksheet row.

Choose Data>Validation.
From the Allow drop-down list, choose List.

Click the spreadsheet icon in the Source box. The Data
Validation dialog box temporarily collapses.

Highlight cells Q1 and Q2, or whichever cells you used
in Steps 1 and 2, and press Enter. The Data Validation
dialog box reappears, as shown in Figure 17-4.

Click OK. Notice when you click cell C9 or lower, a
drop-down arrow appears with the Yes or No choices.
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Figure 17-3: Copy the Amount Due formula

Data Validati
Settings | Input Message | Error Alert
Validation crieria
Alow:
Lise [v] Ignore blark
Data: 3 In-cell dropdowin
Source:
=5051:4082]

Figure 17-4: Setting a Yes or No validation
answer for the Rx column
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Chapter 17: Tracking Medical Expenses

Format the Worksheet

Highlight worksheet cells you want to format.

Apply any desired formatting such as applying currency
or number formatting, widening columns, bolding head-
ings, and applying borders. See Chapter 4. Figure 17-5
illustrates a formatting example.

Determine Print Settings

1.

162

Choose Filer>Page Setup. Excel displays the Page Setup
dialog box.

On the Page tab, select Landscape, choose the Fit To
option, and make it 1 page wide by 1 page tall.

Depending on the number of rows in your sheet, you may want fo
make the settings more than 1 page tall.

Click the Margins tab and enter .5 for each margin.
Click the Center on Page Horizontally option.

Click the Header/Footer tab and click the Custom
Footer button.

In the Left section, type Page &|[Page]| of &[Pages].
Optionally, click the Page Number and Number of
Pages buttons.

Click OK.

On the Sheet tab (shown in Figure 17-6), click in the
Print Area text box and type A1:K50 (or however many
rows you anticipate using).

Click OK to close the Page Setup dialog box.
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Figure 17-5: Apply formatting to your worksheet fo make it easier to read
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Duplicate the Worksheet for Other Family Members

Add Protection from Accidental

Password £o unpratect sheet:
Changes |
Allow all users of this warksheet ta:
Select locked cells ]
Select cells A1 and A2. Choose Formatr>Cells. £ o =

| Format columns
[ For

2. From the Protection tab, remove the check mark from

| tnse
the Locked option. Click OK. @éﬂi‘egthy?y.‘m
3. Select cells A9 through J50 (the data entry area). Choose e -
Formatc>Cells.
4. From the Protection tab, remove the check mark from Figure 17-7: Profect your worksheet
the Locked option. Click OK. from accidental changes

5. Choose Tools=>ProtectiontoProtect Sheet. The Protect
Sheet dialog box, shown in Figure 17-7, opens.

Move or Copy

Move selected sheets

. To baok:
6. Click OK. | Medical Bil Tracking ks ¥
Before shest:

| Mary
Shestz

Duplicate the Worksheet for -

In cell A2, type the patient’s name. Figure 17-8: Duplicate
2. Right-click the Sheetl tab and choose Rename. The }he ‘.'ImkSheEI for each
Sheetl name is highlighted. amily member
3. Type the patient’s name. Press Enter. Excel renames the
worksheet.

4. Right-click the newly renamed tab and choose Move
or Copy.

5. Click the Create a Copy option. (See Figure 17-8.)
Click OK. Excel adds a copy of the sheet.

Right-click the new worksheet tab and rename it to the
second patient’s name.

8. In the second patient worksheet, click cell A2 and enter 163
the second patient’s name.



Chapter 17: Tracking Medical Expenses

Create a Totals Worksheet

1.

W

& ® NS 0B

10.

12.

Rename the tab of Sheet2 (or any blank worksheet in
the workbook) to Totals.

From one of the patient worksheets, copy cells A1 and
A2 to cells A1 and A2 on the Totals worksheet.

From one of the patient worksheets, copy cells E8 through
18 to cells E8 through 18 on the Totals worksheet.

Widen the columns as needed to see the text.

In cell A2, type the word Totals.

In cell C8, type the words Patient Name.

In cell D8, type the word Service. (See Figure 17-9.)
In cells C9 and C10, type the first patient’s name.
In cell DY, type Rx.

In cell D10, type Other.

In cell D11, type Totals. (See Figure 17-10.)

In cells E9 through I11, type the formulas in the follow-
ing table, substituting Mary for the first patient worksheet
tab name.

In Cell Type

£

=SUMIF(Mary!C:C,” Yes”,Mary!E:E)

E10

=SUMIF(Mary!C:C,”No”,Mary!E:E

£l

=SUM(E9:E10)

F

=SUMIF(Mary!C:C," Yes”,Mary!F:F)
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Create a Totals Worksheet

In Cell Type a8
F10 =SUMIF(Mary!C:C,”No”,Mary!F:F
F11 =SUM(F9:F10)
69 =SUMIF(Mary!C:C,” Yes”,Mary!G:G)
610 =SUMIF(Mary!C:C,”No”,Mary!G:G
611 =SUM(G9:G10)
H9 =SUMIF(Mary!C:C,” Yes”,Mary!H:H)
H10 =SUMIF(Mary!C:C,”No”,Mary!H:H
HI1 =SUM(H9:H10) e Se o E s =
. o O T 7T Trass y
19 =SUMIF(Mary!C:C,” Yes”,Mary!l:l) O Y —— if
D bty A AN ke AR E M A
110 =SUMIF(Mary!C:C,”No”, Mary!l:1 Figure 17-11: The Medical Bill Tracker worksheet with sample data
m =SUM(19:110)
These formulas look at column C on the patient worksheet, and defer-
mine if the expense is a prescription. It then adds the values together.
13. Repeat Steps 8 through 12 for each patient. Figure 17-11

14.
15.

16.
17.
18.

illustrates data entered into the Mary worksheet and how
the totals reflect in the Totals worksheet.

Click cell Aland choose Formatc>Cells.

From the Protection tab, remove the check mark from
Locked.

Click OK.
Choose Tools=>Protectiont>Protect Sheet.

Click OK. The worksheet is now protected against acci-
dental changes.

If you need fo unprotect the sheet to make changes, choose Tools=>
Protection=>Unprotect Sheet.

Save and use the workbook as a template! See the next section to
do so.
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Sava M gis)
Save the Workbook as a Template e |
ERERCRC RN
1. Delete any data in the patient worksheets. L‘;,.‘:_".‘, NAIGH. feoiien Wdlabe G e G e
2. Choose Filem>Save As. The Save As dialog box appears, u[:.dw l,-,il—,.‘] M%L
as shown in Figure 17-12. 5 N i il
Hhy Docmns

From the Save as Type drop-down list, choose Template.

el
4. Click the Save button. pricesg
Close the template. You can now safely enter data into a s
blank Medical Bill Tracker without danger of modifying
the original template and its formulas. b T ]
e — e

Figure 17-12: Save the workbook as a template

166



Planning for Your
Financial Future

your life is taking shape right in front of you. You and your spouse want
to buy a house, raise a family, and spend life happily ever after. Your
personal future depends a lot on your financial future. Fortunately, Excel has
several functions you can use to plan for the future you want.

First, to keep up your expectations, you need to determine how much

house you can afford to buy. But before you can buy the dream house, you
know you need to pay off some credit card debt. Next, from you own experi-
ence, you know that college is expensive, and the costs are bound to get
much higher by the time the kids are ready. Finally will come your golden
years. You dream of the house on the beach or traveling to exotic places.

How are you ever going to save enough for that? This chapter shows you
how to

w= Determine how much payments will run on that cute little ranch
house down the street. Excel has a PMT function to help with that.

== Plan to pay off a credit card balance using the NPER function, which
requires three key pieces of information: the interest rate, the current
payment amount, and the credit card balance.

w= Determine how much you need to save each month to reach a college
fund or retirement goal. Again, utilize Excel’'s PMT function.

| “*lapter

18

Getready to. ..

w= Plan for a House 168
w= Prepare to Pay Off a

Credit Card Balance ... 169
w= Save for College or Retirement ................ 170



Chapter 18: Planning for Your Financial Future

Plan for a House

168

In cell A1, type OUR DREAM HOUSE.

In cells A3 through A8, type House Price, Down
Payment, Loan Amount, Interest Rate, Loan Term,
and Monthly Payment.

In cell B3, enter the house price.
In cell B4, enter the down payment amount.

In cell B5, enter the formula =B3-B4. This gives the
amount you will finance.

In cell B6, enter the interest rate. Format this amount as
a percentage.

In cell B7, enter the loan term. Usually for a house, this
value is in years. See Figure 18-1.

In cell B8, enter a PMT function to calculate the monthly
payment. The PMT function has three required argu-
ments (=PMT (RATE, NETPER, PV) so you need to
enter =PMT(B6/12,B7*12,B5). See Figure 18-2.

e RATE is the annual interest rate. You entered the
interest rate in cell B6. To get a monthly rate, you
divide this argument by 12.

e NETPER is the term of the loan that you entered in
cell B7. Because this value is in years, and you want
monthly payments, you multiply this argument by 12.

e PV represents the present value that is the amount
you will finance, not including interest. You calculated
this amount in cell B5.

When you type the start of a function, Excel displays a yellow box
containing a list of the arguments used by the function. Arguments
in brackets are opfional.
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Figure 18-1: Enter the values needed fo calculate o home loan payment
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Figure 18-2: Using the Excel PMT function



Prepare to Pay Off a Credit Card Balance

Prepare to Pay Off a Credit
Card Balance

L.
2.

In cell D1, type PAY OFF CREDIT CARD.

In cells D3, D4, and D5, type Monthly percentage rate,
Current payments, Credit card balance, and Months
until paid off, respectively.

In cell E3, create a formula to enter the monthly percentage
rate you are paying on a credit card. For example if you
are paying a 21% annual interest, you enter =21%/12.
Excel displays a value of .0175, which is the 21% annual
rate divided by 12 months. (See Figure 18-3.)

In cell E4, enter your current payment amount, preceded
with a minus sign. Enter -125 if you are making $125
payments every month against the credit card balance.

In cell E5, enter the remaining balance on the credit card.
Like the payments, this must be entered as a negative
value such as -3700.

Create an NPER formula to calculate how many months
you need to pay off the credit card. The formula should
read =NPER(E3,E4,E5). As you see in Figure 18-4, the
resulting answer shows how many months it will take to
pay off the credit card balance. The NPER function has
three required arguments:

e Interest rate is usually given annually, so you divide it
by 12 to give a monthly rate.

e Payment amount that you enter as a negative
amount.

e Present value is the amount of the loan, not includ-
ing interest.

Apply any desired formatting to the cells.
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Figure 18-3: Enter the annual interest rate divided by 12
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Save for College or Retirement

S B &2 W N~

N

10.

11.

12.

170

In cell A12, type OUR SAVINGS GOALS.
In cell A14, type Savings Goal Amount.
In cell A15, type Interest Rate.

In cell A16, type Years to Goal.

In cell A17, type Current Savings.

In cell A18, type Monthly Amount to Save. See
Figure 18-5.

In cell B14, enter the savings goal amount.
In cell B15, enter the annual interest rate.

In cell B16, enter the number of years you have until
you will need the money for college or retirement.

In cell B17, enter the amount you already have saved
toward the goal.

In cell B18, create a PMT formula that includes the interest
rate, term, and amount. You also need to add one of the
optional arguments: the future value argument. This time,
the PMT formula format is =PMT (interest rate,
term, current value, future wvalue) soyou
should enter =PMT(=PMT(B15/12, B16*12,B17,B14).
The PMT function actually has two optional arguments:

e Future Value is the balance of the loan after all
payments have been made. You do not need to enter
a future value unless the value at the end is not equal
to zero.

e Payment Type, one or zero, which indicates
whether the payment occurs at the beginning of the
month (1) or the end of the month (0).

Format the cells as desired. Figure 18-6 displays an
example.
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Figure 18-5: Reach your savings goals by following the Excel function
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Integrating Excel
into Word

No single computer program does everything. You probably use multi-
ple applications for different tasks, such as playing Solitaire, surfing

the Internet, reading e-mail, and of course, working with Excel. If you use
Excel, you probably use Microsoft Word to handle creating memos, letters,
and other such documents.

In this chapter, I show you how to integrate two major Microsoft Office
applications: Word and Excel. You discover how you can create a worksheet
in Excel and include it in the middle of a Word document.

If you begin by creating a table in Word, then conclude that you are better
off working with Excel, you also see how you copy the Word table into any
Excel worksheet. There’s no need to completely start over.

| “*lapter

Getready to. ..

= Copy Excel Cells into Word ...................... 172
w= |nsert a Saved Excel Worksheet

into Word 173
w= Edit the Inserted Worksheet .................. 173
w= Embed an Excel Worksheet into Word ......174
= Copy a Word Table to Excel..................... 175
w= (reate a Word Mail Merge Form

Letter Using an Excel List ..........cccooeen.... 176

= Make Mailing Labels.............ccccoeeerrrerrrne. 178



Chapter 19: Integrating Excel into Word
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Copy Excel Cells into Word

1. From the Excel worksheet, highlight the cells you want

The Word table includes any Excel formatting such as column width,

to copy into a Word document. Choose Edit=>Copy. B
2. Open a Word document. Make sure the blinking cursor e e
is at the location where you want the cells. e e
3. Choose Edit=>Paste. Excel pastes the cells into a 20, e N IR
Word table. Figure 19-1 shows both the Excel worksheet S s e
and the new Word table. g i
font, color, and border style. S 1 *
The Word table and the Excel worksheet are not linked together. N, : :” 1
Any changes made to one don't reflect on the other. L o g P R e

Figure 19-1: C(;hy Excel cels into a Word fable
4. Modify the Word table using any of the following:

e Replace a value: Highlight any existing text in a cell
and type the replacement text.

¢ Delete a column or row: Click in a cell of the col- e T
umn or row you want to delete and choose Tabler> o e
Deleter>Columns or Table=bDeletec>Rows. W PN
e Insert rows or columns: Click in a table cell where i3
you want the new row or column and choose Table=> AT W —

Insert. Then select Columns to the Left, Columns to |
the Right, Rows Above, or Rows Below.

e Widen a column: Position the mouse at the line to
the right of any column and drag to the left or right.

e Delete the table from the Word document: Select the -
row above the table, the table itself, and the row below

the table and press the Delete key (see Figure 19-2). iy -

172 Figure 19-2: Remove the table from Word



Edit the Inserted Worksheet

Insert a Saved Excel Worksheet o o o o e

b s 42 T8 din: I DM GLE O TN e
- -

into word ’,‘.g...,.: p m-,_.-..... 29 ‘. " !.'“.-_.A- -;.:- = = ,'.’_,-. -.'L

1. In a Word document, position the insertion point where
you want the worksheet to appear.

Choose Insert=>Object. The Object dialog box opens.

From the Create from File tab, click the Browse button.
The Browse dialog box opens.

4. Locate and double-click the Excel file you want to bl e =
include in your Word document. The Object dialog box
reappears (see Figure 19-3).

5. Click OK. The Excel workbook appears as a Word table.

Even if your worksheet contains mulfiple sheets, only the top sheet TR et
with all cells containing data appear. You cannot specify a particu- Figure 19-3: Insert a worksheet as an object
lar range of cells. If you want an Excel chart, save the workbook

with the chart on top before inserting into Word. T P e

Edit the Inserted Worksheet

1. Click once on the Word table.

2. Perform one of the following actions:

e Press Delete to delete the table.

e Drag one of the handles to resize the table.

e Double-click to edit the values. The Excel menu bar
appears, along with column letters and row numbers.
(See Figure 19-4.) The worksheet includes any formu-
las you created in Excel.

3. Click outside the table to deselect the table. kI —
Figure 19-4: Edit cells, formulas, or formatting

Badis A
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Embed an Excel Worksheet into Word

174

1.

Follow Steps 1 through 4 of the “Insert an Existing
Worksheet into Word” section.

Click the Link to File option in the Object dialog box,
shown in Figure 19-5. Click OK. The Excel workbook
appears as a Word table. The Word table is linked to the
original Excel worksheet.

If you dick Display as Icon, instead of displaying the workhook as a
table, Word inserts an Excel icon info the document. Double-clicking
the icon opens the workbook in Excel. However, the Excel program
must be installed on the PC trying to open the workbook.

To resize the Word table, click once on the table, which displays the
eight sizing handles, and drag any handle until the table reaches
the size you want.

To delete the table, click once on the table and press the Delete key.

Make changes in the Excel workbook and the Word
document using any of the following methods:

e With the Word document open, right-click the Word
table and choose Update Link.

e Double-click the Word table, which launches the
Excel program and opens the linked workbook
(see Figure 19-6). Make any changes in Excel;
the Word table automatically updates.

¢ When you reopen the Word document, a dialog box
prompts you to update the Word document from the
original Excel file. Click Yes.
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Copy a Word Table to Excel

Copy a Word Table to Excel

1.

8.

In Microsoft Word, create a table (choose Tabler>
Inserte>Table).

Enter any desired data in the Word table.

Press Tab to move from cell to cell, or click the mouse in any indi-
vidual cell.

Drag across the table to highlight the cells you want to
copy, as shown in Figure 19-7.

Choose Edit>Copy or press Ctrl+C.

To move, instead of copy, the Word table to Excel, choose Editc>
Cut or press Cirl+X.

Open or create the Excel workbook in which you want
to place the Word table.

Click the cell in which you want the table to begin.

Choose Edit=>Paste or press Ctrl+V. The Excel worksheet
displays the Word table. As shown in Figure 19-8, each
cell in the Word table occupies one cell in the Excel
worksheet.

If the Word table cells have a border around them, the Excel cells
also have a border around them.

The Word table and the Excel worksheet are not linked together.
Any changes made to one don't reflect on the other.

Format the cells as desired. See Chapter 4.
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Figure 19-8: Copy a table from Word to Excel
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Create a Word Mail Merge Form
Letter Using an Excel List

1.

NI

e X NS

10.

176

Create and save an Excel worksheet with the data you
want to merge in an Excel list. The Excel worksheet does
not need to be open.

Although not a requirement, the data will be easier for you to
identify later if it has column headings.

In Word, choose Tools=>Letters and Mailings=>Mail
Merge. The Mail Merge task pane appears on the right
side (see Figure 19-9).

Select the Letters option.
Click Next: Starting Document.

Choose whether to create the mail merge from the cur-
rent Word document or an existing Word document.

Click Next: Select Recipients.
Select the Use an Existing List option.
Click Browse. The Select Data Source dialog box appears.

Double-click the Excel file containing your list. The
Select Table dialog box opens, as shown in Figure 19-10.

Select the range name, sheet name, or area containing data.

If the first row of your list does not contain headers, remove the
check from the First Row of Data Contains Colomn Headers option.
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Figure 19-9: Select a mail merge document type
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Creating a Word Mail Merge Form Letter Using an Excel List

11.

12.

13.
14.

15.

16.

Click OK. A Mail Merge Recipients list like the one in
Figure 19-11 appears, containing your data.

Remove the check mark next to any record you don't
want to include. Click OK.

Optionally, click Clear All to clear all the check marks or click
Select All o check all the records.

Click Next: Write Your Letter.

Type the form letter document, leaving blanks where
you want the variable (such as name, address, phone
number, or product) information to appear.

Click the insertion point at the first location where you
want the variable information (such as the recipient
name and address location).

From the task pane, select the desired option:
e Address Block: Select an address layout.

e Greeting Line: Insert a greeting of your choice, along
with the recipient’s first name (if you have such a
field in your database), and then a comma or colon.

e Electronic Postage: Prints electronic postage on your
envelopes (if you subscribe to an electronic postage
service).

e Postal Bar Code: Prompts you for the zip code field
from your Excel list and inserts a bar code matching
the zip code field.

e More Items: Displays the Insert Merge Field dialog
box (see Figure 19-12), which displays each field
listed in your Excel list. Click the field you want to
insert into Word, and click the Insert button.
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Chapter 19: Integrating Excel into Word

17. Click Next: Preview Your Letters. As shown in Figure [ o s ==
19-13, the document you created appears with the first T P A ST TR Wl - TP I SIS e 1
el et o — TR T yaeTey

data record from your Excel list. = g
Jarkiary 14, 2006

Click through the Forward and Back buttons to browse through each

AL UNGER

recipient in your lst. If you find a repient you don't want fo ; Sk AW
indude, click the Exclude This Recipient button. ATLANTALIN 46131
B Atz AL LUNGER
!
18. Click Next: Complete the Merge. You can now print . TG edfloriar Mewstratmdrd e L M S St Ao

held this year on July 4, at the Mamiott Bast. The fee for attending this seminar
$150.00 which you need to remit by June 17, If you have any guestions; pleas
free to call olr Seminar Reservation hot line at 1-B00-555-5555,

your form letters. |

We look, forward to sesing you on July 47!

To edit a specific letter, dick Edit Individual Letters. To make a change '
to the master document, click the Previous button unfil you get fo . i

Sincerely,
Step 4, and then make any desired changes. Click the Next button s
until the merge is completed. Event Hansger

= )
.

Make Mailing Labels ==

igure 19-13: Preview the merged Excel list in the Word document file
Follow Steps 1 and 2 from the previous section.

Select the Labels option and click Next: Starting Document. ltlmm -
Click Label Options. The Label Options dialog box, o e
shown in Figure 19-14, appears. i |y e x
4. Choose the label size and click OK. You see a blank nﬁ%.. » B bee
document with label gridlines. ner- Al oo I
5. Click Next: Select Recipients. Follow Steps 7 through 12 : g
Detads,. | [ heswiabol, | oo ) |

of the previous section.

6. Click Next: Arrange Your Labels. On the first label,
either insert the Address Block or individual fields.

7. Click the Update All Labels button. The fields you
inserted appear on each label.

Figure 19-14: The Label Options dialog box

8. Click Next: Preview Your Labels. Each record appears on
its own label.

9. Click Next: Complete the Merge. Print your labels.
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Blending Excel and
PowerPoint

One of the most common ways to make others aware of your work is
by giving a presentation. The Microsoft Office product, PowerPoint, is
one of the most effective presentation products available in today’s market.
And because PowerPoint is part of the Microsoft Office suite, it's very easy
to integrate information from other Office applications — in this example,
Excel — into a PowerPoint presentation.

My mother always told me to do things right the first time. If you already
spent the time and energy to create information in Excel, why should you
have to re-create it in your PowerPoint presentation? You don't.

That's what this chapter is about. You find out how to take the powerful
worksheet data or creative chart that you created in Excel and copy it to a
PowerPoint slide. You can simply copy it once from Excel to PowerPoint, or
you can create a link so that if the data in Excel changes, your PowerPoint
presentation automatically reflects the changes. That's doing it right the
first time.

| “*lapter
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a PowerPoint Slide 181
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Chapter 20: Blending Excel and PowerPoint

Copy Excel Cells into
a PowerPoint Slide

1.

180

From the Excel worksheet, highlight the cells you want
to copy (see Figure 20-1). Choose Edit=>Copy. A mar-
quee appears around the highlighted cells.

Open a PowerPoint presentation. Make sure you display
the slide on which you want to paste the cells.

Choose Edit>Paste or press Ctrl+V. Excel pastes the cells
into a PowerPoint table including any formatting.

The PowerPoint table and the Excel worksheet are not linked
together. Any changes made to one don't reflect on the other.

Modify the PowerPoint table using any of the following:

e Replace a value: Highlight any existing text in a cell
and type the replacement text.

e Delete a row: Click in the row you want to delete,
right-click, and choose Delete Rows.

e Delete a column: Highlight the column you want to
delete, right-click, and choose Delete Columns.

e Change a column width: Position the mouse at the
invisible boundary line (as shown in Figure 20-2) to
the right of any column and drag to the left or right.

¢ Delete the table from the slide: Click once to select
the table object (the table object boundary has
striped edges) and click again on the table object
boundary and press the Delete key.
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Figure 20-1: Use your favorite Copy command to duplicate cells
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Drag an Excel Chart into a PowerPoint Slide

Drag an Excel Chart into
a PowerPoint Slide

1.

Open both the PowerPoint presentation you want to use
and the Excel workbook that contains the chart. Make
sure to display the PowerPoint slide you want.

Resize and arrange the PowerPoint and Excel windows
so that both are visible at the same time. Use either of
the following methods:

e Right-click a blank area of the Windows taskbar and
choose Tile Windows Vertically or Tile Windows
Horizontally.

e (Click the Restore button in each window so they are
no longer maximized. Drag the window borders to
resize them and drag the title bars to move them until
both windows are in the desired size and location.

Select the Excel chart you want to copy.

Hold Ctrl and drag the chart from the Excel window until
it is in the PowerPoint slide. As you drag the mouse, the
pointer looks like a small box as in Figure 20-3.

If you want to move the chart from Excel to PowerPoint, instead of
copying it, don't press Cirl. Dragging an object without Cirl moves
the obiect.

Release the mouse button. The Excel chart appears on
the PowerPoint slide, as shown in Figure 20-4.

Maximize the PowerPoint window to restore it to full
screen. You can then resize or edit the chart as desired.
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Chapter 20: Blending Excel and PowerPoint

Insert a Saved Excel Worksheet = =
a a a Z)rrake i e [ocama |
or Chart into a PowerPoint Slide ==
1. In PowerPoint, display the slide you want the worksheet E‘D bt s el ot s
or chart to appear on. B rcperlrli P et
If you want to copy a chart, make sure to save the workbook with F-ig;_ljre 20-5: Inserting data from a previously _
the chart as the top sheet. If your workbook contains multiple work- saved Excel workbook
sheets, only the top sheet appears in the PowerPoint slide.
(= T T T
2. Choose Insert=>Object. The Insert Object dialog box e e S iy A S
T T ENE [T ey _'.:}-;:J’Ei:n.;_twilll 4

opens (see Figure 20-5).

Click the Create from File option.

Click the Browse button. The Browse dialog box opens.

Double-click the Excel file you want to include. The
Object dialog box reappears and the path and filename
appear in the File text box.

6. Click OK. The Excel workbook or chart appears on the
current PowerPoint slide, as shown in Figure 20-6.

7. Modify the PowerPoint table or chart with any of the
following methods (or check out the earlier section
“Copy Excel Cells into a PowerPoint Slide” for addi-

Fe

st 4

tional ways): e T T PP -
Any changes are saved in PowerPoint only, not in the original Figure 20-6: An Excel chart inserted into a PowerPoint slide
Excel workbook.

e Click once on the PowerPoint object. Drag a handle
to resize the object.

e Double-click the table or chart to edit the actual val-
ues. The Excel menu bar appears, along with column
letters and row numbers.
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Link an Excel Worksheet into a PowerPoint Slide

Link an Excel Worksheet B —m
into a PowerPoint Slide g e —
1. Open the desired Excel file. When creating a link, the s L, AT T O

M'E'] preve fakaan, bt ibecodea » stk U
mu’nwl}(d‘uﬂqﬂmwm:u fie el b
refleched 11 youe reson

originating Excel file must be a previously saved file.

2. Select the portion of the file you want to duplicate in F_i@ 20-7: The_PowerPoim Puste Speall didlog box

PowerPoint.
Choose Edit=>Copy or press Ctrl+C. e =
4. Display the PowerPoint slide on which you want to create L ._—‘ .—‘—' e
the link and choose Edit>Paste Special, which displays L= _. —
the Paste Special dialog box (see Figure 20-7). ’-E il 1
. . e ~— | Forthe Sales Associate...
5. Choose the Paste Link option. With this option selected, : "'T| ' 4 ? |
any changes you make to the original workbook reflect in L‘: 5 ity
the PowerPoint slide each time you open the PowerPoint = | - - s":‘dm ?;’;’ g"m""ss';;
presentation. ‘ $ 2000 359 5 70
== B $ 8000 40% _ s 120
If you click Display as lcon, PowerPoint inserts an Excel icon onto ' '3 4,000 45% i 0
the slide. Double-clicking the icon opens the workbook in Excel. e § 5000 6.0% °_ : o
The PC opening the workbook must have Excel installed. % ] I L
6. Click OK. The linked object appears on the slide. \; ; I:é
Refresh Excel data in PowerPoint by one of these | e L
methods; Praw - Mln» R e S YT M

e With the PowerPoint presentation open, right-click Figore 20-8: Upduting the PowerPomI slide ob|ed

the PowerPoint table and choose Update Link (see
Figure 20-8).

e Double-click the PowerPoint table, which opens the
linked workbook in Excel. Changes in Excel automat-
ically update in the PowerPoint table.

e When you reopen the PowerPoint presentation, a dia-
log box prompts you to update PowerPoint from the

original Excel file. Click Yes.
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Using Excel
with Access

you can share data between Access and Excel in many ways. You can
copy data from an open worksheet and paste it into an Access data-
sheet, import a worksheet into an Access database, or simply load an
Access datasheet into Excel using the Analyze It with Excel command.

This chapter shows you how to exchange data between Access and Excel
through one of several processes:

»= Importing, which creates a copy of an Excel spreadsheet in Access
format.

== Linking, which connects an Access table to an Excel worksheet. You can
view and edit the data in both the original program and in the Access
file. Linking is useful when you need to share Excel data between
Excel and Access users.

»= Exporting, which lets you analyze your Access data in Excel format.
This chapter assumes you already know general database terms, such as records,

fields, tables, queries, and primary keys. I also assume you know the basics
of creating and using an Access database.
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Chapter 21: Using Excel with Access

Copy Data from Excel
to an Access Table

1.

e R NS

10.

186

If you don't already have an Access database created, from
Access, choose Filec>New. If you already have an Access
database, open the database and skip Steps 2 and 3.

From the task pane, click Blank Database. The File New
Database window appears.

Enter a name and location for the new database and click
Create.

Switch to the Excel worksheet that contains the data you
want to copy.

You cannot save an Excel worksheet as an Access database and
you cannot create a link to Access from within Excel.

Highlight the cells you want to copy to Access. Be sure
to include headings if you have them, as shown in
Figure 21-1.

Choose Edit=>Copy.
Switch to the Access database.
Choose EditcoPaste.

Click Yes if you included column headings in Step 5.
A completion message box appears.

If you included headings, Access uses those headings as field
names in the fable.

Click OK. Access creates a new table in the database (see
Figure 21-2).
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Import Data from Excel to an Access Table

Import Data from Excel
to an Access Table

1.

Prepare your Excel worksheet data before importing:

e If you don’t want to import the entire worksheet, in
the Excel workbook, create a named range containing
the cells that you want to import. (See Chapter 2.)

e Make sure the cells are in tabular format. If the work-
sheet contains merged cells, then the contents of the
cell are placed in the field that corresponds to the
leftmost column, and the other fields are left blank.

o [f the Excel spreadsheet has a cell containing more
than 255 characters, and the cell is in a row farther
than row 25, move the row up in the Excel list so it’s
within the first 25 records. Otherwise, Access trun-
cates the data to 255 characters.

If you don't already have an Access database created, from
Access, choose Filer>New. If you already have an Access
database, open the database and skip Steps 3 and 4.

From the task pane, click Blank Database. The File New
Database window appears (see Figure 21-3).

Enter a name and location for the new database and
click Create.

Choose Filer>Get External Datac>Import. The Import
dialog box appears.

Select Microsoft Excel from the Files of Type drop-down
list, as shown in Figure 21-4.

Select the Excel file from which you want to import data.

Importing a worksheet into Access creates a duplicate copy of the
data and does not make any changes fo the source Excel file.
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Chapter 21: Using Excel with Access

10.

11.

12.

13.

188

Click the Import button. The Import Spreadsheet
Wizard appears (see Figure 21-5).

Select whether to import the entire spreadsheet or a
range. If the spreadsheet has no named ranges and only
one worksheet, you do not see this screen. Click Next.

Specify whether the first row of your worksheet contains
column headings. If it does, Access creates field names
from the first row. If it doesn't, you can assign field
names in Step 12. Click Next.

Specify whether you want the data in an existing table
or a new table. If you want the data in an existing table,
you need to select the table name. Click Next.

If you select an existing table, Access appends the data fo the table.
Make the sure the number of columns in the worksheet or named
range matches the number of fields in the table. The name, date
type, and position of each column must also match those of the cor-
responding field in the Access fable.

Assign field names to each column by clicking each col-
umn and typing a name in the Field Name text box.
(See Figure 21-6.)

If a column name violates the field naming rules in Access, Access
assigns a valid name to the field.

Choose Yes or No if you want the field indexed.
Click Next.

Optionally, click on a column you don't want to include and dick the
Do Not Import Field (Skip) option. You can skip columns during the
import, but you can't skip rows.
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Import Data from Excel to an Access Table

14.

15.
16.

17.

18.

Select an option for the primary index key. You can either
let Access create one for you, select your own primary
key or not have a primary key at all. Click Next.

Enter a name for the Access table.

Click Finish. Access imports the data and displays a
message box like the one in Figure 21-7.

If any errors incur during the import, Access creates an error log fable
in the database and displays the name of the table in the message.
It's a good idea to open the error log table and review the errors.

Click OK. Access creates the table (see Figure 21-8).

To import multiple worksheets or named ranges, repeat the
import process for each worksheet or range.

Review the imported data. Keep the following items in
mind:

e Graphical elements: Access does not import graphi-
cal elements, such as logos, charts, and pictures.

e Data type: Access determines the data type based on
the first 25 rows of data. If any values beyond the
25th row are not compatible with the chosen data type,
Access ignores those values and does not import them.

You cannot change the data type of the destination field during the
import operation, but you can change data types from the Access
table design.

e (Calculated values: Access imports only the results of
a calculated cell, not the formula itself. If you need
the formulas to update, you need to link the Excel
worksheet to Access.

e Hyperlinks: Access imports cells containing hyperlinks
as text fields.
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Chapter 21: Using Excel with Access

Link an Excel Worksheet
to an Access Database

1.

10.
11.
12.

190

Begin by applying Steps 1 through 4 of the previous
section.

Choose Filer>Open. The Open dialog box appears.
From the Files of Type list box, select Microsoft Excel.

Locate and select the Excel worksheet you want to link
to Access (see Figure 21-9).

Click the Open button. Access creates a blank database
named with the Excel filename, and automatically starts
the Link Spreadsheet Wizard.

Select which worksheet or named range you want to
link. If the spreadsheet has no named ranges and only
a single worksheet, you do not see this screen.

You can import only one worksheet or named range at a fime. To link
multiple worksheets or named ranges, repeat the link operation.

Click Next.

Specify whether the first row of your worksheet contains
column headings (see Figure 21-10). If there are head-
ings, Access creates field names from the first row. If not,
Access assumes the first row is a record.

Click Next. Enter a name for the table.

Click Create.

Click Finish. A completion message box appears.
Click OK.
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Figure 21-9: Determine the Excel file you want Access to link
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Analyze Access Data with Microsoft Excel

13. Double-click the Access table that appears as an Excel icon

with an arrow next to it (as shown in Figure 21-11). Keep
the following in mind when reviewing the data in Access:

e Graphics, such as logos, charts or pictures, stored in
the Excel worksheet, are not visible in Access.

¢ You cannot change the field data type or size.

e The source cells that contain formulas display only as
results in Access, but you cannot modify the values in
Access.

e Access stores Excel cells longer than 255 characters in
a memo field that displays only the first 255 characters.

If you delete the table from Access, you're deleting only the link,
not the actual Excel worksheet.

Analyze Access Data
with Microsoft Excel

1.

Open the Access database you want to analyze.
Select the datasheet, form, or report you want to analyze.

Choose Tools>Office Links=>Analyze It with Microsoft
Excel. The datasheet opens in Microsoft Excel as an
Excel worksheet. Figure 21-12 shows both the Access
form and the Excel worksheet.

Access saves the datasheet as an Excel file in the same location as
the Access file. If a file already exists with that name, Access prompts
you to overwrite the existing file. If you choose not fo, then Access
prompts you for a filename and location.

The worksheet is not linked to Access. Any changes made to the
Excel worksheet do not appear in the Access datasheet.
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Figure 21-11: An Excel linked icon in an Access
databose
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Export Access Data to Excel

. L |l Bl e v 3 sl
1. Open the Access database and select the database object 7 o a E-::-'m--m:m E ot |
. AT S Proders
that you want to export. (See Figure 21-13.) The follow- T | bty H oty s |
ing table illustrates what Access exports, depending on | e O et
the object and the view you have open when perform- ki I; g g - Sl
ing the export. i l; s %
Gy S ervhyses s track
You can export only an Access table, query, form, or report. You [ S e
| 1% ']

cannot export data Access pages, macros, or modules.

Figure 21-13: Select the Access object you want
to export

Object View What Exports

4] Savas e
U Hile Lt Wiew joert [oeb Windew Help Show Me

Tables, Queries,  Databose window  Everything unless you pre-select an
or Forms area before exporfing.

v
>

Al fields and records even if the fields aren't
included in the view.

Form Form view

i

Report Database window,

Print Preview, or
Layout Preview

All data Group Header and Detail text hoxes,
and any text box in a Group Footer that has a
Sum function. Access uses Excel’s Outline feature.

[aweswalf] |
HERRRN

i

2. Choose FilemExport. The Export To dialog box shown in
Figure 21-14 appears.

In the Save as Type box, choose Microsoft Excel 97-2003.

4. TFrom the Save In box, select a location in which to save
the file, as shown in Figure 21-15.

5. In the File Name box, enter a name for the file. By Figure 21-14: The Export To dialog box

default, Access suggests the Access object name.
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Export Access Data to Excel

Optionally, if you are exporting a table or a query, click
the Save Formatted check box, which tells Access to also
export the field formatting. If the filename you selected
in Step 5 already exists, one of the following occurs:

e If you don't select the option, and the filename you
choose already exists, Access doesn’t overwrite the
file; it adds a new worksheet to the file with the same
name as the object that is being exported.

e If you select the option and export a table, the Excel
worksheet takes on formatting similar to the Access
table, but overwrites the existing worksheet contents.

e If you select the option and if you export an Access
form or report, Access overwrites the Excel workbook
by removing the original worksheets, and creating a
new worksheet with the same name as the exported
object.

Click the Export button or, if you want to export only a
pre-selected datasheet portion, click Save Selection. Addi-
tionally, the following actions occur during the export:

e Graphic items such as images do not export.

e Only calculation results export, not the calculation
itself.

e Check boxes on forms do not export.
e Subreports export, but subforms do not.

e Date values earlier than Jan 1, 1900, do not export
and are replaced with a Null value.

Open the Excel worksheet and validate the export
feature. (See Figure 21-16.) For example, if a value was
Null in Access, during the export, the values might be
replaced with the data that should be in the adjacent
column in the resulting worksheet.

|
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Figure 21-15: Select a location for the exported Excel file
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Figure 21-16: Export some or all of the Access data to Excel

193



Chapter 21: Using Excel with Access

194



-,

o Symbols and Numerics ®

& (ampersand), joining text items using, 148
" (apostrophe), ignored during sort, 78
* (asterisk)

as multiplication operator, 21

not allowed in worksheet names, 55
\ (backslash), not allowed in worksheet names, 55
$ (dollar sign)

for absolute references, 62

specifying repeating rows and columns, 104
= (equal sign) for references, 61, 62
- (hyphen), ignored during sort, 78
/ (slash)

as division operator, 21

not allowed in worksheet names, 55
3-dimensional effects

AutoShapes, 50

charts, 94

o/ o

absolute formulas, 26

absolute references, 62

Access
analyzing data with Excel, 191
copying data from Excel to, 186

exporting data to Excel, 192-193

importing data from Excel to, 187-189

linking a worksheet to a database, 190-191
Advanced Filter feature, 124-125
aligning data in cells, 15, 34
ampersand (&), joining text items using, 148
analyzing Access data with Excel, 191
annotating, text boxes for, 48
apostrophe (‘), ignored during sort, 78
arranging windows, 70
arrows in worksheets, 47, 52
asterisk (*)

as multiplication operator, 21

not allowed in worksheet names, 55
auditing formulas, 30
AutoCorrect feature, 149, 150
AutoFill feature

copying formulas with, 25

for custom lists, 79

extending a data series with, 19
AutoFilter feature

customizing, 119, 122

finding multiple criteria, 123

overview, 119

secondary filter selection, 120

Top 10 option, 119, 121
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AutoFormats feature, 40, 132
AutoOutline feature, 114
AutoShapes feature, 49, 50, 52
AutoSum button, 24

conditional formatting for, 46
copying data to Access table, 186
copying formatting, 40

copying into PowerPoint slides, 180
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average value, calculating, 24
axes of charts
displaying or hiding, 90
formatting the Value axis, 95
labels for, 91
X or Category axis, defined, 86
Y or Value axis, defined, 87

ol e

background color for cells, 44

backslash (\), not allowed in worksheet names, 55
bold type in this book, 1

borders around cells, 45

o o

cascading windows, 70

case
macro names and, 140
passwords and, 59
searching for data and, 81

cell references. See references

cells. See also data entry; formatting
adding borders, 45
aligning contents, 15, 34
background color for, 44
changing the active cell, 14
clearing formats, 46

copying into Word, 172
deleting data, 16

editing data, 16

finding, based on format, 82
hyperlinks for, 63

importing data to Access table, 187-189

indenting data, 35
inserting comments, 72
inserting hyperlinks, 63
merging data in, 148
merging to create a title, 35
naming a range, 18
relocking, 58

selecting multiple cells, 17
unlocking, 58

wrapping text in, 36

charts

adding data series, 95
adding data tables, 90, 93
adding graphics, 87, 92
adding titles and labels, 91
basic, creating, 86
changing location of, 93
changing type for, 90
Chart Wizard for, 88-90
customizing the legend, 91
deleting, 86-87

deleting data series, 95

dragging into PowerPoint slides, 181
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elements of, 86-87
formatting the Value axis, 95

inserting into PowerPoint slides, 182

modifying attributes, 92

organization, creating, 96

overview, 85

PivotCharts, 138

printing, 105

subtypes, 89

3-dimensional effects, 94

types available, 88-89
circular reference error, 29
clearing. See also deleting or removing

conditional formatting, 48

print area, 101

selections, 17
clip art, inserting, 51
closing Excel or Excel workbooks, 6
collapsing subtotal headings, 111
college savings worksheet, 170
colors

for arrows, 47

for AutoShape shadows, 49

background for cells, 44

for fonts, 44

for gridlines, 104

for worksheet tabs, changing, 56
columns in worksheets

adjusting width, 38

freezing and unfreezing titles, 69

grouping and ungrouping, 115

hiding and unhiding, 57

merging data in, 148

printing headings, 104

repeating, 104

R1C1 style for, 74

splitting data into multiple columns, 147
comments, 72, 74
Commission Calculator worksheet

calculating commissions, 156-157

counting sales, 156

creating the commission table, 154

creating totals, 157

entering headings, 154

formatting, 158

overview, 153

protecting, 158

sales data input area, 155

totaling sales, 155
comparing spreadsheets, 71
compound formulas, 23
conditional formatting, 46
conventions in this book, 1
converting merged cells into plain text, 148
copying. See also inserting

absolute formulas, 26

cells into PowerPoint slides, 180

cells into Word, 172

charts into PowerPoint slides, 181

data, pasting and, 18

data to Access table, 186

formatting, 40

formulas with AutoFill, 25

subtotals, 113

values using Paste Special, 26

Word tables to Excel, 175

worksheets, 55
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COUNTIF function, 156 databases. See also Access; filtering data
credit card payments worksheet, 169 creating a data entry screen for, 118
cropping images, 52 defined, 109
customizing dates
AutoFilter feature, 119, 122 entering in cells, 15
chart legend, 91 formatting, 37
header or footer for printing, 103 sorting by, 80
lists, 79, 80 validating, 20
toolbars, 146 decimals
viewing options, 74 alignment of data and, 15
formatting, 34
) D ) deleting or removing. See also hiding
arrows, 48
data entry AutoCorrect entries, 149
alignment in cells and, 15 AutoOutline, 114
AutoFill for data series, 19 AutoShapes, 49
copying and pasting, 18 cell data, 16
creating a data entry screen, 118 cell formats, 46
deleting cell data, 16 charts, 86-87
editing cell data, 16 clearing conditional formatting, 48
primary types of data, 13 clearing print area, 101
undoing, 16 clearing selections, 17
validating data, 20 comments, 72
data series in charts custom lists, 79
adding a series, 95 data series in charts, 95
adding graphics, 92 existing Excel file, 8
deleting, 95 graphics, 52
overview, 87 hyperlinks, 63
data tables for charts, 90, 93 macros, 144
data validation PivotCharts, 138
locating cells with, 19 PivotTable fields, 131, 137
in Medical Bill Tracker worksheet, 161 PowerPoint slide elements, 180
using, 20 separate PivotTables, 133

198



Index

subtotals, 113

text boxes, 48

ungrouping items, 115

Word table columns or rows, 172

Word tables, 172, 173, 174

worksheets, 54

worksheets embedded into Word, 174
digital signatures for macros, 141
displaying. See viewing or displaying
DIV/Q! error, 29
dollar sign ($)

for absolute references, 62

specifying repeating rows and columns, 104
drawing AutoShapes, 49
DREAM HOUSE worksheet, 168

oFf o

editing
cell data, 16
cells copied into Word, 172
comments, 72
custom lists, 79
formulas, 25
tables in PowerPoint slides, 180
worksheets inserted into Word, 173
e-mail
attaching workbook to, 105
hyperlinks for, 63
embedding worksheets into Word, 174
entering data. See data entry
equal sign (=) for references, 61, 62
error checking for formulas, 149

error messages for formulas, 29
exporting Access data to Excel, 192-193

ofF e

files
deleting, 8
hyperlinks for, 63
opening an existing Excel file, 8
opening in different formats, 12
password-protecting, 60
saving as templates, 73, 166
saving in different formats, 12
searching by properties for, 12
filtering data
advanced filtering, 124-125
AutoFilter for, 119-123
for blanks in selected field, 119
customizing AutoFilter, 119, 122
for data (NonBlanks) in selected field, 119
finding multiple criteria, 123
overview, 117
secondary filter selection, 120
Top 10 option, 119, 120
financial planning worksheets
OUR DREAM HOUSE, 168
OUR SAVINGS GOALS, 170
overview, 167
PAY OFF CREDIT CARD, 169
finding. See also filtering data
all data occurrences, 82
cells based on format, 82
cells with data validation, 19
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finding (continued)
clip art, 51
data containing a word or value, 81
files by properties, 12
and replacing data, 83
tracing formula dependents, 30
fonts, 36, 44
footers, 102-103
form letter in Word using Excel list, 176-178
formatting. See also colors
aligning data, 34
arrow styles, 47
AutoFormat feature for, 40, 132
cell borders, 45
column width, 38
Commission Calculator worksheet, 158
conditional, 46
copying, 40
dates, 37
finding cells based on format, 82
font attributes, 36
indenting data in cells, 35
Medical Bill Tracker worksheet, 162
merging cells to create a title, 35
PivotCharts, limitations on, 138
PivotTable values and text, 134
PivotTables using AutoFormat, 132
replacing data and, 83
rotating text, 37
row height, 39
styles for, 41
text boxes, 48
Value axis of chart, 95

values, 34
wrapping text in a cell, 36

formulas. See also functions
absolute, defining, 26
adding to PivotTables, 137
amount due calculation, 161
auditing, 30
AutoSum button for adding numbers, 24
for average value, 24
commission calculation, 156-157
in Commission Calculator worksheet, 155-157
compound, creating, 23
copying with AutoFill, 25
counting sales, 156
editing, 25
error checking for, 149
Function Wizard for building, 27
hidden rows or columns and, 57
IF statements for, 28, 156-157
in Medical Bill Tracker worksheet, 160-161,

164-165

merging data in columns, 148
in OUR DREAM HOUSE worksheet, 168
in OUR SAVINGS GOALS worksheet, 170
overview, 21
in PAY OFF CREDIT CARD worksheet, 169
payment calculation, 168, 169
references in, 61, 62
savings calculation, 170
simple, creating with operators, 21
totaling, 155, 157, 161, 164-165
troubleshooting errors, 29

freezing titles, 69
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full screen view, 71
Function Wizard, 27
functions. See also formulas; specific functions
arguments list for, 168
changing in PivotTables, 132
in Commission Calculator worksheet, 155-157
for hyperlinks, 63
inserting, 27
in Medical Bill Tracker worksheet, 160-161,
164-165
merging data in columns, 148
in OUR DREAM HOUSE worksheet, 168
in OUR SAVINGS GOALS worksheet, 170
overview, 21
in PAY OFF CREDIT CARD worksheet, 169

oG o

graphics
adding to charts, 87, 92
arrows, 47
AutoShapes, 49
clip art, 51
customizing viewing options, 74
inserting hyperlinks, 63
inserting saved images, 50
manipulating, 52
shadows for AutoShapes, 49
text boxes, 48
3-dimensional, 50

graphs. See charts

gridlines
of charts, 87, 90, 92
colors, 104

printing, 104

showing or hiding in worksheets, 74
grouping

PivotTable data, 136

rows or columns (outline groups), 115

o o

headers, 102-103
headings
collapsing and expanding for subtotals, 111
for Commission Calculator worksheet, 154
for Medical Bill Tracker worksheet, 160
printing, 104
height of rows
adjusting, 39
hidden rows, 57
hiding. See also viewing or displaying
cell comments, 72
collapsing subtotal headings, 111
customizing viewing options, 74
grand totals from PivotTable display, 132
Office Assistant, 9
open workbooks, 70
outlines, 114
PivotTable data, 131
rows or columns, 57
toolbars, 10
worksheets, 56
house payments worksheet, 168
hyperlinks, 63
hyphen (-), ignored during sort, 78
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icons for SmartTags, 150
IF statements
creating formulas using, 28
nested, for calculating commissions, 156-157
images. See graphics
importing Excel data to Access table, 187-189
indenting data in cells, 35
inserting. See also copying; data entry
arrows, 47
AutoCorrect entries, 149
cell comments, 72
clip art, 51
functions, 27
hyperlinks, 63
images, 50
special characters, 146
text boxes, 48
Word table columns or rows, 172
worksheets into Word, 173
worksheets into workbooks, 54
worksheets or charts into PowerPoint slides, 182

o/ o

labels (mailing) in Word using Excel list, 178
labels on charts

adding, 91

Category label, 86

options for, 90

Value label, 87
labels on spreadsheets, 13, 15

Landscape printing orientation, 101
legend of charts, 87, 90, 91
linking worksheets
to Access database, 190-191
hyperlinks for, 63
into PowerPoint slides, 183
lists
creating custom, 79
sorting custom, 80
Word mail merge form letter using, 176-178
Word mailing labels using, 178

o o

macros
assigning shortcut keys to, 142
creating a toolbar button for, 143
defined, 139
deleting, 144
digital signatures for, 141
locations for storing, 140
making available whenever you use Excel, 140
naming, 140
overview, 139
preventing from running when Excel starts, 143
recording, 139, 140
running, 139, 142
security for, 139, 141
stopping, 143
undoing not possible for, 142
mail merge form letter in Word using Excel list,
176-178
mailing labels in Word using Excel list, 178
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margins, setting for printing, 102
Medical Bill Tracker worksheet
calculating amount due, 161
creating totaling formulas, 160
duplicating the worksheet for family
members, 163
entering headings, 160
formatting, 162
overview, 159
print settings, 162
protecting, 163
saving as a template, 166
specifying data validation, 161
totaling formulas for, 160
totals worksheet, 164-165
menus
conventions in this book, 1
displaying all choices, 10
merging
cells to create a title, 35
data in columns, 148
moving items
charts, 93
graphics, 52
Office Assistant, 9

o\l e

NAME# error, 29

names
for macros, 140
for PivotTable formulas, 137
for range of cells, 18

renaming PivotTable fields, 134
renaming worksheets, 55
rules for worksheets, 55

NPER function, 169

o () o

Office Assistant, 6, 9
opening
Excel, 6
existing Excel file, 8
files in different formats, 12
new, blank workbook, 7
preventing macros from running when opening
Excel, 143
templates, 73
operators
creating simple formulas with, 21
in PivotTable formulas, 137
Rule of Priorities, 23
organization charts, creating, 96
orientation for printing, 101
OUR DREAM HOUSE worksheet, 168
OUR SAVINGS GOALS worksheet, 170
outlines
AutoOutline feature, 114
collapsing and expanding subtotal headings, 111
controlling individual subtotals, 111
copying subtotals, 113
creating multiple subtotals, 112
forming groups, 115
generating subtotals, 110
hiding, 114
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outlines (continued)
overview, 109
removing items from a group, 115
removing subtotals, 113

opPoe

page breaks
adding manually, 100
between subtotal groups, 110
page fields for PivotTables, 133
Page Setup dialog box, 101-104, 162
pages of PivotTables, 130
paper size and orientation for printing, 101
passwords
for files, 60
for protected worksheets, 59
Paste Special, copying values using, 26
PAY OFF CREDIT CARD worksheet, 169
payment worksheets. See financial planning
worksheets
percent of totals, calculating in PivotTables, 136
Personal Workbook
deleting macros from, 144
storing macros in, 140
pictures. See graphics
PivotCharts, 138
PivotTable and PivotChart Wizard, 129
PivotTables
adding your own calculations, 137
AutoFormats for, 132
calculating percent of totals, 136
changing the calculation type, 132

creating, 128-130
creating PivotCharts from, 138
data source for, 129
deleting separate PivotTables, 133
displaying details for data, 131
elements of, 129-130
formatting values and text, 134
generating multilevel totals, 135
generating separate PivotTables, 133
grouping data, 136
hiding data, 131
organizing data for, 128
overview, 127
page fields, 133
removing calculated fields, 137
removing grand totals from display, 132
removing unwanted fields, 131
renaming fields, 134
updating (refreshing data), 131
plot area of charts, 87
PMT function, 168, 170
Portrait printing orientation, 101
PowerPoint slides
copying cells into, 180
deleting tables in, 180
dragging charts into, 181
editing tables in, 180
inserting worksheets or charts into, 182
linking worksheets into, 183
previewing before printing, 99
printing
adding page breaks manually for, 100
charts, 105
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checking spelling before, 97, 98

clearing the print area, 101

fitting worksheets on the page, 101

gridlines, 104

header or footer, 102-103

headings for rows and columns, 104

Page Setup dialog box for, 101-104

paper size and orientation for, 101

previewing before, 99

repeating rows and columns, 104

selected area, 100

setting margins for, 102

settings for Medical Bill Tracker worksheet, 162

specifying the print area, 100

worksheets or workbooks, 105
properties

searching for files by, 12

specifying for workbooks, 11
protection. See security

o R o

ranges of cells, naming, 18

recording macros, 139, 140

references
absolute, 62
to another cell in the same worksheet, 62
to another worksheet, generating, 61
cross-referencing other workbooks, 62
including in formulas, 61
recording macros and, 140
R1C1 style for, 74

refreshing data. See updating
relocking cells, 58
removing. See deleting or removing
renaming. See names
repeating rows and columns, 104
replacing data with Find and Replace, 83
resizing
column width in PowerPoint slides, 180
column width in Word tables, 172
column width in worksheets, 38
graphics, 52
row height in worksheets, 39
split window sections, 68
tables in Word, 173, 174
worksheets embedded into Word, 174
retirement savings worksheet, 170
R1C1 reference style, 74
rotating
AutoShapes or arrows, 52
text, 37
rows in worksheets
adjusting height, 39
freezing and unfreezing titles, 69
grouping and ungrouping, 115
hiding and unhiding, 57
printing headings, 104
repeating, 104
Rule of Priorities, 23
running macros, 139, 142
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saving
files in different formats, 12
workbook as template, 73, 166
workbook properties, 11
workbooks, 7
worksheets into Word, 173
savings calculation worksheet, 170
SAVINGS GOALS worksheet, 170
scientific notation, values displayed as, 15
screen. See windows
searching. See finding
security
for macros, 139, 141
password-protecting files, 60
protecting the Commission Calculator
worksheet, 158
protecting the Medical Bill Tracker
worksheet, 163
protecting worksheets, 59
relocking cells, 58
unlocking cells, 58
unprotecting worksheets, 59
selecting
active cell, 14
cells with data validation, 19
clearing a selection, 17
multiple cells, 17
PivotTable data to show, 131
shading cells, 44
shadows for AutoShapes, 49
shortcut keys, assigning to macros, 142

showing. See viewing or displaying
slash (/)
as division operator, 21
not allowed in worksheet names, 55
SmartTags feature, 150
sorting data
custom lists, 79
by day or month, 80
by multiple criteria, 78
for multiple subtotals, 112
Sort command for, 77
toolbar buttons for, 76
before using subtotals, 109, 110
sounds for SmartTags, 150
special characters, inserting, 146
spell check, 97, 98
splitting
data into multiple columns, 147
Excel screen, 68
outline groups, 115
spreadsheets. See worksheets
stopping macros, 143
styles for formatting, 41
subtotals
AutoOutline feature, 114
collapsing and expanding headings, 111
controlling individually, 111
copying, 113
generating, 110
generating in PivotTables, 135
multiple, creating, 112
page breaks between groups, 110
removing, 113
sorting before using, 109, 110



Index

SUM function, 157, 160-161, 164-165
SUMIF function, 155, 164-165
symbols, inserting, 146

o e

templates, 73, 166
text. See also cells; data entry; formatting
adding to AutoShapes, 49
annotating with text boxes, 48
cell comments, 72
fonts, 36, 44
joining using ampersand, 148
rotating, 37
wrapping in cells, 36
text boxes, 48
3-dimensional effects
AutoShapes, 50
charts, 94
tick marks, 87
tiling windows, 70
titles
of charts, 86, 90, 91
freezing and unfreezing, 69
merging cells to create, 35
toolbars
creating buttons for macros, 143
creating custom, 146
described, 6
displaying or hiding, 10, 76
showing on two rows, 10
tracking medical expenses. See Medical Bill
Tracker worksheet
troubleshooting formula errors, 29

ol o

undoing
data entry, 16
generating separate PivotTables and, 133
macros and, 142
unfreezing titles, 69
ungrouping rows or columns, 115
unhiding
Personal Workbook, 144
rows or columns, 57
worksheets, 56
unlocking cells, 58
unprotecting worksheets, 59
updating (refreshing data)
PivotTables, 131
worksheets linked into PowerPoint slides, 183

o (/o

validating data. See data validation
#VALUE! error, 29
values
alignment in cells, 15
copying using Paste Special, 26
defined, 13
entering in cells, 15
formatting in PivotTables, 134
formatting in spreadsheets, 34
viewing or displaying. See also filtering data;
finding; hiding
all menu choices, 10
arranging windows, 70
cell comments, 72
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viewing or displaying (continued)
comparing spreadsheets, 71
customizing viewing options, 74
full screen view, 71
PivotTable data details, 131
previewing before printing, 99
R1C1 reference style, 74
splitting the Excel screen, 68
subtotal headings, collapsing

and expanding, 111

toolbars, 10, 76
toolbars on two rows, 10
tracing formula dependents, 30
unhiding rows or columns, 57
unhiding worksheets, 56
zooming in or out, 68

o ({/ o

Web sites, hyperlinks for, 63
width of columns

adjusting in worksheets, 38

hidden columns, 57

in PowerPoint slides, 180

in Word tables, 172
windows

arranging, 70

customizing viewing options, 74

full screen view, 71

splitting the screen, 68
Word

copying cells into, 172

copying tables to Excel, 175
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creating mail merge form letter using Excel list,

176-178
creating mailing labels using Excel list, 178
deleting tables, 172, 173, 174
editing inserted cells, 172
editing inserted worksheets, 173
embedding worksheets into, 174
resizing tables, 173, 174
saving worksheets into, 173
workbooks
attaching to e-mail, 105
automatic prompt for setting properties, 11
changing worksheet tab colors, 56
closing, 6
comparing side by side, 71
creating new, 7
cross-referencing other workbooks, 62
default worksheets in, 53
defined, 53
hiding an open workbook, 70
inserting worksheets, 54
maximum worksheets per workbook, 53
printing, 105
saving, 7
saving worksheets into Word, 173
specifying properties, 11
worksheets
attaching to e-mail, 105
changing tab colors, 56
comparing side by side, 71
copying, 55
copying data to Access table, 186
default number created, 53
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defined, 53

deleting, 54

embedding into Word, 174

fitting on the page, 101

hiding and unhiding, 56

importing data to Access table, 187-189
inserting, 54

inserting into PowerPoint slides, 182
linking into PowerPoint slides, 183
linking to Access database, 190-191
maximum number per workbook, 53
moving between, 14

printing, 105

protecting, 59
referencing another worksheet, 61
renaming, 55
rules for naming, 55
saving into Word, 173
splitting data into multiple columns, 147
unprotecting, 59
wrapping text in cells, 36

o o

zooming in or out, 68
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