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Introduction

Excel is the most sophisticated spreadsheet program available in the world of personal
computing. As such, this program is much more than just an electronic version of an

accountant’s familiar green sheet for crunching numbers. For millions of users the world

over, Excel is also their number one forms designer, their interface to the corporate data-

base, as well as their premier charting program.

Given Excel’s indisputable versatility, it should come as no surprise that mastering the basics
of the program, not to mention its finer points, is no small undertaking. My experience, how-
ever, in teaching adults to use all manner of Excel’s capabilities has convinced me that this
mastery is greatly accelerated with just a modicum of hands-on experience judiciously
applied to rather simple but realistic data-related problems.

About This Book

As its name suggests, Excel Workbook For Dummies is designed to give you the kind of hands-
on experience with all the major aspects of the program you need to start using the program
for business or home with a certain degree of confidence and efficiency. As you’d expect from
this type of book, the workbook is primarily composed of questions and exercises that give
you plenty of opportunities to experience the purpose and benefits of Excel’s many features.

It’s my hope that as a result of doing the exercises in this workbook, you’ll not only be in firm
command of the basic skills necessary to work with confidence in the Excel spreadsheet but
also have a good idea of the overall power of the program through experience with its fea-
tures beyond the spreadsheet.

Conventions Used in This Book

By convention, all the text entries that you type yourself appear in bold. In addition, all file-
names appear in italicized type even though they are not italicized when you see their names
in Windows Explorer or the Excel Open dialog box.

When it comes to instructions in the exercises throughout the workbook, you’ll notice two
conventions:

v+ Menu commands are introduced by the word “choose” followed by the menu sequence
separated by the = symbol, as in “Choose Filec>Save As.”

1 Selections in dialog boxes are most often introduced by the word “select” followed by
the name of the option name or button, as in “Select the Alignment tab” or “Select the
OK button.”

In both cases, you must decide on your own whether to select the menu command or dialog
box option or button with the mouse or with the keyboard. In the case of menu commands,
you can choose among clicking the menu and menu items with the mouse, activating the menu
by pressing F10 and selecting the menu and menu items with the cursor keys, or pressing the
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Alt key and then pressing the menu’s and menu items’ hot keys. In the case of dialog box
options, you have a choice between clicking them with the mouse or pressing their hot
keys. You can also select default buttons in a dialog box (indicated by shading around
the button) by simply pressing the Enter key.

The method you use for selecting commands and dialog box options is completely up
to you and should be dictated by your comfort level with the mouse or keyboard as
well as which method is most efficient. For example, pressing the Enter key to select
the default OK button in a dialog box is often the most efficient method when the next
step you take is entering or editing in the current cell or range.

One other convention that you’ll notice used throughout the text is the display of the
names for Excel menu commands, toolbar buttons, and dialog box options in the title
case, wherein all major words are capitalized except for prepositions. The title case is
used to make these names stand out from the rest of the text. Often, however, espe-
cially in the case of dialog box options, Microsoft does not always follow this conven-
tion, often preferring to capitalize the first letter of the option name.

Foolish Assumptions

[ assume that you're a new Excel user motivated to master its essentials either for
work or at home. Further, [ assume that you're someone who learns by doing as least
as well, if not better than, by reading alone.

To complete most of the exercises in this workbook, you only need to have Microsoft
Excel installed on a computer running a version of Microsoft Windows. For some of the
printing exercises, you will benefit from having a printer installed on your system
(although you can complete most of their steps and get the gist of the lesson without
actually printing the sample worksheets). For a few of the Web exercises in Part VI, you
will need to have access to the Internet in order to complete them.

The workbook is designed to be used with various versions of Excel; from Excel 2000 up
to and including Excel 2003. There are, however, a few exercises that are designed pri-
marily for users of Excel 2003, whose specific steps require slight modification in order
to be accomplished on earlier versions. Only in the rarest of cases will you encounter
an exercise that cannot be completed with all three versions. If you are a user of Excel
97, you can complete the majority of the exercises in the workbook, although you may
find some of the steps confusing as they reference toolbar buttons or task pane com-
mands that haven’t yet been invented as far as your edition of Excel is concerned.

How This Book Is Organized

This workbook is organized into eight parts, each of which contains two or more
related chapters. Each of the chapters follows a similar pattern of introductory text fol-
lowed by exercises. In some of the chapters, you’ll also encounter question and
answer sections that are designed to stimulate your thinking regarding the features
you’re about to practice in the subsequent exercises. Note that although the exercises
within any given chapter do build on one another, you're certainly not expected to
complete them in strict chapter order. Feel free to work on the exercises in any order
that feels comfortable and fits your learning needs.
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This part contains the most exercises of any in the workbook. It is made up of four
chapters designed to give you practice in all the spreadsheet basics, all the way from
starting Excel to editing a completed spreadsheet:

v Chapter 1 enables you to practice creating a new spreadsheet.

v Chapter 2 runs you through formatting spreadsheet data.

v Chapter 3 gives you training in all aspects of printing the completed spreadsheet.

v Chapter 4 gives you plenty of experience with making modifications to the com-
pleted spreadsheet.

Part II: Using Formulas and Functions

This part gives you all the practice you need with creating and using formulas in the
spreadsheet. Chapter 5 introduces you to formula-making just as Chapter 6 introduces
you to the all-important topic of formula copying.

Because of the importance of Excel’s built-in functions in formula building, the remaining
seven chapters in this part concentrate on building formulas using a particular category
of functions:

v Chapter 7 gets you up and running on date and time formulas.
v Chapter 8 trains you in the use of financial formulas.

v Chapter 9 gives you practice creating formulas using Excel’s Math functions.

v Chapter 10 concentrates on exercises in creating formulas using Statistical
functions.

v Chapter 11 introduces you to the creation of formulas using Lookup functions.

v Chapter 12 runs you through the creation of formulas using the Logical func-
tions, the performance of which depends upon prevailing conditions in the
spreadsheet.

v Chapter 13 introduces you to the creation of text formulas that manipulate and
change text entries in the spreadsheet.

Part [1I: Working with Graphics

This part takes you into the graphical aspects of Excel, the most important of which is
its rich and versatile charting capabilities covered in Chapter 14. In addition to charts,
in Chapter 15 you get practice in working with other types of graphics in the spread-
sheet, both those that you generate with the program’s own drawing tools and those
that you import from other sources such as clip art and digital photos.

Part JU: Managing and Securing Data

This part is concerned with the management and security of the vast amounts of data
that you accumulate in your worksheets. Chapter 16 gives you practice in creating,
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maintaining, sorting, and querying database tables and data lists in the worksheet.
Chapter 17, on the other hand, gives you practice using Excel’s various methods for
protecting your data and worksheets from illicit viewing and unwanted changes.

Part U: Doing Data Analysis

This part takes you to the next step of using the Excel spreadsheet by introducing you
to two different kinds of data analysis. Chapter 18 gives you practice in doing various
types of what-if analysis that enable you to look at different potential outcomes in the
spreadsheet. Chapter 19 concentrates on training you in the use of pivot tables, a
dynamic type of data table that you can use to summarize vast amounts of data.

Part Vl: Excel and the Web

This part gives you experience with Excel’s Web capabilities in two forms. Chapter 20
gives you experience converting Excel spreadsheets to Web pages, both in static and
dynamic formats. Chapter 21 trains you in the use of hyperlinks in spreadsheets that
connect you to different sheets in the same workbook, different documents on the same
computer, as well as to different pages and e-mail addresses on the World Wide Web.

Part Ull: Macros and Visual Basic
for Applications

This part introduces you to the topic of creating and using macros to both streamline
and customize your work in Excel. Chapter 22 introduces you to recording your
actions as Excel macros and then playing them back in the worksheet. Chapter 23
gives you practice using Excel’s Visual Basic Editor to edit macros and extend macros
you've recorded as well as to create your own user-defined functions.

Part VIII: The Part of Tens

This part gives you tips for using Excel on your own after you complete the exercises
in this workbook. Chapter 24 is full of tips on using some of the many features you've
practiced using in the workbook like a professional. Chapters 25 through 28 are full of
various and sundry keystroke shortcuts designed to save you keyboard enthusiasts
out there all sorts of time as you work in Excel.

Using the Practice Material on the CD-ROM

The CD-ROM that comes with this workbook is an integral part of the workbook experi-
ence. It contains not only the practice material that you need to complete most of its
exercises but lots of third-party utilities that you may be able to put to good use as you
start to work with Excel on your own.

All the practice material for the book is located in a single Excel Workbook folder on the
CD-ROM. This Excel Workbook folder contains 22 chapter folders (Chapter 1 through
Chapter 21 and Chapter 23 — the exercises in Chapter 22 don’t require any practice files),
plus a Templates folder.
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Before you start working through the exercises in this workbook, I suggest that you copy
this Excel Workbook folder to the My Documents folder on your computer’s hard disk
and then rename the Excel Workbook folder to My Practice Spreadsheets as follows:

1. Insert the CD-ROM into your computer’s CD/DVD drive.

N

Click the Start button on the Windows taskbar and then click My Computer on
the Start menu to open My Computer in Windows Explorer.

W

Right-click the icon for your CD/DVD drive and select Explore to open its con-
tents in the Windows Explorer window.

Click the Excel Workbook folder icon and then press Ctrl+C.

o=

Click the My Documents link in the left pane of the Windows Explorer window
and then press Ctrl+V.

S

Right-click the Excel Workbook folder and then select the Rename option on its
shortcut menu.

N

Replace Excel Workbook by typing My Practice Spreadsheets and then press
Enter.

*x

Click the Close button in the upper-right corner of the Windows Explorer window
to close it.

NS

Open the My Practice Spreadsheets folder in My Documents on your hard disk
and then open the Templates folder. Select all the files by pressing Ctrl+A and
copy them to the Windows Clipboard by pressing Ctrl+C.

10. Open the Microsoft Templates file on your computer’s hard disk by double-click-
ing the My Computer icon on the desktop and then double-clicking the Local
Disk (C:) icon followed by the following folders: Document and Settings= Your
personal folder (as in Greg) =>Application Data=>Microsoft=>Templates.

If the Application Data folder icon does not appear in your personal folder, you
need to choose Tools=>Folder Options and then select the Show Hidden Files and
Folders option button on the View tab before you select OK.

11. Paste the copied template files into the Templates folder by pressing Ctrl+V.
You are now ready to tackle any of the exercises in the workbook using the practice

files saved in the My Practice Spreadsheets folder inside the My Documents folder on
your hard disk.

When you're finished doing the exercises and no longer need access to the practice

files, go ahead and delete the My Practice Spreadsheets folder and all its contents by
dropping it in the Recycle bin on the Windows desktop.

Icons Used in This Book

Icons are sprinkled throughout the text of this workbook in high hopes that they draw
your attention to particular features. Some of the icons are of the heads-up type, while
others are more informational in nature:

This icon indicates the start of a question-and-answer section in the workbook.

This icon indicates that the question that follows is a little more difficult and its
answer a little less than obvious than the others in the question-and-answer section.
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This icon indicates a hint that can help you perform a particular step in the exercise.

This icon indicates that the file referred to in an exercise or some part of it is supplied
to you on the CD-ROM that comes with this workbook.

This icon indicates a tidbit that, if retained, can make your work somewhat easier
in Excel.

This icon indicates a tidbit that is essential to the topic being discussed and is, there-
fore, worth putting under your hat.

This icon indicates a bit of trickery in the topic that, if ignored, can lead to some real
trouble in your spreadsheet.

Where to Go from Here

This workbook is constructed such that you don’t have to start working through the
exercises in Chapter 1 and end with those in Chapter 23. That being said, it is still to
your benefit to complete all the exercises within a particular chapter, if not in a single
work session, at least in a short time period.

If you're a real newbie to Excel and have no experience with the program, I urge you to
complete the exercises in Part [, Chapters 1 through 4, before you take off in your own
direction. The exercises in this part are truly fundamental and are meant to give you a
strong foundation in the basic features that all Excel users need to know.

Please keep in mind that I designed the exercises in this workbook to work with my
Excel companion books, Excel For Dummies and Excel All-In-One Desk Reference For
Dummies (published by Wiley). They can therefore provide you with additional infor-
mation about the Excel features you're using either at the time you go through the
workbook exercises or afterward. To facilitate this crossover usage, I have, wherever
possible, used the same example files in the exercises of this workbook as you see
illustrated and explained at length in these references.

Whatever you do next and wherever you go in this workbook, just be sure that you
enjoy yourself!



Part|
Creating Spreadsheets

The 5th Wave By Rich Tennant

“Unless there’s a corrupt cell in our spreadsheet
analysis concerning the importance of tyrunk
space, this should be a big seller next year.”



In this part . . .

Fe chapters and exercises in Part I form the core skills
on which all spreadsheet users rely. These skills run
the gamut from basic data entry to more complex data
editing with cell formatting and worksheet printing in
between. When you have these skills under your belt,

you are well on your way to mastering Excel.




Chapter 1

Entering the
Spreadsheet Data

In This Chapter

Launching Excel and opening a new workbook
Moving around the workbook

Selecting cell ranges in a worksheet

Doing simple data entry in a worksheet

Using AutoFill to create data series and copy formulas

Saving the spreadsheet as an Excel workbook file

Data entry is the bread and butter of any spreadsheet you create or edit. The exercises
in this chapter give you a chance to practice launching Excel, moving around a new
spreadsheet, the many aspects of data entry, and, most importantly, saving your work.

Launching Excel

Excel is only one of the many application programs included as part of Microsoft Office. In
order to be proficient in its use, you need to be familiar with all the various ways of launch-
ing the program.

e Double-click an Excel workbook file in
any folder on any drive to which your
computer has access.

What are the different techniques I can use
to start Excel?

A.  You should be familiar with all these ¢ Double-click the Excel program icon on
methods: your computer’s desktop.
¢ Click Start on the Windows taskbar and ¢ Click the Microsoft Excel icon on the
then highlight All Programs and click taskbar’s Start menu.

Microsoft Office Excel (2003 users need
to select the Microsoft Office item before
clicking Microsoft Office Excel).

e (lick the Excel icon on the Quick Launch
toolbar.
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Exercise 1-1: Launching Excel

The last three methods listed previously for launching Excel are available only if
you’'ve added the Excel program icon to the desktop, the Start menu, and the Quick
Launch toolbar, respectively. For this exercise, add the Excel program icon to your
computer if you still need to and then launch Excel using each of the five methods.

v Add an Microsoft Office Excel shortcut to the Windows desktop by right-clicking
the Microsoft Office Excel item as it appears on the Start=>All Programs=>
Microsoft Office submenu and then highlighting Send To before you click
Desktop (Create Shortcut) on the Send To submenu.

v Add Excel to the Start menu by right-clicking the Microsoft Office Excel desktop
shortcut and then clicking Pin to Start Menu on its shortcut menu.

v Add Excel to the Quick Launch toolbar on the Windows taskbar by holding down
Ctrl as you drag and drop the Microsoft Office Excel desktop shortcut on to its
place in the toolbar.

Q. How do I make Excel launch automatically A. Copy the Microsoft Office Excel item to the
each time I start my computer? Startup submenu on the All Programs
menu.

Opening a New Workbook

Each time you launch Excel (using any method other than double-clicking an Excel
file icon), a new workbook containing three blank worksheets opens. You can then
build your new spreadsheet in this workbook, using any of its sheet pages.

The blank workbook that opens with Excel is given a temporary filename such as
Book1, Book2, and so on that appears after Excel’s name on the program window’s
title bar. If you want to start work on a spreadsheet in another workbook, click the
New button on the Standard toolbar.

When Excel opens a blank workbook upon launching the program or after clicking
the New button, the new workbook follows the general Excel Worksheet template
(which controls the formatting applied to all its blank cells). You can also open new
workbooks from other, specialized templates or from a workbook that you've
already created. To do this, choose Filew>New. If you're running Excel 2002 or 2003,
the program opens the New Workbook Task pane, where you can click the template
or file to use. If you're running Excel 2000 or earlier, the program opens the New
dialog box, from which you can open the template.

The Templates folder in the Excel Workbook folder on the workbook CD-ROM (which
you copied to the Excel Workbook Templates folder on your hard disk) contains a
couple of template files that you can use and modify for your own use. To take a
peek at them on the General tab of the Microsoft Templates folder, click the On My
Computer link under Templates on the New Workbook task pane.



us
xS

<

What'’s so special about an Excel template?

A template is a particular type of Excel file
designed to automatically generate new
workbooks that use both its data and for-
matting. Each time you open a template,
Excel opens a copy of the template file
rather than the original (by appending a
number to the template’s original file-
name). Excel template files use the file-
name extension .xlt to differentiate them
from regular Excel workbook files, which
carry an .xls filename extension.

How can I create templates out of my own
Excel workbook files?

Build a spreadsheet in a new or existing

workbook file. To this spreadsheet add all
the stock text and data, calculating formu-
las, and formatting required in all the files

S

Chapter 1: Entering the Spreadsheet Data

What'’s the difference between opening a
new workbook file from an Excel template
file rather than an existing Excel workbook
file?

None, provided that you open the new file
using the From Existing Workbook under
New or the On My Computer link under
Templates in the New Workbook Task pane,
rather than in the Open dialog box. (Doing
this opens not a copy of the template or
workbook file but the original file for
editing.)

you will generate from its ensuing template
and then save this file with the Filec>Save
As command. Select Template (*.xIt) in the
Save As Type drop-down list box and edit
the dummy filename (without removing the
xlt filename extension) before you click
the Save button.
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Exercise 1-2: Opening a New Workbook

Launch Excel and then open a new workbook (Book2). Switch to Book1 (notice the
change in the Excel program title bar) and then back to Book2 and close this work-
book. Notice what happens to Bookl when you close Book2. Leave Book1 open for the
next exercise.

To switch from Sheet] of Book2 and make Sheetl of Book1 active, click the Book1 icon
on the Windows taskbar or press Ctrl+Tab (to switch back to Book2, click the Book2
icon on the taskbar or press Ctrl+Tab again so that Sheetl of Book?2 is selected).

To close a workbook file, choose File=>Close or click the workbook’s Close Window
button. (The Close Window button is the one with the black X, which is immediately
beneath the program’s red Close button, which has a white X.)

Exercise 1-3: Opening a New Workbook from a Template

Open a new workbook from the Hourly Wages template that you copied from the
Templates folder on the workbook CD-ROM to the Microsoft Templates folder (see
“Using the Practice Material on the CD-ROM” in the Introduction for details). Switch
back and forth between the Bookl and Hourly Wages1 workbook files. Then, close the
Hourly Wages1.xls workbook file, leaving open the Bookl1.xls file for the next exercise.

To open a new workbook from a template file, you click the On My Computer link
under Templates on the New Workbook task pane, and then click the .xlt file to use in
the General tab of the Templates folder before you select OK.
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Moving around the Workbook

WBER
“&
&

The key to doing both data entry and data editing in any spreadsheet is selecting the
cell or cells you want to fill or modify. Selecting a cell almost always entails moving the
cell cursor (or pointer) to another part of the current worksheet. Sometimes, it also
involves activating a different worksheet in the workbook file.

Excel gives you plenty of choices in techniques for moving the cell cursor: Some use
the mouse and others are keyboard driven.

Moving within the displayed area

Here’s a recap of the most important ways to move the cell cursor to a new cell within
the area of the worksheet that is currently displayed on-screen:

v Click the target cell with the white-cross mouse pointer.

v Press the arrow keys until the cell pointer is in the target cell.

v Click the Name Box with the current cell reference at the very beginning of the
Formula Bar, enter the reference of the target (by column letter and row number
as in D12), and press Enter.

Exercise 1-4: Moving the Cell Cursor within the Displayed Area

Make Sheet1 of the blank workbook, Bookl, active and then practice moving the cell
cursor to different cells in the displayed area using the mouse, arrow keys, and
Name Box:

1. Move the cell pointer to cell F9 with the mouse.
2. Move the cell pointer to cell C13 using just the down and left arrow keys.
3. Move the cell pointer to cell Al using only the Name Box.

Keep in mind that you can always move the cursor to cell Al (also known as the Home
cell) of any active worksheet simply by pressing Ctrl+Home.

Moving to a new area of the worksheet

Many times you have to make cell entries in areas that aren’t currently displayed in the
active worksheet. One of quickest ways to do this is by entering the reference of the
cell you want to go to in the Name Box. You can also use any the following techniques
to scroll to new parts of the current worksheet:

v To scroll up and down rows of the worksheet by windows, press Page Up or Page
Down or click the blank area above or below the scroll box in the vertical scroll bar.

v To scroll left and right columns of the worksheet by windows, click the blank
area to the left or right of the scroll box in the horizontal scroll bar.

v To quickly scroll through rows or columns of the worksheet, hold down the Shift
key as you drag the scroll box up or down in the vertical scroll bar or left and
right in the horizontal scroll bar.



Chapter 1: Entering the Spreadsheet Data

v If you use a mouse with a wheel button, scroll up and down the rows of the work-
sheet by rotating the wheel button forward (to scroll up) and backward (to scroll
down).

v~ If you use a mouse with a wheel button, pan through the rows and columns of
the worksheet by clicking the wheel button and then dragging the triangular
mouse pointer in the direction you want to scroll.
WMBER
‘x&
& Don’t forget that scrolling is not the same as selecting! After scrolling to a new part of

the worksheet in view, you still have to select a cell by clicking it to set the cursor in it.

Exercise 1-5: Moving the Cell Cursor to Distant Parts of the Worksheet
Practice moving the cell pointer to cells in unseen parts of Sheet1 in the Book1l work-
book by doing the following:

1. Move the cell cursor to cell C125 with the Name Box on the Formula Bar.

2. Move the cell cursor to cell CA125 using the horizontal scroll bar.

3. Move the cell cursor to cell CA63560 using the vertical scroll bar.

4. Move the cell cursor directly to cell Al (the Home cell) in a single operation.

Hold down the Shift key to scroll quickly through columns and rows by dragging
the scroll box in the horizontal or vertical scroll bar.

After scrolling into view the region with the cell you want to select, you still need
to click the cell to select it.

\US
S
Q. What'’s the most efficient way to move A.  Usethe Ctrl key in combination with any of
between ranges of data that are spread out the four arrow keys to jump from occupied
across a worksheet? cell to occupied cell in a particular direction.

Exercise 1-6: Moving the Cell Cursor from Entry to Entry

Practice moving the cell pointer around a blank worksheet and between data entries
with the Ctrl key and the arrow keys in Sheet1 of Bookl by doing the following:

’. Press Ctrl+—, Ctrl+!, Ctrl+<, and Ctrl+T in succession to jump the cell cursor
from Al to IV1, IV1 to IV65536, IV65536 to A65536, and A65536 to back to Al
(when there are no occupied cells in a particular direction, the cursor jumps
right to the border of the worksheet).

2. Move the cell cursor to cell A18, type Stop, and press Ctrl+Home. Next, press
Ctrl+| (the cursor stops in A18 rather than A65536 because A18 is now occupied).

3. Move the cell cursor to cell AB18, type Stop Again, and press Home. Next, press
Ctrl+— (the cursor stops in cell AB18 rather than IV18 because AB18 is now
occupied).

4. Press the Delete key, and then press Ctrl+« followed by the Delete key to remove
the two dummy cell entries. Press Ctrl+Home to put the cursor back in cell Al.

13
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Moving to a different sheet in the workbook

Each new workbook you start uses the general Excel Worksheet template that auto-
matically includes three blank worksheets that you can fill with data. If you need more
space for a particular spreadsheet, you can add additional worksheets with the
Insert>Worksheet command. If you want all new workbooks you open to have more
worksheets, enter a new value in Sheets in a New Workbook text box on the General
tab of the Options dialog box (Tools=>Options).

Each sheet in a workbook is automatically given the next available numeric name such
as Sheetl, Sheet2, and the like, but you can easily replace these generic names with
something descriptive: Double-click the tab you want to rename, type the new sheet
name, and press Enter. You can also color-code a sheet tab by right-clicking it, clicking
Tab Color on the shortcut menu, and then selecting the color Format Tab Color dialog
box before you select OK.

Of course, you must know how to move between the sheets in order to be able to add
and edit data in them. The most direct way to select a new worksheet is to click its
sheet tab, although you can also use the shortcut keys Ctrl+Page Down to select the
next sheet and Ctrl+Page Up to select the previous sheet.

If you add so many worksheets to your workbook that all their sheet tabs can’t all be
displayed at one time, you can use the Tab scroll buttons to the immediate left of the
sheet tab to bring into view the tabs you want to select. You can also display more
tabs by reducing the width of the horizontal bar (by dragging to the right the split bar
that appears when you position the mouse pointer on the vertical bar at the beginning
of the scroll bar).

Exercise 1-7: Moving to Different Worksheets
Practice moving the cell cursor to specific cells in different worksheets of Bookl by
doing the following:
1. Move the cell cursor to cell J25 on Sheet2 (whose cell reference is Sheet2!J25).
2. Move the cell cursor to cell CC1000 on Sheet3 (Sheet3!CC1000).

3. Move the cell cursor to cell Sheet 3:J25 on Sheet3, and then activate Sheet2 (note
the difference in the worksheet view despite the fact that you’ve moved to the
same cell on an earlier worksheet).

4. Rename Sheet]1 to Spring Sale.

Selecting Cell Ranges

When entering, editing, or formatting a single cell, all you have to do is move the cell
cursor to it as you practiced in the earlier exercises. You can also enter the same data
as well do the same type of editing and formatting in a bunch of cells at one time, but
to do so, you must first select the cells where all this is going to happen.

Most of the time when selecting multiple cells in a worksheet, you select a discrete
block of cells of so many rows high and so many columns wide. Such a block is known
as a cell range in the parlance of spreadsheet software.
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A cell range is most often described by the reference of its first and last cell (that is,
the cell in the upper-left corner and the lower-right corner of is block, respectively).
When written, a cell range is separated by a colon, as in B15:F20, for a six-row and six-
column cell range whose first cell is B15 and last cell F20. To select this cell range, you
move the cursor to cell B15 and then hold down the Shift key as you use the | and —
keys to move the cursor to cell F20.

Excel, however, does not limit you to selecting a single cell range for data entry, edit-
ing, or formatting. You can select as many cell ranges (even those as small as a single
cell) by holding down the Ctrl key as you add a new range to the cell selection.

Always think of the Shift key when you want to select a single range of cells and the
Ctrl key when you want to select more than one cell range at one time.

How do I select cell ranges that include
complete rows and columns of the active
worksheet?

A. Click the letter of the column or the
number of the row whose cells are to be
selected in the column and row header,
respectively. To select multiple columns or

Q. How do I select cell ranges that span differ-
ent worksheets of the active workbook?

rows, hold down the Shift key as you drag
through them, if they are consecutive, or
click them as you hold down the Ctrl key, if
they are noncontiguous. Press Ctrl+A or
click the box at the junction of the column
and row header to select all the columns
and rows in the active worksheet (in other
words, the entire worksheet).

Click the tab of the first worksheet and
then hold down Shift as you click the last
sheet before you select the cell range or
ranges on the active sheet.

Exercise 1-8: Selecting Various Cell Ranges

Practice selecting cell ranges in the Spring Sale worksheet of Bookl by doing the

following:

1. Select the cell range A2:E2, and then click the Fill Color drop-down button on the
Formatting toolbar. Click the Gray-25% square in the pop-up color palette.

2. Select the cell ranges A3:A9 and B3:E3 as a single cell selection (I'm sure you can
ConTRoL it) and then assign Light Turquoise to it using the Fill Color drop-down

button.

3. Select the cell range B4:E9 and then assign Light Yellow to this range using the
Fill Color drop-down button. Next, move the cell cursor to cell Al (Home).

Making Cell Entries

As you are probably already aware, Excel recognizes only two types of cell entries, text
(label) and number (or value). Numeric cell entries are those that consist solely of
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numbers or calculable formulas. Text entries are those that consist of all letters or a
combination of letters, numbers, and punctuation on which Excel can perform no sort
of calculation.

Anything you enter into a cell or cell selection is immediately analyzed as either being
a number or text entry. Because the general Excel Worksheet template automatically
left-aligns all text entries and right-aligns all numeric ones, you can often tell immedi-
ately how your entry has been classified by noting how it’s aligned in its cell.

When you make a numeric entry in a worksheet, Excel not only right-aligns the value in
its cell but also assigns the General number format to it. In this format, only significant
digits are displayed. This means that all trailing zeros are dropped. Also, if the number
you enter contains more that can fit within the current column width, Excel automati-
cally converts the value to scientific notation (as in 5.00E+09 for 5,000,000,000).

Sometimes you have to override Excel’s number/text assignment in order to obtain the
desired cell entry. The most famous example of this is a ZIP code or all numeric part or
item number that begins with a zero, as in 00105. If you try to enter this ZIP code into a
cell simply by typing its five digits, Excel will interpret it as a numeric entry and in
assigning the General format to it, retain only the value 105 in the cell. In order to
retain the preceding zeros, you need to force the entry to be recognized as text by
typing an initial apostrophe as in '00105 (this apostrophe does not appear in the cell
although you can see it on the Formula bar).

Entering data in a single cell

Most cell entries are made by typing from the keyboard (although later versions of
Excel do support voice and ink text entry). After typing the characters, which appear
both in the cell and on the Formula bar, you must still complete the entry:.

Anytime prior to completing the cell entry, you can press the Esc key to clear the cell
of all characters you typed there.

How many methods can [ use to complete * Press the Enter key.

an entry in the current cell? e Press one of the arrow keys.

e Press Tab, Shift+Tab, Home, Ctrl+Home,
Page Up, Page Down, Ctrl+Page Up,
Ctrl+Page Down, or any of the other

¢ C(lick the Enter box on the Formula bar cursor-movement key combinations
(the one with the check mark).

A.  You should be familiar with all these
methods:

\3
) Click the Enter box on the Formula bar when you want the cell cursor to remain in the cell

where you just made the entry (so that you can format it in some fashion). Press Enter
when you want to move the cell cursor to the next row in order to make another entry.
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Exercise 1-9: Making Simple Data Entries
Complete the data entry for the simple Spring Sale table shown in Figure 1-1 by doing
the following:
1. Enter the table title Spring Sale Furniture Prices in cell A2.
2. Enter the column headings in row 3 as follows:
¢ Code in cell A3
¢ Description in cell B3
¢ Retail Price in cell C3
¢ Discount in cell D3

¢ Sales Price in cell E3

3. Enter the code numbers in column A as follows:
¢ 02-305 in cell A4
¢ 02-240 in cell A5
¢ 04-356 in cell A6
e 01-234 in cell A7
® 03-003 in cell A8
¢ 01-240 in cell A9

4. Enter the furniture descriptions in column B as follows:
¢ 36-inch round table in cell B4
¢ 72-inch dining table in cell B5
¢ Hutch in cell B6
¢ Side chair in cell B7
¢ Arm chair in cell B8

e Armoire in cell B9

5. Enter the retail prices of the furniture in column C as follows:
e 1250 in cell C4
¢ 1400 in cell C5
¢ 2500 in cell C6
¢ 350 in cell C7
¢ 500 in cell C8
¢ 1750 in cell C9

6. Enter the discount percentages in column D as follows:
* 25% in cells D4, D5, and D6
¢ 15% in cells D7 and D8
e 25% in cell D9

17
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Figure 1-1:
The Spring
Sale table
after com-
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data entry.
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Check your completed spreadsheet table against the one in SolvedI-9.xls. (Open this
workbook in the Chap1 folder inside the My Practice Spreadsheets folder that you've
created in your My Documents folder your hard disk, or in the Excel Workbook folder
on the CD-ROM that came with this book.)

Entering data in a cell range

Sometimes you want to make the same entry in several different cells in the same
worksheet. To do this, select all the cells and cell ranges and then press Ctrl+Enter to
both complete the entry you make in the active cell and simultaneously insert it into
all the other selected cells.

Filling in a data sevies with the Fill handle

The tiny black square in the lower-right corner of the cell cursor is known as the Fill
handle. The Fill handle is your key to the AutoFill feature that makes it super-easy
either to fill in a continuous range with the same entry or with data series (such as
Monday, Tuesday, Wednesday, and so on, or 101, 102, 103, and the like).

To create a sequential series that increments by one unit (day, hour, month, widget
number), you enter the first entry in the series in a blank cell and then drag the Fill
handle in the direction you want the series to appear (down or to the right are the
most common directions). To create series that increments by other units (every
other day, every third month, every fourth hour, every tenth widget), you enter the
first two entries in the series (that serve as an example of the increment to be used) in
two adjacent blank cells and then drag the Fill handle in the appropriate direction.
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Instead of filling in these recognized data series with AutoFill, you can force Excel to
copy the entry you've made in the current cell by holding down the Ctrl key as you
drag the Fill handle. Excel indicates that it copied rather than filled a range by display-
ing a tiny plus sign to the side of the Fill handle mouse pointer.

Chapter 1: Entering the Spreadsheet Data

Exercise 1-10: Entering the Same Entry and Using AutoFill
Open a new blank workbook, Book2, and then practice making the same data entry in
multiple ranges and using the Fill handle to create various data series in its Sheet1:
’. Enter today’s date, following the date format Oct-25-06, in the cell selection Al,
D3:F3, and B4:B6.

e Don’t forget to hold down the Ctrl key when you'’re selecting the three
ranges in the cell selection.

¢ Be sure to complete the current date entry into all the cells of the selection
by pressing Ctrl+Enter.

N

Use AutoFill to create a data series with all 12 months in the cell range A8:A19
starting with January.

W

Use AutoFill to create a data series with the names of all the days of the week in
cell range C8:I8 starting with Monday.

=

Use AutoFill to create a data series with hours that go from 8:00AM to 8:00PM in
cell range C10:C22.

Use AutoFill to create a data series in cell range E10:H10 containing the headings
Qtrl, Qtr2, Qtr3, and Qtr4.

Use AutoFill to create a series in cell range E12:E21 containing 1st Team, 2nd
Team, 3rd Team, and so on all the way up to 10th Team.

NS W=

Use AutoFill to create a data series in cell range G12:L12 that contains the name
of every other month starting with November and ending with September.

e Don’t forget that you need to indicate the every-other-month increment to
Excel (by entering January in cell H12 and then selecting the range
G12:H12) before using the Fill handle to create the data series.

8. Use AutoFill to copy the data entry Item 1 to the entire cell range G14:G19 (don’t
let this one get out of ConTRoL).

Copying a formula with the Fill handle

AutoFill is not only useful for filling in a data series or copying a static data entry to a
continuous cell range but also for copying a formula across a row or down a column of
a data table. When you copy a formula, Excel automatically adjusts the column and
row references in the copies so that they refer to the right data.

Don’t forget that Excel automatically uses the so-called relative column and row refer-
ences cell addresses in all formulas you create. If you ever need to override this so
that all or part of a cell reference is not adjusted in the copied formulas, you enter a $
(dollar sign) before the cell’s column letter or row number (you can have Excel do it
for you by pressing F4 while building the formula on the Formula bar).

19
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Exercise 1-11: Copying a Formula with AutoFill

Complete the Spring Sale table by using the following steps to enter the formula that
calculates the sales price in cell E4 and then use AutoFill to copy that formula down
the cell range E5:E9. (Check your results against those in the Spring Sale table shown
in Solvedl-11.xls. You can find this workbook in the Chapter 1 folder in the My Practice
Spreadsheets folder in the My Documents folder on your hard disk or in the Excel
Workbook folder on the CD-ROM that comes with this book.)

1. switch to the Spring Sale sheet of Bookl and then move the cell cursor to cell E4.

Type = (equal) to start the formula for calculating the sale price of the 36-inch
round table (all Excel formulas start with the equal sign).

2.
3. Click cell C4, and then type * (asterisk), which Excel uses as the sign of multiplica-
tion, before you click cell D4 (the formula now reads =C4*D4 on the Formula bar).

Click the Enter box on the Formula bar and then drag the Fill handle of the cell
cursor in cell E4 down to E9 and release the mouse button to make the copies of
the formula.

Saving the Spreadsheet in a Workbook File

A\

How many different techniques can I use to
save changes to my workbook file?

You should be familiar with all these
methods:

¢ Click the Save button on the Standard

Now all that remains to do is to save the spreadsheets you created while performing
the exercises in this chapter before exiting Excel. As you know, all work that you do in
between the times you save the worksheet is at risk because you immediately lose it if
your computer experiences even the briefest power interruption.

The first time you save your spreadsheet in a workbook file, the Save As dialog box
appears, giving you the opportunity to rename the file (replacing the Bookl, Book2
monikers with something more descriptive) in the File Name text and indicate the
folder in which it should be saved in the Save In drop-down list box. After that, you can
use the Save command to save all additional changes to the same file without opening
any dialog box.

Excel saves the current position of the cell cursor in the worksheet when you save its
workbook. Therefore, always position the cursor in the cell you want to be current
when you next open the workbook for editing before doing the final save of your work
session.

¢ Choose Filer>Save on the Menu bar
(choose Filem>Save As if you want to
open the Save As dialog box again so
that you can rename or save a copy in a
new folder).

e Press F12 (Shift+12 to open the Save As

toolbar (the one with the disk icon). dialog box).
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Exercise 1-12: Saving a Spreadsheet

Save the Spring Sales table in a new My Spreadsheets folder inside the My Documents
folder on your hard disk:

1. With the Spring Sales table displayed on-screen, select cell A2 before you open
the Save As dialog box and then click the New Folder button in the Save As
dialog box.

2. Type My Spreadsheets (or My Practice Spreadsheets if you already have a My
Spreadsheets folder inside the My Documents folder) as the folder name in the
Name text box of the New Folder dialog box and select OK.

3. Replace Bookl xls in the Name text box by typing Spring Furniture Sale and
then clicking the Save button.

4. Close the Spring Furniture Sale workbook and then switch to Sheet1 of Book2.
Save this spreadsheet in the My Spreadsheets folder with the filename AutoFill
Practice after positioning the cell cursor in cell Al.

5. Close the AutoFill Practice workbook and the Hourly WagesI workbook by exiting
Excel (FilewExit or Alt+F4) — don’t save your changes to the Hourly Wages!
workbook.
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Chapter 2

Formatting the
Spreadsheet

In This Chapter

Resizing columns and rows in a worksheet

Formatting cells with the Formatting toolbar

Formatting cells with the Format Cells dialog box

Formatting tables with AutoFormat and ranges with Format Painter
Using Conditional Formatting

Hiding columns and rows in a worksheet

In Excel, formatting means formatting cells of the worksheet. Therefore, the formatting
you assign a cell not only affects the cell’s current contents, but any contents you enter
into it. Performing the exercises in this chapter gives you a chance to practice widening
and narrowing the columns of rows of a worksheet to suit the formatting and contents of
its cells. You also discover a full array of techniques for assigning formatting to cells in a
worksheet, including using the Formatting toolbar and the Format Cells dialog box and the
AutoFormat and Conditional Formatting features.

Resizing Columns and Rows

In all new workbooks generated from the general Excel Worksheet template, all the columns
of its worksheets are a standard 8.43 characters or 64 pixels wide, and all the rows are 12.75
points or 17 pixels high. You can, if you need, change this default column width for an entire
worksheet by clicking its sheet tab to select it before choosing Format>Column=>Standard
Width on the Excel menu bar. Then, you enter the new default width in the Standard Column
Width text box (in characters) before you select OK.

Note that Excel does not provide any way for setting a new row height default in a worksheet.
The 12.75-point default value is universal for all worksheets unless you manually override
this height. This is probably because Excel always automatically increases the height of all
rows to suit the formatting of its cell entries. Column widths, on the other hand, are automat-
ically widened only under certain circumstances (when applying certain AutoFormat styles
and building data tables with later versions of Excel).
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Making column widths suit the data

Resizing particular columns to suit the data they contain is one of the most common
formatting tasks you perform in creating and editing a spreadsheet.

MBER You need to widen a column in a worksheet whenever it contains cells with numerical
data having too many digits to be displayed in the current column width (indicated by
a string of pound signs (#) in the cells) or text data with characters cut off (because
they spilled over into cells in columns to the immediate right that were then truncated
by entries made in the adjacent column).

e Select the column or columns to resize
and then choose Format=>Column=>
Width. Enter the new width (in charac-
ters) in the Column Width dialog box
before you select OK.

How many different ways should I know for
resizing particular columns in a worksheet?

A.  You should be familiar with all the follow-

ing methods:

e Select the cell range or selection whose
columns need resizing and then choose
Format=>Column=>AutoFit Selection.
(Excel widens or narrows the columns in
the cell selection to display all the digits
and text in the cells in the selection.)

¢ Drag the column’s right border in the
column header to the left (to narrow) or
right (to widen). To resize several columns
at once, drag through their column letters
in the header or Ctrl+click them before
dragging right border of one of them.

¢ Select the column or columns to resize
to standard column width (of 8.43
characters) and then choose Format=
Column=>Standard Width and select
OK in the Standard Width dialog box.

e Double-click the column’s right border
in the column header to resize it with
AutoFit. To resize several columns at
once, drag through their column letters
in the header or Ctrl+click them before
double-clicking the right border of one of
them.

Exercise 2-1: Modifying Column Widths in a Spreadsheet

Launch Excel and then open the Spring Furniture Sale.xls workbook you created in
doing the exercises in Chapter 1 and saved in the My Spreadsheets (or My Practice
Spreadsheets folder). If you didn’t do these exercises, open the Exercise2-1.xls file in
the Chapter 2 folder.

v 1If you're using Excel 2002 or 2003, look for the Spring Furniture Sale.xls on the
Open Task pane and, if you find it, click its name to open the file. If you're using
an earlier version, open the File menu and then type the number of Spring
Furniture Sale.xls if it’s listed among the four most recently used files at the
bottom of the File menu.

v~ 1f Spring Furniture Sale.xls is not listed as one of the four most recently used files,
click the Open button on the Standard toolbar. Next click the My Documents
button on the left pane and double-click the My Practice Spreadsheets folder to
display the Chapter 2 folder (which contains the Exercise 2-1.xls file). After dis-
playing the file to open, click its icon and then select the Open button.

After you open this workbook file, make the following changes to the widths of the
columns on the Spring Sales worksheet:
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1. Use the AutoFit feature to widen Column B containing the furniture descriptions
sufficiently so that none of these descriptions are cut off.

2. Drag the right border of Column C to the left until the column is 33 pixels wide
and then release the mouse button (note the appearance of ### indicators in all
but two cells in the Sale table). Next, use AutoFit to widen Column B so that all
the entries in this column are displayed.

3. Use the Column Width dialog box to set column E to a width of 10 characters.

4. Narrow column A to 7.14 characters or 55 pixels wide (use any method that
works).

5.1 you've been modifying your Spring Furniture Sale.xls file, click the Save button
on the Standard toolbar or press Ctrl+S to save your changes. If you've been
modifying the Exercise 2-1.xls file, choose Filew>Save As or press F12 to open the
Save As dialog box and then rename Exercise 2-1.xls to Spring Furniture Sale.xls in
the File Name text box. Make sure that the My Practice Spreadsheets folder
inside My Documents is selected as the location in the Save In drop-down list
before you select Save.

Manipulating the height of certain rows

You don'’t find yourself having to resize the rows of a worksheet all that much. Most of
the time, Excel does all the work for you by automatically resizing them just right to
accommodate any and all formatting changes you make to their cells.

About the only time you might want to increase the height of a row on your own is
when you want to increase the space between the contents of one row and the con-
tents of the row immediately above without going through the trouble of inserting a
blank row as a spacer between them.

row numbers in the row header) and
then drag just the lower border of just
one of the selected rows.

How can [ manually modify the height of
selected rows in a worksheet?

A. You should be familiar with both of these e Position the cell cursor in any one of the
methods for changing row height: cells in the row to be modified, and then
choose Format=>Rowr>Height, and then
enter the number of points in the Row
Height text box before you select OK.
To modify multiple rows at one time,
select the rows before opening the Row
Height dialog box.

¢ Drag the lower border of the number of
the row to modify in the row header
either up (to shorten the row) or down
(to heighten the row). To modify multiple
rows at one time, select the rows (by
dragging through or Ctrl+clicking their

Exercise 2-2: Modifying Row Heights in a Spreadsheet
In the Spring Furniture Sale.xls workbook, practice modifying row height by doing the
following:
1. Increase the height of Row 2, which contains the table title, to 26.25 or 35 pixels
by dragging the row’s border.

Note how the spreadsheet title sinks down when the row height is increased.



26 Part I: Creating Spreadsheets

2. Restore the height of Row 2 to its original height with AutoFit.

Double-click the lower border of a row in the row header to modify its height
using AutoFit or place the cell cursor somewhere in the row and choose
Format=>Row=>AutoFit.

Cell Formatting Techniques

MBER
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Figure 2-1:
You can do
most of your
everyday
formatting
with the
tools on the
Formatting
toolbar.
|

Cell formatting can run the gamut from changing the font, color, attribute, and/or align-
ment of a cell entry to the color, borders, and protection status of the cell itself. You
can accomplish much of the formatting in a typical spreadsheet with the buttons on
the Formatting toolbar. The rest you can accomplish with the options available on the
various tabs of the all-important Format Cells dialog box.

The first rule of formatting is to remember to select all the cells that need formatting
before you select the desired button on the Formatting toolbar or an option on one of
the tabs in the Format Cells dialog box.

Formatting cells with the Formatting toolbar

The Formatting toolbar shown in Figure 2-1 contains the tools you most often need
when formatting your average spreadsheet. These tools are arranged into six groups of
buttons (from left to right across the toolbar):

v Font and Font Size drop-down buttons

v Bold, Italic, and Underline attribute buttons

v~ Left, Right, Center, and Merge and Center alignment buttons

v Currency, Percent, and Comma Style buttons along with Increase Decimal and
Decrease Decimal buttons

1 Decrease Indent and Increase Indent buttons

v Borders, Fill Color, and Font Color buttons

Currency Style Comma Style

Align Right Decrease Decimal
Italic Increase Indent
Font Size Align Left Fill Color
—
el 2w S| B ZU|SES=5ES % o R == S A
Font Bold Center Borders
Underline Decrease Indent

Merge and Center | Increase Decimal

Percent Style Font Color
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To make it easier to find the tool you need while you're first learning Excel and, espe-
cially, while using this workbook, be sure that Excel always displays the Standard and
Formatting toolbars on separate rows (ensuring instant access to all their buttons)
and that the full Excel menus are always displayed. To do this, choose View=>
Toolbars=>Customize to open the Customize dialog box. Then, put a check mark in
the Show Standard and Formatting Toolbars on Two Rows and Always Show Full
Menus check boxes on the Option tab before selecting the Close button.

Exercise 2-3: Formatting Cells from the Format Toolbar

In the Spring Furniture Sale.xls workbook, practice modifying formatting cells from the
Formatting toolbar:

1. Center the title of the table in cell A2 over the range A2:E2 and make it bold.

Click the Merge and Center button after selecting the range of cells over which
you want to center the text that’s entered in the first cell of the range (the range
A2:E2, in this case).

2. Make the column heading entries in cell range A3:E3 bold and italic and center
them in their cells, and then increase the height of row 3 to 17.25 points (23
pixels) to put some space between the table title and the column headings.

3. Right-align the code numbers in the cell range A4:A9.

« Increase the indent of the furniture descriptions in the cell range B4:B9 one
tab and then use AutoFit to widen column B sufficiently to display all the
descriptions.

5. Apply the Comma Style number format to the retail prices in the cell range
C4:C9.

0. Center the percentages in the cell range D4:D9.
7.

Apply the Currency Style number format to the sale prices in the cell range
E4:E9.

8. Add a thick line border around the entire Spring Sale table.

To draw a border around a block of cells, select its cell range (A2:E9 in this case),
and then click the Borders drop-down button and click the Thick Box Border on
the pop-up palette (the one in the lower-right corner).

9. Put borders between all the cells in the table in the range A3:E9.

Select this range and then click the All Border swatch on the Borders pop-up
palette (the one divided into four quadrants).

10. check your fully formatted table against the one entered on the Spring Sale sheet
in the workbook file, Solved2-3.xls, and then when everything checks out, save
your formatting changes in the Spring Furniture Sale.xls workbook file.

Formatting cells with the Format Cells dialog box

You rely on the Format Cells dialog box for applying more complex formatting than
provided by the buttons on the Formatting toolbar. This includes applying any number
formats other than the standard Currency, Percent, and Comma number formats from
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the Number tab as well as for applying alignment changes that involve modifying

the vertical alignment and wrapping, orientation, or direction of the text from the
Alignment tab. You can also use its options on the Font tab for selecting more font
attributes, the Patterns tab for applying patterns along with fill-in colors for cell back-
grounds, and the Protection tab to change locked or hidden status of cells that goes
into effect as soon as you protect the worksheet (see Chapter 17 for details).

Press Ctrl+1 (that’s the Ctrl key and the number 1 on the top row of the QWERTY key-
board) to quickly open the Format Cells dialog box.

The options on the Number tab for applying the various and sundry number formats
that Excel has to offer as well as for creating your own custom number formats are
possibly the most important in the Format Cells dialog box (see Figure 2-2). This tab
organizes the ready-made number formats by category from General, the default for all
cells in a new worksheet, which retains only significant digits, to Custom, where you
can create your own number formats. Here’s a quick rundown on the other ten cate-
gories of number formats that you will probably use more often:

+ Number applies a number format to numeric entries in which you determine the
number of decimal places to display, whether to use the comma as a thousands
separator, and the appearance of negative numbers (either with a negative sign
or enclosed in parentheses in black or red).

v Currency applies a number format to numeric entries in which you determine
the currency symbol (the dollar sign is the default), the number of decimal
places to display, and the appearance of negative numbers (either with a nega-
tive sign or enclosed in parentheses in black or red).

v Accounting applies a number format to numeric entries in which you determine
the currency symbol (the dollar sign is the default) and the number of decimal
places to display (the difference between Accounting and Currency is that
Accounting always uses two decimal places and aligns the currency symbol and
decimal points in their cells).

+* Date uses a new date format for numeric entries that Excel recognizes as repre-
senting dates of the year (because it was entered following one of these date
formats).

v+ Time applies a time format using either a 12- or 24-hour clock for numeric entries
that Excel recognizes as representing times of the day (because it was entered
according to one of the time formats).

1 Percentage multiplies the numeric entries by 100 with a percent sign and the
number of decimal places you designate.

v Fraction selects a fractional number format for the decimals in your numeric
entries.

v~ Scientific applies scientific notation to numeric entries by applying an exponent
and the number of decimal places you designate.

v Text formats numeric entries as though they were text entries.

v Special formats numeric entries following the Zip Code, Zip Code + 4 (with lead-
ing zeros retained), Phone Number (with parentheses added to the first three
digits as the area code and dashes between the third and fourth digits of the
next seven indicating the prefix and main number), or Social Security Number
(with dashes between the third and fourth and fifth and sixth digits of the nine-
digit number).
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Exercise 2-4: Formatting Cells with Number Tab on the Format Cells Dialog Box

Open a new spreadsheet on Sheet1 of a Bookl workbook and use it to practice applying
the following number formats using the Number tab on the Format Cells dialog box:

1.
2.

Format the cell range B2:B5 using the Accounting number format with two deci-
mal places, and the dollar sign.

Enter the following values in the cell range with the Accounting format:
¢ 1234.75 in cell B2
¢ 23500 in cell B3
¢ -1450.5 in cell B4
¢ 100.345 in cell B5

Apply the Text format to cell B7 and then enter 200.25 in this cell. Note how
Excel left-aligns the value and the appearance of the Number Options drop-down
button in later versions of Excel (the diamond with the exclamation point in the
upper-left corner of cell B7).

Create a formula in cell C7 that adds B5 and B7 together and then apply the
Accounting format to the cell. Note that despite the application of the Text
format, Excel still uses its value to return the correct sum (real text entries such
as Paris or Budget all carry a zero value in terms of arithmetic calculations).

Enter the date 02-15-05 in cell B9 (note how Excel automatically converts this
entry to 02/15/2005). Format this cell with the Date format that follows the pat-
tern March 14, 2001.

Format cell B9 with the General number format (note the appearance of the date
serial number 38398, indicating that this date represents the 38,398th day since
the dawn of the twentieth century). Click the Undo button on the Standard tool-
bar to restore the previous date formatting.

Enter the number 00401 in cell B11 and then format it with Special Zip Code
format (note what happens to the dropped zeros).

Enter the number 4155051122 in cell B13 and then format it with the Special
Phone Number format.
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9. Enter the number 20012551 in cell B15 and then format it with the Special Social
Security Number format.

’0. Check your results against those on Sheetl in the workbook file, Solved2-4.xls,
and then when everything checks out, save your practice workbook in your My
Practice Spreadsheets folder inside My Documents under the filename Number
Formatting Practice.xls. Close the workbook.

The options on the Alignment tab of the Format Cells dialog box, as you can see in
Figure 2-3, give you control not only over the horizontal alignment of cell entries (that
is, between the left and right borders of their columns) but over vertical alignment
(between the top and bottom borders of their rows) and the orientation (direction of
the text with regard to a horizontal baseline of 0 degrees) as well. In addition, its Text
Control options (Wrap Text, Shrink to Fit, and Merge Cells) enable you to accommo-
date longer cell entries to restricted column widths.
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Exercise 2-5: Formatting Cells with the Alignment Tab on the Format Cells
Dialog Box

In the Spring Furniture Sale.xls workbook, practice modifying the alignment of various
cell entries using the options on the Alignment tab of the Format Cells dialog box:

1. Increase the height of row 2 from 12.75 points (17 pixels) to 30 points (40 pixels)
and then change the vertical alignment of the table title in cell A2 from Bottom to
Center.

2. Apply the Wrap Cell control to the cell range B4:B9 with the furniture descrip-
tions and then narrow Column B to 12.71 (94 pixels). Then, use AutoFit to
increase the height of rows 4:9 to accommodate the wrapping of the text in
cells B4 and B5.

3. Change the vertical alignment of the cell ranges A4:A5 and C4:E5 from Bottom to
Center.

4. Change the orientation of the column headings in the cell range A3:E3 from 0
degrees to 60 degrees counterclockwise (don’t forget to use AutoFit to increase the
row height so that all the text in the now-diagonal column headings are displayed).
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Entering positive numbers in the Degrees text box on the Alignment tab of the
Format cells dialog box moves the orientation of the text up, counterclockwise to
the baseline; whereas entering negative numbers in the Degrees text box moves
the text orientation down, clockwise from the baseline.

5. Remove the Gray-25% fill color from the merged super-cell A2 by selecting the
merged cell (A2 in this case) and then clicking the No Color button on the
Patterns tab of the Format Cells dialog box.

6. Remove the borders from the merged super-cell A2 by clicking the None button
under Presets on the Border tab of the Format Cells dialog box.

7. Unmerge cell A2 and return it to left horizontal and bottom vertical alignment.

To unmerge a super-cell, select it and then remove the check mark from the
Merged Cells check box on the Alignment tab of the Format Cells dialog box.

To restore left horizontal and bottom vertical alignment, select Left (Indent) on
the Horizontal drop-down list and Bottom on the Vertical drop-down list on the
Alignment tab.

8. Return the height of row 2 to its default height and then move the table title in
cell A2 to cell Al by clicking the empty sample called None in the Presets section
on the Border tab of the Format Cells dialog box.

9. Place a top line border back on top of the skewed column headings in the cell
range B3:E3 by selecting the cell range and then clicking the sample with a line at
the top in the Border section on the Border tab of the Format Cells dialog box.

10. Move the cell pointer up to cell Al, and then check the changes you’ve made to
the formatting of your Sale table against those shown in the Solved2-5.xls work-
book file in the Chapter 2 folder. When everything checks out, save your work as
a new workbook called Spring Furniture Sale — fmt01.xls in your My Practice
Spreadsheets folder inside My Documents on your hard disk and then close the
workbook.

Using Format Painter and AutoFormat

Excel’s Format Painter and AutoFormat features are designed to make quick work of
applying complex formatting to large regions of the worksheet. Format Painter enables
you to copy the formatting you’ve applied to a single cell to many ranges, whereas
AutoFormat enables you to apply formatting to an entire table of data.

To use Format Painter, you put the cell cursor in the cell containing the formatting you
want to copy (formatting that you've already applied with the tools on the Formatting
toolbar or the options in the Format Cells dialog box). Then click the Format Painter
button (the one with the paintbrush icon) to copy the formatting in the current cell
(indicated by a marquee moving around inside the cell’s borders) and drag the mouse
pointer (now equipped with a paintbrush icon) through the range of cells to be format-
ted. As soon as you release the mouse button, all the formatting in the cell where you
originally clicked the Format Painter button is now transferred to the selected range
you painted.

Format Painter normally turns off the moment you release the mouse button after
dragging through the cell range to be painted. If you need to paint multiple ranges, you
need to turn on Format Painter by double-clicking its button on the Standard toolbar.
This enables you to paint as many ranges as you want by dragging through them.
When you finish copying the formatting, you must, however, remember to click the
Format Painter button on the Standard toolbar again to turn Format Painter off.

\\3
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Exercise 2-6: Formatting Cells with the Format Painter

Open the Exercise2-6.xls workbook file in your Chapter 2 folder inside the My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook’s CD-ROM) and then practice using Format Painter to quickly
add formatting to its unformatted Production Schedule for 2006:
1. Apply the following formatting to cell B2 containing the first column heading:

e Light Yellow fill color

e [talic text attribute

¢ Qutside Borders all around the perimeter of the cell

2. Use the Format Painter button to copy the formatting you applied to cell B2 to all
the other column headings in the cell range C2:J2.

3. Apply the following formatting to cell B3 containing the production value for Part
100 in April, 2006:

¢ 9-point Arial type

e Number format with zero decimal places

e Gray-25% fill color

¢ Outside Borders all around the perimeter of the cell

4. Use Format Painter to copy all this formatting to all the rest of the production
values in the table in the cell range B3:J6.

When copying the formatting and/or entry from the first cell in a block to all the
cells in that block, you need to include the cell with the formatting or contents to
copy as part of the copy-to range

5. Apply the following formatting to cell A3 and then use Format Painter to copy it
to the cell range A4:A7 and the range B7:J7:

¢ Right alignment

e Number format with zero decimal places

e Light Green fill color

e Outside Borders all around the perimeter of the cell

When you need to use Format Painter to copy formatting to more than one cell
range in a worksheet, double-click its button — when you’re finished painting all
the ranges, click the Format Painter button again to turn it off.

6. Move the cell cursor to cell Al and then check your fully formatted Production
Schedule table against the one shown in Solved2-6.xls in the Chapter 2 folder.
When everything checks out, save your work as a new workbook called
Production Schedule 06 — fmt.xls in your My Practice Spreadsheets folder
inside My Documents on your hard disk and then close the workbook.

As fast as Format Painter is for copying complex formatting from one to many cells in the
worksheet, its speed is nothing compared to that of AutoFormat. With AutoFormat, you
can dispense complex formatting to an entire table of data in just a single operation.

All you have to do to use AutoFormat is put the cell cursor in any one of the cells in a
table of data (that is, a block of data bounded by the borders of the worksheet or
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empty cells), and then open the AutoFormat dialog box (Format=>AutoFormat). Now
select the style of table formatting to apply to the table from the samples shown in this
dialog box.

Exercise 2-7: Formatting a Table with AutoFormat

Open the Exercise2-7.xls workbook file in your Chapter 2 folder inside the My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook’s CD-ROM) and then practice using AutoFormat to format
another copy of the unformatted Production Schedule for 2006 table, this time in one
operation:

1. Open the AutoFormat dialog box and then double-click the Classic 1 sample.

2. Click the Undo button or press Ctrl+Z to remove this table formatting and then
open the AutoFormat dialog box a second time. This time, double-click the List 3
sample.

3. Apply the Number format with zero decimal places to the cell range B3:J7.

4. Move the cell cursor to cell Al and then check your Production Schedule table
formatted with AutoFormat against the one shown in Solved2-7.xls in the Chapter
2 folder. When everything checks out, save your work as a new workbook called
Production Schedule 06 — autofmt.xls in your My Spreadsheets (or My Practice
Spreadsheets) folder inside My Documents on your hard disk and then close the
workbook.

Using Conditional Formatting

Conditional Formatting enables you to set up a particular type of formatting that goes
into effect only when a condition or a series of conditions that you define actually go
into effect in the spreadsheet. This type of formatting is useful when you want to apply
a special type of formatting (such as a red fill color or underlining) to a cell to alert
when its calculated data entry reaches a particular (high or low) value.

Exercise 2-8: Formatting Cells with Conditional Formatting

Open the Exercise2-8.xls workbook in the Chapter 2 folder and then use its Income
Statement to get practice in applying and using Conditional Formatting by doing the
following:

1. Put the cell cursor in cell B10 containing the formula for calculating the total
operating loss and then open the Conditional Formatting dialog box.

2. Click the drop-down list button in the box to the immediate right of the one that
says Cell Value Is and select Greater Than or Equal To on its drop-down menu.

3. Click the empty text box to the immediate right of the drop-down list box that
now says Greater Than or Equal To and then type 100000 (1 and five zeros).

4. Click the Format button to open the Format Cells dialog box where you select
the following formatting:

¢ Bold as the Font Style and Yellow as the Color on the Font tab
* Red as the Color and 6.25% Gray as the Pattern on the Patterns tab
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5. Select OK to close Format Cells. After checking the preview of the conditional
format, select OK again to close the Conditional Formatting dialog box.

0. Reduce the Product Costs in cell B6 from the current -12,175 to -2175 (note that
cell B10 now uses your yellow-on-red conditional formatting because the
Operating Income (loss) in this cell has risen to 109,440, 9,400 above 100,000 con-
dition you set).

To replace an existing entry with a new entry, simply select the cell and enter the
new entry as though the cell were still blank.

7. Click the Undo button on the Standard toolbar or press Ctrl+Z to return the
Product Costs and Operating Income (loss) cells in this spreadsheet to their orig-
inal values. (Note how the conditional formatting immediately disappears when
the value in cell B10 returns to its original 99,440.)

8. Click the Redo button or press Ctrl+Y to undo your undo in step 7, restoring
the -2175 entry in cell B6 and 109,440 calculated value in cell B10. (Note how the
conditional formatting for Operating Income (loss) cell returns.)

9. Check your Income Statement with conditional formatting against the one shown
in Solved2-8.xls in the Chapter 2 folder. When everything checks out, save your
work as a new workbook, Income Statement 06 — condfmt.xls in your My Practice
Spreadsheets folder inside My Documents on your hard disk, and then close the
workbook.

Hiding Columns and Rows

Excel enables you to hide entire columns and rows in your worksheet. You can use this
facility to conceal sensitive data (such as salaries and the like) in a spreadsheet that
are used in formula calculations but that are not for everyone’s eyes.

Hiding columns and rows is a lot like modifying their width and height (in fact, if the
truth be known, a hidden column is just one whose width is reduced to zero and a
hidden row is one whose height is shrunk down to zero). Select the column or columns
to hide and then choose Format=>Column=>Hide or the row or rows to hide and
Format=>Rowr>Hide.

To redisplay concealed columns, you select the remaining columns on either side (left
and right) of the hidden columns and then choose Format>Column=>Unhide. To redis-
play concealed rows, select the rows on either side (above and below) the hidden
rows and then choose Format=>Row=>Unhide. Excel then redisplays all the formerly
hidden columns or rows, which are automatically selected, and all you have to do is
click a single cell anywhere in the worksheet to deselect them.

NUS
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spaces between). Be aware, however, that
applying this ;;; Custom number format
hides only the entries as they appear in the
worksheet itself but does nothing to cloak
their appearance on the Formula bar when
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Exercise 2-9: Hiding Columns and Rows in a Worksheet

Open the Exercise 2-9.xls workbook file in the Chapter 2 folder located in the My
Practice Spreadsheets folder inside My Documents on your hard disk (or in the Excel
Workbook folder on the workbook’s CD-ROM) and use its 12-month Regional Income
table to practice hiding columns and rows:

’. Hide the column ranges B:D, F:H, J:L, and N:P and then put the cell cursor in cell
Al so that only columns A, E, I, M, Q, and R are displayed at the far left of the
Income Analysis worksheet.

2. Select the column range A:Q and then choose Format=>Column="Unhide. Click
cell Al and then verify that all the erstwhile hidden columns of the spreadsheet
are redisplayed.

3. Hide the row ranges 4:8, 12:16, and 20:24 and then scroll up to verify that only
rows 1, 2, 3;9, 10, 11; 17, 18, 19; and 25 are displayed at the top of the Income
Analysis worksheet.

4. Select the row range 3:25 and then redisplay all the hidden rows by choosing
Formate>Column=>Unhide. Click cell A3 and then verify that all the missing rows
are now redisplayed in the worksheet.

5. Close the Exercise 2-9.xls workbook file without saving your changes and exit
Excel.
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Chapter 3

Printing Spreadsheet
Reports

In This Chapter

Previewing the printed report

Using Page Break Preview to adjust the paging

Adding ready-made and custom headers and footers to a report

Adjusting various Page and Print Settings

Printing all or portions of a workbook

printing easy-to-read and well-organized reports from your spreadsheets is one of the
most important tasks you do in Excel. The exercises in this chapter give you a chance
to practice printing many types of spreadsheet reports using Excel’s Print Preview, Page
Break Preview, headers and footers, and print title features. Don’t worry if you don’t have
access to a printer while completing these exercises: In almost all cases, you can use the
Print Preview feature to get an idea of how the report would appear on the printed page.

Previewing the Printed Report

\\3

Print Preview is your first line of defense against wasting paper on useless reports that contain
bad page breaks, which separate columns and rows of the spreadsheet with data that need
to appear together on a page. In Print Preview, all the information, both text and graphics,
within the current Print Area (that is, the section of the worksheet included in the printout) is
displayed as it appears on the printed page. Along with this spreadsheet data, any headings
that you've assigned to the pages of the report also appear.

Always use Print Preview to check your report before sending it to the printer, unless it’s one
that you've already successfully printed from the spreadsheet.

Exercise 3-1: Previewing a Printed Report

Open the Spring Furniture Sale.xls workbook in your My Spreadsheets (or My Practice
Spreadsheets) folder inside the My Documents folder and use it to practice using Print
Preview:

1. Click the Print Preview button on the Standard toolbar to open it in the Print Preview
window.
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Click the Margins button on the toolbar at the top of the Print Preview window to
display the markers for the left, right, top, and bottom page margins along with
those indicating the current column widths.

Click somewhere in the displayed Sale table with the magnifying glass mouse
pointer to zoom in on the table and its data.

Click the Setup button on the Print Preview toolbar to open the Page Setup
dialog box and then select the Horizontally and Vertically check boxes in the
Center on Page section on the Margins tab.

Select the Page 1, Spring Furniture Sale.xls heading in the Header drop-down list
box on the Header/Footer tab and then select the OK button.

Click the Print button on the Print Preview toolbar to close the Print Preview
window and open the Print dialog box. If you have a printer installed on your
system, make sure that its name is displayed in the Name text box and then
select OK to send the one-page report to it. Otherwise, click Cancel to close the
Print dialog box without printing the report.

Close the Spring Furniture Sale workbook and save the changes when an alert
dialog box appears asking you to do so (your changes to the print settings,
including the header, are then saved as part of the file).

Adjusting Page Breaks

Whereas Print Preview alerts you to all sorts of potential problems in the printed
report by showing you everything on the page as it will print, Page Break Preview only
shows you where the page breaks occur. Page Break Preview does this by drawing
lines between columns and rows in the worksheet that indicate the limits of each page
in the report. You can then manipulate the page breaks by dragging these lines to new
columns and rows.

1.

Exercise 3-2: Paging a Report with Page Break Preview

Open the Exercise3-2.xls workbook in the Chapter 3 folder in your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM) and use it to practice using Page Break Preview:

Select Viewr>Page Break Preview on the Excel menu bar to put the Income
Analysis worksheet into Page Break Preview mode and then select OK or the
Close box to close the Welcome to Page Break Preview dialog box. Note that
Page Break Preview automatically sets the worksheet zoom factor to 60% (indi-
cated by the 60% in the Zoom combo box in the Standard toolbar).

Click the Zoom combo box, type 48, and press Enter to increase the zoom factor
to 48% (just a little below half-size) so that the entire Income Analysis spread-
sheet is displayed on the screen.

Remove the first bad page break that occurs between rows 28 and 29 where the
Northern region Net Income in row 28 on pages 1, 3, and 5 of the report is sepa-
rated from the other regions on pages 2, 4, and 6.

Return the spreadsheet to 100% (by clicking 100% on Zoom drop-down list on the
Standard toolbar), scroll down until you see the break between rows 28 and 29,
and then drag the page break line between rows 28 and 29 up two rows so that
the break now occurs between rows 26 and 27. The heading Net Income and
Northern region income figures are now printed on pages 2, 4, and 6 of the report.
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4. Adjust the page break between pages 1 and 3 and pages 2 and 4 so that only the
Qtr 1 income figures are printed on pages 1 and 2 and all the Qtr 2 income data
are together on pages 3 and 4.

Scroll up so you can see the column header in the worksheet and then drag the
page break line between columns G and H to the left so that the break now
occurs between columns E and F, putting all the Qtr 2 figures on pages 3 and 4 of
the report.

5. Adjust the page break between pages 3 and 5 and 4 and 6 so that only the Qtr 2
income figures are printed on pages 3 and 4 of the report.

6. Adjust the page break between pages 5 and 7 and 6 and 8 so that only the Qtr 3
income figures are printed on pages 5 and 6 of the report.

7. Choose View>Normal to get out of Page Break Preview mode. Note that the page
breaks continue to appear as dotted lines in normal spreadsheet view.

« Verify the pages of the report in Print Preview.

8
9. Center the printing between the left and right margins on each page of the
report.

Select the Horizontally check box in the Center on Page section on the Margins
tab of the Page Setup dialog box to center the printing between the left and right
margins.

10. Remove the column and row gridlines from the report by removing the check
mark from the Gridlines check box on the Sheet tab of the Page Setup dialog box.

11. preview all eight pages of the final report using the Page Down key to advance to
the next page and the Page Up key to return to the previous page (make sure
that you've zoomed out on the previewed page before pressing these keys, or
you only end up scrolling around the same page).

12. when you’re sure that all the pages of the report are okay, print the report if you
have access to a printer; otherwise, close the Print Preview window and then
save the revised Income Analysis workbook file as Solved3-2.xls in the Chapter 3
folder before you close the workbook.

Adding Custom Headers and Footers

In Exercise 3-1, you added a canned or ready-made header to your simple one-page
report. This header centered the page number between the left and right margins and
aligned the name of the workbook file with the right margin inside the top margin of
the printed page. In addition to these types of ready-made headers and footers, Excel
enables you to create custom headers and footers for your reports.

To add a custom header or footer to a report, you insert codes (selected from buttons
like those that appear in the Header dialog box shown in Figure 3-1) that retrieve infor-
mation about the report or workbook file that you can mix with stock text (such as the
company or department name) in one of three sections:

1 Left Section for information to be left-aligned against the page’s left margin

v Center Section for information to be centered between the left and right
margins

v Right Section for information to be right-aligned against the page’s right
margin
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of the Page Setup dialog box (choose the
Filem>Page Setup menu command or click
the Setup button in Print Preview).
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Header or Custom Footer button and insert

the codes and stock text you want to add
to it in the Header or Footer dialog box.

Exercise 3-3: Creating a Custom Header and Footer for a Report

Open the Exercise3-3.xls workbook in the Chapter 3 folder of your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM) and use this new copy of the Income Analysis work-
sheet to practice creating a custom header and footer for a report:

1. Open the Print Preview window, open the Page Setup dialog box, and select the
Header/Footer tab.

2. Select Page 1 of ? in the Footer drop-down list box (Page 1 of 8 appears in the
Footer preview area at the bottom of the Page Setup dialog box).

3. Click the Custom Header button to open the Header dialog box and then insert
the date and time codes in the Left Section and make their text 9-point bold
Times New Roman.

When inserting codes in a custom header or footer, you need to insert spaces
between the codes and any stock text if you don’t want their text to all run

together.
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To change the font or assign an attribute to the codes or stock text you add to a
section of a custom header or footer, drag through them, and then click the Font
button. Choose the font, font style, and attributes in the Font dialog box.

4. Insert the filename in the Center Section of the custom header and make its text
9-point bold italic Arial.

5. mnsert the stock phrase PRELIMINARY (in all caps) in the Right Section of the
custom header: Make this stock text 9-point Times New Roman and then select
OK to close the Header dialog box.

0. Make the ready-made footer with the current page and total page numbers
10-point bold Arial.

To customize the font settings for a ready-made header or footer, open the
Header or Footer dialog box with the Customize Header or Customize Footer
button, respectively, and then select the codes or stock text before you click the
Font button.

7. Close the Footer dialog box and the Page Setup dialog box and then check out
your custom header and footer in the Print Preview window.

8. If the header and footer check out, close the Print Preview window and then save
the revised Income Analysis workbook file as Solved3-3.xls in the Chapter 3 folder
and close the workbook.

Adding Print Titles to a Report

In Excel reports, you use Print Titles to print the column and row headings from the
worksheet on each and every page. If you don’t bother to add Print Titles to multi-page
reports, only the first pages of the report contain the headings that identify the related
data, and your readers have no way of identifying the data on the later pages of the
report.

Exercise 3-4: Adding Print Titles to a Report

Open the Exercise34.xls workbook in the Chapter 3 folder in your My Spreadsheets (or
My Practice Spreadsheets) folder or on the workbook CD-ROM and use it to practice
adding Print Titles to a report:

1. Open the Bo-Peep Client List in the Print Preview window and then preview each
of its four pages. Note that page 2 lacks the spreadsheet title and the column
headings with the field names, page 3 lacks the row headings with the case num-
bers, and page 4 lacks the spreadsheet title as well as the identifying column and
row headings.

2. Close the Print Preview window and then open the Page Setup dialog box
(File=>Page Setup) and select the Sheet tab.

You can only assign rows and columns of the spreadsheet from the Sheet tab of
the Page Setup dialog box when you open this dialog box in the normal work-
sheet window. The Rows to Repeat at Top and Columns to Repeat at Left text
boxes in the Print Titles section on the Sheet tab are grayed out and unavailable
when you open the Setup dialog box with the Setup button in the Print Preview
window.
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3. Click the Rows to Repeat at Top text box and then click row 2 of the Client List.
Note that the Page Setup dialog box temporarily collapses down to just Rows to
Repeat at Top text box as you click row 2 in the worksheet. A marquee now
appears around this row in the worksheet and that its row range, $2:$2, appears
in the text box on the Sheet tab.

4. Click the Columns to Repeat at Left text box and then click somewhere in column
Ain the Client List — a marquee now appears around column A in the worksheet
and the column range. $A:$A appears in this text box on the Sheet tab.

5. Click the Print Preview button on the Sheet tab in the Page Setup dialog box and
then page through each of the four pages in the Print Preview window. Now the
column headings with the field names for the list and the row headings with the
case numbers appear at the top and at the left of every page in the report.

0. Close the Print Preview window and then save the revised Bo-Peep Client List
workbook file as Solved34.xls in the Chapter 3 folder and close the workbook.

Modifying the Print Setting for a Report

Regardless of what type of printer you use, Excel has a number of default print settings
that it automatically puts into effect when you first print a spreadsheet. These print
settings include

v Portrait rather than landscape orientation for the printing (so that the printing
runs with the shorter width of the page rather than with the longer length)

v Printing at 100% of normal size

v Print quality medium (on printers that support different print quality modes)

v Letter (8.5 x 11 in.) paper size

v Top and bottom margins of 1 inch

v Left and right margins of 0.75 inch

v Header and footer margins of 0.5 inch (with no header or footer defined)

v No printing of the column and row gridlines that define the cells in the
worksheet

v No printing of the column letters and row numbers associated with the cells
within the Print Area in the worksheet

v No printing of the comments attached to cells included in the Print Area
(see Chapter 4 for more on comments)

v Printing of error values returned by formulas as they appear in the worksheet
(see Chapter 5 for more on error values)

v Paging order down the rows of the Print Area and then across the columns
v Printing a single copy of all the pages generated from a Print Area that includes
all the data in the active worksheet(s)

Many times you may find that you can solve minor paging problems in a report simply
by modifying the orientation of the printing, the percentage of normal size on the Page
tab of the Page Settings dialog box, or the margin settings on the Margins tab.

If your intention is simply to produce a facsimile of the worksheet for reviewing its
data, you should include the worksheet gridlines and column and row headings in the
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printout. To do this, you select the Gridlines and Row and Column Headings check
boxes on the Sheet tab of the Page Settings dialog box. If you also want to print the
comments, select the At the End of the Sheet or As Displayed on Sheet option on the
Comments drop-down list box on this tab.

Exercise 3-5: Changing the Print Settings for a Report

Open the Exercise3-5.xls workbook in the Chapter 3 folder in your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM) and use it to practice changing various print
settings:

1. Open the Print Preview window and check out the page breaks for this three-
page report that prints all the data in the Total Sales worksheet in portrait mode.

2. Open the Page Setup dialog box from the Print Preview window and then select
the Page tab.

hd

Click the Landscape option button under Orientation and then select OK to close
the Page Setup dialog box.

=

Check out the page breaks for printing the report in landscape mode. Note that
the third page now contains an “orphaned” column with the annual total sales.

N

Open the Page Setup dialog box again and then click the Page(s) Wide text box to
the immediate right of the Fit To option button in the Scaling section of the Page
tab. Replace the 1 in this text box with a 2 so that the Fit To option button is
selected with the setting 2 pages wide by 1 page tall.

Using the Fit To Scaling option to constrain the printing to a particular number of
pages rather than Adjust To option to set a specific scaling percentage is often a
much more effective way to eliminate pages with orphaned columns or rows of
data.

A\

0. Close the Page Setup dialog box and then check out the paging in this now two-
page report. Note that the column with annual total sales is no longer orphaned.

7. Close the Print Preview window and then select Qtrl worksheet.

8. Open the Print Preview window for this second worksheet in the Exercise 3-5.xls
workbook and then click the Margins button to turn on the margin and column
markers in Print Preview.

9. Turn on the gridlines and row and column Headings with the Page Setup dialog
box in the Print Preview window.

The display of the gridlines and row and column headings are controlled from
check boxes located on the Sheet tab of the Page Setup dialog box.

10. Zoom in on the preview of page 1 of the report by clicking the Sales table with
the magnifying glass mouse pointer.

11. Narrow column B to somewhere between 14.43 and 14.39 characters wide,
column C to somewhere between 14.29 and 14.22, and column D to somewhere
between 14.22 and 14.20 characters wide. Note the addition of the Qtr1 totals in
column E and the reduction of the report to a single page.

Refer to the Width display indicator on the left side of the status bar in the Print
Preview window when you manipulate the column markers (this indicator
changes to Left Margin, Right Margin, Top Margin, Header Margin, Bottom
Margin, and Footer Margin when you move their respective markers).
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12. Turn off the gridlines and row and column headings in the Print Preview window;
add a footer that prints the page number centered and the worksheet name
right-aligned.

73 If you have access to a printer, print this worksheet; otherwise, just close the
Print Preview window and then save the workbook as Solved3-5.xls in the
Chapter 3 folder in your My Practice Spreadsheets folder before you close
the workbook.

Printing All or Part of the Workbook

A\

A\

As noted in the previous section on default print settings, the Print Area that defines
which cell ranges are included in the printout consists of whatever worksheet or work-
sheets that you've selected at the time of printing. Many times you need to reduce the
Print Area to just a range of cells within the active worksheet or to increase it to
include the data on all the worksheets in the entire workbook. The exercises in this
section give you practice in printing not only Print Areas of different sizes but also
printouts that include the contents of formulas in the spreadsheet (as opposed to
their calculated values) and charts that you've created (see Chapter 14 for practice on
charting spreadsheet data).

If you want to print all the data on the active worksheet using the print settings cur-
rently in effect for that sheet, simply click the Print button on the Standard toolbar:
Excel then sends the print job directly to the default printer without ever opening the
Print dialog box.

Printing a range of cells

Many times you only need to print a particular table or list of data on the active work-
sheet (as opposed to all the data on the sheet). To do this, select the cell range or
ranges that encompass this data in the active worksheet and then click the Selection
option button in the Print What section in the Print dialog box (File=>Print or Ctrl+P).
Then send the print job to the printer by selecting OK.

If you have a table or list in a worksheet whose updated data you need to print regu-
larly, name the range and use the Go To feature (as covered in Chapter 4) to quickly
select it for printing.

Exercise 3-6: Printing a Particular Range of Worksheet Data

Open the Exercise3-6.xls workbook in the Chapter 3 folder in your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM) and use it to practice printing just a table of data:

1. Select the cell range A1:R15 (note that several of the rows and columns in the
worksheet are hidden) and then open the Print dialog box.

2. Click the Selection option button and then click the Preview button at the
bottom of the Print dialog box to verify that only the Sales table, and not the
embedded column chart immediately beneath it in the 2006 Sales worksheet,
will be printed.
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3. Center the printing of this sales table both horizontally and vertically on the page.
4. Add a footer that prints the page number centered at the bottom of the printout.

5. Add a custom header that prints your name or your company name in the Left
Section, the current date in the Center Section, and type the word CONFIDENTIAL
in the Right Section.

0. 1t you have access to a printer, print this worksheet; otherwise, just close
the Print Preview window and then save the workbook as Solved3-6.xls in the
Chapter 3 folder in your My Practice Spreadsheets folder before you close the
workbook.

Printing the entire workbook

Printing all the data in the entire workbook is a snap: Simply open the Print dialog box
(Filew>Print or Ctrl+P) and then select the Entire Workbook option button in the Print
What section before sending the print job to the printer by selecting the OK button.

How can I print data on multiple work- A. Select the tabs for all the worksheets in the
sheets without printing the entire workbook that contain data you want
workbook? printed (remember to Ctrl+click to select

multiple sheet tabs) before sending the job
to the printer.

Exercise 3-7: Printing the Entire Workbook

Open the Exercise3-7.xls workbook in the Chapter 3 folder in your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM) and use it to practice printing all the sheets in a
workbook:

1. Open the Print dialog box and then select the Entire Workbook option button in
the Print What section before selecting Preview to open the Print Preview window.

2. Check out all three pages of the report in the Print Preview window. Note the
orphaned column of data on page 2 and the landscape orientation of the printing
of the column chart on page 3.

3. Select page 1 of 3 in the Print Preview window and then change the orientation of
the printing of this page from portrait to landscape. Check out the paging again
in Print Preview.

4. Center the printing of the Production Schedule on page 1 between the left and
right margin.

5. Add afooter to the report that prints the current page number and total pages
centered at the bottom of the page.

. Preview the two pages of the report. Note that the page number footer only
appears at the bottom of page 1 with the data table and not on page 2 with the
column chart.

The footer isn’t displayed on page 2 with the chart because by default Excel
prints all charts on their own Chart sheets Full Page, leaving no room for a
header or footer (see Exercise 3-8 to see how you go about changing this setting).

45
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7.1 you have access to a printer, print this two-page report; otherwise, just close
the Print Preview window and then save the workbook as Solved3-7.xls in the
Chapter 3 folder inside your My Practice Spreadsheets folder before you close
the workbook.

Printing charts in the spreadsheet

Charts that you create from the data in your spreadsheets are either embedded in the
same worksheet that contains the data or on a separate Chart sheet (see Chapter 14).
In Exercise 3-6, you saw that embedded charts are printed as part of the worksheet
unless you select just the data ranges they’re created from as the print selection. In
Exercise 3-7, you saw that charts placed on their own Chart sheets are not printed
unless you select their sheets as part of the print selection.

What you didn’t see is that when you print a chart placed on its own Chart sheet,
Excel adds a Chart tab to the Page Setup dialog box. The Chart tab contains options
for scaling the chart instead of printing it full page and for printing the chart in black
and white instead of color. You get experience using these options in Exercise 3-8 that
follows.

Exercise 3-8: Printing a Chart in a Report

Open the Exercise3-8.xls workbook in the Chapter 3 folder in your My Spreadsheets (or
My Practice Spreadsheets) folder or on the workbook CD-ROM and use this copy of
the 2006 Production Schedule workbook to practice printing a chart saved on its own
Chart sheet in a workbook:

1. Select the Column Chart sheet in the Exercise3-8.xls workbook and then open the
Page Setup dialog box.

2. Change the Printed Chart Size option from Full Page to Scale to Fit Page and
select black-and-white printing for the Printing Quality. Next open the chart in
the Print Preview window.

3. Display the margin markers in the Print Preview window and then add a header
with the sheet name centered in the top margin and the current page number in
bottom margin.

4. Close the Print Preview window and return to the Column Chart sheet in the
Exercise3-8.xls workbook.

5. If you have access to a printer, click the Print button on the Standard toolbar to
print this Chart sheet; otherwise, just make the Schedule sheet active before you
save the workbook as Solved3-8.xls in the Chapter 3 folder in your My Practice
Spreadsheets folder, and then close the workbook.

Printing the spreadsheet formulas

When you print a worksheet, Excel prints the entries exactly as they appear in their cells
of the worksheet. As a result, when you print a section of a worksheet that contains for-
mulas, the printout shows only the results of the calculations performed by the formulas,
not the contents of the formulas themselves. In addition to a printout showing the results,
you may also want to print a copy of the worksheet showing the formulas by which these
results were derived. You can then use this printout of the formulas when double-checking
the formulas in the worksheet to make sure that they are designed correctly.
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To help you identify the cell reference of each formula in your printout, be sure to
include the gridlines and column and row headings as part of the printout.

Exercise 3-9: Printing the Formulas in a Spreadsheet

Open the Exercise3-9.xls workbook in the Chapter 3 folder in your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM). Use this copy of the Income Analysis spreadsheet to
practice printing the formulas in a table of data in a workbook:

1. Display the formulas in the cells of the Income Analysis spreadsheet by selecting
the Formulas check box on the View tab of the Options dialog box (Tools=
Options). Note how turning on the formula display enlarges the columns to
accommodate all the formulas.

2. Press Ctrls+~ (tilde) to turn off the formula display and return to the normal work-
sheet display.

The tilde key is located on the * key (accent grave) that is usually located to the
immediate left of the 1 key on the top row of the QWERTY keyboard.

Ctrl+~ (tilde) is a toggle key combination: The first time you press it, it turns on
the formula display and the second time turns it off.

3. Press Ctrl+~ (tilde) again, this time to turn the formula display back on and then
change the following settings in the Page Setup dialog box:

e Change the orientation of the printing from portrait to landscape.

e Add a centered header that contains the text Formula Check and a cen-
tered footer that displays the current page number and total pages in the
report, both in 10-point Arial Black.

¢ Make the row 3 the Rows to Repeat at Top and column A the Columns to
Repeat at Left.

e Add the gridlines and the row and column headings to the printout.
¢ Change the page order from Down, Then Over to Over, Then Down.

4. Close the Page Setup dialog box and then display the Income Analysis worksheet
in the Print Preview window. Note that the report now contains 18 pages.

5. Constrain the pages to 9 pages wide by 1 page tall and center the data on each
page horizontally between the left and right margins; then close the Page Setup
dialog box and return to the Print Preview window.

6. Turnon Page Break Preview mode and then dispense with the Welcome dialog box.
7.

Move the page markers so that page 1 contains only Qtr1 figures; page 2 only
Qtr2 figures; page 3 only Qtr3 figures, and page 4, the Qtr4 figures with the grand
totals.

8. If you have access to a printer, click the Print button on the Standard toolbar to
print the four-page report showing all the Income Analysis formulas; otherwise,
use Print Preview to verify the layout and contents of these pages and then
return to the Normal worksheet mode.

9. Hide the display of the formulas in the cells.

10. save the workbook as Solved3-9.xls in the Chapter 3 folder in your My Practice
Spreadsheets folder and then close the workbook file.
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Chapter 4

Modifying the Spreadsheet

In This Chapter

Finding and opening a workbook for editing

Selecting the cell ranges that require editing

Finding data entry errors with Text to Speech

Inserting and deleting cell ranges

Moving and copying cell ranges

Using comments in the spreadsheet

Finding and replacing cell entries and spell-checking the spreadsheet
Editing worksheets as a group

S)me of the spreadsheets you work with require constant updating, whereas others
need only the occasional revision. Whichever is the case, being able to revise an exist-
ing spreadsheet without disturbing either its underlying structure or its current contents is
essential. The exercises in this chapter give you a chance to practice all aspects of basic
editing, including locating the workbook file to open, finding the area in the worksheet that
needs editing, and making all the necessary editing changes.

Finding and Opening the Workbook for Editing

You can’t edit a spreadsheet if its workbook is not open in Excel, and you can’t open its work-
book in Excel if you don’t know where it’s saved on your computer. The secret to locating the
workbook files that need editing (aside from sticking to a clear and consistent system for
naming your files and deciding where to save them) is to make them eminently searchable.
And the key to making your workbook files super-searchable is to add summary information
that you can then use in doing a file search to each and every new workbook you save.

Adding summary information to a workbook

The Properties dialog box (Filew>Properties) contains all sorts of vital statistics about the
workbook, such as its size, location, the name of its creator, as well as the date it was origi-
nally created, last modified, and last opened (accessed). In addition to this information that’s
automatically kept on the file (as listed on the General and Statistics tabs), you can add your
own information to its Summary tab. You can then use any and all of the statistics, both
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those automatically recorded and those you add, when doing a file search to locate the
file for editing.

Figure 4-1 shows the Summary tab of the Properties dialog box for the Exercise4-1.xls
workbook you use later in a related exercise. As you can see, this tab contains a
number of fields that you fill in. Although you may not want to add all this summary
information to all the workbooks you create, you would do well to develop a system
whereby you consistently fill in those fields you routinely use when doing a file search.

Exercised-1.xls Properties

General | SUmMMary | Statistics || Contents | Custom

Title:

Subject:

Authaor: Greg Harvey
Manager:

Company;: |Mind Over Media, Inc,
Category:

Keywords:

Comments:

Hyperlink
base:

[(]5ave preview picture

e

Be sure to check the Save Preview Picture check box at the bottom of the Summary
tab if you want to be able to use the Preview viewing mode in the Open dialog box to
later identify it. When you select Preview on the Views drop-down list, a snapshot of
the upper-left part of first worksheet in the workbook appears in a pane on the right
side of the dialog box whenever you select its filename in a list in a pane on the left
side. If you don’t select this check box, all you see is a Preview Not Available message
when you select the workbook’s filename.

Exercise 4-1: Adding Summary Information to a Workbook

If Excel’s not already running, launch the program. Then, open the Exercise4-1.xls file in
the Chapter 4 folder inside your My Practice Spreadsheets folder in My Documents on
your hard disk. You will use this workbook to practice adding summary information:

1. Open the Exercise4-1.xls Properties dialog box (File=Properties) and then select
the Summary tab.
2. Enter the following information into the designated fields:
¢ Hourly/Wages - February, 2006 in the Title field
e Monthly payroll in the Subject field
¢ Payroll in the Category field
¢ Array in the Keywords field
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3. Select the Save Preview Picture check box and then select OK to close the
Properties dialog box.

4. Open the Save As dialog box (F12). If My Documents folder is not already shown
in the Save In drop-down list box, click the My Documents button and then
create a new folder name Lost Spreadsheets inside this folder.

To create a new folder in the Save As dialog box, click the Create New
Folder button on the Open dialog box toolbar (the one with the star-
burst on its folder icon) and then enter the folder name in the New
Folder dialog box.

5. Rename the workbook Exercise4-1.xls to Hourly Wages 02-06.xls and then select
the Save button.

6. Close the Hourly Wages 02-06.xls workbook.

Searching for workbook files

The file search feature available from Excel’s Open dialog box is one of the program’s
better-kept secrets. To use this very important feature, you open the File Search dialog
box by selecting the Search item at the very top of the Tools drop-down list. (Open the
drop-down list by clicking the Tools button at the end of the Open dialog box toolbar
on the right.)

The File Search dialog box contains two tabs:
v Basic, where you can search for workbook files by entering all or part of their

filenames in the Search Text box

v Advanced (shown in Figure 4-2), where you can search for a workbook by select-
ing the property (including automatically kept stats and information you add to
the Summary tab fields) and then designating the value it should contain

File Search

|EE

Property: Cordition: Valuz:

Text or property V| | indudes e | |payroll

|
Figure 4-2:
The
Advanced
tab of the
File Search
dialogbox || —————
enables you ||l2=== | [ s |
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summary
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|

Results shoulo be;

¥ |Anything st
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Exercise 4-2: Searching for the Workbook to Edit

This exercise gives you practice finding workbook files using both the Basic and
Advanced tabs on the File Search dialog box:

1.

2.

Display the Open dialog box (Ctrl+O) in Excel, click the My Documents button to
make this folder current, and then open the File Search dialog box (click Search
on the drop-down list attached to the Tools button).

Type Exer in the Search Text box on the Basic tab of the File Search dialog box
and then set up the following Search Options:

e My Computer and all its subfolders as the location to search in the Search
In drop-down list box

¢ Excel Files as the type of files to find in the Results Should Be drop-down
list box

¢ To restrict the location of the file search to My Computer and its subfold-
ers, click the Everywhere check box on the Search In drop-down list to
deselect it and all the other locations, and then click the My Computer
check box (the Search In drop-down list box will then read Selected
Locations).

¢ To restrict the type of files to be searched for to Excel files, click the
Anything, Outlook Items, and Web Pages check boxes to deselect them and
their associates and then click only the Excel Files check box under Office
Files. (The Results Should Be drop-down list box will then read, “Selected
File Types.”)

Select the Go button to begin searching for all the Excel files that contain Exer in
the filename within your My Computer folder and its subfolders.

When the file search stops, you will see a whole list of all the Exercise workbook
files that you copied from the workbook CD-ROM and that you created in doing
the exercises in previous chapters in the Results section at the bottom of the File
Search dialog box.

Delete the text Exer in the Search Text box on the Basic tab and then click the
Restore button on the Advanced tab of the File Search dialog box.

Using the Advanced tab, set up a Search for every workbook with a Category
that includes payroll:

To set up this search option, click Category in the Property drop-down list,
select Includes in the Condition drop-down list, and then type payroll in the
Value text box before you select the Add button.

Select the Go button to find all the Excel workbooks within your My Computer
folder and its subfolders whose Category summary information contains payroll.

When the File Search stops, you should see your Hourly Wages 02-06.xls file listed
in the Results section at the bottom of the dialog box.

Click the Hourly Wages 02-06.xls file listed in the Results section.

Note that a border now appears around the filename with a drop-down list
button on the right. When you mouse over this drop-down list button, a ToolTip
displaying the file’s entire path name appears.

Select the Properties item on file’s drop-down list to open the Hourly Wages
02-06.xls Properties dialog box and then click its Summary tab.
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Note that this tab contains all the summary information you entered there when
you created this file as part of Exercise 4-1.

9. Select the OK button to close the Hourly Wages 02-06.xls Properties dialog box.
Next click the OK button while Hourly Wages 02-06.xls is still selected in the
Results section to close the File Search dialog box and return to the Open dialog
box. (Leave this dialog box displayed in Excel for Exercise 4-3 on using the Open
options.)

Exploring the Open options

Normally you don’t think twice about opening workbooks that you located and
selected in Excel’s Open dialog box. However, just opening the original file for editing
by selecting the Open button is not your only option. In addition to the normal Open
option, the drop-down list attached to the Open button gives you the following other
options:

+* Open as Read-Only to open the workbook file in read-only mode in Excel so that
you can’t save changes to the original file.

+* Open as Copy to open a copy of the workbook file in Excel so that you can’t save
changes to the original file.

* Open and Repair to have Excel attempt to repair a damaged workbook file
before opening. (Use this option when you’re unable to open a workbook file that
has somehow become corrupted using the normal Open option.)

Exercise 4-3: Using the Various Options for Opening a Workbook

Use the Hourly Wages 02-06.xls file that you located with File Search and selected in the
Open dialog box in Exercise 4-2 to get practice with using the different Open options:

1. Click the drop-down list button attached to File Name combo box in the Open
dialog box and then click the path name of the Hourly Wages 02-06.xls at the top
of this drop-down list.

Excel responds by selecting the Lost Spreadsheet folder that you created for the
Hourly Wages 02-06.xls file in the last lesson.

2. Click the Hourly Wages 02-06.xls file icon in the Open list box to select it.

3. Click the drop-down button attached to the Open button and then select the
Read-Only option on its drop-down list.

Excel opens a copy of the Hourly Wages 02-06.xls workbook in read-only, indicated
by [Read-Only] appended to the filename on the program window’s title bar.

4. Increase Michelle’s hourly wage from $25.00 an hour to $40.00 in cell A4 and then
save the changes (Ctrl+S).

To replace one value with another, enter the new value in the cell just as though
it were blank — as soon as you complete the entry by clicking the Enter box or
pressing the Enter key, Excel replaces the original value with the new one, using
the formatting assigned to the cell.

5. select OK in the alert dialog box informing that this workbook is read-only and
then save your changes in the Lost Spreadsheets folder under the filename
Hourly Wages 02-06-rev1.xls and close this workbook file.
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0. Display the Open dialog box again (Ctrl+O) and this time open a copy of the
Hourly Wages 02-06.xls file icon in the Lost Spreadsheets folder.

To open a copy of a workbook, select its file icon in the Open list box and then
select the Open as Copy option on the Open button’s drop-down list — Excel
opens the a copy of the original file indicated by the Copy (1) of text that
precedes the filename on the program window’s title bar.

7. Redisplay all the hidden columns in the Feb 06 sheet of this workbook (see
Chapter 2 if you've forgotten how to do this), and then select cell Al before
you save your changes (Ctrl+S) and close the workbook.

Finding and ldentifying the
Region that Needs Editing

As you’re already well aware, an Excel worksheet represents an extremely large space
in which to work. Often the biggest challenge in editing a spreadsheet is just finding
and identifying the data ranges in the worksheet that are in need of revision. To help
in this endeavor, you can often use the following three features to good advantage:

v Zoom to gain an overview of the worksheet and its data ranges by zooming out
on the worksheet and then using it to gain a close-up view of the particular range
in the sheet you need to edit

v Freeze Panes to prevent the rows and columns containing the column and row
headings from scrolling so that these headings remain visible at all times while
you are scrolling through their data entries

v Custom Views to name and save a combination of different worksheet display
settings (including frozen panes and various magnification settings) so that you
can put them into effect by simply selecting them

Q. What is the range of zoom settings I can A.  You can set the worksheet display magnifi-
select for my worksheet display? cation setting anywhere in the range of 10%
to 400% of normal by entering the value of
the new magnification percentage directly
into the Zoom combo-box in whole degree
increments.

Exercise 4-4: Using Zoom, Freeze Panes, and Custom Views

Open the Exercise4-4.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This file contains a copy of
the now-familiar Regional Income worksheet that you can use to practice using the
Zoom, Freeze Panes, and Custom Views features to find and identify ranges for editing:

1. Select 50% on the drop-down list attached to the Zoom combo-box.

Excel reduces the magnification of the worksheet display to half the normal
size. Note, however, that even at one-half, not all of the data ranges are visible
on-screen.
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2. Click the Zoom combo-box that reads 50% on the Standard toolbar and then type
45 and press Enter.

At a maghnification setting of 45% of normal, you can now see all the data entered
in the Income Analysis worksheet.

3. Select the cell range J20:M25 by carefully dragging through this range in the
worksheet (not so easy to do when the cells are so small), and then click
Selection at the bottom of the drop-down list attached to the Zoom combo-box.

Excel responds by setting the magnification setting to something over 200% so
that all of the cells in the selected range J20:M25 are visible in the display. Note,
however, that without the row and column headings, it is impossible to identify
these entries in this range.

4. Put the cell cursor in cell Al (Ctrl+Home) and move it to the empty cell B3 so
that the cursor is in the row immediately beneath the one with the table’s
column headings and the column immediately to the right of the one containing
the row headings.

5. Select Windowr>Freeze Panes.

Excel draws a horizontal line between rows 2 and 3 and a vertical line between
columns A and B indicating the limits of the frozen panes — any entries above
the horizontal line and to the left of the vertical line remain on screen as you
scroll through their columns and rows.

6. Use the Tab key to scroll new columns on the right into view.

Note how the column headings in row 2 as well as the table title in row 1 remain
displayed as you move to columns of the table into view.

7. Use the Page Down key to scroll new rows lower in the worksheet into view.

Note how the row headings in column A remain displayed on the screen as you
move new rows of the table into view.

8. Repeat steps 2 and 3 in this exercise. Select the cell range J20:M25 and then set
the magnification to the display of this selection.

Note that this time with the addition of the frozen panes that retain the associ-
ated row and column headings, you can tell right away that you’re looking at the
3rd Qtr operating expenses for all the divisions.

9. Return the Zoom setting to 100% and then position the cell cursor in cell B3,
which you used to freeze the row and column headings.

10. Open the Custom Views dialog box (Viewr>Custom Views) and then select the
Add button to open the Add View dialog box.

11. Type 100% w/ Row & Col Headings in the Name text box and then select OK.

’2. Hide the column ranges B:D, F:H, J:L, and N:P. Next, select cell B3 and then, fol-
lowing steps 10 and 11, name this view 100% 4 Qtrs Display.

73. Open the Custom Views dialog box and double-click the 100% w/ Row & Col
Headings view in the Views list box.

’4. Open the Custom Views dialog box and select the 100% 4 Qtrs Display view and
then hide the following row ranges: 4:8, 12:16, 20:24, and then select cell B3. Save
this view under the name 100% 4 Qtrs Total Display.

15. Return the worksheet to the 100% w/ Row & Col Headings view, and then choose
Window=Unfreeze Panes to remove the panes.

16. Position the cell cursor in cell Al. Save this version of the Income Analysis work-
sheet with the custom views under the filename Solved4-4.xls in the Chapter 4
folder and close the workbook.



56 Part I: Creating Spreadsheets

Selecting the Ranges to Edit

Selecting occupied cells in the worksheet for editing is very much the same process as
selecting blank cells for preformatting or data entry with one important exception.
Because the cells already contain data, in addition to dragging through the ranges and
clicking the first and last cell while holding down the Shift key, you can use a technique
known as AutoSelect to quickly select an entire block of occupied cells in a couple of
mouse clicks.

Moreover, you can use Excel’s Go To and range name features to combine locating a
cell range that needs editing and selecting its cells all at the same time!

Exercise 4-5: Selecting the Range of Cells for Editing

Open the Exercise4-5.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This file contains a copy of
the 2006 Production Schedule worksheet that you can use to practice selecting cell
ranges for editing beginning with the AutoSelect feature:

1. Position the mouse pointer on the bottom edge of the cell cursor in cell A2, hold
down the Shift key, and then when the Arrowhead mouse pointer appears,
double-click the bottom edge.

AutoSelect extends the selection down to row 7, the last occupied row in the
data table.

2. Continue to hold down the Shift key as you double-click anywhere on the right
edge of the extended cell cursor.

AutoSelect extends the cell selection to column J, the last occupied column in
the data table, effectively selecting all of its cells in the range A2:J7.

3. Click cell A15 in the worksheet to position the cell cursor in this cell while at the
same time deselecting the cell range A2:J7.

Now you will practice selecting the cells in the data table using Excel’s Go To
feature, which is normally used to position the cell cursor in a new cell in the
worksheet.

4. Press F5 or Ctrl+G to open the Go To dialog box and then type A2 (it’s all right to
enter the reference as a2) and press Enter.

The Go To dialog box disappears and the cell cursor jumps to cell A2, making it
current.

5. Press F5 or Ctrl+G to open the Go To dialog box again and then type J7 (or j7).
This time, however, hold down the Shift key as you press Enter.

Excel jumps the cell pointer to cell J7 and, because you held down the Shift key,
the program also selected all the cells in between (if you didn’t hold down Shift
key, the program just moves the cursor from A2 to J7).

6. Position the cell cursor in cell Al and use AutoSelect on your own to select the
cell range Al:J7.

Note that this time it takes an extra double-click on the bottom edge of the cell
cursor to extend the cell selection down to row 7. Next, you're going to name
this cell selection.
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7. Click the Name Box on the Formula bar that currently displays Al, and then type
prod_table (with an underscore and no space) and press Enter.

Excel assigns the range name prod_table to the cell selection, Al:J7.

8. Use the Go To feature to move the cell cursor to cell IV4000 on the other side of
the worksheet.

9. Click the drop-down button attached to the Name Box on the Formula bar and
then click prod_table on its drop-down list.

Excel responds by selecting the range A1:J7 and repositioning the worksheet so
that this range is in view.

10. Click cell Al to deselect the range Al:J7, and then save this workbook with the
prod_table range name with the filename Solved4-5.xls in your Chapter 4 folder
inside the My Practice Spreadsheets folder and close the workbook file.

Editing Data Entries

A\

In the previous exercises in this chapter, the sole technique you've used to modify the
entry in a cell is to replace it completely by entering the new value into that cell as
though it were still blank. This method is fine as long as the replacement entry is short
and easy to type. It is not, however, the preferred method when you only need to make
slight corrections to a long text entry or a complex formula. Rather than replace the
original entry, you need to put Excel into Edit mode so that you can edit its contents as
you would a word or phrase in a word-processing program such as Microsoft Word.

Excel gives you a choice of techniques for putting the program into Edit mode:

v Click the I-beam cursor at the place in the current cell entry that needs editing
on the Formula bar and then edit its contents on the Formula bar.

v Double-click the white-cross mouse pointer at the place in the cell entry in the
worksheet that needs editing and then edit its contents in the cell.

v Press F2 to place the Insertion point at the end of the current cell entry in the
worksheet and edit its contents in its cell.

After you've placed Excel in Edit mode and positioned the Insertion point somewhere
in the entry, you can then use the «— and — to move the flashing pointer in front of or
immediately after the characters to modify. Press the Delete key to remove characters
to the right of the Insertion point or the Backspace key to remove characters to its left.
To insert new characters at the insertion point and move existing characters out the
way and to the right, just type them.

After you finishing modifying the contents of the entry, you still need to complete the
edit as you do a new entry. Only in this case, you need to rely on the Enter box, Enter
key, Tab, or clicking another cell as you can’t use any of the arrow keys (T, |, «, or —).
In Edit mode, these cursor keys only move the Insertion point within the characters of
the entry.

If you need to abandon an edit without entering the changes you’ve made in the cell or
on the Formula bar, press the Esc key. If you complete a mistaken editing change, click
the Undo button on the Standard toolbar or press Ctrl+Z to undo the change (and keep
in mind that Excel supports multiple levels of undo).
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Exercise 4-6: Editing Cell Entries

Open the Exercise4-6.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This file contains a copy of
the CG Media 2006 Sales worksheet that you can use to practice making simple editing
changes to the contents of particular cells in the spreadsheet:

1. Click the I-beam pointer in front of the C in Category, and then type Media and
on the Formula bar and click the Enter box to insert this text in the spreadsheet
title in cell Al.

The edited title in cell Al now reads, CG Media - 2006 Sales by Media and
Category.

2. Double-click the white-cross pointer after the s in Discs in the row heading in cell
A3, and then remove this extraneous s.

The edited row heading in cell A3 now reads, Compact Disc Sales.

3. Position the cell cursor in cell A14, press F2 and then replace Cassette in the row
heading with Tape and press Tab to complete the edit.

The row heading in cell A14 now reads, Total Tape Sales.

4. Select cell Al again and save your editing changes in a new file named
Solved4-6.xls in your Chapter 4 folder inside the My Practice Spreadsheets
folder, and then close the workbook file.

Catching Errors with Text to Speech

If you're using Excel 2002 or 2003, you can use the Text to Speech feature to catch data
entry errors by listening to them. Text to Speech reads the entries in a data table or
list out loud, enabling you to check their accuracy by keeping your eyes focused on
the printed source from which they were originally entered.

Exercise 4-7: Verifying Data Entries with Text to Speech

If you have Excel 2002 or 2003 installed on your computer, open the Exercise4-7.xls
workbook file in the Chapter 4 folder inside your My Practice Spreadsheets folder or in
the Excel Workbook folder on the workbook CD-ROM. This file contains a copy of the
Spring 2006 Furniture Sale spreadsheet that you can use to practice using Text to
Speech to verify the accuracy of entries in a data table:

1. Choose Tools=>Speechw>Text to Speech on the Excel menu to open the Text to
Speech toolbar (see Figure 4-3).

If this is the first time you've used Text to Speech, Excel must install the program
before it can display this toolbar. Follow the prompts to install the program and
then after you have it installed proceed to the next step of the exercise.

2. Click the Speak Cells button on the Text to Speech toolbar and listen to the
entries in cell Al and then across the column headings in the row. After you
hear the entry Sale Price in cell E2, click the Stop Speaking button.

3. Click the By Columns button and then click the Speak Cells button again and
listen to the entries in the cell range A3:A7.
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Notice how the mechanical voice, called LH Michael (LH stands for Lerner &
Hauspie, the folks who created the voice), pronounces the contents of cell A3 as
“twelve to three hundred five” rather than “twelve dash three hundred five” (the
program interprets the dash as indicating a range).

4. After LH Michael finishes speaking “retail price one thousand three hundred
ninety-nine” in cell C7, click the Stop Speaking button again.

5. Click the Start button on the Windows taskbar and then click Control Panel on
the Start menu.

0. Click the Sounds, Speech, and Audio Devices link followed by the Sound link (if
your Control Panel is in Classic view, simply double-click the Speech icon) and
then click the Text to Speech tab to display its options in the Speech Properties
dialog box.

7. Select LH Michelle in the Voice Selection drop-down list and listen to her voice
preview before you select OK.

8. Click the Speak Cells and listen to LH Michelle say the remaining entries in the
data table. When she’s finished speaking, click the Stop Speaking button.

In addition to listening to entries already made in a spreadsheet, you can have
Text to Speech read back each entry as you make it. Try this in a scratch work-
sheet in a blank workbook.

9. Open a new blank workbook by clicking the New button on the Standard toolbar.

10. Click the Speak on Enter button on the Text to Speech toolbar (upon which LH
Michelle tells you that “cells will now be spoken on Enter.” Make the following
entries down column A:

¢ Northeast Consortium in cell Al.
¢ Alfred E. Neuman in cell A2

¢ -89.45 in cell A3

¢ CD-ROM in cell A4

¢ 95-11-0034 in cell A5

¢ 415-555-0023 in cell A6

¢ 3678.6 in cell A7

e May 12, 2006

11. Close the blank workbook without saving your Speak on Enter text entries to the
scratch worksheet; then click the Speak on Enter button to turn off this feature
before you close the Text to Speech toolbar. Close the Exercise4-7.xls workbook
without saving your changes.

|
Figure 4-3:
The
Advanced Speak on Enter
tab of the
File Search
dialog box |
enables you |EESEEIEIRES
to search
for work-
books using By Columns
summary
information.
|

Speak Cells

Stop Speaking
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Deleting and Inserting Data and Cells

\NG
s

Deletions in a worksheet are a little more complicated than in other software pro-
grams. This is because Excel gives you a choice between deleting only the cell entry,
leaving intact the cell structure and all assigned formatting attributes; clearing the
cell of all its contents without disturbing its structure; and removing the cell structure
along with everything its contains, causing remaining cell entries in neighboring cells
to adjust to fill in the gap:

v Press the Delete key to remove only the entry in the current cell.

v Choose Edit=>Clear=>All to remove the entry in the current cell plus all format-
ting attributes and comments.

v Choose Edit>Delete and then choose between the Shift Cells Up and the Shift
Cells Left options to remove the cell along with all its contents, formatting, and
comments and to adjust remaining cells in rows below up or in columns on the
right to the left.

The Insert>Cells command is the opposite of Edit=>Delete. You use it to insert blank
cells in regions where you need to squeeze in data entries that were somehow left out.
In the process of squeezing in these blank cells, you can have Excel shift existing
entries down to rows below or to columns to the right.

You can delete and insert entire rows and columns from the worksheet by selecting
the Entire Row and Entire Column option in the Delete or Insert dialog box or by
selecting the rows and columns in the column and row header in the worksheet
and then selecting Edit=>Delete or Insert=>Columns or Insert>Rows commands.

Be very cautious about deleting or inserting entire rows or columns in any worksheet,
especially one that you didn’t create or are not that familiar with. You can easily take
out vital data in tables and lists located in unseen regions of the worksheet when doing
a deletion. Inserting new columns and rows can be almost as dangerous, however, as
your insertions can just as well corrupt the accuracy or even disrupt the functionality
of the formulas in these unseen tables and lists. To stay on the safe side, constrain your
cell deletions and insertions to just the cell ranges in the region you're working in.

Exercise 4-8: Deleting and Inserting Cells in the Spreadsheet

Open the Exercise4-8.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder or in the Excel Workbook folder on the workbook CD-ROM. This
file contains a copy of a House Sales table that you can use to practice deleting and
inserting cells and cell entries.

1. Select cell C4 with the selling price of the house on Elm Street and delete just
this entry by pressing the Delete key.
2. Enter 1250000 in now blank cell C4.

Because you only deleted the contents in cell C4, Excel applies the remaining
Currency style number format with no decimal places to the new entry you made
so it immediately appears as $1,250,000 in the cell.

3. Delete everything in cell C4 by choosing Edit=>Clear=>All.
4. Enter 735000 in the now blank cell C4.



Chapter 4: Modifying the Spreadsheet 6 ’

This time, Excel does no number formatting to the 735000 value because you
cleared the cell of formatting plus contents.

5- Use the Format Painter to restore the Currency style number format with no dec-
imal places to cell C4.

Position the cell cursor in cell C5 that still contains this Currency number for-
matting. Click the Format Painter button on the Standard toolbar and then click
cell C4 to copy just the formatting from cell C5.

Select the cell range A5:C5 listing a house sale on Apple Drive.

NS

Choose Edite>Delete and then leave the default Shift Cells Up option button
selected as you choose OK.

Excel removes the cells in the selected cell range A5:C5 while at the same time
pulling up the data in the rows below so that there are no gaps in the table.

8. Click the Undo button on the Standard toolbar or press Ctrl+Z to restore the
deleted cell range.

9. Leave the cell range A5:C5 selected and then choose Insert>Cells. Leave the
default Shift Cells Down option button selected as you select OK.

Excel inserts three blank cells above the Apple Drive sales information, shifting
the remaining entries in this table down. If you're using Excel 2002 or 2003, you’ll
note the appearance of the Insert Options button at the Fill handle in the lower-
right corner of the extended cell cursor: You display its drop-down button by
positioning the mouse pointer over the button and then use its options to copy
cell formatting from the cells in the row below (it automatically uses the format-
ting in the cells in the row above) or to clear all formatting from the newly
inserted cells.

’0. Make the following entries in the new, empty cell selection, A5:C5:
¢ The address, 500 King Street, in cell A5
¢ The selling date, 4/2/2006, in cell B5
¢ The selling price, 820000, in cell C5

11. Select cell Al and then save your editing changes to the House Sales table in a
new workbook named Solved4-8.xls in your Chapter 4 folder inside the My
Practice Spreadsheets folder.

Moving and Copying Data and Cells

Excel provides two methods for moving and copying a cell selection (along with their
contents and formatting) to a new place in the same worksheet. You can either use

v Drag-and-drop to manually take the selection or a copy of it with the mouse
pointer and drop it into its new place in the sheet

v Cut and paste to cut or copy the selection to the Windows Clipboard and then
paste it into its new position after moving the cell cursor to the first cell of that
range

QQ,N\BEI? &
& Keep in mind that you must use the cut-and-paste method to move or copy cell ranges
from one worksheet to another in the same workbook or from one workbook to another.

When using the cut-and-paste method, you can select what part of the cut or copied data
is transferred when pasting it into their new position in the worksheet or workbook. You
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do this by selecting the Edit=>Paste Special command and then selecting the appropri-
ate Paste option in the Paste Special dialog box (see Table 4-1).

Table 4-1 The Paste Options in the Paste Special Dialog Box

Paste Option What It Does

All Pastes all types of entries (numbers, formulas, and text),
their formats, and comments from the selection in the
paste area

Formulas Pastes only the entries (numbers, formulas, and text)

from the selection in the paste area

Values Pastes only numbers and text from the selection in the
paste area, converting all formulas to their current calcu-
lated values so they're pasted into the worksheet as

numbers

Formats Pastes only the formats from the selection into the paste
area

Comments Pastes only the comments from the selection into the
paste area

Validation Pastes only the entries in cells that use data validation
into the paste area

All Except Borders Pastes everything but the borders assigned to the cell
selection into the paste area

Column Widths Pastes everything into the paste area and adjusts the
column widths in this area to match those of the original
cell selection

Formulas and Number Formats Pastes only the formulas and number formatting (omitting
all text and numeric entries) from the cell selection into
the paste area

Values and Number Formats Pastes only the numbers and number formatting (omitting
all text and converting all formulas to their calculated
values) from the cell selection into the paste area

\3
) Use the Transpose check box in the Paste Special dialog box to transpose the data in
the table so that data that used to run across the columns now run down the rows,
and vice versa.
Exercise 4-9: Moving and Copying Cells in the Spreadsheet
<WECD Open the Exercise4-9.xls workbook file in the Chapter 4 folder inside your My Practice

Spreadsheets folder or in the Excel Workbook folder on the workbook CD-ROM. This
file contains a formatted copy of the Production Schedule table that you can use to
practice moving and copying cells and their data entries. Note that this copy of the
spreadsheet contains the range name prod_table assigned to the cell range Al1:J7 that
you can use to select its cells:

=

1. Select the table’s cells (A1:J7) and then use drag-and-drop to move it so that it
now occupies the range B8:K14.
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Position the white-cross mouse pointer somewhere on the bottom edge of the
extended cell cursor and then when the pointer changes to an arrowhead, drag
the selected range of cells to its new position.

When the ToolTip at the bottom of the outline representing the cell selection
you’re moving reads B8:K14, release the mouse button to drop it in place.

2. Use AutoFit to widen columns B, E, and H so that their column headings can be
displayed in their cells.

3. Use drag-and-drop to copy the table you've just moved to the cell range B8:K14
to the cell range B19:K25.

Hold down the Ctrl key as you drag the outline of the copy of the selected cell
range to its new position in the worksheet.

4. Cut the copy of the Production Schedule table in the cell range B8:K14 to the
Clipboard by clicking the Cut button on the Standard toolbar, or press Ctrl+X.

Excel responds by putting a marquee around the cell selection B8:K14 and dis-
playing Select Destination and Press ENTER or Paste on the status bar.

5. Make Sheet2 active, and then move the cell cursor to cell B2 and press Enter.

The moment you press the Enter key, Excel moves the table to the cell range
B2:K8 on Sheet2 of the workbook.

6. Switch back to the Schedule sheet and select cell Al.

Excel deselects the cell range B8:K14 on the Schedule sheet that used to contain
the table you moved to the B2:K8 on Sheet2.

7. Select the cell range B8:K14 containing the original Production Schedule table by
selecting its range name, prod_table, on the Name Box button’s drop-down list.

Note how a range of cell entries retains its range name even after you've changed
all of its cell references in a workbook.

8. Click the Copy button on the Standard toolbar or press Ctrl+C to copy the cell
selection, B8:K14 to the Windows Clipboard.

9. Select cell B17, and then choose Edit>Paste Special to open the Paste Special
dialog box. Select the All Except Borders Paste option in this dialog box and then
select OK.

Excel makes a copy of the table without the borders that divide the table’s row
and column headings from their data.

10. Select the range B22:K22 with the Part 103 units in the copy of Production
Schedule table.

11. use drag-and-drop to move this cell range up three rows (so that the row with
the Part 103 units is in row 19, right below the column headings in row 18).

Excel displays an alert dialog box the moment you release the mouse, asking you
if you want to replace the contents of the destination cells.

12. Select the Cancel button in the alert dialog box to abort the move.

’3. Repeat the move of the cell selection B22:K22, this time holding down the Shift
key as you drag upward.

Holding down the Shift key as you drag a cell selection ensures that Excel
automatically shifts existing cell entries out of the way so that you don’t inadver-
tently replace them. Excel indicates that the range will be inserted by represent-
ing the moved range as a horizontal or vertical I-beam rather than as an outline.

74 When the extended horizontal I-beam appears between rows 18 and 19 and the
ToolTip reads B19:K19, release the mouse button.
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This time Excel inserts Part 103 data entries at the top of the table without any
warnings.

15. use drag-and-drop with the Shift key to complete the reordering of the rows of
data in the copy of the Production Schedule table so that cell range B20:K20
contains the Part 102, B21:K21 the Part 101 data, and B22:K22 the Part 100 data.

16. Relocate the two Production Schedule tables that now exist on the Schedule
Sheet up so that the original table now in cell range B8: K14 occupies the cell
range Al:J7 and the copy you made in cell range B17:K23 occupies the range
Al10:J16.

17. select cell Al, and then save your work in a new workbook in your Chapter 4
folder in the My Practice Spreadsheets folder with the filename Solved4-9.xIs.
Close this workbook.

Using Notes in the Spreadsheet

|
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Excel makes it easy to attach notes to the cells of a spreadsheet. You can use these
notes (officially called comments in the program) to remind yourself or your cowork-
ers of changes that need to be made in the spreadsheet or data that needs to be
reviewed and verified.

The key to adding and managing notes in a worksheet is the first section on the left
side of the Reviewing toolbar. This section (identified in Figure 4-4) contains all the
buttons you need to add, edit, delete, display and hide, and move from comment to
comment in the worksheet.

New/Edit Comment
Next Comment

Show All Comments

Delete Comment

Show/Hide Comment

Previous Comment

Exercise 4-10: Adding Comments to the Spreadsheet

Open the Exercise4-10.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder in My Documents on your hard disk (or in the Excel Workbook
folder on the workbook CD-ROM). This file contains a copy of the Employee list that
you can use in practicing how to use comments in a spreadsheet:

1. Display the Reviewing toolbar by choosing View=>Toolbars>Reviewing and then
dock the floating toolbar on the right side of the worksheet (so that Comment-
related buttons appear vertically, one on top of the other).
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To dock a floating toolbar, drag it by its title bar to any of the four sides of the
Excel worksheet and then, when the title disappears, drop it into place.

To undock a toolbar drag it by the dotted line that appears in front of the initial
button and then when its title bar reappears, drop it onto the Excel program
window.

Select cell J2 and then click the New Comment button on the Reviewing toolbar.

Excel responds by inserting a new text box with an arrow pointing to cell J2 con-
taining your name.

Type Verify this employee’s status as the text of this comment.

Resize the text box, making it wide enough for all the comment text to appear on
a single line of the box and short enough that there’s no longer lines of empty
space below the text.

To resize a text box, position the mouse pointer over one of the eight sizing han-
dles that appear as circles at the four corners and midpoints around the perime-
ter of the box. When the mouse pointer changes into a double-header arrow,
drag the sides of the box until it is the size and shape you want (note that Excel
automatically reflows the text in the box to accommodate these changes).

Select cell E6 and then add a comment to this cell reminding you to change
Cindy’s department from Accounting to Human Resources as of 01-01-07.

Move the text box for this comment you add to cell E6 so that the box no longer
obscures cell entries in the Employee list by locating to the right somewhere in
the blank columns of K, L, and M in the worksheet.

To move a text box, position the mouse pointer anywhere on the outline of the
box outside of the eight sizing handles and then drag the outline of the box until
it is positioned to the desired place in the worksheet.

Select cell F20 and then add a note to this cell reminding you to verify Miriam’s
salary and then resize to remove its unused space and reposition the comment’s
text box outside of the list in the empty columns K, L, and M.

Position the cell cursor in cell Al, and then position the mouse pointer over each
of the three cells, J2, E6, and F20 that now contain comments.

Note that positioning the mouse pointer over a cell with a comment causes that

comment’s text box to be displayed. Also note that each of these three cells now
contains a tiny red triangle in the upper-right corner, indicating that the cell has

a comment attached to it.

Click the Show All Comments button on the Reviewing toolbar.

Note this button is a toggle switch that shows or hides all the comments in a
worksheet.

Hide all three comments and then click the Next Comment button on the
Reviewing toolbar to display each of the three comments in succession.

When you reach the last comment attached to cell F20, double-click the border
of the text box to open the Format Comment dialog box.

Select the text of the comment and then change the comment text to 9-point
Arial bold italic and the fill color of the text box to Gray-25%.

Normally, Excel only shows the comment indicator (that red triangle) except
when you select a cell or engage the Show All Comments toggle button on the
Reviewing toolbar. You can, however, change the comments display option so
that the program always shows the comments added to the worksheet.

Select the Comment & Indicator option button on the View tab of the Options
dialog box (Tools=>Options) and then select OK.
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As soon as you close the Options dialog box, all three comments are displayed
in the worksheet. The only way to remove them from view (other than restoring
the Comment Indicator Only default setting) is to click the Hide All Comments
button on the Reviewing toolbar (which replaces the Show All Comments
button).

Hide all the comments along with the Reviewing toolbar and then save this ver-
sion of the Employee list with your notes with the filename Solved4-10.xls in your
Chapter 4 folder in the My Practice Spreadsheets folder. Now close the workbook.

Using Find and Replace and Spell-Checking

Just like Microsoft Word, Excel is equipped with a Find, Find and Replace, and Spell-
checking feature that you can use in editing your spreadsheets:

v+ Find (Ctrl+F) enables you to search for and locate text or values in the spread-
sheet that potentially need changing.

v+~ Find and Replace (Ctrl+H) enables you select whether or not Excel replaces one
set of text or values it locates in the spreadsheet with another set that you specify.

v Spelling (F7) to catch and correct spelling errors using either the built-in diction-
ary or custom dictionary you build.

“‘QN\BER
& Keep in mind when using Find and Find and Replace to locate entries in the spread-
sheet that you can change any of the following search options to refine the search. You
can use the

v Within drop-down list box to choose between Sheet (the default) to look for the
search text only in the cells of the current worksheet or Workbook to search the
cells on all the sheets in the workbook.

v Search drop-down list box to choose between By Rows (the default) to conduct
the search across the rows and then down the columns of the worksheet or By
Columns to conduct the search down each column and then across each row.

v+ Look In drop-down list box to choose among Formulas (the default) to look for
matches to the search text in the entries as they appear on the Formula bar,
Values to look for matches in the entries as they appear in the cells of the work-
sheet, or Comments to look for matches in the comments added to the cells of
the worksheet.

1 Match Case check box to match the upper- and lowercase spelling in the cell
entries with the search text.

1+ Match Entire Contents check box to match the entire contents of a cell with the
search text.

v+ Format button to specify formatting that the cell or cell entries must match.

Exercise 4-11: Editing with Find and Replace and Spell Checking

Open the Exercise4-11.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder in My Documents on the hard disk (or in the Excel Workbook
folder on the workbook CD-ROM). This file contains a number of numeric (variations of
2500 and a variety of dates in 2006) and text (different Italian pastas, yum!) cell entries
that you can use to practice using the Find, Find and Replace, and Spell-checking fea-
tures in Excel:
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1. Open the Find and Replace dialog box with the Find tab selected (Ctrl+F) and
then enter 25? in Find What text box. Continue to select the Find Next button to
locate all the matches in the Find, Replace & Spell worksheet, and Excel returns
the cell cursor to the cell with the first match.

You can use the wildcard characters, ? (question mark) or * (asterisk), to stand
for missing characters in the search text. Note that Excel considers the 2500
entered in cells A2, D2, and D5 as matches but not the 2500 that’s displayed in
cell A7. This is because the 2500 in cell A7 is the calculated result of the formula
=A5+A6 and not a static value entered on the Formula bar.

2. Click the Options button to display the search options and then select Values on
the Look In drop-down list, and then select the Find All button to display the
locations of all the cells with matching entries.

This time, Excel considers the 2500 calculated in A7 as well as those entered into
cells A2 and D5 as matches. However, when Values is set as the Look In search
option, the program no longer considers the $2,500.00 in D2 with its Currency
Style number formatting as a match.

3. Select Comments in the Look In drop-down list and then select the Find Next
button.

Excel jumps the cell cursor to cell C12 in the spreadsheet.

4. Position the mouse pointer over cell C12 and verify that the comment attached
to this cell contains the value 25.

5. Modify the search text in the Find What text box slightly by adding a comma
between the 2 and the 5 so that this text box now contains 2,5?. Now select
Values in the Look In drop-down list again before you select the Find All button.

Now, Excel considers only the $2,500.00 in D2 as a match, as none of the other
2500s have a comma between the 2 and 5 as these entries appear in the cells of
the Find, Replace & Spell worksheet.

6. Modify the search text in the Find What text box again by prefacing 500 with a
question mark wildcard character so that this text box now contains ?500. Then,
select the Find All button.

This time, Excel includes all the cells containing 2500 (including the $2,500.00 in
cell D2) as matches as well as the 1500 entered into cell A6.

7. Select the Match Entire Cell Contents check box under Find search options
before you select the Find All button.

When the Match Entire Cell Contents check box is selected, the $2,500.00 in cell
D2 is no longer considered to be a match because of the decimal point and two
zeros that trail the 500 (the question mark wildcard only pertains to characters
that precede 500).

8. Select the Replace tab in the Find and Replace dialog box and then set up the fol-
lowing conditions:

¢ Position the cell cursor in cell Al of the Find, Replace & Spell worksheet.
¢ Enter 25 in the Find What text box on the Replace tab.

e Enter 27 in the Replace With text box on the Replace tab.

¢ Deselect the Match Entire Contents check box on the Replace tab.

9. Use the Find and Replace feature to change the date May 25, 2005 in cell A17 to
May 27, 2005.

Select the Find Next button until you locate the occurrence of the search text (25
in this case) that you want to replace and then (and only then) select the
Replace button.
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10. Select the 2005 Prod Sch worksheet and then use the Find and Replace feature to
globally update the years in all the dates in the spreadsheet from 2005 to 2006.

Enter 2005 in the Find What text box and 2006 in the Replace With text box and
then select the Replace All button — Excel then displays an alert dialog box indi-
cation the number of replacements.

Be extra careful with performing global replacements, as you can all too easily
wreak havoc in the spreadsheet at the click of the Replace All button — should
you make a major boo-boo with this feature, remember to hit the Undo button to
with all due haste.

1 1. Rename the 2005 Prod Sch worksheet to 2006 Prod Sch by editing its sheet tab.

12. Close the Find and Replace dialog box and then select the Find, Replace & Spell
worksheet and use Excel’s Spelling Checker to check the spelling of the Italian
pasta text entries (F7).

The unknown spelling occurs with Fetticine in cell E10. This is a misspelling, so
you must change it.

73. Accept the Spelling Checker’s suggestion of Fettuccine by clicking the Change
button.

The second unknown spelling occurs with Maccaroni in cell E12. This is also a
misspelling, so you must change it.

74. Accept the Spelling Checker’s suggestion of Macaroni by selecting the Change
button.

The third unknown spelling occurs with Capellini in cell C14. This is a correct
spelling so you can either ignore it or add it to the dictionary.

15. Add the word to the dictionary by selecting the Add to Dictionary button.

76. Close the dialog box indicating that the spelling check is complete, and then
select cell Al and save this version of with the filename Solved4-11.xls in your
Chapter 4 folder inside the My Practice Spreadsheets folder.

Group Editing

Group editing enables you to save time by making the same editing changes to multi-
ple sheets in the workbook at the same time. To put Excel in Group Edit mode, all you
have to do is select all the sheets in the current workbook that you want to edit
together — Excel indicates that a workbook is in Group Edit mode by appending
[Group] to its filename on the Excel program window’s title bar.

S

How do I select individual, nonadjacent How can I quickly select all the sheets in a
worksheets to be included for group workbook for group editing?
editing?

A. Right-click one of the sheet tabs and then
A. Ctrl+click the sheet tab of each worksheet select the Select All Sheets item on the
you want to include in the group. shortcut menu.
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us
S

0. Howcanl easily take the workbook out of A. Click any single visible sheet tab on the

-

group-editing mode? status bar other than the one for the active
worksheet (indicated by the sheet tab name
in bold lettering).

Exercise 4-12: Editing Different Worksheets as a Group

Open the Exercise4-12.xls workbook file in the Chapter 4 folder inside your My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This version of the CG Media
Sales workbook file contains three worksheets, 2004 Sales, 2005 Sales, and 2006 Sales,
that you can use to practice group editing:

1. Quickly examine each of the three worksheets by clicking their sheet tabs in suc-
cession and then return to the first sheet, 2004 Sales.

2. Select all three worksheets for group editing.

To select a group of adjacent worksheets, hold down the Shift key as you click
the tab of the last sheet in the group (2006 Sales in this case) — note the appear-
ance of [Group] after the workbook’s filename on the Excel program window’s
title bar.

3. Apply the Accounting 3 table AutoFormat to CG Media — 2004 Sales by Category
and Date table without applying its font setting, and then the narrow column A to
22.14 characters (160 pixels).

Click the Options button in the AutoFormat dialog box and then deselect the
check boxes for all the formats you don’t want to change (Font, in this case)
before clicking the preview of the AutoFormat (Accounting 3, in this instance)
and then selecting OK.

4. Select the 2005 Sales worksheet and then the 2006 Sales worksheet to verify that
they now share the same table formatting as the 2004 Sales sheet.

Note that the moment you click the sheet tab of the 2005 Sales worksheet, Excel
automatically takes the workbook out of Group mode.

5. Regroup the three worksheets, 2004 Sales, 2005 Sales, and 2006 Sales, and then
make the column headings in the cell range B2:R2 bold and the column headings
in the range A3:A15 right-aligned and bold.

6. Take the workbook out of Group mode, and then select cell Al on the 2004 Sales
sheet. Next save the modified workbook under the filename Solved4-12.xls in
your Chapter 4 folder inside the My Practice Spreadsheets folder and close the
workbook.
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In this part . . .

F)rmulas and spreadsheets go together like cake and
ice cream, and the chapters that make up Part Il are
full of exercises that you give you a chance to create for-
mulas of almost every flavor. Here, you get a taste of every
kind of function that Excel has to offer. You also have an
opportunity to practice building and copying the types of
basic formulas that are a sure recipe for success in any
spreadsheet you create.




Chapter 5
Building Formulas

In This Chapter

Constructing simple arithmetic and comparative formulas by hand
Constructing formulas that use Excel’s built-in functions

Editing formulas

Altering the order in which a formula’s operands are calculated
Creating external reference link formulas

Controlling formula recalculation

No one disputes that formulas are the center of almost every spreadsheet you create.
Being able to build formulas (both those that perform simple arithmetic calculations
as well as those that perform more sophisticated computations using Excel’s built-in func-
tions) is a critical skill. The exercises in this chapter give you a chance to practice building
both types of formulas as well as modifying how and when the formulas in the spreadsheet
are recalculated.

Building Formulas

All the formulas you build in an Excel spreadsheet regardless of their function and degree of
complexity have one thing in common: They all begin with one simple character, = (the
equal to sign).Typing an equal to sign activates the Insert Function, Enter, and Cancel but-
tons on the Formula bar. It also changes the nature of the Name Box drop-down box so that
its list displays commonly used functions rather than the range names assigned to the
workbook.

If you forget to type this as your initial character when creating formulas by hand (Excel is
always sure to put one in for you when you build formulas with the Insert Function button),
the program inserts the string of operands and operators you enter as a text reference.

If you build a legitimate formula, Excel either computes the answer and displays it in the
current cell in the worksheet or, if unable to successfully calculate the answer, the program
displays one of the following error values in the cell:

v~ #NULL! appears when your formula specifies an intersection of two ranges that do not,
in fact, intersect.
v~ #DIV/0! appears when your formula attempts to divide by zero.

v #VALUE! appears when your formula contains some sort of improper argument type or
operand (such as a text entry when the operator requires a value).

v #REF! appears when your formula contains an improper cell reference.
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v #NAME? appears when your formula contains a text reference that Excel doesn’t
recognize (such as a reference to a range name that no longer exists in the
workbook)

v #NUM! appears when your formula contains invalid numeric values (such as a
text entry where a number is required)

v #N/A appears when your formula refers to a value that is not available to it

Building formulas by hand

To build a formula by hand, all you have to do is type an = (equal to) sign and then
designate the string of operands and operators that the formula should use in making
its calculation(s). Operands can be constants that you type into the formula (such as
5.5 or 100), or they can be cell references (such as B5 or A10:J17) that you point
directly to in the worksheet or type.

Table 5-1 shows you a list of all the operators, including their type, character, and
operation.

Table 5-1 The Different Types of Operators in Excel Formulas

Type Character Operation Example
Arithmetic

+ (plus sign) Addition =A24B3

- (minus sign) Subtraction or negation =A3-A2 or -C4

* (asterisk) Multiplication =A2*B3

/ Division =B3/A2

% Percent (dividing by 100) =B3%

A Exponentiation =A273
Comparison

= Equal to =A2=B3

> Greater than =B3>A2

< Less than =A2<B3

>= Greater than or equal to =B3>=A2

<= Less than or equal to =A2<=B3

<> Not equal to =A2<>B3
Text

& Concatenates (connects) entries  =A2&"” “&B3

to produce one continuous entry

Reference

:(colon) Range operator that includes all =SUM(C4:D17)
cells between the colon
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Type Character Operation Example

, (comma) Union operator that combines mul- ~ =SUM(A2,C4:D17,B3)
tiple references into one reference

(space) Intersection operator that produces =SUM(C3:C6C3:E6)
one reference to cells in common
with two references

Exercise 5-1: Building Arithmetic Formulas

If Excel’s not already running, launch the program. Use the first two blank worksheets
of the Book1 workbook to create a practice spreadsheet that gives you experience in
building various types of simple arithmetic formulas by hand:

1. Rename Sheet1 of the worksheet Formulas and Sheet2, Ext Ref.

2. Group the Formulas and Ext Ref sheets together and then increase the worksheet
display magnification percentage for the two sheets to 175%.

3. Ungroup the two worksheets, enter 42 in cell A2, and then name this cell source.
4. Select cell A4, type = (equal to sign) to start a new formula, and click cell A2.

The formula you’re in the process of entering into cell A4 now reads =source,
both in the cell and on the Formula bar. A marquee showing the cell named
source is displayed in cell A2.

5. Click the Enter button (the one with the check mark) on the Formula bar to com-
plete the formula entry in cell A4.

The formula in cell A4 now returns 42 as its answer — this formula consists
solely of an external reference to cell A2, the cell you named source, so whatever
value you enter into the source cell is immediately brought forward and dynami-
cally copied to cell A4.

6. Update the value in cell the source cell, A2, from 42 to 128.

Because the link between cell A4 and A2 was created by your formula with the
external reference, cell A4 of the worksheet now contains 128 as well.

7. Enter the following values into the designated cells of the Formulas worksheet:
* 34 in cell B4
® 47.5 in cell B5
e 2.2 in cell B6
® 10% in cell B7
® 3in cell B8
8. Create an addition formula in cell C4 that adds the value in cell A4 to that in cell
B4 by pointing to these cells:
¢ Position the cell cursor in cell C4
* Type =

® Press « twice to select cell A4 (the first operand)
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* Type + (the addition operator)
¢ Press the < one time to select B4 (the second operand)
¢ If the formula reads =A4+B4, click the Enter button on the Formula bar

9. Use this same pointing technique to create an addition formula in cell A5 that
adds 5 to the value in cell A4 above.

The addition formula in cell A5 should read =A4+5 on the Formula bar and the
answer should appear as 133 in the cell.

10. with the cell cursor in cell A5, drag the Fill handle down to the cell range A6:A8.

Excel copies the original formula you entered into cell A5 down to cells A6, A7,
and A8, which now contain the calculated values, 138, 143, and 148, respectively.

11. Build the following arithmetic formulas in the designated cells:

e Subtraction formula in cell C5 that subtracts the value in cell B5 from that
in cell A5 — remember that - (hyphen or dash) is the subtraction operator
in Excel.

¢ Division formula in cell C6 that divides the value in cell A6 by that in B6 —
remember that / (forward slash) is the division operator in Excel.

e Multiplication formula in cell C7 that multiplies the value in cell A7 by that
in B7 — remember that * (asterisk) is the multiplication operator in Excel.

¢ Exponentiation formula in cell C8 that raises the value in cell A8 by that in
cell B8 — remember that * (caret) is the exponentiation operator in Excel.

12. save your workbook with the filename Practice Formulas.xls in the Chapter 5
folder inside the My Practice Spreadsheet folder, and then open Solved5-1.xls and
compare your results before proceeding to Exercise 5-2.

Arithmetic formulas in the spreadsheet (when properly formed) always return numeric
results. Excel supports another type of formula, known as a comparative formula,
which returns only one of two possible results, TRUE or FALSE. Exercise 5-2 gives you
some practice in creating these types of formulas.

Exercise 5-2: Building Comparative Formulas
Use the Practice Formulas.xls workbook that you created in Exercise 5-1 to get some
experience with building comparative formulas:
1. Build a comparative formula in cell D4 that weighs the value in cell A4 against
that in B4 and indicates whether they are equal to each other:
* Type = in cell D4 to begin the formula
¢ Press the < key three times to select cell A4
¢ Type = again, this time as the comparative operator

* Press the « key twice to select cell B4 so that the formula now reads,
=A4=B4

Click the Enter button on the Formula bar to complete the formula and
compute the result (which is FALSE because the values in these two cells
are not currently equal to one another)
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2. Build the following comparative formulas in the designated cells:

¢ In cell D5, a formula that compares the values in cell A5 to that in cell B5
and indicates whether the one in A5 is larger than the one in B5 — use the
> (greater than) symbol as the operator.

¢ In cell D6, a formula that compares the values in cell A6 to that in cell B6
and indicates whether the one in A6 is smaller than the one in B6 — use the
< (less than) symbol as the operator.

¢ In cell D8, a formula that compares the values in cell A8 to that in cell B8
and indicates whether the one in A8 is unequal to the one in B8 — use the
<> (less than and greater than back to back) symbols as the operator.

3. Change the value in the source cell, A2, from 128 to 34.

Note how Excel immediately updates all the formulas in columns A, C, and D
whose computations depend in some way on this value.

4. Save your changes to your Practice Formulas.xls workbook before proceeding on
to Exercise 5-3.

Well-designed spreadsheets contain many dependent formulas like your Practice
Formulas.xls workbook. The problem comes when any the formulas on which they
depend return one of those dreaded error values covered earlier in this chapter.
When that happens, the error values spread like wildfire to all the dependent formu-
las, making it very difficult, if not impossible, to identify the source of the problem.

Exercise 5-3: Working with Error Values in Formulas

Use your Practice Formulas.xls workbook to get some experience with the error values
that formulas can return and how they infect all dependent formulas in a spreadsheet:

1. Open the Define Name dialog box (Insert->Namer>Define) and then click Source
in the list box before you select Delete and OK.

As soon as you click OK to close the Define Name dialog box, most of the cells in
this spreadsheet contain the #NAME? error value because every formula you cre-
ated in this worksheet is dependent in some way upon the source range name,
inheriting this error value from the original formula in cell B4 with the external
reference the moment you delete its name.

2. Use Undo to restore the source range name to the workbook and get rid of those
awful #NAME? error values in the spreadsheet.

3. Now, delete the value (2.2) in cell B6 and see what effect this has on the division
formula in cell C6.

As soon as you empty cell B6, a #DIV/0! error value is returned by the division
formula in cell C6. This is because all empty cells in any Excel worksheet carry
the value of zero, and this is why #DIV/0! is the most common type of error value
to plague spreadsheets. Often, a template or new spreadsheet you create con-
tains division formulas referring to empty cells for which you do not have or
have not yet entered values. These all naturally return #DIV/0! error values (in
Chapter 12, you find out how to create formulas using the IF function that pre-
vent such formulas from returning this type of error value).

4. Use Undo to restore the original 2.2 value to cell B6 and remove the #DIV/0! error
value from cell C6; in cell B7, enter the text ten percent to see what effect this
has on the multiplication formula entered in cell C7.

/7
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|
Figure 5-1:
Practice
Formulas.xls
with all its
formulas
displayed in
their cells.
|

Although it’s possible to build formulas that deal with text, the one in cell C7 is
not one of them. When you enter ten percent as a text entry in cell B7, its for-
mula essentially chokes, returning the #VALUE! error value to the cell.

5. Use Undo to restore the original 10% value to cell and then press Ctrl+~ (tilde) to
display the formulas in the cells of the worksheet.

Remember that you can always use the Ctrl+~ (tilde) key combination to display
the formulas in your spreadsheet in their cells in the worksheet (very valuable
for verifying its functioning). Check the contents of your formulas against those
shown in Figure 5-1.

0. Press Ctrl+~ again to return the worksheet to its normal display wherein all for-
mulas display their results in the worksheet and their contents on the Formula
bar when the cell cursor is in their cells.
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Building formulas with built-in functions

Excel offers you a wide assortment of built-in functions that can save valuable time in
creating the formulas needed in your spreadsheet. In place of the operands and oper-
ators of your handmade formulas, built-in functions use function names and argu-
ments. All the Excel functions follow the general syntax of the SUM function, the most
widely used spreadsheet function:

=SUM (numberl, number2, . . .)
Note the following about this syntax in this example:

v The function name is always shown in all caps because Excel automatically dis-
plays it that way on the Formula bar regardless of what case you use in entering
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Figure 5-2:
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directs you
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Excel func-
tion to a for-
mula in the
spreadsheet.
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its name. (This means that there are no case restrictions when typing in the func-
tion name — you just have to be careful to spell its name correctly.)

v The argument(s) used by the function immediately follow the function name and
they are enclosed in a balanced pair of parentheses — this means that for every
open parenthesis [(], you need a close parenthesis [)].

v The functions that require or can take more than a single argument separate the
individual arguments within the parentheses with commas.

Even functions such as NOW that take no arguments require the use of a pair of
parentheses to finish them off; for example, =NOW(). If you omit the empty pair of
parentheses, Excel fails to recognize the function and returns the #NAME? error value
to its cell.

Excel classifies each of its built-in functions into one of nine categories (with a tenth
being custom functions that you define yourself), all of which are available from the

Insert Function dialog box, which you open by clicking the Insert Function button on
the Formula bar (the one with the fx marking).

Building a formula that uses a built-in function with the Insert Function dialog box
carries many benefits. Besides starting your formula by automatically entering the
requisite = (equal to) symbol on the Formula bar for you, this dialog box, shown in
Figure 5-2, contains the following features that aid you in locating and using any
function:

1 Search for a Function enables you to look for a function by entering a brief
description of the kind of calculation you want to do.

1 Or Select a Category enables you to find a function by selecting a category
(Financial, Date & Time, and so on) other than the default Most Recently Used
that keeps a record of the most commonly used functions, including the ones
you've used most recently.

v Select a Function enables you to display syntax information showing you the
arguments plus a short description of any function you select in this list box.

v+ Help on This Function displays online help (that you can also print) about the
usage and arguments required by the function currently selected in the Select a
Function list box.

As soon as you select your function in the Insert Function dialog box by selecting it
and clicking OK, Excel not only inserts the skeleton of the function on the Formula
bar but also displays a Function Arguments dialog box for the function, which you
can use in selecting the cell references and values to be used in the computation.

Insert Function %

Search for 3 functon:

Orss

& gategonyt | Most Recently Ussd |
Select 2 funcoon:

T B

AVERAGE
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construct manually, as in =SUM(A5:

J10)”2 to square the total of the range of
values in the cell range A5:J10 of the work-
sheet returned by the SUM function.

Q. Can [ mix built-in functions with handmade
formulas?

A. Yes, most definitely: Excel functions can
serve as operand in any formula that you

Exercise 5-4: Building Formulas with AutoSum

Use your Practice Formulas.xls workbook to get some experience using the SUM,
AVERAGE, and COUNT functions in the spreadsheet. These functions are so fre-
quently used that Excel doesn’t even require you to access them from the Insert
Function dialog box, making them readily available from the AutoSum button on
Standard toolbar:

1. Drag through the cell range A4:A8 to select all their values in the Formulas work-
sheet of your Practice Formulas.xls workbook.

Note that the AutoSum indicator on the Status bar immediately shows you that
the total of the values in this range is 220 (Sum=220).

2. Right-click the AutoSum indicator and then select Average on its pop-up menu.
The AutoSum indicator on the Status bar changes to Average=44.

3. Return the AutoSum indicator to its default Sum setting and then click cell A9 to
place the cell cursor in this cell and deselect the range A4:A8.

4. Click the AutoSum button on the Standard toolbar (the one with sigma _ on it).

Excel immediately responds by entering the SUM formula, =SUM(A4:A8) in cell
A9. Note that the program also places a marquee bounding box around the cell
range A4:A8 in the worksheet as well as selects the argument A4:A8 in the SUM
function itself. This enables you to modify the range or ranges of cells to be
totaled by the SUM function either by editing its argument in the function or
dragging the boundaries of its marquee.

5. Click the Enter button on the Formula bar to complete this formula in cell A9.

Excel enters the formula, =SUM(A4:A8) in this cell as shown on the Formula bar
and displays the total of the range, 220, in the cell.

0. Click the drop-down button attached to the AutoSum button on the Standard
toolbar and then select Average on its drop-down list.

Excel now enters the formula =AVERAGE(A4:A8) for your editing or approval in
cell A9.

7. Click the Enter button on the Formula bar to enter this formula in the cell.

Excel enters the formula =AVERAGE(A4:A8) in this cell as shown on the Formula
bar, and displays the total of the range, 44, in the cell.

8. Use Undo to restore the SUM formula in cell A9 and then use the Count option on
the AutoSum drop-down list to create a formula in cell B9 that returns the
number of values in the range B4:B8.

The formula you construct in cell B9 should read =COUNT(B4:B9) and this for-
mula should return 5 as its result.

9. Replace the value 10% in cell B7 with the text entry, ten.

Ignoring the reappearance of the #VALUE! error in cell C7 for the moment, note
that the result returned to cell B9 changes from 5 to 4, indicating that the COUNT
function counts only the numeric entries in the cells you include in its argument.



70. Restore 10% to cell B7 with Undo, position the cell cursor in cell C9, and click the
Insert Function button on the Formula bar.

11. Move the Insert Function dialog box to the right out of the way of the values
in your spreadsheet. Click SUM in the Select a Function list box before you
select OK.

12. Drag through the cell range A4:A8 to replace the default Numberl argument of
C4.C8 with this range.

Note how Excel automatically condenses the Function Arguments dialog box
down to just the text box for the Number1 argument as you drag through the cell
range and then immediately restores the dialog box the moment you release the
mouse button.

’3. Press Tab or click the Number2 argument text box and then drag through the cell
range B4:B8 to select this range as the second to be included in the total.

Note that as soon as you select the Number2 argument text box, Excel adds a
Number3 text box to the Function Arguments dialog box.

74. Designate the cell range C4:C8 as the third argument in the Number3 argument
text box.

Note that the Function Arguments dialog box shows the subtotals of each of the
three ranges you've selected immediately following their respective argument
text boxes and that the Formula bar now contains the whole SUM formula ready
for insertion into cell C9:

=SUM(A4:A8,B4:B8,C4:C8)

15. Select OK to close the Function Arguments dialog box and enter the SUM formula
into cell C9.

76 Save your changes to the Practice Formulas.xls workbook file.

Editing formulas

Editing a formula, especially one that uses a function with multiple arguments, can
take a little getting used to. Fortunately, Excel makes formula editing within the cells
of the worksheet as easy as it can by isolating the ranges and displaying them in dif-
ferent color bounding boxes when you put the program in Edit mode.

The only problem comes when you’re dealing with a formula so complex and long
that its contents can’t be displayed within the worksheet display. Fortunately, on the
rare occasion when this occurs, you can still edit the formula on the Formula bar as it
automatically expands its rows to accommodate the extra length.

Chapter 5: Building Formulas

Exercise 5-5: Editing Formulas in the Spreadsheet

Use your Practice Formulas.xls workbook to get some experience with formula editing.
In this exercise, make changes to the SUM formula you previously constructed in cell
C9 that totals the three ranges A4:A8, B4:B8, and C4:C8:

1. Position the cell cursor in cell C9 and then press F2 to put Excel into Edit mode.

Excel responds by displaying the contents of the SUM formula in cell C9 of the
worksheet. The addresses of each of the cell ranges in the three arguments of
this SUM function appear in a different color and each of these colors corre-
sponds to that of the bounding box that encloses its cell range in the worksheet.
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2.

Use the < to move the insertion point through the arguments in the SUM func-
tion until the insertion point is flashing between the 8 in the A8 and the comma
that follows the first A4:A8 argument.

Note as you move the insertion point to the left through the SUM function how
the syntax for the SUM function appears right below it and how Excel displays
the Number3, Number2, and finally the Numberl argument in bold as the inser-
tion point travels through the cell range in the equivalent argument in the func-
tion above.

Hold down the Shift key as press the < key to select and highlight the range
A4:A8 (from right to left).

Redefine the Numberl argument by dragging through the cell range A2:A8 in the
worksheet.

A moving marquee appears in the cells you select as you redefine the cell range
for the Number1 argument in the SUM function.

Check the formula on the Formula bar in cell C9 to make sure that cell range for
the Number1 argument of the SUM function is now A2:A8. Next click the Enter
button to complete the editing of the formula in cell C9.

Apply the Comma style format with two decimal places to cell C9 (widen column
C to display the value in this new number formatting, if necessary).

Save your editing changes to the formula in cell C9 in the Practice Formulas.xls
workbook file.

Altering the natural order of operations

When you build a formula that combines different operators, Excel follows the order
of precedence shown in Table 5-2. When you use operators that share the same prece-
dence level, the program performs the calculations designated computations on the
operands in a strictly left-to-right order.

Table 5-2 Natural Order of Operator Precedence in Formulas
Precedence Operator Type/Function

1 - Negation

2 % Percent

3 A Exponentiation

4 *and/ Multiplication and Division
5 +and — Addition and Subtraction
6 & Concatenation

7 =, &, >, <=, 55, <> All Comparative Operators

Sometimes, you need to override the natural order of precedence in order to get your
formula to return the desired result. To override the natural order, you enclose the
operand and operator of the operation you want performed first in parentheses.

For more complicated formulas, you may end up nesting sets of parentheses one
within the other in order to obtain the desired computation order. When this is the
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case, Excel always performs the calculation within the inmost set of parentheses
working its way out according the sequence shown in Table 5-2.

Exercise 5-6: Changing the Order in Which Formulas Are Calculated

Use your Practice Formulas.xls workbook to construct several new formulas and then
experiment with adding parentheses to see what effect they have on the computed
results:

1. Enter the following values in designated cells in the Formulas worksheet in your
Practice Formulas.xls workbook:
¢ 100 in cell B11
¢ 50 in cell C11
e 2incell D11
2. Position the cell cursor in cell E11 and construct and enter the following formula:
=B11+C11/D11

Instead of an answer of 75, Excel returns one of 125 because it performs the divi-
sion between cell C11 and D11 (50/2=25) with its higher level of precedence of 4
before doing the addition between cell B11 and C11 (100+25) with its lower
precedence level of 5.

3. With the cell cursor in cell E11, press F2 to put Excel in Edit mode.

« Press the < key until the insertion point is located between the = and the B in
B11, and then type (press the — key until the insertion point is between the
second 1 in C11 and the / and then type).

The edited formula should appear as follows in cell C11:
=(B11+C11) /D11

5. Click the Enter button on the Formula bar to complete the edit of the formula in
cell E11.

After the addition of the parentheses, the formula returns the result of 75, show-
ing that it now performed the addition between cell B11 and C11 first (100+50)
and then divided that result by the value in D11 (150/2).

0. Enter the following values in designated cells:
¢ 300 in cell A13
¢ 200 in cell B13
® 100 in cell C13
e 2incell D13
7. Position the cell cursor in cell E13 and construct and enter the following formula:
=A13+B13-C13/D13

Note that Excel returns a result of 450 when you enter this formula because, fol-
lowing the natural order of precedence, it performs the computations as follows:

e C13/D13 or 100/2 = 50 to cell C13
* A13+B13 or 300 + 200 = 500 to cell B13
e B13-C13 or 500 - 50 = 450 to cell E13
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8. Use pairs of parentheses to alter the computation order in the formula in E13 so
that Excel performs the subtraction between cells B13 and C13 first, adds this
result to the value in cell A13, and then finally divides the result of that addition
by the value in D13, giving you a final result of 200.

When editing this formula, begin by enclosing the first operation to be performed
inside a pair of parentheses (B13-C13), and then enclose the second operation in
second pair of parentheses, (A13+(B13-C13)) so that the edited formula appears as

=(Al3+(B13-C13)) /D13

9. With the cell cursor in cell E13, display all the formulas in the cells of the work-
sheet, reducing the display magnification percentage as needed so that you can
see all the formulas on your screen. (Check your results against those shown in
Figure 5-3.)

Note that in this display mode, when the cell cursor is in a cell that contains a
formula, Excel employs the same type of color coding as it does when you edit a
formula in its cell. The colors assigned to the cell references within the formula
correspond to that of the bounding box surrounding the actual cell or cell range
in the worksheet.

10. Use the arrow keys to move the cell cursor to other cells in this spreadsheet that
contain formulas, including cell C9.

11. Turn off the display of the formulas in the worksheet and then save your changes
to your Practice Formulas.xls workbook.

Using External Reference Links

|
Figure 5-3:
The
Formulas
sheet of the
Practice
Formulas.xls
workbook,

with all its |

formulas dis-
played in the

worksheet.
|

External references in a formula are those that refer to cells outside of the current
worksheet, either on other sheets of the same workbook file or in sheets in other
workbook files. Because their cells reside outside of the current worksheet, it isn’t
sufficient to specify the cell reference only, as you do with purely local cell references.
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When you refer to a cell that resides in another worksheet of the same workbook, you
preface the cell address with the sheet name separated by an exclamation point (),
following this syntax:

Sheetl!Al

When you refer to a cell that resides in a sheet in another workbook file, you need to
include the filename (enclosed in square brackets) as well as the sheet name and cell
reference, following this syntax:

'[file.x1ls]Sheetl'!Al

Many times, you use external references to create a link to values in another sheet
that need to be brought forward to the new worksheet. When you set up a link rather
than just pasting in a static value, any changes made to the value in the original cell is
automatically updated in the linked cell.

The easiest way to create an external reference link is by copying the cell to the
Clipboard (Ctrl+C) and then pasting it with the Paste Special command (Edit=>Paste
Special) using its Paste Link button.

Exercise 5-7: Building Formulas with External Links

Use your Practice Formulas.xls workbook to get experience with constructing links
using external references:

’. Position the cell cursor in cell C9 of the Formulas worksheet that contains the
SUM formula totaling the values in the cell ranges A2:A8, B4:B§, and C4:C8 and
then copy the value in this to the Clipboard (Ctrl+C).

2. Switch to the Ext Ref worksheet in the workbook and then position the cell
cursor in cell B3 of this sheet.

3. Choose Edit>Paste Special and then click its Paste Link button, and then use
AutoFit to widen column B.

The value 157889.20 appears in cell B3 of the Ext Ref sheet and the following link
formula with the external reference appears on the Formula bar:

=Formulas!S$CS9

4. Enter the heading Formulas Sheet Total in cell A3 and, if necessary, widen
column A of the Ext Ref sheet sufficiently to display the entire heading.

5. switch back to the Formulas worksheet and then change the value in the source
cell A2 of this sheet from 34 to 56.

Note the effect that increasing this source value has on the total in cell C9 of this
worksheet.

6. Switch to Ext Ref worksheet, position the cell cursor in cell B3, and verify that
cell B3 in this worksheet now contains the same value as C9 in the Formulas
worksheet, thanks to the linking formula you created there.

7. Open a new blank workbook and then enter the heading Practice Formulas
Workbook Total in cell A2, widen column A to display the entire heading, and
then increase the display magnification percentage to 200%.

8. Save the workbook file with the filename External Link.xls in your Chapter 5
folder in the My Practice Spreadsheets folder.
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9. Switch to the Practice Formulas.xls workbook and then copy the value in cell B3
of the Ext Ref worksheet to the Clipboard (Ctrl+C).

’0. Switch to the new External Link.xls workbook, select cell B2 of Sheetl, choose
Edit=>Paste Special, and then click its Paste Link button.

The value 439,589.40 appears in cell B2 of the Sheetl worksheet and the follow-
ing link formula with the external reference appears on the Formula bar:

='[Practice Formulas.xls]Ext Ref'!S$BS3
11. save your changes to the External Link.xls workbook and then close this file.

12. Select cell A2 in the Formulas sheet in the Practice Formulas.xls and then update
the value in this cell from 56 to 72.

73. Check that the contents in cell B3 of the Ext Ref sheet have been updated to
779,438.27 to reflect the change to the value in cell C9 of the Formulas sheet.
Now save your changes to the Practice Formulas.xls workbook before you close it.

74. Open the External Link.xls workbook by selecting it from the File pull-down
menu.

As soon as this file opens, Excel displays an alert dialog box, informing you that
this workbook contains links to other sources.

’5. Select the Update button in Excel alert dialog box to have the program update
the value in cell B2 of Sheet1 to 779,438.27.

Note that the external reference displayed on the Formula bar now contains the
entire pathname for the workbook file along with its sheet and cell reference.

16. save your changes to the External Link.xls workbook and then close this file.

Controlling When Formulas Are Recalculated

As you've seen in the exercises in this chapter, Excel immediately and automatically
recalculates all the formulas in a worksheet the moment you make a change to any
cell that referred to in its formulas. This automatic recalculation mode is fine as long
as your spreadsheet is relatively small and your edits to it are few.

Working in this mode can, however, be a real drag (both literally and figuratively)
when the worksheet is large and contains lots and lots of formulas: You may be forced
to wait quite a few seconds while Excel recalculates every loving formula before you
can do anything more after each and every editing change you make.

To avoid this hassle, change the recalculation mode from automatic to manual on the
Calculation tab of the Options dialog box (Tools=>Options) so that Excel recalculates
the formulas in the worksheet only when you specifically tell it to by selecting its Calc
Now(F9) or Calc Sheet button or when you save changes to the worksheet.

Exercise 5-8: Controlling When Formulas Are Recalculated

Open your Practice Formulas.xls workbook in the Chapter 5 folder inside the My
Practice Spreadsheets folder and use it to get some experience using Excel in both
automatic and manual recalculation mode:

1. Update the value in cell A2 of the Formulas sheet from 72 to 102.
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Verify that Excel has automatically recalculated the formulas in both your
Formulas and Ext Ref worksheets and that cell C9 on the Formulas sheet and B3
on the Ext Ref sheet now both contain the same value: 1,816,854.91.

Select the Manual option button on the Calculation tab of the Options dialog box
(Tools=>Options).

Update the value in cell A2 of the Formulas sheet from 102 to 144.

Note that none of the calculated values in the Formulas sheet have been updated
(C9 still contains 1,816,854.91) and that the Calculate indicator has now
appeared on the Status bar.

Select the Calc Sheet button on the Calculation tab of the Options dialog box.

Note that Excel recalculates the formulas on the Formulas worksheet and that
cell C9 now contains the value 4,412,310.20, but that the Calculate indicator has
not disappeared from the Status bar. Then, switch to the Ext Ref sheet and note
that the linked formula in cell B3 has not been updated and still contains the
value 1,816,854.91.

Press F9 to have Excel recalculate all the formulas in the entire workbook.

Note that not only does cell B3 of the Ext Ref worksheet now contains the
updated value 4,412,310.20, but that the Calculate indicator has now disappeared
from the Status bar.

Switch back to the Formulas worksheet, and then update cell A2 to 165.88 before
you press F9.

Check to make sure that all the formulas on both sheets of the workbook have
now been updated by verifying that both cell C9 in the Formulas sheet and B3 in
the Ext Ref sheet now contain 6,423,962.85.

Update cell A2 in the Formulas worksheet to 188 and then save this change to
the Practice Formulas.xls workbook.

Note that Excel not only saves your change to cell A2 in Practice Formulas.xls
workbook file, but also recalculates the formulas using this new value and then
saves these updated values as well.

Save a copy of this workbook file under the filename Solved5-8.xls in your
Chapter 5 folder inside the My Practice Spreadsheets folder.

Note that any changes you make to the recalculation mode are saved as part of
the workbook file, so that they are in effect the next time anyone opens the file
for editing.
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Chapter 6

Copying and
Correcting Formulas

In This Chapter

Copying formulas with relative cell references
Copying formulas with absolute cell references
Copying formulas with mixed cell references
Using range names in formulas

Creating array formulas

Tracing and eliminating formula errors

Dealing with circular references in a formula

C opying an original formula to all the cells in the worksheet that perform the same type
of computation is one of the more common tasks you perform as part of creating a new
spreadsheet. Despite this fact, understanding just how Excel goes about adjusting the cell
references when you copy a formula is not widespread among new users. The exercises in
this chapter give you a chance to practice copying formulas using all the different types of
cell references. In addition, you practice assigning range names to the cells that are refer-
enced in spreadsheet formulas, creating array formulas that do away with the need for
making formula copies, as well as tracing and eliminating the source of errors that have
spread across the workbook.

Copying Formulas with Relative References

When your original formula uses cell references rather than constant values (as most
should), Excel makes copying that formula to every place that requires the same type of
computation a complete no-brainer. The program does this by automatically adjusting the
cell references in the original formula to suit the position of the copies you make. It does
this through a system known as relative cell addresses, whereby the column references in
the cell address in the formula change to suit their new column position, and the row refer-
ences change to suit their new row position.

<MBER

Excel indicates that a cell reference is relative simply by stating its column letter and row

number without preceding either part of the reference with a $ (dollar sign), the symbol

denoting an absolute reference, as in A1 or BC457.
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Exercise 6-1: Copying Formulas in the R1C1 Reference Style

1.

If Excel isn’t running, launch the program. Open the Exercise6-1.xls workbook file in
your Chapter 6 folder in the My Practice Spreadsheets folder inside My Documents on
your hard disk or on the Excel Workbook CD-ROM. This file contains a copy of the
2006 Production Schedule table without any formulas:

Position the cell cursor in cell K3 and use the AutoSum button to create a SUM
formula that totals the Part 100s scheduled to be produced over the nine-month
period from April to December in row 3.

AutoSum creates the following master formula in cell K3:
=SUM (B3:J3)

Use the Fill handle on the cell cursor to copy this formula down column K to the
cell range K4:K7.

Position the white-cross mouse pointer on the Fill handle of the cell cursor and
then, when the AutoFill Options drop-down button appears, click it. Select the
Fill without Formatting item at the bottom of the drop-down list that appears
(doing this restores the border along the top edge of cell K7 that Excel took out
when copying the formatting from cell K3 to this range).

Now, take a moment to examine the copies you made of the original SUM formula
in cell K3 by using the arrow keys to move the cell cursor through each cell K4,
K5, K6, and K7. What do you note that is different in each copy of the formula
and what is the same?

To help you understand what Excel is really doing when you make copies of a
formula containing relative cell references down the rows of a column, turn on
the R1C1 Reference system. In this system, both the rows and columns of the
worksheet are given numbers so that the cell reference Al, for example, becomes
R1C1 (because column A is the first column from the left edge of the worksheet)
and cell D6 becomes R6C4 (because column D is the fourth column from the left
edge of the worksheet).

Select the R1C1 Reference Style check box on the General tab of the Options
dialog box.

You can tell you are “not in Kansas anymore” using the familiar row number,
column letter reference type system — all the columns are now numbered from
left to right just as the rows are from top down.

Position the cell cursor in cell K3 and examine the contents of the original SUM
formula on the Formula bar.

In R1C1 notation, the formula entered in this cell now reads:
=SUM(RC[-9]:RC[-1])

The first thing to note about cell references in formulas in R1C1 notation is that
they are completely egocentric; always referring to the cell that contains the for-
mula (they could care less about the worksheet at large). This formula says, in
essence, “Use the SUM function to total from the cell that is nine columns to the
left of the current column through the cell that is one column to the left all in the
same row.” The minus sign in front of the number following the column reference
denotes columns to the left of the current one just as the minus in front of a
number following a row reference denotes rows above (positive integers in these
references denote columns to the right and rows below the current one).

Press the | key to move the cell pointer down column K through all the cells, K4,
K5, and K6 that contain copies of the formula you constructed in cell K3, noting
the contents of each copy on the Formula bar as you move the cursor down a row.
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You will note that each and every cell in this column contains the exact same
formula:

=SUM(RC[-9]:RC[-1])

Excel hasn’t really adjusted anything in any of the formula copies you made! It’s
all a convenient fiction (that’s fancy talk for a big lie) to say that Excel adjusts
the relative row and column references in formula copies because that’s the way
it appears to work when the program is in its normal row number, column letter
reference system. (Now that I've let you in on this little secret, just keep it under
your hat.)

7. Position the cell cursor in cell R7C2 (erstwhile B7) and use AutoSum to construct
a SUM formula that totals the part numbers scheduled to be produced in April,
2006.

This formula in R1C1 notation appears on the Formula bar as follows:
=SUM(R[-4]C:R[-1]C)

8. Use the Fill handle to copy this formula across the rest of the columns of the
table to the range R7C3:R7C10 (C7:J7).

Verify that each of the copies in all these cells contains the identical formula in
R1C1 notation as you constructed in cell B7, that is, R7C2.

9. Restore the old tried-and-true row number and column letter notation system by
removing the check mark from the R1C1 Reference Style check box on the
General tab of the Options dialog box.

10. Move the cell cursor across the cell range B7:J7, noting how Excel adjusts the
column reference (in standard notation) and then up and down the cell range
K3:K7, noting how the row reference changes.

11. Save this workbook under the filename Solved6-1.xls in your Chapter 6 folder
inside the My Practice Spreadsheets folder on your hard disk and then close the
workbook.

Copying Formulas with Absolute References

Absolute cell references, as their name implies do not change for nobody or nothing. A
truly absolute reference firmly roots both the row and row reference (as opposed to a
mixed reference that just plants either the row number or the column letter, but not
both). This type of reference comes in handy when you need to refer to a cell that con-
tains a value that acts like a constant that must remain unchanged in all formula copies.

WMBER Excel indicates that a cell reference is absolute by preceding both its column letter
and row number with a $ (dollar sign), the symbol denoting an absolute reference, as
in $A$1 or $BC$457. When building or editing a formula, you can convert a relative
cell reference that contains the insertion point simply by pressing the F4 key.

Exercise 6-2: Copying a Formula with Absolute Cell References

Open the Exercise6-2.xls workbook file in your Chapter 6 folder in the My Practice
Spreadsheets folder inside My Documents on your hard disk or on the Excel
Workbook folder on the workbook CD-ROM. This file contains a copy of the 2006
Production Schedule table with all the formulas you created and copied in Exercise
6-1 for totaling the units to be produced by month across the columns and by part
down the rows. In this exercise, you add a row of formulas that computes what per-
centage each monthly production quota represents of the projected nine-month total:
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1. Enter the heading % of Total in cell A9 of the 2006 Prod worksheet. Now position
the cell cursor in cell B9 and use AutoFit to widen column A so that this new
heading is completely displayed in its cell.

2. Construct a formula in cell B9 that divides the April 2006 quota in cell B7 by the
projected total in cell K7 and then format the cell with the Percent Style number
format with two decimal places.

The formula in this cell should read:
=B7/K7

3. Use the Fill handle to copy the original formula you constructed in cell B9 to the
cell range C9:J9.

Something is clearly wrong with the copies, as they all contain those dreaded
#DIV/0! error values rather than the desired percentages.

4. Position the cell cursor in cell C7 to examine the formula that Excel copied there.
The formula in this cell reads:
=C7/L7

When Excel made the first copy, the program not only adjusted the column refer-
ence for the monthly quota (from B7 to C7) but for the projected total as well (J7
to L7), and because L7 is empty, the copy is, in essence, trying to divide by zero
(all empty cells carry a zero value), thus the division error value.

To prevent this problem with the copies (and to correct it), in the original divi-
sion formula, the divisor, K7, with the projected total must be an absolute cell
reference (as in $K$7), so that it remains constant in all the copies in which Excel
naturally adjusts the dividend (that is, the amount to be divided) containing the
various monthly production quotas.

5. Position the cell cursor back in cell B9 with the original formula and then press
F2 to put Excel in Edit mode.

. Press F4 to convert the cell reference from the relative K7 to absolute $K$7 and
then click the Enter button on the Formula bar.

7. Use the Fill handle to copy this edited version of the original formula in cell B9 to
the cell range C9:J9.

That’s more like it! This time all the formula copies return realistic percentages
in place of those awful division errors.

&. Position the cell cursor in cell Al of the 2006 Prod worksheet and then save the
workbook with the filename Solved6-2.xls in your Chapter 6 folder inside the My
Practice Worksheets folder before you close the workbook.

Copying Formulas with Mixed References

WMBER
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Just as you’d expect, mixed cell references are those that mix relative and absolute
references in a cell. A mixed cell reference can either have the row reference absolute
and column relative (as in A$3) or the column reference absolute and the row relative
(as in $A3).

You can convert a cell reference you're entering or editing in a formula to either type
of mixed reference by pressing F4 as follows:
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v~ First time to convert the cell reference from completely relative to completely
absolute (C5 to $C$5)

+* Second time to convert from completely absolute to a mixed reference with the
row absolute and the column relative ($C$5 to C$5)

v Third time to convert from a mixed reference with the row absolute and the
column relative to one with the column absolute and row relative (C$5 to $C5)

+* Fourth time to convert from a mixed reference with the column absolute and
row relative back to a completely relative reference ($C5 to C5)

You only need to resort to mixed cell references in an original formula when you
intend to copy this formula to empty cells in two directions; that is, both down the
rows and then over the columns to the right or over to columns on the right and then
down the rows, and need to prevent Excel from adjusting either the column letter or
the row number reference in all the copies.

Exercise 6-3 gives you practice in constructing a loan payment table that requires just
this kind of two-dimensional formula copying. To create this payment table, you need
to copy an original formula using the PMT function, the arguments of which require
all the different types of cell references (including both types of mixed cell refer-
ences) in order for all the copies to refer to the correct cells.

Exercise 6-3: Creating a Loan Table with Mixed Cell References

Open a new workbook in Excel and use its blank Sheet1 worksheet to create this loan
payment table. This table uses the PMT function to compute the monthly mortgage
payments for a sequence of different loan amounts (principals) and interest rates. The
PMT function is a Financial type function that requires three arguments: Rate, which is
the interest rate per payment period, Nper, which is the number or payment periods
for the loan, and Puv, which is the present value or loan amount (the function also
accepts two other optional arguments that you won’t need to use in this exercise).

You begin by entering the table headings and the three initial values (loan amount,
term of the loan, and interest rate) to be used to generate the sequence of the differ-
ent loan amounts and interest rates as well as in the construction of the original PMT
formula that you then copy in two dimensions to the rest of table:

1. Enter the following headings in the designated cells and then widen column A to
suit with AutoFit:
¢ Loan Payment Table in cell Al
e Initial Principal in cell A2
e Starting Interest Rate in cell A3

¢ Loan Period in cell A4

2. Enter the following values in the designated cells and format them as indicated:

¢ 400000 in cell B2 formatted with the Currency Style format with zero deci-
mal places

* 3% in cell B3 formatted with two decimal places

¢ 30 in cell B4 formatted with the Number format with zero decimal places

93
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12.

Create a formula in cell A7 that dynamically copies the initial principal value
entered in cell B2 to this cell.

To create a dynamic link between the value in one cell and another cell in the
same worksheet, type = to start the formula, followed by the reference of the cell
with which you want the value linked.

Create a formula in cell A8 that adds 1000 to the value in cell A7 and then use the
Fill handle to copy this formula down the rows to the cell range A9:A16.

Create a formula in cell B6 that dynamically copies the initial interest rate
entered in cell B3 to this cell.

Create a formula in cell C6 that adds 0.25% to the value in cell B6, reduce the
number of decimal places to two, and then use the Fill handle to copy this for-
mula across the columns to the cell range D6:G6.

Position the cell cursor in cell B7 to build the original PMT formula and then
click the Insert Function button on the Formula bar.

Type loan payment in the Search for Function text box in the Insert Function
dialog box and then press Enter to search for the PMT function.

With the PMT function highlighted in the Select a Function list box, select OK
to close the Insert Function dialog box and open the Function Arguments
dialog box.

Move the Function Arguments dialog box to the right, out of the way:.

The first argument to specify is the Rate argument, for which you will select cell
B6 that is linked to the starting interest rate in cell B3. Note that you must con-
sider what part of this cell reference, if any, should be adjusted when you copy
this formula down the rows of this table (from 7 through 16) and then across the
columns (from B through G) and adjust its reference accordingly.

Note that when you copy the PMT formula down the rows of the table, you defi-
nitely do not want Excel to adjust the row number because all of the interest
rates are in row 6, meaning that this part of the cell reference must be absolute.
When you then copy the PMT formula to columns on the right, you do, however,
need the column letter to be adjusted in order to pick up the quarter percentage
point entered into the succeeding columns in row 6, so you do need to keep this
part of the cell reference relative. Therefore, for this argument, you need to con-
vert B6 from its completely relative reference to the mixed cell reference, B$6
(column adjusted but not the row).

In addition, because the starting interest rate you enter into cell B3 and bring for-
ward to cell B6 is a yearly rate and the PMT function calculates the monthly pay-
ment, you need to divide this yearly interest amount by 12 so that the Rate
argument represents a monthly portion.

With the insertion point in the Rate text box, click cell B6 to select and enter its
reference, and then press F4 twice to convert it to the mixed reference, B$6,
before you type /12 before you press Tab.

B$6/12 now appears in the Rate argument text box.

The Nper argument picks up the single loan period value entered in cell B4.
Because this value acts a constant in the table, all the loan payments calculated
by the PMT function refer to it. Therefore, this reference has to be completely
absolute, $B$4, so that Excel adjusts neither its column letter nor its row number
in any of the copies. In addition, because this period is in years (30 years to
begin with), you need to multiple it by 12 so that the PMT function is dealing
with the total number of months.

With the insertion point in the Nper text box, click cell B4, and then press F4
once to convert its reference to $B$4. Type *12 before you press Tab.
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$B$4*12 now appears in the Nper argument text box.

The last required argument is the present value or loan amount for which you
will select cell A7 that is linked to the initial principal entered into cell B2. When
you copy the PMT formula down the rows of column B, you want Excel to adjust
the row number so that it picks and uses the increased principals (that incre-
ment by $1,000 in each subsequent row). You do not, however, want Excel to
adjust the column letter in this argument when you copy the formula to the
columns to the right because all the principals are entered in only one column.
Therefore, for this last PMT argument, you need a mixed cell reference of $A7
(with column reference absolute and row reference relative).

’3. With the insertion point in the Pv text box, click cell A7, and then press F4 three
times to convert it to the mixed reference, $A7.

Check the arguments in your Function Arguments dialog box against those
shown in Figure 6-1. When each argument checks out, including the Formula
Result equal to ($1,686.42), proceed to Step 14. If you discover that you need to
change the type of cell reference in any argument, position the insertion pointer
in that reference and press F4 until the correct mixed or absolute reference
appears.

74. Select the OK button to close the Function Arguments dialog box and to com-
plete the formula with the PMT function in cell B7, and then use the Fill handle to
copy this formula down the rows of column B to cell B16.

15. With the range B7:B16 still selected by the cell cursor, use its Fill handle to copy
the original PMT formula across the columns of the table to and including
column G (the entire cell range B7:G16 is selected when you finish copying the
formulas in the second direction across the columns).

16. Use AutoFit to widen columns C:G sufficiently to display their contents.
The results in your loan table should match those shown in Figure 6-2.

17. Change the term from 30 to 15 in cell B4 and note the increase to the monthly
payments in the table, and then use the Undo feature to return the loan term to
its original 30 years.

18. Put Excel into manual recalculation mode and then experiment with changing
the initial principal in cell B2 to 650000 and a starting interest rate in B3 of
2.50%. Press F9 to recalculate the monthly payments in the table.

79. Use Undo to restore the original 400000 and 3% values in cells B2 and B3, respec-
tively, and then save your Loan Payment Table with the filename Solved6-3.xls in
your Chapter 6 folder inside the My Practice Spreadsheets folder. Close the
workbook.
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Using Range Names in Formulas
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In completing the exercises in Chapter 5, you got experience with assigning a range
name to a cell that held a constant (named source) and then using that name in a link-
ing formula. This linking formula then supplied the basic value used in most of the
handmade formulas you then constructed on the worksheet.

Instead of assigning range names to constants that you actually enter into particular
cells of the worksheet, you can create range names that store constant values not tied
to entries in any cell. You can then paste the constant’s range name into any formula
that needs its value in order to successfully perform its calculations.

Another important use for range names is as identifiers of the cell references used in
the operands and arguments of the formulas constructed for a typical data table. In
this situation, you have Excel assign the table’s row and column headings as the
range names for data cells in the corresponding rows and columns. You then have
Excel substitute these range names for the cell references in all the formulas in the
table that refer to these data cells.

Exercise 6-4: Creating Range Names for Formulas

Open the Exercise64.xls file in your Chapter 6 folder inside the My Practice Spreadsheets
folder or on the Excel Workbook CD-ROM. This file contains a variation on the Spring
Sale table that you can use to practice assigning a range name to a constant as well as
create range names from a table’s row and column headings:
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Choose Insert=>Namer>Define to open the Define Name dialog box, and then type
discount_rate (don’t forget the underscore) as the range name. (This name
replaces the title of the table that automatically appears as the suggested range
name because its cell, Al, is selected in the worksheet.)

Press Tab twice to select ="2006 Spring Sale’!'$A$1 in the Refers To text box, and
then type =15% and select OK.

Excel now contains a range name called discount_rate that sets the discount per-
centage equal to a constant 15 percent. Note, however, that this range name does
not refer to any particular cell in the worksheet.

Position the cell cursor in cell D3 and there construct a formula that multiplies
the retail price of the table with the code number 12-305 in cell C3 by the 15%
discount rate.

To insert a range name that you’ve defined in the workbook as an operand or
function argument in a formula you’re building, choose Insert->Namer>Paste and
then select the range name in the Paste Name list box and select OK.

Copy the formula that computes the amount of the discount for the table code
numbered 12-305 in cell D3 down to the cell range D4:D7.

Note in each of the copies of the formula that although Excel adjusts the row
number of each reference to the cell in the Retail Price column, it treats the
range name, discount_rate, as an absolute reference.

Create a formula in cell E3 that computes the sale price of the table code num-
bered 12-305 by subtracting its discount amount from its retail price and then
copy this formula down the cell range E4:E7.

Next, you're going to have Excel assign range names to the table cells in the
range C3:E7 from the row and column headings in row 2 and column B of the Sale
Table.

Select the cell range B2:E7 and then choose Insert=>"Namer>Create to open the
Create Names dialog box.

Note that the Top Row and Left Column check boxes are automatically selected
in this dialog box, indicating that Excel will use the headings it finds in the top
row (7) and the left column (B) of the current cell selection when assigning the
ranges names.

Select OK in the Create Names dialog box to accept its default settings and close
the box, and then make Sheet2 of the Exercise6-4.xls workbook active.

Rename Sheet2 to Range Names, enter the heading, Range Name List, in cell Al,
and position the cell cursor in cell A2.

Choose Insert>Name=>Paste and then select the Paste List button in the Paste
Name dialog box.

Excel pastes an alphabetical list of range names in the cell range A2:B11. Note
that this alphabetical listing the range names in the workbook is static so that
you’d have to generate it again with the Paste List button were you to edit the
names in this workbook and then want an up-to-date list.

Use AutoFit to widen column A of the Range Names sheet so that all the entries
in the first column of this list are completely displayed in the worksheet.

Next, you create a new window in the Exercise64.xls workbook that enables you
to compare the Sale Table in the 2006 Spring Sale and the Range Name Listing
side by side on the screen.
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16.

17.

Choose Window=>New Window to create a new window in the workbook named
Exercise6-4.xls:2, then choose Window=>Exercise6-4.xls:1 to make the first
window active. Finally, choose Window=>Compare Side by Side with Exercise6-4.
xls:2 to display both the Exercise6-4.xls:1 and the Exercise6-4.xls:2 window
together on the screen, one on top of the other.

Click the 2006 Spring Sale sheet tab in the Exercise6-4.xls:1 window on the top to
make the sheet with the Sale Table active in the top window and then change the
maghnification display percentage to 115% in the workbook.

Note that both the 2006 Spring Sale worksheet in the top window (Exercise6-4.
xls:1) and the Range Names sheet in the lower window (Exercise6-4.xls:2) are
affected equally by the zoom command. Also notice the appearance of the
Compare Side by Side floating toolbar with its Close Side by Side button.
(Your computer screen should now look like the one shown in Figure 6-3.)

Now, you're ready to apply the range names listed in the Range Name Listing on
the Range Names sheet to the formulas you constructed and copied in the Sale
Table in the 2006 Spring Sale worksheet.

Select the cell range with the formulas, D3:E7 in the Sale Table on the 2006 Spring
Sale worksheet, and then choose Insert=>Name=>Apply to open the Apply Names
dialog box.

This dialog box contains a list with all the range names you’ve defined in the
workbook selected.

Select the Options button to expand the Apply Names dialog box, and then dese-
lect the Omit Column Name If Same Column and the Omit Row Name If Same
Name check boxes and select OK.

When these check boxes are selected, Excel does not bother to repeat row and
column range names in the formulas. As a result, the formulas copied down the
rows and across the columns of a table all end up with the same descriptions
(which pretty much defeats the purpose of displaying them in the formulas in
the first place).

Click the Close Side by Side button in the Compare Side by Side toolbar to
close the second window and return to a full-screen view of 2006 Spring Sale
worksheet.

Examine the use of the range names created from the row and column headings
in all the formulas in the cell range D3:E7.

Note that the operand of each formula now includes both the row and the
column range name (separated by a space that represents the Intersection
operator) created from the cell’s row and column heading. For example, the
subtraction formula in cell E6 now reads:

=Buffet Retail Price-Buffet Discount

This identifies the formula as subtracting the value in the cell at the inter-
section of the Buffet row and Discount column range names from the value in
the cell at the intersection of the Buffet row and Retail_Price column range
names.

Select cell Al and then save your changes to this workbook with the filename
Solved6-4.xls in your Chapter 6 folder inside the My Practice Spreadsheets
folder, and then close both windows on the workbook.
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Building Array Formulas

Instead of copying a formula to all the cells that perform the same type of calculation,
you can build an array formula that performs the desired calculation not only in the
active cell but in all the other cells to which you would normally copy the formula. An
array formula is a special formula that operates on a range of values. If this range is
supplied by a cell range (as is often the case), it is referred to as an array range. If this
range is supplied by a list of numerical values, it is known as an array constant.

You are already quite familiar with arrays even though you may not realize it. This is
because the Excel worksheet grid with its column-and-row structure naturally organizes
your data ranges into one-dimensional and two-dimensional arrays (one-dimensional
arrays take up a single row or column, whereas two-dimensional arrays take up multi-
ple rows and columns).

Figure 6-4 illustrates a couple of two-dimensional arrays with numerical entries of two
different sizes. The first array is a 3-by-2 array in the cell range B2:C4. This array is a
3-by-2 array because it occupies three rows and two columns. The second array 2-by-
3 array in the cell range B6:D7. This array is a 2-by-3 array because it uses two rows in
three columns. If you were to list the values in the first 3-by-2 array as an array con-
stant in a formula, they would appear as follows:

{1,4;2,5;3,6}
Here are several things of note in this expression:

v The array constant is enclosed in a pair of braces ({}).

v Columns within each row are separated by commas (,) and rows within the array
are separated by semicolons (;).
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v Constants in the array are listed across each row and then down each column,
not down each column and across each row.

The second 2-by-3 array expressed as an array constant appears as follows:
{7,8,9;10,11,12}
Note again that you list the values across each row and then down each column, sepa-

rating the values in different columns with commas and the values in different rows
with a semicolon.
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The use of array formulas can significantly reduce the amount of formula copying that
you have to do in a worksheet by producing multiple results throughout the array range
in a single operation. In addition, array formulas use less computer memory than stan-
dard formulas copied in a range. This can be important when creating a large worksheet
with many tables as it may mean the difference between fitting all of your calculations
on one worksheet or having to split your model into several worksheet files.

Exercise 6-5: Constructing Array Formulas

Open the Exercise6-5.xls file in your Chapter 6 folder inside the My Practice Spreadsheets
folder or on the Excel Workbook CD-ROM. This file contains a copy of the February 2006
Hourly Wage spreadsheet that you can use to practice constructing array formulas. This
worksheet is designed to compute the biweekly wages for each employee by multiplying
the hourly rate by the number of hours worked. Rather than create an original formula
for each period that computes the wages for the first employee and then copying it
down rows for all the others, do this with array formulas:
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1. Position the cell cursor in cell R10 and then select the cell range R10:R13.

You are going to construct the following array formula that you then enter as a
single entry into the cell range R10:R13 you just selected:

={A4:A7*R4:R7}

The range A4:A7 contains the hourly rates for all four employees, whereas the
range R4:R7 contains the total hours each one worked in the first period.

2. Type = to start the array formula and then select the cell range A4:A7.

b

Type * (asterisk), the multiplication operator, and then select the cell range
R4:R7.

To complete an array formula, you must press a very special key combination,
Ctrl plus Shift plus Enter. This key combination lets Excel know you’re construct-
ing an array formula as well as informs it to enter this array formula into all the
cells in the selected range.

4. Press Ctrl+Shift+Enter to complete the array formula and enter it into the
selected range R10:R13.

Excel responds by entering the array formula in all the cells in the selected range
R10:R13.

5. construct an array formula in the cell range Al10:AI13 that multiplies the hourly
rates in the cell range A4:A7 by the second-period hour totals in the cell range
Al4:Al7.

The array formula you enter into the cell range Al10:AlI13 appears on the Formula
bar as follows:

={A4:A7*AT4:AT7}
6. Construct an array formula in the cell range AJ10:AJ13 that totals the two pay
periods for each employee.

The array formula you enter into the cell range AJ10:AJ13 appears as follows on
the Formula bar:

={R10:R13+AT10:ATI13}

7. Select cell AJ10 to deselect the cell range and then press the Delete key to
remove the addition formula from this cell.

Excel responds by displaying an alert dialog box informing you that you cannot
change part of an array. When editing array formulas, you must work entirely
with the ranges specified as the operands.

8. Select OK to close the alert dialog box and now select the range AJ10:AJ13 before
you press Delete.

This time, Excel deletes the array formula from the entire range.

9. Select Undo to restore the deleted array formula to the range AJ10:AJ13, and
then select cell Al and save this workbook with the filename Solved6-5.xls in
your Chapter 6 folder in the My Practice Spreadsheets folder before you close
the workbook.

Tracing and Eliminating Formula Errors

As you found out firsthand when performing Exercise 5-3 in Chapter 5, an error value
returned by a single faulty formula can spread like wildfire to all the cells that refer to
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its value throughout the entire spreadsheet, making it very difficult to determine its
source. Fortunately, Excel offers some very effective tools on its Formula Auditing
toolbar that you can use to track down the cell that’s causing your error woes by
tracing the relationships between the formulas in the cells of your worksheet.

By tracing the relationships, you can test formulas to see which cells, called direct
precedents in spreadsheet jargon, directly feed the formulas and which cells, called
dependents (nondeductible, of course), depend upon the results of the formulas.
Excel even offers a way to visually backtrack the potential sources of an error value
in the formula of a particular cell.

To display the precedents and dependents of a formula as well as for tracing the
source of errors, you can either use the tools on the Formula Auditing toolbar
(Tools>Formula Auditing=>Show Formula Auditing Toolbar) shown in Figure 6-5,
or select the equivalent items on the Tools=>Formula Auditing submenu.
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When you click the Trace Precedents and Trace Dependents buttons on the Formula
Auditing toolbar (or choose the comparable commands on the ToolsoFormula Auditing
submenu), Excel shows the relationship between a formula and the cells that directly
and indirectly feed it as well as those cells that directly and indirectly depend upon
its calculation. The program establishes this relationship by drawing arrows from the
precedent cells to the active cell and from the active cell to its dependent cells.

If these cells are on the same worksheet, Excel draws solid red or blue arrows (on a
color monitor) extending from each of the precedent cells to the active cell and from
the active cell to the dependent cells. If the cells are not located locally on the same
worksheet (they may be on another sheet in the same workbook or even on a sheet
in a different workbook), Excel draws a black dotted arrow. This arrow comes from or
goes to an icon picturing a miniature worksheet that sits to one side, with the direc-
tion of the arrowheads indicating whether the cells on the other sheet feed the active
formula or are fed by it.

Exercise 6-6: Finding the Source of Error Values in a Spreadsheet

Open the Exercis6-6.xls workbook in your Chapter 6 folder inside the My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This workbook contains

a copy of the Practice Formulas workbook you created as part of the exercises in
Chapter 5. You can use its Formulas and Ext Ref worksheets to practice tracing and
eliminating errors:



10.

Display the floating Formula Auditing toolbar (Tools=>Formula Auditing=>Show
Formula Auditing Toolbar).

Remove the range name, source, given to cell A2 in the Formulas worksheet by
selecting source in the Define Name dialog box (Insert=>"Name=Define) and then
clicking the Delete button before you select OK.

As soon as you remove the range name, the spreadsheet on the Formulas work-
sheet fills with #NAME? error values. Now use the Trace Error button to trace the
source of this error value.

Position the cell cursor in cell C9 with the SUM function that sums the three cell
ranges A2:A8, B4:B8, C4:C8.

Click the Error Checking button (the first one) on the Formula Editing toolbar.

Excel displays the Error Checking dialog box, which briefly explains that this
error value is due to the fact that the formula now contains unrecognized text.
This is not something that you can fix by editing the formula on the Formula bar,
so, in this case, you need to trace the error.

Select the Trace Error button in the Error Checking dialog box.

Excel draws a diagonal arrow from cell A4 pointing to cell C9, indicating that
this is the direct source of the error (if you select the Previous button in the
Error Checking dialog box, Excel steps the cell cursor back through each of
the cells with the #NAME? error value in the order in which they spread in this
spreadsheet).

In this situation, you need to identify the cell or cells that feed the cells contain-
ing the #NAME? error values.

Click the Trace Precedents button on the Formula Auditing toolbar (the second
from the left).

Excel adds three arrows pointing directly to cell C9, showing the precedents of
its error value, the most telling of which is the one drawn from cell A2. If you
didn’t already know that cell A2 was the culprit causing all these error values
(having removed its range name yourself), this precedents diagram would have
tipped you off immediately.

Click the Trace Precedents button on the Formula Auditing toolbar a second
time.

Clicking the Trace Precedents or Trace Dependents button a second time (or
double-clicking it to begin with) displays all the indirect precedents and depend-
ents of the formula in the current cell. In this case, Excel now shows the flow and
direction of all the sum formulas both down the columns and across the rows
that contribute both directly and indirectly to its computed value.

Click the Remove All Arrows button on the Formula Auditing toolbar (the one
with the eraser) and then close the Error Checking dialog box.

Position the cell cursor in cell A4, the first one with a #NAME? error value, and
then click the Trace Dependents button on the Formula Auditing toolbar (the
one fourth from the left).

The program draws arrows showing the direct dependents of the formula in this
cell, which include the formulas down the column that use its value to compute
their own and the formulas across the row in C4 and D4 and, of course, the for-
mula in cell C9.

Click the Trace Dependents button on the Formula Auditing toolbar a second time.

Chapter 6: Copying and Correcting Formulas ’03
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Excel draws arrows showing the indirect dependents of the formula in cell C9.
Note that this includes a black dotted arrow line drawn from cell C9 to a graphic
showing a tiny worksheet. This is Excel’s way alerting you to the fact that there
are cells dependent on this one on other worksheets of the workbook to which
its error value has naturally spread.

1 1. Make the Ext Ref worksheet active and note that cell B3 that contains the linking
formula also now contains a #NAME? error value.

12. Switch back to the Formulas worksheet and there, reassign the range name,
source, to cell A2.

Note that the moment you rectify the source of the error (both literally and figu-
ratively), all the nasty #NAME? error values in the spreadsheet immediately dis-
appear along with all the arrows depicting the direct and indirect dependents.

73. Close the Formula Auditing toolbar and then close the Exercise6-6.xls workbook
file without saving your changes.

Dealing with Circular References

A circular reference in a formula is one that depends, directly or indirectly, upon its
own value. The most common type of circular reference occurs when you mistakenly
refer in the formula to the cell in which you’re building the formula itself. For exam-
ple, suppose that cell B10 is active when you build the formula:

=A10+B10

As soon as you complete this formula entry in cell B10, Excel displays an alert box
that says that it cannot calculate the formula due to the circular reference. As soon as
you press Enter or select OK to close this alert box, the program displays the Circular
Reference toolbar along with arrows tracing the formula’s precedents and dependents
and a help window on allowing or correcting a circular reference. The program also
inserts 0 in the cell with the circular reference and the indicator Circular followed by
the cell address with the circular reference appears on the Status bar.

Excel is not able to resolve this example of a circular reference in cell B10 because the
formula’s calculation depends directly upon the formula’s result, creating an endless
loop that continuously requires recalculating and can never be resolved.

Not all circular references are impossible for Excel to resolve. Some formulas contain
a circular reference that can eventually be resolved after many recalculations of its
formula (referred to as iterations) because, with each iteration of the formula, the
results get closer and closer to a resolution point.

Exercise 6-7: Solving a Circular Reference in a Formula

Open the Exercise6-7.xls workbook in your Chapter 6 folder inside the My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM. This workbook contains an
income statement spreadsheet with a circular reference in cell B15 that Excel catches
the moment you open the file:

1. Read the text of the alert dialog box that appears the moment you open the
Exercise6-7.xls workbook and then select OK to close it.
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The moment you close this alert dialog box, the floating Circular Reference tool-
bar is displayed only to be overshadowed immediately by a Microsoft Help
dialog box. This particular Help dialog box gives you information either on locat-
ing and removing a circular reference or on making a circular reference work by
changing the number of times that the program evaluates it formula.

Click the Make a Circular Reference Work by Changing the Number of Times
Microsoft Excel Iterates Formulas link to display its information in the Help
dialog box. Look over this information or print it out before you close the Help
dialog box.

Excel draws arrows that point to the cells involved in this circular reference,
starting with cell B15 that computes the bonuses and then going to the formula
in cell B17 that computes the total other income, and from there to cell B19 that
computes total income (or loss) before taxes, and, finally, from there to cell B21
that computes the net income.

These computations constitute a circular reference because the formula in cell
B15 computes the amount of the bonuses as a percentage of the net income in
cell B21 (=B21*20%), which, in turn, is dependent upon the amount of the bonus
as it is included in the other income calculation in cell B17 that is then fed to the
total income (loss) calculation in cell B19, which is itself used in calculating the
net income in cell B21.

Select the Iteration check box on the Calculation tab of the Options dialog box
(Tools=>Options).

The moment you select OK to close the Options dialog box and to put this new
Calculation setting into effect, Excel resolves the circular reference in cell B15
that calculates the bonuses based on the net income and the Circular Reference
toolbar. All the arrows showing all the cells involved in this circular reference
disappear from the worksheet.

Save this version of the Income Statement with the filename Solved6-7.xls in
your Chapter 6 folder inside the My Practice Spreadsheets folder on your hard
disk and then close this file.
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Chapter 7

Creating Date and
Time Formulas

In This Chapter

Building date and time formulas
Using the Date functions

Using the Time functions

Formulas that perform calculations between elapsed dates and times are quite common
in spreadsheets. The exercises in this chapter give you a chance to build formulas that
calculate the difference between starting and ending dates and times as well as to use Excel
Date and Time functions to perform a variety of tasks including returning the current date
and time in a spreadsheet, converting text entries to valid date and time numbers, and
more.

Constructing Date and Time Formulas

You already have some experience entering dates and times in a worksheet and then chang-
ing how they appear by assigning different date and time number formats. Remember that
all you need to do when you need to enter a date or time number in a worksheet is to emu-
late one of these date or time number formats when making the entry.

The only thing the least little bit baffling about date and time entries in a worksheet is the
actual way that Excel stores the date and time numbers into a cell when you make an entry
following one of the standard number formats. Behind the scenes (that is, the date or time
number formats) lies a serial number. In the case of dates, this serial number represents
the number of days that have elapsed between the date you enter and the beginning of the
twentieth century (making January 1, 1900 serial date number 1). In the case of time, the
serial number is a fraction representing the number of hours, minutes, and seconds that
have elapsed since midnight (which is serial number 0.00000000, so that 12 noon is
0.50000000).

To build a simple date formula that calculates the number of days that have elapsed
between two dates entered in the worksheet, subtract the cell containing the starting date
from the one containing the ending date. Excel then displays the calculated result in a date
format, which you then you have to reformat with another number format (such as Number
with no decimal points) to see the number of days that this “date” actually represents.

To build a simple time formula that calculates the fractional part of the day that has elapsed
between two times entered in the worksheet, you subtract the cell containing the starting
time from the one containing the ending time. Excel then displays the calculated result as a
fraction that you can then convert into hours by multiplying by 24.
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When entering times in a spreadsheet that you intend to use in formulas to compute
elapsed times, be sure to enter all times after 12 noon either using a 24-hour clock (as
in 13:05 for 1:05 PM) or with the PM signifier after the time number. Otherwise, Excel
interprets all the times you enter as occurring in the AM.

Exercise 7-1: Building Formulas that Calculate Elapsed Dates and Times

Launch Excel, if the program is not currently running, and use a blank workbook to
build some simple formulas that calculate elapsed times and dates:

1.

Increase the display magnification percentage from 100% to 200% and then enter
the following headings in the designated cells of Sheetl in the new workbook:

e Start in cell Al
¢ End in cell Bl
¢ Elapsed in cell C1

Enter the following dates in the designated cells:

¢ 11-6-05 in cell A2

e 2-15-06 in cell B2
Construct a formula in cell C2 that subtracts the ending date from the starting
date.

Excel calculates the difference between the two dates and returns the result for-
matted as the date 4/10/1900 to cell C2.

Format cell C2 with the Number format and zero decimal places.
Excel now displays 101 as the answer in cell C2.
Enter the following dates in the designated cells:
® 4-26-04 in cell A3
e 7-21-06 in cell B3
¢ 11-30-03 in cell A4
¢ 5-19-06 in cell B4
Use the Fill handle to copy the formula in cell C2 down to the range C3:C4.

Because you formatted the calculated result in cell C2 before you copied its for-
mula, the results returned to cells C3 and C4 automatically appear formatted as
whole numbers rather than as dates.

Enter the following times in the designated cells:
¢ 8:12 AMin cell A6
e 2:15 PM in cell B6

Construct a formula in cell C6 that calculates the difference between the ending
time and the starting time.

Excel calculates the difference between the two times and returns the result for-
matted as the date and time 1/0/1900 6:03, or simply 6:03 or 6:03 AM (depending
upon your version of Excel), to cell C6.

Format cell C6 with the Number format with two decimal places.

Excel now displays 0.25 as the answer in cell C6.
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10. Convert the fraction of the day into hours by editing the formula in cell C6 so
that the program multiplies the difference between the two cells by 24.

When editing the formula, be sure to enclose the subtraction operation in paren-
theses so that Excel performs the subtraction first and then multiplies this differ-
ence by 24 as in

=(B6-A6) *24

11. Enter the following times in the designated cells:
e 7:35 AM in cell A7
¢ 15:05 in cell B7
¢ 9:45 in cell A8
* 6 PM in cell B8
12. Use the Fill handle to copy the formula in cell C6 down to the range C7:C8.

Because you edited the basic formula in cell C6 so that it returns the number

of hours elapsed (rather than the fractional part of the day) and formatted the
result with the Number format with two decimal places before you copied the
formula, the copies in cells C7 and C8 automatically return the number of hours
expressed with two decimal places.

’3. Position the cell cursor in cell Al and then save this new workbook with the file-
name Solved7-1.xls in your Chapter 7 folder in the My Practice Spreadsheets
folder on your hard disk and then close the workbook.

Working with the Date Functions

Excel contains a number of Date functions that help you work with dates in your
spreadsheets. These functions run the gamut from those that return the current date
to those that convert text to date serial numbers (so you can use them in formulas
that compute the number of days that have elapsed).

When you install and activate the Analysis ToolPak add-in program that comes with
Excel, you have access to even more Date functions, many of which are specifically
targeted to performing date computations involving the normal five-day, Monday
through Friday, workweek.

Exercise 7-2: Building Formulas with Common Date Functions

Open the Exercise7-2.xls workbook file in your Chapter 7 folder in the My Practice
Spreadsheets folder on your hard disk or on the Excel Workbook folder on the work-
book CD-ROM. This workbook contains several worksheets, the first two of which
give you practice using the Date functions built into Excel and are available to you
when you activate the Analysis ToolPak:

1. Insert the current date in cell Bl using Excel’s TODAY function.

When working with a new function, use the Insert Function button on the
Formula bar to enter the function. That way, you can learn the purpose of the
function in the Insert Function dialog box and what arguments, if any, the func-
tion requires through the use of the Function Arguments dialog box.

2. Insert the current time in cell D1 using the NOW function and then format it with
the Custom h:mm AM/PM time number format.
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3. In cell D3, create a date entry using the DATE function with the three separate
numeric entries in cells A3, B3, and C3 as its arguments in the following order:

¢ C3 as Year argument
e A3 as Month argument
¢ B3 as the Day argument

4. Format the date returned by the DATE function in cell D3 with the March 14, 2001,
date format and then copy this DATE formula down to the cell range D4:D8.

Note that contents of the cell range D3:D8 is composed of DATE function formu-
las rather than date serial numbers. If you want to convert the formulas to their
calculated values, you need to use the Values option in the Paste Special dialog
box.

N

Select the cell range D3:D8 and then copy it to the Clipboard (Ctrl+C).

0. Position the cell pointer in E3 and then select the Values option button in the
Paste Special dialog box.

Excel copies the date serial numbers into the range E3:E8. Note that the date
serial numbers copied into this cell range are completely static: Unlike the DATE
function formulas in the cell range D3:D8, revising the numeric entries made in
the cells in the range A3:C8 would have no effect on them.

7. Use the DATEVALUE function in cell B10 to convert the text entry in cell A10 to
the date serial number and then copy the formula down to the cell range
C11:C14.

8. Position the cell cursor in cell B1 of the Date Formulas sheet and then save a
copy of the workbook with the filename Solved7-2-mine.xls in your Chapter 7
folder in the My Practice Spreadsheets folder, but leave the workbook open for
Exercise 7-3.

Add-in programs extend Excel’s basic feature set, usually by giving you access to new,
specialized functions. Excel ships with several add-in programs including the Analysis
ToolPak with its extra Date functions. Before you can use the functions or features
offered by an add-in program, you must activate it by selecting its check box in the
Add-Ins dialog box (Tools>Add-Ins).

The Analysis ToolPak, which you activate in the next exercise, adds the following
Date functions to Excel:

v EDATE(start_date,months) calculates the elapsed date so many months ahead
(positive months argument) or behind (negative months argument) the start_
date argument you specify.

v EOMONTH(start_date,months) calculates the last day of the month so many
months ahead (positive months argument) or behind (negative months argu-
ment) the start_date argument you specify.

v NEWORKDAYS(start_date.end_date,[holidays]) calculates the number of work
days between the start_date and end_date arguments — the optional holidays
argument can specify a range of holiday dates to be excluded from the workday
total.

v WEEKNUM(serial_number,[return_type]) calculates a number indicating where
the week in the date specified by the serial_number argument falls within the
year — the optional return_type argument can be the number 1 or 2, where 1 (or
no return_type argument specified) starts the week on Sunday (1) and ends it on
Saturday (7) and 2 starts the week on Monday (1) and ends it on Sunday (7).



Chapter 7: Creating Date and Time Formulas ’ 7 1

v WORKDAY((start_date,days, holidays]) calculates the work date that is so
many days ahead (positive days argument) or behind (negative days argument)
the start_date argument you specify — the optional holidays argument can spec-
ify a range of holiday dates to be excluded from the calculation.

v YEARFRAC(start_date,end_date,[basis]) calculates the fraction of the year
between the start_date and end_date arguments you specify — the optional
basis argument can be a number between 0 and 4 that signifies the following:

* 0 (or no basis argument) bases the year fraction on the U.S. (NASD)
method of 30/360 (whereby if the starting date is equal to the 31st of the
month, it becomes equal to the 30th and if the ending date is equal to the
31st of the month, the ending date becomes the 1st of the following
month).

¢ 1 bases the year fraction on the actual days divided by the actual days.
e 2 bases the year fraction on the actual days divided by 360.
¢ 3 bases the year fraction on the actual day divided by 365.

¢ 4 bases the year fraction on the European method of 30/360 (whereby start-
ing and ending dates that fall on the 31st of the month are made equal to
the 30th of the same month).

Exercise 7-3: Building Formulas with Date Functions in the Analysis ToolPak

Use the Solved7-2-mine.xls workbook file you created when doing the previous exer-
cise. If you did not perform this exercise or no longer have access to this workbook,
open the Solved7-2.xls file located in your Chapter 7 folder in the My Practice
Spreadsheets folder on your hard disk or on the Excel Workbook CD-ROM. In this
exercise, you activate the Analysis ToolPak add-in and then practice using its
WEEKNUM and NETWORKDAYS functions:

1. Position the cell cursor in cell C10 and then select the Analysis ToolPak check
box in the Add-Ins dialog box, if this check box is not already selected in your
copy of Excel (Tools>Add-Ins).

If you've not previously installed this add-in, Excel displays an alert dialog box
asking you if you want to install this add-in.

2. Select Yes in the alert dialog box asking you to install this add-in if prompted to
do so.

3. Select Date & Time as the category in the Or Select a Category drop-down list
box in the Insert Function dialog box (Insert=>Function) to display the list of Date
and Time functions.

Scroll through the list of Date & Time functions verifying that your activation of
the Analysis ToolPak add-in has inserted the EDATE, EOMONTH, NETWORKDAYS,
WEEKNUM, and YEARFRAC functions.

4. Select the WEEKNUM function in the Select a Function list box before you choose
OK to close the Insert Function dialog box.

5. Select cell B10 for the Serial_number argument and choose OK to close the
Function Arguments dialog box.

0. Copy the WEEKNUM formula in cell C10 down to the cell range C11:C14.
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7.

Switch to the 2006 Holidays worksheet and then use the individual calendar
worksheets (Jan-06 through Dec-06) to enter the dates of the holidays missing in
the cell range B3:B13.

Martin Luther King Day is in January

Presidents’ Day is in February

Memorial Day is in May

Labor Day is in September

Veteran’s Day is in November as is Thanksgiving in the U.S.A.

Name the cell range B3:B13 Holidays_06 and then position the cell cursor in
cell D3.

Construct a formula in this cell using the NETWORKDAYS function that calcu-
lates the number of workdays between 12-31-05 and 12-31-06.

Select cell B15 in Start_date text box and cell B16 in the End_date text box in the
Function Arguments dialog box

Construct a formula in cell D4 using the NETWORKDAYS function that calculates
the number of workdays between 12-31-05 and 12-31-06 and that deducts the hol-
idays that fall on workdays in the named range Holidays_06 in the 2006 Holidays
worksheet.

When creating this NETWORKDAYS function, type the range name, Holidays_06,
in the Holidays text box in the Function Arguments dialog box after selecting cell
B15 in the Start_date text box and B16 in the End_date text box.

Check your answers against those shown in the 2006 Holidays sheet in the
Solved7-3.xls workbook file in your Chapter 7 folder inside the My Practice
Spreadsheets folder or on your Excel Workbook CD-ROM. When everything
checks out, save your workbook in the Chapter 7 folder with the filename
Solved7-3-mine.xls.

Working with the Time Functions

Excel’s Time functions are a smaller subset of the Date functions. They include the
NOW function, which returns the current date and time; TIME, which creates a time
fraction from values representing the hour, minutes, and seconds; and TIMEVALUE,
which converts a time entered or imported into the worksheet as text so that you can
use it in formulas that calculate elapsed times.

Exercise 7-4: Building Formulas with Common Time Functions

1.
2.

Open the Exercise74.xls file located in your Chapter 7 folder in the My Practice
Spreadsheets folder on your hard disk or on the Excel Workbook CD-ROM. The file
contains a Time Formulas worksheet that you can use to practice using some of the
Time functions:

Display the current time in cell B1 using the NOW function — format the result
with the 1:30 PM Time format.

In cell D3, use the TIME function to enter a time using the entry in cell A3 as its
Hour argument, B3 as its Minute argument, and C3 as its Second argument.



Chapter 7: Creating Date and Time Formulas ’ 73

Copy the formula down to the cell range D4:D7.

Copy the times calculated in the cell range D3:D4 and then paste their fractional
values in the range E3:E7.

To copy only the values from a cell range, paste them into place using the Values
option in the Paste Special dialog box (Edit=>Paste Special).

In cell B10, use the TIMEVALUE function to convert the text entry in cell A10 to a
bona fide time.

Format the result in this cell with the 13:30:55 time format and then copy this for-
mula down to the cell range B11:B14.

Check your answers against those shown in Time Formulas sheet in the
Solved74.xls workbook file in your Chapter 7 folder inside the My Practice
Spreadsheets folder or on your Excel Workbook CD-ROM. When everything
checks out, save your workbook in the Chapter 7 folder with the filename
Solved7-4-mine.xls.
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Chapter 8

Financial Formulas
and Functions

In This Chapter

Understanding how the basic financial functions work
Using the basic investment accumulation, discounting, and amortization functions

Using the program’s depreciation functions

A s the old song says, “Money makes the world go 'round” and to that end, Excel sup-
plies you with plenty of built-in functions for getting the latest spin on how much
you're making and spending. In this chapter, you get the chance to practice using some of
the basic investment, depreciation, and currency-conversion functions that make up a part
of the program’s financial group.

Working with Financial Functions

Excel offers a fair number of sophisticated financial functions for determining such things as
the present, future, or net present value of an investment; the payment, number of periods,
or the principal or interest part of a payment on an amortized loan; the rate of return on an
investment; and the depreciation of your favorite assets.

By activating the Analysis ToolPak add-in, you add some 30-odd specialized financial func-
tions that run the gamut from those that calculate the accrued interest for a security paying
interest periodically and only at maturity all the way to those that calculate the internal rate
of return and the net present value for a schedule of non-periodic cash flows.

The key to using many of Excel’s financial functions is in understanding the terminology used
by their arguments. Many of the most common financial functions such as PV (Present Value),
NPV (Net Present Value), FV (Future Value), and PMT (Payment) take similar arguments:

v Pv is the present value that is the principal amount of the annuity

v Fv is the future value that represents the principal plus interest on the annuity

v Pmt is the payment made each period in the annuity. Normally, the payment is set over
the life of the annuity and includes principal plus interest without any other fees.

1 Rate is the interest rate per period. Normally, the rate is expressed as an annual
percentage.

v Nper is the total number of payment periods in the life of the annuity. It is calculated
by taking the Term (the amount of time that interest is paid) and multiplying it by the
Period (the point in time when interest is paid or earned) so that a loan with a 3-year
term with 12 monthly interest payments has 3 x 12, or 36, payment periods.
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QQ,N\BER When using financial functions, keep in mind that the fv, pv, or pmt arguments can be

& positive or negative, depending on whether you’re receiving the money (as in the
case of an investment) or paying out the money (as in the case of a loan). Also keep in
mind that you want to express the rate argument in the same units as the nper argu-
ment. For example, if you make monthly payments on a loan and you express the
nper as the total number of monthly payments (as in 360 (30 x 12) for 30-year mort-
gage), you need to express the annual interest rate in monthly terms as well. So if, for
example, you pay an annual interest rate of 7.5% on the loan, you express the rate
argument as 0.075/12 so that it is monthly as well.

Using the Basic Investment Functions

The following six functions form the core Excel financial functions for determining
whether a particular investment is worthwhile:

v FV(rate,nper,pmt,[pv],[type]) — Future Value — calculates the future value of an
investment, assuming a constant interest rate and constant payments on a peri-
odic basis.

v PV(rate,nper,pmt,[fv],[type]) — Present Value — calculates the present value of
an investment; that is, the total amount that a series of future payments is worth
Nnow.

v PMT(rate,nper,puv,[fv],[type]) — Payment — calculates the payment for a loan,
assuming a constant interest rate and stream of payments.

v RATE(nper,pmt,puv,[fv],[type]) calculates the interest rate for any type of
annuity.

v NPER(rate,pmt,puv,[fv],[type]) — Number of Periods — calculates the how many
periods are required for an investment, assuming a constant interest rate and
constant payments on a periodic basis.

v NPV(rate,valuel,[value2],[...]) — Net Present Value — calculates the present
value of an investment by using a discount rate and a series of future payments
(negative values) and income (positive values).

As you can see in this list, the syntax of these functions is similar, requiring, with the
exception of NPV, its own particular combination of the standard rate, nper, pmt, and
pv arguments discussed in the previous section. You will also note that the functions
that use these combination take the following optional arguments (indicated in the
square brackets):

v [Pv] optional argument in the FV function is the present value or lump-sum
amount for which you wish to calculate the future value: If you omit the pv
argument, Excel assumes a present value of zero (0).

Vv [Fv] optional argument in the PV, PMT, RATE, and NPER functions represents the
future value or cash balance you want to have after making your last payment: If
you omit the fv argument, Excel assumes a future value of zero (0).

v [Type] optional argument in the FV, PV, PMT, RATE, and NPER functions indicates
whether the payment is made at the beginning or the end of the period — enter 0
(or omit the type argument) when the payment is made at the end of the period
and use 1 when it is made at the beginning of the period.

In the following exercise, you get a chance to practice using the FV, PV, PMT, RATE,
and NPER financial functions to solve a series of seven real-world problems found on
the four worksheets (FV, PV, PMT, and NPER) in the Exercise8-1.xls workbook file.
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Exercise 8-1: Building Formulas with the FV, PV, PMT, RATE, and NPER
Functions

If Excel is not currently running, launch the program and then open the Exercise$-1.xls
workbook file inside your Chapter 8 folder in the My Practice Spreadsheets folder on
your hard disk or in the Excel Workbook folder on the workbook CD-ROM. Use the
problems found on the FV, PV, PMT, and NPER worksheets in this workbook to prac-
tice creating financial formulas using the FV, PV, PMT, RATE, and NPER functions:

1. Position the cell cursor in cell C4 of the FV worksheet, the answer cell for
Question 1, and construct a formula using the FV financial function (with the
appropriate cells in the range B7:C11 as its arguments) that calculates the return
on your investment.

When defining the arguments for your FV function in its Function Arguments
dialog box, move the dialog box out of the way of the cell range B7:C11 and then
click the appropriate cell in this range to define the three required (Rate, Nper,
and Pmt) and two optional arguments (PV and Type) when the insertion point is
located in its argument text box.

2. Position the cell cursor in cell C15 of the FV worksheet, the answer cell for
Question 2, and construct a formula using the FV financial function (with the
appropriate cells in the range B18:C22 as its arguments) that calculates the total
amount of money that you pay on the loan.

3. Position the cell cursor in cell C4 of the PV worksheet, the answer cell for
Question 3, and construct a formula using the PV financial function (with
the appropriate cells in the range B7:C11 as its arguments) that calculates
the amount of money you should pay for the property.

4. Position the cell cursor in cell C15 of the of the PV worksheet, the answer cell for
Question 4, and construct a formula using the RATE financial function (with the
appropriate cells in the range B7:C11 as its arguments) and your answer to
Question 3 in cell C4 to check the interest rate.

The formula with the RATE function in cell C15 should compute the same 6.50%
interest rate that is entered in cell C7.

5. Position the cell cursor in cell C4 of the of the PMT worksheet, the answer cell
for Question 5, and there construct a formula using the PMT financial function
(with the appropriate cells in the range B7:C11 as its arguments) that calculates
your monthly loan payment.

Be sure that you convert the rate argument and the nper argument for the PMT
function you construct to the equivalent months by entering the appropriate cal-
culations to their cell references in the Rate and Nper argument text boxes of the
Function Arguments dialog box for the PMT function.

6. Position the cell cursor in cell C15 of the PMT worksheet, the answer cell for
Question 6, and construct a formula using the PV financial function with the
appropriate cells in the range B7:C11 as its arguments to check the loan
amount you used in Question 5.

The formula with the PV in cell C15 should compute the same $465,000 amount
entered in cell C9 that you used as the PV argument of the PMT function in
cell C4.

7. Position the cell cursor in cell C4 of the of the NPER worksheet, the answer cell
for Question 7, and construct a formula using the NPER financial function (with
the appropriate cells in the range B7:C11 as its arguments) that calculates how
long it will take you to pay off your loan.
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Be sure that you convert the answer returned by the NPER function in months to
the equivalent years.

8. Check your answers against those in the equivalent worksheets in the Solved§-1.
xls workbook located in your Chapter 8 folder in the My Practice Spreadsheets
folder or on the Excel Workbook CD-ROM. If everything checks out with your
financial formulas, proceed to step 9.

9. Position the cell cursor in cell Al of the FV worksheet and then save your work
in a new workbook file named Solved8-1-mine.xls in your Chapter 8 folder and
then close both this new workbook and the Solved§-1.xls workbook file.

The NPV function returns the sum of any series of cash flows, discounted to the pres-
ent day, using a particular discount rate. The cash flows tracked by the NPV function
are either income (money you make) indicated by positive numbers in the function’s
values argument or payments (money you pay out) indicated by specifying negative
numbers.

When using the NPV function to determine the wisdom of an investment, you keep in
mind that this function assumes that the cash flows (be they income or payments) speci-
fied by the values argument(s) are all made at the end of the first period. As this assump-
tion does not conform to the understanding of net present value in standard accounting,
when using this function, you always need to include a Time 0 (even if its value is $0) in
order for your answer to be in accord with the accepted definition of NPV.

In the next exercise, you get an opportunity to practice using both the NPV and IRR
functions (Internal Rate of Return) to determine the advisability of making certain
capital expenditures in the form of equipment purchases. The IRR function returns
the interest rate received for an investment consisting of cash flows (income and pay-
ments) made at regular intervals. Note that unlike when using the RATE function, the
cash flows do not have to be equal, although they must be made regularly on a peri-
odic basis (monthly, quarterly, annually, and the like).

The IRR function computes its result using an iterative process (similar to that used
to resolve certain circular references like the one you encountered in Chapter 6). For
this reason, the function takes an optional guess argument, where you may specify
your best guess or target percentage. If you don’t specify a guess argument for an IRR
function, Excel automatically uses 10% as its target.

To determine the prudence of making the proposed capital expenditures using the
NPV and IRR functions in exercise ahead, you finish creating a partially constructed
spreadsheet model on NPV & IRR worksheet in the workbook file Exercise8-2.xls.

Exercise 8-2: Building Formulas with the IRR and NPV Functions

Open the Exercise§-2.xls workbook file inside your Chapter 8 folder in the My Practice
Spreadsheets folder on your hard disk or in the Excel Workbook folder on the work-
book CD-ROM. In this exercise, you finish the model constructed on its NPV & IRR
worksheet. In doing so, you get practice using the NPV and IRR functions to deter-
mine the financial wisdom of making capital expenditures in the form of purchased
equipment given the level of anticipated of income resulting from the asset acquisi-
tion, the anticipated taxes on that extra income, and the depreciation of those assets
over their three year life:
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Select the cell range B3:C7, and then choose Insert=>Namer>Create and make
sure that only the Left Column check box is selected in Create Names dialog box
before you select OK.

You use the Create Names feature to assign the row headings in B3:B7 to the cells
in C3:C7.

Make the following entries in the designated cells:
¢ 38000 in cell C3
¢ 1500 in cell C4
¢ 15000 in cell C5
® 6% in cell C6
® 27% in cell C7

Position the cell cursor in cell H10 and type = - (an equal to sign followed by a
minus sign with no spaces) and then click cell C3.

In the cell and on the Formula bar, Excel inserts the equal to sign, a minus sign,
and then cell’s range name:

=—Initial_Cost

Click the Enter button on the Formula bar to complete the cell entry and then
position the cell cursor in cell C11.

Type an = (an equal to sign) and then click cell C5.

In the cell and on the Formula bar, Excel inserts an equal to sign followed by the
cell’s range name:

=Expected_Income

Click the Enter button on the Formula bar to complete the cell entry and then
position the cell cursor in cell D11 to the right.

In this cell, you insert the SLN (Straight Line depreciatioN) function that figures
the depreciation on the $38,000 worth of equipment purchases.

Click the Insert Function button on the Formula bar and then, in the Insert
Function dialog box, select the SLN function in the Financial Category before you
select OK.

The SLN function takes three arguments; cost, with the initial cost of your assets;
salvage, with the value of the assets at the end of its useful life; and life, which
indicates the number of years that the asset is expected to be in use.

While the insertion point is in the Cost argument text box, click cell C3 in the
worksheet to insert the range name Initial_Cost in this box and then press Tab.

Click cell C4 in the worksheet to insert the range name Salvage_Value in the
Salvage argument text box and then press Tab.

Type 3 in the Life argument text box and then select OK.

Position the cell cursor in cell E11 and construct a formula that subtracts
the first-year depreciation amount in cell D11 from the pretaxable income in
cell C11.

Position the cell cursor in cell F11 and construct a formula that deducts the esti-
mated taxes using the tax rate percentage in cell C7 from the taxable income in
cell E11.
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The standard way to construct this type of formula is to multiply the taxable
income by 1 minus the tax rate. In this particular case, this formula in F11 would
appear as

=Ell1* (1-Tax_Rate)

Position the cell cursor in cell H11 and there construct a formula that adds the
depreciation value in cell D11 to the after-tax income in cell F11 to salvage value
in cell G11.

If you use the SUM function, this formula in G11 appears as
=SUM(D11,F11,G11)

Use the Fill handle to copy the entries in the cell range C11:H11 down to the
range C12:H13.

Position the cell cursor in cell G13 and construct a formula with a reference to
the Salvage_Value cell C4.

This formula in cell G13 appears as
=Salvage_Value

Position the cell cursor in cell F2 and type = (equal to sign), and then click the
cell H10 in the worksheet to select it before you type + (plus sign).

The formula in the cell and on the Formula bar in F2 now reads
=H10+

Click the Insert Function button on the Formula bar and then, in the Insert
Function dialog box, select the NPV function in the Financial Category before
selecting OK.

Click cell C6 in the worksheet to insert the Interest_Rate range name in the Rate
argument text box and then press Tab.

Select the cell range H11:H13 in the worksheet to insert this range address in the
Valuel text box and then select OK.

Excel inserts the following formula in cell F2 that computes the net present value
of the investment in cell F2 as $1,310:

=H10+NPV (Interest_Rate,H11:H13)

Position the cell cursor in cell H2 and then click the Insert Function button on
the Formula bar. In the Insert Function dialog box, select the IRR function in the
Financial Category before you select OK.

Select the cell range H10H13 in the worksheet to insert this range address in the
Values argument text box and then select OK.

Excel computes an 8% internal rate of return on this investment, which is cer-
tainly acceptable.

Check your model against the one in the NPV & IRR worksheet in the
Solved§-2.xls workbook in your Chapter 8 folder.

If everything checks out, proceed to step 24.
Change the following values in the designated cells:
¢ 1000 in the Salvage_Value cell C4
¢ 12000 in the Expected_Income cell C5

Note that at this salvage value and anticipated income amount, the net pres-
ent value is a loss of $4,884 and the internal rate of return has now sunk to

a dismal -1% — with these figures, the capital investment is decidedly not a
wise one.
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2 4. Click the Undo button on the Standard toolbar or press Ctrl+Z to restore the orig-
inal salvage value and expected income figures to the spreadsheet.

25. save your work in a workbook named Solved8-2-mine.xls in your Chapter 8
folder and then close both this new workbook and the Solved§-2.xls workbook
file.

Figuring the Depreciation of an Asset

MBER
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The moment you put an asset you purchase into service, it begins to depreciate (lose
value). Excel lets you choose between four different Depreciation functions, each of
which uses a slightly different method for depreciating an asset over time. These
built-in Depreciation functions include

»* SLN to calculate straight-line depreciation
v SYD to calculate sum-of-years-digits depreciation
v DB to calculate declining balance depreciation

+ DDB to calculate double-declining balance depreciation

All four depreciation functions require the following cost, salvage, and life arguments,
and in addition, all except the SLN function, require the period argument:

v Cost, indicating the initial cost of the asset that you're depreciating.

v~ Salvage, indicating the value of the asset at the end of the depreciation (also
known as the salvage value of the asset).

v~ Life, indicating is the number of periods over which the asset is depreciated
(also known as the useful life of the asset).

v Period, indicating the period over which the asset is being depreciated — note
that the units you use in the period argument must be the same as those used in
the life argument of the Depreciation function. For example, if you express the
life argument in years, you must also express the period argument in years.

Note that the DB function accepts an optional month argument. This argument is the
number of months the asset is in use in the first year. If you omit this optional argu-
ment from your DB function, Excel assumes the number of months of service to be 12.
Also, when using the DDB function, you can add an optional factor argument. This
argument is the rate at which the balance declines in the depreciation schedule. If
you omit this optional argument, Excel assumes the rate to be 2 (thus, the name
double-declining balance).

The following exercise gives you an opportunity to practice using all four types of
depreciation in a partially completed Depreciation Table that then enables you to
compare the amount you depreciate each year in the useful life of an asset.

Exercise 8-3: Building Formulas with the SLN, SYD, DB, and DDB Depreciation
Functions

Open the Exercise§-3.xls workbook file inside your Chapter 8 folder in the My Practice
Spreadsheets folder on your hard disk or in the Excel Workbook folder on the work-
book CD-ROM. This workbook contains a Depreciation worksheet with a Depreciation
Table comparing the four depreciation methods side by side that you will complete:
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Select the cell range B3:C6 and then open the Create Names dialog box (Insert=>
Names=>Create) and select only the Left Column check box in this dialog box
before you select OK.

Make the following entries in the designated cells:
e Office Furniture in the Type_of_Asset cell, C3
* 50000 in the Cost cell, C4
¢ 10 in the Life_in_years cell, C5
¢ 1000 in the Salvage cell, C6

Position the cell cursor in cell C9 and construct a formula that references the
Cost cell, C4, and then use the Fill handle to copy this formula across the row to
the cell range D9:F9.

Position the cell cursor in cell C10; there, type = (an equal sign) and then select
cell C9 before you type - (minus sign).

The formula in the cell and on the Formula bar now reads
=C9-

Click the Insert Function button on the Formula bar and then in the Insert Function
dialog box, select the SLN function in the Financial Category before you select OK.

Select the following cells to insert their names in the designated argument text
boxes and then select OK:

e Cost cell (C4) in the Cost text box
¢ Salvage cell (C6) in the Salvage text box
e Life_in_years cell (C5) in the Life text box
Copy the formula in cell C10 down to the cell range C11:C19.

Position the cell pointer in cell D10 and construct a formula that subtracts the
cost amount in D9 from the first-year depreciation returned by the SYD function
using the following arguments:

¢ Cost cell in the Cost text box
¢ Salvage cell in the Salvage text box
e Life_in_years cell in the Life text box
¢ Cell B10 in the Per text box
Copy the formula in cell D10 down the cell range D11:D19.

Position the cell pointer in cell E10 and construct a formula that subtracts the
cost amount in E9 from the first-year depreciation returned by the DB function
using the following arguments:

¢ Cost cell in the Cost text box
e Salvage cell in the Salvage text box
e Life_in_years cell in the Life text box
¢ Cell B10 in the Per text box
Copy the formula in cell E10 down the cell range E11:E19.

Position the cell pointer in cell F10 and construct a formula that subtracts the
cost amount in F9 from the first-year depreciation returned by the DDB function
using the following arguments:

e Cost cell in the Cost text box

e Salvage cell in the Salvage text box
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e Life_in_years cell in the Life text box
e Cell B10 in the Per text box
Copy the formula in cell F10 down the cell range F11:F19.

Check the formulas in your Depreciation worksheet against those in the
Solved§-3.xls workbook file in your Chapter 8 folder inside the My Practice
Spreadsheets folder or on the Excel Workbook CD-ROM.

If everything checks out, proceed to step 14.

Make the following updates in the designated cells:
¢ 25000 in the Cost Cell (C4)
¢ 5 in the Life_in_years cell (C5)
¢ 500 in the Salvage cell (C6)

Note that when Excel finishes recalculating the Depreciation Table using your
new inputs, the depreciation formulas in the Straight Line column (C) return
negative values to all the rows below Year 5 and #NUM! error values to the SYD,
Declining Balance, and Double-declining Balance columns.

Click the Undo button on the Standard toolbar or press Ctrl+Z until you have
restored the original Cost, Life_in_years, and Salvage values to cells C4, C5,
and C6 in the table. Next save your work in a workbook file named Solved8-3-
mine.xls in your Chapter 8 folder inside the My Practice Spreadsheets folder
before you close the file.
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Chapter 9
Using Math Functions

In This Chapter

Rounding off numbers in a spreadsheet
Using functions for calculating products, powers, and square roots
Summing the products in cell ranges or arrays

Doing conditional summing

Fe Math & Trig group of functions includes a wide variety of mathematical functions for
computing new values as well as for controlling the results of calculations. This group
also includes a large assortment of trigonometric functions most often needed in engineer-
ing and scientific endeavors. In this chapter, you get a chance to practice using some of the
math functions more commonly needed in spreadsheets for business applications.

Rounding Off Values

Rounding off the numbers that have fractions is one of the more frequent tasks you may
undertake in Excel. Excel includes three functions in the Math & Trig category that you can
use for rounding off the numbers in a worksheet:

v ROUND(number,num_digits) to round the value specified by the number argument to
the number of digits specified by the num_digits argument

v ROUNDUP(number,num_digits) to round up the value away from 0 (zero) that is specified
by the number argument to the number of digits specified by the num_digits argument

v ROUNDDOWN(number,num_digits) to round down the value toward 0 (zero) that is
specified by the number argument to the number of digits specified by the num_digits

argument
What'’s the difference between using one of A. Formatting a number only changes the way
Excel’s rounding functions to round off the value appears in the cell, whereas
values to a particular decimal place and rounding off a number with one of the Excel
using a number format to control how functions actually changes the number of
many decimal places are displayed? digits in the value entered in that cell.

Exercise 9-1: Building Formulas the ROUND, ROUNDUP, and ROUNDDOWN
Functions
If Excel isn’t running, launch the program and then open the Exercise9-1.xls workbook

file in your Chapter 9 folder in the My Practice Spreadsheets folder inside My
Documents on your hard disk or in the Excel Workbook folder on the workbook
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Figure 9-1:
The
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book with

its ROUND,
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formulas.
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CD-ROM. This file contains a Rounding Formulas worksheet where you can practice
using the ROUND, ROUNDUP, and ROUNDDOWN functions on the value of the mathe-
matical constant pi, accurate to 15 placed returned by the PI function to cell A3:

1.
2.
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9.

Position the cell cursor in cell B3 and construct a formula using the ROUND func-
tion that rounds off the value of pi in cell A3 to no decimal places.

In cell B4, construct a formula with the ROUND function that rounds off the value
of pi in cell A3 to one decimal place.

Because all the rounding formulas you’re going to create for this exercise use the
same value in cell A3, you can save time by making copies of the original ROUND
formula and then editing the function name or the num_digits argument in the
copies as needed. To do this, however, you must remember to convert the refer-
ence to cell A3 from relative to absolute when constructing the formula with the
Insert Function feature.

In cell B5, construct a formula with the ROUND function that rounds off the value
of pi in cell A3 to two decimal places.

In cell B6, construct a formula with the ROUND function that rounds off the value
of pi in cell A3 to three decimal places.

In cell B7, construct a formula with the ROUNDUP function that rounds up the
value of pi in cell A3 to two decimal places.

In cell B8, construct a formula with the ROUNDUP function that rounds up the
value of pi in cell A3 to four decimal places.

In cell B9, construct a formula with the ROUNDDOWN function that rounds down
the value of pi in cell A3 to two decimal places.

In cell B10, construct a formula with the ROUNDDOWN function that rounds
down the value of pi in cell A3 to four decimal places.

Compare your spreadsheet to one shown in Figure 9-1. If everything checks out,
proceed to Step 9.

Save your workbook file in the Chapter 9 folder with the filename Solved9-1.xls.

=] Microsoft Excel - Exercisa91.xls SEE|
@_] File Edit View Inset Format Tools Data Window Help Adobe PDF o i el - @ X
; AATRIA BRI | R
«_a_ o zB U |SES=54 % o SR F
E1'.] b F =ROUNDDOWNISAES 4) =
| A B E I
1 |Rounding Off Numbers
2 Value of Rounding Off 1 Rounding Function Used
3 3.141592654 3 Round to zero digits
4 3.1 Round to one digit
8 3.14) Round to two digits
6 3.142) Round to three digits
7 3.15 Round up to two digits
8 3.1416) Round up to four digits
i3 3.14 Round down to two digits
10 3.1415] Round down to four digits
11
12
13
" 1{4 1\ Rounding Functions { 5h2eta / Sheats / |¢] > lY
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Finding Products, Powers, and Square Roots

Although you can create formulas that multiply values using the asterisk (*) operator
as well as those that raise a number to a particular power by using the caret (*), Excel
also includes PRODUCT and POWER functions that perform these types of calcula-
tions for you. And for those times when you need to find the square root of a value,
the program includes a SQRT function. These three Math functions work with the fol-
lowing arguments:

v PRODUCT(numberl,number2, . . ) where the numberl, number2 arguments are
the values you want to multiply with one another

v POWER(number,power) where the number argument is the value you want to
raise the power specified by the power argument

v SQRT(number) where the number argument is the value for which you want the
square root

Exercise 9-2: Building Formulas with the PRODUCT, POWER, and SQRT
Functions

Open the Exercise9-2.xls workbook file in your Chapter 9 folder in the My Practice
Spreadsheets folder inside My Documents on your hard disk or in the Excel
Workbook folder on the workbook CD-ROM. This file contains a Misc. Math Formulas
worksheet where you can practice using the PRODUCT, POWER, and SQRT functions
in a couple of tables:

1. Position the cell cursor in cell D3 and construct a formula using the PRODUCT
function that multiplies the price in B3 by the quantity in cell C3.

2. Format the computed amount in cell D3 with the Currency Style format and then
copy this formula down to the cell range D4:D5.

3. In cell BY, construct a formula that squares the value in cell A9 and then copy
this POWER formula down to the cell range B10:B11.

In cell C9, construct a formula that cubes the value in cell A9 and then copy this
POWER formula down to the cell range C10:C11.

In cell D9, construct a formula that finds the square root of the value in cell A9
and then copy this SQRT formula down to the cell range D10:D11.

NAI

Cell D11 returns a #NUM! error value in the cell because the SQRT function
cannot compute square roots for negative numbers (multiplying one negative
number by another always results in a positive product).

To avoid the #NUM! error in this formula, you can nest the ABS function that
returns the absolute value of cell A11 (which is always positive) inside the SQRT
function as follows:

=SQRT (ABS (A11))

6. Edit the original formula in cell D9 by positioning the insertion point between the
T in SQRT and the open parenthesis. Type (ABS and then position the insertion
point between 9 in A9 and the close parenthesis, and then type another close
parenthesis before clicking the Enter button on the Formula bar.

The edited formula should appear on the Formula bar as follows:
=SQRT (ABS (A9) )
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7. Copy this edited version of the SQRT formula with the nested ABS function over
the original formula copies in the cell range D10:D11.

Check your results against those shown in Figure 9-2. If everything checks out,
proceed to Step 8.

8. save your workbook file in the Chapter 9 folder with the filename Solved9-2.xls.
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Ready

Doing Fancier Sums

Without any doubt, SUM is the preeminent function in the Math & Trig category. This
function is so central to spreadsheet formula-making that the Standard toolbar con-
tains its own AutoSum button to facilitate the construction of all your SUM formulas.

The SUM function is not the only function in the Math & Trig category capable of
computing totals. In addition, the program offers more specialized summing functions
for use when you need to total the products or squares of the values in a range or
total values only when a particular condition is met.

Summing products, squares, and
their differences

You can use the SUMPRODUCT function to have Excel total the products returned by
multiplying the values in corresponding arrays. For one array to correspond to
another, each must consist of the same number of rows and columns.
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For example, suppose you have a spreadsheet with a 2 x 1 array in the cell range
B2:B3 that contains the values 4 and 5 (expressed as {4;5}), and another 2 x 1 array in
the cell range D2:D3 that values 6 and 3 (expressed {6;3}) — see Chapter 6 for a quick
refresher on arrays. Because both these arrays have the same number of rows (2) and
columns (1), they correspond and can be used as arguments in the SUMPRODUCT
function.

The SUMPRODUCT function uses the following syntax:
SUMPRODUCT (arrayl,array2, . . .)

Note that the SUMPRODUCT function accepts up to a maximum of 30 array argu-
ments. The SUMPRODUCT function is not the only summing function to use
these arguments. The following summing functions also follow the same syntax
as SUMPRODUCT:

v SUMX2MY2 (SUM X squared minus Y squared) to sum the difference between the
squares of two corresponding arrays

v SUMX2PY2 (SUM X squared plus Y squared) to return the grand total of the sums
of the squares in two corresponding arrays

v SUMXMY2 (SUM X minus Y squared) to sum the squares of the differences in two
corresponding arrays

The SUMSQ function that totals the squares of the arguments is similar to these
summing functions, except that you can use individual numbers as well as arrays for
its arguments.

Exercise 9-3: Building Formulas with the SUMPRODUCT, SUMSQ, and
SUMX2PY2 Functions

Open the Exercise9-3.xls workbook file in your Chapter 9 folder in the My Practice
Spreadsheets folder inside My Documents on your hard disk or in the Excel Workbook
folder on the workbook CD-ROM. This file contains a SUM Formulas worksheet with
two 2 x 1 arrays, the first in light yellow in the cell range B2:B3 and the second in
light green in the cell range D2:D3. You will use these arrays to practice using the
SUMPRODUCT, SUMSQ, and SUMX2PY2 functions:

1. Position the cell cursor in cell F6 and construct a formula with the SUMPRODUCT
function that totals the products of the first array in light yellow in the cell range
B2:B3 and the second array in light green in the cell range D2:D3.

Excel returns a result of 39 in cell F9 as the sum of the products of the two
arrays.

2. Verify the calculated result returned by the SUMPRODUCT formula in cell F6 by
constructing the following simple formulas in the designated cells that replicate
the computation made by the SUMPRODUCT function:

¢ Formula in cell C6 that multiplies the value in B2 by that in D2
e Formula in cell D6 that multiplies the value in B3 by that in D3
e Formula in cell E6 that adds the value in C6 to that in D6

The calculated total returned to cell E6 should be 39, just like the one in cell F6
next door.
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Position the cell cursor in cell G8 and construct a formula with the SUMSQ func-
tion that sums the squares of the value in cell B2 with that in cell D2.

Excel returns a total of 52 to cell G8.

Verify the calculated result returned by the SUMSQ formula in cell G8 by con-
structing the following simple formulas in the designated cells that replicate its
computation:

e Formula in cell D8 that squares the value in B2
* Formula in cell E8 that squares the value in D2
e Formula in cell F8 that adds the value in D8 to that in E8

To square a value in a cell, insert the cell reference followed by the caret (%)
operator and 2 (for example, =B2”2 to square the value in B2).

The calculated total returned to cell F8 should now match the one in cell G8 next
door.

Position the cell cursor in cell G10 and construct a formula with the SUMSQ func-
tion that sums the squares of the first array in the cell range B2:B3 with that in
the second array in the cell range D2:D3.

Excel returns a sum of 86 to cell G10.

Verify the calculated result returned by the SUMSQ formula in cell G10 by con-
structing the following simple formulas in the designated cells that replicate its
computation:

¢ Formula in cell B10 that squares the value in B2
e Formula in cell C10 that squares the value in B3
e Formula in cell D10 that squares the value in D2
e Formula in cell E10 that squares the value in D3
¢ Formula in cell F10 that sums the values in cell range B10:E10
The calculated total returned to cell F10 should now match the one in cell G10.

Position the cell cursor in cell G12 and construct a formula with the SUMX2MY2
function that calculates the difference between the squares of the first array in
the cell range B2:B3 and that in the second array in the cell range D2:D3.

Excel returns a sum of -4 to cell G12.

Verify the calculated result returned by the SUMX2MY2 formula in cell G10 by
constructing the following simple formulas in the designated cells that replicate
its computation:

¢ Formula in cell B12 that squares the value in B2
e Formula in cell C12 that squares the value in B3
e Formula in cell D12 that squares the value in D2
e Formula in cell E12 that squares the value in D3

e Formula in cell F12 that subtracts the sum of B12 plus C12 from the sum of
D12 plus E12

When constructing the formula in cell F12 that subtracts the sum of B12 and C12
from the sum of D12 plus E12, be sure to enclose the values to be summed
(B12+C12) and (D12+E12) in parentheses.

The calculated total returned to cell F12 should now match the one in cell G12.
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9. Open the Solved9-3.xls workbook in the Chapter 9 folder and check the results in
your SUM formulas sheet against its formulas. If everything checks out, save
your workbook in the Chapter 9 folder with the filename Solved9-3-mine.xls and
then close both workbooks.

Conditional totals

All the variations of the SUM function you’'ve used up to now calculate their totals come
rain or shine. The SUMIF function, however, is a little different: It only sums its desig-
nated values when a particular condition is true. The SUMIF function, although located
in the Math & Trig category, could have just as easily been classified as one of the
Logical functions (see Chapter 12) because it basically works only when its compara-
tive condition returns the logical value TRUE (refer to Chapter 12 for a refresher on cre-
ating comparative formulas that return TRUE or FALSE as their answers).

The syntax of the SUMIF function includes the following arguments:
SUMIF (range, criteria, [sum_range] )

The range argument specifies the cells that you want Excel to evaluate using the
condition or conditions specified by the criteria argument. The optional sum_range
argument specifies the cells you want Excel to sum when the condition in the criteria
argument is found TRUE. You only need to specify a sum_range argument when the
cell range to be summed is not the same as the one whose values are evaluated as to
whether they meet the condition set up in the criteria argument.

To get some practice using the SUMIF function, you will work with the Jan-06 Sales
worksheet in the workbook containing the data list of the January 2006 sales for the
fictitious company, Chris’s Cookies. This data list tracks the sales by store location,
the type of baked item sold (lemon tarts, blueberry muffins, Lots of Chips cookies,
and strawberry pie), the date of sale, the number of dozens sold, the price per dozen,
and the daily sales total. Most of these fields tracked in the data list have range
names assigned to their data (Store_name to the data in the Store field, Date_sold to
the data in the Date field, Item_sold to data in the Item field, and Daily_sales to the
data in the Daily Sales field) that you can refer in place of cell ranges in the formulas
you construct using the SUMIF function.

Exercise 9-4: Using the SUMIF Function

Open the Exercise94.xls workbook file in your Chapter 9 folder in the My Practice
Spreadsheets folder inside My Documents on your hard disk or in the Excel
Workbook folder on the workbook CD-ROM. Use its Jan-06 Sales worksheet to practice
using the SUMIF function.

1. Position the cell cursor in cell I3 and construct a formula using the SUMIF
function that totals the daily sales for all lemon tarts sold in the month of
January 2006.

This SUMIF function uses the Item_sold range as its range argument and the
Daily_sales range as its sum_range argument. The condition for the criteria
argument is where the item sold is equal to lemon tarts, which is expressed as
follows:

"=lemon tarts"
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Note that because you are evaluating a text string in this comparative expression
that contains a space, you must enclose the entire criteria argument inside
double quotation marks.

Select the SUMIF function in the Math & Trig category in the Insert Function
dialog box and then select OK to open the Function Arguments dialog box for
this function.

With the insertion point in the Range text box, choose Insert>Namer>Paste and
then select Iltem_sold in the Paste Name dialog box before you select OK.

Use the Paste Name dialog box to insert range names already defined in the
workbook that you want to use as the operands or functional arguments of the
formulas you’re building.

Press Tab to select the Criteria text box and then type “=lemon tarts” here.

Press Tab to select the Sum_range text box and then select Daily_sales in the
Paste Name dialog box.

Check the values in your argument text boxes against those shown in the one in
Figure 9-3. If everything checks out, proceed to Step 6.

Select OK to insert the SUMIF function in cell I3.
Excel returns a total of $815.00 for the lemon tarts sold in January 2006.

Construct a SUMIF function in cell 4 that totals the daily sales for just blueberry
muffins.

Be sure the criteria argument for this SUMIF function includes the quotation
marks:

"=blueberry muffing"

Construct a SUMIF function in cell I5 that totals the daily sales for just Lots of
Chips cookies.

Construct a SUMIF function in cell I6 that totals the daily sales for just straw-
berry pie.

Construct a SUMIF function in cell I8 that totals the daily sales for all items
except for strawberry pie.

Use the <> operator with strawberry pie to have Excel exclude it from the total,
while at the same time summing the daily sales for all the other baked items:

"<>Strawberry pie"

Save your work under the filename Solved9-4.xls and leave this workbook open
to use in completing Exercise 9-5 on using the Conditional Sum Wizard.

- = B3
Function Arguments g
=
Range | TN (.| - (Lemon i=iis s B
Criteria | "=Lemon tarts’
SUm_rarge | Daily_ssles [ = Ersaoszrrsee
=gi5
Ards the calls spedfied by 5 given conditon or oiters,
Range = the range of c2lls you want evaliated,
Formuia result = s B15.00
Hetpom s fretims Gk | Cancel
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The SUMIF function works great when you only have only one criterion that you want
to apply in doing the summing. It does not, however, work when you have multiple
criteria that you need to use in determining which numbers get added to the total and
which don’t. For those situations, you have to turn to the Conditional Sum Wizard, a
nifty little Excel add-in tool that walks you through the steps of building more com-
plex SUM formulas that utilize IF conditions that can include multiple criteria.

In the next exercise, you use the Conditional Sum Wizard to construct a formula using
the Chris’s Cookies monthly sales list in the Jan-06 Sales worksheet that sums the
daily sales made at the Anderson Road store location for all baked items except for
strawberry pie after the date of January 1, 2006.

Exercise 9-5: Using the Conditional Sum Wizard

Use the Solved9-4.xls workbook that you created in Exercise 9-4 to complete this exer-
cise using the Conditional Sum Wizard:

1. Select the Conditional Sum Wizard check box in the Add-Ins dialog box (Tools=>
Add-Ins) and then select Yes if prompted by an alert dialog box to install the
add-in.

2. Position the cell cursor in cell 110 to use the Conditional Sum Wizard to construct
the formula that sums all baked goods except for strawberry pie sold after
January 1 at the Anderson Road store location.

3. Open the Step 1 of 4 Conditional Sum Wizard dialog box by choosing Tools=>
Conditional Sum.

In this dialog box, you indicate the entire range of the data list, including its
column labels (field names). In this case, you need to select the cell range of the
entire data list A2:G62

4. Drag the cell cursor through the cell range A2:G62.

The text box in the Step 1 of 4 dialog box now contains the range ‘Jan-06
Sales’!$A$2:$G$62.

5. Select the Next button to proceed to the Step 2 of 4 Conditional Sum Wizard
dialog box.

In the Step 2 of 4 dialog box, you indicate the column to sum as well as the
column(s) to evaluate and the condition(s) to be used.

0. Leave Daily Sales in the Column to Sum text box, select Date in the Column drop-
down list box below, > (greater than) in the Is drop-down list box, and leave
1/1/2006 selected in This Value drop-down list box before you select the Add
Condition button.

7. Using these drop-down list boxes and the Add Condition button, add a second
condition where the Item is not equal to (<>) strawberry pie.

8. Add a third and final condition with these controls where the store is equal to (=)
Anderson Road.

9. Check your Step 2 of 4 Conditional Sum Wizard dialog box against the one shown
in Figure 9-4: If everything checks out, click the Next button.

10. 1n the Step 3 of 4 Conditional Sum Wizard dialog box, leave the Copy Just the
Formula to a Single Cell option button selected and then click the Next button.
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If you were to select the Copy Formula and Conditional Values, the Wizard would
then prompt you for cell references for each column used in a condition and its
associated SUMIF formula.

In the Step 4 of 4 Conditional Sum Wizard dialog box, click cell [10 in the work-
sheet to insert the reference ‘Jan-06 Sales’!$1$10 in its text box and then select
the Finish button.

Excel then inserts a long SUM function containing several nested IF conditions in
cell 110.

Open the Solved9-5.xls workbook in your Chapter 9 folder inside the My Practice
Spreadsheets folder and then check the SUMIF formulas and SUM formula with
nested IF functions in your workbook against those found in this workbook file.
If everything checks out OK, save your workbook under the name Solved9-5-
mine.xls and then close both the workbook files as you exit Excel.

I | Conditional Sum Wizard - Step 2 of 4 %]
Figure 9_4: Wit collum contains the values tosim? Select the column lsbel
The Step Column o sum: | Daitv Sales =]
20f4 :
. Mex, select & column yoll wart to Bvaluate, and then type or select a
Conditional | vaive to compare with datz i that column,
Sum Wizard Colurn: Is: This value:
dialog box | gz = [ = =l ancersonrd. e
after speci-
fying the | : |
column to
sum and the
conditions
to use. 7 Cance < Batk | ext = Ij | ‘
— A




Chapter 10
Using Statistical Functions

In This Chapter

Calculating averages

Finding the maximum and minimum values

Counting the cells in a range of data

Using the Statistical functions offered by the Analysis ToolPak add-in

Ecel includes one of the most complete sets of statistical functions available outside of
a dedicated statistics software program. These functions run the gamut from the more

mundane AVERAGE, MAX, and MIN functions to the more exotic and much more specialized
CHITEST, POISSON, and PERCENTILE statistical functions. In addition, the program offers an
assortment of counting functions that enable you to count the number of cells that contain
values, are nonblank (and thus contain entries of any kind), or count only the cells in a cell

range that meet the criteria you specify. In this chapter, you get a chance to practice work-

ing with the most commonly used statistical functions, AVERAGE, MAX, and MIN, as well as
the different counting functions.

Computing Averages

The average is the arithmetic mean computed by summing all the values to be averaged and
then dividing this total by the number of values. Excel’s AVERAGE function, which calculates
the average of a range or series of values, uses the following syntax:

AVERAGE (numberl, [number2], [. . .])

One way to understand the workings of the AVERAGE function is to display the correspon-
ding SUM and COUNT formulas that return the exact same result. For example, suppose you
want to find the average of the values in the cell range D4:D8 in your spreadsheet by enter-
ing the following formula in a cell:

=AVERAGE (D4 : D8)

In place of this AVERAGE function, you could obtain the same result by entering the follow-
ing formula:

=SUM (D4 :D8) /COUNT (D4 :D8)
Note that the COUNT function shown as the divisor in this equivalent formula returns the

number of cells in the specified range that contain numeric entries (see Exercise 10-3 later
in this chapter for practice on using COUNT).
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Note that if the values in the number arguments of the AVERAGE function contain
cells with text entries, logical values (TRUE or FALSE), or that are blank, Excel ignores
them in the counting calculation (they are naturally ignored in the summing). However,
if the cells in the number arguments contain 0 (zero) values, they are used in the
counting calculation (even though they add nothing to the sum).

In addition to the AVERAGE function used to calculate the arithmetic mean in range or
series of values, Excel also includes a MEDIAN function, which takes the same kind of
arguments. Instead of the arithmetic mean, the MEDIAN function returns the value
that lies precisely in the middle of those in the range or series specified as its argu-
ments, with half greater and half less.

Exercise 10-1: Building Formulas with the AVERAGE and MEDIAN Functions

If Excel is not currently running, launch the program. Then, open the Exercisel0-1.xls
workbook file in your Chapter 10 folder inside the My Practice Spreadsheets folder or
in the Excel Workbook folder on the workbook CD-ROM. This workbook contains a
Home Sales-06 worksheet with a concise data table showing the recent house sales
during April and May in a small subdivision. You can use the sampling in this sales
table to practice using the AVERAGE and MEDIAN functions:

1. Select the cell range D4:D8 in the Home Sales-06 worksheet and then assign to
this selected cell range, the range name, Selling_price.

2. Position the cell cursor in cell D10 and then enter a formula there using the
AVERAGE function (in the Statistical function category in the Insert Function
dialog box) with the range Selling_price as its argument.

Use the Insert=>Name=>Paste command to insert the range name in the Number1
text box in the Function Arguments dialog box for the AVERAGE function.

3. Enter the following formula in cell E10:
=SUM(Selling_price) /COUNT (Selling_price)

As you can see, this division formula using the SUM and COUNT functions in cell
E10 returns the same value as the AVERAGE function in D10.

4. Enter a formula in cell D12 using the MEDIAN function that uses the Selling_price
range name as its sole argument.

Note the difference between the average and the median sales price as computed
by Excel in cells D10 and D12. The average selling price for a home in the sample
shown in this table is nearly $100,000 more than the median.

5. save your work in a new workbook file named Solved10-1.xls in the Chapter 10
folder inside the My Practice Spreadsheets folder and leave this file open in
Excel for the next exercise.

Finding the Highest and Lowest Values

The MAX and MIN functions compute the highest and lowest values in a cell range
or series, respectively. They take the same type of arguments as the AVERAGE and
MEDIAN statistical functions. Although they may not seem very powerful when using
them on very small samples (such as the selling prices in the Home Sales-06 work-
sheet you used in Exercise 10-1), where you can visually pick out the highest and
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lowest selling prices in an instant, they come in quite handy when dealing with
large data sets, where it would take a long time to locate these key values.

Exercise 10-2: Building Formulas with the MAX and MIN Functions

Use the Solved10-1.xls workbook you created at the end of Exercise 10-1 to practice
adding MAX and MIN functions to the spreadsheet table located on the Home Sales-06
worksheet:

1. Locate the cell cursor in cell D14 in the Home Sales-06 worksheet and construct a
formula using the MAX function with the range name Selling_price (assigned in
Exercise 10-1) as its argument to find the largest selling price in the range.

No surprise here: Excel returns $1,085,000 as the highest selling price in this
range.

2. Construct a formula in cell D16 using the MIN function with Selling_price as its
argument to find the lowest selling price in the range.

Again no surprise here: Excel returns $550,000 as the lowest selling price in the
range.

3. Insert two new rows into the sales table immediately above the row containing
the sales data for 566 Elm Street in the cell range B7:D7.

To insert two rows of blank cells in this table, select the cell range B7:D8 and
then choose Insert=>Cells and select OK when the Shift Cells Down option button
is selected.

4. Update the sales table by making the following data entries into the newly
inserted blank rows of cells:

¢ 211 River Road in cell B7, 5/15/06 in cell C7, and 495000 in cell D7
¢ 8989 King Place in cell B8, 5/23/06 in cell C8, and 1,500,000 in cell D8

Note the effect that your table edits have on the average price, high price, and
low price cells in the spreadsheet as calculated by the AVERAGE, MAX, and MIN
functions, respectively.

5. save your work in a new workbook named Solved10-2.xls in the Chapter 10
folder inside the My Practice Spreadsheets folder and then close this work-
book file.

Counting Cells

Excel includes three counting functions, COUNTA, COUNT, and COUNTBLANK. You
can use these functions to build formulas that compute the number of cells in a
particular region or worksheet that are occupied, contain numeric entries, or are blank.
The syntax of these functions is as follows:

v COUNTA(numberl, [number2l], [. . .]) to return the number of nonblank cells in
the number argument(s)

v COUNT(numberl, [number2],[ . .. ]) to return the number of cells containing
numeric entries in the number argument(s)

1 COUNTBLANK(range) to return the number of blank cells in the range argument

137
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In addition to these standard counting functions, the program includes a COUNTIF
function that works much like the SUMIF function you encountered in Chapter 9.

You can use this function to return the count in a cell range of only those cells whose
entries meet the condition you set up in its criteria argument. This function uses the
following syntax:

COUNTIF (range, criteria)

When specifying a number for the criteria argument of the COUNTIF function, you
simply enter the number or the reference to the cell that contains the number. When
specifying a comparative expression or text for the criteria argument, you must
remember to enclose the argument in a set of double quotation marks. For example,
to use COUNTIF to find the number of cells in the range E15:E45 that contain the
number 50, you would enter the following formula:

=COUNTIF (E15:E45,50)

If, however, you want to know the number of cells in this range that contain values
greater than or equal to 50, you would enter this formula:

=COUNTIF (E15:E45, ">=50")

Further, suppose that cell D10 contains the numeric entry 50 and you want to con-
struct the COUNTIF formula using this cell reference in the criteria argument rather
than the number itself. You would have to enter this version of the formula as

=COUNTIF (E15:E45, ">="&D10)

Remember from Table 5-1 that the & (ampersand) acts as the concatenation text
operator that connects text to another entry (in this case, it connects the text “>=" to
the cell reference, D10) to produce one continuous entry.

If you enclose a cell reference (such as D10 in the previous example) inside quotation
marks in the COUNTIF criteria argument, Excel interprets the cell address as a text
string to locate in the entries in the function’s range argument.

Exercise 10-3: Building Formulas with the COUNT, COUNTBLANK, COUNTA,
and COUNTIF Functions

Open the Exercise10-3.xls workbook file in your Chapter 10 folder inside the My
Practice Spreadsheets folder or in the Excel Workbook folder on the workbook
CD-ROM. This workbook contains a version of the Home Sales-06 worksheet that
you can use to practice using the counting functions:

1. Select the cell range B1:D8 in the Home Sales-06 worksheet and assign the range
name Sales_table to it.

2. Position the cell cursor in D12 and construct a formula using the COUNTA statis-
tical function with Sales_table as its argument that returns the number of cells
with entries of any kind in this range.

3. Position the cell cursor in D14 and construct a formula using the COUNT func-
tion with Sales_table as its argument that returns the number of cells with
numeric entries in this range.
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Position the cell cursor in D16 and construct a formula using the COUNTBLANK
function with Sales_table as its argument that returns the number of empty cells
in this range.

Position the cell cursor in cell D10 and construct a formula that computes the
total number of cells in the Sales_table range.

The total number of cells in the Sales_table range is equal to the number of occu-
pied cells returned by the COUNTA function in cell D12 plus the number of
empty cells returned by the COUNTBLANK function is cell D16.

Position the cell cursor in cell D18 and create a formula with the COUNTIF func-
tion that returns the number of addresses in the cell range B4:B8 of the Sales
table that have the word Street in them.

When specifying text in the criteria argument of the COUNTIF function, you can
use the * (asterisk) as the wildcard character to stand in for multiple, unnamed
characters or the ? (question mark) to stand in for individual characters, as in
“*Street” to find the addresses of any length that end with the word Street.

Position the cell cursor in cell D20 and create a formula with the COUNTIF func-
tion that returns the number of selling prices in the cell range D4:D8 of the Sales
table that are above $600,000.

Don’t forget to enclose the criteria argument with the > (greater than) operator
in a set of double quotation marks.

Enter the value 400000 in cell F3 and then format it with Currency style with no
decimal places.

Edit the formula in cell D20 so that the criteria argument immediately following
the “>” (greater than) operator refers to contents in cell F3 rather than the static
value of 600000.

When referring to a cell reference in the criteria argument of the COUNTIF func-

tion, don’t omit the & (ampersand) text operator immediately following the “>
(greater than) operator and immediately preceding the reference to cell F3.

Replace the $400,000 entered into cell F3 with $700,000.

Note that COUNTIF function immediately updates the result in cell D20 from 5 to

2 (only two entries in the range D4:D8, cells D4 and D8, have selling prices over
$700,000).

Save your workbook in a new file named Solved10-3.xls in your Chapter 10
folder inside the My Practice Spreadsheets folder on your hard disk and then
close the file.

Using the Statistical Functions in the
Analysis ToolPak Add-in

For you serious statisticians out there, the Analysis ToolPak add-in — which you first
encountered in Chapter 7 if you completed its exercises — contains a whole bunch
of extra statistical functions that may come in handy in your work. Before you can
access these supplementary statistical functions, you must install and activate

the Analysis ToolPak by selecting its check box in the Add-Ins dialog box (Tools=>
Add-Ins).
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After that, you access their functions from the Data Analysis dialog box (Tools=>Data
Analysis) shown in Figure 10-1. To use a particular function, select its name in the
Analysis Tools list box and then select OK. To get online information about the
purpose of these statistical functions, select the Help button in this dialog box.

After selecting OK, Excel opens another dialog box specific to the function you selected
in the Data Analysis dialog box. This new dialog box contains all the controls and text
boxes needed to select and fill in the function’s arguments (for help on the arguments,
select its Help button). After filling in the necessary arguments, select OK to have
Excel compute the statistical result and return it to the current cell.
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Chapter 11

Using the
Lookup Functions

In This Chapter

Doing a horizontal lookup in a data table
Doing a vertical lookup in a data table

Looking up values in a data table using the Lookup Wizard

Tle Lookup functions in the Lookup & Reference category of Excel functions are designed
to automate the process of matching values in two separate lists or tables in a work-
book and then returning a related value. For example, you can set up a price lookup table
in a worksheet where you store and update the prices for all the items your company sells.
After that, you construct formulas in a sales table using the appropriate lookup function
that match an item number entered into a field in the sales table with an item number
entered into the price lookup table. When the function finds a match between these item
numbers, Excel then copies the price associated with that item number in the price lookup
table and pastes it into the appropriate field in the sales table.

The Reference functions are primarily designed to return specific types of information
about particular cells or regions of a worksheet. This part of the Lookup & Reference cate-
gory also includes functions that create hyperlinks to different worksheets and documents
and that transpose the data in a table so that data that originally ran across the rows now
runs down the columns, and vice versa.

In this chapter, you get a chance to practice creating formulas that automate table lookup,
including looking up a single value, either across a row of a lookup data table or down one
of its columns, as well as using the Lookup Wizard to perform a lookup that uses two values
to find the matching data in a lookup data table.

Returning Single Values from a Lookup Table

The most popular of the Lookup & Reference functions are the HLOOKUP (for Horizontal
Lookup) and VLOOKUP (for Vertical Lookup) functions. The VLOOKUP function searches
vertically (top to bottom) the leftmost column of a lookup table until the program locates a
value that matches or exceeds the one you are looking up. The HLOOKUP function searches
horizontally (left to right) the topmost row of a lookup table until it locates a value that
matches or exceeds the one you’re looking up.

The VLOOKUP function uses the following syntax:

VLOOKUP (lookup_value, table_array, col_index_num , [range_lookup] )
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The HLOOKUP follows the nearly identical syntax:
HLOOKUP (lookup_value, table_array, row_index_num, [range_lookup] )
The arguments of these two Lookup functions can be explained as follows:

v The lookup_value argument designates the range that contains the values or text
to be looked up in the table.

v The table_array argument designates the range with the data table you want
looked up in the lookup table as well as the data you want returned from the
lookup table.

v The col_index_num argument in the VLOOKUP function designates the number
of the column in the lookup table (starting with 1 for the leftmost column and
increasing one each column to the right) that contains the data you want
returned to the data table.

v The row_index_num argument in the HLOOKUP function designates the number
of the row in the lookup table (starting with 1 for the topmost row and increasing
one down each row) that contains the data you want returned to the data table.

v The optional range_lookup argument is a TRUE or FALSE value that indicates
whether you want Excel to find an approximate (TRUE or argument omitted) or
exact match (FALSE) to numerical entries in the range designated by the func-
tion’s lookup_value argument.

WBER When using the VLOOKUP and HLOOKUP functions, the text or numeric entries in the
lookup column or row (that is, the leftmost column of a vertical lookup table or the
top row of a horizontal lookup table) must all be unique (no duplicates allowed).
These entries must also be arranged or sorted in ascending order; that is, alphabeti-
cal order for text entries, lowest-to-highest order for numeric entries. (See Chapter 16
for exercises on sorting data in a list or table.)

Performing a horizontal lookup

You use the HLOOKUP function when you’re dealing with a lookup table where the
data to look up is entered in the first (top) row, arranged sequentially (that is, alpha-
betically for text entries and from smallest to largest in the case of numeric entries)
by columns from left to right. Figure 11-1 shows just such a lookup table at the top of
the Jan-06 Sales worksheet — the Price Lookup Table in the cell range C3:F4.

First off, note that bakery items listed in the top, lookup row of this Price Lookup
Table are text values arranged in alphabetical order from left to right as follows:

v Blueberry muffins in cell C3

v Lemon tarts in cell D3

v Lots of Chips cookies in cell E3

v Strawberry pie in cell F3
Second, note that the price per dozen for each bakery item is listed in a correspon-
ding column immediately below in the second row of the table (cell range, C4:F4). The

order of the values in the cells in this row is dictated entirely by the order of their
associated bakery items in the row above.
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In the following exercise, you use the information kept in this Price Lookup Table to
supply the missing information to the Price/Doz column in the Daily Sales data list
below it. To do this, you construct a formula using the HLOOKUP function that
matches the bakery item listed as sold in the Item column of the data list (C7:C66)
against the items shown in the top row of the Price Lookup Table. It then returns the
price per dozen for the matched item to the appropriate cell in the Price/Doz column
in the data list (F7:F66).

Exercise 11-1: Building Formulas that Perform Horizontal Lookups in a Table

If Excel is not currently running, launch the program. Then, open the Exercisel1-1.xls
workbook file in your Chapter 11 folder inside the My Practice Spreadsheets folder or
in the Excel Workbook folder on the workbook CD-ROM. This workbook contains the
Jan-06 Sales worksheet with the Price Lookup Table and the Daily Sales data list you
need to practice using the HLOOKUP function:

1. Assign the following range names to the designated cell ranges:
¢ Item_match to cell range C7:C66

¢ Price_info to cell range C3:F4

2.
3.
4.

Position the cell cursor in cell F7 and then click the Insert Function button on the
Formula bar.

Select Lookup & Reference in the Select a Category drop-down list box, and then
click HLOOKUP in the list and select OK.

Choose Insert=oNamer>Paste and then click Item_match and select OK in the
Paste Name dialog box.

Chapter 11: Using the Lookup Functions ’43
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10.

11.

The range name Item_match encompassing C7:C66 is now listed in the
Lookup_value argument text box of the Function Arguments dialog box for
HLOOKUP.

Press Tab and then use the Paste Name dialog box to select Price_info and insert
its name into the Table_array argument text box.

Press Tab and then type 2 into the Row_index_num argument text box.

You enter 2 for this value because you want Excel to return the appropriate
prices from the second row (as you count down) of the Price_info range.

Press Tab and then type false into the optional Range_lookup argument text box.

You enter FALSE into this argument text box because you only want exact matches
between the bakery items entered into the Item_match range (C7:C66) and the
bakery items entered into the top row of the Price_info range.

Check the Formula Result shown at the bottom of the Function Arguments dialog
box. Because the first bakery item sold in cell C7 of the Daily Sales list is lemon
tarts, the price per dozen returned by the HLOOKUP function from the Price_info
table should be listed as 2.5. If this is the Formula result displayed at the bottom
of your Function Arguments dialog box, proceed to Step 8.

Select OK to close the Function Arguments dialog box and insert the formula
with the HLOOKUP function into cell F7.

Use the Fill handle on the cell cursor to copy this formula down to the cell range
F8:F66.

Check the prices returned by the copies of the original HLOOKUP formula in the
top rows of the Daily Sales data list against those shown for the various bakery
items in the Price Lookup Table. The price per dozen for the blueberry muffins
should be returned as 3.75, strawberry pie as 8.99, and Lots of Chips cookies

as 1.89.

Increase the price per dozen for Lots of chips cookies in cell E4 of the Price
Lookup Table from 1.89 to 3.89.

Note that this change to the basic price is immediately updated in all the sales
of Lots of Chips cookies in the Daily Sales data list. By using a lookup table to
supply the basic price per dozen data to this list, you only need make a single
change to a price in the Price Lookup Table in order to update every single sale
of that item in the entire data list.

Save your work in a new workbook named Solved11-1.xls in your Chapter 11
folder inside the My Practice Spreadsheets folder and then close this work-
book file.

Performing a vertical lookup

You use the VLOOKUP function when the data to look up is entered in the first (left-
most) column, arranged sequentially (that is, alphabetically for text entries and from
smallest to largest in the case of numeric entries) by rows from top to bottom. Figure
11-2 shows you just such a vertical lookup table in the form of its Tip Schedule in the
cell range B4:C103 (of which only the first 21 rows are visible in the figure).

The Tip Schedule in the Tip Lookup worksheet is arranged in two columns: Pretax
Total and Tip Amount. Because the Pretax Total column is the first or leftmost column
in this table, it contains the data to look up and match against the Food Total entered
in cell F2 of this spreadsheet. As the lookup column, you note that its values are
arranged in numerical order from smallest to largest.
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In the following exercise, you construct a formula using the VLOOKUP function that
returns the tip amount to cell F3 from the Tip Amount column of the Tip Schedule
table based on the Food Total entered into cell F2 and matched against the amounts
listed in the Pretax Total column. Note that this represents a situation where you do
not want Excel to use exact matching because the amount entered into the Food Total
cell can often fall between the whole dollar amounts listed in the Pretax Total column
of the Tip Schedule. When this happens (and you don’t specify FALSE as the optional
range_lookup argument in the VLOOKUP function), Excel returns the amount from the
row above.

Exercise 11-2: Building Formulas that Perform Vertical Lookups in a Table

Open the Exercisel1-2.xls workbook file in your Chapter 11 folder inside the My
Practice Spreadsheets folder or in the Excel Workbook folder on the workbook
CD-ROM. This workbook contains the Tip Lookup worksheet with the Tip Schedule
that you need to practice using the VLOOKUP function:
1. Assign the following range names to the designated cells and cell ranges:
¢ Food_total to cell F2
¢ Tip_table to the cell range B4:C103

When naming the Tip_table range, try using the AutoSelect feature to select the
cell range B4:C103 in a couple of clicks.

2. Position the cell cursor in cell F3 and then click the Insert Function button on the
Formula bar.

3. Select Lookup & Reference in the Select a Category drop-down list box, and then
click VLOOKUP in the list and select OK.
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4.

Choose Insert=>Name=Paste and then click Food_total and select OK in the
Paste Name dialog box.

The range name Food_total, the name assigned to cell F2, is now listed in the
Lookup_value argument text box of the Function Arguments dialog box for
VLOOKUP.

Press Tab and then use the Paste Name dialog box to select Tip_table and insert
its name into the Table_array argument text box.

Press Tab and then type 2 into the Row_index_num argument text box.

You enter 2 for this value because you want Excel to return the appropriate tip
amounts from the second column (as you count from left to right) of the Tip_
table range.

Note that you omit the optional range_lookup argument for this particular
VLOOKUP function because you want Excel to return a tip amount even when
the program doesn’t find an exact match between the amount in the Food_total
cell and the whole dollar amounts listed in the Pretax Total column.

The Formula result shown at the bottom of the Function Arguments dialog box
is a perfect example of this situation. Currently, the Food_total cell F2 contains
$9.33. When Excel matches this in Pretax Total column of the Tip Schedule, it
does not find an exact match. In this case, it returns 1.35 as the formula result,
the tip amount for a pretax total of 9.00 in row 13 of the Tip Schedule.

When you don’t use exact matching for numerical values, Excel always selects
the value from the row in the table_array argument in a VLOOKUP function or
the column in an HLOOKUP function whose value is closest but doesn’t exceed
the value specified by the lookup_value argument.

Select OK to close the Function Arguments dialog box and insert the formula
with the VLOOKUP function into cell F3.

Change the Food Total value in cell F2 from $9.33 to $87.20.

The moment you complete the edit in this cell, Excel returns a new tip amount
of $13.05 to cell F2 (this tip amount is 15% of 87.00, the nearest value in the Tip
Schedule that does not exceed the Food Total value).

Save your changes to the Tip Lookup worksheet in a new workbook named
Solved11-2.xls in your Chapter 11 folder in the My Practice Spreadsheets folder
and then close the workbook file.

Using the Lookup Wizard

The HLOOKUP and VLOOKUP functions are just fine when you only need Excel to

look up a single value in a horizontal or vertical lookup table and then return the
nearest or exact match based on that single value. Sometimes, however, you need

Excel to perform a two-way lookup, whereby the program returns a value from a data
table based on both a lookup value in its top row as well as a lookup value in its left-

most column.

When such a need arises, it’s time to call upon the Lookup Wizard. This nifty add-in

enables you to perform two-way lookups in a table without having to worry about

constructing the final complex formula with its required INDEX and MATCH Reference

functions.
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Figure 11-3 shows you a situation where you need to look up two values, the Part
Number and the Date, in order to return the Quota from the 2006 Production
Schedule table. You will use the Lookup Wizard add-in in the following exercise
to return the production quota from this table based on these two lookups.
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Exercise 11-3: Using the Lookup Wizard to Build Formulas that Perform Two-
Way Lookups in a Table
<MECD Open the Exercisel1-3.xls workbook file in your Chapter 11 folder inside the My
$ Practice Spreadsheets folder or in the Excel Workbook folder on the workbook
O CD-ROM. This workbook contains the Production-06 worksheet with the 2006
Production Schedule you need to practice performing a two-way lookup using the

Lookup Wizard add-in:

1. select the Lookup Wizard check box in the Add-Ins dialog box (Tools=>Add-Ins)
and then select OK.
Select the Yes button in the alert dialog box if you are prompted to install this
add-in.

2. Choose Tools=>Lookup on the Excel menu bar.
Excel opens the Step 1 of 4 Lookup Wizard dialog box that prompts you to indi-

cate the cell range to search including its row and column labels. In this case,
you must select the range B3:K7.

3. Select the cell range B3:K7 in the Production-06 worksheet (‘Production-06'!$B$
3:$K$7 appears in the text box) and then select the Next button.
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10.

11.

12.

The Step 2 of 4 Lookup Wizard dialog box now appears, asking you to identify by
its heading the column and the row that contain the data to look up.

Leave Apr-06 selected in the Column Label drop-down list box and Part 100
selected in the Row Label drop-down list box and then select the Next button.

The Step 3 of 4 Lookup Wizard dialog box now appears, asking you to select the
form in which the Wizard displays the result. By default, Excel just copies the
formula to a cell in the worksheet, but you can also have the program copy the
lookup parameters; that is, the column lookup value and the row lookup value
along with the lookup formula it constructs.

In this case, this latter option is exactly the one you want to use because it
enables you to change these lookup parameters in the worksheet later on and
have the lookup formula find a new result based on these new values.

Select the Copy the Formula and Lookup Parameters option button selected and
then select the Next button.

Excel displays the Step 4 of 6 Lookup Wizard dialog box, asking you to identify
the cell where you want to copy the date, 4/1/2006.

Click the text box and then select cell C12 in the Production-06 worksheet
(‘Production-06’'$C$12 appears in the text box) and then select the Next button.

Excel displays the Step 5 of 6 Lookup Wizard dialog box, asking you to identify
the cell where you want to copy the part number, Part 100.

Click the text box and then select cell C11 in the Production-06 worksheet
(‘Production-06’!$C$11 appears in the text box) and then select the Next button.

Excel displays the Step 6 of 6 Lookup Wizard dialog box, asking you to identify
the cell where you want to copy the lookup formula.

Click the text box and then select cell C13 in the Production-06 worksheet
(‘Production-06’!$C$13 appears in the text box) and then select the Finish button.

Excel returns the result 500 to the Quota cell, C13.

Position the cell cursor in cell C13 and then examine the formula Excel entered
there on the Formula bar.

Note that Excel has constructed a formula using an INDEX function with two
nested MATCH functions as its arguments. Both of these Reference functions
are needed in order to perform a two-way lookup in a table.

Change the Part Number in cell C11 to Part 102.

As soon as you change the Part Number to Part 102, Excel recalculates its lookup
formula and returns 350 to the Quota cell, C13 (you can check that this is the
correct value in the 2006 Production Schedule table above).

Change the Date in cell C12 by entering Sep-2006 in this cell.

As soon as you change the Date Number to Sep-06 in this cell, Excel recalculates
its lookup formula and returns 378 to the Quota cell, C13.

Save your changes to the Production-06 worksheet in a new workbook named
Solved11-3.xlIs in your Chapter 11 folder in the My Practice Spreadsheets folder
and then close this workbook file and exit Excel.



Chapter 12

Using the
Logical Functions

In This Chapter

Finding how the Logical functions operate
Using Logical functions to create decision-making formulas

Using Logical functions to create formulas that trap errors

Tle Logical function category is a small but powerful group of six functions (TRUE, FALSE,
IF, AND, OR, and NOT) that you can use in decision-making formulas. (A decision-making
formula is one where one set of values should be used or action taken when a particular
condition is met and another when it is not.) You can also combine them with certain
Information functions (such as ISBLANK, ISNUMBER, ISTEXT, and ISERROR) to create error-
trapping formulas that prevent Excel error values (especially #DIV/0!, #NUM!, and #VALUE!
errors) from spreading to other dependent formulas in the spreadsheet.

In this chapter, you get a chance to practice using the Logical functions in spreadsheets to
create both decision-making and error-trapping formulas.

Working with the Logical Functions

The Logical functions, as their name implies, deal exclusively with the Logical values of
TRUE and FALSE. With the exception of the TRUE, FALSE, and NOT functions (whose only
purpose is to enter the Logical values, TRUE, FALSE, and its opposite into a cell of the work-
sheet), the other three Logical functions, IF, AND, and OR, evaluate expressions entered as
their arguments as either TRUE or FALSE.

The granddaddy of all the Logical functions is the IF function, which follows this syntax:
IF (logical_test,value if_ true,value if false)

The IF function works by evaluating a comparative expression that you enter as its logical_
test argument as being either TRUE or FALSE. If the expression is found to be TRUE, Excel
then uses the value or text or executes the expression you enter as the value_if_true argu-
ment of the function. If the expression is found to be FALSE, the program uses the value or
text or executes the expression you enter as the value_if_false argument.
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When entering a number or reference to a cell that contains a number or formula
that returns a number for the value_if_true and value_if_false arguments, you simply
enter the value or cell address. When entering text for these arguments, you need to
enclose the text in a set of double quotation marks. And when entering an expression,
you enter the operands and operator or function name and arguments as you would
in any formula.

Constructing Decision-Making Formulas

|
Figure 12-1:
The Tip with
alternate
15% and
20% tip
percentages.
|

The biggest use for the IF function is performing conditional operations in a formula,
one set of operations when the IF condition expressed by its logical_test argument is
found to be TRUE and another when it is not. These decision-making formulas can

be one of two types: formulas that perform their computations using alternate values
depending upon the outcome of the condition or those that perform alternate calcula-
tions based on the outcome.

Selecting between alternate values

Figure 12-1 shows an example of the first type of decision-making formula, where
alternate values can be put to good use. The spreadsheet shown in this figure con-
tains a variation of the Tip Lookup worksheet you encountered in Chapter 11. In this
version, the Tip Schedule contains tip amounts for alternate tip percentages (15% in
column C and 20% in column D), and the input section of the spreadsheet contains a
Tip Percentage cell (G2), where the user can specify either a tip percentage of 15 or
20 percent.
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To take advantage of the alternate percentages in this revised Tip Schedule in the fol-
lowing exercise, you need to nest an IF function inside the VLOOKUP function as its
col_index_num argument. This IF function then selects the appropriate column of the
Tip Schedule to use (2 for the 15% Tip amount in column C or 3 for the 20% Tip
amount in column D), depending upon whether the Tip Percentage cell, G2, contains
15% or 20% as its data entry.

Exercise 12-1: Using the IF Function to Build Formulas that Select Alternate
Values

If Excel is not currently running, launch the program and open the Exercisel2-1.xls
workbook file in your Chapter 12 folder in the My Practice Spreadsheets folder on your
hard disk or in the Excel Workbook folder on the workbook CD-ROM. You will use this
expanded version of the Tip Lookup worksheet to practice adding the IF function to a
VLOOKUP function that selects between the 15% or 20% column of the Tip Schedule,
depending upon which percentage is entered into the Tip Percentage cell, G2:

’. Position the cell cursor in cell G2.

This Tip Percentage cell can contain only one of two entries: 15% or 20%. You
will use Excel’s Data Validation feature in this cell to ensure that it can contain no
other data entry.

2. Choose Datar»Validation to open the Data Validation dialog box.

3. Select the List option in the Allow drop-down button and then enter 15% and 20%
in the Source text box separated by a comma (with no spaces, as in 15%,20%)
before you select OK.

When you select the List as the Data Validation option, you can either select the
cell range that contains the allowable data entries in the Source text box or type
in the allowable entries.

4. Click the drop-down button that now appears on the right side of the Tip
Percentage cell, G2, and then select 20% on its drop-down menu.

5. Assign the following range names to the designated cells or cell ranges:
¢ Tip_percent to cell G2
¢ Food_total to cell G3
¢ Tip_table to the cell range B4:D103

0. Position the cell cursor in cell G4.

This is the cell where you will construct your lookup formula using the
VLOOKUP function with an IF function, as its col_index_num argument.

As you may remember from Exercise 11-2, the VLOOKUP function takes the fol-
lowing arguments:

¢ Lookup_value argument that specifies the cell containing the value you
want looked up in the first column of the vertical lookup table (the cell
named Food_total, in this case)

e Table_array argument that specifies the cell range containing the values
in the lookup table (the cell range named Tip_table, in this case)

¢ Col_index_num that specifies the number of the column, counting from
left to right, that contains the values you want returned from the lookup
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7.
8.

10.
11.

12.

13.

14.

15.
16.

table (in this case, that number is 2 when the Tip Percentage is 15% or 3
when the Tip Percentage is 20%)

Click the Insert Function button on the Formula bar, select VLOOKUP in the
Lookup & Reference category, and select OK.

Use the Paste Name dialog box (Insert->Namer>Paste) to paste the range name
Food_total in the Lookup_value argument text box and Tip_table in the
Table_array argument text box in the Function Arguments dialog box.

Now all you need is to construct a formula using the IF function in the Col_index_
num text box. The IF function inserts 2 as the column index number when the
cell named Tip_percent contains 15% as its entry; otherwise, it inserts 3. This is
how this function should appear in the Col_index_num argument text box:

IF (Tip_percent=15%,2,3)

Click the Col_index_num argument text box to put the insertion point inside it,
and then do the following:

¢ Type IF(— don’t forget the open parenthesis and make sure you don’t put
a space between it and IF.

¢ Open the Paste Name dialog box and then use it to insert the range name
Tip_percent immediately following the open parenthesis.

e Type =15%,2,3) — don’t forget the commas or the close parenthesis and
make sure that there are no spaces between any of the values.

The Formula result shown at the bottom of the Function Arguments dialog box
for the VLOOKUP function should now read $1.80 (the tip amount for a food total
of $9.33 at 20%). If this checks out, proceed to step 10.

Select OK in the Function Arguments dialog box to close it and to enter the
lookup formula in the Tip cell, G4.

Change the Tip Percentage from 20% to 15% by positioning the cell cursor in this
cell and then selecting 15% on its drop-down list.

Excel immediately decreases the tip amount in cell G4 from $1.80 to $1.35.
Increase the food total in cell G3 to 75.50.
Excel increases the tip amount in cell G4 from $1.35 to $11.25.

Type 17 in the Tip Percentage cell and then click the Enter button on the
Formula bar.

Excel beeps at you and displays an error dialog box with the message, “The
value you entered is not valid.”

Select the Cancel button and then open the Data Validation dialog box again
(Datas>Validation).

Data Validation enables you to enter an input message that the user sees when-
ever he selects the cell, as well as an error message that is displayed whenever
he tries to enter a value that is no longer allowed.

Click the Input Message tab and then, in the Input Message text box, type Click
this drop-down button and then select 15% or 20% on its drop-down menu.

Click the Error Alert tab and then, in the Error Message text box, type The entry
in this cell is limited to 15% or 20% only! Click Cancel and then select 15% or
20% on the cell’s drop-down list before you select OK.

A text box with your input message now appears next to the lower-right of
cell G2.
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17.

Click the text box with your input message and drag it up until the top of the
message box is even with the top of the Tip Percentage cell, G2, and position its
left edge so that it’s now touching the cell’s drop-down button without obscuring
any part of it.

18.

Type 12 in the Tip Percentage cell, G2, and then press Enter.

This time, Excel displays your custom error message in its error alert dialog box.

19.
20.

Select the Cancel button in the error alert dialog box to close it and restore the
current 15% entry to the cell.

Save your work in a new workbook called Solved12-1.xls in your Chapter 12
folder inside the My Practice Spreadsheets folder on your hard disk and then
close the workbook file.

Selecting between alternate calculations

In addition to selecting alternate values, you can use IF functions to perform alternate
calculations depending upon the outcome of the condition stated by its logical_test
argument. A common situation is to have Excel perform the calculation only when the
IF condition is TRUE and perform no computation when it is FALSE.

Figure 12-2 shows you an example of this situation. Here, you see a slightly different
version of the Spring Sale worksheet that you used in earlier exercises. This table
contains a Discounted column, which determines whether a furniture item is to be
discounted based on its suggested retail price listed in the Retail Price column. It
also contains a Discount Amount column, which computes the amount of the dis-
count only if the Discounted column indicates that the furniture item is eligible for
a discount.
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8 | 03-003| Arm chair 500.00 $ 500.00

9 01-240] Armoire 1,750.00 $1,750.00
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In Exercise 12-2, you will construct the necessary formulas with IF functions for this
version of the Spring Sale worksheet — one set to determine whether or not the furni-
ture item should be discounted and another set to compute the discount amount only
when the item is eligible for the discount.

Exercise 12-2: Using the IF Function to Build Formulas that Perform Alternate
Calculations

Open the Exercise12-2.xls workbook file in your Chapter 12 folder in the My Practice
Spreadsheets folder on your hard disk or in the Excel Workbook folder on the work-
book CD-ROM. You will use this expanded version of the Spring Sale worksheet to
practice constructing the formulas with IF functions needed to determine whether a
furniture item is eligible for a discount. If it is, you create formulas to compute the
discount amount and sale price:

1. Position the cell cursor in cell D4 where you build the formula that determines
whether the 36-inch round table is to be discounted.

2. Click the Insert Function button on the Formula bar. Next, double-click IF in the
Select a Function list box after selecting Logical in Select a Category drop-down
list box to open the Function Arguments dialog box for the IF function.

The determinant for eligibility for a discount is whether the suggested retail
price is greater than or equal to $1,000. In terms of the Logical_text argument
text box, you need to create this type of comparative expression using cell C4,
as in

C4>=1000
3. Select cell C4 in the worksheet and then type >=1000 before pressing Tab.

« Type “Yes” (and be sure to enclose Yes in the pair of double quotation marks) in
Value_if_true argument text box before you press Tab.

5. Type “No” (and be sure to enclose No in the pair of double quotation marks) in
Value_if_false argument text box.

The Formula result at the bottom of the Function Arguments dialog box should
be equal to Yes as the value currently entered into cell C4 is indeed greater than
1000. If this checks out, proceed to step 6.

0. Select OK to close the Function Arguments dialog box and enter the formula with
the IF function into cell D4.

7. Use the Fill handle to copy this formula in D4 down to the cell range D5:D9.

Now, you need to create a formula using the IF function that checks whether the
cell in the Discounted column contains Yes or No and then calculates the dis-
counted amount accordingly.

8. Position the cell pointer in cell E4.

« Construct a formula in this cell using the IF function that multiplies the value in
the Retail Price column by 20% if the Discounted column contains Yes; other-
wise, the formula enters 0 (zero) into the cell.

The argument text boxes in the Function Arguments dialog box for the IF func-
tion you create for this formula should contain the following values:

* D4="Yes" in the Logical_text argument text box
e C4*20% in the Value_if_true argument text box

¢ 0 in the Value_if_false argument text box
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10. Use the Fill handle to copy this formula in cell E4 down to the cell range E5:E9.

In the final table, all the furniture items except for the Side chair and Arm chair
should be discounted and have discounted amounts computed in column E.
Check your final results against those shown in the Solved12-2.xls workbook file
in your Chapter 12 folder. If everything checks out, proceed to step 11.

11. save your changes to a new workbook named Solved12-2-mine.xls in your
Chapter 12 folder inside the My Practice Spreadsheets folder and leave this file
open for Exercise 12-3.

Nesting IF functions

IF functions in decision-making formulas are great when you're dealing with situations
that only require two alternatives — one that comes into play when a certain condi-
tion exists and the other that comes into play when it does not. But what about a situ-
ation where you have more than two alternatives?

For example, in the Spring Sale worksheet you used in the previous IF function exer-
cise, suppose you still only want to discount furniture that retails over $1,000 but
want to use two different discount amounts as well: 15% for suggested retail prices
that are lower than $1,500 and 20% for suggested retail prices that are above $1,500.

To accommodate such a case, you would have to nest a second IF function within

the original one, making the second nested IF function either the value_if_true or
value_if_false argument of the original. Specifically, in for the Spring Sale worksheet
example, you would nest the second IF function as the value_if_true argument of the
original IF function. The first IF condition then tests if the furniture item is to be dis-
counted (indicated by a Yes in the Discounted column, meaning that the item’s retail is
above $1,000). If this item is found to be eligible for a discount, the second value_if_true
argument IF function determines whether it receives a 20- or 15-percent discount.

Exercise 12-3: Building Formulas with Nested IF Functions

Use the Solved12-2-mine.xls workbook file you created in Exercisel2-2 (if you don’t
have access to this file, open the Solved12-2.xls workbook in your Chapter 12 folder in
the My Practice Spreadsheets folder on your hard disk or in the Excel Workbook
folder on the workbook CD-ROM). You will use this version of the Spring Sale work-
sheet with the completed formulas in the Discounted and Discount Amounts columns
to practice using one IF function as an argument of another:

1. Position the cell cursor in cell E4 that contains the formula with the IF function
that currently computes a 20% discount when the Discounted column contains
Yes.

2. On the Formula bar, click the insertion point in immediately in front of the C in
C4 in the value_if_true argument of the IF function in this cell.

3. Type IF(— open parenthesis — and then click cell C4 in the worksheet.
The edited formula on the Formula bar should now read:
=IF (D4="Yes", IF (C4C4*20%,0)

4. Type >1500, — a greater than sign, 1500, and a comma — to complete the
value_if_true argument for the new nested IF function.
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The edited formula on the Formula bar should now read
=IF (D4="Yes",IF(C4>1500,C4*20%,0)

5. Click the I-beam mouse pointer to position the insertion point between the %
(percent sign) and the , (comma) immediately preceding 0 in this formula — be
sure not to press the — key.

6. Type , (comma) and then click cell C4 in the worksheet.
The edited formula on the Formula bar should now read
=IF (D4="Yes", IF(C4>1500,C4*20%,C4,0)

7. Type *15%) — that is an asterisk, 15% and a close parenthesis — to complete
the value_if_false argument for the nested IF function.

The final edited formula on the Formula bar should now read
=IF (D4="Yes",IF(C4>1500,C4*20%,C4*15%),0)

In essence, this edited form of the formula with nested IF function in the
value_if_true argument of the original IF function is saying

¢ Evaluate the contents of cell D4 and, if Excel finds that this cell contains
Yes as its entry, the program evaluates the contents of cell C4; otherwise, it
just enters 0 (zero) in the current cell.

e If Excel does end up evaluating the contents of cell C4, the program checks
to see if this cell contains a value greater than 1,500. If the cell does, it then
multiplies this value by 20 percent; otherwise, the program multiplies the
value in C4 by 15 percent.

8. Click the Enter button on the Formula bar and then copy this edited formula
down to the cell range E5:E9.

In this version of the Spring Sale table, the Hutch and Armoire are now dis-
counted 20 percent, the 36-inch round table and 72-inch dining table are both
discounted 15 percent, and the Side and Arm chairs still receive no discount at
all. Check your final results against those shown in the Solved12-3.xls workbook
file in your Chapter 12 folder. If everything checks out, proceed to step 9.

9. Save your changes to a new workbook named Solved12-3-mine.xls in your
Chapter 12 folder inside the My Practice Spreadsheets folder and then close
this file.

Constructing Error-Trapping Formulas

Sometimes, you know ahead of time that certain error values are unavoidable in a
worksheet as long as certain data entries are missing. The most common error value
that gets you into this kind of trouble is the #DIV/0! error value. This error value
appears not only when the divisor in a division formula is actually 0 (zero) but also
when the divisor refers to an empty cell (which carries the numerical equivalent) in
which you haven’t yet had an opportunity to make any data entry (as when generat-
ing a new workbook from an Excel template file).

Fortunately, you can use the IF function to suppress the appearance of such error
values in formulas. When you do this, you not only get the benefit of not having to
look at them (there is, after all, nothing subtle about them), but you also ensure
that they don’t spread to any other parts of the spreadsheet containing dependent
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formulas. This means that in suppressing the display of error values in their original
formulas, you also end up trapping them in their original cells.

When using IF functions in the construction of error-trapping formulas, you often use
them in combination with some of the functions in the Information category, the most
versatile of which is the ISERROR function. This nifty little function evaluates the cell
reference you specify as its value argument and returns TRUE if the cell contains any
of those pesky error values #N/A, #VALUE!, #REF!, #REF!, #DIV/0!, #NUM!, #NAME?, and
#NULL) and FALSE if it contains any other kind of entry. You can use its little brother
function, ISERR, to test for all error values in a cell, excluding #NA, for Not Available,
which some users do not consider an error value per se.

Figure 12-3 shows you a situation where you need to construct an error-trapping for-
mula. Here, you see an empty version of the Production Schedule worksheet that is
on its way to being saved as an Excel template file. Before that can happen, however,
you would need to suppress all those #DIV/0! error values in the cell range B9:J9 until
you begin entering the production quota figures for the particular months. (The error
values appear because cell K7 with the grand total that it used as the divisor in their
formulas contains 0 (zero).) The way to do that, as you will see in Exercise 124, is by
constructing a formula that traps this error in the original formula and all its copies.
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Exercise 12-4: Building Formulas that Trap Error Values

<WECD Open the Exercise124.xls workbook in your Chapter 12 folder in the My Practice
$ Spreadsheets folder on your hard disk or in the Excel Workbook folder on the work-
book CD-ROM. You will use this empty version of the Production Schedule worksheet
to practice constructing error-trapping formulas using the IF function:
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1.

10.
11.

Position the cell pointer in cell B9 that contains the original division formula.

You need to edit this formula by adding an IF function that inserts 0 (zero) rather
than the #DIV/0! error value in the cell if cell K7 is empty or contains 0 (zero) as
is currently the case.

Press F2 to place Excel in Edit mode and then press the « key to position the
insertion point between = (equal to sign) and the B in B7.

Type IF(— open parenthesis — and then select cell K7.
The edited formula in the cell and on the Formula bar should now read:
=IF (K7B7/SKS7

Press F4 