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Introduction

oomla (we're dropping the final exclamation point from Joomla! in the

text of this book, following the convention in other books and making
this book more readable) gives you total control of your Web site — the
layout, the navigation menus, the text, everything. And this book gives you
total control of Joomla.

Today, users are demanding more from Web sites. It’s not enough to have
static text on your Web site — not if you want a steady stream of visitors.
You’ve got to update your pages continually, making your site fresh and
keeping it new. You've got to have an attractively, professionally formatted
site. You’ve got to have tons of extras: polls and e-mail signups and news-
flashes and menus, and more.

Who can afford the time to maintain a site like that and write the content too?

Now you can. Content management systems (CMSes) like Joomla are coming to
the rescue, letting people put together spectacular sites with very little work.

Want to publish a new article on your site? No problem. Want to let users
rate your articles with a clickable bar of stars? Also no problem. Want to link
your articles with a cool system of drop-down menus? No trouble. Want to
let people log into your site to gain special privileges? No worries. Want to let
users search every page on your site? Yep — no problem at all.

CMSes are all the rage on the Internet these days: They give you the complete
framework of a Web site and allow you to manage it professionally with a few
clicks. All you have to do is provide the content — such as text, images, and
videos — that you want to display. Using a CMS is as easy as typing in a word
processor (in fact, one way to think of CMSes is as word processors for the
Web) but a lot more fun.

The CMS of choice these days is Joomla, which is what this book is all about.
Joomla is free and dramatically powerful. Want a site that looks as though a
Fortune 500 company is behind it? Coming right up in just a few minutes. You're
going to find that Joomla is not only free but also remarkably trouble free.

In the old days, you had to build your own site from scratch using HTML.
These days, Joomla takes care of all the details for you, allowing you to con-
centrate on the content of your site instead of struggling with the details of
how that content is presented.

Welcome to the new era.
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How This Book Is Organized

Joomla is a big topic because Web-site possibilities are endless. Here are the
various parts you're going to see coming up.

Part I: Getting Started with Joomla

This part is where you get your start with Joomla. We give you an overview of
Joomla as it’s been put to work in Web sites both nationally and internationally.

You also see how to get Joomla (for free) and install it. This process can take
a little doing, so Chapter 2 is devoted to the topic.

Finally, we show you how to jump right into Joomla, customizing the home
page (called the front page on Joomla sites) by installing your own logo,
adding text, modifying navigation menus, and more.

Part II: Joomla at Work

This part gives you the skills you need to put Joomla to work every day. We
start this part with a chapter on those most basic Web-site skills: creating
your own pages and customizing them with text and images, laying out their
content as you want.

In this part, you also see how to work with menus, because menu items are
very powerful in Joomla. Believe it or not, a Web page can’t even exist on a
Joomla site unless a menu item points to it — and menu items actually
determine the layout of the Web pages they point to.

Part [1I: Working with Joomla
Modules and Templates

Joomla comes packed with dozens of built-in modules that give you
extraordinary power. These modules include search, polls, menus, newsflashes,
and banners. This part is where you see how to use all the modules that
come with Joomla.

Part III also looks at how to work with Joomla templates. Templates create the
actual layout of your pages: what goes where, how modules are positioned,
where the page content is displayed, what images and color schemes are used,
and more. Although Joomla comes with only a few templates, thousands more
are available on the Internet.
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Part IU: Joomla in the Real World

This part takes you into the real world, dealing with real people. Joomla
supports eight levels of users, and in this part, we show you how to manage
them.

We also take a look at how to get users to come to your site through search
engine optimization — the process of making your site friendly to search
engines to get a high ranking. This topic is a big one in Joomla.

Finally, we discuss how to extend Joomla with extensions. Although the
software is very powerful out of the box, thousands of extensions are just
waiting to be installed — everything from games to complete shopping-cart
systems, from site-map generators to multilingual content managers.

Part U: The Part of Tens

In Part V, we list ten top Joomla extensions, ten places to get Joomla help
online, ten top sources of Joomla templates, and ten places to find Joomla
tutorials.

Foolish Assumptions

We don’t assume in this book that you have a lot of Web-site design
experience. You don’t need to know any HTML or Cascading Style Sheets
(CSS) code to read and use this book.

We do assume that you have a Web site and that you can upload files to it,
however. You're going to need that skill to create a Joomla site, so if you're
unfamiliar with the process of uploading files to your Internet service
provider, ask your provider’s tech staff for help.

That’s all you need, though. Joomla takes care of the rest.

Conventions Used in This Book

Some books have a dozen dizzying conventions that you need to know before
you can even start. Not this one. All you need to know is that new terms are
given in italics, like this, the first time they’re discussed.
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Icons Used in This Book

<® You'll find a few icons in this book, and here’s what they mean.
This icon marks an extra hint for more Joomla power.
Q,N\BER

This icon marks something you should remember to make sure you're getting
the most out of Joomla.

This icon means that what follows is technical, insider stuff. You don’t have to
read it if you don’t want to, but if you want to become a Joomla pro (and who
doesn’t?), take a look.

This icon warns you of things to be super-careful about!

What Vou're Not to Read

You don’t have to read some elements if you don’t want to — that is,
Technical Stuff elements. Technical Stuff paragraphs give you a little more
insight into what’s going on, but you can skip reading them if you want to.
Your guided tour of the world of Joomla won'’t suffer at all.

Where to Go from Here

You're all set now, ready to jump into Chapter 1. You don’t have to start
there, though; you can jump in anywhere you like. We wrote the book to
allow you to do just that. But if you want to get the full Joomla story from the
beginning, start with Chapter 1, which is where all the action starts.
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In this part . . .

Fis part is where you begin putting Joomla to work.
First, we give you an overview of Joomla as it’s used
today around the world. Then we show you how to get
and install Joomla — or how to get other people to do the
work for you (on pay sites)!

Finally, we dig into Joomla by helping you master the
home page of any Joomla site — the front page, in Joomla
lingo. You see how to add your own text to the front page,
change the front page’s logo, sling the menu items around,
and more.




Chapter 1
Essential Joomla

In This Chapter

Discovering Joomla

Viewing some example sites

Knowing what content management systems do
Finding out why Joomla is so popular

Preparing to use Joomla

' he head Web designer walks into your sumptuous office and says, “We
landed the MegaSuperDuperCo account.”

“That’s good,” you say.

“They want you to design their new Web site.”

“That’s good,” you say.

“They want to use a CMS.”

“That’s bad,” you say.

“What’s the problem?” the head Web designer asks.

You shift uncomfortably. “Well, I have no idea what a CMS is.”

The head Web designer laughs. “That’s no problem. It’s a content manage-
ment system. You know — like Joomla.”

“Like whomla?” you ask.

The head Web designer tosses a folder on your desk. “Take a look at these
sample sites. Joomla provides an easy framework for managing the content of
your Web site. You type in the content, and Joomla takes care of displaying it
for you.”
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You pick up your cup of coffee as the head Web designer leaves and start
leafing through the pages. Some of the Web sites are snazzy. Then you turn
to your computer and start entering URLs. Welcome to Joomla!

What Joomla Can Do for You

As the head Web designer said, Joomla is a content management system
(CMS), which means that after you set the site up, you (or your clients) are
responsible only for entering text and figures. Joomla arranges the content,
makes it searchable, displays it, and generally manages the Web site. You
need little or no technical expertise to create and manage your own sites.

Setting up a cool site from scratch is not easy — especially if you want to
keep that site updated. A person who runs a newspaper site with about

6,000 visitors a day once came to us utterly exhausted. It turned out that he
was formatting his entire site from scratch, using HTML, which meant that he
had to get up at five every morning to enter the news stories in HTML tables
and format them for his Web site. He still had his day job (he wanted to quit,
but the news site’s advertising was just ramping up) and found that he was
working a total 14 hours every day.

Joomla was the answer for him. Now all he has to do is copy and paste the
stories into Joomla’s Article Manager and click a few options. The stories are
published — no fuss, no muss.

Sample Joomla Sites

A great way to get to know Joomla is to take a look at what it’s capable of,
which means taking a look at some Joomla-powered sites. The following
sections introduce a few examples.

City of Longwood (Florida)

First, check out the City of Longwood Web site at www.longwoodfl.org
(see Figure 1-1). The home page has a navigation bar of drop-down menus
across the top and a menu of quick links on the right, some nice photos, a
custom logo, and even a search box.

The site is well balanced, giving the impression of professionalism, and it’s
powered by Joomla, which is operating behind the scenes. You can'’t tell just
by looking that the content of the page — the text, photos, and menus — is
actually stored in a database. Joomla handles all the details.
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|
Figure 1-1:
The official
city Web
site for
Longwood,
Florida.
|
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welcome to the City of Longwood website. This site is designed for simplicity and service,
whether yau are trying to find City Hall, contact one of aur departments, or download a
City Code or meeting agenda, it is all here. We provide information regarding our
Recreation Events. as well as stories to keen vou informed of the events takina place in
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NZMac.com

Another Joomla-powered site is NZMac.com, which caters to the New
Zealand Macintosh community, at www .nzmac . com (see Figure 1-2).

This site is another good one, with a top menu bar, a login box, a Main Menu
box, and even a Recent Topics box. This site is also powered by Joomla, even
though it looks different from the City of Longwood site. This difference is
one of the strengths of Joomla: It’s easy to customize.

Royal Oak Public Library

Now take a look at www . ropl . org, the Royal Oak (Michigan) Public Library
site (see Figure 1-3).

This site is another well-designed one, with plenty of fresh content. Joomla
excels at keeping site content up to date and makes the process easy.

Jenerate and Everything Treo

Two other good examples are Jenerate.com at www. jenerate.com (see
Figure 1-4) and Everything Treo at www.everythingtreo.com.

All these Web sites look professional, and they also look different. Yet they
all use Joomla as their content management system. So just what is a CMS,
and how does it work?

9
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All about Content Management Systems

When the Web was young, static Web pages were all that anyone needed.

These pages could be hand-entered in HTML for display in a browser, like this:

Browser
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That kind of page served its purpose well for small sites. It gave people a Web
presence and allowed them to display some images or maybe even add a
little JavaScript to bring the page to life.

But as the Web grew and pages got larger and larger, people discovered

an inherent problem: They had to mix the HTML that handled the visual
presentation in a browser with the data that was displayed. This mix made
Web pages hard to maintain and update, because site owners were working
with both text data and HTML.

Good: Web pages with CSS

To handle this issue, Web designers created Cascading Style Sheets (CSS).
CSS became primarily responsible for presenting the data in a Web page,
although that page was still written in HTML, as follows:

HTML || €SS |

Now the presentation details were separated from the formal HTML structure
of a page — tags such as <html>, <head>, and <body>. But the actual content
of the page was still wrapped up in the HTML; site owners had to format

the content by putting in the HTML tags. In other words, the addition of CSS
removed the presentation details from the rest of the Web page but hadn’t
yet separated the content from the HTML.
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That situation was a problem for nontechnical people, who didn’t want to
have to fit their text into HTML tags. After all, when someone writes a book
report, he doesn’t have to worry about enclosing each paragraph in <p></p>
elements, or styling text with <div> or <span> class elements. That’s where
CMSes came in.

Better: Dynamic Web pages via CMS

The whole idea of a CMS is to separate as much of the content as possible
from the presentation details, which means that you don’t have to embed
HTML tags in the content you want to display. The CMS does all that for
you. You just have to write your Web site’s content, much as you would in a
word processor. The CMS adds the CSS (from the Web-site templates you’'ve
decided on) and creates the actual HTML that goes to the browser, like this:

Content || CSS |
from templates |

cMS |
generates the HTML |

13
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In this scenario, you're responsible for only the content of your Web site; the
CMS handles all the presentation details. That’s the way things should be.
Content should be king.

The upshot is that you end up writing what you want to say on your Web
site and format it as you like, making text italic, large, small, or bold, just as
you’'d see in a word processor. The CMS takes what you write and displays
it in a browser, using the Web-page templates you've selected and making
hand-coded HTML and CSS obsolete.

Pretty cool, eh?

Reasons to Choose Joomla

The CMS of choice these days is Joomla. When we wrote this chapter in the
summer of 2008, Wikipedia listed 86 free and open-source CMSes (http://
en.wikipedia.org/wiki/List_of_content_management_systems),
and Joomla was the most popular of them in terms of number of installations.
A Google search on content management system, also done in the summer of
2008, returned Joomla first (following two generic Wikipedia articles), and

a Google search on Joomla produced a mere 101 million hits — making this
CMS more popular than apples (50.6 million hits) and oranges (20.1 million
hits) put together.

Loyal users

What makes Joomla so popular? One reason is that it’s free — but you can
find dozens of free CMSes. Another reason is that it’s been around for a long
time — but dozens of other CMSes have been around for years as well.

No, the real reasons for Joomla’s popularity are its reputation and loyal user
base, both of which it has earned. All over the world, you'll find dedicated
Joomla people who have created a very strong community. That community
in turn has created thousands of items to extend Joomla — templates,
components, modules, plug-ins, and so on — just waiting for you to use. This
thriving community also specializes in providing help to novices.

Ease of use

Joomla is super-powerful, easy to use, and loaded with tons of extras
(and even more tons of extras are available for download). Using Joomla
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makes creating a professional Web site nearly as easy as printing a word
processing document.

Minimal learning curve

Although Joomla involves a learning curve, after you master a few basic
skills, you're up and running. The technical expertise you need is minimal
compared with the requirements of other CMSes.

Other advantages

Following are some other advantages of Joomla:

v Intuitive interface and management panel

v What-you-see-is-what-you-get (WYSIWYQ) editing

v Rich formatting capabilities

v Thousands of downloadable page templates

v Full text searches

v Plug-ins for commercial sites, including complete shopping carts
v Search-engine optimization features (still rare in CMSes)

v Scheduled publishing

Where to Jump into Joomla

The main Joomla site is www . joomla.org (see Figure 1-5). This site is where
you’ll get your copy of Joomla; it’s also your source for downloads and a
great deal of help.

When you install Joomla, you get the default Web site shown in Figure 1-6,
which is populated with all kinds of sample content.

Our job in this book is to help you understand and customize what you see in
this figure so you can create stunning Web sites.
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|
Figure 1-5:
The official
Joomla Web
site.
|

|
Figure 1-6:
The default
appearance
of a Joomla
site.
|
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Chapter 2
Getting and Installing Joomla

In This Chapter
Downloading and installing Joomla
Putting Joomla on an ISP’s server
Putting Joomla on your own computer

Getting acquainted with your site

' his chapter is all about installing Joomla. You have two main ways to do
this: on remote hosts like Internet service providers (ISPs) and on your
local machine. We describe both methods in this chapter.

Installing Joomla on an ISP server requires some work with a File Transfer
Protocol (FTP) client like FileZilla, CuteFTP, or even Internet Explorer. You
have to upload the Joomla files to the ISP server, configure MySQL on that
ISP, and then install Joomla. Not all Web hosts are capable of running Joomla;
you also have to have PHP support, as described in this chapter.

Installing Joomla on your own computer is a good idea if you're going to be
doing a lot of Joomla development; you can save a lot of time waiting for a
Web server to respond over the Internet to everything you do. And fine-
tuning your site is much easier if you have a local installation of Joomla as
well as a remote one. In this chapter, you see how to set up a Joomla instal-
lation on your computer as well as remotely. Take your pick: online installa-
tion, offline installation, or both.

The first step in the process is getting Joomla itself.

Getting Joomla

You can get Joomla free at www. joomla.org. To get your copy of the pro-
gram, click the Download Joomla button in the bottom-right corner of the
home page.
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Downloading the software

Joomla is distributed as a compressed file, and the name reflects the version
number — something like Joomla_1.5.6-Stable-Full_Package.zip.
The version number changes often to reflect small upgrades.

To work with the examples in this book, make sure to download Version 1.5
or later.

If you’re downloading Joomla to a Windows machine, click the ZIP link on the
download page. Your browser asks whether it should open or save the . zip
file. Choose the Save option, and save the . zip file to your hard disk in a
directory named something like c: \ joomla.

If you're using an operating system other than Windows, click the Download
Other Joomla 1.5.x Packages link; then select the appropriate tar.bz2 or
tar.gz file. (Your choice depends on your system.) When your browser asks
whether it should save or open the file, choose the Save option, and save the
compressed file to your hard disk.

The actual download is surprisingly small — just 6MB or less. A lot of func-
tionality is packed into that small package, and to unleash it, you have to
uncompress it.

Unzipping the software

Use your favorite uncompression utility, such as WinZip for Windows (www .
winzip.com/index.htm), to extract all the files inside the compressed down-
load. Joomla opens as a bunch of directories and files, as you see in Figure 2-1.

We’re not going to describe in tedious detail what each directory contains,
because Joomla handles the details for you. Besides, we rarely work with the
directory structure directly in this book (and when we do, we tell you exactly
which directory you need to work with).

Checking minimum requirements

You can install Joomla online (on an ISP server) or offline (on your own
machine), but either way, you have to meet the minimum Joomla require-
ments so that you can actually run the program.

Online requirements

If you're installing Joomla on an ISP server, check out the minimum Joomla
requirements listed in Table 2-1. You need support for the PHP scripting



Chapter 2: Getting and Installing Joomla

language MySQL (future versions of Joomla may support other database
systems) and a Web server such as Apache.

<P You can check with your ISP to see whether it meets the minimum system
requirements, but finding out can be difficult at times: ISPs often don’t make
public the version of their installed software. The easy way is to just go ahead
and try to install Joomla; the second step of the installation process (see
“Doing the preinstallation check,” later in this chapter) tells you whether your
host meets the minimum requirements.

File Edit “iew Favorites Tools  Help

Q Back ~ - search Folders x ) m-
Address | &S c:\soomia v a Go |
MName Size | Type ~
|\ administrator File Folder
|Zicache File Folder
jcomponents File Folder
\images File Folder
| hincludes File Folder
|hinstallation File Falder
ilanguage File Folder
ilibraries File Faolder
I logs File Falder
| _media File Folder
_amodules File Folder
\Zplugins File Folder
| hitemplates File Folder
IZtmp File Folder
'Dxmlrp: File Folder
CHANGELOG.php Z8KB PHF File
!ﬂ configuration, php-dist 4 KB PHP-DIST File
@ COPYRIGHT.php ZKB PHP File
s || = cREDITS.ohp 13KB  PHP File
[Z] hkaccess bxt 3KB  Text Document
Figure 2_1: @lndexz‘php 1KB PHF File
@] index.php 3KB PHPFile
Joomla @INSTALL.php SKB  PHF File ~
unzipped. |£. _. &
34 objects 16.7 MB f My Computer
|
Table 2-1 Minimum Joomla Requirements
Software ~ Minimum Recommended  Latest Web Site
Version Version Options
PHP 43.10 52+ 5.x series www . php . net
MySQL 3.23.x or 41x+ 5.x series http://dev.
later mysqgl.com/
downloads/
mysgl/5.0.html
Apache 1.3 or later 2X+ 2.2 series http://httpd.

apache.org
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Don’t use PHP 4.3.9, PHP 4.4.2, or PHP 5.0.4; these versions have bugs that
interfere with the installation of Joomla. A problem also occurred with Zend
Optimizer Version 2.5.10 for PHP 4.4.x, so avoid it as well.

Offline requirements

You can install Joomla on Linux, Windows, and Mac OS X machines.
Although the recommended Web-server software is Apache, you can also use
Microsoft’s Internet Information Services (1IS), which many Windows users
already have installed in Windows XP and Vista. In this book, however, we
stick with Apache.

Excellent — you’ve got your own copy of Joomla, you've met the require-
ments, and you're ready to install. The next step is finding a place to install
the software. We start with installing on a host server; later in the chapter,
we show you how to install Joomla on your own computer.

Installing Joomla on a Host Server

WMBER
@ﬁ
&

\NG/
V?‘“

Most ISPs that give you access to PHP and MySQL can run Joomla.

In this section, we show you how to install Joomla on a Joomla-friendly ISP;
in this case, we’ll use Go Daddy (www.godaddy . com), which meets all the
minimum Joomla requirements. We're not particularly recommending Go
Daddy, but setting up an account with this host takes only about five
minutes.

Make sure when you set up your account that it’s a Linux account, not a
Windows server account. Joomla doesn’t run on Windows servers.

To be able to upload files, the best option is to get your own domain name,
which you can do while signing up with your ISP. For this example, we chose
the (not exactly inspired) domain www.myjoomlal23.com.

After creating your account, log in with your username and password. If
you're using Go Daddy, your next step is choosing My Hosting Account
from the Hosting & Servers drop-down menu at the top of the page and then
selecting your account in the My Account page.

Now it’s time to upload the Joomla files you unzipped to your host’s server.

Go Daddy will actually install Joomla for you. How’s that for service? This
offer has two small drawbacks, however. First, the host is usually a minor
version behind the current one on the Joomla site. Second, and more
annoyingly, Go Daddy installs the software in a directory named Joomla; by
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|
Figure 2-2:
Connecting
to your site
via FTP.
|

default, the directory has to be reflected in the URL, so you’ll be left using a
URL like www . myterrificsite.com/joomla for your main page instead

of just www.myterrificsite.com. You can get around this problem with
scripting and/or a more advanced Go Daddy account, but for purposes of this
book, we show you how to do your own installation on the host server.

Uploading the Joomla files

Next, you've got to upload the Joomla files to your host. For this process, you
use a File Transfer Protocol (FTP) application of the kind you use to upload
ordinary HTML pages to a Web site.

Many FTP applications can upload files to a Web server. For the example in
this section, we use FileZilla (www . uberdownloads.com/software/ftp-
clients/filezilla.html).

To upload your Joomla files to the host server with FileZilla, follow these
steps:

o

. Choose File=>Site Manager to open the Site Manager page.
. Click the New Site button.

W N

. In the resulting page, enter the site name.
For this example, type myjoomlal23.com.
4. Enter your FTP username and password; then click Connect.

You connect to your site (see Figure 2-2).

[Z FileZilla - Connected to myJoomlai 23 (myjoomlal23.com) g@|@
File Edb Transfer View Queus Server Help
B8 - |[B e Q‘ & ?
Address: | User Password: Fort: [ Quickgannect]+
Fiesponse: 226-Options: -2 -/ &
[Fiespanse: 226 44 matches otal
Status: Directary lising successtul
Command ]
Response: 350 Restarting at 0
Conmand
Response: 200 TYPE is naw 4GCII ]
Local Site: | C:\Joamla\ v [ Remote Site:[E v
-3 Joomla =] Filename ¢ Filesize  Date Time: Pemissions ]
# Joomla2 Ll =
Filename ¢ Filesize | Filetype Last M A | |5 _db_backups 0B/15/2008 07:46  drvwr-xrx
@. ([ administrator 08/14{2008 1453 drwsrorx
() adhiristrator File Folder siasizt— |Zicache 08/14{2008 1335 drwwarorx
Ccache File Folder siesjzt | CEhcomponents 061142008 1345 drwwraex
) components Filee Folder Si23i20 Chimages 08/14/2008  13:47 drywser-r-x
Chimages File Folder sizyzt [ (Cdincudes 08/14{2008 1349 drwsrxrx
(Cincludes File Falder sieaizt | Chinstallation 08/14{2008 1354 drwwarorx
(Cinstallation File Folder Sf23f20 language 08[14j2008 13:56  drwr-xr-x
Clanguage File Folder sizaiat | | Dlibraries 061142008 1411 drwwsrurx
i Es i | ess 08/14{2008 14:11  drwsrxrx @
15 Folders and 13 files with 17552557 bytes, 19 Folders and 23 files with 11526412 bytes,
Local Filenarme: Size Direction  Remote Filename Host Skatus
Ready I " Quewe; Dbytes @ @
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5. In the left pane, select the directory that contains the Joomla files
you’ve uncompressed, and in the right pane, make sure that the host
server’s root directory is selected.

The root directory is indicated by a forward slash (/).
6. Select all the Joomla directories and files in the left pane, and drag
them to the right pane to upload them to your ISP’s server.

Uploading all these files takes some time, so grab a cup of coffee.

When you’ve uploaded all the Joomla files and directories, the next step is
preparing MySQL.

Setting up MySOL

When you install Joomla, it expects MySQL to be ready for it to use, so in this
section, you get MySQL ready for Joomla.

ISPs usually have only one MySQL installation that everybody shares, so you
may need to set up a unique username and password to avoid interfering with
anyone else on the host server. If you install Joomla on your own machine,
you also install your own version of MySQL — a considerably easier process,
as you see later in this chapter.

Creating the database

The first step in setting up MySQL for Joomla is creating the database. We
show you how the process works for the Go Daddy account we used earlier
in this chapter; adapt the process for your own ISP.

To create the database in Go Daddy, follow these steps:
1. On the home page, enter your username and password in the login

boxes.

2. Choose My Hosting Account from the Hosting & Servers drop-down
menu at the top of the page.

The My Account page opens.

3. In the Hosting section, click the Manage Account link (see Figure 2-3).
The Hosting Control Center page opens.

4. Click the Databases bar to expose a MySQL icon (see Figure 2-4).

5. Click the MySQL icon.

The database summary page opens (see Figure 2-5).



Chapter 2: Getting and Installing Joomla 23

|
Figure 2-3:
The Manage
Account
link.

Figure 2-4:
MySQL icon.
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6. Click the Create Database button.
The Create Database page opens.
7. Enter a MySQL username.

For this example, we use JoomlaDB_Online, but you need to choose a
different username to follow along, because MySQL usernames in Go
Daddy must be unique.

8. Enter and reconfirm the password you want to use for MySQL access,
as shown in Figure 2-6.
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Figure 2-6:
Entering
MySQL user
information.
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|
Figure 2-7:
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Daddy
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database
pending.
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9. Click OK.
A new database summary page opens (see Figure 2-7).

Notice that the Status column reads Pending Setup. You have to wait
until that column reads Setup to use the database; you can keep check-
ing by refreshing the page in your browser. This process usually takes
ten minutes or so, but on busy days it can take a couple of hours.
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Figure 2-8:
Find infor-
mation
about the
new
database.
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Collecting database details

When your database is set up, you're almost done. You just need to get some
details on the database to give Joomla when you install it. Again, we use the
Go Daddy example in this section; adapt the procedure for your own ISP.

When your database is ready to use, click the pencil icon in the Action

column (refer to Figure 2-7). The Database Information page opens (see
Figure 2-8).

i Hosting Control Center - Microsoft Internet Explorer [ [=1E3]
s
Ll
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database. You can editthe Host Name: pd1mysqll 41.securesenvernet
description for this database or !
cthange the password associated Database Name: JaomlaDB_Online
with it by using the huttons in the Database Version: 4.1
menu bar. Description: JoomlaDB_Online
User Name: JaomlaDB_Online
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3 | B
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Record this information from the database information page:

v Status

»* Host name

v Database name
v Database version
v Description

v User name

Note in particular the host name; you have to give it to Joomla when you
install.

You've set the stage. Now it’s time to install Joomla itself.
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3

Installing the Joomla software

Installing Joomla involves seven steps:

. Language selection
. Preinstallation check

. License acceptance

. FTP configuration

1

2

3

4. Database connection
5

6. Main configuration

7

. Finalizing

Here’s how the process works: When you copy the Joomla files to the host
server, you copy a file named index . php, written in the PHP online program-
ming language. When you navigate to the directory containing index.php,
that file runs, starting the installation. The primary job of the installation actu-
ally is to write a file named configuration.php that runs from then on,
starting Joomla whenever you navigate to the directory where you installed
the program. The configuration.php file stores the answers you give
Joomla during the installation process.

You can find the official Joomla installation manual online at http://
help.joomla.org/content/section/48/302/. But an even better set
of installation instructions is at http: //dev.joomla.org/content/
view/2013/93/.

Selecting the language
The first of the seven steps is selecting a language. Follow these steps:

1. Navigate to your site on the ISP’s server (for the example in this chap-
ter, www.myjoomlal23.com).
You see the first Joomla installation page (see Figure 2-9).

One of the big attractions of Joomla is that it’s international, with many
languages available. Surprisingly, however, only British English is avail-
able — not American English.

2. Select the only English option: en-GB - English (United Kingdom).
3. Click the Next button.
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2 Joomla! Web Installer. - Microsoft Internet Explorer @
Fle Edt View Favortes Took Help 7
Qback - O - XN Rt Poearch FrFaveres @ | 2- 2 @l DB D3
Adiress | @] myjoomla desx.php v B o ks »
~
Installation
Steps Choose Language next ()
1:Language
Select Language
2: Pre-nstallation Check Please select the Language to use during the Joomla!
installation steps.
3:License B0 Esperanto
88-E5 - Spanish (Espafiol internacional)
5 8U-ES - Baggue (Euskara estandarra)
& Database fa-IR - Persian( e )
fi-F| - Finnish (Suomi)
5:FTP Configuration ir-FR - French (Fr)
he-IL - Hehrew (lsrael)
6 : Configuration hr-HR - Croatian {Hr}
hu-HU - Hungarian (Magyar)
7+ Finish it-IT - talian (taly)
el ja-JP - Japaness(JF)
I ko-KR - Kaorean (Republic of Korea)
o-LA - Lao (NND) &
- . LT - Lithuanian
Flgure 2-9: beL - Latvian
= nb-NQ - Morsk bokm3l {Nonway)
The Choose [ nl-HL - Nederlands (NL-BE)
pl-PL - Polish (Poland) &
La nguage pt-BR - Portugués (Brasil) v
page. v
— [0 L
Doing the preinstallation check
Clicking Next in the Choose Language page navigates you to the next page,
Pre-Installation Check (see Figure 2-10).
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A Joomla installation involves a lot of technology — Web server, FTP, MySQL,
PHP, and so on — and it would be a big pain to have to track down the cor-
rect settings of all those components from your ISP and check them against
the minimum requirements in the Joomla documentation. No worries. Joomla
looks up those items for you during the preinstallation check. Make sure that
all items in the top pane on this page read Yes (if you don’t see Yes, ask your
ISP’s tech staff about it):

v PHP Version >=4.3.10

v Zlib Compression Support

v XML Support

v MySQL Support

v MB Language Is Default

v MB String Overload Off

V¥ configuration.php Writable
It’s particularly important to make sure that configuration.php is writable,
meaning that the file can be created and written on your server to store your
configuration when you start Joomla from now on. If not, you need to change
the permission setting of the folder on the host server where you copied the

Joomla files. An FTP application lets you change permissions; check with your
ISP for the best setting.

This page also displays a list of recommended settings. If you're installing
Joomla on an ISP’s server, you don’t have a heck of a lot of choice about
these settings, because they’re made by the ISP’s tech staff. Following are the
settings we recommend for the example in this chapter:

Setting Actual Recommended
Safe Mode Off Off
Display Errors On Off
File Uploads On On
Magic Quotes Runtime Off Off
Register Globals Off Off
Output Buffering Off Off
Session Auto Start Off Off

Everything agrees except the Display Errors setting for PHP, which most ISPs
set to On.

If you want to change the settings in this page, you can click the Check Again
button and make your changes, but we recommend starting the installation
over again instead.
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When you're satisfied with the preinstallation check, click the Next button.

Accepting the license

Clicking Next in the Pre-Installation Check page takes you to page 3 of the
installation process: the License page.

Joomla uses the GNU general public license (a popular software license cre-
ated by Free Software Foundation, Inc.), which gives you broad rights. You
should at least scan the text of the document before clicking the Next button,
which means that you accept the license.

Connecting to the database

Clicking Next in the License page brings up the Database Configuration page,
shown filled out in Figure 2-11.
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This page is super-important, because Joomla doesn’t store the pages in your
site as actual pages at all — but as entries in a MySQL database. When you
navigate to the page in question, Joomla extracts the content from the data-
base and constructs its HTML page on the fly. You have to get the database
connection right, because if you can’t connect Joomla to MySQL, your site

isn’t going to run.



30

SMBER
S

|
Figure 2-12:
The FTP
Configura-
tion page.
|

Part I: Getting Started with Joomla

Here are the settings you have to make in this page, along with brief
explanations:

v+~ Database Type: probably MySQL

v Host Name: usually localhost or a name provided by the ISP

v User Name: the default MySQL username root, a name provided by the
ISP, or a name you create while setting up your database server

v Password: the same password you use to access your database (may be
preset by your ISP)

v Database Name: the name you used when you set up your database

If you followed along with the examples earlier in this chapter, you set all this
information when you configured MySQL.

MySQL is notoriously finicky about usernames and passwords; case counts.
Make sure that you pay attention to the difference between, say, Steve and
steve.

When you finish, click Next. Joomla tests the connection to the database, and
if everything works properly, it takes you to the next page.

Setting the FTP configuration

After a successful test of the database connection, Joomla displays the FTP
Configuration page (shown filled out in Figure 2-12).

8 Joomlal Web Installer. - Microsoft Internet Explorer A=ES
Flle Edt View Favortes Tools Help "
Qeack ~ ) [ 2 h | S search <7 Favorites 62 ~ & 093

Adiress | @] myioomlal dex.php v|Beo ks »

F
ot i :
Joomlal™ Installation
Steps FTP Configuration () Previous | tiext ()
1:Language = .
FTP Configuration:
2:Pre-nstallation Check Due to file system permission restrictions, within Lins - -
and other Urnix sytems, and PHP Safe Mode restrictions | Basic Settings
T in ordder that all users can utiize the Joomla! instalers
zHicense an FTF Layer exists o handle file system manipulation, @ ves
Enter an FTP Username and Password with access to o Enable FTP File system Layer
s the Joamla! roct diectory, this will be the FTP Account L No
4:Database B
that handles all file system operations when Joomlat — 1
requires FTP access to complete a task, |
5: FIP Configuration For security reasons, It i best F 2 separate FTP User
y Account is created with access only ta the Joomlal FTP Password L |
instalation, and not the whole Web server if this option - |
6: Configuration is available to you, FTP Root Path 4 |
P Note: IF the instaliation is on 2 Windows Operating AR [ e setnges]
i System the FTP Layer is not required
Advanced Settings
-
2] Dane ® Internet




Chapter 2: Getting and Installing Joomla 3 ’

Configuring the database

The Advanced Settings section of the Database option. It wipes the slate clean by clearing

Configuration page contains a couple of radio any Joomla data in the MySQL database

buttons that you may want to look at if you're under the username and password you'll

an expert: be using.

v+~ Drop Existing Tables. If you've already ¢~ Backup Old Tables. Select this option if you
installed Joomla and want to reinstall it have old Joomla data that you want to back
or upgrade to a newer version, select this up before installing Joomla again.

You don’t need to configure the FTP server if you're installing in Windows.
This page has mostly to do with Linux and other Unix hosts, because they
can be a little finicky about file permissions. Later, if you have problems with
uploading files to Joomla (such as image files or new templates), you can use
the built-in FTP server (called the FTP layer) or your own FTP application to
upload the files to the correct directories.

If you need to configure the built-in Joomla FTP server, follow these steps:

1. Enter an FTP username and password.

This step creates the FTP account to handle all file-system tasks if
Joomla needs FTP access.

2. Enter the root path.

If your Joomla installation is in the main (root) directory of your site,
simply enter a forward slash (/) in the FTP Root Path text box.

3. Click the Verify FTP Settings button.
You should get a confirmation dialog box.
4. Click OK to close the dialog box.
5. When you’re done with the FTP Configuration page, click Next.

Setting the main configuration

Clicking Next in the FTP Configuration page brings up the Main Configuration
page, which lets you set information about your new Joomla site.

To enter the main configuration settings, follow these steps:

1. Enter the name of your new Joomla site in the Site Name text box.
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This name will appear when you log in as an administrator. (For this
example, we're using Joomla Super Jungle.)

2. Enter an administrator e-mail address in the Your E-Mail text box.

When you log into your new site, you'll be the super administrator (no
cape or tights required). This fine-sounding title is as high as you can
get in Joomla. The super administrator has maximum control of the site.
(Just try not to let all that power go to your head.)

You can have several super administrators, but you can’t delete a super
administrator account.

Make sure that you enter a valid e-mail address, so that users of your
site can contact you.

3. Enter and then confirm the administrator password you want to use.

Please remember this password. (You don’t need to tattoo it on your
forearm, but you may want to jot it down; you're going to need it
throughout this book.)

As the super administrator, your username will be admin. You can
change it later (which is a good security measure), but when you’re log-
ging in as the super administrator, use admin at least to start.

Joomla gives you the option of installing some sample data to see how
the site works, and unless you're an experienced Joomla user, you
should definitely do that.

4. Select the Install Default Sample Data radio button; then click the
Install Sample Data command button (see Figure 2-13).

When you complete this step, the Install Sample Data button changes to
the Sample Data Installed Successfully! button.

If you don't install the sample data, your Joomla installation starts off
blank, and your home page is nearly empty. You may want to set things
up this way later, when you’re creating sites for clients, but if you're
installing Joomla for the first time, load the sample data so that you can
understand the structure of a Joomla site by playing around with the
various management tools.

5. Click Next.

Later, you can also use the Main Configuration page to install a backup copy of
the Joomla data from another Joomla installation, using a Joomla 1.5—-compatible
SQL script file, or you can migrate data from a previous version of Joomla. For
details, check the Joomla! 1.5 Migration Guide at http://help.joomla.org/
content/view/1933/294/.
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Finishing the installation

Clicking Next in the Main Configuration page takes you to the Finish page
(see Figure 2-14).

You're all set — nearly. Note the message on the right side of the page, which
reminds you to remove the installation directory.

Pay attention to this message; you really do need to remove the installation
directory before you continue. Joomla requires this step for security reasons:
Details about your site are stored in the installation directory, and you don’t
want those details hanging around.

To delete the Joomla installation directory, connect to your site in your FTP
program, and delete the directory there. (In FileZilla, for example, you right-
click the installation directory and choose Delete from the shortcut menu.)
As an alternative, you could rename the installation directory, but you have
no reason to keep it around.

After you delete the installation directory, you're ready to roll. You can click
the Site button to visit your new Joomla site or click the Admin button to

go to the administrator control panel. Skip to “Looking at Your New Joomla
Site,” later in this chapter, which covers both options.
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|
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Installing Joomla on Your Own Machine

To get your Joomla site out in the world, you've got to get it on the Internet,
and that means using an ISP. But to develop Joomla sites and come up to
speed on Joomla, installing the program on your own local machine often is
much easier.

In this section, we show you how to do just that.

Installing Joomla locally is great if you're doing anything experimental,
such as creating new templates or mucking around with the front page. You
may have a dozen commercial sites that you’ve built, but rather than make
changes publicly, you may want to get your changes running locally first.
Also, response time is much faster when you don’t have to upload new files
and wait for browser refreshes all the time.

You have two ways to install Joomla on your local machine: the hard way and
the easy way. We look at both methods — with special emphasis on the easy
way, of course.
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The hard way: Installing components

The hard way to get Joomla running on your local machine is to install the
components you need, one by one, and get them running. Those components
(and the URLs where you can get them) are

v PHP 4.3.10 or later (www.php.net)

v MySQL 3.23.x or later (http://dev.mysqgl.com/downloads/
mysqgl/5.0.html)

v Apache 1.3 or later (http://httpd.apache.org)
Each of these components comes with its own installation manual; just follow

the manual’s directions. Unfortunately, however, you sometimes run into
issues when you try to get all three components working together.

That’s why we also cover the easy way to install the components you need to
run Joomla: install XAMPP, which wraps all three components into a single
installable package.

The easy way: Installing XAMPP

Most people (especially smart ones like you) find it easiest to install the
Joomla environment as a single package via XAMPP. This package can be
installed with minimal effort and in just a few minutes — so of course, we rec-
ommend this method.

When you install XAMPP, that package installs the Apache Web server, PHP,

and MySQL for you all in one fell swoop — no fuss, no muss. XAMPP lays the
full groundwork for Joomla; after you install XAMPP, all you’ve got to do is to
unzip and install Joomla.

Currently, XAMPP supports these operating systems:
v Linux (tested for Ubuntu, SUSE, Red Hat, Mandriva [formerly Mandrake],
and Debian)
»* Windows 98, NT, 2000, 2003, XP, and Vista
v Solaris SPARC (developed and tested under Solaris 8)
v Mac OS X (still undergoing some development)
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As a bonus, XAMPP contains more than just the three components you need
for Joomla. The Windows version, for example, includes all the following:
Apache, MySQL, PHP + PEAR, Perl, mod_php, mod_perl, mod_ssl, OpenSSL,
phpMyAdmin, Webalizer, Mercury Mail Transport System for Win32 and
NetWare Systems v3.32, Ming, JpGraph, FileZilla, mcrypt, eAccelerator, SQLite,
and WEB-DAV + mod_auth_mysql. Whew!

You get XAMPP from the Apache Friends Web site at www . apachefriends.
org/en/xampp.html. Just select the version you want — Linux, Windows,
and so on — to go to a download page.

In the following sections, we take a brief look at installing XAMPP for
Windows, Linux, and the Mac.

XAMPP for Windows
To install XAMPP in Windows, follow these steps:

1. Download the executable installer file (such as xampp-win32-1.6.7-
installer.exe).

2. Double-click the . exe file to open the XAMPP installer wizard (see
Figure 2-15).

B XAMPP 1.6.7 win32 (Basic Package) (A=

Welcome to the XAMPP 1.6.7 Setup
Wizard
This wizard will guide you thraugh the installation of XAMPP
1t is recommended that you close all ather applications
before starting Setup. This will make it possible bo update
relevant system Files without having to reboot your
I computer.
. Click MNext to continue,
Figure 2-15:
The
XAMPP for
Windows
installer
wizard. [ ]
|
3. Click the Next button.
4. Follow the directions in the wizard to install XAMPP, which also
B installs Apache, PHP, and MySQL.
MBER
S
&

Use the password you selected for MySQL (refer to “Creating the database,”
earlier in this chapter); the default installation gives you the username root.
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Windows Vista users, take note: Because of missing or insufficient write per-
missions in the C: \program files directory in Vista, Apache Friends sug-
gests that you install XAMPP in another directory, such as C : \xampp.

If your machine is already running Internet Information Services (IIS) — that
is, you have a ¢ : \ inetpub directory and can bring up an IIS page when you
navigate to http: //localhost — you should disable IIS if you're going to
install and run Apache on the same computer. By default, these servers use
the same port and will conflict with each other. To disable IIS in Windows,
open Control Panel, choose Administrative Tools>Services=IIS, right-click
IIS in the Startup Type column (currently set to Automatic), choose Disabled
from the shortcut menu, and then reboot your computer.

When the installation is complete, reboot your computer. The components of
XAMPP run as Windows services. During installation, the wizard adds an icon
for the XAMPP control panel to the bar at the bottom of the screen. Double-
clicking that icon opens the control panel, shown in Figure 2-16.

B3 XAMPP Control Panel Application EJ@@

®AMPP Contral Panel SCM...

Modules
Status

M sve Apache Runn!ng Adrmin.., PR
Sve .Myéql HHRnY Explore...
Osve  Filezilla m l:l Help
O Mercury m l:l Exit

HAMPP Control Panel Wersion 2.5 (9. May, 2007)
Windows £.1 Build Z&00 Platform 2 Zerwvice Pack Z

Current Directory: c:'xampp
Install Directory: co:)\xampp
Status Check OR

To test your new installation, open a browser and navigate to http://
localhost. Click the Documentation link, and you should see something like

Figure 2-17.

To test whether PHP is running, click the phpinfo() link on the left side of the
main XAMPP page. This link runs a PHP function that displays a table of infor-
mation about the PHP installation.

If you have problems installing XAMPP, check the XAMPP Frequently Asked
Questions (FAQ) list at www . apachefriends.org/en/fag-xampp-
windows.html/.
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XAMPP for Linux
To install XAMPP in Linux, follow these steps:

—

. Download the .tar.gz installer file (such as xampp-1inux-
1.6.7.tar.gz).

N

. Open a Linux shell.

w

. Log in as the system administrator by entering the su command.

4. Extract the downloaded .tar.gz file to the /opt directory by enter-
ing this command:

tar xvfz xampp-linux-1.6.7.tar.gz -C /opt

That’s it. XAMPP is installed in a directory named /opt/lampp (LAMPP is
the Linux version of XAMPP).

To start XAMPP, just enter this:
/opt/lampp/lampp start

You should get the following message:
Starting XAMPP 1.6.7...
LAMPP: Starting Apache...
LAMPP: Starting MySQL. ..

LAMPP started.
Ready. Apache and MySQL are running.
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If you see this message, open a browser and navigate to http: //local
host; you should see the main XAMPP page.

If you have problems, check the XAMPP for Linux FAQ at www . apache
friends.org/en/fag-xampp-linux.html.

XAMPP for the Mac
To install XAMPP on the Macintosh, follow these steps:

1. Download the .tar.gz installer file (such as xampp-macosx-
0.7.3.tar.gz).

2. Uncompress the compressed file to get a package, PKG, file, and
double-click the PKG file.

3. Follow the installation wizard’s steps.

4. Run the following command in Terminal (in an admin account):
sudo su

5. Enter your password.

6. Enter the following command:
tar xfvz xampp-macosx-0.7.3.tar.gz -C /

That’s all you need to do. To start XAMPP for Mac OS X in a Terminal
window, enter this command:

sudo su
/Applications/xampp/xamppfiles/mampp start

You should see something like this:

Starting XAMPP for MacOS X 0.7.3...

XAMPP: Starting Apache with SSL (and PHPS) ...
XAMPP: Starting MySQL. ..

XAMPP: Starting ProFTPD. ..

XAMPP for MacOS X started.

Ready. Apache and MySQL are running.

If that message looks OK, open a browser and navigate to http://
localhost; you should see the XAMPP main page.

If problems pop up, check the XAMPP for Mac FAQ at www.apachefriends.
org/en/fag-xampp-macosx.html.

XAMPP is still under development for the Mac, so the FAQ page may still be
under construction.
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Installing the Joomla program

Now that you’ve got XAMPP up and running, you have Apache, PHP, and
MySQL. Cool. All you need to do now is install Joomla, and that process
works the same way as installing Joomla on an ISP’s server. Just follow these
steps:

1. Go to www.joomla.org, and click the Download button.

2. Download the compressed zip or .tar.gz file that’s appropriate for
your operating system.

3. Uncompress the Joomla files, using a program such as WinZip.

Your newly installed XAMPP directory contains a subdirectory named
htdocs, which is where you put the files you want to access when you
navigate to http://localhost in your browser.

You can copy the uncompressed Joomla files directly to the xamMpp
htdocs directory or to a subdirectory of htdocs. If you create a sub-
directory of the htdocs directory named Joomla (that is, htdocs\
joomla) and copy the uncompressed files to that subdirectory, Joomla
will start when you navigate to http://localhost/joomla in your
browser.

4. Copy the uncompressed Joomla files to the htdocs directory, or
create a subdirectory of htdocs and then copy the uncompressed files
to that subdirectory.

5. Open your browser, and navigate to http://localhost or http://
localhost /xxxx (Where xxsx is the name of the subdirectory you
created in Step 4).

The first Joomla installation page appears.

6. Follow the directions in “Installing Joomla on a Host Server,” earlier
in this chapter, making these substitutions:

¢ Enter localhost as the MySQL server name.
¢ Enter root as the MySQL username.

¢ Enter the password you selected when you set up MySQL during
XAMPP installation.

* You can skip the FTP server setup page when you install on your
own machine.

When the installation is complete, give Joomla a test drive. Click the Site
button in the final installation page, or go to http://localhost (or
http://localhost/xxxx, if you copied the Joomla files to a subdirectory
of htdocs). You should see the Joomla front page.
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Looking at Vour New Joomla Site

Figure 2-18 shows your Joomla site as users will see it, displaying the sample
data you installed earlier in this chapter. Congratulations — you’ve got your
site up and running.
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The figure shows your new home page, called the front page in Joomla. In

Chapter 3, we give you an in-depth look at it and show you how to modify it.

But it bears a little examination now.

Ordering from the menus

You'll notice plenty of menus on the front page. Menus are much more impor-

tant in Joomla than you may think. You can’t publish content to your site

without connecting it to a menu

item — and the way you configure a menu

determines the actual layout of the content when a user sees it. We describe
the various menus in the following sections.
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Top menu
The horizontal bar at the top of the page, which is called the top menu (also

called the pill menu because of its shape) contains these general Joomla
commands:

v About Joomla!

v Features

v News

v The Community

Main menu
The Main Menu pane on the left side of the page has these somewhat more

important items:
v Home
v Joomla! Overview
v Joomla! License
v More about Joomla!
v FAQ
1 The News
v+ Web Links
1 News Feeds

Resources menu
The Resources menu contains links to several Joomla resources:

v Joomla! Home
v Joomla! Forums
v Joomla! Help
»* OSM Home

v Administrator

Touring the modules

The front page is divided into sections, including Latest News, Popular,

and Polls. Those sections are Joomla modules, which you start managing in
Chapter 3. Working with each section as a discrete module makes front-page
management a snap.
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Figure 2-19:
Loginas

the admin-
istrator of
your site.
|

The actual content of the page, such as the Welcome to the Frontpage sec-
tion, isn’t a module; it’s an article that’s been published to the front page. In
Chapter 3, you find out how to create articles and publish them to the front

page.

The positions of the modules and other content in the front page — or any
Joomla page, for that matter — is set by the Joomla template you're using

for your site. You see in Chapter 9 how to work with different templates to
change not only the color scheme of your site, but also the arrangement of its
content.

Controlling the action

A link on the front page takes you straight to the administrator’s control
panel, which allows you to control the site behind the scenes. To see the con-
trol panel, click the Administrator link in the Resources menu or navigate to
yoursite/administrator (such as www.myjoomlal23.com/
administrator).

Logging in as administrator

When you click the Administrator link, you see a page with the login section
shown in Figure 2-19.

Joomla! Administration Login

Use a valid username and
passvord to gain access to Username admin
the Administrator Back-end

Password  (sessseees |
Return to site Home Page
Language Default v

Login ()

Q

Enter the username admin and the password you entered in the Main
Configuration page of the Joomla installation process; then click Login.
Joomla displays the administrator control panel, which should look some-
thing like Figure 2-20.

Congratulations — now you’re operating behind the scenes, and you've got
the power to run things. Nice going, Joomla boss!
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2 Joomla Super Jungle - Administration - Microsoft Internet Explorer
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Meeting the managers

Take a look at the icons in the control panel. These icons represent Joomla
managers, which you use to — surprise, surprise — manage your site. Even
more managers are available from the Extensions drop-down menu at the top
of the page. Chapter 3 describes them in more detail.

Working with and mastering these managers make up much of the book;
you're going to get very familiar with all of them.

Chapter 3 digs farther into the front page, taking it apart piece by piece to
show you what makes it tick.



Chapter 3
Mastering the Front Page

In This Chapter

Touring the front page

Getting acquainted with the control panel
Creating and titling articles

Working with modules and menus
Adding polls

Changing newsflash text

Replacing the front-page logo

Trying out templates

ou jump right into Joomla by seeing how to work with and modify

what’s going on in the front page. After all, the default front page that
you're left with after a Joomla installation is nice, but as a dedicated Web
designer, you know that your clients will want their sites totally customized.

To modify the front page, you need to know it, and you’re going to start
there, taking apart the front page to see what makes it tick.

Dissecting the Front Page

Take a look at the default Joomla front page in Figure 3-1 (with sample data
installed).

A great deal of the information in a Joomla page is presented in modules. In
Figure 3-1, you see the Latest News, Popular, Newsflash, and Polls modules.
To handle these elements, you use Module Manager.

The figure also shows several menus. You control the items in them — and
the names of the menus themselves — with Menu Manager. Menus are also
presented in modules, so you can delete entire menus with Module Manager.
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Site logo  Main menu Newsflash module
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The central text of the page is an article. Articles aren’t presented in
modules; they're presented in what Joomla calls components. You manage
articles with — you guessed it! — Article Manager.

So where are all these managers? They're available in the administrator
control panel, which we discuss next.

Sitting in the Power Seat: The
Administrator Control Panel

What you see in Figure 3-1 is the Joomla front end, which is available to non-
administrators. This part of the site presents articles, menus, and modules
for all to see.

To administer the site, you use the back end, where you find all the manager
tools: Module Manager, Article Manager, and so on. The back end is well
named; it’s the part of the site that lets you work behind the scenes and pull
the strings. To gain access to those tools, you have to be an administrator.

As an administrator, you can grant several levels of privileges to users of
your site. Each level has different capabilities and different resources. A
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menu that appears to registered users (those who log in with their user-
names and passwords) may not be visible to casual public Web surfers, for
example. We discuss these privileges in the following sections.

Granting user privileges
Here are the front-end user levels, in ascending order of power:

v Public: casual Web surfers

1 Registered: Web surfers who have registered with your site
v Author: users who can submit articles

v Editor: users who can submit and edit articles

v~ Publisher: users who can designate articles for publication to the site

Notice in particular the Author, Editor, and Publisher levels. Joomla empha-
sizes user interaction and contribution to your site (if you allow it, of course,
by granting privileges in User Manager). Accordingly, users who have author
privileges can submit new content to your site; editors can also submit con-
tent and edit other submissions; and publishers can mark content to be pub-
lished to your site.

You may wonder how authors, editors, and publishers are allowed to submit,
edit, and publish articles to your site if they don’t have access to the adminis-
trative back end. The answer is that they can do what they do from the front
end. When they log in, Joomla knows their privilege level. Authors, editors,
and publishers see small icons on the page that link to article submission,
editing, and publishing pages.

Actually publishing an article is still up to administrators, however. Publishers
can mark an article for publication, but an administrator still has to approve it.

Granting administrator privileges

Joomla offers three administrator levels. You can grant these privileges in
User Manager:
1 Manager: users who have back-end privileges

v Administrator: users who have more back-end privileges than
Managers do)

+* Super Administrator: user who has the most back-end privileges

If you installed the site, you're the super administrator — and the super
administrator is the ruler of everything.
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Logging on as administrator

How do you log on as an administrator? You have several options:

v~ If Joomla is installed locally (on your own computer), navigate to
http://yoursite/administrator (that’s http://localhost/
administrator or http://localhost/xxxx/administrator if you
installed Joomla in the directory xxxx).

v~ If Joomla is installed remotely (on an ISP’s server), navigate to www.
yoursite.com/administrator.

v Pull up the default front page in your browser, and click the
Administrator link in the Resources menu.

Whichever option you choose, you see a login page for administrators.
Enter your username (that’s admin for the super administrator of the default
installation) and password; then click the Login button (see Figure 3-2).

Joomla! Administration Login

Use a valid username and
pazsyard to gain access to Username  |admin
the Administrator Back-gnd

Pass | (eeesssnssy |
Return to ste Home Pags ASSWOTC

|
Language Defau|_t v

Figure 3-2: Login ()

Logging
in as =

an admin- [m\

istrator of l

your site. |
|

When you’re logged in, you see the administrator control panel, displaying a
set of manager icons. Cool — you're in.

Managing the managers

Figure 3-3 shows some of the managers that are available in the control
panel.

The icons for these managers are displayed in the control panel by default:

v Add New Article
v Article Manager
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v Front Page Manager
v Section Manager

v Category Manager
v Media Manager

v Menu Manager

v Language Manager
v User Manager

v Global Configuration
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You can choose some additional managers from the Extensions drop-down
menu at the top of the page:

v Module Manager

v Plugin Manager

v Template Manager

v Language Manager
Now that you're familiar with the control panel, you're ready to start putting

some of this technology to work by creating an article to be displayed front
and center on the front page.
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Creating Articles

Creating any new article starts with clicking the Add New Article icon in the
control panel. Joomla opens the article-editor page (see Figure 3-4).

2 JoomlaSite - Administration - Microsoft Internet Explorer
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This page is a WYSIWYG (what you see is what you get) editor, not an HTML
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needed.
\\3

You can edit the raw HTML of an article in this page if you want, however; just
click the HTML button in the article editor’s toolbar.

Creating a new article

To create a new front-page article, follow these steps:
1. Double-click the Add New Article icon in the administrator control
panel.
The article-editor page opens.
2. Type the article’s title in the Title text box.

For this exercise, enter Welcome to my site.
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3. Leave the Section and Category drop-down menus set to
Uncategorized.

You can manage your site’s organization with Section Manager and
Category Manager, both of which we discuss in detail later in the book.
For now, though, leave this new article uncategorized.

4. Enter the article text in the editor window, using the Bold and Italic
buttons to add bold and italic formatting as desired.

For this exercise, enter the following text:

Welcome to my site. Do you like it? This site uses Joomla! 1.5 for content
management. Joomla! handles the details of the presentation and lets you
focus on writing the content of the site. No complicated knowledge of
HTML or style sheets is necessary. Pretty nice site, eh?

5. To publish this article to the front page, select the Yes radio button in
the Front Page section.

6. Click the Apply button.

Joomla displays a message that it has successfully saved the changes to
your article (see Figure 3-5).
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7. Preview your article in a new window by clicking the Preview link
next to the Logout button in the top-right section of the page.

8. Click the Save button to close the article editor.
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WMBER
@&
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|
Figure 3-6:
The new
article on
the front

page.
|

The Apply button in the article editor causes Joomla to save the article; the
Save button causes Joomla to save the article and close the article editor.

You can see the article on the front page when you navigate to your site (see
Figure 3-6). Nice. You’ve published your first article.

But surely you don’t want the default “Welcome to the Frontpage” title for the
article. In the following section, we show you how to change it.
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Tweaking article titles

Before you change anything on the front page (or anywhere in your Joomla
site, for that matter), you have to do a little digging into how Joomla works.
Knowing how articles are presented is very important. In Joomla, articles
don’t exist until they’re requested, which is when their content is plucked
from the database, formatted, and displayed.

Understanding article/menu links

Every article — including the one you just created — is linked to a menu item
that makes it accessible, and that fact is of utmost importance in Joomla. In
Joomla, menus have more power than you may be used to, because they're
responsible for telling Joomla what to fetch from the database. Not only is
the content of an article linked to a menu item, but also, that menu item
specifies the layout in which the content is displayed.
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That’s a crucial fact in getting to know Joomla: Menu items specify both
articles and the layout of those articles. Many content management systems
are set up this way.

This fact is easier to remember if you bear in mind that an article doesn’t even
exist until the user clicks the menu item to which it’s linked.

Changing an article’s title

So what menu item points to front-page articles? The answer is Home, listed
in the Main menu on the front page (refer to Figure 3-6). This menu item is
responsible for the “Welcome to the Frontpage” title, so to change the title,
you have to change the settings for that menu item.

To change the settings for the Home menu item, follow these steps:
1. Go back to the control panel (choose Site~>Control Panel in any back-
end page).
2. Click the Menu Manager icon.

Menu Manager opens (see Figure 3-7).
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3. In the Main Menu row, click the icon in the Menu Item(s) column.
Menu Item Manager opens (see Figure 3-8).
4. Double-click the Home link.

Joomla displays the Home item’s Menu Item page.
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5. In the parameters pane on the right side of the page, click the
Parameters - System bar to display the system parameters, as shown in
Figure 3-9.
You see Welcome to the Frontpage in the Page Title text box, just wait-
ing to be changed.
6. Change the title.
<P For this exercise, type This is my site.

If you wanted to remove the title instead, you would select the No radio
button in the Show Page Title section of the system parameters.

7. Click the Apply or Save button.
Joomla saves your changes and displays a message to that effect.
8. Navigate to the front page of your site in a browser.

The title of the article has changed — in the example, from “Welcome to
the Frontpage” to “This is my site,” as shown in Figure 3-10. Cool!
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One annoying aspect of the back end in Joomla
is that by default, it times out after 15 minutes
of inactivity, and you have to log in again. That
happens more often than you may think. You may
find yourself keeping a back-end window open
while you monitor other things on the site — and
next thing you know, you're being asked to log
in again.

You can change this timeout setting easily,
however. To do that, follow these steps:

1

When Joomla times out

. Choose Siter>Global Configuration in
any back-end page to open the Global
Configuration page.

. Click the System tab at the top of the
page.

3. Inthe Session Settings section, change the

Session Lifetime setting.

You may wantto change it to as much as 60
(minutes) if you're getting a lot of annoying
timeouts.

4. Click Apply; then click Save.

Remodeling Modules

|
Figure 3-11:
Module
Manager.
|

Most of the items around the edge of your front page are modules;
even the login form is a module. You can manage all these elements
with Module Manager (see Figure 3-11). To access this feature, choose
Extensions=>Module Manager in any back-end page.
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When you're in article-editing mode, the drop-down menus are disabled. To
get out of a page and enable the administrative drop-down menus, click Close.

Navigating Module Manager

First, note that Module Manager has two tabs at the top: Site and Administrator.
In other words, Joomla has two sets of modules: one for the site as a whole (that
is, the front end) and one for administrators (that is, the back end).

Also note that you see entries for three menus in Figure 3-11: Main Menu,
Resources, and Key Concepts, all of which appear on the front page by default.

But don’t you manage menus by using Menu Manager? Why do these menus
appear in Module Manager?

Menus are actually modules, so when you want to work with a menu as a
whole, you turn to Module Manager. When you want to work with only the
content of a menu, you work with Menu Manager. That’s another one of the
things you just have to know about Joomla.

Now look at the Access Level column, which indicates the user level that can
view specific modules. As you see in Figure 3-11, all the listed modules are
visible to everyone — the Access Level column lists the Public user level.

Viewing modules

Now suppose that you want to remove the Latest News and Popular modules
from the site. But when you click the Site tab and scroll up and down the list
of modules, you don’t see those modules. Where are they?

By default, Module Manager displays only 20 modules, which is why you
don’t see Latest News and Popular. To see all available modules, scroll to the
bottom of the page and choose All from the Display drop-down menu.

Following are the 25 site modules available in the default Joomla installation:

v Breadcrumbs v Banners

v Footer I Main Menu

1 Resources I Key Concepts
v User Menu I Example Pages
v~ Statistics 4 Login Form

v Archive I Sections
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v Related Items 7 Wrapper

v Feed Display I Polls

v Who'’s Online 4 Advertisement
v+ Random Image v Syndication
1 Newsflash 4 Latest News
v Popular I Top Menu

v Search

A few of these modules bear explanation. Breadcrumbs is the path to the
current page (Home >>The Community, for example) that appears at the top
of the screen. Wrapper is a wrapper for other Web sites that you can use to
make those sites visible in Joomla. And Newsflash is the text at the top of a
page, next to the logo.

Removing and deleting modules

To remove a module from view, click its green check mark in the Enabled
column of Module Manager. For this exercise, click the green checks for
Latest News and Popular. Each check you click changes to a red X, as you see
(in glorious black and white) in Figure 3-12.
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|
Figure 3-13:
The updated
front page.

You've removed the Latest News and Popular modules, but are they really
gone? Yes indeed. Click the Preview link at the top of Module Manager to
open a preview of your site in a new window. As you see in Figure 3-13, the
page no longer displays those modules.

To delete a module — as opposed to just removing it from view — check its
check box in Module Manager; then click the Delete button at the top of the

page.

In the next section, you customize your site even more by working with menus.
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Modifying Menus

You may have noticed that the Main Menu pane on the front page contains
a Joomla! License menu item. That item is important for administrators, but
you don’t necessarily want to foist it on ordinary users.

So how do you modify a menu? If you said, “Menu Manager,” you're right. Go
to the control panel (by logging in to the back end or choosing Siter>Control
Panel in any back-end page), and open Menu Manager (see Figure 3-14).
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The default Joomla installation provides these menus:

»* Main Menu

v User Menu

v Top Menu

1 Resources

v Example Pages
v Key Concepts

Removing menus

Your task is to remove the Joomla! License menu item from the Main menu,
so click the icon in the Menu Item(s) column of the Main Menu row to open
Menu Item Manager (see Figure 3-15).

By default, you find these items in the Main menu:

»* Home

v Joomla! Overview
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|
Figure 3-15:
Menu Item
Manager.
|

<MBER
43“

v |_What’s New in 1.5?
v Joomla! License

»* More about Joomla!
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Notice that the What’s New in 1.5? menu item is preceded by a vertical pipe
and an underscore ( |_). These characters mean that What’s New in 1.5? is
a submenu of the preceding item Joomla! Overview; when you click Joomla!
Overview, it opens to show the submenu.

To remove (unpublish) a menu item, click the green check mark in its
Published column, changing the check to a red X. For this exercise, click the
check for Joomla! License. When you view the front page again, that menu
item no longer appears in the Main menu, as you see in Figure 3-16. Nice.

In Chapter 4, you see how to create new menu items. For now, how about
renaming a menu?
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|
Figure 3-16:
Removing a
menu item.
|
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Renaming menus

The Resources menu on the front page isn’t really about general resources;

it’s about Joomla stuff. So you may want to rename it.

To change a menu name, you use Module Manager, not Menu Manager.
(Menus are displayed in modules, remember?) Follow these steps:

1. Choose Extensions=>Module Manager in any back-end page.

Module Manager opens.

2. Select the radio button for the module you want to rename.

For this exercise, select Resources.

The selected module opens in Module Manager.

3.

For this exercise, type Joomla! Stuff.

4.

Click the Apply button.

In the Details pane, enter the new name in the Title text box.

Joomla! displays an Item Saved message (see Figure 3-17).

(2]}

6.

The renamed menu (that is, module) appears, as you see in Figure 3-18.

Preview the site.

. Click Save to close Module Manager.
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You're mastering the front page, getting to know the differences between
Menu Manager and Module Manager. Now meet a whole new feature: Article
Manager.
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Strike That: Removing Articles

|
Figure 3-19:
Article
Manager.
|

You cast your eye over the front page, noting in particular the article titled
“We are Volunteers.” Hmmm. You may be developing this page for a for-profit
business, which may not want an article titled “We are Volunteers” on its
front page.

Earlier in this chapter (in “Creating Articles”), we show you how to add a new
article by using the Add New Article feature. Joomla doesn’t have a Remove
0Old Article feature, though, so how do you remove an article?

You use Article Manager (see Figure 3-19) to work with existing articles. To
open it, double-click its icon in the control panel or choose Content>Article
Manager in any back-end page.
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Viewing articles

By default, Article Manager displays this information about articles:
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v~ Title: The title of the article.
v+~ Published: Indicates whether the article has been published.
v Front Page: Indicates whether the article is on the front page.

v Order: Indicates the location of the article on the page. You can move
articles around by adjusting this setting.

v Access Level: Indicates who can see this article. Public means everyone,
for example; Registered means only logged-in users.

v Section: The section of the article. (This setting is irrelevant for articles
on the front page.)

v Category: The category of the article. (This setting is irrelevant for arti-
cles on the front page.)

v Author: The author of the article.
v Date: The date of the article.
v~ Hits: The number of hits the article has received.
v ID: The internal Joomla ID number for the article.
Note in particular the Published and Front Page columns, which indicate

whether an article is published — that is, visible on your site — and whether
it’s on the front page.

Filtering articles

Many articles come with the default Joomla installation, but that number is
nothing compared with the number of articles on a Joomla site that’s been up
for years. You may have to search through thousands of articles to find the
one you want to manage in Article Manager. To zero in on the article you're
interested in, you need to filter the results.

To filter the articles displayed in Article Manager, follow these steps:
1. In the Filter text box in the top-left corner of the Article Manager

window, enter a filter criterion (such as article title or article ID).

For this example, enter the title of the article you're looking for: We are
Volunteers.

2. Click the Go button next to the text box.
Joomla displays the filtered results (see Figure 3-20).
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Bingo. You've found the article you want to work with.

Unpublishing articles

To unpublish an article, simply click the green check in its Published column.
For this example, your task is to unpublish the “We are Volunteers” article,
so click the icon in its Published column, changing it from a green check
mark to a red X.

When you view the page in a browser, you no longer see the article. In
Figure 3-21, in fact, an article titled “Stick to the Code!” has replaced the “We
are Volunteers” article. (You can set the order of articles in Article Manager;
see Chapter 4 for details.)

In the next section, you turn your attention to another front-page module:
Polls.
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Inquiring Minds Want to
Know: Creating Polls

The poll in the default Joomla installation asks “Joomla! is used for?” and
allows users to answer by selecting one of the following radio buttons:

v Community Sites

v Public Brand Sites

v eCommerce

” Blogs

v Intranets

v Photo and Media Sites

v All of the Above

The bottom of the Polls module provides two buttons: Vote and Results
(which users can click to see how other people voted).
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You may not want a Joomla poll. Instead, you may want a poll about how
much money users plan to send you, including these options:

v Very little

v Alittle

* Not so much

v Pretty much

v Alot

v More than that

+* None of the above
To change the poll, you need Poll Manager. (If you wanted to remove the poll,

you could do that with Module Manager; refer to “Remodeling Modules,”
earlier in this chapter.)

Changing the default poll
Follow these steps to change the default poll:

1. Choose Components=>Polls in any back-end page.
The Poll Manager page opens (see Figure 3-22).
2. Click the “Joomla! is used for?” title.

That poll opens (see Figure 3-23).
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Figure 3-23:
Opening a
poll.

2 This is my site - Microsoft Internet Explorer,

Fle Edk View Favorites Tooks  Help

O-H@E.

- search

E93

Favorices €2 -

Chapter 3: Mastering the Front Page

69

fdbess | ] tpiflocahost fjoomls)

4 Joomlal

...because open sout

Harme

Home

Joomla! Overview
More about Joomla!
FAG

The News

Web Links

News Feeds

Resources

Joomla! Home
Joomiat Forums
Joomiat Help
OSM Home
Administrator

About Joomla! Features News The Community

This is my site

Welcome to my site re=

‘Welcome to my site. Do you like it? This site uses Joomla! 1.5 for content
managerment. Joomlal handies the detailz of the presentation and lats you focus on
writing the content of the site. Mo complicated knowledge of HTWL ar style shests is
necessary. Prefy nice site, en?

Welcome to Joomlal = S = \Wae are Volunteers = & =

Wiritten Jministrator i Imiistrator

The Joomlal Core Team eonsists of
volunteer developers, designers,
administrators and managers wha,
toaether with & larte ranae of Wark

‘festerday all servers in the U8 went out on strike in a bid to get mare RAM and better CPUs. A
spokes persan said thatthe need for better RAM was dus to soms fool increasing the fom-
side bus speed. In future, huses will ke told to slow down in residential motherhoards

Links

v | B Go

search..

Polls

Joomila! is used for?
) Community Sites
(& Public Brand Sites
O eCommetrce
© Elogs
© Intranets

(& Photo and hledia
Sites

(O All ofthe Abovel

Whe's Online

e have 1 guest online

|

%J Local intranet:

3. In the Details pane, enter the new poll title in the Title text box.

For this exercise, type How much money do you plan to give us?

4. In the Options pane’s numbered text boxes, enter the poll answers.

For this exercise, make these entries:

e Option 1: Very little
e Option 2: A little

e Option 3: Not so much

e Option 4: Pretty much

e Option 5: A lot
e Option 6: More than that

e Option 7: None of the above

5. Click Apply; then click Save to close Poll Manager.

6. View the front page in a browser.

You see the new poll (see Figure 3-24). Not bad.
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Creating a new poll

Want to create an entirely new poll? You can do that too. Follow these steps:

1

—

The New Poll page opens.

Module Manager opens.

7.

Click the New button.

The New Module page opens.

8.

9.
list box.

0.

Select Poll, and click Next.

. Choose Extensions=>Module Manager.

Enter a title for the poll in the Title box.

. Choose Components=>Polls to open Poll Manager.
Click the New button.

. In the Details pane, enter a title in the Title text box.

. In the Options pane’s numbered text boxes, enter your poll answers.

Click Apply; then click Save to close Poll Manager.

In the Module Parameters section, select the poll you want in the Poll
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11.

Click Apply; then click Save to close Module Manager.

12. View your site in a browser.

You see the new poll.

Stop the Presses!: Changing
the Newsflash

The newsflash is the text you see at the top of the main page. By default, it
rotates various pieces about Joomla. You can put anything you want into
your newsflash — information about your school, your neighborhood, any-
thing. If you decide that a company like SuperDuperMegaCo wants its own
newsflash, you can set about changing the default.

To change the default newsflash, follow these steps:

1.

Open the control panel, and double-click the Add New Article icon.

The article-editor page opens.

2. In the text pane, enter your newsflash text.

. In the Title text box, enter a title.

The title you enter won’t be shown on the Web site. For this exercise,
just type Whatever you want.

4. Choose News from the Section drop-down menu.

5. In the Published section, select the Yes radio button.

6. Choose Newsflash from the Category drop-down menu.

At this point, your settings should resemble Figure 3-25.

. Click Save.

The article-editor page closes, and Article Manager opens.

. Choose News from the Section drop-down menu and Newsflash from

the Category drop-down menu.

. Deselect the newsflash articles you don’t want to display (click their

green check marks in the Published column to turn the checks to red
X marks); then click the Unpublish button.

Normally, the newsflash module rotates through various newsflash arti-
cles each time the front page is displayed. If you don’t want to display
other newsflash articles, deselect them.

Figure 3-26 shows all the newsflash articles deselected except the new
one you created for this example (“Whatever you want”).

/1
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|
Figure 3-27:
An updated
newsflash
article.
|
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10. Click the Unpublish button.
11. View the front page in a browser.

Joomla displays only the selected newsflash(es), as shown in
Figure 3-27.

2} This is my site - Microsoft Internet Explorer

Fle Edt Vew Favoites Took Help T
¢ Q-HEG 593

Address | ] hetpfflocalhostfioorls)

S Searth - Favorites €9 (2= L4

Links *>

Vv:Gn

Welcame to the SuperDuperhegaCo site. We hope you brought lots of money. There's nothing
quite as good as buying products from SuperDupertegaCo

& Joomlal

About Joomla! Features News The Community

Home search
(T T sy sie Palls

o Home Welcome to my site L= E “IOW much money doyou

= Joomla! Overview i planto give us?

& More about Joomla! O Averylitie

o FAO O Alitle

= TheNews Welcome to my site. Do vou like it? This site uses Joamlal 1.5 for content

® Web Links management. Joomlal handles the details of the presentation and lets you focus on ) Notso much

® News Feeds waiting the content ofthe site. Mo complicated knowledge of HTML or style sheets is 5o "

necessary. Pretly nice site, eh? O Pretly mue
© Alot

O More than that

Joomla! Stuff

% Welcome ta Joomlal = 9= Sickto the Codel 2 &= ) None ofthe above
. i iministrat
® OSM Home
* Administrator Joomlalis a free open source To ensure this code release, Wilco v §
framework and content publishing Jangen resorted fo sending rum to Who's Online
system designed for quickly creating juint lead-developer Johan Janssens. We have 1 guest online
B highly interacty | Weh Johan, who's had a penchant for rum ]
&] Done %J Local intranet

To add more newsflash articles, double-click the Add New Article icon in the
control panel, and repeat the procedure in this section. Joomla will rotate
through all the selected newsflashes on your site.

Creating a New Logo for a New Look

By default, the logo on your new site is a Joomla logo. That logo isn’t going to
work for other kinds of sites, such as school or restaurant sites. How can you
change it?

The current logo is stored with the current template, which by default is
Milky Way. The actual logo is an image file named mw_joomla_logo.png,
which is stored in the Joomla directory templates/rhuk_milkyway/
images.
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Are you wondering what .png files are? Portable Network Graphics files are
the default format for template images in Joomla, and they’re widely accepted
by browsers. Long ago, after the GIF format started charging to create new
images, people turned to PNG format images (JPG images aren’t great on reso-
lution), so Joomla uses PNG graphics images. If you're installing your own logo
image, you can use your own JPG or GIF files, of course.

WMBER
“&
&

Changing the default logo

In this section, we show you a simple technique for changing the default logo.
Follow these steps:

1. Download or locate the mw_joomla_logo.png file.

If you installed Joomla on an ISP’s server, connect to that server via your
FTP program, and download the file; if you're working locally, just get
the file from your hard disk.

2. Open the file in a graphics program (see Figure 3-28).

Windows users may want to use Microsoft Paint, which is standard in
Windows. (To launch it, choose Start=>Programs=AccessorieswPaint.)

=G

EEx

& mw_joomla_logo.png - Paint
Edit View Image Colors Help

o Joomlal

. because open source matters

Figure 3-28:
mw_ e o
joomla_
logo.
pngin |

Microsoft | o m aEmE T
Paint, |™ FrErErmE AR
I

For Help, click Help Topics or the Help Menu,

3. Choose Filem>Save As to display the Save As dialog box.

4. Choose a location (any directory on your hard disk) for the file from
the Save In drop-down menu.

5. In the File Name text box, enter the new name you want to use.
§ghl STy, For this exercise, type superdupermegaco.

If you're using Paint, it automatically capitalizes the extension, for some
reason, so you'll actually be saving a file named superdupermegaco . PNG.
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|
Figure 3-29:
The new
site logo.
|

6. Make sure that the Save As Type drop-down menu is set to PNG
format.

7. Click Save.
8. Open the renamed file in your graphics program.

9. Using the tools in your graphics program, change the logo the way you
want it.

For this exercise, create a text logo that says SuperDuperMegaCo.

If you're using Paint, for example, you could choose Edit=>Select All;
press the Del key to clear the image; click the Text tool; and then type
the text you see in Figure 3-29.

=

# superdupermegaco.PNG - Paint

Edt View Image Colors Help

SuperDuperMegaCo

00/ ¢ =K
OR~ o0

B

1 1 O I I
SRR IREN | (R

For Help, ciick Help Topics o the Help Menu,

10. Save the new logo in the templates/rhuk_milkyway/images direc-
tory, whether that’s on your hard disk or on your ISP’s server.

Adding the new logo to the template

Now you're ready to tell Joomla to display the new logo superduper
megaco.png (or superdupermegaco . PNG, if your graphic program is
Paint). Follow these steps:

1. Choose Extensions=>Template Manager.

Template Manager opens.

2. Select the default template, rhuk_milkyway, and click the Edit
button.

The Edit Template page opens (see Figure 3-30).

Many CSS (Cascading Style Sheets) files are connected with a template.
For this exercise, you need to edit template.css.
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|
Figure 3-30:
The Edit
Template

page.
|
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3. Click the Edit CSS button.
The Template CSS Editor page opens (see Figure 3-31).

4. Scroll down the page to select the radio button next to
template.css.

5. Click the Edit button.
Joomla displays the Template Manager page for template.css.
6. Scroll down to the section labeled div#logo, shown in Figure 3-32.

7. In the background line of the code, replace mw_joomla_logo.png
with the name of your new image file, as shown in Figure 3-33.

For this exercise, type superdupermegaco.png or (for Paint users)
superdupermegaco.PNG.

Enter the name carefully; the code is case sensitive.

8. Click the Save button to save your changes and close Template
Manager.

9. View the front page of your site in a browser.

Your new logo is in place (see Figure 3-34).
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Using a different-size logo

What if you're using a new logo that's a differ- margin-left: 30px;
ent size from the original? Take a look at the margin-top: 25px;
CSS entry for div#logo: }

Seethe width and height parameters? Just

dlzzi‘;?gnf sbsolute: change those values to the new logo’s width
Ll)eft- 0; ! and height.
top: 0; If your new logo is exactly the same size as
float: left; the current logo, an even easier method is to

width: 298px; . . .
! overwrite 1 1 o with your
height: 75px; T e v

T resindl el (. o flieeicEs new image (keeping the filename the same,
mw._Joomla_logo.png) 0 0 because by default, Joomla looks for that file
no-repeat; when it loads the logo).

Trying a New Template on for Size

Joomla templates are responsible for the overall look and layout of the mod-
ules and articles in your pages. Joomla makes a large number of templates
available — many of them for free (take a look at www.joomla24 . com, for
example), as we discuss in Chapter 9.

Joomla comes with three default templates: Milky Way (which we discuss in
“Creating a New Logo for a New Look,” earlier in this chapter), Purity, and
Beez (which is pronounced bees). You can switch easily between these two
templates — and among as many other templates as you have — by using
Template Manager.

In this section, we show you how to switch from the Milky Way template to
the Beez template.

To switch to a new template, follow these steps:

1. Choose Extensions-~>Template Manager.

Template Manager appears, open to the Site tab and displaying three
templates: Milky Way (rhuk_milkyway), Purity (JA_Purity), and Beez
(beez). The Default column of the active template contains a gold star.
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\\3

Figure 3-35:
Anew
template
applied in
Joomla.
|

If you want to see a preview of a template, let the mouse pointer rest on
the template’s name in Template Manager. A preview pops up at the
pointer location.

2. Select the radio button next to the name of the template you want to
use.

For this exercise, select the Beez radio button.
3. Click the Default button.

Joomla switches to the selected template.
4. View your site in a browser.

You see your site with the new template applied (in Figure 3-35, the Beez

template).
8 This is my site - Microsoft Internet Explorer =6
Fle Edt View Favortes Tools Help »
H @ @ P search Favorites 4 = [ . §
Addhess | ] bitpflocalhastioomla v & ks

Fontsize: ®) bigger = smaller (O reset &

— ,'.'.7',_ ’:ip‘
%‘BEEZ -

Joomla! accessible Template

About Joomla! | Features | News | The Community

Vou are here: Horne

Main Menu This is my site \’/‘ve‘r"f'-“‘h -
‘elcome to the
SuperDupertegaCo site. We
hope you brought lots of
ooz Qrerrey —\/‘l roney. There's nothing guite
Mare ahout Joornlal ) WELCOME TO MY SITE as good as buying products

. from SuperDuperMegaCo
FAQ Lot

Last Updated (Thursday, 21 August 2006 18:17)

The News
Witten by Administrator Polls
Web Links Thursday, 21 Agust 2008 17:57
How much meney do you
News Feeds Welcome to my site. Do you like it? This site uses plan to give us?
Joomlal 1.5 for content managerment. Joormlal .
handles the details of the presentation and lets you O Avery little
Joomla! Stuff facus on writing the content of the site. No O Alitle
complicated knowledge of HTML or style sheets is o
Joomlal Home necessary. Pretty nice site, eh? O ek
O Pretty much v
&) &J Local intranet

To revert to the Milky Way template, go back to Template Manager, select
the Milky Way template’s radio button, and then click the Default button.

You may worry that installing a new template will make your site unusable.

If that happens, how can you get back to the Milky Way template? Actually,
that’s not a worry; the Site and Administrator templates are different, so

they have different tabs in Template Manager. (The default template in the
Administrator tab is named Khepri.) So if a template messes up your site, you
can always go back to Template Manager, which won’t be messed up, and
change the site back to a better template.
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ﬂle Sth Wave By Rich Tennant
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“OKay, well, T think we all get the gisb of
where Jerry wWas going with the site map.”




In this part . . .

' his part really gets you into the thick of things. Here’s
where you acquire the everyday skills to make a
Joomla site tick.

We start by showing you how to create and format new
Web pages. Next, we show you how to create menu items
that point to those new Web pages; in Joomla, you can’t
have Web pages without menu items that point to them.
We finish the part with an in-depth treatment of the ins
and outs of publishing Web pages on your site.




Chapter 4

Adding Web Pages to Your Site

In This Chapter

Working with sections and categories

Creating new articles

Making menu items point to articles

Reorganizing the site’s menus
Adding Read More links

Changing the order of articles

n Chapter 3, we show you how to create an uncategorized article and

display it on the front page. Creating Web pages in addition to the front
page is different. What you write for these pages isn’t displayed on the front
page but has to be reached through a link — that is, a menu item.

In this chapter, you find out how to create articles that don’t appear on the
front page. You start by creating an uncategorized article; then you create
new sections and categories for a Web site. Finally, you see how to place an
article in a particular section and category, and then add a link to it.

First, however, you need to understand how Web pages are organized in
Joomla.

Organizing Web Sites

A\

As sites get bigger, organizing them becomes more important. For that
purpose, Joomla uses sections and categories.

It may be helpful to think of a section as a filing cabinet, a category as a file
folder in that cabinet, and an article as an individual piece of paper in a folder.

You should make every effort to fit your articles into sections and categories.
Your site may be fine with a few uncategorized articles for a while, but when
it starts to grow, masses of uncategorized articles become very awkward.
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Imagine that you run a law firm. When you’re just starting out, keeping all
the individual papers for all your cases on your desk may be fine, but as

time goes by, you’d be buried in paper. You’d be much better off organizing
everything in filing cabinets and folders. (Nancy does this with every piece of
paper that comes her way, and things are always at her fingertips.)

Organizing your site in sections and categories is good practice not only from
the back-end perspective, but also from the front-end perspective. You give
your site users menus (sections) to help them navigate your site, and if you
put articles in categories, you can display individual articles as menu items.

Seeing sections

Sections are the topmost divisions that you use to organize your Joomla site.
Categories fall into sections.

Suppose that you have a client named SuperDuperMegaCo whose three prod-
uct lines are ice cream, sandwiches, and ocean liners. People who navigate
to the company’s site to read about ocean liners probably aren’t going to be
interested in ice cream. So it makes sense to divide the Web pages on this
site into three sections, one for each of the three product categories:

SuperDuperMegaCo

| Ice Cream

|

| Sandwiches

|

| Ocean Liners

That way, site visitors can access pages that summarize each section.

Counting categories

Categories are essentially subdivisions of sections. In the SuperDuperMegaCo
example, you could divide the Ice Cream section into three categories: Bars,
Cartons, and Cones. Then you could divide the Sandwiches section into three
categories: Subs, Wraps, and Triple Deckers. Finally, you could divide the
Ocean Liners section into three categories: Yachts, Queen Mary Class, and
Aircraft Carriers.

Sizing up the site

Next, you plan the organizational layout of the site.
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In the example scenario, you would wind up with this section and category
organization:

SuperDuperMegaCo
Ice Cream
__ Bars
___ Cartomns
__ Comes
__ Sandwiches
Subs
_____ Wraps

Triple Deckers

————— e e

____ Ocean Liners

Yachts

Queen Mary Class

Aircraft Carriers

In addition, the client may want a few uncategorized pages on the site, such
as its privacy policy.

How do you start building a site like this? First, we have you create an uncat-
egorized page; then we show you how to organize pages in sections and
categories.

Working with Uncategorized Articles

Uncategorized articles are free-floating on your site. Joomla thinks that you
should have relatively few uncategorized articles — mostly loners that aren’t
related to other pages.

Many Joomla site developers don’t have any uncategorized articles at all;
they create sections and categories especially for loner pages. A privacy
policy could go in a section called Notices and a category called Privacy, for
example.

In this section, you create an uncategorized article — for this example, a
policy page for the SuperDuperMegaCo Web site.
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Creating an uncategorized article

To create an uncategorized article, follow these steps:

1.

Log in to Joomla by going to the administrator subdirectory of your
site, which navigates you to the control panel.

. Click the Add New Article icon.

The article-editor page opens.

By default, new articles are uncategorized. The Section and Category
drop-down menus both are set to Uncategorized, and you leave them
that way for this exercise.

. Enter the article’s title in the Title text box.

For this exercise, type Privacy Policy.

. Enter an alias for the article in the Alias text box.

An alias usually is a computer-friendly name for the article, often with-
out spaces. Code scripts can use the alias to jump to the article page.
You can leave the Alias box blank, however; Joomla will fill it in with the
title you added, with hyphens replacing any spaces.

For this exercise, type privacy-policy.

. In the text window, enter the article body.

For this exercise, use the following text:
Actually, we don’t really have a firm privacy policy.
Does that mean we’ll sell your email address to spammers?
Well, could be. . ..

At this point, your changes should look like Figure 4-1.

. Click the Save button.

The article-editor page closes, and Article Manager opens, displaying the
new article in the top row (see Figure 4-2).

To display all articles, you may need to click the Reset button next to
the Filter text box in the top-left corner of the page.

When you're done working with an article in the article-editor page, click
Save or Apply — don't just close the page. Whenever you open an article in

the editor page, Joomla checks that article out for you. If you just close the

editor page without applying or saving your changes, you may see a padlock
in the article’s Published column in Article Manager from then on, which
means that the article is still checked out. To check all articles back in, choose

Tools=>Global Checkin.
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Filtering uncategorized articles

As the number of articles on your site climbs, finding a particular uncatego-
rized article will get harder and harder. You can always search for an article
by title (if you remember the exact title) by entering it in Article Manager’s
Filter text box and then clicking Go. (Alternatively, you can enter the article’s
ID, although we’re not sure why Joomla thinks you would remember an arti-
cle’s ID a year later.)

But the more articles you assign to sections and categories overall, the fewer
articles you have to sift through to find the one uncategorized article you
want. Easy organization is one of the primary reasons for categorizing most
of your articles in the first place.

You've created a new article, but not a new Web page; you've just stored a
new article in the database. How does a user get to your new article? And what
does the new article look like? Those questions don'’t arise in Chapter 3, which
shows you how to create articles for display on the front page, but they do
come up here. To make an article accessible and to specify its actual layout,
you need to link it to a menu item.

Linking Articles to Menu Items

<MBER
é‘,\*

Working with menu items in Joomla means working with Menu Manager. In
fact, working with articles also means working with Menu Manager, which is
where you set the layout of an article.

A menu item determines the layout of articles.That’s one of the aspects

of Joomla that you have to get used to. Web pages don’t exist physically in
Joomla — only articles in the database — until the article is accessed. Joomla
takes advantage of this system by wrapping formatting options into menu
items.

Creating the menu item
To create a new menu item to link to an article, follow these steps:

1. Click the Menu Manager icon in the control panel or choose
Menus=>Menu Manager in any back-end page.

Menu Manager opens (see Figure 4-3).
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2. Click the Menu Item(s) icon of the menu to which you want to add an
item.
For this exercise, click the icon in the Menu Item(s) column in the Main
Menu row.
Menu Item Manager opens (see Figure 4-4).
3. Click the New button.
The New Menu Item page opens, displaying a node tree.
4. To create an internal link — one to an article on this Web site —
click the Internal Link node to open it (see Figure 4-5), and then click
Articles below it.
5. Below the Articles node, click Article; then click Article Layout below
it (see Figure 4-6).
&gN\BEH The Article Layout page opens (see Figure 4-7).
&

Article Layout refers to the node you selected in Step 5; you don’t actu-
ally select a layout in this page.
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Setting the menu item’s attributes

To set various attributes of the menu item you’re creating, follow these steps:

1.

In the Title and Alias text boxes, enter the title and alias, respectively,
of the new menu item.

For this exercise, type Privacy Policy as the menu item’s title and
privacy-policy as its alias.

. Make sure that the Display In drop-down menu is set to the correct

menu.

In this example, Main Menu should be selected, because you clicked the
Menu Item(s) icon in the Main Menu row to create the new menu item in
the first place.

. Make a selection in the Parent Item list to specify whether the new

menu item should be in a submenu.

You can make your new menu item a submenu item — that is, the child
of a parent menu. If you leave Top selected, your new menu item will be
a normal menu; if you select any other menu in this list, your new menu
item becomes a child item of that menu (and the user can see it by click-
ing the parent menu item).

. In the Access Level list, set the access level of the new menu item.

You can choose among three levels:
¢ Public: visible to everyone
¢ Registered: visible to logged-in users
¢ Special: visible to administrators

For this exercise, accept the default setting (Public).

. In the On Click, Open In list, specify how Joomla should display the

article when the user clicks your new menu item.
You have these choices:

¢ Parent Window with Browser Navigation

¢ New Window with Browser Navigation

¢ New Window without Browser Navigation

For this exercise, accept the default setting (Parent Window with
Browser Navigation).
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Linking the menu item to an article

The last step is linking the new menu item to a specific article. Follow these
steps:

1. Click the Select button in the Parameters - Basic section of the Article
Layout page (refer to Figure 4-7).

The article-selection page opens on top of the Article Layout page, as
shown in Figure 4-8.
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Note the Section and Category drop-down menus in Figure 4-8. You can
assign the new menu item to a section and category in this page, but leave
the menus alone for this exercise, because the article is uncategorized.

2. Select the Privacy Policy article.
The article-selection page closes.
3. Click the Save button to close the Article Layout page.

You return to Menu Item Manager, which displays a message that the
menu item was saved.
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Testing the new menu item

But was your menu item really saved? Is it really active? Take a look at the
front page now (refreshing it, if necessary) to check. As you see in Figure 4-9,
the Main menu has a new item — Privacy Policy — at the bottom. Great!
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Clicking the new Privacy Policy menu item opens the Privacy Policy page
(created on the fly by Joomla), as you see in Figure 4-10.

<P What’s an ad doing on your new page? That ad is the product of the Banners
module, which displays banner ads. To remove those ads, unpublish the
Banners module in Module Manager — that is, click the green check mark in
its Enabled column to change it to a red X. (For more information on using
Module Manager, refer to Chapter 3.)

Congratulations — you’ve added a new Web page to the SuperDuperMegaCo
site. The head Web designer would be very proud. (Only 9,999 more pages
to go!)

Now that you’ve created an uncategorized article, you're ready to create one
that fits into a category for easier navigation by users. That’s coming up next.
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|
Figure 4-10:
The new
page.
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Organizing with Sections

You can add new articles to existing Joomla sections and categories, of
course. All you need to do is select an existing section and category when
you create a new article. Joomla comes with three built-in sections:

v About Joomla

v News

v FAQs
But it doesn’t come with the sections you need for the example

SuperDuperMegaCo site, which requires Ice Cream, Sandwiches, and Ocean
Liners sections. So how do you create them? This section shows you how.

Creating a new section

In Joomla, you create new sections with Section Manager. In this part of the
chapter, you use it to create a new section for the example Web site. Follow
these steps:
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Figure 4-11:
Section
Manager.
|

1.

Click the Section Manager icon in the control panel, or choose
Content~>Section Manager in any back-end page.

Section Manager opens (see Figure 4-11).
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2.

5.

6.

Click the New button.

The New Section page opens. The Scope option is already set to content,
meaning that the section will contain article content.

Enter the new section’s title in the Title text box.

For this exercise, type Ice Cream.

Enter an alias in the Alias text box, if you want to use one.
For this exercise, type ice-cream.

In the Published section, make sure that the Yes radio button is
selected.

This option specifies whether the section is published — that is, visible
to users.

Select an option in the Access Level list — Public, Registered, or
Special — to specify who can access the articles in the section.

For this exercise, select Public.
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7. If you want to give the section an image (see “Selecting a section image,”
later in this chapter), choose it from the Image drop-down menu.

For this exercise, choose articles. jpg.

8. If you chose an image in Step 7, set its position by making a choice
from the Image Position drop-down menu: Center, Left, or Right.

For this exercise, choose Left.

9. In the Description window, enter a description of your new section.

For this exercise, type This is SuperDuperMegaCo’s Ice Cream Section.
10. Click the Save button.

The New Section page closes, and you return to Section Manager, which
displays the new section (see Figure 4-12).
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Selecting a section image
The default Joomla installation comes with several image files:

v articles.jpg
v clock.jpg
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¥ ext_com.png
V¥ ext_lang.png
v ext_mod.png
v ext_plugin.png
v joomla-dev_cycle.png
»” key.ipg
v pastarchives.jpg
v powered_by.png
V” taking_notes.jpg
v web_links.jpg
You can apply any of these images to a section in Section Manager. To pre-

view an image, select it in the New Section page of Section Manager (refer to
the preceding section), and Joomla displays it, as you see in Figure 4-13.
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Organizing with Categories

The default Joomla installation comes with these nine categories (organized
in these sections):
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v The Project (section: About Joomla!)
v The CMS (section: About Joomla!)
v The Community (section: About Joomla!)
v General (section: FAQs)
v Current Users (section: FAQs)
v New to Joomla! (section: FAQs)
v Languages (section: FAQs)
v Latest (section: News)
v Newsflash (section: News)
Want to change the section a category is assigned to? Just click the category’s

name in Category Manager, choose the new section from the Section drop-
down menu, and then click the Save button.

For the example site you're building, though, none of these categories will
work. The Ice Cream section you just created needs three categories: Bars,
Cartons, and Cones. In this section, you create a new category and assign
articles to it.

Creating a new category

To create a new category, follow these steps:

1. Click the Category Manager icon in the control panel, or choose
Content~>Category Manager in any back-end page.
Category Manager opens (see Figure 4-14).

2. Click the New button.
The New Category page opens.

3. Enter a title for the category in the Title text box.
For this exercise, type Cartons.

4. Enter an alias in the Alias text box, if you want to use one.
For this exercise, type cartons.

5. In the Published section, make sure that the Yes radio button is
selected.

6. From the Section drop-down menu, choose the section you want this
category to go in.

For this exercise, choose Ice Cream.



’00 Partll: Joomla

at Work

2 JoomlaSite - Administration - Microsoft Internet Explorer

Fle  Edt

View Favortes Tools Help .’,'

|
Figure 4-14:
Category
Manager. g

@Back - 0 [ [ b D search Ut Favorites £ - B g9 3 tiks
Address @] betpis i i indse.php?optionecom_cakegorisssection—com_content ~¥ B
- pa
 Joomlal' JoomlaSite
Site  Menus  Comtent  Components  Extensions  Tools  Help (5 Preview 0 ®1 Oiogout
= =
ol | Category Manager: [ Content] e 2 d ~ © O

Fublish Unpublish  Move  Copy  Delste  Edi Mew  Hel

Unoategorized v |[- Select State - v
7 4 Access 5 # #
I Title Published  Orders PO Section iton | ooy (10
= The Project o 1' Public  About Joomial 3 o 25
I The CMS 4 2 Public About Joomisl 5 o 29
I The Community 4 Public  Akout Joomial 2 o 30
3

I General ./ = Public  FaGs ] o3
= Currert Users J T Public  FAQs & o 28
Iz Heww to Joomial 4 : Public  Fo0s 3 o 27

— 200

ut with errars on page. %J Local intranet:

7.

8.

9.

10.

11.

Select an option in the Access Level list — Public, Registered, or
Special — to specify who can access the articles in the section.

For this exercise, select Public.

If you want to give the category an image (refer to “Selecting a section
image,” earlier in this chapter), choose it from the Image drop-down
menu.

For this exercise, choose articles. jpg.

If you chose an image in Step 8, set its position by making a choice
from the Image Position drop-down menu: Center, Left, or Right.

For this exercise, choose Left.
In the Description window, enter a description of your new section.

For this exercise, type This is SuperDuperMegaCo’s Ice Cream Cartons
category.

At this point, your settings should look like Figure 4-15.
Click the Save button.

The New Category page closes, and you return to Category Manager,
where you see the new category (line 8 in Figure 4-16).

Great — now you’ve added a new section (Ice Cream) and a new category
(Cartons) to your site. Now how about adding some articles to that new sec-
tion and category?
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Adding articles to a new category

In this section, you continue this process by creating new articles and adding
them to the new category.

For your example site, you get an e-mail from SuperDuperMegaCo, indicat-
ing that the company offers the finest ice cream in three flavors: chocolate,
vanilla, and sardine. You need to create new articles for each of these flavors
and then add those articles to the Cartons category of the Ice Cream section.
And you do just that in this section.

Adding one article
To add an article to a category, follow these steps:

1. Click the Add New Article icon in the control panel.
The Add New Article page opens.

2. Enter a title for the new article in the Title text box.
For this exercise, type Chocolate Ice Cream.

3. Enter an alias for the new article in the Alias text box.
For this exercise, type chocolate-ice-cream.

4. Choose Ice Cream from the Section drop-down menu.

5. Choose Cartons from the Category drop-down menu.

6. In the text window at the bottom of the page, enter a description.
At this point, your settings should look like Figure 4-17.

7. Click the Save button.

The Add New Article page closes, and Article Manager opens, displaying
the new article (line 37 in Figure 4-18).

Adding more articles

You can continue adding articles to a category by repeating the steps in the
preceding section.

For the example Web site, repeat the procedure twice to add these articles:

v A Vanilla Ice Cream article in the Ice Cream section and the Cartons
category

1 A Sardine Ice Cream article in the Ice Cream section and the Cartons
category

Now all three articles — Chocolate Ice Cream, Vanilla Ice Cream, and Sardine
Ice Cream — appear in Article Manager, as you see in Figure 4-19.
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As you may recall from “Linking Articles to Menu Items,” earlier in this chap-
ter, to make these three new articles visible on your site, you have to connect
them to menu items. You do that in the following section.

Choosing a Menu Structure

Now it’s time to link your categorized articles to menu items.

For the example site you're building, you need to make the Chocolate
Ice Cream, Vanilla Ice Cream, and Sardine Ice Cream articles visible to
users. You'll link them to the Main menu, because ice cream is one of
SuperDuperMegaCo’s main products.

You have three choices:

1. Add the three articles to the Main menu as three separate menu items.
2. Add an item to the Main menu that points to the Ice Cream section.

3. Add an item to the Main menu that points to the Cartons category.

You consider these choices.
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Option 1: Adding three menu items

The first choice works like this:

Main Menu Articles

Chocolate

Chocolate Ice Cream |----- >| Ice Cream
Vanilla

Vanilla Ice Cream |--—--—- >| Ice Cream
Sardine

Sardine Ice Cream |--—-—-—- >| Ice Cream

But this choice — add three new items to the Main menu, for chocolate ice

cream, vanilla ice cream, and sardine ice cream — doesn’t seem like such a
good idea. As you added more articles, you’d need more menu items. And if
SuperDuperMegaCo really is planning a site with 10,000 pages . . . well, that

would be a lot of menu items.

Option 2: Adding a menu item
that points to a section

The second choice works like this:

Main Menu Section Articles
Chocolate
Ice Cream Flavors |----- >| Chocolate|-->| Ice Cream
Vanilla
Vanilla |-->| Ice Cream
Sardine
Sardine |-->| Ice Cream
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This option — creating a menu item that points to the Ice Cream section —
seems as though it might work. The problem is that such a menu item would
take the user to a page that summarizes all the articles in the section, regard-
less of category. If you add the Bars and Cones categories to the Ice Cream
section, not only are you going to have a lot of articles, but also, you may

get the user mixed up. Which articles are for bars, which are for cones, and
which are for cartons?

Option 3: Adding a menu item
that points to a category

The third idea works like this (note that the example links to just a category,
not a whole section):

Main Menu Category Articles
Chocolate
Ice Cream Flavors |----- >| Cartons -->| Ice Cream
Vanilla

Sardine
-->| Ice Cream

This plan — create a menu item for the Cartons category — seems to be the
most workable. That way, all the flavors in that category will be summarized
in a single page, and the user can choose among them. Ice cream bars and
cones can have their own menu items, which will take the user to their own
article summary pages.

In the following section, you put this plan to work.

Linking Categories to Menu Items

When you decide how you want to structure your menus to point to articles
in specific categories, you're ready to do the actual linking.

For your example site, you want to create an Ice Cream Flavors item in the
Main menu and link that item to the Cartons category. The link will display a
summary of the three ice-cream-flavor articles, and users can select the one
they want to read. The following sections show you how.
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To create a new menu item that points to a specific category on your site,

follow these steps:

1. Click the Menu Manager icon in the control panel or choose

Menus->Menu Manager.

Menu Manager opens.

2. Click the icon in the Menu Item(s) column of the Main Menu row.

Menu Item Manager opens.

3. Click the New button.

Joomla displays the New Menu Item page.

4. Expand the node tree by clicking Internal Link=>Articles=>Category

(see Figure 4-20).
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5. Below the Category node, click Category Blog Layout.

The Category Blog Layout page opens.

This page doesn’t actually create a blog. Blog Layout is Joomla’s way of
saying that each article will be summarized (the first sentence or two will be
displayed) and that you can add a Read More link so that users can read the
rest of the article. (See “Creating Read More Links,” later in this chapter.)
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6. Enter a title for the new menu item in the Title text box.
For this exercise, type Ice Cream Flavors.

7. Enter an alias for the new menu item in the Alias text box.
For this exercise, type ice-cream-flavors.

8. On the right side of the page, click Parameters - Basic to expand that
section, and choose Ice Cream/Cartons from the Category drop-down
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menu.

At this point, your choices should look like Figure 4-21.

2 Menu Item: [New] - Microsoft Internet Explorer g@@
r

9. Click Save.
The Category Blog Layout page closes.

10. View the front page in a browser or click the Preview link in any back-

end page.

You see the new menu item — Ice Cream Flavors, in this example.

11. Click the new menu item to display the new category page (see

Figure 4-22).

If you scroll up and down the page, you can see all the articles: choco-
late ice cream, vanilla ice cream, and even sardine ice cream. Looks

good, right?
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Creating Read More Links

What Joomla calls blog layout is really called that because it presents a sum-
mary of each article followed by a Read More link — not because you’re actu-
ally writing a blog. In this section, you see how to add Read More links to a
category page, so that you don’t have to display the entire text of each article
on the front page.

To add Read More links to a category page, follow these steps:
1. Click the Article Manager icon in the control panel or choose
Content~>Article Manager in any back-end page.
Article Manager opens.
2. Open an article that you want to add a Read More link to.

For this exercise, open the Chocolate Ice Cream article in Article
Manager.

3. Scroll to the bottom of the page, where you find the Read More button.

4. Click the place in your article’s text where you want that link to
appear; then click the Read More button.

For this exercise, click after the second sentence.

Joomla inserts a red dotted line (black in this book!), as you see in
Figure 4-23.
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5. Repeat Steps 2-4 for any other articles to which you want to add links.

For this exercise, add links for the Vanilla Ice Cream and Sardine Ice
Cream articles.

6. View your front page again, and click the link to the category page for
which you added Read More links.

For this exercise, click the Ice Cream Flavors link in the Main Menu pane.

The category page opens, displaying your new Read More links (see
Figure 4-24).
7. Click a link to open the corresponding article in full (see Figure 4-25).

That’s great — but you may have noticed that Joomla got the order of your ice
cream articles in the category page wrong. SuperDuperMegaCo wants this order:

v Chocolate
v Vanilla
v Sardine
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But Joomla gave you this order:

v Sardine
v Vanilla
v Chocolate

This arrangement is in reverse because by default, the most recently created
article goes at the top of the category. How can you fix the order? You see

how in the following section.

Adjusting Article Order

How can you alter the position of articles? You use Article Manager (click
the Article Manager icon in the control panel or choose Content=>Article
Manager in any back-end page). As Figure 4-26 shows, however, Article
Manager displays too many articles to work with conveniently.

2 JoomlaSite - Administration - Microsoft Internet Explorer
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Now you see another advantage of dividing your articles into sections and
categories: You can use those divisions to filter articles in Article Manager

and work with just the ones you want.
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Joomla currently has only two levels of organization: sections and categories.
But plans are afoot to make the organizational levels infinite (presumably by
numbering them) in future versions of Joomla.

Filtering articles

Chapter 3 also discusses filtering articles, but we give you a refresher in this
section. To filter articles in Article Manager, choose the section and category
you want to view from the Section and Category drop-down menus at the top
of the page.

For this exercise, choose the Ice Cream section and Cartons category. Article
Manager displays just those articles (see Figure 4-27).
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EEE— 48] Dane, but with errors on page. %J Local intranet

Reordering articles in Article Manager

When you'’ve filtered Article Manager to display just the articles you want to
work with, you're ready to change their order. Follow these steps:

1. In the Order column (refer to Figure 4-27), click the green up and
down arrows to position articles where you want them, or enter ordi-
nal numbers in the text boxes.
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For this exercise, enter 1 for Chocolate Ice Cream, 2 for Vanilla Ice
Cream, and 3 for Sardine Ice Cream.

2. Click the floppy-disk icon at the top of the Order column.

Joomla displays the articles in the new order (see Figure 4-28).
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You did it, right? Actually, no. Changing the order of articles in Article
Manager only changes the order of articles in Article Manager. If you look at
the category page for the Cartons category, you see that the article order is
unchanged.

To change the order in which articles appear in the category page, you need
to use Menu Manager, as we show you in the following section. (For more
information on Menu Manager, refer to “Creating the menu item,” earlier in
this chapter; also see Chapter 3.)

Reordering articles in the category page

To reorder articles in the category page, follow these steps:

1. Click the Menu Manager icon in the control panel or choose
Menus=>Menu Manager in any back-end page.

The Menu Manager opens.



|
Figure 4-29:
The
Category
Blog Layout
page.
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2. Click the icon in the Menu Item(s) column of the Main Menu row.

The Menu Item Manager opens.

3. Click Ice Cream Flavors to open that menu item in an editor.

4. Click the Parameters - Advanced bar to open that section, as shown in

Figure 4-29.
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Hews Feeds [}
Published: ¢ o & ves
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This page is where you set the order of articles as they appear in the

category page.

5. From the Primary Order drop-down menu, choose an option to specify

the order in which you want orders to appear.

In your example site, your articles appear in chronological order (most
recent first), and you want them to appear in reverse chronological

order (oldest first). So for this exercise, choose Oldest First.

6. Click the Apply button in the top-right corner of the page.

N

8. Click the link of the pertinent category page to view the new article

order (see Figure 4-30).

. View the front page in a browser.
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2l Cartons - Ice Cream Flavors - Microsoft Internet Explorer
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Success — the articles are now ordered the way you want them. But the
menu items may not be quite right. We show you how to make them right in
the following section.

Who's on First?: Setting
Menu Item Position

As the preceding section shows, you can change the order of articles in
Article Manager, but the layout of those articles doesn’t actually change; you
have to make that change in Menu Item Manager. Consequently, Menu Item
Manager is more powerful than Article Manager when it comes to the actual
layout of your articles.

Given that Menu Item Manager is the layout king, then, you shouldn’t be sur-
prised to discover that you can use it to set the order of menu items as well.
This arrangement illuminates Joomla’s inner workings: Joomla wraps up all
the layout details in the pertinent menu items, not in the articles themselves.

QQ,N\BER Whereas adjusting the position of items in the Order column of Article

Y Manager doesn’t affect their layout on the page (layout is up to Menu Item
Manager; refer to “Reordering articles in Article Manager,” earlier in this
chapter), changing the position of menu items in Menu Item Manager’s Order
column does change the position of a menu item on the page.
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Reviewing the example site

In your example site, the order of menu items probably isn’t what
SuperDuperMegaCo wants. Currently, the items are in this order:

»* Home

v Joomla! Overview

1 More about Joomla!

v FAQ

v The News

v+ Web Links

1 News Feeds

v Privacy Policy

v Ice Cream Flavors
But because ice cream is one of the client’s major products, that item prob-
ably should appear near the top of the list, like this:

v+ Home

v Ice Cream Flavors

v Joomla! Overview

1 More about Joomla!

v FAQ

v The News

v+ Web Links

1 News Feeds

v Privacy Policy

So how do you move items around in a menu? Read on.

Changing the order of menu items

To change the order of the items in a menu, follow these steps:

1. Click the Menu Manager icon in the control panel or choose
Menus->Menu Manager in any back-end page.

Menu Manager opens.
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2. Click the icon in the Menu Item(s) column of the Main Menu row.
Menu Item Manager opens.

For your example site, the Ice Cream Flavors menu item is listed dead
last in the Order column, as shown in Figure 4-31.

EBX

2 View Menu Item(s) - Microsoft Internet Explorer

File Edt View Favorites Toos Help o
QBack = O [H @ b O seach LrFavoites £ 9+ L g3 Links ™
) 3 ”~
5 | More about Joomia! v o Public Articles » Section 37
B I FAG ~ = = Public Articles » Section “
7 r The News o = Public Articles » Category f Blog 50
g r Wyieh Links o4 = Public Whieb Links » Categories 48
a & Mews Feeds ' 5 Public Mews Feeds » Categories 49
I
. 18| I Privacy Policy ' S Public Articles » Article 5%
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3. In the text box of the menu item’s Order column, enter a new position
number.
For this exercise, enter 2 for Ice Cream Flavor.
4. Click the floppy-disk icon at the top of the Order column.
Joomla displays the menu items in the new order (see Figure 4-32).
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order. i
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Figure 4-33:
The new
menu-item
order.

5. Click Save in the Menu Item Manager page to close it.
6. View the front page again.

You see the menu items displayed in the new order (see Figure 4-33).
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Ice Cream Flavors

Home
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Removing menu items

Another way to reorganize menus is to remove some menu items. You can either

trash them or unpublish them. We show you both methods in this section.

Unpublishing items
To unpublish menu items, follow these steps:
1. Click the Menu Manager icon in the control panel, or choose
Menus=>Menu Manager in any back-end page.
Menu Manager opens.
2. Click the icon in the Menu Item(s) column of the Main Menu row.

Menu Item Manager opens.

3. In the Published column of each menu item you want to remove, click

the green check mark to change it to a red X.

For this exercise, change green checks to red X marks for the following

menu items:
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Figure 4-34:
A trimmer
menu.
|

¢ Joomla! Overview

e What’s New in 1.5?
¢ Joomla! License

e More about Joomla!
¢ FAQ

When you unpublish a menu item, it’s unpublished immediately; you
don’t have to click the Save or Apply button.

4. View the front page again.

You see the new, leaner menu (see Figure 4-34).
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Trashing items

Besides unpublishing items in Joomla, you can delete them by trashing them.

So should you unpublish or trash unused items?

Trashing an item (and deleting it by emptying the trash) is forever, so we

favor unpublishing items, because you can easily publish them again. As time

goes on, however, the performance of your site can degrade significantly
if you have too many unpublished items, which Joomla still has to manage
behind the scenes.
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If you have items (menu items, articles, and so on) that you know you’ll never
use again, you should trash them. Here’s how:

1.

Complete Steps 1 and 2 of “Removing menu items” to open Menu Item
Manager.

2. Check the check box at the beginning of the item’s row.

3. Click the trash icon in the top-right corner of the page.

You've just moved the item to the trash, however. To delete it, you have
to use Trash Manager.

. Choose Menus~>Menu Trash to trash a menu item.

or
Choose Content=>Article Trash to trash an article.

The appropriate Trash Manager opens.

. For each item you want to delete, check the check box at the begin-

ning of its row.

. Click the Delete icon in the top-right corner.

Trash Manager deletes the item forever.

. Choose Filez>Control Panel to go back to the control panel.
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Chapter 5

Building Navigation into
Your Site with Menus

In This Chapter

Understanding menus in Joomla
Adding submenus

Working with list layouts
Putting menu options to work
Creating a default menu item

Using menu separators

M enus in Joomla are central to everything — more so than people not
in the know can imagine. You can’t view a Web page in Joomla that

doesn’t have a menu item pointing to it, and when you create a menu item,
you select the layout of the Web page to which it points.

Joomla packs a lot into menus, and this chapter is theirs.

All about Joomla Menus

Because Web pages don’t exist in Joomla until the data in is accessed
through menu items, Joomla wraps all the presentation details of Web pages
into menu items. Templates (see Chapter 9) may be responsible for what
goes where in a page, using a mix of HTML and CSS, but the menu item deter-
mines what template Joomla uses to lay out the resulting Web page.

When you create a menu item, you specify the layout that Joomla will use to
display the linked-to Web page, and you can choose among a large number of
options. You can create standard Web pages (stand-alone articles), category
pages (which show an overview of all the articles in that category), and
section pages (which show an overview of all the articles in that section).
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You can publish to the front page of your site or to external sites. You
can also link to specific types of modules: polls, search boxes, wrappers
(which present external pages in Joomla pages; see Chapter 8), and so on.

All these layout options give you a rich tool set — richer than in other con-
tent management systems. The previous chapters show you how to work
with menu items, because you can’t get anywhere in Joomla without them,
but this chapter is where menus really shine.

To make menu creation easier to understand, we use a single example
throughout this chapter, but feel free to substitute your own site structure
and text.

Under and Over: Creating
Submenu Jtems

Because it’s impossible to display Web pages in Joomla without a menu item
pointing to that page, Chapters 3 and 4 show you the basics of working with
menus. In this chapter, however, you discover more in-depth menu power.

We start by showing you how to create submenu items: menu items that
appear below other menu items.

As an example, this section works with a Web site that has an Ice Cream
section and a Bars category, with the following articles in that category:

| SuperDuperMega Bar
|

| Tutti Fruity Bar

|

| Broccoli Bar

(Yes, we know that it’s usually spelled tutti frutti.)

You can use three submenus to display these articles.

Creating the section and category pages

First, you need to create the section and category pages. (If you completed
the exercises in Chapter 4, you may already have them on your computer;
apply these directions to your own situation.) Follow these steps:
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|
Figure 5-1:
Creating a
category.
|

Fle  Edit View Favortes Tools Help -
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. Click the Section Manager icon in the control panel or choose

Content->Section Manager in any back-end page to open Section
Manager.

2. Click the New button to open the New Section page.

. Enter the new section’s title in the Title text box.

For this exercise, type Ice Cream.

4. Click the Save button.

. Click the Category Manager icon in the control panel or choose

Content=>Category Manager in any back-end page to open Category
Manager.

6. Click the New button to open the New Category page.

7. Enter a title for the new category in the Title text box.

For this exercise, type Bars.

. From the Section drop-down menu, choose the section in which you

want to place the new category.

For this exercise, choose Ice Cream.

. In the Description text box at the bottom of the page, enter a

description.

At this point, your settings may resemble Figure 5-1.
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This categary is for the ice cream bars that SuperDuperMegaco offers.|
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10. Click the Save button.

You return to Category Manager, which displays the new category.
(If you completed the exercises in Chapter 4, you may also see a
Cartons category.)

Creating target Web pages

Next, you need to create an article for each submenu item: the target Web
page to which that submenu item points. Follow these steps:

1.

Click the Add New Article icon in the control panel, or choose
Content=>Article Manager in any back-end page to open Article
Manager and then click the New button.

The article-editor page opens.

. Enter a title for the article in the Title text box.

For this exercise, type SuperDuperMega Bar.

. Choose the appropriate section from the Section drop-down menu and

the category from the Category drop-down menu.

For this exercise, choose Ice Cream as the section and Bars as the
category.

. In the text box at the bottom of the page, enter the article text.

At this point, your settings may resemble Figure 5-2.

. Click the Save button.

Article Manager opens, listing the new article.

. Repeat Steps 1-5 to add as many articles as you want.

For this exercise, create two more articles: Tutti Fruity Bar and
Broccoli Bar. Assign both of them to the Ice Cream section and the
Bars category. When you finish, your Article Manager page should
resemble Figure 5-3.
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|
Figure 5-4:
The new
parent menu
item on the
Web site.
|

Creating the parent menu item

After you have the articles for the submenu items, you need to create a
parent menu item (refer to Chapter 4) for the submenu items. Follow
these steps:

1.

10.

Create a new dummy article to link to.

For this exercise, title the article Ice Cream Bars.

. Click the Menu Manager icon in the control panel or choose

Menus=>Menu Manager in any back-end page to open Menu Manager.

. In the row of the menu where you want to place the parent menu,

click the icon in the Menu Item(s) column.
For this exercise, select Main Menu.

The Menu Item Manager page opens.

. Click the New button.

The New Menu Item page opens, displaying a node tree.

. Click Internal Link=>Articles>Article>Article Layout to open the

Article Layout page.

. Enter a title for the new menu item in the Title text box.

For this exercise, type Ice Cream Bars.

. In the Parameters - Basic pane, click the Select button to browse to

and select the article that you want to link to the menu item.

For this exercise, select the Ice Cream Bars article.

. Click the Save button.

You return to Menu Item Manager.

. If you want to change the order in which the menu items appear,

enter new ordinal numbers in the Order columns of the menu items;
then click the floppy-disk icon at the top of the column.

For this exercise, type 3 in the Order column of the Ice Cream Bars menu
item.

Click the Preview link to view your site.

Joomla displays the updated menu, which may resemble the one shown
in Figure 5-4.
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Creating the submenu Items

To add the submenu items, follow these steps:

1.

Click the Menu Manager icon in the control panel or choose
Menus=>Menu Manager in any back-end page to open Menu
Manager.

. In the row of the menu that you want to use as the parent menu,

click the icon in the Menu Item(s) column.
For this exercise, select Main Menu.

The Menu Item Manager page opens, displaying a node tree.

. Click Internal Link=>Articles>Article=>Article Layout to open the

Article Layout page.

. Enter a title for the submenu item in the Title text box.

For this exercise, type SuperDuperMega Bar.

. In the Parent Item list, select the new submenu item’s parent menu.

For this exercise, select Ice Cream Bars (refer to “Creating the parent
menu item,” earlier in this chapter).

. In the Parameters - Basic pane, click the Select button to browse to

and select the article that you want to link to the submenu item.

For this exercise, select the SuperDuperMegaBar article (refer to
“Creating target Web pages,” earlier in this chapter). At this point, your
settings should resemble Figure 5-5.

7. Click the Save button.

8. Repeat Steps 2-7 to create as many submenu items as you want.

For this exercise, create two more submenu items: Tutti Fruity Bar and
Broccoli Bar.

. Click the Preview link to view your site.

Joomla displays the new submenu items, which may resemble
Figure 5-6.

Clicking any of those new submenu items takes you directly to the page to
which the item is linked.

Because the menu item to which an article is linked determines how Joomla
displays that article, you turn your attention next to layout options. Chapter 4
presents article layout and blog layout. The other major layout type is list,
which we cover in the following section.
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Click Me: Working with List Layout

List layout is like blog layout in that you use it to display an overview of

Joomla articles. Instead of displaying introductory text for articles, however,

list layout shows a simple list of links to articles.

For the example in this section, you create a Cones category in the Ice Cream

section and apply list layout to the articles in that category:
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SuperDuperMega Cone
Sprinkles Cone

Gravy Cone

Creating the category

To start, create the new category, as follows:

1. Click the Category Manager icon in the control panel or choose
Content~>Category Manager in any back-end page to open Category
Manager.

2. Click the New button to open the New Category page.

3. Enter a title for the new category in the Title text box.
For this exercise, type Cones.

4. Choose a section from the Section drop-down menu.
For this exercise, choose Ice Cream.

5. In the Description text box at the bottom of the page, enter a
description of the new category.

6. Click the Save button.

You return to Category Manager.

Creating the articles

Next, you need to create the articles for the new category. Follow these steps:

1. Click the Add New Article icon in the control panel, or choose
Content=>Article Manager in any back-end page to open Article
Manager and then click the New button.

The article-editor page opens.
2. Enter a title for the article in the Title text box.
For this exercise, type SuperDuperMega Cone.

3. Choose the appropriate section from the Section drop-down menu and
the category from the Category drop-down menu.

For this exercise, choose the Ice Cream section and the Cones category.
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4.
5.

6.

In the text box at the bottom of the page, enter the text for the article.
Click the Save button.

You return to Article Manager.

Repeat Steps 1-5 to add as many articles as you want.

For this exercise, add two more articles: Sprinkles Cone and Gravy Cone.
Assign both articles to the Ice Cream section and the Cones category.

Creating the menu item

To create the menu item to which you’ll link the new articles, follow these
steps:

1.

Click the Menu Manager icon in the control panel or choose
Menus=~>Menu Manager in any back-end page to open Menu Manager.

. In the row of the menu to which you want to add the new item, click

the icon in the Menu Item(s) column.
For this exercise, select Main Menu.

The Menu Item Manager page opens, displaying a node tree.

. Click Internal Links=>Articles~> Category~ Category List Layout to open

the Category List Layout page.

. Enter the title of the new menu item in the Title text box.

For this exercise, type Ice Cream Cones.

. Enter an alias for the menu item in the Alias text box.

For this exercise, type ice-cream-cones.

. From the Display In drop-down menu, choose the parent menu for the

new menu item.

For this exercise, choose Main Menu.

. In the Parent Item list, select the parent menu’s level.

For this exercise, because you're using the Main menu, select Top.

8. In the Published section, select the Yes radio button.

. In the Access Level list, select Public.
10.

In the On Click, Open In list, select Parent Window with Browser
Navigation.
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|
Figure 5-7:
Creating a
menu item.
|

11. In the Parameters - Basic pane, choose the category from the Category
drop-down menu.

For this exercise, choose Ice Cream/Cones. At this point, your settings
may resemble Figure 5-7.

12. Click the Save button.

You return to Menu Manager, which displays the new menu item.
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Changing the order of menu items

You can see the new menu item in Menu Manager, but it’s been added to

the bottom of the list of menu items — and, therefore, will appear last in its
parent menu. You can change that arrangement by entering new ordinal
numbers in the menu items’ Order columns and then clicking the floppy-disk
icon at the top of the column.

For this exercise, type 4 in the Ice Cream Cones menu item’s Order column,
and click the floppy-disk icon at the top of the column to save the new order.
Now you’ve got the menu items in the order you want (see Figure 5-8).
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Viewing the list layout
To see what your site looks like at this point, click the Preview link at the top
of any back-end page to open a preview of your site in a new browser
window). You should see the new menu item you added. Now click that menu
item, and you should see the articles that you linked to it displayed in list
layout. Figure 5-9 shows an example. The article titles in the list are links, and
you can click them to open the associated articles.
Changing article order in list layout
If the articles don’t appear in the order you had in mind, you can rearrange
them. Do you use Category Manager? Nope. Article Manager? Nope. You use
Menu Item Manager.
<MBER §
S
&

In Joomla, the layout of a page is determined by the menu item that links to
that page (and the template used in that page).
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To rearrange the order of articles in list layout, follow these steps:
1. Click the Menu Manager icon in the control panel or choose
Menus=~>Menu Manager in any back-end page to open Menu Manager.

2. In the row of the menu to which you want to add the new item, click
the icon in the Menu Item(s) column.

For this exercise, select Main Menu.
The Menu Item Manager page opens, displaying a node tree.

3. Click the name of the menu to open the Edit Menu Item page.
For this exercise, click Ice Cream Cones.

4. Click the Parameters - Advanced bar to open that pane.

5. Choose a new order from the Primary Order drop-down menu.

For this exercise, choose Oldest First. At this point, your settings may
resemble Figure 5-10.

6. Click the Save or Apply button.
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Now you’ve mastered list layout.

The following sections give you an in-depth look at the options available for
the three most common types of menu-item layouts: standard article layout,
blog layout, and list layout. Together, those three layout types make up the

majority of menu-item layouts in Joomla sites, and you have to know what’s
available to use them effectively.

Choice, Choices: Taking Advantage
of Your Menu Options

Joomla offers a long list of options for different types of layouts, including
those shown in Figure 5-11.

We haven’t got space in this book to examine all these options, so we give
you a brief overview and then show you how to use a few selected options.

Typically, four parameters panes are available when you set the layout
connected with a menu item: Basic, Advanced, Component, and System. We
discuss these panes in the following sections.
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Basic parameters

The top parameters pane in menu-item layout pages is always Parameters -
Basic, which offers a limited number of options. Typically, this pane is
where you select the article you want to link to or the section or category
in which you want to display a page. Here are typical options in the
Parameters - Basic pane:

v Select Article: The article to link to

1 Category and Section: The category and section to create a layout
page for

v+ Description: A section or category description (show or hide)

v Description Image: An image for a section or category (show or hide)

Advanced parameters

Advanced parameters are available for category or section layouts, not
standard article layouts. Here are the kinds of items you’re likely to see in
the Parameters - Advanced pane:
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1 Category or Section Order: The order of the articles in a section or
category layout. You can sort by primary order (see the following item),
alphabetically by title, or reverse-alphabetically by title.

v Primary Order: The order of the articles in a section or category layout.
Your options include oldest or newest article first, alphabetically by
title or author, and most or least hits.

1 Pagination: Whether to display pagination (show or hide).
+* Show a Feed Link: Whether to display an RSS link (show or hide).

Component parameters

The items in the Parameters - Component pane are the same in most types of
layouts: article, category, section, and so on. Here are the parameters you're
likely to see:

+* Show Unauthorized Links: Whether to display unauthorized links (show
or hide) — that is, links that the user doesn’t have sufficient privileges
to view

1 Show Article Title: Whether to display article titles (show or hide)
v~ Title Linkable: Whether the title should be a link

v+ Show Intro Text: Whether to display introductory text for each article
(show or hide)

1 Section Name: Whether to display the section name (show or hide)

1 Section Title Linkable: Whether the section name should be a link to the
section

v Category Title: Whether to display the category title (show or hide)

v Category Title Linkable: Whether the section name should be a link to
the category

v Author Name: Whether to display the author name (show or hide)

v Created Date and Time: Whether to display the creation date and time
(show or hide)

v Modified Date and Time: Whether to display the date and time of the
last modification (show or hide)

1 Show Navigation: Whether to display navigation links between articles
(show or hide)

1 Read More: Whether to display a Read More link for each article (show
or hide)

v Article Rating/Voting: Whether users are allowed to rate articles
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v Icon options: Whether to display Print, PDF, and E-Mail icons (show
or hide)

v Hits: Whether to track hits

System parameters

You usually have a Parameters - System pane for all layout types. Here’s what
you find in this pane:

v Page Title: The title of the page

1 Show Page Title: Whether to display the page title (show or hide)

+* Menu Image: An image for the menu

1 SSL Enabled: Whether the menu will appear in a secure connection
using SSL (Secure Socket Layer)

Setting Some Powerful Menu Options

You have plenty of options when it comes to configuring your menu items in
Joomla. In the following sections, you put a few of these options to work.
Mastering these options is crucial to creating a professional-looking site.

Turning article titles into links

When you use category list layout, all the article titles in a category are links
automatically, but they’re not when you use category blog layout. You can
change that situation via the settings in the Parameters - Component pane.
Follow these steps:

1. Open the menu item that links to the article you want to change by
clicking that menu item in Menu Item Manager.

For this exercise, open the category blog layout page for the Ice Cream
Flavors menu item.

2. In the Parameters - Component pane, choose Yes from the Title
Linkable drop-down menu (see Figure 5-12).

3. Click the Apply button (to apply your change) or the Save button
(to apply your change and close the Menu Item Editor page).

Joomla now displays linked article titles in category blog layout. Figure
5-13 shows an example.
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We recommend that you always set your article titles as links when you use
category blog layout, because users expect titles to be links.

Showing article ratings

How about letting users rate an article? To do that, follow these steps:

1. Open the menu item that points to the article you want to let users
rate by clicking that item in Menu Item Manager.
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2. In the Article Layout page, click the Parameters - Component bar to
open that pane.

3. Choose Show from the Article Rating/Voting drop-down menu
(see Figure 5-14).

4. Click the Apply or Save button.
5. Click the Preview link in any back-end page to view your site.

Users can now rate the article via a series of radio buttons, from Poor to
Best (see Figure 5-15).

Author Hame | Use Global |+ |
i Created Date and Time | Use Globsl ||
Flgure 5-1 4: Modified Date and Time | Use Global =
ShOV\{Ing Show Havigation | Use Global |
ar'tlde Read more... Link | Use Global % |
ratlngs Article Rating/Voting | Show |
|
e | Crocooli Bar
User Rating. ® "
Figure 5-15: | For O OO O @ gest[Rate]
An article’s ; -
ratings.
ABROCCOL bar??
|

Setting menu access

Suppose that you want to allow only logged-in users to access a certain arti-
cle. To do that, follow these steps:

1. Open the pertinent menu item in the Menu Item Editor by clicking
that item in Menu Item Manager.

2. Make a selection in the Access Level list.
For this exercise, select Registered (logged-in users only).

3. Click the Save button.

Now any user who isn’t logged in can’t see the article.

Opening articles in new windows

Perhaps you want a new browser window to open when a user clicks a
certain menu item. To set up that behavior, follow these steps:
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Figure 5-16:
Setting
anew
browser
window to
open.
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1. Open the pertinent menu item by clicking that item in Menu Item

Manager.

. In the On Click, Open In list, select New Window with Browser

Navigation (see Figure 5-16).

. Click the Apply or Save button.

Now when the user clicks the menu item, a list of articles in that
category opens in a new window. When the user clicks the name of an
individual article, however, the article appears in that same window.

If you want to open a new browser window without an address bar, toolbars,
or menu bar, select New Window without Browser Navigation in Step 2.

Hiding author names

You may want to clean up your Joomla site’s pages a little. One place to start
is the Written by Administrator line that appears at the top of every article

by default. You can hide this author name, or any other author name, in
individual articles linked to a menu item or in all articles on the site. We show
you both methods in the following sections.

By menu item

To hide an author’s name in one or more articles linked to a menu item,
follow these steps:

1.

Open the pertinent menu item by clicking that menu item in Menu
Item Manager.

2. Click the Parameters - Component bar to open that pane.

. Choose Hide from the Author Name drop-down menu (see Figure

5-17).

4. Click the Apply or Save button.

5. Click the Preview link in any back-end page to view your site.

The author name no longer appears in any articles linked to that
menu item.
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Across the site

You can also remove author names from all articles on your site by resetting
the global article parameters. Follow these steps:

1. Choose Content=>Article Manager in any back-end page to open
Article Manager.
2. Click the Parameters button.

A pop-up window appears, displaying global article settings (see
Figure 5-18).

This window is where you set the global article parameters used by
default in menu item layouts.

3. In the Author Name section, click the No radio button.
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Figure 5-19:
Navigation
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4. Click the Save button to close the pop-up window and return to
Article Manager.

5. Click the Preview link to view your site.

Author names no longer appear on articles.

Showing article-to-article links

You can display navigation links from article to article in a category or sec-
tion, if you like. In a menu item’s Parameters - Component pane (which you
reach by clicking the item in Menu Item Manager and then clicking the
Parameters - Component bar on the right side of the Menu Item Editor page),
simply choose Show from the Show Navigation drop-down menu, and click
the Apply button.

Now users can navigate the articles in a category by using Prev and Next
links (see Figure 5-19).

Speaking of navigation, links like Home >> Ice Cream Cones >> Sprinkle Cones
are called breadcrumbs. Breadcrumbs appear by default; you can turn them off
in Module Manager. For details, see Chapter 7.

Sprinkle Cone Le=
Usually, we have all kinds of sprinkles on our sprinkle cones. Due to cuthacks, however, we no longer offer
strawberry, lemon, blueberry, chocolate, raspberty, pomearanate, persimmaon, champaane, or caviar sprinkles. Hope
you like licorice sprinkles!

= Prev Mext =

Setting Default Menu Items

Some menu items are activated by default in Joomla, such as the Home item
in the Main menu, because it points to the front page. You can determine
what menu item is the default by looking at the menu’s Default column in
Menu Item Manager. Home is the default item in the Main menu when you
install Joomla — but you can change that.

To set a new default menu item, follow these steps:

1. Click the Menu Manager icon in the control panel or choose
Menus=>Menu Manager to open Menu Manager.

2. Click the icon in the Menu Item(s) column of the menu you want to
change.

Menu Item Manager opens.
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3. Check the check box of the menu item that you want to make
the default.

4. Click the Default button.

The Menu Item Manager page updates, and you see a gold star (black
and white in this book) in the menu’s Default column (see Figure 5-20).

A\
To restore your site, repeat this procedure to make the original default item
the default again.
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Creating Menu Separators

As our last topic for this chapter, in this section we show you how to create
menu separators. A menu separator is an inactive menu item that you

use to group or offset other menu items. You create separators with the
Separator menu item type.

To create a menu separator by changing a menu item’s type, follow
these steps:

1. Open a menu item in the Edit Menu Item page by clicking the menu
item in Menu Item Manager.

2. Click the Change Type button.
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The Change Menu Item page opens, displaying a list of possible types
(see Figure 5-21).

3. Select the Separator type.
The Separator page for the selected menu item opens,

4. In the Title text box, enter the character(s) you want to display as the
separator.

For this exercise, enter a hyphen (-).
. Click the Apply button.

(2]}

6. Click the Preview link in any back-end page to view your site.

You see the new separator in the menu (see Figure 5-22).

A\
You can also create menu separators from scratch, of course. Just select the
Separator menu type when you create a new menu item.
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Chapter 6
Mastering Web Page Creation

In This Chapter

Setting article options

Working with the editor

Formatting and embellishing articles

Using tables and columns

Adding a table of contents

Scheduling publishing (and unpublishing)
Making your site interactive with user roles
Counting page hits

Taking down the site

Fere’s a terrific amount of Web-page power in Joomla, and this chapter
takes a look at it in depth. You can set up articles so that Joomla starts
publishing them at a later date automatically — or even stops publishing
them automatically at a later date. You can insert images in articles, track
page hits, set up article columns, and create automatic tables of contents.
You can even allow some users to edit articles from the front end (not

the back end), although you get the chance to approve or disapprove their
edits before they get published.

That’s the kind of stuff that’s coming up in this chapter. We introduce
writing Web-page content in Chapter 4, but this chapter is where this
topic really takes off. To start this chapter, you get control of the article-
creation process, seeing what options are available and putting those
options to work.

Working with Article Options

Take a look at Figure 6-1: an uncategorized privacy policy open in the Joomla
article editor. (To open the article editor, click the Article Manager icon in
the control panel, or choose Content=>Article Manager in any back-end page.)
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You're going to see this page a lot as you work with Joomla, so it really pays
to know what’s going on in it. The following sections give you an overview of
the options in the article editor; then you put some of these options to work.

Article options

These options appear in the top-right corner of the article-editor page:
v Article ID: Joomla’s internal ID for the article. (You can search for
articles by ID or title.)
1~ State: The article’s state (published or unpublished).
v~ Hits: The number of times the article has been viewed.
v Revised: The number of times the article has been revised.
1 Created: The article’s creation date.
v Modified: Setting indicating whether the article has been modified and

the date it was modified.

Below this list of options are the parameters you can set for the article,
which we describe in the following sections.
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Parameters - Article options

The Parameters - Article section, directly below the options we list in the
preceding section, contains these items:
v Author: The username of the article’s author.

v Author Alias: An alias for the author, should you want to use one.
If you list an alias, it appears on the Web page instead of the author’s
username.

v Access Level: The access level that users must have to see this article.
Here are the options:

e Public: Everybody
* Registered: Logged-in users
¢ Special: Administrators
1 Created Date: The date the article was created.

v~ Start Publishing: The date and time you want to start publishing
the article.

v~ Finish Publishing: The date and time you want Joomla to stop
publishing the article, if any.

Parameters - Advanced options

Here are the advanced parameters in the Parameters - Advanced section of
the article editor. For most options, your choices are Use Global (that is, use
the setting in the Global Configuration page, which you access by choosing
Siter>Global Configuration), Yes/Show, and No/Hide.

1 Show Title: Indicates whether you want to show the article title

v Title Linkable: Indicates whether the article title, if visible, should be a
link to the full article

v Intro Text: Indicates whether introductory text for the article should be
visible

1+ Section Name: Indicates whether the section name of the article should
be visible

+* Section Title Linkable: If the section title is visible, indicates whether
you want it to be a link to the section

v Category Title: Indicates whether the category name of the article
should be visible

v Category Title Linkable: If the category title is visible, indicates whether
you want it to be a link to the category
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v Article Rating: Indicates whether users can rate the article (see
Chapter 5)

v+ Author Name: Indicates whether the article author’s name is visible

v Created Date and Time: Indicates whether you want the date and time
the article was created to be visible

v Modified Date and Time: Indicates whether you want the date and time
the article was modified to be visible

v+ PDF Icon: Indicates whether you want to display a PDF icon to allow
users to download the article in PDF format

v~ Print Icon: Indicates whether you want to display a print icon for the
article

v E-Mail Icon: Indicates whether want to display an email icon to let users
e-mail the article to others

1 Content Language: Specifies the language the article is written in

1 Key Reference: Allows you to enter a text key that allows users to find
the article

v~ Alternative Read More: Allows you to enter additional text in the Read
More link

Metadata options

You can also enter metadata information about the article, to be stored in

<meta> HTML tags. Search engines like Google use metadata to categorize
your article. Here are the items in the Metadata Information section of the

article-editor page:

v Description: The article’s human-language description

1 Keywords: The list of comma-separated keywords you want your page
to be indexed under (the terms users should be able to search on)

+” Robots: Keywords targeted to search-engine robots

1 Author: The author’s name

Getting to Know Vour Editor

The actual mechanics of creating an article occur in the editor section in

the bottom-left corner of the article editor (refer to Figure 6-1). For detailed
information on creating an article, see Chapter 4. The editor that comes built
into Joomla — TinyMCE — wasn’t actually created by the Joomla developers.
Currently, Joomla uses Version 2 of this powerful, JavaScript-based editor.
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TinyMCE is a WYSIWYG (what you see is what you get) editor with three
toolbars. It provides these features (among many others):

v Supports colored text and backgrounds

v Supports insertion of images, HTML, links, horizontal rules, emoticons,
and more

v~ Allows table creation and manipulation
v Supports layers
v Provides total CSS support

If you're working in Windows, you can also use XStandard Lite — a Joomla
plug-in. To enable XStandard Lite, choose Extensionst>Plugin Manager to open
Plugin Manager; disable TinyMCE by clicking the green check mark in its
Enabled column, changing it to a red X; then enable XStandard Lite by clicking
the icon in its Enabled column, changing that icon from a red X to a green
check mark.

After you create an article in any editor, you have to create a menu item that
points to it, using Menu Item Manager. And if you want to juggle the positions
or appearance of menus in Joomla, you can do that with Module Manager
(which you access by choosing Extensions"Module Manager). For details, see
Chapter 7.

Dressing Up Your Articles with
Emoticons and Images

Emoticons and images are two staples of modern Web pages, and Joomla lets
you work with both. Embedding them in your articles is a snap; just use the
following instructions.

Smile!: Adding emoticons

Emoticons are small colored icons depicting happy or sad faces. They add
a touch of emotion to your text — something that might not come through
otherwise.

Suppose that your site has a privacy policy containing this text:

Actually, we don’t really have a firm privacy policy.
Does that mean we’ll sell your email address to spammers?
Well, could be. . ..
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|
Figure 6-2:
TinyMCE's
emoticons.
|

|
Figure 6-3:
An added
emoticon.
|

That looks a little menacing, you decide. How about adding a smiley face at

the end? To do that, click to position the insertion point at the end of the text

and then click the Emoticons button in the middle toolbar of the TinyMCE
editor to open the Insert Emotion dialog box (see Figure 6-2).

Click the emoticon you want to use to insert it into the text (see Figure 6-3).
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Adding images

Web pages often show whole images. Can you insert images into articles?
Sure you can.

Say, for example, that you want an image to illustrate the timeliness of an
article. After looking around, you decide on the perfect one: an image of a
clock (see Figure 6-4). This image, clock. jpg, is preinstalled with Joomla.
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|
Figure 6-4:
Aclock
image.
|
‘sgN\BEB
« Images that can be inserted into articles are stored in the Joomla images/
stories directory, or a subdirectory of that directory.
To insert an image into an article, follow these steps:

1. Open the article in which you want to insert the image (choose
Content->Article Manager and then click the article’s name to open it
in the article editor).

2. Click the Image button below the text window.

The image-insertion dialog box opens (see Figure 6-5).
3. Select the image you want to use.
<P If you don’t see the image you want, click the Browse button in the
Upload section of the image-insertion dialog box to find an image on
your local computer; then click the Start Upload button to upload
the image.

4. In the article editor, click the place in the text where you want to
insert the image.

5. Click the Insert button in the image-insertion dialog box.

Joomla inserts the image into the article (see Figure 6-6).
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|
Figure 6-6:
The image
in the
article.
|
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Just as you can insert images into articles, you can insert multimedia. To
do so, click the Insert or Edit Media button in the TinyMCE editor’s middle
toolbar. The types of multimedia you can insert are Adobe Flash, QuickTime,

Adobe Shockwave, Windows Media, and Real Media.

Now you can insert images into articles — and, therefore, into Web pages.

What else can you do?

Formatting Articles with HTML Tags

You can add some pizzazz to an article by adding HTML tags while you work
with it in the article-editor page. To insert HTML tags with the TinyMCE

editor, follow these steps:

1. With the article you want to format open in the article editor, click

the Edit HTML Source button in the middle toolbar.

The HTML Source Editor window opens, displaying the text of your

article enclosed in paragraph tags (<p>/</p>).

2. To enter a heading, type <h1>heading</hl>, where heading is the

heading text.

If you want to use the raffle example, you might type <h1>RAFFLE!</h1>

(see Figure 6-7).
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HTML Source Editor - Microsoft Internet Expli
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3. Click the Update button.

You see the result in the text window (see Figure 6-8).
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Actually, the HTML editor in the TinyMCE editor isn’t really worth that much.
You could have made the same change by typing the heading text in the text
window, selecting it, and then choosing Heading 1 from the Format drop-down
menu.

If you insert HTML tags that TinyMCE deems to be nonstandard, such as a
<marquee> tag to create a scrolling marquee in Internet Explorer, TinyMCE
removes that tag (not the enclosed text). The same goes for JavaScript. If you
try to insert an HTML <form> tag for a control like a button in your article,
TinyMCE strips the <form> tag out of the article.

Working with Tables and Columns

If you've got data that you want to organize visually in your Web pages, what
better constructions could you use than tables? Tables are neat and lay out
your data in a concise form.

Suppose that you're creating a school site, and you want to list the top
honor-roll students in an article. How about creating a table that lists them
like this?

Student Rank
Fred 1
Ethyl 2
Lucy 3
Ricky 4
Ralph 5

Creating a table in an article

To place a table in an article, follow these steps:

1. With the article open in the article editor, click Insert New Table.
The Insert/Modify Table dialog box opens.
2. In the General tab, set the options you want to use.

Figure 6-9 shows an example.
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Figure 6-9:
Setting table

options.
P

3. Click the Insert button.
A blank table grid appears in your article.

4. Type the table text in the table cells (see Figure 6-10).
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Formatting a table

That’s good so far, but now you want to apply some formatting — to make
the column heads to stand out, maybe, and to add a border. To format a
table, follow these steps:
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Figure 6-11:
The Table
Row
Properties
dialog box.
|

1.

2.

Select the top row of the new table, and click the Table Row
Properties button in the bottom toolbar of the TinyMCE editor.

The Table Row Properties dialog box opens.

From the Row in Table Part drop-down menu, choose Table Head
(see Figure 6-11); then click the Update button.
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6.

Joomla converts the headers in the top row of your table to actual
table headers (that is, the <th> tag will be used for the headers, not
the <td> tag).

. To give the table a visible border, click inside the table and then click

the Table Cell Properties button in the bottom toolbar of the editor.
The Table Cell Properties dialog box opens.

By default, all table borders are white, so they won’t show up on a Web
page that has a white background. But you can change that setting.

. Click the Border Color box, and choose a new color from the pop-up

color palette.
You may want to choose black (hex code #000000).

. To apply the new color to the border of all cells, choose Update All

Cells in Table from the drop-down menu in the bottom-left corner of
the dialog box (see Figure 6-12).

Click the Update button.

The appearance of the table in the article editor doesn’t match what the
final table will look like on your site. To see what the table will actually look
like, click the Preview link in the top-right corner of the article-editor page
(see Figure 6-13).
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Changing an article’s columns

Want to change the number of columns that an article’s content is divided
into? You may think you’d do that with Article Manager or the article editor,
but the number of columns is a layout issue, so you set it in Menu Item
Manager. (To open Menu Item Manager, choose Menus>Menu Manager in
any back-end page; then click the icon in the Menu Item(s) column of the
menu whose items you want to edit.)

To change the number of columns, enter a new value in the Columns text box
of the Parameters - Basic section. Figure 6-14, for example, is set to display
two columns. You can format articles in as many columns as you like.
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Figure 6-14:
Setting the
number of
columns in
an article.
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Creating a Table of Contents

Joomla lets you break your articles up by adding a table of contents, which is

particularly good for longer articles. If you have an article that’s 30 pages
long, for example, you don’t want to make your users wait while the whole

thing loads. It’'s much better to break the article into titled pages, especially

when Joomla’s page-break feature is so easy and painless.

Suppose that in the article editor, you're viewing an article about a picnic
that a neighborhood group is throwing. Here’s the text of the article:
We’re having a picnic!
Where:
Stewart Park
When:
Tomorrow

What to bring:
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|
Figure 6-15:
Inserting a
page break.
|

Potato salads
Sandwiches
Drinks

You can break this article up into pages by clicking the Pagebreak button
below the text window in the article editor.

To see how this feature works, follow these steps:

1. With the article open in the article editor, click the Pagebreak button.

A pop-up dialog box asks you for the title of the new page (see
Figure 6-15).

. Enter a page title, and click the Insert Pagebreak button.
. Repeat Steps 1 and 2 to create as many new pages as you want.

. Click the Save or Apply button in the article-editor page.

G s wN

. Open the article in the front end.

You see the article’s table of contents (see Figure 6-16).
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Figure 6-16:
Table of
contents.
|
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In Figure 6-16, notice that Joomla uses the article’s title as the title of the first
page in the article. The text links are the names of page breaks, and Joomla
displays << Prev and Next >> links to let users navigate from page to page.
The All Pages link in the table of contents displays the whole article without
page breaks.

Back (And Forth) to the Future:
Publishing at Different Times

You may have articles that need to appear on a certain schedule. Perhaps
you're promoting a picnic (and need to take down the notice about it when
the picnic is over) or a theatrical production (and need to display the notice
only when tickets are available). Joomla helps with this task.

Publishing articles in the future

You can create articles that will be published at some future time. Suppose
that your not-for-profit organization is running a raffle from now until
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Figure 6-17:
Setting a
date to start
publishing
an article.
|

March 2, 2010, and you want to publicize the raffle You create this article by
clicking the Add New Article icon in the control panel or by clicking the New
button in Article Manager.

Suppose, however, that you don’t want this article to appear until December.
To make sure of that, set the publication details in the Parameters - Article
section on the right side of the article editor. To start publishing on
December 1, 2009, at midnight, for example, enter 2009-12-01 in the Start
Publishing text box (see Figure 6-17).

Be sure to use yyyy-mm-dd format when you enter the date.
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Stopping publishing in the future

You can also end the publication of an article on a date in the future. To
continue the example in the preceding section, perhaps the raffle ends
March 2, 2010, so you’d want to stop publication on that date.

That’s easy enough to do. To make Joomla end the publication of an
article (or unpublish the article, taking it off the site), enter the stop date
in the Finish Publishing text box of the Parameters - Article section (see
Figure 6-18).
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Figure 6-18:
Automati-
cally ending
publication
of an article.
|
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Unpublishing now

Finally, you can unpublish an article in the present — right now or an hour
from now, for example.

To unpublish an article in Joomla, follow these steps:

1. Click the Article Manager icon in the control panel or choose
Content~>Article Manager in any back-end page to open Article
Manager.

2. In the article’s Published column, click its green check mark to
change it to a red X.

Figure 6-19 shows the Privacy Policy article being unpublished.

Unpublishing an article doesn’t remove the menu item that points to
it, however. The menu item is still listed in its original menu, and if

users click that item, they get an error page. So you have to unpublish
the menu item as well.

3. To unpublish the menu item, click the Menu Manager icon in the

control panel or choose Menus->Menu Manager in any back-end page

to open Menu Manager.

4. In the Published column of the appropriate menu item, click the green

check mark to change it to a red X.

You've unpublished both the article and its menu item.
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Now you’re ready to tackle a big topic: user interaction. One of the appealing
things about Joomla sites is that they promote interaction, which means
that users can submit their own articles to you. How you actually handle
submissions is up to you.

Making Your Joomla Site Interactive

When it comes to being a back-end administrator, you're all-powerful in
Joomla. You can sweep down from the heavens and change just about
anything on the site. Your power is enormous.

But where does that leave the site’s users? Part of making a site grow is
getting people involved; that’s how viral marketing works, for example.
Joomla is up to the challenge.

Three levels of users don’t have back-end privileges, but they can submit
and work with the content in your site if you allow them to:

v Authors can submit articles.

v~ Editors can submit articles and make changes to them.

+” Publishers can submit, change, and publish articles.
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Figure 6-20:
Creating a
new author.
|

Authors can submit articles, but someone in the back end has to approve
them before they appear. Editors can submit and edit articles. And
publishers can submit articles, edit articles, and publish them. (For more
details on these roles, see “Authors and Editors and Publishers, Oh My!”,
later in this chapter.)

We’ve found that editors are more common than authors except on very large

sites. Site administrators seem to like enabling users to edit site content,
which saves the administrators all the trouble of doing it themselves.

Adding and managing users

To add users to your site and assign roles to them, you employ User
Manager. Follow these steps:

1. Click the User Manager icon in the control panel or choose Site~>User

Manager in any back-end page to open User Manager.
2. Click the New button.
An Edit User page opens.

3. In the User Details section, enter the user’s name, username, e-mail

address, and password.

4. To give the user author, editor, or publisher privileges, select the
appropriate role in the Group list (see Figure 6-20).
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Figure 6-21:
Three new
users:
author,
editor, and
publisher.
|

5. Click the Save or Apply button.
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Creating new users is just that quick. The full details on User Manager are

laid out in detail in Chapter 9, if you're interested.

To illustrate the discussion in this section, we created three

NEw users:

author, editor, and publisher, shown in User Manager in Figure 6-21. As you

might guess, these users’ privilege levels match their names
the Group column.

, as you see in

To let your new users submit content, you need an article submission page,

which you create in the following section.
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4] Done, but with errors on page.
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Creating an article submission page

Article submission pages let authors, editors, and publishers write their own
content and submit it. You create an article submission page by creating a
new menu item that points to an article submission layout.
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Take a look at the default Joomla’s site’s front page, shown in Figure 6-22. A
Key Concepts menu appears right above the login form that authors, editors,
and publishers use to log in from the front end.

You can add a menu item to the Key Concepts menu and link that new menu
item to an article submission page. To create that new menu item in the Key
Concepts menu, follow these steps:

—

. Click the Menu Manager icon in the control panel or choose
Menus=>Menu Manager in any back end page to open Menu Manager.

2. Click the icon in the Menu Item(s) column of the Key Concepts row.

|
Figure 6-22:
The Key
Concepts
menu.

Menu Item Manager opens (see Figure 6-23).

3.

Click the New button.

The New Menu Item page opens.

4.

The Article Submission Layout page opens.

2l This is my site - Microsoft Internet Explorer

Click Internal Link~>Articles~>Article~>Article Submission Layout (see
Figure 6-24).
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5. In the Menu Item Details section, enter a title in the Title text box,
and select a setting in the Access Level list (bottom-left corner of
Figure 6-25).

Here are your access-level choices:
¢ Public: Everybody
* Registered: Logged-in users
e Special: Authors, editors, publishers, and administrators
6. Click the Apply or Save button to create your new menu item.

Congratulations — you’ve also created a new article submission page.
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Viewing the link to the article
submission page

How do you access the new article submission page? If a casual user (without
site privileges) looks at the menu, he won’t see anything special. For this
example, he’d see just the same Key Concepts menu shown in Figure 6-22,
earlier in this chapter.

But if the user named author used the login form on the front page to
log in, she’d find the new menu item in the Key Concepts menu (see
Figure 6-26). Cool!
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Figure 6-26:
The new
menu item,
visible after
login.
|

Authors and Editors and
Publishers, Oh My!

Figure 6-27:
Creating a
new article.

In this section, we take a look at the capabilities enjoyed by the special users:
authors, editors, and publishers. Different levels of users have different levels
of options available to them.

Authors can write articles

Assuming that you're logged in as an author, and you click the appropriate
menu item, the article submission page appears. Then you can enter and edit
text, as shown in Figure 6-27.
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Figure 6-28:
Selecting
anew
article’s
section and
category.
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In the figure, the author is submitting a new article named Neighborhood
watch, with the dotted line indicating a Read More link. (For details on Read
More links, see Chapter 4.)

Submitting an article (author)

Farther down the page, you can select the proposed article’s section and
category. (In Figure 6-28, the author has selected the News section and the
Latest category.) You can enter metadata for the article as well.

When you’re done with the new article, click the Save button. Joomla
takes you back to the front page and displays a thank-you message
(see Figure 6-29).

To log out as author, click the Logout button that appears on the front page
after you log in.
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Approving an article (administrator)

So how do administrators learn about new article submissions? Log in to
the back end as an administrator and check the mail icon in the top-right
corner of the page. If you see a number next to this icon, you have mail
waiting (see Figure 6-30).



Figure 6-29:
Submitting a
new article.

Figure 6-30:
A new mail
message
foran
admini-
strator of a
Joomla site.
|

Chapter 6: Mastering Web Page Creation 1 73

2l This is my site - Microsoft Internet Explorer

File
Qback - @ - [H @ | P search Favorites 4 Ml BE

fddress ] hetp:flocalhost fiorla)

Edit  View Favortes Tools Help s

Harne search..

Welcame to the SuperDuperMegaCo site. ¥e hope you brought lots of money. There's nothing

SuperDuperMegaCo oo

About Joomla! Features News The Community

@ Thanks for your submission. Your submission will now be reviewed hefore being posted to the site.

This is my site Whe's Online

e Welcoirie o iy §ite & =1 Wehave | member online
eam Flavors -
eam Bars
Ice Cream Cones
The News Welcome to my site, Do you like it? This site Uges Joornlal 1.5 for cortent
Web management. Joomlal handles the details ofthe presentation and lets you focus on
:‘{W"FE;“I? wiriling the content of the site. Mo complicated knowledge of HTML or stle sheets is © Averylitle
rivacy Policy e si >
e necessary. Pretfy nice site, huh © itte
Edit Your Account %) epts
Picn

Polls

How much money do you
planta give us?

© Motsomuch

Welcome to Joomlal % == Stickto the Cods! & =4 O Pretymuch %

S Localintranet

Mail icon

2 JoomlaSite - Administration - Microsoft Internet Explorer

File Edit Wiew Favorites Tools Help "
@Back » @~ ¥ [2) f | S search v Favories R EBUE9 3
Address | (&] http:flocalhost fjoomlafadministratarjindex. php v (o
~
- r .
Joomlal” JoomlaSite
Menus Content Components Extensions Tools Help |24 Preview 1 M2 @ Logout
Welcome to Joomla!
AN
5
+, Congratulations on choosing Joomial as your cortert managemert system
e hope you ere ehie to create a successful Weh ste with our program
el Newe Article Articke Manager  Front Page Manager &l mayie you wil be sbleto give Something back 1o the communty later
= T make your start with Joomial 65 Smooth & posskle, v vart to give
| ™ you some pointers to documertation, commen questions and helo an
securing your server. A good place to start is the "&bsolute Beginners
Guide ta Joomis"
Section Manager Category Manager Media Manager
For your most common questions the best place to start looking for
answers is the Frequently Asked Guestions (FAQ) area. If you are stuck
on & patticular screen inthe Administration area of Joomial (which is where
Ij Cn ol aie now), then try clicking on the Help toolbar button which you wil
finel on slmost ail screens. This will take you to 2 page sbout that screen on
our Help Site. If you still have questions then take a look on our forum which
MR e e e N is: most likely the biggest resource on Joomls! there is and you willfind
almost every question answered ot least ance, so please try using the
search function before asking your question
Security is a big concern for us, which s why we would like youto
subscribe to the announcement forum (by clicking on the Motify button) to
albways et the latest information on new relesses for Joormlal Vou shoulst
Giohal Configuration also resdt the Joomls Adiministrator's Security Checkist and regularly check
the security forum
Ve hope you have much fun and sucoess with Joomat and hope to see
wou inthe forum amone the hundreds and thausands of contributors o
) Error on page . Local intranet




’ 74 Part Il: Joomla at Work

\\3
The number next to the people icon in the top-right corner tells you how many
people are logged on currently.
Click the mail icon to open the page you see in Figure 6-31, and select the title
@ to open the message — in this case, a new article.
a\
You can read the submitted article in Article Manager as well by clicking the
article’s title in that page.
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Figure 6-31:
A new
message.
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Editors can make changes

Unlike authors, when editors log in, they see a page like the one shown in
Figure 6-32. Notice the difference? An Edit icon at the top of all articles allows
editors to revise articles.

If you've logged in as an editor, click an article’s Edit icon to open its editing
page. (Figure 6-33 shows an example.) Make any changes to the article that
you want; then click the Save button. The changes are saved and appear on
the site immediately.
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Figure 6-34:
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options.

Sometimes when an editor tries to edit an article, he gets a message from
Joomla saying that the article can’t be edited because someone else is already
editing it — even if nobody is. This situation can happen when editors don’t
click the Save or Apply button to save their changes to an article before leav-
ing the editor window. To check in all checked-out articles — and make them
accessible to editors — choose Tools=>Global Checkin in any back-end page.

Publishers can post articles

The last of the front-end-content manipulators are publishers. In practical
terms, publishers are the same as editors, except that they can also publish
articles to the site.

If you log in as a publisher and then create or edit an article, you see the
two options that set publishers apart from editors: the Published and Show
on Front Page radio buttons (see Figure 6-34). (Start Publishing and Finish
Publishing options are also available to publishers, as you see in the figure.)

Those two options, which don’t appear for authors or editors, allow
publishers to publish articles to the site — even on the front page.
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Stand Up and Be Counted:
Tracking Page Hits

You can track the number of hits a page on your site has received. Just check
the Hits column in Article Manager (see Figure 6-35).
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How can you reset the number of hits an article has to zero? Open the article
in the article editor, and click the Reset button on the right side, next to the
hit counter (the third item down on the right side).

See Vou Later, Alligator:
Taking the Site Offline

One day, you may get a call from a client, who screams into the phone,
“We’re not ready! Take the site offline!”

Take the site offline? How do you do that? You can use the Global
Configuration feature. Follow these steps:

1. Choose Siter>Control Panel in any back-end page to open the control
panel; then double-click the Global Configuration icon.
or
Choose Site=>Global Configuration in any back-end page.
Either way, the Global Configuration page appears, open to the Site tab.

Notice the first option in the Site Settings pane: Site Offline. That setting
is the one you want.
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2. Select the Yes radio button in the Site Offline section.
3. Click Apply.
4. Click the Save button.

Your site is down, and surfers see the message shown in Figure 6-36.

58 Joorlal

JoomlaSite

This gite is down for maintenance. Please check back again soan.

L]
Usemarme ]

Figure 6-36: Passward I:|
The site is Remermber Me

down.

Want to bring the site back up? Follow these steps:

1. Reopen the Global Configuration page.
2. In the Site Offline section of the Site tab, select the No radio button.
3. Click Apply; then click Save.

Your site is back in business.
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In this part . . .

Fis part has fun with Joomla modules and templates.
Modules are those items that appear around the
periphery of your page: menus, polls, newsflashes,
banners, search boxes, custom HTML, and more. Joomla
comes with dozens of built-in modules, and this part of
the book is where you master them.

We also cover working with Joomla templates in this part.
Templates determine every aspect of the layout of your
pages, from where the modules go to the images and colors
they use. Although Joomla comes with limited template
choices, you can download thousands of additional
templates from the Internet.




Chapter 7

Fun with Modules: Advertisements,

Archives, Banners, Custom
HTML, and More

In This Chapter
Understanding modules
Working with ads
Archiving articles
Providing breadcrumbs
Making a Custom HTML module
Adding an RSS feed to your site

oomla modules are those great embedded applications that appear

around the edges of your pages. The newsflash (see Chapter 3), which
rotates news stories on the front page, is a module. So is the poll that
appears on the front page. So are the very advertisements that can appear on
Joomla pages.

In fact, even menus are modules in Joomla.

The chapters in Parts I and II of this book provide a tour of content handling
in Joomla. This chapter and the next one, however, cover modules.

All about Modules

You handle modules in Joomla with Module Manager, which you open by
choosing Extensions>Module Manager in any back-end page. Figure 7-1
shows Module Manager in the default Joomla installation.

This tool is the main one we use in this chapter and Chapter 8.



’ 82 Part lll: Working with Joomla Modules and Templates

2 JoomlaSite - Administration - Microsoft Internet Explorer

Flle Edit View Favorites Tools Help s
7 = »
& back - [ B @ | S search FrFavorites & ~a = E93 Links
fclthess | ] btpiflocalhost fjoorlajadministratorfindes. phptoptionecom_modules v B
~
T - i
¥ Joomlal™ JoomlaSite
Site  Menus  Comtent  Components  Extensions  Tools  Help (25 Preview 0 M1 O Logot
B / 0 O
= =
#% Module Manager + =) qQ 7 o,
Ensble Dissle Copy  Delste  Edt  Mew  Help
Site | Administrator
Fiter [~select Tempiate - (W] - Select Position - [ - Select Type - v seisetstate - b
Col Module Hame Enabled Order~ ¥ Accesslevel Posiion~ Pages Type 1]
1 [ Breadorumbs o4 1 Fublic bresdorunb Al mod_bresdorumbs 35
2 [ Banners s 4 1 Public focter & mod_banners an
| 3 [ Footer - 2 Public frcker &1 mod_footer 3
Figure 7-1: 4 T MeinMenu b4 1 Fublic et Al mod_menmeny 1
Th e d efa u |t 5 [T Joomls! Stutf B4 2 Fublic It Waries  mod_mainmenu kl
J oomla & [ ey conoepts o a Public et &1 mod_mainmeny 40
Module 7O Userblenu v @ Registered lett Al mod_mainmenu AT
M ana g er. 8 [ Exampie Paces o 5 Puiic 53 Waries | mod mainmeny 3 B
—— &) Dane, but with errors on page, 8J Local intranet

To work with an individual module, click its name in Module Manager; a cus-

tomization page for that module opens.

Here are the modules in the default Joomla installation, arranged alphabetically:

Advertisement
Archive
Banners
Breadcrumbs
Example Pages
Feed Display
Footer
Joomla! Stuff
Key Concepts
Latest News
Login Form
Main Menu

Newsflash

Polls

Popular
Random Image
Related Items
Search
Sections
Statistics
Syndication
Top Menu
User Menu
Who'’s Online
Wrapper
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Module Manager has ten columns for each module:

v #: The number of the module in Module Manager

v [Selection Box]: Option enabling you to work with modules en masse
+* Module Name: The name of the module

v Enabled: Option indicating whether the module is enabled

v Order: The order of the module in its subgroup; sets the order of the
menu modules on a page

v Access Level: The access levels for various users: Public (everyone),
Registered (logged-in users), or Special (authors and above)

v Position: The position on the page where the module should appear
v Pages: The pages on which the module is visible

v Type: The type of the module; sets the module’s subgroup and then
allows to set the position of the module in its subgroup via the Order
column.

v ID: The Joomla ID of the module

In the rest of this chapter, you jump into some modules to see what they
offer and what makes them tick.

The Advertisement Module:
For Sale; Buy Now!

The Advertisement module shows . . . well, advertisements. You can see it at
work on the right side of Figure 7-2. (You can’t miss it; it’s the module titled
Advertisement.)

You open the Advertisement module’s administration page by choosing

Extensions=>Module Manager to open Module Manager and then clicking the
module’s name.

Touring the module

Figure 7-3 shows the Advertisement module’s administration page. We take a
few pages here to describe it because it’s typical of Joomla modules.
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The most important options are in the Details pane:

v~ Title: Sets the title you want to display above the module.
v Show Title: Specifies whether to display the title.

+ Enabled: Allows you to enable or disable the module.

v~ Position: Sets the position of the module on the page:

¢ breadcrumb: The breadcrumb position (see “The Breadcrumbs
Module: Like Hansel and Gretel,” later in this chapter)

¢ debug: The debug module’s location

¢ footer: The footer of the page

e left: The left side of the page

¢ right: The right side of the page

¢ syndicate: The syndicate position

e top: The top of the page

¢ userl: At user-defined position userl (depends on template)

e user2: At user-defined position user2 (depends on template)

¢ user3: At user-defined position user3 (depends on template)

¢ user4: At user-defined position user4 (depends on template)
v Order: Specifies the order of multiple modules on a page.

Joomla lists the modules that are already in the position you speci-
fied and allows you to select the order of the current module. For the
Advertisement module, you can set the order of the module in this list:

¢ 0::Polls
e 2::Who’s Online
e 3::Advertisement
¢ 4::Random Image
1 Access Level: Sets the access level of the module (Public, Registered, or
Special)

Ei
é‘,\““’ The Position and Order options allow you to place your module on the page
consistent with where the template you're using places modules when you
select right, left, and so on. For details on using templates, see Chapter 9.
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Putting ads on certain pages

So far, so good — but how do you set what pages the module appears on?
You assign them in the Menu Assignment pane of the administration page
(see Figure 7-4).

You may be puzzled for a moment: You set what pages the module appears in
with a menu assignment? But in Joomla, pages are created only when a menu
item is accessed. So you specify what pages a module appears in by specifying
the menu items that point to those pages.

If you want a module to appear on all pages, select the All radio button. If you
want to specify what pages the module appears on, select the radio button
marked Select Menu Item(s) from the List; then select multiple items in the
Menu Selection list. Selecting just the Home item corresponds to the front
page, so if you select that item, the Advertisement module appears only on
the front page.

Configuring the module

Now check out the Parameters section in Figure 7-5, which allows you to set
the specific parameters of a module.

In the case of the Advertisement module, you see options specific to advertis-
ing. The setting in the Target drop-down menu, for example, specifies where
the new page opens when the user clicks an ad.
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Substituting your own ads

Where do the default ads come from, and how can you replace them with
your own?

The ads are managed by Banner Manager (figures, doesn’t it?). If you check
the Parameters section of the module’s administration page, the Category
drop-down menu shows the type of ads that the Advertisement module is set
up to extract from Banner Manager. In Figure 7-5, earlier in this chapter, that
menu is set to Text Ads.

To manage the category and substitute your own ad, follow these steps:

1. Choose Components->Banner->Banners in any back-end page.
Banner Manager opens (see Figure 7-6).

2. Disable each ad you no longer want by clicking the green check mark
in its Published column, turning the check mark to a red X.

3. Click one of the remaining items to open it.

If you select the Joomla! item, for example, you see the page shown in
Figure 7-7.
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4. In the Name text box, enter the name of the replacement ad.

5. In the Click URL text box, enter the URL of the replacement ad.

To create a new ad, just click the New button in Banner Manager.

The Archive Module: A Sense of History

Archiving articles stores them on your site but gives them less of a presence.

You can archive articles easily in Article Manager. (To open Article Manager,

click the Article Manager icon in the control panel or choose Content>Article
Manager.)

Archiving articles

To archive articles, follow these steps:

1. Select the articles you want to archive by checking the check boxes at
the beginning of their rows.

2. Click the Archive button.

The articles appear in Article Manager with the keyword [Archived]
after their names. Figure 7-8 shows an example of an archived article.
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Displaying lists of archived articles

You can configure the Archive module to display a list of links to archived
articles, arranged by month. Follow these steps:

1. Choose Extensions=>"Module Manager in any back-end page to open
Module Manager.

2. Click Archive to open that module’s administration page.

3. In the Enabled section of the Details pane, select the Yes radio button.

4. Make a choice from the Position drop-down menu to specify where on
the page the Archive module should appear.

You have these choices:

0::Main Menu 7::Login Form
2::Joomla! Stuff 8::Archive

3::Key Concepts 9::Sections
4::User Menu 10::Related Items
5::Example Pages 11::Wrapper
6::Statistics 12::Feed Display

5. In the Menu Assignment pane, set the menu(s) you want to link the
Archive module to.

To link the module to the Main menu, for example, select the radio
button marked Select Menu Item(s) from the List, and select Home in the
Menu Assignment list (see Figure 7-9).

6. Click the Save button.
7. View the front page to see your changes.

Figure 7-10 shows an example. Clicking the link would take you to the
archived articles for that month and year.
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The Banners Module: A Picture’s

Worth a Thousand Words

Banners are advertisements with banner images, like the one you see at the

bottom of the default front page (see Figure 7-11).

191
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Figure 7-11:
A banner ad.
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When you click a banner, the browser navigates to the ad’s URL, just like the
banner ads you see all over the Internet.

Viewing the Banner module

To view the Banner module’s administration page, choose Extensions=>
Module Manager in any back-end page to open Module Manager; then click
Banners to open the module’s administration page.

In the example shown in Figure 7-12, the All radio button is selected, meaning
that this module appears on every page, and the Position drop-down menu is
set to Footer, so the ads appear at the bottom of every page.

Want to get rid of the banner ads at the bottom of the pages on your site? Just
select the None radio button in the Menus section of the Menu Assignment
pane, and click the Apply or Save button.

To view all the ads on your site in Banner Manager, choose Componentsc>
Banner=>Banners (refer to Figure 7-6).

Changing banner ads

The available banner images are stored in the Joomla images/banners
directory, and each image (usually in . jpg or .png format) is 468 pixels wide
by 60 pixels tall. To choose among the available banners when you’re editing



Chapter 7: Fun with Modules ’ 93

a banner ad, click the ad’s name in Banner Manager (refer to Figure 7-6) and
then make a choice from the Banner Image Selector drop-down menu (see
Figure 7-13).

You can also click the New button in Banner Manager to create a new ad.

2 JoomlaSite - Administration - Microsoft Internet Explorer

File Edt View Favorites Toos Help i
Qback - D - [ @ | Poeach JrFavortes 8@ | 2-L S0 H @3 Links
Advess ] htpe poption—som_moduksbcient—Dtkask—sdted[ 130 8=
~
Details Parameters
Module Type: mod_bauners = Module Parameters
Title: [Banners Target | NewWindow with Browssr Havigation  w

Show Title: & g ™ ves

Enabled: o & ves Count [1

¢ [footer ™ Banner Client | Open Souroe Matters |

Category |Josmlal Prome %

S SearchByTags & Ng © vVes
Registered —
Special Randomise [ sty Randamise ]
0

D 3

Orde

Access Level;

Description: The Banner Module allows to show the active Barners
ot of the Camponent within your site. Header Text

Menu Assignment

Menus: Footer Text

© a0 None © Select Meny fem(s) fromthe List

Menu Selection:
Module Class Suffix

|
Figure 7-12:
Editing the
Banner
module.
— B) pore % Local intranet

Advanced Parameters

Fle Edk View Favorites Tooks  Help

2l JoomlaSite - Administration - Microsoft Internet Explorer E"EE]
>

Qoxck » & - &R fh| Psearch drravoriees @ (2~ 2 B LE @ 3 Lnks
Addiess | @] bttp:flocahostfic i index. php7aption=com_t id[]=7 ¥ B
~

Clicks: q Reset Clids il

Custom Banner Code:

Deseription/Hotes:

Bannet Image Selestor: [dhop-ad jog ~)

Banner Image:
Look Sensational with.....
I gear from the Joomla! Shop
- Tags:
Figure 7-13: e

Selecting
a banner

im a g e doormlal is Free Sottware released under the GRLIGPL Licerse. L8

— B hietp: v, aru. orajlicensesigpl-2, 0.kl %J Lacalintranet




’ 94 Part lll: Working with Joomla Modules and Templates

The Breadcrumbs Module:
Like Hansel and Gretel

Breadcrumbs are those link trails you see at the top of articles, such as the
trail you see in the top-left corner of Figure 7-14.

1 SuperDuperMega Cone - Microsoft Internet Explorer
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Breadcrumbs

Breadcrumbs are innocuous parts of a Joomla site, and you have little reason
to fool with them, but you can change them if you like. To edit the module’s
settings, click its name in Module Manager to open the module’s administra-
tion page.

The Custom HTML Module:
Doing It Yourself

Sometimes, you want to add your own HTML to your site, but the TinyMCE
editor (see Chapter 6) usually gets in the way. Suppose that you have HTML
generated by eBay, Amazon.com, or PayPal, and you want to paste that code
into your site. The TinyMCE editor doesn’t allow you to use HTML tags that it
doesn’t understand, however.
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The solution is to create a Custom HTML module, which you do in the follow-
ing sections.

Changing the default editor

The first phase of creating a Custom HTML module is changing the default
editor. To do so, follow these steps:
1. Choose Site~>Global Configuration in any back-end page.

The Global Configuration page opens.

2. From the Default WYSIWYG Editor drop-down menu, choose Editor -
No Editor (see Figure 7-15).

3. Click the Save or Apply button.
You've removed TinyMCE as the default editor.

Creating the Custom HTML module

Next, you create the Custom HTML module. Follow these steps:

1. Choose Extensions~>Module Manager in any back-end page to open
Module Manager.

You can look for a Custom HTML module in Module Manager, but you’ll
search in vain; you have to create it yourself.
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|
Figure 7-16:
Adding
Custom
HTML.
|

|
Figure 7-17:
The Custom
HTML mod-
ule at work.
|

2. Click the New button.
The New Module page opens.
3. Select the Custom HTML radio button, and click the Next button.

The module administration page opens (see Figure 7-16).
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4. In the Title text box, type Custom HTML.

5. In the Custom Qutput window at the bottom of the page, enter some
sample custom HTML.

You can enter anything you want, including JavaScript.
6. Click the Save button.

Joomla saves the new module and returns you to Module Manager.
7. View your site in a browser.

The new Custom HTML module now appears (see Figure 7-17).

Custom HTML

This is custom HTML!
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Don’t forget to restore the TinyMCE editor as your default when you're done
adding custom HTML. To do that, choose Siter>Global Configuration to open
the Global Configuration page; choose TinyMCE from the Default WYSIWYG
Editor drop-down menu; and click the Save button.

The Feed Display Module:
Getting RSS Your Way

\\3

NMBER
@&
&

RSS (which stands for, among other things, Really Simple Syndication) is a
great way to spread news through newsfeeds. RSS feeds are supported by
thousands of sites, and they allow you to stream their articles into RSS
readers — or your Joomla site.

The Feed Display module allows you to display other sites’ RSS feeds on your
site, which is a great way to add value. Suppose that you have a site about
hamsters. If you can find another site that has an RSS feed about hamsters,
displaying that feed on your site will keep your content from being static
(assuming that you can’t find the time to keep adding new articles).

You can find RSS feeds in hundreds of thousands of places on the Internet;
just click the XML or RSS button that you see on various sites.

RSS feeds are always XML files.
To add an RSS feed to your Joomla site, follow these steps:
1. Choose Extensions=>Module Manager in any back-end page to open
Module Manager.
2. Click Feed Module to open the module’s administration page.

3. In the Enabled section of the Details pane, select the Yes radio button.

4. In the Feed URL text box, located in the Module Parameters pane,
enter the URL of the feed you want to add to your site.

If you want to add the RSS feed for USA Today’s Money section, for
example, enter this URL:

http://rssfeeds.usatoday.com/UsatodaycomMoney-TopStories

At this point, your settings should resemble Figure 7-18.
5. Click the Save or Apply button.
6. View your site in a browser.

You find the RSS feed added to your site (see Figure 7-19).
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Chapter 8

More Fun with Modules: Footers,
Search Boxes, Who's Online,
Wrappers, and More

In This Chapter
Setting login options
Displaying random images
Setting up search
Showing statistics

Displaying other sites on yours

‘ hapter 7 reviews the built-in Joomla modules, and this chapter covers

the remaining modules, from Footer to Wrapper. In this chapter, you
see how to use footers to place text at the bottom of all your pages, how to
place search boxes anywhere so your users can search your site, how to
place Who’s Online boxes to display your site’s current users, how to show
current site statistics, and how to use wrappers to embed pages from other
Web sites in your own site.

The Footer Module: Joomla’s
Copyright Notice

The Joomla Footer module appears at the bottom of every page by default, as
you see in Figure 8-1.

Although you’d think that this module would allow you to set your own copy-
right text at the bottom of every page, that’s not the case. Footer is designed
only to display the Joomla copyright notice.
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If you open the Footer module for editing (choose Extensions=>Module
Manager in any back-end page and then click Footer), you see that you have
no option to enter your own footer text. Your only option is to turn the
Joomla copyright notice at the bottom of every page on or off.

But if you're willing to be a little sneaky, you can set your own footer text by
replacing the Joomla copyright notice. Joomla stores most text messages in
its language directory, and the messages for an English-language installa-
tion are stored in the 1language\en-GB directory. The footer text is in the
file language\en-GB\en-GB.mod_footer.ini, which looks like this by
default:

# $Id: en-GB.mod_footer.ini 9765 2007-12-30 08:21:02Z ircmaxell $

# Joomla! Project

# Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.

# License http://www.gnu.org/licenses/gpl-2.0.html GNU/GPL, see LICENSE.php
# Note : All ini files need to be saved as UTF-8 - No BOM

# Note : %date% will be auto replaced by current year !Don't translate

FOOTER=Footer

FOOTER_LINEl=Copyright &#169; %date% %sitename%. All Rights Reserved.

FOOTER_LINE2=<a href="http://www.joomla.org">Joomla!</a> is Free Software
released under the <a href="http://www.gnu.org/licenses/gpl-
2.0.html">GNU/GPL License.</a>

MOD_FOOTER=<em>mod_footer</em>

THIS MODULE SHOWS THE JOOMLA! COPYRIGHT INFORMATION=This Module shows the
Joomla! Copyright information
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You can change the footer text to whatever you want by changing FOOTER _
LINE1 and FOOTER_LINEZ2. Not bad!

The Joomla 1anguage directory is a gold mine if you want to customize
Joomla’s modules, components, and templates. If you're into customization,
get to know the . ini files in this directory; you can change the messages
Joomla displays.

The Login Form Module:
Getting Users on Board

|
Figure 8-2:
The Login
Form
module.
|

The Joomla Login Form module (see Figure 8-2) allows a user to enter his user-
name and password to log in to the site. By default, the login form appears
only on the front page, but you can make it appear anywhere you want.

Login Form

Username

Passward

Rermermber e [

e Forgotyour
password?
Forgotyour
usernamey
Create an
account

The login form also shows these links:

v Forgot Your Password?
v Forgot Your Username?
v Create an Account
Clicking the Create an Account link opens the Registration page (see Figure 8-3).

Users can create new usernames and passwords on this page. For more on this
topic, see Chapter 10.

To make the login form appear on every page, choose Extensions>Module
Manager to open Module Manager and click Login Form to open the module’s
administration page.
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The Popular Module: Only the
Best and Brightest Articles

The Popular module (nice name for a module) publishes a list of links to

the five articles with the most hits. By default, this module isn’t enabled. To
enable it, choose Extensions=>Module Manager in any back-end page to open
Module Manager, and click the red X in the Popular item’s Enabled column to
turn the red X to a green check mark.

By default, the Popular module appears at top of the page (see Figure 8-4).

mm——— | Popular

Figure 8-4:

o Joomial Overdew
» Exlensions
The Popular e Joomlal License Guidelines
module. + Welcome to.Joommial
= Wihat's Mew In 1.7




Chapter 8: More Fun with Modules 203

The Random Image Module:
Adding a Little Art

|
Figure 8-5:
Editing the
Random
Image
module.
|

The Random Image module, as its name implies, shows a random image
every time the page it appears on is refreshed.

This module is great to use if you want to display some kind of product (such
as ice cream cones) on your site. A new image appears each time a visitor
comes to the site.

To set the Random Image module, follow these steps:

1. Choose Extensions=>Module Manager to open Module Manager.
2. Click Random Image to open the module’s administration page.

Because the Random Image module doesn’t appear on any pages by
default, you may think that it isn’t enabled by default. But that’s not
true: It is enabled. It has no menu assignment, however, so the module
never appears by default.

3. In the Menu Assignment pane, select the radio button labeled Select
Menu Item(s) from the List.

4. In the Menu Selection list, select the pages on which you want the
Random Image module to appear.

At this point, your choices in the Details and Menu Assignment panes
should resemble Figure 8-5.
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ArFimaenu

lce Cream Flavars

lce Cream Bars
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The settings you make in the Module Parameters section of the adminis-
tration page specify where the module gets the random images.

5. In the Image Type and Image Folder text boxes, enter the file exten-
sion and location of the images you want to use.

If you want to use the .png images that are already in the Joomla
images directory, for example, enter .png in the Image Type text box
and /images in the Image Folder text box. Your settings should look like

Figure 8-6.
Parameters
Module Parameters
Image Type |png
Image Folder fimages
— Lk
Figure 8-6: Width (px)
. Height (pxp
Setting the Bt
mOdU|e § Module Class Suffix
parameters.
Advanced Parameters
I
6. Click Apply or Save.
7. View your site.
The module displays a random image from the images directory (see
Figure 8-7).
I
Figure 8-7: oo om Image
The Random | .y
Image mod- | ==
ule at work.
I
WBER
\x&
&

Be sure to change the title of this module from Random Image to something
more appropriate to the images you're displaying.

The Related Items Module:
Unlocking the Keywords

Another nifty module is Related Items, which displays articles related to the
current one. How does this module know what articles are related to the
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|
Figure 8-8:
Adding
metadata
keywords.
|

current article? It uses the keywords you entered in the metadata settings for
each article.

To set up and use this module, follow these steps:

1. Choose Content=>Article Manager to open Article Manager.

2. Click the name of an article you want to include in the Related Items

module.

An article-editor page opens for that article.

3. In the Metadata Information pane on the right side of the page, enter a

keyword in the Keywords text box (see Figure 8-8).

Parameters - Article
Parameters - Advanced

Metadata Information

Description

Keywords

Robots

ice cream bar

Author

@ N &

4. Repeat Steps 2 and 3 for each article you want to include, using the

same keyword each time.
. Choose Extensions=>Module Manager to open Module Manager.
. Click Related Items to open that module’s administration page.
. In the Enabled section of the Details pane, select the Yes radio button.

. In the Menu Assignment pane, select the radio button labeled Select
Menu Item(s) from the List; then, in the Menu Selection list, select the
pages where you want the Related Items module to appear.

At this point, your choices in the Details and Menu Assignment panes
should resemble Figure 8-9.

9. Click Apply or Save.

10. View your site.

Joomla displays the Related Items module (see Figure 8-10).
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|
Figure 8-9:
Editing the
Related
[tems
module.

|
|
Figure 8-10:
The Related
Items mod-

ule at work.
|
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The Search Module: Finding
a Needle in a Haystack

One of the big attractions of Joomla is the Search module, which lets users
perform a search of all your articles. That’s often very hard to implement on
a site that you build yourself from the HTML up, but in Joomla, which stores
articles in a MySQL database, searching is a snap.

Figure 8-11 shows the Search module: the small text box with the word
search in it.
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|
Figure 8-12:
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|
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search...

The Search module isn’t the most inviting module, displaying just the terse
word search — not even capitalized — and not showing a cheery button
marked Go! or Find It! But the module does its job, as you see in the example
results page shown in Figure 8-12. You enter your search term and press the
Enter or Return key on your keyboard to search for that term.

2l JoomlaSite - Microsoft Internet Explorer

Fle Edt View Favorites Tooks Help

Qeack = ) - [ 2] (b | Fsearch o Favorites £ - B g o3 Links
Address | &] hitpifflocalhost e  php?seard) g=ssearchpl ption=com_search

Velcome to the SuperDuperMegata site. ¥We hope you brought lots of money. There's nothing
quite a3 good a3 buying products fram SuperDuperiegaco.

SuperDuperMegaCo

About Joomla! Features News The Conmunity

Home search

Home
Ice Cream Flavors

Search Keyword: sardine ice cream .
@® Allwords O Anywards () Exact Phrase
Ordering: | Newsst First w

Search Only: [] Aticles DVWVEb Links [] Contacte [] Categories [] Sections [ Mews Feeds

Ice Cream Cones

The News Search Keyword sardine ice cream
Web Links
News Feeds Total 3 results found
Privacy Policy
Display#[20 ¥
1 SuperDupertega Cone
Key Concepts e p_, y p !
 Extensiong This cone is the king of cones--the SuperDupemaga cone weighs five pounds. Every

imaginahle lavar of ice cream is here-ifyour imagination is restricted to chocolate, vanilla,

& Content Layouts
and sardine. ..

& Example Pages

SuperDuperhlega Bar

|
iz

S Localinkranet:

Using the search controls

Joomla offers a full set of search controls in its results page (refer to Figure 8-12),
including a Search Keyword text box and a Search button. When users enter
a phrase to search for, they can set one of these search options: All Words,
Any Words, or Exact Phrase.

Users can also set the order in which the search results are displayed by
making a choice from the Ordering drop-down menu: Newest First, Oldest
First, Most Popular, Alphabetical, or Section/Category.
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Finally, users can restrict the scope of the search to Articles, Web Links,
Contacts, Categories, Sections, or News Feeds.

Making search more user-friendly

You can do quite a bit to make the Search module more friendly in Joomla.
To do so, follow these steps:

1. Choose Extensions~>Module Manager to open Module Manager.

2. Click Search to open that module’s administration page.

3. If you don’t want the Search module to appear on all pages (the
default setting), change the settings in the Menu Assignment pane.

4. Adjust the appearance of the search box by changing the settings in
the Module Parameters pane (see Figure 8-13).

Parameters
Module Parameters
Module Class Suffix
Box Width |20
Text
|
. Search button (& g O ves
Figure 8-13: =
) Button Position | Right %
Setﬂng Search button as image & pg 7 yes
search-box
Button Text
parameters.
Advanced Parameters
|

Here are the parameters you can set to customize the Search module:
¢ Box Width: Width (in characters) of the search text box
e Text: The default text that appears in the search text box

¢ Search Button: Whether a search button appears next to the
search text box (the default is No)

¢ Button Position: The position of the search button relative to the
search text box (Right, Left, Top, or Bottom)

¢ Search Button As Image: Whether to use an image as the search
button

¢ Button Text: The search button’s caption
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A\ : .
We recommend adding a search button to your Joomla site. Many users

don’t know that they should press Enter or Return after entering their
search term and expect to click a search button.

5. Click Save or Apply to save your settings.

The Sections Module: Great for Overviews

Joomla uses categories and sections to help you organize larger sites. “Divide
and conquer” is the operative phrase here. When a site gets very large, with
a dozen or so active sections, a Main menu showing links to all the articles on
the site can become unwieldy, so Joomla introduced the Sections module.

The module displays a bulleted list of the sections on your site; users can
click a link to go to the appropriate section page. That’s great for maintaining
site overview on complex sites.

The Sections module doesn’t offer many options to set because it’s a very
simple module. By default, it isn’t enabled and is set to appear on no pages —
sort of a double whammy against it.

To see the Sections module at work, check the bottom-left corner of the front
page of your Joomla site (see Figure 8-14).

Figure 8-14:
The
Sections e« AboutJoomlal
& Mews
module » FAQs
e« lce Cream
at work.

The Statistics Module: Stand Up
and Be Counted

Want to display what operating system your Joomla site is hosted on? It’s
hard to know why you’d want to do that, but you can with the Statistics
module.

Sections
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Figure 8-15:
The
Statistics
module

at work.
|

The module also shows useful information such as the total number of regis-
tered users your site has (something to boast about) and the total number of
hits the site has received.

By default, the Statistics module is disabled and doesn’t appear in any
menus, but you can set the appropriate options in its administration page
(refer to the procedures for other modules earlier in this chapter).

You can also configure what information the Statistics module shows. To see
all that the module is capable of doing, select all these radio buttons in the
Module Parameters pane of the administration page:

v Server Info

v Site Info

v+ Hit Counter

Figure 8-15 shows an expanded Statistics module in action.

Statistics

0S8 Windows

PHP 525

MySOL : 5.0.19-nt

Time 1 12:26

Caching : Disabled

GZIP : Disahled
Members : 4

Content ; 53

Web Links : 6

Content View Hits | 1264

It’s hard to see how operating-system information would be of use to general
users, but the number of members, the number of articles (Content), and
the total number of hits can be interesting, especially if you have some good
numbers to display here.

The module’s administration page features a sneaky option: the Increase
Counter text box, located in the Module Parameters pane. You can increase
the number of hits by the number you enter in that text box, giving your site
the appearance of being more popular than it really is — not the most honest
of options but an option just the same.
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The Syndication Module:
Creating RSS Feeds

Want to let users read RSS feeds from your site? You can do that with the
Syndication module. Enabling and displaying that module puts an RSS button
on the pages in which you’ve enabled the module (see Figure 8-16).

That button actually is a link to a file named index. rss that you can pass to
RSS readers, and this file contains an RSS feed for the page. Here’s an exam-
ple from our front page:

<?xml version="1.0" encoding="utf-8"?>
<!-- generator="Joomla! 1.5 - Open Source Content Management" -->
<rss version="2.0">

<channel>
<title>This is my site</title>
<description>Joomla! - the dynamic portal engine and content management

system</description>
<link>http://localhost/joomla/index.php?option=com_
contenté&amp; view=frontpage</link>
<lastBuildDate>Thu, 11 Sep 2008 17:12:44 -0400</lastBuildDate>
<generator>Joomla! 1.5 - Open Source Content Management</generator>
<language>en-gb</language>
<item>
<title>Welcome to my site</title> <link>http://localhost/
joomla/index.php?option=com_content&amp;view=article&amp;id=45:wel
come-to-my-site</link>
<description><! [CDATA[<strong>Welcome to my site.</strong> Do you
like it? This site uses Joomla! 1.5 for content management.
Joomla! handles the details of the presentation and lets you focus
on writing the content of the site. No complicated knowledge of
HTML or style sheets is necessary. <em>Pretty nice site, huh? </
em>]]></description>
<category>frontpage</category>
<pubDate>Thu, 21 Aug 2008 21:57:43 -0400</pubDate>
</item>
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Figure 8-16:
AnRSS

RSS button

A This is my site - Microsoft Internet Exploren

File EHit Wiew Favorites Tools Help
(3 Back ~ & | P search Favorites £ -~ & 0e®3
Address | €] http: flacalhost fioomla

Links

v e

About Joomla! Features News The Community
Hefre search
ED Feed Ertries This is my site Polls
Welcome to my site k& =1 Howmuch money do
Main Menu you plan to give us?
& Averylitle
Home
g . Alitle
lco 'E‘“’"S Welconie to my site. Da you like it? This site uses Joomlal 1.5 far content o
ikl management. Joomlal handles the details ofthe presentation and lets you focus on O Mot samuch
e witing the content of the site. No cornplicated knowledge of HTML or ste sheets is o Prety much
b % ? QO
Web Links necessary. Prafly nice sita, huf -
News Feerls O Alot
Pitvacy Policy 5

Joomia! Stuff

SuperDuperMegaCo

Welcame to the SuperDuperiegaCo site. We hope you brought lots of money. There's
nothing guite as gaod as buying produsts from SuperDuperegaCo

Welcome to Joomlal & = = Stickto the Codel & == ) Mone of the above

Wote Results

button. |§
I &l

The Who's Online Module: Anyone There?

The Who’s Online module is a simple one that’s enabled by default. It indi-
cates how many guest users and registered users (that is, logged-in users)
are on your site at any time.

% J Local intranet.

Figure 8-17 shows the Who’s Online module at work.

Figure 8-17:
The Who's
Online
module.
|

Who's Online

We have 1 member online
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Figure 8-18:
The Who's
Online mod-
ule showing
logged-in
users.
|

You can configure the module to show the names of the current mem-
bers logged on, if you want. Just select one of these options in the Module
Parameters pane of the module’s administration page:

v # of Guests / Members

v Member Names

v Both

Figure 8-18 shows the Who’s Online module configured to display the names
of logged-in users.

Who's Online

= author

The Wrapper Module: Displaying
Other Sites

Here’s a cool one: The Wrapper module lets you display external sites in
wrappers (square frames) on your Joomla site. This feature can be great if
you have an allied site that you want people to know about or if you want to
show your site visitors the latest news.

You enable the Wrapper module by selecting the Yes radio button in

the Enabled section of the module’s administration page. In the Module
Parameters pane, you also supply the URL of the site you want to wrap by
typing it in the URL text box (see Figure 8-19).

That creates a new wrapper for the Joomla site, which you can see in Figure 8-20.
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Parameters
> Module Parameters

Module Class Suffix

Scroll Bars

| Wid

Figure 8-19:

100%

Height 200

URL | hitp:#fasajoomla.org

oo ves  muto

The Wrapper module works by using an HTML IFrame element to wrap and
display the external site.

Setting Auto Height ™ g (8 yas
wrapper
Auto Add (& i+
parameters. bRt
—— Jataet!
2} This is my site - Microsoft Internet Explorer
y p
Fle Edt View Favorites Took Help o
Qback -~ & - B B | Osearch LrFavorites @ | 3- 2 U E @3 liks
aiichess | ) bitpsiflocalhost/ioorls) v| B
T 0 e T
o Submitan Article all sizes for Public Web sites, Intranets, and | 1OW 0 | create "Read & =& doomlel Exdensions
i i Extransts and is supportad by a community ~ MOM8..."? doeiat Companents, Modules,
& Submit aWeb Link b ot s b Plugins and Languages by the
» Logout bucket losc!
ka8 10 Joorls! Shop
~ — This is now implemented by inserting a For all your Joomlal merchandise.
Login Form ead more... >> Read more... tag (the bution is located rr—
R below the editar area) a dotted line Siogsonne
appears inthe edited text showing the
split|ocation forthe Read more.... Anew
Plugin takes care ofthe rest
Wrapper Itis worth mentioning that this does not
have a negative effect on migrated data
- The FTF Laver allows fle operations (such ~ 1om older sites. The new implementation
£ as installing Extensions or updating the Is Tully bacleward cornpatible
main configuration file) without having to
make allthe folders and fies wiitable. This
Joomlc has been an issue on Linwcand other Unic
based platforms in respect of file
I permissions. This makes the site admin's

Figure 8-20:
The
Wrapper
module on a
Joomla front

page.

life & lot easier and increases security of the
site.

‘fou can check the write status of relevent
folders by going to "Help->System Infa” and
then inthe sub-menu to "Directary
Permissions" With the FTP Layer enablad
even if all directaries are red, Joamial will
operate smaothly.

MOTE: the FTP layer is not required on a
Windows hostiserver.

) Error on page:

& 4 Unknown Zone (Mixed)




Chapter 9

Laying Out Your Web Pages
with Joomla Templates

In This Chapter

Understanding templates

Using Template Manager

Setting a new default template
Customizing the built-in templates

Getting new Joomla templates

Tlis chapter is all about the layout of your Web site. You can set the
layout with menu items, of course, but even more essential are templates:
those collections of PHP and CSS (Cascading Style Sheets) files that deter-
mine the real layout of your Web pages in Joomla.

Templates determine what goes where in Joomla, so they’re exceptionally
important. Although Joomla itself comes with only a few built-in templates,
you can download your own, as you see in this chapter.

Formatting Joomla Sites with Templates

Joomla has built-in HTML editors that allow you to format articles the way
you want them, but it has no officially sanctioned editor that allows you to
create your own templates. The way your individual pages are laid out —
their very look and feel — is totally dependent on the template you use.

What’s more, Joomla doesn’t have a built-in template editor that allows

you to drag components and modules where you want them in a page and
design their appearance. As we show you in this chapter, you can edit some
template parameters in Template Manager, but you can’t make fundamental
changes unless you get into the PHP and the CSS files.
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Various third-party template editors are available for Joomla, and they're a
good start. But we've found the ones we’ve worked to be unsatisfactory in one
way or another, so we can’t recommend any of them. If you're interested, do a
Google search for Joomla template editor or Joomla template designer.

\\3

It’s a pity that Joomla provides such limited template-editing capabilities, but
in this chapter, we show you how to get around that limitation by download-
ing and installing new templates. You can find hundreds of Joomla templates
on the Internet, and installing them is a breeze.

Template Central: Template Manager

In Joomla, you manage templates with — surprise! — Template Manager.
To open Template Manager (see Figure 9-1), choose Extensions=
Template Manager in any back-end page.

2 JoomlaSite - Administration - Microsoft Internet Explorer, Q@@
:'l

Fle Edt View Favorites Tools Help
Qback - O - B @ €| Osearch rravoites @ | -2 2 E DB ks
sldess | €] heep:iflocalhost joomlajadministratarindz:c. php?option=com_templates v| B
&
e g - i |
¥ Joomlal”™ JoomlaSite
Site  Menus  Content  Components  Extensions  Tools  Help (24 Preview 0 &2 @ Logout
l.,, Template Manager 7 Qb
Defautt Edit Help.
Site Administrator
# Template Hame Default Assigned Version Date Author
1 € JA_Purity 120 12726007 JoomlArt.com
2 € beez W 100 13 February 2007 Angie RactkeRobert Deutz
I 3 € thule_milkyvay 102 112006 Andy Miler
- . Display €20 %
Figure 9-1: B
The Joomla
Joomls! is Free Softvware released under the GNUAGPL License
Template
Manager. =
—— &) bane J Local intranat

Template Manager gives you as much control of templates as you can get
unless you want to get your hands dirty with HTML and CSS.
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Figure 9-2:
Joomla's
default
administra-
tor template,
Khepri.
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The three template files shown in Figure 9-1 — JA_Purity, beez, and rhuk_
milkyway — are site templates, which is to say front-end templates. (Note
that the Site tab is selected in the figure.) Administrator templates are
available too, as you see when you click the Administrator tab (shown in
Figure 9-2). The default administrator template — that is, back-end template —
is named Khepri, and if you've taken a look at the Joomla back end, you're
already familiar with Khepri.

2 JoomlaSite - Administration - Microsoft Internet Explorer

Fle Edt View Favortes Tools Help o
; == »

Qeack - O - ¥ [@ b Posearch JeFavortes £ -REBU0d9o3 Links

#ddress | @] http:flocalhost fioomlajadministratorjindex.php?option=com_templateséclient=1 v e

¥ Joormlal’ JoomlaSite

Site Menus Content Components Extensions Tools Help (54 Preview 0 M1 Oiogout
F - s
..l Template Manager / »,
Defaut  Edt  Help

Site Administrator

# Template Hame Default  Version Date Author

1 o Khepri 10 0524106 Ancly Miller

Display #20 v

Joomial is Free Software released under the GRILIGPL License.

&) Dane 8 Local intranet

Why does Joomla have two sets of templates: site and administrator? The
reason is that this arrangement is meant to save you from the problems a
dysfunctional template can cause if you install it. If you install a template that
has serious problems (and a few like that are out there), your site may be
unreadable. How could you change back to the previous template?

That’s why the site and administrator templates are different. Even if you
mess up your site with an unworkable template, the back end will still be fine,
with the Khepri template still purring along. You can use Template Manager
to change the site template back to one that works.

Now that you know about this safety net, we show you how to change the
default site template.
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Changing the Default Template

|
Figure 9-3:
Making
Beez the
default site
template.
|

The default site template in Joomla is Milky Way (rhuk_milkyway), which

you'll also see spelled MilkyWay and Milkyway. You can tell that it’s the

default when you view Template Manager, because a gold star appears in

that template’s Default column.

To make the Beez template the default instead, select the radio button in the
beez row in Template Manager and then click the Default button. Template

Manager now shows Beez as the default site template (see Figure 9-3).

2 JoomlaSile - Administration - Microsoft Internet Explorer: E@@
:'l

File Edt View Faworites Tools  Help
Qback ~ O - B B 6| Oseach Frravoites @ | (3- % B0 E D B ks
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! Joomlal’ Joomlasite

Site Menus Content Components Extensions Tools Help |24 Preview: o M2 O oot

. Template Manager 7

Defout  Edt  Hep

Site | Administrator
# Template llame Default Assigned  Version Date Author
1 e A Puriy 120 122607 Joormlrt com
2 C beez 4 100 19February 2007 Angie RactkeRobert Deltz
3 © rhuk_milkyay 102 11720106 Ancly Miller
Display #20 |
dnamlal is Free Software released under the GRLIGPL License
v
&) bane % Local intranet

To switch back to the Milky Way template, select the radio button in the
rhuk_milkyway row in Template Manager; then click the Default button.

Editing a Built-In Template

If you're restricted in terms of the number of templates that come with

Joomla, can you at least customize the built-in templates? You can, and we

show you how in the following sections.
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Figure 9-4:
The Edit
Template
page for
rhuk_
milkyway.
|
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Customizing a template is not something to be undertaken lightly; it demands
knowledge of CSS and sometimes of PHP. You can really mess up your site’s

templates if you don’t know what you’re doing!

Customizing a template

You can customize a built-in Joomla template, at least to a limited extent.
To do so, click the template’s filename in Template Manager to open its Edit
Template page (see Figure 9-4).

2 JoomlaSite - Administration - Microsoft Internet Explorer

File Edit View Favorites Tools  Help
Qek - Q- HN R G

Address |&] hetp:j)

£E93
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- search Favorites ) v i

php?option—rom t

7
»
Links

> S

¥ Joormlal’ JoomiaSite

Details Parameters

Hame: RHUK Milkyway template

Color Variation [Blue |

Description: Mikyiiay is & fresh new template for
Jnomizl The clean design of this template

makes it very lightuweioht and fast

Background Variation [Blue  |[w

Template Width | Fluid with maximum |

Menu Assignmernt

Menus: Cannot assign Default Template:

Joomlal is Free Software released under the GNLIGPL License.

site Menus | Content = Components  Extensions  Tools | Help (5 Freview 0 M1 9 Logout
( B S =,
K1 Template: [gdit) XL e e v v QO
Preview EditHTML EdtCSS  Save  Apply  Closs  Help

The Parameter-File templatesirhuk_milkyvvaysosrams i is Whitable!

&) Dane

% Local intranet

Changing colors, backgrounds, and widths

The Edit Template page allows you to edit some settings, but your options
are pretty limited. You can set the main color of elements such as menu bor-
ders, for example, with the Color Variation drop-down menu, which contains

these options:

v Blue
v Red
v Green
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\NG/
$

v Orange

v Black

v White
You can also set background colors with the Background Variation drop-
down menu. Here are the possibilities:

v Blue

» Red

v Green

v Orange

v Black

v White
Finally, you can set the Template Width drop-down menu to one of these
options:

v Fluid with Maximum (fluid means that it resizes with window width)

v Medium

v Small

v Fluid

Assigning templates by page

The Menu Assignment setting is a great feature that lets you assign templates
on a page-by-page basis. If you install the Beez template for only one article,
for example, while using the Milky Way template on the rest of the site, the
result is a page like Figure 9-5. Just select the menu items whose pages you
want the template to be used for.

Using different templates on your site can be a good idea if your site is
broken up into sections on discrete topics — sports and fashion, for example.

Although the ability to use different templates for different pages is a very

powerful feature, you should use it with care to keep your site from looking
chaotic.

Editing a template’s code

If you want to make more significant changes to a template, you have to
change its underlying code.
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You can get into a template’s actual HTML and CSS code via its Edit Template
page (refer to Figure 9-4), which contains Edit HTML and Edit CSS buttons.

Click the appropriate button to view the template’s HTML or CSS code.

CSS code. For that reason, we discuss the CSS file in this section.

Viewing the CSS file

To open a template’s CSS file for editing, follow these steps:

1. In the template’s Edit Template page, click the Edit CSS button.

When you customize a template in Joomla, you typically make changes to its

\NG/
S

The Template CSS Editor page opens (see Figure 9-6). This page lists the
CSS files associated with the template — usually, a lot of them.

2. In the Writable/Unwritable column, check the status of the template

you want to edit.

Make sure that the template’s Writable/Unwritable status is Writable. If
it’s not, you probably need to change the associated file’s protection set-
ting on your Web server before working with that file. (If you don’t know
what that means, ask your service provider’s tech staff for help.)

3. Select the radio button for the template you want to edit, and click the

Edit button.

The template’s CSS file (template.css) opens for editing in Template
Manager (see Figure 9-7).
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Figure 9-6:
The
Template
CSS Editor
page.

Figure 9-7:
Viewing a
tem-
plate.
css file.
|
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/*%* Core html setup stuff *++/
2 U S

Beml {
height: 100%;
margin-bottem: lpx;

¥

form {
margin: 0f
padding: 0;
3
body {
font-fawily: Helvetica,Arial,sans-serif;
line-height: 1.%em;
uargin: Opz Opx Opx Opx;
font-zize: Lopx; b
&) Dane %J Local intranet

The template.css file is a long one — about 16 pages — and that’s just
one of the files that goes into a Joomla template. It’s a bona-fide CSS file, and
here’s how it starts:
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/*****************************/

/*** Core html setup stuff ***/

/*****************************/

html {
height: 100%;
margin-bottom: 1lpx;

}
form {
margin: 0;
padding: 0;
}
body {
font-family: Helvetica,Arial, sans-serif;
line-height: 1.3em;
margin: Opx Opx Opx Opx;
font-size: 12px;
color: #333;
}

a:link, a:visited {
text-decoration: none;
font-weight: normal;

}

a:hover {
text-decoration: underline;
font-weight: normal;

}

input.button { cursor: pointer; }

p { margin-top: 0; margin-bottom: 5px; }
img { border: 0 none; }

/*****************************************/

/*** Template specific layout elements ***/
/*'k***************************************/
#page_bg {

padding: 10px 0;

margin-bottom: 1lpx;

}
div.center {

text-align: center;

}

(continued)
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div#wrapper {
margin-left: auto;
margin-right: auto;

}

body.width_medium div#wrapper {
width: 950px;
}

Unfortunately, to edit this file you really have to know what you’re doing —
not only in CSS, but also in PHP and HTML — to make your own changes.
(A good WYSIWYG code editor built into Joomla would be great for this
situation.)

Editing code to this extent is beyond the scope of this book, but see two other
titles for help: HTML, XHTML & CSS For Dummies, 6th Edition, by Ed Tittel and
Jeff Noble, or PHP & MySQL For Dummies, 3rd Edition, by Janet Valade (both
from Wiley Publishing).

Editing the CSS file

In Chapter 3, we show you how to edit template.css to change the logo
that you can see at the top of all pages. To do that, you change the div#logo
item like this:

div#logo {
position: absolute;
left: 0;
top: 0;
float: left;
width: 298px;
height: 75px;
background: url(../images/superdupermegaco.PNG)
0 0 no-repeat;
margin-left: 30px;
margin-top: 25px;

}

Templates generate their HTML using a PHP file. and the main PHP file is
named index.php. Here’s the section of that file from the Milky Way tem-
plate that generates the <body> element:

<body...>
<a name="up" id="up"></a>
<div class="center" align="center">
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<div id="wrapper">
<div id="wrapper_r">
<div id="header">
<div id="header_1">
<div id="header_r">
<div id="logo"></div>
<jdoc:include type="modules" name="top" />
</div>
</div>
</div>

<div id="pathway">
<jdoc:include type="modules" name="breadcrumb" />
</div>

<div class="clr"></div>

<div id="whitebox">
<div id="whitebox_t">
<div id="whitebox_ tl">
<div id="whitebox_ tr"></div>
</div>
</div>

<div id="whitebox_m">
<div id="area">
<jdoc:include type="message" />

<div id="leftcolumn">
<?php if($this->countModules ('left')) : ?>
<jdoc:include type="modules" name="left"
style="rounded" />
<?php endif; 2>
</div>

<?php if (Sthis->countModules('left')) : ?>
<div id="maincolumn">
<?php else: ?>
<div id="maincolumn_full">
<?php endif; 2>
<?php if(Sthis->countModules ('userl or
user2'))
?>
<table class="nopad userluser2">
<tr valign="top">
<?php if ($this->countModules ('userl'))
2>
<td>

(continued)
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<jdoc:include type="modules"
name="userl" style="xhtml" />
</td>
<?php endif; 2>
<?php if (Sthis->countModules ('userl and
user2')) : ?>
<td class="greyline">&nbsp;</td>
<?php endif; 2>
<?php if (Sthis->countModules ('user2'))
?>
<td>
<jdoc:include type="modules"
name="user2" style="xhtml" />
</td>
<?php endif; ?>
</tr>
</table>

<div id="maindivider"></div>
<?php endif; 2>

<table class="nopad">
<tr valign="top">

<td>
<jdoc:include type="component" />
<jdoc:include type="modules"
name="footer" style="xhtml"/>

</td>

<?php if (Sthis->countModules ('right') and

JRequest: :getCmd('layout') != 'form')

<td class="greyline">&nbsp;</td>
<td width="170">
<jdoc:include type="modules"
name="right" style="xhtml"/>
</td>
<?php endif; ?>
</tr>
</table>

</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

</body>
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Note how this works. To include a component (that is, to display article con-
tent), you use a <jdoc:include> element with the type attribute set to
"component":

<jdoc:include type="component" />

To include a module, you use a <jdoc: include> element with the type
attribute set to "modules". Here’s how the code includes the footer module:

<jdoc:include type="modules" name="footer" style="xhtml"/>

If you look at the above code for the <body> element, you'll see that the
Milky Way template creates Web pages by inserting components and mod-
ules into an HTML table, which gives structure to the page and arranges
those components and modules on the page.

There’s a lot of debate about whether it’s better to use HTML tables or CSS to
arrange components and modules in Joomla templates; both sides of the argu-
ment have strong points. HTML tables, for example, are pretty rigid structures
that make it hard for search engines to understand the content of your page.
CSS implentations, on the other hand, vary widely from browser to browser,
and some older browsers allow you to use only minimal CSS. The Beez tem-
plate in Joomla is an example of a tableless CSS template.

As you can see, truly customizing a Joomla template is not something to be
undertaken lightly. So how do you get the template you want? You can down-
load it.

Working with New Joomla Templates

Want to use a template that’s out of the ordinary — one that offers you more
color and pizzazz than the built-in templates? You can get fancy templates by
the hundreds on the Internet and install them in Joomla, because Joomla is
built to be extended.

One of the greatest features of Joomla is extensibility. You can extend the
software by installing new plug-ins (tools like CSS editors), components, mod-
ules, and templates. Hundreds of such items are available to download from
the Internet — some free, some not. The offerings vary widely, from new edi-
tors to whole shopping-cart systems to template designers (usually not very
good yet) to fancy templates.

In this section, we show you how to find, download, and install new Joomla
templates.
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Templates you find on the Internet aren’t always marked for the version of
Joomla they’re designed for, so make sure that you install only templates
designed for your version. If you try to install a template designed for Joomla 1.5
in Joomla 1.0, for example, Joomla displays a message asking you to install the
Legacy plug-in, which helps modules and templates make the transition from

1.0 to 1.5. It’s better just to find another template, though.

A word about security: When you download and install new templates, com-
ponents, modules, or plug-ins, you're asking Joomla to run unknown PHP code
on your computer or your host’s server. This situation can be a significant
security risk. Before you download and install something, make sure that you
feel comfortable about it. If you wouldn’t feel OK about running an executable
program from a given source, think twice.

Finding and downloading a new template

To find templates to install, just search the Internet. At this writing, a Google
search for Joomla templates turns up a mere 13.9 million matches, whereas a
search for free Joomla templates yields 823,000 matches, including such sites
as Lonex (www. lonex.com), Joomlashack (www. joomlashack.com), and
Joomla24 (www.joomla24.com).

For this exercise, you download a free template from Lonex. Follow these
steps:

1. Point your Web browser to www.lonex.com/content-management -
system/joomla/templates.
2. Scroll down the page to find the template you want.
For this exercise, select the Graffiti template (for Joomla 1.5).
3. Click the Free for Download link.
The Graffiti.zip file downloads to your computer.
Most of the items you can install in Joomla come in compressed files, such as

. zip files. Usually, all you have to do is to tell Joomla what to install, and it
uncompresses and installs the item for you.



Chapter 9: Laying Out Your Web Pages with Joomla Templates 2 2 9

Installing a new template

To install your new template, follow these steps:

1. Log in to Joomla, and choose Extensions~Install/Uninstall.

SMBER
)
Iy Y . . . . . .
ou use this command to install or uninstall any extension, including
plug-ins, modules, components, and templates.
Extension Manager opens (see Figure 9-8).
2 Extension Manager : Install - Microsoft Internet Explorer E@E‘
Fle Edit View Favortes Tools Help o
Q) Back - H B b Oseach rFavorites £ (9v i B3 links ™
Address :gjhttp‘ﬂf\D[a\hustf]uumla/admlmstraturﬂlndex.php?nplmn:[nm _installer | | G0
¥ Joomlal” Joomlasite
Site Menus Content Components Extensions Tools Help |28 Preview 0 M1 O Logou
;J Extension Manager L
Help
Install Components Modules Plugins Languages Templates
Upload Package File
Package File: CiJoomlabookiGraffiti.zip Browse. Upload File & Install
Install from Directory
Install Directory. Install
I Install from URL
Figure 9 8' Install URL: hittp:ir Install
Extension
M a n a g er Joomla!is Free Softvware released under the GNUUGPL License =
. &
— ) pore % Local intranet

2. In the Upload Package file section, click the Browse button to find and
select the new template file on your hard drive.

For this exercise, select Graffiti.zip.

. Click the Upload File & Install button.

If the installation process (which involves making a new subdirectory
named Graffiti in the Joomla templates directory) went smoothly,
you should see a confirmation page.
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You can make the new template the default template, if you want, by select-
ing the Graffiti template’s radio button in Template Manager and then click-
ing the Default button (refer to “Changing the Default Template,” earlier in
this chapter).

To view the new template (see Figure 9-9), click the Preview link in the top-
right corner of any back-end page. Pretty snazzy, eh?
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AV P =2
saalch - q v
S . ~
i P ¥ -
i)
JoomlaSite L]
About Joomla! Features HNews The Community
IWE HAHHENS This is my site
A
+ Home Welcome to my site o=
+ Ice Cream Flavars
‘Written by Administrator
» Ice Cream Bars
Thursday, 21 August 2008 17:57
+ lee Cream Cones
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i R :
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Part IV

Joomla in the
Real World

The 5th Wave By Rich Tennant
[PReENT - g hates

“We have no problem funding your Web
site, Frank. Of all the chicken farmers
operating Web sites, yours has the most

impressive cluck—through rates.”



In this part . . .

Tlis part takes a look at real-world issues for Joomla
sites, starting with managing eight levels of users.
With the exception of casual surfers, you create accounts
for all these users or allow them to create accounts for
themselves. In this part, we show you how to manage
your site’s users.

We also show you how to drive users to your site through
search engine optimization. Finally, we show you how to
extend Joomla by downloading and installing new modules,
components, and plug-ins.




Chapter 10
Managing Your Web Site’s Users

In This Chapter

Understanding Joomla’s eight user levels

Adding new users to your site
Editing user accounts
Creating a contact page
Managing e-mail on your site

Giving users options that they can manage themselves

' his chapter is all about giving the users of your site user privileges:
author, administrator, registered user, and so on. A Joomla site has eight
levels of users; in this chapter, you see all of them and what they can do.

Rest assured that you're still the super administrator — and the super admin
can do anything it’s possible to do on a Joomla site.

Introducing the Wonderful
World of Joomla Users

Joomla sites can have eight levels of users, starting with the front-end users:

v~ Public users are casual surfers of your site.

1 Registered users can log in to see resources that are reserved for them.
The next three levels of front-end users fall into the Special user class, along
with all the back-end users:

v Authors can submit articles.

v~ Editors can submit new articles and edit existing articles.

+~ Publishers can submit new articles, edit existing articles, and publish
articles.
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Finally, the back end has three levels of users:

1 Managers can manage everything having to do with site content.

v Administrators can perform administrative functions.

v Super administrators can do anything that’s possible to do on a
Joomla site.

How do you handle these various types of users and give them their privi-
leges in the first place? You use the Joomla User Manager.

Managing Users with User Manager

So how do you manage users? This being Joomla, of course you use a feature
called User Manager (see Figure 10-1). To open it, click its icon in the control
panel or choose Sitem>User Manager in any back-end page. You can see the
User Manager in Figure 10-1.

User Manager is great for adding new users to your team or editing the
records of existing users, such as when they change their e-mail addresses.
To edit an existing user, check the check box in his row of User Manager and
then click the Edit button to open the Edit User page.

2 JoomlaSite - Administration - Microsoft Internet Explorer Eﬁ|@
Fle Edt View Favortes Took Help *
Qback - 3 B B | Osearch rravoices €| -2 2L E D3 Links ™

Acibess | ] tprilocalhost fjoomla/administratarjindex. php?option=com_users v B

¥ Joormlal’ JoomlaSite

Site  Menus  Comtent  Components  Extensions  Tools  Help [ Preview 0 M1 'O Logout

o8 User Manager g - Q0

Logout  Delets  Ecit  New  Help
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et [-setwctoroup- ][ Stect Log st ]
# Hame Username LoggedIn Enabled Group E-Mail Last Visit {1
1 T Administrator adimin v ' Super Administrator  steve@superdupermegaca com 2008-08-161510:01 62
2 [ author author 4 Ahor author@superdupermegaco.com 2008-08-11 17:32:42 63
3 T edtor ecitor ~ Edlitor editor@sUperdupermegaco com 2008-08-0518:08:05 64
4 [ publisher publisher ~ Puklisher publisher@superdupermegaco. com  2008-09-0519:06:25 65
Fi 10-1 Display (20 %
igure 10-1:
U S e r Joomlalis Free Software released under the GRUIGPL License
Manager.

) Done, but with errors on page. % Lacal intranet
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You can configure several settings in the Edit User page (see Figure 10-2),
such as entering a new e-mail address or password, or changing the user’s
privilege level by resetting the user group (author, publisher, administrator,
and so on) to which he belongs. You can also disable the account by select-
ing the Yes radio button in the Block User section.

A JoomlaSite - Administration - Microsoft Internet Explorer FEIx
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New Password User Editor |- Select Edftor- ~|
Verify Password Help Site v
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- Editor _ .
- Publisher Contact Information
- Public Badend
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Receive System E-mails g & ves

Register Date 2008-05-23 18:36.06
Last Visit Date 2008-08-16 15:10:01

|
[[E3
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% Local intranet:

If you haven’t added any users to the default Joomla installation, only

you appear in this page, listed as a super administrator. (Your name is
Administrator, even though you’re not just an administrator; you’re a super
administrator.) But your site would be awfully lonely if you were the only
user. In the following sections, we show you how to add new users, starting
with the most basic type: registered users.

Creating registered users

The most basic users — beyond mere Web surfers who happen by your site —
are registered users. They can log in to your site (using the login box that
appears on the front page by default) and see resources reserved for regis-
tered users.

Chapter 10: Managing Your Web Site's Users 235
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Joomla provides two ways to create a registered user:

v The administrator creates the user’s account in User Manager.

v The user herself can click the Create an Account link in the login module
on the front page and then fill out a registration page.

We describe both methods in the following sections.

User-created accounts

When a new user registers by creating her own account, however, she can’t
log in until the account is activated. Joomla sends the new user an e-mail,
and she clicks an activation link in the e-mail to register and activate the new
account. After the account is activated, the new user can log in to the site.

Joomla activates the account this way because it verifies both the user and
her e-mail address, and it allows the user to select her own password. This
setup also allows you, as site administrator, to manage new users better. A
nonactivated account appears as a blocked account in User Manager, and
when you check the record, it will indicate that the user has never signed in.
Such an account is easy to delete if necessary.

You don’t have to require new users to click a link in an e-mail message to
active their accounts, however. Choose Sitew>Global Configuration to open
the Global Configuration page; then look at the User New Account Activation
option. When you disable user activation, new users will be able to log in
immediately after registering. This page also contains an option labeled
Require Unique Email, which ensures that the same e-mail account can’t be
used to create more than one account.

The default user group for newly registered users is Registered, but you can
make it Author, Editor, or Publisher by default. To do that, choose Siter>
Global Configuration to open the Global Configuration page, and select the
default user group for newly registered users in the New User Registration
Type list.

Administrator-created accounts
Besides allowing users to create their own accounts, you can create accounts

for them with User Manager. Follow these steps:
1. Click the New button in User Manager.
The New User page opens.
2. Enter the account information for the new user.

The Public Front-End and Public Back-End items you see in the Groups
list box aren’t actually groups; they’re just placeholders for features that
are expected to appear in future versions of Joomla.

Your settings may resemble Figure 10-3.
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3. Click the Save button.

Joomla creates the new account and takes you back to User Manager,
where the new registered user appears. The user can log in immediately
and view resources that you've marked as needing registered privileges.

Registered users are the lowest level of users that your site keeps track of.
We discuss the next level — special users — in the following sections.

Creating authors

Authors can write articles and submit them on your site. To add a new
author, click the New button in User Manager to display the New User page;
then fill in the user’s account information, making sure to add the user to
the Author group. When you finish, click the Save button. Your settings may
resemble Figure 10-4.

Creating editors

Like authors, editors belong to the Special users group; also like authors,
they can submit articles. But they can edit articles, too, and their edits
appear on the site as soon as they make them.
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Figure 10-4:
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Figure 10-5:
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an editor
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User Details
Hame Scoftie Fitzgerald

Username scoftiefitzgerald
E-mail |scottiefitzgerald@superdupermegaco.ci
Hew Password sesssssss
Verify Password

Group [ Fublic Front-end

- Registered

- Editor
- Publisher
- PublicBadeend
- Manager
- Administrator
- Super Administrator

To add a new editor to your site, enter the appropriate information in the
New User page, making sure to add the new user to the Editor group. Your
settings may look something like those in Figure 10-5.

User Details
Hame |Maxie Peddns

Username maxiepeking
E-mail maxiepedkins@auperdupermegace.com
Hew Fassword (sssssesss

Verify Passwortd eesseesse

Group ||

Public Frontend
- Registered
- Author

- Fublisher
- PublicBadeend
- Manager
- Administrator
- Super Administrator

Creating publishers

Publishers are the most powerful of the front-end users. Like authors, they
can submit articles. Like editors, they can edit articles, and their edits appear
online immediately. But they also have the authority to publish articles on
your Web site — without back-end approval.

Adding a new publisher is simple enough; just set the appropriate options in
the New User page. Your settings may resemble those in Figure 10-6.

Now that you know how to create registered users, authors, editors, and pub-
lishers, you're ready to create new back-end users.
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Figure 10-6:
Creating a
publisher
account.
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User Details
Hame |Charlie Scribner

Username | charlieseribner
E-mail harlieseribnern@superdupermegaco.com
Hew Fassword (sssssesss

Verify Passwortd eesseesse

Group [ Fublic Front-end
- Registered
- Author

- Editor

- PublicBadeend
- Manager
- Administrator
- Super Administrator

Creating managers

Managers are back-end content managers and can do anything related to the
content of your site, such as writing articles, editing them, and publishing
them — all from the back end. They can’t do the following, however:

v Manage users

v Install or uninstall modules

v Install or uninstall components

v Work with some components (as set by the super administrator)
These tasks are reserved for administrators and super administrators.

You create a manager account the same way you create any other user
account: in the New User page.

Creating administrators

Administrators are near the top of the Joomla hierarchy. No one is higher
than administrators except super administrators.

Administrators can manage other users (except super administrators); they
can enable or disable user accounts; they can install or uninstall modules.
They can’t do the following things, though:

v Add to or edit the Super Administrator group

v Access the Global Configuration page
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v Access the Mass Mail function to e-mail multiple users
1 Manage, install, or uninstall templates

v Manage, install, or install language files

Use the New User page to set up an administrator account.

Creating super administrators

Super administrators can do it all: publish and edit articles; set global configu-

rations; install and uninstall modules, components, and templates; disable user
accounts; create new accounts — and more. These administrators can do any-
thing that a person can do in Joomla, either from the front end or the back end.

The name super administrator fools some people into thinking that you can
have only one super administrator per Joomla site, but that’s not so. You can
have as many super administrators as you like.

You need at least one super administrator for every Joomla site, and when
you create a new site, that’s you. The default super administrator is given the
username admin.

For security reasons, it’s a good idea to change the admin username.
Now that you’ve seen the whole spectrum of Joomla users, from casual Web

surfers to super administrators, you're ready to see how to give all these
users access to the personnel of a Joomla site.

Building a Contact Page

A contact page is a great addition to any Joomla site. Several big-time corpo-
rations’ Web sites provide no way to contact anyone, which is very frustrat-
ing to users, so think twice before omitting this page.

If you want to list some of your users in a contact page. Joomla can help. In
fact, it maintains a Contacts category that makes creating a contact page
simple. In the following sections, we show you how to add contacts to your
site and then display them in a contact page.

Adding contacts to your site

Joomla maintains — what else? — a Contact Manager to let you add contact
information.
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To add a contact to your site, follow these steps:

1. Choose Components->-Contacts=>Contacts in any back-end page.

The Contact Manager page opens, listing one default contact (see
Figure 10-7).

2. Click the New button to open the New Contact page.

The Information pane has space for a great deal of contact information,
including the following:

Contact’s Position Telephone
E-Mail Mobile Phone
Street Address Number
Town/Suburb Fax
State/County Web URL
Postal Code/ZIP Miscellaneous

Information
Country

3. Enter as much contact information as you like in the Information pane.

4. In the Details pane, choose Contacts from the Category drop-down
3 menu and the user’s name from the Linked to User drop-down menu.

Want to create a contact page for someone who’s not a user? Just
choose No User from the Linked to User drop-down menu.

3 JoomlaSite - Administration - Microsoft Internet Explorer ME|@
Fle FEdt View Favortes Tools Help o
Qbsck - 9 - B B 6| Osearch Frravortes @3- % B0 E @3 liks ™
address ] http:flocalhost fioomlajadministratorindex.php?option=com_rorkact v B

¥ Joomlal’ Joomlasite

Site  Menus  Content  Components  Extensions  Tools  Help B preview 0 M1 OlLogout

- o =
W Contact Manager 2 s @ - @ P Lo

s Publish  Unpuklish  Delete  Ecit Mew  Parameters  Help

Contacts  Categories
Fiter: |- selecta Categary- v |- Gelect State - v |
i Hame Published Order by~ ¥ AccessLevel  Category  LinkedtoUser ID
1 Name -1 Fublic Contacts 1

Fi

Display #20 v

Joomlal is Free Software released under the GHLIGPL License.

Figure 10-7:
Contact
Manager. |
—— ] Done, but with errars on page.

% Local intranst




202 PartIv: Joomla in the Real World

Figure 10-8:
Adding a
new user

to Contact
Manager.
|

5. In the Contact Parameters pane, set radio-button options to specify
what contact information appears (and doesn’t appear) in the user’s
contact page.

Your choices are similar to those in the Information pane.
At this point, your settings may resemble Figure 10-8.
6. Click the Save button.

You return to Contact Manager, which shows the new contact (see
Figure 10-9).

7. Repeat Steps 2-6 to add as many contacts as you want.

8. When you finish adding contacts, delete the default Name entry by
selecting that item and clicking the Delete button.

Creating a contact page

After you add contacts to your site, the next step is creating a contact page
and a menu item that links to it.

To create the page and menu item, follow these steps:

1. Choose Menus=>Menu Manager menu in any back-end page to open
Menu Manager.

For more information on using Menu Manager, see Chapter 5.
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2. In the row of the menu you want to use, click the icon in the Menu
Item(s) column to open Menu Item Manager.

For this exercise, select Main Menu.
3. Click the New button to open the New Menu Item page (see Figure 10-10).

4. Click Internal Link=>Category=>Contact Category Layout to open the
Contact Category Layout page.

The Contact Category Layout page opens.
5. In the Title text box, enter the title of the new menu item.
For this exercise, type Contact Us.

6. In the Parameters - Basic pane, choose Contacts from the Select
Category drop-down menu.

7. Click the Save button.
You return to Menu Item Manager.

8. Click the Preview link in the top-right corner.
Joomla displays the new menu item on your site.

9. Click the new menu item to open the contact page (see Figure 10-11).
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Now, if a user wants to send a message to a particular contact, the user can
just click that contact’s name to display an e-mail form.
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Managing Site E-Mail

What if you want to get in touch with not just one user on your site, but a
whole group of users? You can send e-mail en masse with the Mass Mail func-
tion. To set up that function, choose Tools=>Mass Mail in any back-end page
to open the Mass Mail page; then set the various options you want to use and

enter your message (see Figure 10-12).

You can select the recipient user group(s) in the Group list, or you can select

All User Groups to e-mail all the users on your site.
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You can create and read private messages in
Joomla, but for some reason, private messages
are available only to members of the Super
Administrator group. If you're a super adminis-
trator, you can create a new private message
to another super administrator by choosing
Tools=>Write Message in any back-end page.

Super administrators see a message icon in the
top-right corner of back-end pages (