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Introduction

ware. The depth and breadth of the program is unheralded. Photoshop immediately

sucks you in with its easy-to-use interface and powerful tools and commands. It is so fea-
ture rich that you soon begin to lose track of time and start blowing off your commitments
just to try one more thing. And just when you think you’ve finally explored every nook and
cranny and mastered the program, you suddenly read a tip in a book or magazine that enlight-
ens you about something you didn’t know. Or even more likely, you stumble upon some great
effect while working on a late-night project. That’s the beauty of Photoshop. It’s the program
that just keeps giving.

There’s a reason why Photoshop is the world’s industry standard in image-editing soft-

The depth and breadth of Photoshop has downsides, too, of course. You must make a major
time commitment and invest much effort to master it — hence the large number of books writ-
ten on the program. Walk into your neighborhood bookstore or type Photoshop in the Search
field at any online bookseller’s site, and you’ll see a barrage of choices. Some books are gen-
eral reference books, some are targeted toward the novice user, and others focus on a specific
mission, such as color management or restoration and retouching.

About This Book

This book is written for the person who has a good grasp of using a computer and navigating
the operating system and at least a cursory knowledge of Photoshop. It is intended to be a
comprehensive reference book that you can read cover to cover or reach for when you're
looking for specific information about a particular task.



What’s in This Book

Wherever I can, [ sneak in a useful tip or an interesting technique to help you put Photoshop
to work for your project needs.

Numbered steps

When you see a sequence of triangles just before a section heading, you know that the section
you'’re about to read contains a numbered sequence that shows you how to complete a spe-
cific task. Steps appear in an easy-to-follow, two-column format, along with plenty of images to
help you out.

If you see a black box around a step number, it indicates that a figure accompanies that step.
For example, if the 2 in Step 2 has a black box around it, a figure that follows corresponds with
that step. The figure itself will have a numbered callout referencing the step number.

Putting It Together

Sometimes, knowing how to use a tool doesn’t necessarily mean that you know what to do
with it. That’s why this book contains several exercises that help you make a connection
between the multiple Photoshop tools at your disposal and the very specific task you need to
accomplish. Want to get the red out of a subject’s eyes or create a collage? Just check out the
Putting-It-Together sections in Books Il through X. These sections present info in easy-to-
follow numbered steps, in a hands-on style, building on what’s presented in the chapter so
that you can go to the next level, put concepts to work, and move on to the next task.

What’s in This Book

This book is broken down into minibooks, each covering a general topic. Each minibook con-
tains several chapters, each covering a more specific topic under the general one. Each chap-
ter is then divided into sections, and some of those sections have subsections. I'm sure you
get the picture.

You can read the book from front to back, or you can dive right into the minibook or chapter
of your choice. Either way works just fine. Anytime a concept is mentioned that isn’t covered
in depth in that chapter, you find a cross-reference to another book and chapter where you
find all the details. If you're looking for something specific, check out either the Table of
Contents or the index.

The Cheat Sheet at the beginning of the book helps you remember all the shortcuts you'll use
most often. Tear it out, tape it to your monitor, and don’t forget to say, “Thanks.” You're very
welcome.

And finally, I've got pictures. Lots of them. And many of these pictures have callouts that point
to specific steps or identify important concepts, buttons, tools, or options. With a program
like Photoshop, an image often speaks louder than words.

This book contains ten minibooks. The following sections offer a quick synopsis of what each
book contains.



What's in This Book

Book I: Photoshop Fundamentals

Ready to get your feet wet with the basics of Photoshop? Head to Book I. Here’s where you get
familiar with the Photoshop environment — the desktop, the menus, and the palettes. I also
briefly introduce the tools and explain what each one does.

In this book, I cover how to get started on Photoshop and how to view and navigate your
image window. Here’s also where I give you all the important details about the o’'mighty File
Browser and also how to customize your workspace and preference settings.

Finally, I go into the bare basics of printing, and then how to save files and close Photoshop.

Book II: Image Essentials

This book covers all those nitpicky — but critical — details about images, such as size, resolu-
tion, pixel dimension, image mode, and file format. Turn to this book to find out how to safely
resize your image without causing undue damage.

You can also find out how to crop images and increase their canvas size. In addition, I breeze
through basic color theory and get you started using and managing color.

But wait, there’s more. I give you the lowdown on the History palette and brushing and eras-
ing to history. And, if that’s not enough, I throw in a chapter on applying annotations and
notes to your image and using and creating actions for enhanced productivity.

Book IllI: Selections

This important book gives you all the juicy details and techniques on creating and modifying
selections and paths. You find out about each of the selection tools and also the powerful —
albeit sometimes unruly — Pen tool and its accompanying Paths palette.

Book IV: Painting, Drawing, and Typing

If you want to know about the drawing and painting tools, this is the book for you. Here |
cover the Brush and Pencil tools, along with the once again improved Brushes palette. [ also
show you how to create vector shapes by using the shape tools, and how to fill and stroke
selections.

Head to this book to find out how to create both gradients and patterns and, last but not least,
become familiar with the type tools and how to use them to create and edit both standard
type, type on and in a path, and type with special effects.

Book V: Working with Layers

Layers are an integral component in a Photoshop image, and Book V is where I explain them.
In this book, you discover how to create and edit layers and how to use multiple images to
create a multilayered composite image. I also introduce you to the various ways that you can
manage layers for maximum efficiency, including using the new Layer Comps palette. Finally, I
show you how to enhance your layers by applying different blend modes, opacity settings,
layer styles, styles, and clipping groups.
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What’s in This Book

Book VI: Channels and Masks

This book gives you all the how-tos you need to work with channels and masks. [ show you
how to save and edit selections as alpha channels so that you can reload them later. And I
show you how to work with the various kinds of masks — quick masks, layer masks, and
channel masks — and how you can use each to select difficult elements. I also cover other
masking techniques, such as erasing and using the Color Range command.

Book VII: Filters and Distortions

[ filled this book with tons of handy tips and techniques on using filters to correct your images
to make them sharper, blurrier, cleaner, and smoother — whatever fits your fancy. You also
find out how to use filters to give your image a certain special effect, such as a deckled edge
or water droplets. Then I introduce the Liquify command so that you can see the wonder of its
distortion tools — and how they can turn your image into digital taffy.

Book VIII: Retouching and Restoration

Everything you need to know about color correction or color enhancement can be found in
Book VIII — getting rid of colorcasts, improving contrast and saturation, remapping, and
replacing colors.

In addition, I included a chapter on using the focus and toning tools to manually lighten,
darken, smooth, soften, and sharpen areas of your image. You get to see how you can use the
Clone Stamp tool, and the Healing Brush and Patch tools to fix flaws and imperfections in your
images, making them good as new. And finally, I introduce you to the new Color Replacement
tool and show you how to replace your image’s original color with the foreground color.

Book IX: Photoshop and the Web

This book gives you the lowdown on preparing your images for the Web. Find out how to opti-
mize your images for maximum quality and quick download times. You also find information
on slicing your images and creating a photo gallery that you can easily post on the Web. |
show you where Photoshop comes to an end with its Web-friendly tools and where
ImageReady then picks up the ball.

Book X: Photoshop and Print

If you need to get the scoop on how to prep your images for print, this is the book you need to
check out. Here you find the details on how to get the right resolution, image mode, and file
format for various applications. You also discover how to set up both process and spot color
separations. If you also work with other programs, [ provide a chapter on how Photoshop
plays nicely with other programs. And, for good measure, | throw in a chapter on how to
create contact sheets and picture packages from your digital masterpieces.



Conventions Used in This Book

Appendix A: Working with Digital Cameras and Scanners

If you own either a digital camera or a scanner, be sure to take a gander at Appendix A. You
find lots of juicy tidbits on prepping your images for scanning and then cleaning them up
afterward. [ also include some useful information on getting images from your camera into
Photoshop.

Appendix B: A Visual Reference of Photoshop Tools

If you're like me, you're probably reeling from all the tools and options. Which one does what?
How do you know which to choose? Check out Appendix B for a visual reference that shows
you each of the tools — as well as what the tools do. How’s that for handy?

Color Insert

Trying to illustrate the powers of Photoshop without showing some images in full, living color
is about as useful as if | handed you a broken umbrella on a rainy day. The 16-page color insert
does just that, so don’t miss it.

Conventions Used in This Book

You'll find that this book is cross-platform. Windows commands are given first, followed by
Mac commands in parentheses, like this:

Press Enter (or Return on the Mac) to begin a new line.

And occasionally, text is specific to one platform or another. You'll find that figures are divided
into both platforms as well.

Often the commands given involve using the keyboard along with the mouse. For example,
“Press Shift while dragging with the Rectangular Marquee tool to create a square,” or
“Alt+click (Option+click) on the eyeball to redisplay all layers.”

When you see a command arrow (=) in the text, it indicates that you should select a com-
mand from the menu bar. For example, “choose Edit=>Define Custom Shape” means to click
the Edit menu and then choose the Define Custom Shape option.

While this book has been written using Photoshop cs, you can still glean valuable info if you're
using Version 6 or 7. It may take a little more time to understand how a palette or options
have changed, and of course, the topics covering new features won’t be applicable. But hey,
when you see the cool Version cs features, you may get the impetus you need to go out and
upgrade!



Icons Used in This Book

Icons Used in This Book

While perusing this book, you’ll notice some icons beckoning you for your attention. Don’t
ignore them; embrace them! These icons point out fun, useful, and memorable tidbits about
Photoshop, plus facts you’d be unwise to ignore.

This icon indicates information that makes your Photoshop experience easier. It also gives
you an icebreaker at your next cocktail party. Whipping out, “Did you know that pressing
the bracket keys enlarges or shrinks your brush tip?” is bound to make you the center of
conversation.

Seasoned users will appreciate this icon, which kindly points out new features introduced in
Photoshop cs.

g

2

This icon is a reminder of things that | already mentioned and want to gently re-emphasize.
Or | might be pointing out things that | want you to take note of in your future Photoshop
excursions.

The little bomb icon is a red flag. Heed these warnings, or else Photoshop may show its
ugly side.

) &

{

<0)
YO!

This icon marks eggheady graphics or Photoshop info that goes beyond the basics.
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Where to Go from Here

If you want your voice to be heard, you can contact the publisher or authors of the For
Dummies books by visiting the publisher’s Web site at www.dummies.com, sending an e-mail
to customer@wiley.com, or sending snail mail to Wiley Publishing, Inc., 10475 Crosspoint
Boulevard, Indianapolis, IN 46256.

And, of course, the very next place to go is to the section of this book that covers your
favorite topic. Go ahead and dive right in.
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Examining the
Photoshop
Environment

In This Chapter
v~ Starting Photoshop

v~ Exploring the anatomy of
dialog boxes

v Working with palettes

v Examining the Photoshop
desktop

v~ Investigating the menu bar

v~ Discovering the Options bar

is pretty cool: as inviting as a landscaped backyard and

not nearly as likely to work you into a sweat. Each of the
many tools in Photoshop is custom-designed for a specific
chore and chock-full of more options than a Swiss Army knife.
When you’re familiar with your surroundings, you’ll be eager to
make like Monet in his garden, surrounded by palettes,
brushes, buckets of paint, and swatches of color, ready to
tackle the canvas in front of you.

E s environments go, the Photoshop working environment

Getting a Warm Welcome

"T When you launch Photoshop cs for the first time, you're

&?‘, :fw greeted by Photoshop’s rendition of the friendly neighbor-
hood welcome wagon. The handy Welcome Screen, shown
in Figure 1-1, provides a virtual plethora of goodies for
everyone from the beginner to the advanced user. New
feature descriptions, tutorials, tips, tricks, and help with set-
ting up color management are all at your fingertips. Don't
worry about exploring every item when you first launch
Photoshop. You can call up the Welcome Screen anytime
by choosing Help->Welcome Screen. Some of the informa-
tion provided is in PDF (Portable Document Format)
format, which can be read in Adobe Acrobat Reader (a
free download from www . adobe . com). Other information
is available through links to the Adobe Web site. There's
even a movie that details all the new features. So grab
some popcorn and enjoy.

If you prefer to access the Welcome Screen at your own leisure
and don’t want it to appear every time you launch Photoshop,
deselect the Show This Dialog at Startup option in the bottom-
left corner of the Welcome Screen window.
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Welcome Screen

o
Figure 1-1
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Launching Photoshop and Customizing the Desktop

You start Photoshop just as you launch any other program under Windows or the Mac OS. As
with other programs, you can choose the method you find the easiest and most convenient.
Here’s a quick summary of your options:

v Launch from the Windows Start menu. Windows PCs have a handy pop-up Programs
menu that includes your most frequently used applications. Just locate the program on
the menu and select it.

v Launch from the Windows taskbar or Macintosh OS X Dock. You may have inserted
icons for your really mission-critical programs in these readily accessible launching
bars, usually found at the bottom (or sometimes sides) of your screen. Click the
Photoshop icon to start.

v Launch Photoshop by double-clicking a shortcut or alias icon placed on your
desktop.

v Double-click an image file associated with Photoshop. When you installed Photoshop,
the setup program let you specify which type of common image file types (. TIF, . PSD,
.PCX, and so forth) you wanted to be associated with (or linked to, for launching pur-
poses) Photoshop, ImageReady, or neither (Windows only). Double-clicking an icon,
shortcut, or alias representing the file type you chose launches Photoshop.

When you launch Photoshop, the desktop workspace, shown in Figure 1-2, appears. Like the
real-world desktop where your keyboard and monitor reside, the Photoshop desktop is a
place for you to put all the documents you're working with.

The desktop consists of a main window, called the application window if you’re using Windows
(and called the document window if you're using the Mac OS), which takes up the majority of
your screen by default. Within the main window, you see a variety of other windows and
boxes, such as the image document window that enables you to view and edit images.
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Figure 1-2
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The main window contains the stuff you’re probably used to seeing in other programs — a
title bar at the top of the window, a status bar at the bottom (unless you have it turned off) if
you’re a Windows user, and menus to help you execute commands and get important informa-
tion about your image files. But the arrangement of controls may be a little unfamiliar to you.
Photoshop arranges controls into groups called palettes.

In Windows, borders mark the left and right edges of the Photoshop window — even if the
main application window’s contents fill up more than your screen can show.

Your virtual desktop can become as cluttered as the real thing, but Adobe has built in some
special features (located on the Options bar, which I discuss later in this chapter) that let you
keep stuff close at hand but tuck things away so they’re not constantly underfoot (or under-
mouse, so to speak). After you’ve arranged your Photoshop desktop just as you like it for a spe-
cific project, you can even save the desktop and reuse it whenever you work on that project.

11
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Using Photoshop with two monitors

If you're serious about your graphics work, you
may consider purchasing a second monitor (and
video card if you don’t own a two head video
card that can operate a second display) to attach
to your main computer system. A second moni-
tor gives you additional monitor space to display
multiple large image files and palettes of
Photoshop tools. | often move stuff from screen
to screen to maximize the area on my main

If you have a dual-monitor setup, you can even
move components from one display screen to
another. Whether you're using Mac or Windows
machines, whenever you want to use a tool that
appears on your secondary screen, you just slide
the mouse over to the alternate display and click.

In order to use a second monitor, your computer
must have Windows 2000 or later installed. Or
you should be running any recent Mac OS.

screen for an image I'm working on.

Every document you ever work on appears within the confines of this window and can’t leave
its borders. You can move around some other components, such as the various palettes and
the Options bar, both inside and outside the Photoshop application window.
Windows users can close, minimize, and restore the main Photoshop window, just as you can
@ with most windows in other programs. Mac users can choose Photoshop=>Hide Photoshop.
To display Photoshop again, simply click the icon in the Dock.

The Photoshop window hides one cool secret for Windows users: If you double-click any-
where in the gray empty area, the Open dialog box pops up, so you can navigate to a file
you want to work on without wandering up to the File menu, using the Ctrl4+O keyboard
shortcut, or using File Browser.

The following sections show you how to customize the main working area so that you can get
to work.

Setting display settings with the Window menu

The Window menu, shown in Figure 1-3, controls the display of palettes and some other ele-
ments of the Photoshop working area. (Find out more about maneuvering palettes later in this
chapter.)

The top two entries on the Window menu enable you to control the display arrangement of
your open documents and manage your workspaces. In the Windowr>Arrange submenu, you
can tell Photoshop to cascade (stack) or tile (butt them edge to edge) all open documents.
Here is the lowdown on the other options found on the Windowr>Arrange submenu:

l W
cgi N}:

v The new Match Location command takes all your open documents and matches the
location of your currently active document. In other words, if you are viewing the lower-
left corner of your active document and choose Match location, all your open docu-
ments will also be displayed from the lower-left corner.

The new Match Zoom command takes all your open documents and matches the magnifica-
tion percentage of your currently active document.
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And of course, Match Zoom and Location employs both commands simultaneously.

Choose New Window to open another view of the same image, allowing you to work on
a close-up of part of the image while viewing results on the entire image.

The Arrange Icons command (Windows only) takes minimized files and arranges the
title bar icons in a neat row directly above the status bar.

Minimize (Mac only) hides the image while placing the image’s thumbnail in the Dock.
Click the thumbnail to restore the image in Photoshop.

If you have multiple applications launched and document windows open, the Bring All
to Front command (Mac only) will enable all Photoshop documents to come to the
front, ahead of any open document windows from other applications.

Figure 1-3
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On the Window=>Workspace submenu, you can save your current desktop arrangement, load
or delete a stored arrangement, or reset your palette locations. For step-by-step instructions,
see Book I, Chapter 6. The remaining bulk of the Window menu contains a list of palettes in

alphabetical order.

58] yEW
&v;,,,

Photoshop cs has eliminated the Windowr>Documents menu. Consequently, you don’t have
to open a submenu to see a list of open documents. The list of all open documents is once

again shown at the bottom of the Window menu. Hallelujah!
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Setting up the status bar

By default, the status bar appears at the bottom of the Photoshop working area in Windows,
as shown in Figure 1-4. If you’re using the Mac OS, each document window has its own status
bar.

On a PC, you can turn the status bar on or off by selecting it or deselecting it on the Window
menu.

s Towe masamaam B Ghik e dhad bear o arse i il 16 Snlarge, Ghangs e Baie (e 06 B St i |

Figure 1-4

Many people tend to associate status with wealth, so [ don’t really think there’s a reason not
to accept the free wealth of information that the status bar offers:

v At the far left is a box that displays an active image’s current zoom level (such as 66.67
percent). Incidentally, the title bar of the document itself also shows the zoom level.

features, which enable file sharing and other perks, you see the icon for the Workgroup

Es If you installed Photoshop to a networked computer and you've activated the workgroup
Services pop-up menu just to the right of the zoom info box.

v Next is the file and image information display area, which, by default, shows the docu-
ment size information. You can customize this area to display other information. Click
the size value to display a preview of how your image fits on your selected paper size.

v Because the good people at Adobe know just how complex a program Photoshop is,
next to the file and info display area of the status bar is a description of the currently
selected tool’s functions, as well as information on how to select additional options for
that tool. This extra tidbit will only be found on Windows machines, however.

Although each Macintosh document includes its own status bar, all the bars for all the open

documents show the same category of information. That is, if you change the status bar of
one image to display scratch sizes (defined a little later in this chapter), all the status bars of
the other document images switch to display scratch sizes, as well.

Because Photoshop files can get pretty hefty in size, your status bar shows the file size of the
active image by default. To display other types of information, click the right-pointing arrow in
the status bar and select one of the following options from the menu that pops up:

v Document Size: When you select this option, Photoshop displays two numbers to
approximate the size of the image. The first number shows you the size of the file if
you were to flatten (combine) all the layers into one and save it to your hard drive.
The number on the right shows the full size of the image — including all the individual
layers, channels, and other components of the image. You’ll want this option active
when you need to keep track of how large your image is.

v Document Profile: When you select this option, the status bar displays the name of the
color profile that the image uses. You probably won’t use this option unless you need to
know the profiles of all the open documents while making complex color corrections.
You can find more information about profiles in Book I, Chapter 3.



Dissecting Dialog Box Jargon

v Document Dimensions: When you select this option, the status bar shows you the size
of the image by using the default measurement increment you’ve set in Photoshop’s
Preferences (pixels, inches, picas, and so on). You might need this for instant reference
to the physical dimensions of your open files. For information on setting preferences in
Photoshop, see Book I, Chapter 6.

v Scratch Sizes: Scratch space is the virtual memory set aside on your hard drive to simu-
late RAM and make editing large files easier. Enabling this option shows two measure-
ments for an active image. On the left, you see the amount of real memory and virtual
memory that all open images are using. On the right, you see the total amount of RAM
available for working with images. Photoshop needs a lot more memory and disk space to
work on an image while it’s open, and that’s what’s shown by the Scratch Sizes display, as
opposed to the Document Size display that shows only the file size of the document itself.

v~ Efficiency: This indicator helps you gauge whether you really have enough RAM to per-
form a task. It shows the percentage of time Photoshop spends actually working on an
operation, compared to the time it must spend reading or writing image information to
or from your hard disk. If the value dips below 100 percent most of the time, you need
to allocate more memory to Photoshop (if you're using a PC). For more information on
parceling out RAM, see Book I, Chapter 6.

\

Timing: This number shows you how long it took you to complete your last incredible feat.

v Current Tool: This option shows you the name of the tool currently in use.

Dissecting Dialog Box Jargon

In many respects, the Photoshop dialog boxes are very much like the dialog boxes you find in
all other Windows and Mac applications. You'll find text boxes with space to type in informa-
tion (such as the name of a new layer, or the width or height you want to apply to a new docu-
ment), pop-up menus of parameters you can choose from (such as whether you want the
width and height expressed in pixels, inches, millimeters, picas, or some other unit of meas-
urement), and controls like sliders that you use to specify amounts (in percentages, pixels, or
degrees) over a continuous range.

Photoshop’s dialog boxes perform a variety of functions, the controls in them are standard-
ized and familiar enough that, after you know how to use a few dialog boxes, you can use
them all.

Some dialog boxes are very complex and perform multiple tasks. However, even though

Photoshop dialog boxes, particularly filter dialog boxes, include preview windows so that you
can check out the effects of your settings before clicking the OK button. The Photoshop
Variations dialog box is one of the most complex of these. It includes a whole clutch of thumb-
nail images that show you the current image, plus several different renditions.

Dialog boxes generally appear when you choose a menu item followed by an ellipsis, such as

Load Selection . . .. The ellipsis is your tip-off that the menu selection needs additional infor-

mation to complete the operation. Dialog boxes can also pop up at other times, such as when
you double-click the Quick Mask icon in the Tools palette to produce the Quick Mask Options
dialog box, or double-click the www.adobe.com icon at the top of the Tools palette.
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If you know how to work with other applications, you already know how to use most of the
controls in Photoshop dialog boxes. These include
v Pop-up menus: Drop-down lists of choices that have been preselected for you.

v Spin buttons: These are up-/down-arrow buttons that you click to increase or decrease
values quickly.

v Text boxes: Areas in which you can type values of your own choosing.

v Radio buttons: A set of mutually exclusive buttons; you can select only one of them,
such as the Inside, Center, or Outside radio button, which tells the Stroke dialog box
where to apply the stroke.

v Check boxes: Boxes that you can select or deselect to turn a feature on or off, inde-
pendently of other features.

\

Slider controls: Controls for specifying any one of a continuous range of values.

\

Nested dialog boxes: Some dialog boxes include a button with text followed by an ellip-
sis, indicating that when you click the button, a new, sub-dialog box appears.

v Action buttons: Labeled with text such as OK or Cancel, these buttons activate or
cancel an operation when you click them.

Playing with Palettes

Many image-oriented programs use palettes of a sort, and Photoshop itself has had palettes
since version 1.0, released in January of 1990. However, since Photoshop 3.0, the program has
used a novel way of working with palettes. Instead of stand-alone windows, Photoshop uses
grouped, tabbed palettes, which overlap each other in groups of two or three (or more, if you
rearrange them yourself). To access a palette that falls behind the one displayed on top, click
the palette’s tab. By default, some palettes, such as Brushes, Info, Layer Comps, and Tool
Presets, appear alone.

Palettes operate a little like dialog boxes and may contain sliders, buttons, drop-down lists,
pop-up menus (as shown in Figure 1-5), and other controls. You’ll also find icons at the bottom
of many palettes. For example, at the base of the Layers palette are icons that let you create a
new layer, add a layer style, or trash a layer that you no longer want.

Some palettes can change like chameleons. The Actions palette can be displayed in Button
mode, in which you see only the name of each set of procedures you might want to invoke. Or
you can flip the Actions palette to Normal mode, which lists each of the procedures in the
action separately for you to view or edit.

Many palettes, such as the Brushes, Styles, Actions, and Colors palettes, include options for
defining sets of parameters (called presets) that you can store for reuse at any time.
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Figure 1-5
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Here’s how to open, close, and otherwise manipulate a palette group from the Window menu:

v~ To bring a palette to the front of its group: When the palette group is open, the palette
that’s visible is the palette that has a check mark next to it on the Window menu. In this
mode, you can select only one palette in any group because only one tab in a group can
be on top at one time.

When you select a palette from the Window menu, you have no way of knowing which
&@’NE":V palettes are grouped together because Adobe now lists palettes alphabetically instead of by
b~ groups.

1 To move a palette out of its group: Grab the palette’s tab and drag to its new location,
such as another group, the Palette Well, or the Photoshop desktop. If you move the
palettes out of their groups or drag them onto the desktop so that they stand alone, any
of them can be check marked.

v To hide a palette: Select a check-marked palette on the Window menu or click the Close
button at the top of the palette.

v To access a palette from the desktop: Find its group and click the palette’s tab to bring
it to the front.

Here are some palette-manipulation tips:

v Save space by keeping palettes in groups. You can drag all the palettes in a group by
dragging the group’s title bar. Access an individual palette by clicking its tab to bring it
to the front. As a result, several palettes occupy only the screen space required by one.

v Use the Window menu if you can’t find a palette. If you can’t find a palette or suspect
that it’s hidden, access the Window menu and select the palette’s name to make it visi-
ble or to bring it to the top of its group.

1 Rearrange groups by dragging. If you’d like to move a palette to another group or to dis-
play it as a stand-alone palette, grab its tab and drag. Release the mouse button where
you’d like the palette to reside in the workspace, or in the destination palette group.
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v Customize, customize, customize. After you've used Photoshop for a while, creating
your own custom palette groups based on the palettes you most often use can be a real
time saver. For example, if you don’t use the Paths palette very often but can’t live with-
out the Actions palette, you can drag the Paths palette to another group or the Palette
Well and put the Actions palette in the same group as the mission-critical Layers and
Channels palettes.

v Minimize palettes to save even more space. You can double-click a palette’s title bar
(or tab if you're using the Mac OS) to shrink the palette or palette group down to its
title bar and tabs alone. You can also click the Minimize button at the top of palette.

v Restore default palette locations whenever you need a change. If you decide you
don’t like the way you’ve arranged your palettes, you can choose Windowr>Workspacer>
Reset Palette Locations to return them to the default configuration (the one they had
when Photoshop was installed).

settings back to their defaults. Select Reset from the palette’s pop-up menu located in the

@ Some individual palettes, such as the Swatches and Character palettes, allow you to reset the
top-right corner.

Working with Your First Photoshop File

So many menus, so little time! The second you begin working with Photoshop, you may be
convinced that Adobe’s flagship image editor has somewhere on the order of 8,192 different
menu selections for you to choose from. In truth, Photoshop has only about 500-plus separate
menu items, including some that are duplicated. That figure doesn’t count the 100 or so
entries for filter plug-ins (which can expand alarmingly as you add third-party goodies).
However, even 500-plus menu items are considerably more than you’ll find in the most ambi-
tious restaurants. Basically, if you want to do something in Photoshop, you need to use the
menu bar. The menu bar consists of nine main entries, each of which holds a dozen or more
nested subentries and sub-subentries that cascade into view as you drag the cursor down the
list. If you're using the Mac OS, the Photoshop menu bar may share space with Finder compo-
nents, such as the Apple menu or the Clock.

You'll find pop-up menus everywhere, next to icons on the Options bar, on menus that fly out
from palettes, in the status bar, and especially in the menu bar. You can find detailed descrip-
tions of the menus and how to use them elsewhere in this book, but the following sections
offer a summary of what you can find and where you can find it.

depending on what you're doing. You don't see options you don’t need and do see options

@ Photoshop also helps you by providing context-sensitive menus, which change their listings
appropriate to what you're working on.

Opening and saving files

The File menu offers a cornucopia of file options, from opening new images and opening saved
files to browsing existing files, closing files, and saving files. The first layer of file options is
shown in Figure 1-6.
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Figure 1-6 New... Ctrl+N
Open... Ctrl+0
Browse... Shift+Ctrl+0
Open As... Alts+Ctrl+0
Open Recent 4

Edit in ImageReady  Shift+Ctrl+M

Close Ctrl+W

Save As... Shift+Ctrl+S

Save for Web...  Alt+ShiftsCtrl+S

Place...

Online Services...

Impaort L
Export 4
Automate ’
Scripts L4
File Info... AltsCrrl+]
Page Setup... ShiftsCtrl+P
Print with Preview... Al Crrl+P
Print... Ctrl+P

Print One Copy  Alt+Shift+Ctrl+P

Exit Ctrl+Q

You can edit a file in ImageReady, save a file optimized for the Web, import and export special
file types, grab an image from your scanner or digital camera, and apply automated tasks to cer-
tain files or batches of files. You can even enter or retrieve specialized information about a file.

You'll find the page setup, preview, and printing commands on the File menu. And on a PC,
there’s even an entry for leaving Photoshop entirely (Mac users can find the Quit command
on the Photoshop menu). To open a file, choose Filer>Open and navigate to the folder contain-
ing the file you want to open. Select the file and click OK to open it.

é_%w Choose Online Services to access Adobe partners and providers offering a variety of services
{ ¥% such as ordering prints, photo books, and calendars.

For detailed instructions on all the many different ways you can open files, see Book I,
Chapter 3.
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Making selections

Selections let you work with only part of an image. You can choose all of a layer or only por-
tions of a layer that you select with one of the selection tools, such as the Marquee or Magic
Wand. The Select menu (shown in Figure 1-7) is short and sweet, but the capability and con-
trol that the menu unleashes is nothing short of an image-editing miracle.

Select

Figure 1-7 All Ctil+A

Deselect Cul+D

Inverse Shift+Ctrl+l
Color Range...

Feather...  Alt+Ctrl+D
Modify »

Grow
Similar

Transform Selection

Save Selection...

Understanding selections is such an important cornerstone to your Photoshop knowledge
that I devote an entire book (Book III) to showing you how to use them.

I describe the Selection menu options in Table 1-1.

TaBLE 1-1: SeLecTion MEenu OPTIONS

Menu Option What It Lets You Do Windows Keyboard Mac Keyboard
Shortcut Shortcut
All Select a layer (and everything in Ctrl+A $8+A
the layer).
Deselect Undo (or deselect) a selection. Ctrl+D 8+D
Reselect Re-create your most Shift+Ctrl+D Shift+88+D

recent selection.

Inverse Reverse a selection so that Shift+Ctrl+I Shift+88+I
everything that wasn’t selected
is now selected (and vice versa).

Color Range Select areas based only on arange  None None
of pixel colors (rather than on both
brightness and color range).

Feather Blend a selection’s edges into Alt+Ctrl+D Option+8+D
the surrounding area.
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Menu Option What It Lets You Do Windows Keyboard Mac Keyboard BO(;(
Shortcut Shortcut
Chapter
Modify=>Border  Frame the original selection None None 1
with a new selection based on
a specified number of pixels.
Modify=>Smooth ~ Smooth stray pixels inside or None None
outside a selection, within a
specified range of pixels.
Modify=>Expand  Expand a selection a specified None None
number of pixels.
Modify=>Contract Contract a selection a specified None None
number of pixels.
Grow Expand or contract a selection. None None
Similar Select similar pixels that aren’t None None
adjacent to those you've already
selected.
Transform Resize and reshape a selection None None
Selection by dragging handles.

Another important capability is the option of saving selections and loading them later for
reuse. As you find out in Book VI, not only can you load a selection you've already made, but
you can also subtract the saved selection from another selection or add it to another new or
saved selection.

To save a selection, choose Selectr>Save Selection. In the Save Selection dialog box that
appears, type a name for the selection and click OK.

Making simple image edits

The Edit menu, shown in Figure 1-8, contains tools that enable you to cut, copy, or paste
image selections in several different ways. You can fill selections or stroke their outlines
(create a line along their edges). And you can use this menu to rotate, resize, distort, or per-
form other transformations (changes in size or shape) on your selections. You can undo the
change you made in Photoshop, fade a filter, check your spelling, or find and replace text.

The Edit menu also offers some choices that may not logically belong here but which don’t fit
anywhere else. For example, you can define brushes, patterns, and shapes. You can clear the
Photoshop clipboard, dump Photoshop’s list of the changes you’ve made, and establish your
color management settings and tool presets. On a PC, you also access Photoshop’s Preferences
(your personal settings for things such as memory, how cursors look, and so on) from the Edit
menu. You find out more about preferences in Book I, Chapter 6.

Mac users will find Color Settings and Preferences located on the Photoshop menu. For
details on establishing your color settings, see Book Il, Chapter 2.
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. Edit

Figure 1-8
Step Backward Alt+Ctrl+Z
Cut Ctrl+X
Copy Ctrl+C
Clear
Fill... Shift+F5
Stroke...
Free Transform Ctrl+T
Transform L
Define Brush Preset...
Define Pattern...
Purge ’
Color Settings... ShiftsCtrl+K
Keyboard Shoertcuts...  Alt+Shift+ Ctrl+K
Preset Manager...
Preferences »

:.%w You'll also find a new command that allows you to customize your own set of keyboard
‘ v shortcuts. For more details, see Book I, Chapter 6.

Making changes by using the Image menu

You'’d think the Image menu (shown in Figure 1-9) might have something to do with making
changes to an image document as a whole, wouldn’t you? In practice, some of the entries
you’ll find here do apply to the whole document, but others apply only to particular layers or
selections.

For example, the Mode menu item allows you to change an entire image from grayscale to
color. The Duplicate, Image Size, Canvas Size, Rotate Canvas, Crop, and Trim selections all
change the whole document in some way. (Their functions are obvious from their names,
except for Trim, which removes pixels from the edge of an image.)

{T A new command on the Image menu is Pixel Aspect Ratio. This command allows you to
&Vﬂ ifw view your image in common digital video aspect ratios that aren’t square (such as 16:9),
> thereby simulating the display of the image on a device that uses non-square pixels, such as
a movie screen or a wide-screen TV.
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Image Book

Figure 1-9 Mode v I

Chapter
Adjustments * 1

Duplicate...
Apply Image...
Calculations...

Image Size...
Canvas Size...

Pixel Aspect Ratio  *
Rotate Canvas 4
Crop

Trim...

On the other hand, the changes wrought from the Adjustments submenu can’t be applied to an
entire image if the document has more than one layer. Adjustments such as Color Balance,
Hue/Saturation, or Brightness/Contrast work only with a single layer or a selection on that layer.

You'll find yourself turning to the Image menu more often than many of the other menus, par-
tially because it’s so useful, and partially because, for some reason, many of the options don’t
have keyboard shortcuts that let you bypass the menu.

8l e By the way, Adobe removed the Histogram option from the Image menu in favor of its own
‘ vi palette. For details on this new palette, see Book VIII, Chapter 1.

Creating layers

Layers give you a way of stacking portions of an image — overlay style — on top of one
another so that you can work on individual pieces separately. Then, when you’re satisfied
with your changes, you can combine the changes into a final image.

The Photoshop Layers feature, which gets an entire book of its own (Book V), is so useful it’s
hard to imagine that it hasn’t always been present in Photoshop. (Thank your lucky stars if
you didn’t have to use versions of Photoshop that preceded version 3.0.) Those of us who
worked with Photoshop 2.5 and earlier still wake up from nightmares in which a floating selec-
tion (the predecessor to the layer feature) permanently merged with the background because
of an ill-timed sneeze.

The Layer menu in Photoshop cs (shown in Figure 1-10) lets you create new and duplicate
layers, delete one or several layers, change layer properties (such as a layer’s name), or add
special features, such as drop shadows or beveled edges, to objects in a layer. You can also
create special kinds of layers to make adjustments or mask out portions of an image. The menu
has selections for changing the order of the layers (moving a specific layer to the front or top
of the stack, and so on) and grouping layers together so that you can treat them as a set.
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. Layer
Figure 1-10 New %
Duplicate Layer...
Delete *

Layer Properties...

Layer Style L
New Fill Layer 4
New Adjustment Layer *

New Layer Based Slice

Add Layer Mask *
Add Vector Mask r
Create Clipping Mask Ctrl+G
Arrange *
Align To Selection *
Merge Down Ctrl+E
Merge Visible Shift+Ctrl+E

Flatten Image

You also can merge layers down, combine them with all other visible layers, or flatten them
into one single-layer image. Although merging your layers makes the file smaller, flattening is
irreversible after you close the file. It’s always a good idea to store an unflattened version of a
file in case you want to make more changes later on.

Photoshop has two key layer facilities, the Layer menu and the Layers palette. Some of their
functions are duplicated, but some are not, so make sure you're using both of them. You find
out the distinctions in Book V.

o The latest member of the layers family is the Layer Comps palette. This palette enables you
&V] Ni,, to capture different versions of your document by recording the configuration of your layers
- at a point in time. Again, for all the pertinent details on layers, see Book V.

Applying filters

A filter is an effect that changes an entire layer, channel, or selection. Some common filters
include the Blur and Sharpen filters as well as distortion filters such as Spherize. The Filter menu,
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shown in Figure 1-11, consists almost entirely of cascading categories of image-transmogrifying
plug-ins. You can wade through this menu to find the perfect effect to apply to an image or selec-
tion. Book VII has everything you need to know about filters.

Filter

Figure 1-11

Extract... Alt+Ctrl+X
Filter Gallery...

Liquify... Shift+Ctrl+X
Pattern Maker... Alt+Shift+Ctrl+X
Artistic

Blur

Brush Strokes

Distort

Noise

Pixelate

Render

Sharpen

Sketch

Stylize

Texture

Video

Other

* rF Y v *r¥ v ¥v v vy v v v v

-

Digimarc
Synthetic *

After you apply a filter, Photoshop moves the filter to the top of the Filter menu for easy
accessibility in case you want to reapply the filter with the exact same settings.

&-vé NEW The new Filter Gallery command allows you to apply several filters simultaneously in one
),/ heat editing window.

@ To choose the last filter you used, use the Ctrl+F (88+F on the Mac) keyboard shortcut.

Extract, Liquify, and Pattern Maker are more like miniprograms than filters. The rest of the
Filter menu consists of 14 different filter categories, each containing from zero to a dozen or
more options:

v Single-step filters are pretty basic to use but can make a huge impact on an image.
These include simple filters such as the Blur, Facet, and Clouds filters. Just click each
filter to apply it; it has no options to choose.

v Dialog box-based filters let you choose options galore. These filters come complete with
preview windows, buttons, slider controls, and menus. You can distort, pixelate,
sharpen, stylize, apply textures, and perform other functions with these filters.
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bottom of the Filter menu. You can find third-party filters at Web sites such as www .

E s If you've installed additional filters from third parties, Photoshop lists them at the very
alienskin.com, wew.andromeda.com, and www.autofx.com.

Simplifying your edits with the Options bar

The Options bar, shown in Figure 1-12, was a welcomed addition to Photoshop because it elim-
inated the need to access a separate options palette for each tool. The bar remains available
at all times, docked beneath the menu bar (unless you decide to hide it for some bizarre
reason), and the options change as you switch tools.

E PR AL A w| opsctrs s b | W s o | s ._'p' _:| ll

Figure 1-12

Because the Options bar changes its appearance with each active tool, it’s difficult to explain all
the components you might find there; but every Options bar does have some characteristics in
common:

v Gripper bar: Grab this bar and drag to undock or dock the Options bar at the top or
bottom of the Photoshop window. You can also let the Options bar float anywhere in the
working space.

v Tool options: This box displays the icon of the currently active tool and may include
some options for that tool.

v Options pop-up menu: The Options bar may have a pop-up menu that includes a selec-
tion of brush tips (for painting and erasing tools), a flyout-type options menu that lets
you select presets (saved settings) for various tools, and additional options, such as the
size of the icons used to represent brush tips. You may also reset a particular tool or all
tools to their Photoshop default values.

v Bar options: Additional options, such as mode, opacity, feather, type styles, and fonts
are arrayed on the rest of the Options bar.

v~ File Browser button: The File Browser button (a folder with magnifying glass icon)
allows you to display and hide the File Browser window with a mere click. See Book I,
Chapter 5 for lots of details.

&%? NEW The File Browser button is a new member to the Options bar.
'}!

v Palette Well: If your monitor has a screen resolution higher than 800 x 600 pixels, the
Palette Well appears at the right side of the Options bar. You can drag palettes from
their groups into the Palette Well, where only their tabs appear. Click the tab, and the
palette appears, ready for use. When you click again in your document, the palette
shrinks down to its tab. The Palette Well is a great tool for keeping your frequently used
palettes accessible. I like to keep some palettes, particularly the Layers and Channels
palettes, open in the workspace at all times, but some others (such as the Swatches or
Styles palettes) don’t need to be visible on-screen at all times.
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Proofing and finalizing the image

A hodgepodge of functions is sprinkled throughout the View menu, shown in Figure 1-13.
Some of them, like Proof Setup, Proof Colors, and Gamut Warning, won’t trouble you until
you’ve become a fairly advanced Photoshop user.

. View
Figure 1-13 Proof Setup »

Proof Colors Crrl+Y
Gamut Warning  Shift+Ctrl+Y
Zoom In Ctrl++
Zoom Out Ctrl+.
Fit on Screen Ctrl+0
Actual Pixels Alt+Crrl+0
Print Size
Screen Mode r

v Extras Ctrl+H
Show 4
Rulers Cul+R

v Snap Shift+Ctrl+;
Snap Te L4
Lock Guides Alts+Ctrl+;
New Guide...
Lock Slices

If you prefer using the View menu instead of the Zoom tool, you'll find various commands to
zoom into and out of the image. You can also choose your screen mode, which lets you view
your image full screen with the menu bar and palettes, or full screen with just palettes.

From the View menu, you can select which extras Photoshop displays. You can choose to see
(or hide) the following:

v Selection Edges: Moving lines that define the boundary of a selection and are very
useful for obvious reasons.

v~ Target Path: Lines and curves that define a shape or are used to select part of an image.

You definitely want to see them if they need editing.

v Grids and Guides: Lines that display on screen and are great when you're aligning
selections, objects, or other components, and potentially distracting when you’re not.
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v Slices: Rectangular pieces of an image to which you can optimize or apply Web features.
If you've sliced the image, you probably want to view the results.

v Annotations: On-screen notes and audio annotations that you can create and view (or
play). Annotations can sometimes be confusing, unless you'’re already confused; then
annotations can help you sort out what’s what.

The View menu holds the controls for turning on and off the snap feature in Photoshop. (The
snap feature makes objects magnetically attracted to grids and guides.) You can also create
new guides, lock and clear slices (see Book IX, Chapter 3, for slice-and-dice information), and
turn rulers on or off.

shortcuts. Trust me, when you've learned to zoom in and out by pressing Ctrl++ (38++ [plus
sign] on the Mac) and Ctrl+- (88+—Iminus sign] on the Mac), you won't be spending a lot of
time in this menu searching for those functions.

@ Some functions, especially the zoom features, are better accessed through tools or keyboard

Accessing Help When You Need It

To access the Photoshop Help system, plus some other useful information, look no further
than the handy-dandy Help menu, as shown in Figure 1-14.

If you're using the Mac OS, the Help menu also lets you turn Balloon Help on and off.

Help
Photoshop Help... F1
Welcome Screen...
About Photoshop...

Figure 1-14

About Plug-In 4

Export Transparent Image...
Resize Image...

System Info...

Updates...

Photoshop Online...

Because you can view the Help screens (they pop up in a Web browser window) simply by
pressing F1 (or 38+? on the Mac), you may not visit the Help menu very often, but if you ever
want to find all your help resources in one location, this is the place to be. Here are some
other help sources:

v The Welcome Screen allows you to access valuable tips and tutorials.

ﬁ? NEW See the earlier section, “Getting a Warm Welcome,” that describes this new feature.
;‘}';
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v The About Photoshop splash screen displays the version number of your Photoshop Book
program. That way you’ll always know if you've installed the latest patches and updates I
to Photoshop cs. Chapter

1

v The About Plug-In entry displays a list of all the plug-ins you've installed for Photoshop.
Selecting an item in the list shows an About screen of version information for that plug-in.

On a Mac, both the About Photoshop splash screen and About Plug-In menu are on the
Photoshop menu.

v The Export Transparent Image and Resize Image choices launch a wizard (assistant on
the Mac) that leads you step by step through all the decisions you need to make to
create an image that includes transparency. For example, you might want to create
some text in Photoshop and then have it appear to “float” above your Web page’s back-
ground. The Resize Image Wizard (Assistant on the Mac) leads you through adjusting
the image size so the document will print at the size you want.

v The System Info entry displays information about your computer, its operating system,
and available memory, plus Photoshop-specific data such as the location you set for
your Plug-Ins folder. If you like, you can click the Copy button to copy this information
to the clipboard, and then paste it in a text document and print it out.

v The Updates, Registration, and Photoshop Online choices access Internet resources for
Photoshop.



30 Book 1 + Chapter 1: Examining the Photoshop Environment



Getting to Know
the Tools Palette

In This Chapter
v Using the Tools palette

v~ Taking a look at what each
tool does

v~ Creating tool presets

ronment (described in Book I, Chapter 1), you're ready to

dive into the cache of gadgets that, along with the menus
and palettes and dialog boxes, make it all happen. Just as you
can use a saw, hammer, and nails to transform a pile of 2 x 4s
into a garden gazebo, you can use the Lasso tool, Healing
Brush, and Smudge tool to convert a mediocre photo into a
masterpiece fit to be framed. But remember, behind every
garden gazebo is a carpenter who knew how to use the tools
required to build it.

E fter you have a good grasp of the overall Photoshop envi-

Turning On the Tools Palette

You can access the Tools palette — or Toolbox as it is often
affectionately called — by choosing Window=>Tools. Here are a
few tips for using the Toolbox:

v To quickly hide and show the Tools palette (along with
the other palettes), press the Tab key.

v To collapse the Tools palette, double-click the title bar
above the feather icon at the top.

v To move the Tools palette anywhere within the
Photoshop window, drag the title bar above the feather
icon.

Selecting tools

To select a tool, simply click it in the Tools palette. A small
black triangle in the bottom-right corner of a tool slot indicates
that more tools are hidden behind that tool on a flyout menu. To
display the flyout menu and reveal the hidden tools, click and
hold down the mouse button on the tool. Then drag to the right
and down the column of tools, highlight the tool you want, and
release your mouse button.
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You can also access tools by using keyboard shortcuts (which are listed in Figure 2-1):

v Selecting visible tools: You can access the visible tools by pressing a single key on the
keyboard. For example, to select the Move tool, press the V key; to select the Brush
tool, press the B key.

v Selecting hidden tools: For the most part, you can access a hidden tool by pressing the
Shift key along with the keyboard letter of the visible tool. For example, to select the
Pencil tool, which shares the flyout menu with the Brush tool, press Shift+B.

Photoshop has a couple of exceptions, however. You can press Shift+M to switch
between the Rectangular and Elliptical Marquee tools, but you can’t access the Single
Column and Single Row marquee tools. Press Shift+P to cycle through the Pen and the
Freeform Pen; however, the remaining tools — the Add Anchor Point tool, Delete
Anchor Point tool, and Convert Point tool — do not have keyboard shortcuts.

key to access a hidden tool. Choose Edit=>Preferences->General (Photoshop>Preferences—>
General in Mac OS X) and deselect the option Use Shift Key for Tool Switch. You can then
rotate through the tools by pressing the same letter repeatedly.

@ You can adjust your preferences if you decide that you don't like having to press the Shift

hidden beneath it. The only exceptions are the Marquee tools and the Pen tools; some of the
tools on their flyout menus aren’t accessible this way.

Fi 2-1 — Go to www.adobe.com
lgure £- 'F' - Photoshop & ImageReady

@ You can also Alt+click (Option+click on the Mac) on a tool to cycle through all the tools
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Turning On the Tools Palette

When you hover your mouse over a tool, color control, or icon, you see a tool tip. The tool tip
tells you the name of the tool or icon and its keyboard shortcut, if any. This feature is helpful
when you first start working in Photoshop, but if it gets annoying after a while, feel free to
turn it off. Choose Edit=>Preferences (Photoshop=>Preferences in Mac OS X) and deselect the
Show Tool Tips option in the General Preferences dialog box.

If you try to use a tool and all you see is the Cancel or No (the circle with a diagonal line) icon,
click the image. Photoshop politely informs you why it isn’t allowing you to use the tool. For
example, if you try to apply color with the Brush tool on a shape layer, you get a message that
you can’t use the Brush because the content of the layer can’t be edited with that particular
tool.

Getting to know your tools

The Tools palette is divided into three basic sections: tools, color swatches, and icons for
masking modes and viewing options. The next several sections introduce you to the tools.
The following list details the other residents of the Tools palette, shown in Figure 2-2:

v Foreground Color and Background Color: Color swatches represent the current fore-
ground and background colors. When using some of the tools, such as the Brush or Pencil,
you may apply either of these colors. The small black and white swatches represent the
default colors of a black foreground and white background. Click the Default Colors icon to
reset the colors to the default. Click the curved arrow icon to switch the foreground and
background colors. For everything you need to know on color, see Book II, Chapter 3.

v Edit in Standard Mode and Edit in Quick Mask Mode: The first set of icons allows you
to work in either Standard mode or Quick Mask mode. For now leave the mode set to
Standard. Quick Masks, which offer a way to view, make, and edit a selection, are covered
in detail in Book VI, Chapter 2.

v Standard Screen Mode: The default setting, this mode enables you to see your entire
Photoshop desktop.

v Full Screen Mode with Menu Bar: This mode hides your desktop background and other

open images.

v Full Screen Mode: Use this mode to hide your desktop background, any open images,
and the menu bar. In addition, the Photoshop window turns to black.

&5@’ NEW You can now move an image even when it is in Full Screen Mode.
!f

v~ Edit in ImageReady: When you click the bottom-most icon, you launch Photoshop’s
sister program, ImageReady, a Web graphics program. Check out Book IX, Chapter 5, for
more on ImageReady.

v Go to the Photoshop and ImageReady area of www.adobe. com: If you click the feather
icon at the top of the Toolbox (refer to Figure 2-1), you are transported to the
Photoshop product area of the Adobe Web site. This site is loaded with tons of great
info, such as tips, tech support, upgrades, and news on products and events.
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. a1 Switch foreground and background colors
Figure 2-2 % & g
L]

Default colors !
Standard mode > i@I@- Quick Mask mode

Standard Screen mode »!@!2 = Full Screen mode

Full Screen mode

jump Lo ImageReady g

Introducing the Photoshop Tools

I'm just giving you a very brief description of what each tool does. You’ll be more thoroughly
initiated with the use of each of the tools as you go through the book. Don’t want to go page
by page through the book? Okay. Well, you're in luck; I also give you the exact spot where you
will find more on each of the tools. For what it’s worth, I have organized the tools into logical
groupings, although some can cross over into other groups and some are unique enough that
they don’t really fit well in any group. For a great visual reference of what each tool does, be
sure and check out Appendix B.

Using selection tools

The selection tools, shown in Table 2-1, are the workhorses of Photoshop. They allow you to
capture and isolate pixels so that you can edit or manipulate just a portion of an image.
Marquee tools capture rectangular, elliptical (see the results of the Elliptical Marquee tool in
Figure 2-3), or single rows or columns of pixels. Whereas the Lasso tools make freeform selec-
tions, the Magic Wand tool creates selections by picking up pixels of similar colors. And the
Move and Crop tools do just what their names describe — move and crop images. (Figure 2-4
shows the results of the Move tool.)

Figure 2-3
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Figure 2-4

TaBLE 2-1: SELecTION TooLS

Button Tool Does See
r—1 Rectangular Marquee tool Makes a rectangular selection Book III, Chapter 1
1
B
Elliptical Marquee tool Makes an elliptical selection Book III, Chapter 1

Single Row Marquee tool Makes a selection of a single Book III, Chapter 1
==C row of pixels
n Single Column Marquee tool Makes a selection of a single Book III, Chapter 1
L' column of pixels
P Lasso tool Makes a freeform selection Book III, Chapter 1
.E;ﬂ Polygon Lasso tool Makes a straight-sided selection Book IIl, Chapter 1
Magnetic Lasso tool Makes a selection by Book III, Chapter 1
ﬁ magnetically snapping to

the edge of an element

continued
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TaBLE 2-1: (cONTINUED)

Button Tool Does See
mba Magic Wand tool Makes a selection by selecting  Book Ill, Chapter 1
-.:'r..\‘ similarly colored pixels within
a specified range
Move tool Moves selections, layers, Book IIl, Chapter 3
.e and guides selections); Book V,

Chapter 1 (layers);
Book I, Chapter 5
(guides)

ﬁ Crop tool Trims images Book II, Chapter 1

Creating and modifying paths

The path tools, shown in Table 2-2, create and modify paths, which are elements comprised of
straight and curved segments and anchor points. You can then use these paths as a basis for
a selection or to define a shape. Because of their precision, using path tools to ultimately
create a difficult selection usually yields better results than you can achieve with the selection

tools. Figures 2-5 and 2-6 show examples of using the Pen tool and Direct Selection tool,
respectively.

Figure 2-5




Figure 2-6
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TaBLE 2-2: PatH TooLs

Button

Tool

Does

See

v

Y
¢+

- 7

Pen tool

Freeform Pen tool

Add Anchor Point tool

Delete Anchor Point tool

Convert Point tool

Path Selection tool

Direct Selection tool

Makes a path consisting of
anchor points and curved and
straight segments

Makes a path consisting of
anchor points and curved and
straight segments but it’s more
automated than the Pen tool

Adds anchor points to a path

Deletes anchor points from
a path

Converts a smooth point to a
corner point and vice versa

Selects paths, including those
comprising shapes

Selects the various components
of paths, including those com-
prising shapes

Book III, Chapter 2

Book III, Chapter 2

Book IlI, Chapter 2

Book IlI, Chapter 2

Book IlI, Chapter 2

Book IlI, Chapter 2
(paths); Book IV,
Chapter 2 (shapes)

Book III, Chapter 2
(paths); Book IV,
Chapter 2 (shapes)
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Using painting tools

The painting tools, in general, allow you to apply color or erase pixels. In the case of the
Gradient tool, you can apply multiple colors simultaneously. And with the Art History Brush
tool, you paint on a stylized effect rather than color. All the painting tools rely on the Brushes
palette for the size, shape, texture, and angle for the tip of the tool. See Table 2-3 for a list of

the painting tools.

Figure 2-7 shows examples of what you can do with the Brush tool. An example of the effects
of using the Eraser tool is shown in Figure 2-8.

Figure 2-7

Figure 2-8
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TABLE 2-3: PAINTING TooLs Bof;‘
Tool Does See Chapter
Brush tool Paints with strokes by using a Book IV, Chapter 1 2

F 0§ 8 WS R

Pencil tool

Gradient tool

Paint Bucket
tool

Art History
Brush tool

Eraser tool

Magic Eraser
tool

Background
Eraser tool

variety of attributes

Paints with a hard-edged
stroke

Creates a blend between two or
more colors in a linear, radial,
angled, reflected, or diamond
pattern

Fills similarly colored pixels
with color

Paints with artistic strokes that
create a watercolor-like effect,
using a selected state or snapshot
from the History palette

Erases pixels, or with the Erase
to History option selected,
restores the image to a source
state in the History palette

Erases similarly colored pixels

Erases the background pixels
by detecting the edge between
the foreground element and
the background

Book IV, Chapter 1

Book IV, Chapter 3

Book IV, Chapter 3

Book II, Chapter 4

Book VI, Chapter 2 (eraser);
Book II, Chapter 4 (history)

Book VI, Chapter 2

Book VI, Chapter 2

Using tools for cloning and retouching

The cloning and retouching tools, shown in Table 2-4, are the powerhouse tools to break out
when you need to do some image repair work. These tools allow you to duplicate portions of
your image, paint with a pattern, or seamlessly fix scratches, wrinkles, and other blemishes.
The unique History Brush tool lets you actually paint a previous version of your image back
into your current image — perfect for undoing mistakes or repairing edits that went awry. The
new Color Replacement tool lets you replace the color of your image with the foreground
color. Figures 2-9 and 2-10 show examples of using the Clone Stamp tool and Pattern Stamp
tool, respectively.
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Figure 2-9

Figure 2-10

TaBLE 2-4: CLoNING AND RETOUCHING ToOLS

Button Tool Does See

Clone Stamp tool Paints with sampled pixels Book VIII, Chapter 3

Pattern Stamp tool  Paints with a preset or Book IV, Chapter 3
% custom pattern Book VIII, Chapter 3
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Does

See

Button Tool
: i? History Brush tool
9 Healing Brush tool
Q Patch tool
s Color Replacement

Allows you to restore the image
to a source state in the History
palette by painting with a brush

Paints with sampled pixels
to repair flaws in an image

Repairs flaws on a selected portion
of an image by covering the area
with sampled pixels

Replaces the color of an image
with the foreground color

Book II, Chapter 4

Book VIII, Chapter 3

Book VIII, Chapter 3

Book VIII, Chapter 3

Creating effects with typographical tools

The type tools, shown in Table 2-5, pretty much do as their moniker suggests — create type of
varying sorts. The Horizontal Type tool (Figure 2-11 shows text created using it) and Vertical
Type tool create regular old type, whereas the Mask Type tools create selections in the shape

of letters, which can then be filled with images. Figure 2-12 shows text created using the

Horizontal Type Mask tool.

Figure 2-11
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Figure 2-12

TaBLE 2-5: TyPe TooLS

Does

See

Button Tool

T Horizontal Type tool
lT Vertical Type tool
T Horizontal Type

¢-: :1_ Mask tool

Vertical Type
Mask tool

Creates type horizontally
across the canvas

Creates type vertically
down the canvas

Creates a horizontal
selection marquee
from type

Creates a vertical
selection marquee
from type

Book IV, Chapters 4 and 5

Book IV, Chapters 4 and 5

Book IV, Chapter 5

Book IV, Chapter 5

Using focus and toning tools

The focus and toning tools, shown in Table 2-6, allow you to enhance your image by altering
the pixels in various ways. You can lighten, darken, blur, smudge (see Figure 2-13), sharpen,
saturate, or desaturate color in selective portions of your image. These tools work best for
touching up smaller areas rather than the entire image. For example, | used the Burn tool to
darken the pixels in the groom’s face shown in Figure 2-14. Hopefully he doesn’t take it

personally.



Figure 2-13

Figure 2-14
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TaBLE 2-6: Focus AnD ToninG TooLs

Button

Tool

Does See

¢
A

Blur tool

Sharpen tool

Blurs pixels by decreasing ~ Book VIII, Chapter 2
the contrast between pixels

Sharpens pixels by
increasing the contrast
between pixels

Book VIII, Chapter 2

continued
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TABLE 2-6: (coNTINUED)

Button Tool Does See
¥ Smudge tool Smudges (smears) pixels Book VIII, Chapter 2
j.i:,:j in an image
t Dodge tool Lightens pixels in an image Book VIII, Chapter 2
@: Burn tool Darkens pixels in an image  Book VIII, Chapter 2
Sponge tool Saturates or desaturates Book VIII, Chapter 2
@ color in an image

Creating shapes

The Shape tools, shown in Table 2-7, allow you to create vector-based elements in your image.
Depending on the mode selected, these elements are automatically filled with the foreground
color or left as just an empty path. The beauty of vector-based elements is that they are reso-
lution independent, meaning that they always print at the resolution of the output device
rather than the resolution of the image. Vector-based shapes created with the Shape tools

can also be resized and transformed without any quality degradation, unlike raster images.
Although vector-based elements are the heart and soul of the Shape tools, you can also create
shapes filled with pixels of the foreground color. For more on resolution, see Book II, Chapter 1.
Figures 2-15 and 2-16 show the Polygon and Custom Shape tools, respectively, in action.

Figure 2-15




Figure 2-16
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TaBLE 2-7: SHAPE TooLs

Button

Tool

Does

See

|

= L1 L

bt

Rectangle tool

Rounded
Rectangle tool

Ellipse tool

Polygon tool

Line tool

Custom Shape tool

Creates a vector rectangle filled with
the foreground color

Creates a rounded vector rectangle
filled with the foreground color

Creates a vector ellipse filled with the
foreground color

Creates a vector polygon filled
with the foreground color

Creates a foreground-colored line
of specified thickness

Creates a vector shape selected from

a custom shape library and fills it with

the foreground color

Book IV, Chapter 2

Book IV, Chapter 2

Book IV, Chapter 2

Book IV, Chapter 2

Book IV, Chapter 2

Book IV, Chapter 2

Viewing, navigating, sampling, and annotating tools

Photoshop has an abundance of tools to help you view and navigate your image window.
These tools allow you to zoom in (as shown in Figure 2-17) and out, move your image within
the window, and measure distances and angles. The Eyedropper and Color Sampler tools let
you pick up and sample color respectively — handy for grabbing or evaluating color in an
image. The Notes tool (shown in Figure 2-18) and Audio Annotation tool create written and

b5
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audio notes that you can leave in an image window — useful for collaboration purposes or
simply for reminders to yourself. See Table 2-8.

Figure 2-17

Figure 2-18

rmenu layout,

TaBLE 2-8: TooLs FOR VIEWING, EDITING, AND SAMPLING FILES

Button Tool Does See
Eyedropper tool Samples a color in your image Book II, Chapter 3
f and makes it the foreground or

background color
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Button

Tool

Does

See

b4
&
Q
WV
&
)

Color Sampler tool

Measure tool

Zoom tool

Hand tool

Notes tool

Audio Annotation tool

Samples and evaluates up to
four colors in your image

Measures distances and angles
on your canvas

Zooms into or out of your image

Moves your image within
the window

Creates a digital Post It note that
can be attached to your canvas

Creates an audio annotation that
is attached to your canvas and
can be played back

Book II, Chapter 3

Book I, Chapter 5

Book I, Chapter 5

Book I, Chapter 5

Book II, Chapter 5

Book II, Chapter 5

Using tools for the Web

Photoshop doesn’t have a whole lot of tools dedicated to the preparation of Web images

(though it does have quite a few commands). That’s mainly because its companion program,
ImageReady, takes up the slack in that department. You will find the Slice tool and Slice Select
tool (shown in Figure 2-19), which allow you to create and select slices, or rectangular sections,
from an image. You can then optimize, and apply Web features like rollovers and image maps,

to those slices separately for the best viewing experience on your Web page. See Table 2-9.

Figure 2-19

T

[0 ‘

| oo

home
&l events
d-news -

contact
links

\Ee o 3d t

b7

Book

/

Chapter

2



48

Saving Time with Tool Presets

TaBLE 2-9: WEeB TooLs

Book 1  Chapter 2: Getting to Know the Tools Palette

Button Tool Does

See

._Y Slice tool
e

the Web)

Slice Select tool

Selects slices

Creates slices (rectangular sections
of an image used for display on

Book IX, Chapter 3

Book IX, Chapter 3

Tool presets enable you to create tool settings that you can save and use again. This feature is
areal time-saver if you use specific tool settings on a frequent basis. For example, [ make
numerous 2-x-2-inch and 2-x-3-inch rectangular selections on images I use in a newsletter.
Because I saved the settings as presets, I don’t have to redefine them each time [ want to
select an image for my project.

Creating custom tool presets

Here are the short and simple steps for creating your own custom tool preset:

1.

Choose a tool.

Most tools are fair game. If a tool
doesn’t allow for presets, such as the
Measure tool for example, the Tool
Preset picker button (described in
Step 3) is grayed out.

Select the option you want for the tool
in the Options bar.

Click the Tool Preset picker button
in the Options bar, as shown in
Figure 2-20.

You can also choose Window=>Tool
Presets to bring up the Tool Presets
palette. The Tool Presets palette offers
an additional handy icon at the bottom
of the palette: the trash icon. This icon
lets you delete a preset quickly. Select
the preset and click the trash icon or
simply drag the preset to the trash.

You can’t create a new preset from
the Preset Manager, which is acces-
sible from the Tool Preset picker
pop-up menu or by choosing Edit=>

4.

Preset Manager. You can only load pre-
sets, as described in Step 6.

Click the Create New Tool Preset
picker button (the dog-eared page
icon), or if you’re using the Tool
Presets palette, choose New Tool
Preset from the palette menu.

Name the preset and click OK.

Your new preset is now saved and
ready for reuse.

To select the tool preset, you can do
one of three things:

v Click the Tool Preset picker button
and select a preset from the picker
pop-up menu.

v~ Select a preset in the Tool Presets
palette.

v~ Select a preset in the Preset
Manager. Choose Tools from the
pop-up menu and select your preset.



Figure 2-20
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Managing your presets

You can manage your presets by choosing options from the Tool Preset picker pop-up menu.

Table 2-10 describes these options.

TaBLE 2-10: THE TooL PReSeT Picker Por-up MENU

Option What It Does

Dock to Palette Well
accessibility.

New Tool Preset

Places the Tool Presets palette in the palette well for easy

Creates a new preset.

continued
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Option

What It Does

Rename Tool Preset

Delete Tool Preset

Sort by Tool

Show All Tool Presets
Show Current Tool Presets
Text Only

Small List

Large List

Reset Tool

Reset All Tools

Preset Manager

Reset Tool Presets

Load Tool Presets

Save Tool Presets

Replace Tool Presets

Art History, Brushes, Crop and
Marquee, and Text options

Renames the preset. (Select the preset in the list and then
choose this option.)

Deletes a preset. (Select the preset in the list and then
choose this option.)

Groups your presets by tool.

Shows the presets for all your tools.

Shows the presets for the active tool only.

Gives you the name of the preset without the icon.
Shows a small icon, along with the preset name.
Shows a larger icon with the preset name.

Closes the active preset and returns to the default tool
setting.

Returns all tools to their defaults.

Opens the Preset Manager, which manages all the various
libraries of preset brushes, swatches, gradients, styles, pat-
terns, contours, custom shapes, and tools. You can also
load other libraries and the custom preset libraries you
have created. In addition, you can rename or delete a preset
library:.

Deletes all your tool presets at once. If you want to restore
the defaults but keep your custom tool presets, choose
Append.

Loads tool presets that have been previously saved or
acquired elsewhere.

Saves a custom set of tool presets for later retrieval. The
saved file has a . tp] extension.

Replaces your current tool presets. Allows you to load a
.tpl file that will replace your current tool presets.

Allows you to either append or replace your current tool
presets with the tool presets from each of those individual
libraries.




Getting Started and
Finishing Up

In This Chapter
v Opening images
¥~ Saving images

v~ Closing Photoshop

scratch in Photoshop, most of the time you’ll be working

with digital pictures that already exist. These may be
images captured by your scanner, photos you’ve grabbed with
your digital camera, or snapshots stored on a Kodak Photo CD.

E Ithough you can create some interesting images from

Photoshop offers you lots of different options for opening exist-
ing images, creating new images, and saving changes to your
hard drive. This chapter takes you through the steps you need
to know to begin working with your images.

If you want to capture an image with your scanner or import a
photograph from your digital camera, opening such a digital
image may involve a little more than just using the file naviga-
tion tools built into Windows Explorer or the Mac OS Finder.
Check out Appendix A for a complete discussion.

Browsing for Files

If you don’t know the exact filename of the image you want to
open or can’t remember its location, you can use the Photoshop
File Browser to search for and open files. (Check out Book I,
Chapter 5 for a complete description of the File Browser.)

Finding a file is about as easy as you might expect: Choose
Filew>Browse, or press Shift+Ctrl+O (Shift+8+0 on the Mac).
Guess what! The File Browser window opens.

which looks like a folder & magnifying glass, and is on the

s Now you can also just click the new File Browser button,
right side of the Options bar.
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To navigate to a folder you’d like to search, use the folder tree in the upper-left corner of the
window. Click an image to see it in the Preview window (which shows up on the left side of the
File Browser). Photoshop graciously provides information about the file on the Metadata
palette below the preview.

When you find a file you're sure you want to open, double-click it, or choose File>Open on the
Browser menu, as shown in Figure 3-1.

Figure 3-1 o=

0 1 "
= IMACES Lhow Flagged and Unflsgged 31

e |
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Opening an Image

If you know exactly where an image file is stored, you can open the file in a similar way to
opening a word processing, spreadsheet, or other file; the default Open dialog boxes resemble
those that you find in most other applications. (I discuss other file-opening options in the fol-
lowing sections.)

Follow these steps to open a file:

1. Choose File~>Open, or press Ctrl+O
(38+0 on the Mac).

The standard Open dialog box for
Windows or the Mac OS appears. The

layout of the dialog box differs slightly
between the two operating systems,
as you can see in the Windows version
in Figure 3-2, and the Mac version in
Figure 3-3.



2. Navigate to the folder that contains
your file.

OS X has a Favorites folder like the
Windows taskbar where you can add fre-
quently used folders. It also sports a Find

button in the Open dialog box for those 4.
hard-to-locate files.

From the Files of Type list (Windows)
or Show list (Mac OS), you can choose
which types of files you want displayed.

To view all image files, choose All Formats
(Windows) or All Readable Documents
(Mac OS).

ﬂ Click the name of the image file you
want to open.

Opening an Image

To select multiple files, click the first
file and then Ctrl+click (88+click in Mac
OS X) each additional file.

You may see a preview of the image in
the dialog box’s Preview window.

After you select the file you want,
click the Open button.

The file opens in Photoshop.

If you choose File>Open Recent, a sub-
menu lists the last files you worked on.
Click a filename to open it or simply
type the number next to the filename.
You can define the number of files that
appear on this menu in File Handling
section of the Preferences dialog box.
For the lowdown on how to specify this
value, jump ahead to Book I, Chapter 6.

Figure 3-2 |

Y
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Figure 3-3

Opening special files

Photoshop needs to know the image format of a file (that is, whether it’s a TIFF, PCX, PSD, or
JPEG file, for example) before it can open the file. Photoshop uses different methods in
Windows and Mac OS to determine the format of an image file:

‘/

In Windows, Photoshop looks at the file extension (. tif, .pcx, .psd, and so forth), and
if it finds a standard image format extension, it assumes that the file was saved using
that format.

The Mac OS X uses a similar system based on filename extensions. The difference is that
the file extensions may or may not be hidden. Showing or hiding file extensions can be
accomplished via any file’s “Info” dialog. Select the file in the Mac OS X Finder, press 38+I,
and the Info dialog pops up. Here you can show or hide the extension for that file, and
change what application is associated with that file (and all files with the same extension).

For compatibility reasons, Macintosh applications like Photoshop usually use the Windows
file extension. However, when you move files from one platform to the other, they can easily be
misidentified. With Photoshop’s Open As feature, you can specify the format you think (or know)
that a given file uses. This facility works slightly differently in Windows than in the Mac OS.

Opening special files using the Windows 0S

In Windows, follow these steps:

1

Choose File~>Open As. 2. Navigate to the file you want to open.

The Open As dialog box appears, as 3. From the Open As drop-down list,
shown in Figure 3-4. choose the file format you want to use.



Opening an Image

4. Double-click the file’s icon. If the file doesn’t open, you may have
, . chosen the wrong format. Choose another
If you've Chosen the right format, the and try again.
file opens in Photoshop.
. Open As >
Figure 3-4 e — = e
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Opening special files using the Mac 0S

The standard Open dialog box includes a Format list at the bottom. Make sure that the Show
list displays All Readable Documents. Then you can choose the file format you’d like to try
directly from the Format list.

Opening a Photo CD image

The Eastman Kodak Company originally developed the Photo CD format more than a decade
ago. It has become a popular image format option because of its flexibility and high quality.
Photo CDs store each image in multiple versions as Image Pacs, so you can open the version
that has the resolution you need. Professional versions of this format provide copy protection
and other features that professional photographers need. Your photofinisher can save your
images to a CD in Photo CD format for you; Photoshop can’t save in this format, however.

CONTINUED
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Follow these steps to open a Photo CD image:

1.

2.

Choose File=>Open and navigate to
the folder containing the Photo CD
image you want to open.

Double-click the file’s icon.

The Kodak PCD Format dialog box
appears, as shown in Figure 3-5, con-
taining the preview image and several
other options.

Choose the desired resolution from
the Pixel Size drop-down list.

Versions from 64 x 96 to 2048 x 3072
pixels are available.

You can select a color profile tailored
to a specific type of image from the
Profile drop-down list. (Generally, only
advanced users will want to change the
default value.)

In the Profile drop-down list, choose
the film type for the original image,
such as color negative, Ektachrome
(E-6), Kodachrome (K-14), and so forth.

. I odak PCD Format
Figure 3-5
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In the Destination Image area, choose
a resolution and indicate whether you
want the image to open in landscape
(wide) or portrait (tall) orientation.

Only advanced users will want to
change the Color Space definition.

The ProCD version of Photo CD has one
additional higher resolution than is avail-
able in the consumer version: 4096 x 6144
pixels, a whopping 72MB per image! The
top resolution of 2048 x 3072 (18MB) in
the consumer version should be plenty for
all but the most demanding applications.

Click OK to open the image.

In the Image Info area of the dialog box,
you can see what type of equipment
was used to scan the original as well as
the original image type (color negative,
transparency, and so forth).

Placing Files

In Photoshop, you use the Filer>Place command to put PDF (Portable Document Format),
Adobe Illustrator (Al), or EPS (Encapsulated PostScript) files into a layer of their own. These



Placing Files

files are often created by programs other than Photoshop, such as Adobe Acrobat, Adobe
[llustrator, or CorelDRAW. Although Photoshop can open these files independently, you must
use the Place feature if you want to combine them with an existing image.

Follow these steps to place a PDF, Adobe Illustrator, or EPS file:

1.
2.

3.

Figure 3-6

Open an existing document into
which you want to place a file.

Choose Filer>Place.
The Place dialog box opens.

Navigate to the file you want to insert
and then double-click the file.

For some types of files, such as multi-
page PDF files, you may see a dialog
box like the one shown in Figure 3-6,
which lets you specify which page you
would like to place.

Your image appears in a bounding box
in the center of your Photoshop image.

You can reposition the artwork by
positioning your cursor inside the
bounding box and dragging. You can
also transform (size, rotate and so on)
your placed artwork if desired by
dragging or rotating the handles on
the bounding box or by entering
values in the Options bar.

Be careful, however. If you enlarge your
placed image too much, you may degrade

the quality of your image. For more infor-
mation on transforming images, see Book
I, Chapter 3.

Note that when you place a file, you
cannot edit the text or vector artwork in
it. Why? Because Photoshop rasterizes
the file, using the resolution of the file
into which you placed it. Note too that
when art is larger than the Photoshop
image, Photoshop downsizes the art so
that it fits the image. See Book II,
Chapter 1, for more on resolution.

Choose Anti-Alias in the Options bar
if you want to soften the edges of the
artwork during rasterization.

Not choosing the option produces a
hard edge.

Double-click inside the bounding box
to commit the placed image to a new
layer. You can also press Enter
(Return on the Mac) or click the
Commit button (the check icon) in the
Options bar.

POF Page Selector

Safiect & Page to Cpen

7 | B

Bk

2

= =
b=

wiHJ

1

57

Book

/

Chapter

3



58

Book 1  Chapter 3: Getting Started and Finishing Up

Creating a New Image

At some point, you’ll want to create a new image from scratch. You may want an empty canvas
to paint on or need a blank image as scratch space. Or you may want to paste a copied selec-

tion into a new document.

Follow these steps to use the New feature to create a new image:

1. Choose File=>New or press Ctrl+N

(38+N on the Mac).

The New dialog box appears, as shown
in Figure 3-7.

If you copy a selection to the Clipboard
and then choose Filez>New, Photoshop
automatically selects the Clipboard preset
and enters the dimensions of the copied
selection as the width and height of the
new document. You can create the new,
empty document and then paste the
copied selection into it by pressing Ctrl+V
(38+V on the Mao).

2. Type in a name for the new file.

If you specify no name, Photoshop cre-
ates one for you, such as Untitled-1,
Untitled-2, and so forth.

Enter the width and height of your
image by using one of the following
methods:

v+~ Enter the width and height manu-
ally. Type the width and height of
your choice in the text boxes. The
Preset size will automatically revert
to Custom.

Note that now when you change the units
for either the width or height, the other
also changes. Hold down the Shift key

to change both width and height
independently.

Y

v Choose a preset size from the Preset
drop-down list. The document sizes
include Default Photoshop Size;

common printing sizes such as 4 x 6,
5x 7, or 8 x 10 inches; display

screen sizes such as 640 x 480 pixels
or 800 x 600 pixels; digital video sizes;
plus an array of other popular sizes.

- Photoshop cs has a couple new presets.

cqf’ M The Clipboard provides the size that cor-
responds with an image that you have
copied to the clipboard. You can also
choose to match the size of any open file.
Open files are listed at the bottom of the
Preset list.

Now for the best new preset — your own!
Photoshop now allows you to create a
user-defined custom preset based on your
defined settings. Click the Save Preset
button in the New Document Preset
dialog box. Name your preset. Choose
any or all the options you want to include
in your preset. When you choose not to
include an option, Photoshop displays the
last used value for that option. Click OK.
Your custom preset now appears at the
top of the Preset list.

B NEW
\v,,;

As with other Photoshop dialog boxes,
you may change from the default unit of
measurement of pixels to another, such as
inches.

Enter the resolution for the new
document.

For example, you may want to choose
72 pixels/inch for images that will be
displayed on-screen and 300 pixels/inch
for images that will be printed.



It's important to choose the right resolu-
tion at this point in the creation process

because if you need to change the resolu-

tion later, you degrade image quality. For

more information on selecting an appro-
priate resolution, see Book Il, Chapter 1.

;_T Note that Photoshop now kindly gives you
cv?’ ifw the size of your image in the lower-right
> of the dialog box based on your settings.
This is good information if you're target-
ing a specific file size for your image.

From the Color Mode drop-down list,
select a color mode.

Your choices include Bitmap,
Grayscale, RGB Color, CMYK Color, and
Lab Color.

’"’?v Photoshop c¢s now provides support for
&V) f 16-bit images. Therefore, you can now

select the desired color depth for your
document. Only 1-bit color depth is avail-
able for Bitmap images (each pixel is
either black or white). The remaining 8-bit
and 16-bit color depths are available for
the other color modes. For details on
modes and color depths, see Book lI,
Chapter 2.

ﬂ In the Background Contents drop-
down list, select an option for how you
want the background layer to be filled.

7.

Creating a New Image 59

You choices are white, the current Book

background color, or transparent. I/
Chapt

Click the Advanced button to display i ;

a couple of additional options the
New Document dialog box in
Photoshop cs now has.

v Color Profile assigns a color profile
(a definition of the way color looks
in a document) to your new docu-
ment. The default color profile is the
Don’t Color Manage This Document
profile. I don’t recommend using
this setting. As an overall recom-
mendation, use Working RGB when
creating a new document unless you
have good reason not to otherwise.
This setting provides a nice, large
gamut (range) of RGB colors.

1+ Pixel Aspect Ratio selects an aspect
ratio (the relationship of Width to
Height). The default setting of
square is fine for print or Web
images. Images for digital video
content may require a non-square
aspect ratio such as D1/DV NTSC or
others.

Click OK when you’re finished enter-
ing your options.

Photoshop creates the new image.

[ New
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Saving a File

Before you exit Photoshop, you’ll want to save your file on your hard drive or other media.
Don’t worry if you forget to do this; Photoshop won'’t let you exit without first asking you if
you’d like to save any files that you've changed or newly created. However, it’s a good idea to
save files from time to time as you work on them so that you always have a recent copy safely
stored on your drive.

Follow these steps to save a file:

1

Choose File>Save As.

Choose Filew>Save to store the current
file under its present name. Choose
Filer>Save As to store a new file never
saved or a file already saved under a
different name.

The Save As dialog box appears, as
shown in Figure 3-8.

Navigate to the folder where you’d
like to store the file.

Type a name in the File Name text box.

Choose a format from the Format
drop-down list.

Some file formats have special capabili-
ties and requirements. For example, if
your document has layers, you can
save it in TIFF or PSD or PDF formats.
Your options appear in the Save As
dialog box when you select a format.
For more information on file formats,
see Book II, Chapter 2.

In the Save and Color Options areas,
select or deselect the following check
boxes as desired:

v As a Copy: Save the file as a copy.

+ Annotations: Include or delete
annotations in the saved copy.
(See Book II, Chapter 5, for more 6.
on annotations.)

v Alpha Channels: Include or ignore
alpha channels (stored selections).
(See Book VI, Chapter 1, for a dis-
cussion of channels.) 7

1 Spot Colors: Enable spot colors in the
saved file. (For more information on
spot colors, see Book X, Chapter 2.)

v Layers: Include layers or simply flat-
ten the image to one layer. (See
Book V, Chapter 1, for the lowdown
on layers.)

v Use Proof Setup: Enable proof
setup, which includes an on-screen
preview of how the image will look
when printed or viewed on a spe-
cific device. (See Book II, Chapter 3,
for more information.)

v+ ICC Profile (Windows)/Embed
Color Profile (Mac): Embed a color
profile in the file based on the set-
tings established in your Color
Settings dialog box. Leave this value
at the default setting, but check out
Book II, Chapter 3, for information
on the specialized situations when
you might want to change it.

+* Thumbnail (Windows only): Embed
a thumbnail image in the file if
you've defined thumbnails as
optional in Photoshop’s Preferences.
(You can find more on Preferences in
Book I, Chapter 6.)

1~ Use Lower Case Extension (Windows
only): Use lowercase extensions (that
is, . tif instead of . TIF) regardless of
how you type the filename.

Depending on which file format you
choose, you may get an additional
dialog box of options. For specifics on
these file format options, see Book II,
Chapter 2.

Click Save to store the image.
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Saving a backup copy

You usually want to have a backup copy of an
image safe on your hard drive any time you
make changes to a file and, often, periodically
throughout a work session. If you change your
mind about the modifications you've made to an
image, you can always return to the backup
copy. Photoshop offers several ways to create
such copies:

1 Choose Filer>Save As and enter a new
name to the file. It's also a good idea
to specify a new location, such as another
hard drive or perhaps a removable storage
destination, such as a Zip disk or a CD-R/RW
disc.

1 Choose File=>Save As and select the As
a Copy check box. Photoshop simply adds

“copy” to the current filename (for example,
myfile.psd becomes myfile copy.
psd) and saves the file under that new name.

Photoshop also enables you to create backup
snapshots of your images at any time (or even a
snapshot of an earlier version of the image by
using the History palette). However, because
Photoshop does not save these snapshots when
you close an image, you should use them just as
backups during a particular working session. For
more information on snapshots and the History
palette, see Book Il, Chapter 4. In addition,
Photoshop now offers a Layer Comps palette,
which enables you to save different configura-
tions of your document by recording the appear-
ance of your layers. For details on this new
feature, see Book V, Chapter 2.
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Applying Digital Copyrights

You may want to protect your work from unauthorized reuse by embedding digital copyright
information in the file — using the watermark capabilities in Photoshop (provided by
Digimarc technology). You should apply a watermark only after an image is finished. If you
change an image later, you have to apply the watermark to a new copy of the image; you
cannot add a watermark to an image that has previously been marked. Although watermark-
ing isn’t bulletproof, it can help preserve your rights.

Follow these steps to apply a digital copyright to an image:

1.

2.

If your image has more than one layer,
choose Layer=Flatten Image to com-
bine all the visible layers into one.

If the image is an Indexed Color
image (for example, a GIF file),
choose Image=>"Mode=>RGB Color to
convert it to RGB mode.

You can always reconvert it to GIF after
applying the watermark.

Choose Filter~>Digimarc~>Embed
Watermark.

The Embed Watermark dialog box
opens, as shown in Figure 3-9.

If this is the first time you’ve applied
a watermark, click the Personalize
button and follow the instructions to
register with Digimarc Corporation
over the Web or by telephone. Enter
your ID and PIN numbers as
instructed and then click OK.

Digimarc Corporation charges an
annual fee based on the number of
images you want to watermark and
your desired subscription level. For
example, 1 to 99 images at the basic
subscription level costs $49 per year.

Enter a copyright year for the image
in the text box.

Choose from the following options:

1 Restricted to limit the use of the
image.

10.

+* Do Not Copy to specify that the
image should not be copied.

v Adult Content to mark the image
suitable for adults only.

In the Target Output area, choose
whether the image is intended for
Monitor, Web, or Print display.

In the Watermark Durability area,
drag the slider or enter a value.

Durability in this case is a compromise
between visibility (very durable) and
unobtrusiveness (not very visible). If
you make the watermark less visible,
someone can accidentally (or inten-
tionally) damage or make it less effec-
tive by some image-processing
operations. The more durable a water-
mark becomes, the more likely it will
be visible to the eye, but the image will
remain protected even if the image is
scanned, modified with filters, or
printed.

Select the Verify check box in the
lower right.

This tells Photoshop to double-check
the image after the watermark is
applied, to make sure it was success-
fully embedded.

Click OK to apply the watermark.
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Closing and Quitting

When your session is finished, you’ll want to close up shop and quit Photoshop. PC users, in
addition to using the traditional File=>Exit option, you can close Photoshop in any of the fol-

lowing ways:

Closing and Quitting

v Choose Close from the Windows Control menu in the upper-left corner of the

Photoshop title bar.

v Click the Close (X) button in the upper-right corner of the Photoshop title bar under

Windows.

v Press Ctrl+Q.

v Mac users can choose Photoshopr>Quit or press 8+Q.

With any of these methods, Photoshop asks you, in turn, if you'd like to save any open file that
has not been saved or has not been saved since it was modified in this session. Click the Yes

button to close and save the files.

You can also close any open files without exiting Photoshop by pressing Shift+Ctrl+W
(Shift+88+W on the Mac).
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Getting It on Paper

In This Chapter

v Looking at printers

v~ Printing from the Windows
and Mac operating systems

v Choosing print options

option, thanks largely to the swarm of sub-$200 photo-

quality inkjet printers that are vying for your discre-
tionary dollars. Today, anyone can afford a printer capable of
producing sparkling prints from digital images. The chief prob-
lem is restraining the urge to print everything in sight before
your ink tank (and wallet) runs dry.

Hard-copy prints have become a hugely popular output

Actually, making the prints is only a minor puzzle, and one
addressed in this chapter. You can print most images with just
a few clicks. Most of the advanced options discussed in this
chapter are needed only for special situations or specialized
applications and are not discussed in detail; this chapter
covers only the basics. If you need more detailed or advanced
information on printing, see Book X, Chapter 2.

Taking a Look at Printers

You can print Photoshop images on any kind of printer, but,
aside from the occasional 200-copy print run of black-and-white
“Have You Seen This Kitty?” posters, monochrome laser printers
are not high on the list of favored Photoshop output hardware.

More often, you’ll be choosing a full-color printer, probably an
inkjet model, but also possibly a dye-sublimation, thermal-wax,
or even color laser printer model. Although all these printers
produce roughly similar results, they do have some differences,
as detailed in the following list:

v Inkjet printers: These printers paint the page by spray-
ing a jet of ink one dot at a time, under precision com-
puter control. The ink can be water-based or solid ink
that is melted just before application. Liquid inks tend to
spread by soaking or wicking into the fibers of the paper,
can smear when wet, and produce better results when
used with photo paper designed especially for inkjets.
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Most inkjet printers use four ink tanks for black, cyan, magenta, and yellow. A few use

six tanks, adding “weak” cyan and magenta hues to the strong colors and black to pro-
vide more colors. Regardless of configuration, inkjet printers generally provide excel-

lent full-color output, but the cost of consumables (ink and paper) can add up fast.

v Dye-sublimation printers: These printers potentially offer better-looking prints, but
require even more expensive materials than inkjet printers. Most models cost more
than inkjet models. Many consumer-oriented dye-sub printers are models capable of
producing only snapshot-sized (roughly 4-x-6-inch) prints. They use a continuous ribbon
of color panels in a roll that is the same width as the print, with each panel used only
once. The print head’s tiny heating elements can melt dots of dye over a range of 256
values to generate up to 16.8 million colors. Professional dye-sub printers are accurate
enough to be used for color proofing.

v Thermal-wax printers and solid-ink printers: These printers use blocks of wax or resin
that are melted and sprayed directly onto a page. Some apply ink to a drum that rolls
against a piece of paper, like an offset printing press. Significantly more expensive to
own and operate than inkjet printers, these devices are generally for advanced-amateur
or professional applications.

Printing an Image

The process of printing an image in Photoshop is slightly different in the Windows and Mac
OS operating systems. The chief differences are in the Page Setup step, in which you select a
printer and choose orientation, paper size, and other parameters. The next few sections take
a closer look at Page Setup in the two operating systems.

Using professional printing services

Even if you own a photo-quality printer, you may
want to take advantage of professional services
from time to time. For example, you may own a
dye-sublimation printer that cranks out snapshots
with aplomb but can’t give you a 5-x-7-inch or
8-x-10-inch print.

Hop in the car and jaunt over to a retailer in your
area equipped with one of those stand-alone
kiosks, such as the Kodak Picture Maker. These
devices accept images in many formats. You can
use your digital camera’s memory cards, Kodak
Photo CDs, or diskettes to supply fodder for
the kiosk. Most include scanners that can cap-
ture your original prints, slides, and negatives.
They even offer Photoshop-like picture-fixing
capabilities. You can adjust color, repair red-eye

problems, crop or enlarge your images, and add
text.

Many photofinishers or service bureaus can
make prints from your Photoshop-edited images
if you burn them to a CD, save them to a Zip
disk, or upload them to an FTP site over the
Internet. You can often purchase greeting cards,
T-shirts, mouse pads, and other printed output
that is difficult to duplicate at home. Large-format
prints, posters, and murals are other cool options.
Online service providers are also becoming
increasingly popular. Adobe has partnered with
shutterfly.com and MyPublisher.com to offer
prints of all sizes, calendars, and professionally
printed and bound photo books.




Printing an Image

Page Setup in Microsoft Windows

With Windows applications such as Photoshop, you open the Page Setup dialog box by choos-
ing Filer>Page Setup or by pressing Shift+Ctrl+P. In this dialog box, shown in Figure 4-1, you
can select the paper size, orientation (Portrait or Landscape), and other things, such as which
paper tray to use. If you click the Printer button, a second Page Setup dialog box appears.
Here, you can choose a specific printer from those attached to your computer or network.
Clicking the Properties button takes you to specific options customized for your printer, such
as print quality or special effects available with that printer. These vary from printer to
printer, so consult your printer’s instruction manual.

Figure 4-1
Page Setup . =]
Sae Letss Masme  HPLasenlet 5000 PS v [ Progames
Sounce: Sasamatcallly Select Stnur  Feady
Ty HP Lanes Dot 5000 Samen PS
Wisest oS00
Posat Comegnt
ot M oW Cantsl
0 Camtod Pt
Page Setup in the Mac 0S

To choose which printer is active in the Mac OS, use the Print Center to access the Page Setup
dialog box, shown in Figure 4-2, choose Filez>Page Setup, or press Shift+8+P. You can set the
page size and orientation, scaling, and additional parameters, depending on your printer.

in Windows. Also in Mac OS X, if you're connected directly to a printer via the USB port, the
system automatically detects the printer. If you're on a network, you can use Print Center
and select a printer from the Printer list or in the Print dialog box.

@ In Mac OS X, you can also choose a printer directly from the Print dialog box just as you can
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Fage Setup
Figure 4-2
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Setting Printing Options

Photoshop has several printing modes to choose from, depending on how much control you
need and how much of a hurry you'’re in. Here are your options:

v Print One Copy (Alt+Shift+Ctrl+P, or Option+Shift+8+P on the Mac) is a quick way to
print a hard copy using the default settings.

7

Print (Ctrl+P, or 8+P on the Mac) pops up the standard Windows (or Mac) Print dialog
box, with options to choose a new printer, select which pages to print, select the
number of copies, and indicate whether to collate the output. The exact options avail-

able depend on what printer you are printing to.

Print with Preview (Alt+Ctrl+P, or Option+88+P on the Mac) opens an expanded Print
dialog box that includes a preview window and many more options to choose from. You
can even access the Page Setup dialog box from this dialog box if you want to change the
orientation, paper size, or switch to a different printer. This dialog box is almost identical
under the Windows and Mac operating systems, as you can see in Figures 4-3 and 4-4.

To set your print options, follow these steps:

1

2.

Choose Filer>Print with Preview.
The Print dialog box opens.

Use the Top and Left boxes in the
Position area to indicate where you

want the image to appear on the page.

To center the image, select the Center
Image check box.

Select the Show More Options check
box and choose Output from the
drop-down list.

The other option on the drop-down
list, Color Management, controls
advanced proofing and color profile
tasks. Check out Book X, Chapter 2, for
information on printing using color
management, as well as Book II,
Chapter 3, for more detail on general
color-management topics.

Note that any options that don’t apply to
your selected printer are grayed out.



Figure 4-3

Figure 4-4
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If you want to scale the image up or
down, choose the scale percentage
and/or enter height and width values
in the Scaled Print Size area.

(This doesn’t change the physical
dimensions of the image, just the print
size.) Additional options include:

» Show Bounding Box: Places the
handles around the image area and
allows for visual sizing.

v Print Selected Area: Allows you to
print only part of a large image.

v Scale to Fit Media: Sizes your image
to fit on a particular paper size.

Choose the printing options you want
to apply:

v Background: The area surrounding
the printed image is called the back-
ground, not to be confused with the
background color on the Colors
palette or the background layer of
an image. You can change this color
from the default (white) to any other
color. Clicking the Background button
brings up the Color Picker tool. Black
is often the best background choice if
you are printing slides on a film
recorder and want the area outside
the image to remain dark.

v Border: The dialog box that pops up
lets you specify a black border to be
printed around an image in any
width from 0 to 10 points, 0 to 3.5
millimeters, or 0 to 1.5 inches.

v~ Bleed: A bleed is an image that
extends right up to the edge of the
paper size on one or more edges. In
effect, you're cropping inside the
image area. In practice, most print-
ers don’t actually print right to the
edge, so to bleed, say, a 5-x-7-inch
image, you need to print it on a
larger sheet of paper, such as 8 x 10.
Clicking the Bleed button opens a
dialog box in which you enter a
width in inches, millimeters, or
points inside the edge of the image.

+* Screen: When you click the Screen
button, you see the Halftone Screens
dialog box, shown in Figure 4-5,
which lets you create halftones for
color separation. See Book X,
Chapter 2, for more information on
color separations.

v Transfer: This is an advanced func-
tion used for prepress operations to
compensate for the change in dot
sizes when halftoned images are
printed on a press.

v~ Interpolation: This option is only
available with some printers, partic-
ularly PostScript Level 2 (or higher
models), to even out the jagged
appearance of diagonal lines in low-
resolution images. Just be aware
that interpolation can only help so
much and in some cases, it can be
damaging. For more on interpola-
tion, see Book I, Chapter 1.

Select options for marking the area
outside the print area. These include
several items that appear only when
the print area is smaller than the
paper size:

v~ Calibration bars: This option adds
an 11-step grayscale bar outside the
image area when printing to a paper
size that is larger than the image
area. You can use calibration bars to
gauge how accurately the gray tones
of an image are being reproduced.

1~ Registration marks: Registration
marks are handy when you’re print-
ing with multiple plates for color
separations, such as those used in
four-color or duotone processes.
These marks help keep the plates
aligned so the image is printed
properly.

v+ Corner crop marks: Clicking this
box prints crop marks at the cor-
ners of the image, which indicate
where trimming should take place.
You can see these and other marks
in Figure 4-6.



v+ Center crop marks: These crop
marks show where the page will be
trimmed at the top, bottom, and
each side.

v Description: To include a descrip-
tion on a printout, choose Filer>File
Info and enter the text you want to
appear. Then check the Description
box in this dialog box.

v~ Labels: Selecting this check box
prints the document name and
channel name on the image.

8. Set the options that apply when
you're printing to film for color sepa-
rations, if that’s the case.

Be sure to talk to your service bureau or
@ offset printer representative for their rec-

ommendations. For more tips on prepress
and printing, see Book X, Chapter 2.

Here are your choices:

Setting Printing Options

+* Emulsion Down: The side of a film
or photographic print paper that is
light sensitive is called the emulsion
side. You must specify whether you
want the emulsion side up or side

down for film output. Emulsion Down

is the most common film output
choice, although some publications
may request Emulsion Up. The
default is Emulsion Up (the check
box is not selected). This option is
not available with all printers.

v Negative: When you're printing an

image on paper, you usually want a
positive image, in which case you

should not select the Negative check

box. However, if you're printing the
image on film (as is the case if
you’re printing color separations),
your printer will probably request a
negative. To print a film positive, do
not select this check box.
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Viewing and
Navigating Images

In This Chapter

v Exploring the image
window

v Zooming within an image
+* Moving with the Hand tool

v~ Traveling around with the
Navigator

v~ Selecting screen modes

v~ Positioning and measuring
precisely

v Finding images with the File
Browser

ments as you work with them. You can pull back to look at

the big picture or zoom in to work on a tiny portion of the
image in minute detail. A useful Navigator palette is also at hand
to show you exactly where you are in an image and help you
move to a specific spot with a click of the mouse button. Should
you want to align objects precisely on the screen, Photoshop
offers grids and guides with some “magnetic” properties. And, if
you’re having trouble finding the image you want, Photoshop
even includes a browser to help you search visually.

Photoshop offers a variety of ways to view your image docu-

This chapter introduces you to all these viewing and navigating
aids, each designed to help you spend less time cruising
around the images and more time working with them.

Looking at the Image Window

Each Photoshop image document resides in its own window,
which provides multiple views of the same document. You can
drag the window anywhere in the Photoshop working space,
but you can’t drag it to a second display screen if you're using
Photoshop with more than one monitor in Windows (Mac users
can, though). Remember that you can, however, move palettes
and dialog boxes onto a second monitor.

You can move palettes and dialog boxes out of the main
working space (and onto a second monitor), but documents
must stay put in the original display if you're using Windows.

The image window comes in handy because sometimes you’ll
want to look at an image from two perspectives. For example,
you may want to get up close and personal with an image to

edit pixels, but you still want to view the full image in a fairly
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large size. Or, you might want to zoom in on two different portions of an image, but find that
simply enlarging the entire image on your screen doesn’t show both parts at once.

In either case, all you need to do is create a new image window for the same image. You can
size each window separately, and you can center the window on any portion of the image you
like, as shown in Figure 5-1. For example, you can have one window zoomed in on the upper-
right corner of an image and a second window zoomed in on the lower-right corner, and have
both visible on the screen at once.

. ol Scarecrow pg @ 121% (RGB)
Figure 5-1 || ’ T o

W Scarecrow jpg @ 300% (RGB) BEB|

~ 7 &

Here’s a quick list of what you can do with multiple windows:

v Keep different parts of an image straight by creating multiple windows. Select
the document window you want to duplicate, and then choose Window=>Arrange=
New Window for (filename) from the menu bar. You can size and position the new
window and zoom in or out without affecting the view of the original window. I
describe some shortcuts for zooming later in this chapter.

v Keep windows organized by cascading them. If you find that you’'ve created so many
windows that you can’t view them all easily, Photoshop can automatically arrange them
for you in its working space. Choose Windowr>Arranger>Cascade to create an overlap-
ping stack of windows arranged from the upper-left to the lower-right side of your
display.



Zooming In and Out of Image Windows

v Keep from losing important windows by tiling them. Choose Windowr>Arranger>Tile
to arrange the windows side by side without overlapping. Photoshop changes the size
of the document windows so they all fit on the screen, but doesn’t change the zoom
amount. In many cases, the reduced-size windows have scroll bars to let you view the
hidden portion of the window.

v Tidy up by closing windows you don’t need anymore. To close a specific window,
click its Close button in the upper-right corner of its title bar under Windows (at the top
left in the Mac OS).

v Close all windows in one fell swoop. To close all windows, choose Windowr>Arranger>
Close All (or press Shift+Ctrl+W) in Windows. If you're using Mac OS, choose Filer>
Close All instead. On the Mac, you can also hold down the Option key and click the Close
button to close all open documents.

v Minimize a document (in Mac OS). To minimize an active document and place the
thumbnail in the Dock, choose Window=>Arranger>Minimize. To maximize the image,
simply click the image thumbnail in the Dock.

v Bring all Photoshop documents to the front (in Mac OS). The Mac OS allows you to
work in multiple applications and multiple files simultaneously. Sometimes when you
switch back into working in Photoshop, your documents may be buried behind non-
Photoshop files that are open in the other applications (the files are interleaved).
Choose Windowr>Arranger>Bring All to Front to bring all your Photoshop documents
to the forefront.

Zooming In and Out of Image Windows

Photoshop offers several ways to zoom in or out of an image, but you’ll probably find yourself
using one method, such as the keyboard shortcuts, almost instinctively.

Each method has advantages of its own. Here’s a quick discussion of each:

v Keyboard shortcuts: While using any tool, hold down the Shift key. Then press the Alt
key (or press spacebar+Option on the Mac) and click to zoom out from a point centered
on where you click. Press the Ctrl key instead (or spacebar+8 on the Mac) and click to
zoom in to a point centered on where you click the mouse button. Photoshop zooms in
or out by one of its preset increments (such as 100 percent, 200 percent, or 50 percent,
33 percent, 25 percent, and so forth). The maximum magnification Photoshop allows is

i 1,600 percent; the minimum magnification is 0.0533 percent.

Using keyboard shortcuts is the best way to change magnifications on the fly.

v Zoom tool: Click the Zoom tool in the Tools palette or press Z to activate it. Click any-
where in the image to magnify it by one of the preset magnifications mentioned in the
preceding bullet. Hold down the Alt key (or the Option key on the Mac) and click with
the Zoom tool to zoom out. In either case, the zoom centers on the point you click. The
Zoom tool’s big advantage is its zoom selection facility. With the Zoom tool, drag in
your image to create a temporary selection. When you release the button, Photoshop
zooms in to fill the image window at the highest magnification that includes the
selected area.
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v Options bar zoom buttons: When the Zoom tool is active, plus (+) and minus (-) zoom

buttons appear on the Options bar, as shown in Figure 5-2. You can click the buttons to
enlarge or reduce the image to the next preset percentage, centering the zoom on the
center of the image.

- - DR Batie Wridlas Bo 80 Tgres ket Do A By Ao Pty il S ey S s

Figure 5-2

As you zoom in and out, Photoshop does not alter the size of the document window, so
your image may become too large for its window (in which case scroll bars appear so
you can view the rest of the image) or too small (in which case a gray border appears
around the image).

changes the size of the document window to show the full document in view, up to the size

@ Select the Resize Windows to Fit option on the Options bar, and Photoshop automatically

of the Photoshop working area.

v Menu zoom: Choose Viewr>Zoom In or Viewr>Zoom Out to enlarge or reduce the image

from the menu bar. You can also choose from these options on the View menu:
Actual Pixels (which shows your image on the screen at 1:1 pixel ratio)
Fit on Screen (which enlarges the image to the maximum size that will fit on the screen)

Print Size (which shows the image at the size it will print)

v Magnification box: The Magnification box in the status bar at the bottom of the

Photoshop working area (in Windows) or the bottom of each document (in Mac OS)
shows the current magnification ratio. Many Photoshop users don’t realize you can also
type in an exact magnification ratio in this box to produce a custom zoom level. This is
handy if you need a specific amount of enlargement or reduction.

for zooming. | describe them later in this chapter.

@ Another Magnification box appears in the Navigator palette, along with some other options

7 d

1 d

Match Zoom: Photoshop cs offers a new command for zooming when you have more
than one document open. Choose Match Zoom to have all your open documents match
the magnification percentage of your active document.

Match Location: Another new command, Match Location, matches the locations of all
your open documents with the location of your active document. For example, if you
are viewing the center portion of an image, choosing this command then adjusts the
views of all your open documents to the center as well.

Match Zoom and Location: And finally, Match Zoom and Location does both commands
simultaneously.

@NEW Match Zoom, Match Location, and Match Zoom and Location are new to Photoshop cs.
;‘}';
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Zooming tricks Book
After you've absorbed the basic features of the various zoom alternatives in Photoshop, you’ll Chapter
want to find out about some of the special tricks built into them. Here’s a list of the most L}

useful options:

v Magnify by dragging. With the Zoom tool, drag over the portion of the image you want
to zoom into. A selection marquee appears, and when you release the mouse button,
that portion of the image fills your document window. To freeze and then move the
selection marquee around the image, begin your drag and then hold down the spacebar
while dragging the marquee to a new location.

v Double-click the Zoom tool to display the image at 100 percent magnification. You
can also choose View=>Actual Pixels from the menu bar or, if the Zoom tool is active,
click the Actual Pixels button on the Options bar.

1 Choose View= Fit on Screen to make an image the largest possible size that will fit on
the screen. You also can click the Fit on Screen button on the Options bar if the Zoom
tool is active or (the fastest way) just double-click the Hand tool. (You can find more on
the Hand tool later in this chapter.)

Edit>Preferences->General (or Photoshop~>Preferences>General in Mac OS X) and select

@ To resize windows to fit on the screen when you're not using the Zoom tool, choose
the Keyboard Zoom Resizes Windows option.

Handling the Hand tool

The Hand tool helps you to quickly move around in an image document. The Hand tool works
similarly to a scroll bar, but you’ll probably find the scroll bar to be more efficient.

The Hand tool is more of a function than an actual tool because you rarely need to click the
Hand tool to use it. Simply press the spacebar while using any other tool, and the cursor
changes into the Hand icon, enabling you to move the image around in its window by dragging.

Here are some tips for using this tool:

v Press H to activate the tool: To activate the Hand tool without clicking its icon on the
Tools palette, just press the H key.

v Use the Options bar to change the size of a window: When the Hand tool is active, the
Actual Pixels, Fit on Screen, and Print Size buttons appear in the Options bar. Click
these buttons to enlarge or reduce the image window so the whole image fits in the
window; make the document as large as it can be in your working space; or make the
document appear in the size it will be when printed.

v Use the Hand tool as a spacebar lock: When the Hand tool is active, you can hold
down the Alt key (Option key on the Mac) and click in the image to zoom out, or
hold down the Ctrl key (8 key on the Mac) and click to zoom in — without needing
to hold down the spacebar as you would with the normal keyboard shortcut.

:"%W The Hand-tool-as-a-spacebar-lock trick is new in Photoshop cs. Another new option, Scroll
& y» All Windows, enables you to move around all open documents simultaneously.
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Double-clicking the Hand tool resizes the document image so its longest dimension expands

to fill the screen in that direction. A tall, portrait-oriented image balloons up until the docu-
ment is as tall as possible in the Photoshop working area. A wide, landscape-oriented image
expands its width to fit within the left and right borders of the screen.

v Press the Page Up or Page Down buttons to change the view. These buttons move the
view up or down by a window.

- Now that you have become friendly with the Zoom and Hand tools, here is one last tip. If
cﬁq wa you hold down the Shift key while scrolling with the Hand tool or zooming with the Zoom
> tool, all open image windows will scroll or zoom together. This can come in especially handy,
for example, when you have created another view of the same document (Windowr>>
Arranger>New Window).

Cruising with the Navigator Palette

Some Photoshop users don’t use the Navigator palette, which is a roadmap to your image
document, nearly as often as they could, and there’s a simple reason for that: In its default
size, the Navigator palette is just too darned small to be of use.

Most new Photoshop users see the tiny Navigator window and decide that working with such
a small thumbnail image isn’t worth the bother. There’s a quick fix, and after you've seen
exactly what the Navigator palette can do for you, it may become one of your favorite tools.

Here are the keys to using the Navigator palette:

v Resize the Navigator palette: Before you begin working with the Navigator palette, grab
the size box at the lower-right corner of the Navigator palette and drag it down and to
the right to create a jumbo version with a much larger, more viewable thumbnail, as
shown in Figure 5-3.

can’t put another document window on the second monitor. Placing the jumbo-sized

E s This works really well if you are using a second monitor, especially in Windows, since you
Navigator palette on the second monitor is the next best thing.

Well. It's most useful when it is visible at all times. Position the Navigator palette to one side

s The Navigator palette is one palette that you probably won’t want to relegate to the Palette
of your image so it's ready for instant use.

v View the thumbnail: The entire Navigator window shows the full document image, with
an outline called a View box showing the amount of image visible in the document
window at the current zoom level.

v Change the view: Click anywhere in the thumbnail outside the View box to center the
box at that position. The comparable view in your main document window changes to
match.



Choosing a Screen Mode

v Move the view: Click anywhere in the thumbnail inside the View box and then drag to
move the box to a new position. The main document window changes to match the new
view.

v Zoom in or out: Click the Zoom In button (which has an icon of two large pyramids) or
Zoom Out button (which has an icon of two smaller pyramids) to zoom in or out. Or
drag the Zoom slider that resides between the two icons. The View box changes sizes as
you zoom in or out, and Photoshop magnifies or reduces the view in the original docu-
ment window to match, as well.

v Specify an exact magnification: The lower-left corner of the Navigator palette has a
Magnification box just like the one in the status bar. It shows the current magnification,
and you can type in a new value to zoom to the exact magnification level you need.

If the View box color is too similar to a dominant color in your image, you can choose a new
color for its outline by selecting Palette Options from the Navigator palette pop-up menu.

& ImageQ1.jpg @ 68T
Ay 't

Figure 5-3

Choosing a Screen Mode

Photoshop’s working area can become horribly cluttered. And here’s a secret: The more adept
you become, the more cluttered the desktop becomes. Just when you begin to appreciate a
neatly docked Options bar and the convenience of displaying palettes, you realize that you've
gobbled up all your free working space.
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Even if you have a behemoth 22-inch monitor or use a dual monitor setup, you may still
find that your screens fill up faster than Yankee Stadium on Bat Day.

Photoshop has three different screen modes (or maybe five, depending on what you consider to
be a screen mode). Each mode shows or hides some of the elements on the screen at the press
of a key or click of the mouse button. Three screen modes are on the Tools palette; two more are
hidden but easily accessible. Table 5-1 shows you how to unclutter your screen quickly.

TaBLE 5-1: CLEANING UP WORKING SPACE CLUTTER

Do This.... ... To Change to What's Happening
This Screen Mode
Press Shift+Tab Hide all palettes All the palettes in your working

space — except for the Tools palette
and any palettes stowed in the Palette
Well — vanish. When you need to
access them again, press Shift+Tab

again.
Press the Tab key Hide all palettes and All the palettes (including the Tools
the Options bar palette) and the Options bar vanish,

leaving you with a clean workspace
showing only the menu bar, applica-
tion title bar, and any open documents.

Click the Full Screen with Full Screen mode with ~ Only the active document window is

Menu Bar icon in the menu bar visible, along with the palettes,

second row from the menu bar, and Options bar. The

bottom of the Tools palette document window is maximized,
and the other documents are hidden.
(See Figure 5-4.)

Click the Full Screen button  Full Screen mode Press Shift+Tab and the Tab to hide

to view the image alone, the palettes and/or Options bar.

with the menu bar and other
components hidden

Click the Normal Standard Screen mode  The default Photoshop screen appears,
Screen button displaying all menus and palettes.

Press the F key to cycle between the three screen modes.

In the Full Screen mode, Standard Screen mode, or Full Screen mode with menu bar, you
can still press Shift+Tab and the Tab key to hide the palettes and/or Options bar.

If you hide the Tools palette when in either Full Screen mode, you can't click the icons to
return. Press Tab or Shift+Tab to reveal the Tools palette, or simply press the F key to cycle
among the screen modes.

® @.@
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Getting Precise Layout Results

Photoshop includes numerous useful features that help you lay out your images precisely.
There are dozens of reasons to make a selection in a particular place, position an object at an
exact location, or align several objects along the same imaginary line. Here are a few examples:

v You want to draw parallel lines exactly 50 pixels apart to create a “window blind” effect.

v You're creating a set of thumbnails that need to be aligned so they line up in neat rows
and columns.

v You want to create an object that is the exact same size (in one or more dimensions) as
another object already in your image.

You have several tools to help you do this, and more.

Creating guides

Guides are nonprintable horizontal and vertical lines that you can position anywhere you like
within a document window. Normally, they are displayed as solid blue lines, but you can
change guides to another color and/or to a dashed line.

To use guides, choose Edit~>Preferences=>Guides, Grid, & Slices (or PhotoshopPreferences>
Guides, Grid, & Slices in Mac OS X)), as discussed in Book I, Chapter 6. Guides would be useful
even if they were only, well, guides. However, they have another cool feature: Objects and tools
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dragged to within 8 screen pixels of a guide are magnetically attracted to the guide and snap
to it. That makes it ridiculously easy to align objects precisely. Because the objects snap to
the guides, you can be confident that you have placed the objects exactly on the guide and
not just near it. You can turn off the “snap to” feature if you want a little less precision in your
arrangements.

To place guides, follow these steps:

1. Make sure that rulers are visible in When you release the mouse button,
your image. Choose View=>Rulers to your new guide stops.
display them, if necessary. You can also create a horizontal guide
by Alt+clicking in the vertical ruler
from the ruler, the Show Guides option (Option+clicking on the Mao), or a

s Anytime you create a guide by dragging

automatically switches on. At other times, vertical guide by Alt+clicking in the
you can show or hide guides by choosing horizontal ruler (Option+clicking on
View=>Show>Guides, or by pressing the Mac). Use whichever method is
Ctrl+semicolon (38+semicolon on the Mac). faster for you.

Click in the horizontal ruler and drag 4. Use the Move tool (press V to activate
down to create a new horizontal it) to reposition your guides.
guide. Release the mouse button when Look for the guides in Figure 5-5.
the guide is in the location you want.

Click in the vertical ruler and drag to
the right to create a new vertical guide.

Figure 5-5

El—
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Using guides Book
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After the guides are in place, here are a few of the things you can do with them: Chapter
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Turn the Snap to Guides feature on or off: Choose Viewr>Snap Tow>Guides.

Lock all guides so you don’t accidentally move them: Choose View=>Lock Guides.
You can also select Alt+Ctrl+semicolon (Option+8+semicolon on the Mac).

Remove all guides and start from scratch: Choose Viewr>Clear Guides.

Change a horizontal guide to a vertical guide (or vice versa): Hold down the Alt key
(Option key on the Mac) as you drag the guide.

Align a guide at a precise location on the ruler: Hold down the Shift key as you drag
a guide to force it to snap to the ruler ticks.

Create a new guide in a precise location: Choose Views>New Guide, click the
Horizontal or Vertical option, and type in a distance from the ruler where you want
the new guide to reside.

Using grids

The Photoshop Grid feature offers a convenient canned set of guidelines already nicely
arranged for you at preset intervals. You can use a grid for any application where you want
to align objects in a pleasing, geometrically precise arrangement.

Grids share some features in common with guides but boast a few differences, too:

)

Like guides, grids don’t print with your image. They are transparent artifacts used only
as reference lines in your image, as shown in Figure 5-6.

Objects and tools can optionally snap to the lines on a grid, depending on whether you
have Viewr>Snap Tor>Grid turned on or off.

You can show or hide grids by choosing Viewr>Show (Hide)=>Grid.

You can change the color of the grid and choose solid lines, dashed lines, or dots for
the grid by choosing Edit=>Preferences=Guides, Grids, & Slices (Photoshop=>
Preferences in Mac OS).

You can specify the distance between grid lines and the number of subdivisions
between grid lines in the Preferences dialog box. For more information on setting
grid and guide preferences, see Book I, Chapter 6.
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Figure 5-6 e R
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Measuring On-Screen

You can measure distances and objects within Photoshop many different ways. The rulers,
used in combination with guides, are a good way to mark distances precisely so that you can
create objects of a particular size. You can change the increments used for these measure-
ments in Photoshop’s Preferences, as detailed in Book I, Chapter 6.

However, Photoshop also has a handy Measure tool you can use to lay measurement outlines
in any direction (not just vertically or horizontally as with grids and guides). These lines tell
you a great deal more than just the size of the object you’re measuring. You can also measure
angles and determine the exact coordinates of an object.

When you use the Measure tool, the Options bar offers a read-out of information that includes
the following values:

v X,Y — the X and Y coordinates of the start of the line: For example, if you start at the
l-inch position on the horizontal ruler and the 3-inch position on the vertical ruler, the
X and Y values in the Options bar are 1.0 and 3.0, respectively. (You select the incre-
ments for the X and Y values on the ruler in Photoshop’s Preferences.)

v W, H — the horizontal (W) and vertical (H) distances traveled from the X and Y
points: A 1l-inch long, perfectly horizontal line drawn from the X,1 and Y,3 position
shows a W value of 1.0 and an H value of 0.0.

\

A: The angle of the first line.
D1: The total length of the line.
v D2: The total length of the second line.

\



Measuring an object

To measure an object, follow these steps:

1. Select the Measure tool.

It’s tucked away in the Tools palette
with the Eyedropper. Press [ to cycle
among the Eyedropper, Color
Eyedropper, and Measure tool until it
appears.

Measuring On-Screen

Click at a starting location for the
measuring line and then drag to the
end location.

Hold down the Shift key to constrain
the line to multiples of 45 degrees.

Release the mouse button to create
the measurement line, as shown in
Figure 5-7.

HE M ane v 053

Figure 5-7
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Measuring an angle

You can measure an angle by drawing two lines and reading the angle between them from the

Options bar. Just follow these steps:

1. Select the Measure tool.

ﬂ Click at a starting location for the first
line and drag to the end location.

You can hold down the Shift key to con-
strain the line to multiples of 45
degrees.

4.

Release the mouse button to create
the first line.

Hold down the Alt key (or the Option

key on the Mac) and click in the end

point of the first line where you want

to measure the angle.
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Drag the second line and release the You can also see the length of each of
mouse button when it is finished. the lines as D1 and D2, as shown in
Figure 5-8.

6. In the Options bar, read the angle
between the two lines (A).
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Using the Info Palette

The Info palette, shown in Figure 5-9, displays a variety of information, depending on what
tool you're using. For example, if you're using the Measure tool, the information in the Info
palette duplicates the measurements shown in the Options bar. Choosing other tools modifies
the Info palette’s display to reflect the functions of that tool. Here is some of the information
you can find out by keeping the Info palette visible on your desktop:

v When using most tools, the Info palette displays the X and Y coordinates of the cursor,
as well as the color values of the pixel directly beneath the cursor.

v When making a selection with the marquee tools, the Info palette shows both the X and
Y coordinates of the cursor, as well as the width and height of the selection.

v When dragging with the Crop or Zoom tools, the Info palette shows the width and
height of the marquee used to define the cropping or zoom borders. The Crop tool’s
current angle of rotation is also displayed.

v With the Line, Pen, and Gradient tools, the Info palette shows the X and Y coordinates
of the starting position for the line, path, or gradient you are defining, as well as the dis-
tance (D) of the line you've dragged, the change in X and Y directions (DX and DY), and
the angle (A).
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Working with Extras

When you use a transformation command, the Info palette displays the percentage
change in the Width, Height, and Angle, Angle of Horizontal Skew (H), and Angle of
Vertical Skew (V). For more on transformations, see Book IIl, Chapter 3.

When you use a color adjustment, such as Levels, the Info palette displays before and
after color values beneath the mouse cursor. See Book VIII, Chapter 1, for more on color
adjustments.

After you've made a selection with the Lasso or Magic Wand tools, the Info palette also
shows the Width and Height of the selection. Choose Palette Options from the Info
palette’s pop-up menu (click the triangle in the upper right to open the pop-up menu).
Here you can define a second color readout in addition to the default readout, using a
different color model if you want. In addition to the regular color modes, the default
Actual Color option displays values in the current mode of the document. Proof color
displays values based on the setting chosen in Viewr>Proof Setup. The Total Ink option
displays the percentage CMYK ink under the cursor based on the settings in the CMYK
Setup dialog box in the Color Settings (Advanced). You can also define a measurement
increment for the mouse cursor (in inches, pixels, millimeters, and so forth) independ-
ently of the increment you've selected in Preferences. (For more information on setting
increments in Preferences, see Book I, Chapter 6.)

Working with Extras

Extras are the optional items displayed on your screen, such as grids, guides, selection edges,

annotations, slices, and the target path (a line drawn with the Pen tool). Although you can turn
on and off the display of each of these options independently, the Extras function helps you to
create a set of extras that you want to see or hide. You can then turn them all on or off at once.

The following list explains how to show or hide these extras:

’/

‘/

To turn one extra on or off, choose Viewr>Show and then choose the extra you want to
show or hide in the Show Extras Options dialog box, shown in Figure 5-10.

To show or hide extras in a group, choose Viewr>Show>Show Extras Options. Select
each extra that you want to show in the dialog box that appears.

To show or hide all the extras you've selected in Extras Options, choose Viewr>Extras
or press Ctrl+H (88+H on the Mac).
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Show Extras Options

Include: T

Selection Edges [ Grid
Target Path Guides

Annotations Slices

Figure 5-10

Managing Images with the File Browser

The File Browser, shown in Figure 5-11, is a powerful tool that gained even more power in
Photoshop cs. The File Browser lets you visually explore your hard drives and external media
to find the exact image you need and has a multitude of sorting and viewing features that let
you list the images in various ways.
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As you can with any browser, you can use the Photoshop File Browser after very little prac-
tice. Many of its functions are similar to browsing functions you already know. There are
several ways to access the File Browser.

v Choose Windowr>File Browser.

v Choose FilecBrowse.

v Click the new File Browser button on the Options bar.



Managing Images with the File Browser

No matter how you access the File Browser, after you open it, this behemoth of a window fills
your screen. And because the File Browser has become such a feature-rich entity, I describe
its various components in the next few sections.

Eﬁ%NEW

Note that the File Browser has undergone an identity change. In Version 7, the File Browser
was a palette; in Photoshop cs, it has gained window status and can no longer be docked
in the Palette Well. It also means, unfortunately, that if you're a Windows user and you use
a dual monitor setup, you will not be able to drag the File Browser onto your second moni-
tor. If you're a Mac user, you're in luck — you've always been able to move any palette,
dialog box, or window and still can. In addition, because the File Browser is now a window,
it doesn’t automatically close after you open your images.

Brief Anatomy of the File Browser

Before I dive headlong into the detailed operations of the File Browser, let me give you a brief
anatomical breakdown of each of its components, shown in Figure 5-11.

I/

\

\

Menu bar: Commands found on the menu bar allow you to open or delete images, edit
an image in ImageReady, add file info, and search for images. You can also flag files and
append their metadata (information about your file). See more on metadata coming up.
The menu bar also offers options for sorting and viewing files. Finally, you have access to
basically the same Automate menu that you find in Photoshop itself (in the File menu).

Buttons: Rotate, flag, search, or delete files with a click of the button.

Location bar: Across the top center edge of the File Browser is a location bar that lists
the current location (such as a folder on your hard drive) on display.

Show bar: Choose to display files that are either flagged or unflagged files or both.

Folders palette: Located in the upper-left corner of the File Browser is a palette
showing the folders on your computer. If an image file is available to your computer,
the File Browser lets you use this palette to find it.

Preview image: Beneath the Folder palette is a preview of the currently selected image.

Main browser window: Beneath the location bar is a scrollable browsing window that
shows thumbnail images of all the image documents in the currently selected folder. In
addition, any folders located within the current folder are shown with a folder icon.

Keywords palette: This new feature lets you tag your images with keywords such as the
names of people or places to enable easier locating and sorting of images.

Metadata palette: Below the Preview window is a Metadata palette that shows informa-
tion about your images. The File Properties section shows items such as filename, date
of creation, date last modified, image format and size, and so on. Any file information
for images added via the FileFile Info displays in the IPTC section of the Metadata
palette. Likewise, you can also enter, or edit file information directly in the IPTC section
in the File Browser. Finally, the Camera Data section displays information associated
with your digital photos, such as the make and model of your camera, and exposure
and ISO speed. You can also display other types of metadata, such as Camera Raw infor-
mation, by choosing them in the Metadata Display Options dialog box accessed via the
Metadata palette pop-up menu.
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Configuring the File Browser Window

The File Browser, being as enormous and full-featured as it is, is surprisingly flexible when it
comes to how you configure its various panes and palettes. Here’s a rundown of how to cus-
tomize your File Browser window:

v To size the entire File Browser window, diagonally drag any corner or edge of the
window. On the Mac, drag the lower-right corner.

v To resize panes, drag the bar that divides them. Position your cursor over the bar
(it changes to a double-headed arrow) and click and drag the bar to size the pane.

v To view just the large pane containing the thumbnails, click the double-headed arrow
located at the bottom of the File Browser window.

v You can drag and regroup the tabbed palettes in the File Browser just as you can the
regular Photoshop palettes. To collapse a palette, double-click its tab.

v After you have configured your File Browser, you can save it as a workspace preset that
you can then call up at anytime. Simply choose Windowr>Workspacer>Save Workspace.
Provide a name and click Save. To access the workspace, choose Workspace and then
select the name of your saved preset. For more on workspaces, see Book [, Chapter 6.

Using the menu bar and buttons

o o The File Browser now sports a new menu bar, shown in Figure 5-12. This menu bar is a
&V] Ni. visual testimony to the newly expanded capabilities of the File Browser. The next several
- sections provide a rundown of what you'll find under each menu category.
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Figure 5-12

File menu

Here’s what you'll find on the File Browser’s File menu:

v New Folder: This command creates a new folder in the location listed in the location bar.

v Open: After you select a thumbnail in the main browser window, you can choose the
Open command to open the image in Photoshop. Of course, you can also simply
double-click the selected file(s). To open multiple files, just press Ctrl (88 on the Mac)
while selecting. To select a group of contiguous files, Shift+click the first and last files to
select those and all the files in between.

v~ Edit in ImageReady: Choose this command if you want to open the selected files in
ImageReady to prep the files for the Web.

v Close File Browser: When you’ve had enough of the File Browser, choose this com-
mand. Or click the Toggle File Browser button in the Options bar.

To have the File Browser close after you open an image, be sure to Alt+double-click
(Option+double-click on the Mac) when you select your files in the File Browser window.
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Managing Images with the File Browser 91

File Info: This feature lets you add some of your own metadata, such as title, author, Book
copyrights, dates, credits, and so on. This information can come in handy for photogra- I
phers and reporters. You can also edit (replace, append, save, and delete) Advanced Chapter
Data such as EXIF (Extended File Information) Properties and TIFF Properties. But feel L}

free to leave this data as it is.

Delete: To get rid of a selected image, choose Delete or click the trash can icon.

Be warned that choosing Delete removes the image(s) from your hard drive or external
media, not just from the File Browser view.

Add/Remove Folder to Favorites: You can choose to add or remove a folder from your
Favorites. If you're not familiar with Favorites, it is a special folder that lists your
favorite files, folders, programs, and drives for quick and handy access. You can easily
find the Favorites folder in the folder bar and the location bar. And depending on your
operating system, you'll come across numerous ways to access your Favorites.

Cache commands: Cache is memory that stores frequently used data, such as thumb-
nails and file info, to allow for quicker loading when you display a previously viewed
image or folder. Building cache for a subfolder will allow you store the information for

a selected folder. If you purge the cache, you delete ranking and thumbnail information,
thereby creating more disk space. Exporting cache lets you export to the folder selected
in the location bar. This allows you to burn a CD without generating thumbnails.

Search is a great new feature that enables you to find files in selected folders or subfolders,
based on a variety of criteria such as filename, dates, flags or keywords. Click Search and the
files matching your criteria appear in the File Browser window. Note that you can also click
the Search icon (binoculars icon) on the menu bar.

Assigning keywords to files is one of the quickest and most efficient ways to search for and
locate images.

Many commands, such as Open, Delete, Rotate, Flag, and Rank, are available via a context-
sensitive menu. Simply select an image or folder and right-click (Control+click on the Mac)
to access the menu.

Edit menu

On the File Browser’s Edit menu, here are your options:

I’

1
‘/
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Select All/Deselect All: These two commands quickly select or deselect all the files in
your selected folder.

Select All Flagged: Selects all flagged images located in your selected folder.

Flag: Select your desired images and choose Flag. Photoshop then tags the images and
adds a small flag icon to the thumbnail, shown in Figure 5-13. You can flag images for
distinction and quick locating. Think of it as an electronic sticky note. For example, you
can flag images that need editing or retouching or those you are considering using for
an upcoming project.

You can also quickly flag images by clicking the Flag icon in the menu bar.
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v You can also choose to display either Flagged, Unflagged, or both Flagged and
Unflagged files from the Show drop-down list.

Figure 5-13

v Rank: You can create your own custom sorting order by applying a “rank” for each
image. Happily, you are no longer limited to ranking images from A to E. Apply any
alphanumeric text, and Photoshop does its best to make sense of your ranking scheme
and sort the images in a logical order. Numeric rankings appear first, followed by alpha
rankings.

Remember | said Photoshop tries to logically sort your ranking. But be warned that if you
number your images 1, 2, 12, and 122, Photoshop sorts the images as 1, 12, 122, and 2.
Photoshop looks to the first character, then the second, and so on.

v Clear Ranking: Choose this command to strip all ranking from your images in the
selected folder.

v Rotate: The rotate commands rotate your images in varying degrees and direction. Note
that when you rotate your images, the rotation is shown in the File Browser only when
you open the image. When you open the image, Photoshop then applies the rotation.
Use the Apply Rotation command to apply rotation without opening the file. You can
also click the rotate buttons.

v Append Metadata and Replace Metadata: Allow you to add or substitute existing meta-
data based on a template. To create a template, choose Filer>File Info. In the File Info
dialog box, enter all of your desired data. Then choose Save Metadata Template from
the dialog box pop-up menu. Name the template and click Save.

v Metadata Display Options: This command allows you to choose the fields displayed in
each of the metadata categories.

v Preferences: Selecting this command brings up the File Browser options of the
Preferences dialog box. In addition, all other preferences are accessible as well. Here
you can specify the file size limit of images you allow the File Browser to process. The
default size is 100MB, while the maximum size allowed is 2047MB. However, allowing
the File Browser to process extremely large files slows down its performance. If you
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don’t work in the world of mondo files, leave Preferences at the default setting and Book

don’t worry about it. Here is the lowdown on the other Preference settings: I/
. . . . Chapt

Display: You can specify the number of most recently used folders in your location il g

bar pop-up menu.

Custom Thumbnail Size: Choose a Custom thumbnail size for displaying your images
when you choose Views>Custom Thumbnail Size. Specify the Width of your thumb-
nail in pixels.

Allow Background Processing: Select this option to allow Photoshop to process
images in the background while you execute other tasks.

Pre-generate High Quality Previews: This option enables the File Browser to create
high-quality preview thumbnails of all images in your selected folder even before you
select them. You must have Background Processing turned on to be able to select
this option.

Render Vector Files: Select this option if you want to allow your non-Photoshop files,
such as EPS and PDF files, to be rendered, or displayed, in the File Browser window.

Parse XMP Metadata from Non-image Files: This setting removes metadata from
non-graphic images, such as text files.

Keep Sidecar Files with Master Files: The Camera Raw file format has a feature that
enables conversion and adjustment settings to be recorded and stored with the file.
These settings are stored in a sidecar file, which is an XMP (Adobe’s version of XML)
data file. If you want to be able to reopen your file and have your conversion settings
intact, select this option. If you want the conversion data stored in a single, collective
file in the Camera Raw database, deselect this option.

You'll notice the standard Copy command isn’t in the Edit menu. To copy a file, Alt+drag
(Option+drag on the Mac) the file into another folder. To move a file, just drag it into
another folder, either in the Folders palette or in the thumbnail panel.

Automate menu

On the File Browser’s Automate menu, you have the following options:

v Batch: This command applies an action to multiple files within your selected folder in
one fell swoop. For more on actions and batch processing, see Book I, Chapter 6.

v Batch Rename: Choose this command to rename multiple image files within a folder in
one execution. You can choose to rename the files and keep them in the same folder or
move them to a new folder. Click the Choose button to select that folder. Next, desig-
nate how your files are named. Choose an option from the pop-up menu or type your
own. In my example, [ chose to keep the original name of my documents, plus NYC, the
date, and file extension. Next, choose the starting number for renamed images and
check whether you want to enable the naming convention to be compatible with
another platform. My images were quickly renamed, as shown in Figure 5-14.
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v Apply Format Settings: If you have a file selected in the browser, and the file is in a
format that supports it (such as Camera Raw), the settings in the Camera Raw plug-in
will tweak the results and be shown in the file browser. Any plug-in can potentially take
advantage of this function, but currently the Camera Raw plug-in is the only one that
does. Therefore, if you have the Camera Raw file selected, and the Camera Raw plug-in
installed, the menu command will read “Apply Camera Raw Settings.” However, if you
don’t have both of those conditions, the command will be grayed out and will just say
“Apply Format Settings.”

v Online Services: You can access Adobe’s partners and service providers online to
order products such as prints and photo books.

v All the remaining features are the same as those found in the Photoshop Filew>
Automate menu. See Book X, Chapter 3, for more on contact sheets, picture packages,
Photomerge, and PDF Presentation. For more on Web Photo Gallery, see Book IX,
Chapter 4.

Sort menu

From this menu in the File Browser, select the criteria by which you want to sort your files.
The default is by the name of your file, but a ton of other options, such as rank, flag, or date,
are up for grabs. After you select the criteria, the File Browser displays your files accordingly.
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View

And last but not least, here’s what the File Browser’s View menu has to offer:

v Folders: Select this option to view folder icon thumbnails, in addition to image thumb-
nails, in your File Browser.

v Unreadable Files: Select this option to see files that Photoshop does not recognize.

v~ Flagged/Unflagged: Choose to view either flagged, unflagged, or both flagged and
unflagged files in the File Browser. For more on flags, see the earlier section, “Using the
menu bar and buttons.”

v Thumbnails: Choose the viewing size of your thumbnails. The Custom Thumbnail size
is based on your Preferences setting. The Details view displays the metadata in the File
Browser window, next to a small thumbnail of the image.

v Show Rank: Choose this option to display the ranking, if any, of each image. You can
use ranking to sort your images in a specific order.

v Reveal Location in Explorer (Finder on the Mac): If you select a file and then choose
this option, the File Browser opens a Windows Explorer window and shows you the
location of that file on your system.

v Refresh: If you've renamed a file, the order of your files isn’t updated in the File
Browser window. Choose Refresh or press F5, to get your files in order. Note that you
i can also choose Refresh from the Folders palette pop-up menu.

Closing and opening files also causes the File Browser to refresh.

Photoshop cs has bestowed the thumbnail pane with light-box powers. You can now drag
images around to reorder, group, or rank them. What the heck? You can just drag them
around to give them a little exercise if you want. Sitting in that File Browser window all day
can make a file a little stiff.

Working with Metadata

When you select an image, you can view its metadata. Metadata is just a fancy name for infor-
mation that is embedded in your image file. In fact, Photoshop allows an image to have so
much attached information, the only thing you won’t know is your image’s favorite color and
hobbies. The metadata categories include the default categories of File Properties, IPTC
(International Press Telecommunications Council), and Camera Data (EXIF or Extended File
Information). You can also choose to display the additional categories of GPS (Global
Positioning System), Camera Raw (a digital camera file format), and Edit History categories.
Choose Edit>Metadata Display Options to access these categories. In the following sections,
you can find a brief description of each one.

File Properties

The fields in the File Properties category include common vitals, such as filename, size,
format, color mode, and so on. This data cannot be edited.
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option allows you to collapse the left side of the File Browser without sacrificing the display of

@ Choose Viewr>Details to display the File Properties data next to the image thumbnail. This
important metadata.

IPTC

This data includes info commonly used in the media and press industry. Fields such as head-
line, credit, source, and copyright are available for input via the FilewFile Info command. Or
make it easy: Select an image, or several images, and simply click the field in the File Browser
and type your entry. If you select more than one image, Photoshop asks if you want the
change to apply to all selected images. If so, click Yes. All fields are later editable as well.

8! \ew The File Info dialog box is now extensible, which means that users can create custom panels
‘ %  with fields specifically tailored to business needs or personal interests.

Camera Data (EXIF)

EXIF data is information that is attached to an image created from a digital camera. It includes
data such as make and model of camera, exposure, and F-Stop settings. If a digital camera
didn’t capture the image, it doesn’t have any EXIF data, although some scanners attach EXIF
data, such as date, time, pixel dimensions, and resolution. Camera Data is not editable.

GPS

Some files, such as images captured by satellites, may contain GPS, or Global Positioning
System, data. This data may contain information on latitude, longitude, altitude, direction,
speed, and so on. However, this data is not shown in the Metadata palette by default. Choose
the Metadata Display Options (described later) command to display the GPS data.

Camera Raw

Camera Raw is a file format used to capture images by a lot of different digital cameras. The
image information is captured directly from the camera’s sensors and is not adulterated by fil-
ters or adjustments made by the camera. This enables photographers to read the image data
and make their own controlled adjustments. Camera Raw data includes settings like white bal-
ance, temperature, exposure, color saturation, and so on. Like GPS data, the Camera Raw data
is not shown in the Metadata palette by default. Choose the Metadata Display Options com-
mand to display this information.

Edit History

The Edit History option records all the edits (image enhancements, retouches, and so on)
made on an image in an edit log that you can save as a text file or as attached metadata.
Choose the File Handling panel in the Preferences dialog box to establish your desired settings
for your editing history. See the section, “Deciding how you want files handled,” in Book I,
Chapter 6 for details.
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The Metadata palette offers some options via the palette pop-up menu:

v Search: Select Search to locate images by various metadata fields. For details on search-
ing, see the next section.

v Increase/Decrease Font Size: Choose these options to enlarge or decrease the font size
in set increments.

v Metadata Display Options: This command allows you to choose the fields displayed in
each of the metadata categories. Select the Hide Empty Fields option to display only
your selected data fields. Keep your palette lean and mean by choosing the Hide Empty
Fields option to hide metadata items that are set to display, but do not contain any data.

— Note that you can define and create custom File Info panels for XMP metadata to suit your
§ company’s specific data needs. By creating a Custom Panel Description file and storing it in a
common location specified by Adobe applications that use this feature, this custom panel
shows up when users select Filer>File Info either in the File Browser or in the Photoshop
application window. For specifics on this feature, download the XMP Custom Panels PDF
document at Adobe’s Web site.

Using Keywords

Keywords are descriptive labels that you attach to files. They help to categorize your images,
enabling you to more efficiently and quickly locate your desired files. Here is the lowdown on
creating and using keywords.

v To create a new keyword set, click the folder icon at the bottom of the Keywords palette
or choose New Keyword Set from the Keywords palette pop-up menu. Name your set
and press Enter (Return on the Mac).

v To create a new keyword, select your desired keyword set, click the dog-eared page
icon at the bottom, or choose New Keyword from the Keywords palette pop-up menu.
Type your name and press Enter (Return on the Mac).

v To rename an existing keyword set or keyword, select it and choose Rename from the
Keywords palette pop-up menu. Provide a new name and press Enter (Return on the Mac).

Note that renaming a keyword in the palette doesn’t also rename it if it has already been
applied to a file.

v To delete a keyword set or keyword from the palette, select it and click the trash icon or
choose Delete from the Keywords palette pop-up menu. Again, deleting the keyword
doesn’t delete it from any files that it has previously been applied to.

v To apply a keyword, select the file or files and check the box to the left of the keyword
in the palette.

v To remove a keyword from a file, select the file(s) and deselect the keyword in the
palette.

v To apply all the keywords in a set, select the files and select the check box to the left of
the keyword set.
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v To search for images labeled with certain keywords, choose Search from the Keywords
palette pop-up menu or click the Search button in the menu bar. Choose your desired
folder or disk from the location bar or click the Browse button to navigate to your
desired location. Select your criteria from the pop-up menu, choose either Contains or
Does Not Contain, and enter your text. To add additional criteria fields, click the plus
sign. When finished, click the Search button. All images containing your entered
keyword appear in the thumbnail pane of the File Browser.

Right-click (Control+click on the Mac) on a keyword in the palette and select Search from
the context-sensitive menu. The keyword is automatically entered in the Search field.



Customizing Your
Workspace and
Preferences

In This Chapter

v~ Saving your workspace as
a preset

v~ Defining preferences in
Photoshop

v Managing settings with the
Preset Manager

without having to make a trip down to the local burger

shack. You can easily customize the look of your work-
space, specifying everything from the location of palettes to
the arrangement of dialog boxes when you begin a session.
You can even store these physical layouts and recall them
anytime you like.

To a certain extent, Photoshop lets you have it your way

Photoshop also makes it easy to choose how certain tools and
features operate. You can choose how the cursors for tools
such as brushes look, tell Photoshop your preferred way of
storing files, and specify just how much memory you’d like to
set aside for image editing. You can set all these preferences
once and then forget them, or you can change them from time
to time as your needs change. This chapter shows you how to
customize your workspace and preferences so that Photoshop
works your way.

Creating Workspace Presets

Photoshop is a complicated program; the more you learn, the
more complicated (and routine) your activities become. For
one project, you may find yourself using the Styles palette
repeatedly to add special effects to layers. For your next proj-
ect, you may never use the Styles palette but require frequent
access to the Paths palette to create curves that you use to
make selections. And so it goes. Use custom presets to save
time and effort, or to instantly clean up a messy desktop.

Custom workspaces come in handy if you share a computer
with students, family members, or coworkers. Those who pre-
pare images for both Web and print have different needs that
may call for special workspaces, too.
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You can create customized workspace presets that handle all these needs and a great deal
more. Here are some of the ways you can tailor your workspace:

v Combine palettes to group the ones you use most often together. (For more informa-
tion on arranging palettes, see Book I, Chapter 1.) Drag a palette’s tab into another
palette group to add it to that group. If the Layers, Channels, and History palettes are
the ones you use most often, you might want to group them together. You can also hide
palettes that you rarely use for a particular project, tuck them away in the Palette Well,
or minimize them to their title bars.

Move a palette out of the way quickly by Shift+clicking its title bar. The bar snaps to the
nearest screen edge.

Before saving your workspace preset, show or hide the palettes as you prefer them and
move them to the locations you want on your screen.

v Position dialog boxes. Photoshop’s menu bar dialog boxes pop up in the same location
they appeared the last time you used them. You may want to drag them to a specific
place on your screen and store that location when you save your workspace preset.
When I’'m working with a large image, [ sometimes position dialog boxes on the screen
of my second monitor to maximize the area for the image on my main display.

v Customize the Options bar. You can grab the gripper bar at the left edge of the Options
bar and drag it to another location. For example, you can dock the bar at the lower edge
of your screen or have it float in a specific place on your Photoshop desktop. You can also
double-click the title bar of the floating Options bar to collapse it so that only the active
tool’s icon is showing. Photoshop stores these settings with your workspace preset.

Saving and Deleting Presets

After you’ve set up your workspace, you can save it by choosing Windowr>Workspacer>Save
Workspace. In the Save Workspace dialog box that appears, type a name for your saved work-
space and click the Save button. Your saved workspace now appears as a listing on the
Workspace submenu.

To delete a saved workspace, choose Windowr>Workspacer>Delete Workspace. In the Delete
Workspace dialog box that appears, choose the name of the workspace you want to remove
from the drop-down list. Click the Delete button, and your preset is gone, gone, gone.

Setting Your Preferences

Photoshop stores settings for many different options in a Preferences file on your hard drive.
The first time you run Photoshop after a new installation, you probably want to customize
Preferences to suit your own needs.

You can access the Preferences dialog box by choosing Edit=>Preferences (Photoshop=>
Preferences on the Mac). You can also press Ctrl+K (8+K on the Mac). The General
Preferences dialog box (shown in Figure 6-1) pops up by default, but you can choose any of
the other Preferences dialog boxes from the drop-down list. You can also move between the
dialog boxes by clicking the Prev or Next buttons that appear in each of the Preferences
dialog boxes. The next several sections give you a rundown of what you can do with the
settings in the different Preferences dialog boxes.



Setting Your Preferences

The ghost in your machine

From time to time, you may discover that
Photoshop has inexplicably trashed your prefer-
ences and reset all your settings to their default
values. Your first clue that this has happened may
be when you open the program and find the
palettes arrayed neatly on the right side of the
workspace in an arrangement you’'d never use.

Surprise! An impossible-to-trace, tiny fault (think
bug) or unexpected behavior (either in Photoshop
or your operating system) has confused Photo-
shop to the extent that the program has wisely
decided to reset your preferences rather than con-
tinue with (possibly) corrupted settings.

©)

When the General Preferences dialog box is visible, you can switch to the other Preferences
dialog boxes by pressing Ctrl+1, Ctrl+2 (88+1, 88+2 on the Mac), and so forth. These short-
cuts can be useful if you need to frequently access particular dialog boxes.
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Setting general preferences

The General Preferences dialog box is where you select some options that are, well, general in
nature. You can select some choices from drop-down lists, and others are check boxes you
can select or deselect to activate or disable that option. Here’s a rundown of options in the
upper part of the dialog box:

v Color Picker: Choose the familiar Adobe Color Picker to select precise colors or work
with the Windows or Macintosh system color pickers, as desired. You might want to use
the Windows color picker, for example, if you've previously defined some custom colors
outside of Photoshop and now want to make them available for a Photoshop project.
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7

Image Interpolation: When Photoshop resizes an image, it must either create new pixels
(when making the image larger) or combine existing pixels (to make the image smaller).
To do this, the program examines neighboring pixels and uses the information to derive
the new or replacement pixels. You can select the type of mathematical algorithm
Photoshop uses to do this. The Image Interpolation drop-down list offers these options:

Nearest Neighbor (Faster): This is the fastest (and lowest quality) interpolation
method, under which Photoshop examines only one pixel to perform its calculations.
Use this method only if your work is not critical and your computer is relatively slow.

Bilinear: This choice provides better quality and is almost as fast as Nearest
Neighbor. With this method, Photoshop looks at pixels above, below, and on either
side of the pixel being processed (four pixels in all).

Bicubic (Better): This option is a new and improved version of the old Bicubic
method. Most users will want to stick this option, which is the default setting.
Photoshop takes a little longer to perform its calculations but generates an opti-
mized pixel after looking at 8 surrounding pixels — one above, one below, two on the
sides, and four in the corners.

Bicubic Smoother: Like Bicubic, but provides the maximum amount of softening
between pixel edges. A good method when upsampling, or enlarging, an image. Can
slightly affect the sharpness of the resulting image.

Bicubic Sharper: Again, like Bicubic, but applies just a little softening to pixel edges.
This is a good method when downsampling, or reducing the size, of an image.

For more on interpolation, see Book I, Chapter 1.

History States: Photoshop remembers how your document looks at various stages of
editing, storing all the image information on your hard drive and listing the individual
states in the History palette. (For more information on using the History palette, see
Book II, Chapter 4.) Keeping track of every change you make requires lots of memory
and hard drive space, so you can specify how many resources to use by typing a value
into this box. The default is 20 (the max is 1000). If you have resources to burn and fre-
quently find yourself stepping way back in time to modify or delete a step, you can type
a larger number. If your resources are skimpy and you don’t anticipate making many
changes to earlier steps (or are willing to take frequent snapshots or save interim
images), you can enter a smaller number.

In the Options section of the General Preferences dialog box, you find nearly a dozen check
boxes that you can select or deselect, as described in the following list:

1V

Export Clipboard: When this feature is active, Photoshop transfers its private clip-
board (used only within Photoshop) to the general Windows or Macintosh Clipboard so
that you can paste information into other applications. If you activate this option,
switching from Photoshop to other applications takes a little longer, and Photoshop’s
clipboard contents replace whatever was in your system Clipboard when you switched.

The clipboard is generally a poor vehicle for moving image data between applications
because the transferred information may not be of the best quality. Instead, save your file
and open it in the other application. If you do this, you can turn off the Export Clipboard
option, saving you some time when switching between applications.
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v Show Tool Tips: Photoshop can display little pop-up reminders about tools and other Book
objects on your screen. If you find these reminders distracting, deselect this check box I
to turn off Tool Tips. Chapter

6

v Zoom Resizes Windows: Select this check box if you want your document windows to
grow and shrink to fit your document as you zoom in and out. Deselect this check box
if you want the document’s window to always remain the same size; you might want to
deselect the check box if you frequently work with several documents side by side and
don’t want them to change relative size as you zoom in and out.

v Auto-update Open Documents: When you're working on an image and move to another
application (such as ImageReady) to work on the same image, you’ll probably want the
changes made in the other application to be reflected in the document still open in
Photoshop. Select this check box so that Photoshop will monitor the document and
update its version whenever the document is changed in the other application.

v Show Asian Text Options: Although Photoshop supports Chinese, Japanese, and
Korean text, this option is off by default. You can activate it here so that Asian text
options become available as you work.

v Beep When Done: [ remember the bad old days when Photoshop would take a minute
or two to apply the Gaussian Blur filter or perform calculations when merging even
moderate-sized image layers. Photoshop wasn'’t inefficient; computers a decade ago
were really slow compared to those available today. The Beep When Done signal was
my cue to stop watching television and resume working with Photoshop. Although most
operations are a lot faster today, if you’'re working with very large images or simply like
to be notified when a step is finished, the beep option can be useful (or incredibly
annoying to your coworkers).

v Dynamic Color Sliders: The sliders in the Color palette change colors to match the set-
tings you make. If your computer is on the slow side, you can turn off this feature to
improve performance.

v Save Palette Locations: Select this check box if you want Photoshop to restore your
most recent palette locations the next time you start up. Deselect this check box if
you always want your palettes in the same location each time you begin working.

v Show Font Names in English: If you've selected the Show Asian Text Options check
box, Photoshop can display font names in Chinese, Japanese, or Korean by turning
this option off. Activate this option if you want font names displayed only in English,
regardless of the other Asian text options you’re using.

v Use Shift Key for Tool Switch: When this feature is active, you can change from one
tool in the Tools palette to another in the same group (say, to change from the Gradient
tool to the Paint Bucket tool) by pressing the Shift key and the keyboard shortcut for
that tool.

v Use Smart Quotes: Love ’em or hate '’em, you can instruct Photoshop whether to use
smart (curly) quotes or plain (straight) quotes with this option.

v History Log: You can have Photoshop record all your editing commands.

{TW This new feature is handy if you want to present a finished, fully edited image to a client or man-

|00/

&V :IE ager, but need to be able to show the steps of how you got there. Or maybe you want a record
- of the steps, so you can repeat them on other images and don’t want to rely on your memory.
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You have a few formats in which you can save your edit history log:

Metadata: Saving the log to metadata (information embedded in your image file)
allows you to view the log in the File Browser window. For more on the File Browser,
see Book [, Chapter 5.

Text File: You can save the log to a text file. Click the Choose button to provide a
name and location for the file.

Both: This option saves the log as both metadata and a text file.

Edit Log Items: You choose Sessions Only, Concise, or Detailed. The Sessions Only
option records your editing until you close the file or quit Photoshop. The Concise
option keeps a comprehensive log (multiple sessions), but in short and sweet steps.
The Detailed option provides a comprehensive, detailed log. For example, a concise
log entry may be just Crop, whereas a detailed log entry may be Crop. To rectan-
gle and then also provide the original and cropped dimensions, the angle and the
resolution values.

v Reset All Warning Dialogs: If you've turned off the display of certain warnings by
selecting the Don’t Show Me This Dialog Box Again check box, you can reactivate all the
warnings by clicking this button.

Deciding how you want files handled

The options in the File Handling Preferences dialog box, shown in Figure 6-2, control how
Photoshop handles files as they are opened and closed. Here’s the lowdown on these options:
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Image Previews: Storing a preview thumbnail with an image can speed up browsing for
the image you want. You can tell Photoshop to save a preview by default or to ask you
first (in case you want to create images that are a little smaller in size, especially for the
Web). Or you can also choose not to ever save a preview. Mac users need to select the
kinds of image previews they need. Select the Icon option to enable an image icon to
appear on the Desktop. Select the Macintosh Thumbnail option to see a preview in the
Open dialog box. Select the Windows Thumbnail option to see a preview in a Windows
OS. Finally, select the Full Size option to save a low-resolution version of the file to use
in applications that can open only low-resolution (72 ppi) Photoshop images.

File Extension: You can select whether the file extensions appended to filenames (such
as .psd, .tif, and so forth) are consistently uppercase or lowercase, as you prefer. On
Macs, you can choose whether to add extensions by selecting from the Always, Never,
or to Ask When Saving options. If you want cross-platform compatibility with PCs or
prep Web graphics, select the Always option. Mac users, select the Use Lower Case
option to save extensions as lowercase characters.

Ignore EXIF sRGB tag: When this option is selected, Photoshop ignores the sRGB tag
that many digital cameras add to their EXIF (camera) data. The sRGB tag is widely used,
but not well respected among many high-end digital photography professionals.

Ask Before Saving Layered TIFF Files: Photoshop can save an advanced type of TIFF
file that includes layers, exactly as with its own native PSD files. However, many applica-
tions cannot read these files. If you always open TIFF files in Photoshop and don’t mind
creating larger TIFF files in the process, you can disable this option. Otherwise,
Photoshop asks you for confirmation each time you want to save a TIFF file that con-
tains layers.

Enable Large Document Format (. psb): Photoshop can now create documents up to
300,000 x 300,000 pixels. You can save these humongous files as TIFFs (up to 4GB) or in
the new . psb or Photoshop Raw formats, with no limitation in size.

Maximize PSD File Compatibility: Photoshop now lets you choose an option for file
compatibility.

Not all applications can handle the more sophisticated features that may be stored in a PSD
file (such as fancy layer effects). If you frequently open PSD files in applications other than
later versions of Photoshop, you may want to set this option to Always. Keep in mind that
you may lose some features when you do this. Choose Ask to have Photoshop prompt you
when you save a file as to whether you want the option. Or select Never to ignore the option
completely.

When you maximize compatibility, Photoshop saves a composite (flattened) version
along with the layered file to ensure that older applications (such as Version 2) can read
the files. However, this option also makes your file size balloon enormously. In addition,
when you save in this mode, you get an annoying warning that your file may not be read
by future versions of Photoshop. This silly warning appears every time you save a lay-
ered PSD file.

If you plan to use your PSD files in InDesign or lllustrator, you need to have the maximize
compatibility feature turned on because those programs need to have a composite along
with the layers.
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v Enable Version Cue: Select this option if your computer is located on a network and
you need to share your files with others in your workgroup by using a server.

v Recent File List Contains: Type a value from 0 to 30 to specify the number of recently
used files you want displayed in the Recent File list on the File menu.

Adjusting your display and cursors

This Display & Cursors Preferences dialog box, shown in Figure 6-3, enables you to set several
options that control how cursors display on-screen and three display parameters that may
affect how quickly your computer completes an operation. The following list describes these
options:
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v Color Channels in Color: When selected, this option tells Photoshop to show each of
the color channels (for example, red, green, blue or cyan, magenta, yellow, and black) in
their respective colors in the Channels palette. In most cases, you won’t want to use
this feature. You need to be able to see the channels in their grayscale form to perform
image-editing tasks such as converting from color to grayscale, channel masking, or for
selective sharpening on certain channels.

v Use Diffusion Dither: This option is a holdover from the days when those working with
images sometimes used graphics cards and displays that could show only 256 different
colors. With this feature active, Photoshop simulates all the colors in an image by creat-
ing mixtures of the 256 available colors in a pattern that the human eye automatically
merges together. You can use this option to work with full-color, 24-bit images in 256-
color viewing mode. However, any computer that meets the specs needed to run
Photoshop should be able to operate in full-color display mode.
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v Use Pixel Doubling: Many dialog boxes and tools have preview windows that show the Book
effect of the settings you're working with. With this feature active, Photoshop doubles I
the size of the pixels in the preview only, reducing the resolution of the preview but Chapter
speeding display. 6

v Painting and Other Cursors: Choose the Standard option to show a tool’s cursor as an
icon representing the tool itself (although I don’t know why you’d want to do this). Use
Precise to switch to a cursor that has crosshairs, which is useful for positioning the
center of a tool’s operational area in a particular place. Brush Size (available for painting
tools only) tells Photoshop to show the cursor in the same size as the brush itself. Most
users prefer to set the painting cursors to Brush Size and the other cursors to Precise.
Some folks do complain that precise cursors are hard to see against some backgrounds,
but you can always press the Caps Lock key to toggle precise cursors on or off.

Adjusting transparency and gamut

Photoshop uses colors and patterns to represent information about an image that is

normally invisible, such as areas that are transparent, or parts of an image that contain colors
that cannot be represented by your current display or printing system. The Transparency &
Gamut Preferences dialog box, shown in Figure 6-4, enables you to tailor these displays to
your own preferences.
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For example, transparency is typically shown on the screen by using a gray-and-white
checkerboard pattern. You can change the pattern and colors if you prefer another type of
display.
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Here is a rundown of the options you find in this dialog box:

v Grid Size: You can choose small, medium, large, or no grid at all. You may want to

switch from the default medium-sized grid to a large grid if you're using a very high-
resolution setting (such as the 1920 x 1440 pixel setting I use on my monitor) so the grid
is a little easier to see. (I don’t bother with this, myself.) Or you can switch to a smaller
grid if you’re working at a 640 x 480 or an 800 x 600 resolution.

Grid Colors: The default light grid is the least obtrusive, but you can switch to a
medium or dark grid if you want. Also, you are not limited to gray-and-white checker-
board squares. To choose custom colors, double-click the white and gray squares
below the Grid Colors list.

Use Video Alpha: If you have a video board that supports chroma keying, select this
option to be able to view video in the transparent portions behind a layer.

Gamut Warning: You can adjust the color used to represent out-of-gamut colors and to
specify the transparency for the warning color. Double-click the Color box to set the
hue and choose the transparency with the Opacity slider. The gamut warning is gener-
ally used before converting RGB images to CMYK to see which colors will be lost. For
more information on color gamuts, see Book II, Chapter 2.

colors generally are those that can’t be represented by cyan, magenta, yellow, and black and,

@ A gamut is the range of colors that can be displayed or printed. In Photoshop talk, out-of-gamut

therefore, can’t be printed. To turn gamut warnings on or off, choose Viewr>Gamut Warning.

Setting measurement preferences

In the Units & Rulers Preferences dialog box, shown in Figure 6-5, you can set the units used

to measure things on-screen (inches, pixels, millimeters, and so forth) and to define a default
column size when typing text in multiple columns. In addition, you can define the resolution of
the image when you choose Filem>New and select Default Photoshop Size from the Preset Sizes

list. (See Book I, Chapter 3, for more on preset sizes.)
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In the Units area of the dialog box, you find these options: Book
v Rulers: Select the measurement units Photoshop uses for rulers. Your choices are Chapter
pixels, inches, centimeters, millimeters, points, picas, or percent. The most popular 6

sizes are inches and millimeters, but if you're working with publications and specifying
in picas, you might prefer that increment instead. If you're prepping Web graphics, you
may prefer to have your rulers incremented in pixels.

v Type: Choose the measurement used to represent the dimensions of type. Point size is
almost universally used, but pixels and millimeters are also available. You may want to
use pixels if you're trying to fit type into a specific-sized area of an image.

In the Column Size area, you can specify the following:

v Width: The width of the column in inches, centimeters, millimeters, points, or picas.
v Gutter: The width of the area separating columns, also in inches, centimeters, millime-
ters, points, or picas.
In the New Document Preset Resolutions area, you can set the following:
v Print Resolution: The default is 300 pixels per inch, a good setting to keep. You can
change to another value and use pixels per centimeter as a measurement if you want.

v Screen Resolution: Generally, 72 pixels per inch works with most images that will be
prepped for screen viewing. You can select another resolution and use pixels per cen-
timeter if you like.

image and degrade quality. It's best to choose the final resolution you want when you create
a document, whether you specify the resolution manually or use these presets.

Changing the resolution of an image after it's been created can impact the sharpness of your

In the Point/Pica Size area, you can choose whether you want to use a measurement of 72
points per inch (which first became relevant in the Macintosh realm and spread as desktop
publishing became widespread) or the traditional 72.27 points per inch definition used in the
precomputer era. Unless you have a special reason to choose otherwise, use the Postscript
(72 points per inch) option.

Setting up guides, grids, and slices

Guides are nonprinting lines you can create on your screen to make it easier to align objects.
Grids are vertical and horizontal lines in the background that make lining up objects even easier.
Slices are sections of an image you can create for Web page graphics so that each slice can be
loaded and treated separately (usually in a table or similar arrangement). For more information
on using grids and guides, see Book I, Chapter 5. For a full explanation of slices, check out

Book IX, Chapter 3. Figure 6-6 shows the Guides, Grid & Slices Preferences dialog box.
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Figure 6-6
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In the Guides area, you can set these options:

7

Color: Either select a color from the drop-down list or click the color sample swatch to
choose your own color. You may want to change the default color if that color is too
similar to a dominant color in your image.

Style: Select from lines or dashed lines. If you work with images that contain many hori-
zontal and vertical lines that extend across most of an image, dashed lines may be more
visible.

In the Grid area, these are your options:

1V

7
1V
1V

Color: Select a color from the drop-down list or click the color sample patch to define
a specific hue.

Style: You can choose lines, dashed lines, or dots.
Gridline Every: Choose the distance between gridlines.

Subdivisions: Select the number of subdivisions for each gridline.

In the Slices area, these are your choices:

"

1V

Line Color: From the drop-down list, choose a color for the lines that surround
each slice.

Show Slice Numbers: If you select this check box, Photoshop adds a slice number to
the display of slices, which makes it easier to keep track of individual slices.



Plug-Ins and Scratch Disks

Plug-Ins and Scratch Disks

Plug-ins and scratch disks are a couple of unrelated options combined in a single dialog box,
shown in Figure 6-7. Briefly, plug-ins are mini software programs that add features to
Photoshop. Scratch disks are free areas on your hard drive(s) that Photoshop uses as virtual
memory when it is short on RAM. Read on to find out more.
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The Plug-Ins folder is where Photoshop stores all your filters and other plug-in add-ons. A
default folder is created when you install Photoshop.

Photoshop allows you to specify an additional folder to search other than its own Plug-Ins
folder. This additional folder may come in handy if you want to keep your third-party add-ons
separate from Photoshop’s native plug-ins. An auxiliary plug-ins directory (not nested within
Photoshop’s own Plug-Ins folder) can simplify managing those extra filters, and you can turn
off their use (potentially speeding up Photoshop’s load time) by deselecting the Additional
Plug-Ins Folder check box in this dialog box. You can also use this option when you have some
plug-ins installed for another application and want to share them with Photoshop without
having to make extra copies in your Photoshop Plug-Ins directory.

To activate a new plug-ins directory, select the Additional Plug-Ins Folder check box and then
click the Choose button. In the dialog box that appears, navigate to the folder you want to use
and select it. Click OK. You then need to exit Photoshop and restart the program to activate
the new directory.
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the plug-in or folder name. Photoshop will ignore the plug-in(s) or folder(s) specified. Just
remove the tilde from the name to activate the plug-in or folder. This can come in handy if
you are having a program glitch and want to deactivate your plug-ins to troubleshoot
whether or not they are causing the problem.

E s If you have a plug-in or folder you'd like to deactivate, use a tilde (~) as the first character of

Scratch disks

Scratch disks are areas on your hard drive that Photoshop uses to substitute for physical
RAM when you don’t have enough RAM to work with the images you have opened. Scratch
disks are no replacement for physical memory, but there are many times when Photoshop
will need them, even if you have huge amounts of memory.

Photoshop uses your startup drive (the drive used to boot your operating system) as its first
scratch disk by default. That may not be the best choice because your startup drive is usually
pretty busy handling requests of your operating system and, if you're running Windows,
requests for Windows’ own virtual memory scheme (your so-called swap file or paging file).
Ideally, your scratch disk(s) should be a different hard drive and, preferably, the fastest one
you have available.

If you have more than one hard drive, choose one other than your startup drive as your first
scratch disk. Select your fastest drive; for example, select a FireWire (IEEE 1394) or USB 2.0
drive over one using the original, slow, USB 1.1 connection. If you have an Ultra-DMA EIDE
drive or, better yet, a SCSI drive, use that. Although Ultra-DMA drives have transfer rates that
rival even the speediest SCSI models, SCSI can be better because the SCSI bus is designed for
multitasking. You’ll often get better performance than with an EIDE drive that shares one of
the two EIDE channels with other devices.

a partition on an existing drive for use as a scratch disk. Remember to keep the scratch disk
defragmented (that is, with the files all organized together on your hard drive) by using your
favorite defragmentation utility. See Book I, Chapter 1, for information on how you can moni-
tor how much scratch disk space you have available and how it is being used.

@ If you don’t have a second hard drive, you can improve scratch disk performance by creating

ins that require a valid Photoshop serial number, you can enter the serial number from an

@ Adobe changed the format for serial numbers with Photoshop 7, and if you have old plug-
older version into the space provided in this dialog box.

Changing Memory and Cache Settings

The perennial question: How much memory does Photoshop require? The perennial answer:
As much as you can cram into your computer! Memory is so inexpensive right now there’s no
excuse for not having at least 512MB of RAM, and more is even better if you're using an oper-
ating system that can handle extra memory efficiently, such as Windows XP and Mac OS X.

When you’ve crammed your RAM, you’ll want to make sure Photoshop can use as much as
you can spare. You can use the Memory & Image Cache Preferences dialog box, shown in
Figure 6-8, to allocate your memory.
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Managing memory

Here’s how to allocate RAM:

1.

Choose Edit~>Preferences>Memory &
Image Cache.

The Memory & Image Cache
Preferences dialog box opens.

In the Memory Usage area, change
the Maximum Used by Photoshop
parameter.

Use a value of 50 to 80 percent,
depending on how much memory you

)

Setting aside memory for storing screen images

have to waste. Allocating more to
Photoshop reduces the RAM for other
applications, so if you have other pro-
grams that need lots of memory,
choose a prudent value.

Click OK to apply the option.

Exit Photoshop and relaunch the pro-
gram to activate the new setting.

You can also set aside the amount of memory for storing screen images in the Memory &
Image Cache dialog box, to speed up redraws of a reduced-view image on your screen as you
make changes. You have two options. You can specify the number of copies of your image
stored in memory, from the default value of 4 up to 8 levels. You can also set aside cache
memory for drawing histograms (brightness graphs produced by the Levels command) if you
use histograms frequently.
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Setting File Browser Preferences

f_? Photoshop cs has added a new set of preferences for the File Browser. These preferences
&Vm ifw enable you to customize how the newly souped-up File Browser processes and displays your
> images. For details on setting the File Browser preferences, see the section, “Managing
Images with the File Browser,” in Book I, Chapter 5.

Using the Preset Manager

Many of the palettes and tools Photoshop works with can use settings that you store on your
hard drive as presets. For example, you can create custom colors and brush tips, build your
own gradients, create a library of shapes, or compile a set of styles to apply to layers.

You’ll want to become familiar with the Preset Manager, which provides a central management
tool for all the options that are individually available from the palettes and tools themselves.
Just as with the tools, you can select, edit, and delete presets. The only thing you can’t do
with the Preset Manager is actually create a preset. You must do this with the Tool Preset
picker or Tool Presets palettes. For more details, see Book I, Chapter 2. Here are some tips on
using the Preset Manager, shown with its pop-up menu in Figure 6-9:
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To show the Preset Manager, choose Edit=>Preset Manager. To hide it, click Done.

v To select a specific type of preset to work with, choose it from the Preset Type drop-
down list.

v To modify a preset, choose the option from the pop-up menu available in each preset’s
dialog box. Click on the right pointing arrow to the left of the Done button to access the
preset pop-up menu.
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Customizing Keyboard Shortcuts

To load an existing set of presets from your hard drive, click the Load button and navi-
gate to the presets you want to access. You can also choose a preset library listed

under the pop-up menu of each preset type.

To store a new or modified group of settings, click the Save Set button and type a name.

To give a particular preset a new name, select the setting in the dialog box, click the

Rename button, and type the new name.

You can rename multiple settings consecutively by clicking and Shift+clicking the items to
be renamed and then clicking the Rename button. Photoshop asks you to supply a new

name for each, in turn.

To quickly load the default preset library for any tool or palette, choose Reset [name]
Preset from the Preset Manager pop-up menu. You can also replace your current Preset

library with another.

Different preset display options are available on the Preset Manager pop-up menu.

Customizing Keyboard Shortcuts

B NEW
\v,,,.

1

For those of you who are like me — | avoid using a mouse and prefer the ease and speed of
keyboard shortcuts — Photoshop now offers customizable keyboard shortcuts. You can
assign shortcuts to menu commands, palette commands, and tools. You can edit, delete, or
add to the Photoshop default set or create your own custom set. Here are the steps to work

with keyboard shortcuts:
Choose Edit->Keyboard Shortcuts.

For those who have good manual dex-
terity, you can also press
Alt+Shift+Ctrl+K (Option+Shift+88+K).
The Keyboard Shortcuts dialog box
appears, shown in Figure 6-10.

Choose between the Photoshop
Defaults set or create a new set by
clicking the New Set button (the dog-
eared page icon) in the upper-right
corner of the dialog box.

Clicking New Set makes a copy of the
selected set for you to then edit and
customize. If you choose a new set,
name the set (leaving it with a . kys
extension), and keep it stored in the
Keyboard Shortcuts folder.

Choose Application Menus, Palette
Menus, or Tools from the Shortcuts
For drop-down list.

4. Select your desired command from
the list. Type in the shortcut keys you
want to assign to that command in the
shortcut field. If you type a keyboard
shortcut that is already assigned to
that command, you can simply type
over it.

As you well know, Photoshop often has
multiple ways of accessing the same
command. For example, you can create
a new layer by using the Layers palette
pop-up menu or buttons or by choos-
ing the menu command Layer=>Newr>
Layer. Therefore, you may get a warn-
ing that your chosen command and
another command on another menu
must have the same shortcut and

that changes will be applied to both
commands.

CONTINUED
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If the keyboard shortcut you type is
already being used, Photoshop warns
you that if you accept the shortcut, it
will be removed from the original
command.

Click Accept or Undo. You can also
click the Add Shortcut button.

If you later change your mind and want
to use the original keyboard shortcut
(if there was one), click Use Default. If
you decide you don’t want the shortcut
at all, click Delete Shortcut. And if you
make a mistake, just click Undo.

Figure 6-10
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Application and Palette menu commands
must include a Ctrl (38 on the Mac) and/or
an F key in the keyboard shortcut.

ﬂ When you finish, click the Save Set

button (the disk icon).

If you want to delete the set, click the
Delete Set button (the trash icon).

Click the Summarize button to save

8.

Keybioad Shortcuts

the keyboard shortcut set as an .htm
file, which will load in your Internet
browser. You can then print the file
and keep it as a handy reference of
your shortcuts.

Click OK to exit the dialog box.
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Specifying Size
and Resolution

In This Chapter

v~ Pixel versus vector images

v~ Working with the Image
Size command

v Resizing with the wizard
v Adjusting the canvas size

v~ Cropping an image

a pixel-based (or raster) application designed primarily for

print, it has been transformed into a program capable of
both vector- and pixel-based output with added features aimed
at producing Web content as well.

Photoshop has evolved into a Swiss Army knife. Once only

You need to be aware of important issues when you produce both
pixel-based and vector-based graphics. I give you a bit of back-
ground in that department in this chapter. Also, [ show you the
components that make up the physical aspect of your pixel-based
image — the dimensions, the file size, and the resolution — and
how they relate to one another.

Even though Photoshop can now produce vector graphics,
its primary mission is to create awe-inspiring raster images.

And because the issue of resolution is so critical to raster

images, this chapter primarily discusses methods for sizing

and resizing raster images. | cover producing vector art in
more detail in Book IV, Chapter 2.

You find out how to change any of the three components with-
out harming your image. Yes, you can harm your image. Not
intentionally, of course. But it can happen quicker than you can
close a dialog box. But with a firm understanding of how pixels
live and breathe, you can ensure that your images are safe from
any undue damage.

Putting Images under the Microscope

Digital images fall into two camps, vector images, which are cre-
ated based on mathematical formulas, and raster images, which
are made up of pixels. Photoshop allows you to produce both
types of images and even to combine both types within a
single file.
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Table 1-1 gives you the skinny on vector and raster images. For the details, keep reading.

TaBLE 1-1: CHARACTERISTICS OF VECTOR AND RASTER GRAPHICS

Graphic  How It Works File Size Image Resolution
Type Degradation Dependent?
Possihle?
Vector = Mathematical formulas precisely locate and Usually No No
connect geometric objects and segments smaller
Raster Breaks pieces of an image into a grid made up Usually  Yes Yes
of pixels larger

Vector images

One cool thing about vector images, also called object-oriented images, is that when you
zoom in on them, they don’t look blocky. That’s because vector images are comprised of
segments — curved or straight — and anchor points — elements that indicate the endpoints
of the segments — that are defined by mathematical objects called vectors. Vectors use a
unique mathematical formula to define the specific location of an object as well as its
geometric shape.

Vector images are usually the product of drawing programs, such as Adobe Illustrator, but

Photoshop is also capable of producing a vector or two. And not to be outdone, its cousin

[llustrator can also rasterize (or convert into pixels) vector artwork, thereby providing you
with raster images to work with.

Here is some additional information about vector graphics:

v A curve is still a curve, even at 20,000 feet. Because they are mathematically defined,
vector graphics can be sized and otherwise transformed without an inkling of quality loss.
Take that little 2-inch spot illustration and size it up to mural size, and it appears identical.
A perfect true curve remains a perfect true curve, whether it’s 2 inches or 20 feet long.

* You can get pretty pictures in small packages. Vector images can be small in file size
because the file size depends on the complexity of the vector objects, not the size of
the illustration.

Graphics that need clean lines, such as logos, typographic illustrations, and line art, work
great in vector format, such as my logo, shown in Figure 1-1.

v Vector images are independent — resolution independent, that is. Not only can they
be transformed and printed without a degradation in quality, but they also have no
built-in resolution — they take on the resolution of the output device. For example,
print my logo in Figure 1-1 to an imagesetter (a high-end printing device used for color
separations) at 2400 dots per inch (dpi), and the image comes out at 2400 dpi. Print it to
a 300 dpi laser printer and what do you get? A 300 dpi image. (If all this technical lingo
like imagesetter and dpi is confusing, it might help to skim over Book X, Chapter 2.)

Because your monitor can display images only on a grid, vector images display on-screen as
pixels. This accounts for the jagged appearance you see when you zoom into a curved
vector object. But don’t worry; it will print just fine.
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Raster images

Raster images are usually the result of the digitizing of continuous-tone images, such as
photographs or original painted or drawn artwork. Raster images are comprised of a grid of
squares, which are called pixels. Pixel is short for PICture Element and is the smallest compo-
nent of a digital image. If you've ever looked at a bathroom wall made up of those small square
tiles reminiscent of the '40s, you're familiar with what a grid of pixels looks like: Each pixel
lives in a specific location on that grid and contains a single color. When you edit a bitmap
image, you are editing one or more pixels rather than an object-oriented shape.

Although it doesn’t seem like it when you’re viewing an image that fits inside your computer
screen, your entire image can be broken down into a grid of square pixels. That means the
elliptical shapes of my beanie, shown in Figure 1-2, also have to fit within this system of
squares. But how do you fit a round peg in a square hole? By faking it. Unlike the true
mathematical curve possible when drawing vector shapes, raster images must try to
approximate a curve by mimicking the overall shape with square pixels.

Fortunately, the mimicry the pixels have to do is indecipherable with high-resolution images
viewed at a reasonable distance. But when you zoom in, you can see that a curve in an image
(like the curve of my beanie) is indeed comprised of square pixels. Raster graphics work great
for photorealistic or painterly images where subtle gradations of color are necessary. On the
downside, because they contain a fixed number of pixels, raster graphics can suffer a degrada-
tion of quality when they’re enlarged or otherwise transformed. They are also large in file size.
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Figure 1-2
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Bitmap images are resolution dependent. Because they contain a fixed number of pixels, the

resolution of the device they are being printed to is only one of two factors that influence the
quality of the image. The quality of the output also depends heavily on the resolution of the
image. For example, an image with 72 dots per inch (dpi) doesn’t look any better printed on
a 600 dpi printer than it does on a 1200 dpi printer. Likewise, a 300 dpi image doesn’t look
as good printed on an old 72 dpi dot matrix printer as it does on a 1200 dpi printer.

Viewing Raster Images On-Screen

Resolution really doesn’t play a role in how you view images on-screen. The display of images
on-screen is based on 1 image pixel per 1 screen pixel.

The most important issue, then, is making sure that your image fits inside your (or your
audience’s) monitor when viewed at 100%. This is where pixel dimensions come into play —
especially if you're putting images on the Web.

When you view an image on-screen, the display size is determined by the pixel dimension,
@ plus the size and setting of the monitor. You therefore need to determine the demographics
of your audience and then size your graphics accordingly.
v A 17-inch monitor probably displays 1024 by 788 pixels. An 800 x 600 pixel image fills
part of the screen. Change the monitor setting to 800 x 600, and the image fills the
screen, with each pixel appearing larger.

On a 15-inch monitor, an 800 x 600 pixel image fills the screen. But a 1024 x 768 image
can’t be viewed in its entirety.

You may also hear monitor resolution being referred to in graphic display standards, such as
VGA (640 x 480 pixels), XGA (1024 x 768 pixels), UXGA (1600 x 1200), and so on.



Resolution is measured in pixels per inch, or

Viewing Raster Images On-Screen

ppi. You may also run across the term samples

per inch (spi). Another term you will see often is dots per inch (dpi). Dots per inch is always
used in reference to printers, scanners, imagesetters, and other paper-outputting devices.
You may hear people refer to dpi as printer resolution.

Resolution, dimension, and size in raster images

Every raster image has these physical attributes —
resolution, dimension, and size. Size takes on two
personalities. You have the file size, which is a
result of the pixel dimensions, and you have print
size, which is the width and height of an image.
These attributes are interrelated. Change any
one and at least one of the other attributes is
affected also.

The file size of a raster image is determined by
the pixel dimensions — the number of pixels
along the height and width of the image. The fol-
lowing figure shows a Photoshop dialog box that
lists all the vital statistics of an image that takes up
176K of space and is 200 pixels wide and 300
pixels high. Just multiply these values:

200 x 300 = 60,000 pixels contained in the
image

How do 60,000 pixels lend a file size of 176K?
60,000 x 3 = 180,000
180,000 + 1024 = 176

There are 3 bytes in a 24-bit color image. Multiply
3 bytes by 60,000 pixels, and the result is 180,000
pixels. Divide 180,000 pixels by 1024 bytes per
kilobyte, and you get the file size value of 176K.

Remember: These are the basics that affect file
size, but other factors contribute to size as well,
such as layers and channels. For more on layers,
see Book V, and for details on channels, see
Book VI.

Resolution is usually measured in pixels per
linear inch (ppi), although it can also be meas-
ured in pixels per millimeter. The image in my
example has a resolution of 120 pixels per inch
(ppi), or 14,400 pixels, which just happens to be
120 x 120, or 120°.

The dimensions of an image are its width and
height when it is printed. To calculate these
dimensions, all you have to do is divide the
number of pixels by the image’s resolution:

200 + 120 ppi = 1.667 inches (image width in
print)

300 =+ 120 ppi = 2.5 inches (image height in
print)

Another way of calculating how much resolution
an image requires is by multiplying the desired
print size by the printer resolution. In other words,
to print a 5-x-7-inch image at 300 dpi requires a
resolution of 1500 x 2100 pixels per inch.

Document Size
Width 1.667
Height .5

Resolutior

Resample Image

Imagre 212¢
Pixel Dimensions: 175.8K f o A
Width: 200 pixels Cancel
Height 30K pixels Auto

inches v
o]
inches . ]
5l

pixels /inch 'y
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You’ll see recommended resolution settings somewhere between 72 ppi and 96 ppi even
though resolution isn’t really a factor in preparing screen images. That’s just because moni-
tors display somewhere in the 72 to 96 ppi range. So if you change the physical dimensions of
an image, then it is always at a one to one ratio with the monitor. If you view an image whose
resolution is higher than that of the monitor, the image appears larger on-screen than in its
printed state. For example, try opening (or dragging and dropping) a 300 pixel-per-inch (ppi)
JPEG file into a browser window. It explodes on your screen. Because the monitor can display
only 72 to 96 ppi, it needs a ton of space to show all the pixels in the image.

Using the Image Size Command

A time will come when you need to mess with the resolution or dimensions of an image. You
may want to change the file size, or you may simply need to make sure that the resolution is
appropriate for printing or some other paper output. Or you need to adjust the dimensions so
that they’re just right for viewing on-screen. And sometimes — only sometimes — you may
need to add or delete pixels.

Or you need to change the width, height, and/or resolution of your image for printing or some
other kind of output. Photoshop, being the powerhouse that it is, certainly allows you to do
so with the Image Size command found on the Image menu.

Follow these steps to resize your image:

1.

Open the image and then choose
Image~>Image Size.

The Image Size dialog box opens, as
shown in Figure 1-3. This is where the
magic happens.

Note the current pixel dimensions of
your image and the resulting file size.

Mine shows 1536 pixels in width and
1024 pixels in height for a file size
of 4.5M.

Also note your current document size.

This is the size of your image when it
prints on paper. Mine shows a width of
21.333 inches and a height of 14.222
inches with a resolution of 72 ppi. A
resolution of 72 ppi isn’t adequate for
printing purposes. [ will be able to see
some pixelation (visible little squares)
on my printout. Therefore, | need to
reduce the size of the image so that my
total pixels are spread out over a smaller
area, making them more densely packed.

Make sure that the Resample Image
check box is deselected and then

enter a new value for the width in the
Document Size area.

Don’t worry about the definition of
resample; | explain it in the next section.
I entered a value of 5.12 inches. Note
how my height value automatically
changed to 3.413, as shown in Figure
1-4. That’s because the Constrain
Proportions check box is selected, as
indicated by the chain and bracket icon.
Notice that the check box is also grayed
out. If the Resample Image option is
deselected, the Constrain Proportions
option is unavailable. Nine times out of
ten, you're probably going to want your
image to stay proportional. You can also
change your units of measurement by
choosing from the pop-up menu.

Note how the resolution automatically
changed based on what you entered
in Steps 3 and 4.

In my example, my resolution went
from 72 ppi to 300 ppi. When you do
not have Resample Image selected,
your pixel dimensions remain



unchangeable (note how there is no
text box for you to enter new pixel
dimension values). Therefore, when
you enter a smaller width or height
value, the resolution must increase in
order to accommodate all the pixels
in the image. Similarly, if you enter a
new resolution value (rather than a
width value as I did), Photoshop then
adjusts the width and height values in
order to accomplish the same thing.

Before you close this dialog box, [ would
be remiss in not telling you about the
Auto button. This is Photoshop’s way of
giving you a suggested resolution setting
based on your screen frequency. Don’t

worry about it for now. But if you feel the

burning need to know about screen fre-
quencies, check out Book X, Chapter 2.

Image ke
.

Figure 1-3
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Using the Image Size Command

;T Again, before you click OK, | want to fill
evf' sz you in one new option. The Scale Styles
> option allows you to scale or not scale any
effects or styles that you have applied to
your layer(s). Note that this option is avail-

able only if you have checked Constrain Book
Proportions. ”

Chapter

6. Click OK. 1

You won't notice any difference in the
way your image appears on-screen
because you haven’t added or deleted
any pixels; you've merely compacted
them into a smaller space.

Congratulations! You have just safely
resized your image. You can proudly
say, “No pixels were harmed in the
making of this image.”

. image Size
Figure 1-4

Pinel Dvmensions. 4.50M

Width 1536 pineli

Height 1024 T

Dacument Size

n—> Wichth 5.12
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Resample Image
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Resampling Images

Resampling means you are changing the pixel dimensions of an image. When you downsample
(or resample down), you are eliminating pixels and therefore deleting information and detail
from your image. When you resample up (or upsampling), you are adding pixels. Photoshop
adds these pixels by using interpolation. Interpolation means Photoshop analyzes the colors
of the original pixels and “manufactures” new ones, which are then added to the existing ones.

You can specify the interpolation method in the Image Size dialog box. The default that
appears in the dialog box is based on the interpolation method you specified in your General
Preferences dialog box. Here are your five choices:

v Nearest Neighbor: This method is fast and provides for the smallest file size, but it is
less precise and therefore of the lowest quality. This method works by copying the
color of the nearest pixel. It can result in jagged edges, so use it only for images with
non-anti-aliased edges (hard edges).

v~ Bilinear: Considered a medium-quality method, it works by averaging the color of the
pixel above, below, and to the right and left of each pixel.

v Bicubic: This method is the slowest but most precise. It averages the color of the pixel
above and below and the two on the right and left of each pixel. It provides a smoother
transition between pixels but also increases the contrast between pixels to reduce
blurriness.

v Bicubic Smoother: Like Bicubic, but provides an even smoother transition between
pixels and therefore increases the amount of blurriness. A good method to use when
upsampling images. Can slightly affect the sharpness of the image.

v Bicubic Sharper: Also similar to Bicubic, but applies less anti-aliasing and therefore less
blurriness as well. This method applies just a little softening to pixel edges. This is a
good method when downsampling an image.

&?NEW Bicubic Smoother and Bicubic Sharper are new to Photoshop cs.

_’f
If you really must resample, | recommend leaving the method set to Bicubic Smoother. Notice I
said if you really must. Here are some reasons why you might choose to add or delete pixels:

v You no longer have access to the original artwork, which you could rescan at the
proper resolution and size.

» You no longer have access to the original high-resolution version of the file.

v You absolutely cannot substitute the low-resolution image with another of higher
resolution.

Resampling isn’'t a recommended activity, especially when it pertains to upsampling. | mean
as smart as Photoshop is, having to manufacture pixels out of the blue is not an exact sci-

ence. Your image tends to lose detail and sharpness and get blurry and mushy. The bottom
line is your resampled image never looks as good as the original. Downsampling isn't as
scary. Even though you are deleting pixels, and therefore detail, the degradation is virtually
undetectable with the eye.



Adding pixels to an image
To add pixels to an image, follow these steps:

7. With your desired image open, first
choose Image=>Duplicate to make a
copy of your original. With the dupli-
cate active, choose Imager>Image Size.

See Figure 1-5.

This is where the havoc happens.
Be careful!

Make sure that the Resample Image
option is selected.

Enter a higher value for the resolu-
tion, and if desired, enter a higher
value for the width or height.

[ entered a resolution of 300 ppi and a
width of 8 inches.

Note how the pixel dimensions
increased dramatically as did the file
size (from a mere 149K to 10.9M), as
shown in Figure 1-6.

The Width and Height under Pixel
Dimensions are now text boxes into

©)

bnage Dile

Figure 1-5 _
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Resolution

Scale Styles
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pinels

inches
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Resampling Images

which you can enter values as well.
They are no longer fixed values as
they were when Resample Image was
deselected.

Leave your Interpolation method set to
Bicubic.

If you get all discombobulated when
working in the dialog box, press Alt
(Option on the Mac). The Cancel button
will change to a Reset button. Click it, and
you're back to where you started.

Click OK.

Photoshop now goes through its inter-
polation ritual and churns out a newly
resampled image. Do a side-by-side
comparison to the original, looking at
both at 100% view. Your original should
look better than the resampled image.
Notice the overall blurriness and goopy
edges that are an unfortunate side effect
of interpolation, as shown in Figure 1-7.

oo 3

! ] i Cancel

Ao

CONTINUED
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i image Size
Figure 1-6 -
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Document Size
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Figure 1-7

Original gy
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Taking pixels out of an image

As I mention earlier, when you downsample you eliminate pixels and therefore delete informa-
tion and detail from your image. Although I have emphasized the pitfalls of resampling up, you
can sometimes damage your image by downsampling, as well.

Granted, downsampling is sometimes necessary when converting high-resolution print graph-
ics into Web graphics. For example, you may be forced to take images used for a corporate
brochure and repurpose them into content for the company’s Web site. You probably won’t
notice much degradation in image quality because the images are just being viewed on-screen.
In addition, downsampling can occasionally camouflage the moiré patterns caused by scan-
ning halftones (for more on halftones, check out Book VII, Chapter 1). However, you can down-
sample to the extreme where the images look horrid even on-screen, as shown in Figure 1-8.
But just remember, you should never need to make an image smaller than 72 ppi.



Figure 1-8

4 x 3.75 inches at 72 ppi

A potpourri of image size do’s and don'ts

Here are some tips and tricks to keep in mind
when you're messing around with image size
and resolution settings:

v Use the Unsharp Mask filter when you
resample. If you resample your image,
either up or down, it is sometimes helpful to
apply an Unsharp Mask filter (choose
Filter=>Sharpent>Unsharp Mask). This filter
heightens the contrast between pixels to give
the illusion of sharpening or forcing the
image more in focus.

+* You can always look without touching.
If you don’t want to change the resolution or
size of your image, but just get its vital statis-
tics, use the file information box at the bottom
of the application window (document window
on the Mad). Press Alt (Option on the Mac)
and click your mouse button over the file
information box. You can see the width,
height, channels (see Book VI, Chapter 1), and
resolution of the document.

v Don't change your settings — just use
Print with Preview. If you want to leave
the size and resolution settings untouched,
but need to print your image at a different
size, use the Print with Preview command.
For details on Print with Preview, see Book |,
Chapter 4.

Resampling Images

4 x 3.75 inches at 36 ppi

v Try starting out with the proper dimen-

sions. It goes without saying, but I'll say it
anyway. You want to try to enter the proper
dimensions and resolution when creating a
new document. You don’t want to find your-
self in the unfortunate situation of creating
your file at 72 ppi, spending hours getting it
just perfect and then remembering that you
were supposed to prep it for print and really
needed it to be 300 ppi. Resampling your
image from 72 ppi to 300 ppi is going to
make it go from perfect to, well, far less than
that. And when scanning an image, make sure
that you scan it at a high enough resolution
that if you need to enlarge the dimensions,
you can do so without changing the pixel
dimensions. See Book X, Chapter 2, for more
details on prepping an image for print.

Don't use a higher resolution than you
need. All you do is create an unnecessarily
huge file with a slower print time. In addition,
the output device may not be able to repro-
duce all the detail in the image. In some
cases, it may actually make your printout look
darker and muddier.

Look no further than this book. Use the
handy, dandy table of recommended resolu-
tion settings for a variety of output devices in
Book X, Chapter 2.
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you get better results if you do several successive 50% downsamples, applying a Unsharp
Mask filter on the image in between each image sizing. For more on the Unsharp Mask filter,
see Book VII, Chapter 1.

gs If you have to downsample your image significantly, for example to 25% of its original size,

To remove pixels from an image, follow the steps in the preceding section and change the
image settings accordingly.

Resizing Images with the Resize Image Wizard

You find the Resize Image Wizard (Resize Image Assistant on the Mac) on the Help menu on
the Photoshop menu bar. When selected, the Wizard/Assistant dialog box appears and asks
you questions about your intended use for the image. The wizard/assistant then guides you
through the image-sizing process. If you happen to choose options that the wizard doesn’t
like, you get a warning that your changes are likely to lower your image quality. You can then
go back and try another setting.

The Resize Image Wizard is more for beginners and doesn’t offer quite the control that the
Image Size dialog box does. In addition, you can’t see all your options on one screen and must
continually go back and forth between screens when entering different values.

When you finish changing settings and choosing options, the wizard/assistant creates a new
file called Resize Wizard 1 (Resize Assistant 1 onthe Mac), leaving your original
unharmed. Like any kind of wizard, this one is pretty savvy, but I recommend having a firm
understanding of proper output resolution (see the beginning of this chapter for info on that
topic) before you use the wizard/assistant. And actually with that firm understanding, you can
do manually everything the wizard/assistant can do and more. Remember the old adage,
knowledge is power.

Although using the Resize Image Wizard is fine, try to avoid using Filem>Automater>Fit

Image. When | see a dialog box having to do with image sizing that only contains two text
boxes, it's an immediate red flag! This command resizes your file as close to your entered
dimensions as possible, while maintaining the same proportions. But in order to do so,
Photoshop enlarges or decreases your image while leaving the resolution the same. And if
you've read earlier sections of this chapter, you know this is also called resampling — not a
nice thing in image-editing circles.

Changing the Canvas Size

I've probably harped on you to the point that you're slightly paranoid, or at least ultraconscious,
of using the Image Size command. Well, you can relax now because the Canvas Size command is



Changing the Canvas Size

as safe as can be. Unlike the Image Size command, which enlarges or reduces the dimensions
or resolution of your image, the Canvas Size command merely changes the size of the canvas,
or page, on which the image sits.

When you increase the size of the canvas, Photoshop fills the expanded area outside the

image with your chosen color. Increasing your canvas size can come in handy if you are trying
to add a frame or border around your image. If you make the canvas smaller, Photoshop crops
(cuts away) the image.

Here are the quick and easy steps to changing your canvas size:

1.

Choose Imager>Canvas Size.

The Canvas Size dialog box, shown in
Figure 1-9, appears. The current size of
your canvas appears at the top of the
dialog box.

Enter new values in the Width and
Height text boxes.

You can also change the unit of meas-
urement by using the pop-up menus.
Select the Relative check box to specify
an amount of space for Photoshop to
add around your image. This feature is
handy when adding equal amounts of
canvas around images with fractional
measurements.

Specify your desired anchor placement.

The anchor shows how the image sits
inside the canvas. By default, Photoshop
centers the image and adds the canvas
around it. Click any of the other eight
squares to have Photoshop add the
canvas asymmetrically around the
image, as shown in Figure 1-10.

If you reduce either the Width or
Height value and click OK, an alert box
appears asking if you really want to
proceed because you will be clipping
the image. This is actually another way
of cropping an image, albeit not one
you will use everyday. Photoshop has

more exact ways of cropping an image
(see the next section). However, this
method can occasionally come in
handy when you want to crop your
image on one or more sides by a cer-
tain number of pixels. For example,
sometimes cropping (using the Crop
tool described in the next section) a
one- or two-pixel-wide row or column
along the edge of an image is difficult.
In this case, use the Canvas Size com-
mand and specify a value for the Width
and/or Height that is a couple of pixels
smaller than your original. Pesky prob-
lem solved.

Choose your canvas color from the
Canvas Extension color pop-up menu
and click OK.

No longer do you have to be diligent in
selecting a background color before you
initiate the canvas size command.
Photoshop now offers you the option of
choosing the color you want for your
newly expanded canvas. Choose from
Foreground, Background, White, Black,
Gray or Other. If you select Other,
Photoshop transports you to the Color
Picker where you can choose any color
you desire. Note that the small swatch to
the right of the pop-up menu displays the
current background color. You can also
click this swatch to access the Color Picker.

CONTINUED
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Cropping an Image

Even a novice photographer knows that cropping an image can make a composition stronger.
Cropping entails cutting away background clutter or endless expanses of empty space in order
to focus in on your desired subject.

This simple process can transform a ho-hum photograph into a visually exciting one. Take a
look at my example in Figure 1-11. [ mean, it doesn’t take an Ansel Adams to figure out which
image is stronger. (It would be even better if the fence weren’t in the background, but hey,
that’s nothing that a little Photoshop retouching can’t take care of. Check out Book VIII; it’s
all about retouching and restoration techniques.)
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Figure 1-11
Book
I/}
= Chapter
Using the Crop tool

The most popular way to crop an image is by using the Crop tool. This simple tool is as easy
and effective to use as a T square and X-ACTO knife, and without the possibility of bodily
injury. Select the Crop tool or press C on the keyboard and then follow these steps:

part of the image you want to keep
and then release your mouse button.

As you drag, a marquee (a dotted out-
line) appears displaying the cropping
boundaries. Don’t worry if your crop-
ping marquee isn’t exactly correct. You
can adjust it in the next step.

Notice how the area outside the crop-
ping marquee appears darker than the
inside, in order to better frame your
image. Adobe calls this a shield. You
control the color and opacity (the
amount of transparency) of the shield
by adjusting the settings in the Options
bar. If, for some strange reason, you
don’t want the shield, deselect the

example of way too much background
clutter. I dragged around the only thing
[ want to retain — my daughter.

Adjust the cropping marquee by drag-
ging the handles.

The small squares on the sides and cor-
ners of the cropping marquee are called
handles. When you hover your mouse
over any handle or the marquee itself,
your cursor changes to a double-headed
arrow, indicating that you can drag.

If you drag the handles outside the
image boundary, Photoshop adds a
canvas around the image when you
crop.

CONTINUED
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Figure 1-12

To move the entire marquee, position
your mouse inside the marquee until
you see a black arrowhead cursor and
then drag. Adjust the marquee until
you're satisfied.

You can also drag the origin point
to change the axis of rotation.

If you move your mouse outside the
marquee, the cursor changes to a curved,
double-headed arrow. Dragging with this
cursor rotates the marquee. This feature
can be extremely useful when you need
to rotate and crop a crooked image. By
using the Crop tool, you can perform both
commands in one step and often more
quickly and accurately. Just be aware that

Book 11 + Chapter 1: Specifying Size and Resolution

rotation, unless it’s in 90-degree incre-
ments, resamples your image, which, if
done repeatedly, can damage your image
(see the beginning of this chapter for
more on resampling). So it’s best to try to
get the rotation right the first time around.

Double-click inside the cropping
marquee.

You can also just press Enter (Return
on the Mac) or click the Commit
(check mark icon) button on the
Options bar. Photoshop discards the
area outside the marquee, as shown in
Figure 1-13. If you want to cancel the
crop, just press Esc or click Cancel (the
slashed circle icon) in the Options bar.
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Figure 1-13
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Cropping with the Marquee tool

If you get bored using the Crop tool, you can also crop a selected area by choosing Imagew>
Crop. Simply make a selection with any of the tools and then choose this command. Although
using the Rectangular Marquee tool for your selection makes the most sense, you don’t

have to.

You can use Image=~>Crop with any selection — circular, polygonal, kidney bean, even feath-
ered. Photoshop can’t crop to those odd shapes, but it gets as close to the outline as it can,
as shown in Figure 1-14.

Using the Trim command

The fabulous Trim trims away transparent or solid-colored areas around your image. Choose
Image=>Trim, and a dialog box appears. Select Transparent Pixels (for layered images), Top
Left Pixel Color, or Bottom Right Pixel Color as a basis for the trim. Next, instruct Photoshop
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to trim away the Top, Bottom, Left, or Right side(s) from the image. This command works
great for quickly eliminating black-and-white borders around images, as shown in Figures 1-15
and 1-16.

Figure 1-14

ful IMGOO26. PCD & 66.7% (RCE)

Figure 1-15
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Cropping an Image

Sure-fire cropping tips

Even though cropping is about as simple an
image-editing maneuver as you can get, you
need to know about a few other options:

dles to move independently. Cropping with
Perspective selected can help to rectify
images that have keystone distortion, which
occurs when you photograph an image from
an angle rather than straight on.

v The Front Image option enables you to crop
one image so that it's the exact same sizeas
another image. Open two images and crop
the first one. Click Front Image. Photoshop
enters the width, height, and resolution
values from the first image in the Options
bar. Drag the Crop tool on your second
image and adjust the marquee as desired.
Double-click inside the marquee. Photoshop
automatically crops your second image to
match your first. The Front Image command
is also available in the Options bar only
before you drag your cropping marquee.

v If your image doesn’t contain any layers —
that is, it consists only of a background — any

cropped areas are permanently deleted from
your file. However, if your image consists of
one or more layers (see Book V for the low-

the cropped area if you move the layer with
the Move tool. Another way to see the
hidden area is to choose Imager>Reveal All.
Photoshop expands the canvas to show all
areas in all layers. These options are available
only while the crop marquee is active.

If you want to crop an image to an exact
measurement, enter a value in the Width,
Height, and Resolution text boxes in the
Options bar. Note that these options are avail-
able only when the Crop tool is active and you
haven't yet dragged a cropping marquee. You
can still freely drag and adjust the cropping
marquee. When you commit the crop, your
image matches the physical dimensions you
specified. You can enter values in just one,
two, or all three options. But again, be care-
ful about the value you use for the Resolution
setting. Remember, resampling is not a good
thing. To remove the entered settings, click
the Clear button in the Options bar.

Using the Crop and Straighten Photo Command

‘NEW Because cropping is one of the most commonly used Photoshop features, this version comes

Yy equipped with an additional cropping mechanism.

137

down on layers), you have the choice of delet- Book

v If you need a nonrectangular cropping mar- ing or hiding your cropped area. Delete /]
quee, select the Perspective check box in eliminates the cropped areas, whereas Hide Chapter
the Options bar. This allows the corner han- just hides the cropped area. You can see 1

Choose Filer>Automater>Crop and Straighten Photos. Photoshop then looks for rectangular
areas in your document, extracts each one into its own document, and then straightens those
individual images, as shown in Figure 1-16.

The Crop and Straighten Photos command is fabulous if you want to save time by scanning
multiple images initially into one document (and the command works on single images as
well). This command is a real manual labor time saver, and [ wholeheartedly endorse it.
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Figure 1-16
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In This Chapter

» Understanding the theory
of color

v~ Taking a look at color
modes

v Focusing on file formats

previous chapter), you need to decide on an image mode and

file format for your image. This decision is usually based on
the final use for the image. Will it be imported into a page
layout program and then offset printed? Will it be posted on a
Web page? Will it be used for a newspaper article?

In addition to choosing a size and resolution (discussed in the

When you know an image’s final destination, you can make
intelligent choices of which color mode and file format are best.
This chapter gives you some background information to help
you make those choices so that you don’t end up having to do
extra work, spend extra time, or waste extra money.

Understanding Color Theory

You can find many books, most of them detailed and lengthy,
devoted to a single subject — color — and written by bona fide
color experts who spend their days analyzing complex color
algorithms for fun. [ recommend owning at least one heavy-duty
tome on color, even if its main function is to act as a paper-
weight. Even as an occasional reference, a book on color theory
is essential if you're serious about using Photoshop in your daily
activities. In this chapter, [ provide you with the minimalist’s
take on color theory.

Knowing RGB basics

When you view an RGB image, you are looking at an image com-
prised of three colors — red, green, and blue. These colors are
v The primary colors of light

v The colors that correspond to the three types of cones
inside your eyes
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v The colors that comprise white light from the sun

v The colors your monitor uses when displaying images

Mixing these three primary colors can yield up to 16.7 million colors. In Photoshop, each of
these colors resides in a color channel in the image. Photoshop looks at a color image in terms
of its channels — individual bands of 8-bit grayscale images. When you view the channels indi-
vidually in Photoshop, you can visually see that each channel appears as a grayscale image
made up of light-, medium-, and dark-colored pixels (assuming that you have deselected the
Color Channels in the Color check box). RGB images have three bands, and CMYK images have
four bands. Each one of these bands, or grayscale images, is a channel, or more specifically a
color channel. When you view the channels together, the pixels from each channel mix to form
colors, which give you a composite, or full-color image. For the lowdown on channels, check
out Book VI, Chapter 1.

Photoshop assigns each pixel a brightness value ranging from 0 (black) to 255 (white). These
grayscale pixels from each channel mix together to form colors, which in turn provide you
with a composite color image.

Here are some color channel examples to help you see how the RGB system works to create
so many different color variations:

v Alight-colored pixel from the green channel, a dark-colored pixel from the red channel,
and a dark-colored pixel from the blue channel combine to give you a green pixel.
v Avalue of 255 from all three channels produces white.

Because RGB colors combined at 255 create white, they are known as additive colors.
When you view this white on your computer monitor, for example, it transmits all
visible wavelengths back to your eyes.

v A value of 0 from all three channels produces black.

\

If all three values are equal, a neutral gray is produced.

\

A medium-dark pixel from the red channel, a black pixel from the green channel, and a
light-colored pixel from the blue channel combine to produce purple.

v Mixing colors in RGB produces lighter colors. Try playing with the RGB color sliders in
your Color palette and mix your own colors to see this concept in action. Remember
that the right side of the slider (the higher numbers) represents light, and the left side
of the slider (the lower numbers) represents dark. For more on working with the color
sliders and Color palette, see Book II, Chapter 3.

Knowing CMYK basics

The CMYK color scheme is based on the light-absorbing quality of ink on paper. In theory,
a white light hits these inks. Some visible wavelengths are absorbed, or subtracted, while
others are reflected back to your eyes. CMYK images comprise various percentages of only
four colors of ink — cyan, magenta, yellow, and black. These colors correspond to the inks
used in the offset printing process.

Cyan, magenta, and yellow are called subtractive colors. Technically if you combine these three
colors of ink, you produce black. But because of ink impurities, you actually end up with a
nasty brown color. (That’s why we add K, or black to produce black.)
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CMYK colors are also known as process colors. Mixing colors in CMYK produces darker
colors. Setting all four inks to 0% produces pure white.

@ Subtractive and additive colors are complementary. This means that each pair of subtractive
colors creates an additive color and each pair of additive colors creates a subtractive color.

Selecting a Color Mode in Photoshop

Every file has a color mode, also called an image mode or just plain mode. To determine the
color mode of an image, look in the title bar of the image window or choose Imager>Mode.
Color modes define the color values used to display the image. Photoshop offers eight differ-
ent modes and allows you to convert images from one mode to another. The color mode you
choose for a particular image depends on a couple of factors:

v~ The file format you plan to save it in. Some modes call for specific file formats. You
may find that a certain format is unavailable because your file isn’t in the appropriate
color mode.

v The end use for the image. Do you plan to post the image on the Web? Or are you put-
ting it in a brochure that will be offset printed? For more on prepping images for print,
see Book X, Chapter 2.

The next few sections provide a brief description of each mode and any file format or usage con-
nections. For examples of some modes, in full, living color, be sure to check out Color Plate 2-2.

the number of channels. Each mode is also represented by one or more channels, where the
color data is stored. Grayscale images have one channel — black. CMYK images have four
channels — cyan, magenta, yellow, and black. For the lowdown on channels, see Book VI,
Chapter 1.

@ Color modes affect the number of colors that are displayed, as well as the size of the file and

RGB Color

Uses: RGB is the gold standard for most scanners, all monitors, and some desktop inkjet
printers. And it’s the primary color mode (with Indexed Color being secondary) to use
with any images to be viewed on-screen (whether on the Web or in any kind of multimedia
presentation).

File formats: RGB can handle just about every format except GIF.

RGB can be considered the default color mode of Photoshop. RGB images contain values of
0-255 for each of three colors — red, green, and blue. With 8 bits of color information for each
of the three colors, these 24-bit images can reproduce up to 16.7 million colors on-screen. And
48-bit images (16 bits per color) can display even more. Most scanners also scan images in
RGB, all monitors display in RGB, and some desktop inkjet printers prefer to print RGB (rather
than CMYK) images. Remember that the RGB mode in Photoshop varies according to the RGB
Working Space setting you have selected in the Color Settings dialog box. For details on Color
Settings, see Book I, Chapter 3.
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CMYK Color
Uses: CMYK is the standard for images that are color separated for offset printing.
File formats: CMYK can handle just about every format except GIF.

CMYK images contain a percentage of one or more of four-process color inks — cyan,
magenta, yellow, and black. Darker colors have higher percentages, whereas lighter colors
have lower percentages. Pure white is created when all four colors have a value of 0%. Many
other composite printing devices also require images to be in CMYK mode. Again, like RGB
mode, remember that the CMYK mode in Photoshop can vary according to the CMYK Working
Space setting you have selected in the Color Settings dialog box.

Make sure that you do all of your image editing in RGB mode, where you have access to the
full range of filters. When you complete your editing, convert the image from RGB to CMYK.
(For details, see “Converting from RGB to CMYK,” later in this chapter.)

Grayscale
Uses: Grayscale mode is for black-and-white (and all shades of gray in between) images.
File formats: All of the most commonly used file formats accept Grayscale mode.

Grayscale images contain up to 256 levels of gray. Each pixel has a brightness value ranging
from 0 (black) to 255 (white). You can scan an image in Grayscale mode, or you can convert
color images to grayscale. If you convert a color image to grayscale, Photoshop discards all
the color information, and the remaining gray levels represent the luminosity of the pixels.
(Check out the “Converting to Grayscale” section, later in this chapter.) You can also convert
a grayscale image to a color image, which, while it doesn’t convert your grayscale image to
color, it allows you to apply color on top of the grayscale image.

Monotone, Duotone, Tritone, and Quadtone

Uses: Because printing presses can print only about 50 gray levels per ink color, duotones,
which use two to four inks, are used to increase the range of tones of grayscale images.
Duotones are often created by using black and spot colors (premixed inks), although you can
also use process colors. For more on spot colors, see Book X, Chapter 2.

File formats: The only file formats that can save duotones, tritones, and quadtones are native
Photoshop, Photoshop 2.0, EPS, PDF, Large Document Format, or Photoshop Raw.

These modes create one-color, (monotone), two-color (duotone), three-color (tritone), and
four-color (quadtone) images. Note that Photoshop lumps all the various “tone” modes under
duotone. You will find a pop-up menu in the Duotone options dialog box where you can select
the various options. Unlike RGB and CMYK images where the components of the image dis-
play with different colors, the monotones, duotones, tritones, and quadtones have the colors
mixed throughout the image. The colored inks are used to reproduce tinted grays, not the dif-
ferent colors you find in RGB and CMYK images.

To access the Duotone mode, you must first convert the color image to grayscale by choosing
Image=>Moder>Grayscale. Then choose Imager>Moder>Duotone. In the dialog box that
appears, choose Monotone, Duotone, Tritone, or Quadtone from the pop-up menu. Next,
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select ink colors — either spot or process — by clicking the swatches. Finally, you can adjust
the curves settings and tell Photoshop how to distribute the ink(s) among the various tones.
Note that you do not have access to the individual color channels in Duotone mode. The only
manipulation that you do is with the curves settings.

If you are new to these modes, you need to know that Photoshop offers numerous preset duo-
tones, tritones, and quadtones. To access these presets, click the Load button and go to the
Duotones folder (which is located in the Presets folder in the Photoshop folder).

Indexed Color
Uses: Indexed Color mode is primarily for Web graphics and multimedia displays.

File formats: Indexed Color mode supports a variety of formats, with GIF being the most pop-
ular. Others formats supported include Photoshop, Photoshop 2.0, Photoshop Raw, BMP, EPS,
Electriclmage, Large Document Format, PCX, PDF, PICT, PICT Resource, PNG, Targa, and TIFF.

Indexed Color mode uses 256 colors or less; what graphics aficionados call 8-bit color. When
you convert an image to indexed color, Photoshop builds a Color Lookup Table (CLUT), which
stores and indexes the color. (Note the Color Table option in the Mode menu.) If a color in the
original image isn’t in the table, Photoshop chooses the closest match or makes a new one
from the available colors. The small amount of colors reduces the file size, which is why the
GIF file format, the preferred format for Web graphics, uses this mode. (See the “GIF” section,
later in this chapter.)

6 The Indexed Color mode does not support layers, and editing capabilities are limited. For
more on indexed color, see Book IX, Chapters 1 and 2.

Lab Color

Uses: Lab Color mode provides a consistent color display, which is ideal for high-end retouch-
ing of images.

File formats: You can save an image in Lab Color mode in native Photoshop, Photoshop Raw,
EPS, TIFF, PDF, JPEG 2000, Large Document Format, or Photoshop DCS 1.0 and 2.0 formats. You
can save images containing 48 bits (16 bits per channel) in Photoshop, Photoshop Raw, Large
Document Format, and TIFF formats.

Lab Color mode is usually thought of as the internal color mode Photoshop uses when con-
verting from one color mode to another — for example, when going from RGB to CMYK. It is
also the mode preferred by color-retouching experts because it is considered to be device
independent (it appears consistent on various devices).

Lab Color mode consists of a lightness channel and two additional channels, a and b, which
contain the range of color from green to red (a) and blue to yellow (b).

Bitmap

Uses: This mode is best for scanned line art and signatures (your John Hancock).

File formats: Photoshop, Photoshop 2.0, EPS, TIFF, PDF, BMP, PNG, GIF, PNG, PCX, PICT, PICT
Resource, Portable Bitmap, and Wireless Bitmap.
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Bitmap images contain pixels that are either black or white, exclusively. You must convert
color images to grayscale before you can access Bitmap mode. Upon choosing Imager>
Moder>Bitmap, a dialog box appears, offering options for resolution and method. The various
methods give different appearances, as shown in Figure 2-1, so try each one to see which you
prefer.

If you save a file in Bitmap mode as an EPS (see “EPS,” later in this chapter), you can convert
the white areas in the image to transparent areas. This allows you to overlay the file over a
background containing color or an image, and only the dark pixels show.

Figure 2-1
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Multichannel

Uses: Multichannel mode is for special printing needs or as an intermediate mode when con-
verting between different color modes.

File formats: The only file formats available for multichannel images are native Photoshop,
Photoshop 2.0, Photoshop DCS 2.0, Large Document Format, or Photoshop Raw formats.

The Multichannel mode comprises multiple grayscale channels, each containing 256 levels
of gray. Whenever you delete or mix channels, you end up with a multichannel image. You
can also convert any image with more than one channel to this mode. In a multichannel
image, each channel becomes a spot channel, with 256 levels of gray.

For more on channels, see Book VI, Chapter 1.

Converting to a Different Color Mode

Sometimes, your image starts out in one color mode and then you find you need to convert
the image to another mode. Maybe you need to strip the color out of an image you’re submit-
ting to the local newspaper. Or maybe you need to convert your RGB image to CMYK to get it
ready for an offset print job.

When you convert modes, you are permanently changing the color values in your image, so
save a backup image just in case.

The next few sections offer pointers for the most common conversions you’ll make.

Converting from RGB to CMYK

As I mention several times in this book, CMYK is the image mode necessary for high-end
composite printing and offset printing. You will first want to perform all your necessary
image-editing tasks in RGB mode for the following reasons:

v The image size is smaller because RGB mode has only three channels.
The RGB color space provides more device independence because it isn’t reliant on inks.

You have full accessibility to filters.

X Y\

RGB mode provides a large color gamut, so Photoshop preserves more colors after it
makes image adjustments.

When you're finished editing the image in RGB mode, you can convert the image from RGB to
CMYK (you can perform any fine-tuning in CMYK mode if necessary). If you're new to this pro-
cedure, you may be surprised at what can result. Because the color gamut (range of colors) of
the RGB model (16.7 million) is much larger than that of CMYK (approximately 55,000), you
may see a color shift, which may range from slight to major.

The extent of the shift depends on the colors in the RGB image and how many of them are out
of gamut. Photoshop replaces RGB colors that are out of gamut with the closest match avail-
able within the CMYK gamut, often replacing the electric blues, fiery reds, and sunny yellows
with duller, muddier CMYK equivalents. Unfortunately, you can’t do anything to prevent this.
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It is just the way of the world of color. However, if you can select colors (rather than acquiring
them from a scan), be sure that you don’t select any colors that are out of gamut to begin
with. Check out Book II, Chapter 3, for all you need to know about working with and managing
color in Photoshop.

choose View=>Proof Setup>Working CMYK. This view is referred to as a soft proof — previewing
on-screen how your image will look on various output devices or various modes. For more on soft
proofs, see Book Il, Chapter 3.

@ If you want to see what the effects of your CMYK conversion will be without actually converting,

Converting to Grayscale

You can convert a color image to grayscale a multitude of ways. The next few sections cover a
few that you may want to try out.

You can also use the Channel Mixer to create custom grayscale images. For more on the
Channel Mixer, see Book VI, Chapter 1.

Quick and dirty method

Choose Image>Moder>Grayscale. Photoshop then asks you whether you want to discard
color information. Click OK. Photoshop merges the RGB or CMYK channels into one black
channel, and you now have a grayscale image. You may find that although this method does
the job in stripping color from your image, you may be left with an image that is flat and lack-
ing contrast. You can apply a Levels adjustment (choose Image~>Adjustments=>Levels) to
boost the contrast, or you can try one of the other conversion methods. If your image con-
tains multiple layers, Photoshop asks whether you want to merge your layers. If you want to
keep your layers, click the Don’t Merge button.

Be aware that you can no longer apply color to your image. If you choose a color in the Color
palette, the color appears gray in the foreground and background color icons. If you want to

apply color to your grayscale image, you must convert it back to RGB or CMYK mode.

Lab Color mode method

Choose ImagervModer>Lab Color. As mentioned earlier, converting to Lab Color mode con-
verts the channels into a lightness channel and a and b channels containing ranges of color.
Delete the a channel. The b channel then changes its name to Alpha 2. Delete the Alpha 2
channel. That leaves you with the lightness channel, which is now named Alpha 1. Choose
Image=>Moder>Grayscale. Your color image is now a grayscale one. Note that if your image
contains multiple layers, Photoshop flattens the layers when you convert to grayscale. Make
sure that you finish all your edits requiring layers before you convert to grayscale. This
method most likely provides a better grayscale image than the quick and dirty method.

Best channel method

If you look at the individual channels in the image, one often stands out as being a very good
grayscale image by itself. (If channels are a mystery to you, check out Book VI, Chapter 1, for
details.) You may find that the red channel provides a good grayscale image when the subject
is people, because humans have a lot of red in their skin. Or you may find the green channel
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looks good in a scenic shot. The blue channel rarely yields a nice image, though. Most of the
crud picked up from scanners finds its way into the blue channel.

In the Channels palette, select each channel and view its contents. Find the channel that looks
the best and then choose Image>Moder>Grayscale. Photoshop asks you if you want to dis-
card all the other channels. Click OK. Like with the Lab Color method, if your image contains
multiple layers, Photoshop flattens the layers when you convert to grayscale.

Converting to Indexed Color

You may need to convert your RGB or CMYK images to Indexed Color to save them as GIFs
and prepare them for posting on the Web. The main issue to be aware of is that the Indexed
Color mode contains only 256 colors (or even less). That is a far cry from the thousands or
millions offered by CMYK and RGB images. If color is critical, you may want to reconsider
making the conversion and instead leave or convert your image to RGB mode.

The Indexed Color mode cannot support layers, so again, be sure to perform all necessary
editing functions before making the conversion. You also lose all capabilities to anti-alias any
portion of your image, including your text, which can lead to hard, jagged edges that you may
not want. The bottom line is, perform all of your editing functions in another mode and con-
vert to Indexed Color only when you're ready to save the image for the Web. When converting
to indexed color, you have options for specific palettes, numbers of colors, dithering, and so
on, as shown in Figure 2-2. These options affect the appearance of the image. For more on the
Indexed Color mode and these options, see Book IX, Chapters 1 and 2.

Indexed Calar
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Using the Conditional Mode Change Command

Photoshop enables you to specify instances where one mode changes into another so that
you can utilize the conversion command in an action. Briefly, an action is a collection of
recorded and saved commands that you can replay again and again. For details on actions,

CONTINUED
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see Book II, Chapter 6. Sometimes when you incorporate a mode conversion as part of an
action, you get an error message because the file you're opening may not have the same mode
you specified as the source mode in the action. For example, you may have specified CMYK as
your source mode in the action. But if the action opens a file in Grayscale mode, you get an
error message, because the Grayscale mode of the file doesn’t match the CMYK source mode.
The Conditional Mode Change command takes care of this problem. Here’s what you do to
add this command to your action:

1. Start creating and recording your the All or None buttons to select all
" action. modes or no modes.
2. Choose File>Automater>Conditional Select your desired target mode from
Mode Change. the Mode pop-up menu.
In the Conditional Mode Change 5. Click OK.

dialog box, shown in Figure 2-3, select
the mode(s) you want as valid for the
source mode. Other options include

If all goes well, Photoshop incorporates
the Conditional Mode Change com-
mand as a step in your action.

Conditional Mode Change

Figure 2-3
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Choosing the Right File Format

A critical component in saving a file is choosing the file format. The file format is the way the
file’s data is represented and saved. Photoshop generously offers numerous file formats to
choose from. Some you'll use frequently, and others you’ll never set eyes on.

[ provide quite a bit of detail on the formats you’ll use most frequently, and throw in a brief
description of those you’ll encounter only once in a blue moon (if at all).

Note that if a file format doesn’t appear in the Open, Save, or another dialog box, you may
need to install the plug-in for that particular format.

Be sure to check out the handy table in Book X, Chapter 2. It offers a list of what file formats
work for various applications and uses.

TIFF

TIFF, Tagged Image File Format, is by far one of the best and most useful formats. One of the
great qualities of TIFFs is that they are and have always been totally cross-platform. In addition,
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almost every program on the planet can import TIFFs. Okay, so that’s a slight exaggeration.
Almost every word processing, presentation, page layout, drawing, painting, and image-editing
program can import TIFFs. This file format works especially well for images that will be printed
or color separated.

Photoshop allows you to save layers and transparency and also use various methods of com-
pression. You have the option of having Photoshop warn you that including layers increases
your file size. To enable this option, select the Ask Before Saving Layered TIFF Files check box
in the Preferences dialog box. Photoshop saves the layers along with a flattened version of the
image. Be aware that some applications may display only the flattened version.

It should come as no surprise that the most commonly used format offers a variety of options —
all of which are available in the TIFF Options dialog box (shown in Figure 2-4). The following
sections give you everything you need to know about your various options so that you can
make an informed decision based on your intended uses for the image.

TIFF Options
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Figure 2-4
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Image Compression

Photoshop offers three methods of compression, besides the option of None, which of course
leaves your image uncompressed:

v LZW: This method has been around for eons and is a lossless compression scheme. This
means that data is not deleted to make your file smaller. LZW does an especially good
job when you use it to compress images with large areas of a single color. Most pro-
grams that support TIFF also support LZW compression, so you can use this method
without much hesitation.

If your files are unusually large, compressing them will make your files save and open more
slowly. Note that TIFFs can be up to 4GB in file size. Be careful, however, because older ver-
sions of Photoshop and other applications don’t support file sizes larger than 2GB.
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v Zip: Zip compression is also a lossless method and is popular in the Windows arena.
Like LZW, it works well with images that have large areas of a single color.

v JPEG: This method, while popular and very effective, is a lossy compression process.
When compressing, JPEG deletes data in order to reduce the file size. (That’s where the
loss in lossy comes from.) When you open the file again, that deleted data is remanufac-
tured by the program. Over time, this repetitive deleting and remanufacturing can
degrade image quality. [ recommend that you stick with LZW compression.

JPEG image every time you save it in JPEG format. During a single edit session, this com-
pression won't hurt because JPEG works from the on-screen version. But if you close,
reopen, and resave the image in JPEG format, degradation occurs. You may not see the
results right away, but you will over time. Leave your image in either TIFF or native
Photoshop file formats while editing. Then when you're completely done editing and you
need to compress the image, save the file as a JPEG at a high to maximum quality setting.

Es Lossy compression can eat away at the quality of your image. Photoshop recompresses a

Byte Order

Specify whether you want to save the TIFF for a Mac or a PC. If you want to be able to use the
image on both platforms, select IBM PC. Macs are much more forgiving when exchanging files.

Save Image Pyramid

This option allows you to save multiple resolutions of an image. The top of the pyramid is the
lowest resolution, and the bottom of the pyramid is the highest resolution. If the program
supports them, you can choose to open any of the resolutions.

Currently, only Adobe InDesign supports image pyramids. Photoshop can open only the image
at the highest resolution within the file. | recommend leaving this option deselected.

Save Transparency

Select this option to preserve transparent areas when the TIFF is opened in other applica-
tions. Of course, those applications must also support transparency. If you open a TIFF with
transparency in Photoshop, the transparent areas are always preserved whether or not you
select the option.

Layer Compression

If you want to save the layers in your file, Photoshop saves a flattened version along with
your layered version to ensure compatibility with programs that don’t recognize layers. If
you retain the layers, you have the choice of RLE (Run Length Encoding) or Zip compression.
Because RLE compression is also lossless, you have the choice of faster saves (RLE) or
smaller files (Zip). The last choice is for Photoshop to discard the layers, thereby flattening
the image and then saving it as a copy. Your original layered file also remains intact.
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JPEG

JPEG, the acronym for Joint Photographic Experts Group, is a file format that uses lossy
compression (explained in the “Image Compression” section). The JPEG file format offers
13 compression settings — the higher the quality, the less the compression, and vice versa.

Book
JPEG compression is very effective. It can squeeze your file size to practically nothing. JPEG Il
compression works best with continuous-tone images, such as photographs. But because the Chapter
compression is lossy, I don’t recommend this format for high-end printing and color separations. 2

JPEG supports RGB, CMYK, and Grayscale image modes. It doesn’t support alpha channels.

JPEG works great with photographic images that have a wide range of colors. Check out

s If you want to post your image on the Web, you have to save it as a JPEG, GIF, or PNG.
Book IX, Chapters 1 and 2, for the lowdown on all the JPEG options and settings.

JPEG 2000

1__? JPEG 2000 is a new member to Photoshop repertoire of supported file formats. A cousin to
cvf’ i}EW standard JPEG, it provides a few more bells and whistles, including better compression rates
> and more quality settings. In addition to the standard lossy compression algorithms, JPEG 2000
also offers lossless compression, shown in Figure 2-5, and can support 16-bit images, alpha and

spot channels, and transparency (8 bit-images only). You can save this format using the fol-
lowing image modes: RGB, CMYK, Grayscale, and Lab Color. If you want to be able to utilize

this file format, be sure to install this optional plug-in found on the Photoshop cs Install CD.

JPEC. 2000

Figure 2-5
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One of the coolest features of this format is it supports the use of a Region of Interest (ROI).
This feature allows you to selectively choose a region of an image that you can then optimize
to ensure the best quality. You save an alpha channel to define that vital portion of the image
where detail retention is critical. You can then compress the rest of the image more heavily
and with lesser quality, resulting in a smaller file size. For more details on JPEG 2000, see Book
IX, Chapters 1 and 2.

Although praising the qualities of JPEG 2000 is all well and good, be warned that you cur-
rently (at press time of this book) need a plug-in to be able to view these files on the Web. In
the future, this format is sure to become a standard on the Web and with digital cameras.

GIF

GIF is another file format used for Web graphics. While GIFs support transparency, on the
down side you must save GIFs in the Indexed Color mode, which comprises 256 colors or less.
Although this is great for making tiny files, it’s not so great for continuous-tone images where
the number of colors displayed is critical. Therefore, the GIF format is usually reserved for
illustrations (spot illustrations, buttons, logos, and so on) and type with large areas of flat
colors and sharp details. For the whole story on GIFs, see Book IX, Chapters 1 and 2.

EPS

EPS is short for Encapsulated PostScript. PostScript is a page-description language developed
by Adobe and used by many printers. The EPS format can contain both vector and raster
graphics. (For details on vector and raster graphics, see Book II, Chapter 1.) EPSs tend to
create larger file sizes and do not have a built-in compression scheme like JPEGs or TIFFs. EPS
is the recommended file format for creating color separations for high-end, four-color print
jobs. This is also the file format to use for images with clipping paths and those with a
Duotone color mode. In addition to duotones, EPS supports Lab Color, CMYK, RGB, Indexed
Color, Grayscale, DCS, and Bitmap modes. It does not support alpha channels. Finally, EPS is
the format of choice for importing to and from drawing programs such as Illustrator,
FreeHand, and CorelDraw.

Here are the options when saving in the EPS format, as shown in Figure 2-6:

EPS Options

Preview: | TIFF (8 bits/pixeh W . |

ﬂrcamd_\_

Figure 2-6

Encoding: | Binary
) Include Halftone Screen

™ Include Transfer Function

) PostScript Color Management
g include Vector Data

2 image Interpolation |

Files with vector data will be

& rasterized by Photoshop when
opened
|
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v Preview: If you import your EPS into another application, this option provides a low-
resolution image for you to view. | recommend choosing 8-bit TIFF, which works on both
PC and Mac.

v Encoding: This option specifies the way an image is sent to the PostScript printer.
Choose Binary if you can; it produces smaller files and keeps all original data. If you're
having printing problems, choose ASCIL. JPEG compresses the file, but discards data
and may cause color-separation problems. Avoid it if possible.

v Include Halftone Screen and Include Transfer Function: Use these options for offset
print jobs. Leave these options to the service-bureau or commercial-printing experts.

v Transparent Whites: If your image is in Bitmap color mode, this option allows white
areas to appear transparent.

v PostScript Color Management: This option converts the file’s color data to the printer’s
color space. I do not recommend selecting this option if you are importing your image
into a document that is color managed. For more on color management, see Book II,
Chapter 3.

v Include Vector Data: When selected, this option preserves any vector graphics, such as
type and shapes. However, it is preserved only when you import the file into another
program. If you reopen the EPS in Photoshop, however, your vector data is rasterized.

v+~ Image Interpolation: This option anti-aliases (softens the edges) of low-resolution
images when printed.

PDF: The Universal Donor

PDF is the acronym for Portable Document Format, which is the native format of Adobe
Acrobat. This format, developed by Adobe, can contain editable text, vector, and raster data.
PDF files are often used for electronic documentation that will be downloaded from the Web.
You’ve probably noticed that every Adobe Help document is in PDF format, and if you're a
Web user, you've probably downloaded more than a few PDFs. Even the government, notori-
ously slow to catch on to new technology, has embraced PDF. The military uses PDFs for tech-
nical documentation. And all your tax forms are available as downloadable PDFs.

You might be thinking, “So what. I'm into images, not documents.” Well, hold on a second.
PDFs can be extremely useful in the imaging world as well. Anyone with a computer running
Windows, Mac OS, or Unix can read a PDF. All you need to view a PDF file is Adobe Acrobat
Reader, which is available as a free download from the Adobe Web site. If you save your image
as a PDF and e-mail it (or post it on the Web as a downloadable file) to a colleague, manager,
client, or friend, that person can see your image — colors, fonts, and all — exactly like you see
it. The other nice thing about PDFs is that they have an automatic compression process that
makes the files small and manageable for mail transfer or loading on the Web.

When you save a file as a Photoshop PDF, you have all the same save options of the native
Photoshop format. PDF supports layers and annotations, so select these options if you have
either one. It also supports the same image modes as the native Photoshop format. In addi-
tion, you can now save 16-bit images as PDF. Here is a description of the other options found
in the PDF Options dialog box, shown in Figure 2-7:
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PO¥F Options
Figure 2-7 Encording ey
or
@ ec Cancel
Quality; (10 Maximum 81

image merpolation

W POF Security [ Securmty Setings
POF Security
v Fassyword Reguired 1o Open Document

Document Open Password Cancel

~ PFaryvword Regured 1o Change Permugsion and Papswords

Permissions Pasveoed

Compatibility:  40-bit RC4 (Acrobat 3.x, 4.x) 18]
No Printing
No Changing the Document

No Coment Copying or Extraction, Disable Acceisibility
No Adding or Changing Comments and Form Fields

& I 488, the Permisdions Prsdword id requined aach time the fle i1 opened
in Photoshop. Other security restrictions (such as printingl are applied
to the Ale only when R 15 opened in Adobe® Acrobat®

Encoding: Choose Zip compression if optimum print quality is an issue. Otherwise,
select JPEG at the maximum setting.

Save Transparency: When selected, this option preserves any transparent areas in your
file. This option is grayed out if your file doesn’t contain transparency or has a spot
color channel.

Image Interpolation: This option anti-aliases, or slightly softens the edges, of low-
resolution images when they are printed. Keep this option selected.

Downgrade Color Profile: If you selected ICC Profile (Windows) or Embed Color Profile
(Mac) in the Save dialog box in Photoshop Version 4, selecting this option downgrades
the profile to Version 2. Select this option if you need to open the file in a program that
doesn’t support Photoshop Version 4 profiles.

PDF Security: Click the Security Settings button to access the PDF Security dialog box,
also shown in Figure 2-7. You can assign a password for opening the file in Acrobat
Reader. You can also assign a master password that is required to open the file in
Photoshop, which then allows for full access, enabling you to make changes to the
image and to the passwords themselves. On the Compatibility pop-up menu, choose
the type of encryption — 40-bit RC4, a low encryption level, is fine if you just want to
prevent opening the file. Choose a higher level 128-bit RC4 encryption if you want more
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specific options regarding accessibility (for disabled persons), level of content changes

allowed, and allowable printing resolutions. Finally, choose whether you want your user
to be able to print or change the document, copy it or extract content, or add or change
comments and form fields.

Note that Acrobat 3 and Acrobat 4 users cannot open PDFs with 128-bit RC4 (Acrobat 5)
encryption. And similarly, Acrobat 3, Acrobat 4, and Acrobat 5 users cannot open PDFs with
128-bit RC4 (Acrobat 6) encryption.

v Include Vector Data: Select this option to preserve vector paths. If you have text in
your file, select the Embed Fonts option, which ensures that your fonts display cor-
rectly on any computer, even if those fonts aren’t installed. But be sure not to use any
faux styles or warped text. Embedding fonts increases file size, but it is well worth it. If
you select the Use Outlines for Text option, Photoshop converts all your text to paths.
This can be helpful if your fonts aren’t displaying or printing properly, but you won’t be
able to select the text or use the Search command in Acrobat. Your text does remain
editable in Photoshop, however.

is a great way to e-mail images to coworkers, family, and friends. Choose Filer> Automater>

s You can now save multiple images into a single, multi-paged PDF document or slide show. This
PDF Presentation. For more details, see Book X, Chapter 3.

Photoshop

Of course, I can’t forget the native Photoshop format (. psd). This format offers a lot of bene-
fits. First of all, along with TIFF and PDF, Photoshop allows you to save layers in your image.
The other formats flatten the layers into a single background. This format works well if you
are going to spend a considerable length of time working on your image. The Photoshop
format also supports all image modes, is the fastest format for opening and saving, and offers
all the various save options.

Like TIFF, the Photoshop format uses a lossless compression process, although it’s invisible to
you. If you need to open a file in an older version of Photoshop, be sure to save it as a native
Photoshop file. Finally, almost all drawing and layout programs now support the importing of
Photoshop files.

Photoshop Raw

This format is designed to transfer images among applications and platforms. The Photoshop
Raw format can be useful if you want to transfer an image to or from a mainframe computer or
other type of device that doesn’t support the standard graphic formats. Don’t confuse it with
the Camera Raw format described later in this chapter. The Photoshop Raw format supports
CMYK, RGB, and Grayscale images with alpha channels. It also supports Multichannel and
Lab Color images without alpha channels. The format allows for any pixel or file size, but it
doesn’t support layers.

You may never have to save a file in the Photoshop Raw format. And you may not want to
after you read the options involved in saving in this format. The Photoshop Raw format
imports and exports files in an uncompressed, binary format. The format does not specify
image size, color mode, or bit depth. It is simply comprised of bytes that represent the color
information in the image. Each pixel is represented by a brightness value, with 0 being black
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and 255 being white. The format then includes the total number of color channels in the
image, plus any other channels, such as alpha channels. In order to save a file in the
Photoshop Raw format you must specify certain settings found in the Photoshop Raw Options
dialog box:

v File Type (Mac OS only): This four-character ID identifies the file type. PRAW is the
default ID for the Photoshop Raw format. Leave this default setting.

v File Creator (Mac OS only): Another four-character ID which tells the operating system
which application created the file. Leave the default setting of 8BIM (Photoshop’s code),
unless you know the special file creator ID for the application you plan on using the file
with. Many Mac applications have file creator IDs registered with the Apple Computer
Developer Services group.

v Header: This parameter specifies how many bytes of information appear in the file
before the image data starts. The default setting of 0 means there is no header. If, for
example, you enter a 2, two zeros are entered at the beginning of the file as placehold-
ers. When you open the Photoshop Raw format, you can then replace those placehold-
ers with a header. | recommend leaving the value at 0.

v Save Channels In: Choose between Interleaved Order and Non-Interleaved Order. The
default setting of Interleaved Order stores the color data sequentially by pixels. In other
words, in an RGB image, the first byte is red for the first pixel, the second byte is green
for the second pixel, the third byte is blue for the third pixel. Non-Interleaved Order
stores the color data by channel. In this case, the first byte is red for the first pixel, the
second byte is also red for the second pixel. Once the red channel is complete, it then
goes and saves the green and then the blue channel.

Your choice depends on requirements of the application that will open the file.

Camera Raw

-~ The Camera Raw file format is the format used by many digital cameras to capture and save
&Qﬂ wa image data and also the image’s metadata. In fact, this format captures everything there is to
> get about an image. Each camera has its own proprietary raw image format. Fortunately,

Photoshop can support most camera models, especially higher-end cameras. In this new ver-
sion of Photoshop, the Camera Raw plug-in has been directly incorporated into the applica-
tion, which enables you to work more efficiently with camera data. It also enables you to
quickly select and apply your Camera Raw settings by batch processing images using the
File Browser. Within the plug-in, you will find controls to make adjustments in white balance,
exposure, shadows, contrast, saturation, sharpness, and so on. If, by chance, the Camera Raw
plug-in doesn’t support your particular camera model, contact Adobe to see if they will be
supporting it in the near future.

Camera Raw files utilize a lossless scheme to capture and save image data, similar to TIFFs.
This is advantageous, because no data is lost through compression as it is with the JPEG
format. Camera Raw files also have the advantage of being smaller than uncompressed

TIFFs. Of all the digital camera file formats, only Camera Raw images contain the actual,
unadulterated data captured by the digital camera’s sensor (a Charged Coupled Device [CCD]
or Complementary Metal-Oxide Semiconductor [CMOS]) without any camera adjustments,
filters, and other processing. Many hard-core photographers consider this file format to be
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the pure digital “negative,” so to speak. They prefer to analyze, manipulate, and adjust the
image data themselves rather than leaving those decisions to the mercy of the camera. This
file format also prevents the loss of any image data that can sometimes occur when a file is
converted from its native format to a more commonly used format like TIFF or PSD.

Your camera may not capture images in the Camera Raw format. It may just allow you Book
@ to save your images as either JPEG or TIFF. Don’t worry. You'll be fine with these formats. 1/}
However, if your camera is capable of saving images in Camera Raw format, you want to Chapter
check out the capabilities of this plug-in. Because going into detail on each setting found in 2

the plug-ins dialog box is beyond the scope of this book, be sure and visit www.adobe . com/
products/photoshop/cameraraw.html. Here you will find a downloadable User Guide,
a Q&A file, and great tutorials showing you all you need to know about working with the
Camera Raw plug-in.

PICT

PICT, for Macintosh Picture, is a format developed by Apple as its main format for Mac graph-
ics. It is based on the QuickDraw screen language. And although many Mac programs support
PICT, I don’t recommend using it for any images that you plan to print. PICTs are notorious for
being absurdly slow in the printing department. Today, PICT images are usually used for
graphics to be incorporated into slides, screen presentations (such as PowerPoint), multi-
media projects, and digital video. PICT supports RGB (with a single alpha channel), Indexed
Color, Grayscale, and Bitmap (without alpha channels) image modes.

Make sure that QuickTime is running if you want to save a file as a PICT. Here are the options
that appear in the PICT File Options dialog box, shown in Figure 2-8:

Fi 2.8 MCT File Options
igure 2- Resolution D
0 16 bits/pixel F Cancel )
® 12 bits/pixel

Compression

O None

© IMEC (low quality)

O IPEC (imedium quality)
O PEC (high quality)

® PEC (maximum quality)

v Resolution: Options for grayscale images are 2, 4, and 8 bits per pixel. Options for color
images are 16 and 32 bits per pixel. Under no circumstances should you change the
default option. If you do, you delete colors from your image, and you cannot access the
compression settings.

v Compression: The compression settings for PICT are more limited than those for the
regular JPEG format. Be aware that the compression scheme used for PICTs causes even
more degradation to your image than with JPEGs. To minimize the damage, always
select the maximum quality setting.



158 ook 11 Chapter 2: Choosing Color Modes and File Formats

BMP

BMP is a standard Windows file format commonly used for saving images that you want to
make part of your computer’s resources, such as the wallpaper that you see on your Windows
desktop. BMP is also a format used by computer programmers. BMP supports RGB, Indexed
Color, Grayscale, and Bitmap image modes.

Here are your options when saving a BMP file:

v File Format: Choose between Windows and OS/2.

v Depth: Although you can select a bit depth, | recommend leaving the default setting
Photoshop has selected for you.

v Compress (RLE): The compression scheme used is lossless, which is great, but don’t
select this option if you are creating wallpaper. Windows won’t recognize it.

v Flip Row Order: This option enables Windows to recognize the file by reading the first
row of pixels first and the last row last. It is for programmers who are coding for
Windows applications. Leave it deselected unless you're one of them.

Don’t worry about the Advanced Modes option. It is even more eggheady than the other
options and strictly programming territory.

Large Document Format (PSB)

o Work with humongous files? Then you'll be pleased to know that the Large Document
&V?’ Nfgj Format supports files of any size. Besides the Photoshop Raw and TIFF file formats, the Large
X Document Format is the only other format that can save files over 2GB. What's even better
is that the coveted features, such as layers, layer effects, and filters, are all supported by this
format. If you want to work with large files, just make sure you have the Enable Large
Document Format option selected in the File Saving panel of your Preferences.

You knew it was too good to be true, right? Just remember that Large Document Format

files can be opened in Photoshop ¢s only. So make sure any recipients of your files have the
latest and greatest version of Photoshop. This limitation isn’t confined to older versions of
Photoshop either. Be forewarned that many other applications fall to their knees when pre-
sented with a file size larger than 2GB.

The others

The formats I describe in previous sections are ones you'll use 99 percent of the time, but
here’s a brief description of some of the others, just in case you're curious:

v Photoshop DCS 1.0 and 2.0: A version of EPS, this format divides your CMYK or
Multichannel image into Desktop Color Separations (DCS). DCS 2.0 supports spot and
alpha channels. It requires a PostScript printer to print.

v EPS Pict Preview/EPS TIFF Preview: These EPS formats are created in applications,
such as Quark Xpress, which create previews but aren’t directly supported by
Photoshop. However, you can open and edit these files.
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PICT Resource: This format, Macintosh Picture Resource, is used for Mac start-up
screens. You can use images that are in RGB (with a single alpha channel), Indexed
Color, Grayscale, or Bitmap (without alpha channels) modes.

PCX: This is the native format for PC Paintbrush. This format supports RGB, Indexed
Color, Grayscale, and Bitmap color modes. It doesn’t support alpha channels. Images
can have a bit depth of 1, 4, 8, or 24, and RLE compression is supported.

Acrobat TouchUp Image: Editing an image in Adobe Acrobat with the TouchUp tool
allows the file to be opened in Photoshop. That image is then saved in this file format,
which uses a . pdf extension. You can also open Adobe TouchUp Images in Photoshop.
Mac OS X screenshots are also saved in this format by default.

PhotoCD: This Kodak file format allows a single file to contain five different resolutions
that you can open.

PixelPaint: This format is an early file format native to Apple’s first color paint program.

PNG: A newer format for Web graphics, PNG (Portable Network Graphics) offers good
lossless compression, transparency, and 24-bit color. PNG supports RGB, Indexed Color,
Grayscale, and Bitmap image modes. See Book IX, Chapters 1 and 2.

Pixar: This is the format used for Pixar workstations, which are high-end, 3-D-modeling
computers. You can use RGB or grayscale images with a single alpha channel.

Filmstrip: This format is used for animation and digital video. For more information, see
Book X, Chapter 1.

IFF Format: The IFF (Interchange File Format) is a general storage format that can store
different types of data, such as image, sound, music, video, and textual information. The
popular modeling program Maya uses the IFF format.

MacPaint: This oldie but goodie is the native file format for Apple’s early black-and-
white paint program.

Generic PDF: Generic PDFs are created in programs such as Adobe Acrobat and
[llustrator and can contain multiple pages or images. When you open a Generic PDF
with multiple pages, you can specify which page you wish to open. If you open a
Generic PDF with vector graphics, Photoshop rasterizes the image.

Generic EPS: When you open a vector graphic, Photoshop rasterizes the graphic as a
Generic EPS. Generic EPS can also be created in other non-Adobe imaging, drawing, and
layout programs.

QuickTime Movie (ImageReady): This cross-platform format is used mainly for digital
video. ImageReady enables you to open and save animations as .mov files. Note that
Windows users must have QuickTime installed in order to have this format listed on
their File of Type pop-up menu.

Macromedia Flash (SWF) (ImageReady): The Flash file format is used for saving stream-
ing animations, which are commonly integrated in Web sites. This format allows you to
embed other file formats such as JPEG.

WBMP: This format, Wireless Bitmap, is used for images that will appear on mobile
devices such as cell phones and PDAs. WBMP supports only 1-bit color (black or white).
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v Portable Bitmap (PBM): This 1-bit, monochrome file format is mainly for Unix platforms
as an intermediate file format used in graphic conversions.

v Scitex CT: This format, Scitex Continuous Tone, is designed for Scitex prepress software
and hardware.

v SGI RGB: The high-end Silicon Graphics computer platform uses this format for RGB and
Grayscale images. Files can be recognized by their .sgi, .rgb, or . bw file extensions.

v Targa: Developed by TrueVision for its video boards, Targa is used to capture still
frames from video on PCs. This format supports RGB, Indexed Color, and Grayscale
images, the latter two without alpha channels.

v Raw: This format is used to exchange files between PCs and Macs and mainframe com-
puters. It is often used to save images created by scientific applications. Be aware that
this format sacrifices colors and other image data.

v~ Alias PIX, Wavefront RLA, Electric Image, and Soft Image: These are extremely high-
end formats used for 3-D, animation, and special-effect graphics.

v Cineon: Kodak developed this high-end file format. Cineon files have 10 bits per channel
and are used in the film industry for electronic compositing and enhancement.

v Photoshop 2.0: Use this format if you know someone living in an ice cave in Siberia who
is still using Photoshop 2. This format is Mac only.



Using and
Managing Color

In This Chapter
v Specifying colors
v Using the Color Picker

v Working with the Color
palette

v~ Selecting color swatches

v Working with the
Eyedropper and Color
Sampler

v Managing color

hand, choosing colors and applying them is easy, fun, and

stress free. On the other hand, managing color — that is,
making what you see on-screen match what comes out on
paper (or in your browser) — can be difficult, frustrating, and
chock-full of stress.

C olor in Photoshop takes on two personalities. On one

Unfortunately, you have to be well versed in both picking great
colors and managing colors for print. (What'’s the use of creat-
ing the next Mona Lisa in Photoshop only to find it looks like a
fifth-generation color Xerox copy?) In this chapter, [ start out
by showing you how to define and apply color; then I ease you
into the world of color management.

If you haven’t already read the section on color theory in Book
I, Chapter 2, you might want to give it a gander before you dive
into this chapter. Knowing a little color theory may make this
chapter a little more, er, palette-able.

Dealing with Foreground and
Background Colors

Photoshop has two categories of color — a foreground color and a
background color. You apply the foreground color when you use
the type tools, the painting tools, or the shape tools. It is also the
beginning color of a default gradient applied by the Gradient tool.
The background color is the color you apply with the Eraser tool
(assuming you don’t have layers) and is the ending color of the
default gradient. When you increase the size of your canvas, you
fill the additional canvas with the background color (also assum-
ing you don’t have layers). You find the swatches that represent
the two color categories in the lower part of the Tools palette
(also known as the Toolbox), as shown in Figure 3-1.
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Figure 3-1 Switch foreground

and background colors
Foreground color
Background color
Default colors E

labeled in Figure 3-1 to return the colors to the defaults or simply press the D key. That's
easy to remember. To switch the foreground and background colors, click the curved arrow
in the Toolbox or press the X key.

s The default color for the foreground is black; the background is white. Click the small icon

Here are a few tips about using tools with foreground and background colors:

v Use the Brush tool or the Pencil tool with the foreground color. These tools always
apply the foreground color.

v Blend the foreground and background with the Gradient tool. When you drag with
the Gradient tool across the canvas and the gradient is set to the default, you get a
blending of the foreground and background colors.

v~ Fill selected areas with the foreground color. Just click your canvas with the Paint
Bucket tool to select areas based on a Tolerance setting and fill those areas with the
foreground color.

v Apply the background color by erasing. If you are working on a background rather
than a layer, you can use the Eraser tool to apply the background color. Some people
prefer to say you are erasing to the background or canvas color.

If you use the Eraser tool on a layer, you erase to transparency. See Book V for the
scoop on layers.

1 Use the Shape tools to create shapes that are filled with the foreground color. Simply
create the shape, and voila.

v Add more background to your canvas and fill it with the background color. When
you enlarge your canvas size, Photoshop automatically fills the added canvas with the
background color.

If you enlarge a layer, the extra canvas is transparent. See Book II, Chapter 1, if the word
canvas seems foreign to you.



Defining Color

Like most everything else in Photoshop, you can choose color in several ways. I explain each
of the following color definition options in upcoming sections:

)

X Y\

Click a color in the Color Picker.

Move the sliders in the Color palette.

Defining Color

Sample color from your image (or elsewhere) with the Eyedropper tool.

Grab a color from the Swatches palette.

Poking around the Color Picker

When you click either the Foreground or Background color swatch in the Toolbox (also called
the Tools palette), you're transported magically to the Color Picker. This huge dialog box,
shown in Figure 3-2, allows you to select a color from the color spectrum (called a color
slider) or to define your color numerically.

Choosing a color visually is fine for Web or multimedia work, but not recommended for
print work, of course. Among other reasons, your monitor uses an RGB (red, green, blue)
color model, whereas printers use a CMYK (cyan, magenta, yellow, and black) model. For
more on this and other color management issues, see “Color Management Essentials,” later
in this chapter. For the basics of color theory, see Book II, Chapter 2.

To choose a color visually with the Color Picker, follow these steps:

1.

=

Click either the Foreground or
Background color swatch in the
Toolbox.

The Color Picker dialog box appears,
as shown in Figure 3-2.

Click in the narrow color slider to get
in the ballpark for the color you want.

You can also move the slider.

To fine-tune your choice, click in the
large square on the left.

4.

This square area is called a color field.
The circular icon targets your selected

shade. The dialog box displays your
new chosen color as well as the origi-
nal foreground or background color.

The numeric values also change
accordingly to represent the exact
shade you’ve chosen.

Alternatively, if you know the numeric
values of the color you want to use,
you can plug in the values in the text
boxes on the right side of the Color
Picker.

When you’re satisfied with the color,
click OK to exit the Color Picker
dialog box.

CONTINUED
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. Color Picker
Figure 3-2
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You can do pretty much the same thing in the Color palette that you can do with the Color
Picker. | prefer the Color palette, so | go into more detail about it in the next section.

Mixing with the Color palette

To open the Color palette, shown in Figure 3-3, choose Window=>Color. A couple of swatches in
this palette may look vaguely familiar. That’s because they represent the foreground and back-
ground colors, just like the swatches in the Toolbox. And just like the Toolbox swatches, if you
click the swatches in the Color palette, the infamous Color Picker appears. But forget the Color
Picker; you don’t need to go there. Everything you need is right here in this tiny palette.

Before you use the Color Picker to define your colors, you should know which color model
you want to use. Here is a short description of each:

v RGB (Red-Green-Blue) is the color model used for anything that will be viewed on-
screen — from multimedia and slide presentations to content for the Web. Occasionally,
you can use it if you plan to print using desktop inkjet printers.

v CMYK (Cyan-Magenta-Yellow-Black) is the color model used in printing.

v Web Color is the model used strictly for the Web. If you choose this model, make sure
that you also choose Make Ramp Web Safe from the Color palette options menu.

v HSB (Hue-Saturation-Brightness), which [ don’t cover in Book II, Chapter 2, is based
on percentages of saturation and brightness and an angle (0 to 360 degrees), which
corresponds to a location on the color wheel.

v Lab (Lightness, a, b) color model contains three channels, one for lightness; one (a),
which contains colors from green to red; and one (b), which contains colors from blue
to red. Lab is more complex to understand and work with than the other models and is
the color model of choice for high-end color experts. By the way, Lab is also
Photoshop’s “native” color mode.
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v Grayscale is the color model if you want to work strictly in black and white and shades
of gray. You'll get one slider, K, which represents black. Move the slider to get shades of

gray, including complete white and black.

Here are the quick and easy steps to define a color by using the Color palette:

=

e

Choose either the Foreground or
Background color swatch in the
Color palette.

You can change only one swatch at a time.

If the one you want is already selected, do
nothing. A double outline appears around
the swatch indicating that it’s selected.

If you accidentally click the swatch
that is already selected, the Color
Picker dialog box appears. Just click
Cancel and start over.

Select your desired color model from
the Color palette pop-up menu.

Your options are RGB Sliders, CMYK
Sliders, Lab Sliders, Web Color Sliders,
HSB Sliders, and Grayscale Slider.
You'll probably be using RGB, CMYK,
or Web Color the majority of the time.
If you're not sure what these color
models represent, check out the previ-
ous list and review Book II, Chapter 2.
(See Figure 3-3.)

In the Color palette, move the sliders
for each component of the color
model or enter a numeric value.

RGB values are based on brightness
levels, from O to 255, with 0 being black
and 255 being the pure color or white.
CMYK values are based on percentages
(1-100) of the four process colors — Cyan,
Magenta, Yellow, and Black. The Web
Color model gives you only the 216 colors
used by Web browsers.

You can also select a color by clicking
inside the color ramp at the bottom of
the Color palette. And to quickly return
to the default colors, click the small
black and white swatches at the end of
the color ramp.

Keep an eye open for a triangular
alert icon, shown in Figure 3-3.

®

6.

This icon is known as the gamut alarm.
Its appearance is Photoshop’s way of
saying, “Hey, you! That color you mixed
won’t print like you think it will because
it’s out of gamut.” Remember gamut is
the range of colors a device can either
display or print.

Because the RGB color model has a
much wider gamut than the CMYK
color model, some of the colors can
only be viewed on-screen and not
reproduced on paper.

Photoshop offers you a substitution.
Inside a little square to the right of the
gamut alarm icon, the closest printable
color to the one you chose appears.

Click either the icon or the square if
you want to use the closest printable
color rather than your original choice.

The gamut alarm isn’t applicable if you
choose Web Color Sliders. You have
another kind of alarm described next.

If you want to use the RGB color model
but also want to ensure that any color you
choose is printable, select CMYK Spectrum
from the Color palette options menu. By
default, all the colors in the ramp are
printable. Just be sure to choose your
colors by clicking in the ramp.

Be on the lookout for a small cube icon.
Click either the icon or the square to
use the closest Web-safe color.

The cube indicates that the color you
mixed is not a Web-safe color. Clicking
the cube tells Photoshop that you want
to use its Web-safe alternative instead.
A Web-safe color ensures that the color
will not dither (mixing available colors
to simulate a missing color) when dis-
played in the browser.

CONTINUED
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Fugure 3-3 — ‘_ '—1:-.‘ Dock to Palette Well
H . Grayscale Slider
] 8| M) o RGE Shiders
| HSB Sliders <_n
CMYK Sliders
Lab Sliders
Web Color Sliders

Copy Color as HTML

v RGB Spectium
CMYK Spectrum
Grayscale Ramp
Current Colors

Make Ramp Web Safe

If you're monkeying around with print media
One thing that you do find in the Color Picker 3. Click OK to accept the color as your

that is absent from the Color Palette is the ability new foreground or background color,
to select custom colors, which are also known as or click the Picker button to return to
spot colors. Spot colors are premixed inks used in the Color Picker.

printing and manufactured by various compa-
nies such as Pantone or Trumatch. You can use
spot colors in addition to or in lieu of CMYK
colors in the printing process. To pick a custom
color, follow these steps:

Do not choose spot colors visually; choose them
from a printed swatch book published by the ink
manufacturer. The books, which provide the
numeric values for each spot color, provide a
true representation of how the color will appear
1. Click the Custom button in the Color when printed.

Picker dialog box. During the RIP (raster image processing) — the

The Custom Colors dialog box opens, as  process your image goes through to create color
shown in the following figure. separations for printing — Photoshop converts

2. Ch desired I custom colors to CMYK for every image mode
- Choose your desired custom color (except Duotone), unless you create spot color

book from the pop-up menu an-d th‘_’“ channels. For more on this technique, see Book
select your color from the scrolling list X, Chapter 2. For more on image modes, see
of swatches. Book Il, Chapter 2.

Custom Colors

a CGre)
:  mcker )
n

L 64

a 59

b -19

Type a color name to
select it in the color list
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Grabbing color from the Swatches palette

Another way to define a foreground or background color is by clicking a color in the Swatches

palette, shown in Figure 3-4. Choose Windowr>Swatches to bring up the palette.

<

Dock 1o Palette Well
New Swatch

Small Thumbnail
Semall List

Preset Manager

Reset Swatches
Load Swatches.
Save Swatches
Replace Swatches

ANPA Colors

DIC Color Guide
FOCOLTONE Colors

HKS E Process

HKS E

HKS K Process

HKS K

HKS N Process

HES N

HKS 2 Process

MKS Z

PANTONE metallic coated
PANTONE pastel coated
PANTONE pastel uncoated
PANTONE process coated
PANTONE solid coated
PANTONE solid matte
PANTONE solid 1o process
PANTONE solid uncoated
PANTONE solidtoprocess EURD
Photo Filter Colors

TOYO Color Finder

TOYD Process Color Finder
TRUMATCH Colors

Mac 0§

VisiBone

VisiBone?

Web Hues

Web Safe Colors

Web Spectrum

Windows

You can have any tool active when you use the Swatches palette to define a color because as
soon as you move the tool over the Swatches palette, it changes to an eyedropper icon that
samples the color. (You're still using whatever tool is active; the cursor simply changes to

indicate that you temporarily have the

capabilities of the Eyedropper tool.)

Besides being a way to select your foreground and background colors, the Swatches palette
acts like a traditional artist’s paint palette in digital form by letting you store as many colors
as you want in the palette for later use.
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To change the background color, either select the background swatch icon in the Color
palette or simply Ctrl+click (88+click on the Mac) a swatch.

Here are some of the things you can do with the Swatches palette:

v Customize the Swatches palette’s display. You can choose how to display the Swatches
palette by choosing Small Thumbnail (swatch thumbnails) or Small List (swatch thumb-
nails along with a name) from the Swatches palette pop-up menu (click the right-pointing
triangle in the upper right to open the menu).

v Use preset colors. To load a particular preset swatch library, choose it from the list on
the Swatches palette pop-up menu. Click Append to add the library to the existing
swatches or OK to replace the existing swatches. You will find libraries specific for Web
graphics and for implementing spot colors such as those created by Pantone, Toyo, and
Focoltone. You can also select Load Swatches from the Swatches palette pop-up menu.
In the Load dialog box, navigate to the Color Swatches folder by following this path:
Adobe Photoshop>Presetsr>Color Swatches; and select your desired library:.

You can also work with swatches by using the Preset Manager. For more on the Preset
Manager, see Book I, Chapter 6.

v Customize your own Swatches palette. To add a color to the Swatches palette, do one
of the following:

Click the New Swatch icon (the dog-eared page icon) at the bottom of the Swatches
palette.

Choose New Swatch from the Swatches palette pop-up menu. Name your swatch and
click OK.

Click an empty spot in the Swatches palette (your cursor changes to a Paint Bucket
icon). Name your swatch and click OK. Or Alt+click (Option+click on the Mac) on an
empty spot to add the color and bypass the Name dialog box.

v Delete swatches that you don’t want anymore. To delete a swatch, drag it to the trash
can icon at the bottom of the Swatches palette. Or Alt+click (Option+click on the Mac)
over a swatch. Your cursor changes to a pair of scissors.

v Create your own library of swatches. To save a set of swatches as a library, choose
Save Swatches from the Swatches palette pop-up menu. Navigate to the folder you want
to save the library in.

| recommend saving libraries in a subfolder of the Presets folder. Follow this path: Adobe
Photoshop=>Presets=>Swatches; then create your own folder, name the file, and click Save.

v Restore your default swatch libraries. To return to the default library of swatches,
choose Reset Swatches from the Swatches palette pop-up menu. You can choose to
either replace or append to the current library.

Lifting and sampling color

Photoshop lets you change foreground or background colors by lifting them from the image
with the Eyedropper tool. Using the Eyedropper tool comes in handy when you want to sample
an existing color in an image for use in another element. For example, if I want my text to be
the same color as the flower in my image, I click a petal with my Eyedropper tool, which then
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lifts (samples) the color and makes it my new foreground color. I then create my type, which
uses that foreground color. Voila — color coordination at its finest.

Here are some handy tips for using the Eyedropper tool to suck up color from one place and
use it elsewhere in your image:

)

Choose any color you want from any image that’s open. If you have multiple images
open, you can also click inside an image that you’re not working on. In fact, if that
doesn’t knock your socks off, you can lift any color you see on-screen, even from a file
in another application such as Illustrator or from your desktop. Just drag your
Eyedropper from the image window onto the color you want to sample.

Choose your sampling area. You have only one option (found in the Options bar) to
worry about when using the Eyedropper tool. You have the option of selecting the color
of just the single pixel you click (Point Sample). Or Photoshop will average the colors of
the pixels in a 3-x-3- or 5-x-5-pixel radius.

Make colors Web safe with a right-click of your mouse button. For you Webbies out
there, if you right-click (Ctrl+click on the Mac) on your image to bring up the context
menu, you have one more option — Copy Color as HTML. This option converts the sam-
pled color to a Hexadecimal color code that’s safe for the Web and copies the code to
the Clipboard so that you can paste the code into an HTML file.

Toggle between the Eyedropper and other tools. For your productive painting pleas-
ure, when you're using the Brush, Pencil, Gradient, Paint Bucket, or Shape tool, pressing
Alt (Option on the Mac) allows you to temporarily access the Eyedropper tool. Release
the key and return to your original tool.

Toggle between the background and the foreground. If the foreground color swatch is
active, press Alt+click (Option+click on the Mac) with the Eyedropper tool to lift a new
background color. If the background color swatch is active, pressing Alt+click
(Option-+click on the Mac) lifts a new foreground color.

To use the Eyedropper tool, you first need to decide whether you want to change the fore-
ground or background color. Then follow these steps:

1.

2.

Select the foreground (or the back- Fortunately, the Eyedropper looks
ground) in the Tools palette or the exactly like a real eyedropper.

Colors palette. 3. Click the color in your image that you
Select the Eyedropper tool in the want to use.

Tools palette (or press the I key). That color becomes your new fore-

ground (or background) color.

Using the Color Sampler tool to measure color

The Eyedropper’s cousin, the Color Sampler tool, looks like an eyedropper with a small target
next to the icon. It also shares the Eyedropper’s flyout menu.

The moniker of “Sampler” is kind of misleading because this tool only measures the colors you
click. Aside from merely obtaining the numeric value of a color, another use of the Color Sampler
tool is to monitor changes to your image after you apply color-correction techniques and filters.

CONTINUED
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Follow these steps to use the Color Sampler tool:

1. Select the Color Sampler tool in the
Tools palette and then click the color
you want to measure.

3.

Note the target icon that appears on
your image. It is labeled as #1.

Photoshop automatically opens the
Info palette and shows you the numeric
values for that color, as shown in
Figure 3-5.

Repeat Step 1 up to three more times
for a total of four targeted colors.

Figure 3-5 ] I ] F o]

®

Target icons appear for your second,
third, and fourth samples.

With the Color Sampler tool, drag the
targets to sample new areas of your
image if you want. Delete a target by
Alt+clicking (Option+clicking) it.

You can actually measure a fifth color by
just moving the Color Sampler cursor
around the image. The numeric value dis-
plays in the upper portion of the Info
palette.
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Color Management Essentials

Grab some Tylenol. You're about to delve into the rather confusing and sometimes cantanker-
ous world (or as some users would call it — underworld) of color management. It is, by far,
the biggest headache of every graphics professional’s day-to-day experience. And I'm sure
quite a few home users also scratch their heads wondering why their digital photo looked

so great on-screen and turned into a muddy mess on paper.

Reproducing color is not an exact science. In fact, sometimes you would think it takes an act

of voodoo magic to get the output you want. Don’t throw up your hands and live with what-
ever output comes out the other end; if you can't change the color, you can at least change
your attitude toward color. Getting a handle on color management requires four things —
some knowledge, some patience, a significant amount of time to experiment and test, and,
most importantly, acceptance. Acceptance of the unfortunate fact that we don’t live in a
WYSIWYG world. What you get in one medium is sometimes merely an approximation of
what you see in another.

Why? Well, I'll start with the basic gripe of many users as they look disapprovingly at their
printout — “But it didn’t look like that on the screen!” As detailed in Book II, Chapter 2, there
are two major color models — RGB (Red-Green-Blue) and CMYK (Cyan-Magenta-Yellow-Black).
The RGB color model (16.7 million colors), which all monitors use, has a significantly wider
range of color (called a gamut in computer lingo) than the CMYK color model (approximately
55,000 colors) that is used by printers. The result is that many of the colors you see on-screen
fall outside the CMYK gamut and therefore cannot be reproduced on paper. And in some
cases, some CMYK colors fall outside the RGB gamut. Programs such as Photoshop try to do
their best by providing colors that are the closest match. But those bright and vibrant colors
that are out of gamut are matched with duller, darker versions at best.

And if that difference alone isn’t enough to complicate matters, hardware devices that share
the same color model can possess different gamuts within the same color model. For example,
the RGB color space of a monitor can differ from the RGB color space of a scanner. Not only
that, but you can also have different color spaces within the same type of device. A 15-inch
generic monitor won'’t display color equal to a 21-inch Sony Trinitron monitor. Likewise, an
Epson printer may not share the same color space as a Hewlett-Packard or Lexmark printer.
So when you take into account the differences that can occur between platforms, monitors,
printers, browsers, scanners, applications, paper and other substrates, or any of the almost
infinite number of possible permutations, it makes you want to return to the days of quill and
parchment. Techies often call this mind-numbingly large number of possible inconsistencies
device-dependent color. In other words, the color is dependent upon the hardware device. And
device-dependent color varies. That’s just the cold, harsh reality, and nothing’s changing that.

But Adobe, being the kind and benevolent software mega giant that it is, has developed (first
introduced in Version 5.0) a color management system designed to be device independent.
The five-cent explanation of this system is that you first identify your working color spaces.
Photoshop then tags your files with that color space by embedding a color profile (also known
as an ICC profile) with your files. The program then analyzes any color space in which you
either view or output a file and makes adjustments on the fly so that the color is viewed and
printed reasonably accurately and consistently, in theory, independent of the device.
Photoshop also reads the embedded color profile (or lack thereof) of any file you open and
addresses how you wish to deal with that profile if it doesn’t match your working color space.
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In the

upcoming sections, [ give you the 25-cent explanation — which I hope is enough to

get you managing color. If color management is an extremely critical workflow issue to you,
[ recommend buying a book or two strictly devoted to nothing but managing color. It is well
worth the dollars.

Setting up your work environment

One aspect of color management that people often overlook is setting up a good working envi-
ronment for digital image editing. You may wave your hand impatiently and say, “Yeah, yeah, I
just want to get to the important stuff.” This is the important stuff.

Don’t worry. Setting up a good work environment won’t cost you anything. Just do these
things:

7

©)

7

‘/

Do always keep your computer desktop a neutral gray. | know having dancing bears and
family photos in the background is tempting, but these elements don’t contribute to a
good viewing environment. Colors and patterns behind your images influence the way
that you view those images. Creating a neutral, gray desktop is the closest you can get
to mounting your work on gray, black, or white mat board (and not neon green or pais-
ley) the way professional graphic designers and photographers do.

Do keep your lighting as consistent as possible. Avoid working on or viewing images in
full, bright afternoon sun and then again under a single desk lamp late at night. Keep the
level and intensity as consistent as possible, and be sure to look at your source mate-
rial, along with the images you’re working on, under the same intensity of light.
Likewise, view on-screen images and your printed output under the same lighting,
thereby establishing a consistent benchmark to use in your Photoshop editing sessions.
Variations in lighting can cause you to perceive color differently and can then lead to
color shifts in your output. And whatever you do, please, no disco balls.

If your desk is next to a window, you may want to invest in a monitor hood or visor to cut
down on screen glare and reflections. They run around $15 to $100. And if you find you
really want an optimum lighting situation, you can look into a couple of additional devices.
Task lamps provide consistent full spectrum light and enable you to see color with more
accuracy and clarity. They run $50 to $200 and even help to cut down on eyestrain. A light
box (or light booth or color viewing booth) offers various lighting environments, from fluo-
rescent to daylight. Professional grade light boxes adhere to lighting standards developed by
ISO (International Standards Organization). They allow you to view images in a consistent
and controlled environment. Depending on the make and the model, the cost of a light box
ranges from a few hundred dollars to several thousand.

Do keep the walls of your work environment as neutral as your monitor desktop. You
don’t have to paint your office gray, but try to avoid lots of colorful posters and artwork
in your direct line of vision (around and behind your monitor).

Speaking of monitors, if you are using an LCD (flat screen) monitor, rather than a real-
estate hogging CRT monitor, do be sure you are sitting directly in front of it, because
color shifts quite a bit on LCDs if you are viewing it at even a slight angle. So no slump-
ing in your chair!
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And because you shouldn’t slump, for many reasons, do make sure you have a comfort-
able desk and chair.  mean, let’s be honest, if your back or neck is screaming with pain
while you are trying to edit an image, you won'’t last long. Invest in a chair with good
support. If you experience wrist or hand strain, check out those squishy gel pads for
your mouse and keyboard. It is amazing how much those little buggers can help.

For print work, do keep a swatch book (or two) handy, such as those from Pantone or
Trumatch, to choose your colors. Don’t make a decision based on what you see on-
screen. These books give you a true representation of how color looks when printed on

papetr.

| recommend getting a swatch book that shows both spot (premixed inks of a single color)
and process colors (colors made by mixing the four process colors — Cyan, Magenta, Yellow,
and Black [CMYKD).

Be prepared for a healthy monetary investment when you buy a swatch book. These little bug-
gers can cost anywhere from $75 to $200 and need to be replaced over time as the colors can
fade. Keep them in a dark location to extend their life span. You can purchase swatch books
from some larger art supply stores or order them online. You can purchase Pantone books
from www.pantone. com. Do a search for others such as Trumatch, Focoltone, and Toyo.

If you buy imaging or printing services, do spend some time finding the best service
bureau and printer in your area and develop a good working relationship. Most likely,
you’ll run into a digital color expert or two hanging around. You should also stick with
that vendor for all your products — scans, prints, Kodak Photo CDs, slides, and so on.
You’ll know what to expect in terms of color and quality, and you’ll get better customer
service by being a regular.

Do take some time to test your workflow (production methods) and your computer
system. Scan images using multiple settings, print images using multiple settings, and
view your images using different browsers on different monitors and different platforms.

Get to know the strengths and limitations and quirks of every piece of your equipment.
Experiment with Photoshop. I know, [ know, you have a life. But trust me, it will be an
investment with great returns.

Calibrating your monitor

Calibrating your monitor and creating an ICC profile of your monitor ensures that your moni-
tor doesn’t display any red, green, or blue color casts and that it provides as neutral a gray
screen as possible. Calibration is incredibly important if you want to standardize your image
display — knowing that how you view your image today will be how you view your image
tomorrow or next week.

If you

really want to do a great calibration job, consider investing in a combination hardware/

software calibration package. These products used to be really pricey, but you can get a decent
package for around $250. You can choose from several manufacturers. ColorVision (www .
colorcal.com), for example, offers more than one program. The package includes software
that displays color swatches on your screen. Then a photoelectric device, called a colorimeter,
attaches to your monitor with a suction cup. The sensors in the colorimeter measure the color,
brightness, and other characteristics of the monitor. The software then takes the data, adjusts
the monitor, and creates a profile from the data.
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If more software isn’t within your budget, you can use the simple calibration tool that comes
with Photoshop (Windows) or your system software (Mac).

Turn on your monitor and let it warm up at least an hour. Then, if you're a Windows user, you
can use Photoshop’s Adobe Gamma utility. (Look for it in the Control Panel on the Windows
Start menu.) You can either use the Gamma utility’s wizard, shown in Figure 3-6, which walks
you through the calibration process by asking you a series of questions, or manually calibrate
your monitor by using sliders in the Adobe Gamma control panel.
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If you're a Mac OS X user, you can use the Display Calibrator Assistant. Choose Appler>System
Preferencest>Displays=>Color. Click the Color tab and then click the Calibrate button. Answer
the questions in the Display Calibrator Assistant. (See Figure 3-7.)

Both utilities, Adobe Gamma and the Display Calibrator Assistant, help you remove any color
casts and get as neutral a gray background as you can. They also create a profile of your moni-
tor for Photoshop, lllustrator, and other programs so that those applications know how your
monitor displays color.

For example, use an image that you've worked with and for which you have a good print and
then use that image each and every time you calibrate. Your goal is to match the digital image
on your screen to the printed image. You should calibrate every so often because monitors can
drift and degrade. Some experts say weekly; others are more liberal and say monthly is fine.

s When you calibrate your monitor, display an image for which you already know the color values.

You can also find various calibration utilities on the Web. Here are just a few. Do a search and
I'm sure you'll find a ton more.

V¥ www.viewsonic.com/support/calibration.htm
www.easyrgb.com/calibrate.php

www.risingphotography.com/calibration

X Y\

www.praxisoft.com
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By the way, not only is letting your monitor warm up a prerequisite before you calibrate, it is
also a good idea before you sit down to tackle any image adjustment work.

Establishing Your Settings

After you have calibrated your monitor (see the preceding section) and adequately arranged
your work environment, you need to nail down the color settings and make sure that they're

the right match for your intended output.

Choose Edite>Color Settings (Preferencest>Color Settings on the Mac). The intimidating Color

Settings dialog box rears its ugly head, as shown in Figure 3-8.

©)

In the Color Settings dialog box, you can choose from predefined settings established for spe-
cific types of output, or you can customize your own settings to fit your individual needs. And
there’s no law that says that you can’t have multiple groups of settings — one for each type of
project. Maybe you create both Web and print graphics. In that case, you may want to have a

set of options for each workflow.

As you're perusing the dialog box, hover your cursor over any item, and a great description
of that item appears at the bottom of the dialog box.

The following sections offer more details about the settings you can choose in the Color

Settings dialog box.
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Handling Photoshop’s predefined settings

In the Color Settings dialog box, Photoshop allows you to take the easy route and choose from
a long list of predefined color settings based on your desired output.

After you've set up the predefined settings, Photoshop provides all the appropriate working
color spaces and color management policies you need to get good color results. Being the
smart program that it is, Photoshop won’t steer you down the wrong path with its predefined
settings. The only way you can mess up the predefined settings is if your output doesn’t
match the setting. Say you choose the Web Graphics Defaults setting for your high-end, four-
color print job; you'll be in for a surprise. (Hint: You may want to change those settings.)

Here is a brief description of the predefined color settings in the Color Settings dialog box:

v Custom: Allows you to manually assign your own settings. When you define a custom
configuration, save your settings so that you can reload them later if necessary.

v Color Management Off: Deactivates Photoshop’s color management system. I recom-
mend it for video output but not for anything else, unless you’re a color guru and know

what you’re doing.

v ColorSync Workflow (Mac only): Uses ColorSync 3.0 Color Management System and
ColorSync profiles. It’s not recognized by the Windows platform.

v Emulate Acrobat 4: Emulates Acrobat 4 and earlier versions.



Establishing Your Settings

Emulate Photoshop 4: Turns off color management and emulates Photoshop 4’s
display. Photoshop 4 didn’t employ color management.

Europe General Purpose Defaults: Provides general color settings for using Adobe
software in Europe.

Europe Prepress Defaults: Provides settings to be used for printing in Europe.

Japan Color Prepress: Provides settings to be used for printing in Japan. Uses the
Japan Color 2001 Coated CMYK profile, which provides for 350% total ink coverage.

Japan General Purpose Defaults: Provides general color settings for using Adobe
software in Japan.

Japan Prepress Defaults: Provides settings to be used for printing in Japan. Uses the
Japan Standard v2 CMYK profile, which provides for 300% total ink coverage.

North America General Purpose Defaults: Provides general color settings for using
Adobe software in North America. Uses the same CMYK, Grayscale, and Spot working
spaces as the U.S. Prepress Default, but uses the same RGB working space as the Web
Graphics Default.

Photoshop 5 Default Spaces: Uses the default color settings found in Photoshop 5, the
first version to use color management.

U.S. Prepress Defaults: Provides the settings for printing in the United States. This is a
good overall selection if you use Photoshop mainly for print work.

Web Graphics Defaults: Provides the settings for Web graphics. If you use Photoshop
primarily for Web content, this setting is a good option because it reflects the average
PC monitor.

You can always use a predefined setting as a starting point and adjust whatever individual
settings you need to. Note that if you do, your predefined setting name automatically
changes to Custom.

Indicating your working spaces

If you choose one of the predefined color settings, Photoshop plugs in all the necessary
remaining options in the dialog box. (If you select the Custom option, Photoshop leaves what-
ever settings were there previously because it knows you are going to choose your own set-

tings anyway.)

When you chose one of the predefined color settings, the first group of settings Photoshop
plugged in were your working spaces. Working spaces are the color profiles associated with
the RGB, CMYK, Grayscale, and Spot color modes. If you choose the Custom color setting, you
need to choose your own working spaces.

Each of the four working spaces is equally important, so | advise you to read all the following
sections — and read them in order — if you're serious about color management.

177

Book

]

Chapter

3



178

RGB working spaces

Book Il » Chapter 3: Using and Managing Color

Table 3-1 gives you a quick view of your RGB working space options.

TaBLE 3-1: RGB WoRKING SPACE OPTIONS

Working Space What It Does Recommendation

Monitor RGB The default setting for the predefined 1don’t recommend this setting
setting of Color Management Off unless you have a specific
and Emulate Acrobat 4. Sets the need to use it.
working space to your current
monitor space (which it gets from the
monitor profile you established during
calibration). Forces Photoshop to
turn off color management.

ColorSync RGB Sets the working space to the profile For Macintosh only.
specified in the Apple Color Sync
control panel. The default setting for
the ColorSync Workflow predefined
setting.

Adobe RGB (1998) The default setting for all the Prepress [ recommend this setting for all
predefined settings. It is the best color print work and as an overall
profile to use for viewing 24-bit images setting if you’re unsure what
and for converting RGB files to CMYK. to choose.

Provides a large gamut of RGB colors.

Apple RGB The default setting for the Emulate Adobe also says it can be used
Photoshop 4 predefined setting. Can with other older desktop pub-
also be used for older Mac OS scanners lishing applications, but unless
and monitors. you're the proud owner of a 13-

inch Apple monitor, I'd avoid it.

Color Match RGB Use this working space only with [ don’t think I need to give you
Radius Pressview monitors. a recommendation on this one!

You Radius Pressview users
know who you are.

sRGB The default setting for Web Graphics If your goal is to ensure your

Defaults. This color profile, developed
by Microsoft, HP, and Kodak, represents
a standard, Trinitron PC monitor —
the viewing platform of choice for
many of the world’s Web surfers. Can
also be used with Windows scanners.
Avoid it for print work due to its
limited RGB color gamut.

Web graphics look relatively
the same in Los Angeles as
they do in Bangladesh, sRGB is
a good profile to use.

After you set RGB working spaces, don’t forget that you also have to configure the other
three working spaces, as described in the following sections.



After You Define Your Settings

CMYK working spaces

CMYK working spaces are a little more involved than RGB options, listed in the preceding
section. They serve a threefold purpose:

v CMYK is the color space to which Photoshop converts your RGB file when you choose
Image>Moder>CMYK.

v CMYK s the color space you will view your RGB image in when you choose View=>Proof
Setup>Working CMYK (see the upcoming section on soft proofing colors).

v The CMYK color space determines how a CMYK file is displayed on an RGB monitor.

There are specific color profiles for printing in Europe, Japan, and the United States. Those

four CMYK options are divided between those for coated and uncoated paper, and sheet-fed
or Web printing presses. The latter two have different percentages of ink coverage and paper
stock. | would leave the setting at U.S. Web Coated (SWOP)v2 unless your commercial
printer tells you otherwise.

Grayscale working spaces

Grayscale working spaces have to do with two parameters — viewing and dot gain of
grayscale images (ImageModer>Grayscale). You can choose Gray Gamma 1.8 for a Macintosh
monitor or Gray Gamma 2.2 for a PC monitor. You can also view an image according to how it
will print, based on typical dot gain.

Dot gain is how much ink the paper absorbs, thereby increasing the size of every halftone dot.
When continuous-tone images are digitized, they are converted into a series of dots known as
a halftone.

If you'’re preparing graphics for the Web, you may want to set your working space to Gray
Gamma 2.2 — whether or not you're using a Mac — because most of the Web surfers world-
wide are PC users.

For print work, leave the setting at Dot Gain 20% unless your commercial printer tells you

otherwise.
Don't forget — you still have to adjust another working space.
Spot working spaces

Spot working spaces have to do with spot colors. Spot colors are premixed inks that are
printed in addition to, or in lieu of, the four process colors — cyan, magenta, yellow, and black.
Unless your commercial printer tells you otherwise, stick with a setting of Dot Gain 20%.

After You Define Vour Settings

Your specified working space acts as the default color profile for any new images you create.
That means that every file you create on your computer now uses the colors within the gamut
of your color profiles (either RGB or CMYK depending on your document color mode).
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Any images that are untagged — that don't already have an embedded profile (for example,
Photoshop files created before Version 5) — also use your working spaces.

In addition, your working spaces also define how Photoshop converts your images. For exam-
ple, say your CMYK working space is U.S. Web Coated (SWOP) v2. When you convert an RGB
image to CMYK (Image>Moder>CMYK) prior to sending it off to the printer, Photoshop automat-
ically tags the image with the U.S. Web Coated (SWOP) v2 color profile. (If this looks like a whole
lot of letters jumbled together, read the sections devoted to RGB and CMYK working spaces.)

w When you save your file, make sure that you select the Embed Color Profile option in the

Save dialog box, if it's available. (Some file formats don’t support color profiles.) This ensures
that Photoshop tags the file with the specified color profile and that its origins are always
known.

Setting Color Management Policies

After you've established working color spaces, the next step is to establish the default color
management policy for each color mode. In other words, you need to tell Photoshop how to
interpret and manage the color profiles of files it opens.

Photoshop looks at the color profile of an opened or imported file, compares it to your work-
ing spaces, and then employs the default policies you have established. If the files it opens
have been embedded with the same color profile as yours, there isn’t an issue. You're good to
go. But sometimes this isn’t the case:

+ You may open files that have no profile. These can be older files, files that were cre-
ated with color management turned off, or files created in other applications that do
not employ color management.

»* You may open a file that has a color profile that doesn’t match your working space.
Say that you have a Web designer friend, and his settings are based on the Web
Graphics Defaults. He gives you a file, and you open it on your computer. You do mostly
print work, so your settings are the U.S. Prepress Defaults. He gives you a file, which
you open in Photoshop on your computer. Photoshop then displays an alert that says
the file has an embedded color profile that doesn’t match your current RGB working
space — his working space is SRGB and yours is Adobe RGB (1998). The alert then goes
on to describe the default policy that is invoked on the file, as shown in Figure 3-9.

. Embedded Profile Mismatch
Figure 3-9
The document “Ducky.tif” has an embedded color profile that
does not match the current RCE working space. The document’s
colors will be converted to the working space

Embedded: sRGBE IEC61966-2.1
Working: Adobe RCE (1995

] Don't show again ( Cancel ) E




Setting Color Management Policies

for you, and those should work fine. | do recommend, however, that you change the policies
of one of the predefined settings. If you choose Web Graphics Defaults, the Color
Management Policies options are all set to Off. Unless you have a good reason not to,
change these to Convert to Working RGB. Remember color management is a good thing.

s Again, if you have selected a predefined setting, the policies have already been established

Here are the three policy options:

v Off: This option turns color management off for any new files you create, import, or
open. However, if the opened or imported file’s color profile matches your current
working space, the profile is preserved.

v Preserve Embedded Profiles: This option displays the files in their original embedded
color space. No color conversion occurs. Untagged files remain untagged but use the
current working space for display.

v Convert to Working RGB (or CMYK or Grayscale, depending on your image mode):
This option converts any files with missing or mismatched embedded profiles to your
working RGB space. Untagged files remain untagged but use the current working space
for display.

The next decision you have to make is whether you want Photoshop to automatically invoke
your default management policies or you want to be able to evaluate them on a file-by-file basis.
If you do not select the Ask When Opening option for Profile Mismatches and Missing Profiles,
Photoshop displays the Embedded Profile Mismatch alert message (refer to Figure 3-9), describ-
ing what default policy will occur. You can then select the Don’t Show Again check box, and from
that point forward, Photoshop executes the policy without displaying an alert. For files with
missing profiles, Photoshop simply invokes the default policy without an alert.

If you select the Ask When Opening option for Profile Mismatches, Photoshop not only dis-
plays an Embedded Profile Mismatch alert, but also provides you with options for handling
the color of that file, thereby overriding the default policy, as shown in Figure 3-10.

. Embedded Profile Mismatch
Figure 3-10

The document “Ducky.tf” has an embedded color profile that

does not match the current RCE working space

Embedded: sRGE IEC61966-2.1
Working: Adobe RGE (1998)

How do you want 10 proceed?

@ Use the embedded profile (instead of the working space)
T Convert document’s colors to the working space
O Discard the embedded profile (don't color manage)

€ CGncel )} 00
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The options are similar to the default policies of the Color Settings dialog box:

v Use the Embedded Profile (Instead of the Working Space): Photoshop displays the file
in its original embedded color space and does not perform any color conversions.

v Convert Document’s Colors to the Working Space: Photoshop converts the file from its
embedded color space to your working color space.

v Discard the Embedded Profile (Don’t Color Manage): Photoshop doesn’t utilize any
color management when opening files but displays the file in your working space.

Be cautious about making any CMYK conversions. If you encounter a Profile Mismatch with
a CMYK image, you will probably want to preserve the image’s embedded profile unless

you're absolutely sure it should be converted to another CMYK working space. But, if the

image doesn’t have a profile, then by all means convert it to your CMYK working space.

If you select the Ask When Pasting option for Profile Mismatches, Photoshop prompts you
when you drag and drop layers or selections that have the same color mode (see Book II,
Chapter 2, for more on modes) but different color profiles. In the Paste Profile Mismatch
alert dialog box, you have two options:

v Convert (Preserve Color Appearance): Photoshop converts and matches the appear-
ance of the color rather than the RGB numerical values. For example, the RGB color of
R 152, G 122, B 250 may be a different shade of purple in one RGB working space versus
another. If you preserve the numerical values, the shades won’t match. If you preserve
the appearance, Photoshop attempts to maintain the two shades.

v Don’t Convert (Preserve Color Number): Photoshop does not convert the appearance
of the color but instead matches the RGB numerical values.

If you don’t select the Ask When Pasting check box, Photoshop pastes the color appearance
between RGB images and pastes the numerical values between CMYK images.

If you select the Ask When Opening option for Missing Profiles, Photoshop displays a Missing
Profile alert and also provides you with the following options, as shown in Figure 3-11:

Rk Missing Profile
Figure 3-11

The RCB document “Flower.psd” does not have an embedded color profile

1Fs How do you want 1o proceed?
= @ Leave a5 is (don't color manage)
O Assign working RGB: Adobe RGB (1998)

© Assign profile: | Adobe RCB (1998) i)

( Cineet Y o)




Getting Consistent Color among Adobe Applications

1 Leave As Is (Don’t Color Manage): This leaves the image untagged and without a color
profile, but displays the image in your working space.

v Assign Working RGB (or CMYK or Grayscale, depending on your image mode): your
working space: Photoshop tags the image with your working space and displays it in
that working space. If you change your working space, the image retains the old work-
ing space.

v Assign Profile: This option allows you to assign any color profile contained within the
pop-up menu. You can use this option if you know where the untagged image originated.
For example, if you scanned your image and your scanner doesn’t embed profiles, you
can assign the scanner profile.

Unless you have a specific reason not to, [ recommend that you assign your working RGB
space to those orphan files.

[ recommend selecting the Ask When Opening and Ask When Pasting check boxes. That way

you know when a profile mismatch occurs and you have the choice of picking your course of
action, which includes overriding the defaults you set in the policy settings. This allows you

to evaluate whether you want to preserve or convert on a file-by-file basis.

For example, if you're a print designer, and a Web designer gives you a file, you get a profile
mismatch alerting you that the file has the sRGB color space and that it doesn’t match your
working space of Adobe RGB (1998). If you're going to use the image as-is for Web content,
you tell Photoshop to preserve the embedded profile and not to make any conversion. But if
you want to repurpose the image (for, say, a logo), you have to instruct Photoshop to convert
the file to your working RGB space. (Of course, ultimately, you have to also convert the image
mode to CMYK for printing purposes.)

the bottom of the image window (described in detail in Book I, Chapter 1). Also if an image
has a color profile that differs from your working space, an asterisk appears in the title bar.
An untagged image displays a pound sign.

@ To find out the color profile of an image, choose Document Profile from the pop-up menu at

By the way, when you select the Advanced Mode option, you have a few additional options
regarding color conversion engines and rendering intents, which are methods of color transla-
tion. I recommend putting your trust in Photoshop and leaving these options at their defaults,
unless you're a bona fide color expert.

Getting Consistent Color among Adobe Applications

If you have a complete Adobe workflow like I do, you’ll want to use the same Color Settings for
all your Adobe applications. lllustrator, InDesign, and Acrobat share a similar Color Settings
dialog box. They have a few minor differences, but nothing major. If an element doesn’t exist
in one application’s Color Settings dialog box, Adobe merely plugs in the default setting. You
can save your Color Settings in Photoshop by clicking the Save button in the Color Settings
dialog box. To ensure that all your Adobe applications can access the settings file, save it to

a default location:
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v For Microsoft Windows, the default location is the Program Files/Common Files/
Adobe/Color/Settings folder.

v For Mac OS X users, the default folder is User/CurrentUser/Library/
ApplicationSupport/Adobe/Color/Settings.

Launch your other applications, open the Color Settings dialog box, and click the Load button.
Navigate to the saved settings file and select it. You are all set for color consistency among
applications.

Reassigning, Removing, or Converting Color Profiles

Before you read this section, let me gently note that the operations described are really for
advanced users. Although these aren’t overly difficult, you should know why you’re doing a
particular operation and have a good reason for doing it. That said, once in a great while, you
may want to either assign a different color profile to an image without converting the color,
convert an image’s color profile, or on a very rare occasion, eliminate the color profile of your
image altogether. For example, say you're a photographer and you need to take a folder of
photos and hand them off to a Web design firm. In that case, you may want to change the
Adobe RGB (1998) color profile of those images to sRGB.

To reassign or eliminate a color profile, choose Image=>Moder>Assign Profile and select one of
the following three options, shown in Figure 3-12:

v Don’t Color Manage This Document: Strips the color profile and doesn’t employ color
management.

v Working RGB (or CMYK or Grayscale, depending on your color mode): your working
space: Assigns your current working space to a file that either is untagged or has a dif-
ferent color profile than your working space.

v Profile: Choose the color profile you want from the pop-up menu. Photoshop assigns
that profile to the file but doesn’t convert the colors to that profile. Be aware that this
option may drastically change the appearance of the colors because the color numbers
are retained (the numeric value of the color) in the new color profile.

Fi 3-12 Assign Profile

igure 35-

9 Assign Profile %
) Don't Color Manage This Document -
- . = f Cancet
O Working RGB: Adobe RGB (1998) 4
® Profile: | SRCE IEC61966-2.1 ) Preview

Make sure that you have the Preview check box selected so you can see the result of your
action.

To convert to another color profile, choose Imager>Moder>Convert to Profile. Choose your
desired color profile for conversion from the Profile pop-up menu, shown in Figure 3-13. Your



Soft Proofing Colors

file is now converted and tagged with this color profile. You can also specify the color man-
agement engine (specifies the color matching method), rendering intent (the method used for
color translation), and whether to use black point compensation (when selected, the full
dynamic range is mapped to the destination space), and dithering options (colors are mixed
to simulate a missing color in the destination space). Again, unless you are a real color guru, |
recommend taking Adobe’s word for it and leaving the default settings for whatever destina-
tion profile you choose. Even if you don’t, | recommend that you select the Use Black Point
Compensation and Use Dither check boxes (unless the size of your Web graphics is critical).
If you have layers, you can choose to flatten all the layers into a single one. I recommend this
because it makes the preview more accurate. Keep the Preview check box selected to view
your conversion.

Convert to Profile

Source Space

Profile. Adobe RGB (1998) —_—
£ Cancel

Figure 3-13

Destination Space

! Preview
Profile: | Working CMYX - U.S. Web Coated (SWOP) v2 )

Conversion Dplions
Engine: Adobe (ACEH a
Intent l-lolrvf_(_ofd_r_umﬂn: a
E Use Black Point Compensation
El.lu Dither

Soft Proofing Colors

Photoshop allows you to preview on-screen how your image will look on a variety of output
devices. First, choose Viewr>Proof Setup and select your desired setup. The Working options
are based on the working spaces you specified in the Color Settings dialog box.

v Macintosh RGB and Windows RGB display your image as it will appear on a standard
Macintosh or Windows monitor. This can come in handy when you want to see how
your Web graphic will generally look on another platform.

v Monitor RGB allows you to view the image by using your current monitor’s color space.

This essentially turns off your RGB working space and lets you see the image without
any color management.

v Custom allows you to choose a specific device. For example, choosing U.S. Web Coated
(SWOP)V2 lets you to see how your RGB images will look when they’re converted to
CMYK for printing.

After you have chosen your setup, choose Viewr>Proof Colors to view the image in your
chosen working space. For the most reliable results, use a good quality monitor. And don’t
forget about the importance of setting up a good viewing environment as well. Also keep in
mind that although soft-proofing is a good thing, it is not a substitute for a good quality hard
copy proof. Some things, such as the type and quality of paper, certain inks, and so on cannot
be accurately simulated on-screen. See Book X, Chapter 2, for details on printing.
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Time Travel —
Undoing in
Photoshop

In This Chapter
+ Undoing and redoing

v Exploring the History
palette

v~ Erasing with the Erase to
History option

v Brushing back in time with
the History Brush tool

hen Tom Wolfe said, “You can’t go home again,” he
Wwasn’t talking about Photoshop. If you change your

mind about something you've done and want to return
to your starting place (or any point in between), Photoshop is
very forgiving. My favorite image editor offers many different
ways to reverse actions, undo what you did, reapply effects
you've cancelled, and generally change your mind as often as
a new apartment owner deciding where to put the couch.

Photoshop is the ultimate time machine. Not only can you
reverse actions, but you can also go back to the future to
restore them. This flexibility enables you to work on your
image as you please, without worrying that a particular action
will be locked in stone. Confident in your ability to retrace or
repeat your steps as necessary, you can experiment, try
different effects, and be much more creative.

This chapter helps you master Photoshop’s powerful time-
traveling features, including the Undo command, the History
palette, and tools like the Art History Brush tool.

Undoing What's Done

Photoshop gives you two simple ways to undo your efforts: the
Undo/Redo command and the Revert command. Both are easy
to master, as described in the next few sections.

Using the Undo command

Your first stop in your journey through time is the Undo/Redo
command. This command simply reverses the last action you
took or reapplies it if you just undid something. For example,
if you apply a brush stroke you don’t like, use Undo to remove
that stroke. Then if you immediately change your mind, you
can redo it.
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To undo your last action, choose Edit=>Undo or simply press Ctrl+Z (38+Z on the Mac).

quickly. For example, you can apply a filter, examine the results, and then flip back and forth
between the filtered and unfiltered version by pressing the Undo/Redo shortcut keys rapidly.
When you decide which way to go, stop. This procedure works best if you've chosen to press
Ctrl+Z (88+Z on the Mao) to apply both Undo and Redo.

@ Use Undo/Redo to toggle an effect on and off to compare the before and after effects

Remember that Undo/Redo works only for a single command. If you do anything else after
applying a command and then change your mind, you have to resort to one of the other time-
travel techniques described later in this chapter.

If an action can’t be undone or redone, Undo/Redo is grayed out and unavailable. For exam-
ple, if you apply a brush stroke and then save the file to your hard drive, you can no longer
undo the brush stroke. (However, you can use the History palette to remove the brush stroke.
See “Working with the Almighty History Palette,” later in this chapter.)

the item is grayed out, the buffer is already empty. Note that this action cannot be undone,

@ If you want to free the memory used by the Undo command, choose Edit=>Purge=>Undo. If
so only do it if you notice Photoshop acting sluggish.

Reverting to what's saved

Revert replaces your current file with the last saved file, effectively wiping out everything
you've done since the file was last saved. You can revert to the last version of the file by
choosing Filem>Revert (or by pressing F12). You lose all the changes in your current file when
the last saved version replaces it on-screen.

On the surface, Revert seems like an all-or-nothing proposition to be resorted to only when
you've given up all hope of salvaging the current file. However, that’s not necessarily the case.

For example, you may find using Revert to produce two versions of an image beneficial.
Perhaps you’ve done some work on an image and now want to compare this version of the
image with a version of the image that you apply an entirely different set of commands to. Just
duplicate the current version (choose Imager>Duplicate) and revert back to its pristine state
to apply the other effects. Then you can compare versions to see which you like best. (This
tactic works only if you haven’t saved the file along the way, of course.) You can use Revert in
this manner as many times as you like to create two, three, or more versions all based on one
original image.

The Revert command is stored on the History palette, so in many cases, you can remove the
Revert command to restore the file to its manipulated state once again. You find out how to
remove a command from the History palette in the next section.

changes, and then save it, Revert backtracks to that saved version, not to the original. That's
why working with a copy of an image is a good idea, in case at some point you really do
want to go back to the original version.

@ Revert restores only the last saved version of your image. If you open an image, make some



Working with the Almighty History Palette

Working with the Almighty History Palette

Undoing and redoing commands are kid’s stuff next to the power of the almighty History
palette. Think of this tool as a recipe listing all the steps you took to cook up your image in its
present state. Using the History palette, you can browse through the recipe and return to any
step in the list to begin work anew from that point. In this mode, the History palette operates
like a multistep undo process.

Understanding states and snapshots

You can’t go too far in your use of the History palette without understanding two important
concepts, as well as how the concepts are different:

v States: States are just another way of saying steps. At any given point in your image-
editing activities, Photoshop saves your individual edits into states. By default,
Photoshop remembers 20 states for an image.

v Snapshots: You can save temporary copies of an image, each containing all its various
states. For example, say you make six edits to an image before you take a snapshot. The
snapshot shows the image, but it also contains a complete history of the six states.
Make a few more changes, and take another snapshot: The new snapshot contains the
six states you made previously, as well as any new ones. See “Taking Snapshots,” later
in this chapter, to find out how to use snapshots.

When you have these concepts down, you can get to the business of understanding how the indi-
vidual tools in the History palette use states and snapshots to help you go back in time (and back
to the future again) to undo, redo, and modify each miniscule edit you make to your images.

Changing the default number of steps that the History palette displays

The History palette displays a list of each change you make to your image — every brush
stroke you dab, every deletion you make, every layer you create — up to a default limit of 20
steps, or states. The list begins at the top of the History palette, and Photoshop tacks each
new step on at the bottom. When you reach the limit of 20 steps, the oldest step (at the top of
the list) drops off to make room for the latest one at the bottom.

If you move something repeatedly and don’t choose another tool, all the moves are
considered a single step, until you do select another tool.

If your computer has lots of memory and you want to be able to move back and forth more
than 20 steps, you can increase the number of steps to as many as 1,000 in the General
Preferences dialog box. Choose Edit>Preferences=>General (or Photoshopr>Preferences>
General in Mac OS X) and enter a new value in the History States box. Keep in mind that
boosting this number can eat up your available memory quite quickly, because after you acti-
vate a higher number of states, Photoshop always stores up to that number every time you
edit an image (even images with which you don’t contemplate needing access to more than 20
steps). A better choice may be to leave the states set to 20 and instead save snapshots of your
image, as described in the following sections.
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Introducing History palette options and tools

The History palette has several components you should know about, as shown in Figure 4-1:
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Undone states - i | SewRecunem
2 4 71 | Histery Options...

Create new document Current history state

Delete current state

from current state

Create new snapshot

Snapshot thumbnail: This is a miniature image of the most recently saved snapshot
image, which is a copy of your document with all the current states included. (For more
on snapshots, see “Taking Snapshots,” later in this chapter.)

Source state column: Click in this column next to a particular snapshot or state, and
when you begin painting with the History Brush tool or when erasing with the Erase to
History option, Photoshop uses the snapshot or state you select as the source.

History state: This is a particular step or edit in your document’s list of steps. An icon
appears in this column showing what kind of action occurred in that state.

Active state marker: This slider points to the currently active state. You can drag it up
or down to change the current state.

Create new document from current state: Click this icon to create a duplicate copy of
your image at the currently selected state. Your new document starts out with a clean
slate and an empty history list.

Create new snapshot: Click this icon to store an image of your document, preserving all
the states listed.

Delete current state: Click this icon to remove a selected state.

Undone states: These are the grayed-out states that are undone when you select an
earlier state in the list.

Open state: This is the original document when first opened.

Current history state: This is the active state you've selected in the history list.
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Viewing an Image’s Various States

You can move back to any state listed in the History palette, remove a state to cancel a step,
or perform other time-travel stunts with the History palette. The following sections outline

some basic time-shifting techniques you should know. -

I/}
Going back to a particular state Chapter

4

To go back in time and resume editing at a particular point, just click the state you want to
return to. All subsequent states appear grayed out, or what Adobe calls undone. Then begin
editing your image as usual. As soon as you perform a new step, all the states that follow your
re-entry point vanish. It’s like applying the Undo command to a group of steps with one click.

you change your mind, immediately undo your first action — press Ctrl+Z (38+Z on the
Mac). The subsequent steps that were removed reappear.

@ If you intentionally (or accidentally) begin editing while a previous state is highlighted, and
Reviewing your image at different states

To review how your image looked at various previous states, just click the state you want to
take a look at. (You can also drag the active state marker up and down the list.) The document
image immediately changes to reflect that earlier state. You can move back and forth between
any point in the history list if you like. As long as you don’t make any editing changes during
your time-traveling jaunt, your current history list is preserved.

Removing a state

To remove a state and all the steps that follow it, select the state and then do one of the
following:

v Press the Delete key.
Click the trash can icon.

Drag the state’s icon to the trash can icon.

X Y\

Right-click the state (or Control+click on the Mac) and choose Delete from the context-
sensitive menu that pops up.

v Choose Delete from the History palette pop-up menu.

Clearing all states

You can clear all the states from the palette by choosing Clear History from the palette pop-up
menu. To delete all the states except the last one in the history list, as well as keep the snap-
shots you've saved, choose Edit>Purge=>Histories. You can clear or purge your history list
when you don’t need the states that are included anymore, to save memory or to return to the
original state of your document. Just be sure you're really, seriously, not interested in going
back again later to make changes because this command cannot be undone, with one excep-
tion. You can only undo your clearing or purging if you choose Edit=>Undo immediately after
you execute the command.
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Navigating the history list

You can move up and down the history list even if the list isn’t visible on your screen. The
Edit>Step Forward and Edit=>Step Backward commands move forward and back in the his-
tory list. The best way to access these commands is to use the keyboard shortcuts:

v Press Alt+Ctrl+Z (Option+8+Z on the Mac) to move backward in time (upward in the
history list).

v Press Shift+Ctrl+Z (Shift+3+Z on the Mac) to move forward in time (down the history list).

Looking at the History Options Dialog Box

The History palette has four options that change its behavior. To access these options,
choose History Options from the History palette pop-up menu to open the History Options
dialog box, shown in Figure 4-2. The dialog box offers these options:

History Options %)
Automatically Create First Snapsiot ox
Automaticaly Create New Snagahot When Siing
Al Nicar-Lirwiae Bty
Show Niew Snagsihiot Diiog by Default

Figure 4-2

= L)

v Automatically Create First Snapshot: This option, selected by default, tells Photoshop
to create a snapshot of the image when you first open it, before you make any changes.
You can return to this snapshot at any time by clicking its name in the History palette.
Keep this option selected. That way, you can always return to your original image if
necessary.

v Automatically Create New Snapshot When Saving: This option tells Photoshop to
create a new snapshot each time you save the image. If you're like me and save every
couple of minutes, you probably won’t want to select this option; otherwise, you end up
with a palette full of unwanted snapshots.

v Allow Non-Linear History: This option makes editing or deleting a state without remov-
ing all the states that follow it possible.

When the Non-Linear History capability is active, you can make an editing change to an
intermediate state in the history list, perhaps save the edited state as a snapshot, or
even delete the state, leaving the other steps below it unchanged. (When you delete a
state you've edited, the edit you made is added to the end of the history list.)

Use this option with caution because steps are interdependent. A change you’ve removed
may form the basis for another edit later on, so deleting it can cause weird results.

v Show New Snapshot Dialog by Default: This option ensures that Photoshop asks you
for a name for any new snapshot you create. Applying names to snapshots makes
reminding yourself of the state of the image when you saved the snapshot easy.



Keeping the New Snapshot dialog box close at hand

If you want the New Snapshot dialog box to
open when you create a new snapshot by click-
ing the camera icon, select the Show New
Snapshot Dialog by Default option described in
the preceding section.

Hold down the Alt key (Option key on the Mac)
when you click the camera icon to access the

dialog box even when the Show New Snapshot
Dialog by Default option is deselected. If you
remember this technique, you can alternate
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Taking Snapshots

between creating generic snapshots and using B
the dialog box. ”
Chapter

Taking Snapshots

Snapshots are duplicates of your image at a particular point in time, similar to saving a docu-
ment under an alternate name. (Photoshop automatically names the snapshots something
generic like Snapshot 1 or Snapshot 2.) However, snapshots are temporary copies, available
only during your current work session. When you save your image and close it, you lose all
the snapshots. So thinking of snapshots as a way of saving your history lists at various points

in time while you’re working is best.

Snapshots are a handy way to alternate between versions of an image when you’re making
major changes. For example, if you plan to apply several filters that will drastically modify
your image, you may want to save a snapshot before you use the filters and save another one
after you've applied them. You can then click either snapshot to switch from one version to

the other quickly.

To take a snapshot, follow these steps:

Comps palette in Book V, Chapter 2.

1. Select the state at which you want to
take a snapshot.

The state can be the most recent one
with all your latest editing changes, or
an earlier state.

Choose New Snapshot from the
palette pop-up menu.

Or right-click (Control+click on the Mac)
the state and choose New Snapshot
from the context-sensitive menu.

The New Snapshot dialog box opens,
as shown in Figure 4-3.

The second you close a file, the snapshots you've taken disappear forever. If you want a
more permanent way of saving versions of your file, see the section on using the new Layer

If you want to bypass this dialog box,
just click the New Snapshot button to
create a snapshot. Photoshop names
your first snapshot Snapshot 1.

In the Name box, enter a name for the
snapshot, preferably one that helps
you remember the contents of that
particular snapshot.

You can add or change the name of the
snapshot later by double-clicking the
snapshot name in the history list.

CONTINUED



194

Choose one of the subtypes of snap-
shots in the From menu (as shown in
Figure 4-3):

v Full Document creates a snapshot
of all the layers in the image at the

currently selected state. (This is the

default.)

1 Merged Layers creates a snapshot
with a single layer, merging all the
layers in the image at the currently
selected state. Use this option to

Book Il » Chapter 4: Time Travel — Undoing in Photoshop

create a flattened version with the
visible layers combined.

v Current Layer creates a snapshot of
only the active layer of the current
state.

5. Click OK to create the snapshot.

©)

If you no longer need a snapshot, select
the snapshot and press the Delete key.
You can also click the trash icon, or drag
the snapshot to the trash icon, or choose
Delete from the palette options menu.

[ Hew Snapshot

Figure 4-3 n [ e
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Restoring Part of an Image

Although the concept may seem like quantum physics, you can erase and brush on an image

by using previously saved states or snapshots.

What? Okay, let me try this again. You can erase portions of an image to a history state, as
well as paint on an image from a history state. This means that traveling through time doesn’t
have to be an all-or-nothing thing; you can erase or paint portions of a different state onto

your currently active state.

For example, suppose you applied a blur filter to a face and decide later you want to make the
eyes sharp again. You can use the Eraser tool with the Erase to History option, or the History
Brush tool, to paint over the eyes with information from an earlier state before you blurred

them, as shown in Figure 4-4.
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Using the Eraser with the Erase to History option

Restoring Part of an Image

You’d want to use the Eraser with the Erase to History option when a portion of an earlier
state or snapshot contains information that you want to include in an image that has other-
wise been extensively edited. To erase and restore to a portion of an earlier state or snapshot,

just follow these steps:

1. In the History palette, click in the
far-left column of the state or snap-
shot you want to use as the source for
the Eraser tool with the Erase to
History option.

An icon appears, indicating that
Photoshop will use this state as the
source for the Eraser tool with the
Erase to History option.

Select the Eraser tool.

Choose the Erase to History option in
the Options bar.

Choose any other Eraser tool options
you want to use, such as brush size
and type, blend mode, opacity and
flow percentages, or airbrush.

Using the History Brush tool

5.
6.

©)

For more on blend modes, see Book V,
Chapter 3.

Select the layer and state you want to
erase.

Begin to erase.

Photoshop removes the image in the
layer and replaces it with the image in
the state you specified as the origin for
the Eraser with the Erase to History
option.

You can convert the Eraser tool temporar-
ily to use the Erase to History option by
holding down the Alt key (Option key on
the Mac) when you erase or paint.

You can also use the History Brush tool to apply an image area from a different state or snap-
shot to your current state. You’d want to use this tool to restore a portion of an image to an
earlier state, while leaving the rest of the heavily modified image alone. Just follow these steps:

n In the History palette, click in the
far-left column of the state or snap-
shot you want to use as the source for
the History Brush tool, as shown in
Figure 4-5.

An icon appears, indicating that
Photoshop will use this state as the
source for the History Brush tool.

In my example, [ chose my original
image just after cropping it.

Select the History Brush tool in the
Tool palette.

3.

4.

You can also press Y or Shift+Y to
select the tool.

On the Options bar, choose any other
brush options you want to use, such
as brush size and type, mode, opacity
and flow percentages, and airbrush.

Having access to blend modes is one
advantage the History Brush tool has
over the Eraser tool and the Erase to
History option.

Select the layer in the Layers palette
and select the state that you want to
paint on in the History palette.

CONTINUED
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Begin to paint.

Figure 4-5

Photoshop paints over the image in the
layer with the image from the state you

Book Il » Chapter 4: Time Travel — Undoing in Photoshop

specified as the origin for the History
Brush tool.

[ painted my original over my filtered
image. (I used the Graphic Pen filter.)

Using the Fill to History feature

If you can easily select the area you want to replace with a specific state, you can use the Fill
to History feature. Suppose you didn’t like the sky in a particular image. You selected the sky
area and then added clouds by using the Clouds filter. Now you want to put the original sky
back, but don’t want to reverse any of the other edits you performed in the meantime. Just
follow these steps to replace an area by using the Fill to History feature:

1.

Select a state as the source for the Fill
to History function in the History
palette.

For example, select the state that has
the original sky.

Choose the current state and use your
favorite selection tools to select the
area you want to replace.

For example, if you remembered to
save your original sky selection when
you originally added clouds, you can
choose Selectr>Load Selection and
retrieve that selection.

Choose Edit~Fill and then select
History from the Use pop-up menu.

Click OK to fill your selection with the
image area from the selected state.
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‘ ) When Photoshop won't let you go back

Sometimes you may see a No symbol when Image Size or Canvas Size commands, or rotat-
trying to use the Eraser with the Erase to History  ing any amount other that 180 degrees can pre-

option, the History Brush tool, or the Fill with  vent you from going back to a previous state. B
History command. You must be sure that your  However, if you happen to have a square image, ”
current image is the same file size (same number  you can rotate in 90-degree increments and still Chapter
of pixels) as the state you are trying to go back  use the Eraser with the Erase to History option. 4

to. Actions such as cropping, trimming, using the

Using the Art History Brush tool

The Art History Brush tool is an interesting variation on the plain old History Brush tool. Both
paint over an image by using information from a previous state. The Art History Brush tool,
however, includes several choices in the Options bar that let you apply brush-stroke effects to
your image as you paint:

v Style: The Style menu contains various-shaped brush stroke styles, such as Tight Short,
Loose Medium, Dab, or Loose Curl. Although their names describe the look of the strokes
fairly well, you’ll want to experiment with them to see exactly what they look like.

v Area: This option controls the area covered by the paint stroke independently of the
brush size you select. The larger the size, the more area that’s covered, and the more
brush strokes that are applied per movement.

v Tolerance: This option adjusts the amount of the change applied to your image. A
low tolerance value lets you apply strokes anywhere in the image, regardless of color
values. A high tolerance limits Art History strokes only to areas that are very different
from the source state or snapshot, thereby making your image not quite as dramatically
different from the original.

The result of using these options is an interesting hand-painted effect that you can control
quite easily after you've had some practice.

The Art History Brush tool often works best when you use a state that is quite different from
the state you're painting over. For example, you can apply a heavy filter that makes the image
almost unrecognizable and then use that filtered image to paint with the Art History Brush
tool. You can even completely fill an image with color or texture and work with that.

To paint with the Art History Brush tool, follow these steps:
1. Apply any effects you want to use to a 3. Select the Art History Brush tool from

chosen state. the Tool palette.
n Click in the far-left column in the You can also press Y or Shift+Y to
History palette to select the state you select it.

want to use as the source for the Art
History Brush tool, as shown in

Figure 4-6. CONTINUED
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Select from the choices in the Options 5. Paint with the brush to get the effect
bar. you want.

Several of the options, such as Brush, Don't forget that you can use the History

Mode, or Opacity, are similar to the palette to reverse Art History strokes that
options available with the ordinary you change your mind about!

Brush tool. The new options are Style,
Area, and Tolerance.

e Tmage Loyer Select Fier View Talp
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Applying

Annotations
and Notes

In This Chapter

v Adding text and audio
notes

v~ Using notes with Adobe
PDF files

using Photoshop in a work environment — or in any sce-
nario that involves anything but 100 percent freedom to
perform your Photoshop magic as you want.

E verybody’s a critic! That’s especially true when you’re

Sometimes, you’ll want to collect comments from your col-
leagues, approvals from your supervisors, ideas from your
friends, or nit-picks from your clients. Photoshop lets everyone
have his or her say by using annotations, notes, or audio com-
ments. You can use these clever feedback tools without worrying
about physically modifying the work that you’ve carefully done.
Imagine sticky notes you can move around your screen, and
you’ll see what Photoshop’s Annotations feature can do for you.

Text documents often are distributed for approval in a Portable
Document Format (PDF) format by using Adobe Acrobat Reader,
and comments are added by using the full Acrobat application.
Photoshop is compatible with Acrobat, too, so you can save your
Photoshop files in the PDF format. For more detailed information
on the PDF format, see Adobe Acrobat 6 PDF Bible, by Ted
Padova (published by Wiley Publishing, Inc.).

This chapter provides a quick introduction to Photoshop’s
annotation and audio notes features.

Having Your Say with Notes
and Audio Annotations

Text annotations (which Photoshop calls notes) are text
comments that appear as icons within an image document
when you choose to make them visible.

If you're reviewing someone else’s notes, you simply double-
click the note to view it or to modify the text it contains.
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You can do lots of things with notes:

\

X Y X\

X \
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Show or hide all the notes: Choose View=>Showr=>Annotations.

Expand any note from its icon: Double-click the icon.

Edit a note: Expand the note and revise the text by using standard editing commands.

Delete a note: Select the note and press Delete.

Remove all closed notes: Right-click any note (Ctrl+click on the Mac) and choose
Delete All Annotations from the context menu that pops up. You can also select a note
and click Clear All in the Options bar. This removes all closed notes but doesn’t remove

notes that are open.

Move a note’s icon: Drag the icon. (The note still pops up in its original location, however.)

Relocate a note’s window: Open the note and drag its title bar to the new location.

It then pops up in the new location.

Creating a text annotation

To create a text annotation, follow these steps:

1

2.

3.

Select the Notes tool in the Tool
palette (or just press N).

If necessary, change the name in the
Author text box in the Options bar.

Just double-click inside the Author text
box, shown at the top of Figure 5-1, and
start typing.

By default, when you create a note, the
name you entered when you installed
Photoshop appears as the author of the
note. However, you may be working on
an image with someone else’s com-
puter, or you may be on the lam and
using an assumed name.

Be sure that everyone looking at the file
uses a unique name so that you can sort
out the various notes and, perhaps, give all
of them their proper weight (that is, always
do what the boss says, but take Seymour
the intern’s comments with a grain of salt).

From the Font and Size drop-down
lists in the Options bar, choose a font
and font size for the text.

4.

Selecting a particular font and size for
each author may just be a matter of
preference or readability or can be
used to further differentiate between
authors’ comments. You choose font
sizes in relative sizes from Smallest to
Medium to Largest so Photoshop can
adjust the notes to be readable on
monitors set for different resolutions.

Click the Color box on the Options
bar and select a color for the title bar
of each note and the color of its icon
when you minimize the note.

Color-coding is a good way to differen-
tiate authors, as well as priorities. For
example, you can use Red, Yellow, and
Green to indicate relative status of a
particular suggestion, or select a color
to represent a particular author.

Click in the note’s window and type
the text you want to enter, as shown
in Figure 5-1.

You can use traditional editing commands,
such as the Backspace key, Ctrl+X, Ctrl+C,
and Ctrl+V (88+X, 88+C, and 38+V on the
Maq) to edit the text.
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6. When you're finished entering a note, Photoshop minimizes the note to an
click the note’s Close box on the right lcon.
end of the title bar (Windows) or the
left end of the title bar (Mac OS).

Book
Figure 5-1 e T v fus =] S [tnesie 2] | oo D s | Chapter
o StillLife. tif _@33 3% (RGB) 5

Options bar
Close box

Click here to
create note

Creating an audio note

If you have a microphone connected to your computer, you can add audio notes to your
image files. Audio notes are great for adding annotations that take a long time to type or that
are better explained through audio.

S Audio annotations can bloat your file size, so unless using audio annotations is really more
advantageous, stick with text notes.

To add an audio message to your file, just follow these steps:

1. Select the Audio Annotation tool. 3. Click in the image where you’d like to

Press N to activate the Notes tool and include the audio annotation.

then Shift+N to choose the Audio The Audio Annotation dialog box,
Annotation tool. shown in Figure 5-3, pops up.

2. Ifnecessary, change the author name 4, Click the Start button (Windows) or
or note color in the Options bar. Record button (Mac OS) and begin

Figure 5-2 shows the Options bar with speaking into the microphone.

the Audio Annotation tool activated.
CONTINUED
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To play the audio annotation, double-

5. Click Stop when you’re finished
click its icon.

talking.

FIRIESE T - [ mnl‘

Figure 5-2

Figure 5.3 Audio Annotation

Instruction —— Start...

x|
Presz the Start button to bagin
recording by speaking into the
ricrophone,
Cancel |

Importing and Exporting PDF Files with Annotations

You can view PDF or FDF (Forms Data Format) documents that contain annotations, review
the annotations, and make new notes of your own.

can still get input. You can even include notes of your own. To export your file (and its anno-

E s If you want to send an image file to a friend or colleague who doesn’t have Photoshop, you
tations) for review in Adobe Acrobat, just save the document and choose PDF as the format.

Then when your Acrobat-using friend sends the file back to you, just follow these steps to
access his or her input:

1. Choose File=>’Import=>Annotations. 3. Click the Load button.

2. Navigate to the PDF or FDF file you Photoshop imports the file with the
want to open. annotations intact.



Creating Actions
for Productivity

and Fun

In This Chapter

v Working with actions
v Playing presets

+* Recording a new action

v~ Editing and organizing
actions

v Processing batches of files

v~ Creating droplet applets

same steps in Photoshop over and over, the result is often

tedium and impatience. You wouldn’t want to have to rein-
vent the wheel each time you wanted to go for a spin around the
block, so why repeat the labor needed to carry out specific tasks
if you don’t have to? Photoshop lets you record steps by using a
fast and fun feature called Actions. Photoshop actions are similar
to the macro recording features found in your word processing
or spreadsheet program, but they’re usually easier to create
and have capabilities custom-tailored for image editing and
customization.

Practice makes perfect, but when it comes to repeating the

For example, Photoshop has preset actions to create a wood
frame, simulate water reflections, or provide a molten lead
look. You can also use preset actions to create filterlike effects.

And then there are the chores you can automate on your own.
This chapter shows you how to do a few of them and how to
take advantage of Photoshop’s macro recording and editing
capabilities.

Using the Actions Palette

Not surprisingly, a palette is dedicated to the automation of
various chores. To view the Actions palette, choose Windowr>
Actions (or press F9), or click the Actions tab in its palette
group or in the Palette Well. You can view the Actions palette
in two different modes, each of which is useful in its own way.
Here’s a short description of each mode:

v List mode: List mode, shown in Figure 6-1, is the default
display in which each action is shown as a folderlike
heading. You can open the heading to reveal all the steps
within the action or collapse the heading to hide them.
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You operate in List mode when you record an action and when you edit individual
steps. List mode also lets you perform only some of the steps in a macro.

v Button mode: Button mode, shown in Figure 6-2, is a convenient, compact mode that
hides all the inner workings of the actions, presenting only a button face that you can
click to trigger a particular macro. Button mode is fast and easy; just click and go.
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Getting to know List mode

When you're working in List mode, the Actions palette has these three columns:

v The leftmost column contains check boxes that you can select or deselect to control
what actions are available in Button mode. You can use this column to ensure that
your most commonly used actions are available for use in Button mode and those that
you don’t use very often are hidden.

v The second column toggles on or off the display of dialog boxes in actions. Some
actions include options you can select while running the macro. For example, the
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Vignette (Selection) action, which creates a faded frame around a selection, includes a
dialog box that lets you specify the width of the fading. This dialog box is shown only
when you select the dialog box column; if you deselect that option, the action uses a
default value of 5 pixels as the width for the feathered effect.

The third and widest column shows the name of the action. Click the right-pointing
arrow to the left of the action’s name to reveal the individual steps of the action. Many
(but not necessarily all) steps have their own arrows, which can expand or collapse to
show or hide the options used to carry out that step. In case you're curious, the good
folks at Adobe call these twisty-turny arrows disclosure triangles.

At the bottom of the Actions palette in List mode, you find six icons, not all of which are
available at all times. The following list describes the icons from left to right:

v

I/

I’
I/

Stop Playing/Recording: This icon is active when you’re recording a macro. Click it to
stop recording (or to stop playing back an action).

Begin Recording: Click this icon to begin recording a macro (as described in more
detail later in this chapter).

Play Selection: Click this icon to begin playing a selected action. Playback begins at the
step selected; you can choose the action’s name to start the macro at the beginning, or
expand the macro and select any step to begin playback at that point.

Create New Set: Click this icon to create a new action set (as described later in this
chapter).

Create New Action: Click this icon to begin a new action.

Delete: Click this icon to remove a selection action or step.

@ You can also find all these commands on the Actions palette pop-up menu.

Examining an action in List mode

Try this quick practice run to see exactly how the Actions palette works:

1.

Display the Actions palette in List The StepS for the Vignette (Selection)
mode. action are displayed in Figure 6-3.

If you're in Button mode, click the Click the right-pointing arrow next to
palette pop-up menu arrow and select the step you want to change.

Button mode to untoggle the option.

The step expands to show the parame-
You need to be in List mode to create b exp =

ters used for that step. For example,

an action. for the Vignette (Selection), the layer
Expand the Default Actions folder, is filled by using white at an opacity
and click the right-pointing arrow of 100 percent and by using the Normal
next to the name of the action. fill mode.

CONTINUED
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You can click in the dialog box
column for several of the steps (Make
Snapshot, Feather, Make Layer, and
Fill). You can select or deselect this
column for a specific step to control
whether the dialog box for that step is
displayed.

For example, with the Vignette
(Selection) action, if you deselect all the

boxes in the dialog box column except
for the one next to Fill, the action pro-
ceeds without input from you until it
reaches the Fill step. Then the Fill dialog
box pops up, and you can change set-
tings such as the fill color, opacity, and
fill mode. You can also click in the
dialog box column next to the action’s
name to turn on or off all the marked
dialog box steps in the macro.

Figure 6'3 J Actions
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n st 7 it (selaction])
v [ Make snapshat
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v Layer Yia Copy
o [ Show current layer
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v < Fil
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Cpacity: 100%
Maode: normal
i [» Move current layer
« | [ [ Frame Channel - 50 pixel
vl [» Wood Frame - 50 pixel
W [» Cast Shadow (type)
“ [» Wiater Refection (type)
« | [ [# Custom RGE to Grayscale
v [ Malten Lead
o 1 [] [r Make Clip Path (zalection)
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Introducing Preset Actions

Photoshop’s preset actions are located in a series of files in the Actions folder. The default
actions are loaded by, um, default, when you first open Photoshop. However, other preset
actions are available for you to open and use. They include Frames (for putting frames around
your images), Text Effects (for enhancing your text), and Textures, for adding textures to your

selections.



Preset action options

Introducing Preset Actions

Here are some other tidbits about using preset actions :

I’

If you saved actions of your own (as described later in this chapter) somewhere other
than the Photoshop Actions folder, you can navigate to that folder by using the usual

file navigation commands.

To remove the existing actions and replace them with the set you are loading, choose
Replace Actions from the palette pop-up menu.

To reset the Actions palette to the Default Actions set (removing all other sets you may
have loaded), choose Reset Actions from the palette pop-up menu.

To clear all actions from the Actions palette, choose Clear Actions from the palette
pop-up menu. (You might want to do this when creating your own set of actions from

scratch.)

To rename an action set, select it and choose Set Options from the palette pop-up

menu.

Loading preset actions

Follow these steps to load preset actions.

1.

3.

©)

In the Actions palette, click the
palette pop-up menu arrow and
choose Load Actions.

Photoshop opens the Photoshop
Actions folder in the Load dialog box,
as shown in Figure 6-4. This folder con-
tains several sets of actions presets.

Select one of the actions sets.

For example, Image Effects.atn is
selected in Figure 6-4.

Click the Load button.

Photoshop’s additional actions presets also
appear at the bottom of the Actions
palette pop-up menu. You can add any of
them to your current set by clicking the

set’s name. Any action sets that you create
yourself (as described later in this chapter)
also appear in the pop-up menu if you
save them in the Photoshop Actions
folder.

The new actions presets appear in the
Actions palette, appended after the
default actions that are already there.
You can show or hide the actions in the
Default Actions or Image Effects sets
by clicking the expand/collapse arrow
in the third column.

You can also make actions available or
unavailable for an entire set by clicking
the first column in the Actions palette next
to the action set’s folder icon.

CONTINUED
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Figure 6-4
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Playing a preset action

To play a preset action, just open the file you want to apply the action to and then do one of
the following:

v In List mode, select the action you want to play, or expand the action and select the
step you want to begin with. Then click the Play Selection button at the bottom of the
Actions palette. You can also choose Play from the palette pop-up menu.

v In Button mode, click the action you want to play. There are no other options.

you want to play in List mode and then Ctrl+click (88+click on the Mac) the Play button in
the Actions palette. You can also simply double-click the step in the list while holding down
the Ctrl key (the 38 key on the Mao).

@ If you want to play back just one step of an action, say, for testing purposes, select the step

Creating a New Action

The hardest part about creating a new action is figuring out what functions you want to auto-
mate. Think about steps that you carry out over and over, and whether you could be more
productive if you had an action that could do them for you. Then, examine the actual steps



Editing and Managing Actions

you want to automate so that you can record them. After that, creating a new action involves
little more than starting Photoshop’s macro recorder and carrying out the steps you want to
include in the action. You might want to create your own action to reduce images to a con-
stant 500 pixels wide for display in an eBay auction, for example. Or you might want to save a
bunch of files in a particular format or convert them from RGB color to grayscale.

Here are the steps to follow to create a new action:

1.
2.

3.

Figure 6-5

Open an image.

Display the Actions palette in List
mode.

Click the Create New Action button at

the bottom of the Actions palette.

You can also choose New Action from
the palette pop-up menu.

The New Action dialog box opens, as
shown in Figure 6-5.

In the Name text box, enter a name
for the action.

From the Set pop-up menu, choose the
actions set. If you have more than one
actions set open, choose the actions
set in which you want to place the
new action.

You may want to associate the action
with a button on the keyboard.
Function keys like F2, F3, and so on are
very useful for actions you perform all
the time.

To associate the action with a func-
tion key shortcut, choose the name of
the function key from the Function
Key drop-down list.

Select the Shift or Control (8 on the
Mac) check box to use either of these
keys along with the function key:.

Any keyboard shortcut you assign to
an action overrides the default func-
tion already assigned to the keyboard
shortcut. You can revert to the original
shortcut by choosing Edit~>Keyboard
Shortcuts. See Book |, Chapter 6, for
details.

From the Color drop-down list, select

10.

9.

a color to mark your action in Button
mode.

This option enables you to group
related actions by color.

Click the Record button in the New
Action dialog box to begin recording.

Carry out all the steps you want to
record.

Click the Stop Playing/Recording
button at the bottom of the Actions
palette to finish the action.

Your new action appears in the Actions
palette in both List and Button modes.

Hew Action
n——>m:-¢
IIEiI________........;.- St
n—)- Function Key: Fe
n——»-:ﬂu O

Resiog (o
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Emage Effects

v

Shaft
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The first thing you need to do after you create a new action is to try it out by opening an
image and clicking the Play button in the Actions palette. If the action doesn’t perform as you
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expect, you may need to edit your action to fine-tune it. You also may need to edit an action
to add features or change the action’s behavior in some way. For example, you might decide
that you want your resizing action to change the size to 45 percent rather than 50 percent.
Photoshop enables you to edit your actions fairly easily.

You have a lot of editing options; you can change the action’s name, keyboard shortcut, or
color-coding of an action. That’s easy enough: Just double-click the action name in the Actions
palette to enter a new name, or select the action, choose Action Options from the palette pop-
up menu, and change the information as desired. You can also hold down the Alt key (Option
key on the Mac) and click the action’s name in the Actions palette to open the Actions Options
dialog box.

Re-recording an action

As easy as editing an action is, often your best option is to simply re-record the action from
scratch. If the action is not long or complex, you can often re-record it in less time then
editing the existing action takes.

You can re-record an action two ways:

v Create a new action from scratch: Perform all the steps again to replace the old action
with a new one, saving the action under the same (or a different) filename.

v Use the clever Record Again feature: Photoshop runs through the steps you already
recorded, opening the appropriate dialog boxes used the first time around so you can
enter new values.

This method is very handy if you just want to change some of the parameters but keep
the steps the same and in the same order. You don’t even have to remember what steps
you used. Photoshop runs through them for you as you record the steps, or macro, again.

To re-record a macro with the Record Again option, select the name of the macro you want to
re-record and choose Record Again from the palette pop-up menu. As the different dialog
boxes appear, enter the values you want and click OK until the macro is finished.

Slowing down action playback

When you play back an action to test it, the action ~ Options from the palette pop-up menu, as shown
may run too quickly for you to see exactly whatis in the following figure, and choose a playback
going on. To slow things down, choose Playback  speed in the Playback Options dialog box.

Playback Options
Performance fF ox
Acceberated Cancel
) Step by Step

Pauie For

¥ Pauie For Audio Annotation
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Select Accelerated to zip through an action at  create a short pause before moving on. If you
normal speed; Step by Step to command want to get really fancy, you can select the Pause
Photoshop to stop between actions so you can  for Audio Annotation check box and use your
examine what has happened, or Pause For to  microphone to describe what each step does.

Editing an action

You can also edit individual steps of an action. Here are some of the editing changes you can make:

I/

v

Move a step: To move a step from one place in the action to another, click the action
you want to relocate and drag it to its new place in the action list.

Add a step in the middle: To add a new step in the middle of an existing action, select
the step that you want to precede the new step. Click the Record button and perform
the steps you want to add. Click the Stop Recording button when you’re finished.

Add a step to the end: To add a new step at the end of an existing action, select the
name of the action, click the Record button, and perform the steps you want to add.
Click the Stop Recording button when you’re finished.

Remove a step: Click the step you want to delete and either drag the step to the trash
can icon, or click the trash can icon and click OK in the dialog box that pops up. (Hold
down the Alt key [Option key on the Mac] to bypass the dialog box and delete the step
without confirmation.) You can also select a step and choose Delete from the palette
pop-up menu.

Duplicate a step: Hold down the Alt key (Option key on the Mac) and drag the step you
want to duplicate to another location in the Actions palette. Photoshop then creates a
copy of the step, leaving the original step where it was. You can also select a step and
choose Duplicate from the palette pop-up menu or click the Create New Action button in
the Actions palette. Photoshop then creates a duplicate step immediately after the one
being copied. You can then drag the duplicate to the position where you want it to appear.
You can also drag a step onto the Create New Action button to duplicate the step.

@ You can remove or duplicate an entire action by using the procedures described in the

preceding list for removing a step and duplicating a step.

Saving actions

If you create your own sets of actions, you may want to include them in custom sets that you
can load or remove as needed. Just follow these steps:

1.

2.

Display the Actions palette in List 3. Enter a name for your actions set.
mode. -— .

4. Drag any existing actions you want to
Click the Create New Set button in the include from their locations in the
Actions palette or choose New Set Actions palette to a new location
from the palette pop-up menu. within your new set folder.

The New Set dialog box appears. CONTINUED
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Create any new actions you want to
include within the new set.

Select the name of the set and choose
Save Actions from the palette pop-up
menu.

Batch Processing Actions

Photoshop’s Batch feature lets you apply an action to a group of files. Suppose you want to
make changes to a series of files. You could open each file in Photoshop, play the desired
macro, and then save the file. But that might take a few minutes, or much longer if you have a
lot of files to process. If you want to keep your original file, too, you have to remember to save
each file in a new folder. Batch processing can automate tedious chores like this for you.

7.

Save the set in the Photoshop Actions
folder or another folder of your
choice.

To check out this useful tool, copy some files (at least five or six) to a new folder and follow
these steps:

1.

Make sure that all the files are in a
single folder of their own.

Photoshop by default works on all the
files in a folder. You have to use the File
Browser if you want to choose only
some of them using the Batch feature.
You can find out more about the File
Browser in Book I, Chapter 5.

Choose Filec>Automate=Batch.

The Batch dialog box opens, as shown
in Figure 6-6.

From the Set pop-up menu, choose the
set that contains the action you want

to apply.

If you have only one set of Actions
loaded, it appears by default.

Choose the action you want to apply
from the Action pop-up menu.

From the Source pop-up menu, choose
Folder.

You can also select Opened Files to
process files you already opened in
Photoshop; Import to process a series of
files captured with your scanner or trans-
ferred from your digital camera; or File
Browser to process files you selected in
the File Browser. File Browser is a good

7.

method for processing files that do not
appear in the same folder.

Click the Choose button, navigate to the
folder you want to use, and click OK (in
Windows) or Choose (in Mac OS).

Select other options in the Source
area, as desired. Here’s a description
of your choices:

v Override Action “Open” Commands:
Normally, Photoshop automatically
opens each of the files in the selected
folder and processes them, so your
action doesn’t need to contain an
Open command. However, if the
macro does contain an Open com-
mand, you’ll want to select this
option to tell Photoshop to substi-
tute files in the selected folder rather
than those that might be specified in
your action’s own Open command.

Don't select the Override Action “Open”
Commands option if you do want
Photoshop to use files specified by the
action. For example, your action might
open a file and copy its contents to the file
being batch processed. In that case, you
would not want to override the macro’s
Open commands.



v Include All Subfolders: Select this

option to process files in subfolders
within the folder specified.

v+~ Suppress File Open Options

Dialogs: Select this option to have
Photoshop disregard any options
that could be possibly selected

Batch Processing Actions

filenames for the new, processed files
by choosing from the pop-up menus.

You can choose options from six pop-
up menus, depending on how long and
complicated you want the filenames to
be. Here are a few suggestions:

v+ You'll usually want to choose

upon opening a file.

‘NEW Suppres§ Filg Open Options Dialogs is a
d )y nhew option in Photoshop cs.

v~ Suppress Color Profile Warnings:
When Photoshop opens a file that
contains its own color profile, it asks
whether you want to use that profile
or Photoshop’s default profile.
Selecting this check box suppresses
that choice; Photoshop always uses
its own default color profile.

ﬂ In the Destination area, tell
Photoshop what to do with each file
after it is processed with the macro.
Choose one of the following options
from the drop-down list:

v None: Leaves the file open on your
Photoshop desktop without saving
it (unless the action itself contains a
Save command).

1+ Save and Close: Closes the files in
the same folder where Photoshop
found them. Your original file is
overwritten, so use this option only
when you don’t want to save the
original or have another copy.

v Folder: Saves the document in a
folder.

n If you chose Folder in Step 8, click the
Choose button and navigate to a desti-
nation folder for your files.

70. Select the Override Action “Save As”
Commands check box to ignore any
Save As parameters in the action and
use the filenames of the files as speci-
fied in the File Naming section
described in Step 11.

m In the File Naming section, specify
how you want Photoshop to create the

Document Name from the first pop-
up menu. If you do that, Photoshop
retains the document name of the
original file. If your documents are
named Sunset.tif, Sunrise.tif,
and Winter.tif, for example, the
processed versions are given
exactly the same names.

There are other choices in the pop-
up menus, such as consecutive
serial numbers or mm/dd/yy
choices, which you can apply if you
want. The serial numbers choices
create consecutive numbers, either
1-, 2-, 3-, or 4-digit numbers, as well
as serial letters, such as a, b, c or A,
B, C, for each file created.

v You'll usually stick with the file’s

extension in the second pop-up
menu. Choose extension to apply a
lowercase version of the file’s origi-
nal extension, or EXTENSION to
apply an uppercase version.

v Use the four additional pop-up

menus if you want to create longer
and more complicated filenames.

For example, if you choose
Document Name in the first pop-up
menu, 4 Digit Serial Number in the
second pop-up menu, ddmmyy in
the third pop-up menu, and exten-
sion in the fourth pop-up menu (as
shown in Figure 6-6), the
Sunset.tif, Sunrise.tif, and
Winter.tif files are renamed
Sunset0001120302.t1f,
Sunrise0002120302.t1if, and
Winter0003120302.t1f if they're
saved on December 3, 2002.

CONTINUED
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®

12.

13.

Figure 6-6

When processing large numbers of files,
these naming tools can help you keep track
of when and how the files were created.

Select the Windows, Mac OS, or Unix
check box to specify what operating
system you want the saved filenames
to be most compatible with.

From the Errors pop-up menu, choose
whether you want Photoshop to stop
processing a batch when it encounters
an error or whether you want it to
simply continue and list the errors in
a file. If you choose the latter option,
click the Save As button to specify a
log file and location for the log.

©)

4.

If you want to apply several different
actions to a single set of files, or to apply
the same action to multiple folders of files,
just create an action that includes multiple
batch-processing directives. To process
multiple folders, you can also deposit
shortcuts (in Windows) or aliases (in Mac
0O9) to each of the additional folders in the
main source folder, and then select the
Include All Subfolders check box in the
Source area.

When you’re done selecting options
in the dialog box, click OK to start the
batch processing.
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Creating Droplets

Creating Droplets

Droplets are drag-and-drop miniapplications, or applets, in macro form that can exist outside of
Photoshop on your desktop, in your taskbar, or within a folder. They’re always available so that
you can apply them to any image files you want. Think of them as batches waiting to happen.

Photoshop installed on your computer. If you move the droplet to another computer that
doesn’t have Photoshop on it, the droplet just sits there and looks pretty.

Even though you don’t have to be running Photoshop to use droplets, you do need to have

All you need to do is drag the file or files you want to process onto the droplet. Photoshop
doesn’t even have to be open at the time. When you drop the file or files, the droplet opens
Photoshop and carries out the steps in the action embedded in the droplet’s instructions.
You must use an existing action as the core of the droplet.

To create a droplet, follow these steps:

1. Choose File~>Automate~>Create
Droplet.

In the Play area, choose the actions
set, action, and options.

Select a destination from the
Destination pop-up menu.

The Create Droplet dialog box opens,
as shown in Figure 6-7.

3.
ﬂ In the Save Droplet In area, click the Specify any file-naming options you
Choose button and enter a name and want.
location on your hard drive for the ﬂ
7.

droplet application. Specify how Photoshop should

process errors.
The location isn’t of overriding impor-
tance because after you create the
droplet, you can drag it to your desk-
top, a toolbar, or wherever you like. To use the droplet, just select the file,
files, or folders you want to process
and drag them to the droplet applet.

When you’re finished, click OK to
create the droplet.

The rest of the Create Droplet dialog
box is the same as the Batch
Processing dialog box (described in
the steps in the preceding section), CONTINUED
except that you don’t have to specify a

Source. Droplets use the files dropped

on them as their source files.
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Making Selections

In This Chapter

v Capturing selections with
the marquee tools

+~ Roping selections with the
lasso tools

v Picking up pixels with the
Magic Wand tool

can’t make a good selection, your work will look like it

belongs with the creatively, but poorly, composed images
from one of those weekly tabloid rags. You know what I'm talk-
ing about — those pictures that go alongside headlines like
“Bat Boy Wins Bake-Off” and “Woman with 16 Fingers Wins
Typing Contest.” Those pictures could look better, don’t you
think? It seems like some artists intentionally make their com-
posite photos look like they were constructed with a dull pair
of scissors and some Elmer’s glue.

No matter how much you learn about Photoshop, if you

Making accurate selections is the key to creating and editing
images effectively so that the end result looks flawless.
Fortunately, Photoshop offers a bevy of tools and techniques for
creating selections, from the simple to the complex. Photoshop
offers three basic methods of creating a selection: using a selec-
tion tool or method, using the Pen tool, or creating a mask.

one of the most important skills you can acquire. Trust me
when | say that every minute you spend perfecting your
selection techniques will pay off tenfold.

@ No matter which technique you use, creating selections is

In this chapter, I give you the foundation you need to use the
selection and pen tools. In fact, the rest of Book Il covers these
tools in detail. I cover the more complex method of masking in
Book VI

Defining Selections

The tools I discuss in this chapter require you to take a little
piece of a larger image so that you can dig in and make some
serious edits. Defining a selection means that you specify which
part of the image you want to work with.
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Everything within a selection is fair game for manipulation and is considered selected.
Everything outside the selection is protected, or unselected. Simple enough, right? Well, you
can also have partially selected pixels. Confused yet? A partially selected pixel has usually
been anti-aliased, feathered, or masked. (I cover anti-aliasing and feathering later in this chap-
ter. You can find out about masking in Book VI.)

@ When you use a selection tool to define a selection, a moving dotted outline called a selec-
tion marquee appears.

Marqueeing When Vou Can

Photoshop geeks call the selection marquee by a variety of names. Sometimes it’s referred to
as a marquee, other times as a selection, and you might even hear people call it a selection
outline, an outline, selection edges, or just plain old edges. A favorite name for these dotted
lines is marching ants. Throughout the book, I usually call them selection marquees. Boring?
Maybe. Accurate? Yup. Whatever you want to call the selection marquee, how you create one
depends on the particular marquee tool you use.

The marquee tools are the easiest selection tools to use — so I suggest that you use them
when you can.

@ In the Photoshop repertoire of tools, you'll find four types of marquee tools: Rectangular
Marquee, Elliptical Marquee, Single Row Marquee, and Single Column Marquee.

Using the Rectangular Marquee tool

The first tool on the Marquee tools flyout menu is the Rectangular Marquee tool. (If you
skipped Book I, Chapter 2, a flyout menu describes the hidden tools that appear when you
click any tool in the Tools palette that has a small triangle in the bottom-right corner.) Use this
tool to create rectangular or square selections.

The Rectangular Marquee tool is a good tool to use when you want to zero in on an image,
plucking it out of a larger background to provide a better focal point.

Here’s how to make a selection with the Rectangular Marquee tool:

1. Select the Rectangular Marquee tool For example, in Figure 1-1, I dragged
from the Tools palette (also known as from the lower-left corner to the upper-
the Toolbox). right corner.

You can also use the keyboard If you want to drag your selection from
shortcut — press the M key. the center outward instead of corner to

corner, press the Alt key (Option on the
Maco) after you begin dragging. When you
have your desired selection, release your
As you drag, the selection marquee mouse button and then release the Alt
appears. The marquee follows the (Option on the Mac) key.

movement of your mouse cursor.

Drag from one corner of the area you
want to select to the opposite corner.
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3. Release your mouse button. When you have your desired selection,
’ release the mouse button and then the
4. If you want to create a perfect square, Shift key.
press the Shift key after you begin
dragging. You now have a full-fledged rectangular
selection.

Figure 1-1
Book

m

Chapter

1

Using the Elliptical Marquee tool

The Elliptical Marquee tool is designed for elliptical or circular selections. You can easily
select objects such as clocks, balls, and full moons with this tool.

The Elliptical Marquee tool works almost exactly like the Rectangular Marquee tool
(described in the preceding section). The only difference is that you don’t drag from corner to
corner; you drag from a given point on the ellipse, which makes the process a little tougher.
Here are the steps:

7. Select the Elliptical Marquee tool E Position the crosshair (the plus sign
from the Marquee flyout menu in the icon of the cursor) near the area you
Toolbox. want to select and then drag around

You can also use the keyboard short- your desired element.

cut. If the Elliptical Marquee tool is visi- As you drag, the selection marquee
ble, press the M key. If the Rectangular appears.

Marquee is visible, you must press

Shift+M.

CONTINUED
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You may find it easier to create an ellipti-
cal selection by pressing the Alt (Option
on the Mac) key and dragging from the
center outward. First click the mouse
button, and then before you move the
mouse, press Alt (Option on the Mac) and
finally the Shift key. Then drag. When you
have your desired selection, release your
mouse button and then the Shift+Alt
(Shift+Option on the Mac) keys. This tech-
nique works for creating circles or squares.

To create a perfect circle, press the Shift
key after you begin dragging. When you
have your desired selection, release your
mouse button and then your Shift key.

©)

When you’re satisfied with your selec-
tion, release your mouse button.

Your elliptical selection is alive and
well, as shown in Figure 1-2. If you need
to move the selection marquee to
better center your selection, click and
drag inside the marquee.

You can also move a selection with any of
the marquee tools by pressing the space-
bar while you're drawing.

If the selection isn’t quite the right
shape and size, jump to Book III,
Chapter 2, to find out how to make per-
fect selections.

Using the Single Column and Single Row Marquee tools

You probably won'’t find a lot of uses for the Single Row and Single Column Marquee tools.
These tools select a single row or single column of pixels. If you select a row, the selection can
be only 1 pixel tall. Likewise, if you select a column, it can be only 1 pixel wide.

If you don’t go blind using them, these tools can occasionally come in handy for selecting

and repairing a thin scratch or fold line on an image or for getting rid of an artifact such as a
colored line that has somehow appeared on a scanned image. (You can find out more about
making repairs in Book VIIL.)
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To use either of these tools, simply choose a row or column of pixels on your image and click
it. You don’t have to do any dragging, but it does help to zoom into your image so that you
can better position the tool on the offending row or column.

For more on zooming, see Book I, Chapter 5. Check out Figure 1-3 to get familiar with a single
row selection.

The Single Row and Single Column Marquee tools don’t have keyboard shortcuts, so you're
stuck with having to click the tools to select them.

Book
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Figure 1-3

Using the marquee options

If drawing from the center outward or creating a perfect circle or square doesn’t give you
enough control, you may want to take a look at the marquee settings provided by the Options
bar. These options allow you to make even more precise selections by specifying exact
measurements.

You must select the options in the Options bar before you make your selection with the
marquee tools.
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For now, you can ignore the first five icons on the left of the Options bar, as shown in Figure 1-4.
The first icon has to do with tool presets, which [ cover in Book I, Chapter 2. The next four
icons are the selection state icons, which I discuss in Book IIl, Chapter 3.

Fite Edit Image Layer Select Filter View Window Help
Figure 1-4 ;
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Here’s the lowdown on each of the remaining options:

v Feather: Feathering blurs or feathers the edges of a selection. The amount of blur
depends on the pixel value that you enter for the radius — the higher the radius, the
blurrier the edge. For example, in Figure 1-5 you see that a higher Feather radius means
a blurrier edge. The radius measures how far in all directions the feather effect extends.
For example, a radius of 4 means that the feather extends 4 pixels to the right, left, up,
and down from the selection outline.

Feather radius
20 pixels
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You can use feathers to create a subtle and natural transition between selections or to
create a special effect where an image slowly fades out to the background or to trans-
parency. If you want to apply a feather as you are selecting, select the Feather option in
the Options bar before using the marquee tools. However, if you have already made
your selection, you can feather it after the fact by using the Select menu. Check out
Book IIl, Chapter 2, for more feathering details.

v Anti-aliased: Whereas feathering completely blurs edges, anti-aliasing just slightly soft-
ens the edge of an elliptical selection so that very hard, jagged edges aren’t quite so
prominent, as shown in Figure 1-6. You don’t have an option for entering a pixel value
for anti-aliasing. An anti-aliased edge is always 1 pixel wide.

Book
You can use the anti-aliasing option only with the Elliptical Marquee tool. It isn’t avail- 1/}
able for the other marquee tools because the selections you make with the other tools Chapter
always have straight edges — there aren’t any jagged edges to soften. | recommend 1

keeping this option selected, especially if you plan to create composite images. Anti-
aliasing helps in creating natural-looking blends between multiple selections.

v~ Style: The Style drop-down list contains three settings:
The Normal setting enables you to freely drag a selection to any desired dimension.

The Fixed Aspect Ratio option allows you to specify a ratio of width to height in a
selection. For example, if you enter 2 for width and 1 for height, you always get a
marquee selection that’s twice as wide as it is high, no matter what the size. A selec-
tion that’s 4 inches wide is automatically 2 inches high. You aren’t limited to whole
numbers, by the way; decimals are acceptable as well. This option is frequently used
to create vertically oriented images from horizontal video screen captures and
photos taken with digital cameras.

And finally, select Fixed Size to specify exact values for the Width and Height. This
option comes in handy when several images need to be the same exact size, as in a
row of headshots of executives in a corporate brochure.

v Width and Height: When you select a Fixed Size from the Style drop-down list, the
Width and Height text boxes are available for you to enter values.

Even though the default unit of measurement in the Width and Height text boxes is pixels
(px for short), you can enter any unit of measurement that Photoshop recognizes —
pixels, inches, centimeters, millimeters, points, picas, or percents. After the number,
simply type in the word or abbreviation of your desired unit of measurement. Photoshop
even lets you enter mixed units of measurements, so if you want a selection 100 pixels by
1.25 inches, you can do so.

Why would you do this? Who knows, but Photoshop allows you to. You'll only use this
option if a selection must be a certain number of pixels wide, and even though you’re not
sure of the exact pixel measurement of the height, you're guessing that it’s, say, 1.25 inches.

B8] vew Photoshop ¢s has a new button (a double-headed arrow icon) between the Width and
‘V yy Height fields. Click this button to swap the values between the Width and the Height.
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Figure 1-6

Anti-aliasing off

Lassoing When You Can’t

Unfortunately, not much in life is rectangular or elliptical in shape. Most of the time, you have
to deal with irregular shapes with extrusions and protrusions (otherwise known as bumps or
bulges) of some sort or another. That’s where the lasso tools come in handy. This group of
tools allows you to make free-form selections.

Photoshop offers three lasso tools: the Lasso tool (which I call the regular Lasso to distinguish
it from the others), the Polygon Lasso tool, and the Magnetic Lasso tool. Each of the lasso
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tools has its own special purpose in the realm of free-form selections. But in the category of
simplicity, they’re all almost as easy to use as the marquee tools. If you can drag with your
mouse, you're qualified to handle any lasso tool. Just don’t indulge in too much caffeine. A
steady lasso hand is a good lasso hand.

To make a selection with the regular Lasso tool, all you have to do is drag around the part of the
image you want to select. The selection you make is only as good as how accurately you can
trace around your desired element. You need a steady hand — and a lot of practice — to
become a good Lasso tool user. But don't fret; if you don’t make an exact selection the first time
around, you can always go back and make corrections (which I cover in Book IIl, Chapter 3).

©)
©)

If, when making a selection, you find yourself fighting with your mouse (and losing), you
may want to invest in a digital drawing tablet, such as a Wacom tablet. Using the stylus and
the tablet can make mastering tools such as the Lasso a whole lot easier.

The Lasso and the Polygon Lasso tools both have only two choices in the Options bar to
worry about — Feather and Anti-aliased. These options work exactly like they do with the
marquee tools. To find out more, check out the earlier section, “Using the marquee options.”

To make a selection by using the Lasso tool, here’s what you do:

1.

Select the Lasso tool from the Tools
palette.

It’s the tool that looks like a rope. You
can also use the keyboard shortcut;
press the L key.

Position the cursor somewhere on the
edge of the element that you want to
select.

The hot spot (the lead point) of the
lasso cursor is the end of the rope.

Where you start doesn’t really matter.
You may need to zoom in on the image a
bit if there isn’t a lot of contrast between
the element and the background.

In my example, [ started at the top of
the pitcher, as shown in Figure 1-7.

Trace around the element, trying to
capture only what you want to retain
in your selection.

As you trace, a line forms that follows
the movement of your mouse.

Don’t release your mouse button until
you've completed the selection by
closing the loop or returning to the
starting point.

When you release your mouse button,
Photoshop thinks you’re done and
closes the selection from where you
released the mouse button to your
starting point, as shown in Figure 1-8.

Continue tracing until you return to
your starting point; release the mouse
button.

Recognizing that you’re now done,
Photoshop presents you with a selec-
tion marquee that matches your lasso
line (see Figure 1-9).

CONTINUED
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Figure 1-8
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Figure 1-9
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Selecting straight sides with the Polygon Lasso tool

Whereas the regular Lasso tool is great for selecting undulating, curvy elements, the Polygon
Lasso tool shines when it comes to the more regimented, straight-sided subjects, such as city
skylines, buildings, and stairways.

Unlike the regular Lasso tool, the Polygon Lasso tool has rubber-band-like qualities, and
instead of dragging, you click and release the mouse button at the corners of the object
you're selecting. It’s like a digital connect the dots. Bonus: less manual dexterity required.

The following steps show you how to select with the Polygon Lasso tool:

1. Select the Polygon Lasso tool from the

Toolbox. A corner is always a good place to start.
You can also use the keyboard short- 3. Move the mouse and click at the next
cut. Press the L key and then press corner of the object.
Shift+L until you get the Polygon Lasso )
tool. It looks like the regular Lasso tool, The line stretches out from your cursor
but it has straight sides. like a rubber band.

2. With the Polygon Lasso tool selected, 4. Continue clicking at the various
click to establish the beginning of the corners of your object.

first line of your selection.

CONTINUED
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5. To close your selection, return to the You can also double'-click, and
first point you clicked and click one Photoshop automatically closes the
last time. selection from the point you double-
clicked to your starting point.
Whgn you .place your cursor over the A selection marquee that matches your
starting point, a small circle appears next -
Polygon Lasso line appears, as shown

to your cursor, a sure sign that you're at
the right place for closing the selection.

in Figure 1-10.

Figure 1-10

Attracting with the Magnetic Lasso tool

The newest member of the lasso tool trio is the Magnetic Lasso, which [ admit can be kind of
tricky to use and sometimes even downright obstinate. The Magnetic Lasso tool works by ana-
lyzing the colors of the pixels between the elements in the foreground and the elements in the
background. Then it snaps to the edge between the elements, as if the edge had a magnetic pull.

The Magnetic Lasso tool performs best when your image has a lot of contrast between the

@ foreground and background elements — for example, a dark mountain range against a light
sky or a shadow against a stucco wall.

The Magnetic Lasso tool also has some unique settings, which you can adjust in the Options

bar, to tame its behavior. I cover those settings in the next section, “Adjusting the Magnetic

Lasso options.” For now, follow these steps to use the tool:

1. Select the Magnetic Lasso tool from ﬂ Click on the edge of the object you

the Toolbox. want to select.

You can also use the keyboard shortcut: You can start anywhere; just be sure to
Press the L key and then press Shift+L click on the edge between the element
until you get the Magnetic Lasso tool. you want and the background you

The tool looks like a straight-sided don’t want.

lasso with a little magnet on it.
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simply press your Backspace

M rsor around the object,
ove your ctrsorarou onec (Delete on a Mac) key to delete it.

without clicking.

4. Continue moving your mouse around
the object; return to your starting
point and release the mouse button to
close the selection.

The Magnetic Lasso tool creates a
selection line similar to the other Lasso
tools. It also adds little squares called
points along that selection line, as

shown in Figure 1-11. These points pin As with the Polygon Lasso tool, you
down the selection line the way you see a small circle next to your cursor
might section off an area of your yard indicating that you're at the correct
with ropes and stakes. place to close the selection. If you Book
v~ If the Magnetic Lasso tool starts double-click, Photoshop closes the m
veering off the edge of your object, selection from where you double- ChiakiG)
clicked to your starting point. The 1

back up your mouse and click to

force a point down on the line. selection marquee appears when the

selection is closed.
v~ 1If the Magnetic Lasso tool adds a
point where you don’t want one,

Figure 1-11

Adjusting the Magnetic Lasso options

The Magnetic Lasso tool comes equipped with a few settings in the Options bar that control
the sensitivity of the tool (see Figure 1-12).

| recommend starting out by messing around with the Magnetic Lasso tool using its default
settings. If the tool isn't cooperating, then play with the options.
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Having it both ways with the lasso tools

Which tool do you use if you have an object with
both curves and straight sides? You can have
two, two, two tools in one! Press the Alt (Option
on the Mad key to have the Polygon Lasso tool
temporarily transform into the regular Lasso tool.
Then drag to select the curves. Release the Alt
(Option) key to return to the Polygon Lasso tool.
And this trick works with the regular Lasso tool
as well. Press Alt (Option) to temporarily access
the Polygon Lasso tool. When you want the reg-
ular Lasso tool back again, just drag your mouse.
In this case, you can hold down the Alt (Option)

key; it makes no difference. If you want to release
the Alt (Option) key, just make sure that you're
pressing down the mouse button; otherwise,
Photoshop will close the selection.

To temporarily change the Magnetic Lasso tool
into the Polygon Lasso tool, press the Alt (Option
on the Mao key and click. As you hold down the
Alt (Option) key, drag to get the regular Lasso
tool. When you want the Magnetic Lasso tool
back again, release the Alt (Option) key and
move your mouse without clicking.

S |t 7 | 7 i T s | v |

Figure 1-12

The first icon has to do with Tool Presets, and the next four icons are the selection state icons
(check out Book IIl, Chapter 2). The Feather and Anti-aliased options work like they do with
the marquee tools (see the earlier section, “Using the marquee options”). The following list
explains the remaining options:

v Width: This option, measured in pixels from 1 to 256, determines how close to the edge
you have to move your mouse before the Magnetic Lasso tool recognizes the object
you're selecting.

Decrease the value if
The object’s edge has a lot of indentations and protrusions.
The image is of lower contrast.
Increase the value if
The image is of higher contrast.
The image has smoother edges.

When using the Magnetic Lasso tool, you can change the Width value from the key-
board by pressing the open bracket ([ ) key to lower the value and the close bracket
(1) key to increase the value.

v Edge Contrast: Measured in percentages from 1 to 100, this option specifies the
required contrast between the object you're selecting and its background before the
Magnetic Lasso tool hugs the edge between them. If your image has good contrast
between the foreground and background, use a higher percentage.

v Frequency: This setting, measured in percentages from 1 to 100, specifies how many
points to place on the selection line. The higher the percentage, the greater number
of points.

If the object you want to select has a fairly smooth edge, keep the percentage low.
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If the edge is jagged or has a lot of detail, a higher percentage may be more effective
in getting an accurate selection line.

v Pen Pressure: If you own a pressure-sensitive drawing tablet, select this option to make
an increase in stylus pressure cause the edge width to decrease.

Performing Wand Wizardry

The Magic Wand. The name is intriguing, isn’t it? Any tool that has the audacity to call itself

the Magic Wand must be so powerful that it can grant your every selection wish with a mere Book
swoosh. Unfortunately, it’s not quite so awe-inspiring. A better name for this tool would be the 1/}
Click-'n-Select tool. You click your image, and the Magic Wand tool makes a selection, which Chapter
contains areas of similar color, based on the color of the pixel you clicked. 1

Simple enough. What’s not quite so simple is how to determine how similar the color has to be
to get the Magic Wand tool to select it. That’s where the important Tolerance setting comes in.
Before you tackle tolerance (and find out how it affects the Magic Wand tool’s performance),
you first need to get the hang of using the Magic Wand tool.

Selecting with the Magic Wand tool

As with the Magnetic Lasso tool, the Magic Wand tool works best when you have high-contrast
images or images with a limited number of colors. As shown in Figure 1-13, a black-and-white
checkered flag is a perfect example of something that the Magic Wand tool effectively selects.

I click once on the top of a black square, and the Magic Wand tool picks up all the other sur-
rounding black pixels. [ can now easily change the color of my black squares to red or yellow
in one fell swoop.

Figure 1-13




2 3 4 Book 111 » Chapter 1: Making Selections

As you can see, Figure 1-14 is a poor candidate. This image contains a ton of colors and no real
definitive contrast between the scale and the background. Although it takes only one click to
select the black squares on the flag, other high-contrast candidates may take a few clicks. And
some images may need a tweak or two of the Tolerance setting, described in the next section.

Figure 1-14

Setting your Tolerance

Sometimes an image may contain a few shades of a similar color. Consider a cloudless sky for
example. A few shades of blue make up the bright blue yonder. With the Magic Wand tool, if
you click a darker shade of blue in the sky, Photoshop selects all similar shades of blue, but
the lighter shades remain unselected. This is usually a sure sign that you need to increase
your Tolerance level. The Tolerance setting determines the range of color that the Magic Wand
tool selects.

Tolerance is based on brightness levels that range from 0 to 255:

v Setting the Tolerance to 0 selects one color only.

v Setting the Tolerance to 255 selects all colors — the entire image.
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To use the Magic Wand tool and adjust Tolerance settings, follow these steps:

1.

Figure 1-15

Select the Magic Wand tool from the
Toolbox.

The Magic Wand tool looks like the
weapon of choice for many Disney
characters. You can also use the key-
board shortcut; press the W key.

Click the portion of the image that
you want to select; use the default
Tolerance setting of 32.

The pixel that you click determines

the base color. The default value of 32
means that the Magic Wand tool selects
all colors that are 32 levels lighter and
32 levels darker than the base color.

If you selected everything you wanted
the first time you used the Magic Wand
tool, stretch your arm and give your-
self a pat on the back. If you didn’t
(which is probably the case), go to
Step 3.

3. Enter a new Tolerance setting in the
Options bar.

If the Magic Wand tool selected more
than you wanted it to, lower the
Tolerance setting. If it didn’t select
enough, raise the setting.

4., Click again on the portion of the

image that you want to select. 53R
Changing the tolerance doesn’t adjust o n
your current selection. apt;r

The Magic Wand tool deselects the cur-
rent selection and makes a new selec-
tion based on your new Tolerance
setting, as shown in Figure 1-15. If it
still isn’t right, you can adjust the
Tolerance setting again. [ regret that I
can’t give you a magic formula that you
can use to determine the right value.
It’s all about trial and error.

Tolerance of 32

Tolerance of 64



236

Book 111 » Chapter 1: Making Selections

Using the Magic Wand Options bar

If you get a selection close to what you want, stop there and then use the selection-refining
techniques discussed in Book I, Chapter 2. But before you do that, you need to know about
the other Magic Wand settings in the Options bar. The three remaining options are as follows:

v Contiguous: When you turn on this option, the Magic Wand tool selects only pixels that
are adjacent to each other. If you turn off the option, the Magic Wand tool looks
throughout the image and selects all pixels within the range of Tolerance, whether or
not they’re adjacent to each other.

v Use All Layers: This option is valid only when you have multiple layers in your image.
(For more on layers, see Book V.) If you have multiple layers and this option is on, the
Magic Wand tool selects color from all visible layers. If you turn off this option, the
Magic Wand selects colors from the active layer only.

v Sample Size: Although this option affects the Magic Wand tool, it appears in the
Options bar only when you’ve selected the Eyedropper tool. (For more on the
Eyedropper, see Book I, Chapter 3.) Select the Eyedropper tool and, in the Sample Size
pop-up menu that appears, choose from the following:

Point Sample: Samples just the color of the pixel you clicked

3 by 3 Average: Averages the color of the pixel you clicked and the surrounding 8
pixels

5 by 5 Average: Averages the color of the pixel you clicked and the surrounding 24
pixels
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fun, friendly, and pretty easy to wield, sometimes they
don’t quite have the horsepower to make that really pre-
cise selection. So either you spend a lot of time cleaning up
what you’ve selected (see Book Ill, Chapter 3, for more on that
I topic), or you live with a ho-hum selection. That’s where the
In This Chapter Pen tool and its related cronies come to the rescue. The Pen
BRI G With the Pen tools tool creates paths, which you can then convert into selections.

ﬁ Ithough the Marquee, Lasso, and Magic Wand tools are

v~ Using the Paths palette Because the Pen tool (along with its related path-editing tools)
1l I offers control and precision, it is very capable when it comes to
v~ Editing, saving, and select- nailing that accurate selection. The only problem is that the
ing paths Pen tool is a far cry from fun, friendly, and easy. Getting the

hang of it can be tricky. Many new users try the Pen a few
times, but end up muttering in disgust and returning gratefully
v~ Creating clipping paths to the Lasso tool. However, [ guarantee that if you dedicate a
good chunk of time to mastering the Pen tool, you’ll soon turn
your elite little nose up at the simple Lasso tool.

Another added benefit of knowing how to use the Pen

tool is that it’s also the main drawing tool of Adobe
lllustrator. And similar tools exist in layout programs such
as Adobe InDesign and QuarkXPress.

» Loading paths as selections

Introducing Paths

Unlike the other selection tools, the Pen tool doesn’t initially
produce a selection marquee. When you select the Pen tool and
start clicking and dragging around your image, you create a
path. Paths have three components — anchor points, straight
segments, and curved segments.

Curved paths are called Bézier paths (after Pierre Bézier who, in
the 1970s, invented the equation used for CAD/CAM programs),
which means that they are based on a mathematical cubic
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equation where the path is controlled by direction lines that end in direction points (often
referred to as handles), as shown in Figure 2-1. The length and angle of direction lines control
the pitch and angle of the Bézier curve.

Figure 2-1 and the following list introduce all the different kinds of anchor points that
Photoshop puts at your disposal and show you exactly what they do. You can use some or all
of these anchor points in a single path:

v Atrue corner point has no direction lines. Use corner points when selecting objects
with straight sides, such as stairs or barns.

v A smooth point has two direction lines pointing in opposite directions but dependent
on one another. Use smooth points when selecting objects that have alternating curves,
such as a sea of rolling waves.

v A cusp point has two direction lines that are independent of one another. Use cusp
points when selecting an object with curves going the same direction, such as the
petals on a daisy.

v A point between a straight segment and a curve is a corner point with only one direc-

tion line.
Straight
segment

.
line
Corner /—_\ / . .
point ' i 1 ' 1 ' = )

Figure 2-1

Smooth
point

Straight

segment

followed
by a
curve




Creating a Path with the Pen Tool

After you create a Bézier path, you can then edit the path by moving, adding, deleting, or con-
verting anchor points and by manipulating the direction lines. You can also transform paths
by choosing Edit=>Transform Paths (see Book IIl, Chapter 3, for details).

The path hovers over the image in its own space, and is controlled via the Paths palette where
you can save it, duplicate it, stroke it with color (apply color to the edge only), fill it with color
or a pattern, and most importantly, load it as a selection. I say “most importantly” because nine
times out of ten, you are going to painstakingly create a path as a means to an accurate selec-
tion marquee. There’s one other time you may use the path as a clipping path: to hide a part

of a layer or part of an entire image. [ cover clipping paths in the last section of this chapter.

Creating a Path with the Pen Tool

The best way to get the hang of the Pen tool is to dive right in and work with it. You’ll want to
start with straight lines, which are very easy, and then move on to the more difficult curves.
The more you practice with the Pen, the more comfortable and proficient you’ll become. It
definitely is an example of the old adage “you get out what you put into it.”

Knowing your Pen tool options

Although every path consists of three basic components — segments, points, and direction
lines — the Pen tool enables you to use these components to create a few different types of
paths. See Book IV, Chapter 2, for more information on the following options, accessible from
the Pen tool’s Options bar. You must choose one of the following:

v Shape Layers: This option creates a shape on a new layer that’s called, not surprisingly,
a shape layer. After you create the path that defines the shape, Photoshop fills the
shape with the foreground color and stores the path as a vector mask in the Paths
palette. A shape layer is a unique entity.

v Fill Pixels: This option is available only when you’re using the Shape tools. It allows you
to create a shape and fill it with the foreground color, but it does not create a shape
layer nor does it retain the path.

v~ Paths: This option enables you to create a traditional path that hovers over the image.
The path you create will be a work path, which is temporary, appears in the Paths
palette, and is unsaved. If you're creating a path that will eventually be loaded as a
selection, this is your option.

Creating your first work path
Making a work path is the easiest of the three options, and you’ll use it frequently when

you've gotten the hang of using the Pen tool. The following steps show you how to create a
simple, straight path:

CONTINUED
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Rarely (if ever) will you create a work path that’s a single, straight line. Please keep reading

the other sections in this chapter.

7. Open an image you want to practice
on.

[ suggest choosing an image that has

an element with both straight edges

and curves, if you want to also practice 5.
creating curved paths later.

2. Select the Pen tool from the Toolbox
(more formally known as the Tools 6.
palette).

Or you can just press the P key.

3. In the Options bar, click the Paths
button.

You can see this button in Figure 2-2.

4. To create a straight line, click and
release your mouse button at the
points where you want the line to
begin and to end, leaving anchor
points at those positions.

You don't need to do any dragging to
create straight segments.

As you click and add your anchor
points, Photoshop creates straight seg-
ments that connect the anchor points,
as shown in Figure 2-3.

To draw a constrained line — hori-
zontal, vertical, or 45° angle — hold
down the Shift key as you click.

To end the path, click the Pen tool to
deselect it.

Or use this very handy shortcut: Hold
down the Ctrl key (88 on the Mac),
which gives you the Direct Selection
tool (the white arrow), and then click
away from the line. Release the Ctrl key
(8 on the Mac), and the Pen tool
reappears.

When you’ve deselected the path,
you're free to start another, uncon-
nected path if you need to.

Continue on to the following sections if
you want to add other kinds of seg-
ments to the path. Otherwise, skip to
“Closing a path,” later in this chapter.

Figure 2-2
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Figure 2-3

Creating a Path with the Pen Tool

Anchor
points
Straight
segment

Drawing curves

You're probably never going to create a simple work path that doesn’t have curves as well as
straight lines. I mean, not much in life is perfectly linear. Most things have undulations here
and there. Picking up from the preceding section, here’s how to create curved paths:

1. If you are adding onto a previously
created open path, make sure that
you position your cursor on the last
anchor point you created on that
open path to continue.

You see a slash mark or small square
appear next to your cursor. If you are
starting a new path, position the
cursor where you want the curve to
begin.

In both cases, drag toward the direc-
tion that you want the bump of the
curve to go. Release the mouse button
when you're done.

If you are creating a new path, an
anchor point along with two direction
lines, which have direction points at
their ends, appears. If you are adding a
curve to your straight segment, an
anchor point along with one direction
line and one direction point appears.
The direction lines and direction points
control the angle and pitch of the curve.

CONTINUED
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Figure 2-4

Anchor point

Direction line

How do you know how far you should you
drag? You can do what | do and use the
rule of thirds. Imagine that your curve is a
piece of string that you have stretched and
laid out in a straight line. Divide that line
into thirds. The distance you drag your
mouse button is one-third the length of
that line.

How do you establish the angle? Drag
straight from the anchor point for a
steeper curve and at an angle from the
anchor point for a flatter curve. The ele-
ment in my example is a flatter curve;
therefore | dragged up and to the right at
an angle of about 4.5 degrees, as shown
in Figure 2-4.

Move the cursor to the end of the
curve and drag in the opposite direc-
tion, away from the bump.

You now see another anchor point and
a set of two direction lines and points.

®
©)

3.

Photoshop creates the curve segment
between the anchor points, as shown
in Figure 2-5.

If you drag both direction lines in the
same direction, you create a curve shaped
like an S.

In the Options bar, click the down-pointing
arrow at the end of the row of tools and
choose the Rubber Band option. With this
option selected, Photoshop draws a seg-
ment between the last anchor point you
create and wherever your cursor is located,
giving you a kind of animated preview of
how the path will appear. | personally find
the option distracting, but some users
love it.

To draw more alternating curves, just
repeat these steps, dragging in an
opposite direction each time.
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Figure 2-5
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Connecting a straight segment to a curve segment

If you need to create a straight segment after creating a curve (or vice versa), you need to
convert the point where the path changes from curved to straight. To convert a point, follow
these steps:

1. Position your cursor over the second Photoshop, it’s an indication that you are
anchor point in the existing curve and converting an anchor point, from smooth
press the Alt key (Option on the Mac). to corner or vice versa.

You see a caret (which looks like an 2. Move your mouse to the end of the
upside down V) next to the pen cursor. straight edge you want to select and
Click and release your mouse button click and release.

h h int.
over the anchor point You can press the Shift key if you want

The bottom direction line disappears. the line to be constrained horizontally,
You have converted a smooth point vertically, or at an angle with a multiple
into a corner point with one direction of 45 degrees.

line. This action will now allow you to

create a straight segment. Photoshop connects the two anchor

points with a straight segment, as
It's no coincidence that the tool icon for shown in Figure 2-6.
@ the Convert Point tool is also a caret.
Whenever you see a caret symbol in CONTINUED
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Figure 2-6

Corner point with one direction line

Straight segment

Connecting curve segments with cusp points

If you need to create a curve that goes in the same direction as a curve that is adjacent to it,
you need to take a couple additional steps:

1.

Convert the point — this time from
smooth to cusp — by positioning your
cursor over the second anchor point
in the existing curve and pressing the
Alt key (Option on the Mac).

Drag toward the bump of the curve.
Release the mouse button and then

release the Alt (Option on the Mac)

key.

Essentially, your actions are pulling the
direction line out from the anchor
point. Both direction lines move to the
same side of the anchor point, yet are
independent of each other, creating the
cusp point, as shown in Figure 2-7.

Move your cursor to where you want
the curve to end and drag away from
the bump to create your second
curve.

©)

©)

Try to keep anchor points on either side of
the curve, not along the top. It is also
good to try to use the fewest number of
anchor points possible to create your path.
That way, the path will result in a much
smoother curve. It will also create a
smaller file size and reduce the possibility
of printing problems.

To draw a curve after a straight segment,
first position your cursor directly on the
last anchor point of the straight segment.
Drag toward the bump of the curve you
need to draw. A direction line appears.
Position your cursor where you want the
curve to end and drag away from the
bump.
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Figure 2-7

Closing a path

To close the path, return to your first anchor point and click. You see a small circle next to
your pen cursor, indicating that you will close the path when you click.

Congratulations! You are now the proud owner of a work path (see Figure 2-8). Don’t worry if the
path isn’t perfect; you find out how to edit paths in an upcoming section. If your path is perfect
and you want to save it now, skip ahead to the section, “Working with the Paths Palette.”

If your path is incomplete and you need to continue drawing it, either click or drag on the
endpoint with the Pen tool. You will see the appearance of a slash mark or small square next
to the pen cursor.

Creating subpaths

You can also create a series of lines or curves. For example, you may want to create a border
consisting of some decorative curve shapes, which you could later stroke with color. You can
then save these subpaths under a single path name. To create a series of subpaths, simply end
one path before starting another. Make sure that the paths are not hidden when you do so;
otherwise, Photoshop will eliminate the previous path when you start another.

If working with the Pen tool feels awkward, difficult, and frustrating, don’t worry. Those are all
perfectly natural emotions to feel when you first use it. It took me months of grappling with it
before I could get to the point where I could use the tool without uttering several unmention-
able words. All I can say is keep practicing. Open up any images you have laying around on
your hard drive and select something. Before you know it, no image will be safe from the
prowess of your Pen.
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Figure 2-8

Working with the Paths Palette

Working hand in hand with the Pen tool is the Paths palette. You can think of it as a kind of
Command and Control Center for your paths. Although it isn’t mandatory, it’s a good idea to
open up your Paths palette, shown in Figure 2-9, before you create a path so that you can stay
apprised as to what is happening with your image. To open the palette, choose Windowr>Paths.

. | Pabhs [C]
Figure 2-9 hard hofl & bosk " Deock to Paletie Well

e New Path...
Duplicate Path...
Delete Path
Make Work Path..

- Oy
Make Selection
Fill Path..
Saved path Stroke Path...

Clipping Path,

Palette Options. ..

The icons at the bottom of the Paths palette from left to right, as shown in Figure 2-9, are

v Fill Path
v Stroke Path



Working with the Paths Palette

Load Path as Selection
Make Work Path from Selection

X Y X\

Create New Path
v Delete Current Path

The following sections highlight some of the stuff you can do with the Paths palette.

Creating a path

When you create a path, it automatically appears in the Paths palette as a work path.

Remember that a work path is temporary and unsaved, and you can have only one work
path in the Paths palette at a time.

If the work path is selected when you begin another path, your actions are added to the cur-
rent work path. But if the existing work path is hidden and you begin drawing another path,
that new work path replaces the existing one.

Creating a new path

You can save yourself a lot of grief if you make sure that your path is saved before you start. If
you select New Path from the Paths palette pop-up menu before you create the path, Photoshop
automatically saves the work path, and it becomes a saved path or named path. You can also

just click the Create New Path icon (the dog-eared page icon) at the bottom of the Paths palette.

Saving a work path

To save a work path, double-click the path in the Paths palette. Or choose Save Path from the
Paths palette pop-up menu (click the triangle in the upper right to open the menu). Then pro-
vide a name in the Save Path dialog box and click OK.

After you save your path, you can reload it at any time. Unlike layers, paths take up very little
storage space, so don’t hesitate to save them. Plus, you don’t want to go through all that work
again if you don’t have to. Unlike work paths, you can have as many saved paths as your heart
desires.

Deleting, duplicating, and renaming a path

To delete a path, drag the path to the trash can icon at the bottom of the palette. Or choose
Delete Path from the Paths palette pop-up menu.

You can duplicate a saved path by choosing the path in the Paths palette and selecting
Duplicate Path from the Paths palette pop-up menu.

@ You can also drag the saved path on top of the Create New Path icon at the bottom of the
palette.

To rename a path, double-click the path name in the Paths palette. Then enter the new name
directly within the palette.
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You can use the Stroke path command to paint a stroke along the path. You can choose which
painting or editing tool to use to stroke the path. Follow these steps:

1.

Select the path in the Paths palette.
Then choose Stroke Path from the
Paths palette pop-up menu.

Or press the Alt key (Option on the
Mac) and click the Stroke Path with the
brush icon (an outlined circle) at the
bottom of the palette. You can also
click the Stroke Path icon without the
Alt (Option on the Mac) key. Note that
this option bypasses the dialog box in
Step 2 and just strokes your path with
whatever setting was used previously.

In the dialog box that opens, choose
one of the 15 painting or editing tools
you want to use to apply color to the
stroke. Click OK.

ure 2-10

©)

Make sure that you verify your chosen
tool’s settings in the Options bar because
Photoshop uses those settings to stroke
your path. Photoshop will also apply your
current foreground color to the stroke.

If you're using a pressure-sensitive
drawing tablet, you can select the
Simulate Pressure check box to create
strokes with varying widths. If every-
thing has gone well, you should end up
with a stroked path (see Figure 2-10).

If you select one or more paths with

the Direct Selection tool, the Stroke Path
command changes to Stroke Subpath(s),
enabling you to stroke only the selected
paths.

Filling a path

You can fill the interior of a path with color by choosing the Fill Path command. Follow these

steps:



1.

Figure 2-11

Select the path in the Paths palette
and choose Fill Path from the Paths
palette pop-up menu.

A dialog box gives options for Contents,
Opacity, Blending, and Rendering. (For
more on the Contents and Opacity
options, see Book IV, Chapter 3.)

Or you can press the Alt key (Option
on the Mac) and click the Fill Path with
Foreground Color icon (a solid circle)
at the bottom of the palette. You can
also click the Fill icon without the Alt
(Option on the Mac) key. This option
bypasses the dialog box and just fills
your path with whatever setting was
used previously.

In the dialog box, leave the Blending
Mode option set to Normal.

It’s better to use the Layers palette to
apply your blend modes because you

©)

3.

Loading Paths as Selections

have more flexibility (see Book V for
more on layers). Here is the scoop on
the remaining options:

v The feathering option gradually
blurs the edges of the fill into the
background. Enter the feather
radius in pixels. The more pixels,
the greater the blur or feather.

v The anti-aliased option just slightly
softens the very edge of the fill so it
doesn’t appear as ragged.

If you select one or more paths with the
Direct Selection tool, the Fill Path com-
mand changes to Fill Subpath(s), enabling
you to fill only the selected paths.

After you set your options, click OK.

Your path should now be filled like
mine, as shown in Figure 2-11.
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Loading Paths as Selections

Creating a path is usually the means to an end — an accurate selection. Therefore, most likely,
you will frequently be using the Paths palette to load your path as a selection.

CONTINUED
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Follow these steps to get the lowdown on how to do just that. Open an image, make a selec-
tion by using the Pen tool, and get started.

1. Choose Make Selection from the Paths If you happen to have another selec-

Figure 2-12

palette pop-up menu.

Alternatively, you can also press Alt
(Option on the Mac) and click the Load
Path as a Selection icon in the Paths
palette. To bypass the Make Selection
dialog box, simply click the Load Path
as a Selection icon at the bottom of the
Paths palette.

In the Make Selection dialog box,
shown in Figure 2-12, you can

v Feather your selection by entering a
pixel value in the Feather Radius
box. (For more on feathering, see
Book III, Chapter 3.)

v Leave the feather radius at 0 for a
hard-edged selection.

1 Select the Anti-aliased option. This
option slightly softens the edge of
the selection so that it doesn’t
appear so jagged. (It’s my personal
recommendation.)

Make Selecuion

Rendering o

Feather Radius: 0 pixels F Caneel

! Anti-aliased

Dperation

@ New Selection

tion active when you load your current
path as a selection, you can choose to
add, subtract, or intersect with that
other selection.

After the path is made into a selection,
it acts like any other selection.

If you need a selection refresher, see
Book III, Chapter 1. If you want to save
your selection, jump ahead to Book VI,
Chapter 1.

Here’s one of my favorite shortcuts. To
quickly load the path as a selection, select
the path and then press Ctrl+Enter
(88+Return on the Mac). You can also
Ctrl+click (88+click on the Mac) on your
path name in the Paths palette to do the
same. Just be aware that you bypass the
dialog box and its options when you use
the shortcuts.




Making a Selection into a Path

Although you probably won’t use this option nearly as often as you use the option to turn
a path into a selection, the option is, indeed, available: You can create paths from existing
selections.

Using the Kinder Freeform Pen

Creating a path from a selection can come in handy if you need to save a path as a clipping
path (described in the last section of this chapter).

1. If you've been reading from the v The lower the value, the more sensi-
beginning of this chapter, you proba- tive it is, and the better it approxi-
bly have a selection on-screen ready mates your selection.
and raring to go. If you are just jump- 1+ Too low a value, such as 0.5, may
ing in, go ahead and select the create too many anchor points.
desired element in your image.

. . . 1+ Too high a value, such as 10, rounds
2. With the selection marquee active, out your path too much. Start with
select Make Work Path from the Paths the default setting of 2.0.
palette pop-up menu.
3. In the dialog box that appears, enter a You can always tweak the path later

Tolerance value.

You can also create a path from a selec-
tion by pressing Alt (Option on the Mac)
and clicking the Make Work Path from
Selection icon in the Paths palette. If you
just click the icon, you also make a path,
but you bypass the dialog box.

The Tolerance number controls how
sensitive Photoshop is to the nooks
and crannies in the selection marquee
when it creates the path:

Using the Kinder Freeform Pen

Confession: There is a more amicable incarnation of the Pen tool — the Freeform Pen tool.

(check out “Editing Paths” later in this
chapter).

If the path is still showing after you
load your selection marquee, simply
click in the gray area below the path
names in the Paths palette.

This action deselects the path and
leaves you with just the selection
marquee.

Select the work path in the Paths
palette and choose Save Path from
the Paths palette pop-up menu. Name
the path and click OK.

This tool is kind of a hybrid Lasso/Pen tool. Just drag around the element you want to select,
and the tool creates an outline that follows your cursor, exactly like the Lasso, as shown in
Figure 2-13.

After you release your mouse button, Photoshop provides the anchor points, lines, and
curves for that path, exactly like the Pen.

In my humble opinion, the Freeform Pen rates just an okay. The downside is that you are back
to having to have a really steady hand in order to get an accurate selection. The tool is proba-
bly one notch better than the Lasso tool because you do get a path that you can refine before
you load it as a selection. But I'd rather pay my dues and get skilled with the regular Pen.
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Here are some Freeform Pen tips:

v To create straight segments with the Freeform Pen, press Alt (Option on the Mac) while
the mouse button is pressed down and then click to create the anchor point.

v Pressing Alt (Option on the Mac) temporarily turns the Freeform Pen into the regular
Pen. When you want to return to drawing curves, release Alt (Option on the Mac),
keeping the mouse button pressed down.

Be careful: If you release Alt (Option on the Mac) while the mouse button is not pressed
down, Photoshop ends your path, and there’s nothing you can do about it.

The following sections give you the scoop on the options that go hand in hand with the
Freeform Pen tool.

Curve Fit

The Curve Fit option lets you adjust the amount of error Photoshop allows when trying to fit
your cursor movement to a path. You can enter a value from 0.5 to 10 pixels; the default set-
ting is 2 pixels.

At the default setting, Photoshop doesn’t register any movement of your cursor that is 2
pixels or less. Setting the value to 0.5 pixels makes the Freeform Pen very sensitive to your
movement and forces the tool to very closely follow the edge.

The disadvantage of this option is that using it also causes a lot of unnecessary anchor points.
Although a value of 10 pixels corrects this problem by making the option less sensitive, your
path may not be as accurate.



Creating Paths without the Pen

| recommend trying the Freeform Pen at each of these settings and then getting a feel for
the kind of path it makes.

Magnetic

When selected, the Magnetic option makes the Freeform Pen act much like the Magnetic Lasso
tool. Click anywhere on the edge of the element you want to select. Release your mouse
button and then move the cursor around the edge. The tool snaps to the edge of your ele-
ment, creating anchor points and segments. You can

»* Manually control the magnetism: If the Freeform Pen tool starts to veer off course, you
can manually force down an anchor point by clicking.

v Create straight segments: To create straight segments, again press Alt (Option on the
Mac) and click (you temporarily get the regular Pen). Alt+drag (Option+drag on the Mac)
to temporarily access the regular Freeform Pen. To return to the magnetic Freeform Pen
tool, release Alt (Option on the Mac), click again, and continue moving the cursor.

To close a path with the magnetic Freeform Pen, you must double-click.

Width, Contrast, Frequency, and Pen Pressure

The Width, Contrast, and Frequency settings are specifically for the Magnetic option and work
just like the Magnetic Lasso options. Width specifies how close to the edge (1-256) the tool
must be before it detects an edge. Contrast (1-100) specifies how much contrast there must
be between pixels for the tool to see the edge. And Frequency (5-40) specifies the rate at
which the tool lays down anchor points. For more details, see Book IIl, Chapter 1.

The Pen Pressure option is available only if you're using a pressure-sensitive drawing
tablet and allows you to adjust how sensitive the tool is based on how hard you press down
with the stylus.

Creating Paths without the Pen

[ want to let you in on a fun way to create paths. Yes, [ said fun. You have to assume by fun I
mean there is no Pen tool involved in the method.

You can grab any of the shape tools and create a work path. Before you do, however, be sure
to click the Paths icon in the Options bar. It’s the icon that looks like a pen cursor with a
square path around it. Drag the shape tool of choice on your canvas and presto, an instant
path. These shapes can come in handy for creating small spot illustrations, logos, and Web
buttons.

CONTINUED
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Follow these steps: 3. Using the Shape tool, drag a path in

your image window.
1. Open an existing image and select a

You can then use the Paths palette to
shape tool. p

P load the path as a selection. See

In the example shown in Figure 2-14, “Loading Paths as Selections,” earlier
[ used the Custom Shape tool. in this chapter.

2. Choose a shape from the shape preset 4. Choose Layer~>Newr>Layer via Copy.
library and open an image. . . .
You’ve just put the selection on its own
I chose a fish shape. layer.

Figure 2-14 I

—

Custom
Shape
tool

Path
created
with
Custom
Shape
tool

Selection
loaded
from
the path



Editing Paths

[ also applied a Bevel and Emboss and

5. If you want, add some type with the
Drop Shadow Layer Style to both the

Type tool.

. selection and the type. (For more on
If you want to give your type some type, see Book IV, Chapter 4.)
motion, click the Create Warped Text L
button in the Options bar. You can also 6. Delete the original image.
apply drop shadows, bevels, and other When I was done, the image in Figure
effects by choosing Layer=>Layer Style. 2-15 was what I ended up with — fun
I chose the Flag style warp in the Warp and very easy.

Text dialog box.

Figure 2-15
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Editing Paths

Often, it is easier and less time consuming to try to get a reasonably decent, but not perfect
path with the Pen tool. Then after you’ve got that, go back and edit your path for more accu-
racy. And while following the Eyeball-It-Then-Fix-It strategy is valuable any time in your
Photoshop career, it is especially true when you’re first learning to use the Pen tool.

Photoshop offers you a bevy of editing tools that can make your path repair a snap. These tools
even share the same flyout menu as the Pen tool. In addition, the arrow tools, which Adobe calls
the Path Selection and Direct Selection tools, are also extremely helpful when it comes to fine-
tuning your path. In fact, you may find, like I do, that the Direct Selection tool is one of your
favorite tools — so simple to use, yet so functional. Figure 2-16 shows both sets of tools.

CONTINUED
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To edit a path, follow these steps:

1.

If you can’t see the path you want to
edit, select the path in the Paths
palette.

This activates the path.

To see the individual anchor points so
that you can edit them, select the
Direct Selection tool (remember, it’s
the white arrow). Click anywhere
along the path.

You should now see the individual
anchor points and segments that
comprise the path. Most of the anchor
points, if not all, will be hollow because
they are unselected, as shown in
Figure 2-17.

If you need to move an anchor point,
click it with the Direct Selection tool.

When selected, the point becomes
solid, also shown in Figure 2-17. Drag
to move the anchor point. If you need
to, you can move a curved or straight
segment in the same fashion.

If you’re in need of some major repair
and need to move an entire path, use
the Path Selection tool (the black
arrow).

You can also select multiple paths by
pressing the Shift key while clicking
the paths.

If you move any part of the path beyond
the boundary of the image canvas, it is
still available — just not visible. Use the
Zoom tool to zoom out until you see the
hidden portion of the path.



Figure 2-17

Editing Paths

Selected anchor point

Manipulate the direction lines to
change the shape of the curve. First,
click the anchor point of the curve to
select it. Then click and drag the
direction point going the same direc-
tion as the bump.

By lengthening or shortening the direc-
tion line, you can control how steep or
flat the curve is. By rotating the direc-
tion line, you change the slope of the
curve, as shown in Figure 2-18.

v To add an anchor point in your path,
use the Add Anchor Point tool. Click
in the path where you need an anchor
point. This tool always adds a smooth
point, no matter where you click.

v To delete an anchor point, select the
Delete Anchor Point tool, position
the cursor over the anchor point
you no longer need, and click it. The
anchor point disappears while keep-
ing your path intact.

v To convert an anchor point from
smooth to corner or vice versa,
select the Convert Point tool.
Position your cursor on your desired
anchor point. If the anchor point is a
corner point, drag away from the

Unselected anchor point

anchor point to create the direction
lines that create a smooth point. If
the point is a smooth point, simply
click and release on the anchor point
to convert it into a corner point. To
convert a smooth point to a cusp
point, make sure the direction lines
are showing and then drag a direc-
tion line to break it into independent
direction lines. And finally, to con-
vert a cusp point back to a smooth
point, just drag out from the anchor
point.

v To copy a path, first select it with the
Path Selection tool. Then press Alt
(Option on the Mac) and drag away
from the path. As you drag, you will
carry a copied path with you, while
leaving the original path intact. Note
that you can drag a copied path onto
another image window as well as
within the same image.

v To delete a path, select the path
with the Path Selection tool and
press the Backspace key (Delete key
on the Mac). You can also select a
point on the path with the Direct
Selection tool and press Backspace
(Delete on the Mac) twice.

CONTINUED
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Figure 2-18

Using the Options Bar

Quite a few options appear in the Options bar when the Pen tools or Path Selection/Direct
Selection tools are active. Here is the scoop on those options:

‘/

7

The Auto Add/Delete option enables you to add or delete an anchor point with the reg-
ular Pen tool.

Show Bounding Box places a box around the path, allowing you to transform the
path. The bounding box isn’t a path or part of your image. It is merely a visual guide to
assist you in transformations. You can scale it by dragging the handles or rotate it by
dragging just outside the box. Press Ctrl (8 on the Mac) and drag a handle or side to
distort or skew the path. For more on transformations, see Book Ill, Chapter 3.

The path state buttons (add, subtract, intersect, and exclude) combine all visible paths
by adding, subtracting, intersecting, or excluding paths. Click your desired button to
direct Photoshop on how to control the overlapping portions of the path(s) when you
convert it to a selection. For example, clicking the Add button selects all areas whether
or not they overlap. Clicking Intersect selects only the overlapping areas.

The align and distribute buttons align two or more paths and distribute three or more
paths. The icons give you a good visual cue as to how the alignment or distribution will
appear.



Clipping Out the Unwanted

A clipping path hides areas that fall outside your path and displays the area inside your path.
For example, without a clipping path, if you were to import a silhouetted image into Microsoft
Word or an older page layout program or illustration program that doesn’t support trans-
parency and place it against a colored background, it would appear against a rectangular
white background, as shown in Figure 2-19. This occurs whether or not the background was
transparent in Photoshop. This is because the image must be flattened before it can be
imported and therefore loses any transparency. (For more on flattening, see Book V.)

Clipping Out the Unwanted

With the advent of more sophisticated page layout and illustration programs, such as the
latest versions of InDesign, PageMaker, QuarkXPress, and Illustrator, the need for clipping
paths has pretty much lost its urgency. That’s because these programs all support TIFFs
with transparency. (For more on working with Photoshop and other programs, see Book X,
Chapter 1.) But just in case you're using older or less sophisticated software and you need to

use a clipping path, here’s what you need to do:

Because an overabundance of complex clipping paths can cause printing problems, | recom-
mend using clipping paths as a last resort. Even if your illustration or page layout program
doesn’t support transparency, you can always composite your elements in Photoshop. For
more on layers and creating composites, see Book V.

Create your path by using the Pen tool.

A work path appears in the Paths
palette.

Save the path by choosing Save Path
from the Paths palette pop-up menu.

Enter a name and click OK.

Immediately return to the pop-up
menu on the Paths palette and choose
Clipping Path.

In the dialog box, choose the path
name from the Path drop-down list.

Leave the flatness value blank. If it is
blank, the default value of the output
device (printer, image setter and so
on) will be used. And usually the
default value is a good number for the
particular printer used.

Briefly, flatness represents how closely
your curves approximate a true mathe-
matical curve. A higher value causes

more of a polygon shape (albeit often
not noticeable by the eye), but results
in easier printing.

Choose File~>Save and choose a file
format from the Format drop-down
list.

I like the Photoshop EPS format,
personally.

Some programs, such as the latest ver-
sions of InDesign, PageMaker, and
QuarkXPress, will also accept TIFFs
with clipping paths. In addition, you
can save the file as a JPEG, PDF, DCS,
and in the native Photoshop format
from Windows. And the Mac will let
you save the file in any available format.
Because most of my page layout files
are ultimately offset printed, I stick
with EPS. EPS is the preferred file
format for color separations (see Book
X, Chapter 2) necessary for offset print
jobs.

CONTINUED
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6.

Figure 2-19

Set the Preview at TIFF (8 bits/pixel)
and encoding as ASCII (Macintosh [8
bits/pixel] and encoding as Binary on
the Mac) and click OK.

Your clipping path is now in place, and
you can import the silhouetted image
into the desired program.

Occasionally, when you import an
image with a clipping path into certain

page layout programs on the PC, the
screen preview may not display the
image correctly. The clipped, or hidden
portion, of the image may appear
opaque (solid white or black) on-
screen. But it should print okay on a
PostScript printer. You may not be so
lucky if you use a non-PostScript
printer.

Image
imported
with

clipping
path

Image
imported
without

clipping
path



Modifying and
Transforming
Selections and Paths

In This Chapter

v Adding and subtracting
from a selection

v Using the Select
commands

v~ Feathering selections

+ Moving and cloning a
selection

v~ Transforming selections
and paths

selection the first time around. I mean, all it takes is one too

many cups of coffee, and that Lasso tool seems to take on a
mind of its own. That’s okay. Photoshop is way too benevolent
to leave you hanging with a mediocre selection. A multitude of
techniques are available to modify and transform your selec-
tions. You can add or remove pixels from your selection, scale
your selection outline, smooth out jagged edges, or switch
what is selected for what isn’t. Knowing how to clean up and
modify your selections helps you to nail your desired element
with precision.

If you're like me, you may find it tough to get the perfect

If you haven’t already thumbed through the first two chapters
of Book IIl and gotten a good grasp of how to create selections
by using the mighty Photoshop Toolbox (more formally known
as the Tools palette), go ahead and browse those chapters now.

Achieving Selection Perfection

Although the selection tools, such as the Lasso and Magic Wand,
usually do a pretty fair job at capturing the bulk of your selec-
tion, making a really accurate selection often requires another
sort of tool — concentration. Give your selections a little extra
attention, and you’ll be amazed by the results. By adding and
subtracting from the outline here and there, you can refine a
selection and ensure that you capture only what you really
want — and nothing that you don’t.

The following few sections show you how to use keyboard
shortcuts, along with your mouse, to make perfect selections.
If you're not one for keyboard shortcuts, you can use the four
selection option buttons in the Options bar, shown in Figure 3-1,
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to create a new selection, add to a selection, subtract from a selection, or intersect one selec-
tion with another. All you need to do is grab the selection tool of your choice, click the selec-
tion option button you want, and drag (or click if you're using the Magic Wand or Polygon
Lasso tool).

from a selection, a small minus sign appears. When intersecting two selections, a small multi-

s When adding to a selection, a small plus sign appears next to your cursor. When subtracting
plication sign appears.

File Edit Image Layer Select Filter View Window Help
Flgure 3-1 i @ Pesen b Shyles Fiwedt Site v W A

J=J o Feighti A4 ge
-

New selection Intersect with selection

Subtract from selection

Add to selection

Adding to a selection

To add to a current selection, simply press the Shift key and drag around the pixels you want
to include with the regular Lasso or the Rectangular or Elliptical Marquee tool. You can also
press the Shift key and click the area you want with the Magic Wand tool.

To include an area with straight sides in your selection, you can press the Shift key and click
around the area with the Polygon Lasso tool. And although you may not have much need to
do it, you can also press the Shift key and click with the Single Column or Single Row Marquee
tool. I wouldn’t use the Magnetic Lasso tool to add to a selection; it’s way too cumbersome.

original selection. Feel free to use whatever selection tool you think will get the job done.

s You don't have to use the same tool to add to your selection that you used to create the
See Book Ill, Chapters 1 and 2 for details on selection tools and methods.

Here are the steps to use for adding to a circular selection:

1. Make your initial elliptical selection. Alt key (Option on the Mac) to draw
Select the larger circle with the from the center out.
Elliptical Marquee tool. Then press 3. Drag around the smaller selection

the Alt key (Option on the Mac) to with the Elliptical Marquee tool.
draw from the center out.
The resulting selection is shown in the

See the left image in Figure 3-2. example on the right in Figure 3-2.

2. To add the smaller circular area, first
press the Shift key and then press the



Achieving Selection Perfection

Figure 3-2

Original selection Selection after adding

Subtracting from a selection

Just as you can add to a selection marquee, you can also subtract, or deselect, from the selec-
tion. To subtract from a current selection, press the Alt key (Option on the Mac) and drag
around the pixels you want to subtract with the regular Lasso or the Rectangular or Elliptical
Marquee tool.

Press the Alt key (Option on the Mac) and click the area you want to remove with the Magic
Wand tool.

To subtract a straight-sided area, press the Alt key (Option on the Mac) and click around the
area with the Polygon Lasso tool.

You can press the Alt key (Option on the Mac) and click with the Single Column or Single Row
Marquee tool. The Single Column and Row Marquee tools come in handy when you want to
get rid of just the very edge of a selection.

In the top example of Figure 3-3, I first selected the frame with the Polygon Lasso tool. I didn’t
use the obvious tool of choice — the Rectangular Marquee tool — because the frame was not
completely straight. To deselect the inside of the frame from the selection, [ pressed the Alt
key (Option on the Mac) and clicked at each corner of the inside of the frame with the
Polygon Lasso tool, resulting in the selection shown in the bottom example of Figure 3-3.
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PTG -_-.nn.raw“

Figure 3-3

Original
selection

Selection after deleting - —— : T I

Intersecting two selections

What happens when you press the Shift and Alt (Option on the Mac) keys together? Not a col-
lision, but an intersection. Pressing both keys while dragging with a Lasso or Marquee tool or
clicking with the Magic Wand tool creates the intersection of the original selection with the
second selection.

To retain only the part of an image where two selections overlap, press Shift and Alt (or Shift
and Option on the Mac) and then drag.

You can select a portion of an image with a tool such as the Polygon Lasso tool. (In Figure 3-4,
[ selected the top-right portion of the framed photo.) Then press the Shift and Alt (Option on
the Mac) keys at the same time and drag with the Rectangular Marquee tool. (I selected the
lower-left portion of the image.) The resulting intersection of the two selections appears in
the bottom example of Figure 3-4.



Getting the Keys to Behave

Figure 3-4

Second selection

Intersected selection :

Getting the Keys to Behave

Photoshop has a little glitch in its way of doing things. Well, not so much of a glitch as a con-
flict. With so many ways of doing things with Photoshop, it’s no wonder that somewhere along
the line you have to jigger with Photoshop to get it to do what you want. For example, how
does Photoshop know whether you want to create a perfect square or add to a selection when

you press the Shift key?
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Let me lay this out for you:

v  When you make an initial selection with the Rectangular or Elliptical Marquee tool,

pressing the Shift key constrains the proportions of the selection, thereby allowing you
to create a perfect square or a perfect circle.

If you press Alt (Option on the Mac) with either of these tools, you can draw from the
center out.

If you press Alt (Option on the Mac) with the Lasso tool, the Lasso temporarily
becomes the Polygon Lasso tool.

Unfortunately, despite numerous requests, the ability to read users’ minds wasn’t a Version cs
upgrade feature. The following sections show you what you have to do to get Photoshop to
recognize your wishes.

Adding a perfectly square or circular selection

To add a perfectly square or round selection to an existing selection, follow these steps:

1.

Press Shift and drag with the Your unconstrained selection suddenly

Rectangular or Elliptical Marquee snaps into a constrained square or

tool. circle.

Your selection is unconstrained. 3. Release the mouse button before you
release the Shift key.

As you drag, keeping your mouse

button pressed down, release the If you don't release the mouse button

Shift key for just a moment, and then before you release the Shift key, the selec-

press it down again. tion shape will revert back to its uncon-

strained form.

Deleting from an existing selection while drawing from the center out

To delete part of a selection while drawing from the center out, follow these steps:

1

2.

Press Alt (Option on the Mac) and 3. Release the mouse button before you
drag with the Rectangular or Elliptical release the Alt (Option on the Mac)
Marquee tool. key.

As you drag, keeping your mouse See Figure 3-5.

button pressed down, release the Alt

(Option on the Mac) key for just a Use this technique when you're selecting
moment, and then press it down <@s a doughnut, tire, inflatable swim ring, and
again. other circular items with holes in the

middle.
You are now drawing from the center

outward.



Figure 3-5

Using the Select Menu

Although you can add, subtract, and intersect selections with the Shift and Alt (Option on the

Using the Select Menu

Mac) keys and the selection option buttons in the Options bar, you can do much more with

the commands found on the Select menu, shown in Figure 3-6. Here you’ll find ways to expand,
contract, smooth, fuzz, and turn your selection inside out. You can also use this menu to auto-
matically select similar colors and create selection borders. And I show you how to do this in

the next few sections. With this kind of knowledge, imperfect selections will soon be a thing of

the past.

Figure 3-6

Select

Al Ctil+A
Deselect Ctrl+D
Inverse ShiftsCtrl+1
Color Range...

Maodify

Grow
Similar

Feather...  Alt+Ctrl+D

Transform Selection

Border...
Smooth...

Expanil...
Contract...

Save Selection...

267

Book

m

Chapter

3



2 68 Book 111 » Chapter 3: Modifying and Transforming Selections and Paths

Deleting a straight-sided selection

If you have an existing selection, pressing Alt  the Mad and then select the Polygon Lasso tool.
(Option on the Mad) with the Lasso tool subtracts  But this can be tricky and is really unnecessary. |
from the selection. If you want to subtract a recommend just grabbing the Polygon Lasso tool
straight-sided selection from an existing selec- itself to delete your straight-sided selection. Ditto
tion, you can press Alt (Option on the Mad) and  for adding and getting intersections with straight-
begin to drag. Then quickly release Alt (Option on  sided selections.

Selecting All or Nothing

The Select All and Deselect commands are pretty self-explanatory. To select everything in
your image, choose Select=>All. To deselect everything, choose Selectr>Deselect. The key com-
mands Ctrl+A (88+A on the Mac) and Ctrl+D (88+D on the Mac), respectively, come in very
handy and are easy to remember.

In most cases, you don't have to select everything in your image. If you don’t have an active
selection marquee, Photoshop naturally assumes that whatever command you execute
should be applied to the entire image.

Reselecting a selection

If you have taken 20 minutes to carefully lasso a spiny sea anemone from its ocean home, the
last thing you want to have happen is to lose your coveted selection marquee. But that is
exactly what happens if you accidentally click on the canvas when you have an active selec-
tion tool in hand. The selection marquee disappears.

Sure, you can choose Edit=>Undo if you catch your mistake right away. And technically, you
could access the History palette to recover your selection (see Book II, Chapter 4, for more on
history). A much easier solution is to choose Select>Reselect. This command retrieves your
last selection.

Besides immediately bringing back a selection you accidentally deselected, the Reselect com-
mand can come in handy if you decide to select an element again for a second time. For exam-
ple, if you do such a great job retouching your spiny anemone that you decide to add, by
cloning, another anemone to your image, go ahead. It’s all up to you. By using the Reselect
command, you can easily load the selection again rather than start the selection from scratch.

The Reselect command only works for the last selection you made, so don’t go planning to
reselect a selection you made last week — or even ten minutes ago — if you've selected
something else in the meantime.

Swapping a selection

Sometimes it’s easier for you to select what you don’t want than it is to select what you do.
For example, if you're trying to select your pet dog, photographed against a neutral back-
ground, why spend valuable time meticulously selecting him with the Pen or Lasso tool, when



Selecting All or Nothing

you can just click the background with the Magic Wand tool? (Don’t forget to use the Shift key
to select bits of background you might have missed the first time.)

After you've selected the background, just choose Selectr>Inverse. Presto, you now have Fido
the Retriever selected and obediently awaiting your next command, as shown in Figure 3-7.

Figure 3-7

Feathering a selection

In Book Ill, Chapter 1, I described how to feather (blur the edges) a selection when using the
Lasso and Marquee tools by entering a value in the Feather box in the Options bar. This method
of feathering requires that you set your Feather radius before you create your selection.

Unfortunately, using this method, a problem arises if you want to modify the initial selection.
When you make a selection with a feather, the marquee outline of the selection adjusts to take
into account the amount of the feather. That means that the resulting marquee outline doesn’t
resemble your precise mouse movement. As a result, modifying, adding, or subtracting from
your original selection is pretty tough.

A much better way to feather a selection is to make your initial selection without a feather, as
shown in top image of Figure 3-8. Clean up your selection as you need to, and then apply your
feather by choosing Selectr>Feather. Enter a Feather Radius value and click OK. The resulting
selection appears in the bottom image of Figure 3-8.
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The radius is how far out in all directions the feather extends. A radius of 8 means the
feather extends 8 pixels to the right, left, up, and down from the selection outline. A large

feather radius makes the image appear to fade out.

Figure 3-8

Original
marquee

Marquee after

feathering
75 pixels

Using the Modify commands

The Select Modify menu contains a group of modification commands that are lumped categor-
ically. With the exception of the Contract command, you probably won’t use these options
every day. But when you do use them, you'll find that they prove useful. Here is the lowdown
on each command:

v Border: This command selects the area around the edge of the selection marquee. You
specify the width of the area, from 1 to 200 pixels, and you get a border marquee, like
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the one shown in the example on the left in Figure 3-9. Choose a foreground color,
choose Edit=Fill, pick Foreground Color from the Use drop-down list, and then click OK
to fill your border with color, as shown in the example on the right in Figure 3-9. By the
way, you can also achieve a similar look by using the Edit>Stroke command.

selection. On the other hand, the Stroke command, on the Edit menu, creates a hard-edged

s As you can see in Figure 3-9, the Border command creates an anti-aliased (or soft-edged)
selection.
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Figure 3-9

v Smooth: If your selection marquee seems a bit ragged around the edges, try selecting
the Smooth command to round off the nooks and crannies. Enter a sample radius value
from 1 to 100 pixels. Photoshop examines each selected pixel and then includes or de-
selects pixels in your selection based on the range specified by the radius amount. If
most of the pixels are selected, Photoshop includes the strays; if most of the pixels are
unselected, Photoshop removes the pixels. Start with 2 pixels and, if that doesn’t seem
like enough, increase it by a few more pixels or so.

Use this command with great caution and a steady hand. The results can be mushy, ill-
defined selections.

v Expand: This command allows you to increase the size of your selection by a specified
number of pixels, from 1 to 100. This can come in handy if you just missed the edge of a
circular selection and want to enlarge it, as shown in Figure 3-10.

v Contract: To shrink your selection by 1 to 100 pixels, choose Contract. I use this com-
mand a lot, in conjunction with the Feather command, when compositing multiple images.
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Figure 3-10

Expand Selection
e —

f Cand

This technique helps to create a nice, natural-looking transition between the various images
in your composite. The amount you decide to contract and feather varies according to the
resolution of your images. For example, if you're using low-resolution (72 dpi) images, you
may want to use 1 pixel for the Contract amount and 0.5 pixels for the Feather amount;
higher resolution images may warrant 2 to 3 pixels for the Contract amount and 1 to 2
pixels for the Feather amount. (For more on compositing images, see Book V on layers.)

@ After you make a selection, contract it and then feather it before you drag it onto the canvas.

Applying the Grow and Similar commands

The Grow and Similar commands are close cousins to the Magic Wand tool. (For more on the
Wand and Tolerance, check out Book IlI, Chapter 1.) If you're familiar with the modus operandi
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of the Magic Wand tool, you know that you rarely get the perfect selection on the first click.
That’s because you are making an intelligent guess as to what Tolerance setting will pick up
the pixels you want.

The Grow command compensates a little for the Magic Wand tool’s inaccuracy. For example, if
you need to include more in your selection, you can increase the Tolerance setting and try
again — press Shift and click the area you need to include. Or you can choose Select>Grow.
The Grow command increases the size of the selection by including adjacent pixels that fall
within the range of Tolerance.

The Similar command is like Grow, only the pixels don’t have to be adjacent to be selected. Book
The command searches throughout the image and picks up pixels within the Tolerance range, 7]

wherever they may fall. Chapter

the Magic Wand tool selected. Adjust the Tolerance setting, to include more or fewer colors
by increasing or decreasing the setting, respectively.

Both commands use the Tolerance value that is displayed in the Options bar when you have 3

Moving and Cloning Selections

When you have your selection refined to the ultimate in perfection, you may then want to
move it or clone it. To move a selection, simply grab the Move tool (the four-headed arrow) at
the top right of the Tool palette, and then drag the selection.

Sounds easy enough, right? When you move the selection, however, be warned that the area
where the selection used to reside is now filled with the background color, as shown in Figure
3-11. This is provided, of course, that you are moving both the selection outline and the image
pixels. You can move just the selection outline (without the pixels), as | explain in an upcom-
ing section. Also note that if you are moving a selection on a layer, you are left with transpar-
ent pixels. When you use the Move tool, your cursor icon changes to a pair of scissors, letting
you know that you are cutting out the selection.

Figure 3-11
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You can move and clone selections within a single
image or among multiple images. To move a
selection from one image to another, choose
Edit=>Cut, activate the second image, and choose
Edit>Paste. To clone a selection, simply drag the
selection with the Move tool from one image
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Drag ‘n’ drop ‘til you can’t stop

The original image stays intact. To clone a selec-
tion marquee, drag the marquee with any selec-
tion tool from one image window to another.

For more on dragging and dropping selections,
see the Putting-It-Together sections on creating

window and drop it onto another image window. a digital collage, which run throughout Book V.

Cloning

If the idea of leaving a big hole in your image doesn’t appeal to you, you can copy and move
the selection, leaving the original image intact. Just press Alt (Option on the Mac) and drag
with the Move tool. This action is often referred to as cloning because you’re essentially
making a duplicate of a selected area and then moving that duplicate elsewhere.

When cloning, your cursor icon changes to a double-headed arrow, notifying you that you are
duplicating the selection. If you want to move your selection in small increments (1 pixel),
press your arrow keys while you have the Move tool selected. Press Shift along with an arrow
key to move 10 pixels. And of course, adding the Alt (Option on the Mac) key to the key com-
mands allows you to clone a selection while you move it.

©)

Moving the selection outline, but not the pixels

You can temporarily access the Move tool by pressing the Ctrl (88 on the Mac) key when you
have any tool selected, except for the Hand tool, Pen tools, Slice tools, Path Selection tool,
Direct Selection tool, and Shape tools. Likewise, press Alt along with Ctrl with any of these
tools to clone and move a selection.

If all you want to do is move the selection marquee without moving the pixels underneath,
you want to avoid using the Move tool. Instead, grab any selection tool — the marquee tools,
the lasso tools, or the Magic Wand tool — and then click inside the marquee and just drag.
That way you move only the outline of the element, not the element itself. You can also use
the arrow keys to nudge a selection marquee.

Transforming Pixels

Although you may consider the distortions on the Transform menu somewhat mundane when
compared to the fun and flashy Liquify command (described in Book VII, Chapter 3), I'm sure
you’ll find them a lot more practical and useful in your daily digital-imaging chores.




Here’s how to transform a selection:

1.

2.

Create your selection.

I'll leave this task up to you; just use your
now well-honed selection expertise.

You can also apply transformations to a
layer or to multiple layers (for more on
this topic, see Book V).

Choose Edit~>Transform.

If all you want is a single transforma-
tion, this command is adequate.
However, if you want multiple transfor-
mations, you're wise to stick with the
Free Transform command, which |
cover later in this section.

Choose a transformation type from
the submenu, as shown in Figure 3-12:

1 Scale: Increases or decreases the
size of your selection

+ Rotate: Freely rotates your selection
in either direction

v Skew: Distorts your selection on a
given axis

 Distort: Distorts your selection with
no restrictions on an axis

1 Perspective: Applies a one-point
perspective to your selection

+ Rotate 180°, 90° CW (Clockwise), or
90° CCW (Counterclockwise):
Rotates the selection by specified
amounts

1+ Flip Horizontal or Vertical: Flips
your selection along the vertical and
horizontal axes, respectively

As soon as you select your desired
distortion and release the mouse
button, a box called the bounding box,
or transform box, surrounds your selec-
tion, complete with handles on the
sides and corners. Note that you don’t
get a bounding box with the Flip trans-
formation (which just gets applied to
your image).

4.

©)

5.

Transforming Pixels

Depending on which transformation
type you chose in Step 3, drag a
handle.

v Scale: Corner handles work best for
this transformation. Press Shift to
scale proportionately. Press Alt
(Option on the Mac) to scale from
the center.

+* Rotate: Move your cursor outside
the bounding box. When the cursor
becomes a curved arrow, drag CW
or CCW. Press Shift to rotate in 15-
degree increments.

v~ Skew: Drag a side handle.
v Distort: Drag a corner handle.
1 Perspective: Drag a corner handle.

Choosing Rotate 180°, 90° CW, or 90°
CCW or Flip Horizontal or Vertical will
just execute the command. Handle-
dragging isn’t necessary.

Photoshop executes all the transforma-
tions around a point called the reference
point. The reference point appears in
the center of the transform box by
default.

You can move the center point anywhere
you want, even outside the bounding box.
In addition, you can set your own refer-
ence point for the transformation by click-
ing a square on the reference point locator
in the Options bar. Each square corre-
sponds with a point on the bounding box.

You can choose a second transforma-
tion type from the Edit~>Transform
submenu, if desired.

If you're an ultraprecise type of person,
you can also numerically transform the
selection by entering values in the
Options bar, shown in Figure 3-13.

In Figure 3-14, all the transformations
were executed at the same time.

CONTINUED
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Figure 3-12

Figure 3-13
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Be sure to execute all your transforma- 6. After you have transformed your
tions in one fell swoop if possible. In other selection to your liking, do one of the
words, don't scale a selection now and following: Double-click inside the
then five minutes later rotate it and then bounding box; click the Commit
five minutes later distort it, because every button in the Options bar; or press
time you apply a transformation to an Enter (Return on the Mac).
|mlagzg, you are pLI'tttmg Itl tI;rough aln |:1tter- To cancel the transformation, press
p: a |'onlpr‘c;5§ss. nterpola ;on reca ciu ates Esc or click the Cancel button in the
t. e pixels. When you transform a selec- Options bar.
tion, Photoshop either adds or deletes
pixels. You want to try to limit how many Your image is now.maglcaflly traps-
times you interpolate an image because it formed. Note that if your image isn’t on
has a degrading effect — your image will a layer, you can leave a hole flllec_l with
start to appear soft and mushy. The only jche background color after your image
exception is flipping or rotating in 90- 1S tr.z:jns}igrmeid. Check out Book V to
degree increments. These commands are avoid this calamity.
interpolation free. For more on interpola-
tion, see Book Il, Chapter 1.
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Transforming Selection Marquees

Figure 3-14 - !

Bounding
box

Selection
marquee

@ To repeat a transformation, choose Edit=>Transformr>Again.

Transforming Selection Marquees

To transform just the selection marquee without affecting the underlying pixels, make your
desired selection and then choose Select~>Transform Selection. Photoshop doesn’t have a
submenu with individual transformations to choose from. Instead, you must apply the trans-
formations like you do with the Free Transform command: by using the keyboard shortcuts.
You can also enter values in the Options bar to transform numerically, or you can access the
context menu. To move the selection marquee and the bounding box, simply drag inside the
marquee or nudge it by using the keyboard arrow keys. Transforming selections is particu-
larly handy when you’re trying to select elliptical objects. It is often hard to get the selection
precise the first time around, as shown in Figure 3-15, so applying a transformation is often
necessary.

Select Filter  View Window Help |
Figure 3-15 | an CuleA
Deseluct Cule D

Inverse Shifts Crlel
Calor Range...

Feather.. Al CuleD
Modity

Grow
Similar

Save Selection,..
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Distorting selected pixels with Free Transform

The Transform menu isn’t the only way to distort
selected pixels. A much more efficient way is to
use the Free Transform command, also found on
the Edit menu.

Like the Transform command, the Free
Transform command surrounds your selection
with a bounding box. Within the bounding box,
you can scale, rotate, skew, distort, or apply per-
spective without having to choose the individual
distortions. You just have to use the right key-
board shortcuts. To scale and rotate, use the
same method as the Transform commands.
Here's the scoop on the rest:

v~ Skew: Ctrl+Shift+drag (88+Shift+drag on the
Mao on a side handle.

v Distort: Ctrl+drag (88+drag on the Mac) on
any handle.

1 Perspective: Ctrl+Shift+Alt+drag (88+Shift+
Option+drag on the Mao on a corner handle.

Unfortunately, if you want to apply a flip or rotate
by degree while free transforming, you need to
use the Transform submenu.

While the bounding box is surrounding your
selection, you can also access a context menu
that offers all the transform options. Right-click
(Control+click on the Mac on your canvas to
access this handy shortcut.

Transforming Paths

After the bounding box is around the path, the transformation technique for paths is the same
as it is for selections and selection marquees, except that you can apply the distort and per-

spective commands only to whole paths. The major difference between transforming paths
and selections is in how you first select the path.

All paths

To select all paths:

1. Choose Windowr>Paths.

2. Click the pathname in the Paths
palette.

Single path
To select a single path:

1. Choose Windowr>Paths.

3. Choose Edit~>Transform Path and

choose your desired transformation

from the submenu.

You can also choose Edit=>Free
Transform Path.

2. Click the pathname in the Paths
palette.




3. Choose the Path Selection tool.

4. Click the path with the Path Selection
tool.

5. Choose Edit~>Transform Path and
choose your desired transformation

Figure 3-16
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Transforming Paths

from the submenu, as shown in
Figure 3-16.

You can also choose Edit>Free
Transform Path.

Part of a path
To select part of a path:

1. Choose Windowr>Paths.

2. Click the pathname in the Paths
palette.

3. Choose the Direct Selection tool.

4. Select the points you want with the
Direct Selection tool.
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Removing a Person (Without Getting in Trouble with the Law)

Sometimes you may want to take an ele-
ment out of a picture so that you can main-
tain the viewer’s focus on something else.
Or maybe you just don’t want the element
in the image. But remember, if you simply
delete an unwanted element without
cloning, you leave a huge space (colored
with the background color) where the
element was. Not smooth.

In the following steps, [ show you how to
seamlessly remove an unwanted element
(in this case, a person) from an image.

©)

When you're first attempting this tech-
nique, | recommend that you start with
an image that has an element that isn't
physically attached to something that
you want to keep in the image. In this
example, | use an image of a father
and son at the beach. What I'm moving
out of the picture (the son) isn’t touch-
ing what I'm leaving in the picture (the
father). Although in this example I'm
removing a person, you can use the
same technique to remove other
objects as well: trees, dogs, an old
wagon, and what have you.

1.

Book 111 » Chapter 3: Modifying and Transforming Selections and Paths

Open an image that contains some-
thing that you want to remove.

Use the selection tool of your
choice to select the element that
you want to remove.

In this step, you're creating a selec-
tion marquee that you’ll use to clone
another area of the image. You’ll
then use the cloned portion —
which is shaped like what you're
removing — to cover up the element
you're removing.

You don’t have to be super-precise,
so feel free to grab the Lasso tool. If
you need a Lasso refresher, see
Book IIl, Chapter 1. (For more pre-
cise selecting, use the Pen tool,
explained in Book IIl, Chapter 2.)
When you make your selection, be
careful not to cut off any portion of
your element. Otherwise, you’ll
leave some stray pixels — a dead
giveaway that something was once
there. Using the Lasso tool, | made a
rough outline around the little boy.




Removing a Person (Without Getting in Trouble with the Law)

Position your cursor inside the
selection marquee, press the mouse
button and then the Shift key, and
drag your selection to move it hori-
zontally (or vertically if the image
warrants if) to an area of the photo
that you want to clone.

In the example, [ moved the selec-
tion to the right of the little boy:.
Notice how the selection marquee
is the only thing that [ moved. The
pixels were left untouched.

Area to be cloned

With the Move tool selected, posi-
tion your cursor inside the selec-
tion marquee, press Alt+Shift
(Option+Shift on the Mac), and
then drag to move the cloned area
on top of the element that you're
removing. Carefully match up the
edges, release your mouse button,

and then release the Alt and Shift
keys (Option and Shift on the Mac).

Choose Select->Deselect.

The cloned area should now cover
the element that you want to
remove. In the example, the
beach/ocean selection now covers
the little boy.

o

Cloned area covers boy

CONTINUED
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Depending on your image, you may
want to choose Select=>Feather and
enter 1 or 2 pixels before you move the
cloned area. Doing this softens the
edges and smoothes out the transition
between the cloned area and the back-
ground. (See the section, “Using the
Select Menu,” in this chapter for more
on feathering.) | didn’t feather my selec-
tion because it didn’t really need it. Try
it both ways to see which looks better.
Use the History palette to undo your
steps, if necessary (see Book Il, Chapter
4 for more on the History palette).

The final step is to clean up any tell-
tale signs that the element was
there.

Choose the Clone Stamp tool and
select a medium-size feathered

brush from the Brushes palette,
press Alt (Option on the Mac), and
click a good area next to a flaw;
release Alt (Option) and then click
the flaw.

If the Clone Stamp is a mystery to
you, be sure to check out Book VIII,
Chapter 3.

Repeat this step until you've fixed
all the flaws and the clone blends in
seamlessly with the background.
Don’t get carried away with the
Clone Stamp tool, or you'll end up
with a smudgy mess. Being light-
handed is a good thing, as [ was in
the now retouched image in the fol-
lowing figure. Nobody can tell that
only one man stands where two
people once stood.

.- 4
v'..
- "




Book IV

Painting, Drawing,
and Typing

The 5th Wave By Rich Tennant
@ Rl TENMANT _
SINCE INSTALLING PHOTOSHOP, |
THE 4th PRECINCT BECAME NOTED
FOR ITS CREATIVE WANTED ROSTERS
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“Ooo - look! Sgt. Rodriguer has the felons head
floating in a beacup!”







Exploring with the
Painting Tools

In This Chapter
v Making pencil sketches
v Applying brush strokes

v Managing brushes with the
Brushes palette

v Using Brush presets

ing techniques now that you don’t have to worry about

messing up your clothes. Painting is one of the basic
skills you need to work in Photoshop, along with selecting,
working with filters, and other key abilities. After you master
the art of painting strokes, working with brushes, and using the
many options Photoshop offers with its painting tools, you'll be
well on your way to Photoshop guru-hood.

You’re definitely going to want to brush up on your paint-

This chapter introduces you to a plethora of tools and tech-
niques; I also give you a guided tour of the Brushes palette.

Discovering the Brush Tool

I’'m going to be honest with you: If you can get the Brush tool to
work for you, you’ll be well on your way to Photoshop success.
That’s because so many of Photoshop’s tools require the use of
brushes.

The Brush tool, and its hard-edged version the Pencil, use
brush tips and painting strokes to apply color to your images.
But that’s just the beginning. Take a look at Table 1-1 to check
out the versatility of these other functions, which operate in a
way similar to the Brush, even if their results are completely
different.

You can see that there are a dozen different functions that you
can choose from and apply using the basic techniques dis-
cussed in this chapter.
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TaBLE 1-1: A SMATTERING OF BRUSHES AND THEIR FUNCTIONS

Function

Tool

See

Selection

Replacing color

Healing
and cloning

Erasing

Blurring,
sharpening,
smearing

Toning

Restoring

Stroking

In Quick Mask mode, you can use the Brush
(among other tools) to paint a selection with
fuzzy or hard edges, or even the sputtering
spray of the Airbrush.

The new Color Replacement tool lets you
replace the original color of your image with
the foreground color.

The Healing Brush and Clone Stamp let you

clone areas of the image by using brush strokes.

The Eraser tool and its variations, the
Background Eraser and Magic Eraser tools,
work like a brush in reverse, removing parts
of an image with brush strokes.

The Blur, Sharpen, and Smudge tools change
the contrast of your pixels or move them
around by using brush strokes.

The Dodge and Burn tools lighten and
darken pixels of your image under
brush-stroke control.

The History Brush tool selectively restores

portions of your image that have been changed.

The Art History Brush tool adds artistic brush
strokes to an image from a saved copy.

Book VI, Chapter 2

Book VIII, Chapter 2

Book VIII, Chapter 3

Book VI, Chapter 2

Book VIII, Chapter 2

Book VIII, Chapter 2

Book II, Chapter 4

Book II, Chapter 4

Introducing the Pencil and Brush Tools

The Pencil and Brush tools are like peanut butter and chocolate. Not only do they work well
together, but they also share many important traits. You can access these tools in the Tools
palette. Press B, and the Brush tool appears by default. To access the Pencil, press Shift+B.

You can toggle between the tools by pressing Shift+B again.

As you can imagine, the main difference between the tools is that one has a hard edge and the
other has a softer impact. The Pencil and the Brush tools do have some other differences.
Find out more in the following sections.

Finding out what the Pencil tool does

The Pencil and Brush tools are very much alike, except that the Pencil tool has hard edges by
default (as shown in Figure 1-1) and the Brush tool can have soft, feathered edges. The Pencil
tool also has the ability to erase itself!
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Figure 1-1
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You can do all the following with the Pencil tool:

v Drag the mouse to draw freehand lines.

v Click at one point, release the mouse button, and then Shift+click at a second point to
draw a straight line between the points.

As long as you keep the Shift key depressed, you can keep clicking to draw straight lines
between each of the points.

v Click, hold down the Shift key, and then drag up or down to draw a perfectly straight
vertical line. Drag left or right to draw a perfectly straight horizontal line instead.

v Hold down the Alt key (the Option key on the Mac) and click in any area of your draw-
ing to switch the foreground color to that hue.

v Choose the Auto Erase option in the Options bar to activate the Auto Erase feature.

Auto Erase is a handy feature that lets you remove portions of your pencil strokes without
switching to the Eraser tool.

When you have Auto Erase turned on, the operation of the Pencil tool is slightly different from
the default. The effect of either of the following actions is that Photoshop erases lines you've
drawn:

When you click in any area of the drawing other than an area that is foreground col-
ored (for example, the pencil lines you've already drawn), the Pencil tool begins
drawing a line in the foreground color (this is the default mode).

When you click in any area of the drawing that is foreground colored (such as the
pencil lines you’ve drawn), the Pencil tool draws by using the background color.
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Figure 1-2

Book IV + Chapter 1: Exploring with the Painting Tools

Because the Pencil tool doesn’t use soft-edged lines to draw, anything other than straight verti-
cal or horizontal lines has rough, jagged edges, as shown in the close-up image in Figure 1-2.
Jaggies aren’t objectionable in many cases, especially in higher resolution images, but if you
zoom in on an area containing pencil lines, the jaggies will be readily apparent. | show you
how to modify the characteristics of the lines drawn with the Pencil tool later in this chapter

in “Working with the Brushes Palette.”

R

e

Using the Pencil tool

If you're ready to start using the Pencil tool, keep in mind that lines that aren’t vertical or hori-
zontal will look jagged up close. To try out the Pencil tool, work your way through these steps:

1.

Activate the Pencil tool by choosing it
from the Tools palette. (It shares a fly-
out menu with the Brush tool.)

You can press Shift+B to make it
appear if it’s hidden underneath the
Brush tool.

The Pencil tool’s current brush tip
(usually the 1-pixel brush unless you
select something else) is shown in the
Brush Preset picker in the Options bar.

Click the arrow in the Brush box to
summon the Brush Preset picker palette
if you want to choose a different-sized
pencil tip.

2.

If you want to draw using anything
other than the Normal mode, choose
a mode from the Mode options menu.

Modes other than Normal cause colors
to interact and blend in different ways.
You can find more about modes in
Book V, Chapter 3.

Choose an opacity for your pencil
strokes.

If you want whatever is in the back-
ground to show partially through your
strokes, choose an opacity of less than
100 percent by using the slider or by
typing an opacity percentage directly
into the text box.
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You can set opacity percentage in also get increments of 1. For example,
@ 10-percent increments by pressing the type a 6 and another 6 quickly to get an

number keys while the Brush tool is opacity percentage of 66%.

active. The 1 key equals 10 percent, the

2 key equals 20 percent flow rate, and so 4. Click and drag with the mouse to

forth. Type two number keys quickly to create your pencil lines.

Painting with the Brush tool

The Brush tool is a basic tool used throughout Photoshop in various incarnations, so you’ll
want to master its use as quickly as possible.

The most important difference between the Brush and the Pencil tools is that, by default, the
Brush tool produces soft-edged lines that Photoshop renders smoother by a process known
as anti-aliasing. This is a technique that substitutes partially filled pixels along the edges of
lines to produce the illusion of gradual fading. Our eyes merge the transparent pixels together,
so the line looks smooth rather than hard-edged.

Although jaggy edges are most apparent in diagonal lines, Photoshop applies anti-aliasing to
brush stroke edges even in horizontal and vertical lines. The fuzzier the brush, the more semi-
filled pixels used to produce the effect, as you can see in Figure 1-3.

Figure 1-3

Soft-edged brush line
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The Brush tool shares most of the basic features found in the Pencil tool, except the Auto
Erase feature is not available:

7

\

Activate the Brush tool from the Tools palette or by pressing B (or Shift+B if you used
the Pencil tool last).

Choose a brush tip from the Brush Preset picker in the Options bar.
Select a Mode and Opacity from the options in the Options bar.

Drag to paint, click and Shift+click to paint straight lines, and hold down the Shift key
while dragging to constrain the Brush tool to horizontal or vertical lines.

Hold down the Alt key (the Option key on the Mac) and click in any area of color to
switch the foreground color to that color.

The Brush tool has several other options to select from:

‘/

‘/

Flow: Flow determines how quickly the Brush tool applies the paint. You can set a flow
rate from 1 to 100 percent by using the Flow slider or by typing a percentage directly
into the text box. You might think of it as controlling how wet or liquid the paint is. At
low flow rates, Photoshop applies the paint slowly so the color is not as dark; at higher
flow rates, the paint quickly reaches its full strength as you drag.

Airbrush: Click the Airbrush button in the Options bar to switch the Brush tool (as well
as many of the other tools that use brush tips) to Airbrush mode. This produces the
spray effect you get with a traditional airbrush. The longer you hold down the mouse
button, the more paint that pumps out of the tool, and the wider the airbrush effect will
spread, as shown in Figure 1-4.

Toggle Brushes Palette: At the far right of the Options bar is a button (a palette icon)
that shows or hides the Brushes palette. It’s a quick way to access this valuable palette,
and is also available with the Pencil tool and other tools that use brush tips. I show you
how to use the Brushes palette later in this chapter.

Working with the Brushes Palette

You'll find the Brushes palette extremely useful for changing the characteristics of preset
brush tips and for creating your own. You can also access and select brush presets, as |
discuss later in this chapter.

You can view the Brushes palette in several ways:

"

X Y\

Choose Window=>Brushes from the menu bar.
Click the Brushes palette tab in the Palette Well.
Click the Brushes palette button on the right side of the Options bar.

Grab the Brushes palette’s tab and drag it out of the Palette Well and onto your
Photoshop desktop. This mode keeps the Brushes palette visible until you put it away
by dragging it back to the Palette Well, clicking its close box, or rendering it hidden with
the Window=>Brushes command.



Figure 1-4

Working with the Brushes Palette
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The Brushes palette displays a list of brush properties on the left and includes a brush stroke
preview at the bottom of the palette.

The largest pane in the dialog box is the upper-right area that shows various types of informa-
tion, such as the size and type of brush tip, or the different controls offered for any of the 12
different properties you can set.

Click the Brush Presets label in the upper-left. The various preset previews appear in the right
panel.

Choosing a Brush Tip Shape

When you have Brush Tip Shape selected in the left column of the Brushes palette, a scrolling
box shows the available brush tips, as shown in Figure 1-5. You can use the palette pop-up
menu to choose various views, including text only, small and large thumbnails, small and large
lists, and stroke thumbnail. (To access the pop-up menu, click the triangle in the upper right
of the palette.)

The 12 brush parameters that you can choose to apply and edit are arrayed in the left column.
You can select any of these options to apply them to the currently selected brush.

Figure 1-5 |/ —
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Choosing a Brush Tip Shape

Select an option to edit its characteristics. Here are the characteristics:

I/

1

Brush Tip Shape: These controls let you choose the size and shape of the brush tip,
including the diameter, angle, roundness, hardness, and spacing.

Shape Dynamics: These controls include the amount of jitter (randomness or variation)
produced when you draw a stroke, amount of fade, the size, the jitter angle, the round-
ness, and other options. The higher the value, the greater the amount of variance for
each option. Some of these apply only when you are using a pressure-sensitive digital
tablet. Check your digital tablet’s instruction manual for more information on how to
customize brushes for your tablet. The Flip X and Flip Y jitter option flips the brush
shape across the horizontal axis (X) or the vertical axis (Y). For example, if your brush
shape is an L shape and you select Flip X, your brush shape will be backwards L. Check
Flip Y and your brush shape will an upside down L shape. Check both and it will be an
upside-down, backwards L shape.

Scattering: This parameter controls the amount and position of brush marks in a
stroke. The higher the value, the higher the number of brush marks and the farther
apart they are. When you have Both Axes selected, Photoshop distributes the brush
marks radially, as if on a curve. The Count controls the number of brush marks at each
spacing point. The higher the value, the greater the number of marks.

Texture: This control allows you to impart a texture pattern to a brush stroke, either
one of Photoshop’s preset textures or one of your design. Select Invert to reverse the
light and dark pixels in the pattern. Scale sizes the pattern in each stroke. Texture Each
Tip renders each tip as it is stroked, giving a more saturated effect. Depth controls how
prominent the pattern appears against the brush stroke. Minimum Depth specifies the
minimum depth that the paint of each stroke shows through the pattern. Mode lets you
choose one of Photoshop’s blending modes, as described in Book V, Chapter 3. You can
find more about creating and working with patterns in Book IIIl, Chapter 3.

Dual Brush: You can use two tips to draw with a single brush. This option lets you
select the characteristics of the second tip by using the same type of attributes — such
as diameter, spacing, and scatter — applied to the first tip. You can also specify a blend-
ing mode between the two tips.

Color Dynamics: This control uses your foreground and background colors to adjust
how the color varies during a stroke, allowing you to create a multicolored brush. Slight
variations give the stroke a more natural, organic look. You can introduce slight (or
major) jitter to the hue, saturation, brightness, and purity of the colors, as well as some
randomness between the foreground and background colors as you draw a stroke.
Without color dynamics, the stroke color remains constant.

Other Dynamics: These introduce randomness into the opacity and flow factors of a
brush, again making the brush stroke look more natural and less machine-generated.
You’ll want to experiment with all the dynamics to see exactly how they can affect your
image. Note that the Flow and Opacity settings in the Brushes palette do not override
those settings in the Options bar.
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Here’s a list of brush tip characteristics:

v Noise: Adds random pixels to brush tips, giving them texture and an organic quality.
This option is more apparent in feathered brushes.

v Wet Edges: Makes the brush tip leave a stroke that looks more like watercolor, with

paint building up along the edges.

v Airbrush: Gives the brush tip a soft, airbrushed look.

v Smoothing: Smoothes out the curves when drawing arcs with the brush. Again, this
option is more noticeable when you use a pressure-sensitive drawing tablet.

v Protect Texture: Ensures that all brush tips that use a texture use the same texture.
This allows you to switch back and forth between brush tips while painting and still

achieve a consistent texture.

You can now lock any of the brush characteristics by clicking the small lock icon to the right
of the characteristic. This ensures that the settings don’t change after you've gotten your
brush just so. This works especially well if you want the size of your brush to be correlated

with the amount of pressure you apply to a stylus when using a drawing tablet. By locking
settings, you override any specifications set by preset brushes. You can choose the Reset All
Locked Settings option from the Brushes palette pop-up menu to bring back the default set-
tings of the brush. And finally, to clear all brush options, select Clear Brush Controls from the

Brushes palette pop-up menu.

@PUTI‘ING IT TOGETHER

Colorizing Black-and-White Images

Just as there are valid artistic reasons for
shooting a photo in black and white, there
are equally reasonable rationales for
changing a grayscale image into a color
one. Perhaps the picture is an old one,
taken before color film was widely used,
and you’d like to colorize it. Or you may
come across a monochrome image that
would look even better in color. Photoshop
lets you restore black-and-white pictures to
their original colors or create whole new
color schemes. If you can imagine an image
in color, use Photoshop to add the hues
you want to see.

In my example, I chose a black-and-white
photo of a young girl. Instead of a full-color
treatment that attempts to duplicate a
color photograph, [ want to apply a
trendier transformation that adds a touch
of color to the hair, face, and clothing. This
approximates the hand-colored look of the
venerable Marshall’s Photo Coloring
System of pigments, photo oils, spot
colors, retouch pencils, and other products
so popular in the ’50s and '60s and enjoy-
ing a rebirth today. Although I've worked
with a Marshall’s kit myself, Photoshop is a
lot faster, easier, and more versatile.



Similar techniques will work for just about
any black-and-white image, animate or
inanimate.

n Open a grayscale image in
Photoshop.

2. Choose Image~>Mode~>RGB Color
to convert the grayscale image to a
full color image (even though it
presently still lacks any color).

3. Choose Layer->New Layer.

This creates a new transparent layer
to paint on. Although you can paint
directly on an image layer or a copy

Colorizing Black-and-White Images

of an image layer, using an empty
layer is safer and gives you more
flexibility in backtracking when you
make a mistake. For more informa-
tion on working with layers, consult
Book V.

The New Layer dialog box appears.
Name the layer.

Although you can paint all your
colors on a single layer, you’ll find
that using a separate layer for each
part of the face lets you fade that
color in and out as required to blend
smoothly with your other hues.

CONTINUED
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Select the Color mode from the

Modes drop-down list in the
Layers palette.

Photoshop uses this blending mode
to combine the painting layer with
the image layer underneath,
enabling you to apply color while
retaining all the tones and details of
the underlying grayscale image.

Select a color you want to apply
from the Swatches palette.

If you don’t find the exact color you
want, you can also use the Color
palette to mix your own. You’ll find
information on this tool in Book II,
Chapter 3.

Press B to activate the Brush tool.

You may have to press Shift+B to
cycle to the Brush tool if the Pencil
was used last.

Click the down arrow next to the
Brush Preset picker in the Options
bar and choose a brush from the
array.

Hard-edged brushes appear first and
the soft-edged brushes follow. You

& Dl Colorize
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might want to start with a 9- or 13-
pixel-wide soft-edged brush.

If you're already comfortable with the
Brush tool, you can choose the
Airbrush option in the Options bar to
get a very subtle and soft effect. Just
be sure you pick the kind of brush that
works best for the area of the picture
you're colorizing. (Use a small, fuzzy
brush for smaller areas, and use a
bigger, sharper brush for more stark
lines and wider areas.)

Paint over all the parts of the
image that contain that color.

If you make a mistake, you can erase
the bad strokes without affecting
the underlying grayscale image
because you're painting on a sepa-
rate transparent layer.

In my example, | chose a nice, light
blue color to change the color of the
girl’s eyes. A small fuzzy brush is per-
fect for a small area such as the eyes.

Change brushes as necessary by
clicking the Brush Preset picker in
the Options bar and choosing a
larger or smaller brush.
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10.

Creating Your Own Brush Preset

Although you can apply any of the options listed in the preceding section to existing brushes,

You can also make your brush larger or
smaller one size at a time by pressing
the [ and 1 keys (the left and right
bracket keys) on your keyboard.

When you’ve finished with that
area of the image, create a new
layer for each of the main compo-
nents of the photograph and repeat
Steps 4 through 8 with an addi-
tional color.

[ painted the eyes, lips, shirt, cheeks,
hair, and hair highlights separately
because creating natural, subtle
effects with people’s skin, hair, and
eyes takes a special touch:

v Eyes: When painting the eyes,
paint only the irises and leave the
pupils their original black color.
Don’t paint over the catchlights
in the eyes, either. (Catchlights
are reflections of light sources,
such as windows or the flash that
made the picture.)

v~ Lips: Color the inner surface of
the lips a darker, rosier pink than
the outer surface. Lips look best
when portrayed in at least two
shades. Don’t forget to color the
gums with an even lighter pink.

11.

Creating Your Own Brush Preset

v Hair: Hair looks best when the
highlights and darker portions
are slightly different colors.

v~ SKkin tone: For the overall skin
tone, I chose a different tech-
nique using the Hue/Saturation
command. See the Putting-It-
Together project, “A Fast Way to
Colorize Skin,” later in this chap-
ter. To put a little blush in the
cheeks, choose the Airbrush
option from the Options bar and
work with a relatively large brush
size. Apply a good dash of color
to each cheek, and a lighter bit of
color to the forehead and chin.
(I used a 100-pixel brush for this
picture.)

Be sure to pick a color that’s as close to
real life as possible. If the subject has
darker skin, you may need to move
away from rosier blush tones.

Be sure and check out Color Plate
4-2 to see the colorized image in full
living color.

When you’re finished coloring
your layers, you can experiment
with different opacity levels for
each colorized layer to see if more
transparent hues might look better.

you'll find these parameters most useful when creating your own brush.

To create a brush, follow these steps:

1. Click the Create New Brush icon at
the bottom of the Brushes palette, or
choose New Brush Preset from the

palette pop-up menu.

2.

Enter a name for the brush in the
dialog box that opens.
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With Brush Tip Shape selected, set the
shape and angle of your brush in the
Brushes palette, shown in Figure 1-6.

v Use the slider to set a diameter for
the brush, or enter a diameter in the
text box.

v Specify an angle for the brush. Enter
an angle in the text box, or drag the
handles in the preview window to
customize the brush angle.

v Adjust the roundness of the brush.
You can use the Roundness text box
to specify an exact ratio, or drag the
handles in the preview box to
custom-shape the brush.

Use the Hardness slider to adjust the
fuzziness of the brush, from 0 percent
(pretty fuzzy) to 100 percent (hard-

edged).

Use the Spacing slider to insert a gap
between strokes as you draw (produc-
ing a dotted-line effect).

At 1 percent, Photoshop draws a solid
line; as you move the slider to the
right, you insert more space between
short strokes, up to 1,000 percent
(10X) of the diameter of the brush tip.

You can activate/deactivate this fea-
ture by selecting the Spacing option
box.

Choose other brush characteristics
by selecting one or more of the
following:

v Shape Dynamics
v Scattering

v Texture

v Dual Brush

v Color Dynamics
v Other Dynamics

Figure 1-7 shows examples of these
options.

Finish up with some brush tip
options. There are no controls for
these parameters; you can toggle
them on or off:

» Noise

v Wet Edges
v Airbrush
v+ Smoothing

¥ Protect Texture




A Fast Way to Colorize Skin

Figure 1-7

Shape dynamics
fade control
used

Scattering

turned on

Paint with
texture

Dual brush tips

@PUTI’ING IT TOGETHER

A Fast Way to Colorize Skin

In the Putting-It-Together project earlier in
the chapter, you find out how to colorize a
black-and-white image by brushing color
onto the document. This project shows
you how you can get a more realistic skin
color by colorizing a person’s skin using
the Hue/Saturation command. This tech-
nique works especially well with those
who have naturally dark complexions.

Just follow these steps:

1. Create a copy of the underlying
black-and-white picture layer and
then choose Imager>Adjustments->
Hue/Saturation.

The Hue/Saturation dialog box
appears.

3.

Choose the Colorize option and
move the Hue slider all the way to
the left to produce a sepia tone. Set
Saturation to 25 percent and click
OK to colorize this layer.

Use the Eraser tool to remove
everything in the colorized layer
that isn’t skin.

In my example (see Color Plate 4-2),
[ removed the hair, background,
eyes, lips, teeth, and shirt.

This gives the entire face a nice
sepia tone.
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Saving a New Brush Tip

After you’'ve created your new brush tip, you can save it with the currently active brush pre-
sets by choosing Save Brushes from the Brushes palette pop-up menu (click the triangle in the
upper right to open the menu). For more information on saving, loading, appending, and
replacing libraries of presets, see the discussion of the Preset Manager in Book I, Chapter 6.

For some practice in using the brushes, try out the Putting-It-Together project that follows
and find out how to eliminate the dreaded red-eye effect.

Using the Preset Brushes

Photoshop has two brush palettes, in a sense. The Brush Preset picker, shown in Figure 1-8, is
tucked away in the Options bar and appears when you click the down-pointing triangle next to
the box that displays the currently active brush tip. I explain how to use the Brush Preset
picker in this section.

. h: |-
Figure 1-8 SR
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Photoshop has a large number of predesigned brush presets that you can use. The default set
includes six round, hard-edged brushes (which still have softer edges than the Pencil tool)
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and a group of 12 round soft-edged brushes. There are also airbrush, spatter, and natural
media brush tip presets, as well as a group of brush tip shapes such as stars, leaves, and
other shapes. And Photoshop cs has even more brush libraries, so go crazy.

A preset brush’s pixel diameters are shown as text below a thumbnail image of the brush
shape when the palette’s display is in default mode. (I show you how to change the default
display of the Brushes Preset picker shortly.)

To use one of these brush tips, just click the Brush Preset picker arrow in the Options bar and
choose the tip you want from the scrolling preset list. You can augment your choices with any
of the following options:

v Move the Master Diameter slider to change the diameter of the selected brush. This is a
quick way of getting a slightly larger or smaller brush when none of the presets meet
your needs exactly. For example, the largest hard-edged brush preset is 19 pixels in

diameter. You can click this brush tip and move the slider to the right to get a hard- BoH

edged brush in any size up to 2500 pixels. vV
To change the brush size from the keyboard when a tool is active, press the 1 key (the right Chapter
bracket) to increase the size and the [ key (the left bracket) to decrease the size. The amount 1
of change varies according to the initial size of the brush. To adjust the size more dramati-

cally, hold down the bracket key.
v Choose the Use Sample Size option to get brush strokes of equal size.

- This option is new to Photoshop cs. Depending on the size settings in your Shape Dynamics
&V? N:’W characteristics, when you use a scatter brush, such as a fish or flower, you will get random
> variations in sizes. Select the Use Sample Size option before you use the brush to get a con-
sistently sized stroke every time based on a preset sample size. Note that you must select
the option each time you use the brush and you must also click, not drag, the brush for each
individual stroke to be equally sized.

v Choose any of the library of additional brush tip presets provided with Photoshop.
Click the Brush Preset picker palette’s pop-up menu and choose one of the other brush
libraries shown at the bottom. They have names like Special Effect Brushes,
Calligraphic Brushes, and Faux Finish Brushes. Select one to append the brushes to
your current set or to replace the current set with the library you select (a dialog box
appears that offers a choice of either action).

You can also manage brush tip libraries by using the Preset Manager. See Book I, Chapter 6,
for information on using the Preset Manager.

v Select your own custom library of brush tips that you've created. Click Load Brushes to
append new brushes to your current collection or to replace them with the new library.

;_? Another option that may be available is the Hardness slider. If available, adjust this slider to
cvf "‘;W make the brush more (higher) or less (lower) fuzzy.

In the next section, I show you how to manage and edit brush presets.
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Managing Preset Brushes

You can change the way brushes are shown in the Brushes Preset picker and Brushes palette
by choosing a viewing mode from the picker’s or palette’s pop-up menu:

v Text Only: This displays the names of the brush tips in several columns (depending on
how wide you’'ve made the pop-up palette), as shown in Figure 1-9.

Flg“re 1.9 Masher Diarneter 12 pe 3
al
Hardness: 0%
Hard Round 1 pixel i

Hard Round 3 pixels
Hard Round & pixels
Hard Round 9 pixels
Hard Round 13 pixels
Hard Round 19 pixels
Soft Round & pixels
Soft Round 9 pixels
Soft Round 12 pixels
Soft Round 17 pixels
Soft Round 21 pixels
Soft Round 27 pixels
Soft Round 25 pixels
Soft Round 45 pixels
Soft Round E5 pixels
Soft Round 100 pixels

Soft Round 200 pixels

\

Small Thumbnail: This is the default view, with a thumbnail image of the brush tip and
its diameter in pixels.

Large Thumbnail: This view provides a closer look at the brush tip, as shown Figure 1-10.
Small list: This view shows a single-column list of the brush tips with their text names.

Large list: The larger list adds thumbnails so you can see the brush shape.

A W W W

Stroke thumbnail: This view shows a typical ess stroke by using the selected brush so
you can see how it looks when applied, as shown in Figure 1-11.
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Figure 1-11
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@PUTTING IT TOGETHER

Getting the Red Out Without Eyedrops

Red eye occurs when the subject of a pic- v Many cameras have a red-eye
ture looks directly into the flash, and the prevention mode. Usually, this
unfortunate result is that eerie reddish mode triggers a quick, bright pre-
luminescence in the eyes that says, “Not flash just before taking the actual
only didn’t I get any sleep last night, but picture. The preflash causes the
I'm also auditioning for the remake of subjects’ irises to contract,
Michael Jackson’s Thriller video.” Color making their pupils smaller when
Plate 4-1 shows an example of red eye. the second flash (that is, the real

flash) goes off.
The flash bouncing off the blood vessels in

the retina and right back into the camera’s ¥ Some cameras mount the flash
lens causes the red-eye effect. You'll see high or to one side of the lens.
red eye most often in pictures taken in dim This simple trick also minimizes
light because the pupils are at their largest the chance of red eye.

in low-light conditions. You may also see However, these preventive measures are of
red eye if you're using a camera with a little solace when you’ve got a great pic-
flash that’s very close to the camera’s lens  ture that features bright red pupils as its
(thereby making it easier for the light to most dominating feature.

bounce straight back into the lens). The

best way to fix red eye is to avoid it com- Here’s a quick way to paint out red eye and

pletely. That usually means getting a flash restore your image to a less zombielike look:
camera that can work around it:

n Open the original photo with red
eye showing.




Select the pupil of one of the eyes.
I recommend using the Elliptical
Marquee tool.

Press Alt (Option on the Mac) to
draw your ellipse from the center
out. If your selection doesn’t quite
match the shape of the pupil, don’t
sweat it. You can fix that in the next
step.

Getting the Red Out Without Eyedrops 3 05

Choose Select=>Transform

Selection.

The transform box appears around
your selection. To adjust the selec-
tion marquee, drag the handles on
the transform box to either rotate or
scale the marquee. For more on
transformations, see Book III,
Chapter 3.
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4. Press Enter (Return on the Mac) to
accept the transformation.

5. Choose Select Feather and type 0.5
in the dialog box.

This will soften the edge of the
selection, creating a more natural
transition.

6. PressD to get the default colors.

VW CONTINUED
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7.

Choose a fuzzy-edged brush from
the Brushes palette.

The size isn’t really important.
Because you have a selection mar-
quee, your brush strokes will not
spill outside the marquee boundary.

Select Color from the Mode drop-
down list in the Options bar.

The Color mode enables you to
apply color while allowing the tones
and textures of the image to show
through.

Note that you can also use the new
Color Replacement tool to fix red eye.
Set the mode to Hue or Color and
follow step 9. For more on the Color
Replacement tool, see Book VI,
Chapter 3.

Book 1V * Chapter 1: Exploring with the Painting Tools

n Paint inside the selection.

Only the pupil of the eye is selected,
so you can paint without fear of
covering up any other parts of the
eye. If you want to hide the selection
marquee, choose Viewr>Showr>
Selection Edges.

Because grayscale figures don’t do
this technique any justice, check out
Color Plate 4-1 to see color exam-
ples of getting rid of red eye.

You may notice one or two catchlights
(reflections of light sources such as
windows or the flash that made the
picture) on the eye, which is unnatural.
Of course, having no catchlight at all is
even more unnatural! You can cover
the extraneous smaller catchlight in
each pupil if you want, but try not to
obscure the main catchlight.




Creating Vector

Shapes

In This Chapter
+ Understanding vectors
v Applying basic shapes

v~ Setting the geometry
options

v~ Creating your own
customized shapes

your drawing and painting capabilities. Whereas many of

the tools in the Tools palette are pixel oriented, creating
shapes and outlines from swarms of pixels, the Shape tool, like
the Pen and Type tools, initially creates scalable outlines by
using vectors rather than pixels.

Photoshop’s shape tools add an important dimension to

Working with vector shapes gives you the freedom to resize
your objects at will, and convert them to pixels only when you
need to merge them with the rest of your image. This chapter
focuses on how you can create, resize, modify, and manipulate
vector shapes with the Shape tool.

Pivel and Vector Basics

Vectors describe a shape mathematically; pixel images, on
the other hand, describe the same shape in terms of a map of
pixels. Figure 2-1 shows both types of images. An easy way of
understanding this concept is to imagine how each of these
graphical measurements measures a square:

v Measured in pixels: A square might be 200 pixels on a
side with the corners at particular X and Y coordinates in
the image file. The square contains a total of 40,000 differ-
ent pixels, each of which must be created and stored
with the image file.

v Measured in vectors: The same square might be simply
defined as four points with equal-length lines connecting
each of them at right angles. The scale of the square
determines the length of the lines. It isn’t necessary to
store information about the area inside the square; the
vector image file needs to contain only the position of
the four points and the fact that they are each connected
by lines at a 90-degree angle.
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You can see that to enlarge a square created by vectors, all you need to do is increase the dis-
tance between the points. To enlarge a pixel square, you need to create a lot more pixels. The
difference between the ways these measurements handle shapes becomes magnified (so to
speak) if the shape’s outlines aren’t perfectly straight or if points don’t connect at neat right
angles.

object takes on a jaggy appearance in lines that aren’t horizontal or vertical. To enlarge a
vector object, on the other hand, you only need to rearrange the points that define the lines
or curves; the lines and curves themselves don’t grow and become jaggy.

Resizing any sort of object made of pixels causes a problem: As you enlarge the pixels, the




Making Basic Shapes

Making Basic Shapes

When we create vector objects in a program like Photoshop, they are comprised of paths,
which are in turn made up of anchor points and straight and curves segments, or lines. You
can make these paths with the Pen tool (described in Book Ill, Chapter 3) or with the Shape
tool. The Shape tool can create five different kinds of basic shapes. Photoshop also has a
custom shape tool that lets you use preset shapes or create shapes of your own design. To
access the Shape tool, press U on your keyboard to select the currently active shape, or press
Shift+U to cycle through the available shapes. You can see the Shape tools in the Tools palette
in Figure 2-2, and in the Options bar in Figure 2-3.

Simply press U once and then choose the shape you want from the icons that appear on the
Options bar. These include rectangle, rounded rectangle, ellipse, polygon, and line tools.

. |:] Rectangle Tool u
Flgure 2-2 || Rounded Rectangle Taol u
" () Ellipse Tonl u
O Palygon Tool u
™, Lina Taol U
('4\? Custonn Shape Tool u
. | |- pgao| § F@eod N 2 Sl B e o 3 ]
Figure 2-3 : - T T E——

any of these tools are active. You can switch back and forth between Shape and Pen tools by
clicking the appropriate icon in the Options bar. You can find out more about the Pen tool in
Book Ill, Chapter 2.

@ The Options bar shows icons for the Pen tool, Freeform Pen tool, and Shape tool whenever

Choosing a preset shape to create

When you create a shape, you can place the shape on its own layer, which is called a shape
layer. The advantage of a shape layer is that, as with any layer, you can keep the elements
residing in that layer separate from the rest of the image. You can put several shapes in a
single shape layer, and you can control how the shapes interact with each other when they
overlap. (Some options include making the shapes appear to have been added together, sub-
tracted from, and so on.) Photoshop links shapes in a shape layer to a vector mask, which can
show or hide portions of an image. You find out more about shape layers and vector masks
later in this chapter. Here’s a list of shapes you can create:

v Rectangle/ellipse: The rectangle and ellipse have no special parameters on the Options
bar; however, they both behave much like their counterparts among the selection tools.
For example, you can hold down the Shift key while dragging a shape to produce a per-
fect square or circle; hold down the Shift key plus the Alt key (Option key on the Mac)
to draw the shape outward from the center. You have other geometry options that let
you determine how you draw the shapes (unconstrained, fixed size, from center, and so
forth). I give you a quick rundown of your geometry options later in this chapter.
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v+ Rounded rectangle: This shape has the same options as the rectangle shape, with the
addition of a box in which you can type the radius of the circle used to round off the
corners of the rectangle.

v Polygon: This shape includes a box in which you can enter the number of sides you’d
like for the polygon, in the range of 3 to 100, as well as geometry options.

v Line: You can give the line shape a width from 1 to 1000 pixels and assign a layer style
and/or fill color. You can also enter parameters for an arrowhead at either or both ends.
[ explain that option in more detail later.

v Custom: You'll find numerous preset custom shapes to choose from. As with any shape,
you hold down Shift to constrain proportions or Alt (Option on the Mac) to draw from
the center out. See the section on geometry options later in this chapter.

Choosing a shape mode

Here’s a list of ways in which you can create a shape (all options are found on the Options
bar):

v Shape Layers: Click this icon to create the shape in a new layer of its own. When you
choose this mode, icons appear in the Options bar that let you choose a layer style
and/or fill color.

manipulate them further. The shapes remain scalable until you change them into pixels by

@ Shape Layers is a good choice if you want to keep your shapes in separate layers so you can
choosing Layer—>Rasterizer>Shape.

v~ Path: Click this icon to create the shape on an existing layer. The shape appears as a
path that you can edit by using the Pen tools and the Paths palette. For everything you
need to know about paths, check out Book III, Chapter 2.

v~ Fill Pixels: Click this icon to create a shaped area filled with the foreground color.
This option doesn’t produce a vector shape, but instead fills the shape with pixels.
The process is similar to filling a selection created with the Rectangular or Elliptical
Marquee or painting on your canvas with a painting tool. When you choose this mode,
the Options bar includes choices that let you specify a blending mode, the transparency
of the filled area, and whether you want the area anti-aliased. You cannot edit the shape
created with this option.

Drawing a preset shape

Follow these steps to draw a preset shape in your document:

1. Access the Shape tool by pressing U. See the preceding section, “Choosing a
shape mode.”
2. Choose the mode of shape you want . .
to draw from the three icons in the 3. Select your options — both in the
Options bar. Options bar (if any) and in the geome-

try options drop-down palette, which
also resides on the Options bar.
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The Options bar changes to reflect The shape appears in the image

each type of shape; each type has its window. If you chose the Shape Layer
own options, which are listed in mode, it will also appear in the Layers
“Choosing a preset shape to create,” palette in its own layer. A generic
earlier in this chapter. For explanations shape icon (a rectangle filled with your
on the various geometry options, see foreground color) appears in the image
“Setting Geometry Options.” column, and the shape itself is shown

in the mask column as a vector mask,

4., Drag with the mouse in the document as you can see in Figure 2-4.

to produce the shape you’ve defined.

Figure 2-4
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Drawing multiple shapes in a shapes layer

After you've created a shape layer, you can draw additional shapes in the layer, adding to the
vector mask associated with that layer. You can add, subtract, overlap, and intersect shapes
in exactly the same way you do with selections, as described in Book III, Chapter 3.

You can combine and join two or more shapes, subtract one shape’s outline from another
shape, create a shape only from the areas that overlap, and so on.

Four state buttons on the Options bar, similar to their counterparts when a selection tool is
active, let you choose from these modes. You can see these buttons in Figure 2-5.

shape. Hold down the Alt key (Option on the Mac) to temporarily switch to Subtract from

@ Hold down the Shift key to temporarily switch to Add to Shape Area while drawing a new
Shape Area. This works just like adding or subtracting selections.
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QD P g
Exclude Overlapping
Shape Layers
Create New Intersect
Shape Layer Shape Areas
Add to Subtract from
Shape Layer Shape Area

Setting Geometry Options

Geometry options for your shapes (rectangle/rounded rectangle, ellipse, polygon, and line)
help define how the shapes look. The following sections show you what you can do with these
options.

Figure 2-5

Rectangular shape geometry options

Here are the Geometry options for the rectangle shapes, as shown in Figure 2-6:
v Unconstrained: When you have this option (the default) selected, Photoshop defines
the size and proportions of the rectangle as you drag.

v Square: Select this button to constrain the shape to a perfect square. (You can also
hold down the Shift key to do the same thing on the fly.)

v~ Fixed Size: This option lets you draw rectangles only in fixed sizes. Type in a width and
height to specify the exact size.

v Proportional: This option lets you define an aspect ratio, or proportion, for the rectan-
gle. Type 3 into the W box, and 4 into the H box, and you’ll be constrained to drawing
any size rectangle with fixed proportions in a 3:4 ratio.

v From Center: Select this option to expand the shape from the center point you click.

v~ Snap to Pixels: This option aligns the shape to the pixels on your screen.

Rectangle Options
(:'. Unconstrained

Figure 2-6
e Square

C FiedSize  we [ [
e Froportional i/ I— H: I—

[~ From Center u Snap to Pixels
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Elliptical shape geometry options

The ellipse shape has the same options that are available for rectangles (as shown in Figure 2-7):

p
o
P
v
p

Unconstrained
Circle

Fixed Size
Proportional

From Center

Of course, instead of being able to create a perfect square, you can restrain the shape to be a
perfect circle. Also, the Snap to Pixels option (available for rectangles) doesn'’t exist for ellipses.

Figure 2-7

Ellipse Options
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Polygon shape geometry options

These are the geometry options for the polygon shape, as shown in Figure 2-8:

)

\

\

Figure 2-8 Radius: I;_vg_

Radius: You can enter the radius of a circle used to round off the corners of a polygon
when you have the Smooth Corners option selected.

Smooth Corners: Choose this option to round off the corners.

Star: Select this option to create a star shape — that is, a polygon where the sides
indent inward rather than extend outward from the corner points.

Indent Sides By: The value entered here determines the amount the sides indent inward.

Smooth Indents: This option rounds off the inner corners created by indenting the sides.

Polygon Options

F Srnooth Corners
F Star

Indent Sides By: ISD%

[~ Sraaoth Indents
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You can see the difference between an indented five-sided polygon (a star) at right in Figure
2-9, and an outdented five-sided polygon, at left.

Figure 2-9

Line geometry options

The line’s geometry settings, shown in Figure 2-10, include whether to put arrowheads at the
start or end of the line, or both; the width and length of the arrowhead in relation to the
weight (width) of the line itself; and the amount of concavity in the arrowhead. Figure 2-11
shows the typical arrowhead shapes. The arrowheads in the figure are as follows, from top to
bottom:

1V

X Y X\

. Arrowheads
Figure 2-10 [ start v End

4-pixel line, width 500%, length 1000%

4-pixel line, width 300%, length 600%

4-pixel line, width 600%, length 1200%, concavity 50%
4-pixel line, width 600%, length 1200%, concavity -50%

Width: SO0
Length: IIDDD%
Concavity: ID%
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Figure 2-11 —_—
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Creating Custom Shapes

With the Custom Shape tool, you can choose from an extensive array of preset custom
shapes, which Photoshop provides, as well as shapes that you can define yourself.

Using preset custom shapes

Photoshop’s preset custom shapes probably look familiar to you if you've been reading the
earlier sections in this chapter (in particular, “Choosing a preset shape to create”). But there
are a couple of additions:

v Defined Proportions: When you use this option, Photoshop limits any shapes created
using this new custom shape to the proportions you use when you create it now. That is,
you can change the size of a new shape but only in proportion with the original custom
shape you create.

v Defined Size: When you use this option, Photoshop limits any shapes generated based
on this new custom shape to the size you set now.

Choosing a preset custom shape couldn’t be easier:

1. Choose the Custom Shape tool from You can choose Defined Proportions

other preset shapes Photoshop offers.
2. Choose the Shape Layers, Paths, or .
Fill Pixels option found in the Options 6. Drag in your document to draw the

bar. shape.
3. Click the drop-down shapes palette You can load many more custom
triangle in the Options bar. shapes, like those shown in Figure

2-13, into the Shapes palette by choos-
ing a shape library (such as Animals or
Music) from the palette pop-up menu,
also shown in Figure 2-13.

4. Select a shape from the scrolling list
and press Enter (Return on the Mac)
to close the palette.

Choose from the available Custom
Shape Options in the Options bar
(shown in Figure 2-12). CONTINUED
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Figure 2_12 Custom Shape Opl'ions
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Creating your own custom shape

You can create your own custom shape by defining the shape using a vector mask, work path,
or saved path. You can find out more about creating work paths and saved paths in Book III,
Chapter 2. To create a shape and add it to your shape library, follow these steps:

1. Choose the Pen tool from the Tools Photoshop automatically places the

palette, or press Shift+P until the Pen shape you create in its own shape layer
tool is selected. as a vector mask. Find out more about

what you can do with a vector mask in

2. Use the Pen to draw the shape you the following section, “Using vector
want to create. masks.”
Book III, Chapter 2, describes the tech- 3. In the Paths palette, select the path or
niques for adding, removing, and adjust- vector mask you want to convert into

ing the shapes of curves with the Pen. a custom shape.
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4. Choose Edit=>Define Custom Shape 6. Choose Save Shapes from the palette’s
from the menu bar. pop-up menu to store your new

The Shape Name dialog box appears, library on your hard drive.

as shown in Figure 2-14. @ Although you can't create a shape with
5. Enter a descriptive name for your the Presets Manager, you can use it

new shape in the dialog box and then to manage the shapes in your shape
click OK. library.

The new shape appears in the custom
shapes pop-up palette in the Options bar.

) Shape Name &)
Figure 2-14
' Narme:  Sauared Hetl — Book
L Cancm | IV
Chapter
2

Using vector masks

When you create a shape in Shape layer mode, Photoshop automatically saves the shape as a
vector mask. Essentially, a shape layer has two components. First, Photoshop entirely fills the
layer with color. Then, Photoshop places the shape, which (again) is comprised of a path, on
top. The thumbnails in the Layers palette visually display this concept. The color peeks
through the outline of the shape, and Photoshop hides (or masks) the rest of the layer. So in
other words, vector masks clip away the color of a shape layer. If you delete a vector mask,
you are left with just a layer of solid color.

You can edit a shape that Photoshop has saved as a vector mask at any time. Simply click the
vector mask thumbnail to select it. Then use the shape and pen tools to edit the shape.

Here are some additional things you can do with a vector mask:

v To remove a vector mask, drag its thumbnail in the Layers palette to the trash can icon
at the bottom of the palette. You can also select the layer and choose Layer=>Delete
Vector.

v To enable or disable a vector mask, Shift+click its thumbnail in the Layers palette, or
select the layer and choose Layer=Disable (or Enable) Vector Mask. Photoshop marks
the thumbnails of disabled vector masks with an X.

v You can convert a vector mask to a layer mask by selecting the layer and choosing
Layer=>Rasterizer>Vector Mask.
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Manipulating Shapes

You can manipulate shapes you’'ve created by using a variety of tools. Here’s a quick list of the
things you can do:

v Move: Choose the Move tool (press V) to move shapes in their layer.

v Delete: Select a shape and press Delete to remove it.

v Adjust anchor points: Use the Direct Selection tool to manipulate anchor points, direc-
tional handles, lines, and curves.

v Transform shapes: Use the Edit~>Transform Path command or select the Show
Bounding Box option in the Options bar to transform shapes. For more information, see
Book III, Chapter 3.

v~ Align and distribute shapes: Use active buttons in the Options bar when you have the
Move tool selected to change alignment and distribution along an imaginary line
(shown on the button).

v Clone a shape: Press Alt (Option on the Mac) and move the shape with the Path
Selection tool.

You'll find more information on manipulating shapes in Book IIl, Chapter 2.

Like all vector objects, vector paths print at the full resolution of the printer and are resolu-
tion independent. To avoid having your vector shapes first converted into pixels when print-
ing, you must select the Include Vector Data option in the Print Options dialog box.

Remember that if you select the Fill Pixels option in the Options bar, you're stuck without
editing capabilities.



Filling and Stroking

(shapes) out of pixels, and filling and stroking are two
of the most venerable object-builders at your disposal.
You can also paint objects on your canvas by hand, or convert
vector shapes to pixels (see Book IV, Chapter 2, for more on
I that topic). But if you need pixels arranged into regular circles,
In This Chapter ellipses, and polygons, the Fill and Stroke facilities of Photoshop
should be your first stop.

Photoshop offers several different ways to create objects

v~ Filling selections

1~ Stroking selections Photoshop creates these pixel objects by filling selections or
LIl | closed paths with color or patterns, or by tracing the outlines
v~ Filling or stroking paths of the selections or paths. Those coming to Photoshop from

some other image editors may be confused at first, looking for

v~ Buildi d applyi
BIRIET S gPPing separate tools to create, say, rectangles and filled rectangles

RUHITeS when they want to build a shape filled with pixels. The Shape
v~ Creating and applying tool, which creates vector outline objects rather than pixel
patterns shapes, isn’t quite what they are looking for.

You can thank Adobe for not overloading the crowded Tools
palette with separate tools you don’t really need. When you real-
ize that you can simply make a selection of any shape and then
fill it or stroke it, you’ll never miss separate pixel-object tools.

This chapter shows you how to create these objects by filling
and stroking selections and paths, how to add smooth gradient
blends, and the best ways to apply patterns. After reading this
chapter, you will have your fill of different strokes.
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Because fill layers work a little differently than the types of fills discussed in this chapter,

E s Another way of filling is through the use of a fill layer, which you can use to fill a shape.
| cover them in Book V, Chapter 1.

Filling a Selection with the
Foreground or Background Color

The following steps show you the basics of filling a selection with either the foreground or back-
ground color (there are plenty of other filling options, which I discuss later in the chapter):

1. Create your selection on a layer. color. You also can choose color, black,
' 50 percent gray, white, history, or
See the sidebar, “Knowing your selec- pattern.
tion options,” for help with selections. .
Book V covers layers. 4. Click OK.
2. Choose a fill color as the foreground The foreground (or background) color
or background color. fills the selection.

Choose Window=>Color. Use the color You can also choose a blend modg, the
sliders to mix your desired color. For opacity of the fill, and whether to fill the

more on choosing color, see Book II entire selection or only portions of the
Chapter 3. ' ’ selection that contain pixels (the non-
. . transparent areas). | recommend not
3. Choose Edit>Fill. adjusting your blend mode and opacity
The Fill dialog box, shown in Figure 3-1, in the Fill dialog box, but instead
appears. Here, you can select whether to adjusting those settings in the Layers
fill with the foreground or background palette, where you have more flexibility.
Fill =]
Figure 3-1
S
K BT fiow -
Ao
T
Mocks: | Normal b
Opachty ! e
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Knowing your selection options

The first step to filling a selection is to make a v Select pixels by using the Magic Wand.
selection. You can (Check out Book Ill, Chapter 1)

v Draw a freehand selection with the Lasso, 1~ Paint a selection by using Quick Mask mode.
Polygonal Lasso, or Magnetic Lasso tool. (See (See Book VI, Chapter 2.)

Book Ill, Chapter 1) . .
ook lll, Chapter v Change a path into a selection. (Take a look

v Drag a selection with the Rectangular or at Book IlI, Chapter 2.
Elliptical Marquee tools. (See Book IlI, Chap-
ters 1 and 3, for more information about
creating and modifying selections with these
and other selection tools.)

1 Use the Type Mask tools to create selections
shaped like text (see Book IV, Chapter 4).

Book

Filling Options and Tips o]
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After you make a selection, you're ready to use one of the filling options. You can use the Fill
dialog box (as described in the preceding section) to fill the selection with the foreground or
background color; you can also choose to fill the selection with color, black, white, or gray.
Photoshop is full of shortcuts and options. Here are just a few:

v With the selection active, press Alt+Delete (Option+Delete on the Mac) to fill it with the
foreground color. All areas within the selection, including transparent areas, will be
filled with the color.

v Fill only the pixels in a selection with the foreground color, leaving any transparent
pixels transparent, by pressing Alt+Shift+Backspace (or Option+Shift+Delete on the Mac).

v Lock the transparent pixels in a layer (and its selections) by clicking the Transparency
icon in the Lock area of the Layers palette.

v If you're working on the Background layer, you can also fill the selection with the back-
ground color by pressing the Delete key. (Pressing Delete on other layers creates a
transparent area that shows the image in the layer underneath the selection.)

v By clicking the Color option, in the Fill dialog box, you access the Color Picker where
you can select any color of the rainbow to fill your selection with. For more on using the
Color Picker, see Book II, Chapter 3.

v Choose the Pattern option, in the Fill dialog box, to fill the selection with a pattern.
Click the arrow next to the pattern swatch and select a pattern from the pop-up palette.
Click the pattern palette pop-up menu to choose more pattern libraries.

v Select the History option in the Fill dialog box, to restore the selection to a state or
snapshot of the image. For more on working with the History palette, see Book II,
Chapter 4.

v Paint part or all of the interior of the selection by using any of the brush tools, as shown
in Figure 3-2. This option lets you partially fill a selection by using a bit of flexibility and
creativity. When you paint a selection with brush tools, Photoshop confines the paint
inside the boundaries of your selection. For more on painting, see Book IV, Chapter 1.

v Pour color from the Paint Bucket tool into the selection.
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Figure 3-2

Selection
marquee

Pouring with the Paint Bucket Tool

The Paint Bucket tool, available from the Tools palette, operates much like a combination of
the Brush tool and the Magic Wand tool, as you’ll see from looking over its options. To use it,
select the tool (press Shift+G until it’s active) and click inside the selection you want to fill.
Here are your options, all of which are found on the Options bar:

v FHill: You can choose whether to fill with a solid Foreground color or a pattern.

v Pattern: When you’ve chosen Pattern from the Fill list in the Options bar, you can select
a preset pattern, load patterns from your pattern libraries, or create a pattern of your
own. You'll find more information on patterns later in this chapter.

v Mode: You can select a blending mode, too. You’ll find more information on these
modes in Book V, Chapter 3.

v Opacity: Adjust this value to make your fill semitransparent.

\

Tolerance: Like the Magic Wand tool, you can choose a tolerance level that specifies
how similar in brightness a pixel must be before it is selected for painting. You can find
more information on tolerance levels in Book IIl, Chapter 1.

v Anti-aliased: Choose this option to blend the paint in smoothly with the areas not filled.

\

Contiguous: When selected, the paint fills only pixels that are touching. When
deselected, paint fills all pixels within the brightness tolerance you specify.

v~ All Layers: This option applies paint to pixels in all layers that are within the selection
and brightness/tolerance levels you specify.

As with other tools that fill, you can prevent the Paint Bucket tool from filling the transparent
pixels. Just select the Transparency icon in the Lock area of the Layers palette.
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Stroking a Selection

Stroking enables you to create outlines of selections, layers, or paths. Stroking a selection cre-
ates a border around the selection. It’s up to you to decide whether to put the border inside,
outside, or centered on the selection. (Photoshop doesn’t care either way.)

To stroke a selection, follow these steps:

1. Choose a foreground color and make Adjust the settings and the options, as

a selection. described in the following section.

(Stroke can’t automatically use the In the example shown in Figure 3-3, |

background color, although you can specified a 22-pixel stroke, centered

select that color in the dialog box.) around the selection. REAR
2. Choose Edit>Stroke. 4., Click OK to apply the stroke. v

Chapt
The Stroke dialog box opens. i ;
Figure 3-3

Stroke
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Knowing Your Stroking Options

You can adjust the following settings in the Stroke dialog box:

1V

X \

©)

Width: Enter a width for the stroke in the Width box. You can select 1 to 250 pixels. You
can also type in a value by using another measurement, such as inches, but Photoshop
converts it to pixel values before applying.

Color: Choose a color if different from the foreground color, by clicking in the Color
box. You can select the hue you want from the dialog box that appears.

Location: Select whether Photoshop should apply the stroke outside the selection,
inside the selection, or centered on the selection. (For example, a 3-pixel stroke would
extend 1 pixel inside and 1 pixel outside the selection.)

Mode: Choose a blend mode to determine how the stroke merges with other colors.

Opacity: The default value is 100 percent. If you want the stroke to be semitransparent,
type another value.

Preserve Transparency: Choose this option to apply the stroke only to pixels that
already exist, leaving transparent areas alone.

| recommend leaving the blend mode and opacity setting options in the Stroke dialog box
alone. Instead of adjusting these settings, create a new layer for your stroke and then choose
a different blend mode and opacity setting in the Layers palette. This maximizes your ability
to make edits.

Filling and Stroking Paths

Just as you can fill and stroke selections, you also can fill and stroke paths. These capabilities
enable you to create pixel shapes that take advantage of the powerful vector-oriented features
of the Path tools.

For example, you can use the Pen to create complex paths to form shapes and then rescale
the shapes to your heart’s content. Then, when you're ready, convert shapes to pixels or
make an outline of the shape by using the fill and stroke features.

You'll

find the basics for creating paths in Book III, Chapter 2.

Filling a path
To fill a path with a color, follow these steps:
7. From the Layers palette, select the you can find information on clipping
image layer you want to fill. layers in Book V, Chapter 4.
You must choose a layer other than a type 2. In the Paths palette, select the path
layer or layer mask. For more information you want to fill.

on type layers, see Book IV, Chapter 4;



3.
4.

Choose the foreground color you
want to fill the path with.

To fill the path by using the current
setting, click the Fill Path button in
the Paths palette. You then can skip
the remaining step.

To fill the path by using different set-
tings, open the Fill Path dialog box by
using one of the following methods:

+* Hold down the Alt key (Option key
on the Mac) while clicking the Fill
Path button.

v Drag the path to the Fill Path button
while holding down the Alt key
(Option key on the Mac).

v Choose Fill Path from the palette
menu.

The Fill Path dialog box looks similar to
Figure 3-1.

In the Fill Path dialog box, enter or
change settings to meet your needs.

In addition to the regular Fill dialog box
options (see “Filling Options and Tips,”
earlier in this chapter), check out these
bonus settings:

Stroking a path

Filling and Stroking Paths

v+~ Use: This option enables you to pick a
fill color, pattern, or history state. You
can select the current foreground or
background colors, color, black, 50
percent gray, white, a pattern, or the
area the path encompasses in its cur-
rently selected state in the History
palette. (For more on the History
palette, see Book II, Chapter 4.) If you
select Pattern, you can choose a pat-
tern from the Custom Pattern menu. If
you choose Color, the Color Picker
appears, enabling you to select your
desired color.

v+~ Blending: This option enables you
to choose a blending mode and
opacity; you can also decide
whether to protect transparent
pixels within the path while you're
filling it with color.

+ Rendering: With this option, you can
choose a feathering radius to fade
out the color of the fill at the edges of
the path; you can also decide
whether you want to smooth out the
edges by using anti-aliasing options.

Stroking a path produces quite a different result than stroking a selection — even if the selec-
tion is the same shape as the path. That’s because when you stroke a selection, you always
use a simple, solid line.

On the other hand, when you stroke a path, you can use any of the drawing or painting tools,
such as the Pencil, Brush, Smudge, or any of the other tools that use a brush tip. If you want
to add some flair to the outline of a shape, stroking a path is the way to go.

Aside from this visible difference, stroking a path outline is otherwise similar to filling a path.
Just follow these steps:

In the Paths palette, select the path
you want to stroke.

7. From the Layers palette, select the

image layer you want to contain the

stroked path.
3. Choose the foreground color you

As with filling a path, you must choose a want to use to stroke the path.

layer other than a type layer or layer mask.

CONTINUED

325

Book

v

Chapter

3



326

Book IV » Chapter 3: Filling and Stroking

4.

Choose the painting tool you’d like to
use to stroke the path.

Select the brush size, mode, opacity,
flow, or other parameters for that
painting tool.

For more information on setting param-
eters for painting tools, see Book IV,
Chapter 1.

Stroke the path by using any of these
methods:

v Click the Stroke Path button at the
bottom of the Paths palette.

This strokes the path using the
current settings of the Stroke Path
dialog box. You can click more than
once; each click reapplies the stroke,
making a partially transparent stroke
more opaque and thicker.

v Choose Stroke Path from the Paths
palette menu to enter changes in the
Stroke Path dialog box. You can
specify a different drawing/painting
tool, and select the Simulate
Pressure option, which varies the
width of the stroke.

v Hold down the Alt key (Option key
on the Mac) while clicking the
Stroke Path button to access the
Stroke Path dialog box.

v Drag the path to the Stroke Path
button while holding down the Alt
key (Option key on the Mac) to
access the Stroke Path dialog box,
shown in Figure 3-4.

Figure 3-4 | -2" "1

Stroke Path

Tool:  Jj Brush

_ Simulate Pressure
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Working with Gradients

A gradient is a wonderful blend of colors that you can apply to a layer or selection, gradually
fading from one hue to another. Gradients can involve more than two colors, producing a veri-
table rainbow of variations. You can apply gradients by using preset selections of colors, or
you can create your own gradient.

You can create the following gradient effects:

v Foreground to background: The gradient is a transition from the current foreground
color to the background color.

1 Foreground to transparent: The gradient is a transition from the current foreground
color to transparent, allowing whatever is under the transparent portion to show
through.

\

Black to white: The gradient is a transition from black to white.

v An array of colorful selections: This includes rainbows, coppery sheens, and other
effects.

have names such as Color Harmonies, Metals, and Special Effects. For more information on

@ You can load other libraries of gradients from the Gradient palette menu’s libraries. They
managing preset libraries, see Book I, Chapter 6.

In addition to being able to control the appearance and application of a gradient, you also have

the opportunity to adjust the Gradient tool’s options, all of which are found on the Options bar:
v Mode: Select any of Photoshop’s blending modes.

Opacity: Choose how transparent the gradient is.

Reverse: Reverse the order in which the colors are applied.

X Y\

Dither: Add noise, or random information, to produce a smoother gradient that prints
with less banding (color stripes caused by the limitations of the printing process to
reproduce a full range of colors).

\

Transparency: This option determines whether Photoshop ignores the gradient’s trans-
parency settings when you apply a gradient. If you deselect this option, all portions of
the gradient will be fully opaque. I show you how to add transparency to a gradient
later in this chapter.

Choosing a method for applying a gradient

Five different kinds of gradient methods are avail- .~ Radial gradient blends the colors from start
able in Photoshop, as shown in the following to end in a circular arrangement.
figure:
J v Angle gradient creates a counterclockwise
v Linear gradient blends the colors of the gra- sweep around the starting point, resembling
dient from start color to end color in a straight a radar screen.
line.

(continued)
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(continued)

+” Reflected gradient blends the colors by
using symmetrical linear gradients on either
side of the starting point.

Radial

v Diamond gradient blends the colors out-
ward in a diamond pattern.

Reflected

»

Diamond

Applying a preset gradient to a selection

Here’s how to apply a preset gradient:

1. Choose the layer from the Layers 5.

palette and/or make the selection you
want to apply the gradient to.

Select the Gradient tool from the
Tools palette, or press G or Shift+G

2.

until the Gradient tool becomes 6.
active.

3. Choose one of the preset gradients
from the Options bar list. 7.

Choose the method for applying the
gradient by clicking one of the icons
in the Options bar.

You can select a linear, radial, angle,
reflected, or diamond effect.

©)

Choose any other options you want
from the Options bar.

I explain these options in “Working
with Gradients,” earlier in this chapter.

Place the cursor at the position in the
layer or selection where you want to
place the starting color of the gradient.

Drag in any direction to the point you
want to place the end color.

Longer drags result in a subtle transition
between colors, whereas shorter drags
result in a more abrupt transition. Hold
down the Shift key to restrain the direction
of the gradient to an even 45-degree angle.
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8. Release the mouse button to apply the The gradient I created is shown in
gradient. Figure 3-5.

Figure 3-5
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Creating and editing gradients

Although Photoshop includes dozens of different gradient presets, you may want to create
your own. Perhaps you’d like to create a gradient with your company colors or build one to
match the predominant colors in an image. Or you might want to create a gradient that
includes more than two colors. The Gradient Editor lets you create your own gradient preset,
using two or as many colors as you want, which you can save and reuse at any time.

The Gradient Editor has lots of options, but it’s easy to use when you know what all the con-
trols and options do. This next section leads you through the steps for creating your own new
gradient preset.

Creating a two-color smooth gradient
Follow these steps to create a simple two-color smooth gradient:

7. Select the Gradient tool from the The Gradient Editor dialog box opens,
Tools palette. as shown in Figure 3-6.

2. Click in the gradient sample window

in the Options bar. CONTINUED
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If you want to base your new gradient
on an existing gradient preset, click
that gradient in the Presets window.

Click the New button.

Photoshop appends a copy of the gra-
dient you selected to the end of the
Presets. If you didn’t select a preset,
Photoshop uses the default Foreground
to Background gradient as your model
instead.

In the Name box, type in a name for
your new gradient.

Choose Solid or Noise from the
Gradient Type pop-up menu.

A Noise gradient is one containing
random colors. Because the colors are
random, each time you create a noise
gradient the result is different. You can
choose which color model to use and
how rough the gradient is and select a
range of acceptable colors.

Adjust the Smoothness slider. Drag
the slider (click the right pointing
arrow) or enter a value to determine
how smoothly you blend your colors
into one another.

If you chose Noise in the previous step,
the slider changes to Roughness. This
option affects how smooth or abruptly
one color transitions into another.

You can set the following options only
if you chose Noise in Step 6.

v+ Color Model: Select your desired
color model or limit the range
of colors by adjusting the sliders.
See Book II, Chapter 2, for more
on color models.

+* Restrict Colors: Limits the colors to
printable CMYK colors only. Again,
see Book II, Chapter 2, for details.

10.

v Add Transparency: Lets you
include transparency in your gradi-
ent, if desired.

+* Randomize: Changes the colors in
your gradient. Click and each time
you’ll get a new set of colors.

To begin defining the color of the
starting point for your gradient, first
click the left color stop button under
the gradient bar.

The triangle on top of the stop turns
black to indicate you are working with
the starting point of the gradient.

Choose the starting color by using
one of these methods:

v Double-click the left color stop and
select a color from the Color dialog
box that appears.

v Double-click the Color box in the
Stops area of the dialog box and
choose a color from the dialog box.

v Choose Foreground, Background,
or User Color from the Color pop-up
menu in the Stops area of the
dialog box.

Keep in mind that if you select color with
the Foreground or Background option
when you change the foreground or back-
ground color, the color in the gradient
changes automatically. The change doesn’t
affect any gradients you've already cre-
ated, but it does affect any future gradi-
ents. However, when you open the
Gradient Editor again, you can revert to
your original foreground or background
color by selecting the User Color option.

v Position the cursor (it will appear as
an Eyedropper icon) anywhere in
the gradient bar to select a start
color from the bar, or position the
cursor anywhere within an image on
your screen, and then click to select
the color under the cursor.



m Click the end point color stop at the

12.

right side of the gradient bar and use
any of the methods described in Step 10
to choose the end color of the gradient.

Change the proportions of one color
to the other by moving the starting or
ending point’s color stops to the left
or right. Drag the midpoint slider (a
diamond icon) to adjust where the
colors mix equally, 50-50.

13.

Working with Gradients

You can also change the position of the
midpoint by typing a value into the
Location box.

Because the center point of the gradi-
ent is halfway between the start and
end points, the gradient will proceed
smoothly from one color to the other,
meeting to blend evenly in the middle.
Moving the color stops and the mid-
point changes the proportions.

Click OK to apply the settings to your
new gradient.

Figure 3-6
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Creating a multicolor gradient

You can also create a fancier gradient that includes more than two colors. Follow these steps
to add a third color:

1

To add a third color, click below the
gradient bar at the position you want
to place the next color.

A new color stop appears.

2. Define a color for the new color.

3. Click again to add a fourth color.

You can keep going like this for hours.

CONTINUED
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Specify the color for any and all addi-
tional color stops.

Move the color stops to the left or
right to assign proportions for the
additional colors.

You can also type in a position for each
stop by selecting it and typing a value
in the Location box.

Adjust the midpoint sliders between
the colors.

Adding transparency to a gradient

7.

©)

8.

If you change your mind, you can
redefine the color or click the Delete
button.

You can also remove a color stop by
dragging it down from its position on the
gradient bar.

Click OK to apply the settings to your
new gradient.

By default, a gradient has 100-percent opacity in the start color and progresses to 100-percent
opacity in the end color. If you like, you can have the gradient fade out to transparency so that
the portion of the image under the gradient shows through. To add transparency to a gradient,
follow these steps.

1

Create a single or multicolor gradient,
as described in the two previous
sections.

Select the left opacity stop.

This stop is located just above the
gradient bar, as shown in Figure 3-7.

Use the Opacity slider to specify the
amount of transparency for the gradi-
ent at its start point.

You can also type a value into the
Opacity box.

Select the right opacity stop and use
the Opacity slider or text box to spec-
ify transparency for the gradient at its
end point.

5.

Move the Opacity stops to the right or
left to adjust the position where
Photoshop applies each stop’s opacity
setting.

Click above the gradient bar to add
more Opacity stops if you want to
vary the transparency of the gradient
at different points.

For example, you could fade trans-
parency from 100 percent to 50 percent
back to 100 percent to produce a par-
ticular effect.

Gradients ordinarily proceed smoothly
from one color to another. If you'd like a
less homogeneous appearance, adjust the
Smoothness slider to a value of less than
100 percent (click the right-pointing arrow
to access the slider).
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Managing and Saving Gradients

If you're smart, you’ll want to store the gradients you create so that you can use or edit them
again later. Here are some tips for managing your gradients:

v To save a gradient, click the Save button in the Gradient Editor dialog box. You can save
the current presets, including your new gradient, under the current library’s name or
another one that you choose.

v To load gradient presets into the Gradient Editor, click the Load button and select the
name of the gradient library you want to add to the Presets list.

v To add an additional set of presets to the current presets, choose the name of the
presets from the Gradient Editor’s pop-up menu.

For more information about managing gradient presets with the Preset Manager, see Book |,
Chapter 6.

Working with Patterns

Patterns are textures or repeating configurations of pixels that you can use to fill selections or
layers, apply with painting tools, smear around your image with the Pattern Stamp, or use as a
basis for the Healing Brush and Patch tools. Photoshop offers a large selection of patterns,
and you can create your own in two different ways.

You select patterns from palettes that appear in the Options bar for many of the tools just
mentioned, much like brush tips and gradients, and you manage them in much the same way,
using the Preset Manager (see Book I, Chapter 6). The following sections show you how to
apply a preset pattern and create your own.
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Applying a preset pattern

Although you can apply patterns by using many different tools, this chapter sticks with apply-
ing patterns as fills. To fill a layer or selection with a preset pattern, follow these steps.

1.

2.

Choose the layer or selection you
want to fill with a pattern.

Choose Edit~Fill and select Pattern
from the Use pop-up menu.

B In the Custom Pattern palette, select

the pattern you want to fill with.

v Choose a pattern from the current
palette, as shown in Figure 3-8.

v Replace the current patterns with
new patterns by choosing Replace
Patterns from the palette pop-up
menu (click the right-pointing trian-
gle at the right side of the dialog
box). Then choose the new pattern
library from the dialog box that
appears.

v Append new patterns to the current
set by choosing Load Patterns from
the palette pop-up menu.

v Append one of the preset libraries
furnished with Photoshop by choos-
ing the pattern from the list at the
bottom of the palette menu.

4. Choose any other Fill options you
want to apply, such as Mode, Opacity,
or Preserve Transparency.

The Preserve Transparency option pre-
vents Photoshop from filling the trans-
parent areas on your layer with a
pattern.
| recommend adjusting the Mode and
Opacity settings in the Layers palette
rather than the Fill dialog box. This
allows you the maximum flexibility if
you want to make edits later.

5. Click OK to fill the layer or selection
with the chosen pattern.

Figure 3-8
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Creating a new pattern

You can create your own pattern, basing it on an existing image or on one you create yourself.
Select a small portion of an image to build an abstract pattern, or use a recognizable object to
define that object as a pattern stamp. You can use anything from a logo to your signature as a
pattern.

To create your own pattern, follow these steps:

7. Open the image that contains the area You must use a rectangular selection in

you want to use as a pattern, or create order to create a pattern. Note that you
an image from scratch. cannot use a feathered selection of any

kind.
2. Make any modifications to the image

to produce the exact pattern that you 4. Choose Edit->Define Pattern.

Book
want.
The Define Pattern dialog box opens. v
3. Use the Rectangular Marquee tool to E ‘ in th Chapter
select the area you want converted 5. Enter a name for your pattern in the 3

into a pattern. Define Pattern dialog box.

Your new pattern appears in the
Pattern palette for use.

Using the Pattern Maker filter

The Pattern Maker filter is an advanced tool that provides even more ways to customize your
patterns. An easy-to-use dialog box, shown in Figure 3-9, helps you build a pattern that will fill
an entire layer of your choice. The cool part is that you can create a whole series of different
patterns and review them to find the one you like best.

As with creating a pattern from a selection, you must use a rectangular shape to build your
new pattern. If your selection is irregular or feathered when you enter the Pattern maker dialog
box, Photoshop will force a rectangular selection around your irregular or feathered selection.

The most valuable feature of the Pattern Maker is that it creates patterns that tile smoothly.
That is, you can repeat the pattern as many times as you need to fill an area, and the bound-
aries between sections blend together smoothly.

The filter’s dialog box has lots of features. Here’s a quick description of them:

v Tools palette: In the upper-left corner is a small tools palette, containing a Rectangular
Marquee tool you can use to select the area to derive the pattern from, a Zoom tool to
magnify or reduce the image, and a Hand tool to move the image around in the viewing
window. Note that you can also press the Shift+Alt (Shift+Option on the Mac) and
Shift+Ctrl (Shift+8 on the Mac) shortcuts to zoom in and out.
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v~ Status bar: Along the bottom edge is a status bar that shows the following bits of
information:

» Magnification of the preview
» Width and height of the whole image in pixels

» Tile grid, the number of copies of the image that will be needed to fill the entire
selected layer

» Sample, the width and height in pixels of the current image area selected by the
Marquee tool

» Preview, the number of different patterns you've generated so far from the current
sample (more on this in a bit)

v Tile Generation: This area shows the size of the tiled image that Photoshop creates, the
type of offset used (horizontal, vertical, or none), and the amount of smoothness and
detail in the sample picture.

v Preview: This area governs whether the preview window shows the original image or
the patterns you generate, and whether a boundary separates the patterns.

v~ Tile History: This area provides a slide show of all the patterns you generate.
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Generating a pattern

Working with Patterns

To create a pattern using this filter, just follow these steps:

1. To apply a pattern to an existing
image, first make a copy of the layer
that contains the image area you want
to convert to a pattern.

To apply the pattern to a new image,
select the area you want to use with the
Rectangular Marquee tool and choose
Edit=>Copy. Then choose File>New,
choose Custom from the New File dialog
box, click OK to create the new file, and
paste the selection into the new image.

2. Choose Filter~>Pattern Maker.

3. Select the area to be used as the basis
for the pattern.

4. If you're creating the pattern in the
current layer, choose the Rectangular
Marquee tool from the dialog box’s
Tools palette, and select the portion
of the image you want to convert to a
pattern.

You can drag the selection marquee
around the image, use the zoom features
to change the magnification, or drag the
image around by using the Hand tool.

©)

5. If you want to completely fill the layer

with tiled versions of the pattern,
specify the size of the tile by typing
values in the Width and Height boxes
in the Tile Generation area. You can
also enter the offset (None,
Horizontal, or Vertical) to use and the
amount of that offset. If you’d rather
have only a single, non-tiled image,
click the Use Image Size button.

6. Set other options:

v Smoothness: Set a value to deter-
mine how smooth the edges of the
patterns are blended with the sur-
rounding tiles.

v Sample Detail: This parameter con-
trols the maximum size of details in
the pattern.

v Preview: Choose whether to display
the original image or the generated
patterns in the preview window.

v Tile Boundaries: If you want, you
can insert a line between tiled
images to show their boundaries.
Select the Tile Boundaries option
and, if you like, choose a color for
the boundary that will show up well
against your sampled image.

7. Click the Generate button to create a
pattern from your selection. You can
click the button multiple times to
create multiple pattern variations.

Photoshop displays all the different
patterns you generate in the Tile
History panel in the lower-right corner
of the dialog box.

You can review patterns in a slide-show
manner by clicking the Previous, Next,
First, and Last arrows.

©)

If you see a pattern you want to save,
click the floppy disk icon at the
bottom-left edge of the Tile History
panel.

9. You can get rid of patterns that you
don’t like by selecting them and then
double-clicking the trash can icon in
the lower-right edge.

Tile History can save up to 20 gener-
ated patterns.

70. Click OK when you’ve saved all the
patterns you want to reuse.

A typical pattern is shown in Figure 3-10.

CONTINUED
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Figure 3-10
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Creating and
Editing Type

In This Chapter

v Discovering different kinds
of type

v~ Exploring the type tools
v~ Entering text
v~ Editing text

creating type used in images. The last few releases have

added features that let you create paragraphs of text or
simple lines of text used as headlines or labels. You can change
the spacing between characters, warp your type, check your
spelling, or even create selections in the shape of text. Drop
shadows, beveled type, and other special effects are yours
quickly and easily. And this release has given us the coveted
capability of placing text on or inside a path.

Photoshop has morphed into a surprisingly good tool for

You may still want to use Adobe Illustrator or InDesign to
create professional layouts where you can keep text and image
files separate, or where you have to place buckets full of text
at small point sizes. But if what you're looking for is a great-
looking image that includes great-looking snippets of text,
Photoshop can do the job.

This chapter introduces you to Photoshop’s type tools. If you
want to get fancy, check out Book IV, Chapter 5, which explains
some of our favorite image editor’s more advanced capabilities.

Selecting a Type Mode

The text you create in Photoshop can be categorized in several
different ways, but ultimately, you're either adding just a little text
(such as a word or single line of text) or a lot (maybe a paragraph
or s0). Accordingly, Photoshop separates type into two modes:

v~ Point type: Use this mode to create a headline or label. You
can create point type by clicking in your image and typing;
the line appears as you type and grows to whatever length
you need (even if that length is wider or taller than your
image). Point type never wraps around to a new line. To
wrap to the next line, you must insert a hard return.
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v Paragraph type: Use this mode to enter longer blocks of text on an image. It’s (unsur-

prisingly) similar to the kind of type you're accustomed to working with in word pro-

cessing programs. In Paragraph mode, all the text goes into a resizable bounding box,

and if a line is too long, Photoshop automatically wraps it around to the next line.

The Point type and Paragraph type modes each operate a bit differently, although they share

many features and options. I explain each of them separately later in this chapter.

Understanding Different Kinds of Type

Whether you're using Point type mode or Paragraph type mode, you can choose several type

options, each designed to help you work with, display, print, and edit text. These options
determine how Photoshop expresses text in a file:

v Vector type: All text in Photoshop is initially created as vector type. Vector type pro-

vides scalable outlines that you can resize without producing jaggy edges in the diago-

nal strokes. You can also edit type in this mode, adding or subtracting characters or
adjusting attributes, such as kerning and tracking. Vector type is always of optimum
quality and appears crisp and clean.

v Rasterized type: When Photoshop converts vector type into pixels, it’s rasterized. When
text is rasterized, it is no longer editable, but is, rather, a frozen graphic of what the text
looks like. When you've finished editing vector type and want to merge the text with the
other pixels in an image (or to perform some manipulations that can be done only with

rasterized text), you can transform the vector type into pixels by rasterizing it. You

can’t resize rasterized type without losing some quality or risking a bad case of the jag-

gies. For more on working with rasterized type, see Book IV, Chapter 5.

v~ Pixel fonts: Pixel fonts are tiny fonts designed for display at small sizes on computer
screens. Unlike traditional fonts, which don’t fit into the natural pixel grid of your

screen (and thus look rough at small sizes, particularly when they’re anti-aliased), pixel

fonts are designed so every pixel corresponds to a pixel on your screen. These fonts,

with names like MINI 7, MiniSerif, and Tenacity, are created in fixed sizes (say, 7 pixels
high for MINI 7 or 10 pixels high for Tenacity and PixelDust). Diagonal lines are avoided
as much as possible, with the font designs favoring horizontal and vertical strokes. As a
result, pixel fonts look crisp and clear at small sizes without anti-aliasing. Indeed, you
shouldn’t use anti-aliasing with pixel fonts, nor should you attempt to resize or rescale

them. You can buy or download pixel fonts, install them on your computer, and use

them just as you use other fonts, keeping in mind they look their best at their fixed size.

Pixel fonts are often used in Web page design. You can see an example of a pixel font
compared to a traditional font in Figure 4-1.

Photoshop treats pixel fonts as if they were vector type, creating them on their own type
layer. However, pixel fonts look and behave more like bit-mapped raster fonts; you can’t

resize them easily. You'll find them easier to work with if you change your font measurement

unit to pixels; choose Edit->Preferences->Units & Rulers (or Photoshop=>Preferences>
Units & Rulers in Mac OS X) and choose Pixels from the Type menu.
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Exploring the Type Tools

Strictly speaking, Photoshop has four type tools (found in the Tools palette), but two of them

are simply vertically oriented versions of the main two text implements. You can use either Book
Paragraph or Point type mode with any of the Type tools: 1174
Chapter

v Horizontal Type tool: Use this tool to enter point or paragraph type oriented horizon- 4

tally on your screen. If you want text that is oriented at an angle other than vertical, you
can rotate it by choosing Edit=>Rotate after you have entered the text. This tool creates
the type on its own Type layer, except when used in Bitmap, Multichannel, or Indexed
Color modes, which don’t support layers. (Book I, Chapter 2, covers these modes.)

v Vertical Type tool: The Vertical Type and Vertical Type Mask tools (described next) are
handy for entering Asian characters. However, you can also use this tool to enter
Roman character point type oriented in a vertical column. You can also use the Vertical
Type tool to create columns of paragraph text, but the results look a little strange. After
you've entered your text columns, you can rotate the text to an orientation other than
vertical by choosing Edit>Rotate. Like the Horizontal Type tool, this tool creates type
in its own Type layer, except with file modes that don’t support layers.

v Horizontal Type Mask tool/Vertical Type Mask tool: These tools operate identically to
their siblings described in the two preceding bullets, with two exceptions. Instead of
adding filled type, both the Horizontal and Vertical Type Mask tools create a selection
border in the shape of the type you enter. Both tools add a selection marquee to the
current active layer. You can do anything with a type selection that you can do with any
other selection, including saving it (Select>Save Selection) for reuse later. You'll find a
longer discussion of the type mask tools in Book IV, Chapter 5.

The Horizontal and Vertical Type tools have some interesting options, which I explain in the
next section. There are also controls you can set by using the Paragraph and Character
palettes, discussed later in this chapter.

Entering Text in Point Type Mode

If you're image oriented (and why wouldn’t you be if you're using Photoshop?), you're proba-
bly not planning to include a novella with your graphics.
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Point type is great for headlines, labels, and similar small amounts of text. You can also use it
to create logos and headings for Web pages. The Web is one place that text that isn’t tack-
sharp can still do the job.

Although a Photoshop image is generally not the place you'll want to insert a whole lot of
text, you can add larger blocks of text that are professional and effective — read “Entering
Text in Paragraph Type Mode,” later in this chapter. You can modify how point type and
paragraph type are displayed by using the Paragraph and Character palettes.

To enter point type, just follow these steps:

1.
2.

Figure 4-2

Open a saved image or create a new
Photoshop document.

Select either the Horizontal or
Vertical Type tool from the Tools
palette, or press T to select the type
tool if the one you want is active.

Hold down the Shift key and press T to
cycle through the four available type
tools until the one that you want is
active.

Your cursor looks like an I-beam, simi-
lar to one you'd see in a word process-
ing program. (See Figure 4-2.)

Click the area of the image where you
want to insert the text.

This is called the insertion point.

A small horizontal line about one-third
of the way up the I-beam shows where
the baseline (on which the line of text
rests) will be for horizontal type. If
you've selected the Vertical Type tool,
the cursor is rotated 90 degrees. The
baseline is centered in the I-beam and
represents the center axis of the verti-
cal column of text you type.

4.

6.

Choose any of the type options from
the Options bar, Character palette, or
Paragraph palette. To access the
palettes, click the Character and
Paragraph button in the Options bar
or choose either palette under the
Window menu.

[ describe these options later in the
chapter.

Type your text. Press Enter (or Return
on the Mac) to begin a new line.

Lines of point type don’t wrap around.
When you press Enter or Return,
you're inserting a hard carriage return
that doesn’t move. You have to remove
hard returns if you want to change the
length of the lines you type.

When you’ve finished entering the
text, click the Commit (the check
icon) button in the Options bar.

A new type layer with your text is cre-
ated. Note the layer that appears in
your Layers palette, as indicated by
the T icon.



Committing type to a type layer

To commit your type to its type layer, you can also
do any of the following in addition to clicking the
Commit button (which looks like a check mark):

v Press Enter on the numeric keypad. The main
Enter (or Return on the Mad) starts a new line
or paragraph, instead.

v Hold down the Ctrl key (or the 8 key on the
Mad and press the main Enter key (Return
on the Mao.

Entering Text in Paragraph Type Mode 3 43

v Click any other tool in the Tools palette. You
don't actually have to use the tool, but you
must click the tool (as opposed to pressing
the keyboard shortcut that's associated with
the tool).

v Click in the Layers, Channels, Paths, Actions,
History, or Styles palettes.

v Select any menu command.

Book

v

Entering Text in Paragraph Type Mode i

Paragraphs are best allocated to captions or text descriptions that accompany an image.
Large amounts of text in an image don’t look their best because when you rasterize the type,
even the most carefully entered text may have a fuzzy look.

Paragraph type is similar to the text you're accustomed to entering within a word processing
program, except that it’s contained inside a border, called a text box or a bounding box. As you
type into a text box, the lines of text wrap around to fit the dimensions of the box. If you resize
the box, Photoshop adjusts the wrapped ends to account for the new size.

You can type multiple paragraphs, use typographical controls, and rotate or scale the type.
You can easily resize paragraph type (and point type, too) by entering a new point size value
in the Character dialog box without having to reselect all the text. Just make sure the text
layer is selected in the Layers palette and the Text tool is active. This works for all the other

text characteristics as well.

To enter paragraph type, follow these steps:

1. Open a saved image or create a new
Photoshop document.

2. Select either the Horizontal or
Vertical Type tool from the Tools
palette, or press T to select the type
tool if the one you want is active.

Hold down the Shift key and press T to
cycle through the four available type
tools until the one you want is active.

Your cursor looks like an I-beam, simi-
lar to one you'd see in a word process-
ing program.

Insert and size the text box by using
one of the following methods:

v Drag to create a text box of an arbi-
trary size. After you release the
mouse button, you can drag any of
the handles at the corners and sides
of the box to customize the size.

CONTINUED
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+* Hold down the Alt key (Option key Each line wraps around to fit inside the
on the Mac) and drag a box of any bounding box, as you can see in Figure
size. The Paragraph Text Size dialog 4-3.

box appears. You can enter the
exact dimensions of the box you
want to create. When you click OK, a
bounding box of the size you speci-
fied appears, complete with handles
for resizing the box later, if you 6. Click the Commit button in the
choose. Options bar (the button looks like a
check mark).

If you type more text than fits in the
text box, an overflow icon appears. You
can resize the text box by gripping any
of the eight handles and dragging.

4., Choose the type options you want
from the Options bar, or Character or Photoshop creates a new type layer.

Paragraph palettes. . .
You can also use any of the options in

5. Enter your text. To start a new para- the “Committing type to a type layer”
graph, press Enter (or Return on sidebar, earlier in this chapter.
the Mac).

Figwea-3 Paragraph text appearsinside a resizable’
bounding box. The text wrapsaround
from line to line and reflows as the box is

made larger or smaller.

Paragraph text 1s great for entering large

. amounts of text into Photoshop.

Creating Type on or in a Path

A_’T Adobe has brought a long awaited capability to the Photoshop cs type feature set — being
&Vﬂ ifw able to place type in and on a path. Photoshop now joins the ranks of Adobe lllustrator and
> InDesign in being able to put type on and inside a path. In fact, the way you create path type
in Photoshop is even similar to those companion programs. Here’s how.



1.
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Grab the Pen or Shape tool. Choose
the Paths option from the Options bar
and create your path.

Note that you can also copy and paste
an existing path or import a path from
[llustrator or other compatible drawing
program. See Book X, Chapter 1, for
details on working with other pro-
grams.

With the regular Type tool (either
Horizontal or Vertical), click on or
inside the path.

Your type cursor changes to indicate
the path type. Note that if you are fill-
ing a path with type, you see a bound-
ing box appear.

Type your desired text and marvel at
how the type glides along or inside
the path, as shown in Figure 4-4.

Commit the type by clicking the
Commit button in the Options bar. See
the section, “Committing type to a type
layer,” in this chapter for other ways to

Using the Options Bar

©)

Using the Options Bar

commit type. After you commit the
type, the path itself doesn’t display
unless you stroke or fill it with color.

To adjust the starting point for the
text, click the starting point with the
Path Selection tool and drag the type
to a new position.

The path appears along with an
I-beam/black arrow cursor.

Edit the text (changing characters,
colors, alignment and so on) just as
you would with regular type.

Adjust the path by using any of the
Path tools — the Direct Selection tool,
the Convert Point tool, and so on.

The type magically reflows along the
newly adjusted path.

To create regular point or paragraph type
when clicking near a path, hold down the
Shift key when clicking, telling Photoshop
you don’t want path type.

The Options bar, shown in Figure 4-5, contains a group of options, some (but not all) of which

are duplicated in the Character palette. Those options that appear in both places are the most
frequently used options. Talk about convenience.

Your options, shown from left to right in Figure 4-5 (starting after the Tool Preset picker), include

Figure 4-5
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Change the Text Orientation: Use this handy button to toggle between vertical and hor-
izontal text orientations. Just select the type layer you’d like to transform and click.
This option works with point type and paragraph type, although the results you get
from switching the paragraph type to vertical orientation may look odd.

Font family: Select the font/typeface you want from the drop-down list. If you have
more than one version of a particular font family installed on your computer, you'll find
one of these abbreviations after the font name: T1, Adobe Type 1 (PostScript) fonts; TT
(TrueType); OT (OpenType); BM (Bit-Mapped).

Font style: While some fonts can have additional styles, such as light or demi-bold,
most other styles are assigned as separate typefaces. Only the styles available for a par-
ticular font appear in the list. Some are available only in regular and italic, for example.

If a font you want to use doesn’t offer bold or italic styles, you can simulate either or both by
choosing a faux style in the Character palette.

Font size: Choose the size of the text from this list, or type a size in the text box.
Generally, text sizes are shown in points because that’s how text is most commonly
measured, with 72 points equaling 1 inch. (A 36-point font is ¥s-inch in size at 72 ppi.)

If you don’t like points, you can switch to millimeters or pixels in the Units and Rulers
Preferences dialog box. (You can find instructions for doing this in Book I, Chapter 6.) You
might want to use, say, pixels instead of points when creating text for Web graphics. If you're
creating a banner that is 100 pixels tall, you will know that text that is 25 pixels tall will fill 25
percent of that space, for example.

Anti-aliasing: This list includes four different types of smoothing to use on your text,
plus none (which leaves your text unsmoothed). Some kinds of anti-aliasing are better
for text that will be displayed at smaller sizes.

Text alignment: Three buttons specify whether Photoshop aligns your Horizontal Type
tool text left, center, or right. When you use the Vertical Type tool, the buttons rotate 90
degrees clockwise and transform into Top, Center (vertically), and Bottom choices.

Text color: Click in this box to select a color for your text from the Color Picker.

Create warped text: This option lets you warp and bend text by using 15 different types
of distortion. You can find out about all of them in Book IV, Chapter 2. When used with
Paragraph type, the bounding box warps on-screen, too, so you can see how the para-
graph is changing.

Toggle Character and Paragraph palettes: Click this button any time a type tool is
active to show or hide the Character and Paragraph palettes.

Cancel: Click this button (or press the Esc key) to cancel the text entry you're making.

Commit: Click this button to apply the text to a type layer.

Working with the Character Palette

The Character palette, shown in Figure 4-6, is a tabbed palette, usually paired with the
Paragraph palette, which lets you format the appearance of individual type characters. Five of
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the options in the Character palette are exactly the same as those found in the Options bar.
The duplicated features include

v Font family

v Font style

v Font size

v Anti-aliasing

v Text color

The other menus, buttons, and text boxes provide additional functions. I discuss these
options in the following sections.
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Leading

Leading is the amount of space between the baselines of consecutive lines of type, usually
measured in points. (The baseline is the imaginary line on which a line of type rests.) You can
choose a specific amount of leading or allow Photoshop to determine the amount automati-
cally by choosing Auto from the Leading menu.

Wider line spacing can make text easier to read (as long as you don’t go overboard!) or be
used for artistic effect. Tighter line spacing makes for more compact text but can decrease
readability if your tightening goes too far.

When you select Auto Leading, Photoshop multiplies the type size by a value of 120 percent to
calculate the leading size. So Photoshop spaces the baselines of 10-point type 12 points apart.
You can change this automatic value by clicking the Paragraph palette and choosing Justify
from the palette’s menu. A dialog box appears with several values. Type the amount you want
in the Auto Leading box. If all this seems confusing, [ recommend experimenting with leading
to get a true idea of how various values affect the space between lines of text.
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Tracking

Tracking is the amount of space between letters in a string or line. You can specify tight tracking
to squeeze all the letters together more closely, or loose tracking to let them spread out a bit.

Don’t confuse tracking with kerning, which deals with the space between two individual let-
ters. Tracking sets a value to evenly space all the letters you select, and kerning helps you
close or widen the gap between two individual letters.

One use for tracking is to help lines of text fit a specified horizontal space, and you can make
this technique work if you use it judiciously. Beginners typically overdo tracking, squeezing
letters together so tightly they touch, or spreading them apart so that wide gaps appear. You
can see examples of tracking in Figure 4-7.

rewea7 ['hiS 1S normal tracking.

This is loose tracking.
This is tight tracking.

To track a set of characters or a line, select the text you want to squeeze or expand, and
either choose a value from 0 to -100, or 0 to 200, from the Track menu, or type in a specific
value in the Track text box. Each unit is equal to Y100 of an em (the width of an em dash in a
particular typeface), so a setting of —100 reduces the space between characters by Yo the
width of an em dash (quite a lot!).

Kerning

Kerning is a technique for adding or removing space between pairs of letters to make them fit
together more closely and aesthetically. For example, the letters A and V are a natural fit and
often look better when kerned slightly. If you choose Metrics from the Kern menu, Photoshop
automatically tries to kern the characters to provide an attractive look, like that shown in
Figure 4-8. Note that the kerning tables are built into the individual font. Be warned that cheap
fonts sometimes have poorly created kerning tables or no tables at all — another good reason
to stick with quality fonts.

To manually kern letters, click at a point between the two characters and either choose a per-
centage from 0 to -100, or 0 to 200, from the Kern menu, or type in a specific value in the Kern
text box. As with the Track menu, the values represent %1000 of an em.

Vertical and Horizontal scale

The Vertical and Horizontal Scale options represent the relationship between the height and
width of the text. By default, this relationship is 100 percent. To make the width of the type
proportionately 50 percent more than the height, you enter 150 percent into the Horizontal
Scale box. You can see examples of scaling in Figure 4-9.
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Be careful about using the scale options. Type designers create fonts with very specific
proportions. When you deviate from those proportions, you can destroy what was once

a beautifully designed typeface.

Figure 4-9 T extat 1000/0 Scale

WVertical Scale 50%%

Horizontal Scale 50%

Baseline shift and text attributes

The Baseline option adjusts the height above or below a typeface’s normal baseline that the
text appears. You usually employ this option to create superscripts and subscripts. A bar with
several buttons in the Character palette lets you turn on or off several type attributes with a
single click. The text attributes are as follows, from left to right in Figure 4-10:

. T™F TPHETT T %
Figure 4-10 | =

v Faux Bold/Faux Italic: Some fonts don’t have true bold or italic options; Photoshop can
fake either or both of these if you click the appropriate button. Faux fonts can look
good, except at smaller sizes.
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Applying faux styles can distort the proportions of a font. It is really best to use fonts as they
were originally designed and if there is no bold or italic option, c’est la vie.

All Caps: This button changes the case of the characters in selected text to all capitals,
or back to their normal case when you turn it off.

Small Caps: Small caps are uppercase letters about the size of lowercase letters in a
font. They are most frequently used for acronyms and abbreviations, such as NASA or
AM/PM because they are less obtrusive than full-size caps in text passages. Click this
button, and Photoshop either uses the small caps characters built into many fonts or
creates faux small caps for you.

Superscript: Click this button to raise a character automatically to create a superscript,
as in E=MC”. You'll probably also want to reduce the size of the character.

Subscript: Click this button to lower the character below the baseline, creating a
subscript. Usually, subscripts are reduced in size, as in H,O.

Underline: Click this button to underline the selected characters, like this.

Strikethrough: Click the button to provide a strikethreush effect to the selected charac-
ters. In legal applications, strikethrough is widely used to show sections that have been
removed, but in their original context.

Character Set: (Refer to Figure 4-6.) Use this drop-down list to select the language you
want to use for Photoshop’s spell checker and for hyphenation. The option includes
variations, such as USA English or British English, and French or Canadian French.

You can also find the preceding attributes on the Character palette pop-up menu. And the
menu lists a few other attributes that are not displayed directly in the palette:

7

1V

Standard Vertical Roman Alignment: Displays the text in the standard alignment we
are used to seeing — across the page.

Change Text Orientation: Rotates your text horizontally or vertically. You can also click
the button in the left side of the Options bar to do the same task.

Fractional Widths: This setting is the default display. When type gets small, the spacing
between characters may vary by fractions of a pixel. Photoshop has to favor one pixel
or the other and sometimes the appearance is strange. Overall, however, it provides the
best spacing for the legibility and appearance of the type. But, for small type to be dis-
played on the Web, the readability may be impaired due to some characters running
together and words having gaps.

System Layout: Displays the text using the operating system’s default text handling,
similar to what you see in WordPad or SimpleText. This option doesn’t allow fractions
of pixels and removes any anti-aliasing. This is a good option for text to be displayed on
the Web.

No Break: Prevents words from breaking at the end of lines. You may want to select this
option to prevent words such as proper names, dates, initials and so forth from break-
ing. Select your text and then choose the option.
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Working with the Paragraph Palette

Old Style to Fractions: When you work with OpenType fonts, you may find that they
include tables of various font attributes. These tables allow you to apply various styles,
such as true, diagonal fractions, alternate Old Style numerals, fancy cursive type upper-
case letters (Swash and Titling), ligatures (designed to fix the kerning of certain awk-
ward letter combinations such as fi and tt), and ornamental fonts (think dingbats or
wingdings) such as leaves and flowers.

Reset Character: Choose this option to reset your character attributes (font family, size,
style and so on) back to Photoshop’s default.

Working with the Paragraph Palette

You can use the Paragraph palette, shown in Figure 4-11, to format any or all paragraphs in a
type layer. Simply select the paragraph or paragraphs that you want to format by clicking in
an individual paragraph. You can drag a selection to select multiple paragraphs; or click a
type layer containing the paragraphs to format all of them at once.

©)

Justification
. =g
Figure &-11 :f""-‘-"f—'
a _.E == T 88 =2

The Paragraph palette’s pop-up menu gives you access to Justification and Hyphenation
dialog boxes. You can use these to customize the default settings Photoshop uses for these
functions. As a side note, if you're not familiar with the word glyph used in the Justification
dialog box, it is another word for font character.

TR A AT Roman Hanging Punctuation

Indent first line HE oo Justification...

—‘i ot = :e* Hyphenation. .

v Adobe Single line Composer
before Adobe Every line Composer

Reset Paragraph

Space after

Changing paragraph alignment

At the top of the Paragraph palette, you see a set of seven alignment buttons. Three align non-
justified text. They include the following:

I’

)

Left align text: All text is even with the left margin and allowed to be ragged on the right
side of the column.

Center text: Text is evenly centered in its column and ragged on both right and left
edges.

Right align text: All text is even with the right margin and allowed to be ragged on the
left side.
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@ With vertical type, these choices align the text to the top, a center axis, and the bottom of a
column.

Changing paragraph justification

The other four options in the Paragraph palette produce justified text, in which Photoshop
inserts spaces between characters as necessary so each line is flush on both left and right
sides. The options apply only to the last line of text in each paragraph. You can choose to
make this last line flush left, flush right, centered, or force justified on both sides with spaces
inserted by Photoshop. This last option sometimes calls for some manual tweaking to avoid a
final line that is squeezed or expanded too much. Note that you can apply justification options
to paragraph type only, not point type.

@ With vertical type, the justification choices are top aligns, center aligns, bottom aligns, or
force justifies the last line of text.

Changing paragraph indentation

The next three options in the Paragraph palette let you enter an amount of indentation
between the sides of the text bounding box and the actual text. You can specify the amount of
indentation from the left, right, and for the first line of the paragraph (creating a first line that
is indented more than the others in the paragraph). For vertical type, the indentations are
rotated 90 degrees.

Changing spacing between paragraphs

The next two options in the Paragraph palette let you specify the amount of space between
paragraphs. You can specify the amount of space before every paragraph, the amount after
every paragraph, or both.

Breaking long words across two lines

The final option in the Paragraph palette is the Hyphenate check box, which specifies whether
Photoshop hyphenates words that are too long to fit on a line or leaves them intact. Turning
on hyphenation can prevent awkward spacing, particularly with justified text that would
otherwise contain a lot more spaces between characters to make a line fit.

There are a few additional options that are found only on the Paragraph palette’s pop-up menu:

»* Roman Hanging Punctuation: Controls whether punctuation marks (quotations,
dashes, colons and so on) appear inside or outside the margins. Select this option to
have the punctuation marks appear outside.

v Adobe Single-line Composer: Composition includes using a host of parameters, such as
word and letter spacing and hyphenation to determine where a line should break. This
option composes type one line at a time and offers more manual control over where
lines break. The option favors compressing or expanding word spacing over hyphen-
ation, but prefers hyphenation over compressing or expanding letter spacing. This is
the default setting.
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v Adobe Every-line Composer: Looks at multiple, possible breaking points for a range of
lines. The option can optimize earlier lines in the paragraph to avoid weird breaks later
on in the paragraph. Emphasis is given to even spacing of letters and words over
hyphenation. This option can provide more even spacing and fewer hyphens.

v Reset Paragraph: Resets all the paragraph attributes back to the Photoshop default.

Editing Text

You can apply all the options described in this chapter as you enter text, or later, when you're
rearranging words or fixing typos and other errors. To make changes to the text itself, just
follow these steps:

Book
7. Open a saved image or create a new 4. You can begin typing at the place you 114
Photoshop document. clicked, backspace to eliminate char- Chapter
acters, or drag the mouse from the 4
2. Select the Type tool. insertion point to select characters to
3. Select the type layer you want to copy, delete, or format.
g(:)c(:li:ny(’e::: click in the type in the 5. When you’re done entering your

changes, click the Commit button.

Finding and replacing text

You can make global changes in a text layer, switching all occurrences of a set of characters to
another string. For example, you might have typed Ghandi a few dozen times before remem-
bering that the Mahatma’s name is spelled Gandhi. To replace text, follow these steps:

1. Open a saved image or create a new 5. Enter the replacement text in the
Photoshop document. Change To box.
2. Select the type layer you want to 6. If you want the search to locate only
modify. text that exactly matches the case of

the Find string (that is FREEdom but

3. Choose Edit~>Find and Replace Text. not Freedom), choose the Case

The Find and Replace Text dialog box Sensitive option.

appears, as shown in Figure 4-12. 7. To ignore the search word embedded
4. Type or paste the text you want to in another word (say, to find the but

replace in the Find What box in the not there or they), choose Whole

dialog box. Word Only.

8. Click Find Next.

CONTINUED
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v Change All: This changes all occur-
rences of the search text with the
replacement string in your text.

v Change/Find: This changes the
found text and then looks for the
next occurrence.

9. As each string is found, select
whether you want to

v~ Change: This changes only the
string of text just located. Click this
button if you are looking for one par-
ticular occurrence.

| Find And Replace Text %]

Find What Dy

Figure 4-12

|__Find Rowt

; = Change A
Casr Songilive
FForwed | |whole Word Only

Checking your spelling

Photoshop can check your spelling by using an internal dictionary that you can update with
words of your own. Even though you’re not likely to enter huge amounts of text in Photoshop,
that’s no excuse for misspelling the words that you do include. Indeed, because it’s so difficult
to change text after you've rasterized a text layer, the spell checker can save you a great deal
of work. Here’s how to use it:

’. Open a saved image or create a new 17l Ignore All: Ignores all instances of
Photoshop document. tfrlle V\l/{ord fqr the rest of the spell-
check session.
2. Make sure that you've specified the . .
correct language in the Character 1~ Suggestions: Choose a different
palette’s language menu. wotrd frqmt’;lhe Suggegtlonlsl.text box,
or type in the correct spelling your-
3. Select the text that you want to check, self.
or select a type layer to check all the
text on that layer. v Change All: C01.rrects all occur-
4. Choose EditCheck Spelling rences of the misspelled word.
) P ' »* Add: Add the unfamiliar word to
5. When Photoshop identifies a possible Photoshop’s dictionary.

error in the Not in Dictionary box,
click Change to substitute the recom-
mended correction for the word that
is spelled incorrectly.

Or you can choose from one of these
options:

v Ignore: Leaves the word alone and
continues to check the next text.

Deselect the Check All Layers option to
check only the currently selected layer.

6. Click Done when you’re finished.

The Check Spelling dialog box closes.



Masking, Shaping,
and Warping Type

In This Chapter

v Working with type trans-
parency

v~ Ghosting your type

v~ Creating type selections
v~ Rasterizing your type
v~ Creating type shapes
v~ Warping your type

tions, or paragraphs of text. Type can become an integral
part of the decorative design, especially when you stylize,
warp, or otherwise transform it in interesting ways.

You can do a lot more with type than create labels, cap-

Your Photoshop text can have character, too, communicating
messages with more than just words. The text of a beach scene
can appear to be wavy or watery and translucent. Halloween
type can take on a ghostly or spooky appearance. Type can be
romantic, otherworldly, cheerful, or comical. It all depends on
how you create and apply it.

This chapter shows you some of the tricks you can perform by
masking, warping, and shaping your type so your words come
to life and add something special to your images.

Playing with Type Layer Opacity

Layers are the stacks of overlays on which each of the elements
of your image reside. (Check out Book V, Chapter 1, for the low-
down on layers.) You can change the transparency of a type
layer the same as you can with any other layer in Photoshop,
reducing the opacity (transparency) of the type so it allows the
underlying layer to show through. Take a look at Figure 5-1,
which shows type at varying levels of opacity over an image.
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Figure 5-1 PB’QS are re /
Roses are reg
o " Vea

100% opacity

80% opacity
60% opacity

40% opacity

-

Changing the opacity of a type layer can convey an idea of gradual visibility of words onto an
image. When working with opacity in multiple layers of type, you can create a sort of nonani-
mated fade-in, each with a greater opacity. Figure 5-2 shows an example of this effect.

Figure 5-2
COMING SOO0N!

Coming Soon!
Coming Soon!

One way to alter the transparency of type is to use a layer mask. (Check out Book VI, Chap-
ter 3, for more information on layer masks.) Why would you want to use the layer mask
instead of simply applying a gradient to the type itself? In practice, you can’t apply a gradient
to a type layer until the type is rasterized (as described later in the chapter). By fading the
type with a layer mask, you can customize your fading effect as much as you like and still edit

the text to change the wording, font size, font, or anything else.

The first Putting-It-Together project in this chapter shows you another way to use type opac-

ity to create a ghostly effect.



Creating Fade Effects

To create a “fade out” image, just follow these steps:

Creating Fade Effects 3 5 7

1. Enter the words Fading out slowly (or 5. Select the Linear Gradient from the
other text of your choice) into a new Options bar.
type layer. 6. Click the layer mask’s icon in the
You find out how to enter text in Book Layers palette to make sure it is
IV, Chapter 4. active.
2. Choose Layer~>Add Layer Mask—> 7. Click the right side of the type layer
Reveal All. and drag to the left side.
This creates a mask that can show or Photoshop creates a gradient in the BEHR
hide some of the layer. With Reveal All layer mask that is black on the right v
selected, the layer defaults to showing and fades to white on the left, as Chanrl
everything on the layer without hiding shown in Figure 5-3. That means the i 5
any of it. mask is most transparent on the left
s side (where the mask is white) and
3. Pr;ass D to :Eak; ?urfttbhlat Ehot:i)shop s least transparent on the right side
C(;l?trs are the delault black an (where the mask is black). It reveals
white. more of the original type on the left
4. Choose the Gradient tool from the and fades it out on the right, as you
Tools palette. can see in Figure 5-4 to the left of the
. . . words “Fading out slowly.”
Or press Shift+G until it is active.
Figure 5-3 F d" I Y
ading out siov
; . [
Figure 5'4 J Layers »

Marrnal w | Opaciby: | 100% | *

Lock: ] & ++ & Fill: | 1009 | *

= Q| T f El Fading o...
a6 I:l Farkaround &1

. 0 0 ® &l W]
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Ghosting Your Type

Need some ghostly, semitransparent type?
You can twist, transmogrify, and transform
your text by using Photoshop’s arsenal of
features.

You can create your type from scratch in
an empty document or add the type to an
existing picture or background. For the
heck of it, these steps show you how to
add ghostly writing to an existing image.
Just follow these steps:

n Open the backgrou