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PREFACE

Web designers are always comparing notes with each other, studying the code behind Web
pages they admire, and trying to figure out how to create the latest rollover effects, pop-up
windows, and graphic elements that make a Web page come to life.

As three experienced Web designers, we’ve been playing this game for years, looking over
the shoulders of our colleagues and sharing our best ideas with each other. In our 15+
years of combined experience as professional Web developers, instructors, and authors
(including two other Dreamweaver books), we’ve collected far more than 50 great tech-
niques, and we show you how to create the best ones in this exciting new book.

50 Fast Dreamweaver MX Techniques takes you way beyond Web Design 101 to show you
how to quickly enhance your Web projects with the most sophisticated, visually captivat-
ing designs that are possible on the Web today. We also show you how Macromedia makes
it easy for you to create these features with Dreamweaver. We included a few techniques
related to Fireworks and Flash files because we want to help you get the most out these
programs’ integrated features. Whether you create your own Flash and Fireworks files, or
just use Dreamweaver to pull everything together for your team, this book will help you
take Web design to the next level.

In 50 Fast Dreamweaver MX Techniques, you'll discover the hottest things you can do on
the Web (the things other designers are always asking us to show them how we pulled
them off). Each technique is fully illustrated and carefully described in step-by-step detail
so that you can figure out how to use these cool features right away.

OVERVIEW OF THE TECHNIQUES

The 50 techniques detailed in this book are organized into 10 chapters. You can read them
in any order and jump right into the ones that you are most interested in putting to use
right away. As a general rule, the techniques do not build on each other, meaning you do
not need to learn something from an earlier technique to be able to complete a later one.
However, the first two chapters are designed to ease you into things (if that’s your prefer-
ence). Chapters 1 and 2 cover some of the simpler techniques so that you can enjoy instant
gratification and pick up some of the basics (or get a quick refresher course) before you
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Preface

progress into the more complex techniques that make Dreamweaver such a powerful Web
design tool.

As we've written these techniques, all three authors have drawn on real-world experi-
ence, including their favorite features and elements to show you how to create powerful
features that really work on the Web today. We assume that you have some general knowl-
edge of Dreamweaver, but within each section we explain everything you need to know to
complete that technique and get it done fast. So dive into Chapter 1 or skip ahead to any
chapter and get started right away on that cool feature you always wanted to add to your
Web page.

WHAT COMPUTER HARDWARD AND SOFTWARE WILL YOU NEED?

FOR WINDOWS 9X, WINDOWS 2000, WINDOWS NT4 (WITH SP 4 OR LATER), WINDOWS
ME, OR WINDOWS XP:

m PC with a Pentium processor running at 120 Mhz or faster

m Atleast 32 MB of total RAM installed on your computer; for best performance, we
recommend at least 64 MB

m Ethernet network interface card (NIC) or modem with a speed of at least 28,800 bps
m A CD-ROM drive

FOR MACINTOSH:

m Mac OS computer with a 68040 or faster processor running OS 7.6 or later

m Atleast 32 MB of total RAM installed on your computer; for best performance, we
recommend at least 64 MB

m A CD-ROM drive.

CONVENTIONS USED IN THIS BOOK

To make this book easy to use so that you can recreate the effects, we use a special format
that focuses on the actual steps you need to take to complete the technique. Extraneous
discussion is kept to a minimum.

We break each technique into major steps and explain what the step accomplishes. We
refer you to the files on the CD-ROM you’ll use in the technique. Follow the bullet points
and figures to complete the technique on your own. Bold type designates items with which
you interact and any text or numbers to be typed. Figure numbers also appear in bold
type, as in Figure 2.1. If the figure is shown in the color section, the figure number
includes a color plate number, such as CP 2, in parentheses, so that you can quickly find
the image in color.
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CHAPTER

QUICK WAYS TO
BRING YOUR SITE
TO LIFE

ou can create simple Web pages in any

text-editing program, but Macromedia
Dreamweaver offers features that can help

you bring your site to life better than any

other Web design program on the market.

In this first chapter, I combine some of my favorite tech-
niques to get you started. Follow the simple step-by-step
instructions, and you’ll be well on your way to creating
compelling designs and making the most of your images.
If you're just starting to create a new Web page design,
start with the Tracing Image feature in Technique I.
Tracing images are a great aid when you want to re-
create a design in Dreamweaver that was first created
in a program such as Photoshop or Fireworks. In
Technique 2, you discover one of the most popular tech-
niques in Dreamweaver, simple rollovers, which are
ideal for Web site menus or navigation bars. Rollovers
enable you to change the image when a user’s cursor
rolls over it. In Technique 3, you find out how to link
one image to multiple destinations with Dreamweaver’s
image map tools. In Technique 4, you discover how
well Dreamweaver is integrated with the Macromedia
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thumbnail images linked to larger images.
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USING TRACING IMAGES
TO RE-CREATE DESIGNS
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1.1(CP1)

—

You can find all of the files
used in this technique in the
folder called Technique 1 on
the CD-ROM.

1.2 (CP 2)

racing images are a special feature in Dreamweaver that
enable you to use a graphic to guide you as you build your
page in Dreamweaver, much like you would put thin paper
over a cartoon and re-create it by tracing over the cartoon on
the paper.

Tracing images are a special Macromedia feature created to help you
design your Web pages the way most experienced designers have found
works best, by first mocking up the site design in an image program and
then chopping it into pieces and re-creating it as a Web page in
Dreamweaver.



Here’s how it works. First, design your site in a pro-
gram such as Photoshop or Fireworks, which enables
you to have full design control while you’re in the cre-
ative process. Then, you save your design as an image,
which represents an entire page as it would appear on
your Web site. This is your “mock up” image, which is
great for getting the design the way you want it in a
program like Photoshop, but won’t work well on the
Web where giant images take forever to download. To
optimize your design for the Web, you need to build
it with smaller GIFs, JPEGs, and other elements in
Dreamweaver.

The brilliance of the tracing image comes in here.
You can place this big image “behind” your page in
Dreamweaver, as shown in Figure 1.2 (CP 2). Then,
use it as a guide as you re-create your design on top of
it. You can position layers or create table cells on top
of the tracing image, making it easier to exactly re-
create your design in HTML. You can use JPG, GIF, or
PNG format images as tracing images, and you can
create them in any graphics application that supports
these formats. In Figure 1.1 (CP 1) you see the same
design being created on a blank page, without a trac-
ing image to guide your work.

Tracing images are different from background images.
Tracing images only appear in the Dreamweaver
work area so that you can use them as you design
your page. They will never be displayed in a browser,
so your viewers will never see them on your site and

Chapter 1 Quick Ways to Bring Your Site to Life

you don’t have to worry about what they look like or
if they line up perfectly with your design. In contrast,
background images become part of a page design and
do display in a browser. You can use a tracing image
and a background image on the same page.

STEP 1: INSERT A TRACING IMAGE

A tracing image should be a mock up of your page
design, which you place behind a blank page in
Dreamweaver so that you can re-create it with text,
GIFs, JPEGs, and other elements in HTML.

m Open any existing page or create a new blank
page in Dreamweaver by choosing File > New
and then HTML Page.

m Choose View > Tracing Image > Load.

m In the Select Image Source dialog box, select
the image that you want to use as your tracing
image and click Select to insert it behind the page.

—

If a tracing image doesn’t appear, make sure
that you have a check next to Show when you
choose View > Tracing Image > Show.




Using Tracing Images to Re-create Designs

(T used Tracing-Image.jpg from the Technique 1
folder.)

m Alternatively, you can choose Modify > Page
Properties and use the Browse button next to the
Tracing Image text box to select a tracing image.

m Notice that the Tracing Image text box of the
Page Properties dialog box displays the image
name and its path.

m Use the Transparency slider to set the opacity
for the tracing image. This enables you to “soften”
the tracing image so that you can more easily see
the work you are doing on top of it. I set opacity to
45% in Figure 1.3.

Page Properties FXI

Title:[Jznine Wamer \ ok |
Background Image: |mages/page_backgoundgf | [Broms.. |
Background: [ Cancel
Text: M Wistted Links: [)
Links: || Stive Links: |
LeftMargin: [0 | Magnwidhc 0 |
TepMagin [0 | MagnHeight[0 |

Document Encoding: |Weslem [Latint] V‘ I Reload ]
Tracing Image: |...-’Tracing-|mage.ipg ‘ Browse...
Image Transparency:; H L
e fk e

Document Falder: C:\Dacuments and Settings' anine Warner\My Daoc

Site Folder: C:\Documents and Settings'J anine 'w amerty Doc

1.3

m When you are done arranging the tracing image
and have set the opacity the way you want it, click
OK. The tracing image appears in the background
of the document window.

—

Lowering the transparency level causes the trac-

ing image to fade, making it easier to distin-
guish between the tracing image and editable
elements on the page. You can set the trans-
parency level to suit your preferences, but
somewhere around 50% seems to work well
with mostimages.

—

If you press Return/Enter without the Shift key,
Dreamweaver inserts a <p> tag (paragraph),
which puts a blank line between the logo and
the photograph. Holding down the Shift key
while you press Return/Enter inserts a <br> tag
into the HTML and creates a single line break.




STEP 2: ARRANGE GIFS, JPEGS,
AND OTHER ELEMENTS OVER
THE TRACING IMAGE

With the tracing image in place, youre ready to re-
create your design. You do this as you would create
any page in Dreamweaver, but you have the advan-
tage of having the tracing image as a guide behind
your work.

m With the tracing image in place behind your
page, choose Insert > Image (see Figure 1.4),
browse to find the image you want to use (I used
logo.gif), and select it to insert it on the page. In
this example, I placed the logo on the page and
aligned it over the logo on the tracing image.

m Continuing with this design, choose Insert >
Image and select the photograph that goes below
the logo (in the example, I used Janine.jpg). With
the photograph still selected, use the left arrow key
to move your cursor between the two images and
then hold down the Shift key while you press
Return/Enter to insert a line break. This positions

Chapter 1
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If a tracing image doesn’t appear, make sure
that you have a check next to Show when you
choose View > Tracing Image > Show.

A tracing image doesn’t replace a background
image. The tracing image itself is visible only
when you're editing the page in the document
window; it never appears when the page is
loaded into a browser.
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Using Tracing Images to Re-create Designs

the two images almost exactly over their corre-
sponding images in the tracing image.

m To re-create this entire page design, continue to
place images, text, and other elements on the page.
See Figure 1.5.

STEP 3: PREVIEW IN YOUR BROWSER

m Press F12 on your keyboard or click the Preview
in Browser icon on the Document Toolbar.

m The tracing image does not display in the
browser.

OTHER TRACING IMAGE OPTIONS

You have a few other options with the Tracing Image
feature. Choose View > Tracing Image to reveal the
following:

m Show: Hides the tracing image if you want to
check your work without it being visible but don’t
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Chapter 1

want to remove it. You need to uncheck Show for
the tracing image not to appear in Dreamweaver.
m Align with Selection: Enables you to automati-
cally line up the tracing image with a selected ele-
ment on a page.

m Adjust Position: Enables you to use the arrow
keys or enter X, Y coordinates to control the posi-
tion of the tracing image behind the page.

m Reset Position: Resets the tracing image to 0, 0
on the X, Y coordinates.

Quick Ways to Bring Your Site to Life



CREATING ROLLOVERS
FOR INTERACTIVITY

2.1(CP 3)

—

You can find all of the files
used in this technique in the
folder called Technique 2 on
the CD-ROM.

FETETT —— |

CAN WE SAY. "ROAD TRIP"?

=

ion

2.2 (CP 4)

ne of the most popular places to use rollover effects is

on a Web site’s menu buttons. As shown in Figures 2.1

(CP 3) and 2.2 (CP 4), rollovers call attention to particu-

lar items, visually letting a user know when an item is a

link, for example. You can also use rollovers to provide
additional information when the mouse is placed on a particular item on
the page.

A rollover is comprised of a set of two (or more) images and a JavaScript
behavior. In a simple rollover, there are usually two images: the “oft” state
and the “on” state. For example, you may create menu items that contain
black text on a white background for the “off” state and red text on a white
background for the “on” state. If the rollover behavior is properly applied,
the text looks like it is changing color from black to red when the cursor is
placed over it.



STEP 1: INSERT AN IMAGE AND DEFINE
PROPERTIES

m Choose File > Open and browse to find the file
called Technique2.htm for this technique. This
page has already been built for you with the basic
images in place to maintain proper spacing.

m Click the word Concept at the top of the page
to select the image RTConcept_off.jpg. Delete this
image.

m Choose Insert > Interactive Images >
Rollover Image to display the Insert Rollover
Image dialog box.

m Enter the following in the fields of the Insert

Rollover Image dialog box, as shown in Figure 2.3.

m Name the image in the Image Name text box.
m In the Original Image text box, type the name
of the image, RTConcept_off.jpg, that is first seen
on the page. This is the image to which the
rollover action will be applied. You can also use
the Browse button to select the image.

m In the Rollover Image text box, type the name
of the image, RTConcept_on.jpg, that replaces the

original image when you place your mouse over it.

m Leave Preload Rollover Image checked if you
want your rollover images to load when the page
loads. This ensures that a user won’t have to wait
with his or her mouse over the original image
while the rollover image loads.

Chapter 1 Quick Ways to Bring Your Site to Life

m Enter descriptive Alternate Text that appears
while the original image is loading.

m Enter a URL or a Web page name in the When
Clicked, Go To URL text box if you want this
rollover image to be a link.

m Click OK.

STEP 2: CONFIRM AND TEST

m Click File > Preview in Browser and select a
browser or press F12 on your keyboard if you have
already set up a shortcut to a browser for testing
and previewing.

m The page you are working on opens in a
browser window.

m Place your mouse over the image to test that the
rollover works correctly, as shown in Figure 2.4.

Insert Rollover Image X
Original Image: | images{RTConcept_off jpg | [Browse...]
Rallover Image: | images/RTConcept_on.jpg | [Browse... |
Preload Rollover Image
Alternate Text: | The Concept |
When Clicked, Go Ta URL: | concept.htm | [Browse...
2.3
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SETTING LINKS IN AN IMAGE MAP
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m mage maps, such as the one shown in Figure 3.2 (CP 6), enable
You can find all of the files you to link different sections of the same image to different pages.
used in this technique in the Image maps are used to make single images doorways into multi-
folder called Technique 3 on ple places. Image maps are popular on the Web because they
the CD-ROM. enable you to create hot spots in an image and link them to differ-

ent URLs or Web pages. A common use of an image map is a geographic

map, such as a map of the Earth shown in this example. Each of the hot
spots in Figure 3.2 (CP 6) links to a different page that highlights the dam-
age done by Hurricane Andrew.

Image maps have many uses. For example, if you own a chain of music
stores in California and want to make it easy for customers to find a local
store, you can create hot spots on an image map of California and then link
each hot spot to a page listing stores in that geographic location or linking
directly to a page for the store.

Dreamweaver makes creating image maps easy by providing a set of simple
drawing tools that enable you to create hot spots and specify their corre-
sponding links.
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STEP 1: INSERT AN IMAGE AND OPEN
IMAGE MAP TOOLS

You create an image map by first inserting an image
on a page as you would insert any image. Then, using
Dreamweaver image map tools, you click and drag to
create hot spots over different areas of the image.
Each hot spot can be linked to a different URL.
Follow these directions to create an image map:

m Create a new blank page in Dreamweaver by
choosing File > New and selecting Basic Page
and HTML. Choose Insert > Image or click the
Image icon in the Common Tools panel. Browse
to find the earth.jpg image in the Technique 3
folder.

m Alternatively, you can open the file
Technique3.htm in the Technique 3 folder. This
file has the image already placed on a page.

m If the Property inspector isn’t already visible,
choose Window > Properties to open it.

= Properties

Chapter 1 Quick Ways to Bring Your Site to Life

m Notice that when you select the image, the
options in the Property inspector change to repre-
sent image options. If it’s not already expanded,
click the small arrow in the bottom-right corner
of the Property inspector to reveal all of the image
options, as shown in Figure 3.3. (The Image map
tools are only available when the Property inspec-
tor is expanded.)

STEP 2: CREATE HOT SPOTS ON AN
IMAGE MAP

You can specify the regions in an image map by using
three Shape tools:

m Rectangular Hotspot Tool: Creates a rectangu-
lar area over an image that you can link to another
page.

m Oval Hotspot Tool: Creates an oval area over an
image that you can link to another page.

<
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Setting Links in an Image Map

m Polygon Hotspot Tool: Creates a custom shape
over an image. To make a polygon selection (such
as one over the state of Florida in the example),
click the tool once for each point of the polygon
shape you want to draw. Then, to close the shape,
click again on the first point you drew after you
finish drawing all the other points.

m Click the Shape tool you want from the
Property inspector, and then click and drag on the
image to create a hot spot. In this example, I used
the Oval tool to create hot spots over the hurricane
and over the other tropical storm area, as shown
in Figure 3.4.

m To create a hot spot in an unusual shape, such
as the hot spot over Florida in this example, click
the Polygon tool and then click and draw around
the outline of the area you want to make hot, end-
ing at the original point to complete the hot area.

15

m To reposition a hot spot or change its size, click
the Arrow tool from the Property inspector. To
resize a hot spot, click any of the small resize han-
dles at the edge of the image and drag to the
desired size. To reposition, click in the middle of
the hot spot and drag to move the entire hot area.

STEP 3: SET LINKS IN AN IMAGE MAP

m Click to select a hot spot and then click in the
Link text box in the Property inspector.

m Type the URL to which you want the hot spot
to link.

m You can also use the Browse button, the small
folder icon to the right of the Link text box in the
Property inspector. Click the Browse button and
navigate to find the page to which you want to
link. Click to select the page and then click OK.
The path and page name appear automatically in
the Link text box.

You can go back at any time and change the
links in an image map by clicking the blue
region that indicates a hot spot and entering a
new URL.







TECHNIQUE

EXPORTING A LAYOUT FROM
FIREWORKS INTO DREAMWEAVER
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4.1 (CP 7) 4.2 (CP 8)

—

You can find the Fireworks
file used in these steps in the
folder called Technique 4 on
the CD-ROM.

any designers use Fireworks and Dreamweaver

together, creating a layout image in Fireworks and then

exporting it to a file that can be easily integrated into a

site created in Dreamweaver. In Figure 4.1 (CP 7), you

see a layout as it appears in Fireworks before it’s
exported. In Figure 4.2 (CP 8), you see the same layout as it appears in
Dreamweaver.

Exporting from Fireworks to Dreamweaver is a timesaving solution if you
prefer to do your design work in a graphics-editing program, such as
Fireworks and don’t want to manually slice it into pieces and then reassem-
ble it in Dreamweaver. A more complex layout may require some tweaking
after you export it to HTML, but more often than not, the time you save is
significant.

I provide a sample Fireworks file on the CD-ROM called Technique4.png.
However, you can create your original layout in Photoshop or Fireworks. If
you create a layout in Photoshop, simply open the .psd file in Fireworks
and proceed from there.
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STEP 1: SLICE YOUR LAYOUT FOR
OPTIMUM FILE SIZE

m In Fireworks, select the Slice tool.

m “Slice” your layout into small pieces. Position
the crosshair cursor where you want to begin your
slice and then click and drag diagonally to com-
plete the slice. Each slice is highlighted in green by
default. Figure 4.3 shows the logo in the upper-
left highlighted. Repeat this step until you have
sliced the entire layout.

Some slicing hints: When slicing a layout, it’s a good
idea to keep areas with similar colors together as a
slice or set of slices. For a menu, select the entire area
that you want to see as a button on your finished page.
Finally, try to run the slices edge to edge with each
other. If you leave spaces between one slice and
another, Fireworks creates many tiny default slices.

STEP 2: OPTIMIZE EACH SLICE

Optimizing each slice ensures the fastest load time
possible for your Web page.

B Cafe Ole.psd® 100% (Slice)*
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m Click aslice.

m In the Fireworks Property inspector, choose

the type of slice you want to use: Image or HTML.
If this slice does not contain an image, you can
choose HTML from the Type menu. If it is an
image, choose Image and then the most appropri-
ate type of optimization (GIF, JPEG, and so on), as
shown in Figure 4.4.

STEP 3: EXPORT TO HTML

As soon as you determine properties for all your slices,
you can export the entire layout to HTML.

m Click File > Export. The Export dialog box
appears, as shown in Figure 4.5.

m Browse to find the directory in which you want
to save your new HTML page.

m Give your page a name, such as
technique4.htm, for example.

m Save as type: HTML and Images.

m HTML: Export HTML File.

m Slices: Export Slices.

® You can also determine if you want to export
only some specific slices or areas without slices
instead of the entire layout. This is handy when
you've already exported the entire layout before,
and just want to update the content of one slice.

—

You can turn off the Slice Overlay view by using
the Show Slices toggle button, located under
the Slice Tool button, or by clicking the eye icon
next to the first layer, the Web Layer, in the
Layers palette.




Exporting a Layout from Fireworks into Dreamweaver

m If you want to save your images to a subfolder,
check Put Images in Subfolder and click to
browse for the appropriate folder. Otherwise,
leave this option unchecked.

m Click Save.

Export @

Save in; | 29 Technique 4 v| € ? 5 [
[C)images

File: name: |technique4{htm | [ Save
|
Save az type: | HTML and Images w | [ Cancel

HTML: [ Export HTML File v| [ optons.. |

Slices: |Exp0rt Slices b/ |

[ Selected Slices Only [ Current Frame Only
Include Areas without Slices
Put Images in Subfolder

Browsze. .. images/

4.5

GiIF 'web 216
GIF WebSnap 266
GIF webSnap 122
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STEP 4: OPEN THE HTML PAGE IN
DREAMWEAVER

Now you can view the new HTML file in Dreamweaver
and make any necessary changes.

m In Dreamweaver, click File > Open to browse
for the new page. The completed file is in the
Technique 4 folder. It is named technique 4.htm.
m Select the file and click Open. As you can see,
your layout looks just as you created it in
Fireworks. Each slice is now its own image within
the HTML layout, as shown in Figure 4.6.

—

When slicing a layout, try to keep parts of the
layout that contain a gradient together as one
slice or a set of slices, and set the optimization
for those slices to .jpeg in the Optimize panel.
Slices containing solid colors or a combination
of colors with no gradients can be optimized in
.gif format. You can preview the quality of an
optimized slice by clicking the Preview tab at
the top of the image file. Fireworks displays your
layout the way it will look after optimization has
been performed. Play with the different opti-
mization settings to get familiar with the results
on different parts of the layout.

GiIF Adaptive 256

| Slice Tupe:

|CafeDlerie| | p@ w
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CREATING A LINKED IMAGE GALLERY
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You can find all of the files
used in this technique in the
folder called Technique 5 on
the CD-ROM. Look for the
page called Technique5.htm
to see the image gallery
page.

5.2

linked image gallery, such as the one shown in Figure 5.2, is
an ideal way to display multiple images on one page. Because
of long download times and the limited display area on a
computer screen, placing too many large images on one page
is problematic. Instead, try arranging several smaller images
on a page and then linking them to larger versions of the same images, each
on its own page.
In this example, photographs of Sedona are displayed as small images on
the main page with links to larger images, each on its own page that
includes descriptions and other information.

STEP 1: CREATE AN IMAGE GALLERY

You can use a linked image gallery for any collection of images, from paint-
ings to photographs to clip art. Follow these instructions to place your
images on a page and link them to other pages.

21
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m Open any existing page or create a new blank
page in Dreamweaver by choosing File > New
and then Basic Page and HTML Page.

m Choose Insert > Table and specify the number
of columns and rows. In this example, I created a
table that is two rows by three columns so that I
could place each of the photos I took in Sedona in
its own table cell.

m Click to insert your cursor in the first table cell,
choose Insert > Image, browse to find the image
you want to use, and select it to insert it in the
table cell.

m Click to insert your cursor in the second table
cell, choose Insert > Image, browse to find the
image you want to use, and select it to insert it in
the table cell.

m Continue inserting the thumbnail images until
all of the small images are in their own cells in the
table.

STEP 2: SET LINKS FROM THE IMAGE
GALLERY TO LARGER IMAGE PAGES

Before you can link the small images to their corre-
sponding pages, you need to create those pages. By
that T mean creating a separate HTML page for each
larger version of the image so that you can link the
smaller images to the HTML page that contains the

You don’t have to create a table when you create

an image gallery, but it is an excellent way
to organize images and control the spacing
around them.

Chapter 1 Quick Ways to Bring Your Site to Life

larger image. Then, create a page that displays all of
the smaller images and set links from the smaller
images to the pages that contain the larger images.

m Click to select the first thumbnail image (see
Figure 5.3) and then use the Browse button (the
small folder icon to the right of the Link text box
in the Property inspector) to locate the page to
which you want to link. In Figure 5.4, I'm setting
the link to the first thumbnail.

m Repeat this for each small image. See Figure 5.5
for the finished Web page.

7 Image, 10K W80 | S festsedonald_JPGipg €305

e
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Creating a Linked Image Gallery
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CHAPTER

TIMESAVING
TECHNIQUES YOU
CAN USE TODAY

uilding and maintaining a Web site can be

an extraordinarily time-consuming proj-

ect. When I first started building Web

sites, everything had to be done manually,

from writing HTML code to fixing bro-
ken links and organizing the files and folders that make
up a site’s structure. When Dreamweaver came on the
market, I was excited because I immediately saw the
timesaving benefits of this great program. Now, several
years and a few upgrades later, Dreamweaver is a com-
prehensive program with a broad range of features
designed to save you time and make Web design easier
than ever before.

In this chapter, you find some of Dreamweaver’s most
valuable and timesaving techniques, from automatically
finding and fixing broken links to developing a template-
driven site. You also find out how to clean up cluttered
code, gain quick access to site assets, and how to organ-
ize your files and folders without breaking any links.
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FINDING AND FIXING BROKEN LINKS
AUTOMATICALLY

€} Macromedia Dreamweaver MX - [Coastal Images (Coastal site/index*)] EEX #) Macromedia Dreamweaver MX - [Coastal Images (Coastal site/index*)]
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m he broken link on this page of nature photos is easy to fix

with Dreamweaver’s link checking feature.

used in this technique in the Broken links are one of the most embarrassing problems
folder called Technique 6 on you can have on a Web site. Links can get broken so easily:
the CD-ROM. To follow these Just move a file, change a filename, or link to another Web
site that disappears, and you have a broken link. Broken links become espe-
cially problematic as a Web site grows and gets more complex.

Nothing can turn your users off faster than coming upon a page with a
broken image link, such as the one shown in Figure 6.1 (CP 9) or clicking a
link and getting a “File Not Found” error page (also known as a “404 error”
because that’s usually the message viewers see if they click a broken link).
Fortunately, Dreamweaver offers a few features designed to help you find
and fix broken links, even on large, complex Web sites.

You can find all of the files

steps with the provided
files, look for the file called
Technique6.htm.
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STEP 1: FIND BROKEN LINKS

Before you can fix a broken link, you have to identify
that it’s broken. Some links, such as the broken image
link shown in Figure 6.1 (CP 9) are easy to spot, but
broken links to other pages can go unnoticed if you
don’t test your links regularly yourself. Follow these
steps to use the Dreamweaver Link Checking feature
to easily identify broken links in a page or Web site.

m Make sure the site you want to work on is
selected and that you have at least one page of the
site open in the Dreamweaver work area. You can
do this by selecting the site name from the pull-
down menu at the top of the Site panel and choos-
ing the site you want to work on from the list.

m From the Site panel, choose Site > Check Links
Sitewide (see Figure 6.3). You can also check the
links on a single page by opening that page and
choosing File > Check Links.

Mews Site., .,
Edit Sites...

Get Ctrl+Shift+D

Put Chrl4+-Shift+U

Cloaking 3
Reports...

Check Link: e Chrl+F8

Change Link Sitewide. ..
Synchronize. ..

Recreate Sike Cache
Remaove Connection Scripts

Set as Home Page

Expoark...
Irnpotk...
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m Whether you check a single page or the entire
site, the Check Links Results panel opens at the
bottom of the page, just under the Property
inspector, as shown in Figure 6.4. The dialog box
displays a list of filenames with broken links, as
well as any pages, images, or other items that are
not linked to any other pages in the site. This is
handy if you want to clean up old images or other
elements that you are no longer using on the site.

STEP 2: FIX BROKEN LINKS

As soon as you identify which links are broken, you
are anxious to fix them. Dreamweaver enables you
to correct broken links right from the Link Checker
Results panel. Simply identify the correct link, and
Dreamweaver automatically fixes it for you.

After using the Link Checker, described in the pre-
ceding step, to identify broken links, follow these
steps to use the Results panel to fix them.

—

If you like keyboard shortcuts, use 8/Ctrl+F8 to
Check Links Sitewide and 8/Ctrl+F8 to Check
Links on the page you are viewing

—

You can save the Link Checker’s report by click-
ing the Save Report button (the small floppy
disk on the left-hand side) in the Link Checker
panel. This is handy if you want to be able to
refer to it later, print it out, or share it with some-
one else who works on your Web site.




Finding and Fixing Broken Links Automatically

m With the Results panel open at the bottom

of the page, double-click a filename that
Dreamweaver has identified as a broken link to
open the page and its corresponding Property
inspector. The Results panel should remain visi-
ble. (If you are checking the links on a single page,
you can skip this step.)

m In the Results panel, click to select a broken link
or broken image, and then click the folder icon to

the right of the filename.

The link checking only works in local mode,on a
local site. A broken link that is external (i.e., to an
image or page that is outside the main folder of
your site, such as a file on another Web site) can-
not be identified by Dreamweaver's Link
Checker. Dreamweaver does help you identify
potentially broken links by creating a list of
external links that appear in the selected docu-
ment or Web site.

29

m Navigate to find the page or image file to which
the link should go, click to select it, and then click
OK. The link is automatically fixed. If it was a bro-
ken image link, the image reappears in the work
area, as shown in Figure 6.5. If it was a broken page
link, when you preview the page in a browser, the
link works.

m If you already know the location of the file to
which you want to link, you can type the correct file-
name and path in the File name text box or browse
to find the image. The correct image must be in a
folder that is accessible to the site’s root folder.

m You fix links to pages just like you fix links to
images, except you type the name of the correct
file into the Link text box or click the Browse but-
ton next to it to find the file in your site folder.

m If you are fixing a link to a page on another Web
site, you must enter the URL manually in the link
SRC text box of the Property inspector.

m If the link that you correct appears on multiple
pages, Dreamweaver prompts you with a dialog
box asking if you want to fix the remaining broken
link references to the file. Click Yes to automati-
cally correct all other references. Click No to leave
other files unchanged.
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" | {links to files not Found on local disk)

Files
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CREATING A TEMPLATE-BASED

WEB SITE
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For this technique, use
TechniqueZ.htm in the folder
Technique 7 on the CD-ROM.
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&

7.3 (CP 13)

orking with templates can save you a lot of time if

you have to create many pages with the same ele-

ments. Figure 7.1 (CP 11) shows the template used

to create the Web pages shown in Figures 7.2 (CP 12)

and 7.3 (CP 13). Not only does working with tem-
plates speed up the page creation process, but also, when the time comes to
make changes to some of the elements that appear on every page, you only
have to make those changes once.

To follow through with this technique, you can use the sample page on
the CD-ROM referred to here or create your own page to use as a template.
I use the sample page here, which was created by using Fireworks and
Dreamweaver.
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STEP 1: PREPARE THE PAGE TO SERVE

AS A TEMPLATE

m Choose File > Open and browse to find
Technique?7.htm.

m Choose File > Save As Template. The Save As

Template dialog box appears.
m Click to select your local site from the list.

m Enter a name for your template and click Save.
See Figure 7.4. Dreamweaver saves your template

with a file extension of .dwt, and automatically

—

You must already have defined a local site in
Dreamweaver in order to create templates for it.

—

After you create a template file, you can access it
at any time through the Assets panel. Choose
Window > Assets to open the panel, and then
click the Templates icon to see all of the tem-
plates associated with this site. See also
Technique 9, “Accessing URLs, Colors, and
Images Assets.”

Save As Template

3

Site: |Technique 7 ~ | [ Save
|
Exizsting Templates: Cancel
Save Az | productpage | [ Help

7.4
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creates a folder called Templates in your local site
directory to store this and any other templates you
create for this site.

STEP 2: DEFINE EDITABLE REGIONS

Editable regions are the areas of template-based pages
that you can change on the “child” pages created from
the template. Locked regions are only editable on the
template master page, which has a filename that ends
in .dwt.

—

m On your template, click to select an area you
want to make editable. I selected the section title
graphic — the part that includes “Graphic Design
Books” — because I want to be able to change this
graphic title depending on the section of the site
on which 'm working.

m Choose Insert > Template Objects > Editable
Region. The New Editable Region dialog box
appears. Enter a name for this editable region and
click OK. See Figure 7.5.

If you've selected a region but don't see the col-
ored box or the region name, choose View >
Visual Aids on the main menu. The choice
Invisible Elements should be checked.

Newr Editable Region

1
b

Mame: | SectionTitle

X
|

his reqgion will be editable in documents
ased on this template,

7-5



Creating a Template-Based Web Site

m The selected region now appears inside a col-
ored box, with the region name on the top-left
corner. See Figure 7.6.

m Follow these steps for every region you want to
make editable on your template. See Figure 7.7 for
an example of a finished template.

m Choose File > Save.

STEP 3: CREATE A PAGE USING
THE TEMPLATE

Now that you defined your template, or master page,
you can create any number of pages based on this
template.

—ad

Notice that the graphic header and menu area is
not defined as an editable region. That means
this area is locked to users editing the template-
based pages. You should only define as editable
regions parts that will change from page to

page. You should keep locked such features as
navigation, header logo, or graphics and copy-
right information.

SectionTitle

7.6
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m Open a new page in your site by choosing
(88/Ctrl+N). Click the Templates tab, highlight
your site and the template name that you want to
use (in this case, productpage), and click Create.
Then save the page using As. Enter the page
name, including .htm at the end; otherwise,
Dreamweaver will not open it later on.

m Choose Modify > Templates > Apply
Template to Page. Select the template named
productpage from the list and click Select. The
template’s content appears on this new page. A
yellow border and tab let you know this page is
attached to the template named productpage. The

—

You can make text region editable by selecting

the cell in which you want to be able to add or
edit text. Select the cell by clicking the appro-
priate <td> tag at the bottom of the screen.
When the cell is selected, you can follow Step 2
to make it an editable region.
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editable regions are highlighted in blue as they
were in the template master page. The menu
appears locked when you place your mouse cursor
over it. See Figure 7.8.

m Type the content into the editable regions and
insert images into any region that requires an
image. See Figure 7.9.

m Follow these steps to create as many template-
based pages as needed.

STEP 4: EDIT THE TEMPLATE AND
UPDATE ALL PAGES

If you make any changes to the template file,
Dreamweaver will update all attached pages in one
easy step.

m Open the template productpage.dwt.
m Change the link on the “Contact Us” menu
graphic from contact.htm to contactus.htm.

— Al

If you decide later that you don’t want the
template to be attached to a certain page, you
can easily detach the template by clicking
Modify > Templates > Detach from Template.
The page loses all template properties and
become a regular HTML document. All regions
that were previously locked become fully
editable.

Chapter 2 Timesaving Techniques You Can Use Today

m Choose File > Save. The Update Template Files
dialog box appears, listing all the pages that are
attached to this template. If you want to update all
files, click Update. To update only some files,
select the files you want to update and then click
Update. See Figure 7.10.
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REMOVING EMPTY TAGS AND
JUNK CODE
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You can find all of the files
used in this technique in the
folder called Technique 8 on
the CD-ROM.

irtually all visual Web design programs have a tendency to

litter your document with unnecessary code, as shown in

Figure 8.1. It’s the price you pay for the push-click conven-

ience they offer. While usually harmless, junk code and

empty tags can often cause unwanted white space, unpre-
dictable formatting of images and text, as well as larger file sizes. This junk
code doesn’t contribute anything to your Web site, and it also makes your
code harder to read.

Unwanted code appears for a number of reasons. If you're editing format-
ted text and moving blocks of text around, you may unintentionally
produce empty font tags or bold/italic tags. This is most likely to happen if
you primarily use the Design View mode to build your Web pages because
your eyes are not immediately on the code. You can flip to Code View
and remove these tags by hand, but this is time-consuming. Luckily,
Dreamweaver MX comes packed with powerful tools to assist you in clean-
ing up this unwanted code in a matter of clicks without compromising the
integrity of your Web pages, as shown in Figure 8.2.
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STEP 1: MAKE A BACKUP VERSION

Backing up your work is a good idea before you dab-
ble with this technique, just in case the cleanup tools
remove code that you want to keep.

m Choose File > Save As (88/Ctrl+Shift+S) to
save a new copy of your document. Give the new
document a different name and click Save.

STEP 2: SPECIFY THE CLEANUP TYPE

Dreamweaver MX offers two automated code clean-
ing utilities: Clean Up HTML and Clean Up Word
HTML. Both commands offer slightly different fea-
tures, which are outlined here. If your file was created
with Microsoft Word, run the Clean Up Word HTML
command first.

—EGd

Junk tags aren’t limited to Dreamweaver MX. If
you converted a Microsoft Word document into
an HTML file, you'll find a library of unique (and
often unnecessary) tags. Software by Adobe usu-
ally leaves behind comments containing name
and version numbers of its software.

— il

The Clean Up Word HTML command also works
wonders on other Microsoft Office products,
including HTML files generated by PowerPoint,
Excel,and Access.

Chapter 2 Timesaving Techniques You Can Use Today

m Choose Commands > Clean Up HTML.

m The Clean Up HTML/XHTML dialog box,
shown in Figure 8.3, appears with the most
common options already selected.

® You can turn on three additional code-cleansing
features by checking Non-Dreamweaver HTML
Comments, Dreamweaver Special Markup, or
Specific Tag(s). When you specify tags, keep in
mind that Dreamweaver removes every instance
of that tag— not just the unwanted ones. Keep
Show Log on Completion checked to see the
results of the command immediately.

m Alternatively, choose Commands > Clean Up
Word HTML.

m The Clean Up Word HTML dialog box (see
Figure 8.4) displays two tabs: Basic and Detailed.
Click the Basic tab, and you find most of the fea-
tures from the Clean Up HTML menu, plus two
unique options: Remove All Word Specific Markup
and Clean Up CSS. Click the Detailed tab to reveal
various parameters for both of these options.

m Choose the version of Word that created this
document from the Clean Up HTML menu, as
shown in Figure 8.4.

Clean Up HTML / XHTML X

Remave: Empty Container Tags {(<b=<jb=, <hl=<fh1>, ...}
Redundant Mested Tags
Non-Dreamweaver HTML Comments;

D Dreamweaver Spedial Markup

] —

Options: Combine Nested <fere>Tags when Possible

Show Log an Campletion
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Removing Empty Tags and Junk Code

m Check Remove all Word Specific Markup to
remove HTML tags that contain Word-specific
XML, VB Script code (if/then tags), and original
Word formatting tags.

—Gd

When removing CSS, your fonts will usually be
affected, and the positioning of images and
paragraphs may shift.

Clean Up Word HTML X

J Basic | Detailed oK
Clean Up HTML from |Word 20002002
[7| Remove all Word |Word 87/38

¥ Clean up €SS Word 2000/2002
lean up <font> tags

V! ci font= ta

¥ Fix invalidly nested tags

¥ Set background color | #FFFFFF

¥ Apply source formatting

[+ Show log on completion

—

m Check Clean up CSS to remove style sheets
generated by Microsoft Word.

37

You can save yourself a lot of work by saving
Word files as “HTML filtered,” which reduces the
amount of Word-specific markup, although it
still leaves a fair share. If you intend to continue
editing a document in Microsoft Word, these
tags may be necessary to keep.

—

8.4

A standard set of styles is generated with every
Word HTML document — styles that specify the
font size, how paragraphs are spaced, how bul-
lets appear, and so forth. There are often as
many as 30 styles defined even if your docu-
ment has no formatting and consists of only one
sentence. These tags, which usually start with
MSO, can be removed safely and replaced with
more efficient formatting by using Dreamweaver
MX'’s Styles or traditional style sheets.
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STEP 3: INITIATE THE CLEAN UP

m Within the dialog box, select the check boxes
that best fit your filtering criteria. Click OK to
execute the Clean Up HTML command.

m Alogappears showing you how many tags were
removed and consolidated. Click OK to close the
log. See Figure 8.5.

The cleanup is now complete. You may find your
document dramatically changed or not changed at
all— this is all contingent on how much “junk” there
was initially and how many cleaning options you
chose. If the cleanup produced unwanted results,

Macromedia Dreamweaver MX fX|

T Clean Up Word HTML Results:
! 1 Meta Tags Removed
52 Instances of Word ¥ML Removed
2 Empty Paragraphs Removed
21 Margin Defines Removed
104 Waord-only "mso” Styles Removed
Source Formatting Applied

8.5
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simply choose Edit> Undo (8/Ctrl+Z) to move
back one step. You can repeat this process without
consequence as long as you don’t save your document.

In some cases, the Cleanup HTML commands miss
certain tags, markup, or CSS references. You can take
various steps to remove these additional tags. Your
best do-it-yourself utility is the search-and-replace
option found under the Edit menu. You can specify
an unwanted tag, its parameters, and have it removed
by leaving the “replace” field blank. Of course, you
can also switch to Code View, highlight the unwanted
tags, and use your trusty delete key. Just remember
that tags open and close, so hunt them down in pairs
and check back in Design View on a regular basis to
make sure you didn’t remove anything important.
Dreamweaver MX highlights orphan tags in yellow if
you miss any.

If you are working on Web pages with a program-
mer, be cautious when applying these commands to
pages containing custom code. While Dreamweaver
MX may find incomplete or redundant tags, this is
often done on purpose (especially if conditional
loops, such as if/then statements, exist on the page).
Even if the file seems to work after you run these com-
mands, it’s wise to save a copy of the original prior to
cleaning the file of unwanted tags. Of course, you can
always ask your programmer to clean the code for you
while you move on to the next technique!



ACCESSING URLS, COLORS, AND

IMAGES ASSETS
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You can find all of the files
used in this technique in the
folder called Technique 9 on
the CD-ROM.
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he Assets panel boasts many great features, including easy

access to the URLs, Colors, and Images panels, shown in

Figures 9.1 (CP 14), 9.2 (CP 15), and 9.3 (CP 16), respec-

tively. Dreamweaver automatically collects every image, link,

and color you use in your site and stores references to them
in these handy asset panels where they are easy to access when you want to
add any of these elements to your pages.
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Each Assets panel has two display options, one that
lists every element and another where you can specify
your favorites. For example, if you add the images
you use more frequently to the Favorites list, you
won’t have to search through a list of every image on
your site when you want to use them.

STEP 1: USING IMAGES ASSETS

Dreamweaver automatically stores all of the images
in the folders in your site in the Images Assets panel,
where you can apply them to your pages with drag
and drop ease. The other advantage of the Images
Assets panel is that it provides a thumbnail preview
of each image, so if youre trying to remember what
you called an image, you get a reminder in the pre-
view area at the top of the Images Assets panel, as
shown in Figure 9.4. To use the Images Assets panel,
follow these steps.

m Click the Assets tab from the Files panel group
in the panels that appear in the right of the
Dreamweaver work area. Then, click the Images
icon at the top-left of the Assets panel. The images
in your site appear in a list in the main area of the
Images panel.

m You can reorder images by filename by clicking
Name, by size by clicking Size, and by file type by
clicking Type.

m To insert an image on a page, simply open the
page in the main work area of Dreamweaver, click
the filename in the Images Assets panel, and drag

Chapter 2 Timesaving Techniques You Can Use Today

it onto the page. Dreamweaver automatically
inserts the image on the page. You can then
change the attributes of the image in the Property
inspector.

m To add an image to the Favorites section of the
Images Assets panel, right-click the image name and
choose Add to Favorites, as shown in Figure 9.4.
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Accessing URLs, Colors, and Images Assets

STEP 2: ADD COLOR ASSETS

When you apply a color to text or links on your
pages, Dreamweaver automatically stores those colors
in the Colors Assets panel. The beauty of this is that
you don’t have to remember exactly what color you
used when you want to apply it to another element:
You can simply open the Colors Assets panel and
drag it from the list onto the page.

To apply a previously used color to text on a page by
using the Colors Assets panel, follow these steps.

m Click the Assets tab from the Files panel group
in the panels that appear in the right of the
Dreamweaver work area. Then, click the Colors
icon, second down in the row at the top left of the
Assets panel. The Colors panel opens, and all of
the colors used in your site appear in a list in the
main area of the Colors panel.

—

If you don’t see all of your images or other ele-
ments in the Assets panel, click the Refresh icon
(the circular arrow) at the bottom right of the
Assets panel. If you still don’t see all of your
assets, try exiting Dreamweaver and then start-
ing the program again. When you add new ele-
ments, Dreamweaver needs to restart to “find”
them and include them in the Assets panel.
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m To apply a color to text on a page, simply open
the page in the main work area of Dreamweaver,
highlight the text or link to which you want to
apply the color, click the color name in the Colors
panel, and drag it onto the text in the work area.
Dreamweaver automatically inserts the color
onto the page. You can then change the attributes
of the color in the Property inspector. (Figure 9.5
shows the Colors panel with a color applied to text
on a page.)

m To add a color to the Favorites section of the
Colors Assets panel, right-click the color and
choose Add to Favorites.

STEP 3: APPLY URL ASSETS

One of the most convenient features of the Assets
panel is the automatic collection of URLs. This is
especially useful for external links because it can save

If you use CSS to specify color and then you apply
a color from the Assets panel, it will override the

style sheet. You should only do this if you're sure
you want to use a special color that is distinct
from your style sheet. Of course, if you don’t use
CSS, you don't have to worry about this.
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your having to look up addresses when you want to m Click the Assets tab from the Files panel group
link to the same place again. Every time you create a in the panels that appear in the right of the
link in your Web site, Dreamweaver automatically Dreamweaver work area. Then, click the URLs
stores the URL in the URLs Asset panel. To apply a icon, which looks like a chain link and is third
URL to a page by using the URLs Asset panel, follow down in the row at the top left of the Assets panel.

these steps. The URLs panel opens, and all of the URLs used
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in your site appear in a list in the main area of the or image in the work area. You can also click the
URLs panel. Apply button at the bottom of the Assets panel.
m To apply a URL to an element, such as text or Dreamweaver automatically creates the link, as
an image on a page, open the page in the main shown in Figure 9.6.
work area of Dreamweaver, highlight the text or m To add an URL to the Favorites section of the
link to which you want to apply the URL, click the URLSs Assets panel, right-click the URL and

URL in the URLs panel, and drag it onto the text choose Add to Favorites.
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m reamweaver’s Site panel is a wonderful timesaver because it

automatically adjusts links when files are moved in a Web
used in this technique in the site, as shown in Figures 10.1 (CP 17) and 10.2 (CP 18).
folder called Technique 10 As Web sites grow, they can get increasingly compli-
on the CD-ROM. cated to manage. Many Web designers start by putting
all of the main files in a site in one folder. Then, one day they realize that it’s
getting hard to find the file they want to work on because they have one
really long list of files in one folder. That’s the day they think, hey, I'll just
create some new folders and move files into them to organize the site. But
the files in a Web site can’t just be moved around like the files on your hard
drive, because they are all interconnected with links that get broken if you
move them around by using the system options on your computer.

That’s where Dreamweaver’s Site panel becomes an incredible timesaver.
If you create new folders or move files around by using the Site panel,
Dreamweaver automatically fixes any corresponding links.

You can find the sample site
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STEP 1: SET UP A WEB SITE

Before you use Dreamweaver’s site management fea-
tures, you have to set up your site in Dreamweaver.
This preliminary step should be done before you start
doing any work on a Web site, but because it’s crucial
to being able to use the features described in this
technique, you find instructions for setting up a site
in the following steps. If you have already set up your
site, skip ahead to Step 2, Create New Folders.

To set up a Web site in Dreamweaver, follow these
steps.

m Click the Site tab from the Files panel in

the panels that appear in the right of the
Dreamweaver work area.

m From the pull-down menu in the top left of the
Site panel, choose Edit Sites. In the Edit Sites dia-
log box that appears, choose New.

m In the Site Definition dialog box, shown in
Figure 10.3, enter a name for your site next to
Site Name. You can call your site anything you
want. This name appears only in the list of sites in
Dreamweaver’s Site panel and is used to help you
distinguish between sites if you use Dreamweaver
to manage multiple sites.

m Click the Browse button to the right of the
Local Root Folder field in the Site Definition dia-
log box, shown in Figure 10.3, and navigate your
hard drive until you find the folder that contains
your Web site. Click the name of the folder and
then click Select. (If you use the example included
on the CD, you should select the folder called
“Disorganized site.”)

Chapter 2 Timesaving Techniques You Can Use Today

Keep all of the files and folders that make up
your Web site in one main folder on your hard

drive. That way, when you transfer the files to a
Web server, you can keep all of your files in the
same relative location, meaning they stay in the
same place relative to each other —a crucial
element in keeping links functional.

Site Definition for, Nature Site

Basic | Advanced |
Categary Local Info
Local Info
Remate Infa o
Testing Server Site Mame: ‘Nalura Site |
Closki
Dg;g‘:%q ates Local Root Folder: ‘C \Mature Sitel | o
Site Map L. t
Fil\:\l'ieax C?\JUD;nS Refresh Local File List Automatically
Drefault Images Folder ‘E WMature Sitehimagesh | =]
HTTP Address: [hiip:/ A |
This address enables the Link Checker to
detect HTTP links that refer ta your awn
site.
Cache: [¥]Enable Cache
The cache maintains file and asset
infarmation in the site. This speeds up the
Azzet panel, link management, and Site Map
features
oK 1 [ Cancel l [ Help
10.3



Organizing Files and Folders without Breaking Links

m Click the Browse button to the right of the
Default Images Folder field in the Site Definition
dialog box, shown in Figure 10.3, and navigate
your hard drive until you find the folder that con-
tains the images in your Web site. Click the name
of the folder and then click Select. If you use mul-
tiple folders for your images, you can skip this step
or select the folder that holds the most images.
Dreamweaver assumes the folder you select is
where your image files are located unless you
specify otherwise.

m Specify the URL if you have a domain set up for
your site. Make sure the Enable Cache box is
checked and click OK.

The other options listed under Category, including
Remote Info, are not required to use the site manage-
ment features described in this technique but are
necessary if you want to use other Dreamweaver fea-
tures, such as FTP capabilities, which enable you to
transfer your files to a Web server.

STEP 2: CREATE NEW FOLDERS

Before you can start organizing a growing site, you
want to create new folders, and you want to do that in
the Site panel so that Dreamweaver can help you keep
track of these folders and the files you will move into
them.

In the sample site used in this technique, you see a
simple Web site with all of its files in the main folder of
the site, as shown in Figure 10.4. You can organize the
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You should not use spaces or special characters in
file or folder names in a Web site because many
Web servers do not support these filenames.
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site. by adding folders and moving the files into
subfolders. This is a great step to take when you expect
your site to grow and you want to create folders for
related pages so that they are easier to find in the
future. You can use Dreamweaver’s site management
features with a small site, such as the one shown in this
example, as well as with a much larger site.

To create new folders in a Web site, follow these
steps:

m Click the Site tab from the Files panel group
and make sure the Site pull-down menu specifies
the site on which you want to work. Also make
sure that the main folder of your site is selected
(highlighted) in the main area of the Site panel.

m From the Site panel (not the main menu) choose
File > New Folder, as shown in Figure 10.5, and
then name the folder.

— il

Before you start making significant changes to a
Web site, such as creating new folders and mov-
ing files around, it’s always a good idea to save a
backup copy of the entire site.

Chapter 2 Timesaving Techniques You Can Use Today

m To create additional folders, choose File > New

Folder, as shown in Figure 10.5, and then name
the folder.

P

Site | Assets

Filew | Edite Yiew- Site-
ew File Chrl+Shift+r
Mew Folder Clrl+Alk+Shift-+

Open e w |

Turn OFf Read Only

Prewview in Browser »
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Organizing Files and Folders without Breaking Links

STEP 3: MOVE FILES INTO NEW OR
DIFFERENT FOLDERS

In the sample site shown in this technique, I created
separate folders for the pictures of the ocean and the
pictures of the desert. The next step is to move files
into those folders to organize the site, as shown in
Figure 10.6.

Follow these steps to move files into folders and
automatically adjust any related links.

ore

File- Edit- Wiew. Sike.

f2aC |8 % @D

|Nature Site W | |L0cal Wiew ~

=] ED Site - Mature Site {C:\Mature Sike)
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= images
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i@l seals.htm
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""" @": index, hitm
@ Deskbop
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m Click the Site tab from the Files panel group
and make sure the Site pull-down menu specifies
the site on which you want to work.

m Click to select a file in the Files panel and move
it by dragging it onto a folder name. The Update
Files dialog box opens, as shown in Figure 10.7,
asking if you want to update related links. Click
Update to adjust the links as you move the file and
ensure that you don’t break any of the links as you
move files into new or different folders. If you
don’t choose Update, then when the file is moved
you will break the links from any other files that
link to it.

® You can use the sample site provided on the
CD-ROM in the folder Technique 10 to experi-
ment with moving files. Simply drag files from
one folder to another, or create new folders and
move files into those to see how Dreamweaver
automatically fixes broken links.

Update Files

Update
findex. htm -
/deserts/desert. htm

Update links i the following files?
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THE TRICKS BEHIND
ANIMATION
TECHNIQUES

t's true. You don’t always need Macromedia
Flash to create animation and movement
effects on the Web. Dreamweaver offers a vari-

ety of features designed to add movement and
action to your Web site.
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CREATING A DISJOINTED
(ONE-TO-MANY) ROLLOVER EFFECT

Clitko on.

11.1

You can find this page,
named Technique11.htm, on
the CD-ROM.

REVIEWS JOIN mz’cwn

CAN WE SAY. "ROAD TRIP"?

11.2

isjointed rollovers follow the same concept as simple

rollovers, except that the image affected or changed by

the rollover is not necessarily, or exclusively, the one on

which the mouse is placed. In Figure 11.1, for example,

a graphical menu is on the left side of the page, and an
empty space is in the center of the page. When you mouse over each menu
item, a full image pertaining to that menu item replaces the empty space
(see Figure 11.2). Behind the scenes, this is what’s really happening: There
is a default blank image in the center (I call this the “off” state). When you
create the rollovers, instead of applying the behavior to the image on which
you place your mouse, you apply it to the default, or “oft” state, image on
the center of the page.

You can also use simple and disjointed rollovers simultaneously for added
interactivity. For example, when designing a navigation menu for your Web
site, you can add a simple rollover to the menu item, at the same time
adding a disjointed rollover so that an image elsewhere on the page changes
depending on where the mouse is on the navigation menu.
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STEP 1: INSERT THE TRIGGER IMAGE

The trigger image is the image that when “touched”
by the cursor triggers the rollover effect.

m Open the file named Techniquell.htm from
the Technique 11 folder on the CD. The trigger
images (the three CD covers on the left side) have
already been inserted for you. If you are working
on one of your own pages, perform the following
steps to insert your trigger images.

m Position your cursor where you want to insert
the image.

m Choose Insert > Image or click the Image icon
in the Insert bar. You can also insert an image
from the Assets panel, as described in Technique 9,
“Accessing URLs, Colors, and Images Assets.”

m Browse for an image to insert.

m Select the image.

m Click OK.

Chapter 3 The Tricks Behind Animation Techniques

STEP 2: INSERT THE IMAGE THAT WILL
BE AFFECTED BY THE ROLLOVER

The base image is the image that will be replaced when
the cursor rolls over the trigger image. The disjoint
image (RTDisplayblank.gif) has already been inserted
into the center part of Techniquell.htm for you.

m If you are working on one of your own pages,
repeat the instructions in Step 1 to insert the
image.

m In the Property inspector, give each image a
unique name, as shown in Figure 11.3.

STEP 3: SET THE SWAP IMAGE BEHAVIOR

m Click the image that triggers the rollover effect.
m With the image selected, click the Behaviors
tab in the Design panel group.

=
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Creating a Disjointed (One-to-Many) Rollover Effect 55

m Click the Plus Sign (+) button. n
m Choose Swap Images from the pull-down
menu. The Swap Image dialog box appears. See In the Swap Image dialog box, check Preload

Figure 11.4.

m From the Images list, choose the image that will
be affected by the rollover (the image that will
change). In Techniquel 1.htm, this image is named
display.

m Click Browse to select the image you want to
use as the rollover image.

m Click OK.

Images to ensure that all your rollover images
are loaded when the page is loaded into
the browser. This reduces or completely elimi-
nates the amount of time a user waits for the
images to download. Check Restore Images
onMouseOut to return your rollover image to
its original state when the mouse is moved
away from the trigger image.

Swap Image [X

Images: |limage "endcap” QK

image "botkomrow”

image "countryroads"
image "highwaykohell"
image "classicalcrossroads" Help
image "vert"

imaEE "kitle"
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[

Cancel

[ |

Preload Images
Restore Images onMouseut
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Chapter 3 The Tricks Behind Animation Techniques

m Click OK. The newly created behavior appears

in the Design panel, under the Behaviors tab. See %
Figure 11.5.
8 ﬂj <imgr Actions ﬂﬂ
Events Actions
STEP 4: PREVIEW IN YOUR BROWSER [onhouseDlut] Suap Image Restare
: [onhouselver] Swap Image
m Press F12 on your keyboard or click the
Preview in Browser icon on the Document
Toolbar. See Figure 11.6.
11.5

CAN WE SAY. "ROAD TRIP"?

kan a CD for more information.

CHONTRY ROADS
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BUILDING ROLLOVERS IN FIREWORKS
AND EXPORTING THEM TO DREAMWEAVER
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12.1 (CP 19)

—

On the CD-ROM, locate
the Fireworks file called
Technique12.png. To see a
finished HTML page, shown
in Figure 12.2 (CP 20), open
the file called Technique12_
finished.htm. The layout is
already sliced in this exam-
ple to save you time. See
Technique 4, “Exporting a
Layout from Fireworks into
Dreamweaver,” for more
about slices.

12.2 (CP 20)

f you're using Fireworks to design your layout, you can create the
rollover behavior in Fireworks, as shown in Figure 12.1 (CP 19).
instead of doing it later in Dreamweaver. In this technique, you
discover a quick and easy way to build rollovers in Fireworks and
export both the graphics and the code.

STEP 1: CREATE THE ROLLOVER FRAME

After you open Techniquel2.png in Fireworks, notice that all the layers are
in Frame 1. You create the rollover effect — what you want your rollover to
look like — in Frame 2.

m In the Frames and History panel, click the Panel Options menu icon
on the right. From the menu, choose Duplicate Frame. Choose After
current frame from the dialog box and click OK. Frame 2 appears in
the Frames and History panel, as shown in Figure 12.3.
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m On Frame 2, select the menu text (About Us,
Our Services, Deals, Visit Us). With all the menu
text items selected, change the color of the text by
using the Property inspector. I used #CCO0000 as
my rollover color.

STEP 2: ADD THE ROLLOVER BEHAVIOR

Now that you have created the frame for your roll-
overs, add a rollover behavior to each menu item.

m Make sure that you are back on Frame 1 in the
Frames panel and that the Web Layer is visible in
the Layers panel so that you can see the layout
slices. If the Web Layer is invisible, click the layer.
An eye icon appears to the left of the layer name
to let you know that it is now visible, as shown in
Figure 12.4.

| 2 Frame? fi

D, G-y Forever

+H ] T

12.3

Chapter 3 The Tricks Behind Animation Techniques

m Click the slice covering the About Us text to
select it. A white circle icon appears in the center
of the slice.

m Click the circle to view a menu of available
behaviors. Choose Add Simple Rollover from the
menu, as shown in Figure 12.5. The new behavior
appears in the Behaviors panel on the right side of
your screen. If the Behaviors panel is not visible,
choose Window > Behaviors or press Shift+F3 to
open the panel. Perform this step on the remain-
ing menu items.

STEP 3: EXPORT THE LAYOUT TO HTML
AND OPEN IN DREAMWEAVER

After you add the rollover behavior to all your menu
buttons and make any other final changes to the
layout, you are ready to export to HTML. (Before
exporting, the image slices need to be optimized.

w Layers =

3

100 | | hMormal e

al = webLayer 1E|h| =

al = Layer 2 |

=3 = Layer2 |

H H | H

Frame 1 7 B]
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Building Rollovers in Fireworks and Exporting Them to Dreamweaver 59

See Step 2 of Technique 4, “Exporting a Layout from If you want to export the images into an image
Fireworks into Dreamweaver.”) subdirectory, you can specify the directory by
checking Put Images in Subfolder and then
browsing for the folder in which you want to
save your images.
m Click Save.
m Open the new HTML file in Dreamweaver.
You can see the rollover behaviors by clicking
the menu button images. The behavior for each
button appears in the Behaviors panel.
m Assoon as you have the page open in
g @ 100% (abo = Dreamweaver, you can make changes to the
Dolrwied et Yo 1 0@ HTML and layout, such as adding a page back-
L I B P P T T ground, centering the layout on the page, or
adding a page title. You can also copy the desired
portion of HTML from this page and place it into
another HTML page.
m Preview your finished page in a browser by
pressing F12 on your keyboard. See Figure 12.6.

m Choose File > Export or press Ctrl+Shift+R.
The Export dialog box appears.

m Click the Browse button to find the directory in
which you want to store the HTML page and its
corresponding images. By default, your HTML
page is given the same name as your .png file. You
can give it a different name in the File Name field.
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SUDSY PUPPY
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EMBEDDING A FLASH MOVIE

—

You can find all of the files
used in this technique in the
folder called Technique 13
on the CD-ROM.

BIOGRAPHY GALLERY EVENTS CONTACT

mbedding rich interactive content from Macromedia Flash is

one of the most effective ways to make your static pages come

to life. You can make your Flash movie appear to be transpar-

ent, control the rendering quality, and manage the dimensions

and alignment of the movie on the page. There are various
parameters, or properties, to consider when embedding a Flash movie on
the page that go far beyond just inserting the Flash file. Figure 13.1 shows a
Web page with an embedded Flash movie.

STEP 1: INSERT THE FLASH MOVIE

m Open the file called Techniquel3.htm and click inside the area in
your Web page where you want to insert the Flash file. This can be any-
where in the body of the page or inside a table cell.
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m Choose Insert > Media > Flash (Ctrl+Alt+F)
or click the Flash icon in the Insert bar. See Figure
13.2. The Insert Flash dialog box appears.

m Browse to find presentation.swf. Click OK to
insert.

STEP 2: MODIFY THE PARAMETERS

When Dreamweaver inserts a Flash movie on a Web
page, some HTML and ActiveX code is inserted into
the document. If you inspect the code, you’ll find two
seemingly identical instructions on how to display
the movie. These OBJECT and EMBED tags in these

Tag... Cirl+E

Image Cirl+Alt+
Image Placeholder

Interactive Images 3

T T
Shodks e Ctrl+Alt+D

Table Cirl+alt+T
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Table Objects X
L Plugin
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Form
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Email Link
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Date
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Get More Objects...
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instructions ensure that various types of browsers
can view the movie. You also find the Dreamweaver
inserts the URL where you can find the Flash ver-
sion’s plug-in, which triggers an auto-install if you
don’t have it.

<OBJECT classid="clsid:D27CDR6E-AE6D-
11cf-96B8-444553540000" codebase=
"http://active.macromedia.com/flash2/
cabs/swflash.cabffversion=4,0,0,0"
WIDTH=100% HEIGHT=600>

{PARAM NAME=movie VALUE="og.swf">
{PARAM NAME=quality VALUE=high>
{PARAM NAME=bgcolor VALUE=#39484F>

{EMBED src="og.swf" quality=high
bgcolor={f39484F WIDTH=100% HEIGHT=600
TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com
/shockwave/download/index.cgi?
P1_Prod_Version=ShockwaveFlash">
</EMBED>

<{/OBJECT>

—

Flash comes with a built-in HTML generating
feature that can do some of the work for you. It
generates the EMBED and OBJECT tags, sets the
background color of the body to the Flash
movie’s background, and gives you limited
alignment and quality control. Please refer to
the help files that come with your Macromedia
Flash application for more information.




Embedding a Flash Movie

Interestingly enough, Dreamweaver does not treat
the three PARAM tags (shown previously) and a few
others (Play and Loop, for example) as actual
parameters: They are not shown in the Parameters
dialog box. By clicking the inserted Flash movie, you
find that these three PARAM tags have individual
check boxes in the Property inspector. You can access
the Parameters dialog box by selecting the Flash
movie in your document in Dreamweaver and click-
ing the Parameters button in the Property inspector.

m Click the inserted Flash movie. Your Property
inspector shows Flash movie properties.

m Check or uncheck the AutoPlay and Loop
check boxes for the desired effect. These parame-
ters are defaults in Flash, so even though they don’t
exist in the code, they are checked in Dreamweaver.
If you uncheck them, Dreamweaver inserts the
following code:

—Gd

While Parameters are powerful, they have their
limitations. The AutoPlay and Loop parameters
cannot control the animation of movie clips

within your Flash movie — they only control the
progression of the main timeline. Also, the
WMODE parameter makes only your Flash
movie’s background transparent. If you create
solid shapes or use an unmasked photo as a
background instead, the Flash file will not
appear transparent because of layer overlap
within your movie. The Quality parameter does
not affect the quality of your imported raster
graphics (such as JPG and GIF) within the Flash
movie —those values are determined when
you create the SWF with Flash.

63

{param name="LOOP" value="false">
{param name="PLAY" value="false">

m Set the quality of the movie by making a selec-
tion in the Quality box. Choosing High makes
your Flash file look its best.

m Set the background color of the Flash file. In
most cases, Dreamweaver attempts to fill in this
Hex value for you.

m If you want to add transparency or other param-
eters to your movie, click the Parameters button
on the right side of the Property inspector. The
Parameters dialog box appears (see Figure 13.3).

Flash files are not literally embedded into
Web pages. They are simply referenced by the
EMBED and OBJECT tags. The external SWF file
is called upon and controlled by these tags and
the parameters described. Also, be wary of the
Edit button on the Property inspector. In some
cases, this button opens the SWF as a static
frame-by-frame animation. This may not be the

original FLA source file you used to create
the Flash movie. The Edit button is better
reserved for Dreamweaver-made Flash files (see
Technique 15).

+| -] |~ oK

Parameter Walue
whODE

Help
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m Enter the parameter name on the left side m Click OK. Save and test your Web page.

and its value on the right side. For a transparency . .

effect, set Window Mode (WMODE) to Your Flash movie is now properly embedded into
your Web page. See Figure 13.4.

Transparent.

addictzd to drams

oscar.g
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EMBEDDING A MULTIMEDIA FILE
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14.1 (CP 21)

—

You can find all of the files
used in this technique in the
folder called Technique 14
on the CD-ROM.

14.2 (CP 22)

hether you're a videographer who wants to showcase

work samples, or a family guy who wants to share

home movies of grandchildren, embedding multime-

dia files, such as QuickTime movies into your HTML

page is painless using Dreamweaver. Figure 14.1
(CP 21) shows a multimedia file embedded into a Web page. Figure 14.2
(CP 22) shows the multimedia file playing on a Web site.

STEP 1: CREATE THE PAGE THAT CONTAINS THE
MULTIMEDIA FILE
m Open the file called Techniquel4.htm in the Technique 14 folder on

the CD-ROM.
m Or, create a page, leaving a space for your movie.

65



66

STEP 2: INSERT THE CODE THAT
EMBEDS YOUR MULTIMEDIA FILE

m Place the cursor where you want to embed
the file.

m Choose Insert > Media > Plugin. Browse for
the file you want to embed. (I used circuitboard.
mov from the multimedia subfolder in the
Technique 14 folder.) Click to select it and then
click OK. A plug-in icon appears, as shown in
Figure 14.3.

b,

14.3
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m Change the W and H values in the Property
inspector to resize the icon to the size you want
your movie to be when it plays. You should know
this size beforehand. Entering a size other than
the movie’s actual width and height causes the
movie to distort when it plays. The movie on the
CD-ROM plays 159 pixels wide and 130 pixels
high, so resize the plug-in icon to those
dimensions, as shown in Figure 14.4.

Unlike the HTML code for an embedded Flash

movie, the HTML code for this QuickTime movie
looks a lot simpler:

—

When thinking about placing multimedia files
within your Web pages, you should also con-
sider the size of those files. Sometimes multi-
media files are large and take a significant
amount of time to download. If you know that
most of your target audience is using a DSL con-
nection or faster, a 2MB file isn't a problem.
However, that isn't the case when the majority
of your audience is using a dial-up connection.
Many dial-up users will not wait the time it takes
to download that 2MB file at such a slow speed.




Embedding a Multimedia File

{embed src="multimedia/
circuitboard.mov" width="159"
height="130"></embed>

STEP 3: TEST YOUR MULTIMEDIA FILE

m Now that your multimedia file is embedded,
click the Play button on Dreamweaver’s Property
inspector (see Figure 14.4). The movie begins
playing in the document window, as shown in

67

Not all users can view the contents of your multi-
media file. Some users’ browsers don’t support
the file type, for example.In some cases, the user
lacks the plug-in. Dreamweaver allows you to
enter a URL to the plug-in download Web site in
the Plug-in URL text box in the Property inspec-
tor. If the plug-in isn't installed, the user will be
prompted to visit that Web site to download

and install it.
Figure 14.5.
_::J Flugin, 534k W o153 Sre |ultimediatcireuitboard.maw || Align | Default W @
43 Hl0  |PiguRL o &
W Space Border k
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CREATING A FLASH MENU
IN DREAMWEAVER
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15.1

—

You can find all of the files
used in this technique in the
folder called Technique 15
on the CD-ROM.

15.2

ou don’t always need to dive into Macromedia Flash to create
interactive buttons for your site. The Dreamweaver Interactive
Images menu enables you to pick and choose from a wide vari-
ety of premade buttons, readily available to customize and
insert into your Web pages, as shown in Figures 15.1 and 15.2.

STEP 1: PREPARE YOUR SITE

m Copy the Technique 15 folder from the CD. Remove the read-only
designation if required. Make sure that all of the files are in the same
site, and that the site is defined in Dreamweaver
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STEP 2: FIND A STYLE THAT SUITS
YOUR DESIGN

m Save your Web page. The Interactive Images
feature generates SWF files for your buttons, so it
needs to know where to deposit them (relative to
your pages).

m Click the area in your Web page where you
want each button to appear. I've included each
button in an individual cell in a table, as shown in
Figure 15.3.

m Choose Insert > Interactive Images > Flash

Button. The Insert Flash Button dialog box appears.

m A preview of a button style appears at the top
of the dialog box. Use the Style scrollbar to find
more designs. Click the style you want to use (see
Figure 15.4).

Chapter 3 The Tricks Behind Animation Techniques

STEP 3: SPECIFY WHAT THE
BUTTON DOES

Unlike normal image buttons, Flash buttons contain
the URL, Window Target, and other information
within the SWF file. This means that these items
won’t appear on your Property inspector after the file
is generated —instead you find Flash parameters
(refer to Technique 13, “Embedding a Flash Movie”).
There are no required fields.

m Enter the button text to display in the Flash
button.

m Choose a font from the menu for your button.
Choose your font size by entering the size in
points. The default point size is 12.

m Enter the URL in the Link text box or click the
Browse button to locate the file to which you want
to link. Select a Target as needed.

= —_— ; —
“ Home * : ° Shop " i 7 t 1 Make Inquiry
15.3
Insert Flash Button rZ| n
Button Text You can download more button styles and tem-
» plates from the Macromedia Exchange. Choose
=H
Glass-Turquoise = the Interactive Images menu and in the Insert
Mavigation-Mext (Green) . .
Navigation-Previous (Green) = Flash dialog box, click the Get More Styles but-

Simple Tab {down})

Simple Tab v
Button Text: | XA |
Link: |2 | [Browse... ]
Target: | v
BaColor: [|[ |

Save As: | button2.swf | [Erowse...]

ton to be directed to Macromedia’s site.To learn
more about add-ons, please refer to Chapter 10,
“Extend the Features of Dreamweaver with
Extensions.”

15.4
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m Enter the background color you want to see Button dialog box if you want to modify these
behind the button. Most styles have a solid white specifications at a later time. See Figure 15.6.
background — the shapes are not masked to
transparent by default. Please refer to Step 2 of
Technique 13, “ Embedding a Flash Movie,” for
instructions on how to specify transparent back-
ground parameters in Flash.

m Enter a filename for the Flash movie. Click the
Browse button to save the SWF file in a different

Your Flash button is ready and working.
Dreamweaver inserts all of the necessary code to
properly embed the button in its place, as well as the
plug-in code. For more information on manipulating
embedded Flash files, please see Technique 13. For
the completed Web page, see Figure 15.7.

directory.

m Click OK to render the button. See Figure 15.5. m

m Click the Edit button on the right side of the

Property inspector to call back the Insert Flash You can edit the buttons you create (choose a

new model, change the text, and so forth) by
clicking them and clicking the Edit button in the
Property inspector. However, you cannot change
the look of the button in Flash.

15.5

f FlashButton ' [100 File |buttong.swk €% |E#_Edit. %
Cantact H 20

W Space Guality | High + | Alian | Default ¥ [ Py
HSpace Scale | Default [Show all’ | =] l_vl ™
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CHAPTER

CREATING POP-UP
AND POP-UNDER
WINDOWS

ove them or hate them, there’s no doubt

that pop-up and pop-under windows are

popular on the Web today. This chapter

shows you how to create pop-up and pop-

under windows — the notorious, miniature
Web pages frequently used to display small amounts of
information and, increasingly, to deliver advertisements
on top of or just behind Web pages.

Pop-up windows are essentially normal HTML Web
pages, which are resized on the fly by JavaScript. Using a
combination of Dreamweaver MX behaviors, you can
spawn pop-up and pop-under windows after visitors click
a button, roll over a picture, or exit your Web site. You also
explore how to create the new generation of pop-ups—
the type you can't just close—using DHTML behaviors.
Pop-under windows work much the same way, except
that instead of appearing above a Web page, they appear
behind it, becoming visible after a user closes the main
browser window.

Warning: There are valid reasons to use pop-ups, but
not all of your visitors can see them. Not everyone likes
these little windows, especially because they are most
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commonly used for advertising. Some programmers
have created “pop-up killer” applications designed to
automatically close pop-ups or prevent them from
opening. To try one of these killer apps designed to
squelch these little windows, search for “pop-up
killer’on http://download.com.
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16.1 (CP 23)

—

You can find this pop-up page
in the Technique 16 folder
on the CD-ROM.The filename
is 16_2-popup.htm, and its
graphics are in the same
folder’s images directory.

16.2 (CP 24)

efore you can launch a pop-up window from a page, you

must create a separate page that houses the pop-up contents.

This step requires planning ahead; first you need to deter-

mine what size you want your pop-up to be, then create the

graphics and content that go in the pop-up window, and

then create the code on a Web page that spawns the pop-up. You generally

want to create pop-ups to appear in front of regular, full-sized HTML pages.

If you wuse the traditional HTML link techniques (such as

TARGET="_BLANK") to launch pop-ups, you'll wind up with an odd size

such as the one shown in Figure 16.1 (CP 23). This happens because the

browser opens at the last size that it was minimized to and closed. In some

cases, the browser may even open at a size too small to display the intended

content. Note that this also causes the menu bar, URL address, and status

bar to appear. You can put all of this to rest with a behavior that manipu-

lates these browser properties on the fly. Figure 16.2 (CP 24) shows a cor-

rectly sized pop-up window promoting Eliptek Consulting’s latest custom
computer creations.
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STEP 1: PREPARE YOUR POP-UP PAGE

m Create your pop-up Web page and save the
document. To use my page, open the file
16_2-popup.htm from the CD.

m Choose View > Rulers > Show (Ctrl+Alt+R) to
display the rulers along the sides of your document.
Take note of the length and width of your pop-up.

STEP 2: PREPARE YOUR POP-UP
LAUNCHER

m Create a page to summon the pop-up. For
the purpose of this example, the page needs
only a BODY tag, so that even the blank default
Dreamweaver page is fine. Save your page to
continue.

STEP 3: SET THE LINK TO OPEN
THE POP-UP

You have many ways to summon pop-up windows.
One of the most popular methods is to load the pop-
up automatically as soon as the page begins to load.
You do this by adding a JavaScript behavior to the
BODY tag of the document with the OnLoad prop-
erty. If you want to launch a pop-up by using a link
instead, follow these steps, substituting the BODY tag
with the A tagand OnLoad with OnClick.

m Scroll to the top of your launcher page. Click
the <body> tag in the Tag inspector to select it.

—

You can find this pop-up page in the Technique
16 folder on the CD-ROM. The filename is 16_
2-launcher.htm, and its graphics are in the same
folder’simages directory.

Chapter 4  Creating Pop-Up and Pop-Under Windows

m With the BODY tag selected, choose Window >
Behaviors (Shift+F3) to expand the Behaviors
panel. Click the Plus Sign (+) button and choose
Open Browser Window from the expanded
menu. The Open Browser Window dialog box
appears (see Figure 16.3).

The Open Browser behavior enables you to set vari-
ous properties of the pop-up window. Aside from
specifying the window size, you can disable the
browser navigational menus and even turn off scroll-
bars if they don’t suit your content.

m In the Open Browser Window dialog box, enter
the name of the pop-up. Set the size (which you
noted in Step 1) and other specifications of your
pop-up window, and enter a Window Name. Click
OK to complete the behavior.

Save your document and test your page. As soon as
the launcher page is opened, the pop-up appears in
the size you designated, as shown in Figure 16.4.

—

Because pop-up windows appear in the middle
of the screen, the viewer usually sees the page

title before the pop-up content loads. Putting a
title in at this time is a good idea, or at least
remove Dreamweaver’s default “untitled page”
title. Save your changes.

Open Browser Window X
URL to Display: ‘ 16_2-popup.htm | [ Browse... ]
Window Width: | 325 | Window Height:

Attributes: [_] Navigation Toolbar ] Menu Bar
[ Location Toolbar [ serolibars as Needed
[ status Bar [ Resize Handles
Window Mame: ‘ NetBox |

16.3
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TECHNIQUE

CREATING A “GALLERY WALL"” USING
MULTIPLE POP-UP WINDOWS

A Grayscale. ary Gallery by an Ordinary Girl - Microsoft Internet Explorer

T :
3 Cats - Micr... |- | [X] BDawn-M... [- " [X] BTemato -... [= |"[X| A sandwich-... £]0/X]

e {

= 3 My Computer
17.1 (CP 25) 17.2 (CP 26)

m ne of the coolest things I've ever seen done with pop-up

windows is a “gallery wall” (or in context, a gallery
screen). If you’re an artist, this is an ideal way to show-
case your work online. Figure 17.1 (CP 25) shows the

For this technique, use
Technique17.htm in the
Technique 17 folder on the

CD-ROM. You find four other pop-up window, and Figure 17.2 (CP 26) shows the
HTML files used in this gallery wall created when the user clicks the pop-up.

technique:  window1.htm,

window2 htm, window3.htm, STEP 1: INSERT THE OPEN BROWSER WINDOW BEHAVIOR
and window4.htm. Each of

those four pages contains m Choose File > Open and browse to find Techniquel7.htm.

one image for the“gallery.” m Click the Grayscale image in the center of the page to select it.

m With the image selected, click the Behaviors tab in the Design panel.
m Click the Plus Sign (+) button and choose Open Browser Window
from the menu.
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m In the Behaviors panel, make sure that the event
islisted as (onClick).Ifitisn’t, click the black
down arrow and choose (onClick) from the
menu, as shown in Figure 17.3.

m In the Open Browser Window dialog box,
browse for the file called window1.htm. In the dia-
log box, enter a width and height for your new
window. I entered 190 and 145 because the images
are each 180 by 185, and I want the window to
have a 10-pixel area around the image. Leave all
the check boxes unchecked (unless you prefer that
any of these window elements are visible). Enter
an identifying name, such as gall, for the window
name. See Figure 17.4.

S5 Syl
Yle= HTMIL SU;IIE'S Eehaviors
-I:,| — | <img: Actions i | - |

Event= Actions
[onClick] pd COpen Browser Window

17.3
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m With the Grayscale image still selected,
repeat this step for the three remaining gallery
pages (window2.htm, window3.htm, and
window4.htm).

STEP 2: SPECIFY THE POSITION OF
EACH WINDOW

For this step, you need to work in Code View to edit
the JavaScript created by the Open Browser Window
behavior. The position of the windows is up to you.
In this technique, I am placing all four windows in a
horizontal row, 200 pixels from the top of the screen.

—

You can enter only absolute, or pixel, positions
using Dreamweaver’s Open Browser Window
behavior. The downside of this behavior is that
some browsers position the gallery based on
the monitor window and not the browser win-
dow, causing some interesting — and probably
undesired — effects. With a little CSS and
DHTML knowledge however, you can specify
relative positioning for each gallery window,
minimizing undesired positioning.You can learn
more about CSS by selecting O'Reilly CSS
Reference in Dreamweaver’s Reference panel.




Creating a “Gallery Wall” Using Multiple Pop-Up Windows

m In Code View, locate the link tag that launches
the gallery windows. The piece of code for which
you are looking looks something like this, if you

have Word Wrap turned on (View > CodeView

Options > Word Wrap):

{a href="#" onClick="MM_openBrWindow
('windowl.htm', 'gall', 'width=190,

height=145");

81

MM_openBrWindow ('window3.htm', 'gal3"',
'width=190,height=145");
MM_openBrWindow ('window4.htm', 'gald',

'width=190,height=145")">

{img src="images/title.gif"
width="300" height="200" border="0">
</a>

m Insert the Top and Left positions for each of the

MM_openBrWindow('window2.htm', 'gal2’ four gallery windows. Here is the code with the
,"width=190,height=145") ; Top and Left positions included:

Open Browser Window X
URL ko Display: |win-:|u::w1.htm |[ Browse, . ] Ok,
Window Width: | 190 | Window Height: | 145 Cancel

Attributes: [ ] Mavigation Toolbar ] Menu Bar Help

[ ] Location Toolbar
|:| Skatus Bar

[ ] scrolbars as Meeded
[ ] Resize Handles

Window Mame: | gall

17.4
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{a href="j» onClick="MM_openBrWindow
('windowl.htm', 'gall', 'width=190,
height=145,top=200,left=5") ;
MM_openBrWindow ('window2.htm',
'gal2','width=190,height=145,
top=200,left=200");
MM_openBrWindow ('window3.htm',
'gal3d','width=190,height=145,
top=200,left=400");
MM_openBrWindow ('window4.htm',
'gald','width=190,height=145,
top=200,left=600")">

{img src="images/title.gif" width=
"300" height="200" border="0">
<{/a>

m Click File > Save.

STEP 3: TEST THE MODIFIED BEHAVIOR
IN YOUR BROWSER

m Press the F12 key on your keyboard to open
your launch page in a browser window. You
can view a finished version of this technique by

Chapter 4 Creating Pop-Up and Pop-Under Windows

opening the file called Techniquel7_finished.htm
in the Technique 17 folder on the CD.

m Assoon as the page is open in the browser,

click the Grayscale image to launch the gallery. See
Figures 17.5 and 17.6.

& normal day in my house

)

X| ATomato ... = | IX]| A sandwich -... [£]C (X
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CREATING TOOL TIPS WITH ONBLUR
AND ONFOCUS EVENTS
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18.1 (CP 27)

18.2 (cp 28)

—

You can find all of the files
used in this technique in the
folder called Technique 18
on the CD-ROM.

y using layers and JavaScript behaviors, you can create tool
tip windows that display useful information about text fields
without cluttering your form. Even with JavaScript form val-
idation techniques, preventing human error is hard when the
person doesn’t understand what to input. Crowding HTML
forms with supplemental instructions is easy, but many people turn away
from filling out forms that appear too long and daunting. This technique

shows you how to display tool tips next to input boxes that disappear when
they are not in use, as shown in Figures 18.1 (CP 27) and 18.2 (CP 28).
Tool tips enable you to help your visitors better understand what you want
them to fill out on your forms without scaring them away with unnecessar-
ily long or cluttered form pages.
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STEP 1: CREATE A TEXT FIELD

Input fields can’t do much without a Form tag.

m Choose Insert > Form Objects > Text Field
to insert a form field into your document.
Dreamweaver asks you if you would like a Form
tag added. Click OK.

m A red dotted line appears around your text
field, as shown in Figure 18.3. This indicates that
your text field is nested inside a Form tag.

STEP 2: INSERT THE TOOL TIP

Your tool tip resides inside of a layer. Draw your layer
near your text field so that the user immediately
understands its relevance when it pops up.

m Choose Insert > Layer.

m Position the layer near your text field by drag-
ging the layer’s handle. The handle is the small
square within a square at the top left of the layer
indicator. To resize the layer, drag the solid black
dots that appear on the sides and corners of the
layer when it is selected.

This technique is intended for a current browser
audience. Older browsers, such as Internet
Explorer 3, may produce JavaScript errors when
displaying layers. You can use the Dreamweaver
MX Browser Check behaviors to design contin-
gency pages.

Chapter 4  Creating Pop-Up and Pop-Under Windows

m Insert your tool tip graphics, or simply type
your tool tip into the layer. Set the layer’s back-
ground color for contrast by using the Property
inspector. In this technique, a graphic has been
inserted inside the layer.

m With your layer selected, set its Vis (visibility)
property to Hidden in the menu found on the
Property inspector.

Now that the tool tip layer is hidden, you need to
assign a behavior that makes it visible when it is needed.

STEP 3: THE ONFOCUS EVENT SHOWS
THE TOOL TIP

You need to assign two behaviors for each text field.
The first behavior is to show the layer with OnFocus,
which is triggered when the cursor is clicked inside
the text box. To hide the layer as soon as the mouse
exits the text field, you’ll use the OnBlur behavior.

mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm
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Creating Tool Tips with OnBlur and OnFocus Events

m Click to select your text field. Behaviors panel. The Show/Hide Layers dialog
m Choose Window > Behaviors (Shift+F3) to box appears.

display the Behaviors panel. Click the Plus Sign m Choose your layer and click the Hide button.
(+) button and choose Show/Hide Layers. The The word (hide) appears in parentheses next to
Show/Hide Layers dialog box appears. your layer on the menu. Click OK to close the

m Choose your layer and click the Show dialog box.

button. The word (show) appears in parentheses ® An OnBlur event appears in your Behavior
next to your layer on the menu. Click OK to close panel.

the dialog box.

m An OnBlur event appears in the Behaviors
panel. Choose the behavior. Click and hold the
event arrow to reveal more options. Choose
onFocus (see Figure 18.4).

onAfterUpdate
STEP 4: ONBLUR HIDES THE LAYER °“2|Ef°f3“°da‘f
onBiur
WHEN INACTIVE onClick
onChange
. onDblClick
m Click to select your text field. ondrag
. . onDragEnd
m Click the Plus Sign (+) button and onDraginter
choose Show/Hide Layers again from the onDragleave
onDragOver
onDrop
onHelp g
onkeyDown
onFinish
onLoseCapture
onPropertyChange
onStart
onkeyPress
The easiest and fastest way to create a tool tip is onieyL
onMouseDown
to set a contrasting background color to a layer onMouseMove
onMouseQut
and type text into it. You can also add images or onMous=Over
multimedia files, such as Flash. GIF files are 2::';:::“"
especially effective because of their trans- onBeforeEditFocus
. . . onContextMenu
parency properties. As shown in Figure 18.2 (CP onBeforeActivate
0 onFocusIn
28), the tool tip has rounded edges and a pro- s
truding pointer. onMouseWheel
18.4
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This completes the technique. To test it in your Web
browser, press F12. Click inside the text field you cre-
ated to display the layer tool tip, and then click some-
where else to hide it. See Figure 18.5.

If normal text tool tips are too dull for your tastes,
you can create your own designs by using imag-
ing software, such as Fireworks or Photoshop.
You can find the tool tip graphic used in this
technique in the folder called Technique 18 on
the CD-ROM.
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—

For a creative multimedia effect, use your micro-
phone to create audio tool tips. Save the audio
as WAV files individually, and follow the steps in
this technique by using the Play Sound behavior
in the place of the Show/Hide Layer behavior —
or create two onFocus events to do both. Keep
in mind the file size of your WAVs so that they
load quickly when they are referenced, or you
may experience a delayed response.
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FLOATING POP-UPS WITHOUT

WINDOWS

Dreamweaver MX Techniques

WEEKLY NEWSLETTER BROUGHT TO YOU 8Y sz MODERNMETHOD

Welcome to the very first issue of Dreamweaver MX Techniques!
In this issue you will find:
@ Howto Export a Layout from Fireworks Into Dreamweaver k
& How to Create 3 Flash Menu in Dreamweaver
& Howto Create a Template Driven Web Site
In the DWMX Extensions Spotlight: InstaGraphics Extension
component, we can install most peripherals on

location for your convenience. » WEE DESIEN & [LLUSTRATION
5 COMPLETE NETWORK & PHONE WIRING

19.1 (CP 29)

—

You can find this pop-up page
in the folder called Technique
19 on the CD-ROM. The file-
name is 19-step1.htm, and its

DIFEly  Aren't YOU oo
WEEKLY NEWS tir-ed 01: the
Welcome to the blg OneS?

In this issue you!

s /4
Net ~Box

the powerful mini pe
d  Howto Exp s .

.

& Howto Create a Flash b

& How to Create a Template Driven Web 3

In the DWMX Extensions Spotlight: InstaGraphics Extension

We ean Install most on » WEB DESIGN & ILLUSTRATION
location for your convenience.

» COMPLETE NETWORK & PHONE WIRING

19.2 (CP 30)

he floating layer pop-up is the latest craze in online advertis-
ing. The floating pop-up is essentially a DHTML layer with
various supporting JavaScript behaviors associated to it. This
is how it frees itself from needing its own window in which
to appear. Unlike JavaScript pop-ups, which launch separate

graphics are in the same browser windows, this technique embeds the pop-up within the Web page.
folder. You have more control over floating pop-ups — such as where to position
the close button. Now that the majority of America Online users have
browsers that support DHTML, large portals, such as Yahoo! and AOL,

have begun allowing such campaigns to run in their networks. In the fol-
lowing steps, you create a floating pop-up that opens at a designated time
after the page loads and automatically closes itself after a few seconds.

Look ma, no borders! As shown in Figure 19.2 (CP 30), you can use trans-
parency properties in your artwork to give the pop-up any shape you like.
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STEP 1: POPULATE THE FLOATING
POP-UP

m Open the Web page where you'd like the float-
ing pop-up to appear. Click Insert > Layer to
insert a blank DHTML layer.

m Click inside the layer and insert your graphics,
texts, or rich media files.

STEP 2: DESIGNATE THE LAUNCH
BEHAVIOR

Similar to traditional pop-ups, floating pop-ups rely
on JavaScript actions to spawn them. In Technique
16, you used the OnLoad command to launch a
browser window when the page loads. With floating
pop-ups, you can designate more levels of control
because there are a variety of possibilities when
working with layers. You can use the timeline feature
in Dreamweaver to set a timer for the pop-up. In the
following steps, you create a pop-up that opens after
ten seconds, closes itself automatically after ten sec-
onds, and gives the user the option of closing it early.

m Choose Windows > Others > Layers (F2) to
reveal the Layers panel. Click the layer that you
just created. Optionally, you can give the layer a
name in this panel. The Layers panel is a member

— il

If your entire pop-up content is a GIF89 file, you
can set a matte or mask transparency in your

imaging program to give the pop-up a unique
shape. You can do the same with a Flash movie
by creating a new parameter for it by using the
Parameters Editor within the Property inspector.
Enter the Window Mode parameter (WMODE)
and enter the value as Transparent.

Chapter 4  Creating Pop-Up and Pop-Under Windows

of the Advanced Layout panel group. If this group
is already open, just click the Layers tab to open
the Layers panel.

m Choose Windows > Others > Timelines
(Alt+F9) to reveal the Timelines panel options
menu. With your layer selected, click the
Timelines panel options menu and choose Add
Object (see Figure 19.3). Your layer appears with
two keyframes on the timelines (see Figure 19.4).
Check the Autoplay check box. This adds an
OnLoad JavaScript to your BODY tag, which fol-
lows whatever you specify in the timeline when the
page loads.

m Click the first keyframe. Click the space next to
the layer name in the visibility icon to reveal the
eye icon. Click again to reveal the closed eye icon.
Your layer is now invisible.

m Click the second keyframe. Drag it to the
desired frame when you’d like the pop-up to
appear. Because the layer was set to visible by
default in this keyframe, you need not set the
visibility mode for it. This concludes the

launch sequence of the pop-up.

You have two common ways to hide floating pop-
ups. You can set a scheduled hide action by using the
timeline, and/or you can create a hot spot in the ad
where the visibility of the layer is set to hide. The next
few steps illustrate how to do both.

STEP 3: SCHEDULE A FLOATING POP-UP
TO HIDE

You want this pop-up to show for only ten seconds, so
you can determine the frame number by multiplying
the number of seconds by the frame rate (150), and
then adding the amount of frames that already exist
in the sequence (15).

m Scroll to the desired frame in the Timelines
panel. For a pause of ten seconds, select
frame 165.
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m With your desired frame selected, click the
Timelines button and choose Add a Keyframe.
m Click your layer in the Layers panel. Click the
visibility column until your layer is set to hide.
This concludes the automated hide procedure.
Save and press F12 to test in your browser.

STEP 4: ADD A CLOSE BUTTON
BEHAVIOR

One of the great features about floating pop-ups is
that you can choose whether to have a close button. If

—Gd

You can find the completed scheduler in the
folder called Technique 19 on the CD-ROM. The
filename is 19-step2.htm.
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you choose to have one, you can design it to look like
anything and place it anywhere. Even if users want to
close the pop-up, their eyes are going to hunt all over
the ad looking for that button.

m Insert some text or a button into your layer to
set up for the behavior. If your original design has
a close button drawn in like the one shown in
Figure 19.5, you can draw an image map.

m In the Behaviors panel, click the Plus Sign (+)
button and choose Show/Hide Layers with your
link, button, or image map selected.

m In the Show-Hide Layers dialog box, click your
layer and click the Hide button (see Figure 19.6).
Click OK to close the dialog box. Save and test in
your browser. See Figure 19.7.

Chapter 4 Creating Pop-Up and Pop-Under Windows
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20.1(CP 31

—

You can find all of the files
used in this technique in the
folder called Technique 20
on the CD-ROM.

20.2 (CP 32)

op-under windows, shown in Figure 20.2 (CP 32), are a great

way to send messages to visitors without interfering with their

Web browsing. Users generally do not see pop-under windows

until after they close their main browser window.

You create a pop-under window in the same way that you
create a pop-up window. The only difference is that an additional
JavaScript event is required that prevents the pop-up from coming into the
foreground. Pop-under windows are most widely used by sites that want to
deliver advertisements from other companies, but do not want these ads to
be in the foreground while the user browses their site.

STEP 1: CREATE THE POP-UNDER WINDOW FILE

m Follow the steps in Technique 16 to create a pop-up window and a
launcher.
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STEP 2: ADD THE CUSTOM SCRIPT

The little known fact about pop-unders is that they
don’t actually pop-under. The launcher page calls up
the pop-up window event, but then another event
immediately forces itself as the “focus,” which causes
the pop-up to get moved behind the parent window.
The pop-up resides immediately behind the launcher
where it cannot be seen, thereby becoming a pop-
under.

To turn your pop-up window (See Figure 20.3) into
a pop-under window, follow these steps:

m Open the page where you created the pop-up
launcher.

m Click the <body> tag in the Tag inspector to
select it.

m Click the Plus Sign (+) button in the Behaviors
panel and choose Call JavaScript.

m In the Call JavaScript dialog box, enter the
following code: window.focus().

m Click OK (see Figure 20.4).
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SMALL

COOL

fully loaded pc?
[ Meet our LETLITY

1/g of actual size

| |
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The pop-under is now complete. Save and navigate
to your folder to open the file manually to preview it
in a browser.

—

Close all of your browser windows before test-
ing your work. Previewing this technique by
using the Dreamweaver F12 key command may
not be effective because it launches a new
browser window when you press F12. In some
cases, both windows may open minimized,
depending on your configuration.

Call JavaScript

0K

JavaScript: |wind0w.f0cus(}

Cancel

TN
(_Coneel ]

20.4

—

Users generally don’t notice pop-under win-
dows until they close their main browser win-

dow. You can use this opportunity to load high
bandwidth content that you would not nor-
mally ask people to wait for or to deliver mes-
sages that you want them to see after they are
done looking at a site.
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21.1

—

You can find all of the files
used in this technique in the
folder called Technique 21
on the CD-ROM.

21.2

xit pop-up windows enable you to make the best of outgoing
site traffic. By using JavaScript behaviors, you can launch a
pop-up window the very second users leave your Web site or
close their Web browser, as shown in Figure 21.2. There are
many useful applications for pop-up windows on exit. For
example, if your site offers e-commerce, you can pop-up a last chance bar-
gain to invite them back to shop on your site.
The same principles of creating a pop-up window from the previous tech-
niques apply. The only difference in steps is the OnUnload event, which
triggers as soon as the browser closes.
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STEP 1: CREATE THE POP-UP
WINDOW FILE

m Follow the steps in Technique 16 to create a
standard pop-up. In Technique 16, you create two
Web pages, one for the pop-up and one for the
launcher.

STEP 2: MODIFY THE LAUNCHER EVENT

m Open the page where you created the pop-up
launcher.

m Click the <body> tagin the Tag inspector to
select it.

m You see the OnLoad event assigned to the pop-
up behavior. Click to select the OnUnload event
(see Figure 21.3).

m Save and preview your work by pressing F12.
m Allow the page to load completely, and then
close your browser to view the result. See

Figure 21.4.

Chapter 4  Creating Pop-Up and Pop-Under Windows

—

In addition to the browser being closed, the
OnUnload event also goes off when the

browser is refreshed.

—

If the user closes the page before your browser
has a chance to interpret the pop-up code, your
pop-up window will not appear. Similarly, a
“pop-up killer” application also prevents pop-
up windows from working.

—

When finalizing your pop-up window, always
consider the TARGET of the links that you cre-
ate. If you launch a pop-up that does not allow
scrolling or resizing, and your links all use the
default target, the linked pages will be con-
strained in that tiny box. Most designers use
_blank as their TARGET, which opens a full
sized browser window.

CES SIS | HTML Styles Eehaviors

ﬂj <body: Actions ﬂj

Events Betions
anlnload Open Browser wWindow

21.3
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CHAPTER

ADVANCED PAGE
DESIGN TECHNIQUES

esigners who are used to working
in print get frustrated very quickly
when they start working on the Web.
Okay, truth be told, most people who
have good design sense get frustrated
at least once in a while by the limited design control you
have when creating HTML pages. But before you get too
annoyed with all of the limitations, spend some time
exploring the techniques in this chapter, which are
designed to help you take advantage of some of
Dreamweaver’s best design features. You should also
know that as the Web has matured, HTML has evolved
to include more and more cool features, such as floating
layers, covered in Technique 25 at the end of this chapter.
For the most part, when you want to create anything
but the simplest design on a Web page, you should use
the HTML feature known as tables. Tables on a Web
page are used for far more than organizing numerical
data. When used effectively, they provide one of the best
ways to align elements on a page and provide real design
control.
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‘DRAWING” TABLES WITH
LAYOUT FEATURES
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22.1 (CP 33) 22.2 (CP 34)

m ables are by far one of the most important design elements
You can find all of the files used on the Web, but they are a little complicated to create,
used in this technique in the especially if you're working on a really complex page layout.
folder named Technique 22 That’s why the Dreamweaver Table Layout feature is so cool.
on the CD-ROM. With it, you can “draw” a table on a page, creating cells wher-

ever you want in a way that is much more intuitive than splitting and merg-

ing cells. You can achieve the alignment you want with tables, as shown in
Figure 22.2 (CP 34). If you couldn’t use tables, you'd have limited design
control over a page, as shown in Figure 22.1 (CP 33).

STEP 1: DRAW A TABLE

The easiest way to work with tables in Dreamweaver is to switch to Layout
View and use the special Layout Cell and Layout Table tools. With these
tools, which are available only in Layout View, Dreamweaver makes it pos-
sible to place your cursor anywhere on the screen and “draw” a table cell by
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clicking and dragging. That’s right, you can just place
your cursor anywhere on the page, create a cell any
size you want, and then insert any content you want:
images, text, multimedia files, and so forth.
Dreamweaver makes it possible to draw a cell wher-
ever you want it by automatically generating the rest
of the table and the necessary cells around your new
cell. See Figure 22.3 to see what this looks like in
action. I created the outline of the table in Layout
View (you find details in the steps below). As soon as
the outline of the table was created, I simply drew in
the two cells that appear in white by clicking and
dragging them into place. The outline of the newest
cell is in black because I was in the process of drawing
it in when I took the screen shot. The gray cells
appeared automatically around my cells to keep the
spacing the way I wanted. Dreamweaver also uses

Chapter 5 Advanced Page Design Techniques

transparent images in table cells to provide exact
positioning.

Using transparent images is an old trick in Web
design that takes advantage of the fact that you can
change the size of an image to anything you want in

—

The first time you choose Layout View, you find
a message with a brief description of how to use
the Layout Table and Layout Cell buttons. You
may find this a handy reminder and want to
keep it, but if you get tired of it, check “Don't
show me this message again” to prevent seeing
itin the future.Either way, click OK to close it.
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“Drawing” Tables with Layout Features

the HTML code. For example, you can stretch a small
image into a larger one or shrink a large image to a
smaller one. In general, you don’t want to do this
because it can distort the image, but if you place a
transparent, and therefore invisible, image on a page
and then adjust the size, you can use it to control
spacing. You simply adjust the transparent image to
exactly fill the space you want to control, and then
use the image to position other elements precisely on
the page. Dreamweaver automatically does this for
you, in the background when you use Layout View to
create a table.

Of course, you can still create tables the old-
fashioned way in Standard View. You can easily
switch between the two modes, which is important
because you have more editing controls in Standard
View. You're probably already used to working in
Standard View in Dreamweaver because that’s the
default for working on documents. Layout View pro-
vides a special view mode designed to assist in the
constructing and editing of tables, and it’s unique to
Dreamweaver.

To create a table in Layout View with a long cell
across the top and two smaller cells below it (such as
the table shown in Figure 22.2 (CP 34)), create a new
HTML page and follow these steps:

m Switch to Layout View by clicking the Layout
tab in the Insert bar and then clicking the Layout
View button. You can also switch to Layout View by
choosing View > Table View > Layout View, but
I find the Layout tab in the Insert bar is more
convenient.

—

As you draw, notice that the cell “snaps” into
place along the guidelines in the table grid. Use

the grid as a guide in lining up your cells.
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m Click the Draw Layout Table button, and then
click and drag to create the outline of the table on
your Web page. (In Figure 22.3, you can see where
I drew the table outline because it provides the
outside frame of the table area.) You can always
resize the table area by clicking and dragging any
of the borders or by changing the values in the
width and height text boxes in the Property
inspector.

m Click the Draw Layout Cell button, and you see
that the cursor changes to a crosshair when you
move the mouse over the document area. The
crosshair indicates you can draw a table cell.

m Click the mouse on the document, and while
holding down the mouse button, drag to draw a
rectangular shape across the top of the page for
your first table cell. In Figure 22.3, 'm adding a
new cell in the middle of the table to demonstrate
how easy it is to “draw” a new cell anywhere on the
page.

m The cell is drawn and its surrounding table
structure is automatically generated. A grid repre-
senting the table structure appears with the cur-
rent cell shown in white.

m Below the cell you just drew, draw a small,
square shape such as the cell shown in Figure 22.3.
Each time you draw a new cell, you have to click
the Draw Layout Cell button again and then click
and drag on the page where you want the cell.

m You can continue to draw cells by clicking the
Draw Layout Cell button and then clicking and
dragging on the page.

You can add any content into a table cell that
you can add anywhere else on a page, including
images, text, and multimedia files.
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Depending on where you started drawing your table
cells, Dreamweaver may create table cells around the
cells you created to maintain their position on the
page. For example, in the table shown in Figure 22.3,
although I only created three new cells, Dreamweaver
has filled in the gaps by automatically creating more
cells, so that there are actually 10 cells in this final
table.

In Standard View a table defaults to the top-left cor-
ner of a page, so the first cells in the table are close to
the top-left margin. However, using Layout View, you
can draw cells wherever you want them on a page,
and Dreamweaver automatically generates the other
cells that are needed to keep the positioning you cre-
ated in Layout View. Using tables is one of the easiest
ways to place elements exactly where you want them
on a page. Empty cells that Dreamweaver creates to
fill space in a table merely act as spacer cells and don’t
show up in the browser, giving the illusion that vari-
ous page elements are positioned independently on
any part of the page.

Chapter 5 Advanced Page Design Techniques

STEP 2: EDIT TABLES IN LAYOUT VIEW

One of the really wonderful features about working
with tables in Layout View is that you can use the lay-
out grid to edit, move, and resize any of the rows,
columns, and cells in the table. This allows you to use
the grid as a design guide for creating any kind of lay-
out you want. Normally, the only way to create com-
plicated layouts in HTML is by meticulously building
complex tables and carefully splitting and merging
cells manually. Using Layout View, you can simply
draw cells wherever you want them and create asym-
metric tables quickly and easily for complex design
work.

m To edit a table cell in Layout View, simply click
any border and drag it to the desired size, as
shown in Figure 22.4.

m To access other table editing features, such as
Border Color and Background Image, switch to
Standard View by clicking the Standard View but-
ton in the Insert bar or choosing View > Table
View > Standard View.

For the final Web site, see Figure 22.5.
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©  This is crittur.com, home site of mindy and tom mcCain,
web producers since before the turn of the century.

We have built 3 new home on YWhite River!

who we are m tom is an illustrator and lover of anything online,
mindy is a fiber artist and techno-goddess.

what we do B We are web producers and consultants,
8 ] Current projects,

what we like our_offline lives include

everything from soup to {(propeller) nuts,

harme | site and contact info
Materials at this site belong to torm and mindy mcCain,
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FORMATTING MULTIPLE TABLE CELLS

> Insert

Aries: Botrayalis afoot. Plan for a pro-smptive strikc and g0, g0, go!

Taurus: Money is coming your way. Pamper gourself, you deserve it

Gemini: Your secret may get out. Stay home and don't talk to anyone

Cancer: Things are peachyl A Fiend brings g00d news on horseback.

Leo: Mot a good day to get a hair eut, Leave it for tomotrow,

Virgo: Drink water. Lots of water. Your *cendition” requires it today.

Libra: Perhaps you shouldn't have had that glass of wine last right

Scorpio: A Germini finds you irresistible today. Grrrrl

formattingeelzhem

fbody ctablex ct> cte> ctable> <> <>

> Insert

- S 3
s by tMadanie g)rinka
LY, - *

Aries: Betrayal is afoot. Plan for a pre-emptive strike and go, go, go!

*
*

Taurus: Money is coming your way. Pamper yourself, you deserve it

Gemini: Your secret may get out. Stay home and dont talk to anyone.

Cancer: Things are peachy! A fiiend brings good news on horseback

Leo: Not a good day to get a hair cut. Leave it for tomorrow.

Virgo: Drink water. Lats of water. Your "condition” requires it today

Libra: Perhaps you shouldn't have had that glass of wine last night

Scorpio: A Gemini finds you iesistible today. Gl

786488, SO 27 sac. fibody ctabler ct> <t tabley sty <t sfon>

23.1

—

You can find this page as
Technique23.htm on
CD-ROM.

the

STEP 1: ALIGN THE CONTENT IN MULTIPLE CELLS

&

7854 $48 4 39K/ 28 sec

23.2

f you have a table with various consecutive cells that
require the same formatting, you can quickly format them all
at once! I've changed the text alignment and font in

Figure 23.2.

m Make sure you are in Standard View (View > Table View >

Standard View). Click inside the top-left column containing the
Aries symbol and drag down to select the remaining cells below it.
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m With all the cells in the left column selected,
click the Horizontal Alignment down arrow in
the Property inspector. Select an alignment

Chapter 5 Advanced Page Design Techniques

m Next, click the Size down arrow in the Property
inspector and choose 2.
m The text now appears in Arial, size 2.

option, as shown in Figure 23.3.
m The symbols now appear center-aligned.

STEP 3: APPLY A BACKGROUND IMAGE
TO MULTIPLE CELLS
STEP 2: FORMAT THE TEXT IN
MULTIPLE CELLS

m Click inside the top-right column that contains
the text of the Aries horoscope, and drag down to
select the remaining cells below it.

m With all the cells in the right column selected,
click the Font down arrow in the Property inspec-
tor and choose Arial, Helvetica, sans-serif.

m Click inside the top-right column that contains
the text of the Aries horoscope and drag down to
select the remaining cells below it.

m With all the cells in the right column selected,
click the Browse button next to the Background
Image field in the Property inspector to browse for
an image.

m Choose the file named cellbg.gif. Click OK.

m The image now appears in every cell in the right
column. See Figure 23.4.
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» Insert
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DESIGNING A COMPELLING HTML
E-MAIL NEWSLETTER

Wt Dreamweaver MX Techniques Newsletter - |ssue #1

n iy
Wt Dreamweaver, MX Techniques Newsletter - Issue #1 o BEE VD TeEd ot TEd (s GE !
»
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Hella falks!
Welcome to the very first issue of our Drearmweaver MK Technigues Mewsletter!

In this issue you will find:

« How to Export a Layout from Fireworks Into Dreamweaver
& How to Create a Flash Menu in Drearmweaver
e How to Create a Template Driven ¥Web Site

In the DWMX Extensions Spotlight: InstaGraphics Extension

From the Dreamweaver Exchange on Macromedia.com:

“Instantly create Macromedia Fireworks Weh graphics, directly from Macromedia
Dreamweavet--without expert design skills or even knowing Fireworks.

# weekLy wewsLerter erouskt 1o vou s 3fs MIODERNMETHOD

r “’ [;3/ \\ WEB DESIGN TIPS ANDJIECHNBUES

Welcome to the very first issue of Web Design Tips & Techniques

In this issue you will find:

How to Export a Layout from Fireworks Into Drearmweaver
Heowe to Create a Flash Menu in Dreamweaver

Howe to Create a Template Driven Web Site

In the Spotlight: InstaGraphics Extension for Dreaweaver

Fram the Drcamcaunr Exchonar on Marceamedia com b

24.1 (CP 35)

—

You can find all the files for
this technique in a folder
called Technique 24 on the
CD-ROM.

24.2 (CP 36)

n this technique, you turn a boring text-based e-mail newsletter
into a visually appealing HTML e-mail. Figures 24.1 (CP 35) and
24.2 (CP 36) demonstrate the difference.

These days, we all get so much e-mail that sometimes good messages slip
through the cracks. If they don’t grab our attention or don’t immediately

show what they’re about, we’re likely to press that delete key quickly.
Sometimes we even subscribe to e-mail newsletters and then delete them
without ever reading them, especially if they appear very long and
text-heavy!

A word of warning: Not all e-mail programs can send or receive HTML-
formatted e-mails. Also, even if you have an e-mail program that does allow
HTML-formatted e-mails, for example at work, your company’s firewall
may have this option blocked. This technique assumes you will be using
Outlook or Outlook Express to send your HTML e-mails.
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STEP 1: BUILD YOUR NEWSLETTER
IN DREAMWEAVER

In this step, you build your newsletter the way you
would build any other HTML page in Dreamweaver.
As an alternative, you can work with the sample pro-
vided on the CD-ROM.

m Choose File > Open to open the
Technique24.htm file (see Figure 24.3).

m Edit this file to suit your needs, adding or
removing images and text or changing the layout
or color scheme.

STEP 2: UPLOAD IMAGES AND UPDATE
IMAGE SOURCE LINKS

In order for images to show up on your HTML
e-mail message when a recipient opens it, all images
need to be hosted on a Web server.

m Click the Expand/Collapse icon to open the
split view Site Panel.

m Click the Connect icon to connect to your Web
server.

m In the Remote Site window, locate the directory
in which you want to place your e-mail message
image files.

[ Common] Layow | Tem| Tables| Frames| Fﬂrms‘ Templates | Characters | Media | Head | Sotipt| Apploation] goodies |
SRR X =)=
§2 Title: l—\&ﬁﬂ C‘«’»‘»(} i,
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. .([/ \.m (W XD ”ﬂm"“ﬁ

vz MODERNMETHOD

‘Welcome 1o the very first issue of Web Design Tips & Techniques

In this issue you will find: L [

= How to Export a Layout from Fireworks Into Dreamweaver
How to Create a Flash Menu in Dreamweaver
EE] How to Create a Ternplate Driven Web Site

| In the Spotlight: InstaGraphics Extension for Dreaweaver] 2

r, (13, ctables e 1 < chonts <stiongs clonts TT14309 o 2818500
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m In the Local Site window, select the files you
want to upload and drag them to the directory in
the Remote Site window.

STEP 3: MAKE IMAGE SOURCE PATHS
ABSOLUTE

m On your HTML page, change the image source
path to the absolute path on your Web server. For
example, the header image source path changes
from images/header.jpgtohttp://
www.yourwebsite.com/images/header.
jpg. To make this change, you can select your
image in Design View and edit the image Src field
in the Property inspector to reflect the change
noted above.

m Make sure that any links to other pages on
your server are also absolute. You can make the
change by selecting any part of the link in Design
View and editing the link field in the Property
inspector.

STEP 4A: SEND YOUR HTML E-MAIL
FROM OUTLOOK

Now that you prepared your e-mail in Dreamweaver,
it’s time to send it!

m In Outlook, open a new e-mail message by
choosing File > New > Mail Message.

—IGd

If you use another application to FTP your files
to your Web server, please use it as you would
normally. It is not necessary to upload your
files using Dreamweaver.




Designing a Compelling HTML E-Mail Newsletter

m Make sure that the format of the e-mail is
HTML. You can check this by choosing Format >
HTML on the menu in the New Message window.
m Place your cursor in the message body area and
choose Insert > File. The Insert File dialog box
appears.

m Browse for the Technique24.htm file and click it
once to select it.

m Click the down arrow next to the Insert button
and choose Insert as Text from the menu that
appears. The content of Technique24.htm appears
in the body of the e-mail message exactly as you
created it in Dreamweaver. See Figure 24.4.

STEP 4B: SEND YOUR HTML E-MAIL
FROM OUTLOOK EXPRESS

Sending your HTML e-mail from Outlook Express is
slightly different, though just as quick and easy.

m In Outlook Express, open a new e-mail message
by choosing File > New > Mail Message.

m Make sure that the format of the e-mail is Rich
Text (HTML). You can check this by choosing
Format > Rich Text (HTML) on the menu in the
New Message window.
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m Place your cursor in the message body area and
choose Insert > Text from File. The Insert Text
File dialog box appears.

m Choose HTML Files from the Files of Type
menu at the bottom of the dialog box. Then,
browse for the Technique24.htm file. Double-click
it to insert it into your mail message. The content
of Technique24.htm appears in the body of the
e-mail message exactly as you created it in
Dreamweaver. See Figure 24.5.

— il

Occasionally, some text may lose formatting or

may look quirky after the HTML is inserted into
the mail message. Usually, you can fix these
minor details inside that mail message using
the text formatting tools provided in the e-mail
program. However, HTML editing capabilities in
a mail message window are never as robust as
those in Dreamweaver. Using Dreamweaver for
major changes to the layout is best.
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As previously mentioned, sometimes text may lose
formatting, or the layout may look slightly different
in the mail message. With Outlook Express you have
a bit more flexibility for making changes because you
can view and edit the HTML source code of your
message. To view your message as pure HTML,
choose View > Source Edit. Three tabs appear on
the bottom of your mail message: Edit, Source, and
Preview (see Figure 24.6). Click the Source tab to

HY New Message
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<META http-esquiv=Content-Type content="text/html; charset=iso-G859-1">
<META content="MSHTML 6.00.2712.2200" name=GENERATOR> o
<STYLE></STYLE>
</ HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=irial size=2>
<TABLE cellSpacing=0 cellPadding=0 width=550 align=center border=0>
<TBODY>
<TR>
<TD><ING height=101
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edit the HTML source code, and then click the
Preview tab to see how your sent message will look.
To edit just text, you can work in the Edit tab. Keep in
mind that editing your e-mail in Outlook Express
will not save the changes to the original HTML file,
Technique24.htm. See Figure 24.7 for the finished
newsletter.
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CREATING A FLOATING
DHTML TOOLBAR

3 Guzman Menu - Microsoft Internet Explorer EEX 2 Guzman Menu - Microsoft Internet Explorer
Fe Edt View Favoites Tools Hep ar Fle Edt Vew Favortes Tools Help
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- ~
AR GUZMAN&COMPANY A GUZMAN&G COMPANY
w Member of the New York Stock Exchange w Member of the New York Stock Exchange
Home Investment Banking Institutional Brokerage Corporate Services Research About Investment Banking Institutional Brokerage Corporate Services Research
o N o B
President's Message President's Message
e
When Guzman & Company was founded back in 1987, our vision was to build a client-oriented firm When Guzman & Company wa e our vision was to build a client-oriented firm
that would combine the capabilities of the latest trading technologies with the talents of highly that would combine the capabilities of the latest trading technologies with the talents of highly
motivated and experienced employees operating in an motivated and experienced employees operating in an
entrepreneurial environment. By marrying those strengths, we were entrepreneurial environment. By marrying those strengths, we were
convinced we could create a dynamic and truly exceptional firm convinced we could create 2 dynamic and truly exceptional firm
that would be able to contribute significantly to the success of that would be able to contribute significantly to the success of
investors by providing them with consistent, first-rate execution. = investars by providing them with consistent, first-rate execution, =
As things turned out, we were correct. Our vision already has been As things turned out, we were correct. Our vision already has been
translated into reality in the institutional market place. Today, translated into reality in the institutional market place. Today,
Guzman & Company is a leader in the provision of creative, global Guzman & Company is a leader in the provision of creative, global
execution solutions to institutional investors. The challenge now is execution solutions to institutional investors. The challenge now is
to enable the individual investor to benefit from that same level of to enable the individual investor to benefit from that same level of
expertise and commitment. expertise and commitment.
To meet this challenge, we are focusing on four key elements of To meet this challenge, we are focusing on four key elements of
the value equation for individual investors: the value equation for individual investors:
« Quality trade execution + Quality trade execution
o Fair, inclusive access to capital markets « Fair, inclusive access to capital markets
« Useful, high-quality proprietary and third-party research 8 + Useful, high-quality proprietary and third-party research 2

25.1 (CP 37)

—

You can find all of the files
used in this technique in the
folder named Technique 25
on the CD-ROM.

25.2 (CP 38)

f you're designing a site that requires various levels of menu navi-

gation and don’t want to clutter the body with second and third

level toolbars, a great solution is to use a floating layer to build a

menu that expands dynamically over the body of the page, as

shown in Figure 25.2 (CP 38). When the person’s mouse moves
away from the menu, the menu disappears automatically.

Many techniques exist to create a menu such as this one. I'll be the first to
point out that this solution is not the most efficient when compared to
those scripted from the ground up, or premade templates generated by
software such as Fireworks. If you are comfortable editing JavaScript code,
various hard-coded solutions are available all over the Web. A good place to
start is the Macromedia Exchange site (www.macromedia. com), where
various extensions produce crafty DHTML code for dynamic menus.

However, you will find that this technique is one of the easiest ways to
build a custom DHTML menu with absolutely no code writing involved.
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This technique is based on common table and layer
commands, so it’s also very easy to customize them to
your liking.

STEP 1: INSERT YOUR MENU GRAPHICS

You can begin building your horizontal menu as you
normally would. Many designers prefer to slice each
button individually for rollover effects, which you can
combine with the DHTML menu for added effect.
This example uses a menu that already has rollover/
rollout behaviors assigned.

m Create a new Web page with an image-based
menu or use the Menu_Template.htm file pro-
vided on the CD-ROM. If you are new to creating
image-based menus, please refer to Technique 12,
“Building Rollovers in Fireworks and Exporting
Them to Dreamweaver.”

m Insert a value to both your left and top margin
in the Page Properties dialog box by choosing
Modify > Page Properties (Ctrl+]), even if the
values are zero. Netscape and Internet Explorer
have slightly different defaults for page margins,
so this prevents your layers from appearing to be
misaligned with your page.

—

If you want to import a single graphic for a
menu, you can use an image map to create hot
spots for both the links and the Layer behaviors
outlined in the next section. See Technique 3 for
more about image maps.
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STEP 2: CREATE A SECOND LEVEL MENU
TEMPLATE

m Choose Insert > Layer. Resize the layer 100%
larger than your button. Center the layer to your
button and position the top of the layer over your
button.

m Click inside of the layer and then choose
Insert > Table.

m Create a three row, three column table. Merge
the three cells on the first column into one large
cell by using the Merge Cells button on the
Property inspector. After the table is created,
specify a width in pixels.

m Repeat the previous step on column three. The
result is a table with five cells— two long ones on
the sides and three in the center. Set the table bor-
der to 0 so that it is invisible beyond this point.

m Insert a one column, multiple row table in the
center cell of the table. This nested table houses
your menu links.

m Set a background color of your nested table or
table rows/columns. This step is vital because your
links can be difficult to read when overlapping the
body content. You can also set the font color and
size to improve their legibility.

m Insert some links into the rows of your nested
tables. These links save you time when you copy
and paste this template for your other menus.

m Position the layer to where the top of the first
row of the nested table is flush with the button
on your menu (see Figure 25.3). Dreamweaver
may not show the same position as your Web
browser — the best way to check if they are flush
is to preview in your browser periodically as you
design.



Creating a Floating DHTML Toolbar

STEP 3: CREATE ALL MENU LAYERS

This step shows you how to create a foolproof param-
eter that hides your layer as soon as the mouse exits
the submenu.

—iGd

This exercise assumes that your menu is left
aligned and all of your layers have fixed left
positioning. If your page is centered and you
want to write your own code to support this,
you will have to script the position of your layers
dynamically with custom JavaScript. You can
calculate this dynamic value of left by subtract-
ing the browser resolution from the total width
of your buttons area (usually the width of the
table that houses them), and then adding the
desired left position. You may also need to add
page margins to your formula.
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E fyrlamic and truly exceptional firm
ithat would be able to contribute significantly to the success of
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m Copy and paste the layer template you've cre-
ated in the previous step until you have enough
layers for all of the buttons for which you plan to
show submenus.

m Position each layer accordingly so that

the layer’s location logically corresponds to

the button. Please refer to Figure 25.4 for an
example.

m Give each layer a unique name. Your layer
names should begin with a letter and contain no
spaces. Unless you intend to show multiple layers
at a time, the Z-index is not important. If you do,
create your visibility hierarchy by setting higher
numbers on the uppermost layers.

m Save and preview your work.

STEP 4: TURN LAYERS ON AND OFF

Now that all of your layers are in place, you must
assign behaviors to your buttons to control their visi-
bility. In addition, this step shows you how to use an
invisible GIF to create a flexible parameter that hides
your layer after the mouse moves away from the layer.

m Click one of your buttons. In this example, the
button selected is “Investment Banking.”
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m Click the Plus Sign (+) button in the Behaviors
panel and choose Show/Hide Layers. The
Show/Hide Layers dialog box appears.

m Set the layer you want to show when this
particular button is touched to Show (see

Figure 25.5). Set every other layer to Hide.
Repeat this step for all of the other buttons.

STEP 5: INSERT A SPACER
GIF WITH BEHAVIORS

If you preview your work before this step, you should
have layers that work like traffic lights— one turns
on at a time but remains on until another one is
called on. In other words, you need something to

There is no limit to how many levels of menus
you can create. Keep in mind your ideal page
dimensions, because you don't want your
menus going off the page on low-resolution
displays. Please refer to the folder named
Third_Level in the Technique 25 folder on the
CD-ROM to view an example. | did this by insert-
ing an arrow graphic as a button and followed
the same steps listed previously.The only differ-
ence is that you have two layers set as Show for
a third level button — the third level and the
parent layer where the button resides.

Show-Hide Layers

5]
layer "Brokerage™ (hide) ‘ =
layer "Research” (hide
Cancel

layer "Corporate” (hide)

Named Layers:

25.5
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hide the layers after they touch those empty cells you
created in Step 2.

The invisible GIF, also known as a spacer GIF, is a
one color graphic with the same color set to transpar-
ent so that it cannot be seen. The concept is to create
an invisible border around each menu with these
GIFs, assigning behaviors to them that hide the
menus on mouse contact. This works because the
mouse cannot move out of the menu area without
going over one of these GIFs, triggering the Hide
behavior.

m Insert a spacer GIF into one of the blank cells.
m Click the Plus Sign (+) button in the Behaviors
panel and choose Show/Hide Layers. This time
click and select all layers and hide every single one
listed (see Figure 25.6). Click OK to close the dia-
log box.

m Copy and paste this GIF into all empty cells you
created. Size the GIF as needed.

m Use the Vis menu in the Property inspector to
set the visibility of all layers to hidden. Save and
preview your work.

—

Designating other common menu areas with
hide-all functionality is also a good idea. For
example, if the mouse touches the logo, you
can hide all of the layers. This particular site has
a logo graphic with a white background that
spans the full length of the top menu, so moving
anywhere beyond the top of the menu triggers
the hide layers event.The spacer GIF is very ver-
satile because you can size the hide-all perime-
ter to your needs. If you add more layers in the
future, you can simply cut and paste it into

those blank cells while retaining its hide-all
properties. The only elements you have to
tweak by hand are the buttons — hide the new
layers you create accordingly.




Creating a Floating DHTML Toolbar 119

Your DHTML menu is complete as shown in Figure m
25.7. You may need to fine-tune the size of your
GIFs and your layer positions to get a pixel-perfect I encourage you to experiment with other solu-

presentation.

tions as soon as you grasp the theory behind
this technique. For example, experiment with
the OnBlur event instead of relying on the invisi-
ble GIF. Remember, you can also assign behav-

Show-Hide Layers E

Named Layers: m

-y Lo ] iors to blank cells —the invisible GIF is not a
yer "Research” (hide)
[ “InvBanking”™ (hids . . .
e Gt (e required component, but it does make the job
elp
easier.
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When Guzman & Company wallshss h our vision was to build a client-oriented firm
that would combine the capabilities of the latest trading technologies with the talents of highly
motivated and experienced employees operating in an
entrepreneurial environment. By marrying those strengths, we were
convinced we could create a dynamic and truly exceptional firm
that would be able to contribute significantly to the success of
investors by providing them with consistent, first-rate execution.
As things turned out, we were correct. Our vision already has been
translated into reality in the institutional market place. Today,
Guzman & Company is a leader in the provision of creative, global
execution solutions to institutional investors. The challenge now is
to enable the individual investor to benefit from that same level of
expertise and commitment.

President's Message

To meet this challenge, we are focusing on four key elements of
the value equation for individual investors:

# Quality trade execution
s Fair, inclusive access to capital markets
e Useful, high-quality proprietary and third-party research
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CHAPTER ‘

DESIGNING

FOR HIGH
ACCESSIBILITY AND
LOW BANDWIDTH

f you want your Web site to reach the broadest

possible audience, you can add features to

enhance accessibility. Take into consideration

visitors with disabilities who often use special

browsers, as well as visitors with low band-
width connections, especially important for sites that
reach an international audience.

The techniques in this section aren’t as flashy as some
of the others, but they are easy to implement and may
be the most valuable when it comes to ensuring that all
of your visitors have a good experience on your Web site.
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USING DREAMWEAVER'’S
ACCESSIBILITY TOOLS
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California Beaches
By Dave Mitchell

Fall weather is often the most pleasant in the San Francisco Bay Area, for the days tend
to be warm and slies are typically sunny. Visitors to Marin County looking for a Riviera
where they can a few fall days beside San Francisco Bay wil find their Mediterranean
destination in Sauselito and Tiburon. Here stylish people eat and drink beside the water
as sailboats skim across the waves
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You can find all of the files
used in this technique in the
folder called Technique 26
on the CD-ROM.
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26.2 (CP 40)

f you’re not sure about all of the elements you need to have on
your Web pages to ensure they are accessible to visitors with dis-
abilities, or you're just not sure you remembered to apply accessi-
bility options to all of the elements on your pages, Dreamweaver’s
accessibility tools can help you double-check your work.

One of the key elements of accessible page design is that elements, such as
multimedia files, as associated with labels and descriptions can be “read” by
special browsers. When you activate Dreamweaver’s accessibility features in
preferences, special dialog boxes appear to remind you to add accessibility
elements, such as the one shown in Figure 26.2 (CP 40).
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STEP 1: ACTIVATE DREAMWEAVER’S m Choose Edit > Preferences and select
ACCESSIBILITY TOOLS Accessibility to reveal these options, as shown

in Figure 26.3.

m Place a checkmark in each box to activate the
feature. You can choose to activate any or all of the

Before you can use Dreamweaver’s accessibility tools,
you need to activate them in Preferences.

Preferences Ed
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I:l:ude-:ull:uring Show Attributes when Inserting:
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Fonts Images
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Layout Yiew
Mew Document
Panels Offzcreen Bendering [Dizable when using Screen Readers)
Prewview in Browser
Guick Tag Editar
Site

Status Bar
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Make Dreamweaver uze Large Fonts

k. ][ Cancel ] ’ Help
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Using Dreamweaver’s Accessibility Tools

accessibility tools. You must restart Dreamweaver
for this change to take effect.

STEP 2: USING ACCESSIBILITY TOOLS

m After you activate these options, you are
prompted to add the necessary elements, such as
the Alternate Text and Long Description shown in
Figure 26.4.

m If you create a page that uses Frames, you’ll be

prompted to name each frame to make it accessible.

m Multimedia objects, such as video clips and
Flash files, also have accessibility attributes.

— il
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In addition to editing alternative attributes in
the Tag Code Editor, you can edit the text
directly in Code View (but only if you really
know what you're doing).

—

Dreamweaver has a number of features built-in
that make it more accessible to use by anyone
with disabilities. For example, you can set up
key commands to use the keyboard to navigate
Dreamweaver’s floating panels, Property inspec-
tor, dialog boxes,and more.

Image Tag Accessibility Attributes

Alternate Text: | Coastal Traveler |
Long Description: |http:,l',l’www.coastaltraveler.com | =

26.4

When you insert these elements on your pages,
Dreamweaver prompts you for the appropriate
alternative information. To edit accessibility val-
ues for media objects, right-click (Windows) or
88-click (Mac) and choose Edit Tag Code.

m Form elements, such as radio buttons and text
fields, also have accessibility attributes. When you
insert form elements on your pages, Dreamweaver
prompts you for the appropriate alternative infor-
mation. To edit accessibility values for form ele-
ments, right-click (Windows) or 88-click (Mac)
and choose Edit Tag Code.

Many government organizations and non-
profits require that Web sites be accessible to all
potential users. As part of the Americans with
Disabilities Act, if your group or agency receives
government funds, you could be required to
comply with accessible Web design techniques.







PROVIDING MULTIPLE NAVIGATION
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You can find all of the files
used in this technique in the
folder called Technique 27
on the CD-ROM.
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Janing is a part-time lecturer at the University of Southern California Annenberg
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27.2 (CP 42)

roviding text navigation elements, such as the one shown in
Figure 27.2 (CP 42), is one of the simplest ways to make your
Web pages more accessible to those with disabilities, as well as
those limited by slow connections. The images with the
rollover effect shown in Figure 27.1 (CP 41) provide an excel-

lent design option and intuitive user interface, but those images take longer
to load than text and won’t be visible to everyone. Even if you provide alter-

native text behind your images, as described in Technique 26, providing a
list of text links at the bottom of your pages is a commonly recognized
alternative to graphic options and saves viewers time and effort.

STEP 1: CREATE A TEXT NAVIGATION ROW

m Type to enter a text description for each of the pages you link to in
your navigation row.

m Separating each word or phrase with a non-text element, such as the
vertical bar (]) or the tilde (~) is good.
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m Create links for each of the words or phrases as
you would for images in a navigation bar. If you
use one big image and want to create an image
map, Technique 3 in Chapter 1 shows you how.

m Save the text navigation row as a part of a
template or as a library element to make it easy
to place on multiple pages. (See Technique 38

in Chapter 8 to find out how to use templates

for this purpose.)

STEP 2: MAKE A TEXT NAVIGATION ROW

A LIBRARY ITEM

m After you type in the navigation row and set all
of the links, click the Assets tab in the Files panel
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and select the Library icon from the bottom left,
as shown in Figure 27.3.

m Click to highlight the entire navigation row, as
shown in Figure 27.4, and drag it onto the Library
Assets panel. It automatically is added as a library
item.

m Name the library item something you’ll
remember when you need it next. I've named
mine Text Navigation Row, as shown in Figure
27.3.You can click and drag it from the library
onto any other page to add the navigation row.

See Figure 27.5 for the navigation row on a Web site.

Dreamweaver’s template and library items fea-
tures offer the added benefit that if you ever
edit them, the change is automatically applied
to every page where that library item is used or
the template is applied. This is especially useful
for elements, such as navigation bars, which
appear on every page on a Web site and often
need to be changed when you add, remove, or
alter new sections of a site.

fHome ~ Wy

27.4

Home ~ Espafiol ~ Eiugra?hiﬂ‘ Writing ~ Services ~ Resources ~ Contact Janine
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USING ALT TAGS TO DESCRIBE IMAGES

T ommon | Loxou| Teu] Tables | Frames | Forms| Templaes]| Charactors | eda] e Serpt ppication]
BEEE I =R
557 | et [Jarine warner Communicatin 0, @, | C <> (), FE.

W =
< [
as

50 tus<ing src=

sz
53 " celipadding="0">
sa
a0 s e A e &
>
~

i || ety | ronem || s | i | v

o
Janine Warner,
= n
=

g Jarine fa Yo weid Eonference of svent to captlre the iinagination With a Keynots Speech o afer & Gt filed breakild
sessions and haltday seminars. Janine tailors her speeches to each audience with specific examples from your business o
industry. and she can sneak to vour audience in Enalish and Snariish. For more information. cantact Jarine.

< >
Untted1| ndea” | indes*
lebodp caabies ctn e cables er s crables e 1 <35 <imgs TEERITT . 2T sec

28.1

—

You can find all of the files
used in this technique in the
folder called Technique 28
on the CD-ROM. All of the
Alt tags have been inserted "
behind the images in this are displayed.

sample page.

{’j [Be] Wwiiing | [2a] [Se] Pattners | [3] [&] Speaking | [3d Ties

(2] Spesking

Bing Janine to your next conference or event to capture the imagination with a keynote speech o offer a fact-filed breakout
sessions and hall-day seminars. Janine tailors her speeches to each audience with speciic examples from your businsss or
industry, and she can speak to your audience in English and Spanish, Far more information, contact Jarine,

Your Niche on the Web: Making Your Expertise Work for You

Paw that you can find almost anything on the Intemet, credibilty and expertise are increasingly important. Whether you sell
ane specialized product o a wide range of products and semvices, this factfilled session will shaw you how to attract new
customers by facusing on what you know best. Author Janine Wamer draws on her reakworld experience as an Intemet
executive to guide you through the process of identifying valuable niches and show you how to stand out as an expert your
customers will trust, come back to, and buy from again and again

Web Strategies That Work: A Clicks-and-Mortar Guide to Online Success

Beyond the wild promises, there are at least five ways you can successfully use the Interet in your business. Some of the
best success stories on the Internet today are about traditional companies finding clicks-and-mottar solutions that make
fmoney, save money, and better server yaur clients and customers. In non-techie jargon, Dummies author Janine Warmer
offers practical, cost-effective methods for providing greater convenience and value online. Find out how the Intemet is
helping shape the global economy and discover the right mix of services, consultants, and budget to make your business
work online

Getting the Best Value from Technology
Discover the best ways to get top value from the technology you invest in for your business. Learn the five biggest mistakes
people are still making when they invest in new technology, especially on the Internet, and get a sneak preview of the thiee

hottest technical that will imoact vour company. Janine YWarmer_author. consultant. and former Director of ™

28.2

It text is one of the simplest and most important HTML
attributes, but it’s also one of the easiest to forget to include
because it is included “behind” an image, where it is not visi-
ble to most viewers. If you use the Internet Explorer browser,
the Alt text appears when you move your cursor over an
image, as shown in Figure 28.2, but it is otherwise invisible when images

Alt text is important when someone views your pages with the images
turned off or uses a browser that does not display images. (Yes, there really
are browsers that don’t display images.) And Alt text is crucial for visitors

who are blind or visually impaired and use text browsers or readers because
Alt tags provide alternative text that can be “read” by special browsers for
the visually impaired. If you use images for buttons or other text informa-
tion, Alt text is especially important because without the alternative text
description, the meaning of buttons is lost to these users.

129



130

As Web pages are viewed on more and more
devices, such as handheld computers and even cell
phones with very small screens, Alt text becomes
important for new reasons because many of these
small devices use text-only browsers that only pick up
the text on a page.

STEP 1: INSERT ALT TEXT

Alt text is simply a word or short description that is
included in the code that inserts an image on a page.
If an image is not visible in a browser, the Alt text dis-
plays in its place. If a visitor uses a special browser to
“read” the page out loud, Alt text is read in place of
the image.

Dreamweaver makes it easy to include Alt text:
Simply type in the text you want as an alternative in
the Property inspector.

To add Alt text to an image, follow these steps:

m Insert an image or select an image that has
already been inserted on a page (see Figure 28.3).
Notice that after you select an image, the Property
inspector displays the image properties.

m In the top right of the Property inspector, enter
the text you want to provide as an alternative behind
your image in the Alt text box (see Figure 28.4).

m The alternative text is automatically inserted in
the Image tag in the source code.

Writing : Biography i Partners : Services : Speaking
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STEP 2: LOOK FOR MISSING ALT TAGS

It’s easy to forget to include Alt tags when you're
developing a Web page. You don’t see them, and the
page works perfectly in most browsers without them.
Here are three ways to look for missing Alt text.

m You can select any image and view the Alt text
area of the Property inspector to see if the alterna-
tive text has already been included. If not, simply
type it into the text field in the Property inspector.
m If you use the Internet Explorer browser, you
can turn off images so that they don’t display. The
Alt text is then visible in the browser window, or
not visible if no Alt text is included. This method
makes it easy to see all the missing Alt text on a
page with one glance. To turn off images in
Internet Explorer, choose Tools > Internet

You can enter any text you want as alternative
text behind an image, but, in general, it’s best
to keep it brief and focus on a description that

would be useful to someone who can't see the
image. For example, if the image is a Contact Us
button, you can simply include Contact Us as
the alternative text. If the image is a photo or
complex design with no words, consider includ-
ing a brief description.




Using Alt Tags to Describe Images

Options and then click the Advanced tab. Under
Accessibility, place a check next to Always expand
ALT text for images. Under Multimedia, remove
the checkmark next to Show pictures.

m Use Dreamweaver’s Accessibility Validation
tools, described in more detail in Technique 26
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earlier in this chapter, to automatically check for
missing Alt text. To generate a report that includes
a list of all images without Alt Tags, choose File >
Check Page > Check Accessibility.

See Figure 28.5 for a Web page with Alt text.
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INSERTING A QUICK-LOADING
LOW-RES IMAGE

B Low Res images - Netscape 6
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You find the color and black-
and-white versions of this
image, as well as the HTML
file, on the CD-ROM in a
folder called Technique 29.

f you want to offer big, beautiful images on your Web pages but

don’t want to lose visitors who get impatient waiting for them to

download over a slow connection, consider using a low-res image.

Here’s how it works: You insert a low-resolution image, which is

smaller in file size, at the same time that you insert the high-
resolution version—in the next section, you see how easy this is to do
when you use Dreamweaver. When your page loads, the low-res image
loads first, and if you make it a small file size, it pops right into place. Then,
the high-res image slowly appears over the low-res image, depending on
how long it takes for the high-res version to download.

Not only is this a great trick for low bandwidth users, but it can also create
a cool effect as the high-resolution image replaces the low-resolution ver-
sion. One of my favorite uses of this trick is to take a color photograph,
such as the one shown in Figure 29.1 and create a black-and-white version
to serve as the low-res version. Black-and-white works well for low-res
because when you strip out the color, you end up with a much smaller file
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size, even though it’s exactly the same physical
dimension. Not only does this create the illusion that
the page loads more quickly, it creates a cool effect
when the black-and-white image slowly transforms
into a color one. To give you an idea about how much
smaller the file size can be when you strip out the
color, the low-resolution, black-and-white version is
only 4.5K, while the high-resolution, color version is
four times the size at 20K.

STEP 1: CREATE A LOW-RES IMAGE

The simplest way I've found to create a low-res ver-
sion of a color photograph, such as the one used in
this example, is to open the color image in a program
such as Adobe Photoshop and change the image
from color to grayscale. To do this, choose Image >
Mode > Grayscale, as shown in Figure 29.2. As soon
as you have two versions of the image, use the follow-
ing steps to insert the high-res and low-res versions in
Dreamweaver.

—EGd

Not all browsers support this feature, but if

the browser used to view your page does not
support low-res images, it displays the high-res
version only.

Chapter 6 Designing for High Accessibility and Low Bandwidth

You insert a low-resolution image in Dreamweaver
just as you insert a high-resolution version. I recom-
mend that you insert the high-resolution version first
and then add the low-resolution version. Follow
these steps to do so.

m Choose Insert > Image and browse to find the
image. As soon as the image loads on the page,
click to select the image so that the image proper-
ties are visible in the Property inspector.

Mode 3
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Inserting a Quick-Loading Low-Res Image

m If you want to add a low-res version to an exist-
ing image, simply click to select an image that has
already been inserted on a page. Notice that when
an image is selected, the Property inspector dis-
plays the image properties.

m In the bottom of the Property inspector, just
under Target, you find a text box labeled Low. Use
the Browse button to the right of the Low text
box, shown in Figure 29.3, to find the image you

+ Properties

— Image, 20K W Src |cnlur-high-res.jpg |'E3'[E:| Al |Desert Phato v|

| | H|320 | Link |
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want to use as the low-res version. (The Browse
buttons in Dreamweaver all look like small file
folders.)

m After you select the low-res version, you should
see the high-resolution version in the Src area of
the Property inspector and the low-res version in
the Low area of the Property inspector.

m Save your work and preview it in a browser to
see the effect.
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IMAGE TRICKS
THAT MAKE YOU
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erforming the simple techniques that
follow can quickly add style and life to
your Web pages. You should be familiar
with rollovers and layers to work through
the techniques in this chapter.
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‘“ZOOMING IN”" WITH ROLLOVERS

Lorelai Model 1
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Pantry/Utility Room

30.1 (CP 43)

—

For this technique, use the
files in the Technique 30
folder on the CD-ROM. For
an example of this tech-
nique, open the file called
zoom_finished.htm in the
Technique 30 folder.

Lorelai Model 1
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25 Bathrooms

— =
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e
TIPS I
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30.2 (CP 44)

his technique combines rollovers (see Technique 2) and
image maps (see Technique 3). When you mouse over a cer-
tain part of the image map shown in Figure 30.1 (CP 43), it
appears to be zooming in to that area of the image, as shown
in Figure 30.2 (CP 44).
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STEP 1: PREPARE THE MAIN IMAGE AND
THE ROLLOVER ZOOM-IN IMAGES IN A
GRAPHICS EDITING PROGRAM

When creating a “zoom-in” rollover, your original
image and all zoomed-in images should be the same
width and height as the original image so that it cov-
ers the same space. In this technique, I use Adobe
Photoshop to prepare the images, but the steps are
similar in other graphics editing programs, such as
Macromedia Fireworks or Corel Photo-Paint. If you
are using the files from the CD-ROM and prefer to
skip this step, a set of zoomed-in images are also
available on the CD-ROM in the “images” subfolder
of Technique 30.

m Choose File > Open and browse to find
original.gif.

m Reduce the image to 25% of its original size and
save it as zoom.gif. This is the starting image on
your page. Leave this file open in your graphics
program.

Chapter 7 Image Tricks That Make You Look Good

m Copy sections of the original.gif file and paste
them into the zoom.gif file, saving each new sec-
tion as a separate file with a descriptive name,
such as “master_suite.gif” and “livingroom.gif.”
See Figure 30.3. This method of copying and
pasting ensures that all your rollover image files
are the same width and height as zoom.gif.

STEP 2: INSERT STARTING IMAGE
INTO WEB PAGE

In Dreamweaver, you now insert the starting image
into its position on your Web page.

m Open the page you want to use. If using

the files from the CD-ROM, this page is called
Technique30.htm.

m Insert the starting image.

© zoom.gif @ 100... [=|B]X]

30.3



“Zooming In” with Rollovers

STEP 3: CREATE THE IMAGE MAP

m Using the Image Map Shape tools, mark off
each area of the image that you “zoom” into, mak-
ing sure not to overlap any of the areas. You should
know beforehand what areas you want for zooming
in, because you created all the zoomed-in images
prior to starting any work in Dreamweaver. See
Figure 30.4.

STEP 4: ADD ROLLOVER ACTION

m Click the Image Map Selection arrow and click
one of the highlighted areas of the image map.

m In the Behaviors panel, click the Plus Sign (+)
button and choose Swap Image from the menu.

m Click the Browse button to find the zoomed in
image that corresponds with the selected area.
Choose it and click OK. Then, click OK to close
the Swap Image dialog box. Follow this step for
every selected area on the image map.
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142 Chapter 7 Image Tricks That Make You Look Good

STEP 5: TEST THE ZOOM-IN ACTION

m Preview the page in your browser and mouse
over the image. Different areas of the image
should zoom in depending on where you place
your mouse. See Figure 30.5.
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TECHNIQUE

EDITING IMAGES FROM WITHIN

DREAMWEAVER
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For this technique, use
the files in the Technique
31 folder on the CD-ROM.
You find a page «called
Technique31.htm and a
Fireworks file called
Technique31.png.

I

boy 7984357 -, 16K 15500

31.2 (CP 46)

f you created your graphics in Fireworks—and even if you

haven’t!—you can edit your graphics later from within

Dreamweaver. As soon as you slice up your layout and begin

working in Dreamweaver, if you change your mind about

a graphic, it’s as simple as clicking the Edit button. See
Figure 31.1 (CP 45) for the graphic in Fireworks and Figure 31.2 (CP 46)
for the graphic in Dreamweaver.

STEP 1: SELECT THE IMAGE YOU WANT TO EDIT

The file you are going to edit in this technique was created in Fireworks;
therefore, the JPEG in the Dreamweaver document has a corresponding
.png file.
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m In Dreamweaver, choose File > Open and
browse to find Technique31.htm.

m Select the title image, header.jpg (see

Figure 31.3).

m In the Property inspector, click Edit. This
launches the Fireworks application.

m The first time you edit a file directly from the
Dreamweaver document, Fireworks displays a
dialog box asking if you want to use an existing
Fireworks file as the source for this image. In
this case, there is a Fireworks file available:
technique31.png. Click Yes and browse for this
.png file to open it in Fireworks.

—Gd

If you are editing a Fireworks file that was cre-
ated on another computer, you might not have
the fonts used in that file. In such a case,
Fireworks asks you if you want to Maintain
Appearance or Change Fonts. If you select
Maintain Appearance, the layout continues to
show the text in the missing font. If you choose
to edit the type, however, you will lose the origi-
nal appearance and will be asked to select
another font. If you choose Change Fonts,
Fireworks asks you to select another font from
your system to use in place of the missing font.

" L% ﬁm t:::*

COMPRNY

:-"'.E "ﬂ
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STEP 2: EDIT THE IMAGE IN FIREWORKS

m With the source file open in Fireworks, make a
change on the graphic. In this example, I am going
to add a tagline next to the logo.

m When you are satisfied with your changes, click
Done at the top of the Fireworks screen. See
Figure 31.4. The updated image appears automat-
ically in Dreamweaver as shown in Figure 31.5.

—

If you don't have a source file or you do have one

but prefer to edit the actual image instead of the
source file, click No, keeping in mind that any
changes you make to this image are permanent.
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BUILDING A POP-UP MENU

USING FIREWORKS
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For this technique, use the
files in the Technique 32
folder on the CD-ROM. You
find a Fireworks file called
Technique32_start.png and
a finished example of
the technique called
Technique32_finished.htm.
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S0 you think you'e had tasty spaghetti, eh? Enough of all that fru-fu gourmet
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32.2

his technique achieves a similar result to that achieved in

Technique 25, “Create a Floating DHTML Toolbar,” but it is

done using Macromedia Fireworks. After you create your

layout in Fireworks, adding a pop-up menu is a piece of cake.

The result is a very accessible Web site with a highly profes-

sional appearance. See Figure 32.2.
You can save a lot of time if you take a moment to plan your Web site nav-
igation before starting this technique with your own project. In this example,
you work with a recipe Web site called Mamma’s Kitchen. The navigation
consists of three major sections: Cooking Basics, Recipes, and Books. You
use Fireworks to create the navigation for the site. Under Cooking Basics

will be various links to information on meal planning, healthy cooking
alternatives, and tips for busy people. The Recipes menu links to such cate-
gories as Appetizers, Soups 'n’ Salads, Main Course, Side Dishes, and such.
The Books button won’t have a pop-up menu.
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STEP 1: OPEN YOUR SOURCE FILE

m In Fireworks, choose File > Open and browse
to find Technique32_start.png. In this example,
the graphics and slices are already done for you.

STEP 2: ADD THE POP-UP MENU

m Click the slice over Cooking Basics.

m Choose Modify > Pop-Up Menu > Add Pop-
Up Menu. The Pop-Up Menu Editor appears (see
Figure 32.3).

—

Fireworks also opens layout files created with
Photoshop, which you can then save as .pnd files.

Pop-up Menu Editor

Content |Appearance Adwvanced | Position

+
Teut Link. Target
Planning a Meal basics!planning htm
IFYou're Busy... basicsibuzyhtm
The Slow-Cooker bazicsislowcookerhtm

Party Planning basicsipartyplanning htm
Heathy Substitutes basicsihealthy.htm

32.3
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m Under the Content tab, click the Plus Sign (+)
button to add a menu item, and then enter the
name of the first link you want to have appear on
the pop-up menu. Tab once to move the cursor to
the next text box over. In this text box, enter the
URL for this menu item. If you want the linked
URL to open up in a new browser window, tab
over once more and choose _blank from the list.
m Click Next to move to the next tab.

m Under the Appearance tab, you can determine
what you want your menu to look like. You have
options for creating the menu in HTML or as
images, and vertical or horizontal. In this step you
can determine the typeface and size and the back-
ground and text color of the on and off states.
Refer to Figure 32.4 to see what I did.

m Click Next to move to the next tab.

Pop-up Menu Editor
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Pop-up Menu Editor
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m Under the Advanced tab — which sounds
scarier than it really is — you can define the
amount of cell spacing in each menu item, the
color of the border, and whether or not you want
a border to show. See Figure 32.5.

m Click Next to move to the next tab.

m Under the Position tab, you can determine
how you align the menu in relation to the slice.
See Figure 32.6. In this example, I aligned it to the
bottom of the slice and then played with the exact
X- and Y-positioning so that the menu appears to
be left-aligned with the text in each slice.

m Click Done. If you click one of the slices now,
you see an outline of the pop-up menu (see
Figure 32.7). Notice the behaviors listed in the
Behaviors panel: onMouseOver and Show Popup
Menu (see Figure 32.8).
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STEP 3: EXPORT YOUR LAYOUT

m After determining the properties for each slice,
choose File > Export. Save your HTML file as
menu.htm. See Technique 4 in Chapter 1 for more
on exporting a layout from Fireworks. You can
also use the file called menu.htm, available on the
CD-ROM.

STEP 4: COMPLETE YOUR LAYOUT
IN DREAMWEAVER

m In Dreamweaver, open the new HTML file
you created in Fireworks (or menu.htm from
the CD-ROM) and the file called Technique32_

Chapter 7 Image Tricks That Make You Look Good

start.htm. To complete your layout, you insert the
newly created navigation from menu.htm into
Technique32_start.htm.

m In Design View, select all the contents from
menu.htm and copy it.

m Switch to Technique32_start.htm and position
the cursor on the empty cell at the top of that
table. Paste into that cell. The contents of
menu.htm appear on this page. See Figure 32.9.
m Preview this page in your browser. To see an
example of the finished page, open the CD-ROM
file called Technique32_finished.htm in your
browser. See Figure 32.10.

cooking basics  redpes  books
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CREATING A SLIDESHOW USING THE
TIMELINE AND BEHAVIORS

—

33.1

For this technique, use the
files in the Technique 33
folder on the CD-ROM. You
can find the finished slide
show in the file titled
Technique33_finished.htm.

UUNTAIN |

f Flash isn’t available to you, alternatively you can create a

DHTML slideshow by using the timeline and behaviors in

Dreamweaver. In this technique, you create a three-photo

slideshow by using photos from my trip to Stone Mountain in

Georgia. See Figure 33.1. The first image slides in and a caption
appears to the right. After five seconds, that image slides out to the left as
the second image slides in and its caption appears. After another five sec-
onds, the second image slides out to the left and the third and final image
slides in with its accompanying text. Finally, a black layer slides in from the
top saying, “The End.”

STEP 1: INSERT LAYERS FOR FIRST PHOTO AND CAPTION

m Open a new page in Dreamweaver.
m Choose Insert > Layers to insert a new layer into your document.
Name this layer Photol. Inside the layer, insert the image called
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photol.jpg (choose Insert > Image). Make this
layer 200 pixels wide by 115 pixels high. You can
select the layer and enter these values in the
Property inspector.

m Choose Insert > Layers to insert another layer.
Name this layer Photo1Text. This layer holds the
caption for Photo 1. You can type some amusing
descriptive text about Photol here. Make this layer
331 pixels wide by 115 pixels high. This layer
should also be hidden. To hide this layer, choose
Hidden from the Vis menu in the Property
inspector. The Top position for both layers should
be 29 pixels. Enter this value for each layer in the
Property inspector next to “T.

STEP 2: ADD LAYER MOTION USING THE
TIMELINE

m Choose Window > Others > Timelines Panel
to view the Timelines panel.

m Click View > Visual Aids > Invisible Elements
to make sure you can see the yellow marker for the
Photol layer. Then, right-click Frame 1 of Row 1
on the timeline. From the menu that appears,
choose Add Object. This places a beginning and
ending keyframe on the timeline.

—

When working with layers, you can make them
any size you want in Dreamweaver. The sizes |
specify for the layers created in this technique
are just a personal preference to accommodate
the size of the images with which I'm working.

—
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m Drag the ending keyframe to Frame 15. Your
active frames should start on Frame 1 and end

on Frame 15 now.

m Select the Photol layer again and then click
Frame 1. Use your arrow key to nudge the frame
to the left until it is not visible; alternatively, type
—203 as the L value in the Property inspector.
Click the playhead above Frame 1 and drag to
move it across the timeline to Frame 15. The
Photol layer now moves smoothly onto the

page from the left.

m Release the playhead and move your mouse
cursor over to Frame 90. Because the frames ani-
mate at a rate of 15 frames per second, this causes
the Photol layer to remain in that position for five
seconds. Click Frame 90 and then reselect the
layer by clicking the yellow marker. Right-click
Frame 90 and again select Add Object.

m Drag the ending keyframe to Frame 105. Your
second set of active frames start on Frame 90 and
end on Frame 105 now. You are going to create an
exit animation for the Photol layer.

m Select the Photol layer again and then click
Frame 105. Use your arrow key to nudge the frame
to the left until it is not visible; alternatively, type
—203 again as the L value in the Property inspec-
tor. Click the playhead above Frame 90 and drag

The markers aren’t always in the expected order
on your document. You can click a layer’s yellow
marker and then use the Property inspector to
verify that you have chosen the correct layer.
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to move it across the timeline to Frame 105. The m On the timeline, move your mouse cursor over
Photol1 layer now moves smoothly to the left and and click Frame 105 and also the row labeled B.
out of the page. In the Behaviors panel, click the Plus Sign (+)

button and select Show/Hide Layers from the
menu. In the Show-Hide Layers dialog box, select
STEP 3: ADD BEHAVIORS TO SHOW AND PhotolText and click Hide. Click OK.
HIDE TEXT LAYERS

m Select the Photol layer on your document and STEP 4: PREVIEW IN YOUR BROWSER
click Frame 15 on the row labeled B above all the
other rows. See Figure 33.2. In the Behaviors tab, m Make sure that the Autoplay check box is
click the Plus Sign (+) button and choose Show/ checked, and press F12 to preview your slideshow
Hide Layers from the menu. In the Show-Hide in your default browser. The animation should
Layers dialog box (see Figure 33.3), select move along as described in the beginning of this
PhotolText and click Show. Click OK. technique.
Repeat Steps 1-3 to add the other two photos Show:Hide Layens
and “The End” slide to the slideshow. See the Named Layers: [Tayar "Fhatal”
finished file on the CD-ROM, Technique33_ it .
finished.htm, as a guide.
33.3
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TECHNIQUE

ADDING STYLE TO YOUR PAGE WITH
A FIXED TILING BACKGROUND

7 NARTIN T S buARIN !

CATERING PACKAGES (ORPORRTE EVENTS YACHT PAETIES CONTACT US REFERENCES CATERING PACKAGES CORPORATE EYENTY YACHT PARTIES CONTACT U8 REFERENCES

Welcome to Martini Time! Catering & Bartending. We are a boutique-sized
South Florids company specializing in intimate private gatherings and corporate
events for up to 100 peaple.

Welcome to Martini Time! Catering & Bartending. We are a boutique-sized
South Florida company specializing in intimate private gatherings and corporate
events for up to 100 people. We also offer 3 dinner party package on the Martini
Timel Yacht

by

34.1 (CP 47) 34.2 (CP 48)

m good Web designer knows that sometimes a solid color

For this technique, use the background just doesn’t cut it — see Figure 34.1 (CP 47).
files in the Technique 34 For those times, a seamless, tiling background does the trick,
folder on the CD-ROM. adding an element of style and personality to an otherwise
bland Web page, as shown in Figure 34.2 (CP 48).

STEP 1: CREATE THE ELEMENTS FOR THE TILING
BACKGROUND IN FIREWORKS

m In Fireworks, choose File > New to create a new document at 300
by 800 pixels. Alternately, you can browse the CD-ROM to find the
file called Technique34.png, which is already done for you.
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m Use any combination of drawing tools to draw
various shapes until you are satisfied with the
design or pattern. Keep in mind that the final size
of the tiling background image used as an example
will be 190 pixels wide by 420 pixels high, though
you can make your tiling backgrounds any size.

m Choose Modify > Symbol > Convert to
Symbol. In the Symbol Properties dialog box,
select Graphic and click OK.

STEP 2: CREATE THE TILING
BACKGROUND

m Position your symbol at X=0 and Y=0 using the
Property inspector.

m Select your symbol and choose Edit > Clone to
make a new layer with a copy of the symbol. Select
this clone and type X=190 and Y=0.

m Click the symbol at the 0,0 position to select it.
Holding the Shift key, click the clone next to it.
With both items selected, choose Edit > Clone to
create a copy of each one.

m Make sure these two new copies are selected
and move them down to a Y-position of 420 by
using the Property inspector.

34.

w Properties

Chapter 7 Image Tricks That Make You Look Good

m Use the Crop tool to crop this image down to
190 x 420 pixels (see Figure 34.3). You can tweak
the width and height of the crop marquee by typ-
ing in exact pixel measurements in the Property
inspector (see Figure 34.4).

m When you are satisfied with your tiling back-
ground, you can export the image by choosing
File > Export.

3

Document Canwas: !‘I [ Canwas Size... ] [ Image Size... ] @

technique3dbgl ¥

;| 130 w0

H:| 420 T (0

34.4
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STEP 3: ADD TILING BACKGROUND TO m Choose Modify > Page Properties. In the Page
YOUR WEB PAGE IN DREAMWEAVER Properties dialog box, browse for the image you
just exported from Fireworks. On the CD-ROM,
m Start Dreamweaver and open the file to which this file is called tilingbg_short.gif. Select your file

you will add the tiling background. You can use and click OK. Your background now tiles across
the file called Technique34_nobackground.htm the Web page. See Figure 34.5.

on the CD-ROM.

7 MARTINI TIME!

CATERING PACKAGES CORPORATE EVEXNTS YACHT PARTIES CONTMT us REFERENCES

YWelcome to Martini Time! Catering & Bartending. Ve are a boutique-sized
South Flarida company specializing in intimate private gatherings and corporate
events for up to 100 people. We also offer a dinner party package on the Martini
Time! Vacht.
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TILE STYLE

fyou prefer to have an area of solid color toward the bot-
tom of the tile, instead of having the pattern repeat
immediately, you can do this in one of two ways. With the
newer browsers, you can create a style for the body that speci- - _
fies no vertical tiling. For older browsers, you can make the tile jwm‘r?“dmnpzmr;“ﬂgiﬁ:::n?pkzh‘l&:
longer, for example, 800 pixels high. And only clone and nudge
to the right, omitting the last part of Step 2. See the following
figure and Technique34Alternative.htm on the CD-ROM for an
example.

?MARTINI TIMEI

CATERING PACKAGES CORPORNTE EVENTY YACHT PARTIES CONTACT US. REFERENCES




PREVENTING BACKGROUNDS FROM
TILING AND SCROLLING
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35.1 (CP 49)

—

You can find this pop-up
page in Technique 35 folder
on the CD-ROM.

35.2 (CP 50)

ne of the many uncertainties of Web design is that you

never really know in what screen resolution a person will

view your sites. When it comes to inserting full-bleed

graphical backgrounds, many designers make a big pic-

ture that tiles off the screen. This technique has one
major drawback — it can create a large file that will take too long to load.
You also are limited to how much content you can put on a given page,
because too much causes the background to scroll again. The best is to
explicitly define background properties with CSS, or Cascading Style
Sheets, so that there is no guessing involved.

If you set the background property of the page by using Dreamweaver’s
standard method, the background tiles by default, as shown in Figure 35.1
(CP 49). This behavior is predicted in HTML. However, you can use an
alternative method by using Style Sheets, which not only prevent the back-
ground from tiling, but also from scrolling off-screen, as shown in Figure
35.2 (CP 50).
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STEP 1: CREATE A STYLE SHEET

m Create a new Web page. Because you'll be
inserting an image, be sure to save your page
before proceeding.

m Choose Text > CSS Styles > New CSS Style to

open the New CSS Style dialog box.
m Select the Redefine HTML radio button. The

form field at the top of the dialog box changes to a
pull-down menu. Click to select the <body> tag.

If this background is going to be shared through-
out the site, select (New Style Sheet File) or an
existing style sheet located in your site under the
Define menu. Otherwise, select This Document
Only.

— il

If you want your background to stay on-screen
while the page scrolls, choose Fixed from the
Attachment menu. If your page has only a little
bit of content but you want to see what a fixed
property background does, simply press the
Enter key several times to create a longer page.
This choice keeps the background locked in its
place on the browser even while the page is
being scrolled.

Chapter 7 Image Tricks That Make You Look Good

STEP 2: DEFINE YOUR BACKGROUND

m The CSS Style definition for body dialog box
appears (see Figure 35.3). By default, Type is
selected. Click Background to change the dialog
box options.

m Click the Browse button to choose a
Background Image. Select your file and click OK.
Choose no-repeat from the Repeat menu.

m Click OK to close the CSS Style definition dia-
log box. Click Done to close the Edit Style Sheet
dialog box.

Your background now appears without tiling, as
shown in Figure 35.4. Save and test in your Web
browser.

€55 Style definition for body X
Categary Background
i rer—
E
Bsrder Background Image: ‘\mages."EG_\rie.ipg V‘ [ Browse...
List
Pogitioning Repeat: [ K
Extensions
Attachment:
Horizantal Pasition:
Vertical Positior:
0Ok ] [ Cancel ] [ Apply ] [ Help

—

Some older Web browsers do not support CSS,
such as Internet Explorer 3.

35.3
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CREATING TILING GRAPHICS FOR
USE IN AUTOSTRETCH LAYOUTS

A City Summer Camp - Fixed Width Example - Microsoft Internet Explorer

File Edt View Favortes Toos Help

:§ QT SUMMER CAMP "Who neads a stinkin' nature trail, anyway?"

GOVERNMENT PROGRAM  ARTS PROGRAM

Nature trails are for the birds! Our Programs

The Gevernment Program gets yauth
imvolved in our city's inner workings,
with hands-on experience and one-on-
one mentoring by city professionals

The Arts Progar brings together youth
dancers, artists, musicians and actors
with respected professionals for an
entire summer of personal guidance
Why spend a whole summer swimming  and mentoring

in a lake, hiking  nature trai, or
whitling dolls when you could be in the
city making history with our country's
government? How about turning your
hobby into an artform working side by
side with the most respected figures in
the American arts community?

LODGING  RATES

The Combine Program sllows youths
with multi-faceted interests the
oppotunity to enjoy the benefits of both
prograrms. Acceptance in this program
is limited and requires a personal
interiew with the prospective
participant

What are you waiting for?

Contact us today to register for
Summer 20031

BEE
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&

3 My Computer

36.1

—

For this technique, use the
files in the Technique 36
folder on the CD-ROM.

A City Summer Camp - Autostretch Example - Microsoft Internet Explorer E@\E\
o

: Fie Edt View Favoites Took Help

GOVERNMENT PROGRAM  ARTS PROGRAM COMBINED PROGRAM LODGING RATES REGSTRATION

Our Programs The Cormbine Program allows youths with

multi-faceted interests the oppotunity to
The Govemment Program gets youth enjoy the benefits of both programs
imvolued in our city's inner workings, with  Acceptance in this program is limited
hands-on experience and one-on-one and requires a personal interiew with the
mentoring by city professionals prospective participant

The Arts Progam brings together youth
dancers, artists, musicians and actors
with respected professionals for an entire
sumrmer of personal guidance and

Why spend a whole summer swimming  mentaring

in 2 lake, hiking a nature trail, or whitling
dolls when you could be in the city
making history with our country's
government? How about turming your
habby into an artform working side by
side with the most respected figures in
the American arts community?

[y What are you waiing or?

Contact us taday to register for Summer
2003

& 3 My Computer

36.2

ften, the best way to display the most information possi-
ble on any user’s Web browser is to create an autostretch
layout. This means the layout stretches to the width of
the browser window. This is also a quick and easy way to
make a Web page more visually appealing if there is too

much empty space — not that too much empty space is always a bad thing,

from a design perspective! See Figures 36.1 and 36.2.

STEP 1: PREPARE AND SLICE YOUR LAYOUT
IN A GRAPHICS PROGRAM

I provide both a Fireworks .png file and a Photoshop .psd file for your
convenience. Notice the background of the header/title area is a repeating
pattern of a yellow dashed line on a road.
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m Slice your layout for exporting to HTML. In the navigation’s graphic area ends abruptly (see
this example, I use Fireworks to export to HTML. Figure 36.1).
See Figure 36.3 for an example of a properly sliced

layout. You can also use Adobe ImageReady to
perform this step, or you can do it manually. The STEP 2: CREATE TILING BACKGROUND

HTML file called Technique36.htm shows the lay- GRAPHIC FOR HEADER AREA
out exported from Fireworks at a fixed width. I
added text and photos to complete the page. A lot
of empty space is to the right of the content, and

m Using the existing layout, hide any layers sitting
above the black and yellow pattern until all you
see is the pattern. Using guides and the Crop tool,
select one complete section of the pattern. See
Figure 36.4. As soon as you are satisfied with the

m selection, double-click anywhere within the
selected area to crop the image.
If you are not familiar with how to export a lay- m You now have only that small, cropped area on
out from Fireworks to HTML, see Technique 4 in your screen. Choose File > Export to export this
Chapter 1. image. You can find an example of this exported
image, called header_background.gif, on the
CD-ROM for reference.

H T suranvER AP

36.3
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STEP 3: REBUILD EXPORTED
HTML TABLES TO INCLUDE
TILING BACKGROUND

m In Dreamweaver, open the HTML file you
exported from Fireworks (or ImageReady). Your
goal here is to rebuild the navigation area so that
the main table that holds it all together has this
new tiling background graphic. See the file called
Technique36_finished.htm on the CD-ROM for a
finished example.

m While in Design View, click the page to insert
the cursor before any other content on the page.
Insert a new table with five rows and one column.
m Place your cursor in the first row of this new
table and use the Property inspector to add the
background image to that cell. Click the Browse
button next to the BG field to browse for the tiling
background graphic. Select it and click OK. See
Figure 36.5.

H T SUMMER CAMP

SOVERNMENT PROGRAM ARTS PROGRAM COI

Mature trails are for the birds! QOur Programs.

lkbodys <tatles <1 ctas

The Government Program gets youth
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m Still in this cell, insert another table, this time
with one row and three columns. In the first col-
umn, insert the title image (City Summer Camp).
You can copy and paste this from the old table that
should still be on your page. Repeat this step for
the other two images in this row.

m Next, create a 1 row/5 column table, and copy
and paste the table containing the navigation into
the second row of the new table. With the naviga-
tion table still selected, right-align the table by
using the Property inspector.

m In the third row of the new table, insert a hori-
zontal rule (choose Insert > Horizontal Rule).
Change the appearance of the rule in the Property
inspector. The width should be 100%, Shading
should be unchecked, and the height should be

1 pixel.

m In the fourth row, copy and paste the content
from your old table. This can remain the same;
just make sure that if it’s a nested table, that table
is also set to a width of 100%.

Remember you can refer to the file called
Technique36_finished.htm on the CD-ROM for
guidance.
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m Use the last row as a footer area. Give it a height
of 20 pixels and a black background. Insert footer
text, such as a copyright notice or an e-mail
address.

m Remove all traces of the fixed-width table
below the new autostretch table, save, and preview
in your browser. See Figure 36.6.

Chapter 7 Image Tricks That Make You Look Good

<3 City Summer. Camp - Autostretch Example - Microsoft Internet Explorer

File Edit ‘Wiew Favorites Tools  Help

HERE C'TY SUMMER CAMP

Nature trails are for the birds! Our Programs

The Government Pragram gets youth
involved in our city's inner workings, with
hands-on experience and one-on-one
mentoring by city professionals

The Arts Progam brings together youth
dancers, artists, musicians and actors
with respected professionals for an entire
summer of personal guidance and
rentaring.

YWhy spend a whole summer swimming
in & lake, hiking a nature trail, or whitling
dolls when you could be in the city
making histary with our country's
governrment? How about turning your
hobby into an artfarm working side by
side with the most respected figures in
the American arts community?

2, Ivanne Berkowitz

eds a stinkin’ nature trail, any

GOVERNMENT PROGRAM  ARTS PROGRAM COMBINED PROGRAM LODGING RATES REGIETRATION

The Combine Program allows youths with
multi-faceted interests the oppotunity to
enjoy the benefits of both programs.
Acceptance in this program is limited
and requires a persanal interview with the
prospective participant.

What are you waiting for?

Contact us today to register far Summer
20031
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TECHNIQUES TO SAVE
YOU REPETITION

f you're working on a Web site, you probably

don’t have any time to waste, especially on bor-

ing, repetitive tasks. So you’'ll be pleased to dis-

cover that Dreamweaver really shines when it

comes to features that automate tedious activi-
ties, such as changing one element of your navigation
bar across every page on your site.

In the earliest days of the Web, if you wanted to change
an element, such as a link that appeared on every page
on your Web site, you had to manually change each
instance individually. At the time, the best you could
hope for was to automate the process with a program
that had a good global search and replace feature, but
even then it only worked if you had created every link
exactly the same way on every page.

Today you have several ways to add elements to every
page on your site and easily change all of them automat-
ically if you want to make edits or additions later. One
way is to use Dreamweaver’s Library feature, which
enables you to store any element or collection of ele-
ments, such as a logo or a navigation bar, in a way that
makes it easy to add them to new pages and to make
global changes. Technique 37 walks you through the
steps to create and use Library items. Technique 38
shows you how to use frames to create navigation ele-
ments that can also be easily changed.
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If you want to save time on formatting, Technique
39 shows you how to create HTML styles to automate
formatting, and Technique 40 introduces you to the —
full power of Cascading Style Sheets. And finally, Wff ==
Technique 41 shows you how to save time by manag- -
ing multimedia files with the Assets panel. v
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CREATING A LIBRARY OF
COMMON ELEMENTS
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37.1 (CP 51)

—

You can find all of the files
used in this technique in the
folder called Technique 37
on the CD-ROM.

37.2 (CP 52)

ibrary elements can save you time and tedium by providing an
easy way to add commonly used items to multiple pages and to
make global changes automatically.
The Library feature is not a common feature in other Web
design programs, so the concept may be new to you, even if
you've been developing Web sites for a while. The more experienced you
are, however, the more likely you are to appreciate the value of this feature
and the time it can save you.

The Dreamweaver Library feature was designed to automate the process
of inserting and changing elements that appear on multiple pages in a Web
site. You can save any element as a Library item — for example, a logo or a
navigation row of images and links. You can then insert that element (or
collection of elements) on any page by simply dragging it from the Library
to the new page, which is what you see happening between Figures 37.1
(CP 51) and 37.2 (CP 52). Even better, if you ever need to change the
Library element (by adding a link or image, for example), you can change
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the element in the Library and let Dreamweaver
automatically apply the changes everywhere you’ve
inserted the Library item in your site.

A Library item is essentially a snippet of code that
can contain image references and links. Like tem-
plates, Library items are a great way to share the work
of your best designers with less experienced ones. For
example, a designer can create a logo and navigation
elements, and then these items can be placed in the
Library and made available to the rest of the team.
And you have more flexibility with Library items
than you do with Templates because you can place
Library items anywhere on any page, even multiple
times.

Library items can be made up of any element from
the body of a document, including text, tables, forms,
images, Java applets, and multimedia files. Library
elements are efficient because Dreamweaver stores
the snippet of code as a document in the Library
folder and then updates the links to it from wherever
the Library element is applied. Library items can also
contain behaviors, but there are special requirements
for editing the behaviors in Library items. Library
items cannot contain timelines or style sheets.

STEP 1: CREATE A LIBRARY ITEM

The following sections lead you through the steps for
creating a Library item, adding one to a page, and
editing a Library item when an element changes. For
these steps to work appropriately, you must do them
carefully, in sequential order. Before creating or using
Library items, you must first define a site or open an
existing defined site.

To create a Library item that you can use on multi-
ple pages on your site, follow these steps:

m Open any existing file that has images, text, or
other elements on the page or create a new file
with any of these elements.

Chapter 8 Techniques to Save You Repetition

m Select an element that you want to use as a
Library item. A navigation row with images and
links, such as the one selected in Figure 37.3, is an
ideal use of the Library feature.

m From the Files panel group, click the Assets tab
and then click the last icon, the Library icon,
shown in Figure 37.4.

m Name the element as you would name any file
in the Finder on a Mac or in Explorer on a PC.
When you name a Library item, you automatically
save it to the Library, so that you can then easily
apply it to any new or existing page in your site.
All Library items are listed in the Library section
of the Assets panel, as shown in Figure 37.4.

STEP 2: ADD A LIBRARY ITEM TO A PAGE

You can take elements out of the Library as easily as
you put them in. When you add a Library item to a
page, the content (or a link to it) is inserted in the
document, as well.

To add a Library item to a page, follow these steps:

m Create a new document in Dreamweaver or
open any existing file.

m From the Files panel click the Assets tab and
then click the Library icon. The Library panel
opens in the Assets panel on the right side of the
work area.

m Dragan item from the Library panel to the
document window, as shown in Figure 37.5.
Alternatively, you can select an item in the Library
panel and click the Insert button. The item auto-
matically appears on the page. After you insert a

37.3
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Library item on a page, you can use any of
Dreamweaver’s formatting features to position it
on the page.

STEP 3: HIGHLIGHT LIBRARY ITEMS

Library items are highlighted to distinguish them
from other elements on a page. You can customize
the highlight color for Library items and show or
hide the highlight color in Highlighting preferences.

To change or hide Library highlighting, follow these
steps:

m Choose Edit > Preferences and then

Highlighting from the Category section on
the left.
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m Click the color box to select a color for Library
items. Check the Show check box to display the
Library highlight color on your pages. Leave

the check box blank if you don’t want to display the
highlight color.

m For the Library highlight color to be visible in
the document window, you must also be sure that
the Show Library Items box is checked in the
Highlighting section of the Preferences dialog box.
Click OK to close the Preferences dialog box.

STEP 4: EDIT A LIBRARY ITEM TO MAKE
GLOBAL CHANGES

One of the biggest timesaving advantages of the
Dreamweaver Library feature is that you can make
changes to items and automatically apply those
changes to multiple pages. First, you edit the original
Library item file; then you can choose to update the
edited item in any one or all the documents in the
current site.
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To edit a Library item and then update one or all of
the pages on which you use that item, follow these
steps:

m Ifit’s not already open, click to open the Assets
panel in the Files panel and click the Library icon.
m Select the item you want to alter by double-
clicking its name in the Library panel to open it.
Dreamweaver opens the Library item in the main
work area where you can use Dreamweaver’s stan-
dard editing functions to make any changes you
want to the Library item. For example, you can
change a link, alter text, insert or remove images,
or change formatting.

m After you make all of the changes you want,
choose File > Save to save changes to the original
item or choose File > Save As and give it a new
name to create a new Library item.

m If you choose File > Save, the Update Library
items dialog box opens, displaying a list of all
pages where the Library item appears and
prompting you to update all pages where the
Library item is inserted (see Figure 37.6).

Because Library items can contain only Body
elements, but no Body attributes, the Style
panel, the Timeline, and Page Properties are

unavailable when you are editing a Library item.
The Behaviors panel is also unavailable because
itinserts code into the Head as well as the Body.

Chapter 8 Techniques to Save You Repetition

m Choose Update to apply your changes to all

of the pages where your Library item is already
inserted. Choose Don’t Update to save your
changes to the Library item without applying
those changes to pages where the item has already
been inserted.

STEP 5: MAKE LIBRARY ITEMS EDITABLE

If you decide that you want to alter a Library item in
just one place or make just a couple of exceptions,
you can override the Library feature by breaking the
link between the Library and the item in the docu-
ment and then editing the item as a static element on
the page where it has been applied.

Remember that after you break the connection,
you cannot update the Library item automatically.

Update Library Items

Update
foards. him -
findes htra Don't Update

Update library items in theze files?
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To make a Library item editable, follow these steps:

m Open any file that contains a Library item and
click to select the Library item. The Property
inspector changes to display the Library item
options.

m Click the Detach from Original button to
break the link from the Library. A warning mes-
sage appears, letting you know that if you proceed
with detaching the Library item from the original,
it will no longer be possible to update this occur-
rence of it when the original is edited.
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m Click OK to detach the Library item. After a
Library item is detached, it appears on the page as
any other element. For example, if the Library
item is an image, when you break the link to the
Library, the image becomes a static image on

the page, just as if you had inserted it directly

on the page. If the image is linked to another page,
the link to the page remains intact when the link
to the Library is severed.
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—

You can find all of the files
used in this technique in the
folder called Technique 38
on the CD-ROM.

38.2 (CP 54)

rames serve multiple purposes, but what’s unique about them

is that they enable you to display multiple HTML pages in one

browser window and control the contents of each page, dis-

played in separate frames, individually. Designers commonly

use frames to create a page with two or more sections and then
place links in one section that, when selected, display information in
another section of the same browser window.

Figures 38.1 (CP 53) and 38.2 (CP 54) demonstrate how one navigation
frame, in this case the frame on the left, can be used to display different
content in another frame, in this case the frame on the right. Figure 38.1
(CP 53) shows the frame being built in Dreamweaver; Figure 38.2 (CP 54)
shows the frameset displayed in Internet Explorer with the Desert Link
selected.

Frames can save you time because navigation elements are stored on only
one page, instead of being inserted on multiple pages. Thus, if you need to
change the nav bar later, you only have to change one page to fix it through-
out the site. The same goes for the frame at the top that holds the banner
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for this site. If I want to change that, I only have to
change one page and the banner will display correctly
with every other page on the site.

Web pages that use frames are split into separate
sections—or individual frames. All the frames
together make up a frameset. Behind the scenes, each
frame of the frameset is a separate HTML file, which
makes a page with frames a little complicated to cre-
ate, even with Dreamweaver.

STEP 1: CREATE A FRAME BY USING THE
FRAMES INSERT PANEL

The easiest way to create frames in Dreamweaver is
with the Frames Insert panel, as shown in Figure
38.3. The Frames Insert panel (available by selecting
the Frames tab from the Insert panel at the top of the
work area) displays several predefined frames icons.
You can create a frameset in Dreamweaver simply by
clicking any of these icons or by dragging and drop-
ping the icon into your document when you are in
Design View. Figure 38.4 shows a new frameset cre-
ated from the Top and Nested Left Frames icon in the
Frames Insert panel.

To create a framed page by using the icons in the
Frames panel, follow these steps.

m Choose File > New > HTML Page to create a
new page.

[Common [Layout mmbles |Frames [Forms [ Templats
D]D]EQEE[QQ]E[EE]EE\
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m From the Frames Insert panel, click the frames
icon that most closely approximates the type of
frameset you want to build and drag it onto your
page in Design View. Click the icon once to apply
it; I chose the Top and Nested Left Frames icon.
Don’t worry if you can’t find exactly the design
you want: You can alter the frameset after it’s
applied.

m Modify the frameset as needed. Change the size
of each frame by clicking and dragging the border.
You can also add more frames by splitting existing
frames. To split a frame, click to select the frame
you want to split and choose Modify > Frames.
Then, select from the list of options to split the
frame Left, Right, Top, Bottom, or any of several
Nested options. You can also drag additional
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Creating Effective Frame Navigation

frame icons from the Frames panel into existing
frames to divide them with predefined framesets.
m To save your files, continue with Step 2.

STEP 2: SAVE FILES IN A FRAMESET

You shouldn’t save a frameset until after you create all
of the frames; otherwise, keeping track of your files
gets very complicated. Remember, frames in HTML
consist of at least two or more HTML files, even if it
appears as if you are only working on one file. You
have the frameset file, which calls the other frames
into place, and a separate file for each frame area.
When you are ready to save, Dreamweaver gives you
multiple save options for saving all the files. You can
either save everything all at once by choosing File >
Save All, or you can save each frame and frameset

38.5
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individually, by clicking in each frame and choosing
File > Save Frame. To save the frameset document
separately, use the Frames panel in the Advanced
Layout panel (shown in Figure 38.5) to the right of
the work area.

In the example in Step 1, I created four separate
HTML files, three for the frame areas and one for the
frameset. To save all the files in any frames document,
follow these steps.

m Choose File > Save All. In the Save As dialog
box, enter a name for the frameset (the first
document to be saved) and designate a folder in
which to save it. As soon as you name and save the
frameset file, you will be prompted to save the first
of the frames documents.

m Enter a name for each file (or just click Save to
accept the automatic name Dreamweaver recom-
mends, which is something like Untitled-1,
Untitled-2, and so forth.). You are prompted to
name every frame in the frameset. The frame that
you are naming is highlighted in the document
window while the Save As dialog is open so you
can see which frame you are naming.

m After you name the last of the files, the dialog
box closes when you click Save.

Naming the frame is different from naming the
file that the frame represents; the frame name is
like a nickname that allows you to distinguish
your frames from one another on a page and

refer to them individually. The filename is the
actual name of the HTML file for the frame. (If
you've ever created an image rollover, you had
to give each image a name so you could distin-
guish them. Naming frames is very similar.)
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STEP 3: NAMING FRAMES

Before you can set links within a frameset, you need
to do a few things. First, you need to name each frame
so that you can specify where the linked file should
load. By that, I don’t mean you need to name the file
itself — you just did that when you saved the files.
When you name a frame, you give the frame an iden-
tifier, which is part of the document code of the
frameset. This name, or identifier, is then used to tar-
get the frame area when you set links.

To specify the names of the frames in your frameset,
follow these steps.

m Create a new frameset or open an existing one
and make sure that you save all the files.

m Choose Window > Others > Frames to open
the Frames panel at the right of the work area. The
Frames panel is a miniature representation of

the frames on your page that enables you to select
different frames by clicking within the panel, as
shown in Figure 38.6.

m Click to place your cursor in the area of the
Frames panel that corresponds to the frame that
you want to name. In Figure 38.6, you can see that
I selected the top frame, which is called topFrame.
You can also select the entire frameset by clicking
the border around all the frames in the Frames
panel window, but you don’t need to name the
frameset. The Frames panel allows you to select
only one frame or frameset at a time.

Chapter 8 Techniques to Save You Repetition

m When you select any frame area, the Property
inspector changes to display the properties for
that frame, making it possible for you to alter any
of the frame’s properties. In the text box on the

Dreamweaver assigns names automatically
when you save the files in a frameset. In the
example shown in Figure 38.6, Dreamweaver
assigned the names topFrame, mainFrame, and
leftFrame. You can leave these names as is or
change them to something else in the Property
inspector. | recommend naming frames with
descriptive words, such as Nav-Frame, Banner-
Frame, or Content-Frame, so that you can easily
tell which frame is which by its name.

You can name your frame files anything you
want, but you need a distinct name for each
frame. | like to give names, such as frame1.html,
frame2.html, or leftframe.html, rightframe.html
so that it’s easier to identify them later.It doesn't
matter, but it is helpful if you use names that
help you distinguish them. After you save all
the frames, the Save dialog box disappears.
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left side of the Property inspector, you should see
the same name as appears in the Frames panel,
which Dreamweaver has already automatically
named. You can keep this name or enter a new
name, which is what 'm doing in Figure 38.7.
What’s most important is that you know what
each frame area is called so that you can recognize
it in the target field when you set links within your
frameset, as you see in Step 4.

m Save each file after changing its name. You can
either save each frame individually or choose the
Save All command. Refer to Step 2, earlier in this
technique, for more information on saving frames.

Now that you identified or changed the names of
your frames, youre ready to start setting links that

| like to save my work on a regular basis so that |
never lose more than a few minutes of work

if my system crashes or the power goes out.
Beware, however, that when you work with
frames, you need to save all of your pages to
save your work. You can save each page sepa-
rately by choosing File > Save Frame to save
only the frame in which the cursor is currently
located.To save all of your pages at once, choose
File > Save All to save all the pages in the
frameset. To save just the frameset file, choose
File > Save Frameset.
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target frames. Don’t close these files yet— you want
to use them to follow the next step, setting links.

STEP 4: SET TARGETS AND LINKS
IN FRAMES

One of the best features of frames is that you can
change the contents of each frame separately within
the Web browser. This feature opens a wide range of
design possibilities that can improve navigation for
your site. One of the most common is to use a frame
to keep a navigation bar constantly visible and open
the page each navigation item links to in a separate
frame area.

Setting links in a frameset requires some prelimi-
nary work. If you jumped to this section without hav-
ing created a frameset or naming your frames, you
may want to refer to the earlier steps that walk you
through the process of saving and naming your
frames. If you already have a frameset, have named
the frames, and just want find out how to set links,
this is where you want to be.

Links in a frameset work much like links anywhere
else, except that in addition to indicating which page
you want to open with the link, you have to specify
which frame section it should target (or open into).
For example, if you want a link in the left frame to
display in the main frame, such as the example shown
in this technique, you need to specify the main frame
as the target in the link. If you don’t specify a target,
the link opens in the same frame in which the link is.
Because the most common reason to use frames is to

Src | UntitledFrame-10,htm

= Frame
‘ |
Margin Width | |
Margin Height |:|

[+ Mo Resize  order Color Ql:l

| '@'hi'l jorders %
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keep navigation links in one frame and open them in m In the Property inspector, click the Browse but-
another, you probably want to know how to target a ton (the one that looks like a small file folder) next
frame when you set a link. to the Link box. Browse to find the file to which

If this seems confusing, don’t fret. Understanding it you want to link. If you’re using the sample files,
is easier after you try doing it. Follow these steps to you want to link this image to the Sedona-
create a targeted link in a frameset. gallery.htm file. Click the filename to select

the file and choose OK, just like you would

m Click to select an image or highlight text that to set any other link o a file in your Web site.

you want to serve as the link. In the example
shown in Figure 38.8, I selected the top image in
the left frame.
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m Ifit’s not already expanded, make sure that the
Property inspector is open to reveal the advanced

183

as you would create any other link, except that you
are specifying the Target, meaning the area in the

options. (Use the small arrow in the bottom-right
corner to expand the Property inspector.)

m From the drop-down list next to Target in the
bottom half of the Property inspector, choose the
name of the frame into which you want the link to
open. See Figure 38.9.

m If you are following this exercise with the files
on the CD-ROM, select mainFrame. If you
changed the names, choose the name that corre-
sponds to the frame you want the link to open
into on the page. Notice that Dreamweaver
conveniently lists all the frames you named in
your document in this drop-down list.

m To create additional links, repeat these steps.
Essentially, what you are doing is creating a link

frameset where the linked page will open.

See Figure 38.10 for the finished Web site.

You have to save your work before you preview
it in a browser to test the link and ensure that
you have properly targeted the frame. Press F12
as a shortcut to Save All Files and open themin a
browser automatically.
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USING HTML STYLES TO AUTOMATE

FORMATTING
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You can find all of the files
used in this technique in the
folder called Technique 39
on the CD-ROM.

39.2 (CP 56)

f you want to save some time, you can save commonly used for-
matting attributes as a style that can be applied over and over
again.
Don’t confuse HTML styles with Cascading Style Sheets (cov-
ered in the next technique). HTML styles are simply a collection
of <FONT?> tags and other style attributes that you can save in Dreamweaver
and then easily reuse.

HTML styles are convenient and very easy to create, but they are more lim-
ited than Cascading Style Sheets. First of all, they only let you apply font
attributes that are available as part of regular HTML. This means that you
can’t specify font sizes based on pixels, picas, or any other measurement other
than the normal, very limited, HTML sizes. HTML styles also can’t be shared
among sites unless the other sites are also being edited in Dreamweaver. No
other HTML program can use or modify Dreamweaver HTML styles.

Perhaps the greatest limitation of HTML styles compared with Cascading
Style Sheets, however, is that if you format text to a certain style and later
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change the style definition, the text you formatted
earlier doesn’t update automatically to reflect the
changes to the style. Still, in many cases, HTML styles
can save time if you find yourself applying the same
style attributes over and over again, such as in
Figures 39.1 (CP 55) and 39.2 (CP 56), where you see
one of my columns with no formatting, and then
another version with formatting. To make it easier to
format my newspaper column, which I add to my
own Web site regularly, I created HTML styles to for-
mat the body, headline, byline, and dateline more
easily.

STEP 1: CREATE AN HTML STYLE

Here’s an example of how you can use HTML styles.
Say you want all the headlines on your site to be font
face Arial, size 5, and bold. You can create a style
called Headline and apply all of those formatting
options at once when you use the Headline style. If
you want different size headlines, you can create a
style sheet that defines Headline 1 as one size and
Headline 2 as a smaller size for sub heads.
To create a new HTML style, follow these steps:

m Choose Window > HTML Styles to open the
HTML Styles panel in the Design panel to the
right of the Dreamweaver work area.

m Open the panel Options drop-down menu by
clicking the Options icon in the top-right corner
of the panel group. (The Options icon looks like
three very small bulleted items with a little arrow
at the bottom of it.) Choose New from the pull-
down list shown in Figure 39.3.

m Alternatively, you can choose Text > HTML
Styles > New Style and then choose New from
the submenu.
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m Either one of the previous options opens

the Define HTML Style dialog box shown in
Figure 39.4.

m Enter a name in the text box at the top of the
Define HTML Style dialog box. You can name the
style anything you want. In the example shown in
Figure 39.4, 1 chose to name a style Headline. The
name you enter appears in the style menu after you
create the style and is used only to identify the style.
m Specify if the style should be applied only to
selected text elements or to all elements separated
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by the paragraph tag. Be aware that you have more
control over which elements you apply the style to
if you choose Selection instead of Paragraph.

m Specify the behavior of the style when it is
applied. If you want the style you create to be
applied in addition to existing formatting, choose
Add to Existing Style (+). If you want to clear any
existing formatting before applying the new style,
choose Clear Existing Style.

m Select all formatting attributes, including Font,
Size, Color, Style, and Alignment, that you want to
include in this style. The Paragraph attributes are
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only available if you have selected Paragraph in
the Apply To section at the top of the dialog box.
m Click OK to save the style. The new style auto-
matically appears in the HTML Styles panel and
becomes available in the submenu when you
choose Text > HTML Styles. The HTML Style
you created remains as an option in the HTML
Styles menu until you remove it.

STEP 2: APPLY AN HTML STYLE

As soon as you create a new style, you can apply it to
any string of text. To apply an existing HTML style,
follow these steps.

m Highlight the text you want to modify and
choose Text > HTML Styles.

m Click to select one of the styles from the Styles
submenu, and the style is automatically applied

to your selected text. The Styles submenu features
all of the predefined styles that ship with
Dreamweaver, as well any custom styles you create.
m Alternatively, you can apply a style to a selected
area of text by highlighting the text and clicking a
style name in the HTML Styles panel in the Design
panel to the right of the Dreamweaver work area.

HTML styles are stored on your hard drive in a
file called styles.xml.This folder is located either
in the site folder (in the Library subfolder) or in
the Dreamweaver configuration folder if the site
root folder has not been defined.
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You can find all of the files
used in this technique in the
folder called Technique 40
on the CD-ROM.
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detnonstrated something Ive believed for some time: Until computers are as easy to use as
a remote cotrol, they're ot going to reach the broadest possible audience
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ven if youre not familiar with the concept of style sheets,
you're sure to appreciate the benefits. Cascading Style Sheets,
more commonly referred to by the acronym CSS, enable you
to define styles with multiple text formatting options in
HTML. CSS goes a long way toward giving you real typo-
graphic control and a consistent look and feel throughout a Web site, as
well as saving time in designing your Web page.

One of the greatest advantages of CSS styles is that you can create external
style sheets, which means that one style sheet can be applied to multiple
pages, such as the ones I used to format the different text areas in my col-
umn, shown in Figure 40.1 before applying styles, and Figure 40.2 after

applying styles.

Before you get too excited, however, I have to warn you that because CSS
is a relatively new addition to HTML, the more advanced formatting
options may not display consistently in all browsers. If you want to play it
safe, use the most basic CSS options or stick with HTML styles, featured in

Technique 39.
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STEP 1: CREATE AN EXTERNAL
CSS STYLE

The greatest advantage to using CSS to format my
column instead of HTML styles is that I can create
one external style sheet and use it to format all of my
columns, just as I did with the one in Figure 40.2. The
following steps show you how to use Dreamweaver to
create an external style sheet. In this example, you
define a style for headlines by using CSS. If you want
to create a style for another element, follow these
same steps but change the specific attributes.

You can leave attributes unspecified if you don’t
want to use them. If you don’t specify them, the
browser uses its own defaults. For example, I don’t
recommend using any of the Decoration options
because they can distract and confuse viewers.

To define an external style sheet for all your head-
lines, follow these steps.

m Choose Text > CSS Styles > New CSS Style
to open the New CSS Style dialog box, shown in
Figure 40.3. The new style is automatically called
.unnamed].

m In the Name text box, type a new name for the
style. Dreamweaver gives you a default name that
begins with a period (.) because these types of
style names must begin with a period. You can

New CSS Style X
I arne: | V| [ ok ]

Type: (3 Make Customn Style [class)
() Redefine HTML Tag
{3 Use €55 Selector

Define In: (33 | Headline. csx A |

) This Document Only
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name the style anything you want as long as you
don’t use spaces or punctuation. Dreamweaver
adds the initial period to the class name even if
you omit it.

m Next to Type select Make Custom Style (class).
m Next to Define In, select an existing style sheet
(as shown in Figure 40.3) or create a new one by
selecting New Style Sheet File. Either way, make
sure that the radio button next to This Document
Only is not selected. Click OK and the Save Style
Sheet File As dialog box opens. Browse to the
folder where you want to save the style, name the
file in which the style sheet will be stored, and
then click Save.

m In the CSS Style Definition dialog box, choose a
font or font set from the Font drop-down list. If
you want to use fonts that aren’t on the list, choose
Edit Font List from the drop-down list to create
new font options.

m From the Size drop-down list, choose the size
you want for your headline. Large headlines are
generally 24 or 36 point. You may prefer to choose
a relative size, such as large or larger.

m From the Style drop-down list, choose a style.
Italic and Oblique are both good for making text
stand out on a page.

m From the Weight drop-down list, choose Bold
to make your headline thicker and darker.

—

You can also add new styles to an existing style
sheet. Click the Attach Style Sheet button at
the bottom of the CSS Styles panel and follow
the steps.
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m Ignore Variant and Case because these attrib-
utes aren’t well supported by current browsers.

m Click the Color box and choose a color from
the color well. Sticking to the default color
swatches in the color well is best because it ensures
that you use a Web-safe color. You can also create a
custom color by clicking the icon that looks like a
rainbow-colored globe in the upper-right corner
of the color well.

m Click OK and your style is automatically added
to the Styles list and the CSS Styles panel.

You can apply styles in the Styles list to any Web
page or selected text block. After you create your
style, it appears in the submenu under Text > CSS
Styles. Any text that you apply it to takes on the for-
matting attributes you just specified. For more on
how to use styles, see Step 3, “Apply Styles,” later in
this technique.

STEP 2: REDEFINE AN HTML TAG TO
ELIMINATE UNDERLINE FROM LINKS

When you create a custom style as you did in the pre-
vious step, you start a completely new style with its
own unique name. When you redefine an HTML tag,
however, you begin with an existing HTML tag, such
as <B> (bold), <HR> (horizontal rule), or <TABLE>
(table), and change the attributes associated with
that specific tag. Any new attributes that you apply
through CSS to an existing tag override the existing
attributes.

To redefine a tag, start a new CSS style by clicking
the New CSS Style button at the bottom right of the
panel and then selecting Redefine HTML Tag in the
New CSS Style dialog box. When you choose this
option, a list of tags appears at the top of the dialog
box. Choose the tag that you want to change from the
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Tag drop-down list shown in Figure 40.4. Then,
define how you want to change it by altering the
various categories and attributes in the CSS Style
Definition dialog box. Be aware that when you rede-
fine an existing HTML tag, any text that you've
already formatted with that tag changes to reflect the
new definition.

Now that you know how to redefine an HTML tag,
here’s your chance to put it into practice. One of the
most commonly used HTML tag modifications
involves disabling the underline for the anchor tag,
<A>, so that hypertext links are no longer underlined

New CSS Style

Tag: A bt 0k,

Tvpe: [abbr = Canhice
acrangm
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applet
area

b
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bazefont Help
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in the browser. Many Web designers like to remove m Next to Define In, select This Document Only

the underline because they think it detracts from the and click OK to open the CSS Style Definition

design and also because the cursor changes to a hand dialog box, shown in Figure 40.5. (If you want the

over any link, making the underline unnecessary. style to apply to the entire site, choose New Style

This technique works in both Netscape and Internet Sheet File.)

Explorer 4.0 (and above) browsers. m Make sure that the Type category is selected,

To disable underlining for hypertext links, follow and then check the none check box under the

these steps. Decoration section. Click OK to apply the changes.
m Choose Text > CSS Styles > New CSS Style After you click OK, active links are no longer under-
and then Redefine HTML Tag. From the Tag pull- lined on the page, even when displayed in a browser,
down list, choose the anchor tag <a>. as long as it’s 4.0 or higher. In older browsers, the

CSS Style Definition for a in Hea.css

Categaory Type

Eizzigrnund Fant: |Anal, Helvetica, sans-serf w

B
Eg::ler Size: |36 w || pizels v | Wweight:  bold w

List
Positioning Shyle: v W ariant: v
E stensions

Line Height: W Caze: W

Decoration: [ | underline Calar; Q
[ ] overline
[ ] line-through
Al
none

ak. H Cancel H Apply ] [ Help
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links appear with underlines, but otherwise are unaf-
fected. You can make more modifications to the <a>
tag in this manner, or you can apply the same princi-
ples to any of the other HTML tags available in the
New CSS Style dialog box. Remember, any time you
redefine an HTML tag by using CSS, the changes are
visible in your page only if those tags are actually
used.

STEP 3: APPLY STYLES

Defining styles is the complicated part. Applying
them after you define them is easy. You simply select
the text that you want to affect and choose the prede-
fined style that you want to apply.

To apply a style, follow these steps:

m Highlight the text to which you want to apply

a style.

m Select the style that you want to apply from the
list that appears in the white area of the CSS Styles
panel, as shown in Figure 40.6. The style is auto-
matically applied to the selection.

If the Style panel is not visible, choose Window >

CSS Styles to openiit.
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m You can also apply a custom style by selecting
the text that you want to change by choosing
Text > CSS Styles and choosing a style from
the submenu.

See Figure 40.7 for the formatted column.

_ICSS Styles [HTML Styles [Behaviors |
() apply Style (3) Edit Styles

fFarmatted-colurin
=l Hea.css
“o headline 36p Arial bold

< >
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In search of a simple computer
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& frend of mine sat his mother down in front of lis computer not too long age for her first
lesson. Just then, s phone rang and he was momentanly distracted. When he returned, he
tound her holding the mouse i mid air, pointing it at the computer; already frustratd that

chiclang on the buttons wasn't makung anything happen.

He and [ both got a good laugh out of it later {although he worked hard not to laugh while
he carefully explained to her that the mouse wasn't a retnote control). But the incident
demonstrated something I've believed for some time: Until computers are as easy to use as
a remote control, they're not going to reach the broadest possible audience.
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You can find all the files
used in this technique in the
folder called Technique 41
on the CD-ROM.

and Figure 41.2 shows it being played in Internet Explorer.

2 Untitled Document - Microsoft Internet Explorer: [BEE]
Fle Edt View Favorites Tooks Help o
svess | 8
(G Janine Warner
Communications
|€] Done '3 My Computer
41.2

he Assets panel in Dreamweaver provides access to many
timesaving features, including the multimedia assets panels
where all of your multimedia files are automatically stored

for easy access.

If you use a lot of multimedia elements in your Web site, such
as sound files, animations, and video clips, you'll appreciate that the Assets
panel automatically stores all of these elements as you add them to your
pages so that you can easily add them to any of your pages. Figure 41.1
shows a Flash file being added to a page from Dreamweaver’s Assets panel,

STEP 1: SAVE FLASH ASSETS

As you add Flash files (movies, animations, and so on, created in
Macromedia Flash), Dreamweaver automatically stores references to these
files in the Flash Assets panel. To use the Flash Assets panel, follow these

steps.
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m Click the Assets tab from the Files panel group
in the panels that appear in the right of the
Dreamweaver work area. Then, click the Flash
icon at the top left of the Assets panel. The Flash
files in your site appear in a list in the main area of
the panel.

m You can reorder Flash files by filename by click-
ing Name, by size by clicking Size, and by file type
by clicking Type.

m To insert a Flash file on a page, simply open the
page in the main work area of Dreamweaver, click
the filename in the Flash Assets panel, and drag it
onto the page. Dreamweaver automatically inserts
it on the page. You can then change the attributes
of the Flash file in the Property inspector.

m To add a Flash file to the Favorites section of the
Flash Assets panel, right-click the filename and
choose Add to Favorites, as shown in Figure 41.3.
To view your Favorites, click the Favorites radio
button at the top of the panel. The Favorites panel
can help you if you have a lot of multimedia files
and want to be able to more easily find the ones
you use most frequently.

STEP 2: USING FLASH ASSETS

The Flash Assets panel stores all of your Flash files
automatically. The advantage of this is that you can
easily add Flash files to pages from the Assets panel.
That means that if you want to use the same Flash file
on multiple pages, you can insert it by simply drag-
ging it from the Flash Assets panel to the new page.

To insert a Flash file from the Assets panel to a new
page, follow these steps:

Chapter 8 Techniques to Save You Repetition

m Click the Assets tab from the Files panel group
in the panels that appear in the right of the
Dreamweaver work area. Then, click the Flash
icon, fourth down in the row at the left of the Assets
panel. The Flash panel opens and all of the Flash files
used in your site appear in a list in the main area of
the Flash panel. (If all of your Flash files do not
appear, try clicking the Refresh site icon at the bot-
tom right of the panel. If they still don’t appear, try
restarting Dreamweaver.)

:|Site Assets

o7 ER

E@é @

Flash: (3 Site () Favorie: B
P A

Refresh Site List
Recreate Site List
Edit
Insert

Add ba Favarites

Copy ko Site 4
Locate in Site

< | >

(Tnsert ] c
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m To insert a Flash file on a page, create a new
page or open an existing page in the main work
area of Dreamweaver, click the name of the Flash
file in the Assets panel, and drag it onto the page in
the work area. Dreamweaver automatically inserts
the Flash file on the page.

m To change the attributes of the Flash file, click
to select the Flash file on the page and make your
changes in the Property inspector. Figure 41.4
shows the Flash Assets panel open, with the Flash
file selected. The Property inspector displays the
Flash attributes, as shown in Figure 41.5.

STEP 3: USING OTHER
MULTIMEDIA ASSETS

In addition to Flash files, the Assets panel automatically
stores Shockwave files, Movie files, and Scripts. All of
these assets work the same way. When you add any of
these multimedia assets to your pages, Dreamweaver
automatically stores them in the corresponding assets
panel.

If you want to add a multimedia asset to a new page,
simply open the Assets panel, choose the Asset type
by clicking the appropriate icon on the left side of the
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panel, click to select the asset, and drag it onto the
page. Dreamweaver automatically inserts the file on
the page for you.
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SCOURING YOUR DATABASE WITH
AN EASY SITE SEARCH FEATURE

NAME WINS AVG.SCORE  ZIP CODE

42.1(CP 57)

—

You can find the database
used in this technique in the
folder called Technique 42
on the CD-ROM. You should
copy the MDB file to your
computer and create a DSN
entry for it using a Microsoft
Access driver.
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Playoff Pictures.
: AFC | NFC

Showdown — 49ers Rams

fantasyF ootball is having a team me eting
at the Miami Expo Center this Saturday
from 12pm to 4pm. Come and mest the
guys and girls of the game, win prizes,
enjoy free food and more! More info
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fantasyOOTEALL e

Bored of Playing Games Online? We hear ya.
Find people looking to play a game this weekend at a park near yo

Search by Zip: ES]

Jay Moan
Das Nestloch

42.2 (CP 58)

site search enables people to query your database and view
matching results through a Web browser. For example,
Figure 42.1 (CP 57) shows how a fantasy football league
Web site uses a database search to help its members. Their
members simply enter their zip code, and the site dynami-

cally displays information about other members in their area, as shown in
Figure 42.2 (CP 58).

STEP 1: CREATE A SEARCH FORM

The search form is the HTML component that sends the inputted request
to the application server as a database query.

m Create and save a new ASP/VBScript page in your site folder.

m Choose Insert > Form. A red dotted line appears, indicating the
perimeter of the form.

m With your cursor inside the form perimeter, choose Insert > Form
Objects > Text Field.
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m Give your text field a name in the Property
inspector, such as ZipField.

m Choose Insert > Form Objects > Button.
A Submit button appears.

STEP 2: CREATE A RECORDSET

A Recordset is a collection of data retrieved from your
database. Figure 42.3 illustrates how you can create a
specific query that narrows down the retrieved data
for your Recordset. In this example, the Recordset is
to be filtered by the Zip column.

m Open the Server Behaviors panel.

m Click the Plus Sign (+) button and choose
Recordset Query. The Recordset dialog box
appears, as shown in Figure 42.3. If this option

is not available, follow the instructions in the
Bindings panel on how to create a Connection.

m Enter a name for your Recordset. Dreamweaver
rejects spaces and special characters, so enter a
word or alphanumeric string.

Name: | Recordset1 |
Connection: |Meet2PIay V| Defing...
Table: |Players 3 |
Columns: (&) all () Selected:

A~
-

A

Fiter: |Zip /= v

Form Variable ~ || ZipField|
T —

42.3
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m Choose your DSN connection from the pull-
down menu. If you have not created a connection,
you can define one by clicking the Define button.
m Choose the table from the database from which
you'd like to select data columns. In this tech-
nique, you want to search the site’s customer base,
so select Players.

m Select the columns you want to display. You can
either click the All radio button or click the
Selected radio button and click individual column
names in the menu below. Hold down the 88/Ctrl
key to click more than one column if desired.

m Choose a filter by selecting a column name
from the pull-down menu. In this technique, you
are going to display matches of exact zip codes, so
choose the Zip column and choose the = (equal)
sign as the filter method.

m Change URL Parameter to Form Variable
under the third filter menu.

m Enter the name of the form field you created in
Step 1. In this example, the name is ZipField.

m Choose a sort method if desired (this is an
optional step). You can sort your Recordset by
column data by changing None to a column in

You can't click the Live Data button in this tech-
nique to test your work because the application
server requires data inputted into this form
before it knows what data it needs to display.
When you have completed the technique, you
must test it with your Web browser.
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this menu and choosing whether you want the
results to appear in descending or ascending
order.

m Click Test to verify that the proper variables are
set. Enter 33166 when prompted and click OK, as
shown in Figure 42.4. The Test SQL window
appears showing matching data. Close all testing
windows and click OK to save your Recordset.

STEP 3: CREATE A SEARCH RESULTS
ZONE

A Recordset is much like a variable in any
application — its value remains unseen until you dis-
play it. The following steps demonstrate how you can

If you cannot select the Recordset Query behav-
ior after you have clicked the Plus Sign (+) but-
ton, you may not have set up your site correctly
to handle a database connection. Make sure
that IIS or PWS is installed and running, that
your DNS is working, and that you selected
the ASP/VBScript technology for your file type.
Refer to this chapter’s introduction for more

information.
Please Provide a Test Value E\
Plesse provide 2 test value for Form Varisble: ZipField

Test Value: 33166

42.4
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dynamically display the dynamic information resid-
ing in your Recordset. This example utilizes a three-
column table to show the Name, Description, and
Interests columns from the Recordset.

m Create a multicolumn table outside of the
form to house your Recordset by choosing
Insert > Table (Ctrl+Alt+T). You need only
create one row: Additional rows are inserted
dynamically by the application server’s Repeat
Region behavior.

m Expand the Bindings panel and choose your
Recordset. Click the small Plus Sign (+) button
to reveal the columns in your Recordset.

m Click and drag the desired columns from your
Bindings panel directly into your table cells. A
block of highlighted text with the column name
appears on the page.

m Select the Table tag from the Tag inspector at
the bottom left of the document window to be
sure the whole table is selected.

m Expand the Server Behaviors panel and click
the Plus Sign (+) button to reveal the available
behaviors. Choose Repeat Region. The Repeat
Region dialog box appears.

m Choose the Recordset you want to display in
the search results.

m Choose how many search result (rows) you
want to display or select the All option. Click OK
to confirm this behavior.

m With the table still selected, click the Plus Sign
(+) button once more to add another behavior.
This time choose the Show Region > If Recordset
is NotEmpty behavior.

m Choose the Recordset you created for this page.
Click OK to confirm your selection.
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STEP 4: PREVIEW IN YOUR BROWSER If your browser reports an HTTP 500 internal oper-
ation error or reports a similar OLE error about the
database file being in use, save and close your docu-
ment, close Dreamweaver, and navigate to it from
Toolbar. http://localhost. You should also check to
m Enter a search value into your form and click make sure your database isn’t open within the
the Submit button. Search results appear in the Microsoft Access program, because that can also lock
repeat region if a match exists, as shown in you out. You can decrease the chance of this happen-
Figure 42.5. ing by giving your TUSR account rights to the con-
taining folder. Please refer to the end of this chapter
and Appendix C for more information.

HSINGE 1999 Hello JK.Sanders! You have 3 Hook-ups n

Bored of Playing Games Online? We hear ya. .
Find people looking to play a game this weekend at a park near you > > Showmg all search results on one page can slow

m Press F12 on your keyboard or click the
Preview in Browser icon on the Document

down your application and overwhelm your site
Searcl by Zip: visitors if your database contains a lot of con-
tent. Add pagination by specifying a limit in
your Repeat Region behavior, and then add

Recordset Paging behaviors or the Recordset

Navigation object found in the Application

J\mm Sunders .
e Object submenu under the Insert menu.

Jay Moan

Das Nestloch
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INVITING INTERACTIVE GRAFFITTI
INTO YOUR SITE WITH A PUBLIC
GUEST BOOK

7 Read Guestbook - Microsoft Internet Explorer.

= J T § S
|1 JOURNAL OF ADONIS CARPACCIO PIEL I ALSO USE THIS T

THIS WHOLE MP3 THING HAS ME REALLY WORRED UP.

WHEN YOU BUY MUSIC, WHAT EXACTLY ARE YOU BUYING?
YOU DON'T OWN THE CD BECAUSE ITS ILLEGAL TO COPY THE
MUSIC IN IT. YOU DIDN'T BUY THE MUSIC IN IT BECAUSE YOU
WON'T GET A FREE OR DISCOUNTED COPY IF YOUR DOG EATS
IT. SO0, FOR $I5 A CD, WHAT EXACTLY ARE WE BUYING?

shace jour 'i—hou,jh‘i—'s
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m y acting as a digital bulletin board, a guest book is a quick
You can find the database and easy way to allow people visiting your Web site to post
and files used in this tech- information. People fill out a form, and their entry is recorded
nique in the folder called into your database and displayed immediately by your server
Technique 43 on the CD-ROM. application. The online journal shown in Figure 43.1 uses a
Copy the database to your guest book to allow visitors to discuss the latest post.

computer, create a DSN, and
set up a Connection within

Dreamweaver before begin- . . .
ning this technique. The View Guestbook page displays the entries that have already been

recorded in the database. Traditionally, this page is presented as the main

STEP 1: CREATE THE VIEW GUESTBOOK PAGE

guest book page, and the insert guest book page is linked from it. When
creating your database for the guest book, include Fields Names, Contact
Information, and Create One Comment columns.

205
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m Create and save a new ASP/VBScript page in
your site folder.

m Create a Recordset by clicking the Bindings
panel Plus Sign (+) button and choosing
Recordset Query. Create a connection for your
Recordset if you have not already done so.

m Choose your table and the desired columns
you want to display from it. Make sure that your
Primary Key is part of your Recordset. The Primary
Key is the first column in the sample Access data-
base that sequentially numbers all records.

m Sort your Recordset by choosing Descending
and then choose your Primary Key. If you are
using the sample database, the Primary Key is the
ID column. This step is optional but is recom-
mended, because guest books usually show the
most recent entry as the first. Click OK to save
your Recordset.

m Choose Insert > Application Objects >
Dynamic Table. Choose your Recordset and

click OK to close the Dynamic Table dialog box.

m A table appears. Customize the rows and
columns of the table to your liking. As shown in
Figure 43.2, the designer set a third table row with
merged cells to allow the person’s comment to
flow across the bottom of the contact information.
m With the entire table selected, click the Plus
Sign (+) button in the Server Behaviors panel and
choose the Show Region > If Recordset is
NotEmpty behavior.

{Becordsetl.name} {Becordsetl.email}

43.2
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m Choose the Recordset you created for this page.
Click OK to confirm your selection.

m Save and close this document. If you are having
trouble previewing your document, please refer to
Technique 42, Step 4.

STEP 2: CREATE THE INSERT ENTRY PAGE

The Insert Entry page inserts a row into your data-
base with the information provided through a form
on the Web browser. As soon as the person fills out
the form and submits it, they are redirected to the
View Guestbook page where they can see their entry
appear immediately.

—

Some guest books give people the option to
make their posts public or private. If you want to
add this feature to your guest book, create a col-
umn in the database for a privacy value, which
you can populate by adding a “private entry”
check box on your insert form. You can then
filter against this variable accordingly in
your Recordset by using an argument such as
CONTAINS or=.

{Recordsetl.URL} {Becordsetl.location}



Inviting Interactive Graffitti into Your Site with a Public Guest Book

m Create and save a new ASP/VBScript page in
your site folder.

m Create the same Recordset you created on the
View Guestbook page.

m Choose Insert > Application Objects >

Record Insertion Form. The Insert Record dialog

box appears (see Figure 43.3).

—

If the browser returns a “must use updateable
query” error message after you click the Submit
button, you may need to grant your computer’s
Internet guest account (IUSR) privileges to
write/modify documents in the folder in which
your database is stored. You may also need to
tweak other settings in 1IS and in the user man-
ager to grant your application access to write to
the database, such as setting similar permissions
in your TEMP folder. Please refer to the end of this
chapter and Appendix C for more information.

Insert Record X

name inserts into column "name” (Tex
Form Elements: ||email inserts into column "email” (Text)
URL inserts into column "URL™ (Text}
location inserts into column Tocation” (Text)
comment inserts into column "comment” (Text)

Column: [name | submit as: [ Text v
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m Choose your connection, as you did in the
previous steps.

m Choose the appropriate database table into
which to insert new guest book entries.

m Click the Browse button and choose the ASP
page you created for the View Guestbook page.

m If your Recordset has an autonumber ID,
remove it by clicking that column name and then
clicking the Minus Sign (-) button.

m Click OK to insert your record submission form.
m A table with a form tag and form elements
appears on your page. Change the Insert Record
label to something more relevant, such as “Post
Message.” Your form should appear similar to the
table shown in Figure 43.4.

STEP 3: PREVIEW IN YOUR BROWSER

m Press F12 on your keyboard or click the
Preview in Browser icon on the Document Toolbar.
m Fill out the fields and press the Submit button to
create a guest book entry, as shown in Figure 43.5.

Connection: | Guestbook v [Defne.. |

e S

After Inserting, Go To: | view|.questbook.asp | (Browse... |
GetvaesFrom:[formi  |(When Submitted)
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Iame: | |
Email | |
URL | |
Location: | |
Comrnent: | |

43.4
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A Read Guestbook - Microsoft Internet Explorer
File Edit View Favorites Tools Help

THIS WHOLE MP3 THING HAS ME REALLY WORKED UP.

WHEN YOU BUY MUSIC, WHAT EXACTLY ARE YOU BOYING?
YOU DON'T OWN THE CD BEECAUSE ITS ILLEGAL TO COPY THE
MUSIC IN IT. YOU DIDN'T BUY THE MUSIC IN IT BECAUSE YOU
WON'T GET A FREE OR DISCOUNTED COPY IF YOUR DOG EATS
IT. 50, FOR sIS A CD, WHAT EXACTLY ARE WE BUYINGZ

jant us to belie that we ar n it. You're
diction. Nice I

Considering that it only costs nts to mass produce audio cods now, and according to
Courtney Love the artists only of that, vou gotta Wwonder what we're really buying..

if‘il Daone & Trusted sites
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SHOWING OFF A PRODUCT CATALOG
WITH A MASTER/DETAIL PAGE SET

picure
Xpress
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from old Caribbean recipes. They
combine the firm white meat of

Check out our Featured
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44.1 (CP 59)

—

You can find the database
used in this technique in the
folder called Technique 44
on the CD-ROM. You should
copy the database to your
computer, create a DSN, and
set up a Connection within
Dreamweaver before begin-
ning this technique.

44.2 (CP 60)

he most widely used method of presenting a group of similar

items found in a database is to show a list of links with each

item’s link pointing to a page containing more information

about the item. The list page, shown in Figure 44.1 (CP 59),

is often referred to as the Master page, and the page with the
detailed information is known as the Detail page, shown in Figure 44.2
(CP 60). The great thing about creating this dynamic duo is that you need
to create only two ASP pages, regardless of how many thousand products
are in a database. The two pages act as templates— only the body content
changes, which allows you great flexibility in terms of site growth. It also
means you don’t have to convert hundreds of pages when you decide you
want to refresh your site’s graphics.
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STEP 1: CREATE YOUR MASTER/
DETAIL SET

This Application object is different than the previous
one you dealt with because it inserts server behaviors
across two pages in one fell swoop. Because of this,
you need to create both pages before the object com-
mand is initiated.

m Create a new ASP/VBScript page in your site
folder.

m Save this document by choosing File > Save
(Ctrl+S).

m Name this file Detail.asp (or another descrip-
tive name of your choice).

m Close this document, which you intentionally
left blank. You return to it in Step 2.

m Create a new ASP/VBScript page in your site
folder.

m Save this document by choosing File > Save
(Ctrl+S).

m Name this file Master.asp (or another descrip-
tive name of your choice).

— il

Technically speaking, you can make the Detail
page behaviors and the Master page behaviors
exist on the same document. I've found that
this is not common practice, perhaps because of

flexibility and manageability. If you want to
experiment with this method, ignore the first
few instructions in Step 1 and select the same
document with the Browse button instead of
choosing your Detail page.

Chapter 9 Dynamically Display Content with Database Features

STEP 2: APPLY THE MASTER/DETAIL
OBJECT

Dreamweaver inserts everything you need to view the
database content and navigate around the site as soon
as you complete this step. The only work you have left
to do is customization of the otherwise generic default
layout of the object. You want your Master to be quick
and easy to read, so only choose the most important
columns on that page, shown in Figure 44.3.

m Create a Recordset containing the data you
want to use.

m With your Master page open, choose Insert >
Application Objects > Master/Detail Page Set.
A dialog box appears, as shown in Figure 44.4.

m Select the appropriate Recordset from the
drop-down menu.

m Use the Minus Sign (-) button to remove any
fields you don’t want shown in your Master page.
If you accidentally remove one you want to keep
or want to add more, click the Plus Sign (+)
button.

m The Link To Detail From menu places a hyper-
link around the database column of your choice.
Choose a column that best summarizes the item,
such as its name. If you are using the sample data-
base, choose ITEM_NAME.

Conch Fritters

Fieps

Records {Recordset1_first} to {Recordset1_last} of {Recordset1_total}



Showing Off a Product Catalog with a Master/Detail Page Set

m Select your Primary Key in the Pass Unique Key
menu. The sample database’s Primary Key is SKU.
m Select the number of records you want to dis-
play on the Master screen. If you choose All, no
navigation is added. If you enter a number instead,
navigation links automatically appear at the bot-
tom of the page that manages the pagination.

m Click the Browse button and choose the

Detail. ASP page that you created in Step 1.

m Choose the columns you want to display in the
Details page. You can manage what columns are
inserted in the same way you specified the Master
records.

X)
Recordset: | Recordsetl v |

Master Page Fields: lI ;I :I LI [T]

SKU ~
TTEM_MAME ]
ITEM_PRICE

ITEM_QUANTITY L&
ITEM_SHORTDESC

ITEM_LONGDESC v

Pass Unigue Key: |5KL| . |

Show: @ Records at 2 Time

) all Records

Insert Master-Detail Page Set

Detail Page Name: |detai|.asp |[ Browse... ]

Dietail Page Fislds: iI ;I :I LI
SKU A
ITEM_MAME =
ITEM_PRICE
ITEM_QUANTITY L&
ITEM_SHORTDESC
ITEM_LONGDESC

|«

44.4

DYNAMIC IMAGES

211

m Click OK to close the dialog box. This executes
the object, which inserts various server behaviors
into your Master page, opens your Details page,
adds server behaviors to it, and leaves the page
open for further modification.

m Choose File > Save All to save the changes you
made to both Web pages. See Figure 44.5 for the
Detail Web page.

o display images dynamically from a database,

create a column in the database where you can

write out the directory path (URL) of the image.
Then, insert an image placeholder from the Insert menu
and drag the lightning bolt icon from a Recordset column
name to it. The placeholder transforms into a dynamic
image icon, as shown below.

Conch Fritters

| {Recordset1.ITEM_NAMEY

Price:
i {Recordsetl.ITEM_PRICE}

e
i {Recordsetl JTEM_QUANTITY}
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d ltem Details Page - Microsoft Internet Explorer

File Edit Tools  Help
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ADMINISTRATING YOUR DATABASE
WITH YOUR WEB BROWSER

picure Hors Deourves  Game Meats Fowl Seafood Desserts  SALE

Xpress lamb KobeBeef Sushi  Soups Recpes  Sauces Shopping Bag

\Pyecauked Conch Friters (50 Count)

or Batter: Thaw Container overnight in refrigerater. “|

oon out product with a teaspoon and drop into fryer at v

hese extraoridmary conch fritters take their exquisite ~
[Eellefol=Te | r1avor from old Caribbean recipes. They combine the firm v

‘Cumhmllevsj\es/cncmpg ]

YT (onch iiters _fles/FoodFindsCaraWd jpg ]

B oo N
First

Next Last

Records 3 to 3 of 11

45.1

m fter creating your database structure, you can close Access

for good and create specialized administrative Web pages to
tory database and ASP pages better manage your site. For example, you can isolate the
used in this technique in the management of product inventory, price, and descriptions
folder called Technique 45 for your product’s database table. Figure 45.1 shows how
on the CD-ROM. You should EpicureXpress uses a page to edit a product description without needing to
view all products at once, or digging into any HTML code or database
work. Their site also utilizes separate admin pages for managing customer
data, zip code shipping rates, e-coupons, and sales reports that work in a
similar manner. Setting up pages such as this also gives them the added
benefit of being able to administrate their system from any Internet-
connected computer.

You can find the mock inven-

copy the database to your
computer, create a DSN, and
set up a Connection within
Dreamweaver before begin-
ning this technique.
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STEP 1: CREATE THE RECORD
UPDATE FORM

The Update Record object automatically inserts vir-
tually every feature you need to manage any given
row in a database. The components of the object
include a form, text fields that pre-populate with the
database content the row contains, and a Submit but-
ton that saves the changes you make.

m Create and save a new ASP/VBScript page in
your site folder.

m Create a connection for your Recordset if you
have not already done so in preparation.

m Create a Recordset by clicking the Bindings
panel Plus Sign (+) button and choosing
Recordset (Query). The Recordset dialog box
appears. Choose any and all columns you want
to administer with this form. Also include your
Primary Key, even if it is an exclusive autonumber
column. You use the Primary Key in a later step.
m Choose Insert > Application Objects >
Record Update Form. The Record Update Form
dialog box appears.

m Choose your connection and desired database
table.

m Choose the table you want to update from the
Select Table To Update menu.

m Choose the Recordset you created previously
on the Select Record From menu.

m Choose your Primary Key in the Unique Key
Column menu. Specify whether or not it is
numeric by checking the Numeric check box.

—Gd

You can’t enter this string in the Record Update
form screen. Dreamweaver won’t understand
that you are entering a dynamic variable and
will move the quote marks around.

—

Chapter 9 Dynamically Display Content with Database Features

m You may leave the Go To field blank: It’s
optional. If you want to stay on the admin page
when you update the forms, leave it empty. If you
prefer to see the page you just edited, choose
your Detail page for the moment. When you have
completed your selections in this dialog box,
switch to Code View and find the variable called
MM_editRedirectURL. Change its value to read:

MM_editRedirectUrl =
"detail.asp?SKU=" +
Request.Form("MM_recordId")

m Choose the columns you want to display from
your table. Remove your Primary Key column
from this selection by clicking it and pressing the
Minus Sign (-) button.

m Use the Column menu at the bottom of the dia-
log box to individually set the data type submitted
by the form. The most common is text, which
allows for alphanumeric data.

Don’t just rely on “security through obscurity” to
safeguard your database — saving your admin-
istrative pages in an undisclosed location on
your server does not protect you against all
malicious activity. For starters, your administra-
tive pages should be in a password-protected
directory. Dreamweaver provides a user authen-
tication server behavior you can use, or you can
set a password on the folder within IIS. If you
intend on storing sensitive information in your
database, you should consider installing a fire-
wall and a separate database server from the
outside world, and then limiting port access to a
trusted IP range and your Web server. If you are
doing any kind of e-commerce, you should also
look into adding encryption.




Administrating Your Database with Your Web Browser

m Click OK to generate the Update Record object.
A form containing a table with dynamic data
fields appears on your page.

STEP 2: CREATE RECORD NAVIGATION

Your Update Record form is programmed by default
to look at the first entry in your Recordset. This
means to edit another record, you either have to
change your query or, better yet, create a navigation
system that allows you to browse database content.
By pairing up another Application object to the same
page, you can achieve this goal.

m Place your cursor inside of the Record Update
form and press Return/Enter key to insert space
between the existing table and the new table you
are about to create.

m Choose Insert > Application Objects >
Recordset Navigation Bar. The Recordset
Navigation Bar dialog box appears.

m Choose the Recordset you selected in the
Record Update Form dialog box.

—

If you are dealing with a large set of rows in your

database, consider creating a more intuitive
navigational menu. By combining a database
search (refer to Technique 42) with the behav-
iors used in this object, you can locate records
more efficiently. You can also include the
Recordset Navigation Status object from the
Application Object menu to show you how
many total records are found in a query.

215

m Choose whether you prefer text links or if you
want Dreamweaver to generate image buttons for
you. If you choose image, four green navigation
buttons reminiscent of a tape deck appear; text
produces four text links. Either choice provides
the same functionality: the ability to move back
and forth among records and jump to the first or
last record.

m Click OK to include the Recordset Navigation
bar. It appears below your Record Update form, as
shown in Figure 45.2.

—

Wondering how to remove items with your
admin? You can assign a Delete Record behavior
in the place of Update Record. More often than
not, the best way to prevent items from showing
up on your Web page but not from your data-
base is to create an “Active” column. Your
Recordset Query can then check against the
value in this field and knows whether or not it
should be shown.

v T T AMRE |

{Recordset1 TEM_SHORTDESC}

{Recardset] ITEM_LONGDESC}

l{Recurdsel‘l.UPSELLSKU‘l)
](Recurdsel‘l,UPSELLSKuz} | i

Update Record

Records {Recordsetl_first} to {Recordsetl_last} of {Recordsetl_total}

45.2
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STEP 3: PREVIEW IN YOUR BROWSER

m Press F12 on your keyboard or click the Preview
in Browser icon on the Document Toolbar.

m Navigate to the record you want to update.
Make changes in the text fields and click the
Update button as shown in Figure 45.3.

m Your changes are recorded in the database. If
you chose a Go To page, you will be redirected
there immediately afterwards.

— il

Deleting rows from a database is usually not
commonly done in a Web application, because
archived customer service records or sales
reports may depend on that existing data. For
example, if you are selling an item that is out of
stock momentarily and don’t want to take back
orders, you shouldn’t delete this sku. Saving this
item as inactive lets you keep your item descrip-
tion and other related information until you
need it again.
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ONLINE RESOURCES

FIXING COMMON TESTING SERVER PROBLEMS:

Although originally written for Dreamweaver Ultradev,
the majority of the solutions listed in this directory
provide fixes that work with Dreamweaver MX.
www.macromedia.com/support/ultradev/
troubleshoot.html

MICROSOFT SOLUTIONS FORHTTP 500
UPDATEABLE QUERY ERRORS:

Some documentation is available on the Macromedia
site about this topic. However, this page features more
in-depth information and other suggestions on how
to properly tweak your sharing permissions for IUSR,
such as setting permissions in your temp directory.
http://support.microsoft.com/default.
aspx?scid=kb;EN-US;ql75168
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web design and development

CHAPTER ( I .

EXTEND THE
FEATURES OF
DREAMWEAVER
WITH EXTENSIONS

| N

irtually all of Macromedia’s new prod-

ucts now come bundled with an assistant

application called Extension Manager.

This utility enables you to install add-on

functionalities to your Macromedia prod-
ucts. You can currently choose from 800+ Dreamweaver
Extensions. Before developing a common Web site func-
tionality, such as a shopping cart, interactive images, or
an intelligent form, look for an Extension to do the
work for you. There are also Extensions for common
minor production tasks, such as adding filler text.
Extensions can also make other programs work better
with Dreamweaver. For example, you can generate
Fireworks graphics within Dreamweaver with an
Extension.

To browse for Dreamweaver Extensions, visithttp://
exchange.macromedia.com, the Macromedia
Exchange home page. Macromedia provides this site as a
free service; however, you do have to register your
e-mail address to become a member. Once inside, you
can navigate the extensive library of Extensions by type,
keyword, author, and more.
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Please note that if you purchased Dreamweaver MX
when it first debuted, you may have an older build of
the Extension Manager. As of the publication date of
this book, the latest version is v1.5.054. While not
critical, you should update your Extension Manager
to ensure a bug-free experience. This update is avail-
able as a free download from the Macromedia
Exchange home page.
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46.1 (CP 61)

—

You can find the Random
Images Extension on the
CD-ROM.

46.2 (CP 62)

t's a proven fact— the best way to retain steady site traffic is to

continuously update your Web site. But who’s got the time to

update their site many times a day? Implementing a random

image Extension helps you cheat a little. As you see in Figures 46.1

(CP 61) and 46.2 (CP 62), a Web design company uses this tech-
nique to display one of ten case studies on their home page. As a result, a
returning visitor can usually find a new feature on the home page even
though the site hasn’t changed.

STEP 1: INSTALL THE EXTENSION

The Macromedia Extension Manager must be installed prior to installing
Extensions. Chances are that if Dreamweaver MX is installed, you can find
Extensions under your Macromedia folder in the Windows Start menu.
If Extensions is not present, it is available as a free download from
www.macromedia.com for registered users. To install an extension,
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download or copy the MXP file to your computer
and double-click it to begin the setup process.

m Browse to the Technique 46 folder on the
CD-ROM.

m Double-click the file named randImage.mxp. A
disclaimer dialog box appears. Read this docu-
ment before proceeding.

m Click OK to accept the terms of the disclaimer.
m The Extension has been installed. A green
checkmark appears next to its name in your
Extension Manager, as shown in Figure 46.3.

STEP 2: RUN THE RANDOM
IMAGE COMMAND

After installed, you can now run this Extension from
the Dreamweaver Commands menu. As with any
technique involving graphics, you need to prepare
your graphics and save your document before start-
ing this technique so that image paths can be prop-
erly linked.

—

Some vendors may reuse common elements in
their Extensions, which may prompt you to over-
ride files while installing. For example, if you
install any other Extensions from Kaosweaver,
maker of this Advanced Random Image Exten-
sion, the installer will ask you if you want to
override a .gif file. You can always click OK to
proceed — it's the same file.

—
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m Create a new Web page in Dreamweaver MX.
Save your document.

m Choose View > Visual Aids > Invisible
Elements to enable Visual Aids. If Visual Aids

is already checked, proceed to the next step.

m Choose Commands > Kaosweaver.com >
Advanced Random Images. A dialog box appears
(see Figure 46.4).

If Advanced Random Images is grayed out (i.e.,
not available) make sure of two things. First,
check that the extension was installed and is
active. To do this, use the Extension Manager.
There should be a checkmark, as shown in
Figure 46.3. Second, you may not have saved
your page. Save the page now using File >
Save As.

Random Images X

Action: |Random Image “ | Slideshow Timer: l:l

.'. -
=l
Image List: picl.jpg ~

Image Properties

Dimensions :Width: Height: Auto:

Title & Alt: | Panexus Miami |

Border: D

Link: |htm:ﬂwww.panexus.cci [Browse... ]

Target: A

K aosweaver|

46.4



Keeping Your Site Looking Fresh with a Random Image Group 221

4 Macromedia Extension Manager

File Help
) (i} | Dreamweaver b v | (2] €]
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1 - Random Images - Dizplays a randam image from the lizt on a page load or refresh.
2 - Daily Image - Digplavs a zsingle image all day and changes the following day.
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m Choose an action. For this example, choose
Random Images. The four options produce simi-
lar results.
m Random Images: Displays a random image
when a page is loaded or refreshed. You must
specify a pool of images from which it cycles.
m Daily Image: Displays a single image all day.
The image is changed every 24 hours sequen-
tially from a specified selection of images.
m Random Slideshow: Displays a random
image and switches the image randomly at an
adjustable interval, set in seconds.
m Sequential Slideshow: Starts by displaying a
random image from your specified image selec-
tion and then cycles images sequentially.
m Click the Plus Sign (+) button to add an image
to your list. If you change your mind, you can
remove images from your list with the Minus Sign
(-) button. To add all images contained in a speci-
fied folder, use the Browse button. At least two
images must be selected to view results in Step 3.
m Setimage dimensions for each image
manually or check the Auto box to have

—iad

—EGd

The fields available in the dialog box for this
Extension change based on the Action you
choose. For example, if you choose Random
Slideshow or Sequential Slide Show, you won't
be able to specify a URL or image properties for
each image, but the Slideshow Timer field will
be enabled.

Chapter 10  Extend the Features of Dreamweaver with Extensions

Dreamweaver automatically fill these values in for
you.

m Optionally, you can set individual specifications
for Title & Alt, Border, Link, and Target. When
making these entries, do not insert special charac-
ters, such as apostrophes: They may disrupt the
JavaScript code generated by the Extension.

m Click OK to complete the command. A warning
appears, asking you to enable visual aids to see the
inserted object. Click OK to continue because you
already did this earlier in this step.

m A yellow invisible element icon appears on your
screen. You may position it where you want the
random image to appear.

STEP 3: PREVIEW IN YOUR BROWSER

m Press F12 on your keyboard or click the
Preview in Browser icon on the Document
Toolbar.

m Click the Refresh button to view a random
image each time the page is loaded.

This Extension inserts an OnLoad event in the
body tag if you choose either of the two
slideshow actions. If you change your mind
about the action on the page and want to con-
vert it to a random image, you may need to
manually remove that code to prevent an error
message. If you have not saved your document,
Undo should do the trick.
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47.1 (CP 63)

—

You can find the PayPal
Buttons Extension used in
this technique in the folder
named Technique 47 on the
CD-ROM. No working sample
files have been provided for
this technique because they
require an active PayPal
account.

47.2 (CP 64)

ayPal is a popular service that allows people to send and

receive money online. Its most popular feature is the ability to

let average people accept credit card payments online for a

small per-transaction fee and without a merchant account.

PayPal offers an off-site hosted shopping cart service, mean-
ing that you don’t need to worry about installing any server software or
CGI scripts. Your site doesn’t even need to be secure because financial
transactions occur on PayPal’s servers. You simply plug their shopping cart
HTML code and use the buy buttons that appear on your page, as shown in
Figures 47.1 (CP 63) and 47.2 (CP 64).

To complete this technique, you must have a PayPal ID. To become a
PayPal member, visit www.PayPal.com and complete the sign-up
process. After becoming a PayPal member, you need to link a bank account
to your PayPal account in order to receive credit card deposits. PayPal offers
other financial arrangements as well— for more information, visit their
Web site. To install an extension, download or copy the MXP file to your
computer and double-click it to begin the setup process.
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STEP 1: INSTALL THE EXTENSION

To install an extension, download or copy the MXP
file to your computer and double-click it to begin the
setup process.

m Browse to the Technique 47 folder on the
CD-ROM.

m Double-click the file named KW_PayPalButtons.
mxp. A disclaimer dialog box appears. Read this
document before proceeding.

m Click OK to accept the terms of the disclaimer.
m The Extension has been installed. A green
checkmark is next to its name in your Extension
Manager.

STEP 2: CONFIGURE THE PAYPAL
CART MAIN MENU

This Extension’s dialog box has more than one screen,
because there are a lot of possible configuration
options. This step covers the Main menu, which gives
you the option of branding PayPal’s cart with your
company information.

m Create a new Web page.

m Choose Commands > PayPal Shopping Cart.
A dialog box appears, showing the Main submenu
screen (see Figure 47.3).

The Macromedia Extension Manager must be
installed in order for this Extension to work. If
you do not have Extension Manager installed,
you can find it on the Dreamweaver CD-ROM,
or you can download it for free on the
Macromedia Exchange Web site.

Chapter 10 Extend the Features of Dreamweaver with Extensions

m Enter your Site domain name. You should
include the http:// protocol in the URL to
make it an absolute URL. Example:

http://www.YourSiteHere.com

m Enter your PayPal ID. This is the e-mail address
you registered as your member name with PayPal.
If you don’t have a PayPal account yet, click the
Get PayPal button and follow the sign-up process.
m Optionally, enter your Logo URL. This URL
should point to a 150 x 50 picture file on your
server, typically a JPG or GIFE. The URL must be
absolute, as shown in Figure 47.3. Example:

http://www.YourSiteHere.com/images/

logo.gif

m Optionally, enter the Cancel URL. This is a Web
page on your server where PayPal can redirect a
customer that has forfeited an order in the middle

Do not click OK before completing the next two

steps. This is a multipage dialog box, so other
values have to be entered before you execute
the command. Otherwise, an incomplete config-
uration will result,and you'll have to start over.

Paypal Shopping Cart Behavior g_l
Site domain name: | http: ffwsg, sample, com)
Paypal ID: | Sample@sample.com
Logo URL*: | te,comjimages/logo. gif —
Cancel URL*: | ample.com/cancel.htm
et PayPal
Successful URL*: | ample.comythanks, htm|
Cancel
Save These Settings: %
* these are optional
[ copwriaht 2001
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of the checkout process. Your Cancel URL page
can inform customers of alternative ordering
methods or feature bargains to lure them back to
shopping. Just as the previous URLs, it must be
absolute:

http://www.YourSiteHere.com/
cancel.html

m Optionally, enter the Successful URL. Many
sites create a “thank you for shopping” page for
this field. Others use this opportunity to collect
customer feedback about the shopping process by
creating a page with a form. Whatever you decide,
make it an absolute URL:

http://www.YourSiteHere.com/
thanks.html

STEP 3: CHOOSE YOUR BUY BUTTON

The buy button is the most important component of
the online store. When clicked, it tells the cart to add
a particular item to your shopping cart. PayPal
includes various designs (shown in Figure 47.4) that
you can use, or you can create your own for a person-
alized look.

m Click the Graphic button. The Graphic sub-
menu screen appears, as shown in Figure 47.4.

Paypal Shopping Cart Behavior [z|
Graphic; O
O ADD TO CART
[Pay Pallee
ADD ITEM TO CART ==
o (Ao |
o) [ Add to Cart
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m Choose a button graphic style by selecting a
radio button.

m If you want to use a custom buy button graphic,
choose the first option, browse to your graphic,
and select it.

STEP 4: ENTER THE DETAILS OF AN
ITEM FOR SALE

The Item Details menu allows you to set the parame-
ters for the sale. This Extension only inserts a pro-
grammed buy button (link) on your page. You need
to enter the details of the item on your Web page
once again so that people can see it.

m Click the Item button. The Item submenu
screen appears, as shown in Figure 47.5.

— il

The buy button graphic can be any size. For best
results, use a GIF with a transparent background
around the shape. Also, this URL can be relative
or absolute. Unlike the entries in the Main
menu, the location of your buy button is not
passed to the PayPal server for display on their

pages.

Paypal Shopping Cart Behavior rz|
Item Mame or Service: | Bluetooth Jabra Headsets
Item ID or Mumber: | 10001-112
Item Price: | 39.%
»
Base Shipping on One: | 6,95
Gek PayPal
Shipping For Each Item = 1: 0
Handling: |0
Field For Customer Nate: [
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m Enter the Item Name or Service. This name is
displayed in the cart.

m Enter the Item ID or Number. This can be your
SKU number, which also appears in the cart.

m Enter the individual Item Price. (Note: People
can modify quantities within the shopping cart
pop-up later.)

m Enter a numerical value for Base Shipping on
One. This is your flat shipping rate for a single
quantity of this item. If you offer free shipping,
enter 0.

m Enter a value for Each Item Greater than One.
You can offer a discounted rate for multiple

item buys or enter the same value as your Base
Shipping cost. This step is optional.

m Enter a Handling fee. If you offer free handling,
enter 0.

m Click OK to insert the PayPal shopping cart buy
button.

— il

If your inventory specs are already in a data-
base, you should modify the outputted code
to receive dynamic variables. Remember, this
PayPal cart Extension is essentially a URL
builder — it sends all of your items specs to the
PayPal server as a QueryString. All you have to
do is view the source of the page, find the but-
ton link, and replace the static values in your
RecordSet entries. (Don't forget to duplicate
these Recordset entries in your design area as
well.) After you master this, try adding this
functionality to the Master/Detail template set
explained in Chapter 9. With a little work, you’ll
have a truly automated shopping cart system
builtin no time!

Chapter 10  Extend the Features of Dreamweaver with Extensions

STEP 5: PREVIEW IN YOUR BROWSER

m Press F12 on your keyboard or click the Preview
in Browser icon on the Document Toolbar.

m Click your buy button to add the item to your
shopping cart. A PayPal cart appears in a pop-up
window, as shown in Figure 47.6.

m Follow the steps in the pop-up cart window to
complete the purchase.

2 PayPal - Shopping Cart - Microsoft Internet Explorer
Address | &] https://www paypal.com fcart/add=13business =wcreid %40telocity.comAitem_name=Convenii % Go o

\E*-“-‘EE‘- B,

Oty |Remove|Item Options Price

1 O Bluetooth headset by Jabra

Itern 10001-123 $35.99

Shipping, tax, and handling costs will be calculated upon checkout, Amount | $39.99

Update Cart Continue Shopping | | Checkout

€] S @ Internet

47.6
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To add more items to your site, choose
Commands > PayPal Shopping Cart again and
skip to Step 4. The Extension remembers your
settings on the Main and Graphic submenu
screens from your previous selections.

The sample included on the CD-ROM contains
a fictional PayPal ID and is a fictional store, so
as a result the buy button won’t allow you to
open the example. To view a great example
of a real PayPal store, visit www.petals

fragrances.com.
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m s your Web site a victim of third-party framing? Some sites on the
You can find the example Web have been known to frame other Web site’s content as the
used in this technique in the body of their pages. Figure 48.1 shows how a portal has linked
folder named Technique 48 directly into an external site from its frameset. In most cases, this
on the CD-ROM. may confuse site visitors, who may think that the framed page

belongs to the framing site. You can prevent and protect your site from this

activity with the Frame Buster Extension, as shown in Figure 48.2. This
object inserts defensive JavaScript code that detects frames and closes them
immediately, leaving only your protected page on-screen.
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STEP 1: INSTALL THE EXTENSION

Using technology to stop framing sites is easy and
more cost effective than taking legal action. After the
object is installed, it requires no maintenance and
stops offenders in their tracks, whether you’re aware
of them or not. To install an Extension, download or
copy the MXP file to your computer and double-click
it to begin the setup process.

m Gotowww.dreamweaver-extension.
com.

m Download the Frame Buster Extension.

A disclaimer dialog box appears. Read this
document before proceeding.

m Click OK to accept the terms of the disclaimer.

Chapter 10 Extend the Features of Dreamweaver with Extensions

m The Extension has been installed. A green
checkmark appears next to its name in your
Extension Manager.

STEP 2: INSERT THE FRAME
BUSTER OBJECT

Frame Buster is different from the Extensions in the
preceding techniques because it is an object. There is
nothing to configure — Frame Buster simply inserts a
chunk of ready-made JavaScript code before your
HEAD tags, as shown in Figure 48.3.

<titlex</titlex

<3CRIPT LANGUAGE="TzraScript™=

<meta http-sequiv="Content-Type" content="text/html; charset=iso-5559-

<!—— JS/FrameBuster
if {(=self '= top) tn:lp.lncatiun.replace{self.l-:ucatiun};:[
A==
</ 3CRIPT> bﬂ
<l 2]

M
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m Open the Web page that you want to protect
with Frame Buster.

m Choose Insert > Frame Buster. It appears at
the bottom of the Objects menu, along with any
other Objects you installed.

m A dialog box appears. To insert the object, click
OK, as shown in Figure 48.4.

—

The code for this object resides above the BODY
tag, so as a result the Frame Buster code is invisi-
ble in the Design View mode of Dreamweaver.
To remove this object, switch to Code View and
scroll to the top of your document. You find
some comment tags surrounding the Frame
Buster code with its name. Delete everything in
between, including the SCRIPT tags. Also note
that if the words “Frame Buster” appear any-
where in the document, the extension won’t
insert the code because it will assume it already
exists.

229
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Frame Buster is intended for a non-frames site to
defend itself from a framing site. If you built your
site using frames and are having problems with
other sites framing yours, you should migrate to
a dynamic“include file” architecture to get rid of
your frames. Include files enable your applica-
tion server to import code from external docu-
ments into one, similar to how frames are
managed. For more information about include
files, search for Server-Side Includes in the
Dreamweaver help system (press F1).

FrameBuster 2.0.0

Click OK to insert the FrameBuster code

rabi.s.raj@usa.net
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STEP 3: TEST THE FRAME BUSTER m Choose File > Save All to save all Web pages.
m Press F12 on your keyboard or click the

m Save your Frame Buster protected Web page Preview in Browser icon on the Document
and close it. Toolbar.
m Open a frameset. You can find a sample frame- m Click the link that opens your Web page in the
set on the CD-ROM. frameset.
m Change a link on the Frameset menu to point m Frame Buster quickly breaks your page out of
to your protected Web page. Set the Target to open the frameset, as shown in Figure 48.5.

within the frame body of the frameset.

=

1 item in your bag.

Click here to complete vour ordg
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TECHNIQUE

PREVENTING ORPHANED FRAME
CONTENT WITH FRAMESTUFFER

A Splash Page - Missing Frameset! - Microsoft Internet Explorer \;HEHX\

3 Splash Page - Missing Frameset! - Microsoft Internet Explorer: EIEX
Fie Edit View Favorites Tools Help T

Dore My Computer
@ 3 My Compu

49.1 (CP 65) 49.2 (CP 66)

m rames enable you to show multiple Web pages simultaneously

on the screen. However, HTML does not form dependant rela-
tionships for the pages that make up a frameset. As a result, link-
ing to a frame may result in an orphaned page. Usually, a
folder named Technique 49 content page appears without its menu, as shown in Figure 49.1
on the CD-ROM. (CP 65). Orphaned pages occur most frequently when a page is accessed
from external links from search engines. To prevent this, you can use the
FrameStuffer Extension. Orphaned pages then are able to detect the
absence of their parent frame and stuff themselves inside as intended, as
shown in Figure 49.2 (CP 66).

You can find the FrameStuffer
Extension and the example
used in this technique in the
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STEP 1: INSTALL THE EXTENSION

To install an Extension, download or copy the MXP
file to your computer and double click it to begin the
setup process.

m Browse to the Technique 49 folder on the
CD-ROM.

m Double-click the file named FrameJammer.
mxp. A disclaimer dialog box appears. Read this
document before proceeding.

m Click OK to accept the terms of the disclaimer.
m The Extension has been installed. A green
checkmark appears next to its name in your
Extension Manager.

STEP 2: PREPARE THE FRAMESET

FrameStuffer records the default body value (page) on
the Frameset page and adds JavaScript that responds
to orphan “stuff requests.”

m Create a frameset or open an existing frameset.
m Name each frame if you have not already done so.
m Click the body page or any page you want to
prevent from being orphaned.

m Save your Web page. FrameStuffer won’t run
unless the page is saved.

m Choose Command > Dabbler >
FrameStuffer. A dialog box appears, as shown in
Figure 49.3.

Chapter 10  Extend the Features of Dreamweaver with Extensions

m Click Browse to choose the frameset (usually
the one that’s currently open). The names of the
frames in this frameset appear in the lower drop-
down menu.

FrameStuffer’s built-in code uses a variable
name called “booker_" Do not use this name for
your frames because it may make FrameStuffer
fail or produce errors. More information about
this is available in the FrameStuffer documenta-
tion, which can be accessed by clicking Help
from the FrameStuffer dialog box.

FrameStuffer X

Frameset |index.htm\ v|
Remove

Frame |mainFrame e
M

When a FrameStuffed page is opened directly in a browser (as from
a search engine results list), the page will find the frameset you
select above, then position itself in the frame you specify.

There are some nuances to working with frames, though, so please
check the help file.
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m Choose the target frame, as shown in Figure 49.3. n
m Click OK.

m Save and close the frameset.

FrameStuffer is written in JavaScript, so its source
is totally open to customization. For example, its
documentation explains how to use FrameStuffer
STEP 3: PREVIEW IN YOUR BROWSER to jump to an anchor by modifying its code. It
also suggests code changes to ensure better
compatibility with Dreamweaver templates. For
more information, refer to FrameStuffer Help.

m Close all of your documents, open the body
frame, and then press F12.

m FrameStuffer instantly surrounds the body
frame with its dependant frameset, as shown in
Figure 49.4.

:

IACTHUS
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GENERATING IMAGES WITHIN
DREAMWEAVER WITH INSTAGRAPHICS

You can find the example
used in this technique in the
folder named Technique 50
on the CD-ROM. Note: Exten-
sion Manager prevents you
from installing this Extension
unless Fireworks 4 or greater
is installed on your system
first.

nstaGraphics is a suite of objects and commands rolled up into

one powerful Extension. After installed, it adds three dynamic

image-generating features previously native to Fireworks. You can

insert customizable premade rollover buttons, convert text on

your Web page into GIF text graphics, and convert default HTML
bullets into attractive image bullets. All of the graphics in Figure 50.1 were
generated within Dreamweaver by converting existing text elements. The
following steps show you how to create this page.

STEP 1: INSTALL THE EXTENSION

To install an Extension, download or copy the MXP file to your computer
and double-click it to begin the setup process. Remember, you'll need
either Fireworks 4 or Fireworks MX to use this Extension.
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m Gotowww.macromedia.com/software/
dreamweaver/productinfo/extend/
insta.html.

m Download the InstaGraphics Extension.

A disclaimer dialog box appears. Read this
document before proceeding.

m Click OK to accept the terms of the disclaimer.
m The Extension has been installed. A green
checkmark appears next to its name in your
Extension Manager.

STEP 2: GENERATE TEXT GRAPHICS

The Convert Text to Images feature in InstaGraphics
lets you create GIF text directly from Dreamweaver.
You can now freely use nonstandard Web fonts and
dress them with the 30 premade text styles included.
It also has the ability to mass-replace text within

— il

InstaGraphics commands and objects run at
optimal speed when Fireworks is open and run-
ning in the background. Simply start the appli-
cation and switch back to Dreamweaver before
moving on to the next step. Otherwise, it will
attempt to launch Fireworks every time you run
one of its three functions.
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specified tags into images, such as the heading shown
in Figure 50.1.

m Save your Web page.

m Type some text on your page using Heading 1,
found in the Property inspector.

m Choose Commands > Convert Text to Images.
A dialog box appears (see Figure 50.2).

m Choose H1 from the Convert menu because the
text you created was formatted as Heading 1. If
you want to manipulate other tags or a highlighted
selection instead, you may do so by selecting the
other radio buttons.

m Choose a Fireworks Style from the pull-down
menu. A preview of the style appears when you
change the selection.

m Choose a Font. Please note that the preview
image won’t change with your font selection and

Convert Text to Image E

o
O o &
O —
© sacon
PR e | -
Font: |TOMMYHILFIGERAF
sei [24 s
Save Images In: |c:ﬂn5tpuhfwwwrnntflmagss ‘D
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that you cannot select certain types of Type 1
PostScript fonts.

m Enter the desired point size of your font in the
Size menu.

m If you want to save your images in a directory
other than where the Web page was saved, use the
Browse button. Navigate to the folder of your
choice and press the Select button to close the
Pick Folder dialog box.

m Click OK to generate the graphics.

STEP 3: CONVERT HTML BULLETS
INTO GRAPHICS

Bored of the bullet HTML circle character? You can
breathe new life into your unordered bulleted lists

InstaGraphics is extremely picky about special
characters in folder paths. Be sure not to include
any kind of special ASCII character in your site
folder or save the image path, or Dreamweaver

will report that it cannot find the file and fail
mid-process. Also note that deleting the graph-
ics in Dreamweaver or using Undo won't delete
the PNG and GIF graphics from your hard drive.
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with the Convert Bullet to Images command. This
feature generates a bullet design based on your specs,
deletes your old bullets, inserts an invisible two col-
umn table, and inserts your text into individual rows
to the right of the images.

m Create a bulleted list of text by using the
Unordered List button in the Property inspector.
m Choose Commands > Convert Text to Images.
A dialog box appears (see Figure 50.3).

m Choose Unordered List from the Convert
menu. This converts all unordered lists on your
page. Alternatively, you can choose Current List to
just change the bulleted list your cursor was on
prior to running this command.

m Optionally, you can uncheck the Table to

Align Bullets and Text option. This choice is good

Convert Bullets to Images [z_l
ot |Current list v‘
Use Table to Align Bullets and Text
Use Fireworks Style: |Style 15w IE‘
Shape: |Square v‘
Size: picels
Save Image As: | c:finetpub fmwwwrootfmages bullet.gif |[:|
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if you intend to create small bullets, as shown in
Figure 50.3.

m Choose a Fireworks Style from the pull-down
menu. A preview of the graphic appears on the
right-hand side of the menu.

m Choose a bullet shape from the Shape menu.
This selection won’t change the image preview —
you only see the results when the command is
executed.

m Choose the Size of the bullet in pixels. A good
bullet size is 6 to 12 pixels.

m Enter an image name in the Save Image As field.
If you want to override an existing bullet image,
click the Browse button and navigate to the file.
m Click OK to generate your image bullets.

Chapter 10 Extend the Features of Dreamweaver with Extensions

menu. Similar to the Flash menu technique in
Chapter 3, this object allows you choose from a list of
premade button styles and customize them with your
text by using dialog boxes, as shown in Figure 50.4.

m Choose Insert > Interactive Images >
Fireworks Button. A dialog box appears (see
Figure 50.4).

m Choose a button Style. A preview appears in the
Sample window.

m Enter a Button Width in pixels.

m Enter a Text Label. This is the text that appears
inside your button.

m Choose a Font. If you don’t select a font, the
designer’s default font, which is pictured in the
Sample preview, will be selected for you.

STEP 4: CREATE ROLLOVER FIREWORKS
BUTTONS

InstaGraphics adds another instant button solution
to Dreamweaver with its own Fireworks button

—

— il

These graphical bullets do not possess the auto-
indent, auto-wrap properties of HTML bullets.
This is because they are essentially just images
combined with table formatting rules or align-
ment rules (middle) if you don't select the table
option. Expect to make some modifications to
their presentation if your text wraps, such as
using hard enters to control the text or adding
vertical padding to position the bullet within
the cell correctly.

Some of the intended fonts for the premade
Fireworks buttons may not be installed in your
system, so as a result the designs may not look
like the designer originally intended. In my case,
the dialog box warned me that | did not have
the Berkeley font for the Scroll style or the Sand
font for the Surfboard style. These fonts are
available at various type foundries on the Web;
however, they are not required. If you do not
make another selection in the Font menu,
Fireworks will prompt you to choose a substi-
tute font in the image generation process. If
you click the No Change button, Arial will be
selected for you.
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m Choose a font Size. A recommended value is
filled in for you based on the selected Style.

m Enter this button’s Link or click the Browse
button to select a page from your site. Choose a
target from the drop-down menu if appropriate.
m Select a folder to save your images to by press-
ing the Browse button and navigating to the
desired folder.

m Name your button in the Base File Name field.
Two images are created with this name in the
specified folder — one for mouse up and one for
mouse out states.

m Click OK to generate your Fireworks buttons.
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APPENDIX A

WHAT'S ON THE CD-ROM

This appendix provides you with information on the contents of the CD that accompanies this book. For the latest
and greatest information, please refer to the ReadMe file located at the root of the CD. Here is what you will find:

System Requirements
CD-ROM Installation Instructions
What’s on the CD-ROM

]
]
]
m Troubleshooting

SYSTEM REQUIREMENTS

Make sure that your computer meets the minimum system requirements listed in this section. If your computer
doesn’t match up to most of these requirements, you may have a problem using the contents of the CD.

FOR WINDOWS 9X, WINDOWS 2000, WINDOWS NT4 (WITH SP 4 OR LATER), WINDOWS ME, OR WINDOWS XP:

PC with a Pentium processor running at 120 MHz or faster

At least 32MB of total RAM installed on your computer; for best performance, we recommend at least 64MB
Ethernet network interface card (NIC) or modem with a speed of at least 28,800 bps

A CD-ROM drive

FOR MACINTOSH:

Mac OS computer with a 68040 or faster processor running OS 7.6 or later

At least 32MB of total RAM installed on your computer; for best performance, we recommend at least 64MB
Ethernet network interface card (NIC) or modem with a speed of at least 28,800 bps

A CD-ROM drive

CD-ROM INSTALLATION INSTRUCTIONS

To install a particular piece of software, open its folder with My Computer or Internet Explorer. What you do next
depends on what you find in the software’s folder:

1. First, look for a ReadMe.txt file or a .doc or .htm document. If this is present, it should contain installation
instructions and other useful information.
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2. If the folder contains an executable (.exe) file, this is usually an installation program. Often it will be called
Setup.exe or Install.exe, but in some cases the filename reflects an abbreviated version of the software’s name and
version number. Run the .exe file to start the installation process.

WHAT’S ON THE CD-ROM

The following sections provide a summary of the software and other materials you’ll find on the CD.

50 TECHNIQUES

The 50 Fast Dreamweaver MX Techniques CD-ROM contains working Web pages for each technique showcased in
the book. A variety of files, including Fireworks graphics, Flash movies, database files, and graphics can be found on
the disc.

APPLICATIONS

The following applications are on the CD:

Shareware programs are fully functional, trial versions of copyrighted programs. If you like particular programs,
register with their authors for a nominal fee and receive licenses, enhanced versions, and technical support. Freeware
programs are copyrighted games, applications, and utilities that are free for personal use. Unlike shareware, these pro-
grams do not require a fee or provide technical support. GNU software is governed by its own license, which is
included inside the folder of the GNU product. See the GNU license for more details.

Trial, demo, or evaluation versions are usually limited either by time or functionality (such as being unable to save
projects). Some trial versions are very sensitive to system date changes. If you alter your computer’s date, the pro-
grams will “time out” and will no longer be functional.

You can connect directly to these Web sites by clicking the appropriate hyperlink in the HTML interface on the
CD-ROM that accompanies this book.

Dreamweaver MX from Macromedia
30-day trial version for Windows and Macintosh. Dreamweaver MX is an easy to use, full-featured, visual Web devel-
opment program. For more information, check out www.macromedia.com/software/dreamweaver.

Flash MX from Macromedia

30-day trial version for Windows and Macintosh. Flash has become the animation standard for the Web. This latest
installment features vast improvements for building dynamic content with a brand new interface. For more informa-
tion, visit www . macromedia.com/software/flash.

Fireworks MX from Macromedia

30-day trial version for Windows and Macintosh. Fireworks is a graphic design application specifically designed for
designing Web sites and making image editing within Dreamweaver possible. For more information, check out
www.macromedia.com/software/fireworks.
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Acrobat Reader from Adobe
Free version for Windows and Macintosh. Acrobat Reader allows you to view PDF files and eBook files from your
computer. For more information visit www . adobe.com/products/acrobat.

Framestuffer from Hal Pawluk
Freeware version for Windows. Framed pages opened “naked” outside their frameset find the frameset and position
themselves in the correct frame.

HTML Rename! from Expandable Language

Shareware version for Windows and Macintosh. This cross-platform utility augments your HTML editor by generat-
ing universally compatible filenames and fixing URL links. Using HTML Rename before you transfer files saves you
from the need to repair mangled filenames, broken links, and extra or missing carriage returns in text files.

PayPal Cart from Paul Davis
This free extension adds the needed script for PayPal Shopping Cart and retains your default information for quicker
reentry.

Random Images from Paul Davis
Display random images, daily images, or slideshows with this handy extension.

EBOOK VERSION OF 50 FAST DREAMWEAVER MX TECHNIQUES

The complete text of this book is on the CD in Adobe’s Portable Document Format (PDF). You can read and search
through the file with the Adobe Acrobat Reader (also included on the CD).

TROUBLESHOOTING

If you have difficulty installing or using any of the materials on the companion CD, try the following solutions:

m Turn off any anti-virus software that you may have running. Installers sometimes mimic virus activity and
can make your computer incorrectly believe that it is being infected by a virus. (Be sure to turn the anti-virus
software back on later.)

m Close all running programs. The more programs you're running, the less memory is available to other
programs. Installers also typically update files and programs; if you keep other programs running, installation
may not work properly.

m Reference the ReadMe: Please refer to the ReadMe file located at the root of the CD-ROM for the latest
product information at the time of publication.

If you still have trouble with the CD, please call the Customer Care phone number: (800) 762-2974. Outside the
United States, call 1 (317) 572-3994. You can also contact Wiley Customer Care by e-mail at techsupdum@
wiley . com. Wiley will provide technical support only for installation and other general quality control items; for
technical support on the applications themselves, consult the program’s vendor or author.






APPENDIX B
LEARNING MORE ON THE WEB

Just when you figure out all of the coolest, latest developments on the Web, something new comes along. Fortunately,
one of the best ways to keep up with Web design is to look for information on the Internet itself.

I try to visit a few Web sites regularly to keep up with emerging technologies, research on interface design, and the
latest developments, such as Dynamic HTML, XML, and the many other aspects of Web development. The following
sites are in alphabetical order (because that’s supposed to be fair). I reccommend you take a quick look at all of them
and then bookmark the ones you like best so that you can return to them easily.

You can connect directly to these Web sites by clicking the appropriate hyperlink in the HTML interface on the
CD-ROM that accompanies this book.

ADOBE SYSTEMS, INC.

www.adobe.com
Adobe is not only a great resource for graphics and other products, but its Web site features an impressive collection
of design tips and strategies for creating graphics for the Web, in addition to well-designed HTML pages.

ART AND THE ZEN OF WEB SITES

www.tlc-systems.com/webtips.shtml
As the name implies, this site shows you the way to simple yet powerful Web design, and it has a great collection of
quotes (but I have to wonder, did those people really say those things?).

CNET

www.cnet.com
CNET gives you news about all aspects of the Web, as well as in-depth reports on new technologies and other news
affecting Web designers. CNET also has extensive software libraries for both Windows and Macintosh platforms.

COMMUNICATION ARTS INTERACTIVE

Www.commarts.com
Looking for creative ideas? Need some design guidance or a few tips on how to develop the best graphics for your
site? Point your browser in the direction of Communication Arts Interactive.
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THE DIRECTORY

www.thedirectory.org
Looking for an Internet service provider? Look no further. The Directory is a comprehensive guide to ISPs on the
Net, featuring a searchable database with thousands of ISPs worldwide.

DMX ZONE

www.dmxzone.net

This is a great Web site maintained by and for the Dreamweaver MX User Community. You find tutorials, Extensions,
and answers to lots of your questions here. You can also contribute content to the site to share with other
Dreamweaver MX users.

DREAMWEAVER EXTENSIONS DATABASE

www.idest.com/cgi-bin/database.cgi

This site has a vast searchable database of Dreamweaver Extensions, including objects, behaviors, templates, com-
mands, and techniques for extending Dreamweaver — all downloadable from the Web. (Note: If you're still not sure
what Dreamweaver Extensions are, you can skip this site for now — it’s for advanced Dreamweaver users.)

FLASHKIT

www.flashkit.com
Visit Flashkit to find news, tutorials, source files, shareware, and tips about Flash MX and Action Script. Contributions
to the site by other Flash MX users are also encouraged here!

THE HTML WRITERS GUILD

www.hwg.org

This Web site is an international organization of World Wide Web designers and Internet publishing professionals.
The site includes a variety of HTML resources, as well as Web business mailing lists, information repositories, and a
chance to interact with peers.

INTERNET.COM

wWww.internet.com
This site has so many great resources it’s hard to know where to start. On the main page, you find comprehensive
news coverage of events, legal issues, and trends that are shaping the way we work, live, and use technology.

Visit the Web Developers section to find a wealth of information about Web design, including technical issues,
design, and information about software, from development tools to Web browsers.



Learning More on the Web 247

THE MACROMEDIA DESIGNERS AND DEVELOPERS CENTER

www.macromedia.com
The Macromedia Web site is worth a regular visit. Not only do you find product updates and other helpful informa-
tion about Macromedia software, you also find many great resources for designers.

The Macromedia official help center is filled with tutorials, samples, and other assets designed to keep developers
up-to-date, especially if you use its programs, such as Dreamweaver, Fireworks, Freehand, and Flash.

NETSCAPE

www.netscape.com
Keep your eye on the Netscape site for updates to Navigator, as well as the latest on how it will support new features
on the Web.

PROJECT COOL AND DEVX

www.projectcool.comorwww.devx.com
One of my all-time favorite Web sites, Project Cool is dedicated to helping anyone become a better Web designer.
Now that Project Cool and DevX are one, you can find a ton of great resources all in one place.

The creators of the Project Cool site have always had a talent for sharing great Web design tips and showcasing the
best of the Web. The site also does a great job of keeping up with the latest developments, such as DHTML and
Cascading Style Sheets.

SEARCH ENGINE HELP

www.searchenginehelp.com

If you're confused about how to submit your site to search engines, or you want to get better placement in the search
engines where your site already appears, Search Engine Help can give you all the tips and ideas you have time to study
and implement. These are the pros with the most updated tips on how to get your site the best placement possible in
all the most important search engines.

TECHNET

www.technet.com
Watch the Microsoft developer’s site for updates to Internet Explorer, as well as information on how it will support
new features on the Web.

WEBMONKEY

www.webmonkey.com

Tune up your browser and make sure your Web site is up to snuff at the HotWired WebMonkey site. You can use its
online diagnostic tools to test your browser and find out about plug-ins and other Web development tools. You can
also find HTML tutorials and other Web design references.
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WILEY PUBLISHING

www.wiley.com
Wiley Publishing offers a wide range of books on Web design (including this one!) and features links to great maga-
zines and other resources for Web designers.

THE WORLD WIDE WEB ARTISTS CONSORTIUM

WWW.WWWac.org
Better known as the WWWAGC, this nonprofit, member-supported organization of Web designers keeps you up-to-
date on current Web design issues when you subscribe to its e-mail list. But, as with any mailing list, make sure that
you read a few weeks’ worth of messages before you post one of your own. More than 1,000 people share their ideas
on the WWWAC list, including some of the most respected designers on the Web.

WORLD WIDE WEB CONSORTIUM
wWww.w3.0rg

The official source for HTML updates, the W3C sets the standards for HTML code. At this site, you find all of the
published HTML specifications, as well as a wide range of resources for Web developers.

ZDNET

www.zdnet.comorwww.cnet.com

Another great technology news site. ZDNet is now owned by CNET, but the two sites feature different resources and
references and are both worth the visit. ZDNet is the more technical of the two, designed more for developers, while
CNET has more of a consumer focus.



APPENDIX C

EXTENDING THE FEATURES
OF DREAMWEAVER MX

Instead of waiting around for the next version of Dreamweaver to catch up with the bleeding edge technologies and
techniques emerging every day, you can add new features to the program this very minute with Dreamweaver
Extensions—most of which are absolutely free to use. Simply log on to http://exchange.macromedia.
com, fill out the member registration form, and visit the Dreamweaver MX section to browse their 600+ and grow-
ing Extension inventory.

You can connect directly to these Web sites by clicking the appropriate hyperlink in the HTML interface on the
CD-ROM that accompanies this book.

The following list represents Extensions I've found especially useful in recent projects:

FRAME BUSTER

Some Web sites keep one of their frames open, while they display your pages. Your visitors may think that your pages
actually belong or are associated with the site that framed you. This Extension inserts the required JavaScript code to
close all frames, except the one running the script through the use of a redirect.
Developer: Rabi Sunder Raj
URL:www.geocities.com/siliconvalley/garage/2001/dreamweaver

FRAMESTUFFER
Direct links, often by search engines, can cause your framed pages to be opened or “naked” outside their frameset.
This can spell trouble if your site navigation or supporting pages are in a missing frame. The FrameStuffer Extension
can find the frameset and position the parent document in its correct frame.

Developer: Hal Pawluk

URL: www . pawluk.com/public

INSTAGRAPHICS

Create Fireworks Web graphics, directly from Macromedia Dreamweaver — without expert design skills.
Developer: Dreamweaver
URL: www.macromedia.com/software/dreamweaver/productinfo/extend/insta.html
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MUMBO JUMBO

This Extension inserts placeholder text into your Web pages by generating corporate technology geek-speak, which is
quite humorous and useful when your clients don’t provide copy.

Developer: Macromedia

URL: (member protected). Log on and browse the Text category of http://exchange.macromedia.com

PAYPAL SHOPPING CART

Inserts the PayPal shopping cart tags in the page and saves the common entered data. Unlike other PayPal Extensions
available, this one has no limits and no charges.

Developer: Paul Davis of Kaosweaver

URL: www.kaosweaver.com

RANDOM IMAGES

Random Images allows you to display random images on your Web page every time the document is loaded. This
highly configurable Extension can also be set to display daily images or slideshows.

Developer: Paul Davis of Kaosweaver

URL: www .kaosweaver.com

FIXING COMMON TESTING SERVER PROBLEMS:

Although originally written for Dreamweaver Ultradev, the majority of the solutions listed in this directory provide
fixes that work with Dreamweaver MX.
URL: www.macromedia.com/support/ultradev/troubleshoot.html

MICROSOFT SOLUTIONS FORHTTP 500 UPDATABLE QUERY ERRORS:

Some documentation is available on the Macromedia site about this topic; however, this page features more in-depth

information and other suggestions on how to properly tweak your sharing permissions for IUSR (such as setting per-

missions in your temp directory).
URL:http://support.microsoft.com/default.aspx?scid=kb;EN-US;ql75168
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“404 error,” 27

A
A tag, 76
Access, cleaning up files, 36
accessibility tools, 123
Accessibility Validation tools, 131
Acrobat Reader, 243
Add Object command, 154
Add Simple Rollover behavior, 58
Add to Favorites command, 40, 41, 43
Adobe Web site, 243, 245
Advanced Layout panel, 88, 179
aligning content in multiple cells, 107-108
Alt tags, 129-130
alternate text, 127-128, 129-130
Americans with Disabilities Act, 125
animation and frames, 154
Arrow tool, 15
Art and The Zen of Web sites, 245
ASP/VBScript page, 201, 206, 210, 214
Assets panel, 32, 39-43, 195

Flash icon, 196

Library section, 172

multimedia files, 169, 197
audio tool tips, 86
automatic collection of URLs, 41-43
autostretch layouts, 165-168

background images, 104, 108
backgrounds, 161-162
behaviors, 155, 187, 210
Behaviors (Shift+F3) keyboard shortcut, 58, 76, 85
Behaviors panel, 59, 76
Add Simple Rollover behavior, 58
Browse button, 141
Browser Check behaviors, 84

onBlur event, 85
onClick event, 80
onMouseOver behavior, 149
Show Popup Menu behavior, 149
Show/Hide Layers, 85, 90, 118
Swap Image, 141

Bindings panel, 203, 206, 214

<BODY> tag, 76, 88, 94, 96

booker variable, 232

Border Color, 104

<br> tag, 5

broken image link, 29

broken links, 27-29, 49

broken page link, 29

buttons, 69-71, 117-118
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Call JavaScript behavior, 94
Call JavaScript dialog box, 94
cellbg.gif file, 108
cells, 101-103, 107-108, 116
Check Links (88/Ctrl+F8) keyboard shortcut, 28
Check Links Result panel, 28
circuitboard.mov file, 66
Clean Up HTML, 36-38
Clean Up HTML/XHTML dialog box, 36
Clean Up Word HTML, 36-37
Clean Up Word HTML dialog box, 36-37
Close Button behavior, 89-90
closed eye icon, 88
CNET Web site, 245
code cleaning utilities, 36-37
Code View, 35
editing JavaScript, 80
Frame Buster code, 228
link tag that launches gallery windows, 81
removing tags, 38
colors
applying previously used, 41
Library items, 173
Colors Assets panel, 39, 41
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Command>Dabbler>FrameStuffer command, 232
Commands>Clean Up HTML command, 36
Commands>Clean Up Word HTML command, 36
Commands>Convert Text to Images command, 236, 237
Commands>Kaosweaver.com>Advanced Random Images
command, 220
Commands>PayPal Shopping Cart command, 224, 226
Common Tools panel, 14
Communication Arts Interactive Web site, 245
contact.htm file, 34
contactus.htm file, 34
contingency pages, 84
Convert Bullets to Images dialog box, 237-238
Create Fireworks Button dialog box, 238-239
credit card payments, 223-226
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CSS (Cascading Style Sheets), 189-193, 369
defining background properties, 161
removing, 37
Web browsers, 162
CSS Style Definition dialog box, 162, 190-192
CSS styles, 190-191, 193
CSS Styles panel, 190, 193
custom
code, 38
DHTML menu, 115-119
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administrative pages, 214
deleting rows, 216
encryption, 214
firewall, 214
inserting form information, 206-207
privacy value, 206
product catalog, 209-211
record update from, 214-215
Recordset, 202203
searching, 201-204
security, 214
View Guestbook page, 205-206
Davis, Paul, 243, 250
Define HTML Style dialog box, 186-187
Delete Record behavior, 215
describing images, 129-130
Design panel, 54-56, 79, 186
Design View, 35, 228
detaching templates, 34
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Detail page, 209-211
Detail.asp file, 210-211
DHTML layer, 88
DHTML menu, custom, 115-119
Directory Web site, The, 246
disabled visitors, 123—124
disjoint image (RTDisplayblank.gif), 54
disjointed rollovers, 53-56
display image, 55
DMX Zone Web site, 246
.doc file, 241
Download.com Web site, 73
downloading

button styles, 70

plug-ins to view multimedia files, 67
drawing tables, 101-104
Dreamweaver Extensions Database Web site, 246
Dreamweaver MX For Dummies, 199
Dreamweaver-made Flash files, 63
Duplicate Frame command, 57
Duplicate Frame dialog box, 57
.dwt file extension, 32
Dynamic Table dialog box, 206
dynamic variables, 226

earth.jpg image, 14
Ebook version of 50 Fast Dreamweaver MX Techniques, 243
Edit Sites command, 46
Edit Sites dialog box, 46
Edit Style Sheet dialog box, 162
Edit Tag Code command, 125
editable regions, 32-33
Edit>Clone command, 157
editing
buttons, 71
HTML source code, 114
JavaScript, 80
Library item to make global changes, 173-174
tables in Layout view, 104
templates, 34
Edit>Preferences command, 124, 173
Edit>Undo command, 38
e-mail, HTML-formatted, 111
e-mail newsletters
absolute image source paths, 112
building, 112
designing, 111-114
HTML format, 113-114
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sending from Outlook, 112-113
sending from Outlook Express, 113—-114
updating image source links, 112
uploading images, 112
e-mail programs, 111
EMBED tag, 62
embedding
Flash movies, 61-64
multimedia files in Web pages, 65-67
pop-up in Web pages, 87-90
empty tags, removing, 35-38
encryption, 214
Excel, cleaning up files, 36
.exe (executable) file, 242
exit pop-up windows, 95-96
Expandable Language, 243
Expand/Collapse icon, 112
Export dialog box, 18, 59
Export (Ctrl+Shift+R) keyboard shortcut, 59
exporting
Fireworks layout to HTML, 58-59
layouts to HTML, 18-19
rollovers from Fireworks, 57—-59
slices, 18
tiling background, 157
Extension Manager, 217, 224
Extensions, 217-239
installing, 219, 224
reusing common elements in, 220
external
broken links, 29
CSS styles, 190-191
eye icon, 88

F

Favorites panel, 196
“File Not Found” error page, 27
File>Check Links command, 28
File>Check Page>Check Accessibility command, 130
File>Export command, 18, 59, 150, 157, 166
File>New Folder command, 48
File>New>Basic Page>HTML Page command, 4, 14, 23, 178
File>New>Mail Message command, 112, 113
File>Open command, 10, 19, 32, 79, 140, 144
File>Preview in Browser command, 10, 59
files

moving into folders, 49

organizing without breaking links, 45-49

saving in frameset, 179

spaces or special characters in names, 47

updating related links, 49
Files panel, 46, 128

Assets tab, 40—42, 172, 196

Library icon, 172

Site tab, 48, 49
File>Save All command, 179, 181, 211, 230
File>Save As command, 36, 174, 220
File>Save as Template command, 32
File>Save command, 33, 34, 174, 210
File>Save Frame command, 179, 181
File>Save Frameset command, 181
finding broken links, 28
firewall, 214
Fireworks MX, 1, 140, 242

building and exporting rollovers, 57-59

Change Fonts option, 144

designing Web site, 4

editing images, 144

exporting layout to Dreamweaver, 17-19

exporting to HTML, 166

File>New command, 157

File>Open command, 148

fonts, 144

Frames and History panel, 57

intended fonts for buttons, 238

Maintain Appearance option, 144

Modify>Symbol>Convert to Symbol command, 157

opening Photoshop layout files, 148
.png file, 165

pop-up menus, 147-150

Property inspector, 18

rollover behavior, 58

rollover buttons, 238239

rollover frame, 57-58

running in background with InstaGraphics, 236

Slice tool, 18

tiling background element creation, 157-158

fixed tiling background, 157
fixing broken links, 28-29
Flash MX, 242
Assets panel, 195-197
built-in HTML generating feature, 62
files, 63, 195-197
menu creation in Dreamweaver, 69-71
movies, 61-64, 71
transparent background parameters, 71
Flash panel, 196
Flashkit Web site, 246
floating DHTML toolbar, 115
floating layer, 115-119
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floating pop-ups, 87-90 graphics. See images
folders, 45-49 graphics editing programs, 140
<FONT> tags, 185 graphics programs, preparing and slicing layout, 165-166
fonts guest books, 205-207
buttons, 70 guidelines, 103

CSS styles, 190
Fireworks, 144

Format>HTML command, 113 H
Format>Rich Text (HTML) command, 113 header area, tiling background, 166
formatting ’ p

header_background.gif file, 166
Headline style, 186

Hidden, Vis command, 154
hiding tracing images, 8
high-resolution images, 129-130
horizontal rule, 167

hot spots, 13-15

htm file, 241

automating with HTML styles, 185-187
multiple cells, 107-108
forms, 8386, 124
Frame Buster Extension, 227-229
Frame Buster object, 228
Frame Buster Web site, 249
FrameJammer.mxp file, 232

frames e )
altering properties, 180 .htm file extension, 33
animation, 154 HTML, 59

changing contents separately, 181 conver.ting t?ullets to graphics, 237-238
creation of, 178 exporting Fireworks layout to, 58-59

effective navigation, 177-183 exporting layouts to, 18—-19

links, 181-183 opening files in Dreamweaver, 19

naming, 124, 180-181 HTML Rename!, 243

navigation elements, 369 HTML slices, 18

preventing orphaned content, 231-233 HTML source code, 114

saving, 179, 181 HTML styles, 169, 185-187

splitting, 178 HTML Styles panel, 186

targets, 181183 HTML tables, rebuilding to include tiling background, 167-168
Frames and History panel, 57-58, 180 HTML tags, 37, 191-193
Frames Insert panel, 178 HTML Writers Guild Web site, The, 246
framesets, 229 HTML-formatted e-mails, 111

automatically naming files, 180
modifying, 178

naming frames in, 179 I

preparing in FrameStuffer, 232 ; .

saving, 181 icons, resizing, 66

saving files in, 179 image gallery, 1,21-23

setting links, 181-183 Image Map Shape tools, 141
FrameStuffer Extension, 231-233, 243 image maps, 13—15, 139-142
FrameStuffer Web site, 249 Image slices, 18
freeware programs, 242 image-based menus, 116

images, 1
absolute source paths, 112

G affected by rollover, 54

alternate text, 125, 129—130
applying rollover to, 10
background, 4

gallery wall and pop-up windows, 79-82
gallery windows, 80-81

-gif format and slices, 19 converting HTML bullets into, 237-238
GIF graphics, deleting, 237 describing, 129-130

GIF text, 236-237 displaying multiple on page, 21-22
GNU software, 242 editing, 143-144

gradients and slices, 19 generating with Dreamweaver, 235-239
Graphic submenu screen, 225 hot spots, 13

graphical bullets, 238
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inserting in table, 23
inserting on page, 40
interactive, 69-71
as link, 182
low-res, 129-130
“mock up,” 4
optimizing slices, 58-59
random, 219-221
reordering, 40
replacing original image, 10
rollovers, 9, 141
setting links to image gallery, 23
storing, 40
thumbnail previews, 40
tracing, 1, 3-8
transparent, 102-103
updating source links, 112
uploading, 112
without Alt tags, 130
Images Assets panel, 39-40
importing
Fireworks designs, 1
Fireworks layout, 17-19
include files, 229
incomplete or redundant tags, 38
input boxes, 83-86
Insert Entry page, 206-207
Insert File dialog box, 113
Insert Flash Button dialog box, 70-71
Insert Flash dialog box, 62
Insert Flash Movie (Ctrl+Alt+F) keyboard shortcut, 62
Insert panel, 103—104, 178
Insert Record dialog box, 207
Insert Rollover Image dialog box, 10
Insert Text from File dialog box, 113
Insert Toolbar, 54, 62
Insert>Application Objects>Dynamic Table command, 206
Insert>Application Objects>Master/Detail Page Set
command, 210
Insert>Application Objects>Record Insertion Form
command, 207
Insert>Application Objects>Record Update Form command,
214
Insert>Application Objects>Recordset Navigation Bar
command, 215
Insert>File command, 113
Insert>Form command, 201
Insert>Form Objects>Text Field command, 84, 201
Insert>Frame Buster command, 228
Insert>Horizontal Rule command, 167
Insert>Image command, 6, 14, 23, 54, 130
Insert>Interactive Images>Fireworks Button command, 238
Insert>Interactive Images>Flash Button command, 70
Insert>Interactive Images>Rollover Image command, 10

Insert>Layer command, 84, 88, 116, 153, 154

Insert>Media>Flash command, 62

Insert>Media>Plugin command, 66

Insert>Table command, 23, 116, 203

Insert>Template Objects>Editable Region command, 32
Insert>Text from File command, 113

InstaGraphics Extension, 235-239, 249

interactive buttons, 69-71
Interactive Images menu, 69
Internet Explorer, 127-128

Internet guest account (IUSR) privileges, 207

Internet.com Web site, 246
invisible GIF, 118-119
Item submenu screen, 225
ITEM_NAME column, 210

J

JavaScript

behaviors, 9, 76

editing, 80

errors, 84

FrameStuffer Extension, 233
.jpeg format and slices, 19
junk code, removing, 35-38

K

Kaosweaver, 220
KW_PayPalButtons.mxp file, 224

L
Launch behavior, 88
layers
adding motion, 154155
background color, 84
contrasting background color, 85
creation of, 117
hiding when inactive, 85
keyframes, 88
naming, 88, 117
for photo and caption, 153-154
resizing, 84
sizes, 154
tool tips, 84
turning on and off, 117-118
visibility, 84, 88
Layers (F2) keyboard shortcut, 88
Layers panel, 58
Layout Cell tool, 101-104
Layout Table tool, 101-104
Layout View, 101-104

259
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layouts
autostretch, 165-168
exporting to HTML, 18-19
preparing, 165-166
saving to folder, 19
slicing, 18, 165-166
Library Assets panel, 126, 172
Library feature, 169, 171
Library icon, 172
Library items, 128, 171-175
Link Checker report, 28
Link Checker Results panel, 28
Link Checking feature, 28
link tag, 81
linked image gallery, 21-22
linking images, 1
links
automatically collecting URLs, 41-43
frames, 181-183
framesets, 181-183
from image gallery to larger images, 23
image maps, 13-15
images as, 182
for opening pop-up, 76
organizing files and folders, 45-49
redefining HTML tags to eliminate underlining, 191-193
rollovers, 9-10
setting, 15
tables, 116
targets, 181-183
text as, 182
updating related-file, 49
Local Site window, 112
locked regions, 32-33
long description, 124
low-res images, 133-135

M

Macintosh system requirements, 241
Macromedia Designers and Developers Center Web site, The, 247
Macromedia Exchange Web site, 70, 115, 217, 224
Macromedia folder, 219

Macromedia Web site, 242

mainFrame, 183

margins, 116

Master page, 209-211

Master.asp file, 210

Master/Detail set, 210

Master/Detail template set, 226

menu buttons and rollover effects, 9

menu.htm file, 150
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menus, 115-119
Menu_Template.htm file, 116
merging cells, 116
Microsoft Solutions for HTTP 500 Updatable Query
Errors, 216, 250
MM_editRedirectURL variable, 214
“mock up” images, 4
Modify>Frames command, 178
modifying Flash movie parameters, 62—64
Modify>Page Properties command, 5, 116, 159
Modify>Pop-Up Menu>Add Pop-Up Menu command, 148
Modify>Templates>Apply Template to Page command, 33
Modify>Templates>Detach from Template command, 34
moving files into folders, 49
multimedia files, 169, 195
Assets panel, 197
audio tool tips, 86
code for embedding, 6667
embedding in Web pages, 65-67
finding, 196
size of, 66
testing, 67
users unable to view, 67
multimedia objects, 124
Mumbo Jumbo Web site, 250
“must use updatable query” error message, 207
MXP file, 220

navigation, multiple options, 127-128
navigation bars and rollovers, 1

nesting tables, 116

Netscape Web site, 247

New CSS Style dialog box, 162, 190, 192
New Editable Region dialog box, 32

New Page (38/Ctrl+N) keyboard shortcut, 33
non-Dreamweaver HTML comments, 36

0

OBJECT tag, 62

“off” state, 9

“on” state, 9

onBlur event, 85, 119
onClick event, 80

OnClick property, 76
one-to-many rollovers, 53—-56
onFocus event, 84-86
onLoad event, 88, 96, 221
onMouseOver behavior, 149
onUnload event, 95, 96

Open Browser Window behavior, 76, 79-80
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Open Browser Window dialog box, 76, 80
Optimize panel, 19
optimizing slices, 18, 58—-59
original.gif file, 140
orphan tags, 38
orphaned frames, 231-233
Qutlook, 112-113
Outlook Express, 113-114
Oval Hotspot tool, 14
overriding

Library items, 174

style sheets, 41

P

Page Properties dialog box, 5, 116, 159
Page Properties (Ctrl+]) keyboard shortcut, 116
Paragraph attributes, 187
PARAM tags, 63
Parameters dialog box, 63
Pawluk, Hal, 243, 249
PayPal shopping cart, 224-226, 243
PayPal Shopping Cart Behavior dialog box, 224-226
PayPal Web site, 223, 250
Petals Fragrances Web site, 226
Photol layer, 153, 154
photol.jpg file, 154
PhotolText layer, 154
Photo-Paint, 140
Photoshop, 140
designing Web site, 4
Image>Mode>Grayscale command, 130
.psd file, 165
Play Sound behavior, 86
plug-ins, downloading, 67
.png files, 144, 148, 165
PNG graphics, 237
Polygon Hotspot tool, 15
pop-under windows, 73, 93-94
pop-up killer applications, 73, 96
Pop-Up Menu Editor, 148-149
pop-up menus, 147-150
pop-up windows, 73, 76, 79-82, 87-90, 94, 96
PowerPoint, 36
Preferences dialog box, 124, 173
presentation.swf file, 62
preset-size windows, 75-76
Preview in Browser icon, 7, 56, 204, 207, 216, 226
Preview in Browser (F12) keyboard shortcut, 7, 10, 56, 59,
204, 207, 216, 226
previewing
button style, 70
guest book, 207
PayPal Shopping cart, 226

Recordset, 204

rollovers, 10, 56

slices, 19

slideshows, 155

Update Record form, 216

Primary Key, 206, 211, 214

product catalog, 209-211
productpage template, 33
productpage.dwt file, 34

Project Cool and DevX Web site, 247
Property inspector, 14, 29, 58

advanced options, 183
Alt text box, 128
alternative text, 128
Arrow tool, 15

Browse button, 15, 23, 108, 130, 167, 182

changing color attributes, 41
Detach from Original button, 175
displaying Flash attributes, 197
Edit button, 63, 71, 144
editing link field, 112
Fireworks, 18

Flash movie properties, 63
Font down arrow, 108
Heading 1, 236

Hidden, Vis command, 154
Hidden property, 84

High option, 63

Horizontal Alignment down arrow, 108

image Src field, 112

L value, 154

layer background color, 84
Library item options, 175
link SRC text box, 29

Link text box, 15

Low area, 130

Merge Cells button, 116
naming images, 54
PARAM tags, 63
Parameters button, 63
Plug-in URL text box, 67
positioning symbol, 157
properties for frame, 180
Shape tool, 15

Size down arrow, 108

Src area, 135

Unordered List button, 237
viewing Alt text, 130

Vis menu, 118

W and H values, 66

width and height text boxes, 103

.psd file, 17, 165

Q

quick-loading low-res images, 133—134
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R
Raj, Rabi Sunder, 249
randImage.mxp file, 220
Random Image Extension, 219-221, 243
random images, 219-221
Random Images dialog box, 221
Random Images Web site, 250
ReadMe file, 241
record update form, 214-215
Record Update Form dialog box, 214-215
Recordset, 202204, 206-207, 211, 214-215
Recordset dialog box, 202, 214
Recordset Navigation Bar dialog box, 215
Recordset Navigation object, 204
Recordset Navigation Status object, 215
Recordset Paging behaviors, 204
Rectangular Hotspot tool, 14
Reference panel, 80
Remote Site window, 112
Repeat Region behavior, 203, 204
Repeat Region dialog box, 203
Results panel, 28-29
rollover behavior, 58
rollover effects, 9
Rollover Fireworks buttons, 238-239
rollover frame, 57-58
rollovers, 1

alternate text, 10

base image, 54

behavior, 58

building and exporting from Fireworks, 57-59

disjointed, 53-56

image maps, 139-142

image name, 10

images, 9, 54

JavaScript behavior, 9

links, 9-10

loading when page loads, 10

“off” state, 9

“on” state, 9

one-to-many, 53-56

previewing, 10, 56

providing additional information, 9

returning to original state, 55

simple, 53-56

swap image behavior, 54-56

testing, 10

trigger images, 54

zooming in with, 139-142
RTConcept_off.jpg file, 10
RTConcept_on.jpg file, 10

S

Save All Files (F12) keyboard shortcut, 183
Save As dialog box, 179
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Save As (88/Ctrl+Shift+S) keyboard shortcut, 36
Save As Template dialog box, 32
Save (Ctrl+S) keyboard shortcut, 210
Save Style Sheet File As dialog box, 190
saving
CSS styles, 190
frames, 179, 181
framesets, 181
layouts to folders, 19
Library item changes, 174
Link Checker report, 28
Web pages, 181
Web sites before modifying, 36
Search Engine Help Web site, 247
search form, 201-202
search results zone, 203
searching
databases, 201-204
for missing Alt text, 130
second level menu template, 116
security and databases, 214
Sedona-sights.htm file, 182
Select Image Source dialog box, 4
Server Behaviors panel, 202-203, 206
Server-Side Includes, 229
Shape tool, 15
shareware programs, 242
Show Popup Menu behavior, 149
Show Region>If Recordset is NotEmpty behavior, 203, 206
Show Rulers (Ctrl+Alt+R) keyboard shortcut, 76
Show/Hide Layers command, 155
Show/Hide Layers dialog box, 85, 90, 118, 155
Show>Tracing Image> Adjust Position command, 8
Show>Tracing Image> Align with Selection command, 8
Show>Tracing Image> Reset Position command, 8
Site Definition dialog box, 46-47
Site panel, 28, 45, 47-48, 112
site search feature, 201-204
Site>Check Links Sitewide command, 28
Slice Overlay view, 18
Slice tool, 18
slices, 18—19, 58—59
slideshows, 153—155
spacer GIF, 118-119
special markup, removing, 35-38
splitting frames, 178
Standard View, 103—104
starting images, 140
storing images, 40
style sheets
creation of, 162
overriding, 41
removing, 37
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styles, 37

styles.xml file, 187

swap image behavior, 54-56
Swap Image dialog box, 55, 141
SWE files, 70

T
Table (Ctrl+Alt+T) keyboard shortcut, 203
Table Layout feature, 101
Table tag, 203
tables, 99
adding background image to cell, 167
aligning content in multiple cells, 107-108
automatically generating, 102-104
background color, 116
cells, 101-104, 103
drawing, 101-104
editing in Layout view, 104
formatting multiple cells, 107-108
grid, 103
guidelines, 103
horizontal rule, 167
image gallery, 23
inserting images in, 23
inserting in cell, 167
last row as footer area, 168
links, 116
merging cells, 116
nesting, 116
resizing, 103, 104
right-aligning, 167
Standard View, 103
Tag Code Editor, 125
Tag inspector, 76, 94, 96, 203
tags
incomplete or redundant, 38
removing, 36
Teach Yourself VISUALLY Dreamweaver MX, 199
Technet Web site, 247
template master page, 32
template-based Web pages, 32-33
template-based Web sites, 31-34
templates, 31-34, 116
Templates folder, 32
Test SQL window, 203
testing rollovers, 10
text
applying previously used colors, 41
CSS (Cascading Style Sheets), 189-193
formatting in cells, 108
HTML styles, 185-187
as link, 182
text fields
creation of, 84
hiding when inactive, 85

tool tips, 8386
visibility, 84-85
text graphics, 236-237
text layers, 155
text navigation row, 127-128
text region, making editable, 33
Text>CSS Styles command, 191, 193

Text>CSS Styles>New CSS Style command, 162, 190, 192

Text>HTML Styles command, 187
Text>HTML Styles>New Style command, 186
thumbnail previews of images, 40
thumbnails, 1
tiling background, 157-160, 166—168
tiling graphics, 165-168
tilingbg_short.gif file, 159
Timeline panel, 88
timelines, 154
Timelines (F9) keyboard shortcut, 88
Timelines panel, 88-89, 154-155
titles for pop-up windows, 76
tool tips, 8386
tracing images, 1
arranging other elements over, 6-7
automatically aligning with element, 8
controlling position, 8
hiding, 8
inserting, 4-5
lowering transparency level, 5

positioning layers or creating table cells on top of, 4

resetting position, 8
transparent images, 102—-103
trial, demo, or evaluation versions, 242
trigger images, 54

U

Ultradev Web site, 216, 250
Undo (88/Ctrl+Z) keyboard shortcut, 38
Unordered List command, 237
unordered lists, 237
unwanted code, removing, 35-38
Update Files dialog box, 49
Update Library items dialog box, 174
Update Record form, 215-216
Update Record object, 214-215
Update Template Files dialog box, 34
updating

image source links, 112

related-file links, 49

Web pages, 34, 174
uploading images, 112
URLs, 41-43, 70
URLs Assets panel, 39, 42—43
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user authentication server behavior, 214
user-designed tool tips, 86

v

VB Script code, 37

View Guestbook page, 205-206

View>CodeView Options>Word Wrap command, 81
View> Rulers>Show command, 76

View>Source Edit command, 114

View>Table View>Layout View command, 103
View> Table View>Standard View command, 104
View> Tracing Image>Load command, 4
View>Tracing Image>Show command, 4, 7

View> Visual Aids command, 32

View>Visual Aids>Invisible Elements command, 154, 220
visitors with disabilities, 123—124

w

Web browsers
administrating database, 213-216
CSS (Cascading Style Sheets), 162
JavaScript errors, 84
not displaying images, 127
Web pages
adding library items, 172-173
alternate text, 129
displaying multiple images on, 21-22
embedding pop-up in, 87-90
fixed tiling background, 157
Flash files, 196-197
Flash movies, 61-64
frames, 124
global changes, 173-174
images, 40
interactive buttons, 69-71
launching, 76
long description, 124
margins, 116
multimedia files, 65-67
multiple navigation options, 127-128
pop-up window, 76
positioning elements, 103
preparing to serve as template, 32
protecting with Frame Buster, 227-229
random images, 219-221
saving, 181
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starting image, 140

tables, 99

template creation of, 3334

text navigation row, 127-128

updating, 34, 174

visitors with disabilities, 123—-124
Web sites

accessibility, 124

adding folders, 48

automatically finding and fixing broken links, 27-29

backup copy of, 48

credit card payments, 223-226

guest book, 205-207

keeping files and folders together, 46

naming, 46

organizing files and folders, 45-49

PayPal shopping cart, 223-226

saving before modifying, 36

setting up, 46—47

template-based, 31-34

third-party framing, 227-229
WebMonkey Web site, 247
Wiley Publishing Web site, 248
Window>Assets command, 32
Window>Behaviors command, 58, 76, 85
Window>HTML Styles command, 186
Window>Others>Frames command, 180
Window>Others>Layers command, 88
Window>Others>Timelines command, 88, 154
Window>Properties command, 14
windows

floating pop-ups without, 87-90

pop-under, 73

pop-up, 73

preset-size, 75-76
Windows system requirements, 241
Word documents, 36-37
Word-specific XML, 37
World Wide Web Artists Consortium Web site, The, 248
World Wide Web Consortium Web site, 248

ZDNet Web site, 248

zoom.gif file, 140
zooming in with rollovers, 139142
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of the possibility of such damages.

Because some jurisdictions do not allow the exclusion or limitation of liability for consequential or inciden-
tal damages, the above limitation or exclusion may not apply to you.

7. U.S. Government Restricted Rights. Use, duplication, or disclosure of the Software for or on behalf of the United
States of America, its agencies and/or instrumentalities “U.S. Government” is subject to restrictions as stated in
paragraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFARS 252.227-7013, or
subparagraphs (c) (1) and (2) of the Commercial Computer Software - Restricted Rights clause at FAR 52.227-19,
and in similar clauses in the NASA FAR supplement, as applicable.

General. This Agreement constitutes the entire understanding of the parties and revokes and supersedes all prior
agreements, oral or written, between them and may not be modified or amended except in a writing signed by
both parties hereto that specifically refers to this Agreement. This Agreement shall take precedence over any other
documents that may be in conflict herewith. If any one or more provisions contained in this Agreement are held
by any court or tribunal to be invalid, illegal, or otherwise unenforceable, each and every other provision shall
remain in full force and effect.
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